Tech2Win使用者手冊

歡迎來到Tech2Win使用者手冊。

Copyright (C) 2010..2016 SPO Engineering General Motors 版權所有。

  • 介紹:
  • 授權:
  • 安裝:Tech2Win安裝程序說明。
    • 安裝步驟
    • 車輛通訊介面
  • 首要步驟
    • 選擇配置
      • 鍵盤
      • 視窗處理
    • 新配置
    • 修改配置
      • 語言
      • 路徑
      • 顯示器
      • 儲存配置
    • 取得Tech2Win有效授權。
  • 操作Tech2Win: 日常工作細節
    • 選單
    • 下載PCMCIA影像
    • 安全性
    • 查看報告
    • 處理PCMCIA影像
    • 狀態列
  • 高級主題: 正常使用Tech2Win的非必要資訊。 通常僅適用從事管理任務之人士。
    • 重新安裝
    • 卸除安裝
    • 組態檔格式
    • 紀錄檔
    • 錯誤訊息及錯誤代碼
    • ATA卡
    • 登錄紀錄
    • 檔案
    • 配置管理
  • 常見問題


介紹

Tech2Win是一項Windows應用程式，可模擬Tech2功能性。 基本上，Tech2軟體是在PC上執行。 如欲運行本程式，您的PC需符合以下技術條件：

  • 須安裝車輛通訊介面並連接至PC。 可接受之介面列表可能因區域不同而有差異。 在多數情況下，可使用GM多重診斷介面(MDI)。
  • Tech2Win應用程式在安裝期間需要150MByte的硬碟空間。 每張您希望管理的PCMCIA卡需要額外的32MB。
  • 在執行Tech2Win應用程式之前，您最少需要100MB的隨機存取記憶體空間。 您的PC必須有足夠的記憶體以在整個執行期間內可將 應用程式保存於RAM內。
  • 您的PC應具備相當於1.2GHz Pentium(單核心)之計算能力。 我們強烈建議您不要同時使用其他應用程式。
  • 不需要鍵盤。 Tech2Win亦可透過觸碰式螢幕進行操作。 如欲管理配置，我們強烈建議您使用鍵盤，因為您將需要輸入檔名。
  • 您的色彩圖形顯示器最小須具備800 x 600之解析度，最小色彩深度為256。 若無鍵盤，應可接受640 x 480 之解析度。

在使用Tech2Win(膝上型電腦而非Tech2)時，請確保該膝上型電腦電源充足。 正常情況下，您的膝上型電腦無法如Tech2般可經由汽車電瓶供電。

  • 安裝
  • 首要步驟


授權

通用汽車公司歐洲公司 - 全球技術資訊系統準證協議 （General Motors - Tech2Win TIS License Agreement）

使用此程序前請仔細閱讀以下條款。 如果您不接收或不理解這些條款，請聯絡當地售後服務代理公司。 唯獨在用戶安裝此Tech2Win程序時透過接受這些條款而同意此準證前提下才由“通用汽車公司歐洲公司”（General Motors）準許使用此軟體之權利。
“通用汽車公司歐洲公司”僅授予“通用汽車公司歐洲公司”授權之修理商網絡之用戶在結合使用TIS2Web程式或者GlobalTIS程式或者TIS2000程式時使用Tech2Win系統軟體及其包括資訊之權利，而此權利在用戶與“通用汽車公司歐洲國家銷售公司”達成之當地適用的“授權修理商協議”中決定。
只要“授權修理商協議”有效，TIS2Web, GlobalTIS程式或者TIS2000程式使用準證到位，則Tech2Win系統使用準證就有效。 當經授權維修廠的協議終止時，Tech2Win 的授權/使用權以及 TIS2Web 與 GlobalTIS 的授權/使用權會立即一併終止。

在“歐盟限制除外規定（European Union Block Exemption Regulation，簡稱BER）1400/2002”的第4條第2款中規定的獨立修理商可以購買Tech2Win系統，而這是作為“通用汽車公司歐洲公司”的“信息技術門戶”（Info Tech Portal）提供之訂購項目的一個部分購買。

此份Tech2Win書不會綜合本汽車通訊界面或PC硬體。

如無相關“通用汽車公司歐洲國家銷售公司”（General Motors National Sales Companies）的書面許可，Tech2Win系統不可進一步發行、銷售或上網提供給獲授權修理商設施之外的第三者（如在“授權修理商協議”（Authorized Repairer Agreement）附加條款中所做說明）。 此條款適用於目前流通與已停止流通數據（如已過期DVD光碟版本）。

在未獲授權或非法使用情況下，“通用汽車公司歐洲國家銷售公司”有權立即關閉其進入權並通知“授權修理商協議”立即終止。在此情況下，提出剩余信用金平衡及/或訂用年份基本費用補償的權力將排除。

所提供資訊用於以專家專業方式針對未改裝過之“通用汽車公司歐洲公司”車輛執行維護保養服務或修理工作。 作為執行上述工作的前提條件，要求執行人員經過完整的汽車技師培訓和定期的進修培訓。 在所提供資訊中指出必須使用專用工具的地方，則在所有維修工作中必須以專家專業方式使用此類專用工具。

在“通用汽車公司歐洲公司”的“全球技術資訊系統”中出版發表的資訊（文字與圖片、音樂、圖表、動畫、錄像等）及其在“全球技術資訊系統”內的安排，都受到版權保護。 未經過“通用汽車公司歐洲公司”的事先書面許可，不可附製、散播、傳遞及或轉讓或做其它使用。

  • 安裝: 安裝步驟
  • 首要步驟


Installation

安裝

Tech2Win之安裝需PC本地管理員權限。 若無管理員權限，安裝將無效。 在此情形下，請連絡您的本地PC管理員以獲得協助。

如欲成功使用Tech2Win，您必須完成以下兩個步驟：

  • 安裝Tech2Win本身。
  • 安裝車輛通訊介面
  • 安裝: 安裝步驟
  • 首要步驟


安裝步驟

安裝過程僅需幾分鐘，且需以下使用者輸入：

  1. 授權協議
  2. 安裝目錄

語言

預設情況下，Tech2Win用戶介面將顯示您的操作系統之語言。 通常可支援以下語言。 若您的語言並未受到支援，安裝程式啟動時會以英文作為預設安裝語言

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)英語 (英式或美式)*
  • el_GR (EL)Greek
  • es_ES (ES)西班牙語
  • fi_FI (FI)Finnish
  • fr_FR (FR)法語
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)葡萄牙語 (巴西)
  • pt_PT (PT)葡萄牙語 (葡萄牙)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)中文 (簡體)
  • zh_TW (ZH)中文 (繁體)

* 此Tech2Win語言為英式英語。 然而，您所使用的Tech2軟體及安裝程式可能為美式英語，取決於軟體來源。

授權協議

您必須接受該授權協議。

安裝目錄

您可選擇任何目錄做為Tech2Win之安裝位置。 安裝目錄預設值若非在<您的程式目錄>\Motors\Tech2Win，則是重新安裝時在先前指定之位置。

最後部份是確認安裝程序。

虛擬COM 連接埠驅動程式

虛擬的COM連接埠驅動程式僅會在您的電腦上安裝一次，並持續到驅動程序版本升級(極少發生)或Tech2Win從您的電腦卸載為止。
若安裝驅動程式，您會短暫看到一個DOS框。 其將會自動關閉且不需有任何動作。 驅動程式檔案另外放置在Tech2Win安裝目錄內的'驅動程式' 子目錄。
手動安裝或卸載虛擬COM連接埠驅動程式是可能的，但不推薦。 從 CMD 殼層使用下列指令之一：

  • 叫出'vbsetup7'以安裝驅動程式
  • 叫出'vbsetup7 /u'以卸載驅動程式
  • 首要步驟


車輛通訊介面

您的車輛通訊裝置需獨立安裝。 請參考伴隨著車輛通訊介面的各別安裝指南。

  • 首要步驟: 車輛通訊介面
  • 高級主題: 組態檔
  • 安裝: 安裝步驟
  • 常見問題: 我如何使用超過一個MDI？
  • 常見問題: Tech2Win無法找到我的MDI


首要步驟

這些首要步驟指示您如何使用Tech2Win。 其假定您已熟悉Tech2本身。 車輛通訊在這些首要步驟中並不需要。

如欲快速啟動，則進行以下步驟：

  1. 使用桌面上的快速啟動捷徑運行Tech2Win軟體。
  2. 從TIS2Web下載新的Tech2軟體以取得有效授權。

欲使用可選擇之配置：

  1. 使用桌面上的Tech2Win捷徑啟動配置程序。 在安裝後應出現顯示器配置。
  2. 如欲進行新配置，最好是複製預設配置。
  3. 修改現有配置以符合您的特定要求。
  4. 取得有效授權。

在相容模式下請勿啟動 Tech2Win。 在此情況下記錄檔內會出現警示。 Tech2Win 僅能用於 XP 內所存在的微軟 Windows 功能，而對於較早期的微軟 Windows 版本則無法運作。

  • 首要步驟: 新配置
  • 首要步驟: 修改配置
  • 首要步驟: 車輛通訊介面
  • 操作Tech2Win: 選單
  • 操作Tech2Win: 安全性
  • 操作Tech2Win: 狀態列
  • 高級主題: 組態檔


選擇配置

在首次啟動Tech2Win應用程式時，會出現以下畫面。 您可經由預設配置之選項直接啟動Tech2Win。 預設配置運行時不進行任何車輛通訊。

Start First Time

授權資訊訊息框將會出現，您可忽略之，以開啟預設配置。

在操作觸碰式螢幕時，啟動PC鍵盤程式，並經由此模擬鍵盤之程式輸入字母，如此可能較為有利。


鍵盤

若存在PC按鍵與按鈕，其編排類似於Tech2之按鍵。 部份額外按鍵由Tech2Win提供，其並未出現於原本的Tech2。 PC上的數字小鍵盤可能無法作用於所有情況下。 若有任何問題，請檢查您的PC之標準鍵盤配置是否已變更。 特別是SHIFT 鍵在此情形下可能已受損。

PC鍵盤 | 按鈕 | 功能
F1 功能鍵 | 不適用 | Tech2Win說明
F5...F8 功能鍵 | 使用由該熱鍵所佔用的Tech2Win顯示區域 | Tech2的四個熱鍵
上、下、左、右方向鍵 |  | Tech2上、下、左、右鍵; 僅有這些按鍵可自動重複。
0 .. 9 按鍵 | F0 • • • F9 | Tech2 F0 .. F9 按鍵
後退鍵 | Exit | Tech2退出鍵
輸入 / 返回 | Enter | Tech2 ENTER 鍵
Y | Yes | Tech2 確定鍵
N | No | Tech2 否定鍵
Q | ? | Tech2 ?鍵
S | Shift | Tech2 轉換鍵; 狀態列內的轉換指標或轉換鈕上的指標可顯示其狀態。
ctrl-P | PWR | Tech2 電源鍵; 顯然此按鍵僅可關閉Tech2Win應用程式。
ctrl-R | 不適用 | 重設Tech2Win。 類似於Tech2上的電源開啟/關閉週期。 然而，附加的車輛通訊介面並未重設。 例如PCMCIA影像等檔案未重新載入。
首頁 | Home | 啟始鍵。 僅部份應用程式支援。
僅可透過選單項目文件獲取。 | Print Screen | 列印Tech2畫面截圖的方法是建立一個臨時BMP檔，並叫出與BMP檔關聯之應用程式。 在列印之前，使用該應用程式調整影像大小或旋轉其方向。
僅可透過選單項目文件獲取。 | Save Screen | 儲存 Tech2 畫面截圖的 BMP 或 PNG 檔。
僅可透過選單項目文件獲取。 | View Report | 顯示使用中的PCMCIA快閃記憶卡上的所有報告，方便使用者查看。


視窗處理

您可利用標準Windows裝置拖曳主視窗之邊線以 調整您的視窗大小。 此外，選單項目選項/解析度支援若干預設大小。 在透過選單項目調整主視窗大小時，小鍵盤視窗會自動維持停靠住。

視窗外觀可藉由在顯示器標籤中變更配置而進行修改。


新配置

點擊按鈕創建新配置以建立新的配置。 會出現一個對話選單要求您選擇一個現有的組態檔做為原始檔。 通常會選擇預設配置。 在輸入新的組態檔名稱後，點擊複製按鈕。

若您是操作觸碰式螢幕，您可能會發現透過PC鍵盤按鈕啟動PC鍵盤較好。

取消按鈕可讓您取消建立程序。

新配置會使用相同的PCMCIA檔案作為現有的來源配置。 若您想對其進行變更，您必須修改配置以便使用不同的PCMCIA檔案。 多數情況下，您僅須複製現有的PCMCIA檔案至一個新檔案，並使用該新檔案。 您可能會偏好您的新配置使用相同的PCMCIA檔案作為來源配置。 若是這樣，當您點擊存檔按鈕時，會出現一個警告畫面。

  • 修改配置


修改配置

顯示藍色的配置標示為唯讀且無法進行修改。 這些配置僅供查看。 當然您可利用修改程序以查看其內容，但無法進行存檔。

選擇四個製表器語言、車輛通訊介面、路徑、顯示器中的各別設定可修改配置。 您可以挑選所需的製表器，或僅須選擇點擊下一步按鈕便可啟用下一個製表器。 在您完成修改後，按下存檔以儲存您的配置。

每當有必要以鍵盤輸入時，您也可叫出一個模擬 PC鍵盤的PC應用程式。 這在無鍵盤可用的觸碰式螢幕膝上型電腦上特別方便。


語言

製表器語言可允許您選擇Tech2Win之操作語言中。 此選擇不會對Tech2軟體內的語言在PCMCIA影象上產生影響。 在從TIS下載Tech2軟體時，您仍須選擇正確的語言。

對於某些區域，並非所有語言皆提供。 在這種情況下，將改以英文顯示。 請檢查是否有類似的語言可用(PT 葡萄牙語-葡萄牙，而非PB 葡萄牙語-巴西)。


路徑

製表器路徑可讓您設置兩個PCMCIA影像之路徑以及至您的本地軟體鍵盤之路徑。 此外亦具備按鈕復制記憶卡......以複製PCMCIA影像。 若您剛建立新的配置，您可能會想用此按鈕以避免數個配置使用相同的PCMCIA影像。

Memory Card Options

復制記憶卡......

此按鍵可讓您複製PCMCIA影像到其他檔案。 其功能類似於為Tech2購買一張新的PCMCIA卡。 複製功能僅作用於目錄C:\Users\Public\General Motors\Tech2Win\pcmcia內之檔案。

槽0:記憶卡圖像位置

您可在此指定包含用於插槽0之PCMCIA影像的檔案。 正常情況下，此類檔案應存放在C:\Users\Public\General Motors\Tech2Win\pcmcia，但其他位置亦有可能。

槽1:記憶卡或ATA

在Tech2中，Tech2Win亦支援兩張PCMCIA卡(影像)。 然而，配置中的第二張PCMCIA影像通常並不太實用。 第二個軟體可能會用於第二個配置中。

在Tech2中，ATA卡是做為偵錯之用。 如獲得技術支援指示，請僅啟用ATA卡。 他們將提供您更多資訊。

PC軟體鍵盤位置

該檔案之預設值取自Windows登錄，且應指向一個能利用滑鼠模擬PC鍵盤的應用程式。 如果您所使用的膝上型電腦具備有此功能的特殊應用程式，您可在此指定該應用程式。


車輛通訊介面

  • COM端口用於Tech2-RS232-仿真
  • MDI序列號之使用
  • 記錄

COM端口用於Tech2-RS232-仿真

請選擇未使用的COM 連接埠作為Tech2模擬之用。 為了您的方便，配置程序會試圖找出哪些序列埠已在使用中並顯示之。

若您選擇現有的COM 連接埠，Tech2Win會將自身與該現有COM 連接埠連結。 您可利用該COM 連接埠從第二台運行TIS應用程式的電腦下載Tech2軟體，使用零調製解調器電纜。 請注意，由於Windows的限制，使用實際的COM連接埠可能無法以115.200波特可靠地運作。

若選擇非現有COM 連接埠，Tech2Win將自動建立一個虛擬連接埠。 該虛擬連接埠可能用於運行於相同PC的TIS，以和Tech2Win建立通訊。 在使用虛擬連接埠時，便無傳輸速率限制。

若您選擇'搜尋'作為COM 連接埠，Tech2Win會在範圍9至1中的第一個未使用的連接埠建立一個虛擬COM 連接埠。

MDI序列號之使用

輸入MDI之序號。 該號可於MDI背面找到。 在連字號後使用該號。

若您未輸入序號，Tech2Win會自動在網路中顯示一份MDI列表，讓使用者挑選一個MDI。 在未找到指定的MDI時，會出現相同的選擇框。

記錄

'ISO22900-2 / PDU-API'已選擇，且J2534-2隨時呈現灰色。 日後Tech2Win也許亦可支援J2534通訊協定。

  • 高級主題: 組態檔
  • 常見問題: 我如何確定該使用哪個COM 連接埠用於Tech2Win？
  • 常見問題: Tech2Win 與 TIS2Web之間的通訊
  • 常見問題: 我如何使用超過一個MDI？
  • 常見問題: Tech2Win無法找到我的MDI


顯示器

顯示器標籤主要用於變更Tech2Win顯示方面之設定：

  • 鍵盤
  • 色彩
  • 聲音
Display and Key Options

鍵盤

您可在此處選擇是否要顯示小鍵盤。 小鍵盤可在Tech2Win螢幕上左右拖曳。 背景顏色可透過標準顏色對話框進行選擇。

色彩

Tech2螢幕的背景及前景顏色可在此處分別選擇。 此為兩個最常見的顏色組合：

Screen with background 0000FF, foreground FFFFFF | 小鍵盤背景白色; 背景藍色; 前景白色
Screen with background 000000, foreground C0C0C0 | 小鍵盤背景藍色; 背景黑色; 前景淺灰色

聲音

您可在此選擇關閉音效。 每次Tech2程式會發出嗶聲，PC喇叭將被使用。


儲存配置

使用中的配置可經由按下左下角存檔 <配置>進行儲存。 若您查看的是唯讀配置，則該按鈕將不會出現。


經由TIS2Web的有效授權

正常情況下，將Tech2軟體下載至Tech2Win時將會提供您有效之授權。 此外，您可透過 TIS2Web (不是 TIS2000) 去執行「安全途徑（安全）」而取得授權。 因此，前提條件是在汽車通訊介面的配置程序中選擇虛擬COM連接埠。

經過成功的安全性存取，您可看到狀態列右側有一個打開的鎖。 您可在括號中看到授權的有效天數。 當您再次啟動Tech2Win，只要不執行車輛通訊，就不會顯示安全性指標。 在首次與車輛進行通訊時會檢查授權且指標會顯示打開或封閉的鎖。

  • 操作Tech2Win:安全性
  • 常見問題:我如何確定該使用哪個COM 連接埠用於Tech2Win？
  • 常見問題:Tech2Win 與 TIS2Web之間的通訊
  • 常見問題:有效授權
  • 常見問題:Tech2Win和安全性存取之間有何差異？


操作Tech2Win

以下主題是由大多數技工在操作Tech2Win時所使用：

  • 選單: 畫面配置及各別選單項目。
  • 下載PCMCIA影像: Tech2Win之診斷軟體更新相當類似於Tech2所採用之程序。
  • 安全性: 安全性措施可避免Tech2Win在未經授權之環境下執行車輛通訊。
  • 查看報告: Tech2鍵盤在Tech2Win中已稍微改進。 '檢視報告'之按鈕是最明顯的案例。
  • 處理PCMCIA影像: 與擁有用於Tech2的多個PCMCIA卡類似，您可能同時有數個用於Tech2Win的PCMCIA影像在使用中。
  • 狀態列: 狀態列可告知使用者狀態列的各別部份。
    • 高級主題
    • 常見問題


選單

Tech2Win應用程式具有以下選單項目：

  • 文件
  • 選項
  • 視窗
  • 說明

文件

文件 選單提供以下可能性：

  • 儲存T2螢幕（320x240）用於以320x240像素支黑白圖像儲存實際T2-畫面在您的PC中。 儲存位置及檔案格式(BMP, GIF, JPG, PNG)可自由選擇。
  • 列印螢幕 可在Tech2畫面上建立一個白底反黑的BMP圖像，並叫出與BMP檔案聯繫之程式。 您可使用該軟體列印該圖像。
  • 檢視報告文檔 提供檢視(及列印)報告檔案之可能性而不需使用TIS2Web。
  • 退出 可讓Tech2Win關機。

選項

選項提供以下選擇：

  • 解析度可用來選擇三種標準螢幕大小之一。
  • ROM-Write from 0x00003ED76是做為內部偵錯之用。
  • 自動擷圖可儲存各種不同的Tech2畫面至紀錄目錄中。
  • 停用CANdi並重新開機可模擬在其本身及車輛之間不具有CANdi的Tech2。 在CANdi中斷非標準車輛通訊線路之罕見情況下，此部份實屬必要。

視窗

選單 視窗 可提供您啟動選項 Tech2Win資料顯示器 以及 Tech2Win DTC顯示器 的可能性。 在當前的Tech2Win版本中，所有其他選項皆呈現灰色。

倘若 Tech2 軟體可支援 Tech2Win資料顯示器 您便可使用此選單項目。 一旦輸入數據顯示，Tech2Win會顯示額外的數據顯示視窗，和Tech2數據顯示並列。 只要 Tech2 螢幕上一出現資料顯示器 (Data Display) 則選單項目便無法啟用。 在此情況下您便必須退出資料顯示器 (Data Display) 以便啟用選單項目並重新開啟資料顯示器 (Data Display)。

Tech2Win資料顯示器 的類似限制也適用於 Tech2Win DTC顯示器。 倘若 Tech2 軟體可支援 Tech2Win DTC顯示器 您便可使用此選單項目。 額外的診斷故障代碼顯示器 (DTC Display) 視窗會與 Tech2 診斷故障代碼顯示器 (DTC Display) 並排出現。 只要 Tech2 螢幕上一出現診斷故障代碼顯示器(DTC Display) 則選單項目便無法啟用。 在此情況下您便必須退出診斷故障代碼顯示器 (DTC Display) 以便啟用選單項目並重新開啟診斷故障代碼顯示器 (DTC Display)。

說明

可提供以下選擇：

  • 幫助話題......可叫出Tech2Win說明。
  • 指令線路參數 顯示用於Tech2Win的命令列參數。
  • 關於顯示當前之版本號以及Tech2Win的TIS2Web下載限制。


下載

首先，啟動Tech2Win 並使其停留在主畫面。 啟動 TIS2Web 或 GlobalTIS 並透過 車輛通訊介面 選項鍵內所指定的 COM 連接埠進行下載。

使用內建的COM 連接埠可從運行TIS的其他PC下載Tech2軟體。 請務必使用交叉式RS232-纜線。 由於Windows可能會在較高的傳輸速率時遺失數據，因此數據傳輸率可能需要減少到57.600波特，此取決於運行Tech2Win的PC上之硬體。

當TIS2Web 及 Tech2Win在相同PC上運行時，最新的Tech2Win版本亦支援快速下載。 TIS2Web和Tech2Win在COM連接埠上的最小通訊仍在執行，但是到Tech2Win的耗時數據傳輸已由內部檔案傳輸取代。 如此可大量降低下載時間至遠低於一分鐘。

  • 高級主題: 組態檔
  • 首要步驟: 車輛通訊介面
  • 常見問題: 我如何確定該使用哪個COM 連接埠用於Tech2Win？
  • 常見問題: Tech2Win 與 TIS2Web之間的通訊


安全性

Tech2Win所使用的安全性機制取決於正確的PC時脈值。 請隨時確保您的PC時脈值已設定。 Tech2Win可接受發生在夏令時制的微小時脈變化。

若無有效且作用中的授權，Tech2Win不會執行任何車輛通訊。 以下狀態列內的指標顯示授權之狀態：

  • green smiley 授權有效。
  • 無指標： 授權尚未接受檢查。
  • red smiley 授權已到期。

欲取得授權，請使用 TIS2Web 應用程式去執行「安全途徑（安全）」更新。 在多數情況下，透過TIS2Web的'軟體下載（SWDL）' 亦可取得新授權。 由於授權會在一定時間過後失效(在某些區域：四週)，您必須定期執行此類更新。

授權為針對特定區域/軟體。 若您使用Tech2Win時搭配不同版本的Tech2軟體，您的電腦必須具備授權。

授權到期之剩餘天數顯示於狀態列中。

  • ( 0) 表示授權已到期或不存在。
  • (<1) 授權將於24小時內到期。
  • (20) 授權將於20天後到期。

請勿隨意處理該授權檔。 此檔案之詐欺性修改可利用內部安全性措施偵測到，且會導致該電腦中的所有授權遺失。 此外，Tech2Win將會有意外表現。 此問題僅能經由執行新安裝而解決。

  • 高級主題: 錯誤訊息及結束代碼
  • 高級主題: 紀錄檔
  • 操作Tech2Win: 狀態視窗
  • 常見問題: 有效授權
  • 常見問題: Tech2Win和安全性存取之間有何差異？
  • 常見問題: 突然停止


查看報告

View Report 此按鈕可用於觀看任何PCMCIA卡上的PRT-檔案內容。 對話框將開啟以顯示PRT-檔案列表。 如果某程式已與該 PRT副檔名產生關聯，此關聯程序將被執行。 否則將開啟記事本編輯器以顯示所選檔案。

在多數情況下，PRT檔案屬於一種使用語言個別代碼頁的ASCII檔案。 對於中文、日文、韓文與泰文，檔案為Unicode格式，開頭為字節序標記(BOM)。

在檢視報告時，Tech2Win會以子目錄C:\Users\Public\General Motors\Tech2Win\reports進行操作。 子目錄僅在您已觀看報告至少一次後才存在。 該目錄會自動清除並做為一個使用中的PCMCIA卡上的PRT-檔案之臨時工作目錄。 即使在Tech2Win停止執行時，期間持續包含這些檔案。 若您想儲存此類檔案，您須將其複製到其他目錄，否則可能很快會在其他使用者選擇觀看檔案時遭到覆寫。


PCMCIA影像

PCMCIA影像通常存放在子目錄C:\Users\Public\General Motors\Tech2Win\pcmcia。 該檔案大小須正好32Mbyte (33,554,432字節)或10Mbyte (10,485,760字節)以及副檔名*. bin。 如果進行下載，或如果Tech2Win在快閃記憶卡上儲存東西，這些影像會進行修改(如每個正常的PCMCIA卡一般)。 修改功能可利用防寫保護開關(指令 -W0 或 -W1) 而停用，或藉由在'-W'-選項內忽略'p'-值(組態檔). 防寫保護開關無法透過配置程序存取。 若您想使用選項'-W0'、'-W1' 或 '-W'.，您必須手動修改組態檔。


狀態列

狀態列顯示於Tech2畫面底下。 以下項目顯示於狀態列：

  1. 速度指標
  2. 車輛通訊狀態
  3. 序列埠狀態
  4. SHIFT 鍵
  5. 自動擷圖
  6. 登錄警告
  7. 授權

Status Bar

速度指標

速度指標顯示CPU花費多少時間模擬Tech2軟體。 數量低者(指標向左)較數量高者(指標向右)良好。 任何綠色指標皆可接受。 如有其他Windows任務突然作用，該指標可能會短暫變為黃色。 此情況應加以避免。

車輛通訊狀態

車輛通訊狀態可顯示車輛通訊介面(MDI)以及車輛與Tech2Win之間的通訊是否存在。

序列埠狀態

在經由COM 連接埠和Tech2Win進行通訊時，該指標會顯示COM 連接埠上的通訊是否作用中。

SHIFT 鍵

該指標顯示SHIFT 鍵是否作用中。 您可利用鍵盤上的'S'鍵或小鍵盤上的SHIFT鍵進行轉換。

自動擷圖

'自動擷圖' 可在'選項' 選單中啟用。 每次畫面變更時，新的螢幕截圖檔便會儲存在登錄目錄中。 此部份可由狀態列中紅色相機上的曲柄把手轉動而顯示。 一旦'自動擷圖' 停用後，該相機會消失。

登錄警告

記錄狀態指標可具有三種不同狀態。

  • gray log status indicator 紀錄檔未包含警告或錯誤。
  • yellow log status indicator 紀錄檔包含警告訊息。
  • red log status indicator 紀錄檔包含錯誤訊息。

授權

授權指標有三種狀態：

  • green smiley 授權使用中且有效。
  • 無指標： 授權尚未接受檢查。
  • red smiley 授權已到期或不存在。
請參見連結安全性以了解更多細節。

狀態列上的工具提示

對於某些圖示， 會顯示工具提示以提供一些額外資訊：

VCI序號之工具提示：
Tooltip VCI

Tech2軟體版本之工具提示
Tooltip TECH2

相稱性之工具提示
Tooltip Comport

下一個螢幕截圖數量之工具提示 (若'自動擷圖'已啟用)
Tooltip Camera

顯示具有'警告'等級或更高的最後登錄檔之工具提示
Tooltip Logfile

確切授權效期之工具提示
Tooltip License

若游標在某圖示上超過0.5秒未移動，便會顯示工具提示。工具提示會在5秒後或游標移動時消失。

  • 高級主題: 錯誤訊息及錯誤代碼
  • 高級主題: 紀錄檔


高級主題

此處探討之主題對於Tech2Win的標準使用者而言較不重要。 所有涉及Tech2Win設置、管理和配置之人士可能會發現資訊有用。

  • 重新安裝
  • 卸除安裝
  • 組態檔的直接修改
  • 紀錄檔
  • 錯誤訊息及結束代碼
  • ATA卡
  • 登錄紀錄
  • 檔案說明
  • 配置管理範例


卸除安裝

完整的安裝目錄，該目錄包含使用者數據(C:\Users\Public\General Motors\Tech2Win)，且包含應用程式數據的目錄(C:\ProgramData\General Motors\Tech2Win) 已刪除。

  • 高級主題: 重新安裝
  • 安裝


組態檔

組態檔隨時存放在子目錄C:\Users\Public\General Motors\Tech2Win\config 並含副檔名 *.conf。 您可能會決定手動修改組態檔，因為並非所有檔案選項皆可透過 Tech2Win存取。 組態檔是一個開頭字節為Byte-Order_Mark (BOM)的Unicode檔案。 我們強烈建議您在執行任何手動變更時使用可處理Unicode的編輯器，如記事本。

組態檔為行導向。 空的行則忽略。 每行都是以一個選項為開頭，後面接著一個數值。 如需範例，請參閱 default.conf 檔案。 請參考以下表格，其探討所有可用之選項。

若您想直接從桌面啟動某個配置，請建立一個執行'C:\程式資料夾\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf之捷徑。 該程式應會從以下作業目錄中啟動：'C:\程式資料夾\General Motors\Tech2Win\bin'

選項 | 數值/意義
; 註解
@ 主要及次要格式中的十進位制版本編號
帶有不同於Tech2Win主要編號的組態檔將無法被接受。 帶有低於Tech2Win次要編號的組態檔將被接受。
-W0
-W1 		PCMCIA卡在插槽0/1中有一個防寫保護開關已啟動。
-B0
-B1 		插槽0/1內PCMCIA卡的區塊大小Kbyte(千字節)。 可接受的值為128(預設)或256。
-P0
-P1 		該檔案包含插槽0/1PCMCIA卡的二進位制影像。 檔案大小須正好為10MB或32MB。 環境變數如%ProgramData%已擴大。
若此選項不存在，則該插槽應假設為空的。
-A0
-A1 		該檔案包含插槽0/1PCMCIA卡的屬性值。 如果不存在，預設屬性將根據卡及區塊大小而被使用。
-W | 在一退出Tech2Win時，所有持久性數據將被寫入其各自檔案。 數值p/f/r/c可加以組合，以分別表示PCMCIA/Flash-ROM/RTC/CANDI-App。
-H | 堆積管理功能 可結合數值 0/r/w/t 去分別啟動歸零、讀取檢查、寫入檢查以及工作檢查。 數值 l 始終是用來在較低的位址上執行堆積記憶的配置以便實施替代性配置方案。 通常，此選項僅在開發環境中使用。
-PC | 之前用於PCMCIA卡複製之路徑。 本選項目前已忽略。
-MS | 車輛通訊介面(MDI)及序號之識別。 若尚未設定，則會為您顯示一份可提供的MDI清單。
-CT | 文字顏色(前景)為3個十六進位制字節數值。 預設值為000000 (白色)。
-CB | 背景顏色為3個十六進位制字節數值。 預設值為FFFFFF (黑色)。
-ATA | 使用此選項以啟用ATA擷取卡。 移除其以停用ATA擷取卡。
-C | COM端口編號(1...9)作為TECH2的RS232C通訊端口。 通常COM9用於虛擬 COM端口，其經由Tech2Win安裝。 若此選項不存在，則從COM9向下尋找未使用的COM 連接埠。 使用Tech2圖示及TIS2Web圖示之間狀態列上的工具提示，以查看哪個COM 連接埠正在使用中。
-WR | PC位址 (通常為253558)，可允許寫入PCMCIA和快閃唯讀記憶體區域。 此功能須額外在選單中啟用(或藉由使用選項 -WA)。 有必要藉由單步驟偵錯工具對不可修改的記憶體內之代碼進行偵錯。
-WA | 讓單步驟偵錯工具寫入不可修改的記憶體。
-OF | 選項檔案包括選項 / 一對數值。
-TP | 定時調整 (比例值). 預設為5000。 降低此數值使該數量執行週期調適為較實時更快。
-TD | 定時調整 (微分值). 預設為100。 降低此數值以較瞬時之變更反應更快。 警告: 隨意處理TP和TD值可能導致速度問題。
-PJ
-PP 		指定應使用之通訊協定：
用於J2534通訊的PJ。
PP 用於 ISO22900-2 / PDU-API (預設)
-S | 此選項之顯示狀態可開啟PC之蜂鳴器上的聲音輸出。
-L | Tech2Win應用程式的語言。 若此紀錄遺失，則會使用有效的Windows語言做為預設值。 請見以下連結以獲取可指定的語言列表：語言 該Tech2模擬視窗本身會顯示PCMCIA卡上的任何語言上的(例如，已下載到PCMCIA卡)。
-UD | 使用者資料目錄之覆寫. 在 Win7 之下, 它通常位於 C:\Users\Public\General Motors\Tech2Win
-AD | 應用程式資料目錄之覆寫. 在 Win7 之下, 它通常位於 C:\ProgramData\General Motors\Tech2Win
-US | 採用使用者之特定信號去偵測Tech2Win的多種情況. 此選項將使每一位使用者在相同的機器上, 或者是以伺服器去平行操作 Tech2Win. 當使用此選項時, 您也應該同時指定其它選項 -UD 以及 -AD.
-SS | 選項旨在指定 Tech2Win 視窗, 且包括鍵盤 (倘若有提供) 的整個尺寸範圍. 第一個參數必須是被雙引號 (') 所包圍的字串, 它是用來當作 選項 / 解析度 主選單內的範圍名稱. 第二個參數是 Tech2Win 螢幕, 也包括鍵盤的水平像素總數. 第三個參數是 Tech2Win 螢幕的垂直像素總數. 第四個選擇性參數是以像素所計算的鍵盤寬度.
-SH 控制螢幕操作的選項. 下列十進位數字是用來說明哪些螢幕操作會造成停用的可能.
  • 位元 0: 無最小/最大的可能.
  • 位元 1: 螢幕上無法重定位.
  • 位元 2: 無法更改尺寸大小. 在此情況下 選項 / 解析度 主選單會變灰無作用.
  • 位元 3: 資料顯示器以及 DTC 視窗是和Tech2Win (不含鍵盤) 的尺寸完全相同


記錄

每次啟動Tech2Win配置都會以HTML格式建立一個紀錄檔在C:\Users\Public\General Motors\Tech2Win\Logs 子目錄中。 為避免硬碟擁擠，超過一週以上的紀錄檔都將被刪除。

紀錄檔會自動根據其建立之日期(年份, 月份, 日期) 與時間(小時, 分鐘, 秒數)命名：
yyyy-mm-dd_hhmmss.html

紀錄檔紀錄皆使用英文，但為Unicode格式，開頭為字節Byte-Order_Mark (BOM)。 紀錄檔中的每行屬於以下紀錄等級之一：

紀錄等級 | 意義
資訊 | 僅供參考。 執行該程式無效果。
警告 | 發生不尋常情況。 使用者可能看不到任何不良影響。
ERROR | 發生對使用者而言明顯的錯誤。
CRITICAL | 發生嚴重錯誤，將導致程序出現異常。
FATAL | 出現嚴重錯誤，將導致 Tech2Win立即停止操作。

所有'警告'以上的等級皆為有色，使其容易被找到。

此外，若使用列印螢幕 或 自動擷圖 選單項目，列印及視訊檔也會出現在Logs子目錄中。
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
自動擷圖 圖片與HTML檔案連結 - 因此可使用HTML紀錄檢視這些圖片的順序。

使用者可在狀態列得知警告紀錄( yellow lightning bolt)或更嚴重的登錄紀錄( red lightning bolt)是否存在。


錯誤訊息及結束代碼

錯誤訊息可能出現在對話框中。 這些對話框仍允許Tech2Win並行執行Tech2程式。 結束代碼是可導致Tech2Win不正常終止的嚴重錯誤。 該結束代碼可用於批次檔以偵測程序終止原因。

錯誤訊息

可能會彈出以下錯誤訊息。 此處提供此情形之簡短說明以及解決問題之方式。

Emulator too slow Emulator failed to start

結束代碼

結束代碼 | 數值 | 意義
OPCODE_ERROR | -7 | 偵測到Tech2微處理器(68332)的無效指令。 PCMCIA影像可能由於某種原因已毀損。
ATA_PROBLEM | -6 | 在ATA模擬期間發生問題。 如果您在獲得使用ATA卡之說明後發現此類問題，請聯繫服務台。
DEMO_TIME_IS_UP | -5 | 不應該出現在Tech2Win的官方版本。
DLL_NOT_LOADED | -3 | 其中一個必要的DLL檔無法載入。 您的Tech2Win版本似乎不完整。 請執行新的安裝程序並/或選擇不同的語言。
EXIT_INIT_FAILED | -2 | 初始化失敗。 研究紀錄檔以找出確切原因。 若紀錄檔不存在，請檢查您是否具有所有目錄的正確讀取/寫入權限。
正常 | 0 | Tech2Win已正常終止。


ATA卡

TECH2內的ATA卡一般僅用於軟體研發期間偵錯之用。 所有必要的ATA數據儲存在子目錄C:\Users\Public\General Motors\Tech2Win\ataCapture。 這個目錄通常並不重要，除非另有特殊說明，否則可安全刪除。

由於ataCapture目錄是固定的，其內容之所有配置皆相同。


檔案

以下檔案及目錄是由Tech2Win所使用：

目錄 | Vista之前的位置 | 用於Vista及其後的位置
安裝 | 在安裝期間根據定義
使用者數據 | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
應用程式數據 | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

文件 | 使用
[使用者數據]\atacapture | 包含未出現在ATA卡上的檔案。 除非獲得指示，否則這些檔案並非必要。
[安裝]\bin | 包含實際可執行且必要的DLL檔以及用於執行的必要圖像。
[安裝]\bin\emulator.exe | 主要可執行檔執行Tech2代碼。
[安裝]\bin\emulator_xx_XX.dll | 特定語言資源 DLL。
[安裝]\bin\T2Configurator.exe | Tech2Win之配置部份。
[安裝]\bin\Pictures | 包含Tech2Win所需之圖示。
[使用者數據]\config | 包含所有組態檔。
[使用者數據]\data | 包括在Tech2Win執行期間所修改之檔案。 這些檔案對於正確執行Tech2Win而言是必要的。 通常情況下，您不應該接觸這些檔案，除非獲得明確指示應如此做。
[應用程式數據]\data | 包括在Tech2Win執行期間所修改之檔案。 這些檔案對於正確執行Tech2Win而言是必要的。 通常情況下，您不應該接觸這些檔案，除非獲得明確指示應如此做。
[應用程式數據]\data\emulator.sec | 安全性檔案 . 請勿修改此檔案。
[應用程式數據]\data\emulator.card | 卡片檔. 包含所有已知於Tech2Win的PCMCIA卡。 請勿修改此檔案。
[使用者數據]\data\emulator.disp | 此檔案保留了Tech2Win螢幕的位置與大小。 如果您刪除此檔案，其將會被重新建立，且Tech2Win螢幕將會以 640x480的大小啟動於左上角。
[應用程式數據]\data\emulator.lic | 授權檔. 包含有關您的授權有效期間的資訊。 請勿修改此檔案。
[應用程式數據]\data\emulator.rtc | 即時時脈檔案. 本檔案是作為在Tech2的RTC中所發現數據之儲存之用。
[應用程式數據]\data\emulator.dta | 一個'不用再告知我'資料檔。. 該檔案儲存的PCMCIA軟體版本不應(再)顯示無法執行自行檢測之警告，該測試需具備回送介面卡。
[應用程式數據]\data\candi.bin | CANdi應用程式檔案. 保留了附屬於Tech2的CANdi應用程式。
[應用程式數據]\data\eprom.bin | Tech2內部EPROM檔案. 包含Tech2快閃記憶體內部之內容。
[安裝]\driver | 虛擬COM 連接埠驅動程式的安裝檔。
[安裝]\help\emulator_xx_XX.chm | 特定語言的說明檔案。
[使用者數據]\Logs | 包含紀錄檔。 超過一週的資料夾會自動刪除。
[使用者數據]\pcmcia | 包含PCMCIA影像檔。 形象化而言，每個檔案皆對應一個Tech2 PCMCIA卡。 這些檔案可隨意儲存於不同位置。


配置管理

組態檔隨時存放在子目錄C:\Users\Public\General Motors\Tech2Win\config 並含副檔名 *.conf。 Tech2Win僅可用以產生新的組態檔，或修改現有的非唯讀組態檔。 對於所有其他組態檔管理，請使用Windows檔案總管或類似的檔案處理程式。 這對於下列活動而言實屬必要：

  • 刪除組態檔
  • 重新命名組態檔
  • 變更組態檔的唯讀屬性

我們強烈建議您隨時擁有組態檔 default.conf。 正常情況下此檔案應具有唯讀屬性設置，以避免錯誤覆寫。 然而，若您正在變更此檔案以符合您的特定需求，則需立即除去該唯讀屬性。

PCMCIA影像在子目錄 C:\Users\Public\General Motors\Tech2Win\pcmcia。 其中每個檔案皆對應一個您在操作Tech2時已熟悉的PCMCIA卡。 有了Tech2Win您可隨心所欲擁有許多影像。 僅須複製現有影像至新檔名。

若您想直接從桌面啟動某個配置，請建立一個執行"C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf"之捷徑。 該程式應會從以下作業目錄中啟動：'C:\Program Files\General Motors\Tech2Win\bin'

組態檔數量並非取決於您正在使用的PCMCIA影像數量。 您可擁有數個組態檔並使用相同的PCMCIA影像。 這便密切模擬維修廠內的情況，其中會有若干技工共用同一個Tech2 (以及相同的PCMCIA卡)。

您亦可選擇讓每個組態檔擁有其專用的PCMCIA影像。 這將使個別設置彼此更為獨立。 然而，更新每個PCMCIA影像的結果可能無法被接受。

當您透過複製現有配置而建立一個新配置時，若PCMCIA影像並未變更，配置程序會顯示一個警告。 在此情況下，您會有兩個配置使用相同的PCMCIA影像。 若您希望如此，僅需按下確定。 若您希望新配置使用不同的或新的PCMCIA影像，則按下取消。 您可選擇建立新影像，方法是使用復制記憶卡......

這裡提供兩個案例方法，使您可管理您的配置及PCMCIA影像。

根據使用者的一個配置

您有機會根據各使用者儲存配置。 舉例而言，配置名稱將為使用者名稱。 此概念之優點為，使用者特定設置，例如個人車輛通訊介面(MDIs)，可顯示並進行語言設置。 缺點是，如果有多位使用者使用相同軟體，您將須複製 PCMCIA檔案。 當然，該使用者特定配置可能會使用中間的PCMCIA檔案。

根據Tech2軟體的一個配置

您可能會選擇為您所下載的每個軟體進行新的配置。 因此，若有必要，即使是較舊的軟體版本也可立即提供。 在此情況下，軟體名稱及版本號通常會被選作為配置名稱。

  • 首要步驟: 車輛通訊介面
  • 首要步驟: 路徑
  • 高級主題: 組態檔
  • 安裝: 安裝步驟


常見問題(FAQ)

  • 我如何確定該使用哪個COM 連接埠用於Tech2Win？
  • Tech2Win 與 TIS2Web之間的通訊
  • 有效授權
  • 授權編號表示什麼？
  • Tech2Win和安全性存取之間有何差異？
  • 在執行初始軟體之安全性存取時，TIS2Web出現非特定錯誤。
  • Tech2Win 不會從其他區域執行 Tech2軟體
  • 我如何使用超過一個MDI？
  • 紀錄檔包含錯誤'CPU32: Too many 0000/FFFF Commands encountered'
  • 無法看到Tech2視窗
  • SPS無法作用
  • 某些自行測試無作用
  • 速度指標波動
  • 突然停止
  • 瑞典語可顯示於軟體15.001
  • 失去與MDI之通訊
  • Tech2Win無法找到我的MDI
  • 我想立即啟動 Tech2Win而不理會配置程序
  • 列印功能在哪裡？
  • 我的電腦則提供 '未使用' 之 PCMCIA 資料夾
  • 我剛接獲 '非法檔案路徑' 的訊息

我如何確定該使用哪個COM 連接埠用於Tech2Win？

您可利用Windows的'裝置管理員'，查看'連接埠(COM & LPT)'。 但部份電腦有內接式數據機或已安裝藍芽裝置，且並未顯示於此目錄中。
另一種方法是使用一個連同配置程序傳送的小指令。 您可透過開始選單(Tech2Win資料夾) 點擊 'show com ports'執行之。
兩種方法皆顯示安裝於您的電腦的COM 連接埠，以及您不應使用。

Tech2Win 與 TIS2Web之間的通訊

重要的是在您啟動與TIS2Web之通訊以進行安全性存取或軟體下載之前，Tech2Win為運行中。 當Tech2Win已啟動時，TIS2Web僅可辨識虛擬連接埠。

有效授權

正常情況下，來自TIS2Web的'軟體下載（SWDL）' 將會提供有效授權給您。 倘若您仍未取得授權，必須透過 TIS2Web (不是 TIS2000)「安全途徑（安全）」以取得有效授權。 在透過「安全途徑（安全）」取得授權之前，請勿使用 Tech2Win 去執行任何其它的 TIS2Web 通訊，例如「軟體下載（SWDL）」。

授權編號表示什麼？

狀態列右側的授權編號顯示完整的授權天數。 在執行下載或安全性存取後，會立即顯示30天之數字。 然而，在Tech2Win重新開啟後會顯示29，因為授權效期可能會變成29天23小時55分鐘等。 如果授權天數降至24小時內，會顯示授權效期<1。 若授權已到期會顯示0。

Tech2Win和安全性存取之間有何差異？

Tech2Win授權可讓您使用Tech2Win。 如欲取得授權，您可進行軟體下載或定期從事安全性存取(最常見：每30天)。 透過TIS2Web執行此類下載之能力可告知Tech2Win存在一個有效的使用者。 來自Tech2的安全性存取可告知Tech2Win某些安全性相關之活動，例如禁用安全氣囊是允許的。 Tech2Win授權及安全性存取兩者皆可透過TIS2Web '安全途徑（安全）' 應用程式執行。 Tech2Win會在右側狀態列顯示剩餘的授權效期。 不幸的是，在Tech2Win僅執行Tech2軟體時，Tech2Win無法顯示安全性存取之效期，且對Tech2軟體本身不瞭解。

在執行初始軟體之安全性存取時，TIS2Web出現非特定錯誤。

該反應與Tech2上的相同。 由於其使用年限，該初始軟體無法從TIS2Web取得授權。 然而，由於該展示軟體因缺乏必要的授權而無法與車輛進行通訊，因此這並非確實問題。 而且，由於授權是特定由TS2Web下載，無論如何您必須在下載 Tech2軟體後取得授權進行每回各別下載。 初始軟體之授權將無法讓您藉由North American Operations或Opel/Vauxhall軟體進行車輛通訊。

Tech2Win 不會從其他區域執行 Tech2軟體

您的Tech2Win版本可能受限於一個或數個TIS2Web下載(區域)。 按下說明 / 關於 查看您的Tech2Win版本有哪些限制。 Tech2Win之早期版本僅可操作Opel/Vauxhall軟體。 其他GM區域即將跟進。 無論如何，Tech2Win目前有可從通用汽車執行Tech2軟體。

我如何使用超過一個MDI？

若您想指派特定的MDIs給特定的使用者，我們建議您讓每位使用者擁有其專屬配置。 顯然這些配置應根據個別使用者而命名。 在所有配置中，您應該在'車輛通訊介面'鍵中輸入使用者特定的MDI序號。 一旦使用者開啟其配置，Tech2Win會試著與該特定MDI聯繫。 只有在該MDI未出現時，才會出現一個選擇框顯示Tech2Win可尋找到的所有MDI。

如果您有數個MDI作為一般使用，我們建議您採用'車輛通訊介面' 鍵內之車輛通訊介面序號留白的配置。 使用者將隨時看到可用的MDI選擇框。

紀錄檔包含錯誤'CPU32: Too many 0000/FFFF Commands encountered'

檔案'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' 或當前PCMCIA檔已毀損。 請重新執行Tech2Win安裝程式，並下載新的Tech2軟體。

無法看到Tech2視窗

若無法看到Tech2視窗，其可能當下並未在您的顯示器區域。 當您使用一個螢幕以上或在修改螢幕解析度之後時，會遇到此類影響。 在啟動配置期間按下鍵盤上的Shift鍵。 在這種情況下，視窗解析度將被重置為640×480，且Tech2視窗將顯示在螢幕左上角。 您可能亦須刪除檔案C:\Users\Public\General Motors\Tech2Win\emulator.disp 以達到相同效果。

我們已發現，在關上所有其他應用程式的視窗後，Tech2視窗便無法在螢幕上重新提取的情形。 在所有我們已遭遇的情況下，使用Alt鍵轉換Windows應用程式便可叫出Tech2畫面。 按下您PC螢幕底部工作列的Tech2Win按鈕有時會無法作用。 目前我們仍在調查此問題，並希望在之後版本的Tech2Win中修復。

SPS無法作用

是的，我們瞭解。 我們並無計畫變更這點。 您不應該將Tech2Win替代Tech2來進行SPS。 請透過TIS之SPS程式設定直接使用MDI。

某些自行測試無作用

Tech2自行測試目的在測試Tech2硬體之各別部份。 這些測試中有些需要使用回送介面卡。 這些測試將無法作用於Tech2Win，因為回送介面卡功能並未實行(且並無計畫如此)。 請避免在Tech2Win執行此類無意義測試。 若您予以執行，可能會導致錯誤結果或Tech2Win在沒有回送介面卡的情況下如Tech2中止。 在此情況下，請使用Ctrl-R 以重設Tech2Win。

速度指標波動

狀態列左下側的速度指標顯示在Tech2Win須再次'睡眠'之前，有多少'Tech2指令'可執行。 這個方法是用來確保Tech2Win上的時間可對應實時：較快的PC比較慢的PC睡眠更長。 若速度指標產生波動，則可能有其他應用程式正在使用計算能力或PC時脈正在變動。 高波動率對車輛通訊及TIS2Web通訊有負面影響。 請確保沒有其他應用程式在運行。

大多數膝上型電腦可自動降低CPU時脈以延長電池時間。 這也可能是Tech2Win偵測到速度波動的原因。 在此情形下，請勿從電池運行您的膝上型電腦，而須使用外部電源。 您可能亦須嘗試變更您的電原設定，使操作系統不會降低時脈速度。

突然停止

如果您在紀錄檔中找不到程式終止的原因，則Tech2Win內部安全機制可能已啟動。 請勿隨意處理以下檔案：emulator.sec、emulator.lic、emulator.card。 如果Tech2Win出現安全漏洞，您可能須進行重新安裝。

瑞典語可顯示於軟體15.001

伴隨著Tech2Win的初始軟體是一個展示軟體，存在於每張新PCMCIA卡中。 TIS2Web指出此為瑞典語，因為TIS2Web僅會顯示此展示軟體所支援的四種語言(英語、法語、德語、瑞典語)列表中的最後一種語言。 使用更新模式'定製' 而非'標準' ，以利用最新診斷軟體覆蓋此演示軟體。

失去與MDI之通訊

失去MDI通訊的原因有若干。

  • 電纜連線不良 (包括乙太網路及USB)。
  • 無線連接薄弱。
  • PC進入待機狀態。

Tech2Win無法找到我的MDI

請檢查以下各點：

    1. 該MDI是否作用中？
    2. 該MDI管理員是否發揮作用？
    3. MDI是否可被其他應用程式使用，例如SPS？
您可利用桌面圖示或透過'開始/所有程式/General Motors/GM MDI Software'啟動MDI管理員。: 若要點2無法發揮作用，請聯繫服務台。

我想立即啟動 Tech2Win而不理會配置程序

執行"C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf"。 使用以下作業目錄：'C:\程式資料夾\General Motors\Tech2Win\bin' 您仍可利用配置程序對配置進行任何變更。

列印功能在哪裡？

Tech2Win不提供直接列印功能。 相反地，其可建立臨時檔案並叫出與該副檔名關聯之程式。 這些程式可作為列印之用，使您可調整列印資料之外觀。

Print Report | Print Report

欲列印當前的Tech2Win畫面，請使用選單項目文件 / 列印螢幕 或包含顯示印表機的小鍵盤上的按鈕。 若您需列印數個Tech2Win畫面，可利用選項 / 自動擷圖，因其可為每個Tech2Win畫面建立PNG檔案。 這些PNG檔案內嵌在紀錄檔內。

您亦可列印數據顯示內容(利用選單項目視窗 / Tech2Win資料顯示器啟動)。 利用印刷/HTML啟動按鈕啟動然後停止數據採集。 在停止採集後，會啟動HTML關聯的可執行檔(通常為Internet Explorer)，並提供充足的功能以列印您的數據。

Data Display | Data Display

我的電腦則提供 '未使用' 之 PCMCIA 資料夾

先前的Tech2Win 版本始終可在單獨的目錄下複製已儲存的 PCMCIA 檔案. 此目錄經常為 C:\PCMCIA. 現在已不再使用此目錄, 因為從 TIS2Web 進行快速下載會不必要地將此類下載儲存兩次. 您可以安全地刪除此目錄.

我剛接獲 '非法檔案路徑' 的訊息

該檔案名稱似乎包含了不合法的字元例如百分比符號 (%)。 倘若您在安裝之後即看到此問題則最好直接執行解除安裝並且再重複全新的安裝作業。 利用此法可解決大部分的狀況。

進行一般設定時，環境變數 'Tech2WinUserData' 係設定為 'PUBLIC' (用於微軟 Windows 版本 >= Vista) 以及設定為 'ALLUSERSPROFILE\Documents' (用於 Vista 之前的微軟 Windows 版本)。 在極少數的情況下，於安裝過程中不設定環境變數但在第二次嘗試時卻仍可正常運作。 您也可能會選擇以手動方式去設定環境變數。 倘若您不瞭解如何設定環境變數則詢問您的管理員。


登錄紀錄

以下登錄紀錄是由安裝程式產生。 請勿手動修改這些紀錄。 在處理登錄紀錄時，請留意標準Windows警告。

登錄機碼 | 名稱 | 類型 | 意義
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | 內部版本號
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 語言 | REG_SZ | 安裝語言
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | PCMCIA複製目錄之路徑
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 根目錄 | REG_SZ | 安裝路徑
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 卸載選項 | REG_DWORD | 卸載設定
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | 組態檔版本
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | 虛擬COM 連接埠驅動程式版本
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | 顯示名稱 | REG_SZ | 新增/移除程式清單內的軟體名稱
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | 卸載字串 | REG_SZ | 卸載程式之路徑


重新安裝

重新安裝程序將刪除整個Tech2Win安裝目錄，但有下列例外情況。

  1. 包含配置的config子目錄並未刪除。
  2. 一般包含PCMCIA影像的pcmcia子目錄並未刪除。
  3. 可能包含偵錯資訊的ATA子目錄並未刪除。
組態檔可能無法兼容： 原有的Tech2Win版本之組態檔是否可由較新版本的Tech2Win所讀取，這點並無保證。 原則上PCMCIA影像不會變得不兼容。

次要的PCMCIA目錄不會受到重新安裝的影響。

有些環境可能會提供較新版本的Tech2Win自動安裝程式。 由於最後的安裝資訊儲存在登錄中，這些設置將在重新安裝期間作為預設值。

您可藉由使用指令碼enable reinstallation執行Tech2Win重新安裝。 該指令碼會連同Tech2Win一起安裝。 基本上，該指令碼僅將在HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win的登入檔內發現的CurrentVersion鍵之數值設置至數值“1.000”。