Tech2Win用户手册

欢迎访问Tech2Win的用户手册。

Copyright (C) 2010..2016 SPO Engineering General Motors 保留所有权利。

  • 介绍:
  • 许可证:
  • 安装:Tech2Win的安装程序说明
    • 安装步骤
    • 车辆通讯界面
  • 第一步
    • 选择一个配置
      • 键盘
      • 窗口处理
    • 新配置
    • 修改配置
      • 语言
      • 路径
      • 显示器
      • 保存一个配置
    • 获得一个有效Tech2Win许可证
  • 用Tech2Win工作: 日常工作的详细信息。
    • 菜单
    • 下载一个PCMCIA映像
    • 安全性
    • 查看报告
    • 处理PCMCIA影像
    • 状态栏
  • 高级专题: 正常使用Tech2Win不需要的信息。 通常仅具有管理任务的人才会感兴趣。
    • 重装
    • 卸载
    • 配置文件的格式
    • 日志文件
    • 错误信息和错误代码
    • ATA卡
    • 注册表条目
    • 文件
    • 配置管理
  • 常见问题


介绍

Tech2Win是一个Windows应用程序，其可以模拟Tech2的功能。 从根本上说，Tech2软件在PC上执行。 要运行此程序，您的PC需要满足下列技术要求：

  • 必须安装了一个车辆通信接口，且连接到PC。 可接受的接口列表可能因区域的不同而有所不同。 在大多数情况下，可以使用GMs多重诊断接口（MDI）。
  • 在安装期间，Tech2Win应用程序需要150MByte的硬盘空间。 每张您希望管理的PCMCIA闪存卡需要额外的32MB。
  • 在Tech2Win应用程序执行之前，您需要至少100MB的可用物理RAM。 您的PC必须有足够的内存来保存整个执行过程中的RAM内的应用程序。
  • 您的PC应具有相当于1.2GHz奔腾处理器（单核）的计算能力。 我们强烈建议您不要同时使用任何其它应用程序。
  • 不需要键盘。 Tech2Win也可以用触摸屏来操作。 对于配置管理，我们强烈建议您使用键盘，因为您将需要输入文件名。
  • 您的彩色图形显示必须具有最低800 x 600的分辨率，颜色深度最低为256。 在没有小键盘的情况下，640 x 480的分辨率是可以接受的。

在使用Tech2Win（代替Tech2的便携式计算机）时，请确保便携式计算机有充足的电源。 通常，您的便携式计算机将不由汽车蓄电池供电，与Tech2一样。

  • 安装
  • 第一步


许可证

欧洲通用汽车 - Tech2Win许可协议

在使用此程序前，请仔细阅读下列条款及条件。 如果您不接受或不理解这些条款或条件，请联系您当地的售后服务代表。 此软件的使用权，仅由通用汽车欧洲公司在用户安装Tech2Win时同意并接受这些条款和条件的前提下授予。
依照当地适用的与通用汽车欧洲公司各国销售公司达成的《特约修理厂协议》的规定，通用汽车欧洲公司将Tech2Win软件及其所包含有关TIS2Web或GlobalTIS或TIS2000的信息使用权，专门授予通用汽车欧洲公司特约修理厂网络的用户。
只要《特约维修厂协议》有效并且当地存在TIS2Web, GlobalTIS和TIS2000许可协议，Tech2Win使用许可协议就有效力。 当授权维修商协议终止时，Tech2Win许可证将与TIS2Web和GlobalTIS许可证一起立即终止。

在《欧盟汽车业竞争障碍排除条例》(BER) 1400/2002之第2段第4款规定下的独立维修厂商，可以将Tech2Win作为通用汽车欧洲公司的“通用汽车欧洲信息技术门户”(GM Europe Info Tech Portal)订阅所提供的一个组成部分，购买使用协议。

Tech2Win执照并不理解车辆沟通界面或PC硬件。

不经相关通用汽车欧洲公司各国销售公司的书面许可，Tech2Win软件不可被进一步分发、销售或放在网上供任何特约修理部门（如《特约修理厂协议》附件中所描述的）之外的第三者使用。 这适用于当前的或非当前的数据（例如过期的DVD）。

在发生无授权或滥用使用权的情况下，欧洲通用汽车各国销售公司将有权立即终止使用权并通知特约修理厂协议的立即终止。在这种情况下，您无权要求剩余贷方余额和/或年度基本费用的返还。

所提供的信息应用于以专业的方式对未改装的欧洲通用汽车车辆执行维护和修理工作。 执行上述工作的前提条件是完成汽车技术培训和定期的再培训。 所提供信息中指明使用专用工具时，必须使用这样的专门工具来专业地进行所有的修理。

欧洲通用汽车Tech2Win上出版的信息（文字、图片、音乐、图形、动画、录像等）以及Tech2Win的编排布置都受到著作权法的保护。 除非事先得到欧洲通用汽车的书面许可，否则不允许复制、分发、交流和/或传播，或以其它方式加以利用。

  • 安装: 安装步骤
  • 第一步


Installation

安装

安装Tech2Win需要PC的本地管理权。 在无管理权限的情况下，安装将不起作用。 在这种情况下，请联系您的本地PC管理员以获取帮助。

要成功使用Tech2Win，您必须完成下列两步：

  • 安装Tech2Win本身。
  • 车辆通信接口的安装。
  • 安装: 安装步骤
  • 第一步


安装步骤

安装本身只花费几分钟的时间并需要下列用户输入：

  1. 许可证协议
  2. 安装目录

语言

在默认情况下，Tech2Win UI将显示在您的操作系统语言中。 通常可以支持下列语言。 如果不支持您的语言，安装程序以英语作为默认安装语言开始。

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)英语（英国或美国）*
  • el_GR (EL)Greek
  • es_ES (ES)西班牙语
  • fi_FI (FI)Finnish
  • fr_FR (FR)法语
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)葡萄牙语（巴西）
  • pt_PT (PT)葡萄牙语（葡萄牙）
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)中文（简体）
  • zh_TW (ZH)中文（繁体）

* Tech2Win的语言是英国英语。 但是，根据软件的来源，您正在使用的Tech2软件和安装程序可能是美国英语。

许可证协议

您必须接受许可证协议。

安装目录

您可以选择任何目录作为Tech2Win的安装位置。 安装目录默认为<您的程序目录>\General Motors\Tech2Win，或在重新安装的情况下，默认为先前指定的位置。

最后确认安装。

虚拟Com端口驱动程序

虚拟com端口驱动程序将仅在您的计算机上安装一次并保留，直到驱动程序版本被升级（很少发生）或从您的计算机卸载了Tech2Win。
如果安装了驱动程序，您将短暂地看到一个DOS框。 其将自动关闭并且不需要任何行动。 此外，驱动程序文件还被存放在您的Tech2Win安装目录的“驱动程序”子文件夹中。
可以但不建议手动安装或卸载虚拟com端口驱动程序。 使用来自CMD外壳的下列命令之一：

  • 调用“vbsetup7”以安装驱动程序
  • 调用“vbsetup7 /u”以卸载驱动程序
  • 第一步


车辆通讯界面

您的车辆通信设备必须单独安装。 请参考车辆通信接口附带的各自的安装指南。

  • 第一步: 车辆通讯界面
  • 高级专题: 配置文件
  • 安装: 安装步骤
  • 常见问题: 我如何才能使用不止一个MDI？
  • 常见问题: Tech2Win没有找到我的MDI


第一步

这些“第一步”向您显示如何使用Tech2Win。 其假设您已熟悉Tech2本身。 在这些“第一步”期间，不需要车辆通信。

要快速启动，执行下列步骤：

  1. 使用您桌面上的QuickStart快捷方式运行Tech2Win软件。
  2. 通过从TIS2Web下载新Tech2软件来获得一个有效许可证。

要使用一个可选择的配置：

  1. 使用您桌面上的Tech2Win快捷方式启动该配置。 在安装一个默认配置后，应出现。
  2. 要定义一个新配置，最好复制默认配置。
  3. 修改一个现有配置以满足您的特定要求。
  4. 获得一个有效许可证。

不要在兼容性模式中启动Tech2Win。 在这种情况下，日志文件中会出现有警告。 Tech2Win仅能在XP及之后的 Windows版本上使用，在XP之前的版本上无法运行。

  • 第一步: 新配置
  • 第一步: 修改配置
  • 第一步: 车辆通讯界面
  • 用Tech2Win工作: 菜单
  • 用Tech2Win工作: 安全性
  • 用Tech2Win工作: 状态栏
  • 高级专题: 配置文件


选择一个配置

第一次启动Tech2Win应用程序时，下面的屏幕显示。 您可以选择直接用默认配置启动Tech2Win。 此默认配置在无任何车辆通信的情况下工作。

Start First Time

许可证信息消息框将显示，但是您可以忽略它以启动默认配置。

在用触摸屏工作时，起动PC键盘程序可能会有帮助，以便能够通过这一模拟键盘的程序输入字母。


键盘

PC键以及按钮，如果存在，映射为常见的Tech2键。 Tech2Win提供了一些原Tech2上不存在额外的键。 PC上的数字小键盘可能在所有情况下都不起作用。 如果有任何问题，请检查您的PC上的标准键盘布局是否已改变。 在这种情况下，尤其是SHIFT键可能已损坏。

PC键盘 | 按钮 | 功能
F1功能键 | 不可用 | Tech2Win帮助
F5 .. F8功能键 | 使用被软键占用的Tech2Win显示区。 | Tech2的四个软键
上、下、左、右光标键 |  | Tech2上、下、左、右键。; 仅这些键有自动重复功能。
0 .. 9键 | F0 • • • F9 | Tech2 F0 .. F9键
退格 | Exit | Tech2退出键
回车/返回 | Enter | Tech2回车键
Y | Yes | Tech2确认键
N | No | Tech2否认键
Q | ? | Tech2 ?键
S | Shift | Tech2换档键。; 状态栏中的Shift指示器或Shift按钮上面的指示器指示该状态。
ctrl-P | PWR | Tech2电源键; 显然，此键只能关闭Tech2Win应用程序。
ctrl-R | 不可用 | 重置Tech2Win。 类似于Tech2上的一个关闭/打开电源循环。 但是，已连接的车辆通信接口不会被重置。 PCMCIA映像等文件不会被重新加载。
本位 | Home | 一个本位键。 仅某些应用程序支持。
只有通过菜单选项文件才可用。 | Print Screen | 通过创建一个临时BMP文件并调用与BMP文件相关的程序，打印Tech2屏幕的一个屏幕截图。 在打印前，使用此应用程序调整映像的大小或旋转映像。
只有通过菜单选项文件才可用。 | Save Screen | 将Tech2屏幕的屏幕截图保存为BMP或PNG文件。
只有通过菜单选项文件才可用。 | View Report | 在激活的PCMCIA闪存卡上显示所有报告，以便用户可以查看它们。


窗口处理

您可以使用标准窗口机制，通过拖动主窗口的边界线来调整您的窗口大小。 此外，菜单项选项/分辨率支持若干预设尺寸。 在通过菜单项调整主窗口的大小期间，小键盘窗口将自动保持缩回。

窗口的外观通过更改显示器选项卡中的配置来修改。


新配置

点击按钮创造新的以创建一个新配置。 一个对话菜单将显示，让您选择一个现有配置文件，作为一个源文件。 通常将选择默认配置。 在输入新配置文件的名称后，点击复制按钮。

如果您正在用触摸屏工作，您可能会发现最好通过电脑键盘按钮激活一个模拟PC键盘。

取消按钮允许您取消创建过程。

新配置将使用与现有的源配置同样的PCMCIA文件。 如果您想要改变这一点，您将必须修改配置，以便使用不同的PCMCIA文件。 在大多数情况下，您将只需将现有PCMCIA文件复制为一个新文件并使用此新文件。 您可能希望您的新配置使用与您的源配置同样的PCMCIA文件。 在这种情况下，当您点击保存按钮时，一个警告屏幕将显示。

  • 修改配置


修改配置

显示为蓝色的配置被标记为只读，不能修改。 这些配置只能查看。 当然，您可以使用修改方法简单地查看它们的内容，但保存将是不可行的。

通过在四个制表器语言、车辆通讯界面、路径、显示器中选择单独的设置来修改一个配置。 您可以选择所需的制表器或简单地选择点击下一步按钮，其将激活下一个制表器。 在进行修改后，按下保存按钮以保存您的配置。

在需要键盘输入的任何时候，您也可以调用模拟PC键盘的PC应用程序。 这在无键盘可用的触摸屏便携式计算机上尤其方便。


语言

制表器语言允许您选择Tech2Win运行使用的语言。 此选择对PCMCIA映像上Tech2软件内的语言没有影响。 在从TIS下载Tech2软件时，您仍将必须选择正确的语言。

对于某些区域，并非所有语言都是可用的。 在这种情况下，将改为显示英语。 请检查是否提供了一种类似的语言（PT 葡萄牙语-葡萄牙而不是 PB 葡萄牙语-巴西）。


路径

制表器路径允许您选择PCMCIA映像的路径以及通向您的本地软键盘的路径。 此外，提供了按钮复制记忆卡……以复制PCMCIA映像。 如果您刚刚创建了一个新配置，您可能需要使用此按钮，以避免若干配置使用同一PCMICA映像。

Memory Card Options

复制记忆卡……

此按钮允许您将PCMCIA映像复制到另一个文件。 其功能非常类似于为Tech2购买一张新PCMCIA卡。 复制功能仅对目录C:\Users\Public\General Motors\Tech2Win\pcmcia中的文件起作用。

槽0 : 记忆卡图像位置

在这里您可以为插槽0指定包含您的PCMCIA映像的文件。 通常，此类文件应存在于C:\Users\Public\General Motors\Tech2Win\pcmcia中，但也可能存在于其它位置。

槽1 : 记忆卡或ATA

与Tech2一样，Tech2Win也支持两张PCMCIA卡（映像）。 但是，一个配置内的第二个PCMCIA映像通常不是很有用。 第二个软件可能将被用在第二个配置中。

与Tech2上一样，一张ATA卡用于调试目的。 如果得到技术支持部门的指示，请仅激活ATA卡。 他们将为您提供更多信息。

电脑软件键盘位置

此文件的默认值从Windows注册表检索，并且应指向一个能够模拟带鼠标的PC键盘的应用程序。 如果您正在使用的便携式计算机具有一个带此功能的特殊应用程序，您可以在这里指定该应用程序。


车辆通讯界面

  • Tech2-RS232模拟的COM埠口
  • 使用的MDI系列号
  • 规程

Tech2-RS232模拟的COM埠口

请选择一个可用来模拟Tech2的闲置COM端口。 为了您的方便，配制器尝试找出哪些串行端口已被使用并显示它们。

如果您选择一个现有COM端口，Tech2Win就会将自身连接至此现有COM端口。 您可以使用一根零调制解调器电缆，通过此COM端口从运行TIS应用程序的第二台计算机下载Tech2软件。 请注意，由于Windows的限制，使用真实COM端口可能不会以115.200波特可靠地工作。

如果选择了一个不存在的COM端口，Tech2Win将自动创建一个虚拟端口。 此虚拟端口可以用于在同一PC上运行的TIS，以建立与Tech2Win的通信。 在使用虚拟端口时，没有波特率限制。

如果您选择“搜索”作为COM端口，Tech2Win将在范围在9至1内的第一个闲置端口编号上创建一个虚拟COM端口。

使用的MDI系列号

输入MDI的序列号。 该号码可以在MDI的背面找到。 在连字符后面使用该号码。

如果您没有输入一个序列号，Tech2Win将自动显示一个在网络中检测到的MDIs的列表，以让用户选择一个MDI。 当找到指定的MDI时，相同的选择框将显示。

规程

“ISO22900-2 / PDU-API”被选中且J2534-2始终是灰暗的。 将来，Tech2Win可能也能够支持J2534协议。

  • 高级专题: 配置文件
  • 常见问题: 我如何才能确定我应将哪个端口用于Tech2Win？
  • 常见问题: Tech2Win和TIS2Web之间的通信
  • 常见问题: 我如何才能使用不止一个MDI？
  • 常见问题: Tech2Win没有找到我的MDI


显示器

显示器选项卡主要用来更改有关Tech2Win显示的设置：

  • 数字小键盘
  • 颜色
  • 声音
Display and Key Options

数字小键盘

在这里您可以选择是否应显示小键盘。 小键盘被画在Tech2Win屏幕的左侧或右侧。 背景颜色可通过标准颜色对话框来选择。

颜色

Tech2屏幕的背景色和前景色可以在这里单独选择。 这些是两种最常用的颜色组合：

Screen with background 0000FF, foreground FFFFFF | 白色小键盘背景; 蓝色背景; 白色前景
Screen with background 000000, foreground C0C0C0 | 蓝色小键盘背景; 黑色背景; 浅灰色前景

声音

在这里您可以选择关闭声音。 每当Tech2程序将发出嘟嘟声时，都会使用PC扬声器。


保存配置

激活的配置可以通过按下左下角的保存 <配置>按钮来保存。 如果您正在查看一个只读配置，该按钮将不显示。


通过TIS2Web的有效许可证

通常，将Tech2软件下载至Tech2Win将为您提供一个有效许可证。 此外，您可以通过TIS2Web（不是TIS2000）执行一次‘安全进入编程设定（安全）’，从而获得一个有效许可证。 因此前提条件是选择车辆通信接口下的配制器内的虚拟COM端口。

在一次成功的安全访问后，您可以在状态栏右侧看到一把打开的锁。 在括弧内，您会看到许可证的有效天数。 当您再次启动Tech2Win时，只要没有执行车辆通信，安全指示器就不会显示。 在与车辆的首次通信期间，该许可证将被检查并且指示器显示一把打开或闭合的锁。

  • 用Tech2Win工作:安全性
  • 常见问题:我如何才能确定我应将哪个端口用于Tech2Win？
  • 常见问题:Tech2Win和TIS2Web之间的通信
  • 常见问题:有效许可证
  • 常见问题:Tech2Win许可证和安全访问之间的区别是什么？


用Tech2Win工作

在用Tech2Win工作时，大多数技师使用下列主题：

  • 菜单: 屏幕布局和单独的菜单项。
  • 下载一个PCMCIA映像: Tech2Win的诊断软件更新与Tech2使用的方法非常类似。
  • 安全性: 安全措施防止Tech2Win在非授权环境下执行车辆通信。
  • 查看报告: Tech2键盘在Tech2Win中略有改进。 “查看报告”按钮是最突出的示例。
  • 处理PCMCIA影像: 与具有多张用于Tech2的PCMCIA卡类似，您可能具有若干用于Tech2Win的PCMCIA映像。
  • 状态栏: 状态栏通知用户有关状态栏单独部分的信息。
    • 高级专题
    • 常见问题


菜单

Tech2Win应用程序具有下列菜单条目：

  • 文件
  • 选项
  • 窗口
  • 帮助

文件

文件菜单提供了下列可能性：

  • 保存T2屏幕（320x240）用来在您的PC上将尺寸为320x240像素的实际T2屏幕保存为黑白图片。 存储位置和文件格式（BMP、GIF、JPG、PNG）可以自由选择。
  • 打印屏幕在Tech2屏幕的白色BMP映像上创建颠倒的黑色并调用与BMP文件相关的程序。 然后您可以使用此程序打印该映像。
  • 浏览报告文件提供了不使用TIS2Web查看（和打印）报告文件的可能性。
  • 退出关闭Tech2Win。

选项

选项提供了下列选择：

  • 分辨率可用来选择三个标准屏幕尺寸之一。
  • ROM-Write from 0x00003ED76用于内部调试目的。
  • 自动屏幕截图将每个不同Tech2屏幕的一个映像存储在日志目录中。
  • 禁用CANdi并重新启动模拟其本身和车辆之间没有CANdi的Tech2。 对于CANdi打断非标准车辆通信线路的罕见案例来说，这是必要的。

窗口

菜单窗口为您提供了激活Tech2Win数据显示和Tech2Win诊断故障代码显示这两个选项的可能性。 在当前Tech2Win版本中，所有其它选择都是灰暗的。

如果Tech2软件支持Tech2Win数据显示，您可以启用该菜单项。 当进入Data Display时，Tech2Win将显示一个与Tech2 Data Display并列的额外Data Display窗口。 只要Tech2页面显示Data Display，则该菜单项无法启用。 这种情况下，您必须退出Data Display，启动该菜单项，然后重新启动Data Display。

对于Tech2Win数据显示类似的限制同样适用于Tech2Win诊断故障代码显示。 如果Tech2软件支持Tech2Win诊断故障代码显示，您可以启用该菜单项。 另一个DTC Display窗口会和Tech2 DTC Display一起并列出现。 只要Tech2页面显示DTC Display，则该菜单项无法启用。 这种情况下，您必须退出DTC Display，启动该菜单项，然后重新启动DTC Display。

帮助

下列选择是可用的：

  • 帮助主题……调用Tech2Win帮助。
  • 命令行参数显示用于Tech2Win的命令行参数。
  • 关于显示Tech2Win的当前版本号和TIS2Web下载限制。


下载

首先，启动Tech2Win并使其留在主屏幕中。 启动TIS2Web或GlobalTIS，并通过车辆通讯界面选项卡中指定的COM端口执行下载。

使用嵌入式COM端口允许从运行TIS的不同PC下载Tech2软件。 确保使用交叉RS232电缆。 根据运行Tech2Win的PC的硬件，数据传输速度可能需要降低至57.600波特，因为Windows在较高的波特率下可能会丢失数据。

当TIS2Web和Tech2Win在同一PC上运行时，最新的Tech2Win版本也支持快速下载。 通过COM端口的TIS2Web与Tech2Win之间的极少通信仍被执行，但至Tech2Win的耗费时间的数据传送已经被一个内部文件传送所取代。 在这种情况下，下载时间被显著降低至远远低于一分钟。

  • 高级专题: 配置文件
  • 第一步: 车辆通讯界面
  • 常见问题: 我如何才能确定我应将哪个端口用于Tech2Win？
  • 常见问题: Tech2Win和TIS2Web之间的通信


安全性

Tech2Win使用的安全机制依赖于正确的PC时钟值。 请确保您的PC时钟值总是调准的。 Tech2Win将容许可能发生在夏令时期间的较少时钟改变。

在没有有效和激活的许可证的情况下，Tech2Win将不执行任何车辆通信。 状态栏中的下列指示器显示许可证的状态：

  • green smiley 许可证是有效的。
  • 无指示器： 许可证尚未经过检查。
  • red smiley 许可证已经过期。

要获得一个许可证，请使用TIS2Web应用程序执行一次‘安全进入编程设定（安全）’更新。 在大多数情况下，通过TIS2Web的一次‘Software Download (SWDL)}’也将足以获得一个新许可证。 因为许可证将在一定时期（在某些区域：四周）后变得无效，您必须定期执行这种更新。

许可证具有区域/软件特异性。 如果您正在使用具有不同Tech2软件版本的Tech2Win，您的计算机上可能有许可证。

许可证到期前的剩余天数显示在状态栏中。

  • ( 0) 表明许可证已经到期或不存在。
  • (<1) 许可证将在接下来的24小时内到期。
  • (20) 许可证将在20天后到期。

请不要窜改许可证文件。 此文件的欺骗性修改使用内部安全措施检测并且将导致失去该计算机上的所有许可证。 此外，Tech2Win将表现异常。 这只能通过执行一次新安装来解决。

  • 高级专题: 出错信息和退出码
  • 高级专题: 日志文件
  • 用Tech2Win工作: 状态窗口
  • 常见问题: 有效许可证
  • 常见问题: Tech2Win许可证和安全访问之间的区别是什么？
  • 常见问题: 突然停止


查看报告

View Report 此按钮可以用来查看PCMCIA卡上存在的任何PRT文件的内容。 一个对话框将打开，以显示PRT文件的列表。 如果一个程序已经与PRT扩展名联系在一起，将执行此关联程序。 另外，记事本编辑器将打开，以显示选择的文件。

在大多数情况下，PRT文件是一个使用语言单独代码页的ASCII文件。 对于中文、日语、朝鲜语和泰语，该文件采用包含前导字节顺序标记（BOM）的unicode格式。

在查看报告时，Tech2Win用子目录C:\Users\Public\General Motors\Tech2Win\reports运行。 此子目录将仅在您已经查看过报告至少一次时存在。 该目录被自动删除并用作激活PCMCIA卡上的PRT文件的一个临时工作目录。 其将继续包含这些文件，即使Tech2Win停止执行。 如果您想要保存这样一个文件，您将需要将其复制到一个不同的目录，因为一旦其他用户选择查看报告，其可能会被覆盖。


PCMCIA映像

PCMCIA映像通常存在于子目录C:\Users\Public\General Motors\Tech2Win\pcmcia中。 文件的尺寸必须恰好为32Mbyte（33,554,432 字节）或10Mbyte（10,485,760 字节）并具有文件扩展名*.bin。 如果进行了下载或Tech2Win存储了闪存卡上的某些东西，则映像会被修改（与每张常规PCMCIA卡一样）。 可以使用写入保护开关（命令-W0或-W1）或通过删掉‘-W’选项中的‘p’值来禁用修改。(配置文件). 写入保护开关不能通过配制器来访问。 如果您想要使用选项‘-W0’、‘-W1’或‘-W’，您将必须手动修改配置文件。


状态栏

状态栏显示在Tech2屏幕的下面。 下列项目显示在状态栏中：

  1. 一个速度指示器
  2. 车辆通信状态
  3. 串行端口状态
  4. SHIFT键
  5. 自动屏幕截图
  6. 日志警告
  7. 许可证

Status Bar

速度指示器

速度指示器显示模拟Tech2软件所花费的CPU时间。 一个低数值（指示器指向左边）优于一个高数值（指示器指向右边）。 任何绿色指示器都是可接受的。 如果不同的窗口任务突然变为激活状态，指示器可能会短暂地变成黄色。 应避免此类活动。

车辆通信状态

车辆通信状态指示车辆通信接口（MDI）是否存在以及车辆和Tech2Win之间的通信。

串行端口状态

在通过COM端口与Tech2Win通信时，此指示器显示COM端口上的通信是否处于激活状态。

SHIFT键

此指示器显示SHIFT键是否处于激活状态。 您可以使用键盘的‘S’键或小键盘上的SHIFT键来切换它。

自动屏幕截图

‘自动屏幕截图’可以在‘选项’菜单中激活。 每当屏幕改变时，一个新的屏幕截图文件就被存储在日志目录中。 这由状态栏中的红色摄影机的摇柄转动来指示。 ‘自动屏幕截图’一被禁用，该摄影机就会消失。

日志警告

日志状态指示器可能有三个不同的状态。

  • gray log status indicator 日志文件不包含警告或错误。
  • yellow log status indicator 日志文件包含一条警告信息。
  • red log status indicator 日志文件包含一条错误信息。

许可证

许可证指示器可能有三个状态：

  • green smiley 许可证是激活的和有效的。
  • 无指示器： 许可证尚未经过检查。
  • red smiley 许可证已经到期或不存在。
关于更多详细信息，请参阅链接安全性。

状态栏的工具提示

对于某些图标， 显示工具提示以提供一些额外信息：

VCI序列号的工具提示：
Tooltip VCI

TECH2软件版本的工具提示
Tooltip TECH2

Com端口的工具提示
Tooltip Comport

下一个屏幕截图编号的工具提示（如果“自动屏幕截图”处于激活状态）
Tooltip Camera

显示最后一条具有“警告”或更高级别的日志文件条目的工具提示
Tooltip Logfile

许可证确切有效期的工具提示
Tooltip License

如果光标处在一个图标上的时间超过0.5秒而没有被移动，工具提示就会显示。工具提示在5秒后或在光标被移动时消失。

  • 高级专题: 错误信息和错误代码
  • 高级专题: 日志文件


高级专题

这里讨论的主题对于Tech2Win的标准用户来说是无关紧要的。 参与安装、管理和配置Tech2Win的任何人都可能发现下列有用的信息。

  • 重装
  • 卸载
  • 配置文件的直接修改
  • 日志文件
  • 出错信息和退出码
  • ATA卡
  • 注册表条目
  • 文件说明
  • 配置管理的示例


卸载

完整的安装目录，包含用户数据的目录(C:\Users\Public\General Motors\Tech2Win)和包含应用程序数据的目录(C:\ProgramData\General Motors\Tech2Win)被删除。

  • 高级专题: 重装
  • 安装


配置文件

配置文件总是存在于子目录C:\Users\Public\General Motors\Tech2Win\config中并有文件扩展名*.conf。 配置文件的有些选项无法在Tech2Win中改变，所以你可能需要手动编辑配置文件。 配置文件是一个Unicode文件， 该文件的开头有一个字节顺序记号(BOM)。 我们强烈建议你用Unicode兼容的编辑器（例如记事本Notepad）来编辑配置文件。

配置文件是由行组成的。 空行无任何作用。 每一行的开始是一个选项，大多是情况是，选项后会有一个值。 例如default.conf文件。 下表列出了所有选项，供参考。

如果您想要从桌面直接启动某个配制，做一个执行“C:\程序文件\General Motors\Tech2Win\bin\emulator.exe”-OF ..\config\your_configuration_file.conf的快捷方式。 该程序应从下面的工作目录启动：“C:\程序文件\General Motors\Tech2Win\bin”

选项 | 值 / 含义
; 一个注释
@ 一个十进制版本号，格式是： 主版本.次版本。
Tech2Win不接受主版本号不同的配置文件。 Tech2Win可以使用具有更低次版本号的配置文件。
-W0
-W1 		插槽0/1中PCMCIA卡的写保护已经打开。
-B0
-B1 		插槽0/1中PCMCIA卡的区块大小（单位为K字节）。 可接受的值为128 (缺省) 或 256.
-P0
-P1 		该文件包含插槽0/1中PCMCIA卡的二进制文件。 文件的大小必须是 10MB 或 32MB. 环境变量例如%ProgramData%被扩展。
如果该选项没有选中，那么我们认为那个插槽是空的。
-A0
-A1 		该文件包含插槽0/1中PCMCIA卡的属性值。 如果不存在的话，根据卡和区块大小，我们将使用缺省属性值。
-W | Tech2Win退出的时候，所有持续数据都被写入到各自的文件中。 p/f/r/c可被组合使用，分别表示PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | 堆管理功能 可结合值0/r/w/t分别启用“归零、读取检查、写入检查和任务检查 ”。 值l用于在低位地址时执行堆内存分配，因为已执行一个替代分配方式。 通常，此选项仅在开发环境中使用。
-PC | PCMCIA卡副本的先前路径。 此选项当前被忽略。
-MS | 用序列号识别车辆通信接口（MDI）。 如果没有设定，一个可用MDIs的列表将显示给您。
-CT | 文本颜色(前景色)为3字节十六进制值。 缺省值为000000 (白色).
-CB | 背景色为3字节十六进制值。 缺省值为FFFFFF (黑色).
-ATA | 使用此选项启用一张ATA采集卡。 将其删除以禁用ATA采集卡。
-C | Tech2串口通讯所用的串口号(1..9)。 Tech2Win安装了虚拟串口，最常用的为COM9。 如果不存在此选项，从COM9开始向下搜索一个闲置的COM端口。 使用Tech2图标与TIS2Web图标之间的状态栏上的工具提示查看哪个COM端口正在被使用。
-WR | 一个允许写入PCMCIA和FLASH ROM区域的PC地址（通常是253558）。 此功能必需在菜单上另外激活（或使用选项-WA）。 需要用单步调试器调试不可变存储器中的代码。
-WA | 允许单步调试器写入不可变存储器。
-OF | 包含选项/值对的选项文件。
-TP | 定时调整 （比例值）. 默认为5000。 减小此值，使数字执行周期更快地适应真实时间。
-TD | 定时调整 （差值）. 默认为100。 减小此值，以对瞬态定时的改变更快地作出反应。 警告: 窜改TP和TD值可能导致速度问题。
-PJ
-PP 		指定应使用的协议：
PJ用于J2534通信。
ISO22900-2 / PDU-API的PP（默认）
-S | 这个选项将声音输出到计算机的喇叭上。
-L | Tech2Win应用程序的语言。 如果此条目丢失，激活的窗口语言被用作默认语言。 以下的链接为可支持的语言列表： 语言. Tech2模拟窗口本身将显示，无论PCMCIA卡上是什么语言（即被下载到PCMCIA卡的语言）。
-UD | 用户数据目录替代。 在Win7中, 通常在路径 C:\Users\Public\General Motors\Tech2Win 下
-AD | 应用程序数据目录替代。 在Win7中, 通常在路径 C:\ProgramData\General Motors\Tech2Win 下
-US | 使用一个用户专有的信号检测一个以上的Tech2Win使用要求。 该选项将允许每位用户可以在同一台机器（可能是同一个服务器）上同时运行Tech2Win。 在使用该选项时, 您还应当选择选项 -UD 和 -AD。
-SS | 用于规定包括键盘（如果有）在内Tech2Win窗口的总尺寸选项。 第一个参数必须是一个前后有双引号（'）的字符串并且采用选项 / 分辨率菜单中的尺寸名称使用。 第二个参数是包括键盘在内的Tech2Win屏幕的水平像素的总数。 第三个参数是Tech2Win屏幕的垂直像素的总数。 第四个可选参数是像素形式的键盘宽度。
-SH 用于控制屏幕操作的选项。 以下十进制数用于规定哪个屏幕操作是被禁用的。
  • 位0： 无最小/最大。
  • 位1： 在屏幕中无法重新配置。
  • 位2： 无法调整大小。 在这种情况下选项 / 分辨率菜单呈灰色, 不可点击。
  • 位3： 数据显示和DTC窗口与Tech2Win（不带键盘）的尺寸完全相同


记录

每当启动一个Tech2Win配置时，都会在C:\Users\Public\General Motors\Tech2Win\Logs子目录中创建一个HTML格式的新日志文件。 为避免硬盘拥挤，一周前的日志文件被删除。

日志文件根据它们的创建日期（年，月，日）和时间（小时，分钟，秒）自动命名：
yyyy-mm-dd_hhmmss.html

日志文件条目总是采用英文格式，但在Unicode格式中，包含前导字节顺序标记（BOM）。 日志文件中的每一行都具有下列日志级别之一：

日志级别 | 含义
信息 | 仅信息。 不影响程序的执行。
警告 | 已经发生一种罕见的情况。 用户可能不会看到任何不利影响。
ERROR | 出现了一个用户能察觉到的错误。
CRITICAL | 出现了一个将导致程序表现异常的严重错误。
FATAL | 一个致命错误将导致Tech2Win立即停止运行。

所有‘警告’以上的级别都是彩色的，以便可以轻易找到它们。

此外，如果使用了打印屏幕或自动屏幕截图菜单选项，打印和视频文件也将存在于Logs子目录中。
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
自动屏幕截图图片通过HTML文件来链接 - 因此使用HTML日志来查看这些图片的顺序。

在状态栏中，用户被告知是否存在一条警告条目（ yellow lightning bolt ）或一条更严重的日志条目（ red lightning bolt ）。


出错信息和退出码

对话框中可能显示出错信息。 这些对话框仍然允许Tech2Win同时执行Tech2程序。 退出代码是导致Tech2Win异常终止的致命错误。 退出代码可以用在批处理文件文件中，以检测一个程序为何终止。

错误邮件

下列错误邮件可能弹出。 这里是简要的情况说明和解决问题的方法。

Emulator too slow Emulator failed to start

退出代码

退出代码 | 数值 | 含义
OPCODE_ERROR | -7 | 检测到Tech2微处理器（68332）的一个无效命令。 PCMCIA映像可能已经由于某种原因被破坏。
ATA_PROBLEM | -6 | 在ATA模拟期间发生了一个问题。 在得到使用ATA卡的指示后，如果您看到这样的问题，那么请联系帮助台。
DEMO_TIME_IS_UP | -5 | 不应出现在Tech2Win的正式版本中。
DLL_NOT_LOADED | -3 | 其中一个必需的DLL不能载入。 您的Tech2Win副本似乎不完整。 请执行一次新安装和/或选择一种不同的语言。
EXIT_INIT_FAILED | -2 | 初始化失败。 查看日志文件以查明确切原因。 如果一个日志文件不存在，请检查您是否具有所有目录的正确读/写访问权限。
正常 | 0 | Tech2Win已经正常终止。


ATA卡

在软件开发的过程中，Tech2的ATA卡基本上是为调试使用的。 所有必要的ATA数据都存储在子目录C:\Users\Public\General Motors\Tech2Win\ataCapture中。 除非特别注明，这个目录实际上毫不重要，可以删除。

因为目录ataCapture是固定的，对所有的配置，它的内容是相同的。


文件

Tech2Win使用下列文件和目录：

目录 | Vista之前的位置 | 用于Vista及更高版本的位置
安装 | 在安装过程中的确定
用户数据 | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
应用程序数据 | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

文件 | 使用
[用户数据]\atacapture | 包含ATA卡上存在的文件。 除非得到指示，否则这些文件不是必要的。
[安装]\bin | 包含实际的可执行文件和必需的DLLs以及执行所必需的映像。
[安装]\bin\emulator.exe | 执行Tech2代码的主要可执行文件。
[安装]\bin\emulator_xx_XX.dll | 特定语言源DLL。
[安装]\bin\T2Configurator.exe | Tech2Win的配置部分
[安装]\bin\Pictures | 包含Tech2Win需要的图标。
[用户数据]\config | 包含所有配置文件。
[用户数据]\data | 包含在Tech2Win执行期间修改的文件。 这些文件是Tech2Win正确执行所必需的。 通常，您不应动这些文件，除非得到这样做的明确指示。
[应用程序数据]\data | 包含在Tech2Win执行期间修改的文件。 这些文件是Tech2Win正确执行所必需的。 通常，您不应动这些文件，除非得到这样做的明确指示。
[应用程序数据]\data\emulator.sec | 安全性文件 . 不要修改此文件。
[应用程序数据]\data\emulator.card | 卡文件. 包含Tech2Win程序已知的所有PCMCIA卡。 不要修改此文件。
[用户数据]\data\emulator.disp | 此文件保存着Tech2Win屏幕的位置和尺寸。 如果您删除此文件，其将被重新创建，并且Tech2Win屏幕将在左上角出现，尺寸为640x480。
[应用程序数据]\data\emulator.lic | 许可证文件. 包含关于您的许可证有效期的信息。 不要修改此文件。
[应用程序数据]\data\emulator.rtc | 实时时钟文件. 此文件用于存储存在于Tech2的RTC中的数据。
[应用程序数据]\data\emulator.dta | 一个“不要再次告诉我”信息文件。. 此文件存储PCMCIA软件版本，这些版本不应（不再）显示关于不能执行需要回送适配器的自测试的警告。
[应用程序数据]\data\candi.bin | CANdi应用程序文件. 保存着附属于Tech2的CANdi应用程序。
[应用程序数据]\data\eprom.bin | Tech2内部EPROM文件. 包含内部Tech2闪存的目录。
[安装]\driver | 虚拟COM端口驱动程序的安装文件。
[安装]\help\emulator_xx_XX.chm | 特定语言帮助文件。
[用户数据]\Logs | 包含日志文件。 一周前的文件将被自动删除。
[用户数据]\pcmcia | 包含PCMCIA映像文件。 打个比方说，每个文件都相当于一张Tech2 PCMCIA卡。 可以将这些文件随意保存到不同位置。


配置管理

配置文件总是存在于子目录C:\Users\Public\General Motors\Tech2Win\config中并有文件扩展名*.conf。 Tech2Win只可用于生成新配置文件或修改现有的非只读配置文件。 对于所有其它的配置文件管理，请使用Windows Explorer或类似的文件处理程序。 这将是下列活动所必需的：

  • 删除配置文件
  • 重新命名配置文件
  • 更改配置文件的只读属性

我们强烈建议，您务必具有配置文件default.conf。 此文件通常应具有只读属性设置，以避免错误覆盖。 但是，如果您正在更改此文件以满足您的特定需求，您将需要短暂地去掉只读属性。

PCMCIA影像存在于子目录C:\Users\Public\General Motors\Tech2Win\pcmcia中。 这些文件中的每个文件都相当于一张您在用Tech2工作时已经熟悉的PCMCIA卡。 用Tech2Win，您可以有任意数量的映像。 只需将一个现有映像复制到一个新文件名。

如果您想要从桌面直接启动某个配制，做一个执行"C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf"的快捷方式。 该程序应从下面的工作目录启动：'C:\Program Files\General Motors\Tech2Win\bin'

配置文件的数量不取决于您正在使用的pcmcia映像数量。 您可能具有使用同一PCMCIA映像的若干配置文件。 这非常类似于在维修车间中，几位技工共用同一Tech2（和同一PCMCIA卡）的情况。

您也可以选择使每个配置都使用自己的专用PCMCIA映像。 这将使单独配置更加相互独立。 但是，更新每个PCMCIA映像所花费的精力可能是不可接受的。

当您通过复制一个现有配置定义一个新配置时，如果尚未改变PCMCIA影像，配置器将显示一条警告。 在这种情况下，您将具有使用同一PCMCIA影像的两个配置。 如果这正是您所需要的，只需按下确定。 如果您需要使用不同或新PCMCIA影像的新配置，那么点击取消。 然后您可以选择使用复制记忆卡……制作一个新映像

这里是两个您如何管理您的配置和PCMCIA映像的方法示例。

每个用户一个配置

每个用户可以保存一个配置。 配置的名称将是例如用户名。 此概念的优势在于，可以实现个人车辆通信接口（MDIs）、显示和语言设置等用户特定设置。 其缺点是，如果几个用户正在使用同一软件，您将需要复制PCMCIA文件。 当然，用户特定配制可以使用中心PCMCIA文件。

每个Tech2软件一个配置

您可以选择为您下载的每个软件定义一个新配置。 因此，如果需要，更早的软件版本也是立即可用的。 在这种情况下，软件名和版本号经常被选择作为配置名。

  • 第一步: 车辆通讯界面
  • 第一步: 路径
  • 高级专题: 配置文件
  • 安装: 安装步骤


常见问题（FAQ）

  • 我如何才能确定我应将哪个端口用于Tech2Win？
  • Tech2Win和TIS2Web之间的通信
  • 有效许可证
  • 许可证号表示什么？
  • Tech2Win许可证和安全访问之间的区别是什么？
  • 在执行对初始软件的安全访问时，TIS2Web显示了一个非特定错误
  • Tech2Win没有从其它区域执行Tech2软件
  • 我如何才能使用不止一个MDI？
  • 日志文件包含错误“CPU32: Too many 0000/FFFF Commands encountered”
  • 无可见的Tech2窗口
  • SPS不起作用
  • 一些自测试不起作用
  • 速度指示器波动
  • 突然停止
  • 对于软件15.001，瑞典语显示
  • 丢失与MDI的通信
  • Tech2Win没有找到我的MDI
  • 我想要立即启动Tech2Win而不干扰其它配制器
  • 打印功能位于何处？
  • 一个'未使用'的PCMCIA文件夹在我的电脑中
  • 出现了“非法文件路径”消息

我如何才能确定我应将哪个端口用于Tech2Win？

您可以使用Windows的“设备管理器”，查找“端口（COM & LPT）”。 但有些计算机具有未显示在此类别中已安装的内部调制解调器或蓝牙设备。
另一种方法是使用与配制器一起提供的一个小命令。 您可以通过您的开始菜单（Tech2Win文件夹）来执行它，方法是点击“show com ports”。
两种方法均显示您的计算机上已安装的com端口和您不应使用的com端口。

Tech2Win和TIS2Web之间的通信

重要的是，在您启动与TIS2Web的通信以进行安全访问和软件下载前，Tech2Win正在运行。 当启动了Tech2Win时，TIS2Web只能识别虚拟COM端口。

有效许可证

通常，来自TIS2Web的一个‘软件下载（SWDL）’已经为您提供了一个有效许可证。 如果您仍然没有许可证，必须通过TIS2Web（不是TIS2000）进行一次‘安全进入编程设定（安全）’，以获得一个有效许可证。 在通过‘安全进入编程设定（安全）’获得一个许可证前，请不要执行与Tech2Win的任何其它TIS2Web通信，例如‘软件下载（SWDL）’。

许可证号表示什么？

状态栏右侧的许可证号显示完整的许可证天数。 在执行一次下载或安全访问后，立即显示30天的天数。 但是，在重新启动Tech2Win后，显示29，因为许可证有效期可能是大约29天23小时55分钟。 如果许可证天数降至24小时以下，许可证有效期<1显示。 如果许可证已经过期，则显示0。

Tech2Win许可证和安全访问之间的区别是什么？

Tech2Win许可证允许您使用Tech2Win。 要获得这种许可证，您必须定期执行软件下载或安全访问（最常用的间隔：每30天）。 通过TIS2Web执行此类下载的能力通知Tech2Win，存在一个有效用户。 从Tech2得知的安全访问通知Tech2Win，允许某些与安全相关的活动，例如禁用一个安全气囊。 Tech2Win许可证和安全访问均可通过TIS2Web‘安全进入编程设定（安全）’应用程序来执行。 Tech2Win在右侧的状态栏显示剩余的许可证有效期。 很遗憾，Tech2Win不能显示安全访问的有效期，因为Tech2Win只是执行Tech2软件，但不了解Tech2软件本身。

在执行对初始软件的安全访问时，TIS2Web显示了一个非特定错误

其表现与在Tech2上的表现一样。 由于已到期，初始软件不能从TIS2Web获得一个许可证。 但是，这不是真正的问题，因为示范软件不会与需要许可证的车辆通信。 并且因为许可证具有TS2Web下载特异性，在下载Tech2软件后，您无论如何都需要为每次单独的下载获取一个许可证。 初始软件的“许可证”不会使您有权用北美业务或欧宝/沃克斯豪尔软件执行车辆通信。

Tech2Win没有从其它区域执行Tech2软件

您的Tech2Win版本可能仅限于一次或若干次TIS2Web下载（区域）。 按下帮助 / 关于以查看那些限制适用于您的Tech2Win版本。 Tech2Win的早期版本仅允许执行欧宝/沃克斯豪尔软件。 其它GM区域即将跟进。 在任何情况下，Tech2Win当前都能够执行通用汽车的Tech2软件。

我如何才能使用不止一个MDI？

如果您想要将特定的MDIs分配给特定的用户，那么我们建议您让每个用户都具有自己的配置。 显然，这些配置应由它们各自的用户命名。 在每个配置中，您都应在选项卡‘车辆通讯界面’中输入用户特定MDI的序列号。 用户一启动他的配置，Tech2Win就会尝试联系该特定MDI。 只有当该MDI不存在时，一个选择框才会出现，显示Tech2Win能够找到的所有MDIs。

如果您有若干通用MDIs，我们建议您使用选项卡‘车辆通讯界面’中的车辆通信接口序列号被留为空白的配置。 那么用户总是会看到可用MDIs的选择框。

日志文件包含错误“CPU32: Too many 0000/FFFF Commands encountered”

文件‘C:\ProgramData\General Motors\Tech2Win\data\eprom.bin’或当前pcmcia文件有错误。 请执行一次Tech2Win的重新安装并下载一个新Tech2软件。

无可见的Tech2窗口

如果没有可见的Tech2窗口，其可能处于一个当前不在您的显示器上的区域。 在使用不止一个屏幕时，或在修改屏幕分辨率后，您将遇到此类效应。 在启动您的配置时，按下键盘上的Shift键。 在这种情况下，窗口分辨率将被重置为640x480，且Tech2窗口将显示在屏幕左上角。 您也可以删除文件C:\Users\Public\General Motors\Tech2Win\emulator.disp以达到同样的效果。

我们已经看到在关闭所有其它应用程序的窗口后，Tech2窗口根本不会被重画在屏幕上的案例。 在迄今为止我们看到的所有案例中，使用Alt-Tab键在Windows应用程序之间切换能够调出Tech2屏幕。 按下您的PC屏幕底部任务栏中的Tech2Win按钮有时不起作用。 目前，我们仍在调查此问题并希望在以后的Tech2Win版本中修正。

SPS不起作用

是的，我们知道。 我们没有任何计划来改变这一点。 您不应使用Tech2Win来代替Tech2进行SPS。 对于通过TIS的SPS编程，请直接使用MDI。

一些自测试不起作用

Tech2自测试旨在测试Tech2软件的单独部分。 这些测试中的一些测试需要使用回送适配器。 这些测试在Tech2Win中将不起作用，因为回送适配器的功能没有实现（并且没有进行此类测试的计划）。 请在Tech2Win中简单地抑制此类无意义的测试。 如果您执行这些测试，您可能会得到错误的结果，或者Tech2Win可能会像不带回送适配器的Tech2那样挂起。 在这种情况下，使用Ctrl-R重置Tech2Win。

速度指示器波动

状态栏左下方的速度指示器指示在Tech2Win必须再次‘睡眠’前，可以执行多少‘Tech2命令’。 此方法用于确保Tech2Win上的时间符合真实时间：较快的PCs的睡眠多于较慢的PCs。 如果速度指示器波动，那么一些其它应用程序可能正在使用计算能力或PC时钟正在改变。 高波动率对车辆通信和TIS2Web通信有负面影响。 请确保其它应用程序没有运行。

大多数便携式计算机可以自动降低CPU时钟以延长蓄电池时间。 这可能也是Tech2Win检测到的速度波动的原因。 在这种情况下，请不要用蓄电池运行您的便携式计算机，而是使用外部电源。 您也可以尝试改变您的电源设置，以便操作系统不会降低时钟速度。

突然停止

如果您没有在日志文件内部找到程序终止的原因，那么Tech2Win内部安全机制可能已经被激活。 请不要窜改下列文件：emulator.sec、emulator.lic、emulator.card。 如果Tech2Win发现一个安全漏洞，您很可能将不得不执行一次重新安装。

对于软件15.001，瑞典语显示

Tech2Win附带的初始软件是一个示范软件，其存在于每张新PCMCIA卡上。 TIS2Web指示此软件是瑞典语格式的，因为TIS2Web仅显示此示范软件支持的四种语言（英语、法语、德语、瑞典语）列表中的最后一种语言。 使用“更新模式'定制'”而不是'标准'，用最新的诊断软件覆盖演示软件。

丢失与MDI的通信

丢失MDI通信可能有若干原因。

  • 电缆连接不良（以太网和USB）。
  • 无线连接不可靠。
  • PC转入待机状态。

Tech2Win没有找到我的MDI

请检查以下几点：

    1. MDI是否处于激活状态？
    2. MDI管理器是否起作用？
    3. MDI是否正被另一个应用程序使用，例如SPS？
您可以使用其桌面图标或通过“开始/所有程序/General Motors/GM MDI 软件”启动MDI管理器。: 如果第二点不起作用，请致电帮助台。

我想要立即启动Tech2Win而不干扰其它配制器

执行"C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf"。 使用下面的工作目录：“C:\程序文件\General Motors\Tech2Win\bin” 您仍然可以使用配制器对配制进行任何修改。

打印功能位于何处？

Tech2Win不提供直接打印功能。 而是创建临时文件夹并调用与文件扩展名相关的程序。 这些程序可以用于打印目的，允许您调整您的打印输出文件的外观。

Print Report | Print Report

要打印当前的Tech2Win屏幕，使用菜单项文件 / 打印屏幕或显示一个打印机的小键盘按钮。 如果您需要打印若干Tech2Win屏幕，那么可以使用菜单项选项 / 自动屏幕截图，因为它会为每个Tech2Win屏幕创建PNG文件。 这些PNG文件被嵌在日志文件中。

您也可以打印数据显示内容（使用菜单项窗口 / Tech2Win数据显示激活）。 使用打印/HTML 起动按钮启动，然后停止数据采集。 在停止采集后，与HTML相关的可执行文件（通常是Internet Explorer文件）开启，这为您提供了足够的功能来打印您的数据。

Data Display | Data Display

一个'未使用'的PCMCIA文件夹在我的电脑中

以前版本的Tech2Win始终在一个独立目录中有一个PCMCIA文件的复制存储。 该目录通常为 C:\PCMCIA。 现在该目录不再使用, 因为从TIS2Web快速下载不必第二次存储下载文件。 您可以安全地删除该目录。

出现了“非法文件路径”消息

该文件名似乎包含非法字符，如百分比符号(%)。 如果您在安装之后就出现该问题，最好的方法是进行卸载，并重新安装。 大部分情况下，该方法可以解决问题。

在正常安装过程中，环境变量 'Tech2WinUserData'被设置为'PUBLIC'（对于Windows 版本为Vista或以上的情况下）以及 'ALLUSERSPROFILE\Documents' （对于Vista以前的Windows 版本）。 在少数情况下，环境变量在安装过程中并没有设置，但第二次尝试后则可以顺利设置。 您可能会选择手动设置环境变量。 如果您不知道如何设置环境变量，请向您的管理员寻求帮助。


注册表条目

下列注册表条目由安装程序生成。 请不要手动修改这些条目。 在处理注册表条目时，注意标准Windows警告。

注册表项 | 名称 | 类型 | 含义
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | 内部版本号
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 语言 | REG_SZ | 默认语言
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | PCMCIA副本目录的路径
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 根目录 | REG_SZ | 安装路径
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 卸载选项 | REG_DWORD | 卸载设置
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | 配置文件的版本
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | 虚拟COM端口驱动程序的版本
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | 显示名称 | REG_SZ | 添加/删除程序列表内的软件名称
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | 卸载字符串 | REG_SZ | 通向卸载程序的路径


重装

重新安装将删除Tech2Win的全部安装目录，下列目录除外。

  1. 包含配制的config子目录不会被删除。
  2. 在正常情况下包含PCMCIA映像的pcmcia子目录不会被删除。
  3. 可能包含调试信息的ATA子目录不会被删除。
配置文件可能会变得不兼容： 不保证较新的Tech2Win版本可以读出旧Tech2Win版本的配置文件。 原则上，PCMCIA映像不会变得不兼容。

次级PCMCIA目录不受重新安装的影响。

某些环境可能提供较新版本的Tech2Win的自动安装。 因为上次的安装信息存储在注册表中，在重新安装过程中，这些设置将作为默认设置出现。

您可以使用脚本enable reinstallation执行一次Tech2Win的重新安装。 此脚本与Tech2Win安装在一起。 从根本上说，此脚本只是将注册表HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win中存在的键值CurrentVersion设置为数值“1.000”。