Tech2Win Kullanıcı El Kitabı

Tech2Win Kullanıcı El Kitabı'na hoş geldiniz.

Copyright (C) 2010..2016 SPO Engineering General Motors Tüm Hakları Saklıdır

  • Giriş:
  • Lisans:
  • Kurulum:Tech2Win kurulum prosesinin tanımlanması.
    • Kurulum Adımları
    • Araç İletişim Arabirimi
  • İlk Adımlar
    • Bir Yapılandırma Seçimi
      • Klavye
      • Windows'un Kullanılması
    • Yeni Konfigürasyonlar
    • Konfigürasyonları Değiştirme
      • Dil
      • Yol
      • Ekran
      • Bir Konfigürasyonun Saklanması
    • Geçerli bir Tech2Win lisansı alın.
  • Tech2Win ile çalışma: Günlük çalışma ayrıntıları
    • Menü
    • Bir PCMCIA görüntüsü indirme
    • Güvenlik
    • Raporlara Bak
    • PCMCIA görüntülerinin kullanılması
    • Durum Çubuğu
  • Gelişmiş Konular: Normal Tech2Win kullanımı için gerekli olmayan bilgi. Genelde sadece yönetici görevlerine sahip kişileri ilgilendirir.
    • Yeniden Kurulum
    • Kaldırma
    • Konfigürasyon Dosyasının Formatı
    • Günlük Dosyası
    • Hata Mesajları ve Hata Kodları
    • ATA Kartı
    • Kayıt Defteri Girişleri
    • Dosyalar
    • Konfigürasyon Yönetimi
  • SSS


Giriş

Tech2Win bir Windows uygulamasıdır ve bu uygulama ile Tech2 işlevselliği benzetimi yapılabilir. Esasında, Tech2 yazılımı bir PC'de yürütülür. Bu programın çalışması için, PC'niz aşağıdaki teknik gereksinimlere sahip olmalıdır:

  • Bir araç iletişimi arabirimi kurulu olmalı ve PC'ye bağlanmalıdır. Kabul edilebilen arabirimlerin listesi bölgeden bölgeye değişebilir. Çoğu duurmlarda GM'nin Multiple Diagnostic Interface (MDI) arabirimi kullanılabilir.
  • Tech2Win için kurulum esnasında 150Mbayt sabit disk alanı gereklidir. Yönetmek istediğiniz her PCMCIA flash kartı için de ayrıca 32MB gereklidir.
  • Tech2Win uygulamasını çalıştırmadan önce, 100MB boş fiziksel RAM gereklidir. Tüm çalıştırma süresinde uygulamanın RAM içerisinde kalabilmesi için, PC'nizin belleğinin yeterli olması gerekir.
  • PC'nizin hesaplama gücünün 1.2GHz Pentium (tek çekirdekli) değerinde olması gerekir. Paralel olarak başka bir uygulama kullanılmamasını özellikle öneririz.
  • Bir klavyeye gerek yoktur. Tech2Win dokunmatik ekranla da çalıştırılabilir. Dosya adları da girmeniz gerektiğinden, konfigürasyon yönetimi için bir klavye kullanmanızı önemle öneririz.
  • Renkli grafik ekranınızın çözünürlülüğü en az 800 x 600 ve renk derinliği 256 olmalıdır. Klavyesiz olarak 640 x 480 çözünürlük de kabul edilebilir.

Tech2Win kullanıldığında (Tech2 yerine bir dizüstü bilgisayar), lütfen bu dizüstü bilgisayarın gücünün yeterli olmasına dikkat edin. Normal olarak, dizüstü bilgisayarınız Tech2'de olduğu gibi aracın aküsü üzerinden beslenmez.

  • Kurulum
  • İlk Adımlar


Lisans

General Motors - Tech2Win Lisans Anlaşması

Bu programı kullanmadan önce aşağıdaki kayıt ve şartları dikkatle okuyun. Kayıt ve şartları kabulmediğiniz veya anlamadığınız takdirde yerel Satış Sonrası temsilcinizle temasa geçiniz. Bu yazılımı kullanma hakkı General Motors tarafından sadece kullanıcının bu lisansı, Tech2Win kurulumu esnasında bu kayıt ve şartları kabul etmek suretiyle onylaması şartıyla verilir.
General Motors, Tech2Win yazılımını ve içerdiği bilgileri TIS2Web veya GlobalTIS veya TIS2000 ile birlikte kullanma hakkını, münhasıran General Motors Ulusal Satış Şirketleri ile yapılan yerel olarak uygulanabilir Yetkili Tamirci Anlaşmasında belirlenen General Motors yetkili tamirci şebekesi kullanıcılarına vermektedir.
Tech2Win lisansı, Yetkili Onarıcı Anlaşması yürürlükte olduğu ve TIS2Web, GlobalTIS ile TIS2000 lisansı yerinde olduğu sürece geçerlidir. Yetkili Tamirci Anlaşması sonlandırıldığında TIS2Web ve GlobalTIS lisansıyla birlikte Tech2Win lisansı da sonlanır.

Avrupa Birliği Blok Muafiyeti Yönetmeliği (BER) 1400/2002, Madde 4 paragraf 2'de tanımlanan bağımsız tamirciler, General Motors Avrupa'nın GM Europe Info Tech Portal'inde verilen aboneliklerin bir bölümü olarak bir Tech2Win lisansı satın alabilirler.

Tech2Win lisansı araç iletişim arayüzeyini veya PC donanımını kapsamaz.

Tech2Win yazılımı, ilgili General Motors Ulusal Sayış Şirketlerinin yazılı rızası olmadan, yetkili tamirci tesisleri (Yetkili Tamirci Anlaşmasının ilgili ekinde tanımlandığı gibi) dışında bir üçüncü şahıs dağıtılamaz, satılamaz veya çevrim içi verilemez. Bu, hem aktüel hem de aktüel olmayan veriler (ör. süresi dolmuş DVDler) için geçerlidir.

General Motors Ulusal Satış Şirketleri, izinsiz veya kötüye kullanım durumunda, Yetkili Tamirci Anlaşması'na erişimi derhal kapatmaya ve derhal sona erdirildiğini bildirme yetkisine sahip olacaktır.

Verilen bilgiler, modifiye edilmemiş General Motors araçları için servis ve onarım çalışmalarının uzmanca yapılmasına yardımcı olur. Yukarıda bahsi geçen çalışmaların yapılmasının bir ön şartı olarak, bir otomotif teknisyeni eğitimi ve periyodik olarak daha fazla eğitimi gereklidir. Verilen bilgilerde özel aletlerin kullanılmasının gösterildiği yerlerde, bütün tamir işlerinin uzmanca yapılması için bu özel aletlerin kullanılması zorunludur.

General Motors Global TIS'ında yayınlanan bilgiler (metin ve resimler, müzik, grafikler, animasyon, videolar, vs.) ve bunların Global TIS üzerinde düzenlenmesi, telif hakları ile korunmaktadır. Önceden General Motors'nın yazılı rızası alınmadan, çoğaltmaya, neşretmeye, iletişime ve/veya iletime veya başka kullanıma izin verilmeyecektir.

  • Kurulum: Kurulum Adımları
  • İlk Adımlar


Installation

Kurulum

Tech2Win programını kurabilmek için PC üzerinde yönetici yetkilerine sahip olmanız gerekir. Yönetici haklarına sahip değilseniz kurulum çalışmaz. Bu durumda, yerel PC yöneticinizden yardım isteyiniz.

Tech2Win'i başarı ile kullanabilmek için, aşağıdaki iki adımı tamamlamanız gerekmektedir:

  • Tech2Win'in kurulması.
  • Bir Araç İletişim Arabirimi kurulması.
  • Kurulum: Kurulum Adımları
  • İlk Adımlar


Kurulum Adımları

Kurulum yalnızca bir kaç dakika sürer ve açağıdaki kullanıcı girgilerini gerektirir:

  1. Lisans Sözleşmesi
  2. Kurulum Dizini

Dil

Tech2Win UI standart olarak çalışma sisteminizin dilinde görüntülenecektir. Genelde aşağıdaki diller desteklenmektedir. Diliniz desteklenmiyorsa, kurulumcu standart kurulum dili olarak İngilizce başlar.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)İngilizce (İngiliz veya Amerikan İngilizcesi)*
  • el_GR (EL)Greek
  • es_ES (ES)İspanyolca
  • fi_FI (FI)Finnish
  • fr_FR (FR)Fransızca
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portekizce (Brezilya)
  • pt_PT (PT)Portekizce (Portekiz)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Çince (Basitleştirilmiş)
  • zh_TW (ZH)Çince (Geleneksel)

* Tech2Win dili İngiltere İngilizcesidir. Ancak, kullanmakta olduğunuz Tech2 yazılımı ve kurulumcusu, yazılımın kaynağına bağlı olarak, Amerikan İngilizcesi olabilir.

Lisans Sözleşmesi

Lisans Sözleşmesini kabul etmeniz gerekir.

Kurulum Dizini

Tech2Win'i kurmak için istediğiniz herhangi bir dizini seçebilirsiniz. Kurulum dizini ya <sizin program dizininiz>\General Motors\Tech2Win ya da, eğer yeniden kuruyorsanız, daha önce belirlenmiş olan yerdir.

Son olarak, kurulumu onaylayın.

Sanal İlet.(Com) Portu Sürücüsü

Sanal iletişim portu sürücüsü bilgisayarınıza bir kere kurulur ve sürücü sürümü geliştirilinceye kadar (çok nadir olur) veya Tech2Win bilgisayarınızdan kaldırılıncaya kadar orada kalır.
Sürücü kurulursa, kısa bir an için bir DOS kutusu göreceksiniz. Otomatik olarak kapanacaktır ve bir eylem gerektirmez. Sürücü dosyaları, ilaveten, Tech2Win kurulum dizininiz içindeki 'sürücü' alt-dosyasına da yerleştirilir.
Sanal com portu sürücülerinin manüel olarak kurulumu veya kaldırılması mümkündür, ancak tavsiye edilmez. CMD kabuktan aşağıdaki komutlardan birini kullanın:

  • sürücü kurulumu için 'vbsetup7' çağırın
  • sürücü kaldırılması için 'vbsetup7 /u' çağırın
  • İlk Adımlar


Araç İletişim Arabirimi

Araç iletişimi aygıtınız ayrıca kurulmalıdır. Lütfen Araç İletişim Arabirimi ile birlikte gelen ilgili kurulum kılavuzuna bakınız.

  • İlk Adımlar: Araç İletişim Arabirimi
  • Gelişmiş Konular: Konfigürasyon Dosyası
  • Kurulum: Kurulum Adımları
  • SSS: Nasıl birden fazla MDI kullanabilirim?
  • SSS: Tech2Win benim MDI'mi bulamadı


İlk Adımlar

Bu ilk adımlar size Tech2Win'i nasıl kullanacağınızı gösterir. Burada sizin Tech2'yi kullanmayı bildiğiniz varsayılmaktadır. Bu ilk adımlar esnasında araçla işletişime gerek yoktur.

Hızlı Başlangıç için aşağıdaki adımları izleyin:

  1. Masaüstünüzden Hızlı Başlangıç kısa yolunu kullanarak Tech2Win yazılımını çalıştırın.
  2. TIS2Web'ten yeni Tech2 yazılımını indirerek geçerli bir lisans alın.

Seçilebilir bir konfigürasyonun kullanılması:

  1. Masaüstünüzden Tech2Win kısa yolunu kullanarak konfigüratörü başlatın. Kurulumdan sonra varsayılan bir konfigürasyon mevcut olmalıdır.
  2. Yeni bir konfigürasyon yapmak için tercihen standart konfigürasyonu kopyalayın.
  3. Spesifik gereksinimlerinize göre, mevcut bir konfigürasyonu modifiye edin.
  4. Geçerli bir lisans alın.

Tech2Win'i bir uyumluluk modunda başlatmayın. Bu durumda Log dosyasında bir uyarı görünecektir. Tech2Win sadece XP'den bu yana mevcut olan Windows işlevlerini kullanır, daha önceki Wİndows sürümlerinde çalışmayacaktır.

  • İlk Adımlar: Yeni Konfigürasyonlar
  • İlk Adımlar: Konfigürasyonları Değiştirme
  • İlk Adımlar: Araç İletişim Arabirimi
  • Tech2Win ile çalışma: Menü
  • Tech2Win ile çalışma: Güvenlik
  • Tech2Win ile çalışma: Durum Çubuğu
  • Gelişmiş Konular: Konfigürasyon Dosyası


Bir Yapılandırma Seçimi

Tech2Win uygulamasını ilk defa başlattığınızda, aşağıdaki ekran görünür. Tech2Win'i doğrudan varsayılan konfigürasyonla başlatma seçeneği mevcuttur. Bu varsayılan konfigürasyon herhangi bir araç iletişimi seçmeden çalışır.

Start First Time

Ekranda lisans bilgileri iletişim kutusu görünür, fakat varsayılan yapılandırmayı başlatmak için bunu ihmal edebilirsiniz.

Bir dokunmatik ekranla çalışıyorsanız, bir klavye simülasyonu sunan bu uygulama ile harfler girebilmek için, PC klavye programını başlatmanız yararlı olabilir.


Klavye

PC tuşları ve butonları, eğer varsa, benzer Tech2 tuşlarına eşleştirilmiştir. Tech2Win tarafından, orijinal Tech2'de bulunmayan bazı ek tuşlar da sunulmaktadır. Bilgisayarın nümerik tuşlar bloğu her koşulda çalışmayabilir. Herhangi bir sorun oluştuğunda, bilgisayarınızdaki standart klavye düzenin değişip değişmediğini kontrol edin. Böyle bir durumda özellikle SHIFT tuşu hasar görmüş olabilir.

PC Klavyesi | Buton | İşlevsellik
F1 fonksiyon tuşu | yok | Tech2Win yardım
F5 .. F8 fonksiyon tuşları | Sanal tuşlar tarafından tutulan Tech2Win ekran alanını kullanın | Tech2'nin dört yazılım tuşu
Yukarı, Aşağı, Sol, Sağ imleç tuşları |  | Tech2 Yukarı, Aşağı, Sol, Sağ imleç tuşları; Sadece bu tuşlarda otomatik tekrarlama bulunur.
0 .. 9 tuşu | F0 • • • F9 | Tech2 F0 .. F9 tuşları
Geri tuşu | Exit | Tech2 Çıkış tuşu
Enter / Dönüş tuşu | Enter | Tech2 Enter tuşu
Y | Yes | Tech2 Evet tuşu
N | No | Tech2 Hayır tuşu
Q | ? | Tech2 ? tuşu
S | Shift | Tech2 Üst Karakter tuşu. Durum çubuğundaki Shift göstergesi veya Shift düğmesinin üzerindeki gösterge durumu gösterir.
ctrl-P | PWR | Tech2 Güç tuşu; Bu tuş sadece Tech2Win uygulamasını açmak için kullanılır.
ctrl-R | mevcut değil | Tech2Win'i resetler Bir Tech2 üzerindeki Güç Kapat/Aç çevrimine benzer. Fakat, eklenmiş bir Araç iletişim Arabirimi resetlenmez. PCMCIA görüntüsü gibi dosyalar yüklenmez.
Home | Home | Bir home tuşu. Sadece bazı uygulamalar tarafından desteklenir.
veya sadece Dosya menü seçeneği ile kullanılabilir. | Print Screen | Geçici bir BMP dosyası oluşturup BMP dosyalarıyla ilişkili uygulamayı çağırarak, Tech2 ekranının bir ekran görüntüsünü basar. Baskıdan önce imge boyutunu ayarlamak veya çevirmek için bu uygulamayı kullanın.
veya sadece Dosya menü seçeneği ile kullanılabilir. | Save Screen | Tech2 ekran görüntüsünü BMP veya GIF olarak kaydeder.
veya sadece Dosya menü seçeneği ile kullanılabilir. | View Report | Kullanıcının bakabilmesi için, etkin PCMCIA flash kartındaki tüm raporları gösterir


Windows'un Kullanılması

Ana Windows pencerenizin sınır çizgilerini sürükleyerek, standart Windows mekanizmaları ile pencerenizin boyutunu değiştirebilirsiniz. Ayrıca, çeşitli önceden ayarlanmış boyutlar Seçenekler/Çözünürlük menü öğesi tarafından desteklenir. Menü öğesi üzerinden ana pencereyi yeniden boyutlandırırken klavye penceresi otomatik olarak kilitlenir.

Pencerelerin görünümleri, konfigürasyon Ekran sekmesinde değiştirilerek yenilenebilir.


Yeni Konfigürasyonlar

Yeni bir konfigürasyon oluşturmak için Yeni oluştur butonuna tıklatın. Ekrana bir iletişim kutusu gelir ve sizden bir kaynak olarak mevcut konfigürasyon dosyasını seçmenizi ister. Normalde varsayılan konfigürasyon seçilir. Yeni konfigürasyon dosyasının adını girdikten sonra Kopyala butonuna tıklatın.

Bir dokunmatik ekranla çalışıyorsanız, PC klavyesi butonu ile bir PC klavyesi simülasyonu etkinleştirmeyi tercih edebilirsiniz.

İptal butonu ile oluşturma işlemini iptal edebilirsiniz.

Yeni konfigürasyon, mevcut kaynak konfigürasyonla aynı PCMCIA dosyasını kullanacaktır. Bunu değiştirmek isterseniz, farklı bir PCMCIA dosyası kullanılması için konfigürasyonu değiştirmeniz gerekecektir. Pek çok durumda, mevcut PCMCIA dosyasını yeni bir dosyaya kopyalayacak ve bu yeni dosyayı kullanacaksınız. Yeni konfigürasyonunuzun, kaynak konfigürasyonunuzla aynı PCMCIA dosyasını kullanmasını tercih edebiilirsiniz. Bu durumda, Kaydet düğmesine basınca bir uyarı ekranı görünecektir.

  • Konfigürasyonları Değiştirme


Konfigürasyonları Değiştirme

Mavi renkli olarak gösterilen konfigürasyonlar salt okunur konfigürasyonlardır ve değiştirilemezler. Bu konfigürasyonlara sadece bakılabilir. İçeriklerine bakmak için değiştirme yöntemi kullanılabilir, fakat Kaydet ile saklamak mümkün değildir.

Konfigürasyonu değiştirmek için dört Dil, Araç İletişim Arabirimi, Yol, Ekran sekmesindeki değerler teker teker seçilir. İstenen tabülatörü seçebilir veya İleri düğmesini seçebilirsiniz, bu durumda bir sonraki tabülatör etkinleşir. Değişiklikler tamamlandıktan sonra, konfigürasyonu saklamak için Kaydet butonuna basın.

Klavye ile bir değer girmek gerektiğinde, bir PC klavyesi simülasyonu yaparak bir PC uygulaması da seçebilirsiniz. Bu özellikle, klavyesi bulunmayan dokunmatik ekranlı laptoplarda çok kullanışlı bir yöntemdir.


Dil

Dil sekmesi ile Tech2Win'in çalışma dilini seçebilirsiniz. Bu seçim, PCMCIA görüntüsü üzerindeki Tech2Win yazılımının dilini etkilemez. TIS'den Tech2Win yazılımı yüklerken, doğru dili seçmeniz zaten gerekecektir.

Bazı bölgelerde her dili kullanmak mümkün değildir. Bu gibi durumlarda dil olarak İngilizce görünür. (PT Portekizce-Brezilya yerine PB Portekizce-Portekiz) benzer bir dilin kullanılabilir olup olmadığını kontrol ediniz.


Yol

Yol sekmesi ile hem PCMCIA görüntüleri ve hem de yerel yazılım klavyeniz için yol ayarlayabilirsiniz. PCMCIA görüntülerini kopyalamak için ayrıca bir Bellek kartını kopyala butonu da mevcuttur. Yeni bir konfigürasyon oluşturduysanız, bir kaç konfigürasyonun aynı PCMICA imgesini kullanmaması için bu düğmeyi kullanmak isteyebilirsiniz.

Memory Card Options

Bellek kartını kopyala ...

Bu buton ile bir PCMCIA görüntüsünü başka bir dosyaya kopyalayabilirsiniz. İşlevselliği Tech2 için yeni bir PCMCIA kartı satın almaya çok benzer. Kopyalama işlevi sadece C:\Users\Public\General Motors\Tech2Win\pcmcia dizindeki dosyalar için çalışır.

Yuva 0: Bellek kartı görüntüsünün yeri

Burada yuva 0 için PCMCIA görüntünüzü içeren dosyayı belirleyebilirsiniz. Normalde, böyle bir dosya C:\Users\Public\General Motors\Tech2Win\pcmciade kalmalıdır, ancakbaşka yerler de mümkündür.

Yuva 1: Bellek kartı veya ATA

Tech2'de olduğu gibi, Tech2Win de iki PCMCIA kartı (görüntüsü) destekler. Fakat, bir konfigürasyon içerisinde ikinci bir PCMCIA görüntüsü pek yararlı değildir. İkinci konfigürasyonda ikinci bir yazılım kullanılıyor olabilir.

Hata ayıklamak için, Tech2'de de olduğu gibi bir ATA kartı kullanılır. ATA kartını sadece teknik destek tarafından istendiğinde etkinleştirin. Teknik destekten daha ayrıntılı bilgiler alabilirsiniz.

PC yazılım klavyesinin yeri

Bu dosyanın varsayılan değeri Windows kayıt defterinden alınır ve fare ile bir PC klavyesi simüle edebilecek bir uygulamaya işaret etmelidir. Kullanmakta olduğunuz dizüstü bilgisayarınızda bu işleve sahip özel bir uygulama varsa, uygulamayı burada belirleyebilirsiniz.


Araç İletişim Arabirimi

  • Tech2-RS232 emülasyonu için COM portu
  • Kullanılacak MDI'nün seri numarası
  • Protokol

Tech2-RS232 emülasyonu için COM portu

Tech2'ye benzer olarak kullanılabilecek boş bir COM portu seçin. Size kolaylık olması için, hangi seri bağlantı noktalarının zaten kullanılmakta olduğu Configurator tarafından tespit edilir ve ekranda gösterilir.

Mevcut bir COM bağlantı noktası seçildiğinde, Tech2Win kendini mevcut bu COM bağlantı noktasına ekler. Bu COM bağlantı noktasını üzerinde bir TIS uygulaması çalışan ikici bir bilgisayardan bir sıfır modem kablosu kullanarak Tech2 yazılımı indirmek için kullanabilirsiniz. Gerçek bir COM bağlantı noktası kullanılması Windows kısıtlamaları sebebiyle 115.200 baud hızında güvenli olarak çalışmayabilir.

Mevcut olmayan bir COM bağlantı noktası seçildiğinde, Tech2Win otomatik olarak sanal bir bağlantı noktası oluşturur. Bu sanal bağlantı noktası aynı bilgisayarda çalışan bir TIS tarafından Tech2Win ile iletişim sağlamak için kullanılabilir. Sanal bir bağlantı noktası kullanıldığında, baud hızı kısıtlaması yoktur.

COM portu olarak 'ara'yı seçerseniz, Tech2Win 9 ila 1 arasındaki ilk boş port numarası üzerinde bir sanal COM portu oluşturacaktır.

Kullanılacak MDI'nün seri numarası

MDI'nin seri numarasını girin. Numara MDI'nin arka yüzünde bulunur. Kısa çizgiden sonra gelen numarayı kullanın.

Bir seri numarası girilmezse, Tech2Win otomatik olarak ağda tespit ettiği bir MDI'ler listesini gösterir ve kullanıcıdan bir MDI seçmesini ister. Aynı seçim kutusu istenen MDI bulunmadığında da gösterilir.

Protokol

'ISO22900-2 / PDU-API' seçili ve J2534-2 daima gri. Tech2Win gelecekte J2534 protokolünü de destekleyebilir.

  • Gelişmiş Konular: Konfigürasyon Dosyası
  • SSS: Tech2Win için hangi COM bağlantı noktasını kullanacağımı nasıl tespit ederim?
  • SSS: Tech2Win ile TIS2Web arasında iletişim
  • SSS: Nasıl birden fazla MDI kullanabilirim?
  • SSS: Tech2Win benim MDI'mi bulamadı


Ekran

Ekran sekmesi genelde Tech2Win ekranı ile ilgili ayarları değiştirmek için kullanılır:

  • Klavye
  • Renkler
  • Ses
Display and Key Options

Klavye

Klavyenin ekrana getirilip getirilmeyeceğini burada seçebilirsiniz. Klavye Tech2Win ekranının sağında veya solunda bulunur. Fon rengi standart bir renk iletişim kutusu üzerinden seçilebilir.

Renkler

Tech2 ekranının ön ve arka plan renkleri buradan bireysel olarak seçilebilir. En çok kullanılan iki renk kombinasyonu:

Screen with background 0000FF, foreground FFFFFF | Klavye arka planı beyaz; Gri fon; Ön plan beyaz
Screen with background 000000, foreground C0C0C0 | Mavi klavye fonu; Arka plan siyah; Ön plan açık gri

Ses

Burada sesi kapatmayı tercih edebilirsiniz. Her seferinde Tech2 programı bip sesi verdiğinde, PC'nin hoparlörü kullanılır.


Konfigürasyonun Saklanması

Etkin konfigürasyon, sol alt köşedeki Kaydet <konfigürasyon> butonuna basılarak saklanabilir. Salt okunur bir konfigürasyona bakıyorsanız, bu buton görünmez.


TIS2Web üzerinden geçerli lisans

Normalde, Tech2 yazılımının Tech2Win yüklenmesi ile geçerli bir lisans verilir. İlaveten, TIS2Web (TIS2000 değil) üzerinde bir 'Güvenlik Erişimi (Güvenlik)' gerçekleştirerek bir tane edinebilirsiniz. Bunun için, sanal COM bağlantı noktasının Yapılandırıcıda Araç İletişim Arabirimi altında seçilmiş olması gerekir.

Başarılı bir güvenli erişimden sonra, durum çubuğunun sağ tarafında açık bir kilit görünür. Lisansın kaç gün daha geçerli olduğu parantez içerisinde görünür. Tech2Win tekrar başlatıldığında, araçla iletişim devam ettiği sürece ekranda güvenlik göstergesi görünmez. Araçla ilk iletişim esnasında lisansı kontrol edilir ve bu kontrolün sonucuna göre gösterge ya açık ya da kapalı bir kilide dönüşür.

  • Tech2Win ile çalışma:Güvenlik
  • SSS:Tech2Win için hangi COM bağlantı noktasını kullanacağımı nasıl tespit ederim?
  • SSS:Tech2Win ile TIS2Web arasında iletişim
  • SSS:Geçerli lisans
  • SSS:Tech2Win lisansı ile Güvenli Erişim arasındaki fark nedir?


Tech2Win ile çalışma

Tech2Win ile çalışan teknisyenlerin en fazla kullandıkları konular:

  • Menü: Ekran düzeni ve menü öğeleri.
  • Bir PCMCIA görüntüsünün yüklenmesi: Tech2Win arıza teşhis yazılımı için güncelleştirme işlemi Tech2 için kullanılan yönteme çok benzerdir.
  • Güvenlik: Güvenlik önlemleri yetkisiz ortamlarda Tech2Win ile araç iletişimini önlemektedir.
  • Raporlara Bak: Tech2 klavyesi Tech2Win'de bir miktar genişletildi. En önemli örneği 'Raporlara Bak' butonudur.
  • PCMCIA görüntülerinin kullanılması: Tech2'de birden fazla PCMCIA kartı kullanılmasına benzer şekilde, Tech2Win'de de birden fazla PCMCIA görüntüleri kullanılabilir.
  • Durum Çubuğu: Durum çubuğu kullanıcıları durum çubuğunun parçaları hakkında bilgilendirir.
    • Gelişmiş Konular
    • SSS


Menü

Tech2Win uygulamasında bulunan menü girişleri:

  • Dosya
  • Seçenekler
  • Pencereler
  • Yardım

Dosya

Menü Dosya dosyası aşağıdaki olanakları sunar:

  • T2-Ekranı kaydet (320x240) güncel T2 ekranını bilgisayarınıza 320x240 piksel büyüklüğünde siyah-beyaz görüntü dosyası olarak kaydetmek için kullanılır. Kayıt yeri ve dosya biçimi (BMP, GIF, JPG, PNG) isteğe göre seçilebilir.
  • Ekranı Yazdır ile Tech2 ekranının beyaz üzerinde siyah olarak bir ters BMP görüntüsü oluşturulur ve BMP dosyalarına bağlı program seçilir. Bu program daha sonra görüntüyü yazdırmak için kullanılabilir.
  • Rapor Dosyalarına Bak ile rapor dosyaları TIS2Web kullanmadan izlenebilir (ve yazıcı çıktıları alınabilir).
  • Çıkış ile Tech2Win kapatılır.

Seçenekler

Seçenekler ile sunulan seçenekler:

  • Çözünürlük üç standart ekran büyüklüğünden birini seçmek için kullanılır.
  • ROM-Write from 0x00003ED76 dahili hata ayıklama amaçları için kullanılır.
  • Otomatik Ekran Görüntüleri ile günlük dizinine her farklı Tech2 ekranının görüntüsü kaydedilir.
  • CANdi'yi Geçersiz Kıl ve Yeniden Çalıştır araç ile kendisi arasında bir CANdi olmayan bir Tech2 taklidi için. Bu, CANdi'nin standart olmayan araç iletişim hatlarında kesildiği bazı nadir durumlarda gereklidir.

Pencereler

Pencereler menüsü, size Tech2Win Veri Görüntüsü ve Tech2Win DTC Görüntüsü seçimlerini aktive etme olanağını sağlar. Mevcut Tech2Win sürümünde diğer tüm seçimler gri renktedir.

Tech2 yazılımı Tech2Win Veri Görüntüsü destekliyorsa bu menü girişini devreye sokabilirsiniz. Data Display'e girince, Tech2Win Tech2 Data Display'e paralel olan ek bir Veri Görüntüleme penceresi gösterecektir. Tech2 ekranı Veri Görüntüsünü gösterdiği süre boyunca menü girişi sağlanamaz. Böyle bir durumda, Veri Görüntüsünden çıkmalısınız, menü girişini sağlayın ve Veri Görüntüsünü tekrar başlatın.

Tech2Win Veri Görüntüsü için benzer kısıtlamalar, Tech2Win DTC Görüntüsü için de başvurun. Tech2 yazılımı Tech2Win DTC Görüntüsü destekliyorsa bu menü girişini devreye sokabilirsiniz. Tech2 DTC Görüntüsüne paralel olarak bir de DTC Görüntü penceresi görünecektir. Tech2 ekranı DTC Görüntüsünü gösterdiği süre boyunca menü girişi sağlanamaz. Böyle bir durumda, DTC Görüntüsünden çıkmalısınız, menü girişini sağlayın ve DTC Görüntüsünü tekrar başlatın.

Yardım

Kullanılabilir seçimler:

  • Yardım Konuları... ile Tech2Win Yardım seçilir.
  • Komut Satırı Parametresi Tech2Win için kullanılan komut satırı parametrelerini gösterir.
  • İlgi Tech2Win'in mevcut sürüm numarasını ve TIS2Web indirme sınırlamalarını gösterir.


Karşıdan Yükleme

Önce Tech2Win'i başlatın ve ana ekranda bırakın. TIS2Web veya GlobalTIS'i başlatın ve Araç İletişim Arabirimi sekmesinde belirtilen COM bağlantı noktası üzerinden karşıdan yükleyin.

Tümleşik COM portları sayesinde, üzerinde TIS çalışan farklı bir PC'den Tech2 yazılımı yüklemek mümkündür. Çapraz bükümlü bir RS232 kablosu kullandığınızdan emin olun. Windows çok yüksek baud hızlarında veri kaybedebileceği için,üzerinde Tech2Win çalışan PC'nin donanımına bağlı olarak, veri aktarım hızını 57.600 baud'a düşürmek gerekebilir.

En son Tech2Win sürümü, TIS2Web ve Tech2Win aynı bilgisayarda çalışırken, ayrıca hızlı bir indirmeyi de destekler. TIS2Web ile Tech2Win arasında COM portu üzerinden hala minimal bir iletişim sağlanır, ancak çok zaman alan Tech2Win'e veri transferi yerine bir dahili dosya transferi uygulanmıştır. Böyle bir durumda, indirme süresi önemli ölçüde, bir dakikadan az bir süreye indirilmiştir.

  • Gelişmiş Konular: Konfigürasyon Dosyası
  • İlk Adımlar: Araç İletişim Arabirimi
  • SSS: Tech2Win için hangi COM bağlantı noktasını kullanacağımı nasıl tespit ederim?
  • SSS: Tech2Win ile TIS2Web arasında iletişim


Güvenlik

Tech2Win tarafından kullanılan güvenlik mekanizması doğru bir PC saati değerine dayanır. Lütfen bilgisayarınızın saat ayarının daima doğru olduğundan emin olunuz. Tech2Win gün ışığından tasarruf etmek için yapılan saat değişikliklerine tolerans gösterir.

Tech2Win geçerli ve etkin bir lisans olmadan herhangi bir araç iletişimi başlatmaz. Durum çubuğundaki lisans durumunu belirten gösterge:

  • green smiley Lisans geçerli.
  • Gösterge yok: Lisans henüz kontrol edilmedi.
  • red smiley Lisansın süresi geçti.

Lisans almak için lütfen TIS2Web uygulamasını kullanarak bir 'Güvenlik Erişimi (Güvenlik)' güncellemesi yapın. Yeni bir lisans almak için, çoğu durumlarda, Tech2Win üzerinden bir Yazılım Yükleme yeterli olacaktır. Lisans belirli bir süre sonra geçersiz olacağından (bazı bölgelerde: dört hafta), bu güncelleştirmeler düzenli aralıklarla yapılmalıdır.

Lisanslar bölgeye/yazılıma göre değişir. Tech2Win'i farklı Tech2 yazılım versiyonları ile kullanıyorsanız, bilgisayarınızda birden fazla lisans bulunabilir.

Lisansın süresinin dolmasına kaç gün kaldığı durum çubuğunda gösterilir.

  • (0) lisansın sona erdiğini veya artık mevcut olmadığını gösterir.
  • (<1) Lisansın 24 saat içerisinde sona ereceğini gösterir.
  • (20) Lisansın 20 günde sona ereceğini gösterir.

Lütfen lisans dosyası ile oynamayın. Bu dosyada yapılan düzmece değişiklikler dahili güvenlik önlemleri tarafından tespit edilir ve bu bilgisayardaki tüm lisansların iptal edilmesine sebep olur. Ayrıca, Tech2Win beklenmedik davranışlar gösterebilir. Bunun önüne geçmek için yeni bir kurulum gerçekleştirilmelidir.

  • Gelişmiş Konular: Hata Mesajları ve Çıkış Kodları
  • Gelişmiş Konular: Günlük Dosyası
  • Tech2Win ile çalışma: Durum Penceresi
  • SSS: Geçerli lisans
  • SSS: Tech2Win lisansı ile Güvenli Erişim arasındaki fark nedir?
  • SSS: Ani Stop


Raporlara Bak

View Report Bu buton PCMCIA kartı üzerinde mevcut olan PRT dosyalarının içeriklerine bakmak için kullanılır. Açılan bir iletişim kutusunda PRT dosyalarının bir listesi görünür. PRT dosya uzantısına bir program bağlandı ise, bağlı olan bu program yürütülür. Diğer durumlarda ise, seçilen dosyaları göstermek için Notepad editörü açılır.

PRT dosyası çoğu durumlarda bir ACCII dosyasıdır ve dile bağlı kod sayfalarını kullanır. Çince, Japonca, Kore ve Tay dillerinde bu önünde Byte-Order-Mark (BOM) olan unicode bir dosyadır.

Raporlara bakılırken, Tech2Win bir altdizin C:\Users\Public\General Motors\Tech2Win\reports ile çalışır. Bu alt dizin sadece raporlara en az bir defa bakıldığında mevcuttur. Dizin otomatik olarak silinir ve etkin PCMCIA kartı üzerindeki PRT dosyaları için geçici bir çalışma dizini görevini yerine getirir. Tech2Win çalışmaya son verse dahi, içinde bulunan bu dosyalar silinmez. Böyle bir dosyayı saklamak istiyorsanız, farklı bir düzüne kopyalamanız gerekmektedir. Aksi takdirde, başka bir kullanıcı raporlara bakmak istediğinde derhal üzerine yazılır.


PCMCIA Görüntüleri

PCMCIA imgeleri normalde C:\Users\Public\General Motors\Tech2Win\pcmcia altdizinde kalırlar. Bu dosyanın boyutu tam 32Mbayt (33,554,432 bayt) veya 10Mbayt (10,485,760 bayt) ve dosya uzantısı da *.bin olmalıdır. Bir yükleme yapıldığında veya Tech2Win flash kart üzerine herhangi bir şey sakladığında, görüntüler değişir (her normal PCMCIA kartında olduğu gibi). Görüntülerin değişmesi, yazma koruması anahtarı (-W0 veya -W1 komutu) ile ya da 'W' seçeneğindeki 'p' değeri atlanarak önlenebilir.(Konfigürasyon Dosyası). Yazı koruma şalterine konfigüratör vasıtasıyla erişilemez. Opsiyonlar '-W0', '-W1' veya '-W' kullanmak isterseniz, konfigürasyonu elle değiştirmeniz gerekecektir.


Durum Çubuğu

Durum çubuğu Tech2 ekranının altındadır. Durum çubuğunda gösterilen öğeler:

  1. Bir hız göstergesi
  2. Araç İletişiminin Durumu
  3. Seri Portun Durumu
  4. SHIFT tuşu
  5. Otomatik Ekran Görüntüleri
  6. Günlük (Log) Uyarısı
  7. Lisans

Status Bar

Hız Göstergesi

Hız göstergesi Tech2 yazılımının emülasyonu için harcanan CPU süresini belirtir. Küçük bir sayı (gösterge solda) büyük bir sayıdan (gösterge sağda) daha iyidir. Yeşil bir gösterge kabul edilebilir. Birden fazla Windows görevi aniden etkinleştiğinde, gösterge kısa bir süre için sarı olabilir. Bu etkinlikler önlenmelidir.

Araç İletişiminin Durumu

Aracın iletişim durumu ile Araç İletişim Arabiriminin (MDI) mevcut olup olmadığı ve araç ile Tech2Win arasında iletişim olup olmadığı gösterilir.

Seri Portun Durumu

Tech2Win ile COM port üzerinden iletişim kurulduğunda, bu gösterge ile COM portu üzerinden iletişimin etkin olup olmadığı gösterilir.

SHIFT tuşu

Bu gösterge SHIFT tuşunun aktif olup olmadığını gösterir. Klavyedeki 'S' tuşunu veya tuş takımındaki SHIFT tuşunu kullanarak geçiş yapabilirsiniz.

Otomatik Ekran Görüntüleri

Otomatik ekran görüntüleri Seçenekler menüsünde etkinleştirilebilir. Ekran her değiştiğinde, günlük dizinine yeni bir ekran görüntüsü dosyası kaydedilir. Bu, durum çubuğundaki kırmızı kameranın krank kolu döndürülerek gösterilir. Otomatik Ekran Görüntüleri devre dışı bırakıldığında, kamera kaybolur.

Günlük (Log) Uyarısı

Günlük durum göstergesi üç farklı durumda olabilir.

  • gray log status indicator Günlük dosyasında uyarı veya hata yok.
  • yellow log status indicator Günlük dosyasında bir uyarı mesajı var.
  • red log status indicator Günlük dosyasında bir hata mesajı var.

Lisans

Lisans göstergesinin üç farklı durumu mevcuttur:

  • green smiley Lisans etkin ve geçerli.
  • Gösterge yok: Lisans henüz kontrol edilmedi.
  • red smiley Lisans sona erdi veya artık mevcut değil.
Ayrıntılı bilgiler için, lütfen Güvenlik bağlantısına bakınız.

Durum Çubuğu üzerindeki araç ipuçları

Bazı simgeler için, bazı ek bilgi sağlamak için araç ipuçları verilmektedir:

VCI seri numarası için araç ipucu:
Tooltip VCI

Tech2 Versiyonu için araç ipucu
Tooltip TECH2

COM bağlantı yeri için araç ipucu
Tooltip Comport

Bir sonraki ekran görüntüsü için araç ipucu ('Otomatik Ekran Görüntüleri' etkinse)
Tooltip Camera

'Uyarı' veya daha yüksek bir düzeydeki en son günlük dosyasını gösteren araç ipucu
Tooltip Logfile

Tam lisans süresini gösteren araç ipucu
Tooltip License

Araç ipuçları, eğer imleç hareket ettirilmeden bir simge üzerinde 0,5 saniyeden fazla durursa, gösterilir. İmleç hareket ettirildiğinde veya 5 saniye dolduğunda araç ipuçları silinir.

  • Gelişmiş Konular: Hata Mesajları ve Hata Kodları
  • Gelişmiş Konular: Günlük Dosyası


Gelişmiş Konular

Burada tartışılan konular standart bir Tech2Win kullanıcısı için pek önemli değildir. Tech2Win'in kurulumu, yönetimi ve konfigürasyonu ile ilgili kişiler için aşağıdaki bilgiler faydalı olabilir.

  • Yeniden Kurulum
  • Kaldırma
  • Konfigürasyon dosyalarının doğrudan değiştirilmesi
  • Günlük Dosyası
  • Hata Mesajları ve Çıkış Kodları
  • ATA Kartı
  • Kayıt Defteri Girişleri
  • Dosya tanımı
  • Konfigürasyon yönetimi örnekleri


Kaldırma

Komple kurulum dizini, kullanıcı verileri içeren dizin (C:\Users\Public\General Motors\Tech2Win) ve uygulama verileri içeren dizin (C:\ProgramData\General Motors\Tech2Win) silinmiştir.

  • Gelişmiş Konular: Yeniden Kurulum
  • Kurulum


Konfigürasyon Dosyası

Konfigürasyon dosyaları daima C:\Users\Public\General Motors\Tech2Win\config altdizinde kalırlar ve dosya uzantısı *.confdir. Konfigürasyon dosyasının tüm seçeneklerine Tech2Win üzerinden erişilemediğinden, konfigürasyonu elle değiştirmeye karar verebilirsiniz. Konfigürasyon dosyası bir unicode dosyadır ve başında Byte-Order_Mark (BOM) bulunur. Elle herhangi bir değişiklik yaparken Notepad gibi unicode ile çalışabilen bir editör kullanmanızı önemle öneririz.

Konfigürasyon dosyası satıra yöneliktir. Boş satırlar dikkate alınmaz. Bir satır daima bir seçenek ile başlar ve çoğu zaman da arkasından bir değer gelir. Bir örnek için default.conf dosyasına bakınız. Lütfen tüm mevcut seçeneklerin ele alındığı aşağıdaki tabloya bakınız.

Belli bir konfigürasyonu doğrudan masa-üstünden çalıştırmak isterseniz, 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf' uygulayan bir kısayol oluşturun. Program aşağıdaki çalışma dizininden çalıştırılmalıdır: 'C:\Program Files\General Motors\Tech2Win\bin'

seçenek | Değer / Anlamı
; Bir açıklama
@ major.minor formatında bir ondalık versiyon numarası.
Major numaraları Tech2Win'den farklı olan konfigürasyon dosyaları kabul edilmez. Minor numaraları Tech2Win'den düşük olan konfigürasyon dosyaları kabul edilir.
-W0
-W1 		Yuva 0/1'deki PCMCIA kartındaki yazma koruması anahtarı etkin.
-B0
-B1 		Yuva 0/1'deki PCMCIA'nin blok boyu (Kbayt olarak). Kabul edilen değerler 128 (varsayılan) veya 256.
-P0
-P1 		Yuva 0/1 PCMCIA kartının dijital görüntüsünü içeren dosya. Dosyanın boyutu tam 10MB veya 32MB olmalıdır. %ProgramData% gibi Ortam Değişkenleri genişletilmiştir.
Bu seçenek mevcut değilse, yuvanın boş olduğu kabul edilir.
-A0
-A1 		PCMCIA kartının özellik değerlerini içeren kart yuva 0/1'de. Eğer yoksa, karta ve blok boyutuna bağlı varsayılan özellikler kullanılacaktır.
-W | Tech2Win'den çıkarken tüm kalıcı veriler ilgili dosyalarına yazılır. PCMCIA/Flash-ROM/RTC/CANDI-App belirtmek için p/f/r/c değerleri birleştirilebilir.
-H | Bellek Yığını Yönetimi İşlevselliği Sıfırlama, Okuma Denetimi, Yazma Denetimi ve Görev Denetimini sırasıyla etkinleştirmek için 0/r/w/t değerleri bir araya getirilebilir. l değeri, alternatif bir atama şeması uygulandığında alt adreslerde zorla yığın hafızasında ataması yapmak için kullanılır. Normalde bu seçenek sadece geliştirme ortamında kullanılır.
-PC | Daha önce PCMCIA kartı kopyası için yol. Bu opsiyon halen gözardı edilmektedir.
-MS | Araç İletişim Arabirimi (MDI) ile Seri Numarası Tanımı. Ayarlanmamış ise, mevcut MDI'lerin bir listesi görünür.
-CT | 3 onaltılık bayt değerinde metin rengi (ön planda) Varsayılan değer: 000000 (beyaz).
-CB | 3 onaltılık bayt değerinde arka plan rengi Varsayılan değer: FFFFFF (beyaz)
-ATA | Bir ATA kart yakalama için bu seçeneği etkinleştirin. ATA yakalama kartını devre dışı bırakmak için kaldırın
-C | Tech2'nin RS232C iletişim portu olarak COM-portunun numarası (1..9). Tech2Win'e kurulu olan sanal COM portu için genelde COM9 kullanılır. Bu opsiyon mevcut değilse, COM9'dan aşağıya doğru boş bir COM portu için bir arama yapılır. Hangi COM portunun kullanıldığını görmek için, Tech2 ikonu ile TIS2Web ikonu arasındaki durum çubuğu üzerinde tooltip kullanın.
-WR | PCMCIA ve FLASH ROM alanına yazmak için izin verilen bir PC adresi (normalde 253558). Bu işlev, menü üzerinden (veya opsiyon -WA kullanılarak) ayrıca aktive edilmelidir. Kodun TekAdım Hata Ayıklayıcı tarafından değiştirilmeyen bellekte ayıklanması gerekir.
-WA | SingleStep Hata Ayıklayıcının değiştirilemez belleğe yazmasına izin verin.
-OF | Seçenek / değer çiftleri içeren seçenek dosyası.
-TP | Zaman ayarı (Oransal Değer). Varsayılan 5000. Yürütülen çevrim sayısını gerçek zamana daha hızlı uydurabilmek için, bu değeri azaltın.
-TD | Zaman ayarı (Diferansiyel değer). Varsayılan 100. Anlık zamanlama değişmelerine daha çabuk yanıt vermek için bu değeri azaltın. UYARİ: TP ve TD değerleri ile oynamak hız sorunlarına sebep olabilir.
-PJ
-PP 		Kullanılacak olan protokolü belirleyin:
J2534 iletişimi için PJ
ISO22900-2 / PDU-API için PP (varsayılan)
-S | Bu seçeneğin mevcut olması PC'deki bipleyiciden ses çıkışı alınmasını sağlar.
-L | Tech2Win uygulamasının dili. Bu giriş yoksa, standart olarak aktif Windows dili kullanılmıştır. Belirtilebilecek dillerin bir listesi için aşağıdaki bağlantıya bakınız: Diller Tech2 öykünme penceresinde PCMCIA kartı üzerindeki dil gösterilir (örn. PCMCIA kartına yüklenen).
-UD | Kullanıcı veri dizininin geçersiz kılınması. Win7'de bu, normalde C:\Users\Public\General Motors\Tech2Win dedir
-AD | Uygulama veri dizininin geçersiz kılınması. Win7'de bu, normalde C:\ProgramData\General Motors\Tech2Win dedir
-US | Birden fazla Tech2Win anı'nın tespiti için kullanıcıya özel bir semafor kullanın. Bu opsiyon her bir kullanıcının Tech2Win'i paralel olarak aynı makinede, muhtemelen bir sunucuda çalıştırmasını mümkün kılacaktır. Bu opsiyonu kullanırken, aynı zamanda -UD ve -AD opsiyonlarını da belirlemeniz gerekir.
-SS | Klavye (varsa) dahil olmak üzere Tech2Win penceresinin genel boyutlarını belirleme opsiyonu. İlk parametre, çift tırnaklar arasında bir dize olmalıdır ve Seçenekler / Çözünürlük menüsünde boyutun adı olarak kullanılacaktır. İkinci parametre, klavye dahil Tech2Win ekranının yatay piksellerinin toplam sayısıdır. Üçüncü Tech2Win ekranının dikey piksellerinin toplam sayısıdır. Dördüncü opsiyonel parametre klavyenin piksel olarak genişliğidir.
-SH Ekran kullanımını kontrol etme opsiyonu Aşağıdaki ondalık numara, hangi ekran kullanım olasılıklarının geçersiz kılınacağını belirlemek için kullanılır.
  • Bit 0: Min/max mümkün değil.
  • Bit 1: Ekranda tekrar konumlandırma yok.
  • Bit 2: Tekrar boyutlandırma yok. Bu durumda Seçenekler / Çözünürlük menüsü karartılır.
  • Bit 3: Veri Ekranı ve DTC penceresi Tech2Win ile tam olarak aynı boyutta olacaktır (klavyesiz)


Günlük tutma

Tech2Win Konfigürasyonunun her başlatıldığında, C:\Users\Public\General Motors\Tech2Win\Logs alt dizininde HTML formatında yeni bir günlük dosyası oluşturulur. Sabit diskte yığılmayı önlemek için bir haftadan daha eski olan günlük dosyaları silinir.

Günlük dosyalara yaratıldıkları tarihe (yıl, ay, gün) ve saate (saat, dakika, saniye) göre otomatik olarak bir ad verilir:
yyyy-aa-gg_ssddss.html

Günlük dosyaları girişleri sadece İngilizce'dir, fakat önünde bir Byte-Order-Mark (BOM) olarak unicode formatında yazılır. Günlük dosyasındaki her satır aşağıdaki günlük seviyelerinden birindedir.

Günlük Seviyesi | Anlamı
Bilgi | Sadece bilgi için. Programın yürümesini etkilemez.
Uyarı | Normal olmayan bir durum oluştu. Kullanıcı herhangi bir ters etki görmeyebilir.
ERROR | Kullanıcının görebileceği bir hata oluştu.
CRITICAL | Programın anormal davranmasına sebep olan önemli bir hata oluştu.
FATAL | Önemli bir hata Tech2Win'in derhal durmasına sebep olur.

'Uyarı' üzerindeki her düzey, kolayca bulunabilmesi için renkli olarak işaretlenmiştir.

Ayrıca, Ekranı Yazdır ya da Otomatik Ekran Görüntüleri menü seçeneği kullanıldığında, Logs alt dizininde Yazdır ve Video dosyaları da görünür.
yyyy-aa-gg_ssddss_print_nnnnn.bmp
yyyy-aa-gg_ssddss_video_nnnnn.png
Otomatik Ekran Görüntüleri görüntüleri HTML dosyasına bağlıdır - bu görüntülerin sırasına bakmak için HTML günlüğü dosyasını kullanınız.

Bunun bir Uyarı girişi ( yellow lightning bolt) veya daha ciddi bir günlük girişi ( red lightning bolt) olup olmadığı kullanıcıya Durum Çubuğu'nda gösterilir.


Hata Mesajları ve Çıkış Kodları

İletişim kutularında hata mesajları görünebilir. Bu iletişim kutuları Tech2Win'e paralel olarak Tech2 programı çalışmasına izin verir. Çıkış Kodları Tech2Win'i otomatik olarak sonlandıran onulmaz hatalardır. Bir programın neden sonlandığını tespit edebilmek için, çıkış kodları yığın dosyalarında kullanılabilir.

Hata Mesajları

Aşağıdaki hata mesajları açılabilir. Burada durum kısaca açıklanmakta ve sorunun nasıl çözüleceği gösterilmektedir.

Emulator too slow Emulator failed to start

Çıkış Kodları

Çıkış Kodu | Değer | Anlamı
OPCODE_ERROR | -7 | Tech2 mikro işlemcide (68332) geçersiz bir komut tespit edildi. PCMCIA görüntüsü herhangi bir şekilde bozulmuş olabilir.
ATA_PROBLEM | -6 | ATA benzetimi esnasında bir sorun oluştu. ATA kartını kullanma talimatı aldıktan sonra buna benzer bir sorun gördüğünüzde, lütfen yardım masası ile ilişki kurunuz.
DEMO_TIME_IS_UP | -5 | Resmi Tech2Win sürümünde görülmemelidir.
DLL_NOT_LOADED | -3 | Gerekli DLL'lerden biri yüklenemiyor. Tech2Win kopyanızın eksik olduğu anlaşılıyor. Lütfen yeniden kurun ve/veya başka bir dil seçin.
EXIT_INIT_FAILED | -2 | Başlatmada Başarısız Kalındı. Tam sebebini bulmak için günlük (log) dosyasına bakın. Bir günlük dosyası yoksa, tüm dizinlere doğru okuma/yazma erişiminiz olup olmadığını kontrol edin.
normal | 0 | Tech2Win normal olarak sonlandırıldı.


ATA Kartı

ATA kartı Tech2'de genelde sadece yazılım geliştirme aşamasında hata düzeltmede kullanılır. Gerekli bütün ATA verileri C:\Users\Public\General Motors\Tech2Win\ataCapture altdizinde saklanırlar Bu dizin normal durumlarda pek önemli değildir ve aksi belirtilmediği takdirde güvenli olarak silinebilir.

ataCapture dizini sabit olduğundan, içindekiler tüm konfigürasyonlarda aynıdır.


Dosyalar

Tech2Win'de kullanılan dosyalar ve dizinler:

Dizin | Vista öncesi konum | Vista ve ötesi için konum
Kurulum | Kurulum esnasında tanımlandığı gibi
Kullanıcı Verileri | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Uygulama Verileri | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Dosya | Kullanım
[Kullanıcı Verileri]\atacapture | ATA kartında mevcut dosyaları içerir. Başka bir bilgi verilmedi ise, bu dosyalara gerek yoktur.
[Kurulum]\bin | Çalıştırılabilen ve gerekli gerçek DLL dosyalarını ve gerekli görüntüleri içerir.
[Kurulum]\bin\emulator.exe | Tech2 kodu ile ana yürütülebilir çalışma.
[Kurulum]\bin\emulator_xx_XX.dll | Dile özel kaynak DLL'si.
[Kurulum]\bin\T2Configurator.exe | Tech2Win'in konfigürasyon kısmı
[Kurulum]\bin\Pictures | Tech2Win'de gerekli simgeleri içerir.
[Kullanıcı Verileri]\config | Tüm yapılandırma dosyalarını içerir.
[Kullanıcı Verileri]\data | Tech2Win çalışırken değiştirilen dosyaları içerir. Bu dosyalar Tech2Win'in doğru çalışması için gereklidir. Eğer açıkça belirtilmemiş ise, normal durumlarda bu dosyalara dokunmamanız gerekir.
[Uygulama Verileri]\data | Tech2Win çalışırken değiştirilen dosyaları içerir. Bu dosyalar Tech2Win'in doğru çalışması için gereklidir. Eğer açıkça belirtilmemiş ise, normal durumlarda bu dosyalara dokunmamanız gerekir.
[Uygulama Verileri]\data\emulator.sec | Güvenlik dosyası . Bu dosyayı değiştirmeyin.
[Uygulama Verileri]\data\emulator.card | Kart Dosyası. Tech2Win programı tarafından bilinen tüm PCMCIA kartlarını içerir. Bu dosyayı değiştirmeyin.
[Kullanıcı Verileri]\data\emulator.disp | Bu dosyada Tech2Win ekranının yeri ve boyutu bulunur. Bu dosya silindiğinde yeniden yaratılır ve Tech2Win ekranı sol üst köşede 640x480 çözünürlülükle başlar.
[Uygulama Verileri]\data\emulator.lic | Lisans Dosyası. Lisanslarınızın geçerlilik süreleri hakkında bilgiler içerir. Bu dosyayı değiştirmeyin.
[Uygulama Verileri]\data\emulator.rtc | Gerçek Zaman Saati dosyası. Bu dosya, Tech2'nin RTC'sinde bulunan verileri kaydetmek için kullanılır.
[Uygulama Verileri]\data\emulator.dta | Bir 'Bana tekrar söyleme' bilgi dosyası.. Bu dosyada geri döngü bağdaştırıcı gerektiren sınamaları yerine getirememe uyarısı vermesi istenmeyen (artık vermeyen) PCMCIA yazılımı versiyonları saklanır.
[Uygulama Verileri]\data\candi.bin | CANdi uygulama dosyası. Tech2'ye eklenmiş olan CANdi uygulaması bulunur.
[Uygulama Verileri]\data\eprom.bin | Tech2 dahili EPROM dosyası. İçinde dahili Tech2 flash belleğinin içeriği bulunur.
[Kurulum]\driver | Sanal COM bağlantı noktası sürücü için kurulum dosyaları
[Kurulum]\help\emulator_xx_XX.chm | Dile özel yardım dosyaları.
[Kullanıcı Verileri]\Logs | Günlük dosyalarını içerir. Bir haftadan daha eski olan dosyalar otomatik olarak silinir.
[Kullanıcı Verileri]\pcmcia | PCMCIA görüntü dosyalarını içerir. Sembolik olarak bakıldığında, her dosya bir Tech2 PCMCIA kartına eştir. Bu dosyalar istenen herhangi bir yerde saklanabilir.


Konfigürasyon Yönetimi

Konfigürasyon dosyaları daima C:\Users\Public\General Motors\Tech2Win\config altdizinde kalırlar ve dosya uzantısı *.confdir. Tech2Win sadece yeni konfigürasyon dosyaları yaratmak veya salt okunur olmayan mevcut konfigürasyon dosyalarını değiştirmek için kullanılır. Konfigürasyon dosyalarının diğer başka bir şekilde yönetilmesi için, lütfen Windows Explorer veya benzeri bir elleçleme programı kullanınız. Bu durumun gerekli olacağı etkinlikler:

  • konfigürasyon dosyalarının silinmesi
  • konfigürasyon dosyalarının adlarının değiştirilmesi
  • bir konfigürasyon dosyasının salt okunur özelliğinin değiştirilmesi

Daima bir default.conf konfigürasyon dosyası bulundurmanız gerektiğini önemle vurgulamak isteriz. Bu dosya, yanlışlıkla silinmemesi için, salt okunur özellikte olmalıdır. Fakat, size özel gereksinimlerinizi karşılamak için, bu dosyada değişiklik yapmanız gerekiyorsa, salt okunur özelliğini kısa bir süre için kaldırmanız gerekir.

PCMCIA imgeleri C:\Users\Public\General Motors\Tech2Win\pcmcia altdizindedirler. Bu dosyaların her biri, Tech2 ile çalışmanızdan bildiğiniz bir PCMCIA kartına karşılıktır. Tech2Win ile istediğiniz kadar görüntüye sahip olabilirsiniz. Mevcut bir görüntüyü basitçe yeni bir isim dosyasına kopyalayın.

Belli bir konfigürasyonu doğrudan masa-üstünden çalıştırmak isterseniz, "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf" uygulayan bir kısayol oluşturun. Program aşağıdaki çalışma dizininden çalıştırılmalıdır: 'C:\Program Files\General Motors\Tech2Win\bin'

Konfigürasyon dosyası sayısı, kullanmakta olduğunuz pcmcia görüntülerinin adetine bağlı değildir. Aynı PCMCIA görüntüsünü kullanarak birden fazla konfigürasyon dosyasına sahip olabilirsiniz. Bu aşağı yukarı, bir onarım atölyesindeki birden fazla teknisyenin aynı Tech2'yi (ve aynı PCMCIA kartını) kullanmasına benzer.

Her konfigürasyonu size ait PCMCIA görüntüsünü kullanarak yapmayı da seçebilirsiniz. Bu durumda her konfigürasyon diğerine biraz daha bağlı olur. Fakat, her PCMCIA görüntüsünü güncelleştirme zahmeti kabul edilemeyecek kadar fazla olabilir.

Mevcut olanı kopyalayarak yeni bir konfigürasyon yaptığınızda, PCMCIA imgesi değiştirilmediyse, konfigüratör bir uyarı görüntüleyecektir. Bu durumda, aynı PCMCIA imgesini kullanan iki konfigürasyonunuz olacaktır. İstediğiniz buysa, Tamam üzerine basın. Yeni konfigürasyonun farklı veya yeni bir PCMCIA imgesi kullanmasını isterseniz, İptal üzerine basın. Sonra Bellek kartını kopyala ... kullanarak yeni bir imge yapmayı seçebilirsiniz

Konfigürasyonlarınızı ve PCMCIA görüntülerini nasıl yöneteceğiniz burada iki örnek yöntemle açıklanmaktadır.

Her kullanıcı için bir konfigürasyon

Her kullanıcı için bir konfigürasyonu saklayabilirsiniz. Konfigürasyonun adı kullanıcının adı olabilir. Bu tasarımın avantajları kullanıcıya özel araç iletişim arabirimleri (MDI'ler), ekran ve dil ayarları gibi belirli ayarların mümkün olmasıdır. Dezavantajı ise, birden fazla kullanıcı aynı yazılımı kullanıyorsa, PCMCIA dosyalarının kopyalanması gerekir. Kullanıcıya özel konfigürasyonlar, merkezi bir PCMCIA dosyası da kullanabilir.

Her Tech2 yazılımı için bir konfigürasyon

Yüklediğiniz her yazılım için yeni bir konfigürasyon kullanmayı da seçebilirsiniz. Böylece, eski yazılım versiyonları gerektiğinde derhal kullanıma hazırdır. Bu durumda ise, çoğu zaman konfigürasyon adı olarak yazılımın adı ve versiyon numarası seçilir.

  • İlk Adımlar: Araç İletişim Arabirimi
  • İlk Adımlar: Yol
  • Gelişmiş Konular: Konfigürasyon Dosyası
  • Kurulum: Kurulum Adımları


Sık Sorulan Sorular (SSS)

  • Tech2Win için hangi COM bağlantı noktasını kullanacağımı nasıl tespit ederim?
  • Tech2Win ile TIS2Web arasında iletişim
  • Geçerli lisans
  • Lisans numarası neyi gösteriyor?
  • Tech2Win lisansı ile Güvenli Erişim arasındaki fark nedir?
  • TIS2Web Başlangıç Yazılımına güvenlik erişimi yaparken belirlenmemiş bir hata göstermektedir.
  • Tech2Win başka bir alandan Tech2 yazılımı yürütmez
  • Nasıl birden fazla MDI kullanabilirim?
  • Günlük dosyasında 'CPU32: Too many 0000/FFFF Commands encountered' hatası var
  • Tech2 penceresi görünmüyor
  • SPS çalışmıyor
  • Bazı Kendi Kendini Sınamalar çalışmıyor
  • Hız göstergesi değişiyor
  • Ani Stop
  • Yazılım 15.001 için İsveç dili gösteriliyor
  • MDI ile iletişim kesintisi
  • Tech2Win benim MDI'mi bulamadı
  • Konfigüratörle uğraşmadan hemen Tech2Win'i başlatmak istiyorum
  • Basma işlevleri nerede?
  • Bilgisayarımda 'kullanılmayan' bir PCMCIA klasörü var
  • Bir 'yasal olmayan veri yolu' mesajı alıyorum

Tech2Win için hangi COM bağlantı noktasını kullanacağımı nasıl tespit ederim?

Windows'daki 'Aygıt Yöneticisi'nin kullanabilirsiniz, 'Bağlantı Noktaları (COM & LPT)' seçeneğini arayın. Fakat bazı bilgisayarlarda bu kategoride gösterilmeyen dahili modemler veya bluetooth aygıtlar mevcuttur.
Diğer bir yöntem de konfigüratör ile birlikte verilen küçük komut dizisini kullanmaktır. Bu programı başlat menüsü (Tech2Win klasörü) üzerinden 'show com ports' üzerine tıklayarak yürütebilirsiniz.
Her iki yöntem de size, bilgisayarınızda kurulu olan ve KULLANMAMANIZ gereken bağlantı noktalarını gösterir.

Tech2Win ile TIS2Web arasında iletişim

Güvenli erişim veya yazılım yükleyebilmeniz için TIS2Web ile iletişime bağlamadan önce, Tech2Win programının çalışıyor olması önemlidir. TIS2Web sanal COM bağlantı noktasını sadece, eğer Tech2Win başlatıldı ise tanıyabilir.

Geçerli lisans

Normalde TIS2Web'den bir Yazılım İndirme size geçerli bir lisans sağlar. Halen bir lisansınız yoksa, geçerli bir lisans almak için TIS2Web (TIS2000 değil) üzerinden bir 'Güvenlik Erişimi (Güvenlik)' gereklidir. 'Güvenlik Erişimi (Güvenlik)' üzerinden bir lisans almadan önce Tech2Win ile 'Yazılım Yüklemesi (SWDL)' gibi başka bir TIS2Web iletişimi gerçekleştirmeyin.

Lisans numarası neyi gösteriyor?

Durum çubuğunun sağ tarafındaki lisans numarası toplam lisans günlerinin sayısını gösterir. Bir yükleme yapıldıktan veya güvenli erişimden hemen sonra ekranda 30 gün görünür. Fakat Tech2Win yeniden başladığında, lisans süresi 29 gün, 23 saat ve 55 dakika gibi olduğundan, 29 görünüyor. Lisans günü sayısı 24 saatin altına düştüğünde, lisans süresi <1 olarak görünüyor. Lisans süresi geçtiğinde ise, 0 görünür.

Tech2Win lisansı ile Güvenli Erişim arasındaki fark nedir?

Tech2Win lisansı Tech2Win'i kullanmanıza izin verir. Bu lisansı alabilmek için, bir yazılım yükleme işlemi gerçekleştirmeli veya düzenli aralıklarda (genelde 30 günde bir) güvenli erişim yapmalısınız. TIS2Web üzerinden böyle bir yükleme yapabilme yetkisi varsa, Tech2Win'e geçerli bir kullanıcı mevcut olduğu haber verilir. Tech2'den de bilinen Güvenli Erişim, Tech2Win'e, hava yastığının devre dışı bırakılması vb. gibi güvenlikle ilgili işlemlere izin verildiğini haber verir. Hem Tech2Win lisansı ve hem de Güvenli Erişim TIS2Web Güvenli Erişim uygulaması üzerinden gerçekleştirilebilir. Tech2Win kalan lisans süresini sağ taraftaki durum çubuğunda gösterir. Tech2Win sadece Tech2 yazılımını yürüttüğünden ve Tech2 yazılımının içeriğini anlamadığından, maalesef Güvenli Erişim süresini gösteremez.

TIS2Web Başlangıç Yazılımına güvenlik erişimi yaparken belirlenmemiş bir hata göstermektedir.

Davranış bir Tech2'dekiyle aynıdır. Yaşı nedeniyle, Başlangıç Yazılımı TIS2Web'den bir lisans alamıyor. Ancak, gösterici yazılım lisansın gerekli olduğu bir araçla iletişim kurmadığından, gerçek sorun bu değildir. Ve lisanslar TS2Web indirmesine özel olduğundan, Tech2 yazılımı indirdikten sonra her durumda her bir indirme için bir lisans almanız gerekecektir. Başlangıç Yazılımı için bir 'lisans' size bir Kuzey Amerika Operasyonları ya da Opel/Vauxhall yazılımıyla araç iletişimleri yapma hakkı verecektir.

Tech2Win başka bir alandan Tech2 yazılımı yürütmez

Tech2Win versiyonunuz büyük bir ihtimalle bir veya birden fazla TIS2Web indirmesi (bölge) ile sınırlı olabilir. Sizin Tech2Win versiyonunuz için hangi sınırlamalar olduğuna bakmak için Yardım / İlgi üzerine tıklayın. Tech2Win'in eski sürümleri sadece Opel/Vauxhall yazılının uygulanmasına izin vermekteydi. Diğer GM bölgeleri takip edecektir. Her durumda, Tech2Win şimdilik General Motors Tech2 yazılımını yürütebilmektedir.

Nasıl birden fazla MDI kullanabilirim?

Belirli bazı kullanıcılara belirli MDI'ler atamak istiyorsanız, her kullanıcıya kendine ait bir konfigürasyon vermenizi öneririz. Bu konfigürasyonların ilgili kullanıcılara göre adlandırılması gerektiğini unutmayınız. Her konfigürasyonda, kullanıcıya özel MDI'nin seri numarası 'Araç İletişim Arabirimi' sekmesine girilmelidir. Kullanıcı kendi konfigürasyonunu başlatır başlatmaz, Tech2Win bu belirli MDI ile temasa geçmeye çalışır. Sadece bu belirli MDI mevcutsa, bir seçim kutusu açılır ve Tech2Win tarafından bulunabilen tüm MDI'ler gösterilir.

Genel kullanım için birden fazla MDI'niz varsa, 'Araç İletişim Arabirimi' sekmesindeki Araç İletişimi Arabirimi seri numarasının boş bırakıldığı konfigürasyonları kullanmanızı öneririz. Bu sayede kullanıcı daima mevcut MDI'lerin seçim kutusunu görür.

Günlük dosyasında 'CPU32: Too many 0000/FFFF Commands encountered' hatası var

'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' dosyası veya güncel pcmcia dosyası bozuk. Tech2Win'i yeniden kurun ve yeni bir Tech2 yazılımı yükleyin.

Tech2 penceresi görünmüyor

Tech2 penceresi görünmüyorsa, o anda ekranda göremediğiniz bir alanda bulunabilir. Bu etkiler birden fazla ekran kullanıyorsanız veya ekran çözünürlülüğünü değiştirdiğinizde oluşabilir. Yapılandırmaya başlarken klavyedeki Shift tuşuna basın. Bu durumda ekran çözünürlüğü resetlenerek 640x480 olur ve Tech2 penceresi ekranın sol üst köşesinde görünür. Ayrıca aynı etkiyi sağlamak için C:\Users\Public\General Motors\Tech2Win\emulator.disp dosyasını silebilirsiniz.

Diğer uygulamaların pencereleri kapatıldıktan sonra, Tech2 penceresinin yeniden çizilmediği bazı durumlar tespit ettik. Şimdiye kadar gördüğümüz tüm durumlarda, Windows uygulamaları arasında Alt-Tab tuşu ile geçiş yapıldığında Tech2 ekranı da göründü. Bazı durumlarda bu PC ekranınızın alt kısmındaki görev çubuğundaki Tech2Win düğmesine basıldığında da çalışır. Bu sorun şimdilik araştırılıyor ve bu sorunu ilerideki bir Tech2Win versiyonu ile çözebileceğimizi umuyoruz.

SPS çalışmıyor

Evet, biliyoruz. Bunu değiştirmek için bir planımız yok. SPS için Tech2 yerine Tech2Win kullanılmamalıdır. MDI'yı doğrudan SPS programlamasıyla TIS üzerinden kullanın.

Bazı Kendi Kendini Sınamalar çalışmıyor

Tech2 kendini sınama testleri Tech2 donanımı parçalarını test etmek için yapılır. Bu testlerin bazıları geri döngü bağdaştırıcı kullanılmasını gerektirir. Geri döngü bağdaştırıcı işlevselliği eklenmediğinden (ve bunun yapılması da düşünülmüyor) Tech2Win'de bu testler çalışmayacaktır. Lütfen Tech2Win'de bu anlamsız testleri yapmaktan kaçının. Eğer bu testleri yaparsanız, çok hatalı sonuçlar elde edebilirsiniz veya Tech2Win sanki Tech2'de geri döngü bağdaştırıcısı yokmuş gibi kilitlenir. Bu gibi durumlarda Tech2Win'i resetlemek için Ctrl-R kullanın.

Hız göstergesi değişiyor

Durum çubuğunun sol alt tarafındaki hız göstergesi Tech2Win tekrar 'bekleme' konumuna geçmeden kaç 'Tech2 komutu' yerine getirilebileceğini gösterir. Bu yöntem, Tech2Win'in gerçek zamanlı olmasını sağlamak için yapılır: hızlı PC'ler yavaş PC'lerden daha çabuk beklemeye geçerler. Hız göstergesi değişirse, başka bir uygulama PC gücü kullanıyor veya PC saati değişiyor demektir. Yüksek değişme hızları araç iletişimini ve TIS2Web iletişimini olumsuz etkilerler. Başka bir uygulamanın çalışmadığından emin olun.

Bazı dizüstü bilgisayarlar akü ömrünü uzatmak için CPU saatini azaltırlar. Bu da Tech2Win tarafından tespit edilen hız değişimine sebep olabilir. Bu durumda, dizüstü bilgisayarınızı akü ile çalıştırmayın ve harici bir güç kaynağı kullanın. İşletim sisteminin saat hızını değiştirmemesi için bilgisayarın güç ayarlarını değiştirmeyi de deneyebilirsiniz.

Ani Stop

Günlük dosyasında programın sonlandırma sebebini bulamazsanız, Tech2Win dahili güvenlik mekanizması etkinleştirilmiş olabilir. Lütfen emulator.sec, emulator.lic, emulator.card dosyaları ile oynamayınız. Tech2Win bir güvenlik ihlali tespit ettiğinde, büyük bir olasılıkla yeniden kurmanız gerekebilir.

Yazılım 15.001 için İsveç dili gösteriliyor

Tech2Win ile gelen ilk yazılım bir demo versiyonudur ve her yeni PCMCIA kart üzerinde bulunur. TIS2Web bunun İsveç dilinde olduğunu gösteriyor, çünkü TIS2Web sadece bu demo versiyonu tarafından desteklenen dört dilden (İngilizce, Fransızca, Almanca ve İsveççe) en son olanını gösterir. Bu demo yazılımı en yeni diyagnostik yazılım ile değiştirmek için güncelleme modu olarak 'Standart' yerine 'Özel' kullanın.

MDI ile iletişim kesintisi

Bir MID iletişiminin kesilmesinin çeşitli nedenleri olabilir.

  • Kötü kablo bağlantısı (Ethernet ve USB)
  • Kesintili kablosuz bağlantı
  • PC stand-by konumuna geçiyor.

Tech2Win benim MDI'mi bulamadı

Lütfen aşağıdaki noktaları kontrol edin:

    1. MDI etkin mi?
    2. MDI Manager çalışıyor mu?
    3. MDI, SPS gibi başka bir uygulama tarafından kullanılmakta mı?
MDI Manager'i masaüstü simgesini kullanarak ya da'Başlat/Tüm Programlar/General Motors/GM MDI Yazılımı' üzerinden başlatabilirsiniz.: 2. nokta çalışmazsa, lütfen Yardım Masası'na haber veriniz.

Konfigüratörle uğraşmadan hemen Tech2Win'i başlatmak istiyorum

"C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf" uygulayın. Aşağıdaki çalışma dizinini kullanın: 'C:\Program Files\General Motors\Tech2Win\bin' Konfigürasyonda değişiklikler yapmak için hala konfigüratörü kullanabilirsiniz.

Basma işlevleri nerede?

Tech2Win doğrudan baskı işlevselliği sağlamaz. Bunun yerine, geçici dosyalar oluşturur ve dosya uzantılarıyla ilişkili programları çağırır. Bu programlar baskı amacıyla kullanılabilir ve yazılı çıktınızın görüntüsünü ayarlamanıza izin verir.

Print Report | Print Report

Mevcut Tech2Win ekranını basmak için, menü maddesi Dosya / Ekranı Yazdır veya klavyedeki bir yazıcı gösteren düğme kullanılır. Bir kaç Tech2Win ekranı basmanız gerekiyorsa, her bir Tech2Win ekranı için PNG dosyaları oluşturduğundan, menü maddesi Seçenekler / Otomatik Ekran Görüntüleri kullanılabilir. Bu PNG dosyaları günlük dosyasındadırlar.

Ayrıca,veri ekranı içeriklerini de basabilirsiniz(menü maddesi Pencereler / Tech2Win Veri Görüntüsü kullanılarak aktive edilir). Veri toplamayı başlatmak ve sonra durdurmak için Baskı/HTML Start düğmesini kullanın. Toplama durduktan sonra HTML-ilişkili çalıştırılabilir (normalde Internet Explorer) başlatılarak size verilerinizi basmak için bol işlevsellik sağlar.

Data Display | Data Display

Bilgisayarımda 'kullanılmayan' bir PCMCIA klasörü var

Önceki Tech2Win sürümlerinde daima ayrı bir dizinde yinelenen bir PCMCIA dosyaları deposu vardı. Bu dizin genelde C:\PCMCIA idi. Artık bu dizin kullanılmamaktadır zira, TIS2Web'den hızlı indirme indirilenlerin böyle depolanmasına gerek bırakmamaktadır. Bu dizini güvenle silebilirsiniz.

Bir 'yasal olmayan veri yolu' mesajı alıyorum

Dosya adı yüzde işareti (%) gibi yasal olmayan karakterler içeriyor götünmekte. Bu sorunu kurulumdan hemen sonra görüyorsanız, en iyisi kurulumu kaldırmak ve yeniden kurulum yapmaktır. Bir çok vaka bu yöntem kullanılarak düzeltilebilir.

Normal kurulumlar esnasında, ortam değişkeni 'Tech2WinUserData', 'PUBLIC'ye (Windows sürümleri >= Vista için) ve 'ALLUSERSPROFILE\Documents'ye (Vista öncesi Windows sürümleri için) ayarlanır. Bzı ender durumlarda, ortam değişkeni kurulum prosesi esnasında ayarlanmamış, ancak ikinci denemede iyi çalışmıştır. Siz de ortam değişkenini manüel olarak ayarlamayı seçebilirsiniz. Bie ortam değişkeninni nasıl ayarlanacağını bilmiyorsanız idarecinizin yardımını isteyin.


Kayıt Defteri Girişleri

Yükleyici tarafından yaratılan kayıt defteri girişleri: Lütfen bu girişleri elle değiştirmeyin. Kayıt defteri girişleri ile çalışırken standart Windows uyarılarına dikkat edin.

kayıt defteri tuşu | isim | tip | anlamı
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Dahili versiyon numarası
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Dil | REG_SZ | kurulu olan dil
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | PCMCIA kopyalama dizinlerinin yolu
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Kök | REG_SZ | kurulum yolu
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | KaldırSeçeneği | REG_DWORD | Kaldırma Ayarı
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Yapılandırma dosyasının versiyonu
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Sanal COM Bağlantı Noktası Sürücü
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | EkrandakiAd | REG_SZ | Yazılımın program ekle/kaldır listesindeki adı
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Program kaldırma yolu


Yeniden Kurulum

Tekrar kurulum komple Tech2Win dizinini aşağıdakiler dışında silecektir.

  1. konfigürasyonları içeren config alt-dizini silinmez.
  2. Normalde PCMCIA imgelerini içeren pcmcia alt-dizini silinmez.
  3. Hata ayıklama bilgileri içerebilen ATA alt-dizini silinmez.
Konfigürasyon dosyaları uyumsuz olabilir: eski Tech2Win sürümünün konfigürasyon dosyalarının yeni bir Tech2Win sürümü tarafından okunabileceği garanti edilemez. Prensip olarak PCMCIA görüntülerinin uyumsuzlaşmaları mümkün değildir.

Yeniden kurulum ikincil PCMCIA dizinini etkilemez.

Bazı ortamlar yeni bir Tech2Win sürümünün otomatik olarak kurulmasını önerebilirler. Son kurulum bilgileri kayıt defterine kaydedildiğinden, bu ayarlar yeniden kurma esnasında varsayılan değerler olarak sunulur.

Küçük enable reinstallation programını kullanarak yeniden bir Tech2Win kurulumu gerçekleştirebilirsiniz. Bu küçük program Tech2Win ile birlikte kurulur. Bu program aslında HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win adresinde bulunan kayıttaki CurrentVersion anahtarının değerini '1.000' yapar.