คู่มือผู้ใช้ Tech2Win

ยินดีต้อนรับสู่คู่มือผู้ใช้ของ Tech2Win

Copyright (C) 2010..2016 SPO Engineering General Motors สงวนลิขสิทธิ์

  • บทนำ:
  • ใบอนุญาตให้ใช้งาน:
  • การติดตั้ง:คำอธิบายกระบวนการติดตั้งของ Tech2Win
    • ขั้นตอนการติดตั้ง
    • อินเตอร์เฟซการสื่อสารกับรถ
  • ขั้นตอนแรก
    • การเลือกการกำหนดค่า
      • แป้นพิมพ์
      • การจัดการของ Windows
    • สร้างการกำหนดค่า
    • การแก้ไขการกำหนดค่า
      • ภาษา
      • เส้นทาง
      • การแสดงผล
      • การบันทึกการกำหนดค่า
    • รับใบอนุญาตให้ใช้งาน Tech2Win ที่ใช้ได้
  • การทำงานโดยใช้ Tech2Win: รายละเอียดสำหรับการทำงานในแต่ละวัน
    • เมนู
    • การดาวน์โหลดรูป PCMCIA
    • ความปลอดภัย
    • ดูรายงาน
    • การจัดการรูป PCMCIA
    • แถบสถานะ
  • หัวข้อเชิงลึก: ข้อมูลที่ไม่จำเป็นสำหรับการใช้งาน Tech2Win ตามปกติ มักเป็นที่สนใจของผู้ที่มีหน้าที่ดูแลระบบเท่านั้น
    • การติดตั้งอีกครั้ง
    • การถอนการติดตั้ง
    • รูปแบบของแฟ้มการกำหนดค่า
    • แฟ้มบันทึก
    • ข้อความแจ้งข้อผิดพลาดและรหัสข้อผิดพลาด
    • การ์ด ATA
    • รายการรีจิสทรี
    • แฟ้ม
    • การจัดการการกำหนดค่า
  • คำถามที่ถามบ่อย


บทนำ

Tech2Win เป็นโปรแกรมประยุกต์ของ Windows ซึ่งสามารถจำลองระบบการทำงานของ Tech2 ได้ โดยพื้นฐานแล้ว ซอฟต์แวร์ Tech2 จะทำงานในเครื่องคอมพิวเตอร์ส่วนบุคคล ในการเรียกใช้โปรแกรมนี้ เครื่องคอมพิวเตอร์ส่วนบุคคลของคุณจำเป็นต้องตรงตามข้อกำหนดทางเทคนิคต่อไปนี้:

  • ต้องมีการติดตั้งอินเตอร์เฟซการสื่อสารกับรถและเชื่อมต่อกับเครื่องคอมพิวเตอร์ส่วนบุคคล รายการของอินเตอร์เฟซที่ยอมรับได้อาจแตกต่างกันไปในแต่ละภูมิภาค ในกรณีส่วนมาก สามารถใช้อินเตอร์เฟซการวินิจฉัยหลายทาง (MDI) ของ GMs ได้
  • โปรแกรมประยุกต์ Tech2Win จำเป็นต้องใช้เนื้อที่ของฮาร์ดดิสก์ 150 เมกกะไบต์ ในระหว่างการติดตั้ง จำเป็นต้องใช้เนื้อที่เพิ่มเติมอีก 32 เมกะไบต์ ต่อการ์ดหน่วยความจำ PCMCIA ที่คุณต้องการจัดการ
  • ก่อนที่จะเรียกใช้งานโปรแกรมประยุกต์ Tech2Win คุณจำเป็นต้องมี RAM ว่างอยู่อย่างน้อย 100 เมกะไบต์ ข้อบังคับขั้นต้นคือเครื่องคอมพิวเตอร์ส่วนบุคคลของคุณจะต้องมีหน่วยความจำเพียงพอต่อการจัดการโปรแกรมประยุกต์ภายใน RAM ตลอดเวลาที่เรียกใช้งาน
  • เครื่องคอมพิวเตอร์ส่วนบุคคลของคุณควรมีกำลังในการประมวลผลเทียบเท่า Pentium (แกนเดียว) 1.2GHz เราแนะนำเป็นอย่างยิ่งว่าคุณต้องไม่ใช้โปรแกรมประยุกต์อื่นใดควบคู่กัน
  • ไม่จำเป็นต้องใช้แป้นพิมพ์ สามารถใช้งาน Tech2Win ผ่านทางหน้าจอสัมผัสได้เช่นกัน สำหรับการจัดการการกำหนดค่า เราแนะนำเป็นอย่างยิ่งให้คุณใช้แป้นพิมพ์ เนื่องจากคุณจำเป็นต้องป้อนชื่อแฟ้ม
  • หน้าจอกราฟิกสีของคุณต้องมีค่าความละเอียดอย่างน้อย 800 x 600 โดยมีความละเอียดของสีขั้นต่ำเป็น 256 ไม่มีแผงปุ่มกด ค่าความละเอียด 640 x 480 อาจเป็นที่ยอมรับได้

เมื่อใช้ Tech2Win (ใช้แล็ปท็อปแทน Tech2) โปรดให้แน่ใจว่าแล็ปท็อปมีกำลังเพียงพอ ตามปกติ แล็ปท็อปของคุณจะไม่สามารถใช้ไฟฟ้าจากแบตเตอรี่ของรถได้อย่าง Tech2

  • การติดตั้ง
  • ขั้นตอนแรก


ใบอนุญาตให้ใช้งาน

General Motors - Tech2Win License Agreement (ข้อตกลงลิขสิทธิ์ของ Tech2Win)

โปรดอ่านข้อสัญญาและเงื่อนไขต่อไปนี้ก่อนใช้โปรแกรมนี้ หากท่านไม่ยอมรับหรือเข้าใจข้อสัญญาหรือเงื่อนไขต่างๆ โปรดติดต่อตัวแทนหลังการขายประจำท้องถิ่นของท่าน สิทธิในการใช้ซอฟต์แวร์นี้ได้รับลิขสิทธิ์จาก General Motors โดยมีเงื่อนไขเฉพาะคือผู้ใช้ต้องตกลงยอมรับลิขสิทธิ์นี้โดยยอมรับข้อสัญญาและเงื่อนไขต่างๆ เหล่านี้ในระหว่างการติดตั้ง Tech2Win
General Motors ให้สิทธิในการใช้ซอฟต์แวร์ Tech2Win และข้อมูลที่แนบมาร่วมกับ TIS2Web หรือ GlobalTIS หรือ TIS2000 สำหรับผู้ใช้ของเครือข่ายช่างซ่อมที่ได้รับการอนุญาตของ General Motors ตามที่ได้กำหนดไว้ในข้อตกลงช่างซ่อมที่ได้รับการอนุญาต (Authorized Repairer Agreement) ระดับท้องถิ่นที่ใช้กับบริษัทจำหน่ายในประเทศของ General Motors
สิทธิ์ในการใช้งาน Tech2Win จะมีผลตราบเท่าที่ข้อตกลงช่างซ่อมที่ได้รับการอนุญาต (Authorized Repairer Agreement) มีผลบังคับและสิทธิ์ในการใช้งาน TIS2Web, GlobalTIS และ TIS2000 ที่เหมาะสม ใบอนุญาตให้ใช้งาน Tech2Win จะสิ้นสุดลงพร้อมกับใบอนุญาตให้ใช้งาน TIS2Web และ GlobalTIS ทันทีเมื่อข้อตกลงผู้ซ่อมแซมที่ได้รับอนุญาตถูกทำให้สิ้นสุดลง

ช่างซ่อมอิสระตามที่กำหนดไว้ในบทความ 4 ย่อหน้า 2 ของข้อกำหนด European Union Block Exemption Regulation (BER) 1400/2002 อาจสั่งซื้อสิทธิ์ในการใช้งาน Tech2Win ในฐานะส่วนหนึ่งของการสมัครที่เสนอซึ่งมีใว้ใน GM Europe Info Tech Portal ของ General Motors Europe

การอนุญาตให้ใช้งาน Tech2Win ไม่ครอบคลุมอินเตอร์เฟสการสื่อสารของรถหรือฮาร์ดแวร์คอมพิวเตอร์

ห้ามเผยแพร่ จำหน่ายหรือเผยแพร่ซอฟต์แวร์ Tech2Win ออน์ไลน์แก่ฝ่ายที่สามนอกเหนือจากขอบเขตของข้อตกลงช่างซ่อมที่ได้รับการอนุมัติ (ตามที่อธิบายไว้ในข้อแนบท้ายที่เกี่ยวข้องของข้อตกลงช่องซ่อมที่ได้รับการอนุมัติ) หากไม่ได้รับอนุมัติเป็นลายลักษณ์อักษรจากบริษัทจำหน่ายในประเทศของ General Motors ที่เกี่ยวข้อง ซึ่งจะใช้กับทั้งข้อมูลปัจจุบันและข้อมูลที่ไม่ใช้แล้ว (เช่น DVD ที่หมดอายุแล้ว)

บริษัทจำหน่ายในประเทศของ General Motors มีสิทธิ์ที่จะปิดการเข้าถึงโดยทันที รวมทั้งประกาศการสิ้นสุดโดยทันทีของข้อตกลงช่างซ่อมที่ได้รับการอนุมัติในกรณีที่มีการใช้งานโดยไม่ได้รับอนุมัติหรือใช้ในทางที่ผิด ในกรณีนี้ สิทธิในการอ้างการชดใช้ของยอดเงินเชื่อและ/หรือค่าธรรมเนียมพื้นฐานรายปีจะถูกละเว้น

ข้อมูลที่มีให้จะใช้สำหรับงานบริการและงานซ่อมแซมด้วยวิธีการอย่างผู้เชี่ยวชาญสำหรับรถ General Motors ที่ไม่ได้ถูกดัดแปลงแก้ไขใดๆ การอบรมช่างเทคนิครถยนต์ที่สมบูรณ์และการอบรมเพิ่มเติมต่อจากนั้นถือเป็นเงื่อนไขเบื้องต้นของการทำงานที่กล่าวไว้ก่อนหน้านี้ หากมีการระบุการใช้เครื่องมือพิเศษในข้อมูลที่จัดไว้ให้ เครื่องมือพิเศษดังกล่าวจะเป็นคำสั่งสำหรับการซ่อมแซมทั้งหมดจึงจะถือว่าเป็นวิธีการอย่างผู้เชี่ยวชาญ

ข้อมูลที่เผยแพร่บน Global TIS ของ General Motors (ข้อความและรูปภาพ เสียงดนตรี กราฟิกส์ ภาพเคลื่อนไหว วีดีโอ ฯลฯ ) และการจัดการในข้อนั้นของ Global TIS มีการสงวนลิขสิทธิ์ตามกฎหมาย ห้ามทำการคัดลอก เผยแพร่ แถลงและ/หรือถ่ายทอดหรือการใช้งานอื่นๆ นอกจากจะได้รับอนุมัติเป็นลายลักษณ์อักษรจาก General Motors ก่อน

  • การติดตั้ง: ขั้นตอนการติดตั้ง
  • ขั้นตอนแรก


Installation

การติดตั้ง

การติดตั้ง Tech2Win จำเป็นต้องใช้สิทธิ์ระดับผู้ดูแลระบบในเครื่องคอมพิวเตอร์ส่วนบุคคล การติดตั้งจะดำเนินการไม่ได้ ถ้าไม่มีสิทธิ์ระดับผู้ดูแลระบบ ในกรณีดังกล่าว โปรดติดต่อผู้ดูแลระบบของเครื่องคอมพิวเตอร์ส่วนบุคคลของคุณเพื่อขอความช่วยเหลือ

เพื่อใช้งาน Tech2Win ให้สำเร็จ คุณต้องปฏิบัติตามสองขั้นตอนต่อไปนี้:

  • การติดตั้ง Tech2Win ด้วยตัวมันเอง
  • การติดตั้งอินเตอร์เฟซการสื่อสารกับรถ
  • การติดตั้ง: ขั้นตอนการติดตั้ง
  • ขั้นตอนแรก


ขั้นตอนการติดตั้ง

การติดตั้งจะใช้เวลาไม่กี่นาทีและต้องใช้อินพุทต่อไปนี้:

  1. ข้อตกลงใบอนุญาตให้ใช้งาน
  2. ไดเรกทอรีในการติดตั้ง

ภาษา

ตามค่าเริ่มต้น Tech2Win UI จะถูกแสดงผลในภาษาของระบบปฏิบัติการของคุณ โดยทั่วไป จะรองรับภาษาต่อไปนี้ หากตัวติดตั้งไม่รองรับภาษาของคุณ ตัวติดตั้งจะเริ่มทำงานด้วยภาษาอังกฤษเป็นภาษาในการติดตั้งเริ่มต้น

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)อังกฤษ (แบบอังกฤษหรือแบบอเมริกัน)*
  • el_GR (EL)Greek
  • es_ES (ES)สเปน
  • fi_FI (FI)Finnish
  • fr_FR (FR)ฝรั่งเศส
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)โปรตุเกส (บราซิล)
  • pt_PT (PT)โปรตุเกส (โปรตุเกส)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)จีน (ประยุกต์)
  • zh_TW (ZH)จีน (ดั้งเดิม)

* ภาษาใน Tech2Win เป็นภาษาอังกฤษแบบอังกฤษ อย่างไรก็ตาม ซอฟต์แวร์ Tech2 และตัวติดตั้งที่คุณกำลังใช้งานอาจเป็นภาษาอังกฤษแบบอเมริกัน ทั้งนี้ขึ้นกับต้นฉบับของซอฟต์แวร์

ข้อตกลงใบอนุญาตให้ใช้งาน

คุณต้องยอมรับข้อตกลงใบอนุญาตให้ใช้งาน

ไดเรกทอรีในการติดตั้ง

คุณสามารถเลือกไดเรกทอรีใดเป็นตำแหน่งที่จะใช้ในการติดตั้ง Tech2Win ก็ได้ ไดเรกทอรีในการติดตั้งเริ่มต้น อาจเป็น <ไดเรกทอรีโปรแกรมของคุณ>\General Motors\Tech2Win หรือ ในกรณีที่ติดตั้งอีกครั้ง ก็กำหนดไปยังตำแหน่งเดิมที่กำหนดไว้ก่อนหน้านี้

ในขณะที่ส่วนสุดท้ายเป็นการยืนยันการติดตั้ง

โปรแกรมควบคุมพอร์ต COM เสมือน

โปรแกรมควบคุมพอร์ต COM เสมือนจะถูกติดตั้งลงในเครื่องคอมพิวเตอร์ของคุณเพียงครั้งเดียวเท่านั้น และจะอยู่ไปจนกว่าจะมีการอัพเกรดโปรแกรมควบคุมใหม่ (เกิดขึ้นได้ยาก) หรือมีการถอนการติดตั้ง Tech2Win ออกจากคอมพิวเตอร์คุณ
หากโปรแกรมควบคุมได้รับการติดตั้งแล้ว คุณจะเห็นหน้าต่าง DOS ชั่วขณะ ซึ่งจะปิดลงโดยอัตโนมัติและไม่จำเป็นต้องดำเนินการใดๆ แฟ้มโปรแกรมควบคุมถูกวางเพิ่มเติมลงในโฟลเดอร์ย่อย 'driver' ในไดเรกทอรีติดตั้ง Tech2Win
สามารถทำการติดตั้งหรือถอนการติดตั้งโปรแกรมควบคุมพอร์ต COM เสมือนด้วยตนเองได้ แต่ไม่แนะนำให้ทำ ใช้หนึ่งในคำสั่งต่อไปนี้จากเชลล์ CMD

  • เรียกใช้ 'vbsetup7' เพื่อติดตั้งโปรแกรมควบคุม
  • เรียกใช้ 'vbsetup7 /u' เพื่อถอนการติดตั้งโปรแกรมควบคุม
  • ขั้นตอนแรก


อินเตอร์เฟซการสื่อสารกับรถ

ต้องติดตั้งอุปกรณ์สื่อสารกับรถของคุณแยกต่างหาก โปรดดูคู่มือการติดตั้งที่เกี่ยวข้อง ซึ่งให้มาพร้อมกับอินเตอร์เฟซการสื่อสารกับรถ

  • ขั้นตอนแรก: อินเตอร์เฟซการสื่อสารกับรถ
  • หัวข้อเชิงลึก: แฟ้มการกำหนดค่า
  • การติดตั้ง: ขั้นตอนการติดตั้ง
  • คำถามที่ถามบ่อย: ฉันจะสามารถใช้งาน MDI ได้มากกว่าหนึ่งอันได้อย่างไร?
  • คำถามที่ถามบ่อย: Tech2Win ไม่พบ MDI ของฉัน


ขั้นตอนแรก

ขั้นตอนเริ่มต้นเหล่านี้แสดงให้คุณทราบถึงวิธีใช้งาน Tech2Win โดยตั้งอยู่บนสมมติฐานที่ว่าคุณคุ้นเคยกับ Tech2 แล้ว ไม่จำเป็นต้องใช้การสื่อสารกับรถในระหว่างขั้นตอนเริ่มต้นเหล่านี้

สำหรับการเริ่มต้นใช้งานด่วน ให้ปฏิบัติตามขั้นตอนต่อไปนี้:

  1. เปิดใช้ซอฟต์แวร์ Tech2Win โดยใช้ทางลัด QuickStart จากเดสก์ท็อปของคุณ
  2. รับใบอนุญาตให้ใช้งานที่ใช้ได้โดยดาวน์โหลดซอฟต์แวร์ Tech2 ใหม่จาก TIS2Web

การใช้การกำหนดค่าที่เลือกได้:

  1. เริ่มใช้งานตัวกำหนดค่าโดยใช้ทางลัด Tech2Win จากเดสก์ท็อปของคุณ หลังจากการติดตั้ง การกำหนดค่า เริ่มต้น ควรปรากฏขึ้น
  2. ในการสร้างการกำหนดค่าใหม่ แนะนำให้คัดลอกจากการกำหนดค่า เริ่มต้น
  3. แก้ไขการกำหนดค่าที่มีอยู่ เพื่อให้ตรงตามความต้องการเฉพาะตัวของคุณ
  4. รับใบอนุญาตให้ใช้งานที่ใช้ได้

อย่าเริ่มใช้งาน Tech2Win ในโหมดที่เข้ากันได้ ในกรณีดังกล่าว คำเตือนจะปรากฏขึ้นในแฟ้มบันทึก Tech2Win ใช้การทำงานของ Windows ที่มีอยู่ตั้งแต่รุ่น XP เป็นต้นมาเท่านั้น และจะไม่ทำงานกับ Windows รุ่นเก่ากว่านั้น

  • ขั้นตอนแรก: สร้างการกำหนดค่า
  • ขั้นตอนแรก: การแก้ไขการกำหนดค่า
  • ขั้นตอนแรก: อินเตอร์เฟซการสื่อสารกับรถ
  • การทำงานโดยใช้ Tech2Win: เมนู
  • การทำงานโดยใช้ Tech2Win: ความปลอดภัย
  • การทำงานโดยใช้ Tech2Win: แถบสถานะ
  • หัวข้อเชิงลึก: แฟ้มการกำหนดค่า


การเลือกการกำหนดค่า

ครั้งแรกที่เริ่มใช้งานโปรแกรมประยุกต์ Tech2Win หน้าจอต่อไปนี้จะปรากฏขึ้น คุณมีทางเลือกในการเริ่มใช้ Tech2Win โดยตรง โดยใช้การกำหนดค่าเริ่มต้น การกำหนดค่าเริ่มต้นนี้จะทำงานโดยไม่มีการสื่อสารใดๆ กับรถ

Start First Time

กล่องข้อความแจ้งข้อมูลใบอนุญาตให้ใช้งานจะปรากฏขึ้น แต่คุณสามารถข้ามไปเพื่อเริ่มการกำหนดค่าเริ่มต้นเลยก็ได้

เมื่อทำงานโดยใช้หน้าจอสัมผัส อาจเป็นประโยชน์ต่อการเริ่มใช้งานโปรแกรมแป้นพิมพ์ของคอมพิวเตอร์ส่วนบุคคล เพื่อให้สามารถป้อนตัวอักษรผ่านทางโปรแกรมประยุกต์ที่ใช้จำลองแป้นพิมพ์นี้ได้


แป้นพิมพ์

แป้นกด รวมถึงปุ่มต่างๆ ของคอมพิวเตอร์ส่วนบุคคล (ถ้ามี) ถูกจัดวางตำแหน่งให้ตรงกับแป้นกดของ Tech2 ที่คุณคุ้นเคย ใน Tech2Win จะมีการเพิ่มแป้นกดบางอัน ซึ่งไม่มีใน Tech2 แบบเดิม แผงปุ่มกดตัวเลขบนเครื่องคอมพิวเตอร์ส่วนบุคคลอาจไม่ทำงานภายใต้ทุกสภาวะ หากมีปัญหาใดๆ โปรดตรวจสอบว่ารูปแบบแป้นพิมพ์มาตรฐานของเครื่องคอมพิวเตอร์ส่วนบุคคลของคุณถูกเปลี่ยนแปลงหรือไม่ โดยเฉพาะอย่างยิ่ง ในบางกรณี แป้น SHIFT อาจได้รับความเสียหาย

แป้นพิมพ์ของคอมพิวเตอร์ส่วนบุคคล | ปุ่ม | ระบบการทำงาน
แป้นฟังก์ชัน F1 | ไม่ระบุ | วิธีใช้ Tech2Win
แป้นฟังก์ชัน F5 .. F8 | ใช้บริเวณหน้าจอของ Tech2Win ที่มีซอฟต์คีย์อยู่ | ซอฟต์คีย์สี่อันของ Tech2
แป้นลูกศรขึ้น, ลง, ซ้าย, ขวา |  | แป้นขึ้น, ลง, ซ้าย, ขวาของ Tech2; เฉพาะแป้นเหล่านี้เท่านั้นที่มีการทำงานซ้ำอัตโนมัติ
แป้น 0 .. 9 | F0 • • • F9 | แป้น F0 .. F9 ของ Tech2
Backspace | Exit | แป้น Exit ของ Tech2
Enter / Return | Enter | แป้น Enter ของ Tech2
Y | Yes | แป้น Yes ของ Tech2
N | No | แป้น No ของ Tech2
Q | ? | แป้น ? ของ Tech2
S | Shift | แป้น Shift ของ Tech2; ตัวแจ้งเตือนการเลื่อนในแถบสถานะหรือตัวแจ้งเตือนเหนือปุ่มเลื่อนที่แจ้งสถานะ
ctrl-P | PWR | แป้น Power ของ Tech2; เป็นที่ชัดเจนว่าแป้นนี้จะสามารถปิดใช้งานโปรแกรมประยุกต์ Tech2Win ได้เพียงอย่างเดียว
ctrl-R | ไม่มีให้ | รีเซต Tech2Win คล้ายกับปุ่มหมุน Power Off/On ของ Tech2 อย่างไรก็ตาม อินเตอร์เฟซการสื่อสารกับรถที่เชื่อมต่อไว้จะไม่ถูกรีเซต แฟ้มต่างๆ เช่น รูป PCMCIA จะไม่ถูกโหลดใหม่
Home | Home | แป้นหน้าหลัก รองรับโดยโปรแกรมประยุกต์บางอันเท่านั้น
มีให้ใช้ทางตัวเลือกเมนู แฟ้มข้อมูล เท่านั้น | Print Screen | พิมพ์ภาพหน้าจอของหน้าจอ Tech2 โดยการสร้างแฟ้ม BMP ชั่วคราวและเรียกใช้โปรแกรมประยุกต์ที่เกี่ยวข้องกับแฟ้ม BMP ใช้โปรแกรมประยุกต์นี้ในการเปลี่ยนขนาดหรือหมุนภาพก่อนทำการพิมพ์
มีให้ใช้ทางตัวเลือกเมนู แฟ้มข้อมูล เท่านั้น | Save Screen | บันทึกภาพหน้าจอของหน้าจอ Tech2 เป็นแฟ้ม BMP หรือ PNG
มีให้ใช้ทางตัวเลือกเมนู แฟ้มข้อมูล เท่านั้น | View Report | แสดงรายงานทั้งหมดในการ์ดหน่วยความจำ PCMCIA เพื่อให้ผู้ใช้สามารถดูได้


การจัดการของ Windows

คุณอาจเปลี่ยนขนาดหน้าต่างโดยใช้ระบบมาตรฐานของ Windows โดยลากเส้นขอบของหน้าต่างหลัก นอกจากนี้ รายการเมนู ตัวเลือก/ความละเอียด ยังรองรับขนาดที่กำหนดไว้ล่วงหน้าหลายค่าด้วย ในระหว่างการเปลี่ยนขนาดของหน้าต่างหลักผ่านทางรายการเมนู หน้าต่างแป้นพิมพ์จะยังคงยึดอยู่โดยอัตโนมัติ

สามารถแก้ไขหน้าตาของหน้าต่างได้โดยเปลี่ยนการกำหนดค่าในแท็บ การแสดงผล


สร้างการกำหนดค่า

คลิกที่ปุ่ม สร้างใหม่ เพื่อสร้างการกำหนดค่าใหม่ เมนูโต้ตอบจะปรากฏขึ้นเพื่อขอให้คุณเลือกแฟ้มการกำหนดค่าที่มีอยู่เพื่อเป็นแหล่งข้อมูล ตามปกติแล้ว การกำหนดค่า เริ่มต้น จะถูกเลือก หลังจากป้อนชื่อของแฟ้มการกำหนดค่าใหม่แล้ว ให้กดปุ่ม คัดลอก

หากคุณกำลังทำงานโดยใช้หน้าจอสัมผัส คุณอาจพบว่าคุณต้องการเปิดใช้งานระบบจำลองแป้นพิมพ์ของคอมพิวเตอร์ส่วนบุคคลผ่านทางปุ่ม แป้นพิมพ์คอมพิวเตอร์ มากกว่า

ปุ่ม ยกเลิก จะช่วยให้คุณสามารถยกเลิกกระบวนการสร้างได้

การกำหนดค่าใหม่จะใช้แฟ้ม PCMCIA เดียวกันกับการกำหนดค่าต้นฉบับที่มีอยู่ หากคุณต้องการเปลี่ยนแปลง คุณจะต้อง แก้ไขการกำหนดค่า เพื่อใช้แฟ้ม PCMCIA อื่น ในกรณีส่วนใหญ่ คุณเพียงแค่คัดลอกแฟ้ม PCMCIA ที่มีอยู่ไปยังแฟ้มใหม่และใช้แฟ้มใหม่นั้น คุณอาจต้องการให้การกำหนดค่าใหม่ของคุณใช้แฟ้ม PCMCIA เดียวกันกับการกำหนดค่าต้นฉบับ ในกรณีดังกล่าว หน้าจอแจ้งเตือนจะปรากฏขึ้น เมื่อคุณคลิกที่ปุ่ม บันทึกเก็บ

  • การแก้ไขการกำหนดค่า


การแก้ไขการกำหนดค่า

การกำหนดค่าที่แสดงเป็นสีน้ำเงินถูกทำเครื่องหมายว่าเป็นแบบอ่านได้อ่างเดียวและไม่สามารถแก้ไขได้ สามารถดูการกำหนดค่าเหล่านี้ได้อย่างเดียวเท่านั้น แน่นอนว่าคุณอาจใช้วิธีการแก้ไขเพื่อดูเนื้อหาอย่างคร่าวๆ ได้ แต่จะไม่สามารถ บันทึกเก็บ ได้

สามารถแก้ไขการกำหนดค่าได้โดยเลือกการตั้งค่าแต่ละอันในกรอบแท็บสี่อันคือ ภาษา, อินเตอร์เฟซการสื่อสารกับรถ, เส้นทาง, การแสดงผล คุณอาจเลือกกรอบแท็บที่ต้องการหรือเพียงแต่เลือกกดปุ่ม ต่อไป ซึ่งจะเปิดใช้งานกรอบแท็บถัดไป หลังจากแก้ไขแล้ว ให้กดปุ่ม บันทึกเก็บ เพื่อบันทึกการกำหนดค่าของคุณ

เมื่อใดก็ตามที่จำเป็นต้องป้อนข้อมูลโดยใช้แป้นพิมพ์ คุณอาจต้องเรียกใช้โปรแกรมประยุกต์ในคอมพิวเตอร์ส่วนบุคคลที่ใช้จำลองแป้นพิมพ์ของคอมพิวเตอร์ส่วนบุคคลด้วย ซึ่งจะสะดวกอย่างยิ่งเมื่อใช้แล็ปท็อปแบบหน้าจอสัมผัสที่ไม่มีแป้นพิมพ์


ภาษา

กรอบแท็บ ภาษา จะให้คุณเลือกภาษาที่จะใช้งาน Tech2Win การเลือกนี้จะไม่มีผลต่อภาษาในซอฟต์แวร์ Tech2 บนรูป PCMCIA เมื่อดาวน์โหลดซอฟต์แวร์ Tech2 จาก TIS คุณยังคงต้องเลือกภาษาที่ถูกต้อง

สำหรับบางภูมิภาค อาจไม่มีภาษาบางภาษาให้เลือก ในกรณีนี้ จะแสดงเป็นภาษาอังกฤษแทน โปรดตรวจสอบว่ามีภาษาที่คล้ายกันให้หรือไม่ (PT โปรตุเกส-โปรตุเกส นอกจากPB โปรตุเกส-บราซิล)


เส้นทาง

กรอบแท็บ เส้นทาง จะช่วยให้คุณสามารถตั้งค่าเส้นทางของรูป PCMCIA ทั้งสอง รวมทั้งเส้นทางไปยังแป้นพิมพ์ซอฟต์แวร์ในเครื่องของคุณได้ นอกจากนี้ ยังมีปุ่ม คัดลอกการ์ดหน่วยความจำ ... ให้สำหรับคัดลอกรูป PCMCIA หากคุณเพิ่งสร้างการกำหนดค่าใหม่ คุณอาจต้องใช้ปุ่มนี้เพื่อหลีกเลี่ยงไม่ให้การกำหนดค่าหลายชุดใช้อิมเมจ PCMICA เดียวกัน

Memory Card Options

คัดลอกการ์ดหน่วยความจำ ...

ปุ่มนี้จะช่วยให้คุณสามารถคัดลอกรูป PCMCIA ไปยังอีกแฟ้มหนึ่งได้ ระบบการทำงานของมันจะคล้ายกับการสั่งซื้อการ์ด PCMCIA ใหม่สำหรับ Tech2 อย่างมาก การทำงานคัดลอกใช้ได้กับแฟ้มในไดเรกทอรี C:\Users\Public\General Motors\Tech2Win\pcmcia เท่านั้น

สล็อต 0 : การ์ดหน่วยความจำ ตำแหน่งภาพ

ที่ส่วนนี้ คุณจะสามารถระบุแฟ้มที่มีรูป PCMCIA ของคุณสำหรับสล็อต 0 ได้ ตามปกติ แฟ้มดังกล่าวควรอยู่ใน C:\Users\Public\General Motors\Tech2Win\pcmcia แต่ก็สามารถอยู่ในตำแหน่งอื่นๆ ได้

สล็อต 1 : การ์ดหน่วยความจำหรือ ATA

Tech2Win ยังรองรับการ์ด PCMCIA (รูป) สองอันเหมือนกับใน Tech2 อย่างไรก็ตาม ตามปกติ รูป PCMCIA อันที่สองในการกำหนดค่าจะไม่มีประโยชน์มากนัก ซอฟต์แวร์ที่สองอาจจะใช้ในการกำหนดค่าที่สอง

การ์ด ATA จะใช้เพื่อทำการดีบักเหมือนกับใน Tech2 โปรดเปิดใช้งานการ์ด ATA ต่อเมื่อได้รับคำแนะนำจากฝ่ายสนับสนุนทางเทคนิคเท่านั้น พวกเขาจะให้ข้อมูลเพิ่มเติมแก่คุณ

ซอฟต์แวร์คอมพิวเตอร์ ตำแหน่งแป้นพิมพ์

ค่าเริ่มต้นของแฟ้มนี้จะถูกดึงมาจากรีจิสทรีของ Windows และควรใช้เมาส์ชี้ไปยังโปรแกรมประยุกต์ที่สามารถจำลองแป้นพิมพ์ของคอมพิวเตอร์ส่วนบุคคลได้ หากคุณมีโปรแกรมประยุกต์หลายตัวที่มีระบบการทำงานนี้ในแล็ปท็อปที่คุณกำลังใช้งานอยู่ คุณสามารถระบุโปรแกรมประยุกต์ได้ที่ส่วนนี้


อินเตอร์เฟซการสื่อสารกับรถ

  • พอร์ต COM สำหรับ Tech2-RS232-Emulation
  • หมายเลขลำดับของ MDI ที่จะใช้งาน
  • โปรโตคอล

พอร์ต COM สำหรับ Tech2-RS232-Emulation

โปรดเลือกพอร์ต COM ว่างซึ่งสามารถใช้สำหรับการจำลอง Tech2 ได้ เพื่อความสะดวก ตัวกำหนดค่าจะพยายามหาว่าพอร์ตอนุกรมพอร์ตใดที่ถูกใช้งานแล้ว และจะแสดงให้ทราบ

หากคุณเลือกพอร์ต COM ที่มีอยู่ Tech2Win จะผูกตัวเองกับพอร์ต COM นี้ คุณอาจใช้พอร์ต COM นี้ในการดาวน์โหลดซอฟต์แวร์ Tech2 จากคอมพิวเตอร์เครื่องที่สองที่เปิดใช้งานโปรแกรมประยุกต์ TIS อยู่โดยใช้สายแบบ null modem ได้ โปรดทราบว่าการใช้พอร์ต COM จริงอาจไม่ทำงานอย่างน่าเชื่อถือที่บอด (baud) 115.200 เนื่องจากข้อกำหนดของ Windows

หากมีการเลือกพอร์ต COM ที่ไม่มีอยู่ Tech2Win จะสร้างพอร์ตจำลองโดยอัตโนมัติ พอร์ตเสมือนนี้อาจถูกใช้งานจาก TIS ที่กำลังทำงานในเครื่องคอมพิวเตอร์ส่วนบุคคลบางเครื่อง เพื่อสร้างการสื่อสารกับ Tech2Win เมื่อใช้พอร์ตเสมือน จะไม่ข้อจำกัดเรื่องอัตรารับส่งข้อมูล

หากคุณเลือก 'ค้นหา' เป็นพอร์ต COM Tech2Win จะสร้างพอร์ต COM เสมือนบนหมายเลขพอร์ตว่างอันแรกในช่วงตั้งแต่ 9 ถึง 1

หมายเลขลำดับของ MDI ที่จะใช้งาน

ป้อนหมายเลขประจำเครื่องของ MDI สามารถดูหมายเลขนี้ได้ที่ด้านหลังของ MDI ใช้หมายเลขข้างหลังเครื่องหมายขีดสั้น

หากคุณไม่ป้อนหมายเลขประจำเครื่อง Tech2Win จะแสดงรายการของ MDIs ที่ตรวจพบในเครือข่ายโดยอัตโนมัติ เพื่อให้ผู้ใช้เลือก MDI กล่องเลือกอันเดียวกันจะปรากฏขึ้นเมื่อไม่พบ MDI ที่ระบุ

โปรโตคอล

เลือก 'ISO22900-2 / PDU-API' และ J2534-2 จะเป็นสีเทาเสมอ ในอนาคต Tech2Win อาจสามารถรองรับโพรโทคอล J2534 ได้ด้วย

  • หัวข้อเชิงลึก: แฟ้มการกำหนดค่า
  • คำถามที่ถามบ่อย: ฉันจะสามารถหาว่าควรใช้พอร์ต COM ใดสำหรับ Tech2Win ได้อย่างไร?
  • คำถามที่ถามบ่อย: การสื่อสารระหว่าง Tech2Win และ TIS2Web
  • คำถามที่ถามบ่อย: ฉันจะสามารถใช้งาน MDI ได้มากกว่าหนึ่งอันได้อย่างไร?
  • คำถามที่ถามบ่อย: Tech2Win ไม่พบ MDI ของฉัน


การแสดงผล

ส่วนใหญ่จะใช้แท็บ การแสดงผล เพื่อเปลี่ยนการตั้งค่าเกี่ยวกับการแสดงผลของ Tech2Win:

  • แผงปุ่มกด
  • สี
  • เสียง
Display and Key Options

แผงปุ่มกด

ที่ส่วนนี้ คุณจะสามารถเลือกได้ว่าจะให้แสดงแผงปุ่มกดหรือไม่ แผงปุ่มกดจะปรากฏขึ้นทางด้านซ้ายหรือด้านขวาของหน้าจอ Tech2Win สามารถเลือกสีพื้นหลังได้จากกล่องโต้ตอบสีมาตรฐาน

สี

ที่ส่วนนี้ จะสามารถเลือกสีพื้นหลังและพื้นหน้าของหน้าจอ Tech2 แยกกันได้ นี่เป็นคู่สีสองแบบที่ใช้กันมากที่สุด:

Screen with background 0000FF, foreground FFFFFF | พื้นหลังแผงปุ่มกดสีขาว; พื้นหลังสีน้ำเงิน; พื้นหน้าสีขาว
Screen with background 000000, foreground C0C0C0 | พื้นหลังแผงปุ่มกดสีน้ำเงิน; พื้นหลังสีดำ; พื้นหน้าสีเทาอ่อน

เสียง

คุณอาจเลือกปิดเสียงได้ที่ตรงนี้ ทุกครั้งที่โปรแกรม Tech2 ส่งเสียงปี๊บ จะใช้ลำโพงของคอมพิวเตอร์ส่วนบุคคล


การบันทึกการกำหนดค่า

สามารถบันทึกการกำหนดค่าที่ใช้งานอยู่ได้โดยกดปุ่ม บันทึกเก็บ <การกำหนดค่า> ที่มุมล่างซ้าย หากคุณกำลังดูการกำหนดค่าแบบอ่านอย่างเดียว ปุ่มนี้จะไม่ปรากฏขึ้น


ใบอนุญาตที่ใช้ได้ทาง TIS2Web

ตามปกติ การดาวน์โหลดซอฟต์แวร์ Tech2 ไปยัง Tech2Win จะมีใบอนุญาตที่ใช้ได้มาให้ นอกจากนี้ คุณยังสามารถรับได้โดยทำการ 'การผ่านเข้าระบบนิรภัย (ระบบนิรภัย)' ผ่านทาง TIS2Web (ยกเว้น TIS2000) ดังนั้น เงื่อนไขที่ต้องมีก่อนคือการเลือกพอร์ต COM เสมือนภายในตัวกำหนดค่าใน อินเตอร์เฟซการสื่อสารกับรถ

หลังจากผ่านการเข้าถึงด้านความปลอดภัยสำเร็จแล้ว คุณจะสามารถมองเห็นรูปแม่กุญแจปลดล็อคทางด้านขวาของแถบสถานะ ภายในวงเล็บคุณจะเห็นจำนวนวันที่ใบอนุญาตใช้งานได้ เมื่อคุณเริ่มใช้งาน Tech2Win อีกครั้ง ตัวแจ้งเตือนความปลอดภัยจะไม่ปรากฏตราบใดที่ยังไม่มีการสื่อสารกับรถ ในระหว่างการสื่อสารกับรถครั้งแรกจะมีการตรวจสอบ ใบอนุญาตให้ใช้งาน และตัวแจ้งเตือนจะแสดงเป็นรูปแม่กุญแจที่ล็อคอยู่หรือถูกปลดล็อค

  • การทำงานโดยใช้ Tech2Win:ความปลอดภัย
  • คำถามที่ถามบ่อย:ฉันจะสามารถหาว่าควรใช้พอร์ต COM ใดสำหรับ Tech2Win ได้อย่างไร?
  • คำถามที่ถามบ่อย:การสื่อสารระหว่าง Tech2Win และ TIS2Web
  • คำถามที่ถามบ่อย:ใบอนุญาตที่ใช้งานได้
  • คำถามที่ถามบ่อย:อะไรคือความแตกต่างระหว่างใบอนุญาตให้ใช้งาน Tech2Win กับการเข้าถึงด้านความปลอดภัย?


การทำงานโดยใช้ Tech2Win

เมื่อทำงานโดยใช้ Tech2Win ช่างเทคนิคส่วนใหญ่จะใช้งานหัวข้อต่อไปนี้:

  • เมนู: เค้าโครงหน้าจอและรายการเมนูแต่ละรายการ
  • การดาวน์โหลดรูป PCMCIA: การปรับปรุงซอฟต์แวร์การวินิจฉัยสำหรับ Tech2Win คล้ายกับวิธีที่ใช้สำหรับ Tech2 มาก
  • ความปลอดภัย: การประเมินความปลอดภัยช่วยป้องกัน Tech2Win จากการดำเนินการสื่อสารกับรถในสภาพแวดล้อมที่ไม่ได้รับอนุญาต
  • ดูรายงาน: แป้นพิมพ์ Tech2 ได้รับการปรับปรุงเล็กน้อยใน Tech2Win ปุ่ม 'ดูรายงาน' เป็นตัวอย่างที่ชัดเจนที่สุด
  • การจัดการรูป PCMCIA: เช่นเดียวกับการมีการ์ด PCMCIA หลายอันสำหรับ Tech2 คุณอาจมีรูป PCMCIA หลายรูปเพื่อใช้กับ Tech2Win
  • แถบสถานะ: แถบสถานะจะแจ้งผู้ใช้เกี่ยวกับแต่ละส่วนของแถบสถานะ
    • หัวข้อเชิงลึก
    • คำถามที่ถามบ่อย


เมนู

โปรแกรมประยุกต์ Tech2Win มีรายการเมนูต่อไปนี้:

  • แฟ้มข้อมูล
  • ตัวเลือก
  • Windows
  • วิธีใช้

แฟ้มข้อมูล

เมนู แฟ้มข้อมูล ทำให้สามารถใช้งานต่อไปนี้ได้:

  • บันทึก T2-Screen (320x240) จะใช้เพื่อบันทึกหน้าจอ T2 จริงในขนาด 320x240 พิกเซล เป็นแฟ้มภาพขาวดำในเครื่องคอมพิวเตอร์ส่วนบุคคลของคุณ สามารถเลือกตำแหน่งบันทึกและรูปแบบของแฟ้ม (BMP, GIF, JPG, PNG) ได้อย่างอิสระ
  • พิมพ์หน้าจอ จะสร้างรูป BMP แบบกลับสีขาวดำของหน้าจอ Tech2 และเรียกใช้โปรแกรมที่เกี่ยวข้องกับแฟ้ม BMP คุณอาจใช้โปรแกรมนี้เพื่อพิมพ์รูปออกมาได้
  • ดูไฟล์รายงาน ทำให้สามารถดู (และพิมพ์) แฟ้มรายงานโดยไม่ต้องใช้ TIS2Web
  • ออก ปิดการทำงาน Tech2Win

ตัวเลือก

ตัวเลือก มีตัวเลือกให้ดังต่อไปนี้:

  • ความละเอียด สามารถใช้เลือกขนาดหน้าจอมาตรฐานได้สามแบบ
  • ROM-Write from 0x00003ED76 ใช้สำหรับการดีบัก
  • จับภาพหน้าจออัตโนมัติ เพื่อบันทึกรูปของหน้าจอ Tech2 ทุกรูปที่ต่างกันลงในไดเรกทอรีบันทึก
  • ปิดใช้งาน CANdi แล้วบูตใหม่ เพื่อลอกแบบ Tech2 ที่ไม่มี CANdi ระหว่างตัวมันเองกับรถ ซึ่งจำเป็นสำหรับกรณีที่เกิดขึ้นยากซึ่ง CANdi แทรกแซงสายสื่อสารของรถที่ไม่ได้มาตรฐาน

Windows

เมนู Windows ทำให้คุณสามารถเปิดใช้การเลือก ส่วนแสดงข้อมูลของ Tech2Win และ ส่วนแสดงรหัสข้อบกพร่องของ Tech2Winได้ การเลือกอื่นทั้งหมดจะเป็นสีเทาใน Tech2Win รุ่นปัจจุบัน

หากซอฟต์แวร์ Tech2 รองรับ ส่วนแสดงข้อมูลของ Tech2Win คุณจะสามารถเปิดใช้รายการเมนูนี้ได้ เมื่อป้อนค่าใน Data Display Tech2Win จะหน้าต่างแสดงข้อมูลเพิ่มเติมควบคู่ไปกับหน้าต่าง Data Display ของ Tech2 ตราบใดที่หน้าจอ Tech2 กำลังแสดงหน้าต่าง Data Display จะไม่สามารถเปิดใช้รายการเมนูได้ ในกรณีดังกล่าว คุณต้องออกจากหน้าต่าง Data Display, เปิดใช้รายการเมนู และเรียกใช้หน้าต่าง Data Display ใหม่

ข้อจำกัดที่คล้ายกันสำหรับ ส่วนแสดงข้อมูลของ Tech2Win ใช้ได้กับ ส่วนแสดงรหัสข้อบกพร่องของ Tech2Win เช่นกัน หากซอฟต์แวร์ Tech2 รองรับ ส่วนแสดงรหัสข้อบกพร่องของ Tech2Win คุณจะสามารถเปิดใช้รายการเมนูนี้ได้ หน้าต่าง DTC Display เพิ่มเติมจะปรากฏควบคู่ไปกับหน้าต่าง DTC Display ของ Tech2 ตราบใดที่หน้าจอ Tech2 กำลังแสดงหน้าต่าง DTC Display จะไม่สามารถเปิดใช้รายการเมนูได้ ในกรณีดังกล่าว คุณต้องออกจากหน้าต่าง DTC Display, เปิดใช้รายการเมนู และเรียกใช้หน้าต่าง DTC Display ใหม่

วิธีใช้

มีตัวเลือกต่อไปนี้ให้:

  • หัวข้อคำอธิบายเพิ่มเติม... เรียกใช้วิธีใช้ Tech2Win
  • พารามิเตอร์ในบรรทัดคำสั่ง แสดงพารามิเตอร์ของบรรทัดคำสั่งที่ใช้สำหรับ Tech2Win
  • เกี่ยวกับ แสดงเลขรุ่นปัจจุบัน และข้อจำกัดในการดาวน์โหลด TIS2Web ของ Tech2Win


ดาวน์โหลด

อันดับแรก เปิดใช้ Tech2Win แล้วรอที่หน้าจอหลัก เปิดใช้ TIS2Web หรือ GlobalTIS แล้วดาวน์โหลดผ่านทางพอร์ต COM ที่ระบุไว้ในแท็บ อินเตอร์เฟซการสื่อสารกับรถ

พอร์ต COM ติดตั้งในตัวจะช่วยให้่สามารถดาวน์โหลดซอฟต์แวร์ Tech2 จากเครื่องคอมพิวเตอร์ส่วนบุคคลเครื่องอื่นที่เปิดใช้ TIS อยู่ได้ ตรวจสอบให้แน่ใจว่าใช้สาย RS232 แบบไขว้ อาจจำเป็นต้องลดอัตราการถ่ายโอนข้อมูลเป็น 57.600 บอด (baud) โดยขึ้นอยู่กับฮาร์ดแวร์ของเครื่องคอมพิวเตอร์ส่วนบุคคลที่เรียกใช้งาน Tech2Win เนื่องจาก Windows อาจสูญเสียข้อมูลที่อัตรารับส่งข้อมูลสูงๆ ได้

Tech2Win รุ่นล่าสุดรองรับการดาวน์โหลดเร็วเมื่อ TIS2Web และ Tech2Win กำลังทำงานในเครื่องคอมพิวเตอร์ส่วนบุคคลเครื่องเดียวกันด้วย การสื่อสารน้อยที่สุดระหว่าง TIS2Web และ Tech2Win ทางพอร์ต COM ยังคงดำเนินการอยู่ แต่เวลาที่ใช้ถ่ายโอนข้อมูลไปยัง Tech2Win ได้ถูกแทนที่โดยการถ่ายโอนแฟ้มภายใน ในกรณีดังกล่าว เวลาในการดาวน์โหลดจะถูกลดลงอย่างมาก จนกระทั่งน้อยกว่าหนึ่งนาที

  • หัวข้อเชิงลึก: แฟ้มการกำหนดค่า
  • ขั้นตอนแรก: อินเตอร์เฟซการสื่อสารกับรถ
  • คำถามที่ถามบ่อย: ฉันจะสามารถหาว่าควรใช้พอร์ต COM ใดสำหรับ Tech2Win ได้อย่างไร?
  • คำถามที่ถามบ่อย: การสื่อสารระหว่าง Tech2Win และ TIS2Web


ความปลอดภัย

กลไกนิรภัยที่ใช้โดย Tech2Win อ้างอิงตามค่านาฬิกาของเครื่องคอมพิวเตอร์ส่วนบุคคลที่ถูกต้อง โปรดตรวจสอบให้แน่ใจว่ามีการตั้งค่านาฬิกาของเครื่องคอมพิวเตอร์ส่วนบุคคลของท่านเสมอ การเปลี่ยนแปลงนาฬิกาเพียงเล็กน้อยที่อาจเกิดขึ้นในวันที่มีการปรับเวลา จะส่งผลต่อ Tech2Win

Tech2Win จะไม่ทำการสื่อสารกับรถคันใดก็ตามที่ไม่มีใบอนุญาตให้ใช้งานที่ใช้ได้และมีผลอยู่ ตัวแจ้งเตือนต่อไปนี้ในแถบสถานะ จะแสดงสถานะของใบอนุญาตให้ใช้งาน:

  • green smiley ใบอนุญาตให้ใช้งานใช้ได้
  • ไม่มีตัวแจ้งเตือน: ใบอนุญาตให้ใช้งานยังไม่ได้รับการตรวจสอบ
  • red smiley สิทธิ์การใช้งานหมดอายุแล้ว

ในการรับใบอนุญาตให้ใช้งาน โปรดปรับปรุง 'การผ่านเข้าระบบนิรภัย (ระบบนิรภัย)' โดยใช้โปรแกรมประยุกต์ TIS2Web ในกรณีส่วนใหญ่ 'ดาวน์โหลดซอฟต์แวร์ (SWDL)' ผ่านทาง TIS2Web ก็เพียงพอต่อการรับใบอนุญาตให้ใช้งานใหม่ เนื่องจากใบอนุญาตให้ใช้งานจะใช้ไม่ได้หลังจากผ่านไปชั่วระยะเวลาหนึ่ง (ในบางภูมิภาค: 4 สัปดาห์) คุณต้องทำการอัพเดตตามรอบเวลาอย่างสม่ำเสมอ

ใบอนุญาตให้ใช้งานนั้นจำเพาะต่อภูมิภาค/ซอฟต์แวร์ คุณอาจมีใบอนุญาตให้ใช้งานหลายใบในเครื่องคอมพิวเตอร์ของคุณ หากคุณใช้ Tech2Win ที่มีซอฟต์แวร์ Tech2 ที่แตกต่างกัน

จำนวนวันที่เหลืออยู่ก่อนที่ใบอนุญาตให้ใช้งานจะหมดอายุ จะถูกแสดงไว้ในแถบสถานะ

  • ( 0) แสดงว่าใบอนุญาตให้ใช้งานได้หมดอายุแล้วหรือไม่มีอยู่
  • (<1) ใบอนุญาตให้ใช้งานจะหมดอายุภายใน 24 ชั่วโมง
  • (20) ใบอนุญาตให้ใช้งานจะหมดอายุภายใน 20 วัน

โปรดอย่าแก้ไขข้อมูลโดยประสงค์ร้ายต่อแฟ้มใบอนุญาตให้ใช้งาน การแก้ไขเพื่อหลอกลวงต่อแฟ้มนี้จะถูกตรวจจับโดยใช้มาตรการความปลอดภัยภายใน และจะทำให้สูญเสียใบอนุญาตให้ใช้งานทั้งหมดในคอมพิวเตอร์ได้ นอกจากนี้ Tech2Win จะไม่ทำงานตามที่คาด ซึ่งจะแก้ไขได้โดยการติดตั้งใหม่เท่านั้น

  • หัวข้อเชิงลึก: ข้อความแจ้งข้อผิดพลาดและรหัสออก
  • หัวข้อเชิงลึก: แฟ้มบันทึก
  • การทำงานโดยใช้ Tech2Win: หน้าต่างสถานะ
  • คำถามที่ถามบ่อย: ใบอนุญาตที่ใช้งานได้
  • คำถามที่ถามบ่อย: อะไรคือความแตกต่างระหว่างใบอนุญาตให้ใช้งาน Tech2Win กับการเข้าถึงด้านความปลอดภัย?
  • คำถามที่ถามบ่อย: หยุดทำงานฉับพลัน


การดูรายงาน

View Report สามารถใช้ปุ่มนี้เพื่อดูเนื้อหาของแฟ้ม PRT ใดๆ ที่มีอยู่ใน PCMCIA กล่องโต้ตอบจะเปิดขึ้นเพื่อแสดงรายการแฟ้ม PRT หากมีโปรแกรมเกี่ยวข้องกับแฟ้มชนิด PRT โปรแกรมที่เกี่ยวข้องนี้จะถูกเรียกใช้งาน โปรแกรมแก้ไข notepad จะเปิดขึ้นเพื่อแสดงแฟ้มที่เลือก

ในกรณีส่วนมาก แฟ้ม PRT จะเป็นแฟ้ม ASCII ที่ใช้โค้ดเพจที่ตรงกับภาษา สำหรับภาษาจีน, ญี่ปุ่น, เกาหลี และไทย แฟ้มนี้จะเป็นแบบ Unicode ที่มีส่วนนำเป็น Byte-Order-Mark (BOM)

เมื่อดูรายงาน Tech2Win จะทำงานกับไดเรกทอรีย่อย C:\Users\Public\General Motors\Tech2Win\reports ไดเรกทอรีย่อยนี้จะมีอยู่ก็ต่อเมื่อคุณได้ดูรายงานอย่างน้อยหนึ่งครั้งแล้วเท่านั้น ไดเรกทอรีนี้จะถูกลบโดยอัตโนมัติ และทำงานเป็นไดเรกทอรีใช้งานชั่วคราวสำหรับแฟ้ม PRT ในการ์ด PCMCIA ที่ใช้งานอยู่ ระบบจะเก็บแฟ้มเหล่านี้ไว้ต่อไปแม้ว่า Tech2Win จะหยุดทำงาน หากคุณต้องการบันทึกแฟ้มดังกล่าวไว้ คุณจำเป็นต้องคัดลอกแฟ้มนั้นไปยังไดเรกทอรีอื่น เนื่องจากแฟ้มอาจถูกเขียนทับทันทีที่มีผู้ใช้คนอื่นเลือกดูรายงาน


รูป PCMCIA

ตามปกติ รูป PCMCIA จะอยู่ในไดเรกทอรีย่อย C:\Users\Public\General Motors\Tech2Win\pcmcia แฟ้มต้องมีขนาด 32 เมกกะไบต์ (33,554,432 ไบต์) หรือ 10 เมกกะไบต์ (10,485,760 ไบต์) พอดี และมีชนิดแฟ้มเป็น *.bin หากมีการดาวน์โหลดหรือหาก Tech2Win จัดเก็บบางอย่างไว้ในการ์ดหน่วยความจำ อิมเมจจะถูกแก้ไข (เหมือนกับการ์ด PCMCIA ปกติทุกอัน) สามารถปิดไม่ให้มีการแก้ไขได้โดยใช้สวิตช์ป้องกันการเขียน (คำสั่ง -W0 or -W1) หรือโดยข้ามค่า 'p' ในตัวเลือก '-W'(แฟ้มการกำหนดค่า). สวิตช์ป้องกันการเขียนไม่สามารถเข้าถึงได้ทางตัวกำหนดค่า หากคุณต้องการใช้ตัวเลือก '-W0', '-W1' หรือ '-W' คุณจะต้องแก้ไขแฟ้มกำหนดค่าด้วยตนเอง


แถบสถานะ

แถบสถานะจะปรากฏขึ้นใต้หน้าจอของ Tech2 รายการต่อไปนี้จะปรากฏขึ้นในแถบสถานะ:

  1. ตัวแจ้งเตือนความเร็ว
  2. สถานะของการสื่อสารกับรถ
  3. สถานะของพอร์ตอนุกรม
  4. แป้น SHIFT
  5. จับภาพหน้าจออัตโนมัติ
  6. การเตือนรายการบันทึก
  7. ใบอนุญาตให้ใช้งาน

Status Bar

ตัวแจ้งเตือนความเร็ว

ตัวแจ้งเตือนความเร็วจะแสดงเวลาที่ CPU ใช้ในการจำลองซอฟต์แวร์ Tech2 ตัวเลขน้อยๆ (ตัวแจ้งเตือนทางซ้าย) ดีกว่าตัวเลขมากๆ (ตัวแจ้งเตือนทางขวา) ตัวแจ้งเตือนสีเขียวถือว่ายอมรับได้ เมื่องานของ Windows ที่ต่างกันทำงานขึ้นพร้อมกัน ตัวแจ้งเตือนอาจกลายเป็นสีเหลืองครู่หนึ่ง จะต้องหลีกเลี่ยงการเกิดเหตุการณ์เช่นนี้่

สถานะของการสื่อสารกับรถ

สถานะการสื่อสารกับรถจะแจ้งว่ามีอินเตอร์เฟซการสื่อสารกับรถ (MDI) อยู่ พร้อมกับการสื่อสารระหว่างรถกับ Tech2Win หรือไม่

สถานะของพอร์ตอนุกรม

เมื่อทำการสื่อสารกับ Tech2Win ทางพอร์ต COM ตัวแจ้งเตือนนี้จะแสดงว่าการสื่อสารกับพอร์ต COM ทำงานอยู่หรือไม่

แป้น SHIFT

ตัวแจ้งเตือนนี้จะแสดงว่าแป้น SHIFT ทำงานอยู่หรือไม่ คุณอาจสลับมันโดยใช้แป้น 'S' ของแป้นพิมพ์หรือแป้น SHIFT บนแผงปุ่มกด

จับภาพหน้าจออัตโนมัติ

สามารถเปิดใช้ 'จับภาพหน้าจออัตโนมัติ' ได้ในเมนู 'ตัวเลือก' ทุกครั้งที่หน้าจอเปลี่ยนแปลง แฟ้มภาพหน้าจอจะถูกบันทึกไว้ในไดเรกทอรีบันทึก ซึ่งทราบได้จากที่จับที่หมุนบนกล้องสีแดงในแถบสถานะ ทันทีที่ 'จับภาพหน้าจออัตโนมัติ' ถูกปิดใช้งาน กล้องจะหายไป

การเตือนรายการบันทึก

ตัวแจ้งเตือนสถานะรายการบันทึกอาจมีได้ถึงสามสถานะ

  • gray log status indicator แฟ้มบันทึกไม่มีคำเตือนหรือข้อผิดพลาด
  • yellow log status indicator แฟ้มบันทึกมีคำเตือนหรือข้อผิดพลาด
  • red log status indicator แฟ้มบันทึกมีข้อความแจ้งข้อผิดพลาด

ใบอนุญาตให้ใช้งาน

ตัวแจ้งเตือนใบอนุญาตให้ใช้งานสามารถมีได้สามสถานะ:

  • green smiley ใบอนุญาตให้ใช้งานมีผลอยู่และใช้ได้
  • ไม่มีตัวแจ้งเตือน: ใบอนุญาตให้ใช้งานยังไม่ได้รับการตรวจสอบ
  • red smiley ใบอนุญาตให้ใช้งานได้หมดอายุแล้วหรือไม่มีอยู่
โปรดคลิกที่ลิงค์ ความปลอดภัย เพื่อดูรายละเอียดเพิ่มเติม

คำแนะนำเครื่องมือบนแถบสถานะ

สำหรับบางไอคอน คำแนะนำเครื่องมือจะปรากฏขึ้นเพื่อให้ข้อมูลเพิ่มเติมบางอย่าง:

คำแนะนำเครื่องมือสำหรับหมายเลขประจำเครื่อง VCI:
Tooltip VCI

คำแนะนำเครื่องมือสำหรับรุ่นซอฟต์แวร์ TECH2
Tooltip TECH2

คำแนะนำเครื่องมือสำหรับพอร์ต COM
Tooltip Comport

คำแนะนำเครื่องมือสำหรับจำนวนของภาพหน้าจอถัดไป (หาก 'จับภาพหน้าจออัตโนมัติ' ทำงานอยู่)
Tooltip Camera

คำแนะนำเครื่องมือซึ่งแสดงรายการแฟ้มบันทึกล่าสุดที่มีระดับ 'คำเตือน' หรือสูงกว่า
Tooltip Logfile

คำแนะนำเครื่องมือสำหรับอายุใบอนุญาตให้ใช้งานที่แน่ชัด
Tooltip License

คำแนะนำเครื่องมือจะปรากฏขึ้นเมื่อเคอร์เซอร์วางอยู่บนไอคอนนานกว่า 0.5 วินาที โดยไม่เคลื่อนไหว คำแนะนำเครื่องมือจะหายไปหลังจากผ่านไป 5 วินาที หรือเมื่อเลื่อนเคอร์เซอร์ออกไป

  • หัวข้อเชิงลึก: ข้อความแจ้งข้อผิดพลาดและรหัสข้อผิดพลาด
  • หัวข้อเชิงลึก: แฟ้มบันทึก


หัวข้อเชิงลึก

ประเด็นที่ถกกันในที่นี้ไม่ค่อยมีความสำคัญต่อผู้ใช้มาตรฐานของ Tech2Win ผู้ที่เกี่ยวข้องกับการติดตั้ง, การจัดการ และการกำหนดค่าTech2Win อาจได้รับประโยชน์จากข้อมูลต่อไปนี้

  • การติดตั้งอีกครั้ง
  • การถอนการติดตั้ง
  • การแก้ไขแฟ้มการกำหนดค่าโดยตรง
  • แฟ้มบันทึก
  • ข้อความแจ้งข้อผิดพลาดและรหัสออก
  • การ์ด ATA
  • รายการรีจิสทรี
  • คำอธิบายแฟ้ม
  • ตัวอย่างการจัดการการกำหนดค่า


การถอนการติดตั้ง

ไดเรกทอรีในการติดตั้งทั้งหมด, ไดเรกทอรีที่มีข้อมูลผู้ใช้ (C:\Users\Public\General Motors\Tech2Win) และไดเรกทอรีที่มีข้อมูลโปรแกรมประยุกต์ (C:\ProgramData\General Motors\Tech2Win) จะถูกลบออก

  • หัวข้อเชิงลึก: การติดตั้งอีกครั้ง
  • การติดตั้ง


แฟ้มการกำหนดค่า

แฟ้มการกำหนดค่าจะอยู่ในไดเรกทอรีย่อย C:\Users\Public\General Motors\Tech2Win\config และมีนามสกุล *.conf เสมอ คุณอาจเลือกที่จะแก้ไขแฟ้มการกำหนดค่าด้วยตนเอง เนื่องจากไม่สามารถเข้าใช้งานตัวเลือกของแฟ้มทั้งหมดผ่านทาง Tech2Win ได้ แฟ้มการกำหนดค่าเป็นแฟ้ม Unicode ที่มี Byte-Order_Mark (BOM) เป็นส่วนนำ เมื่อทำการเปลี่ยนแปลงใดๆ ด้วยตนเอง เราแนะนำให้คุณใช้โปรแกรมที่สามารถแก้ไข Unicode ได้ เช่น Notepad

แฟ้มการกำหนดค่าเป็นแบบเรียงทีละบรรทัด บรรทัดที่ว่างจะถูกมองข้าม บรรทัดจะเริ่มต้นด้วยตัวเลือกหนึ่งรายการเสมอ และส่วนมากจะตามด้วยค่า โปรดดูตัวอย่างในแฟ้ม default.conf โปรดอ้างอิงตารางต่อไปนี้ ซึ่งจะอธิบายตัวเลือกทั้งหมดที่มีอยู่

หากคุณต้องการเรียกใช้การกำหนดค่าอันใดโดยตรงจากเดสก์ท็อป ให้สร้างทางลัดที่เรียกใช้ 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf โปรแกรมควรถูกเรียกใช้งานจากไดเรกทอรีใช้งานต่อไปนี้: 'C:\Program Files\General Motors\Tech2Win\bin'

ตัวเลือก | ค่า / ความหมาย
; ความคิดเห็น
@ ตัวเลขระบุรุ่นแบบมีจุดในรูปแบบ 'รุ่นหลัก.รุ่นย่อย'
ระบบจะไม่ยอมรับแฟ้มการกำหนดค่าที่มีตัวเลขรุ่นหลักต่างจาก Tech2Win ระบบจะยอมรับแฟ้มการกำหนดค่าที่มีตัวเลขรุ่นย่อยต่ำกว่า Tech2Win
-W0
-W1 		เปิดใช้งานสวิตช์ป้องกันการเขียนของการ์ด PCMCIA ในช่องเสียบ 0/1 ไว้
-B0
-B1 		บล็อกไซส์ในหน่วยกิโลไบต์ของการ์ด PCMCIA ในช่องเสียบ 0/1 ค่าที่ยอมรับได้คือ 128 (ค่าเริ่มต้น) หรือ 256
-P0
-P1 		แฟ้มที่มีรูปแบบไบนารีของการ์ด PCMCIA สำหรับช่องเสียบ 0/1 ขนาดของแฟ้มต้องเป็น 10MB หรือ 32MB พอดี ตัวแปรสภาพแวดล้อม เช่น %ProgramData% ถูกขยายออก
หากไม่มีตัวเลือกนี้ ระบบจะสันนิษฐานว่าช่องเสียบว่างอยู่
-A0
-A1 		แฟ้มที่มีค่าแอตทริบิวต์ของการ์ด PCMCIA ในช่องเสียบ 0/1 หากไม่มีอยู่ จะใช้แอตทริบิวต์เริ่มต้นโดยขึ้นกับการ์ดและบล็อกไซส์
-W | เมื่อออกจาก Tech2Win ข้อมูลที่ยังคงอยู่ทั้งหมดจะถูกเขียนลงในแฟ้มที่เกี่ยวข้อง สามารถใช้ค่า p/f/r/c รวมกันเพื่อแสดงค่า PCMCIA/Flash-ROM/RTC/CANDI-App ตามลำดับ
-H | ระบบการทำงานการจัดการจองเนื้อที่หน่วยความจำ สามารถใช้ค่า 0/r/w/t ผสมกันเพื่อใช้งานการปรับค่าให้เป็นศูนย์, การตรวจสอบค่าที่อ่านได้, การตรวจสอบการเขียน และการตรวจสอบงาน ตามลำดับ ค่า l ใช้ในการบังคับการจัดสรรการจองเนื้อที่หน่วยความจำที่ตำแหน่งต่ำๆ เสมอ เมื่อมีการใช้รูปแบบการจัดสรรทางเลือก ตามปกติ ตัวเลือกนี้จะใช้ในสภาพแวดล้อมการพัฒนาเท่านั้น
-PC | ก่อนหน้านี้ คือเส้นทางสำหรับคัดลอกการ์ด PCMCIA ขณะนี้ ตัวเลือกนี้ถูกละเว้น
-MS | การระบุอินเตอร์เฟซการสื่อสารกับรถ (MDI) ด้วยหมายเลขประจำเครื่อง หากไม่ตั้งค่าไว้ รายการของ MDI ที่มีให้จะปรากฏขึ้น
-CT | สีตัวอักษร (พื้นหน้า) เป็นค่าไบต์แบบเลขฐานสิบหก 3 ค่า ค่าเริ่มต้นคือ 000000 (สีขาว)
-CB | สีพื้นหลังเป็นค่าไบต์แบบเลขฐานสิบหก 3 ค่า ค่าเริ่มต้นคือ FFFFFF (สีดำ)
-ATA | ตัวเลือกนี้จะใช้เพื่อเปิดใช้งานการ์ดบันทึก ATA ลบออก เพื่อปิดใช้งานการ์ดบันทึก ATA
-C | จำนวนพอร์ต COM (1..9) ที่จะใช้เป็นพอร์ตสื่อสาร RS232C ของ Tech2 มักใช้ COM9 เป็นพอร์ต COM เสมือนซึ่งติดตั้งโดย Tech2Win หากไม่มีตัวเลือกนี้อยู่ จะมีการค้นหาพอร์ต COM ว่างไล่ลงมาตั้งแต่ COM9 ใช้คำแนะนำเครื่องมือบนแถบสถานะระหว่างไอคอน Tech2 กับไอคอน TIS2Web เพื่อดูว่าพอร์ต COM ใดบ้างที่ถูกใช้อยู่
-WR | PCaddress (ตามปกติจะเป็น 253558) ซึ่งได้รับอนุญาตให้เขียนลงการ์ด PCMCIA และ FLASH ROM Area ระบบการทำงานนี้ต้องถูกเปิดใช้งานเพิ่มเติมทางเมนู (หรือโดยใช้ตัวเลือก -WA) จำเป็นต้องดีบักรหัสในหน่วยความจำแบบไม่สามารถแก้ไขได้โดยใช้ดีบักเกอร์ SingleStep
-WA | อนุญาตให้ดีบักเกอร์ SingleStep ทำการเขียนไปยังหน่วยความยังที่ไม่สามารถแก้ไขได้
-OF | แฟ้มตัวเลือกมีคู่ ตัวเลือก/ค่า
-TP | การปรับการตั้งเวลา (ค่าสัดส่วน). ค่าเริ่มต้นเป็น 5000 ลดค่านี้เพื่อให้มีจำนวนรอบเปิดใช้งานที่ปรับตามเวลาจริงเร็วขึ้น
-TD | การปรับการตั้งเวลา (ค่าส่วนต่าง). ค่าเริ่มต้นเป็น 100 ลดค่านี้เพื่อให้ตอบสนองต่อการเปลี่ยนแปลงการตั้งเวลาทันทีที่เร็วขึ้น คำเตือน: การเข้าไปยุ่งกับค่า TP และ TD อาจทำให้เกิดปัญหาด้านความเร็ว
-PJ
-PP 		ระบุโพรโทคอลที่ควรใช้งาน:
PJ สำหรับการสื่อสาร J2534
PP สำหรับ ISO22900-2 / PDU-API (ค่าเริ่มต้น)
-S | การมีตัวเลือกนี้จะช่วยให้สามารถใช้เอาท์พุทเสียงที่ตัวสร้างเสียงปี๊บของคอมพิวเตอร์ส่วนบุคคลได้
-L | ภาษาของโปรแกรมประยุกต์ Tech2Win หากรายการนี้ขาดหายไป ภาษาที่ใช้งานอยู่ของ Windows จะถูกใช้เป็นค่าเริ่มต้น ดูรายการภาษาที่สามารถกำหนดได้จากลิงค์ต่อไปนี้ : ภาษา หน้าต่างจำลอง Tech2 จะแสดงภาษาใดก็ตามในการ์ด PCMCIA (กล่าวคือ ภาษาที่ถูกดาวน์โหลดลงไปยังการ์ด PCMCIA)
-UD | เข้าควบคุมไดเรกทอรีข้อมูลผู้ใช้ ใน Win7 ตามปกติจะอยู่ที่ C:\Users\Public\General Motors\Tech2Win
-AD | เข้าควบคุมไดเรกทอรีข้อมูลโปรแกรมประยุกต์ ใน Win7 ตามปกติจะอยู่ที่ C:\ProgramData\General Motors\Tech2Win
-US | ใช้เอกลักษณ์เฉพาะตัวผู้ใช้ในการตรวจหาอินสแตนซ์ของ Tech2Win ที่มากกว่าหนึ่ง ตัวเลือกนี้จะอนุญาตให้ผู้ใช้แต่ละคนเปิดใช้งาน Tech2Win พร้อมกันในเครื่องเดียวกัน เหมือนกับว่าเป็นเซิร์ฟเวอร์ได้ เมื่อใช้ตัวเลือกนี้ คุณควรระบุตัวเลือก -UD และ -AD ด้วย
-SS | ตัวเลือกในการระบุขนาดทั้งหมดของหน้าต่าง Tech2Win รวมถึงแผงปุ่มกด (ถ้ามี) ด้วย พารามิเตอร์แรกต้องเป็นตัวอักษรที่ปิดด้วยเครื่องหมายอัญประกาศ (') และจะถูกใช้เป็นชื่อของขนาดในเมนู ตัวเลือก / ความละเอียด พารามิเตอร์ที่สองคือตัวจำนวนรวมของพิกเซลแนวนอนของหน้าจอ Tech2Win รวมกับแผงปุ่มกด พารามิเตอร์ที่สามคือจำนวนรวมของพิกเซลแนวตั้งของหน้าจอ Tech2Win พารามิเตอร์ที่สี่ (ตัวเลือก) คือความกว้างของแผงปุ่มกดในหน่วยพิกเซล
-SH ตัวเลือกในการควบคุมการจัดการหน้าจอ ตัวเลขทศนิยมต่อไปนี้จะใช้เพื่อระบุว่าจะปิดใช้งานความสามารถในการจัดการหน้าจอใด
  • บิต 0: ไม่สามารถมีค่าต่ำสุด/สูงสุด
  • บิต 1: ไม่มีการจัดตำแหน่งใหม่บนหน้าจอ
  • บิต 2: ไม่มีการปรับขนาด ในกรณีนี้ เมนู ตัวเลือก / ความละเอียด จะกลายเป็นสีเทา
  • บิต 3: หน้าต่าง Data Display และหน้าต่าง DTC จะมีขนาดเดียวกับ Tech2Win (ไม่รวมแผงปุ่มกด) พอดี


การบันทึก

ทุกครั้งที่เริ่มใช้งานการกำหนดค่า Tech2Win จะมีการสร้างแฟ้มบันทึกใหม่ในรูปแบบ HTML ในไดเรกทอรีย่อย C:\Users\Public\General Motors\Tech2Win\Logs เพื่อหลีกเลี่ยงความแออัดของฮาร์ดดิสก์ แฟ้มบันทึกที่เก่ากว่าหนึ่งสัปดาห์จะถูกลบทิ้ง

แฟ้มบันทึกจะถูกตั้งชื่อตามวันที่ (year, month, day) และเวลา (hour, minute, second) ที่สร้างโดยอัตโนมัติ:
yyyy-mm-dd_hhmmss.html

รายการแฟ้มบันทึกจะเป็นภาษาอังกฤษเสมอ แต่เป็นรูปแบบ Unicode ที่มี Byte-Order-Mark (BOM) เป็นส่วนนำ แต่ละบรรทัดในแฟ้มบันทึกเป็นของระดับรายการบันทึกระดับใดระดับหนึ่งต่อไปนี้:

ระดับรายการบันทึก | ความหมาย
ข้อมูล | ข้อมูลอย่างเดียว ไม่มีผลต่อการเรียกใช้งานโปรแกรม
คำเตือน | เกิดสถานการณ์ผิดปกติขึ้น ผู้ใช้อาจมองไม่เห็นผลทางลบใดๆ
ERROR | มีข้อผิดพลาดเกิดขึ้น โดยผู้ใช้จะสามารถสังเกตเห็นได้
CRITICAL | มีข้อผิดพลาดร้ายแรงเกิดขึ้น ซึ่งจะทำให้โปรแกรมทำงานผิดปกติ
FATAL | ข้อผิดพลาดร้ายแรงจะทำให้ Tech2Win หยุดการทำงานทันที

ทุกระดับเหนือ 'คำเตือน' จะมีสี ทำให้สามารถหาได้โดยง่าย

นอกจากนี้ แฟ้มพิมพ์และวิดีโอจะปรากฏในไดเรกทอรีย่อย Logs ด้วย หากมีการใช้งานตัวเลือกเมนู พิมพ์หน้าจอ หรือ จับภาพหน้าจออัตโนมัติ
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
แฟ้ม HTML จะทำลิงค์เชื่อมโยงไปยังภาพ จับภาพหน้าจออัตโนมัติ เพื่อให้สามารถใช้บันทึก HTML เพื่อดูลำดับของภาพเหล่านี้

ในแถบสถานะ ผู้ใช้จะได้รับแจ้งว่ามีรายการเตือน ( yellow lightning bolt) หรือรายการบันทึกที่ร้ายแรงกว่า ( red lightning bolt) อยู่หรือไม่


ข้อความแจ้งข้อผิดพลาดและรหัสออก

ข้อความแจ้งข้อผิดพลาดอาจปรากฏขึ้นในกล่องโต้ตอบ กล่องโต้ตอบเหล่านี้ยังคงอนุญาตให้ Tech2Win ใช้งานโปรแกรม Tech2 ควบคู่กันต่อไปได้ รหัสออกเป็นข้อผิดพลาดร้ายแรงที่ทำให้ Tech2Win หยุดทำงานอย่างผิดปกติ สามารถใช้รหัสออกในโปรแกรมชุดคำสั่งเพื่อตรวจหาว่าทำไมโปรแกรมจึงหยุดทำงาน

ข้อความแจ้งข้อผิดพลาด

ข้อความแจ้งข้อผิดพลาดต่อไปนี้อาจเด้งขึ้นมา นี่เป็นคำอธิบายอย่างย่อเกี่ยวกับสถานการณ์และวิธีที่สามารถแก้ไขปัญหาได้

Emulator too slow Emulator failed to start

รหัสออก

รหัสออก | ค่า | ความหมาย
OPCODE_ERROR | -7 | ตรวจพบคำสั่งที่ใช้ไม่ได้ของไมโครโปรเซสเซอร์ Tech2 (68332) รูป PCMCIA อาจเสียหายด้วยเหตุใดเหตุหนึ่ง
ATA_PROBLEM | -6 | เกิดปัญหาในระหว่างการจำลอง ATA หากคุณพบปัญหาเช่นนี้หลังจากได้รับคำแนะนำให้ใช้การ์ด ATA โปรดติดต่อแผนกช่วยเหลือ
DEMO_TIME_IS_UP | -5 | ไม่ควรปรากฏขึ้นใน Tech2Win รุ่นเป็นทางการ
DLL_NOT_LOADED | -3 | ไม่สามารถโหลดแฟ้ม DLL ที่จำเป็นแฟ้มใดแฟ้มหนึ่งได้ ดูเหมือนว่าคุณมี Tech2Win ฉบับที่ไม่สมบูรณ์ โปรดทำการติดตั้งใหม่และ/หรือเลือกภาษาอื่น
EXIT_INIT_FAILED | -2 | การเริ่มต้นใช้งานล้มเหลว ตรวจดูแฟ้มบันทึกเพื่อค้นหาสาเหตุที่แท้จริง หากไม่มีแฟ้มบันทึกอยู่ โปรดตรวจสอบว่าคุณมีสิทธิ์เข้่าใช้งานเพื่ออ่าน/เขียนไดเรกทอรีทั้งหมดอย่างถูกต้องหรือไม่
ปกติ | 0 | Tech2Win ได้หยุดการทำงานตามปกติ


การ์ด ATA

โดยทั่วไป จะใช้การ์ด ATA ใน Tech2 เพื่อทำการดีบักในระหว่างการพัฒนาซอฟต์แวร์เท่านั้น ข้อมูล ATA ที่จำเป็นทั้งหมดจะถูกเก็บไว้ในไดเรกทอรีย่อย C:\Users\Public\General Motors\Tech2Win\ataCapture ตามปกติ ไดเรกทอรีนี้ไม่มีความสำคัญและสามารถลบออกได้อย่างปลอดภัย เว้นแต่จะมีการแนะนำไว้เป็นพิเศษ

เนื่องจากไดเรกทอรี ataCapture ถูกคงค่าไว้ เนื้อหาในนั้นจึงเหมือนกันสำหรับการกำหนดค่าทั้งหมด


แฟ้ม

Tech2Win จะใช้งานแฟ้มและไดเรกทอรีต่อไปนี้

ไดเรกทอรี | ตำแหน่งสำหรับรุ่นก่อน Vista | ตำแหน่งสำหรับ Vista และรุ่นสูงขึ้นไป
การติดตั้ง | ตามที่กำหนดไว้ในระหว่างติดตั้ง
ข้อมูลผู้ใช้ | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
ข้อมูลโปรแกรมประยุกต์ | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

แฟ้มข้อมูล | ใช้งาน
[ข้อมูลผู้ใช้]\atacapture | มีแฟ้มที่มีอยู่ในการ์ด ATA แฟ้มเหล่านี้ไม่จำเป็น เว้นแต่จะได้รับคำแนะนำเป็นอย่างอื่น
[การติดตั้ง]\bin | มีแฟ้ม DLL ที่จำเป็นและเรียกใช้งานได้จริง และรูปที่จำเป็นสำหรับการเรียกใช้งาน
[การติดตั้ง]\bin\emulator.exe | การดำเนินการรหัส Tech2 หลักที่สามารถเรียกใช้ได้
[การติดตั้ง]\bin\emulator_xx_XX.dll | DLL ทรัพยากรเฉพาะภาษา
[การติดตั้ง]\bin\T2Configurator.exe | ส่วนกำหนดค่าของ Tech2Win
[การติดตั้ง]\bin\Pictures | มีไอคอนที่ Tech2Win ต้องใช้
[ข้อมูลผู้ใช้]\config | มีแฟ้มการกำหนดค่าทั้งหมด
[ข้อมูลผู้ใช้]\data | มีแฟ้มที่ถูกแก้ไขในระหว่างการเรียกใช้งาน Tech2Win จำเป็นต้องใช้แฟ้มเหล่านี้เพื่อให้สามารถเรียกใช้งาน Tech2Win ได้อย่างถูกต้อง ตามปกติ คุณไม่ควรแตะต้องแฟ้มเหล่านี้ เว้นแต่จะได้รับคำแนะนำอย่างชัดเจนให้ทำเช่นนั้น
[ข้อมูลโปรแกรมประยุกต์]\data | มีแฟ้มที่ถูกแก้ไขในระหว่างการเรียกใช้งาน Tech2Win จำเป็นต้องใช้แฟ้มเหล่านี้เพื่อให้สามารถเรียกใช้งาน Tech2Win ได้อย่างถูกต้อง ตามปกติ คุณไม่ควรแตะต้องแฟ้มเหล่านี้ เว้นแต่จะได้รับคำแนะนำอย่างชัดเจนให้ทำเช่นนั้น
[ข้อมูลโปรแกรมประยุกต์]\data\emulator.sec | แฟ้มความปลอดภัย . อย่าแก้ไขแฟ้มเหล่านี้
[ข้อมูลโปรแกรมประยุกต์]\data\emulator.card | แฟ้มระบุการ์ด. มีการ์ด PCMCIA ทั้งหมดที่โปรแกรม Tech2Win รู้จัก อย่าแก้ไขแฟ้มเหล่านี้
[ข้อมูลผู้ใช้]\data\emulator.disp | แฟ้มนี้จะเก็บค่าตำแหน่งและขนาดของหน้าจอ Tech2Win ไว้ หากคุณลบแฟ้มนี้ แฟ้มจะถูกสร้างขึ้นใหม่ และหน้าจอ Tech2Win จะเริ่มต้นทำงานที่มุมบนซ้าย โดยมีขนาด 640x480
[ข้อมูลโปรแกรมประยุกต์]\data\emulator.lic | แฟ้มใบอนุญาตให้ใช้งาน. มีข้อมูลเกี่ยวกับระยะเวลาที่ใช้งานได้ของใบอนุญาตให้ใช้งาน อย่าแก้ไขแฟ้มเหล่านี้
[ข้อมูลโปรแกรมประยุกต์]\data\emulator.rtc | แฟ้มนาฬิกาในเวลาจริง. แฟ้มนี้จะใช้เป็นที่เก็บข้อมูลที่พบใน RTC ของ Tech2
[ข้อมูลโปรแกรมประยุกต์]\data\emulator.dta | แฟ้มข้อมูล 'อย่าบอกฉันอีกครั้ง'. แฟ้มเหล่านี้จะเก็บบันทึกรุ่นของซอฟต์แวร์ PCMCIA ที่ไม่ควรแสดงคำเตือนเกี่ยวกับการไม่สามารถทำการทดสอบตนเองซึ่งจำเป็นต้องใช้อแดปเตอร์แบบวนกลับ (อีกต่อไป)
[ข้อมูลโปรแกรมประยุกต์]\data\candi.bin | แฟ้มโปรแกรมประยุกต์ CANdi. เก็บโปรแกรมประยุกต์ของ CANdi ที่แนบมากับ Tech2
[ข้อมูลโปรแกรมประยุกต์]\data\eprom.bin | แฟ้ม EPROM ภายในของ Tech2. มีเนื้อหาเกี่ยวกับหน่วยความจำแฟลชภายในของ Tech2
[การติดตั้ง]\driver | แฟ้มการติดตั้งสำหรับโปรแกรมควบคุมพอร์ต COM เสมือน
[การติดตั้ง]\help\emulator_xx_XX.chm | แฟ้มวิธีใช้เฉพาะภาษา
[ข้อมูลผู้ใช้]\Logs | มีแฟ้มบันทึก แฟ้มที่เก่ากว่าหนึ่งสัปดาห์จะถูกลบออกโดยอัตโนมัติ
[ข้อมูลผู้ใช้]\pcmcia | มีแฟ้มรูป PCMCIA หรืออาจกล่าวได้ว่า แต่ละแฟ้มที่สอดคล้องกับการ์ด PCMCIA ของ Tech2 สามารถบันทึกแฟ้มเหล่านี้ไว้ที่ตำแหน่งต่างๆ ได้ตามต้องการ


การจัดการการกำหนดค่า

แฟ้มการกำหนดค่าจะอยู่ในไดเรกทอรีย่อย C:\Users\Public\General Motors\Tech2Win\config และมีนามสกุล *.conf เสมอ สามารถใช้ Tech2Win เฉพาะเพื่อสร้างแฟ้มการกำหนดค่าใหม่หรือเพื่อแก้ไขแฟ้มการกำหนดค่าที่มีอยู่ ซึ่งไม่ใช่แบบอ่านอย่างเดียว เท่านั้น สำหรับการจัดการแฟ้มการกำหนดค่าอื่นทั้งหมด โปรดใช้ Windows Explorer หรือโปรแกรมจัดการแฟ้มที่คล้ายกัน ซึ่งจะจำเป็นสำหรับกิจกรรมต่อไปนี้:

  • การลบแฟ้มการกำหนดค่า
  • การเปลี่ยนชื่อแฟ้มการกำหนดค่า
  • การเปลี่ยนแอตทริบิวต์ของแฟ้มการกำหนดค่าเป็นแบบอ่านอย่างเดียว

เราขอแนะนำให้คุณใช้แฟ้มการกำหนดค่า default.conf เสมอ ตามปกติแล้ว แฟ้มนี้ควรตั้งค่าแอตทริบิวต์เป็นแบบอ่านอย่างเดียว เพื่อหลีกเลี่ยงการเขียนทับโดยผิดพลาด อย่างไรก็ตาม หากคุณกำลังเปลี่ยนแปลงแฟ้มนี้เพื่อให้ตรงตามความต้องการของคุณ คุณจะต้องลบแอตทริบิวต์แบบอ่านอย่างเดียวนี้ชั่วครู่

รูป PCMCIA อยู่ในไดเรกทอรีย่อย C:\Users\Public\General Motors\Tech2Win\pcmcia แต่ละแฟ้มเหล่านี้สอดคล้องกับการ์ด PCMCIA ซึ่งคุณคุ้นเคยอยู่แล้วตอนใช้งาน Tech2 เมื่อใช้ Tech2Win คุณอาจมีรูปได้หลายรูปตามต้องการ เพียงแค่คัดลอกรูปที่มีอยู่ไปเป็นชื่อแฟ้มใหม่

หากคุณต้องการเรียกใช้การกำหนดค่าอันใดโดยตรงจากเดสก์ท็อป ให้สร้างทางลัดที่เรียกใช้ "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf" โปรแกรมควรถูกเรียกใช้งานจากไดเรกทอรีใช้งานต่อไปนี้: 'C:\Program Files\General Motors\Tech2Win\bin'

จำนวนแฟ้มการกำหนดค่าจะไม่ขึ้นกับจำนวนรูป PCMCIA ที่คุณกำลังใช้งาน คุณสามารถมีแฟ้มการกำหนดค่าหลายแฟ้มโดยใช้รูป PCMCIA เดียวกันได้ ซึ่งเกือบจะจำลองสถานการณ์ในโรงซ่อมที่มีช่างหลายคนใช้ Tech2 เดียวกัน (และการ์ด PCMCIA เดียวกัน) ร่วมกัน

นอกจากนี้ คุณอาจเลือกให้การกำหนดค่าแต่ละรายการใช้รูป PCMCIA ที่กำหนดไว้โดยเฉพาะสำหรับการกำหนดค่านั้นๆ ได้ด้วย ซึ่งจะทำให้การกำหนดค่าแต่ละรายการเป็นอิสระต่อกันและกันมากขึ้น อย่างไรก็ตาม การพยายามอัพเดตรูป PCMCIA แต่ละรายการอาจไม่สามารถยอมรับได้

เมื่อคุณสร้างการกำหนดค่าใหม่โดยคัดลอกค่าที่มีอยู่แล้ว ตัวกำหนดค่าจะแสดงคำเตือน หากไม่มีการเปลี่ยนแปลงรูป PCMCIA ในกรณีดังกล่าวจะมีการกำหนดค่าสองชุดโดยใช้รูป PCMCIA เดียวกัน หากเป็นสิ่งที่คุณต้องการ ก็เพียงแค่กด OK หากคุณต้องการให้การกำหนดค่าใหม่ใช้รูป PCMCIA อื่นหรืออันใหม่ ให้คลิกที่ ยกเลิก จากนั้น คุณอาจเลือกสร้างอิมเมจใหม่โดยใช้ คัดลอกการ์ดหน่วยความจำ ...

นี่เป็นวิธีที่ยกเป็นตัวอย่างสองวิธีที่คุณสามารถใช้เพื่อจัดการการกำหนดค่าและรูป PCMCIA ของคุณได้

การกำหนดค่าหนึ่งรายการต่อผู้ใช้หนึ่งคน

คุณมีโอกาสในการบันทึกการกำหนดค่าของผู้ใช้แต่ละราย ชื่อของการกำหนดค่าจะเป็นชื่อผู้ใช้ เป็นต้น ข้อดีของแนวคิดนี้คือสามารถทำการตั้งค่าเฉพาะตัวของผู้ใช้ เช่น อินเตอร์เฟซการสื่อสารกับรถ (MDIs) ส่วนบุคคล, การตั้งค่าการแสดงผล และภาษาได้ ข้อเสียคือคุณจำเป็นต้องคัดลอกแฟ้ม PCMCIA หากมีผู้ใช้หลายคนใช้งานซอฟต์แวร์เดียวกัน แน่นอนว่าการกำหนดค่าจำเพาะของผู้ใช้อาจใช้แฟ้ม PCMCIA ส่วนกลางได้

การกำหนดค่าหนึ่งรายการต่อซอฟต์แวร์ Tech2 หนึ่งรายการ

คุณอาจเลือกสร้างแฟ้มการกำหนดค่าใหม่สำหรับทุกซอฟต์แวร์ที่คุณดาวน์โหลด ด้วยเหตุนี้ แม้จะเป็นซอฟต์แวร์รุ่นเก่ากว่า ก็จะมีให้ทันที หากต้องการ บ่อยครั้งที่มีการเลือกชื่อของซอฟต์แวร์และหมายเลขรุ่นเป็นชื่อแฟ้มการกำหนดค่าในกรณีดังกล่าว

  • ขั้นตอนแรก: อินเตอร์เฟซการสื่อสารกับรถ
  • ขั้นตอนแรก: เส้นทาง
  • หัวข้อเชิงลึก: แฟ้มการกำหนดค่า
  • การติดตั้ง: ขั้นตอนการติดตั้ง


คำถามที่ถามบ่อย (FAQ)

  • ฉันจะสามารถหาว่าควรใช้พอร์ต COM ใดสำหรับ Tech2Win ได้อย่างไร?
  • การสื่อสารระหว่าง Tech2Win และ TIS2Web
  • ใบอนุญาตที่ใช้งานได้
  • หมายเลขใบอนุญาตให้ใช้งานบ่งบอกถึงอะไร?
  • อะไรคือความแตกต่างระหว่างใบอนุญาตให้ใช้งาน Tech2Win กับการเข้าถึงด้านความปลอดภัย?
  • TIS2Web แสดงข้อผิดพลาดที่ไม่ระบุ เมื่อทำการเข้าถึงด้านความปลอดภัยของซอฟต์แวร์เริ่มต้น
  • Tech2Win ไม่เรียกใช้งานซอฟต์แวร์ Tech2 จากอีกบริเวณหนึ่ง
  • ฉันจะสามารถใช้งาน MDI ได้มากกว่าหนึ่งอันได้อย่างไร?
  • แฟ้มบันทึกมีข้อผิดพลาด 'CPU32: Too many 0000/FFFF Commands encountered'
  • มองไม่เห็นหน้าต่าง Tech2
  • SPS ไม่ทำงาน
  • การทำงานทดสอบตัวเองบางอย่างไม่ทำงาน
  • ตัวแจ้งเตือนความเร็วมีค่าแกว่งไปมา
  • หยุดทำงานฉับพลัน
  • แสดงภาษาสวีเดนสำหรับซอฟต์แวร์ 15.001
  • ขาดการติดต่อกับ MDI
  • Tech2Win ไม่พบ MDI ของฉัน
  • ฉันต้องการเริ่มใช้งาน Tech2Win ทันทีโดยไม่สนใจตัวกำหนดค่า
  • การทำงานพิมพ์อยู่ตรงไหน?
  • โฟลเดอร์ PCMCIA 'ที่ไม่ใช้งาน' อยู่ใน my computer
  • ฉันได้รับข้อความ 'illegal file path' (เส้นทางแฟ้มผิดรูปแบบ)

ฉันจะสามารถหาว่าควรใช้พอร์ต COM ใดสำหรับ Tech2Win ได้อย่างไร?

คุณสามารถใช้ 'Device Manager' ของ Windows แล้วมองหา 'Ports (COM & LPT)' แต่คอมพิวเตอร์บางเครื่องมีโมเด็มภายใน หรืออุปกรณ์บลูทูธติดตั้งไว้ ซึ่งจะไม่แสดงขึ้นภายในหมวดหมู่นี้
อีกวิธีหนึ่งคือใช้คำสั่งขนาดเล็กที่ส่งมาพร้อมกับตัวกำหนดค่า คุณสามารถเรียกใช้ผ่านทางเมนูเริ่มต้น (โฟลเดอร์ Tech2Win) โดยคลิกที่ 'show com ports'
ทั้งสองวิธีแสดงพอร์ต COM ที่ติดตั้งไว้ในคอมพิวเตอร์ของคุณและ คุณ ไม่ ควรใช้งาน

การสื่อสารระหว่าง Tech2Win และ TIS2Web

เป็นสิ่งสำคัญที่จะต้องเปิดใช้ Tech2Win ก่อนที่คุณจะเริ่มการสื่อสารกับ TIS2Web สำหรับ 'การผ่านเข้าระบบนิรภัย (ระบบนิรภัย)' หรือ 'ดาวน์โหลดซอฟต์แวร์ (SWDL)' TIS2Web จะสามารถทำความรู้จักกับพอร์ต COM เสมือน เมื่อเริ่มใช้งาน Tech2Win แล้วเท่านั้น

ใบอนุญาตที่ใช้งานได้

ตามปกติ 'ดาวน์โหลดซอฟต์แวร์ (SWDL)' จาก TIS2Web จะมีใบอนุญาตให้ใช้งานที่ใช้ได้มาให้อยู่แล้ว หากคุณยังคงไม่มีใบอนุญาตให้ใช้งาน ต้องทำการ 'การผ่านเข้าระบบนิรภัย (ระบบนิรภัย)' ผ่านทาง TIS2Web (ยกเว้น TIS2000) เพื่อรับใบอนุญาตให้ใช้งานที่ใช้ได้ ก่อนรับใบอนุญาตให้ใช้งานผ่านทาง 'การผ่านเข้าระบบนิรภัย (ระบบนิรภัย)' โปรดอย่าดำเนินการสื่อสารของ TIS2Web อื่นใดกับ Tech2Win เช่น 'ดาวน์โหลดซอฟต์แวร์ (SWDL)'

หมายเลขใบอนุญาตให้ใช้งานบ่งบอกถึงอะไร?

หมายเลขใบอนุญาตให้ใช้งานทางด้านขวาของแถบสถานะ แสดงจำนวนวันที่ใช้งานใบอนุญาตไปแล้ว หลังจากดาวน์โหลดหรือ 'การผ่านเข้าระบบนิรภัย (ระบบนิรภัย)' จำนวน 30 วัน จะปรากฏขึ้นทันที อย่างไรก็ตาม หลังจากการเริ่มใช้งาน Tech2Win ใหม่ จะแสดงเป็น 29 วัน เพราะบางครั้งอายุใบอนุญาตอาจจะเหลือ เช่น 29 วัน, 23 ชั่วโมง กับ 55 นาที หากจำนวนวันของใบอนุญาตให้ใช้งานลดลงต่ำกว่า 24 ชั่วโมง จะแสดงอายุใบอนุญาตให้ใช้งานเป็น <1 ตัวเลข 0 จะแสดงเมื่อใบอนุญาตให้ใช้งานหมดอายุ

อะไรคือความแตกต่างระหว่างใบอนุญาตให้ใช้งาน Tech2Win กับการเข้าถึงด้านความปลอดภัย?

ใบอนุญาตให้ใช้งาน Tech2Win จะช่วยให้คุณสามารถใช้งาน Tech2Win ได้ ในการรับใบอนุญาตให้ใช้งาน คุณต้องทำการ 'ดาวน์โหลดซอฟต์แวร์ (SWDL)' หรือ 'การผ่านเข้าระบบนิรภัย (ระบบนิรภัย)' ตามกำหนดเวลาอย่างสม่ำเสมอ (โดยทั่วไป: ทุก 30 วัน) ความสามารถในการดำเนินการ เช่น การดาวน์โหลดผ่านทาง TIS2Web จะแจ้ง Tech2Win ว่ามีผู้ใช้ที่ใช้งานได้อยู่ การเข้าถึงด้านความปลอดภัย (ตามที่ทราบจาก Tech2) จะแจ้งให้ Tech2Win ทราบว่ามีกิจกรรมที่เกี่ยวข้องกับความปลอดภัยบางอย่าง เช่น มีการอนุญาตให้ปิดใช้งานถุงลมนิรภัยได้ ทั้งใบอนุญาตให้ใช้งาน Tech2Win และการเข้าถึงด้านความปลอดภัยสามารถดำเนินการผ่านทางโปรแกรมประยุกต์ TIS2Web 'การผ่านเข้าระบบนิรภัย (ระบบนิรภัย)' Tech2Win จะแสดงระยะเวลาของใบอนุญาตให้ใช้งานที่เหลืออยู่บนแถบสถานะทางด้านขวา โชคไม่ดีที Tech2Win ไม่สามารถแสดงระยะเวลาของการเข้าถึงด้านความปลอดภัย เนื่องจาก Tech2Win เพียงแค่เรียกใช้ซอฟต์แวร์ Tech2 เท่านั้น แต่ไม่มีความเข้าใจซอฟต์แวร์ Tech2 โดยตรง

TIS2Web แสดงข้อผิดพลาดที่ไม่ระบุ เมื่อทำการเข้าถึงด้านความปลอดภัยของซอฟต์แวร์เริ่มต้น

อาการเป็นแบบเดียวกันกับใน Tech2 ซอฟต์แวร์เริ่มต้นไม่สามารถรับใบอนุญาตให้ใช้งานจาก TIS2Web ได้ เนื่องจากอายุการใช้งาน อย่างไรก็ตาม นั่นไปไม่ใช่ปัญหาจริงเนื่องจากซอฟต์แวร์สาธิตไม่สื่อสารกับรถซึ่งจำเป็นต้องใช้ใบอนุญาตให้ใช้งาน และเนื่องจากใบอนุญาตให้ใช้งานจำเพาะต่อการดาวน์โหลดจาก TS2Web คุณจึงจำเป็นต้องรับใบอนุญาตให้ใช้งานสำหรับการดาวน์โหลดแต่ละครั้ง หลังจากดาวน์โหลดซอฟต์แวร์ Tech2 'ใบอนุญาตให้ใช้งาน' สำหรับซอฟต์แวร์เริ่มต้นจะไม่ให้สิทธิ์คุณทำการสื่อสารกับรถด้วยซอฟต์แวร์ North American Operations หรือ Opel/Vauxhall

Tech2Win ไม่เรียกใช้งานซอฟต์แวร์ Tech2 จากอีกบริเวณหนึ่ง

รุ่น Tech2Win ของคุณอาจถูกจำกัดไว้ที่หนึ่งการดาวน์โหลด (ภูมิภาค) จาก TIS2Web หรือหลายครั้ง กด วิธีใช้ / เกี่ยวกับ เพื่อดูว่ามีข้อจำกัดใดที่ใช้กับรุ่น Tech2Win ของท่าน Tech2Win รุ่นก่อนๆ อนุญาตให้เรียกใช้งานได้เพียงซอฟต์แวร์ Opel/Vauxhall เท่านั้น ภูมิภาค GM อื่นๆ ก็ดำเนินการแบบเดียวกัน ไม่ว่าในกรณีใดก็ตาม ขณะนี้ Tech2Win สามารถเรียกใช้งานซอฟต์แวร์ Tech2 จาก General Motors ได้

ฉันจะสามารถใช้งาน MDI ได้มากกว่าหนึ่งอันได้อย่างไร?

หากคุณต้องการกำหนด MDIs เฉพาะอันให้กับผู้ใช้เฉพาะคน เราเสนอให้คุณอนุญาตให้ผู้ใช้ทุกคนมีการกำหนดค่าของตนเอง แน่นอนว่า ควรตั้งชื่อการกำหนดค่าเหล่านี้ตามชื่อผู้ใช้ที่เกี่ยวข้อง ในแต่ละการกำหนดค่า คุณควรป้อนหมายเลขประจำเครื่องของ MDI จำเพาะของผู้ใช้ในแท็บ 'อินเตอร์เฟซการสื่อสารกับรถ' ทันทีที่ผู้ใช้เริ่มการกำหนดค่าของตนเอง Tech2Win จะพยายามติดต่อกับ MDI เฉพาะอัน แม้ว่าจะไม่มี MDI ปรากฏอยู่ กล่องเลือกก็จะปรากฏขึ้นเพื่อแสดง MDI ทั้งหมดที่ Tech2Win เคยพบ

หากคุณมี MDI หลายอัน สำหรับการใช้งานทั่วไป เราแนะนำให้คุณใช้การกำหนดค่าที่หมายเลขประจำเครื่องของอินเตอร์เฟซการสื่อสารกับรถในแท็บ 'อินเตอร์เฟซการสื่อสารกับรถ' ถูกเว้นว่างไว้ หลังจากนั้นผู้ใช้จะมองเห็น MDI ที่มีให้ในกล่องเลือกเสมอ

แฟ้มบันทึกมีข้อผิดพลาด 'CPU32: Too many 0000/FFFF Commands encountered'

แฟ้ม 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' หรือแฟ้ม PCMCIA ปัจจุบันขัดข้อง โปรดทำการติดตั้ง Tech2Win อีกครั้ง แล้วดาวน์โหลดซอฟต์แวร์ Tech2 ใหม่

มองไม่เห็นหน้าต่าง Tech2

หากมองไม่เห็นหน้าต่าง Tech2 มันอาจอยู่ในบริเวณที่ยังไม่ปรากฏบนหน้าจอของคุณ คุณจะพบกับอาการแบบนั้นเมื่อใช้งานมากกว่าหนึ่งหน้าจอ หรือหลังจากแก้ไขค่าความละเอียดของหน้าจอ กดแป้น Shift บนแป้นพิมพ์ในระหว่างเริ่มการกำหนดค่าของคุณ ในกรณีนั้น ความละเอียดของหน้าต่างจะถูกรีเซตให้เป็น 640x480 และหน้าต่าง Tech2 จะปรากฏขึ้นที่มุมบนซ้ายของหน้าจอ คุณอาจลบแฟ้ม C:\Users\Public\General Motors\Tech2Win\emulator.disp ออกด้วย เพื่อให้ได้ผลเหมือนกัน

เราได้พบกรณีที่หน้าต่าง Tech2 ไม่ถูกวาดใหม่บนหน้าจอหลังจากปิดหน้าต่างของโปรแกรมประยุกต์อื่นทั้งหมดแล้ว ในทุกกรณีที่เราได้พบ การใช้งานแป้น Alt-Tab เพื่อสลับระหว่างโปรแกรมประยุกต์ของ Windows สามารถเรียกหน้าจอ Tech2 ขึ้นมาได้ การกดปุ่ม Tech2Win ในทาสก์บาร์ที่ด้านล่างของหน้าจอคอมพิวเตอร์บางครั้งจะใช้ไม่ได้ผล ปัจจุบัน เรายังคงตรวจสอบปัญหานี้และหวังว่าจะสามารถแก้ไขได้ใน Tech2Win รุ่นใหม่

SPS ไม่ทำงาน

ใช่ เราทราบ เราไม่มีแผนในการเปลี่ยนแปลงใดๆ ในส่วนนี้ คุณไม่ควรใช้งาน Tech2Win เพื่อใช้แทน Tech2 ในการทำ SPS โปรดใช้ MDI โดยตรงพร้อมกับการตั้งโปรแกรม SPS ผ่านทาง TIS

การทำงานทดสอบตัวเองบางอย่างไม่ทำงาน

การทดสอบตนเองของ Tech2 มีไว้เพื่อทดสอบแต่ละส่วนของฮาร์ดแวร์ Tech2 การทดสอบเหล่านี้บางอย่างจำเป็นต้องใช้อแดปเตอร์แบบวนกลับ การทดสอบเหล่านี้จะไม่ทำงานใน Tech2Win เพราะใช้ระบบการทำงานอแดปเตอร์แบบวนกลับไม่ได้ (และไม่มีแผนให้ทำเช่นนั้นได้) โปรดละเว้นการดำเนินการทดสอบที่ไร้ความหมายแบบนั้นใน Tech2Win หากคุณดำเนินการทดสอบ ก็อาจได้รับผลที่ผิดพลาดหรือ Tech2Win ค้าง เนื่องจาก Tech2 ไม่มีอแดปเตอร์แบบวนกลับ ในกรณีดังกล่าว ให้ใช้ Ctrl-R เพื่อรีเซต Tech2Win

ตัวแจ้งเตือนความเร็วมีค่าแกว่งไปมา

ตัวแจ้งเตือนความเร็วทางด้านล่างซ้ายของตัวแจ้งเตือนในแถบสถานะระบุจำนวน 'คำสั่ง Tech2' ที่สามารถเรียกใช้ได้ ก่อนที่จะต้อง 'พักการใช้งาน' Tech2Win อีกครั้ง วิธีนี้ใช้เพื่อให้แน่ใจว่าเวลาบน Tech2Win ตรงกับเวลาจริง: คอมพิวเตอร์ส่วนบุคคลที่เร็วกว่าพักการใช้งานมากกว่าคอมพิวเตอร์ส่วนบุคคลที่ช้ากว่า หากตัวแจ้งเตือนความเร็วมีค่าแกว่งไปมา โปรแกรมประยุกต์อื่นบางโปรแกรมอาจใช้กำลังในการประมวลผลอยู่ หรือนาฬิกาของเครื่องคอมพิวเตอร์ส่วนบุคคลเปลี่ยนค่าไป อัตราการแกว่งค่าที่สูงมีผลลบต่อการสื่อสารกับรถ และการสื่อสารกับ TIS2Web โปรดตรวจสอบให้แน่ใจว่าไม่มีโปรแกรมประยุกต์อื่นกำลังทำงานอยู่

แล็ปท็อปส่วนใหญ่สามารถลดความเร็วนาฬิกา CPU ได้โดยอัตโนมัติ เพื่อยืดอายุการใช้งานแบตเตอรี่ นี่ก็อาจเป็นอีกหนึ่งสาเหตุของความเร็วที่แกว่งค่าไปมาซึ่งตรวจพบได้โดย Tech2Win เช่นกัน ในกรณีดังกล่าว โปรดอย่าใช้งานแล็ปท็อปจากแบตเตอรี่ แต่ให้ใช้แหล่งจ่ายไฟจากภายนอกแทน คุณอาจลองเปลี่ยนการตั้งค่าการใช้ไฟฟ้าของคุณเอง เพื่อให้ระบบปฏิบัติการไม่ลดความเร็วนาฬิกา

หยุดทำงานฉับพลัน

หากคุณไม่พบสาเหตุในแฟ้มบันทึกว่าทำไมโปรแกรมจึงหยุดทำงานแล้ว อาจเป็นเพราะว่ากลไกนิรภัยภายในของ Tech2Win ถูกเปิดใช้งาน โปรดอย่าแก้ไขข้อมูลโดยประสงค์ร้ายกับแฟ้มต่อไปนี้ : emulator.sec, emulator.lic, emulator.card หาก Tech2Win ตรวจพบการเจาะระบบความปลอดภัย มีความเป็นไปได้สูงว่าคุณจะต้องทำการติดตั้งอีกครั้ง

แสดงภาษาสวีเดนสำหรับซอฟต์แวร์ 15.001

ซอฟต์แวร์เริ่มต้นที่มีมากับ Tech2Win คือซอฟต์แวร์สาธิตซึ่งมีอยู่ในการ์ด PCMCIA ใหม่ทุกชิ้น TIS2Web จะแจ้งว่านี่เป็นภาษาสวีเดนเพราะ TIS2Web จะแสดงเฉพาะภาษาล่าสุดในรายการสี่ภาษาที่รองรับโดยซอฟต์แวร์สาธิตนี้ (อังกฤษ, ฝรั่งเศส, เยอรมัน, สวีเดน) ตั้งค่าโหมดอัพเดตเป็น 'เฉพาะที่' แทน 'มาตรฐาน' เพื่อเขียนทับซอฟต์แวร์สาธิตการใช้งานนี้ด้วยซอฟต์แวร์การวินิจฉัยที่ใหม่ที่สุด

ขาดการติดต่อกับ MDI

การขาดการติดต่อกับ MDI อาจเกิดจากหลายสาเหตุ

  • การต่อสายที่ไม่ดี (ทั้งอีเทอร์เน็ต และ USB)
  • การเชื่อมต่อแบบไร้สายสะดุด
  • เครื่องคอมพิวเตอร์ส่วนบุคคลอยู่ในโหมดหยุดรอ

Tech2Win ไม่พบ MDI ของฉัน

โปรดตรวจสอบประเด็นต่อไปนี้:

    1. MDI ทำงานอยู่หรือไม่?
    2. ตัวจัดการ MDI ทำงานหรือไม่?
    3. MDI กำลังถูกใช้งานโดยอีกโปรแกรมประยุกต์หนึ่ง เช่น SPS หรือไม่?
คุณสามารถเริ่มใช้ตัวจัดการ MDI ได้โดยใช้ไอคอนบนเดสก์ท็อปหรือผ่านทาง 'Start/All Programs/General Motors/GM MDI Software': โปรดติดต่อแผนกช่วยเหลือ หากประเด็น 2 ใช้งานไม่ได้

ฉันต้องการเริ่มใช้งาน Tech2Win ทันทีโดยไม่สนใจตัวกำหนดค่า

ดำเนินการ "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf" ใช้ไดเรกทอรีใช้งานต่อไปนี้: 'C:\Program Files\General Motors\Tech2Win\bin' คุณยังคงสามารถใช้ตัวกำหนดค่าเพื่อทำการเปลี่ยนใดๆ ไปยังการกำหนดค่า

การทำงานพิมพ์อยู่ตรงไหน?

Tech2Win ไม่เสนอระบบการทำงานพิมพ์โดยตรง แต่จะสร้างแฟ้มชั่วคราวและเรียกใช้โปรแกรมที่เกี่ยวข้องกับนามสกุลของแฟ้มแทน สามารถใช้โปรแกรมเหล่านี้สำหรับพิมพ์ได้ ซึ่งทำให้คุณสามารถปรับลักษณะต่างๆ ของงานที่พิมพ์ออกมาได้

Print Report | Print Report

ในการพิมพ์หน้าจอ Tech2Win ให้ใช้รายการเมนู แฟ้มข้อมูล / พิมพ์หน้าจอ หรือปุ่มบนแผงปุ่มกดที่มีรูปเครื่องพิมพ์ปรากฏอยู่ หากคุณต้องการพิมพ์หน้าจอ Tech2Win หลายรูป อาจใช้รายการเมนู ตัวเลือก / จับภาพหน้าจออัตโนมัติ ในการสร้างแฟ้ม PNG สำหรับทุกหน้าจอ Tech2Win แฟ้ม PNG เหล่านี้ถูกฝังไว้ในแฟ้มบันทึก

คุณอาจพิมพ์เนื้อหาการแสดงผลข้อมูลได้ด้วย (เปิดใช้โดยใช้รายการเมนู Windows / ส่วนแสดงข้อมูลของ Tech2Win) ใช้ปุ่ม พิมพ์/เริ่ม HTML เพื่อเริ่มและหยุดการรับข้อมูล หลังจากหยุดการรับข้อมูล แฟ้มซึ่งเกี่ยวข้องกับ HTML ที่เรียกใช้งานได้ (ตามปกติจะใช้ Internet Explorer เปิด) จะถูกเปิดขึ้น ซึ่งมีระบบการทำงานสำหรับพิมพ์ข้อมูลครบถ้วน

Data Display | Data Display

โฟลเดอร์ PCMCIA 'ที่ไม่ใช้งาน' อยู่ใน my computer

Tech2Win รุ่นก่อนมีการจัดเก็บแฟ้ม PCMCIA ที่ซ้ำกันไว้ในไดเรกทอรีแยกกันเสมอ ไดเรกทอรีนี้มักจะเป็น C:\PCMCIA ตอนนี้ ไม่มีการใช้ไดเรกทอรีนี้อีกแล้ว เพราะความสามารถในการดาวน์โหลดจาก TIS2Web ได้อย่างรวดเร็วทำให้ไม่จำเป็นต้องจัดเก็บรายการที่ดาวน์โหลดมาในแห่งที่สอง คุณอาจลบไดเรกทอรีนี้ออกได้อย่างปลอดภัย

ฉันได้รับข้อความ 'illegal file path' (เส้นทางแฟ้มผิดรูปแบบ)

ดูเหมือนว่าชื่อแฟ้มจะมีอักขระที่ผิดรูปแบบ เช่น เครื่องหมายเปอร์เซ็นต์ (%) หากคุณพบปัญหานี้ทันทีหลังจากการติดตั้ง ทางที่ดีที่สุดคือทำการถอนการติดตั้งแล้วทำการติดตั้งอีกครั้ง กรณีส่วนใหญ่สามารถแก้ไขได้โดยใช้วิธีนี้

ในระหว่างการติดตั้งตามปกติ ตัวแปรสภาพแวดล้อม 'Tech2WinUserData' ถูกตั้งค่าเป็น 'PUBLIC' (สำหรับรุ่น Windows >= Vista) และเป็น 'ALLUSERSPROFILE\Documents' (สำหรับรุ่น Windows ก่อน Vista) ในบางกรณีที่เกิดขึ้นได้ยาก ตัวแปรสภาพแวดล้อมไม่ได้ถูกตั้งค่าระหว่างกระบวนการติดตั้ง แต่ใช้งานได้ดีในการลองครั้งที่สอง คุณอาจเลือกตั้งค่าตัวแปรสภาพแวดล้อมด้วยตนเอง หากคุณไม่ทราบวิธีการตั้งค่าตัวแปรสภาพแวดล้อม ให้สอบถามผู้ดูแลระบบของท่านเพื่อขอความช่วยเหลือ


รายการรีจิสทรี

ตัวติดตั้งจะสร้างรายการรีจิสทรีต่อไปนี้ โปรดอย่าแก้ไขรายการเหล่านี้ด้วยตนเอง เมื่อจัดการกับรายการรีจิสทรี ต้องระวังการแจ้งข้อควรระวังมาตรฐานของ Windows

รีจิสทรีคีย์ | ชื่อ | ประเภท | ความหมาย
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | เลขแสดงรุ่นภายใน
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | ภาษา | REG_SZ | ภาษาที่ติดตั้ง
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | เส้นทางของไดเรคทอรีคัดลอก PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | ราก | REG_SZ | เส้นทางการติดตั้ง
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | UninstallOption | REG_DWORD | การตั้งค่าการถอนการติดตั้ง
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | รุ่นของแฟ้มกำหนดค่า
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | รุ่นของโปรแกรมควบคุมพอร์ต COM เสมือน
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | ชื่อซอฟต์แวร์ภายในรายการเพิ่ม/ลบโปรแกรม
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | เส้นทางไปยังโปรแกรมถอนการติดตั้ง


การติดตั้งอีกครั้ง

การติดตั้งอีกครั้งจะลบไดเรกทอรีติดตั้งของ Tech2Win อย่างสมบูรณ์ด้วยข้อยกเว้นต่อไปนี้

  1. ไดเรกทอรีย่อย config ที่มีการกำหนดค่าจะไม่ถูกลบ
  2. ไดเรกทอรีย่อย pcmcia ซึ่งตามปกติจะมีรูป PCMCIA จะไม่ถูกลบ
  3. ไดเรกทอรีย่อย ATA ที่อาจจะมีข้อมูลการดีบักจะไม่ถูกลบ
แฟ้มการกำหนดค่าอาจใช้งานร่วมกันไม่ได้: ไม่มีการรับรองว่า Tech2Win รุ่นที่ใหม่กว่าจะสามารถอ่านแฟ้มการกำหนดค่าของ Tech2Win รุ่นเก่าได้ ตามหลักแล้ว รูป PCMCIA ต้องสามารถใช้งานร่วมกันได้เสมอ

การติดตั้งอีกครั้งจะไมส่งผลใดๆ ต่อไดเรกทอรี PCMCIA

สภาพแวดล้อมบางอย่างอาจเสนอการติดตั้ง Tech2Win รุ่นใหม่กว่าโดยอัตโนมัติ เนื่องจากข้อมูลการติดตั้งล่าสุดถูกเก็บไว้ใน รีจิสทรี การตั้งค่าเหล่านี้จะกลายเป็นค่าเริ่มต้นในระหว่างการติดตั้งอีกครั้ง

คุณสามารถบังคับให้มีการติดตั้ง Tech2Win อีกครั้งโดยใช้สคริปต์ enable reinstallation สคริปต์นี้ถูกติดตั้งร่วมกับ Tech2Win โดยพื้นฐานแล้ว สคริปต์นี้เพียงแค่ตั้งค่าคีย์ CurrentVersion ที่พบในรีจิสทรีที่ HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win ให้เป็นค่า '1.000'