Användarhandbok för Tech2Win

Välkommen till användarhandboken för Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Med ensamrätt.

  • Introduktion:
  • Licens:
  • Installation:En beskrivning av installationsproceduren för Tech2Win.
    • Installationssteg
    • Bilkommunikationsgränssnitt
  • De första stegen
    • Välja en konfiguration
      • Tangentbord
      • Hantering av fönster
    • Nya konfigurationer
    • Ändra konfigurationer
      • Språk (Language)
      • Sökväg
      • Display
      • Spara en konfiguration
    • Skaffa en giltig Tech2Win-licens.
  • Arbeta med Tech2Win: Information för det dagliga arbetet.
    • Meny
    • Ladda ned en PCMCIA-bild
    • Säkerhet
    • Visa rapporter
    • Hantering av PCMCIA-bilder
    • Statusrad
  • Avancerade ämnen: Information som inte krävs för en normal Tech2Win-användare. Vanligen endast intressant för personer med administratörsuppgifter.
    • Ominstallation
    • Avinstallation
    • Format för konfigurationsfilen
    • Loggfil
    • Felmeddelanden och felkoder
    • ATA-kort
    • Registerposter
    • Filer
    • Konfigurationshantering
  • FAQ (vanliga frågor och svar)


Introduktion

Tech2Win är ett Windows-program som kan emulera Tech2-funktionen. I huvudsak körs Tech2-mjukvaran på en dator. För att köra detta program behöver din dator uppfylla följande tekniska krav:

  • Ett fordonskommunikationsgränssnitt måste vara installerat och anslutet till datorn. Listan över godkända gränssnitt kan variera mellan olika regioner. I de flesta fall kan GM:s MDI-gränssnitt (Multiple Diagnostic Interface) användas.
  • Tech2Win-programmet kräver att det finns 150 Mbyte utrymme ledigt på hårddisken under installation. Ytterligare 32 MB behövs per PCMCIA-flashkort du vill hantera.
  • För att starta Tech2Win-programmet behöver du minst 100 MB ledigt fysiskt RAM-minne. Din dator måste ha tillräckligt med minne för att hålla programmet inom RAM-minnet hela exekveringstiden.
  • Din dator ska ha en processor som motsvarar 1,2 GHz Pentium (enkel kärna). Vi rekommenderar starkt att du inte har några andra program öppna samtidigt.
  • Tangentbord behövs inte. Tech2Win går också att använda med pekskärmen. För konfigurationshantering rekommenderar vi dock starkt att du använder ett tangentbord eftersom du behöver ange filnamn.
  • Färgskärmen måste minst ha upplösningen 800 x 600 och minst 256 färger. Utan numeriskt tangentbord kan 640 x 480 vara acceptabelt.

Om du använder Tech2Win (en bärbar dator i stället för en Tech2), se till att datorn har tillräckligt med ström. I vanliga fall drivs inte din bärbara dator av bilbatteriet som Tech2 gör.

  • Installation
  • De första stegen


Licens

General Motors - Tech2Win-licensavtal

Läs noggrant följande villkor innan du använder programmet. Om du inte godkänner eller förstår villkoren, kontakta din lokala eftermarknadsrepresentant. Rätten att använda denna programvara licensieras av General Motors endast under förutsättning att användaren godkänner denna licens genom att acceptera villkoren under installationen av Tech2Win.
General Motors ger exklusivt rätten att använda programvaran Tech2Win och den ingående informationen tillsammans med TIS2Web eller GlobalTIS eller TIS2000 till användare av General Motorss nätverk av auktoriserade verkstäder enligt det lokalt tillämpliga avtalet för auktoriserade verkstäder inom General Motorss nationella säljbolag.
Tech2Win-licensen är giltig så länge som avtalet för auktoriserade verkstäder är gällande och under förutsättning att det finns licenser för TIS2Web, GlobalTIS och TIS2000. Tech2Win-licensen avslutas omedelbart tillsammans med TIS2Web- och GlobalTIS-licensen om Auktoriserad reparatör-avtalet avslutas.

Fristående verkstäder, enligt definitionen i andra stycket av avsnitt 4 i European Union Block Exemption Regulation (BER) 1400/2002, kan köpa en Tech2Win-licens som en del av den prenumeration som tillhandahålls i GM Europe Info Tech Portal från General Motors Europe.

Tech2Win-licensen omfattar inte bilens kommunikationsgränssnitt eller PC-hårdvara.

Programvaran Tech2Win får inte distribueras vidare, säljas eller placeras online för någon tredje part utanför den auktoriserade verkstadens lokaler (enligt beskrivning i gällande bilaga till avtalet för auktoriserade verkstäder) utan skriftligt tillstånd från det aktuella nationella säljbolaget för General Motors. Detta gäller både aktuella och ej aktuella data (som till exempel utgångna DVD-skivor).

Säljbolag inom General Motors ska ha rätten att omedelbart stänga av tillgången och säga upp avtalet för auktoriserade verkstäder med omedelbar verkan vid obehörig användning eller missbruk. I detta fall undantas rätten till återbetalning av återstående belopp och/eller årsavgifter.

Den ingående informationen är avsedd för utförande av fackmannamässig service och reparationsarbete för omodifierade fordon från General Motors. Genomförd utbildning för bilmekaniker och regelbunden vidareutbildning krävs som förutsättning för att utföra nämnda arbete. När användning av specialverktyg anges i den information som tillhandahålls, är dessa specialverktyg obligatoriska för att reparationerna ska anses utförda på fackmannamässigt sätt.

Den information som publiceras i Global TIS av General Motors (text och bilder, musik, grafik, animationer, video osv.) och deras sammanställning i Global TIS är skyddad av copyright. Ingen återgivning, spridning, kommunikation och/eller överföring eller annan användning är tillåten utan föregående skriftligt medgivande från General Motors.

  • Installation: Installationssteg
  • De första stegen


Installation

Installationen av Tech2Win kräver lokala administratörsrättigheter på datorn. Utan administrationsbehörighet fungerar inte installationen. I sådana fall, kontakta din lokala datoradministratör för hjälp.

För att kunna använda Tech2Win på rätt sätt måste du slutföra följande två steg:

  • Installationen av själva Tech2Win.
  • Installation av ett bilkommunikationsgränssnitt.
  • Installation: Installationssteg
  • De första stegen


Installationssteg

Själva installationen tar bara några minuter och kräver följande åtgärd från användaren:

  1. Licensavtal
  2. Installationskatalog

Språk (Language)

Som standard visas Tech2Win UI på operativsystemets språk. I allmänhet stöds språken nedan. Om ditt språk inte stöds startas installationsprogrammet på engelska som standard.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Engelska (antingen brittisk eller amerikansk)*
  • el_GR (EL)Greek
  • es_ES (ES)Spanska
  • fi_FI (FI)Finnish
  • fr_FR (FR)Franska
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugisiska (Brasilien)
  • pt_PT (PT)Portugisiska (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Kinesiska (förenklad)
  • zh_TW (ZH)Kinesiska (traditionell)

* Tech2Win-språket är brittisk engelska. Men Tech2-programvaran och det installationsprogram du använder kan vara på amerikansk engelska, beroende på var programvaran kommer ifrån.

Licensavtal

Du måste acceptera licensavtalet.

Installationskatalog

Du kan välja vilken katalog som helst som den plats där Tech2Win ska installeras. Som standard är installationskatalogen antingen <your program directory>\General Motors\Tech2Win eller, vid ominstallation, den tidigare specificerade platsen.

Slutligen måste du bekräfta installationen.

Drivrutin för virtuell COM-port

Drivrutinen för virtuell COM-port kommer bara att installeras en gång på datorn och finns kvar tills den uppgraderas (detta sker sällan) eller Tech2Win avinstalleras från datorn.
Om drivrutinen installeras kommer du att se ett DOS-fönster en kort stund. Det stängs automatiskt utan att du behöver göra något. Drivrutinsfilerna placeras dessutom i undermappen 'drivrutin' i din installationskatalog för Tech2Win.
Det går att manuellt installera eller avinstallera den drivrutinerna för virtuell COM-port, men vi rekommenderar inte detta. Använd ett av följande kommandon från CMD-gränssnittet:

  • anropa 'vbsetup7' för att installera drivrutinen
  • anropa 'vbsetup7 /u' för att avinstallera drivrutinen
  • De första stegen


Bilkommunikationsgränssnitt

Din fordonskommunikationsanordning måste installeras separat. Se respektive installationsguide som följde med bilkommunikationsgränssnittet.

  • De första stegen: Bilkommunikationsgränssnitt
  • Avancerade ämnen: Konfigurationsfil
  • Installation: Installationssteg
  • FAQ (vanliga frågor och svar): Hur kan jag använda mer än ett MDI?
  • FAQ (vanliga frågor och svar): Tech2Win hittade inte mitt MDI


De första stegen

Dessa första steg visar hur du använder Tech2Win. Vi förutsätter att du redan känner till Tech2. Fordonskommunikation krävs inte i dessa första steg.

För en snabbstart utför du följande steg:

  1. Kör Tech2Win-programvaran med snabbstartsgenvägen på skrivbordet.
  2. Få en giltig licens genom att ladda ned den nya Tech2-programvaran från TIS2Web.

För att använda en valbar konfiguration:

  1. Starta konfiguratorn med Tech2Win-genvägen på skrivbordet. Efter en installation ska en standardkonfiguration finnas.
  2. För att göra en ny konfiguration är det bäst att kopiera standard-konfigurationen.
  3. Modifiera en befintlig konfiguration så att den uppfyller specifika krav.
  4. Skaffa en giltig licens.

Starta inte Tech2Win i ett kompatibilitetsläge. En varning införs i loggfilen i ett sådant fall. Tech2Win använder endast Windows-funktioner som finns sedan XP, och fungerar inte för tidigare Windows-versioner.

  • De första stegen: Nya konfigurationer
  • De första stegen: Ändra konfigurationer
  • De första stegen: Bilkommunikationsgränssnitt
  • Arbeta med Tech2Win: Meny
  • Arbeta med Tech2Win: Säkerhet
  • Arbeta med Tech2Win: Statusrad
  • Avancerade ämnen: Konfigurationsfil


Välja en konfiguration

Första gången du startar Tech2Win-programmet visas följande skärm. Du har möjlighet att starta Tech2Win direkt med en standardkonfiguration. Denna standardkonfiguration arbetar utan någon fordonskommunikation.

Start First Time

Meddelanderutan med licensinformation visas, men du kan bortse från den för att starta standardkonfigurationen.

När du arbetar med en pekskärm kan det vara bra att starta programmet för datortangentbordet för att kunna skriva in bokstäver med hjälp av detta program, som simulerar ett tangentbord.


Tangentbord

Alla datortangenter och knappar, om sådana finns, mappas till de bekanta Tech2-tangenterna. Tech2Win har några extra tangenter som det ursprungliga Tech2 inte har. Det numeriska tangentbordet på datorn fungerar kanske inte under alla förhållanden. Om du får några problem kontrollerar du om standardtangentbordslayouten på datorn har ändrats. I så fall kan särskilt SKIFT-tangenten vara skadad.

Datortangentbord | Knapp | Funktion
Funktionstangent F1 | inte tillämplig | Hjälp för Tech2Win
Funktionsknapparna F5–F8 | Använd det Tech2Win-skärmområde som upptas av softkeys | De fyra funktionstangenterna på Tech2
Markörknapparna upp, ned, vänster, höger |  | Tech2-tangenterna upp, ned, vänster, höger; Endast dessa tangenter har automatisk upprepning.
Tangent 0–9 | F0 • • • F9 | Tech2-tangenter F0–F9
Backsteg | Exit | Avslutningstangent på Tech2
Enter/retur | Enter | Enter-tangent på Tech2
Y | Yes | Ja-tangent på Tech2
N | No | Nej-tangent på Tech2
Q | ? | ?-tangent på Tech2
S | Shift | Skifttangent på Tech2; Skiftindikatorn i statusfältet eller indikatorn ovanför skifttangenten visar statusen.
ctrl-P | PWR | Strömtangent på Tech2; Med denna tangent går det endast att stänga av Tech2Win-programmet.
ctrl-R | inte tillgänglig | Startar om Tech2Win. Liknar en omstartscykel på Tech2. Fast ett tillhörande gränssnitt för bilkommunikation återställs inte. Filer som PCMCIA-bilden läses inte in igen.
Hem | Home | Hemtangent. Stöds endast av vissa program.
endast tillgängligt via menyalternativet Fil. | Print Screen | Skriver ut en skärmdump av Tech2-skärmen genom att skapa en tillfällig BMP-fil och anropa programmet som är kopplat till BMP-filer. Använd det här programmet för att ändra storlek på eller rotera bilden före utskrift.
endast tillgängligt via menyalternativet Fil. | Save Screen | Sparar en skärmbild av Tech2-fönstret som en fil i något av formaten BMP eller PNG.
endast tillgängligt via menyalternativet Fil. | View Report | Visar alla rapporter på det aktiva PCMCIA-flashkortet så att användaren kan visa dem.


Hantering av fönster

Du kan ändra storleken på dina fönster med standardmekanismer i Windows, genom att dra i kanterna på huvudfönstret. Dessutom har menyalternativet Alternativ/Upplösning stöd för flera förinställda storlekar. När huvudfönstrets storlek ändras via ett menyalternativ förblir automatiskt fönstret med det numeriska tangentbordet dockat.

Ändra fönstrets utseende genom att ändra konfigurationen på fliken Display.


Nya konfigurationer

Klicka på knappen Skapa ny för att skapa en ny konfiguration. En dialogmeny visas och du måste välja en befintlig konfigurationsfil som källa. Vanligen väljs standardkonfigurationen. Tryck på knappen Kopiera när du har angett namnet på den nya konfigurationsfilen.

Om du arbetar med en pekskärm kan det vara bra att aktivera en simulering av ett datortangentbord med knappen Datortangentbord.

Med knappen Avbryt avbryter du processen.

Den nya konfigurationen kommer att använda samma PCMCIA-fil som den befintliga källkonfigurationen. Om du vill ändra detta måste du modifiera konfigurationen så att en annan PCMCIA-fil används. I de flesta fall kopierar du bara den befintliga PCMCIA-filen till en ny fil och använder den nya filen. Du kanske föredrar att din nya konfiguration använder samma PCMCIA-fil som din källkonfiguration. I så fall visas en varningsskärm när du trycker på knappen Spara.

  • Ändra konfigurationer


Ändra konfigurationer

Konfigurationer som visas i blått är skrivskyddade och går inte att ändra. Dessa konfigurationer går endast att visa. Du kan förstås använda ändringsmetoden för att helt enkelt visa innehållet, men det går inte att Spara.

Du kan ändra en konfiguration genom att välja de enskilda inställningarna i de fyra tabulatorerna Språk (Language), Bilkommunikationsgränssnitt, Sökväg och Display. Du kan antingen välja önskat fält eller bara trycka på knappen Nästa som aktiverar nästa fält. När du har gjort dina ändringar trycker du på knappen Spara för att spara din konfiguration.

När du behöver använda tangentbordet kan du också anropa ett datorprogram som simulerar ett datortangentbord. Detta är särskilt bekvämt på bärbara datorer med pekskärm, där inget tangentbord finns.


Språk (Language)

Med tabulatorn Språk (Language) kan du välja språk för Tech2Win. Detta val påverkar inte språket i Tech2-mjukvaran på PCMCIA-bilden. När du laddar ned Tech2-mjukvara från TIS måste du fortfarande välja rätt språk.

I vissa regioner finns inte alla språk tillgängliga. I sådana fall kommer engelska att visas. Kontrollera om ett liknande språk finns tillgängligt (PT portugisiska Portugal istället för PB portugisiska Brasilien).


Sökväg

Med tabulatorn Sökväg kan du ange sökvägar till båda PCMCIA-bilderna och sökvägen till mjukvaran för ditt lokala tangentbord. Dessutom finns knappen Kopiera minneskort för att kopiera PCMCIA-bilder. Om du precis har skapat en ny konfiguration kan du använda den här knappen för att undvika att flera konfigurationer använder samma PCMCIA-bild.

Memory Card Options

Kopiera minneskort ...

Med den här knappen kan du kopiera en PCMCIA-bild till en annan fil. Dess funktion kan jämföras med att köpa ett nytt PCMCIA-kort till Tech2. Kopieringsfunktionen fungerar bara för filer i katalogen C:\Users\Public\General Motors\Tech2Win\pcmcia.

Plats 0: Plats för minneskortsbild

Här kan du specificera vilken fil som innehåller din PCMCIA-bild för plats 0. I vanliga fall skulle en sådan fil finnas i C:\Users\Public\General Motors\Tech2Win\pcmcia, men andra platser är möjliga.

Plats 1: Minneskort eller ATA

Precis som Tech2 stöder också Tech2Win två PCMCIA-kort (bilder). Men den andra PCMCIA-bilden i en konfiguration är oftast inte särskilt användbar. En andra mjukvara skulle troligen användas i en andra konfiguration.

Precis som på Tech2 används ett ATA-kort för felsökning. Aktivera endast ATA-kortet om du blir ombedd att göra detta av teknisk support. De kan ge dig mer information.

Plats för mjukvara datortangentbord

Standardvärdet för denna fil hämtas från Windows-registret och ska leda till ett program som kan simulera ett datortangentbord med musen. Om du har ett specialprogram med denna funktion för den bärbara dator du använder kan du ange programmet här.


Bilkommunikationsgränssnitt

  • COM-port för Tech2-RS232-emulering
  • Serienummer på MDI som ska användas
  • Protokoll

COM-port för Tech2-RS232-emulering

Välj en ledig COM-port som kan användas för Tech2-emuleringen. För att underlätta för dig försöker Configurator ta reda på vilka seriella portar som redan används och visar dessa.

Om du väljer en befintlig COM-port ansluter sig Tech2Win till denna COM-port. Du kan använda denna COM-port för att via en nollmodemkabel hämta Tech2-programvara från en andra dator som kör ett TIS-program. Observera att användning av en verklig COM-port kanske inte fungerar tillförlitligt med 115200 baud på grund av begränsningar i Windows.

Om en ej befintlig COM-port väljs skapar Tech2Win automatiskt en virtuell port. Denna virtuella port kan användas från TIS som körs på samma dator för att upprätta kommunikation med Tech2Win. Vid användning av en virtuell port finns ingen begränsning i baud-hastighet.

Om du väljer 'sök' som COM-port kommer Tech2Win att skapa en virtuell COM-port på det första lediga portnumret i intervallet från 9 till 1.

Serienummer på MDI som ska användas

Ange serienummer för MDI. Numret finns på baksidan av MDI. Använd numret efter bindestrecket.

Om du inte anger ett serienummer visar Tech2Win automatiskt en lista över MDI som detekterats i nätverket för att låta användaren välja ett MDI. Samma valruta visas om det angivna MDI inte hittas.

Protokoll

'ISO22900-2 / PDU-API' är markerad och J2534-2 är alltid inaktiverad. I framtiden kanske Tech2Win även kan hantera J2534-protokollet.

  • Avancerade ämnen: Konfigurationsfil
  • FAQ (vanliga frågor och svar): Hur kan jag avgöra vilken COM-port jag ska använda för Tech2Win?
  • FAQ (vanliga frågor och svar): Kommunikation mellan Tech2Win och TIS2Web
  • FAQ (vanliga frågor och svar): Hur kan jag använda mer än ett MDI?
  • FAQ (vanliga frågor och svar): Tech2Win hittade inte mitt MDI


Display

Fliken Display används huvudsakligen för att ändra inställningarna för Tech2Win-displayen:

  • Knappsats
  • Färger
  • Ljud
Display and Key Options

Knappsats

Här kan du välja om knappsatsen ska visas. Knappsatsen visas antingen på vänster eller höger sida om Tech2Win-skärmen. Bakgrundsfärgen går att välja i dialogrutan för standardfärg.

Färger

Bakgrunds- och förgrundsfärgen på Tech2-skärmen går att välja var för sig här. De här är de vanligaste färgkombinationerna:

Screen with background 0000FF, foreground FFFFFF | Knappsatsbakgrund vit; Bakgrund blå; Förgrund vit
Screen with background 000000, foreground C0C0C0 | Det numeriska tangentbordets bakgrund blå; Bakgrund svart; Förgrund ljusgrå

Ljud

Du kan välja att stänga av ljudet här. Varje gång Tech2-programmet avger en ljudsignal används datorhögtalaren.


Spara konfigurationen

Den aktiva konfigurationen kan sparas med knappen Spara <konfiguration> längst ned i vänstra hörnet. Knappen visas inte om du visar en skrivskyddad konfiguration.


Giltig licens via TIS2Web

Normalt ska hämtning av Tech2-programmet till Tech2Win förse dig med en giltig licens. Dessutom kan du få en genom att utföra en 'Säkerhetsaccess (Säkerhet)' via TIS2Web (inte TIS2000). En förutsättning för detta är att den virtuella COM-porten väljs inuti konfiguratorn under Bilkommunikationsgränssnitt.

Efter en säkerhetsåtkomst som lyckats visas ett öppet hänglås till höger i statusfältet. Inom parentesen visas hur många dagar som licensen gäller. När du startar Tech2Win igen visas inte säkerhetsindikatorn om ingen bilkommunikation pågår. Under den första kommunikationen med en bil kommer licensen att kontrolleras och indikatorn ändras till antingen ett öppet eller stängt hänglås.

  • Arbeta med Tech2Win:Säkerhet
  • FAQ (vanliga frågor och svar):Hur kan jag avgöra vilken COM-port jag ska använda för Tech2Win?
  • FAQ (vanliga frågor och svar):Kommunikation mellan Tech2Win och TIS2Web
  • FAQ (vanliga frågor och svar):Giltig licens
  • FAQ (vanliga frågor och svar):Vad är skillnaden mellan en Tech2Win-licens och säkerhetsåtkomst?


Arbeta med Tech2Win

Följande ämnen används av de flesta tekniker när de arbetar med Tech2Win:

  • Meny: Skärmlayout och enskilda menyposter.
  • Hämta en PCMCIA-avbildning: Uppdateringen av diagnosmjukvaran för Tech2Win är mycket lik den metod som används för Tech2.
  • Säkerhet: Säkerhetsåtgärder förhindrar att Tech2Win upprättar fordonskommunikationer i miljöer som inte är godkända.
  • Visa rapporter: Tech2-tangentbordet är något förbättrat i Tech2Win. Knappen 'Visa rapporter' är det bästa exemplet.
  • Hantering av PCMCIA-bilder: Precis som det går att ha flera PCMCIA-kort för Tech2 går det också att använda flera PCMCIA-bilder för Tech2Win.
  • Statusrad: Statusraden informerar användaren om de olika delarna av statusraden.
    • Avancerade ämnen
    • FAQ (vanliga frågor och svar)


Meny

Tech2Win-programmet har följande menyposter:

  • Fil
  • Alternativ
  • Fönster
  • Hjälp

Fil

I menyn Fil finns följande möjligheter:

  • Spara T2-fönster (320 x 240) används för att spara det aktuella T2-fönstret med storleken 320 x 240 bildpunkter som en svartvit bildfil på din dator. Du kan välja var filen ska sparas och i vilket filformat (BMP, GIF, JPG, PNG).
  • Skriv ut skärmbild skapar en inverterad svart-på-vit BMP-bild av Tech2-fönstret och anropar det program som är associerat med BMP-filer. Du kan sedan använda det programmet för att skriva ut bilden
  • Visa rapportfiler ger möjlighet att visa (och skriva ut) rapportfiler utan att använda TIS2Web.
  • Avsluta stänger av Tech2Win.

Alternativ

I Alternativ finns följande alternativ:

  • Upplösning kan användas för att välja mellan tre standardskärmstorlekar.
  • ROM-Write from 0x00003ED76 används för interna felsökningsändamål.
  • Automatiska skärmbilder om du vill spara en bild av varje Tech2-fönster i loggkatalogen.
  • Inaktivera CANdi och starta om om du vill imitera en Tech2 som inte har en CANdi kopplad mellan sig själv och bilen. Det behövs för sällsynta fall då CANdi avbryter bilkommunikationsledningar av icke-standardtyp.

Fönster

Menyn Fönster ger dig möjligheten att aktivera valen Tech2Win datavisning och Tech2Win felkodsvisning. Alla andra val är gråmarkerade i den aktuella versionen av Tech2Win.

Om Tech2-programvaran har stöd för Tech2Win datavisning kan du aktivera denna menypost. När du öppnar Data Display kommer Tech2Win att vissa ett extra fönster 'Data Display' parallellt med Tech2:s 'Data Display'. Så länge som Tech2-skärmen visar Data Display kan menyposten inte aktiveras. I ett sådant fall måste du lämna Data Display, aktivera menyposten och starta om Data Display.

Liknande restriktioner för Tech2Win datavisning gäller även för Tech2Win felkodsvisning. Om Tech2-programvaran har stöd för Tech2Win felkodsvisning kan du aktivera denna menypost. Ett ytterligare DTC Display-fönster visas parallellt med Tech2 DTC Display. Så länge som Tech2-skärmen visar DTC Display kan menyposten inte aktiveras. I ett sådant fall måste du lämna DTC Display, aktivera menyposten och starta om DTC Display.

Hjälp

Följande val kan göras:

  • Hjälpämnen ... visar Tech2Win-hjälp.
  • Kommandoradsparameter visar de kommandoradsparametrar som används för Tech2Win.
  • Om visar det aktuella versionsnumret och TIS2Web-hämtningsbegränsningarna för Tech2Win.


Ladda ned

Starta först Tech2Win och lämna huvudskärmen igång. Starta TIS2Web eller GlobalTIS och genomför hämtningen via den COM-port som anges på fliken Bilkommunikationsgränssnitt.

Med inbyggda COM-portar går det att ladda ned Tech2-mjukvara från en annan dator som kör TIS. Använd en korsad RS232-kabel. Beroende på hårdvaran i den dator där Tech2Win körs kan dataöverföringshastigheten behöva minskas till 57 600 baud eftersom Windows kan förlora data vid en högre överföringshastighet.

Den senaste Tech2Win-versionen stöder också snabb hämtning när TIS2Web och Tech2Win körs på samma dator. Minimal kommunikation mellan TIS2Web och Tech2Win förekommer fortfarande via kommunikationsporten, men den tidsslukande dataöverföringen till Tech2Win har ersatts av en intern filöverföring. I dessa fall minskas hämtningstiden drastiskt till mycket mindre än en minut.

  • Avancerade ämnen: Konfigurationsfil
  • De första stegen: Bilkommunikationsgränssnitt
  • FAQ (vanliga frågor och svar): Hur kan jag avgöra vilken COM-port jag ska använda för Tech2Win?
  • FAQ (vanliga frågor och svar): Kommunikation mellan Tech2Win och TIS2Web


Säkerhet

De säkerhetsmekanismer som används av Tech2Win är beroende av ett korrekt datorklockvärde. Se till att datorns klocka alltid är rätt inställd. Mindre ändringar av klockan, till exempel vid ändring till sommartid, tolereras av Tech2Win.

Tech2Win genomför ingen aktiv bilkommunikation utan en giltig och aktiv licens. Följande indikator i statusfältet visar licensens status:

  • green smiley Licensen är giltig.
  • Ingen indikator: Licensen har ännu inte kontrollerats.
  • red smiley Licensen har gått ut.

För att skaffa en licens, utför en 'Säkerhetsaccess (Säkerhet)'-uppdatering via programmet TIS2Web. I de flesta fall är en programhämtning via TIS2Web tillräcklig för att få en ny licens. Eftersom licensen blir ogiltig efter en viss tid (fyra veckor i vissa regioner), måste du regelbundet utföra en sådan uppdatering.

Licenser är region- och programspecifika. Du kan ha licenser på datorn om du använder Tech2Win med olika Tech2-programversioner.

Antalet dagar som återstår innan licensen upphör visas i statusfältet.

  • ( 0) visar att licensen har upphört eller inte finns.
  • (<1) Licensen upphör inom de närmaste 24 timmarna.
  • (20) Licensen upphör om 20 dagar.

Ändra inte licensfilen. Olagliga ändringar av den filen detekteras av interna säkerhetsfunktioner och leder till att alla licenser på datorn går förlorade. Dessutom kommer Tech2Win att uppträda oväntat. Det kan endast åtgärdas genom att utföra en ny installation.

  • Avancerade ämnen: Felmeddelanden och felkoder
  • Avancerade ämnen: Loggfil
  • Arbeta med Tech2Win: Statusfönster
  • FAQ (vanliga frågor och svar): Giltig licens
  • FAQ (vanliga frågor och svar): Vad är skillnaden mellan en Tech2Win-licens och säkerhetsåtkomst?
  • FAQ (vanliga frågor och svar): Plötsligt stopp


Visa rapporter

View Report Med den här knappen kan du se innehållet i alla PRT-filer på PCMCIA-kortet. En dialogruta öppnas för att visa en lista över PRT-filer. Om ett program har associerats med PRT-ändelsen startas det associerade programmet. I annat fall öppnas Anteckningar för att visa den valda filen.

I de flesta fall är PRT-filen en ASCII-fil som använder språk- respektive kodsidorna. För kinesiska, japanska, koreanska och thailändska är filen i Unicode och börjar med en byte-ordningsindikation (BOM).

När du visar rapporter använder Tech2Win underkatalogen C:\Users\Public\General Motors\Tech2Win\reports. Denna underkatalog finns enbart om du har visat rapporter minst en gång. Katalogen raderas automatiskt och fungerar som en tillfällig arbetskatalog för PRT-filerna på det aktiva PCMCIA-kortet. Filerna finns kvar i denna katalog också när Tech2Win stängs av. Om du vill spara en sådan fil måste du kopiera den till en annan katalog eftersom den kan skrivas över när en annan användare väljer att visa rapporter.


PCMCIA-bilder

PCMCIA-bilder finns vanligen i underkatalogen C:\Users\Public\General Motors\Tech2Win\pcmcia. Filens storlek måste vara exakt 32 Mbyte (33 554 432 bytes) eller 10 Mbyte (10 485 760 bytes) och ha filändelsen *.bin. Bilderna ändras (som varje normalt PCMCIA-kort) vid nedladdning eller om Tech2Win sparar något på flashkortet. Ändringar kan inaktiveras med skrivskyddskontakten (kommando -W0 eller -W1) eller genom att utelämna 'p'-värdet i '-W'-tillvalet.(Konfigurationsfil). Den skrivskyddade väljaren går inte att komma åt genom konfiguratorn. Du måste ändra konfigurationsfilen manuellt om du vill använda alternativen '-W0', '-W1' eller '-W'.


Statusrad

Statusraden visas under Tech2-skärmen. Följande poster visas i statusraden:

  1. En hastighetsindikator
  2. Fordonskommunikationsstatus
  3. Serieportstatus
  4. SHIFT-tangenten
  5. Automatiska skärmbilder
  6. Loggvarning
  7. Licens

Status Bar

Hastighetsindikator

Hastighetsindikatorn visar hur mycket CPU-tid det går åt för att emulera Tech2-mjukvaran. En låg siffra (indikatorn till vänster) är bättre än en hög siffra (indikatorn till höger). Alla gröna indikatorer är godkända. Indikatorn kan bli gul under en kort stund om olika Windows-aktiviteter plötsligt aktiveras. Sådana aktiviteter ska undvikas.

Fordonskommunikationsstatus

Bilens kommunikationsstatus indikerar om gränssnittet för bilkommunikation (MDI) finns närvarande tillsammans med kommunikationen mellan bilen och Tech2Win.

Serieportstatus

Vid kommunikation med Tech2Win via en COM-port visar denna indikator om kommunikationen över COM-porten är aktiv eller inte.

SHIFT-tangenten

Denna indikator visar om SHIFT-tangenten är aktiv. Du kan ändra den med S-tangenten på tangentbordet eller SHIFT-tangenten på det numeriska tangentbordet.

Automatiska skärmbilder

Automatiska skärmbilder kan aktiveras i menyn Alternativ. Varje gång fönstret förändras sparas en ny skärmbildsfil i loggkatalogen. Det indikeras med att vevhandtaget på den röda kameran i statusfältet vrids ett varv. Så fort automatiska skärmbilder inaktiveras försvinner kameran.

Loggvarning

Indikatorn Loggstatus kan ha tre olika tillstånd.

  • gray log status indicator Loggfilen innehåller inga varningar eller fel.
  • yellow log status indicator Loggfilen innehåller ett varningsmeddelande.
  • red log status indicator Loggfilen innehåller ett felmeddelande.

Licens

Licensindikatorn kan ha tre tillstånd:

  • green smiley Licensen är aktiv och giltig.
  • Ingen indikator: Licensen har ännu inte kontrollerats.
  • red smiley Licensen har upphört eller finns inte.
Se länken Säkerhet för mer information.

Knappbeskrivningar i statusfältet

För vissa ikoner visas knappbeskrivningar för att ge viss ytterligare information:

Knappbeskrivning för VCI-serienummer:
Tooltip VCI

Knappbeskrivning för TECH2-programversion
Tooltip TECH2

Knappbeskrivning för COM-port
Tooltip Comport

Knappbeskrivning för numret på nästa skärmdump (om 'Automatiska skärmbilder' är aktivt)
Tooltip Camera

Knappbeskrivning som visar den senaste loggfilsposten som har nivån 'varning' eller högre
Tooltip Logfile

Knappbeskrivning för licensens exakta giltighet
Tooltip License

Knappbeskrivningarna visas om muspekaren hålls över en ikon i mer än 0,5 sekunder utan att flyttas. Knappbeskrivningarna försvinner efter 5 sekunder eller när muspekaren flyttas.

  • Avancerade ämnen: Felmeddelanden och felkoder
  • Avancerade ämnen: Loggfil


Avancerade ämnen

De ämnen som diskuteras här är av mindre betydelse för den normala Tech2Win-användaren. Alla som kommer i kontakt med inställning, hantering och konfiguration av Tech2Win kan ha nytta av följande information.

  • Ominstallation
  • Avinstallation
  • Direkt ändring av konfigurationsfilerna
  • Loggfil
  • Felmeddelanden och felkoder
  • ATA-kort
  • Registerposter
  • Filbeskrivning
  • Exempel på konfigurationshantering


Avinstallation

Den fullständiga installationskatalogen, katalogen med användardata (C:\Users\Public\General Motors\Tech2Win) och katalogen med programdata (C:\ProgramData\General Motors\Tech2Win) raderas.

  • Avancerade ämnen: Ominstallation
  • Installation


Konfigurationsfil

Konfigurationsfilerna finns alltid i underkatalogen C:\Users\Public\General Motors\Tech2Win\config och har filnamnstillägget *.conf. Du kan ändra konfigurationsfilen manuellt då inte alla tillval i filen går att komma åt genom Tech2Win. Konfigurationsfilen är en Unicode-fil som börjar med en byte-ordningsindikation (BOM, Byte Order Mark). Vi rekommenderar starkt att du använder en redigerare som kan hantera Unicode, t.ex. Anteckningar, när du gör manuella ändringar.

Konfigurationsfilen är radorienterad. Tomma rader ignoreras. En rad startar alltid med ett tillval som oftast följs av ett värde. Se exempelvis filen default.conf. Se den efterföljande tabellen där alla tillgängliga tillval tas upp.

Om du vill starta en särskild konfiguration direkt från skrivbordet, gör en genväg som kör 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_cofiguration_file.conf'. Programmet ska startas från följande arbetskatalog: 'C:\Program Files\General Motors\Tech2Win\bin'

Tillval | Värde/betydelse
; En kommentar.
@ Ett decimalversionsnummer i formatet major.minor.
Konfigurationsfiler med ett annat major-nummer än Tech2Win accepteras inte. Konfigurationsfiler med ett annat minor-nummer än Tech2Win accepteras.
-W0
-W1 		PCMCIA-kortet på plats 0/1 har en aktiverad skrivskyddskontakt.
-B0
-B1 		Blockstorleken i Kbyte för PCMCIA-kortet på plats 0/1. Godkända värden är 128 (standard) och 256.
-P0
-P1 		Filen med den binära bilden av PCMCIA-kortet på plats 0/1. Storleken på filen måste vara exakt 10 MB eller 32 MB. Miljövariabler som %ProgramData% är expanderade.
Om det här tillvalet inte finns förutsätts platsen vara tom.
-A0
-A1 		Filen med attributvärdena för PCMCIA-kortet på plats 0/1. Om den inte finns kommer standardattribut att användas baserat på kort och blockstorlek.
-W | När du avslutar Tech2Win skrivs alla kvarvarande data till sina respektive filer. Värdena p/f/r/c kan kombineras för att beteckna PCMCIA/Flash-ROM/RTC- respektive CANDI-program.
-H | Heap-hanteringsfunktion Värdena 0/r/w/t kan kombineras för att aktivera nollställning, läskontroller, skrivkontroller respektive uppgiftskontroller. Värdet l används för att alltid framtvinga en allokering av heap-minne vid lägre adresser eftersom ett alternativt allokeringsschema är infört. Normalt används detta alternativ endast i en utvecklingsmiljö.
-PC | Tidigare sökväg till kopian av PCMCIA-kortet. Detta alternativ ignoreras nu.
-MS | Identifiering av gränssnittet för bilkommunikation (MDI) med serienummer. Om det inte angetts visas en lista med tillgängliga MDI.
-CT | Färgen på texten (förgrund) i bytevärden med 3 hexadecimaler. Standardvärdet är 000000 (vit).
-CB | Färgen på bakgrunden i bytevärden med 3 hexadecimaler. Standardvärdet är FFFFFF (svart).
-ATA | Använd det här alternativet för att aktivera ett ATA-inspelningskort. Ta bort det för att inaktivera ATA-inspelningskortet.
-C | Antalet COM-portar (1–9) som ska användas som RS232C-kommunikationsportar för Tech2. COM9 används ofta för den virtuella COM-porten som installeras av Tech2Win. Om detta alternativ inte finns genomförs en sökning efter en ledig COM-port från COM9 och nedåt. Använd knappbeskrivningen i statusfältet mellan Tech2-ikonen och TIS2Web-ikonen för att se vilken COM-port som används.
-WR | En PC-adress (normalt 253558) som är tillåten för att skriva till PCMCIA- och FLASH ROM-området. Denna funktion måste särskilt aktiveras via menyn (eller via alternativet -WA). Den behövs för att felsöka kod i det ej ändringsbara minnet med SingleStep-felsökningsprogrammet.
-WA | Tillåt felsökningsprogrammet SingleStep att skriva till ett icke ändringsbart minne.
-OF | Alternativfil som innehåller alternativ-/värdepar.
-TP | Tidsinställningar (Proportionellt värde). Standardvärde: 5000. Minska detta värde för att få antalet utförda cykler att snabbare anpassa sig till realtid.
-TD | Tidsinställningar (Differentiellt värde). Standardvärde: 100. Minska detta värde för att reagera snabbare på ändringar av den ögonblickliga tidsinställningen. VARNING: Ändring av TP- och TD-värdena kan leda till hastighetsproblem.
-PJ
-PP 		Ange vilket protokoll som ska användas:
PJ för J2534-kommunikation.
PP för ISO22900-2 / PDU-API (standard)
-S | När detta tillval finns aktiveras ljudet för datorns summer.
-L | Språket i Tech2Win-programmet. Det aktiva Windows-språket används som standard om denna post saknas. Se följande länk för en lista över språk som kan anges: Språk. Tech2-emuleringsfönstret visar det språk som finns på PCMCIA-kortet (d.v.s. det som hämtades till PCMCIA-kortet).
-UD | Åsidosättning av användardatakatalogen. I Windows 7 finns denna vanligen under C:\Users\Public\General Motors\Tech2Win
-AD | Åsidosättning av programdatakatalogen. I Windows 7 finns denna vanligen under C:\ProgramData\General Motors\Tech2Win
-US | Använd en användarspecifik semafor för att hitta fler än en instans av Tech2Win. Med det här alternativet kan användaren köra Tech2Win parallellt på samma maskin, vanligen en server. När du använder det här alternativet ska du också ange alternativ -UD och -AD.
-SS | Alternativ för att specificera den totala storleken på Tech2Win-fönstret inklusive det numeriska tangentbordet (om det finns). Den första parametern måste vara en sträng omgiven av dubbla citationstecken (') och kommer att användas som namnet på storleken i menyn Alternativ / Upplösning. Den andra parametern är det totala antalet horisontella bildpunkter på Tech2Win-skärmen, inklusive det numeriska tangentbordet. Den tredje parametern är det totala antalet vertikala bildpunkter på Tech2Win-skärmen. Den valfria fjärde parametern är bredden på det numeriska tangentbordet i bildpunkter.
-SH Alternativ för att kontrollera skärmhanteringen. Följande decimaltal används för att specificera vilka skärmhanteringsmöjligheter som ska inaktiveras.
  • Bit 0: Min/max inte möjligt.
  • Bit 1: Ingen omflyttning på bildskärmen.
  • Bit 2: Ingen storleksändring. I detta fall är menyn Alternativ / Upplösning nertonad.
  • Bit 3: Datavisnings- och felkodsfönster har exakt samma storlek som Tech2Win (utan numeriskt tangentbord).


Loggning

Vid varje start av en Tech2Win-konfiguration skapas en ny loggfil i HTML-format i underkatalogen C:\Users\Public\General Motors\Tech2Win\Logs. För att undvika att hårddisken blir full tas loggfiler som är äldre än en vecka bort.

Loggfilerna namnges automatiskt efter datum (år, månad, dag) och tid (timme, minut, sekund) när de skapades:
yyyy-mm-dd_hhmmss.html

Loggfilsposterna är alltid på engelska men i Unicode-format och börjar med en byte-ordningsindikation (BOM). Varje rad i loggfilen är en av följande loggnivåer:

Loggnivå | Betydelse
Info | Endast information. Påverkar inte programfunktionen.
Varning | En ovanlig situation har uppstått. Användaren ser eventuellt inte några negativa effekter.
ERROR | Ett fel inträffade som användaren märker.
CRITICAL | Ett kritiskt fel inträffade som gör att programmet fungerar onormalt.
FATAL | Vid ett allvarligt fel slutar Tech2Win omedelbart att fungera.

Alla nivåer över 'Varning' är färgade så att det är enkelt att hitta dem.

Dessutom finns utskrifts- och videofiler i underkatalogen Logs om du använt menyalternativen Skriv ut skärmbild eller Automatiska skärmbilder.
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
Automatiska skärmbilder-bilder är länkade via HTML-filen – så använd HTML-loggen för att visa bilderna i rätt ordning.

I statusraden informeras användaren om att en varning ( yellow lightning bolt) eller en allvarligare loggpost ( red lightning bolt) finns.


Felmeddelanden och felkoder

Felmeddelanden kan visas i dialogrutor. Dessa dialogrutor tillåter att Tech2Win kör Tech2-programmet parallellt. Felkoder är allvarliga fel som får Tech2Win att avbrytas på ett onormalt sätt. Felkoderna kan användas i batchfiler för att upptäcka varför ett program har avbrutits.

Felmeddelanden

Följande felmeddelanden kan visas. Här följer en kort förklaring av situationen och hur problemet kan lösas.

Emulator too slow Emulator failed to start

Felkoder

Felkod | Värde | Betydelse
OPCODE_ERROR | -7 | En ogiltig begäran av mikroprocessorn i Tech2 (68332) upptäcktes. PCMCIA-bilden kan ha blivit förvrängd.
ATA_PROBLEM | -6 | Ett problem inträffade under ATA-emuleringen. Om du ser ett sådant problem efter att du har instruerats att använda ATA-kortet, kontakta supportavdelningen.
DEMO_TIME_IS_UP | -5 | Ska inte visas i den officiella versionen av Tech2Win.
DLL_NOT_LOADED | -3 | En av de nödvändiga DLL-filerna gick inte att ladda. Du verkar ha en ofullständig kopia av Tech2Win. Gör en ny installation och/eller välj ett annat språk.
EXIT_INIT_FAILED | -2 | Initiering misslyckades. Titta i loggfilen för att få reda på den exakta orsaken. Om ingen loggfil finns, kontrollera om du har rätt läs/skrivåtkomst till alla kataloger.
Normal | 0 | Tech2Win har avbrutits på normalt sätt.


ATA-kort

ATA-kortet i Tech2 används vanligen enbart i felsökningssyften under utvecklingen av mjukvaran. Alla nödvändiga ATA-data är lagrade i underkatalogen C:\Users\Public\General Motors\Tech2Win\ataCapture. Denna katalog är oftast inte viktig och går att radera om inga andra anvisningar har getts.

Eftersom katalogen ataCapture är fast kommer dess innehåll att vara samma för alla konfigurationer.


Filer

Följande filer och kataloger används av Tech2Win:

Katalog | Plats före Vista | Plats för Vista och senare
Installation | Definierad under installationen
Användardata | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Programdata | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Fil | Användning
[Användardata]\atacapture | Innehåller filer som finns på ATA-kortet. Om inget anges på annan plats är dessa filer inte nödvändiga.
[Installation]\bin | Innehåller de faktiska körbara och nödvändiga DLL-filer och bilder som krävs för användning.
[Installation]\bin\emulator.exe | Huvudexekveringsfilen som kör Tech2-koden.
[Installation]\bin\emulator_xx_XX.dll | Språkspecifik resurs-DLL.
[Installation]\bin\T2Configurator.exe | Konfigurationsdelen av Tech2Win.
[Installation]\bin\Pictures | Innehåller de ikoner som Tech2Win behöver.
[Användardata]\config | Innehåller alla konfigurationsfiler.
[Användardata]\data | Innehåller filer som ändras under användning av Tech2Win. Dessa filer behövs för korrekt funktion för Tech2Win. Normalt sett ska du inte röra dessa filer om du inte uttryckligen instrueras att göra det.
[Programdata]\data | Innehåller filer som ändras under användning av Tech2Win. Dessa filer behövs för korrekt funktion för Tech2Win. Normalt sett ska du inte röra dessa filer om du inte uttryckligen instrueras att göra det.
[Programdata]\data\emulator.sec | Säkerhetsfil . Ändra inte denna fil.
[Programdata]\data\emulator.card | Kortfil. Innehåller alla PCMCIA-kort som Tech2Win-programmet känner till. Ändra inte denna fil.
[Användardata]\data\emulator.disp | Denna fil innehåller plats och storlek för skärmen på Tech2Win. Om du raderar den här filen kommer den att återskapas och skärmen för Tech2Win startar i det övre vänstra hörnet med en storlek på 640 x 480.
[Programdata]\data\emulator.lic | Licensfil. Innehåller information om hur länge dina licenser gäller. Ändra inte denna fil.
[Programdata]\data\emulator.rtc | Filen realtidsklocka. Den här filen används för förvaring av data som finns i RTC på Tech2.
[Programdata]\data\emulator.dta | En info-fil 'Visa inte detta igen'.. I den här filen lagras PCMCIA-programversioner som inte (längre) visar varningen om att det inte går att utföra självtester som kräver en loopback-adapter.
[Programdata]\data\candi.bin | CANdi programfil. Innehåller programmet för CANdi som är anslutet till Tech2.
[Programdata]\data\eprom.bin | Tech2 intern EPROM-fil. Innehåller innehållet i det interna Tech2-flashminnet.
[Installation]\driver | Installationsfiler för drivrutinen för den virtuella COM-porten.
[Installation]\help\emulator_xx_XX.chm | Språkspecifika hjälpfiler.
[Användardata]\Logs | Innehåller loggfiler. Filer som är äldre än en vecka raderas automatiskt.
[Användardata]\pcmcia | Innehåller PCMCIA-bildfiler. I bildlig bemärkelse motsvarar varje fil ett Tech2 PCMCIA-kort. Dessa filer kan sparas på olika platser.


Konfigurationshantering

Konfigurationsfilerna finns alltid i underkatalogen C:\Users\Public\General Motors\Tech2Win\config och har filnamnstillägget *.conf. Tech2Win kan bara användas för att skapa nya konfigurationsfiler eller för att ändra befintliga konfigurationsfiler som inte är skrivskyddade. För all övrig hantering av konfigurationsfilerna ska du använda Windows Explorer eller ett liknande filhanteringsprogram. Det behövs för följande aktiviteter:

  • Borttagning av konfigurationsfiler
  • Ändring av namn på konfigurationsfiler
  • Ändring av skrivskyddsattributet för en konfigurationsfil

Vi föreslår att du alltid har en konfigurationsfil som heter default.conf. Denna fil ska vara skrivskyddad för att undvika felaktig överskrivning. Om du vill ändra den här filen så att den uppfyller dina specifika behov måste du avaktivera skrivskyddet en kort stund.

PCMCIA-bilderna finns i underkatalogen C:\Users\Public\General Motors\Tech2Win\pcmcia. Var och en av dessa filer motsvarar ett PCMCIA-kort som du redan är bekant med från arbeten med Tech2. Med Tech2Win kan du ha hur många bilder som helst. Kopiera helt enkelt en befintlig bild till ett nytt filnamn.

Om du vill starta en särskild konfiguration direkt från skrivbordet, gör en genväg som kör "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Programmet ska startas från följande arbetskatalog: 'C:\Program Files\General Motors\Tech2Win\bin'

Antalet konfigurationsfiler beror inte på det antal PCMCIA-bilder du använder. Du kan få flera konfigurationsfiler med samma PCMCIA-bild. Detta simulerar en situation där flera mekaniker i en verkstad delar på samma Tech2 (och samma PCMCIA-kort).

Du kan också ställa in så att varje konfiguration använder sin egen dedikerade PCMCIA-bild. Detta gör individuella konfigurationer mer oberoende av varandra. Men den ansträngning som krävs för att uppdatera varje PCMCIA-bild är kanske inte godtagbar.

När du gör en ny konfiguration genom att kopiera en befintlig visar konfiguratorn en varning om PCMCIA-bilden inte har ändrats. I så fall har du två konfigurationer som använder samma PCMCIA-bild. Om det är så du vill ha det trycker du bara på OK. Om du vill att den nya konfigurationen ska använda en annan eller en ny PCMCIA-bild trycker du på Avbryt. Du kan sedan välja att göra en ny bild med hjälp av Kopiera minneskort ...

Här följer två exempelmetoder på hur du kan hantera dina konfigurationer och PCMCIA-bilder.

En konfiguration per användare

Du har möjlighet att spara en konfiguration per användare. Konfigurationsfilens namn kan till exempel vara användarens namn. Fördelar med konceptet är att användarspecifika inställningar kan göras, till exempel gränssnitt för bilkommunikation (MDI), visnings- och språkinställningar. Nackdelen är att du måste kopiera PCMCIA-filer om flera användare ska använda samma programvara. De användarspecifika konfigurationerna kan naturligtvis använda en central PCMCIA-fil.

En konfiguration per Tech2-mjukvara

Du kan välja att göra en ny konfiguration för varje programvara du hämtar. Därigenom finns även äldre programversioner omedelbart tillgängliga om de skulle behövas. I så fall kan ofta programnamnet och versionsnumret användas som konfigurationsnamn.

  • De första stegen: Bilkommunikationsgränssnitt
  • De första stegen: Sökväg
  • Avancerade ämnen: Konfigurationsfil
  • Installation: Installationssteg


Vanliga frågor och svar (FAQ)

  • Hur kan jag avgöra vilken COM-port jag ska använda för Tech2Win?
  • Kommunikation mellan Tech2Win och TIS2Web
  • Giltig licens
  • Vad anger licensnumret?
  • Vad är skillnaden mellan en Tech2Win-licens och säkerhetsåtkomst?
  • TIS2Web uppvisar ett ospecificerat fel vid utförandet av säkerhetsåtkomst till den ursprungliga programvaran.
  • Tech2Win kör inte Tech2-program från något annat område
  • Hur kan jag använda mer än ett MDI?
  • Loggfilen innehåller felet 'CPU32: Too many 0000/FFFF Commands encountered'
  • Inget Tech2-fönster synligt
  • SPS fungerar inte
  • Vissa självtester fungerar inte
  • Hastighetsmätaren varierar
  • Plötsligt stopp
  • Svenska språket visas för programvara 15.001
  • Förlorad kommunikation med MDI
  • Tech2Win hittade inte mitt MDI
  • Jag vill omedelbart starta Tech2Win utan att bry mig om konfiguratorn
  • Var är utskriftsfunktionerna?
  • Det finns en 'oanvänd' PCMCIA-mapp på min dator
  • Jag får meddelandet 'illegal filepath' (otillåten filadress)

Hur kan jag avgöra vilken COM-port jag ska använda för Tech2Win?

Du kan använda 'Enhetshanteraren' i Windows, leta efter 'Portar (COM & LPT)'. Vissa datorer har dock interna modem eller bluetooth-enheter installerade som inte visas inom denna kategori.
Ett annat sätt är att använda ett litet kommando som levereras tillsammans med konfiguratorn. Du kan köra det via startmenyn (mappen Tech2Win) genom att klicka på 'show com ports'.
Båda metoderna visar de COM-portar som finns installerade på datorn och som du INTE ska använda.

Kommunikation mellan Tech2Win och TIS2Web

Det är viktigt att Tech2Win är igång innan du startar kommunikationen med TIS2Web för säkerhetsåtkomst eller hämtning av programvara. TIS2Web känner bara igen den virtuella COM-porten om Tech2Win är startat.

Giltig licens

Normalt har en programhämtning från TIS2Web redan försett dig med en giltig licens. Om du fortfarande inte har en licens måste en 'Säkerhetsaccess (Säkerhet)' via TIS2Web (inte TIS2000) utföras för att få en giltig licens. Utför inte någon annan TIS2Web-kommunikation med Tech2Win, till exempel en 'Nedladdning av program (NLPR)', innan du fått en licens via 'Säkerhetsaccess (Säkerhet)'.

Vad anger licensnumret?

Licensnumret till höger om statusfältet visar antalet återstående hela licensdagar. Direkt efter en hämtning eller säkerhetsåtkomst visas antalet 30 dagar. Sedan du startat om Tech2Win visas dock 29, eftersom licensens varaktighet troligen är något liknande 29 dagar, 23 timmar och 55 minuter. Om antalet licensdagar sjunker under 24 timmar visas licensvaraktigheten <1. 0 visas om licensen har gått ut.

Vad är skillnaden mellan en Tech2Win-licens och säkerhetsåtkomst?

Du behöver en Tech2Win-licens för att använda Tech2Win. För att få en licens måste du antingen utföra en mjukvaruhämtning eller en säkerhetsåtkomst med regelbundna intervall (vanligast: var 30:e dag). Möjligheten att utföra en sådan hämtning via TIS2Web informerar Tech2Win om att det finns en giltig användare. Säkerhetsåtkomst, som det är känt från Tech2, informerar Tech2Win om att vissa säkerhetsrelaterade aktiviteter, som inaktivering av en Airbag, är tillåtna. Både Tech2Win-licens och säkerhetsåtkomst kan utföras via programmet TIS2Web säkerhetsåtkomst. Tech2Win visar den återstående licenstiden i förloppsfältet till höger. Tyvärr kan Tech2Win inte visa förloppet för en säkerhetsåtkomst eftersom Tech2Win bara startar programvaran Tech2, men inte har någon information om programvaran Tech2 i sig.

TIS2Web uppvisar ett ospecificerat fel vid utförandet av säkerhetsåtkomst till den ursprungliga programvaran.

Den uppför sig på samma sätt om på en Tech2. På grund av sin ålder kan den urspungliga programvaran inte få någon licens från TIS2Web. Det är emellertid inget stort problem eftersom demonstrationsprogramvaran inte kommunicerar med en bil för vilken det krävs en licens. Och eftersom licenser är specifika för TIS2Web-hämtningar skulle du i alla fall behöva skaffa en licens för varje enskild hämtning efter nedladdningen av Tech2-programvaran. En 'licens' för den ursprungliga programvaran skulle inte berättiga dig att utföra fordonskommunikation med en programvara för North American Operations eller Opel/Vauxhall.

Tech2Win kör inte Tech2-program från något annat område

Din Tech2Win-version är troligen begränsad till en eller flera TIS2Web-hämtningar (regioner). Tryck på Hjälp / Om om du vill se vilka begränsningar som gäller din version av Tech2Win. Tidiga versioner av Tech2Win medgav endast att Opel/Vauxhall-programvara kördes. Andra GM-regioner kommer att följa efter. Oavsett detta kan Tech2Win för närvarande köra Tech2-program från General Motors.

Hur kan jag använda mer än ett MDI?

Om du vill tilldela särskilda MDI till specifika användare föreslår vi att du låter alla användare ha sin egen konfiguration. Det är lämpligt att konfigurationerna får namn efter sina respektive användare. I varje konfiguration anger du serienumret för det användarspecifika MDI på fliken 'Bilkommunikationsgränssnitt'. Så fort användaren startar sin konfiguration försöker Tech2Win kontakta det specifika MDI. Bara om det MDI inte är tillgängligt visas en valruta med alla MDI som Tech2Win hittade.

Om du har flera MDI:er för allmänt bruk föreslår vi att du använder konfigurationerna där serienumret för bilkommunikationsgränssnittet på fliken 'Bilkommunikationsgränssnitt' är tomt. Då kommer användaren alltid att se valrutan för tillgängliga MDI.

Loggfilen innehåller felet 'CPU32: Too many 0000/FFFF Commands encountered'

Filen 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' eller den aktuella PCMCIA-filen är felaktig. Installera om Tech2Win och hämta ny Tech2-programvara.

Inget Tech2-fönster synligt

Om inget Tech2-fönster är synligt finns det troligen i ett område som inte syns på skärmen. Sådan effekter kan uppstå om du använder mer än en skärm eller sedan du ändrat skärmupplösningen. Håll Shift-tangenten på tangentbordet nedtryckt när du startar din konfiguration. Då återställs fönstrets upplösning till 640x480 och Tech2-fönstret visas i skärmens övre vänstra hörn. Du kan också radera filen C:\Users\Public\General Motors\Tech2Win\emulator.disp för att få samma resultat.

Vi har noterat fall där Tech2-fönstret inte visades på bildskärmen igen efter att alla andra programfönster stängts. I de fall vi studerat hittills gick det att visa Tech2-fönstret med hjälp av tangentkombinationen Alt+Tab för att växla mellan Windows-program. Det är inte säkert att det fungerar att klicka på Tech2Win-knappen i aktivitetsfältet längst ner i datorfönstret. Vi håller på att undersöka problemet och hoppas kunna införa en programkorrigering i en senare version av Tech2Win.

SPS fungerar inte

Ja, vi vet. Vi har inga planer på att ändra detta. Du ska inte använda Tech2Win som ersättning för Tech2 för att göra SPS. Använd MDI direkt med SPS-programmering via TIS.

Vissa självtester fungerar inte

Tech2-självtester är avsedda för test av de enskilda delarna i Tech2-maskinvaran. Vissa av dessa tester kräver att man använder en loopback-adapter. Dessa tester fungerar inte i Tech2Win eftersom loopback-funktionen inte är införd (och det finns inga planer på att göra det). Låt helt enkelt bli att utföra sådana meningslösa tester i Tech2Win. Om du utför dem kan du få felaktiga resultat eller att Tech2Win hänger sig precis som Tech2 skulle göra utan loopback-adapter. Använd i så fall Ctrl-R för att återställa Tech2Win.

Hastighetsmätaren varierar

Hastighetsmätaren längst ned till vänster i statusfältet anger hur många 'Tech2-kommandon' som kan utföras innan Tech2Win måste 'sova' igen. Den här metoden används för att säkerställa att tiden i Tech2Win motsvarar realtid, snabbare datorer sover mer än långsammare datorer. Om hastighetsmätaren varierar är det något annat program som använder datorkraft eller också varierar datorns klocka. Stora variationer har negativ inverkan på bilkommunikationen och TIS2Web-kommunikationen. Se till att inga andra program körs.

De flesta bärbara datorer kan automatiskt minska CPU-klockhastigheten för att ge längre batteridrifttid. Detta kan också vara orsaken till de hastighetsvariationer som Tech2Win detekterar. Kör i så fall inte den bärbara datorn på batteri utan använd en extern strömkälla. Du kan också prova att ändra energialternativen så att operativsystemet inte minskar klockhastigheten.

Plötsligt stopp

Om du inte hittar någon orsak i loggfilen till varför programmet avbröts kan Tech2Win:s interna säkerhetsmekanismer ha aktiverats. Ändra inte följande filer: emulator.sec, emulator.lic, emulator.card. Om Tech2Win upptäcker en säkerhetsöverträdelse måste du troligen genomföra en ominstallation.

Svenska språket visas för programvara 15.001

Den ursprungliga programvara som följer med Tech2Win är ett demonstrationsprogram som finns på alla nya PCMCIA-kort. TIS2Web anger att detta är på svenska eftersom TIS2Web bara visar det sista språket i listan med de fyra språk som stöds av demonstrationsprogrammet (engelska, franska, tyska, svenska). Använd uppdateringsläget 'Egen' i stället för 'Standard' för att skriva över demonstrationsprogrammet med det nyaste diagnosprogrammet.

Förlorad kommunikation med MDI

Förlorad MDI-kommunikation kan ha flera orsaker.

  • Dålig kabelanslutning (både Ethernet och USB).
  • Dålig trådlös anslutning.
  • Datorn går i vänteläge.

Tech2Win hittade inte mitt MDI

Kontrollera följande punkter:

    1. Är MDI aktivt?
    2. Fungerar MDI Manager?
    3. Används MDI av ett annat program, som till exempel SPS?
Du kan starta MDI Manager med dess skrivbordsikon eller via 'Start/Alla program/General Motors/GM MDI Software'.: Ring helpdesk om punkt 2 inte fungerar.

Jag vill omedelbart starta Tech2Win utan att bry mig om konfiguratorn

Kör "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Använd följade arbetskatalog: 'C:\Program Files\General Motors\Tech2Wi\bin' Du kan fortfarande använda konfiguratorn för att göra ändringar i konfigurationen.

Var är utskriftsfunktionerna?

Tech2Win har ingen funktion för direktutskrift. Istället skapar den tillfälliga filer och anropar de program som är kopplade till filnamnstilläggen. Dessa program kan användas för utskrifter, vilket ger dig möjlighet att justera utseendet på din utskrift.

Print Report | Print Report

För att skriva ut den aktuella Tech2Win-skärmen, använd menyposten Fil / Skriv ut skärmbild eller knappen med en skrivare på det numeriska tangentbordet. Om du behöver skriva ut flera Tech2Win-skärmar kan du använda menyposten Alternativ / Automatiska skärmbilder eftersom denna skapar PNG-filer för varje Tech2Win-skärm. Dessa PNG-filer är inbäddade i loggfilen.

Du kan också skriva ut dataskärmens innehåll (aktiveras med menyposten Fönster / Tech2Win datavisning). Använd knappen Skriv ut/starta HTML för att starta och stoppa datahämtningen. När du har stoppat hämtningen startas den HTML-relaterade körbara filen (vanligen Internet Explorer) och du får många funktioner för utskrift av data.

Data Display | Data Display

Det finns en 'oanvänd' PCMCIA-mapp på min dator

Tidigare versioner av Tech2Win hade alltid dubbletter av PCMCIA-filer i en separat katalog. Den här katalogen hette ofta C:\PCMCIA. Denna katalog används inte längre eftersom den snabba nedladdningen från TIS2Web gör sådana dubbletter onödiga. Du kan utan problem radera denna katalog.

Jag får meddelandet 'illegal filepath' (otillåten filadress)

Filnamnet verkar innehålla otillåtna tecken, som procenttecken (%). Om detta problem uppträder direkt efter en installation är det bäst att helt enkelt utföra en avinstallation och en ny ominstallation. De flesta fall kan lösas med denna metod.

Under normala installationer, sätts omgivningsvariabeln 'Tech2WinUserData' till 'PUBLIC' (för Windows versioner >= Vista) och till 'ALLUSERSPROFILE\Documents' (för Windows-versioner före Vista). I vissa ovanliga fall ställdes omgivningsvariabeln inte in under installationsprocessen, men fungerade bra vid det andra försöket. Du kan även välja att ställa in omgivningsvariabeln manuellt. Kontakta din administratör för assistans om du inte vet hur man ställer in en omgivningsvariabel.


Registerposter

Följande registerposter skapas av installeraren. Ändra inte dessa poster manuellt. Var uppmärksam på Windows standardvarning vid hantering av registerposter.

Registernyckel | Namn | Typ | Betydelse
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Internt versionsnummer
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Språk (Language) | REG_SZ | Installerat språk
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Sökväg till katalogerna för PCMCIA-kopian
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Rot (Root) | REG_SZ | Installationsväg
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Avinstallationsalternativ | REG_DWORD | Avinstalleringsinställning
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Version av Config-filen
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Version av den virtuella COM-portens drivrutin
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Displaynamn (DisplayName) | REG_SZ | Mjukvarunamn inuti listan Lägg till/ta bort program
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Avinstallationssträng (UninstallString) | REG_SZ | Sökväg till avinstallationsprogrammet


Ominstallation

Återinstallationen kommer att radera hela installationskatalogen för Tech2Win med följande undantag.

  1. Underkatalogen config som innehåller konfigurationerna raderas inte.
  2. Underkatalogen pcmcia som normalt innehåller PCMCIA-bilder raderas inte.
  3. Underkatalogen ATA som kan innehålla felsökningsinformation raderas inte.
Konfigurationsfiler kan bli inkompatibla: Det finns ingen garanti för att en konfigurationsfil för en gammal Tech2Win-version kan läsas av en nyare Tech2Win-version. PCMCIA-bilder kan av princip inte bli inkompatibla.

Den sekundära PCMCIA-katalogen påverkas inte av ominstallationen.

Vissa miljöer kan erbjuda automatisk installation av en nyare Tech2Win-version. Eftersom den senaste installationsinformationen sparas i registret anges dessa inställningar som standardinställningar under ominstallationen.

Du kan framtvinga en ominstallation av Tech2Win genom att använda skriptet enable reinstallation. Skriptet installeras tillsammans med Tech2Win. Skriptet sätter egentligen helt enkelt värdet för nyckeln CurrentVersion som finns i registret vid HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win till värdet '1.000'.