Tech2Win Uporabniški priročnik

Dobrodošli v uporabniškem priročniku Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Vse pravice pridržane.

  • Uvod:
  • Licenca:
  • Namestitev:Opis postopka namestitve Tech2Win.
    • Koraki namestitve
    • Vmesnik za komunikacijo z vozili
  • Prvi koraki
    • Izbiranje konfiguracije
      • Tipkovnica
      • Ravnanje z Windows
    • Nove konfiguracije
    • Modificiranje konfiguracij
      • Jezik
      • Pot
      • Zaslon
      • Shranjevanje konfiguracije
    • Pridobite veljavno licenco Tech2Win.
  • Delo s Tech2Win: Podrobnosti vsakodnevnega dela
    • Meni
    • Prenašanje slike PCMCIA
    • Varnost
    • Ogled poročil
    • Rokovanje s slikami PCMCIA
    • Statusna vrstica
  • Napredne vsebine: Informacije niso potrebne za običajno uporabo Tech2Win. Pogosto zanimivo samo za osebe z administrativnimi opravili.
    • Ponovna namestitev
    • Odstranitev
    • Format konfiguracijske datoteke
    • Datoteka z dnevnikom
    • Obvestila o napakah in kode napak
    • Kartica ATA
    • Registrski vnosi
    • Datoteke
    • Upravljanje konfiguracije
  • Pogosta vprašanja


Uvod

Tech2Win je aplikacija programa Windows, ki lahko posnema funkcionalnost Tech2. Programska oprema Tech2 se v glavnem izvaja na osebnem računalniku. Za zagon tega programa mora vaš osebni računalnik izpolnjevati naslednje tehnične zahteve:

  • Na osebnem računalniku mora biti nameščen in povezan vmesnik za komunikacijo vozila. Seznam sprejemljivih vmesnikov se med regijami lahko razlikuje. V večini primerov se lahko uporabi GMs Multiple Diagnostic Interface (MDI).
  • Aplikacija Tech2Win med namestitvijo zahteva 150 MB prostora na trdem disku. Dodatnih 32 MB je potrebnih na pomnilniško kartico PCMCIA, ki jo želite upravljati.
  • Pred izvajanjem aplikacije Tech2Win potrebujete najmanj 100 MB prostega fizičnega RAM-a. Obvezno je, da ima osebni računalnik dovolj pomnilnika za ohranjanje aplikacije znotraj RAM-a med celotnim časom izvajanja.
  • Osebni računalnik naj bi imel moč enakovredno k 1.2GHz Pentium (enojno jedro). Močno priporočamo, da vzporedno ne uporabljate kakšne druge aplikacije.
  • Tipkovnica ni potrebna. Tech2Win lahko upravljate tudi preko zaslona na dotik. Za upravljanje konfiguracije priporočamo uporabo tipkovnice, saj boste morali vstavljati imena datotek.
  • Vaš barvni grafični prikazovalnik mora imeti ločljivost najmanj 800 x 600 in barvno globino najmanj 256 nivojev. Brez tipkovnice bo morda sprejemljiva ločljivost 640 x 480.

Če uporabljate sistem Tech2Win (prenosnik namesto sistema Tech2), poskrbite, da je prenosnik ustrezno napolnjen. Običajno se prenosnik ne napaja preko akumulatorja vozila tako kot Tech2.

  • Namestitev
  • Prvi koraki


Licenca

General Motors - Tech2Win licenčna pogodba

Preden program uporabljate, previdno preberite naslednja določila in pogoje. Če ne sprejmete ali razumete teh določil ali pogojev, prosimo stopite v stik s krajevnimi poprodajnimi predstavniki. Pravico do uporabe te programske opreme daje General Motors le pod pogojem, da se uporabnik strinja s to licenco in sprejme ta določila in pogoje med nameščanjem programa Tech2Win.
General Motors dopušča pravico uporabe Tech2Win programske opreme in vključenih podatkov v povezavi s TIS2Web ali GlobalTIS ali TIS2000, izključno za uporabnike pooblaščene servisne mreže General Motors, kot je določeno v krajevno uporabnih Sporazumih o pooblaščenih servisnih storitvah sklenjenih z General Motors National Sales Companies.
Licenca Tech2Win velja, dokler so v veljavi sporazumi o pooblaščenih servisnih storivah in je licenca za TIS2Web, GlobalTIS in TIS2000 nameščena. Licenca Tech2Win se prekine skupaj z licenco za TIS2Web in GlobalTIS takoj po prekinitvi pogodbe s pooblaščenim serviserjem.

Neodvisni servisi, kot so opisani v 4 sklepu, 2 odstavek, v European Union Block Exemption Regulation (BER) 1400/2002, lahko kupijo licenco Tech2Win kot del ponujene naročnine, ki jo nudi GM Europe Info Tech Portal ali General Motors Europe.

Licenca Tech2Win se ne ujema s komunikacijskim vmesnikom vozila ali strojno opremo osebnega računalnika.

Tech2Win programske opreme ni dovoljeno razdeljevati, prodajati ali jo posredovati preko spleta tretjim osebam izven pooblaščene servisne mreže (kot je opisano v odgovarjajočem dodatku k Sporazumu), brez pisnega privoljenja pristojnega podjetja General Motors National Sales Companies. To se nanaša tako na trenutne in neaktualne podatke (kot na primer zapadli DVD).

General Motors National Sales Companies ima pravico nemudoma preprečiti dostop in izdati obvestilo o nemudnem prenehanju sporazuma o pooblaščenih servisnih storitvah v primeru nepooblaščene ali neprimerne uporabe. V tem primeru se izključi pravica do terjatev za povračilo stroškov preostale bilance in/ali letnih osnovnih pristojbin.

Zagotovljene informacije služijo za izvajanje servisnih storitev in popravil na strokoven način za nespremenjena vozila skupine General Motors. Za izvajanje prodhodno omenjenega dela je predpogoj zaključeno šolanje za avtomobilskega tehnika in redna dodatna šolanja. Če je v navedenih podatkih nakazana uporaba posebnega orodja, je le-to posebno orodje obvezno za vsa popravila, ki jih je potrebno opraviti strokovno.

Podatki objavljeni na Global TIS podjetja General Motors (besedila in slike, glasba, grafike, animacije, video itd.) in ureditev le tega na Global TIS so zaščiteni z avtorskimi pravicami. Ponatis, širjenje, sporočanje in/ali prenašanje ali kakršna koli druga uporaba ni dovoljena brez predhodnega pisnega dovoljenja podjetja General Motors.

  • Namestitev: Koraki namestitve
  • Prvi koraki


Installation

Namestitev

Namestitev Tech2Win zahteva lokalne pravice administratorja na osebnem računalniku. Brez skrbniških pravic namestitev ne bo delovala. V takšnem primeru za pomoč stopite v stik z lokalnim administratorjem osebnega računalnika.

Za uspešno uporabo Tech2Win, morate zaključiti naslednja dva koraka:

  • Namestitev samega Tech2Win.
  • Namestitev vmesnika za komunikacijo z vozili
  • Namestitev: Koraki namestitve
  • Prvi koraki


Koraki namestitve

Namestitev traja le nekaj minut in od uporabnika zahteva naslednje:

  1. Licenčna pogodba
  2. Imenik namestitve

Jezik

Po privzetih nastavitvah bo uporabniški vmesnik programa Tech2Win prikazan v jeziku operacijskega sistema. Trenutno so običajno lahko podprti naslednji jeziki. Če vaš jezik ni podprt, se namestitveni program zažene v angleščini, ki je privzeti jezik za namestitev.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Angleščina (britanska ali ameriška)*
  • el_GR (EL)Greek
  • es_ES (ES)Španščina
  • fi_FI (FI)Finnish
  • fr_FR (FR)Francoščina
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugalščina (Brazilija)
  • pt_PT (PT)Portugalščina (Portugalska)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Kitajščina (poenostavljena)
  • zh_TW (ZH)Kitajščina (tradicionalna)

* Jezik programa Tech2Win je britanska angleščina. Vendar pa lahko programska oprema Tech2 in namestitveni program uporabljata ameriško angleščino. To je odvisno od vira programske opreme.

Licenčna pogodba

Licenčno pogodbo morate sprejeti.

Imenik namestitve

Kot lokacijo za namestitev Tech2Win lahko izberete kateri koli imenik. Imenik namestitve je privzeto ali <vaš imenik programov>\General Motors\Tech2Win ali v primeru ponovne namestitve, predhodno določena lokacija.

Na koncu potrdite namestitev.

Gonilnik navideznih komunikacijskih vrat

Gonilnik navideznih komunikacijskih vrat se samo enkrat namesti v računalnik in deluje, dokler ne posodobite različice gonilnika (redko) ali programa Tech2Win ne odstranite iz računalnika.
Med nameščanjem programa se za trenutek prikaže okno programa DOS. Okno se bo samo zaprlo in ne zahteva nikakršnega posredovanja. Datoteke gonilnika se bodo dodatno namestile v podmapo 'gonilnik' v namestitvenem imeniku programa Tech2Win.
Gonilnik navideznih komunikacijskih vrat lahko namestite in odstranite tudi ročno, vendar tega ne priporočamo. Uporabite katerega od naslednjih ukazov iz okvira CMD.

  • za namestitev gonilnika vpišite ukaz 'vbsetup7'
  • za odstranitev gonilnika vpišite ukaz 'vbsetup7 /u'
  • Prvi koraki


Vmesnik za komunikacijo z vozili

Naprava za komunikacijo vozila mora biti nameščena ločeno. Glejte navodila za namestitev, priložena vmesniku za komunikacijo z vozili.

  • Prvi koraki: Vmesnik za komunikacijo z vozili
  • Napredne vsebine: Datoteka konfiguracije
  • Namestitev: Koraki namestitve
  • Pogosta vprašanja: Kako lahko uporabljam več kot en MDI?
  • Pogosta vprašanja: Tech2Win ne najde mojega MDI


Prvi koraki

Ti prvi koraki prikazujejo uporabo Tech2Win. Predvidevamo, da ste s samim Tech2 že seznanjeni. Med temi prvimi koraki komunikacija z vozilom ni zahtevana.

Za hiter zagon izvedite naslednje korake:

  1. S pomočjo bližnjice QuickStart na svojem namizju zaženite programsko opremo Tech2Win.
  2. Pridobite veljavno licenco, tako da s sistema TIS2Web naložite novo programsko opremo Tech2.

Za uporabo izbirne konfiguracije:

  1. S pomočjo bližnjice Tech2Win na svojem namizju zaženite konfigurator. Po namestitvi naj bi bila prisotna privzeta konfiguracija.
  2. Za ustvarjanje nove konfiguracije je najbolje, da kopirate izvorno default konfiguracijo.
  3. Spremenite obstoječo konfiguracijo skladno s svojimi zahtevami.
  4. Pridobite veljavno licenco.

Ne zaganjajte Tech2Win v načinu združljivosti. V tem primeru se bo v dnevniški datoteki prikazalo opozorilo. Tech2Win uporablja samo funkcije Windowsov, ki so na voljo od različice XP naprej in ne bo deloval pri starejših različicah Windowsov.

  • Prvi koraki: Nove konfiguracije
  • Prvi koraki: Modificiranje konfiguracij
  • Prvi koraki: Vmesnik za komunikacijo z vozili
  • Delo s Tech2Win: Meni
  • Delo s Tech2Win: Varnost
  • Delo s Tech2Win: Statusna vrstica
  • Napredne vsebine: Datoteka konfiguracije


Izbiranje konfiguracije

Prvič, ko zaženete aplikacijo Tech2Win, se pojavi naslednji zaslon. Imate tudi možnost zagnati Tech2Win neposredno s privzeto konfiguracijo. Ta privzeta konfiguracija deluje s katerokoli komunikacijo vozila.

Start First Time

Prikazalo se bo okno s sporočilom o informacijah o licenci, vendar ga lahko zanemarite, da se zažene privzeta konfiguracija.

Ob uporabi zaslona na dotik bo morda bolj koristno zagnati program tipkovnice osebnega računalnika, da boste lahko vnesli črke preko aplikacije, ki simulira tipkovnico.


Tipkovnica

Tipke osebnega računalnika, če so prisotne, so podobne tipkam Tech2. Tech2Win ima nekaj dodatnih tipk, ki jih ni na originalnem Tech2. Številska tipkovnica na osebnem računalniku morda ne bo delovala v vseh pogojih. Če obstajajo težave, označite, ali je bila spremenjena standardna postavitev tipkovnice na vašem računalniku. V takšnem primeru se lahko poškoduje predvsem tipka SHIFT.

Tipkovnica osebnega računalnika | Gumb | Funkcionalnost
Funkcijska tipka F1 | ni uporabljena | Pomoč Tech2Win
Funkcijske tipke F5 .. F8 | Uporabite prikazno območje Tech2Win, ki je zasedeno z mehkimi tipkami. | Štiri mehke tipke Tech2
Smerniške tipke gor, dol, levo, desno |  | Tech2 tipke gor, dol, levo, desno; Samo te tipke imajo samodejno ponavljanje
Tipke 0 .. 9 | F0 • • • F9 | Tipke Tech2 F0 .. F9
Vračalka | Exit | Tipka izhod iz Tech2
Tipki Vnos/Nazaj | Enter | Tipka vnos Tech2
Y | Yes | Tipka Da Tech2
N | No | Tipka Ne Tech2
Q | ? | Tipka Tech2 ?
S | Shift | Tipka dvigalka v Tech2; Indikator pomika v vrstici stanja ali indikator nad gumbom za pomik prikazuje stanje.
ctrl-P | PWR | Tipka Vklop Tech2; Ta tipka lahko očitno lahko izklopi aplikacijo Tech2Win.
ctrl-R | ni na voljo | Ponastavi Tech2Win. Podobno ciklusu Vklop/Izklop na Tech2. Pri tem pa priloženi vmesnik za komunikacijo z vozili (VCI) ni ponastavljen. Datoteke, kot so posnetki PCMCIA, ne bodo ponovno naloženi.
Domov | Home | Tipka domov. Podprta le v nekaterih aplikacijah.
To je na voljo samo z menijsko možnostjo Datoteka. | Print Screen | Natisne posnetek zaslona Tech2 in ustvari začasno BMP-datoteko in prikliče aplikacijo, ki je povezana z BMP-datotekami. Uporabite to aplikacijo za povečanje ali zasuk slike pred tiskanjem.
To je na voljo samo z menijsko možnostjo Datoteka. | Save Screen | Shrani posnetek zaslona Tech2 v datoteko oblike BMP ali PNG.
To je na voljo samo z menijsko možnostjo Datoteka. | View Report | Prikaže uporabniku v pogled vsa poročila aktivne pomnilniške kartice PCMCIA.


Ravnanje z Windows

Velikost okna lahko spreminjate s standardnimi mehanizmi Windows z vlečenjem mejnih linij glavnega okna. Menijska možnost Možnosti/Ločljivost dodatno podpira več velikosti za prednastavitve. Med spreminjanjem velikosti glavnega okna preko menijskega elementa se bo okno tipkovnico samodejno fiksiralo.

Videz okna se modificira s spreminjanjem konfiguracij v zavihku Zaslon.


Nove konfiguracije

Za ustvarjanje novih konfiguracij kliknite gumb Ustvari novo. Pojavilo se bo pogovorno okno, ki vas pozove k izbiri obstoječe konfiguracijske datoteke, ki bo služila kot vir. Običajno je izbrana privzeta konfiguracija. Po vnosu imena nove konfiguracije pritisnite gumb Kopiraj.

Če delate z zaslonom na dotik, boste morda raje aktivirali simulacijo tipkovnice osebnega računalnika z gumbom Tipkovnica osebnega računalnika.

Z gumbom Prekliči lahko prekličete postopek ustvarjanja.

Nova konfiguracija bo uporabljala isto podobo PCMCIA kot obstoječa izvorna konfiguracija. Če želite to spremeniti, morate spremeniti konfiguracijo, da bo ta uporabljala drugo PCMCIA datoteko. Največkrat lahko enostavno kopirate obstoječo PCMCIA datoteko v novo datoteko in zatem uporabite to. Morda pa želite, da nova konfiguracija uporablja isto PCMCIA datoteko kot izvorna konfiguracija. V tem primeru se na zaslonu pojavi opozorilo, ko pritisnete na gumb Shrani.

  • Modificiranje konfiguracij


Modificiranje konfiguracij

Konfiguracije označene modro so označene Samo za branje in jih ni možno modificirati. Te konfiguracije lahko samo pogledate. Seveda lahko uporabite metodo modifikacije, da si jih preprosto ogledate, vendar Shrani ne bo možno.

Konfiguracijo modificirate z izbiro posamezne nastavitve v štirih zavihkih Jezik, Vmesnik za komunikacijo z vozili, Pot, Zaslon. Izberete lahko želeni tabulator ali preprosto pritisnete na gumb Naslednji, ki bo aktiviral naslednji tabulator. Po izvedbi modifikacij pritisnite gumb Shrani, da konfiguracijo shranite.

Ko je potreben vnos s tipkovnico, lahko prav tako prikličete aplikacijo osebnega računalnika, ki simulira tipkovnico osebnega računalnika. To je še posebej priročno na prenosnih računalnikih z zaslonom na dotik, kjer tipkovnica ni na voljo.


Jezik

Zavihek Jezik omogoča izbiro jezika, v katerem bo deloval Tech2Win. Ta izbira ne vpliva na jezik znotraj programske opreme Tech2 na sliki PCMCIA. Ob prenašanju programske opreme Tech2 iz TIS boste kljub temu morali izbrati pravilen jezik.

Za nekatere regije vsi jeziki ne bodo na voljo. V tem primeru bo prikazan angleški jezik. Preverite, ali je na voljo podoben jezik (PT Portugalščina-Portugalska rajši kot PB Portugalščina-Brazilija).


Pot

Zavihek Pot vam omogoča nastavitev poti slik PCMCIA ter tudi poti do tipkovnice lokalne programske opreme. Dodatno je dodan gumb Kopiraj pomnilniško kartico za kopiranje slik PCMCIA. Če ste pravkar ustvarili novo konfiguracijo, boste morda uporabili ta gumb, da preprečite, da bi več konfiguracij uporabljalo isto podobo PCMCIA.

Memory Card Options

Kopiraj pomnilniško kartico ...

Ta gumb vam omogoča kopiranje slike PCMCIA v drugo datoteko. Njegovo delovanje je zelo podobno nakupu nove kartice PCMCIA za Tech2. Funkcija kopiranja deluje samo za datoteke v imeniku C:\Users\Public\General Motors\Tech2Win\pcmcia.

Reža 0: Lokacija slike pomnilniške kartice

Tukaj lahko določite datoteko, ki vsebuje vašo sliko PCMCIA za režo 0. Običajno se takšne datoteke nahajajo v C:\Users\Public\General Motors\Tech2Win\pcmcia, vendar so možne tudi druge lokacije.

Reža 1: Pomnilniška kartica ali ATA

Kot Tech2, Tech2Win prav tako podpira dve kartici PCMCIA (slike). Vendar pa druga slika PCMCIA znotraj konfiguracije običajno ni zelo uporabna. V drugi konfiguraciji bi verjetno bila uporabljena druga programska oprema.

Kot pri Tech2 se kartica ATA uporablja za namene popravljanja napak. Kartico ATA aktivirajte le, če vam tako naroči tehnična podpora. Ta vam bo prav tako nudila dodatne informacije.

Lokacija programske opreme osebnega računalnika na tipkovnici

Privzeta vrednost te datoteke se pridobi iz registra Windows in naj bi nakazala aplikacijo sposobno simuliranja tipkovnice osebnega računalnika z miško. Če imate posebno aplikacijo s to funkcionalnostjo za prenosni računalnik, ki ga uporabljate, lahko aplikacijo določite tukaj.


Vmesnik za komunikacijo z vozili

  • COM-vhod za emulacijo Tech2-RS232 (posnemanje)
  • Serijska številka MDI za uporabo
  • Protokol

COM-vhod za emulacijo Tech2-RS232 (posnemanje)

Izberite prosta vrata COM, ki jih je mogoče uporabiti za emulacijo Tech2. Konfigurator vam olajša delo tako, da poskuša poiskati tista serijska vrata, ki so že v uporabi in jih prikaže.

Če izberete obstoječa serijska vrata, se Tech2Win priključi na ta obstoječa serijska vrata. Ta serijska vrata lahko z neposredno kabelsko povezavo uporabite za prenos programske opreme Tech2 iz drugega računalnika, na katerem se izvaja aplikacija TIS. Ne pozabite, da resnična serijska vrata morda ne bodo delovala zanesljivo s hitrostjo 115.200 Bd zaradi omejitev operacijskega sistema Windows.

Če izberete neobstoječa serijska vrata, sistem Tech2 Win samodejno ustvari navidezna vrata. Ta navidezna vrata je mogoče uporabljati v aplikaciji TIS, ki se izvaja na istem osebnem računalniku, za vzpostavitev komunikacije s sistemom Tech2Win. Kadar uporabljate navidezna vrata, hitrost ni omejena.

Če za vrata COM izberete možnost 'Išči', bo program Tech2Win ustvaril navidezna vrata COM na prvi prosti številki vrat v razponu od 9 do 1.

Serijska številka MDI za uporabo

Vnesite serijsko številko enote MDI. Številko najdete na zadnji strani enote MDI. Uporabite številko za vezajem.

Če ne vnesete serijske številke, programska oprema Tech2Win samodejno prikaže seznam naprav MDI, ki so bile zaznane v omrežju, da lahko uporabnik izbere napravo MDI. Enako izbirno polje se prikaže, če ni mogoče najti navedene naprave MDI.

Protokol

Izbere se 'ISO22900-2 / PDU-API', možnost J2534-2 je vedno siva. V prihodnje bo sistem Tech2Win morda lahko podpiral tudi protokol J2534.

  • Napredne vsebine: Datoteka konfiguracije
  • Pogosta vprašanja: Kako naj določim, katera serijska vrata naj uporabim za sistem Tech2Win?
  • Pogosta vprašanja: Komunikacija med aplikacijama Tech2Win in TIS2Web
  • Pogosta vprašanja: Kako lahko uporabljam več kot en MDI?
  • Pogosta vprašanja: Tech2Win ne najde mojega MDI


Zaslon

Zavihek Zaslon se v glavnem uporablja za spreminjanje nastavitev prikaza Tech2Win:

  • Tipkovnica
  • Barve
  • Zvok
Display and Key Options

Tipkovnica

Tukaj lahko izberete ali želite prikazati tipkovnico. Tipkovnica je prikazana na levi ali desni strani zaslona Tech2Win. Barva ozadja se izbere preko standardnega pogovornega okna z barvami.

Barve

Barvi ozadja in ospredja zaslona Tech2 lahko individualno izberete tukaj. To sta najpogostejši barvni kombinaciji:

Screen with background 0000FF, foreground FFFFFF | Ozadje tipkovnice belo; Modro ozadje; Ospredje belo
Screen with background 000000, foreground C0C0C0 | Modro ozadje tipkovnice; Ozadje črno; Ospredje svetlo sivo

Zvok

Tukaj lahko izklopite zvok. Ob vsakem zvoku programa Tech2 bo uporabljen zvočnik osebnega računalnika.


Shranjevanje konfiguracije

Aktivno konfiguracijo lahko shranite z gumbom Shrani <konfiguracijo> v spodnjem levem kotu. Gumb se ne bo pojavil ob ogledu konfiguracije Samo za branje.


Veljavna licenca preko TIS2Web

Običajno boste veljavno licenco dobili s prenosom programske opreme Tech2 v sistem Tech2Win. Poleg tega lahko to pridobite tako, da izvedete varnostni dostop 'Varnostni dostop (Varnost)' prek sistema TIS2Web (ne TIS2000). Predpogoj za to je izbira navideznih serijskih vrat v konfiguratorju pod možnostjo Vmesnik za komunikacijo z vozili.

Po uspešnem varnostnem dostopu lahko vidite na desni strani vrstice stanja odprto ključavnico. V oklepajih se izpiše število dni veljavnosti licence. Pri ponovnem zagonu Tech2Win se varnostni indikator ne prikaže, dokler ne pride do komunikacije z vozilom. Med prvo komunikacijo z vozilom, se licenca preveri, znak pa se preklopi na odprto ali zaprto ključavnico.

  • Delo s Tech2Win:Varnost
  • Pogosta vprašanja:Kako naj določim, katera serijska vrata naj uporabim za sistem Tech2Win?
  • Pogosta vprašanja:Komunikacija med aplikacijama Tech2Win in TIS2Web
  • Pogosta vprašanja:Veljavna licenca
  • Pogosta vprašanja:Kakšna je razlika med licenco Tech2Win in Security Access?


Delo s Tech2Win

Naslednje teme ob delu s Tech2Win uporabljajo pretežno tehniki:

  • Meni: Postavitev zaslona in posamezni predmeti menija.
  • Prenos slike PCMCIA: Posodobitev diagnostične programske opreme za Tech2Win je zelo podobna metodi uporabljeni za Tech2.
  • Varnost: Varnostni ukrepi preprečujejo, da bi Tech2Win izvajal komunikacijo z vozilom v nepooblaščenih okoljih.
  • Ogled poročil: Tipkovnica Tech2 je v Tech2Win nekoliko povečana. Gumb 'Ogled poročil' je najodličnejši primer.
  • Rokovanje s slikami PCMCIA: Podobno kot lahko imate več kartic PCMCIA za Tech2, lahko imate nekaj slik PCMCIA v uporabi za Tech2Win.
  • Statusna vrstica: Statusna vrstica uporabnika obvešča o posameznih delih statusne vrstice.
    • Napredne vsebine
    • Pogosta vprašanja


Meni

Aplikacija Tech2Win ima naslednje menijske vnose:

  • Datoteka
  • Možnosti
  • Okna
  • Pomoč

Datoteka

Meni Datoteka ponuja naslednje možnosti:

  • Shrani zaslon T2 (320x240) se uporablja za shranjevanje dejanskega zaslona T2 na računalnik v ločljivosti 320x240 slikovnih pik v obliki datoteke s črno-belo fotografijo. Lokacijo in obliko datoteke (BMP, GIF, JPG, PNG) si lahko prosto izbirate.
  • Natisni zaslon ustvari obrnjen črno-bel posnetek BMP zaslona Tech2 in požene program, ki je povezan z datotekami BMP. Ta program lahko nato uporabite, če želite posnetek natisniti.
  • Možnost Poglej datoteko poročil omogoča prikazovanje (in tiskanje) datotek s poročili brez uporabe aplikacije TIS2Web.
  • Možnost Izhod zapre sistem Tech2Win.

Možnosti

Možnosti ponuja naslednje izbirne možnosti:

  • Možnost Ločljivost omogoča izbiranje med tremi standardnimi velikostmi zaslona.
  • Možnost ROM-Write from 0x00003ED76 se uporablja za notranje iskanje in odpravljanje napak.
  • Samodejni posnetki zaslona za shranjevanje posnetkov različnih zaslonov Tech2 v imenik z dnevniki.
  • Onemogoči CANdi in zaženi znova za imitacijo Tech2 brez nameščenega CANdi med aplikacijo in vozilom. To je potrebno v redkih primerih, kjer CANdi prekinja komunikacijske povezave z nestandardnimi vozili.

Okna

Meni Okna vam omogoča možnost aktiviranja izborov Podatkovni prikaz Tech2Win in DTC-prikaz Tech2Win. Vseh ostalih izborov v trenutni različici Tech2Win ni mogoče izbrati.

Če programska oprema Tech2 podpira Podatkovni prikaz Tech2Win, lahko omogočite ta menijski vnos. Po vnosu prikaz podatkov Tech2win prikaže dodatno okno prikaza podatkov vzporedno s prikazom podatkov Tech2. Dokler je na zaslonu Tech2 prikazan podatkovni prikazovalnik, menijskega vnosa ni mogoče omogočiti. V takšnem primeru morate zapreti podatkovni prikazovalnik, omogočiti menijski vnos in ponovno odpreti podatkovni prikazovalnik.

Podobne omejitve za Podatkovni prikaz Tech2Win veljajo tudi za DTC-prikaz Tech2Win. Če programska oprema Tech2 podpira DTC-prikaz Tech2Win, lahko omogočite ta menijski vnos. Vzporedno s prikazovalnikom DTC Tech2 se bo prikazalo še dodatno prikazovalno okno za DTC-je. Dokler je na zaslonu Tech2 prikazan prikazovalnik DTC-jev, menijskega vnosa ni mogoče omogočiti. V takšnem primeru morate zapreti prikazovalnik DTC-jev, omogočiti menijski vnos in ponovno odpreti prikazovalnik DTC-jev.

Pomoč

Na voljo so naslednje izbire:

  • Možnost Teme pomoči ... odpre pomoč sistema Tech2Win.
  • Možnost Parameter ukazne linije prikaže parametre ukazne vrstice, ki se uporabljajo za sistem Tech2Win.
  • Vizitka prikaže številko trenutne različice in omejitve prenosa TIS2Web programske opreme Tech2Win.


Prenos

Najprej zaženite Tech2Win in ga pustite na glavnem zaslonu. Zaženite TIS2Web ali GlobalTIS in opravite prenos preko serijskih vrat, določenih v jezičku Vmesnik za komunikacijo z vozili.

Uporaba vgrajenih vhodov COM je možna za prenos programske opreme Tech2 iz drugega osebnega računalnika, ki ima TIS. Zagotovite uporabo križno vezanega kabla RS232. Glede na strojno opremo osebnega računalnika na katerem se izvaja Tech2Win, boste stopnjo prenosa podatkov morda morali znižati na 57.600 baudov, saj lahko Windows pri višnji stopnji baudov izgubi podatke.

Zadnja verzija Tech2Win podpira hiter prenos, tudi če TIS2Web in Tech2Win obratujeta na istem računalniku. Sicer še zmeraj obstaja minimalna komunikacija med TIS2Web in Tech2Win, prenos podatkov, ki porabi največ časa, pa je nadomeščen z notranjim prenosom datotek. S tem je čas za prenos podatkov bistveno skrajšan krepko pod eno minuto.

  • Napredne vsebine: Datoteka konfiguracije
  • Prvi koraki: Vmesnik za komunikacijo z vozili
  • Pogosta vprašanja: Kako naj določim, katera serijska vrata naj uporabim za sistem Tech2Win?
  • Pogosta vprašanja: Komunikacija med aplikacijama Tech2Win in TIS2Web


Varnost

Varnostni mehanizmi sistema Tech2Win se zanašajo na pravilno nastavljeno uro osebnega računalnika. Poskrbite, da je ura vašega osebnega računalnika vedno nastavljena. Sistem Tech2Win bo dovolil manjše spremembe ure, na primer zaradi prehoda med poletnim in zimskim časom.

Sistem Tech2Win ne bo izvajal nikakršne komunikacije z vozilom, če nima veljavne in aktivne licence. Naslednji znak v vrstici stanja kaže stanje licence:

  • green smiley Licenca je veljavna:
  • Ni indikatorja: Licenca še ni bila preverjena.
  • red smiley Licenca je potekla.

Za pridobitev licence s pomočjo aplikacije TIS2Web posodobite 'Varnostni dostop (Varnost)'. V večini primerov bo za pridobivanje nove licence zadoščal prenos programske opreme preko aplikacije TIS2Web. Ker bo licenca po določenem časovnem obdobju postala neveljavna (ponekod po štirih tednih), morate posodobitev opravljati redno.

Licence so ločene po regijah in programski opremi. Morda imate licence v računalniku, če uporabljate sistem Tech2Win z različnimi programskimi različicami Tech2.

Število dni do poteka veljavnosti licence je prikazano v vrstici s stanjem.

  • (0) pomeni, da je licenca potekla ali da ne obstaja.
  • (<1) Licenca bo potekla v naslednjih 24 urah.
  • (20) Licenca bo potekla v 20 dneh.

Prosimo, da ne posegate v datoteko z licenco. Zlonamerne spremembe datoteke bodo zaznali vgrajeni varnostni mehanizmi, kar bo povzročilo izgubo vseh licenc v računalniku. Poleg tega se lahko sistem Tech2Win obnaša na nepričakovan način. To lahko rešite samo z izvedbo nove namestitve.

  • Napredne vsebine: Sporočila napak in kode izhoda
  • Napredne vsebine: Datoteka z dnevnikom
  • Delo s Tech2Win: Statusno okno
  • Pogosta vprašanja: Veljavna licenca
  • Pogosta vprašanja: Kakšna je razlika med licenco Tech2Win in Security Access?
  • Pogosta vprašanja: Nenadna ustavitev


Ogledovanje poročil

View Report Ta gumb lahko uporabite za ogled vsebin datotek PRT prisotnih na kartici PCMCIA. Za prikaz seznama datotek PRT se bo pojavilo pojavno okno. Če je bil povezan program s končnico PRT, se bo izvedel ta povezan program. V nasprotnem primeru se bo pokazal urednik beležnice za prikaz izbrane datoteke.

V večini primerov je datoteka PRT datoteka ASCII, ki uporablja jezik zadevnih kod strani. Za kitajščino, japonščino, korejščino in tajščino je datoteka v unicode z vodilno oznako Byte-Order-Mark (BOM).

Med ogledom poročil deluje Tech2Win s podimenikom C:\Users\Public\General Motors\Tech2Win\reports. Ta podimenik bo obstajal le, če ste si poročila vsaj enkrat ogledali. Imenik se samodejno izbriše in deluje kot začasen imenik za datoteke PRT na aktivni kartici PCMCIA. Te datoteke bo vseboval tudi, če Tech2Win preneha delovati. Če takšno datoteko želite shraniti, jo morate kopirati v drug imenik, saj se lahko v nasprotnem primeru prepiše, ko si bo kakšen drug uporabnik ogledal poročila.


Slike PCMCIA

Podobe PCMCIA se običajno nahajajo v podimeniku C:\Users\Public\General Motors\Tech2Win\pcmcia. Datoteka mora imeti velikost natančno 32 MB (33.554.432 bitov) ali 10 MB (10.485.760 bitov) in končnico datoteke *.bin. Slike se modificirajo (kot bi se vsaka običajna kartica PCMCIA), če se izvede prenos ali če Tech2Win nekaj shrani na pomnilniški kartici. Modifikacijo lahko onemogočite z zaščito pred pisanjem (ukaz -W0 ali -W1) ali z izpustitvijo vrednosti 'p' v možnosti '-W'.(Datoteka konfiguracije). Stikalo za zaščito pred pisanjem ni dosegljivo preko konfiguratorja. Če želite uporabiti možnost '-W0', '-W1' ali '-W', morate ročno spremeniti konfiguracijo.


Statusna vrstica

Statusna vrstica je prikazana pod zaslonom Tech2. V statusni vrstici so prikazani naslednji predmeti:

  1. Pokazatelj hitrosti
  2. Stanje komunikacije z vozilom
  3. Stanje zaporednega vhoda
  4. Gumb SHIFT
  5. Samodejni posnetki zaslona
  6. Opozorilo vpisa
  7. Licenca

Status Bar

Pokazatelj hitrosti

Pokazatelj hitrosti prikazuje, koliko časa CPU se porabi za posnemanje programske opreme Tech2. Nizka številka (pokazatelj na levi) je boljša kot visoka številka (pokazatelj na desni). Sprejemljiv je kateri koli zelen pokazatelj. Pokazatelj lahko za kratek čas postane rumen, če nenadoma postane aktivna kakšna druga naloga programa Windows. Takšnim aktivnostim bi se naj izognili.

Stanje komunikacije z vozilom

Stanje komunikacije z vozilom označuje, ali je prisoten Vmesnik za komunikacijo z vozili (MDI) in ali je vzpostavljena komunikacija med vozilom in Tech2Win.

Stanje zaporednega vhoda

Ob komunikaciji s Tech2Win preko vhoda COM, ta pokazatelj nakazuje ali je komunikacija na COM aktivna ali ne.

Gumb SHIFT

Ta indikator prikazuje, ali je gumb SHIFT aktiven. Prav tako lahko namesto njega uporabite gumb 'S' na ali gumb SHIFT na tipkovnici.

Samodejni posnetki zaslona

V meniju Možnosti lahko omogočite samodejno zajemanje posnetkov zaslona. Ob vsaki spremembi zaslona se bo v imenik z dnevniki shranila nova datoteka s posnetkom zaslona. Slednje je označeno s premikanjem ročice na rdečem fotoaparatu v vrstici stanja. Takoj, ko možnost samodejnega zajemanja posnetkov zaslona onemogočite, bo fotoaparat izginil.

Opozorilo vpisa

Kazalnik stanja dnevnika ima lahko tri različna stanja.

  • gray log status indicator Dnevniška datoteka ne vsebuje opozoril ali napak.
  • yellow log status indicator Dnevniška datoteka vsebuje opozorilo.
  • red log status indicator Dnevniška datoteka vsebuje obvestilo o napaki.

Licenca

Znak za licenco lahko ima tri stanja:

  • green smiley Licenca je aktivna in veljavna.
  • Ni indikatorja: Licenca še ni bila preverjena.
  • red smiley Licenca je potekla ali ne obstaja.
Za več podrobnosti glejte povezavo Varnost.

Opisi orodja na vrstici stanja

Za nekatere ikone so prikazani opisi orodja, ki nudijo dodatne informacije.

Opis orodja za serijsko številko VCI:
Tooltip VCI

Opis orodja za različico programske opreme TECH2
Tooltip TECH2

Opis orodja za serijska vrata
Tooltip Comport

Opis orodja za številko naslednjega posnetka zaslona (če so 'Samodejni posnetki zaslona' vklopljeni)
Tooltip Camera

Opis orodja, ki prikazuje zadnji vnos dnevniške datoteke s stopnjo 'pozor' ali višjo
Tooltip Logfile

Opis orodja za točno trajanje licence
Tooltip License

Opisi orodja se prikažejo, če je kurzor več kot pol sekunde nad ikono, ne da bi se premaknil. Opisi orodja izginejo po 5 sekundah ali po premiku kurzorja.

  • Napredne vsebine: Obvestila o napakah in kode napak
  • Napredne vsebine: Datoteka z dnevnikom


Napredne vsebine

Tukaj predstavljene teme so za standardnega uporabnika Tech2Win manj pomembne. Vsakomur, ki je vključen v namestitev, upravljanje in konfiguracijo Tech2Win bodo morda koristile naslednje informacije.

  • Ponovna namestitev
  • Odstranitev
  • Neposredna modifikacija konfiguracijskih datotek
  • Datoteka z dnevnikom
  • Sporočila napak in kode izhoda
  • Kartica ATA
  • Registrski vnosi
  • Opis datoteke
  • Primer upravljanja konfiguracije


Odstranitev

Kompletni namestitveni imenik, imenik z uporabniškimi podatki (C:\Users\Public\General Motors\Tech2Win) in imenik s podatki aplikacije (C:\ProgramData\General Motors\Tech2Win) so izbrisani.

  • Napredne vsebine: Ponovna namestitev
  • Namestitev


Datoteka konfiguracije

Konfiguracijske datoteke se vedno nahajajo v podimeniku C:\Users\Public\General Motors\Tech2Win\config in imajo končnico *.conf. Lahko se odločite za ročno modifikacijo konfiguracijske datoteke, saj vse možnosti datoteke niso dostopne skozi Tech2Win. Datoteka konfiguracije je datoteka Unicode z Byte-Order_Mark (BOM). Ob izvajanju ročnih sprememb predlagamo, da uporabite urejevalnik za Unicode, kot je na primer Beležnica.

Konfiguracijska datoteka je linijsko orientirana. Prazne linije so prezrte. Linija se vedno začne z možnostjo in običajno ji sledi vrednost. Kot primer si oglejte default.conf file. Za vse razpoložljive možnosti glejte naslednjo preglednico.

Če želite zagnati določeno konfiguracijo neposredno z namizja, ustvarite bližnjico, ki izvrši 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Program bi morali zagnati iz naslednjega delovnega imenika: 'C:\Program Files\General Motors\Tech2Win\bin'

Opcije | Vrednost/pomen
; Komentar
@ Decimalna različica števil je v formati glavno.manjše.
Druge datoteke konfiguracij z drugačnim glavnim številom kot Tech2Win ne bodo sprejete. Druge datoteke konfiguracij z nižjim manjšim številom kot Tech2Win bodo sprejete.
-W0
-W1 		Kartica PCMCIA v reži 0/1 ima aktivirano stikalo za zaščito pred pisanjem.
-B0
-B1 		Velikost blokov v kilo bajtih kartice PCMCIA v reži 0/1. Sprejemljive vrednosti so 128 (privzeto) ali 256.
-P0
-P1 		Datoteka vsebuje binarno sliko kartice PCMCIA za režo 0/1. Velikost datoteke mora biti natančno 10 MB ali 32 MB. Spremenljivke okolja kot %ProgramData% so razširjene.
Če ta možnost ni prisotna se predvideva, da je reža prazna.
-A0
-A1 		Datoteka vsebuje vrednosti atributa kartice PCMCIA v reži 0/1. Če ni prisotna, bodo uporabljeni privzeti atributu na osnovi kartice in velikosti bloka.
-W | Ob izhodu iz Tech2Win bodo vsi trajni podatki vpisani v zadevne datoteke. Vrednosti p/f/r/c so lahko kombinirane za označevanje zadevne aplikacije PCMCIA/Flash-ROM/RTC/CANDI.
-H | Funkcija skupnega upravljanja Vrednosti 0/r/w/t je mogoče združiti, da bi aktivirali funkcijo za nastavitev ničle, branje pregledov, zapisovanje pregledov in preglede opravila. Vrednosti I se vedno uporablja za uveljavljanje skupinskega pomnilnika pri nižjih naslovih, ko se uporablja alternativna shema dodelitve. Običajno se ta možnost uporablja v razvojnem okolju.
-PC | Prej pot kopije kartice PCMCIA Ta možnost je trenutno izključena.
-MS | Identifikacija vmesnika za komunikacijo z vozili (MDI) s serijsko številko. Če naprava MDI ni nastavljena, se prikaže seznam razpoložljivih naprav MDI.
-CT | Barva besedila (ospredje) v 3 heksadecimalnih bitnih vrednostih. Privzeta vrednost je 000000 (bela).
-CB | Barva ozadja v 3 heksadecimalnih bitnih vrednostih. Privzeta vrednost je FFFFFF (črna).
-ATA | Uporabite to možnost, da omogočite kartico za zajemanje ATA. Odstranite jo, da onemogočite kartico za zajemanje ATA.
-C | Številka vhoda COM (1..9) se mora uporabljati kot komunikacijski vhod Tech2 RS232C. Za navidezen vhod COM, ki ga namesti Tech2Win, se pogosto uporablja COM9. Če ta možnost ni na voljo, se izvede iskanje prostih vrat COM od COM9 navzdol. Če si želite ogledati, katera vrata COM se uporabljajo, uporabite opis orodja, ki je v vrstici stanja med ikonama Tech2 in TIS2Web.
-WR | Naslov PCaddress (običajno 253558), ki ima dovoljenje za zapisovanje v območje PCMCIA in FLASH ROM. To funkcionalnost je potrebno naknadno aktivirati prek menija (ali z uporabo možnosti - WA). Napake kode v nespremenljivem pomnilniku je treba poiskati s koračnim iskalnikom napak.
-WA | Programu za iskanje napak po korakih ('SingleStep Debugger') dovolite, da piše na nespremenljivi pomnilnik.
-OF | Datoteka z možnostmi, ki vsebuje pare možnosti in vrednosti.
-TP | Nastavitev časovne uskladitve (proporcionalna vrednost). Privzeta vrednost je 5000. Zmanjšajte to vrednost, da se število izvedenih ciklov hitreje prilagodi realnemu času.
-TD | Nastavitev časovne uskladitve (vrednost razlike). Privzeta vrednost je 100. Zmanjšajte to vrednost, da se lahko sistem hitreje odzove na spremembe v takojšnji časovni uskladitvi. OPOZORILO: Spreminjanje vrednosti TP in TD lahko povzroči težave s hitrostjo.
-PJ
-PP 		Določite protokol, ki naj se uporabi:
PJ za komunikacijo J2534.
PP za ISO22900-2 / PDU-API (privzeto)
-S | Prisotnost te možnosti omogoča zvočni izhod na zvočnik osebnega računalnika.
-L | Jezik aplikacije Tech2Win. Če je ta vnos prazen, bo uporabljen jezik, ki je nastavljen za sistem Windows. Glejte naslednjo povezavo za seznam jezikov, ki jih lahko določite: Jezik. Samo emulacijsko okno Tech2 bo prikazalo jezik kartice PCMCIA (ki je bil prenesen v kartico PCMCIA).
-UD | Premostitev uporabniškega podatkovnega imenika. V sistemu Win7 se običajno nahaja v C:\Users\Public\General Motors\Tech2Win
-AD | Premostitev programskega podatkovnega imenika. V sistemu Win7 se običajno nahaja v C:\ProgramData\General Motors\Tech2Win
-US | Uporabite uporabniško specifični semafor za zaznavanje več kot enega primerka sistema Tech2Win. Ta možnost bo vsakemu uporabniku omogočila, da Tech2Win zažene vzporedno na isti napravi, verjetno na strežniku. Pri uporabi te možnosti morate določiti tudi možnosti -UD in -AD.
-SS | Možnost za določanje skupne velikosti okna sistema Tech2Win vključno s tipkovnico (če je prisotna). Prvi parameter mora biti niz v dvojnih navednicah (') in bo uporabljen kot ime velikosti v meniju Možnosti / Ločljivost. Drugi parameter je skupno število vodoravnih slikovnih pik zaslona Tech2Win vključno s tipkovnico. Tretji parameter je skupno število navpičnih slikovnih pik zaslona Tech2Win. Četrti izbirni parameter je širina tipkovnice v slikovnih pikah.
-SH Možnost upravljanja zaslona. Naslednje decimalno število se uporablja za določanje tistih možnosti upravljanja zaslona, ki bodo onemogočene.
  • Bit 0: Možnost min./maks. ni mogoča.
  • Bit 1: Prestavljanje položaja na zaslonu ni mogoče.
  • Bit 2: Spreminjanje velikosti ni mogoče. V tem primeru meni Možnosti / Ločljivost ni na voljo.
  • Bit 3: Podatkovni zaslon in okna DTC morajo biti popolnoma enake velikosti kot zaslon sistema Tech2Win (brez tipkovnice).


Beleženje

Vsak zagon konfiguracije Tech2Win ustvari novo dnevniško datoteko v obliki HTML v podimeniku (C:\Users\Public\General Motors\Tech2Win)Logs. Dnevniške datoteke, starejše od enega tedna, se bodo samodejno izbrisale, da se izognete nepotrebnemu zasedanju trdega diska.

Datoteke z dnevnikom so samodejno poimenovane skladno z datumom nastanka (leto, mesec, dan) in časom (ura, minuta, sekunda):
yyyy-mm-dd_hhmmss.html

Vnosi datoteke z dnevnikom so vedno v angleškem jeziku, vendar v formatu Unicode format z vodilno Byte-Order-Mark (BOM). Vsaka vrstica v datoteki z dnevnikom je v eni izmed naslednjih stopenj dnevnika:

Stopnja dnevnika | Pomen
Info | Samo informacije Nima učinka na izpeljavo programa.
Opozorilo | Pojavila se je neobičajna situacija. Uporabnik morda ne vidi škodljivih učinkov.
ERROR | Pojavila se je napaka, ki bo vidna za uporabnika.
CRITICAL | Pojavila se je kritična napaka, ki bo povzročila nenormalno vedenje programa.
FATAL | Resna napaka bo povzročila takojšno zaustavitev Tech2Win.

Vse stopnje nad stopnjo 'Pozor' so obarvane tako, da jih je mogoče enostavno najti.

Razen tega se bodo datoteke za tiskanje in datoteke video v primeru uporabe menijske možnosti Natisni zaslon ali Samodejni posnetki zaslona nahajale tudi v podimeniku Logs.
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
Slike Samodejni posnetki zaslona so povezane z datoteko HTML - zato uporabite dnevnik HTML za pogled zaporedja teh slik.

Uporabnik je v statusni vrstici informiran o obstoju vnosa opozorila ( yellow lightning bolt) ali bolj resnega vnosa v dnevnik ( red lightning bolt).


Sporočila napak in kode izhoda

Sporočila napak se lahko pojavijo v pogovornih oknih. Ta pogovorna okna še vedno omogočajo Tech2Win vzporedno izvajanje programa Tech2. Kode izhoda so resne napake, ki povzročijo nenormalno zaključevanje Tech2Win. Kode izhoda se lahko uporabljajo v paketnih datotekah za zaznavanje vzroka zaključevanja programa

Sporočila napak

Pojavijo se lahko naslednja sporočila napak. Sledi kratka razlaga situacije in reševanja težave.

Emulator too slow Emulator failed to start

Kode izhoda

Koda izhoda | Vrednost | Pomen
OPCODE_ERROR | -7 | Zaznan je bil neveljaven ukaz mikroprocesorja Tech2 (68332). Morda je slika PCMCIA poškodovana.
ATA_PROBLEM | -6 | Pojavila se je težava med posnemavanjem ATA. Če se takšna težava pojavi zatem, ko ste prejeli navodilo za uporabo kartice ATA, se obrnite na pomoč.
DEMO_TIME_IS_UP | -5 | Naj se ne bi pojavilo v uradni različici Tech2Win.
DLL_NOT_LOADED | -3 | Enega izmed zahtevanih DLL-jev ni bilo možno naložiti. Zdi se, da imate nepopolno različico Tech2Win. Izvedite novo namestitev in/ali izberite drug jezik.
EXIT_INIT_FAILED | -2 | Inicializacija neuspešna. Natančen vzrok poiščite v datoteki z dnevnikom. Če datoteka z dnevnikom ne obstaja, preverite ali imate pravilen dostop branja/zapisovanja do vseh imenikov.
normalno | 0 | Tech2Win se je zaključil normalno.


Kartica ATA

Kartica ATA se pri Tech2 običajno uporablja le za iskanje napak med postopkom razvijanja programske opreme. Vsi potrebni podatki ATA so shranjeni v podimeniku C:\Users\Public\General Motors\Tech2Win\ataCapture. Imenik običajno nima pomena in ga lahko varno izbrišete, razen če je v specifikacijah določeno drugače.

Ker je imenik ataCapture fiksen, bodo njegove vsebine enake za vse konfiguracije.


Datoteke

Tech2Win uporablja naslednje datoteke in imenike:

Imenik | Lakacija pred Vista | Lokacija za Vista in kasnejše
Namestitev | Kot je določeno med namestitvijo
Uporabniški podatki | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Podatki aplikacije | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Datoteka | Uporablja
[Uporabniški podatki]\atacapture | Vsebuje datoteke, prisotne na kartici ATA. Te datoteke niso potrebne, če niste dobili drugačnih navodil.
[Namestitev]\bin | Vsebuje dejansko izvedljive in potrebne DLL-je in slike potrebne za izvajanje.
[Namestitev]\bin\emulator.exe | Glavna izvršljiva datoteka, ki izvaja kode Tech2.
[Namestitev]\bin\emulator_xx_XX.dll | Jezikovno specifičen izvorni DLL.
[Namestitev]\bin\T2Configurator.exe | Konfiguracijski del Tech2Win.
[Namestitev]\bin\Pictures | Vsebuje ikone, ki jih potrebuje Tech2Win.
[Uporabniški podatki]\config | Vsebuje vse konfiguracijske datoteke.
[Uporabniški podatki]\data | Vsebuje datoteke, ki so modificirane med izvajanjem Tech2Win. Te datoteke so potrebne za pravilno izvajanje Tech2Win. Običajno naj se teh datotek ne bi dotikali, razen če vam je tako izrecno ukazano.
[Podatki aplikacije]\data | Vsebuje datoteke, ki so modificirane med izvajanjem Tech2Win. Te datoteke so potrebne za pravilno izvajanje Tech2Win. Običajno naj se teh datotek ne bi dotikali, razen če vam je tako izrecno ukazano.
[Podatki aplikacije]\data\emulator.sec | Varnostna datoteka . Te datoteke ne modificirajte.
[Podatki aplikacije]\data\emulator.card | Datoteka za kartice. Vsebuje vse kartice PCMCIA, ki so znane programu Tech2Win. Te datoteke ne modificirajte.
[Uporabniški podatki]\data\emulator.disp | Ta datoteka vsebuje lokacijo in velikost zaslona Tech2Win. Če to datoteko izbrišete, bo ponovno ustvarjena in zaslon Tech2Win se bo zagnal v zgornjem levem kotu z velikostjo 640 x 480.
[Podatki aplikacije]\data\emulator.lic | Licenčna datoteka. Vsebuje informacije o trajanju veljavnosti za vaše licence. Te datoteke ne modificirajte.
[Podatki aplikacije]\data\emulator.rtc | Datoteka ure realnega časa. Ta datoteka se uporablja za shranjevanje podatkov najdenih v RTC od Tech2.
[Podatki aplikacije]\data\emulator.dta | Informacijska datoteka 'Ne me več opomniti'.. Ta datoteka hrani programske različice PCMCIA, ki ne bi (več) smele prikazati obvestila o nezmožnosti izvedbe samopreizkusov, ki zahtevajo uporabo prilagodilnika za povratno zanko.
[Podatki aplikacije]\data\candi.bin | Datoteka aplikacije CANdi. Vsebuje aplikacijo CANdi, ki je priložena k Tech2.
[Podatki aplikacije]\data\eprom.bin | Tech2 notranja datoteka EPROM. Vsebuje vsebine notranjega bliskovnega pomnilnika Tech2
[Namestitev]\driver | Namestitvene datoteke za gonilnik navideznih serijskih vrat.
[Namestitev]\help\emulator_xx_XX.chm | Datoteke s pomočjo specifičnega jezika.
[Uporabniški podatki]\Logs | Vsebuje dnevniške datoteke. Datoteke, ki so starejše od enega tedna, se bodo samodejno izbrisale.
[Uporabniški podatki]\pcmcia | Vsebuje datoteke slik PCMCIA. Povedano simbolično, vsaka datoteka odgovarja kartici Tech2 PCMCIA. Te datoteke lahko po želji shranite na drugo lokacijo.


Upravljanje konfiguracije

Konfiguracijske datoteke se vedno nahajajo v podimeniku C:\Users\Public\General Motors\Tech2Win\config in imajo končnico *.conf. Tech2Win se lahko uporablja le za generiranje novih konfiguracijskih datotek ali za modificiranje obstoječih konfiguracijskih datotek, ki niso označene s Samo za branje. Za vsa druga upravljanja konfiguracijskih datotek, uporabite Windows Explorer ali podoben program. To je potrebno za vse naslednje aktivnosti:

  • brisanje konfiguracijskih datotek
  • preimenovanje konfiguracijskih datotek
  • spreminjanje atributa konfiguracijske datoteke samo za branje

Močno priporočamo, da imate vedno konfiguracijsko datoteko default.conf. Ta datoteka naj bi običajno imela atribut Samo za branje, da preprečite naključno prepisovanje. Če pa datoteko spremenite za izpolnjevanje vaših specifičnih potreb, boste začasno morali odstraniti atribut Samo za branje.

Podobe PCMCIA so v podimeniku C:\Users\Public\General Motors\Tech2Win\pcmcia. Vsaka izmed teh datotek odgovarja kartici PCMCIA, s katero ste se že seznanili ob delu s Tech2. S Tech2Win lahko imate želeno število slik. Preprosto kopirajte obstoječo sliko z novim imenom datoteke.

Če želite zagnati določeno konfiguracijo neposredno z namizja, ustvarite bližnjico, ki izvrši "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Program bi morali zagnati iz naslednjega delovnega imenika: 'C:\Program Files\General Motors\Tech2Win\bin'

Število konfiguracijskih datotek ni odvisno od števila slik pcmcia, ki jih uporabljate. Z isto sliko PCMCIA lahko uporabljate različno število konfiguracijskih datotek. To približno simulira situacijo v delavnici, kjer več mehanikov uporablja isti Tech2 (in isto kartico PCMCIA).

Prav tako lahko izberete, da vsaka konfiguracija uporablja lastno dodeljeno sliko PCMCIA. Na ta način so individualne konfiguracije bolj neodvisne ena od druge. Vendar morda poskus posodabljanja slike PCMCIA ne bo sprejemljiv.

Če želite ustvariti novo konfiguracijo s kopiranjem obstoječe, bo konfigurator prikazal opozorilo, če podoba PCMCIA ni bila spremenjena. V tem primeru bi dve konfiguraciji uporabljali isto podobo PCMCIA. Če to želite, enostavno pritisnite OK. Če želite, da nova konfiguracija uporablja drugo ali novo podobo PCMCIA, pritisnite Prekliči. Za ustvarjanje nove podobe uporabite Kopiraj pomnilniško kartico ....

Tukaj sta dva primera metode, kako lahko upravljate konfiguracije in slike PCMCIA.

Ena konfiguracija na uporabnika

Imate možnost shraniti konfiguracijo za vsakega uporabnika. Ime konfiguracije je lahko na primer ime uporabnika. Prednosti tega koncepta so možnosti določanja uporabniku prilagojenih nastavitev, na primer osebnih nastavitev vmesnikov za komunikacijo z vozili (MDI), prikaza in jezika. Slabost je v tem, da boste morali kopirati datoteke PCMCIA, če želi isto programsko opremo uporabljati več uporabnikov. Seveda lahko uporabniško določene konfiguracije uporabljajo tudi osrednjo datoteko PCMCIA.

Ena konfiguracija na programsko opremo Tech2

Odločite se lahko, da pripravite novo konfiguracijo za vsako programsko opremo, ki jo prenesete. Tako so po potrebi takoj na voljo tudi starejše različice programske opreme. V teh primerih se za ime konfiguracije pogosto izbere ime in številka različice programske opreme.

  • Prvi koraki: Vmesnik za komunikacijo z vozili
  • Prvi koraki: Pot
  • Napredne vsebine: Datoteka konfiguracije
  • Namestitev: Koraki namestitve


Pogosta vprašanja

  • Kako naj določim, katera serijska vrata naj uporabim za sistem Tech2Win?
  • Komunikacija med aplikacijama Tech2Win in TIS2Web
  • Veljavna licenca
  • Kaj označuje licenčna številka?
  • Kakšna je razlika med licenco Tech2Win in Security Access?
  • TIS2Web prikaže nespecifično napako pri izvajanju varnostnega dostopa do začetne programske opreme
  • Tech2Win ne zažene programske opreme Tech2 z drugega območja.
  • Kako lahko uporabljam več kot en MDI?
  • Dnevniška datoteka vsebuje napako 'CPU32: Too many 0000/FFFF Commands encountered'
  • Okno Tech2 ni vidno
  • SPS ne deluje
  • Nekateri samopreizkusi ne delujejo
  • Indikator hitrosti niha.
  • Nenadna ustavitev
  • Pri programski opremi 15.001 je prikazana švedščina.
  • Prekinitev komunikacije z MDI.
  • Tech2Win ne najde mojega MDI
  • Takoj želim zagnati Tech2Win, ne da bi poskušal/-a uporabiti konfiguratorja
  • Kje so funkcije za tiskanje?
  • V imeniku Moj računalnik je prisotna 'neuporabljena' mapa PCMCIA
  • Prikazuje se mi sporočilo 'illegal filepath' (neveljavna pot datoteke).

Kako naj določim, katera serijska vrata naj uporabim za sistem Tech2Win?

Uporabite lahko program 'Upravitelj naprav' v operacijskem sistemu Windows, poiščite možnost 'Vrata (COM & LPT)'. Nekateri računalniki imajo vgrajene modeme in naprave Bluetooth, ki niso prikazani v tej kategoriji.
Druga možnost je, da uporabite majhno krmilno enoto, ki jo prejmete skupaj s konfiguratorjem. Zaženete jo lahko preko zagonskega menija (mapa Tech2Win) s klikom na 'show com ports'.
Oba načina kažeta serijska vrata, ki so nameščena v vašem računalniku in ki jih NE uporabljajte.

Komunikacija med aplikacijama Tech2Win in TIS2Web

Pomembno je, da se aplikacija Tech2Win izvaja, preden začnete komunikacijo z aplikacijo TIS2Web za varnostni dostop ali prenos programske opreme. Aplikacija TIS2Web lahko navidezna serijska vrata uporabi samo ob zagnani aplikaciji Tech2Win.

Veljavna licenca

Običajno boste veljavno licenco dobili že ob prenosu programske opreme iz aplikacije TIS2Web. Če še vedno nimate licence, morate opraviti varnostni dostop 'Varnostni dostop (Varnost)' preko aplikacije TIS2Web (ne TIS2000), da dobite veljavno licenco. Ne izvajajte nobene druge komunikacije TIS2Web s Tech2Win, kot je npr. 'Nalaganje programske opreme (SWDL)', dokler ne dobite licence preko 'Varnostni dostop (Varnost)'.

Kaj označuje licenčna številka?

Licenčna številka na desni strani vrstice stanja prikazuje število celotnih dni veljavnosti licence. Neposredno po prenosu ali varnostnem dostopu se prikaže številka 30 dni. Toda po novem zagonu programa Tech2Win se prikaže 29, ker je trajanje licence najverjetneje okrog 29 dni, 23 ur in 55 minut. Če število dni veljavnosti licence pade pod 24 ur, se prikaže trajanje licence <1. Ko licenca poteče, je prikazana 0.

Kakšna je razlika med licenco Tech2Win in Security Access?

Licenca Tech2Win vam omogoča uporabo programske opreme Tech2Win. Če želite pridobiti takšno licenco morate prenesti programsko opremo ali se preko neposrednega varnega dostopa prijavljati v rednih časovnih presledkih (najpogosteje: vsakih 30 dni). Če ste pooblaščeni za izvedbo takšnega prenosa s TIS2Web, bo Tech2Win prejel podatek o tem, da je prisoten veljaven uporabnik. V Tech2Win bodo posredovani podatki iz Security Access na Tech2 o tem, ali so dovoljene določene dejavnosti, povezane z varnostjo, na primer onemogočanje zračne blazine. Dostop z licenco Tech2Win kot tudi preko Security Access je mogoče izvesti v aplikaciji TIS2Web Security Access. Preostali čas do poteka licence je v Tech2Win prikazan v vrstici stanja na desni. Žal Tech2Win ne more prikazovati časa veljavnosti licence Security Access, saj ta le izvaja programsko opremo Tech2, nima pa podatkov o njej sami.

TIS2Web prikaže nespecifično napako pri izvajanju varnostnega dostopa do začetne programske opreme

Vedenje je isto kakor pri sistemu Tech2. Programska oprema zaradi svoje starosti ni zmožna pridobiti licence s sistema TIS2Web. Vendar pa to ne predstavlja dejanske težave, saj ta demonstracijska programska oprema ne komunicira z vozilom, za katerega je potrebna licenca. Ker so licence specifične za prenos TS2Web, morate v vsakem primeru pridobiti licenco za vsak posamezen prenos, potem ko ste naložili programsko opremo Tech2. 'Licenca' za začetno programsko opremo vam ne daje pravice za izvajanje komunikacije vozila s programsko opremo severnoameriške podružnice ali podjetja Opel/Vauxhall.

Tech2Win ne zažene programske opreme Tech2 z drugega območja.

Vaša različica Tech2Win je najverjetneje omejena na enega ali več prenosov TIS2Web (regij). Pritisnite Pomoč / Vizitka, da si ogledate, kakšne omejitve veljajo za vašo različico programa Tech2Win. Prejšnje različice sistema Tech2Win so dovoljevale izvajanje samo programske opreme podjetja Opel/Vauxhall. Druge GM-regije sledijo kmalu. V vsakem primeru je Tech2Win trenutno zmožen zagnati programsko opremo Tech2 podjetja General Motors.

Kako lahko uporabljam več kot en MDI?

Če želite določeni MDI dodeliti posameznim uporabnikom, predlagamo, da naj ima vsak uporabnik svojo lastno konfiguracijo. Te konfiguracije je seveda treba imenovati po zadevnih uporabnikih. Za vsako konfiguracijo vnesite serijsko številko uporabniškega MDI v zavihek 'Vmesnik za komunikacijo z vozili'. Takoj, ko bo uporabnik naložil svojo konfiguracijo, se bo Tech2Win poskušal povezati z zadevnim MDI. Izbirno okno z vsemi MDI, ki jih je Tech2Win našel, se bo prikazalo le, če zadevni MDI ni bil prisoten.

Če uporabljate več MDI-jev za splošne namene, predlagamo, da zavihek 'Vmesnik za komunikacijo z vozili' za serijske številke vmesnika za komunikacijo z vozili pustite prazen. Uporabnik bo tako zmeraj na voljo vpogled v izbirno okno razpoložljivih MDI-jev.

Dnevniška datoteka vsebuje napako 'CPU32: Too many 0000/FFFF Commands encountered'

Datoteka 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' ali trenutna datoteka kartice PCMCIA je poškodovana. Znova namestite aplikacijo Tech2Win in prenesite novo programsko opremo Tech2.

Okno Tech2 ni vidno

Če okno Tech2 ni vidno, je verjetno v območju, ki trenutno ni prikazano. To se lahko zgodi, če uporabljate več zaslonov ali če spremenite ločljivost zaslona. Med začetkom konfiguracije pritisnite tipko Shift na tipkovnici. V tem primeru se ločljivost okna ponastavi na 640x480, okno Tech2 pa se bo prikazalo v zgornjem levem vogalu zaslona. Če izbrišete datoteko C:\Users\Public\General Motors\Tech2Win\emulator.disp, dosežete enak učinek.

Poznamo primere, ko se okno Tech2 po zaprtju vseh drugih aplikacij preprosto ni hotelo vrniti na zaslon. V vseh teh primerih je bilo zaslon Tech2 mogoče povrniti s pritiskom kombinacije tipk Alt+Tab za preklapljanje med aplikacijami v Windows. Pritisk na gumb Tech2Win v opravilni vrstici vašega računalnika včasih morda ne bo deloval. Težavo preiskujemo in upamo, da bomo jo do izida naslednje različice Tech2Win že odpravili.

SPS ne deluje

Da, vemo. Tega ne bomo spremenili. Tech2Win ne smete uporabljati kot nadomestek Tech2 za izvajanje SPS. MDI uporabite neposredno s programiranjem SPS preko sistema TIS.

Nekateri samopreizkusi ne delujejo

Samopreizkusi Tech2 so namenjeni za preizkušanje posameznih delov strojne opreme Tech2. Nekateri od teh preizkusov zahtevajo uporabo prilagodilnika za povratno zanko. Ti preizkusi ne bodo delovali v sistemu Tech2Win, ker funkcije prilagodilnika za povratno zanko ni na voljo (tega tudi ne načrtujemo). Prosimo, da takšnih preizkusov brez pomena ne izvajate v sistemu Tech2Win. Če jih vseeno izvedete, lahko pride do napačnih rezultatov ali pa se sistem Tech2Win blokira, tako kot bi se tudi sistem Tech2 brez prilagodilnika za povratno zanko. V takšnem primeru ponastavite Tech2Win s kombinacijo Ctrl-R.

Indikator hitrosti niha.

Indikator hitrosti v spodnji levi strani vrstice stanja prikazuje, koliko 'ukazov Tech2' je mogoče izvršiti, preden mora Tech2Win ponovno 'mirovati'. S tem načinom je zagotovljeno, da se čas na Tech2Win ujema z resničnim časom: hitrejši računalniki mirujejo več kot počasnejši. Če indikator hitrosti niha, to pomeni, da katera druga aplikacija morda uporablja moč računalnika ali pa se ura računalnika spreminja. Visoke stopnje nihanja negativno vplivajo na komunikacijo vozila in komunikacijo TIS2Web. Zagotovite, da nobena druga aplikacija ni zagnana.

Večina prenosnih računalnikov samodejno zmanjša CPU-uro, da podaljša trajanje baterije. Tudi to je lahko razlog nihanja hitrosti, ki ga zazna Tech2Win. V tem primeru ne uporabljajte prenosnega računalnika z napajanjem na baterijo, ampak ga priključite na zunanje napajanje. Prav tako lahko poskusite spremeniti nastavitve porabe, tako da operacijski sistem ne bo več zmanjševal hitrosti ure.

Nenadna ustavitev

Če v dnevniški datoteki ne najdete razloga za ustavitev programa, so se morda vključili notranji varnostni mehanizmi programske opreme Tech2Win. Prosimo, da ne posegate v naslednje datoteke: emulator.sec, emulator.lic, emulator.card. Če sistem Tech2Win prepozna kršitev varnosti, boste verjetno morali opraviti ponovno namestitev.

Pri programski opremi 15.001 je prikazana švedščina.

Prvotna programska oprema, priložena Tech2Win, je predstavitvena programska oprema, ki je na voljo na vsaki novi kartici PCMCIA. TIS2Web prikazuje švedščino zato, ker TIS2Web prikaže samo zadnji jezik na seznamu štirih jezikov, ki jih podpira ta demo programska oprema (angleščina, francoščina, nemščina, švedščina). Uporabite način posodobitve 'Po meri' namesto 'Standardni', da prepišete predstavitveno programsko opremo z najnovejšo diagnostično programsko opremo.

Prekinitev komunikacije z MDI.

Prekinitev MDI-komunikacije ima lahko več vzrokov.

  • Slaba povezava kabla (kablov ethernet in USB).
  • Nestabilna brezžična povezava.
  • Osebni računalnik se preklopi v stanje pripravljenosti.

Tech2Win ne najde mojega MDI

Prosimo, odgovorite na naslednja vprašanja:

    1. Ali je MDI aktiven?
    2. Ali Upravitelj MDI deluje?
    3. Ali MDI uporablja druga aplikacija, kot je SPS?
Upravitelja MDI lahko zaženete s klikom na namizno ikono ali preko 'Start/Vsi programi/General Motors/GM MDI Software'.: Če točka 2 ne deluje, se obrnite na center za pomoč.

Takoj želim zagnati Tech2Win, ne da bi poskušal/-a uporabiti konfiguratorja

Izvršite "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Uporabite naslednji delovni imenik: 'C:\Program Files\General Motors\Tech2Win\bin' Konfigurator lahko še vedno uporabite za izvajanje kakršnih koli sprememb konfiguracije.

Kje so funkcije za tiskanje?

Tech2Win ne nudi neposrednega tiskanja. Namesto tega ustvarja začasne datoteke in prikliče programe, ki so povezani s končnicami datotek. Te programe lahko uporabite za namene tiskanja, obenem vam dovoljujejo tudi prilagoditev izgleda natisnjene slike.

Print Report | Print Report

Za tiskanje trenutnega prikaza na zaslonu Tech2Win uporabite menijsko točko Datoteka / Natisni zaslon ali tipko na tipkovnici, na kateri je prikazan tiskalnik. Če želite natisniti več prikazov na zaslonu Tech2Win, lahko uporabite menijsko točko Možnosti / Samodejni posnetki zaslona, ki ustvari PNG-datoteko za vsak posnetek zaslona. Te PNG-datoteke so shranjene v dnevniški datoteki.

Prav tako lahko natisnete tudi podatke z zaslona (s pomočjo menijske točke Okna / Podatkovni prikaz Tech2Win). Uporabite gumb Natisni/start HTML za začetek in zatem za ustavitev zajemanja podatkov. Po zaključenem zajemanju podatkov se zažene izvršilni program, ki je pridružen HTML (običajno Internet Explorer), ki nudi veliko možnosti za tiskanje podatkov.

Data Display | Data Display

V imeniku Moj računalnik je prisotna 'neuporabljena' mapa PCMCIA

Prejšnje različice sistema Tech2Win so imele vedno dvojni hranilnik datotek PCMCIA v ločenem imeniku. Ta imenik se je pogosto nahajal na C:\PCMCIA. Ta imenik ni več v uporabi, ker je zaradi hitrega prenosa iz sistema TIS2Web dodatni hranilnik teh prenosov nepotreben. Ta imenik lahko varno izbrišete.

Prikazuje se mi sporočilo 'illegal filepath' (neveljavna pot datoteke).

Ime datoteke verjetno vsebuje neveljavne znake, kot je znak za odstotek (%). Če se vam ta težava pojavi takoj po namestitvi, bi bilo najboljše, da program odstranite in ga znova namestite. Večino primerov je bilo mogoče popraviti s tem načinom.

Med običajnimi namestitvami je spremenljivka okolja 'Tech2WinUserData' nastavljena na 'PUBLIC' (JAVNO) (za različice Windowsov >= Vista) in na 'ALLUSERSPROFILE\Documents' (za različice Windowsov pred Visto). V nekaterih redkih primerih spremenljivka okolja ni bila nastavljena med namestitvijo, vendar je v drugem poizkusu brez težav delovala. Prav tako lahko izberete, da boste spremenljivko okolja nastavili ročno. Če ne veste, kako nastaviti spremenljivko okolja, za pomoč prosite skrbnika.


Registrski vnosi

Naslednje registrske vnose generira oseba, ki izvaja namestitev. Teh vnosov ročno ne spreminjajte. Zavedajte se standardnih svaril programa Windows ob rokovanju z registrskimi vnosi.

registrski ključ | ime | tip | pomen
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Notranja številka različice
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Jezik | REG_SZ | nameščen jezik
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Pot do map za kopiranje PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Koren | REG_SZ | pot namestitve
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Odstrani možnost | REG_DWORD | Odstranite nastavitev
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Različica konfiguracijske datoteke
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Različica gonilnika za navidezna serijska vrata
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Prikazno Ime | REG_SZ | Ime programske opreme znotraj seznama Dodaj/Odstrani program
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Niz odstranitve | REG_SZ | Pot do programa za odstranjevanje


Ponovna namestitev

Ponovna namestitev bo izbrisala popolno namestitev imenika sistema Tech2Win z naslednjimi izjemami.

  1. Podimenik config, ki vsebuje konfiguracije, ni izbrisan.
  2. Podimenik pcmcia, ki običajno vsebuje slike PCMCIA, ni izbrisan.
  3. Podimenik ATA, ki lahko vsebuje informacije o iskanju napak, ni izbrisan.
Konfiguracijske datoteke morda več ne bodo združljive: Jamstva, da bodo konfiguracijske datoteke stare različice Tech2Win čitljive z novejšo različico Tech2Win, ni. Slike PCMCIA načeloma ne morejo postati nezdružljive.

Na sekundarni imenik PCMCIA ponovna namestitev ne vpliva.

Nekatera okolja lahko nudijo možnost samodejne namestitve novejše različice Tech2Win. Ker so informacije o zadnji namestitvi shranjene v imeniku, bodo te nastavitve predstavljene kot privzete med ponovno namestitvijo.

Ponovno namestitev programske opreme Tech2Win lahko vsilite s skriptom enable reinstallation. Ta skript se namesti skupaj z aplikacijo Tech2Win. Ta skript v osnovi preprosto nastavi vrednost ključa CurrentVersion, ki ga najdete v registru na mestu HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win, na vrednost '1.000'.