Руководства пользователя Tech2Win

Добро пожаловать в руководство пользователя Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Все права защищены.

  • Введение:
  • Лицензия:
  • Инсталляция:Описание процедуры инсталляции Tech2Win.
    • Этапы инсталляции
    • Интерфейс связи с автомобилем
  • Начало работы
    • Выбор конфигурации
      • Клавиатура
      • Работа с окнами
    • Новые конфигурации
    • Изменение конфигураций
      • Язык
      • Путь
      • Дисплей
      • Сохранение конфигурации
    • Получите действительную лицензию для Tech2Win
  • Работа с Tech2Win: Описание порядка обычной работы
    • Меню
    • Загрузка образов карт PCMCIA
    • Защита доступа
    • Просмотр отчетов
    • Работа с образами карт PCMCIA
    • Строка состояния
  • Дополнительная информация: Информация, не требующаяся при нормальной работе с Tech2Win. Как правило, она необходима только лицам, выполняющим административные задачи.
    • Повторная инсталляция
    • Деинсталляция
    • Формат файла конфигурации
    • Файл журнала регистрации событий
    • Сообщения об ошибках и коды ошибок
    • Карта ATA
    • Ключи реестра
    • Файлы
    • Управление конфигурациями
  • Вопросы и ответы


Введение

Tech2Win - это приложение Windows, которое может эмулировать функциональность Tech2. Таким образом, программное обеспечение Tech2 выполняется на ПК. Для работы с этой программой, ПК должен соответствовать следующим требованиям:

  • Интерфейс для связи с автомобилем должен быть проинсталлирован и подключен к ПК. Список допустимых интерфейсов может различаться в зависимости от страны. В большинстве случаев может использоваться интерфейс GM Multiple Diagnostic Interface (MDI).
  • Для инсталляции приложения Tech2Win требуется 150 МБ на жестком диске ПК. Еще по 32 МБ требуется на каждый образ карты PCMCIA, с которым будет нужно работать.
  • Для запуска приложения Tech2Win требуется не менее 100 МБ свободной физической памяти. Необходимо, чтобы ПК был оснащен таким объемом памяти, чтобы приложение оставалось в памяти компьютера в течение всего времени работы.
  • Вычислительная мощность ПК должна соответствовать (одноядерному) процессору Pentium с тактовой частотой 1,2 ГГц. Настоятельно рекомендуется не запускать одновременно с системой другие приложения.
  • Клавиатура для работы системы не требуется. Кроме того, для работы с Tech2Win может использоваться сенсорный экран. Для управления конфигурациями рекомендуется подключить к ПК клавиатуру, так как при этом потребуется вводить имена файлов.
  • Цветной графический дисплей должен иметь разрешение не менее 800 x 600 с числом цветов не менее 256. Если дополнительная клавиатура не используется, может быть приемлемо разрешение 640 x 480.

При использовании Tech2Win (переносной компьютер вместо Tech2) обеспечьте наличие необходимого питания для переносного компьютера. Обычно портативный компьютер не подключается к аккумуляторной батарее автомобиля, как Tech2.

  • Инсталляция
  • Начало работы


Лицензия

Компания General Motors - Лицензионное соглашение по Tech2Win

Перед использованием этой программы внимательно прочитайте следующие условия. Если Вы не принимаете или не понимаете условия, пожалуйста, обратитесь в свое местное представительство по послепродажному обслуживанию. Право использовать это программное обеспечение предоставляется компанией General Motors только при условии, что пользователь соглашается с этой лицензией, принимая эти условия во время установки Tech2Win.
Компания General Motors дает право использовать программное обеспечение Tech2Win и содержащуюся информацию в сочетании с TIS2Web или GlobalTIS или TIS2000 исключительно пользователям сети авторизованных ремонтников компании General Motors, как определено в применимом в данной местности Соглашении авторизованных ремонтников с местными национальными компаниями по продаже General Motors.
Лицензия на Tech2Win действует до тех пор, пока остается в силе Соглашение авторизованных ремонтников и имеется лицензия на TIS2Web, GlobalTIS и TIS2000. Лицензия на Tech2Win будет немедленно прекращена одновременно с лицензией на TIS2Web и GlobalTIS, когда прекратит действие Соглашение авторизованных ремонтников.

Независимые ремонтники, как определено в Статье 4, параграф 2, Регулирования изъятия из блока законов (BER) Европейского Союза 1400/2002, могут купить лицензию на Tech2Win в качестве составной части предлагаемой подписки, предоставляемой на Портале GM Europe Info Tech компании General Motors Europe.

Лицензия на Tech2Win не охватывает интерфейс автомобильной коммуникации или аппаратное обеспечение ПК.

Программное обеспечение Tech2Win не должно в дальнейшем распространяться, продаваться или размещаться в оперативном режиме для любой третьей стороны вне авторизованных ремонтных производственных помещений (как описано в соответствующем приложении к Соглашению авторизованных ремонтников) без письменного согласия соответствующих местных национальных компаний по продаже General Motors. Это относится как к текущим, так и к устарелым данным (таким как устаревшие DVD).

Местные национальные компании по продаже General Motors будут иметь право немедленно закрыть доступ и сделать предупреждение о немедленном прекращении действия Соглашения авторизованных ремонтников в случае несанкционированного использования или злоупотребления. В этом случае право требовать возмещения кредитовых остатков и/или оставшихся годовых основных взносов будет исключено.

Предоставленная информация служит для квалифицированного выполнения работ по техническому обслуживанию и ремонту немодифицированных автомашин компании General Motors. Предварительным условием выполнения вышеупомянутой работы является завершенное обучение по специальности автомобильный техник и регулярное повышение квалификации. В тех случаях, когда в предоставленной информации предусматривается использование специальных инструментов, такие специальные инструменты обязательны для всех ремонтных работ, которые должны выполняться квалифицированно.

Информация, публикуемая в Global TIS компании General Motors (текст и изображения, музыка, графические данные, анимация, видеоматериалы и т.д.), и их компоновка в Global TIS защищены авторским правом. Не разрешается ее воспроизведение, распространение, обмен и/или передача или другое использование без предварительного согласия компании General Motors.

  • Инсталляция: Этапы инсталляции
  • Начало работы


Installation

Инсталляция

Для инсталляции системы Tech2Win требуются права локального администратора данного ПК. Установка возможна только при наличии прав администратора. В этом случае необходимо обратиться за помощью к локальному администратору ПК.

Для нормальной работы Tech2Win необходимо выполнить следующие два действия:

  • Инсталляция системы Tech2Win.
  • Установка интерфейса связи с автомобилем.
  • Инсталляция: Этапы инсталляции
  • Начало работы


Этапы инсталляции

Сама установка занимает всего лишь несколько минут и требует от пользователя ввода следующих данных:

  1. Лицензионное соглашение
  2. Установочная директория

Язык

По умолчанию пользовательский интерфейс Tech2Win будет отображаться на языке вашей операционной системы. Обычно поддерживаются следующие языки. Если ваш язык не поддерживается, программа установки запускается на английском языке, который является языком для установки по умолчанию.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Английский (Великобритания или США)*
  • el_GR (EL)Greek
  • es_ES (ES)Испанский
  • fi_FI (FI)Finnish
  • fr_FR (FR)Французский
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Португальский (Бразилия)
  • pt_PT (PT)Португальский (Португалия)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Китайский (упрощенный)
  • zh_TW (ZH)Китайский (традиционный)

* Языком Tech2Win является британский английский. Однако программное обеспечение Tech2 и программа установки, которые вы используете, могут быть на американском английском, в зависимости от поставщика программного обеспечения.

Лицензионное соглашение

Вы должны принять лицензионное соглашение.

Установочная директория

Вы можете выбрать любую директорию в качестве места установки Tech2Win. По умолчанию, в качестве установочной директории выбирается <директория для программ>\General Motors\Tech2Win или, при повторной инсталляции, директория, указанная при предыдущей установке.

В завершение подтвердите установку.

Драйвер виртуального Com-порта

Драйвер виртуального Com-порта устанавливается на вашем компьютере один единственный раз и остается до тех пор, пока не обновится версия драйвера (что случается не часто) или не будет отменена установка Tech2Win на вашем компьютере.
Если драйвер установится, то на короткое время появится окно DOS. Оно закроется автоматически и не требует каких-либо действий. Файлы драйвера дополнительно располагаются во вложенной папке 'драйвер' вашего каталога установки Tech2Win.
Возможна установка или отмена установки драйверов виртуального Com-порта вручную, но это не рекомендуется. Используйте одну из следующих команд в оболочке CMD:

  • вызвать 'vbsetup7', чтобы установить драйвер
  • вызвать 'vbsetup7 /u', чтобы отменить установку драйвера
  • Начало работы


Интерфейс связи с автомобилем

Устройство, обеспечивающее связь с автомобилем, требует отдельной инсталляции. Смотрите соответствующее руководство по установке, которое поставляется вместе с интерфейсом связи с автомобилем.

  • Начало работы: Интерфейс связи с автомобилем
  • Дополнительная информация: Файл конфигурации
  • Инсталляция: Этапы инсталляции
  • Вопросы и ответы: Как можно использовать более одного интерфейса MDI?
  • Вопросы и ответы: Tech2Win не обнаружила мой интерфейс MDI


Начало работы

В следующих инструкциях описано, как начать работу с Tech2Win. Предполагается, что вы уже знакомы с порядком работы с Tech2. Во время выполнения этих, первоначальных действий связь с автомобилем не требуется.

При выполнении Quick Start придерживайтесь следующих шагов:

  1. Запустите программное обеспечение Tech2Win с помощью ярлыка QuickStart на вашем рабочем столе.
  2. Получите действующую лицензию, загрузив с TIS2Web новое программное обеспечение Tech2.

Чтобы использовать конфигурацию, которую можно выбрать:

  1. Запустите конфигуратор с помощью ярлыка Tech2Win на вашем рабочем столе. После инсталляции системы в ней должна быть конфигурация по умолчанию.
  2. Для создания новой конфигурации желательно копировать конфигурацию по умолчанию.
  3. Модифицируйте имеющуюся конфигурацию в соответствии с вашими конкретными требованиями.
  4. Получите действительную лицензию.

Не запускайте Tech2Win в режиме совместимости. В таком случае появится предупреждение в файле журнала. В Tech2Win используются только те функции Windows, которые существуют, начиная с версии XP, и не будут работать в более ранних версиях Windows.

  • Начало работы: Новые конфигурации
  • Начало работы: Изменение конфигураций
  • Начало работы: Интерфейс связи с автомобилем
  • Работа с Tech2Win: Меню
  • Работа с Tech2Win: Защита доступа
  • Работа с Tech2Win: Строка состояния
  • Дополнительная информация: Файл конфигурации


Выбор конфигурации

При первом запуске Tech2Win появляется следующее окно. Вы можете выбрать запуск Tech2Win с конфигурацией, принятой по умолчанию. В этой конфигурации система работает без связи с автомобилем.

Start First Time

Появляется окно с информацией о лицензии, однако его можно проигнорировать и запустить конфигурацию, используемую по умолчанию.

При работе с сенсорным экраном может быть полезно запустить программу, которая эмулирует клавиатуру ПК и позволяет осуществлять ввод букв.


Клавиатура

Клавиши ПК, если они имеются, ставятся в соответствие с известными кнопками Tech2. В Tech2Win предусмотрено также несколько дополнительных кнопок, которые отсутствуют в Tech2. Цифровая клавиатура ПК может работать не во всех случаях. При возникновении каких-либо проблем проверьте, не изменялась ли стандартная раскладка клавиатуры на вашем ПК. Главным образом, в таком случае может нарушиться работа клавиши SHIFT.

Клавиатура ПК | Кнопка | Функция
Функциональная клавиша F1 | нет | Справочная система Tech2Win
Функциональные клавиши F5 .. F8 | Используйте область просмотра Tech2Win, занятую экранными клавишами | Четыре программные клавиши Tech2
Клавиши управления курсором Вверх, Вниз, Влево, Вправо |  | Кнопки Вверх, Вниз, Влево, Вправо Tech2. Нажатие только на эти кнопки повторяется автоматически.
Клавиши 0 - 9 | F0 • • • F9 | Кнопки F0 .. F9 Tech2
Забой | Exit | Кнопка Выход Tech2
Ввод / Возврат каретки | Enter | Кнопка Ввод Tech2
Y | Yes | Кнопка Да Tech2
N | No | Кнопка Нет Tech2
Q | ? | Кнопка ? Tech2
S | Shift | Кнопка Регистр (Shift) Tech2; Указатель переключения 'Shift' в строке состояния или указатель над кнопкой 'Shift' будет показывать состояние.
ctrl-P | PWR | Кнопка Питание Tech2; Очевидно, эта кнопка может использоваться только для выключения приложения Tech2Win.
ctrl-R | отсутствует | Сброс Tech2Win. Аналогично выключению и включению Tech2. Однако присоединённый интерфейс обмена данными с автомобилем не сбрасывается. Файлы, такие как образ PCMCIA, не перезагружаются.
Клавиша Home | Home | Кнопка Home. Поддерживается только некоторыми приложениями.
доступно только через пункт меню Файл. | Print Screen | Распечатывает снимок экрана Tech2, создавая временный файл BMP и вызывая приложение, сопоставленное типу файлов BMP. Используйте это приложение, чтобы изменять размер изображения или поворачивать его перед выводом на печать.
доступно только через пункт меню Файл. | Save Screen | Сохранение снимка экрана Tech2 в виде файла BMP или PNG.
доступно только через пункт меню Файл. | View Report | Вывод на дисплей всех отчетов из памяти активной карты PCMCIA для просмотра их пользователем.


Работа с окнами

Изменение размеров окон осуществляется обычными для Windows способами: перетягиванием рамки главного окна. Кроме того, пункт меню Функции/Разрешение поддерживает несколько предварительно заданных размеров. При изменении размеров главного окна с помощью пункта меню окно клавиатуры будет автоматически оставаться зафиксированным.

Внешний вид окон можно изменять при помощи вкладки Дисплей диалогового окна конфигурации.


Новые конфигурации

Для того чтобы создать новую конфигурацию, нажмите на кнопку Создать новую. При этом на экран будет выведено диалоговое меню, при помощи которого можно выбрать один из имеющихся файлов конфигурации в качестве исходного. Обычно при этом выбирается файл с конфигурацией по умолчанию. После ввода имени нового файла конфигурации, нажмите на кнопку Копировать.

Если вы работаете с сенсорным экраном, вам может потребоваться включить эмулятор клавиатуры ПК при помощи кнопки Клавиатура ПК.

Кнопка Отмена позволяет отказаться от создания новой конфигурации.

Новая конфигурация будет использовать тот же самый файл PCMCIA, что и существующая исходная конфигурация. Если вы хотите это изменить, то должны модифицировать конфигурацию таким образом, чтобы использовался другой файл PCMCIA. В большинстве случаев вы просто копируете существующий файл PCMCIA в новый файл и используете этот новый файл. Возможно, вы предпочтете, чтобы новая конфигурация использовала тот же файл PCMCIA, что и исходная конфигурация. В этом случае при нажатии на кнопку Сохранить появится экран с предупреждением.

  • Изменение конфигураций


Изменение конфигураций

Конфигурации, отображенные синим цветом, доступны только для чтения и не могут быть изменены. Эти конфигурации доступны только для просмотра. Конечно, вы можете использовать средства редактирования для просмотра информации из этих конфигураций, однако ее Сохранить будет невозможно.

Редактирование конфигурации осуществляется путем выбора отдельных настроек на четырех вкладках: Язык, Интерфейс связи с автомобилем, Путь, Дисплей. Можно либо выбрать необходимую вкладку, либо просто нажать кнопку Следующий, которая активирует следующую вкладку. После того как необходимые изменения будут сделаны, нажмите на кнопку Сохранить, чтобы сохранить измененную конфигурацию.

Во всех случаях, когда требуется клавиатурный ввод, вы можете запустить специальное приложение, эмулирующее клавиатуру ПК. Это особенно удобно на портативных компьютерах с сенсорными экранами, не оснащенных клавиатурой.


Язык

Вкладка Язык позволяет выбрать язык, который будет использоваться при работе Tech2Win. Эта настройка не влияет на язык программного обеспечения Tech2, записанного на образе карты PCMCIA. Выбор необходимого языка должен осуществляться при загрузке программного обеспечения Tech2 из TIS.

В некоторых регионах доступны не все языки. В этих случаях система использует английский язык. Пожалуйста, проверьте, доступен ли похожий язык (PT португальский для Португалии вместо PB португальского для Бразилии).


Путь

Вкладка Путь используется для того, чтобы определить пути к образам карт PCMCIA, а также к программной клавиатуре. Кроме того, для копирования образов карт PCMCIA предусмотрена кнопка Копировать карту памяти. Если вы только что создали новую конфигурацию, то, возможно, захотите применить эту кнопку, чтобы не допустить использования несколькими конфигурациями одного и того же образа PCMICA.

Memory Card Options

Копировать карту памяти ...

Эта кнопка позволяет скопировать образ карты PCMCIA в другой файл. Эта функция похожа на приобретение новой карты PCMCIA для Tech2. Функция копирования работает только для файлов в каталоге C:\Users\Public\General Motors\Tech2Win\pcmcia.

Слот 0: местоположение образа карты памяти

Здесь можно указать файл, в котором содержится образ карты PCMCIA, вставленной в слот 0. Обычно такой файл должен находиться в C:\Users\Public\General Motors\Tech2Win\pcmcia, впрочем, возможно расположение и в других местах.

Слот 1: Карта памяти или ATA

Как и Tech2, Tech2Win поддерживает одновременно две карты (образа) PCMCIA. Однако, наличие двух образов PCMCIA в одной конфигурации практически бесполезно. Обычно второй вариант программного обеспечения используется в отдельной конфигурации.

Как и в Tech2, в целях отладки может использоваться карта ATA. Пожалуйста, используйте карту ATA только при получении соответствующих инструкций от технической поддержки. Там же вы получите и дополнительную информацию.

Программная клавиатура ПК

Путь к этому файлу, принятый по умолчанию, система получает из соответствующего ключа реестра Windows. По этому пути должно располагаться приложение, способное эмулировать клавиатуру ПК для работы при помощи мыши. Если у вас имеется специальное приложение, обеспечивающее данную функциональность на используемом вами портативном компьютере, вы можете указать путь к этому приложению здесь.


Интерфейс связи с автомобилем

  • COM-порт для эмуляции Tech2-RS232
  • Серийный номер MDI, который будет использоваться
  • Протокол

COM-порт для эмуляции Tech2-RS232

Выберите свободный COM-порт, который может быть использован для эмуляции Tech2. Для удобства Конфигуратор пытается определить, какие последовательные порты уже используются, и отображает их.

Если выбран существующий COM-порт, Tech2Win будет привязана к этому существующему COM-порту. Этот COM-порт можно использовать для загрузки программы Tech2 по нуль-модемному кабелю со второго компьютера, на котором запущено приложение TIS. Пожалуйста, учтите, что из-за предусмотренных в Windows ограничений работа реального COM-порта на скорости 115.200 бод может быть недостаточно надёжной.

Если выбран несуществующий COM-порт, Tech2Win автоматически создаст виртуальный порт. Этот виртуальный порт можно использовать из приложения TIS, запущенного на том же ПК, для установки связи с Tech2Win. При использовании виртуального порта ограничений на скорость передачи данных нет.

Если для 'поиска' выбрать COM-порт, то Tech2Win создаст виртуальный COM-порт, присвоив ему первый свободный номер порта в диапазоне от 9 до 1.

Серийный номер MDI, который будет использоваться

Введите серийный номер интерфейса MDI. Номер указан на обратной стороне интерфейса MDI. Используйте номер после дефиса.

Если вы не ввели серийный номер, Tech2Win автоматически выводит на экран список обнаруженных в сети интерфейсов MDI, из которых пользователь может выбрать необходимый. Такое же окно выбора появляется, если указанный интерфейс MDI не найден.

Протокол

Выбрано 'ISO22900-2 / PDU-API', а пункт J2534-2 всегда недоступен. В будущем Tech2Win, возможно, будет также поддерживать протокол J2534.

  • Дополнительная информация: Файл конфигурации
  • Вопросы и ответы: Как определить, какой COM-порт следует использовать для Tech2Win?
  • Вопросы и ответы: Связь между Tech2Win и TIS2Web
  • Вопросы и ответы: Как можно использовать более одного интерфейса MDI?
  • Вопросы и ответы: Tech2Win не обнаружила мой интерфейс MDI


Дисплей

Вкладка Дисплей используется, главным образом, для изменения настроек, касающихся окна Tech2Win:

  • Клавиатура
  • Цвета
  • Звук
Display and Key Options

Клавиатура

Вы можете указать, будет ли отображаться клавиатура. Клавиатура отображается в левой или в правой части окна Tech2Win. Цвет фона можно выбрать при помощи стандартного диалогового окна для выбора цвета.

Цвета

Здесь можно выбрать цвета фона и шрифта экрана Tech2. Ниже приведены два самых распространённых сочетания цветов:

Screen with background 0000FF, foreground FFFFFF | Фон клавиатуры - белый; Синий фон; Цвет шрифта - белый
Screen with background 000000, foreground C0C0C0 | Синий фон дополнительной клавиатуры; Цвет фона - черный; Цвет шрифта - светло-серый

Звук

Здесь можно выбрать отключение звука. Каждый раз, когда программное обеспечение Tech2 будет подавать звуковые сигналы, будет использоваться динамик ПК.


Сохранение конфигурации

Активная конфигурация может быть сохранена нажатием на кнопку Сохранить <конфигурацию>, расположенную в левом нижнем углу. Во время просмотра конфигурации, доступной только для чтения, эта кнопка не отображается.


Действительная лицензия через TIS2Web

Обычно в результате загрузки программного обеспечения Tech2 в Tech2Win вы получаете действительную лицензию. Кроме того, его можно получить, выполнив процедуру доступа 'Доступ к защищенной области (Защита)' посредством TIS2Web (не TIS2000). Поэтому на вкладке Интерфейс связи с автомобилем в Конфигураторе обязательно нужно выбрать виртуальный COM-порт.

После успешного прохождения проверки прав доступа с правой стороны в строке состояния появляется открытый замок. В скобках указано количество дней до окончания срока действия лицензии. Когда вы запускаете Tech2Win вновь, индикатор безопасности не отображается, пока не будет установлена связь с автомобилем. Во время первого обмена данными с автотранспортным средством осуществляется проверка лицензии и индикатор изменяет свой вид на открытый или закрытый замок.

  • Работа с Tech2Win:Защита доступа
  • Вопросы и ответы:Как определить, какой COM-порт следует использовать для Tech2Win?
  • Вопросы и ответы:Связь между Tech2Win и TIS2Web
  • Вопросы и ответы:Действительная лицензия
  • Вопросы и ответы:В чем заключается разница между лицензией Tech2Win и доступом через систему безопасности?


Работа с Tech2Win

Следующие вопросы касаются большинства механиков, работающих с Tech2Win:

  • Меню: Расположение информации на экране и отдельные пункты меню.
  • Загрузка образа карты PCMCIA: Обновление диагностического программного обеспечения для Tech2Win производится таким же способом, что и в Tech2.
  • Защита доступа: Меры защиты доступа, направленные на предотвращение неавторизованной связи Tech2Win с автомобилем.
  • Просмотр отчетов: Клавиатура Tech2 в Tech2Win немного модернизирована. Наиболее характерный пример - кнопка 'Просмотреть отчеты'.
  • Работа с образами карт PCMCIA: Tech2 может работать с несколькими картами PCMCIA. По аналогии, Tech2Win может работать с несколькими образами.
  • Строка состояния: В строке состояния приводится информация по отдельным ее частям.
    • Дополнительная информация
    • Вопросы и ответы


Меню

В меню приложения Tech2Win имеются следующие пункты:

  • Файл
  • Функции
  • Окно
  • Справка

Файл

Меню Файл предоставляет следующие возможности:

  • Команда Сохранить Экран T2 (320x240) используется для сохранения фактического экрана T2 размером 320x240 пикселей в виде черно-белого графического файла на вашем ПК. Местоположение и формат файла (BMP, GIF, JPG, PNG) можно выбрать произвольно.
  • Команда Печать Экрана создаёт инвертированное черно-белое BMP-изображение экрана Tech2 и вызывает программу, ассоциированную с файлами BMP. Затем эту программу можно использовать для распечатки изображения.
  • Просмотреть файлы отчетов - обеспечивает возможность просмотра (и распечатки) файлов отчетов без использования TIS2Web.
  • Выход - используется для завершения работы Tech2Win.

Функции

Команда Функции даёт возможность выбрать следующие варианты:

  • Разрешение - можно использовать для выбора одного из трёх стандартных размеров экрана.
  • ROM-Write from 0x00003ED76 - используется для внутренней отладки.
  • Автоматические снимки экрана - для сохранения изображения каждого нового экрана Tech2 в каталоге журнала.
  • Отключить CANdi и перезагрузить - для имитации отсутствия CANdi между Tech2 и автомобилем. Это необходимо для тех редких случаев, когда CANdi прерывает нестандартные линии обмена данными с автомобилем.

Окно

Меню Окно обеспечивает возможность активировать варианты выбора Tech2Win - отображение данных и Tech2Win - отображение диагностических кодов. Все другие варианты выбора в текущей версии Tech2Win остаются серыми.

Если программное обеспечение Tech2 поддерживает Tech2Win - отображение данных, то вы можете сделать доступным этот пункт меню. После входа в Информационный дисплей, Tech2Win будет отображать дополнительное окно Информационного дисплея одновременно с Информационным дисплеем Tech2. Пока на экране Tech2 отображается меню информационного дисплея, этот пункт меню нельзя сделать доступным. В таком случае вы должны выйти из информационного дисплея, сделать доступным пункт меню и перезапустить информационный дисплей.

Похожие ограничения в отношении Tech2Win - отображение данных применяются также и для Tech2Win - отображение диагностических кодов. Если программное обеспечение Tech2 поддерживает Tech2Win - отображение диагностических кодов, то вы можете сделать доступным этот пункт меню. Параллельно с дисплеем диагностических кодов неисправностей Tech2 появится дополнительное окно с отображением дисплея диагностических кодов неисправностей. Пока на экране Tech2 отображается меню дисплея диагностических кодов неисправностей, этот пункт меню нельзя сделать доступным. В таком случае вы должны выйти из дисплея диагностических кодов неисправностей, сделать доступным пункт меню и перезапустить дисплей диагностических кодов неисправностей.

Справка

Предусмотрены следующие варианты:

  • Справочная информация... - вызов справки Tech2Win.
  • Параметры командной строки - отображает параметры командной строки, используемые для Tech2Win.
  • Сведения о отображает номер текущей версии Tech2Win и ограничения по загрузкам TIS2Web.


Загрузка

Сначала запустите Tech2Win и перейдите в главное окно системы. Запустите TIS2Web или GlobalTIS и выполните загрузку через COM-порт, указанный на вкладке Интерфейс связи с автомобилем.

Используя встроенные COM-порты, можно загрузить программное обеспечение Tech2 с другого ПК, на котором работает TIS. Убедитесь в том, что вы используете перекрестный кабель RS232. В зависимости от аппаратного обеспечения ПК, на котором работает приложение Tech2Win, может потребоваться снизить скорость передачи данных до 57,600 бод. На более высоких скоростях передачи данных Windows может терять информацию.

Самая последняя версия Tech2Win также поддерживает быструю загрузку, когда TIS2Web и Tech2Win выполняются на одном и том же ПК. Минимальная связь между TIS2Web и Tech2Win через COM-порт все еще выполняется, но требующая больших затрат времени передача данные в Tech2Win заменена внутренней передачей файлов. В таком случае время загрузки существенно уменьшается и составляет гораздо меньше одной минуты.

  • Дополнительная информация: Файл конфигурации
  • Начало работы: Интерфейс связи с автомобилем
  • Вопросы и ответы: Как определить, какой COM-порт следует использовать для Tech2Win?
  • Вопросы и ответы: Связь между Tech2Win и TIS2Web


Защита доступа

Механизмы обеспечения безопасности, используемые в Tech2Win, учитывают правильность настройки времени ПК. Обеспечьте, чтобы настройка времени на вашем ПК была всегда правильной. Небольшие изменения настройки времени, которые могут быть связаны с переходом на сезонное время, для Tech2Win допустимы.

Без наличия действительной и активной лицензии Tech2Win не будет осуществлять никакого обмена данными с автотранспортным средством. Статус лицензии показан следующим индикатором в строке состояния:

  • green smiley Лицензия действительна.
  • Нет индикатора: Лицензия ещё не проверена.
  • red smiley Срок действия лицензии истёк.

Чтобы получить лицензию, пожалуйста, выполните обновление 'Доступ к защищенной области (Защита)' с помощью приложения TIS2Web. Кроме того, в большинстве случаев для получения новой лицензии достаточно произвести загрузку программного обеспечения через TIS2Web. Поскольку лицензия через некоторое время теряет свою силу (в некоторых регионах - через четыре недели), необходимо производить такие обновления регулярно.

Лицензии зависят от региона/программного обеспечения. Если вы пользуетесь Tech2Win с другой версией Tech2, то, возможно, в вашем компьютере уже имеются лицензии.

Количество дней до истечения срока действия лицензии указано в строке состояния.

  • ( 0) показывает, что лицензия просрочена или отсутствует.
  • (<1) До истечения срока действия лицензии осталось менее 24 часов.
  • (20) Срок действия лицензии истекает через 20 дней.

Пожалуйста, не вносите никаких произвольных изменений в файл лицензии. Незаконные изменения этого файла будут обнаружены встроенными средствами обеспечения безопасности и приведут к утрате всех лицензий на данном компьютере. Кроме того, работа Tech2Win станет непредсказуемой. Чтобы восстановить работу, необходимо произвести новую установку.

  • Дополнительная информация: Сообщения об ошибки и коды завершения
  • Дополнительная информация: Файл журнала регистрации событий
  • Работа с Tech2Win: Окно состояния
  • Вопросы и ответы: Действительная лицензия
  • Вопросы и ответы: В чем заключается разница между лицензией Tech2Win и доступом через систему безопасности?
  • Вопросы и ответы: Непредвиденная остановка


Просмотр отчетов

View Report Эта кнопка используется для просмотра информации, содержащейся в файлах PRT, записанных на карте PCMCIA. Список имеющихся файлов отображается в специальном диалоговом окне. Если с расширением PRT связана какая-либо программа, она будет запущена. В противном случае для просмотра выбранного файла используется блокнот.

В большинстве случаев файлы PRT представляют собой текстовые файлы, кодировка которых соответствует выбранному языку. При работе на китайском, японском, корейском или тайском языке эти файлы будут иметь кодировку Unicode и начинаться с обозначения порядка следования байтов (BOM).

При просмотре отчетов Tech2Win работает с подкаталогом C:\Users\Public\General Motors\Tech2Win\reports. Эта поддиректория существует только в том случае, если отчеты просматривались хотя бы один раз. Она автоматически удаляется и используется в качестве временной рабочей директории для файлов PRT с активной карты PCMCIA. Эти файлы остаются в ней даже после выключения Tech2Win. При необходимости сохранить эти файлы, следует скопировать их в другую директорию, так как они будут удалены, когда другой пользователь воспользуется функцией просмотра отчетов.


Образы карт PCMCIA

Образы PCMCIA обычно находятся в подкаталоге C:\Users\Public\General Motors\Tech2Win\pcmcia. Размер файла должен быть равен 32 МБ (33 554 432 байт) или 10 МБ (10 485 760 байт). Файл должен иметь расширение *.bin. Образы изменяются (как обычно и содержимое памяти карт PCMCIA) во время загрузки, а также в случаях, когда Tech2Win сохраняет на картах какую-либо информацию. Изменение образов может быть запрещено при помощи переключателя защиты от записи (команда -W0 или -W1) или путем удаления значения 'p' параметра '-W'.(Файл конфигурации). Нельзя получить доступ к выключателю защиты от записи через конфигуратор. Вы должны модифицировать файл конфигурации вручную, если хотите использовать опции '-W0', '-W1' или '-W'.


Строка состояния

Строка состояния отображается ниже экрана Tech2. В строке состояния отображается следующая информация:

  1. Индикатор скорости
  2. Состояние связи с автомобилем
  3. Состояние последовательного порта
  4. Клавиша SHIFT
  5. Автоматические снимки экрана
  6. Предупреждения в журнале регистрации событий
  7. Лицензия

Status Bar

Индикатор скорости

Индикатор скорости показывает, какой процент процессорного времени тратится на эмуляцию программного обеспечения Tech2. При этом малое значение (индикатор ближе к левому краю) лучше, чем большое значение (индикатор ближе к правому краю). Зеленый цвет индикатора является признаком нормальной работы. Если индикатор становится желтым на непродолжительное время, это говорит о том, что неожиданно активизировался другой процесс Windows. Такой активности следует избегать.

Состояние связи с автомобилем

Статус обмена данными с автомобилем показывает, присутствует ли интерфейс обмена данными с автомобилем (MDI), а также состояние обмена данными между автомобилем и Tech2Win.

Состояние последовательного порта

Если связь с Tech2Win осуществляется через COM-порт, данный индикатор показывает, передаются ли через этот порт данные.

Клавиша SHIFT

Этот указатель показывает, активирована ли клавиша SHIFT. Его можно переключать при помощи клавиши 'S' на клавиатуре или клавиши SHIFT на дополнительной клавиатуре.

Автоматические снимки экрана

Опцию 'Автоматические снимки экрана' ('Automatic Screenshots') можно активировать в меню Функции. При каждой смене экрана в каталог журнала будет записываться новый файл снимка экрана. Об этом свидетельствует индикатор в виде вращающейся ручки красной камеры в строке состояния. При выключении опции 'Automatic Screenshots' камера исчезает.

Предупреждения в журнале регистрации событий

Индикатор состояния журнала может иметь три различных состояния.

  • gray log status indicator Файл журнала не содержит никаких предупредительных сообщений или ошибок.
  • yellow log status indicator Файл журнала содержит предупредительное сообщение.
  • red log status indicator Файл журнала содержит сообщение об ошибке.

Лицензия

Индикатор лицензии может иметь три состояния:

  • green smiley Лицензия активна и действительна.
  • Нет индикатора: Лицензия ещё не проверена.
  • red smiley Лицензия просрочена или отсутствует.
Более подробная информация приведена на странице Безопасность.

Подсказки в строке состояния

Для некоторых пиктограмм на экране отображаются подсказки, содержащие дополнительную информацию:

Подсказка серийного номера VCI:
Tooltip VCI

Подсказка версии программы TECH2
Tooltip TECH2

Подсказка COM-порта
Tooltip Comport

Подсказка номера очередного снимка экрана (если активны 'Автоматические снимки экрана')
Tooltip Camera

Подсказка, показывающая последнюю запись в файле журнала, имеющую уровень 'предупреждение' или выше
Tooltip Logfile

Подсказка точного срока действия лицензии
Tooltip License

Подсказки отображаются, если курсор неподвижно находится над пиктограммой в течение более чем 0,5 секунды. Подсказки исчезают через 5 секунд или при перемещении курсора.

  • Дополнительная информация: Сообщения об ошибках и коды ошибок
  • Дополнительная информация: Файл журнала регистрации событий


Дополнительная информация

Рассматриваемые здесь вопросы имеют меньшее значение для обычного пользователя Tech2Win. Однако эти сведения могут быть полезны для тех, кто занимается установкой, управлением и конфигурированием Tech2Win.

  • Повторная инсталляция
  • Деинсталляция
  • Редактирование файлов конфигурации вручную
  • Файл журнала регистрации событий
  • Сообщения об ошибки и коды завершения
  • Карта ATA
  • Ключи реестра
  • Описание файлов
  • Примеры управления конфигурациями


Деинсталляция

Стирается весь каталог установки, каталог, содержащий данные пользователя (C:\Users\Public\General Motors\Tech2Win), и каталог, содержащий данные приложения (C:\ProgramData\General Motors\Tech2Win).

  • Дополнительная информация: Повторная инсталляция
  • Инсталляция


Файл конфигурации

Файлы конфигурации всегда находятся в подкаталоге C:\Users\Public\General Motors\Tech2Win\config и имеют расширение *.conf. Вы можете редактировать эти файлы вручную, так как не все содержащиеся в них опции доступны для изменения при помощи Tech2Win. Файлы конфигурации имеют кодировку Unicode и начинаются с обозначения порядка следования байтов (BOM). Для редактирования файлов конфигурации вручную рекомендуется использовать редактор, поддерживающий Unicode, например, Notepad.

Информация в файлах конфигурации располагается построково. Пустые строки игнорируются. Строка всегда начинается с названия параметра, после которого может быть указано его значение. В качестве примера посмотрите на файл default.conf. Содержащиеся в нем параметры описаны в следующей таблице.

Если вы хотите запускать определенную конфигурацию непосредственно с рабочего стола, создайте ярлык, который выполняет 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Программу следует запускать из следующего рабочего каталога: 'C:\Program Files\General Motors\Tech2Win\bin'

параметр | Значение / Назначение
; Комментарий
@ Номер версии: десятичное число в формате версия.подверсия.
Файлы конфигурации, имеющие номер версии, отличный от номера версии Tech2Win системой не принимаются. Допускается использование файлов конфигурации, имеющих номер версии, меньший, чем номер версии Tech2Win.
-W0
-W1 		Карта PCMCIA, установленная в слот 0/1 имеет защиту от записи.
-B0
-B1 		Размер блока карты PCMCIA, установленной в слот 0/1, в килобайтах. Допустимые значения: 128 (по умолчанию) или 256.
-P0
-P1 		Файл, в котором записан двоичный образ карты PCMCIA, установленной в слот 0/1. Размер файла должен быть точно равен 10 или 32 МБ. Переменные среды, такие как %ProgramData%, расширяются.
Если этот параметр отсутствует, слот считается незанятым.
-A0
-A1 		Файл, в котором содержатся значения атрибутов карты PCMCIA, установленной в слот 0/1. Если этот параметр отсутствует, используются значения атрибутов, принятые по умолчанию в зависимости от карты и размера блока.
-W | При выходе из Tech2Win все текущие данные записываются в соответствующие файлы. Допускается комбинировать значения p/f/r/c, чтобы обозначить карту PCMCIA/Flash-ROM/RTC/CANDI-App соответственно.
-H | Функциональные возможности управления динамически распределяемой памятью Значения 0/r/w/t можно комбинировать, чтобы активировать 'Обнуление', 'Проверки считывания', 'Проверки записи' и 'Проверки задач'. Значение 'l' используется для того, чтобы всегда принудительно располагать динамическую память на более младших адресах, если реализуется альтернативная схема размещения. Обычно этот вариант выбора используется только в проектной среде.
-PC | Ранее путь для копии карты PCMCIA. Эта опция в настоящий момент игнорируются.
-MS | Идентификация интерфейса обмена данными с автомобилем (MDI) по серийному номеру. Если не задано, на экран будет выведен список доступных интерфейсов MDI.
-CT | Цвет шрифта в виде 3 шестнадцатиричных значений. По умолчанию принимается значение 000000 (белый).
-CB | Цвет фона в виде 3 шестнадцатиричных значений. По умолчанию принимается значение FFFFFF (черный).
-ATA | Используйте эту опцию, чтобы задействовать карту захвата ATA. Удалите её, если нужно отключить карту захвата ATA.
-C | Номер COM-порта (1..9), который используется в качестве коммуникационного порта RS232C системы Tech2. Часто используется порт COM9, виртуальный COM-порт, устанавливаемый системой Tech2Win. Если этот вариант выбора не присутствует, то поиск свободного COM-порта производится в убывающем порядке, начиная с COM9. Используйте подсказку в строке состояния между значком Tech2 и значком TIS2Web, чтобы увидеть, какой COM-порт используется.
-WR | Адрес ПК (обычно 253558), который разрешён для осуществления записи на PCMCIA и в область флэш-ПЗУ. Эти функциональные возможности должны дополнительно активироваться через меню (или с помощью опции -WA). Необходимо произвести отладку кода в постоянном запоминающем устройстве с помощью отладчика SingleStep Debugger.
-WA | Разрешите отладчику SingleStep Debugger записывать в немодифицируемую память.
-OF | Файл опций, содержащий пары 'опция - значение'.
-TP | Регулировка синхронизации (Пропорциональное значение). Значение по умолчанию 5000. Уменьшите это значение, чтобы число выполняемых циклов быстрее адаптировалось к реальному времени.
-TD | Регулировка синхронизации (Дифференциальное значение). Значение по умолчанию 100. Уменьшите это значение, чтобы обеспечить более быструю реакцию на изменения текущей синхронизации. ПРЕДУПРЕЖДЕНИЕ: произвольные изменения значений TP и TD могут привести к проблемам с быстродействием.
-PJ
-PP 		Укажите протокол, который следует использовать:
PJ для связи через J2534.
PP для ISO22900-2 / PDU-API (по умолчанию)
-S | Наличие этого параметра означает, что на динамик ПК будут подаваться звуки.
-L | Язык приложения Tech2Win. Если пропустить этот элемент ввода, то по умолчанию будет использоваться активный язык Windows. Список языков, которые могут быть указаны, приведен на странице, расположенной по следующей ссылке: Языки. Само окно эмуляции Tech2 будет отображать информацию на том языке, который используется на карте PCMCIA (т.е. который был загружен на карту PCMCIA).
-UD | Переопределение каталога данных пользователя. Под Win7, он обычно находится по адресу C:\Users\Public\General Motors\Tech2Win
-AD | Переопределение каталога данных приложения. Под Win7, он обычно находится по адресу C:\ProgramData\General Motors\Tech2Win
-US | Используйте пользовательский семафор для обнаружения более чем одного экземпляра Tech2Win. Эта опция позволит каждому пользователю запускать Tech2Win параллельно на одной и той же машине, предположительно, на сервере. При использовании этой опции также следует определить опции -UD и -AD.
-SS | Опция для определения полного размера окна Tech2Win, включая клавиатуру (если имеется). Первый параметр должен быть представлен строкой, взятой в двойные кавычки ('), и будет использоваться как название размера в меню Функции / Разрешение. Второй параметр представляет общее количество горизонтальных пикселов экрана Tech2Win, включая клавиатуру. Третий параметр представляет общее количество вертикальных пикселов экрана Tech2Win. Четвертый дополнительный параметр представляет ширину клавиатуры в пикселах.
-SH Опция для управления работой с экраном. Следующее десятичное число используется для определения того, какие возможности работы с экраном подлежат отключению.
  • Бит 0: Отсутствует возможность задать минимум/максимум.
  • Бит 1: Отсутствует изменение положения на экране.
  • Бит 2: Отсутствует изменение размера. В этом случае цвет меню Функции / Разрешение становится серым.
  • Бит 3: Окна 'Информационный дисплей' и 'Код DTC' будут точно такого же размера, что и Tech2Win (без клавиатуры)


Регистрация событий

При каждом запуске конфигурации Tech2Win в подкаталоге C:\Users\Public\General Motors\Tech2Win\Logs создаётся новый файл журнала в формате HTML. Во избежание переполнения жёсткого диска файлы журнала старше одной недели удаляются.

Файлы журнала событий автоматически получают имена в зависимости от даты (год, месяц, день) и времени (час, минута, секунда) их создания:
гггг-мм-дд_ччммсс.html

Файлы журнала событий всегда ведутся на английском языке, но имеют кодировку Unicode и начинаются с обозначения порядка следования байтов (BOM). Каждая строка файла соответствует одному из следующих уровней событий:

Уровень события | Назначение
Информ. | Только информация Не оказывает никакого влияние на работу программы.
Предупреждение | Обнаружена необычная ситуация. Пользователь может не заметить никаких нежелательных последствий.
ERROR | Произошла ошибка, последствия которой будут видны пользователю.
CRITICAL | Произошла серьезная ошибка, которая приведет к нештатному завершению программы.
FATAL | Произошла критическая ошибка, которая приведет к немедленному завершению работы Tech2Win.

Все уровни выше 'Предупреждения' окрашены таким образом, что их легко обнаружить.

Кроме того, если использовалась опция меню Печать Экрана или Автоматические снимки экрана, в подкаталоге Logs будут присутствовать файлы 'Print' и 'Video'.
гггг-мм-дд_ччммсс_print_nnnnn.bmp
гггг-мм-дд_ччммсс_video_nnnnn.png
Изображения Автоматические снимки экрана привязаны к HTML-файлу - поэтому для просмотра последовательности этих изображений используйте журнал в формате HTML.

Информация о событиях уровня 'Предупреждение' ( yellow lightning bolt) или более серьезных уровней ( red lightning bolt) выводится в строке состояния.


Сообщения об ошибки и коды завершения

Сообщения об ошибках выводятся в диалоговых окнах. Система Tech2Win продолжает выполнение программ Tech2, даже если активно одно из таких диалоговых окон. Коды завершения - критические ошибки, которые привели к нештатному завершению работы Tech2Win. Эти коды используются командными файлами для определения причин завершения программы.

Сообщения об ошибке

В ходе работы системы могут быть выведены следующие сообщения об ошибке. Ниже приводится краткое описание случаев возникновения ошибок, а также методы устранения возникших проблем.

Emulator too slow Emulator failed to start

Коды завершения

Код завершения | Значение | Назначение
OPCODE_ERROR | -7 | Обнаружена неправильная команда микропроцессора Tech2 (68332). Возможно, образ PCMCIA был поврежден.
ATA_PROBLEM | -6 | Возникла проблема при эмуляции ATA. Если данная проблема возникла после того, как вы получили инструкцию использовать карту ATA, обратитесь в службу технической поддержки.
DEMO_TIME_IS_UP | -5 | В официальной версии Tech2Win эта ситуация не должна возникать.
DLL_NOT_LOADED | -3 | Не удалось загрузить одну из необходимых для работы DLL. Возможно, у вас неполная копия Tech2Win. Попробуйте установить систему заново и/или выбрать другой язык.
EXIT_INIT_FAILED | -2 | Сбой при инициализации. Точная причина сбоя указана в файле журнала регистрации событий. Если файл журнала регистрации событий отсутствует, проверьте права на чтение/запись во всех директориях системы.
нормальн. | 0 | Работа Tech2Win завершилась штатным образом.


Карта ATA

Карта ATA используется в Tech2, в основном, только для отладки во время разработки программного обеспечения. Все необходимые данные ATA сохраняются в подкаталоге C:\Users\Public\General Motors\Tech2Win\ataCapture. Эта директория обычно не важна для работы и, если нет специальных указаний, запрещающих это, ее можно удалить.

Так как директория ataCapture имеет фиксированную структуру, ее содержание будет одинаково для всех конфигураций.


Файлы

Система Tech2Win использует следующие файлы и директории:

Каталог | Расположение для версий, предшествующих Vista | Расположение для Vista и более поздних версий
Инсталляция | Как определено во время установки
Данные пользователя | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Данные приложения | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Файл | Назначение
[Данные пользователя]\atacapture | Содержит файлы, имеющиеся на ATA-карте. Если не указано иное, в этих файлах нет необходимости.
[Инсталляция]\bin | В этой директории хранятся исполняемые файлы, библиотеки DLL и образы, необходимые для работы системы.
[Инсталляция]\bin\emulator.exe | Основной исполняемый файл, отвечающий за обработку кода Tech2.
[Инсталляция]\bin\emulator_xx_XX.dll | Библиотека DLL, содержащая ресурсы системы на определенном языке.
[Инсталляция]\bin\T2Configurator.exe | Конфигурационная часть Tech2Win.
[Инсталляция]\bin\Pictures | В этой директории хранятся необходимые для работы Tech2Win пиктограммы.
[Данные пользователя]\config | Содержит все файлы конфигураций.
[Данные пользователя]\data | Содержит файлы, измененные в ходе работы Tech2Win. Эти файлы необходимы для правильной работы Tech2Win. Обычно, если у вас нет специальных инструкций, ничего делать с этими файлами не требуется.
[Данные приложения]\data | Содержит файлы, измененные в ходе работы Tech2Win. Эти файлы необходимы для правильной работы Tech2Win. Обычно, если у вас нет специальных инструкций, ничего делать с этими файлами не требуется.
[Данные приложения]\data\emulator.sec | Файл защиты доступа . Не изменяйте этот файл.
[Данные приложения]\data\emulator.card | Файл карт. Содержит все карты PCMCIA, известные программе Tech2Win. Не изменяйте этот файл.
[Данные пользователя]\data\emulator.disp | В этом файле хранится информация о местоположении и размере окна Tech2Win. Если удалить этот файл, он будет восстановлен, а при запуске системы окно Tech2Win будет располагаться у верхнего левого окна экрана и иметь размер 640x480.
[Данные приложения]\data\emulator.lic | Файл лицензии. Содержит информацию о сроках действия ваших лицензий. Не изменяйте этот файл.
[Данные приложения]\data\emulator.rtc | Файл системы реального времени. Используется для хранения данных системы реального времени Tech2.
[Данные приложения]\data\emulator.dta | Информационный файл 'Не выводить больше это окно'.. В этом файле хранятся версии программного обеспечения PCMCIA, которые не будут (больше) выводить предупреждение о невозможности выполнения тестов самодиагностики, требующих наличия адаптера для замыкания на себя.
[Данные приложения]\data\candi.bin | Файл приложения CANdi. Содержит приложение CANdi, подключенного к Tech2.
[Данные приложения]\data\eprom.bin | Файл внутреннего ППЗУ Tech2. Содержит образ внутренней флэш-памяти Tech2.
[Инсталляция]\driver | Установочные файлы драйвера виртуального COM-порта.
[Инсталляция]\help\emulator_xx_XX.chm | Файлы справки для конкретных языков.
[Данные пользователя]\Logs | Содержит файлы журналов. Файлы старше одной недели будут автоматически удаляться.
[Данные пользователя]\pcmcia | В этой директории хранятся файлы с образами карт PCMCIA. Образно говоря, каждый файл соответствует одной карте PCMCIA Tech2. При желании эти файлы можно сохранить в другом месте.


Управление конфигурациями

Файлы конфигурации всегда находятся в подкаталоге C:\Users\Public\General Motors\Tech2Win\config и имеют расширение *.conf. Tech2Win может использоваться для генерации новых файлов конфигурации, а также для редактирования файлов, доступных не только для чтения. Для управления всеми остальными файлами конфигурации следует использовать Проводник Windows или аналогичные программы для работы с файлами. Это необходимо для выполнения следующих действий:

  • удаление файлов конфигурации
  • переименование файлов конфигурации
  • изменение атрибута 'только для чтения' файлов конфигурации

Настоятельно рекомендуется, чтобы в системе всегда существовал файл конфигурации default.conf. Во избежание ошибочной перезаписи этот файл в обычных условиях должен иметь атрибут 'только для чтения'. Однако, если возникнет необходимость изменения информации, содержащейся в этом файле, потребуется на некоторое время снять этот атрибут.

Образы PCMCIA находятся в подкаталоге C:\Users\Public\General Motors\Tech2Win\pcmcia. Каждый из этих файлов соответствует одной карте PCMCIA, с которыми вы уже знакомы по работе с системой Tech2. В системе Tech2Win может использоваться любое количество образов. Просто сохраните существующий образ под другим именем.

Если вы хотите запускать определенную конфигурацию непосредственно с рабочего стола, создайте ярлык, который выполняет "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Программу следует запускать из следующего рабочего каталога: 'C:\Program Files\General Motors\Tech2Win\bin'

Количество файлов конфигурации не зависит от количества используемых образов PCMCIA. Несколько файлов конфигурации могут ссылаться на один и тот же файл образа. Такой подход соответствует ситуации, когда в ремонтной мастерской несколько механиков используют одну и ту же систему Tech2 (и одну и ту же карту PCMCIA).

Кроме того, каждая конфигурация может использовать отдельный образ PCMCIA. Это позволит сделать конфигурации более независимыми друг от друга. Однако, при этом потребуются дополнительные действия по обновлению всех образов PCMCIA, что может оказаться недопустимым.

При создании новой конфигурации путем копирования уже существующей, конфигуратор отобразит предупреждение в том случае, если образ PCMCIA не изменился. В этом случае у вас будет две конфигурации, использующие один и тот же образ PCMCIA. Если это именно то, что вам нужно, просто нажмите OK. Если вы хотите, чтобы новая конфигурация использовала другой или новый образ PCMCIA, то нажмите Отмена. Затем можно выбрать создание нового образа с помощью Копировать карту памяти ...

Следующие два примера показывают методы управления конфигурациями и образами PCMCIA.

Одна конфигурация на каждого пользователя

Предусмотрена возможность сохранения конфигурации для каждого пользователя. В качестве имени конфигурации может использоваться, например, имя пользователя. Преимущества такого принципа заключаются в том, что можно сохранить специфичные настройки пользователя, например персональные настройки интерфейсов обмена данными с автомобилем (MDI), дисплея и языка. Недостаток заключается в том, что если одну и туже программу будут использовать несколько пользователей, требуется создать копии файлов карты PCMCIA. Для специальных пользовательских конфигураций, конечно же, можно использовать основной файл карты PCMCIA.

Одна конфигурация на программное обеспечение Tech2Win

Можно предусмотреть создание новой конфигурации для каждого загружаемого программного обеспечения. Таким образом, при необходимости можно получить немедленный доступ даже к более ранним версиям программного обеспечения. В таком случае в качестве имени конфигурации часто выбирают имя программы и номер версии.

  • Начало работы: Интерфейс связи с автомобилем
  • Начало работы: Путь
  • Дополнительная информация: Файл конфигурации
  • Инсталляция: Этапы инсталляции


Вопросы и ответы

  • Как определить, какой COM-порт следует использовать для Tech2Win?
  • Связь между Tech2Win и TIS2Web
  • Действительная лицензия
  • Что показывает индекс лицензии?
  • В чем заключается разница между лицензией Tech2Win и доступом через систему безопасности?
  • При выполнении процедуры доступа через систему безопасности к исходному программному обеспечению TIS2Web показывает неконкретную ошибку
  • Tech2Win не запустит программу Tech2 для другого региона
  • Как можно использовать более одного интерфейса MDI?
  • Файл журнала содержит ошибку 'CPU32: Too many 0000/FFFF Commands encountered'
  • Нет видимых окон Tech2
  • Не работает SPS
  • Не работают некоторые тесты самодиагностики
  • Колебания показаний индикатора быстродействия
  • Непредвиденная остановка
  • Шведский язык отображается для программного обеспечения 15.001
  • Потеря связи с интерфейсом MDI
  • Tech2Win не обнаружила мой интерфейс MDI
  • Я хочу сразу запускать Tech2Win и не возиться с конфигуратором
  • Где находятся функции печати?
  • На моем компьютере имеется 'неиспользуемая' папка PCMCIA
  • Я получаю сообщение 'недопустимый путь к файлу'

Как определить, какой COM-порт следует использовать для Tech2Win?

Для поиска портов можно использовать пункт 'Порты (COM и LPT)' в 'Диспетчере устройств' Windows. В некоторых компьютерах, однако, установлены внутренние модемы или bluetooth-устройства, которые не отображаются в этой категории.
Другой способ состоит в использовании простой команды, предлагаемой вместе с конфигуратором. Для её выполнения воспользуйтесь меню 'Пуск' (папка Tech2Win) и щёлкните на 'show com ports'.
Оба метода позволяют найти COM-порты, которые установлены на вашем компьютере и которые НЕ следует использовать.

Связь между Tech2Win и TIS2Web

Важно, чтобы перед началом обмена данными с TIS2Web для проверки прав доступа или загрузки программного обеспечения программа Tech2Win была уже запущена. TIS2Web может распознать виртуальный COM-порт только если запущена программа Tech2Win.

Действительная лицензия

Обычно в результате загрузки программного обеспечения из TIS2Web вы сразу получаете действительную лицензию. Если у вас всё ещё нет лицензии, то для получения действительной лицензии необходимо осуществить 'Доступ к защищенной области (Защита)' через TIS2Web (не TIS2000). Пожалуйста, не устанавливайте какую-либо иную связь TIS2Web с Tech2Win, например, 'Загрузка программного обеспечения (SWDL)', пока не получите лицензию посредством 'Доступ к защищенной области (Защита)'.

Что показывает индекс лицензии?

Индекс лицензии справа от строки состояния показывает число полных дней до истечения срока действия лицензии. Сразу после загрузки или доступа через систему безопасности отображается количество дней '30'. Однако после нового запуска Tech2Win отображается '29', поскольку до истечения срока действия лицензии осталось, например, 29 дней, 23 часов и 55 минут. Если до истечения срока действия лицензии осталось меньше 24 часов, отображается срок действия <1. Если срок действия лицензии истёк, отображается '0'.

В чем заключается разница между лицензией Tech2Win и доступом через систему безопасности?

Лицензия Tech2Win позволяет вам использовать Tech2Win. Чтобы получить такую лицензию, необходимо периодически (обычно каждые 30 дней) производить либо загрузку программного обеспечения, либо доступ через систему безопасности. Возможность осуществления такой загрузки через TIS2Web информирует Tech2Win о присутствии зарегистрированного пользователя. Так же как и в Tech2 процедура доступа через систему безопасности информирует Tech2Win, что определённые действия, относящиеся к безопасности, такие как отключение подушки безопасности, разрешены. И получение лицензии Tech2Win, и доступ через систему безопасности можно осуществить через приложение Security Access системы TIS2Web. Tech2Win отображает на экране оставшийся срок действия лицензии в строке состояния с правой стороны. К сожалению, Tech2Win не может отображать длительность доступа через систему безопасности, поскольку Tech2Win просто выполняет программу Tech2, но не имеет сведений о самой программе Tech2.

При выполнении процедуры доступа через систему безопасности к исходному программному обеспечению TIS2Web показывает неконкретную ошибку

Поведение такое же, как и в Tech2. Из-за своего возраста исходное программное обеспечение не способно получить лицензию от TIS2Web. Однако на самом деле это не проблема, т.к. данное демонстрационное программное обеспечение не связывается с автомобилем, для которого требуется лицензия. И поскольку лицензии относятся к конкретным загрузкам TS2Web, вам так или иначе придется получать лицензию для каждой загрузки в отдельности после загрузки программного обеспечения Tech2. 'Лицензия' на исходное программное обеспечение не дает вам права выполнять автомобильную коммуникацию с использованием программного обеспечения Opel/Vauxhall или North American Operations.

Tech2Win не запустит программу Tech2 для другого региона

Действие вашей версии Tech2Win, вероятно, ограничено одной или несколькими загрузками TIS2Web (регионами). Чтобы посмотреть, какие ограничения относятся к вашей версии Tech2Win, нажмите Справка / Сведения о. Прежние версии Tech2Win допускали только выполнение программного обеспечения Opel/Vauxhall. Готовы последовать и другие регионы GM. В любом случае, в Tech2Win в настоящее время может исполняться программное обеспечение Tech2 компании General Motors.

Как можно использовать более одного интерфейса MDI?

Если требуется назначить конкретные интерфейсы MDI конкретным пользователям, рекомендуется, чтобы каждый пользователь имел свою собственную конфигурацию. Очевидно, что этим конфигурациям следует присвоить имена, соответствующие их пользователям. В каждой конфигурации на вкладке 'Интерфейс связи с автомобилем' следует ввести серийный номер интерфейса MDI для соответствующего пользователя. Как только пользователь запустил свою конфигурацию, Tech2Win пытается установить связь с заданным интерфейсом MDI. Если этот интерфейс MDI отсутствует, на экране появится окно выбора, содержащее список всех интерфейсов MDI, найденных Tech2Win.

Если для общего пользования доступно несколько интерфейсов MDI, рекомендуется использовать конфигурации, в которых поле серийного номера интерфейса связи с автомобилем (VCI) на вкладке 'Интерфейс связи с автомобилем' оставлено пустым. При этом пользователь всегда будет видеть окно выбора со списком доступных интерфейсов MDI.

Файл журнала содержит ошибку 'CPU32: Too many 0000/FFFF Commands encountered'

Повреждён файл 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' или текущий файл карты PCMCIA. Переустановите Tech2Win и загрузите новое программное обеспечение Tech2.

Нет видимых окон Tech2

Если окно Tech2 не видно на экране, вероятно, оно находится за границами рабочей области дисплея. Такое может происходить при использовании нескольких экранов или после изменения разрешения экрана. Во время запуска своей конфигурации нажмите на клавиатуре клавишу Shift. При этом будет установлено исходное разрешение окна 640x480, и окно Tech2 будет отображаться в верхнем левом углу экрана. Вы также можете удалить файл C:\Users\Public\General Motors\Tech2Win\emulator.disp, чтобы достичь такого же эффекта.

Известны случаи, когда после закрытия окон всех других приложений окно Tech2 просто не перерисовывалось на экране. Во всех известных нам случаях комбинация клавиш Alt-Tab, используемая в Windows для переключения между приложениями, помогала восстановить окно Tech2 на экране. Использование кнопки Tech2Win в панели задач в нижней части экрана ПК помогало не всегда. В настоящее время мы исследует этот вопрос и надеемся устранить эту ошибку в следующей версии Tech2Win.

Не работает SPS

Да, нам известно. Мы не планируем это менять. Не следует использовать Tech2Win вместо Tech2 для программирования с помощью SPS. Пожалуйста, используйте MDI непосредственно при помощи программирования SPS через TIS.

Не работают некоторые тесты самодиагностики

Тесты самодиагностики Tech2 предназначены для проверки отдельных компонентов аппаратного обеспечения Tech2. Некоторые из этих тестов требуют использования адаптера для замыкания на себя. В Tech2Win эти тесты работать не будут, поскольку функция адаптера для замыкания на себя не предусмотрена (и не планируется). Пожалуйста, просто воздержитесь от выполнения этих тестов в Tech2Win, поскольку они не имеют смысла. Их выполнение может привести к ошибочным результатам или зависанию Tech2Win, так же как это случилось бы с Tech2 без адаптера для замыкания на себя. В этом случае для сброса Tech2Win в исходное состояние нажмите Ctrl-R.

Колебания показаний индикатора быстродействия

Индикатор быстродействия в нижней левой части строки состояния показывает, сколько 'команд Tech2' может быть выполнено, прежде чем Tech2Win должна будет снова перейти в 'спящий режим'. Этот метод используется для того, чтобы обеспечить соответствие времени Tech2Win реальному времени - более быстрые ПК находятся в спящем режиме дольше, чем более медленные ПК. Если показания индикатора быстродействия колеблются, значит вычислительная мощность используется каким-то другим приложением или тактовая частота ПК нестабильна. Большая интенсивность колебаний негативно сказывается на обмене данными с автомобилем и с TIS2Web. Закройте все другие приложения.

Большинство портативных компьютеров способны понижать тактовую частоту ЦП для увеличения времени работы от аккумуляторной батареи. Это также может быть причиной регистрируемой Tech2Win нестабильности быстродействия. В таком случае, работая на портативном компьютере, подключите его к внешнему источнику питания. Можно также попробовать изменить настройки энергопотребления, чтобы операционная система не снижала тактовую частоту.

Непредвиденная остановка

Если в файле журнала не удалось обнаружить никаких причин прерывания работы, то, возможно, были активированы внутренние механизмы обеспечения безопасности Tech2Win. Пожалуйста, не вносите никаких произвольных изменений в следующие файлы: emulator.sec, emulator.lic, emulator.card. Если Tech2Win обнаружит нарушение системы безопасности, то, скорее всего, придётся произвести переустановку.

Шведский язык отображается для программного обеспечения 15.001

Программное обеспечение, первоначально поставляемое с Tech2Win, является демонстрационным программным обеспечением и присутствует на каждой новой PCMCIA-карте. TIS2Web показывает, что используется шведский язык, поскольку TIS2Web отображает в списке из четырёх языков, поддерживаемых данным демонстрационным программным обеспечением (английский, французский, немецкий, шведский), только последний язык. Чтобы записать вместо этого демонстрационного программного обеспечения новейшее диагностическое программное обеспечение, используйте режим обновления 'Индивидуальный' вместо 'Стандартный'.

Потеря связи с интерфейсом MDI

Потеря связи с интерфейсом MDI может происходить по нескольким причинам.

  • Плохо подключен кабель (относится как Ethernet, так и к USB).
  • Неустойчивое беспроводное соединение.
  • ПК переходит в ждущий режим.

Tech2Win не обнаружила мой интерфейс MDI

Проверьте следующее:

    1. Активен ли интерфейс MDI?
    2. Работает ли MDI Manager?
    3. Используется ли MDI какой-либо другой программой, такой как SPS?
MDI Manager можно запустить с помощью значка на рабочем столе или через меню 'Пуск/Все программы/General Motors/GM MDI Software'.: Если пункт 2 не работает, свяжитесь со службой технического сопровождения.

Я хочу сразу запускать Tech2Win и не возиться с конфигуратором

Выполните "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Используйте следующий рабочий каталог: 'C:\Program Files\General Motors\Tech2Win\bin' По-прежнему можно использовать конфигуратор для внесения любых изменений в конфигурацию.

Где находятся функции печати?

Tech2Win не предлагает функциональные возможности прямой печати. Вместо этого она создает временные файлы и вызывает программы, сопоставленные расширениям файлов. Эти программы могут использоваться в целях печати, позволяя вам корректировать внешний вид распечатки.

Print Report | Print Report

Чтобы вывести на печать текущий экран Tech2Win, используйте элемент меню Файл / Печать Экрана или кнопку на дополнительной клавиатуре, содержащей указание на принтер. Если необходимо распечатать несколько экранных изображений Tech2Win, то можно использовать элемент меню Функции / Автоматические снимки экрана, т.к. он создает файлы PNG для каждого экранного изображения Tech2Win. Файлы PNG внедряются в файл журнала.

Также можно распечатать содержание информационного дисплея (активируется с помощью элемента меню Окно / Tech2Win - отображение данных). Используйте кнопку Запустить Печать/HTML для запуска, а затем и остановки сбора данных. После остановки сбора данных запускается сопоставленная расширению файла HTML исполняемая программа (обычно Internet Explorer), которая дает массу функциональных возможностей для печати ваших данных.

Data Display | Data Display

На моем компьютере имеется 'неиспользуемая' папка PCMCIA

Более ранние версии Tech2Win всегда имели дублирующее место сохранения файлов PCMCIA в отдельном каталоге. Этот каталог часто находился по адресу C:\PCMCIA. Теперь этот каталог больше не используется, т.к. быстрая загрузка из TIS2Web делает ненужным вторичное сохранение таких загрузок. Этот каталог можно безопасно стереть.

Я получаю сообщение 'недопустимый путь к файлу'

Похоже, что имя файла содержит недопустимые знаки, такие как знак процента (%). Если вы сталкиваетесь с этой проблемой непосредственно после установки, то лучше всего было бы просто отменить установку и выполнить новую установку. В большинстве случаев этот метод помогает.

Во время обычной установки переменная среды 'Tech2WinUserData' устанавливается на 'PUBLIC' (для версий Windows >= Vista) и на 'ALLUSERSPROFILE\Documents' (для версий Windows до Vista). В некоторых редких случаях переменная среды не устанавливалась в процессе установки, но со второй попытки все прекрасно получалось. Вы также можете попробовать установить переменную среды вручную. Попросите своего администратора помочь, если не знаете, как установить переменную среды.


Ключи реестра

Программа установки создает следующие ключи реестра. Пожалуйста, не изменяйте их вручную. Имейте в виду стандартные предупреждения операционной системы Windows в отношении работы с ключами реестра.

ключ реестра | наименование | тип | Назначение
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Внутренний номер версии
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Язык | REG_SZ | установленный язык
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Путь к каталогам с копией PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Корневая директория | REG_SZ | путь к установленным файлам
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | UninstallOption | REG_DWORD | Параметры отмены установки
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Версия файла конфигурации
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Версия драйвера виртуального COM-порта
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | НаименованиеПО | REG_SZ | Наименование программного обеспечения, которое используется для отображения в списке 'Установка и удаление программного обеспечения'
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | СтрокаДеинсталляции | REG_SZ | Путь к программе деинсталляции


Повторная инсталляция

При переустановке будет удален полностью каталог установки Tech2Win, исключая следующее.

  1. подкаталог config, содержащий конфигурации, не стирается.
  2. Подкаталог pcmcia, который обычно содержит образы PCMCIA, не стирается.
  3. Подкаталог ATA, который может содержать информацию по отладке, не стирается.
Файлы конфигурации могут стать несовместимыми: не гарантируется, что конфигурационные файлы, созданные в старых версиях Tech2Win, будут читаться более новыми версиями Tech2Win. Образы карт PCMCIA по определению не могут быть несовместимыми.

Директория с копиями образов PCMCIA при повторной инсталляции программного обеспечения не удаляется.

В некоторых случаях возможна автоматическая установка обновленных версий системы Tech2Win. Так как информация о последней инсталляции хранится в реестре, эти настройки будут использоваться в качестве принятых по умолчанию при повторной установке.

Принудительную переустановку Tech2Win можно инициировать с помощью сценария enable reinstallation. Этот сценарий устанавливается вместе с программой Tech2Win. По существу, этот сценарий просто присваивает ключу CurrentVersion, содержащемуся в реестре в строке HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win, значение '1.000'.