Manualul utilizatorului Tech2Win

Bine aţi venit la manualul utilizatorului Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Toate drepturile rezervate.

  • Introducere:
  • Licenţă:
  • Instalare:O descriere a procedurii de instalare Tech2Win.
    • Paşii de instalare
    • Interfaţa pentru comunicaţii a vehiculului
  • Primii paşi
    • Selectarea unei configuraţii
      • Tastatură
      • Manipularea ferestrelor
    • Configuraţii noi
    • Modificare configuraţii
      • Limbă
      • Cale
      • Afişare
      • Salvarea unei configuraţii
    • Obţineţi o licenţă Tech2Win valabilă.
  • Lucrul cu Tech2Win: Detalii pentru utilizarea de zi cu zi.
    • Meniu
    • Descărcarea unei imagini PCMCIA
    • Securitate
    • Vizualizare rapoarte
    • Manipularea imaginilor PCMCIA
    • Bara de stare
  • Subiecte avansate: Informaţia nu este necesară pentru utilizarea obişnuită a aplicaţiei Tech2Win. Cel mai adesea prezintă interes pentru persoanele care au sarcini de administrare.
    • Reinstalare
    • Dezinstalare
    • Formatul fişierului de configurare
    • Fişier jurnal
    • Mesaje de eroare sau coduri de eroare
    • Card ATA
    • Intrări de regiştri
    • Fişiere
    • Administrare configuraţii
  • FAQ


Introducere

Tech2Win este o aplicaţie Windows care poate emula funcţionalitatea Tech2. În esenţă, aplicaţia software Tech2 este executată pe un PC. Pentru a rula acest program, PC-ul dumneavoastră trebuie să îndeplinească următoarele cerinţe tehnice:

  • Este necesară instalarea unei interfeţe de comunicare cu vehiculul şi conectarea acesteia la PC. Lista de interfeţe acceptabile poate diferi de la o regiune la alta. În majoritatea cazurilor poate fi utilizată Interfaţa de diagnostic multiplă de la GM (MDI).
  • În timpul instalării, aplicaţia Tech2Win necesită 150 MB spaţiu liber pe hard disk. Este necesar un spaţiu suplimentar de 32 MB pentru cardul PCMCIA cu care doriţi să lucraţi.
  • Înainte de execuţia aplicaţiei Tech2Win, este nevoie de minimum 100 MB memorie RAM liberă fizic. Este obligatoriu ca PC-ul să aibă suficientă memorie pentru a ţine aplicaţia încărcată în RAM pe durata întregii execuţii.
  • Computerul dumneavoastră trebuie să aibă puterea de calcul echivalentă unui procesor Pentium (single core) de 1,2 GHz. Vă recomandăm cu căldură să nu utilizaţi alte aplicaţii în paralel.
  • Nu este necesară o tastatură. Aplicaţia Tech2Win poate fi operată şi prin intermediul ecranului tactil. Pentru administrarea configuraţiilor vă sugerăm cu căldură să utilizaţi o tastatură, deoarece va trebui să introduceţi nume de fişiere.
  • Afişajul grafic color trebuie să aibă o rezoluţie minimă de 800 x 600, cu o profunzime minimă a culorii de 256. Fără tastatură, poate fi acceptabilă o rezoluţie de 640 x 480.

Când folosiţi Tech2Win (un laptop în locul lui Tech2), vă rugăm să vă asiguraţi că laptopul este suficient încărcat. În mod normal, laptopul dumneavoastră nu va fi alimentat de la bateria maşinii, cum se întâmplă la Tech2.

  • Instalare
  • Primii paşi


Licenţă

General Motors - Acord de licenţă Tech2Win

Citiţi cu atenţie următorii termeni şi condiţii înainte de a utiliza acest program. Dacă nu sunteţi de acord cu sau nu înţelegeţi aceşti termeni sau aceste condiţii, contactaţi reprezentantul local pentru Aftersales. Dreptul de a utiliza acest software este acordat de General Motors, numai dacă utilizatorul este de acord cu această licenţă prin acceptarea acestor termeni şi condiţii în timpul instalării aplicaţiei Tech2Win.
General Motors acordă dreptul de utilizare a software-ului Tech2Win şi a informaţiilor incluse în conexiune cu TIS2Web sau GlobalTIS sau TIS2000 numai utilizatorilor reţelei de reparatori autorizaţi General Motors, după cum s-a stabilit în Acordul de reparator autorizat, aplicabil local, cu Filialele naţionale de vânzări ale General Motors.
Licenţa Tech2Win este validă cât timp Acordul de reparator autorizat este în vigoare şi licenţa TIS2Web, GlobalTIS şi TIS2000 este validă. Licenţa Tech2Win se va termina odată cu terminarea licenţei pentru TIS2Web şi GlobalTIS de îndată ce se termină Acordul pentru reparator autorizat.

Reparatorii independenţi, aşa cum sunt ei definiţi în articolul 4 paragraful 2 din European Union Block Exemption Regulation (BER) 1400/2002, pot achiziţiona o licenţă Tech2Win în cadrul abonamentelor oferite pe GM Europe Info Tech Portal al General Motors Europe.

Licenţa Tech2Win nu include interfaţa de comunicare cu vehiculul sau hardware PC.

Este interzisă distribuirea, vânzarea sau plasarea online a software-ul Tech2Win în scopul utilizării de către orice parte terţă care nu face parte din reţeaua de ateliere de reparaţii autorizate (după cum se descrie în anexa relevantă la Acordul de reparator autorizat), fără consimţământul scris al Filialelor naţionale de vânzări respective ale General Motors. Aceasta se aplică atât datelor curente cât şi celor care nu mai sunt curente (cum ar fi DVD-urile expirate).

Filialele naţionale de vânzări ale General Motors au dreptul să restricţioneze imediat accesul şi să notifice despre încetarea imediată a Acordului de reparator autorizat în cazul utilizării neautorizate sau abuzive. În acest caz se exclude dreptul de a solicita rambursarea soldului creditor rămas şi/sau a taxelor anuale de bază.

Informaţiile furnizate servesc la executarea lucrărilor de service şi reparaţii la nivel de expert pentru autovehicule General Motors nemodificate. Ca o precondiţie pentru executarea lucrărilor menţionate anterior se impune absolvirea unui program de pregătire profesională pentru tehnicieni auto şi pregătire profesională regulată ulterioară. În cazul în care în informaţiile furnizate se indică utilizarea de scule speciale, respectivele scule speciale sunt obligatorii pentru toate reparaţiile ce trebuie executate la nivel de expert.

Informaţiile publicate în Tech2Win General Motors (text şi imagini, muzică, obiecte grafice, animaţii, clipuri video etc.), precum şi dispunerea lor în Tech2Win sunt protejate prin legile dreptului de autor. Se interzice reproducerea, diseminarea, comunicarea şi/sau transmiterea sau utilizarea în orice alt mod, cu excepţia situaţiilor în care există consimţământul prealabil scris al General Motors.

  • Instalare: Paşii de instalare
  • Primii paşi


Installation

Instalare

Instalarea aplicaţiei Tech2Win cere drepturi locale de administrator pe PC. Fără drepturi de administrator, instalarea nu va funcţiona. În astfel de cazuri, contactaţi administratorul local al PC-ului pentru asistenţă.

Pentru a utiliza cu succes Tech2Win, trebuie să efectuaţi următorii doi paşi:

  • Instalarea aplicaţiei Tech2Win în sine.
  • Instalarea unei interfeţe pentru comunicaţii a vehiculului.
  • Instalare: Paşii de instalare
  • Primii paşi


Paşii de instalare

Instalarea în sine durează numai câteva minute şi necesită următoarele confirmări din partea utilizatorului:

  1. Acordul de licenţă
  2. Directorul de instalare

Limbă

În mod implicit, interfaţa cu utilizatorul a Tech2Win va fi afişată în limba sistemului dvs. de operare. În general, pot fi suportate următoarele limbi. Dacă limba dvs. nu este acceptată, programul de instalare este lansat cu limba engleză drept limbă de instalare implicită.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)English (fie U.K. fie U.S.)*
  • el_GR (EL)Greek
  • es_ES (ES)Spaniolă
  • fi_FI (FI)Finnish
  • fr_FR (FR)Franceză
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portuguese (Brazil)
  • pt_PT (PT)Portuguese (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Chinese (Simplificată)
  • zh_TW (ZH)Chinese (Tradiţională)

* Limba Tech2Win este engleza britanică. Cu toate acestea, software-ul Tech2 şi programul de instalare pe care îl utilizaţi pot fi în limba engleză americană, în funcţie de sursa software-ului.

Acordul de licenţă

Este necesar să acceptaţi Acordul de licenţă.

Directorul de instalare

Aveţi posibilitatea de a alege orice director ca locaţie de instalare pentru Tech2Win. Directorul de instalare este implicit <directorul programului>\General Motors\Tech2Win sau, în cazul unei reinstalări, locaţia specificată anterior.

La sfârşit, confirmaţi instalarea.

Driver port COM virtual

Driverul portului COM virtual va fi instalat o singură dată pe computerul dvs. şi va rămâne până când versiunea driverului primeşte un upgrade (lucru rar) sau până la dezinstalarea Tech2Win de pe computer.
În cazul în care driverul este instalat, veţi vedea o casetă DOS pentru o scurtă perioadă de timp. Aceasta se va închide automat şi nu necesită nicio acţiune. Fişierele driverului sunt plasate suplimentar în subfolderul 'driver' din directorul de instalare Tech2Win.
Este posibil, dar nerecomandat, să instalaţi sau să dezinstalaţi manual driverele de porturi COM virtuale. Utilizaţi una dintre comenzile următoare din linia CMD:

  • apelaţi „vbsetup7” pentru a instala driverul
  • apelaţi „vbsetup7 /u” pentru a dezinstala driverul
  • Primii paşi


Interfaţa pentru comunicaţii a vehiculului

Dispozitivul de comunicare cu vehiculul trebuie instalat separat. Vă rugăm să consultaţi ghidul respectiv pentru instalare, livrat împreună cu Interfaţa pentru comunicaţii a vehiculului.

  • Primii paşi: Interfaţa pentru comunicaţii a vehiculului
  • Subiecte avansate: Fişier de configurare
  • Instalare: Paşii de instalare
  • FAQ: Cum pot folosi mai mult decât un MDI?
  • FAQ: Tech2Win nu a găsit MDI-ul meu


Primii paşi

Aceşti primi paşi vă arată cum să utilizaţi Tech2Win. Se presupune că sunteţi deja familiarizat cu Tech2. În aceşti primi paşi nu este necesară comunicarea cu un vehicul.

Pentru o pornire rapidă, efectuaţi paşii următori:

  1. Executaţi software-ul Tech2Win utilizând comanda rapidă Pornire rapidă de pe desktop.
  2. Obţinerea unei licenţe valide prin descărcarea noului software Tech2 din TIS2Web.

Pentru a utiliza o configuraţie care se poate selecta:

  1. Porniţi configuratorul utilizând comanda rapidă Tech2Win de pe desktop. După o instalare, este prezentă o configuraţie implicită.
  2. Pentru a crea o configuraţie nouă, este de preferat să copiaţi configuraţia implicită.
  3. Modificaţi o configuraţie existentă pentru a satisface cerinţele specifice.
  4. Obţineţi o licenţă valabilă.

Nu porniţi Tech2Win într-un mod de compatibilitate. Într-un astfel de caz, în fişierul jurnal va apărea un avertisment. Tech2Win utilizează numai funcţii Windows care există începând cu versiunea XP şi nu va funcţiona cu versiuni Windows anterioare.

  • Primii paşi: Configuraţii noi
  • Primii paşi: Modificare configuraţii
  • Primii paşi: Interfaţa pentru comunicaţii a vehiculului
  • Lucrul cu Tech2Win: Meniu
  • Lucrul cu Tech2Win: Securitate
  • Lucrul cu Tech2Win: Bara de stare
  • Subiecte avansate: Fişier de configurare


Selectarea unei configuraţii

La prima pornire a aplicaţiei Tech2Win apare următorul ecran. Aveţi opţiunea de a porni Tech2Win direct cu o configuraţie implicită. Această configuraţie implicită funcţionează fără nicio comunicare cu un vehicul.

Start First Time

Va apărea caseta de mesaje pentru informaţii despre licenţă, dar o puteţi ignora pentru a începe configurarea implicită.

La lucrul cu un ecran tactil, poate fi utilă pornirea programului de tastatură PC, pentru a putea introduce litere prin intermediul acestei aplicaţii care simulează o tastatură.


Tastatură

Tastele PC, precum şi butoanele, dacă sunt prezente, sunt mapate la tastele familiare din Tech2. Tech2Win oferă câteva taste suplimentare care nu erau prezente în versiunea originală a Tech2. Este posibil ca tastatura numerică de pe PC să nu funcţioneze în toate condiţiile. Dacă există probleme, vă rugăm să verificaţi dacă aspectul tastaturii standard a calculatorului dvs. a fost schimbat. În asemenea cazuri, în special tasta SHIFT poate fi afectată.

Tastatură PC | Buton | Funcţionalitate
Tasta funcţională F1 | n.a. | Ajutor Tech2Win
Taste funcţionale de la F5 la F8 | Folosiţi suprafaţa afişajului Tech2Win ocupată de tastele multifuncţionale | Cele patru taste soft ale Tech2
Taste cursor sus, jos, stânga, dreapta |  | Taste sus, jos, stânga, dreapta Tech2; Numai aceste taste au repetare automată.
Taste de la 0 la 9 | F0 • • • F9 | Taste Tech2 de la F0 la F9
Backspace | Exit | Tasta Tech2 Exit
Enter / Return | Enter | Tasta Tech2 Enter
Y | Yes | Tasta Tech2 Da
N | No | Tasta Tech2 Nu
Q | ? | Tasta Tech2 ?
S | Shift | Tasta Tech2 Shift. Indicatorul Shift din bara de stare sau indicatorul aflat deasupra butonului Shift indică starea.
ctrl-P | PWR | Tasta Tech2 Power; În mod evident, această tastă poate doar să oprească aplicaţia Tech2Win.
ctrl-R | Indisponibil | Resetează Tech2Win. Similar cu un ciclu de oprire/pornire de la Tech2. Cu toate acestea, nu se resetează Interfaţa de comunicaţii cu vehiculul ataşată. Fişiere cum ar fi imaginea PCMCIA nu sunt reîncărcate.
Acasă | Home | O tastă Acasă. Suportată numai de anumite aplicaţii.
disponibil numai prin intermediul opţiunii meniului Fişier. | Print Screen | Imprimă o captură de ecran a ecranului Tech2 prin crearea unui fişier BMP temporar şi accesarea aplicaţiei asociate cu fişierele BMP. Utilizaţi această aplicaţie pentru a redimensiona sau roti imaginea înainte de imprimare.
disponibil numai prin intermediul opţiunii meniului Fişier. | Save Screen | Salvează o imagine de ecran a ecranului Tech2 ca fişier BMP sau PNG.
disponibil numai prin intermediul opţiunii meniului Fişier. | View Report | Afişează toate rapoartele de pe cardul PCMCIA activ, pentru ca utilizatorul să le poate vizualiza.


Manipularea ferestrelor

Aveţi posibilitatea de a vă redimensiona ferestrele folosind mecanismul standard Windows, adică trăgând de marginea ferestrei principale. În plus, articolul din meniu Opţiuni/Rezoluţie suportă câteva dimensiuni presetate. În timpul unei redimensionări a ferestrei principale prin intermediul articolului din meniu, fereastra tastaturii va rămâne automat cuplată.

Aspectul ferestrelor este modificat prin schimbarea configuraţiei în fila Afişare.


Configuraţii noi

Pentru a crea o configuraţie nouă, faceţi clic pe butonul Creează nou. Va apare un dialog cu solicitarea de a selecta un fişier de configurare existent ca şi sursă. În mod normal va fi selectată configuraţia implicită. După introducerea numelui pentru noul fişier de configurare, apăsaţi butonul Copiere.

Dacă lucraţi cu un ecran tactil, este posibil să doriţi să activaţi simularea unei tastaturi de computer prin intermediul butonului Tastatură PC.

Butonul Revocare vă permite să anulaţi procesul de creare.

Configuraţia nouă va utiliza acelaşi fişier PCMCIA ca şi configuraţia sursă existentă. Dacă doriţi să schimbaţi, va trebui să modificaţi configuraţia, astfel încât să se utilizeze un alt fişier PCMCIA. În majoritatea cazurilor, veţi copia doar fişierul PCMCIA într-un fişier nou şi veţi utiliza fişierul nou. Probabil veţi prefera ca noua configuraţie să utilizeze acelaşi fişier PCMCIA ca şi configuraţia sursă. În acest caz, se va afişa un mesaj de avertizare când apăsaţi pe butonul Salvare.

  • Modificare configuraţii


Modificare configuraţii

Configuraţiile indicate în albastru sunt marcate 'numai-citire' şi nu pot fi modificate. Aceste configuraţii pot fi doar vizualizate. Desigur, puteţi utiliza metoda de modificare pentru a vizualiza pur şi simplu conţinutul acestora, dar butonul Salvare nu va avea efect.

O configuraţie este modificată prin selectarea setărilor individuale în cele patru file Limbă, Interfaţa pentru comunicaţii a vehiculului, Cale, Afişare. Puteţi fie alge fila dorită, fie alege pur şi simplu să apăsaţi butonul Următorul care va activa următoarea filă. După ce aţi făcut modificările dorite, apăsaţi butonul Salvare pentru a salva configuraţia.

Ori de câte ori sunt necesare introduceri de la tastatură, aveţi posibilitatea de a deschide o aplicaţie PC care să simuleze o tastatură de PC. Acest lucru este util mai ales pe laptopurile cu ecran tactil, unde nu este la îndemână o tastatură.


Limbă

Fila Limbă vă permite să selectaţi limba în care va rula aplicaţia Tech2Win. Această selecţie nu are nicio influenţă asupra limbii din cadrul aplicaţiei Tech2 pentru imaginea PCMCIA. La descărcarea aplicaţiei Tech2 de pe TIS, va trebui totuşi să selectaţi limba corectă.

Pentru anumite regiuni, nu vor fi disponibile toate limbile. În astfel de cazuri, se va afişa limba engleză. Verificaţi dacă este disponibilă o limbă similară (PT Portugheză - Portugalia în loc de PB Portugheză - Brazilia).


Cale

Fila Cale vă permite să setaţi calea pentru imaginile PCMCIA şi calea către tastatura dumneavoastră locală. În plus, pentru copierea imaginilor PCMCIA este prevăzut butonul Copiere card de memorie. Dacă tocmai aţi creat o configuraţie nouă, probabil veţi dori să utilizaţi acest buton pentru a evita mai multe configuraţii utilizând aceeaşi imagine PCMICA.

Memory Card Options

Copiere card de memorie ...

Acest buton vă permite să copiaţi o imagine PCMCIA într-un alt fişier. Funcţionalitatea sa este foarte similară cu achiziţionarea unui nou card PCMCIA pentru Tech2. Funcţia de copiere are efect numai pentru fişierele din directorul C:\Users\Public\General Motors\Tech2Win\pcmcia.

Slot 0: Locaţie imagine card de memorie

Aici puteţi specifica care este fişierul care conţine imaginea PCMCIA pentru slotul 0. În general, acest fişier ar trebui să se afle în C:\Users\Public\General Motors\Tech2Win\pcmcia, dar sunt posibile şi alte locaţii.

Slot 1: Card de memorie sau card ATA

La ca şi Tech2, programul Tech2Win suportă două carduri PCMCIA (imagini). Oricum, o a doua imagine PCMCIA în cadrul unei configuraţii nu este foarte folositoare în condiţii normale. O a doua aplicaţie software ar fi probabil utilizată într-o altă configuraţie.

La fel ca şi la Tech2, pentru depanare este utilizat un card ATA. Vă rugăm să activaţi cardul ATA numai dacă vi se spune acest lucru de la departamentul de suport tehnic. Cei de la departamentul de suport tehnic vă vor oferi mai multe informaţii.

Locaţie software tastatură PC

Valoarea implicită pentru acest fişier este extrasă din regiştrii Windows şi trebuie să indice o aplicaţie capabilă să simuleze o tastatură de computer cu ajutorul mouse-lui. Dacă aveţi o aplicaţie specială cu această funcţionalitate pe laptopul pe care îl folosiţi, puteţi specifica aici aplicaţia.


Interfaţa pentru comunicaţii a vehiculului

  • Port COM pentru emulare Tech2-RS232
  • Numărul de serie al MDI de utilizat
  • Protocol

Port COM pentru emulare Tech2-RS232

Vă rugăm să alegeţi un port COM liber care poate fi folosit pentru emularea Tech2. Pentru uşurinţă, Configuratorul încearcă să afle care porturi seriale sunt deja folosite şi le afişează.

Dacă alegeţi un port COM existent, Tech2Win se va ataşa automat la acest port COM existent. Puteţi folosi portul COM pentru a descărca software-ul Tech2 de la un al doilea calculator pe care rulează aplicaţia TIS şi care foloseşte un cablu de modem nul. Vă rugăm să observaţi că utilizarea unui port COM real ar putea să nu fie fiabilă la 115.200 baud, datorită restricţiilor Windows.

Dacă este selectat un port COM inexistent, Tech2Win va crea automat un port virtual. Acest port virtual poate fi folosit de la TIS care rulează pe acelaşi PC pentru a stabili comunicaţia cu Tech2Win. La folosirea unui port virtual nu există restricţii referitoare la viteza baud.

Dacă alegeţi „căutare” drept port COM, Tech2Win va crea un port COM virtual la primul număr de port liber din intervalul de la 9 la 1.

Numărul de serie al MDI de utilizat

Introduceţi un număr de serie al MDI. Numărul se găseşte pe partea din spate a MDI. Folosiţi numărul de după liniuţă.

Dacă nu introduceţi un număr de serie, Tech2Win va afia automat o listă a MDI-urilor detectate în reţea pentru a permite utilizatorului să aleagă un MDI. Aceeaşi casetă de selectare va apărea când nu se găseşte MDI specificat.

Protocol

'ISO22900-2 / PDU-API' este selectat, iar J2534-2 este întotdeauna pe fundal gri. În viitor, Tech2Win ar putea suporta şi protocolul J2534.

  • Subiecte avansate: Fişier de configurare
  • FAQ: Cum pot stabili ce port com trebuie să folosesc pentru Tech2Win?
  • FAQ: Comunicarea între Tech2Win şi TIS2Web
  • FAQ: Cum pot folosi mai mult decât un MDI?
  • FAQ: Tech2Win nu a găsit MDI-ul meu


Afişare

Fila Afişare este utilizată în principal pentru a modifica setările privitoare la afişare în Tech2Win:

  • Minitastatură
  • Culori
  • Sunet
Display and Key Options

Minitastatură

Aici puteţi opta pentru afişarea sau nu a minitastaturii. Minitastatura apare fie în partea dreaptă fie în cea stângă a ecranului Tech2Win. Culoarea fundalului poate fi aleasă dintr-o casetă de dialog standard pentru alegerea culorii.

Culori

Aici pot fi selectate separat culorea de fundal şi de prim-plan pentru ecranul Tech2. Acestea sunt două dintre cele mai obişnuite combinaţii de culori.

Screen with background 0000FF, foreground FFFFFF | Alb pentru fundal minitastatură; Albastru fundal; Alb pentru prim-plan
Screen with background 000000, foreground C0C0C0 | Tastatură albastru fundal; Negru pentru fundal; Gri deschis pentru prim-plan

Sunet

Aici puteţi opta să dezactivaţi sunetul. De fiecare dată când programul Tech2 va scoate un beep, acesta se va auzi în difuzorul PC-ului.


Salvarea configuraţiei

Configuraţia activă poate fi salvată apăsând butonul Salvare <configuraţie> din colţul stânga, jos. Acest buton nu va apărea dacă vizualizaţi o configuraţie cu atributul 'numai-citire'.


Licenţă valabilă prin intermediul TIS2Web

În mod normal, descărcarea software-ului Tech2 în Tech2Win vă va asigura o licenţă valabilă. Suplimentar, puteţi obţine un port efectuând funcţia 'Acces de securitate (Securitate)' prin TIS2Web (nu TIS2000). Prin urmare, condiţia preliminară este selectarea portului COM virtual din interiorul Configuratorului de la Vehicle Communication Interface.

După un acces de securitate realizat cu succes, puteţi vedea o blocare deschisă pe partea dreaptă a barei de stare. În interiorul parantezei vedeţi numărul de zile de valabilitate a licenţei. Când porniţi din nou Tech2Win, indicatorul de securitate nu este afişat cât timp nu se realizează comunicarea cu vehiculul. În timpul primei comunicări cu un vehicul, va fi verificată licenţa, iar indicatorul se schimbă fie într-o încuietoare deschisă, fie într-una deschisă.

  • Lucrul cu Tech2Win:Securitate
  • FAQ:Cum pot stabili ce port com trebuie să folosesc pentru Tech2Win?
  • FAQ:Comunicarea între Tech2Win şi TIS2Web
  • FAQ:Licenţă valabilă
  • FAQ:Care este diferenţa dintre o licenţă Tech2Win şi Accesul de Securitate?


Lucrul cu Tech2Win

Majoritatea tehnicieniilor care lucrează cu Tech2Win sunt interesaţi de următoarele subiecte:

  • Meniu: Aspectul ecranului şi elementele individuale de meniu.
  • Descărcarea unei imagini PCMCIA.: Actualizarea aplicaţiei software de diagnostic pentru Tech2Win este foarte similară cu metoda utilizată pentru Tech2.
  • Securitate: Măsurile de securitate împiedică Tech2Win să efectueze comunicarea cu vehiculul în medii care nu sunt autorizate.
  • Vizualizare rapoarte: Tastatura Tech2 a fost uşor îmbunătăţită în Tech2Win. Butonul 'Vizualizare rapoarte' este cel mai edificator exemplu.
  • Manipularea imaginilor PCMCIA: În mod similar cu utilizarea mai multor carduri PCMCIA la Tech2, la Tech2Win puteţi avea câteva imagini PCMCIA în uz.
  • Bara de stare: Bara de stare oferă informaţii utilizatorului despre părţile sale individuale.
    • Subiecte avansate
    • FAQ


Meniu

Aplicaţia Tech2Win are următoarele intrări de meniu:

  • Fişier
  • Opţiuni
  • Ferestre
  • Ajutor

Fişier

Meniul Fişier asigură următoarele posibilităţi:

  • Salvare ecran T2 (320x240) este folosit pentru a salva ecranul T2 actual la dimensiunea 320x240 pixeli ca fişier imagine alb-negru pe PC-ul dumneavoastră. Locaţia de stocare şi formatul fişierului (BMP, GIF, JPG, PNG) este liber selectabil.
  • Tipărire ecran creează un negru inversat pe imaginea BMP albă a ecranului Tech2 şi apelează programul asociat cu fişierele BMP. Puteţi utiliza acest program pentru a tipări imaginea.
  • Vizualizare fişiere raport asigură posibilitatea de a vizualiza (şi tipări) fişierele raport fără a folosi TIS2Web.
  • Ieşire opreşte Tech2Win.

Opţiuni

Opţiuni asigură următoarele selecţii:

  • Rezoluţie poate fi utilizat pentru a alege din cele trei dimensiuni standard ale ecranului.
  • ROM-Write from 0x00003ED76 este folosit în scopuri de depanare internă.
  • Capturi de ecran automate pentru a stoca o imagine a fiecărui ecran Tech2 în directorul jurnal.
  • Dezactivare CANdi şi reiniţializare pentru a imita un Tech2 care nu are o CANdi între acesta şi vehicul. Acest lucru este necesar pentru cazurile rare în care CANdi întrerupe liniile de comunicaţii nestandard ale vehiculului.

Ferestre

Meniul Ferestre vă oferă posibilitatea de a activa selecţiile Afişaj de date Tech2Win şi Afişaj cod de eroare Tech2Win. Toate celelalte selecţii sunt marcate cu gri în versiunea curentă a Tech2Win.

Dacă software-ul Tech2 suportă Afişaj de date Tech2Win, puteţi activa această intrare de meniu. După ce accesaţi Data Display, Tech2Win va afişa o fereastră Data Display suplimentară, în paralel cu fereastra Tech2 Data Display. Atât timp cât ecranul Tech2 afişează Ecranul de date, intrarea de meniu nu poate fi activată. În acest caz, trebuie să părăsiţi Ecranul de date, să activaţi intrarea de meniu şi să reporniţi Ecranul de date.

Restricţii similare pentru Afişaj de date Tech2Win se aplică şi pentru Afişaj cod de eroare Tech2Win. Dacă software-ul Tech2 suportă Afişaj cod de eroare Tech2Win, puteţi activa această intrare de meniu. O fereastră suplimentară Ecran DTC va apărea în paralele cu Ecranul DTC Tech2. Atât timp cât ecranul Tech2 afişează Ecranul DTC, intrarea de meniu nu poate fi activată. În acest caz, trebuie să părăsiţi Ecranul DTC, să activaţi intrarea de meniu şi să reporniţi Ecranul DTC.

Ajutor

Sunt disponibile următoarele selecţii:

  • Subiecte Ajutor... cheamă Ajutor Tech2Win.
  • Parametru linie de comandă arată parametrii liniei de comandă folosiţi pentru Tech2Win.
  • În meniul Despre se afişează numărul versiunii curente şi limitările software-ului Tech2Win legate de descărcarea programului TIS2Web.


Descărcare

Mai întâi, porniţi Tech2Win şi lăsaţi-l în ecranul principal. Porniţi TIS2Web sau GlobalTIS şi realizaţi descărcarea prin intermediul portului COM specificat în fila Interfaţa pentru comunicaţii a vehiculului.

Utilizarea porturilor COM încorporate este posibilă pentru a descărca aplicaţia software Tech2 de pe un alt PC pe care rulează TIS. Asiguraţi-vă că utilizaţi un cablu între ele un cablu RS232. În funcţie de componentele hardware ale PC-ului pe care rulează Tech2Win, este posibil să fie nevoie de reducerea ratei de transfer a datelor 57600 baud, deoarece este posibil ca Windows să piardă pachete de date la o viteză de transfer mai mare.

De asemenea, cea mai recentă versiune de Tech2Win acceptă descărcarea rapidă când TIS2Web şi Tech2Win se execută pe acelaşi PC. Prin portul COM încă mai există o comunicare limitată la minimum între TIS2Web şi Tech2Win, dar transferul îndelungat de date către Tech2Win s-a înlocuit cu un transfer intern de fişiere. În acest caz, timpul de descărcare se reduce drastic, la mai puţin de un minut.

  • Subiecte avansate: Fişier de configurare
  • Primii paşi: Interfaţa pentru comunicaţii a vehiculului
  • FAQ: Cum pot stabili ce port com trebuie să folosesc pentru Tech2Win?
  • FAQ: Comunicarea între Tech2Win şi TIS2Web


Securitate

Mecanismele de securitate folosite de Tech2Win se bazează pe valoarea corectă a ceasului PC. Vă rugăm să vă asiguraţi că valoarea ceasului PC este întotdeauna reglată. Modificările minore aduse ceasului, aşa cum pot apărea ele în timpul zilei de economisire a luminii vor fi tolerate de către Tech2Win.

Tech2Win nu va realiza comunicaţii cu autovehiculul fără o licenţă valabilă şi activă. Următorul indicator din bara de stare arată starea licenţei:

  • green smiley Licenţa este valabilă.
  • Lipsă indicator: Licenţa nu a fost încă verificată.
  • red smiley Licenţa a expirat.

Pentru a obţine o licenţi, efectuaţi actualizarea 'Acces de securitate (Securitate)' utilizând aplicaţia TIS2Web. În majoritatea cazurilor, o descărcare software prin intermediul TIS2Web va fi de asemenea suficientă pentru a obţine o nouă licenţă. Deoarece licenţa va deveni nevalabilă după o anumită perioadă de timp (în unele regiuni: patru săptămâni), trebuie să realizaţi o actualizare la intervale regulate.

Licenţele sunt specifice regiunii/software-ului. Este posibil să aveţi licenţe pe computer dacă folosiţi Tech2Win cu diverse versiuni software Tech2.

Numărul de zile rămase înainte de expirarea licenţei este prezentat în bara de stare.

  • (0) arată că licenţa a expirat sau nu există.
  • (<1) Licenţa va expira în următoarele 24 de ore.
  • (20) Licenţa va expira în 20 de zile.

Vă rugăm să nu modificaţi fişierul licenţă. Modificările frauduloase ale acestui fişier sunt detectate folosind măsurile de securitate interne şi vor duce la pierderea tuturor licenţelor de pe computer. În plus, Tech2Win va avea un comportament impredictibil. Acest lucru poate fi depăşit numai prin realizarea unei noi instalări.

  • Subiecte avansate: Mesaje de eroare şi coduri de ieşire
  • Subiecte avansate: Fişier jurnal
  • Lucrul cu Tech2Win: Fereastra de stare
  • FAQ: Licenţă valabilă
  • FAQ: Care este diferenţa dintre o licenţă Tech2Win şi Accesul de Securitate?
  • FAQ: Oprire bruscă


Vizualizarea rapoartelor

View Report Acest buton poate fi utilizat pentru a vedea conţinutul oricăror fişiere PRT prezente pe cardul PCMCIA. Se va deschide o casetă de dialog care arată o listă a fişierelor PRT. Dacă extensia PRT a fost asociată unui program, va fi executat acest program. În caz contrar, se va deschide editorul Notepad pentru a arăta conţinutul fişierului selectat.

În majoritatea cazurilor fişierul PRT este un fişier ASCII care foloseşte pagina de coduri a limbii respective. Pentru limbile chineză, japoneză, coreeană şi limba Thai fişierul este în format Unicode cu un cod în faţă pentru marcajul ordinii octeţilor (BOM).

La vizualizarea rapoartelor, Tech2Win utilizează un subdirector C:\Users\Public\General Motors\Tech2Win\reports. Acest subdirector va exista numai dacă aţi vizualizat rapoarte cel puţin o dată. Directorul este şters automat şi funcţionează ca un director de lucru temporar pentru fişierele PRT pe cardul PCMCIA activ. Acesta va continua să conţină aceste fişiere chiar dacă Tech2Win nu se mai execută. Dacă doriţi să salvaţi un astfel de fişier va trebui să îl copiaţi într-un alt director, deoarece fişierul poate fi suprascris de îndată ce un alt utilizator alege să vizualizeze rapoarte.


Imagini PCMCIA

În general, imaginile PCMCIA se află în subdirectorul C:\Users\Public\General Motors\Tech2Win\pcmcia. Fişierul trebuie să aibă dimensiunea de exact 32 MB (33.554.432 octeţi) sau de 10 MB (10.485.760 octeţi) şi extensia fişierului să fie *.bin. Imaginile sunt modificate (la fel cum ar fi la orice card PCMCIA normal) dacă are loc o descărcare sau dacă Tech2Win stochează ceva pe cardul flash. O modificare poate fi dezactivată prin utilizarea înterupătorului de protecţie la scriere (comandă -W0 sau -W1) sau prin omiterea valorii 'p' în opţiunea '-W-'(Fişier de configurare). Comutatorul de protecţie la scriere nu se poate accesa prin configurator. Va trebui să modificaţi manual fişierul de configurare dacă doriţi să utilizaţi opţiunile '-W0', '-W1' sau '-W'.


Bara de stare

Bara de stare este afişată sub ecranul Tech2. În bara de stare sunt arătate următoarele elemente:

  1. Un indicator de viteză
  2. Starea comunicării cu vehiculul
  3. Stare port serial
  4. Tasta SHIFT
  5. Capturi de ecran automate
  6. Avertisment din jurnal
  7. Licenţă

Status Bar

Indicator de viteză

Indicatorul de viteză arată cât timp CPU se consumă pentru emularea aplicaţiei Tech2. Un număr mic (indicatorul spre stânga) este mai bun decât un număr mai mare (indicatorul spre dreapta). Orice indicator verde este acceptabil. Indicatorul poate deveni galben pentru scurte perioade de timp, dacă se activează diferite activităţi Windows. Astfel de activităţi trebuie evitate.

Starea comunicării cu vehiculul

Starea comunicaţiilor vehiculului indică dacă Interfaţa de comunicaţii a vehiculului (MDI) este prezentă, dar şi dacă există comunicaţii între vehicul şi Tech2Win.

Stare port serial

Când comunicarea cu Tech2Win se face printr-un port COM, acest indicator arată dacă comunicarea prin portul COM este activă sau nu.

Tasta SHIFT

Acest indicator indică activarea tastei SHIFT. Puteţi comuta utilizând tasta 'S' sau SHIFT de pe tastatură.

Capturi de ecran automate

Imaginea de ecran automată poate fi activată în meniul Opţiuni. La fiecare schimbare a ecranului, un nou fişier imagine de ecran este stocat în directorul jurnal. Acest lucru este indicat de o rotaţie a mânerului de pornire de pe camera roşie din bara de stare. Imediat ce sunt dezactivate imaginile de ecran automate, camera dispare.

Avertisment din jurnal

Indicatorul stării jurnalului poate avea trei stări diferite.

  • gray log status indicator Fişierul jurnal nu conţine avertismente sau erori.
  • yellow log status indicator Fişierul jurnal conţine un mesaj de avertizare.
  • red log status indicator Fişierul jurnal conţine un mesaj de eroare.

Licenţă

Indicatorul de licenţă poate avea trei stări:

  • green smiley Licenţa este activă şi valabilă.
  • Lipsă indicator: Licenţa nu a fost încă verificată.
  • red smiley Licenţa a expirat sau nu există.
Vă rugăm să consultaţi linkul Securitate pentru mai multe detalii.

Sfaturi ecran pe Bara de stare

Pentru unele pictograme, sfaturile ecran sunt afişate pentru a furniza câteva informaţii suplimentare:

Sfat ecran pentru numărul de serie VCI:
Tooltip VCI

Sfat ecran pentru Versiunea software TECH2
Tooltip TECH2

Sfat ecran pentru Portul com
Tooltip Comport

Sfat ecran pentru numărul următoarei capturi de ecran (dacă sunt active 'Capturi de ecran automate')
Tooltip Camera

Sfat ecran care arată ultima intrare a fişierului jurnal care are nivelul 'avertisment' sau superior
Tooltip Logfile

Sfat ecran pentru durata exactă a licenţei
Tooltip License

Sfaturile ecran sunt afişate în cazul în care cursorul se află mai mult de 0,5 secunde deasupra unei pictograme fără a fi mişcat. Sfaturile ecran dispar după 5 secunde sau la mişcarea cursorului.

  • Subiecte avansate: Mesaje de eroare sau coduri de eroare
  • Subiecte avansate: Fişier jurnal


Subiecte avansate

Subiectele discutate aici sunt de mai mică importanţă pentru un utilizator obişnuit al aplicaţiei Tech2Win. Persoanele implicate în instalarea, administrarea şi configurarea aplicaţiei Tech2Win pot găsi aceste informaţii utile.

  • Reinstalare
  • Dezinstalare
  • Modificarea directă a fişierelor de configurare
  • Fişier jurnal
  • Mesaje de eroare şi coduri de ieşire
  • Card ATA
  • Intrări de regiştri
  • Descriere fişier
  • Exemple de administrare configuraţii


Dezinstalare

Directorul instalării complete, directorul care conţine datele utilizatorului (C:\Users\Public\General Motors\Tech2Win) şi directorul care conţine datele aplicaţiei (C:\ProgramData\General Motors\Tech2Win) sunt şterse.

  • Subiecte avansate: Reinstalare
  • Instalare


Fişier de configurare

Fişierele de configurare se află întotdeauna în subdirectorul C:\Users\Public\General Motors\Tech2Win\config şi au extensia de fişier *.conf. Este posibil să decideţi modificarea manuală a fişierului de configurare, deoarece nu toate opţiunile fişierului sunt disponibile în Tech2Win. Fişierul de configurare este un fişier Unicode care are în faţă un cod pentru marcajul ordinii octeţilor (BOM). La efectuarea modificărilor manuale, vă recomandăm cu căldură să utilizaţi un editor capabil să lucreze cu Unicode, cum ar fi Notepad.

Fişierul de configurare este orientat pe linie. Liniile goale sunt ignorate. O linie începe întotdeauna cu o opţiune şi este urmată în majoritatea cazurilor de o valoare. Ca şi exemplu, aruncaţi o privire la fişierul default.conf. Vă rugăm să consultaţi următorul tabel care listează toate opţiunile disponibile.

Dacă doriţi să lansaţi o anumită configuraţie direct de pe desktop, creaţi o comandă rapidă care execută 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf' Programul trebuie lansat din următorul director de lucru: 'C:\Program Files\General Motors\Tech2Win\bin'

Opţiune | Valoare / Semnificaţie
; Un comentariu
@ Un număr de versiune zecimal în format vers_majoră.vers_minoră.
Nu vor fi acceptate fişiere de configurare cu un număr de versiune majoră diferit de versiunea Tech2Win. Vor fi acceptate fişiere de configurare cu un număr de versiune minoră mai mic decât versiunea minoră a aplicaţiei Tech2Win.
-W0
-W1 		Cardul PCMCIA din slotul 0/1 are activat un comutator de protecţie la scriere.
-B0
-B1 		Dimensiune blocuri în Kocteţi pentru cardul PCMCIA în slotul 0/1. Valorile acceptate sunt 128 (implicit) sau 256.
-P0
-P1 		Fişierul care conţine imaginea binară a unui card PCMCIA pentru slotul 0/1. Dimensiunea fişierului trebuie să fie de exact 10 MB sau 32 MB. Variabilele de mediu, cum ar fi %ProgramData%, sunt extinse.
Dacă această opţiune lipseşte, se presupune că slotul este gol.
-A0
-A1 		Fişierul care conţine valorile atributelor cardului PCMCIA pentru slotul 0/1. Dacă această opţiune lipseşte, vor fi utilizate valorile implicite ale atributelor în funcţie de dimensiunea cardului şi a blocurilor.
-W | La ieşirea din Tech2Win, toate datele permanente sunt scrise în fişierele corespunzătoare. Pentru a indica PCMCIA/Flash-Rom/RTC/CANDI-App pot fi utilizate combinat valorile p/f/r/c.
-H | Funcţionalitate de administrare în masă Valorile 0/r/w/t pot fi combinate pentru a activa funcţiile de „Resetare”, „Verificări citire”, „Verificări scriere” şi respectiv „Verificări activitate”. Valoarea I este utilizată pentru a impune întotdeauna alocarea de memorie în masă pentru adrese inferioare atunci când este implementată o altă schemă de alocare. În mod normal, această opţiune este utilizată numai într-un mediu de dezvoltare.
-PC | Calea veche pentru copierea cartelei PCMCIA. Această opţiune este momentan ignorată.
-MS | Identificarea Interfeţei de comunicaţii cu vehiculul (MDI) cu numărul de serie. Dacă nu este setată, vi se va prezenta o listă a MDI-urilor disponibile.
-CT | Culoarea textului (prim-plan) exprimată în 3 octeţi hexazecimali. Valoarea implicită este 000000 (alb).
-CB | Culoarea de fundal exprimată în 3 octeţi hexazecimali. Valoarea implicită este FFFFFF (negru).
-ATA | Folosiţi această opţiune pentru activarea cartelei de captură ATA. Îndepărtaţi-o pentru a dezactiva cartela de captură ATA.
-C | Numărul portului COM (1..9) care va fi utilizat ca şi port de comunicare RS232C de Tech2. Cel mai adesea este utilizat COM9 ca şi port COM virtual care este instalat de către Tech2Win. Dacă această opţiune nu este prezentă, se efectuează o căutare a unui port COM liber după portul COM9. Utilizaţi sugestia pentru instrumente din bara de stare, dintre pictograma Tech2 şi pictograma TIS2Web pentru a vedea ce port COM este utilizat.
-WR | O adresă PC (în mod normal 253558) căreia i se permite scrierea în zonele PCMCIA şi FLASH ROM. În plus, această funcţie trebuie activată din meniu (sau utilizând opţiunea -WA). Este necesară depanarea codului în memoria nemodificabilă cu ajutorul Depanatorului într-o singură etapă.
-WA | Permiteţi Depanatorului SingleStep să editeze memoria care nu poate fi modificată.
-OF | Fişier opţional care conţine perechile opţiune / valoare.
-TP | Reglarea temporizării (Valoare proporţională). Valoarea implicită este 5000. Reduceţi această valoare pentru ca numărul de cicluri executate să se adapteze mai rapid la timpul real.
-TD | Reglarea temporizării (Valoare diferenţială). Valoarea implicită este 100. Reduceţi această valoare pentru a reacţiona mai rapid la schimbările temporizării instantanee. AVERTISMENT: modificarea cu valorile TP şi TD poate duce la probleme de viteză.
-PJ
-PP 		Specificaţi protocolul care trebuie folosit:
PJ pentru comunicaţii J2534.
PP pentru ISO22900-2 / PDU-API (implicit)
-S | Prezenţa acestei opţiuni activează ieşirea de sunet la difuzorul de la PC.
-L | Limba aplicaţiei Tech2Win. Dacă această intrare lipseşte, limba activă a sistemului Windows este utilizată drept implicită. Consultaţi linkul următor pentru a vedea lista de limbi care pot fi alese: Limbi. Fereastra de emulaţie Tech2 va afişa orice limbă se află pe cartela PCMCIA (de ex. a fost descărcată pe cartela PCMCIA).
-UD | Se depăşeşte directorul de date ale utilizatorului. În Win7, acesta se află în mod normal în locaţia C:\Users\Public\General Motors\Tech2Win
-AD | Se depăşeşte directorul de date ale aplicaţiei. În Win7, acesta se află în mod normal în locaţia C:\ProgramData\General Motors\Tech2Win
-US | Utilizaţi un semafor specific utilizatorului pentru a detecta mai multe instanţe ale Tech2Win. Această opţiune îi va permite fiecărui utilizator să ruleze Tech2Win în paralel pe aceeaşi maşină, probabil un server. La utilizarea acestei opţiuni, trebuie să specificaţi atât opţiunea -UD, cât şi opţiunea -AD.
-SS | Opţiune pentru specificarea dimensiunii totale a ferestrei Tech2Win, incluzând tastatura (dacă este prezentă). Primul parametru trebuie să fie un şir introdus între ghilimele duble (') şi acesta va fi utilizat drept nume al dimensiunii în meniul Opţiuni / Rezoluţie. Al doilea parametru este numărul total de pixeli orizontali ai ecranului Tech2Win, incluzând tastatura. Al treilea parametru este numărul total de pixeli verticali ai ecranului Tech2Win. Al patrulea parametru opţional este lăţimea tastaturii în pixeli.
-SH Opţiunea de control al gestionării ecranului. Următorul număr zecimal este utilizat pentru a se specifica ce posibilităţi de gestionare a ecranului trebuie dezactivate.
  • Bit 0: Fără min./max. posibil.
  • Bit 1: Fără repoziţionare pe ecran.
  • Bit 2: Fără redimensionare. În acest caz, meniul Opţiuni / Rezoluţie este gri.
  • Bit 3: Ferestrele Afişare date şi DTC vor avea exact aceeaşi dimensiune ca şi Tech2Win (fără tastatură)


Înregistrarea datelor în fişierele jurnal

Fiecare pornire a unei configuraţii Tech2Win creează un nou fişier jurnal în format HTML, în subdirectorul C:\Users\Public\General Motors\Tech2Win\Logs. Pentru evitarea blocării hard disk-ului, fişierele mai vechi de o săptămână sunt şterse.

Fişierele jurnal sunt denumite automat în funcţie în funcţie de data (an, lună, zi) şi ora (oră, minut, secundă) la care au fost create:
aaaa-ll-zz_hhmmss.html

Înregistrările din fişierul jurnal sunt întotdeauna în engleză, dar în format Unicode cu un cod în faţă pentru marcajul ordinii octeţilor (BOM). Fiecare linie din fişierul jurnal aparţine unuia din următoarele niveluri:

Nivel jurnal | Semnificaţie
Informaţii | Numai informaţii. Niciun efect asupra execuţiei programului.
Avertisment | A apărut o situaţie ieşită din comun. Este posibil ca utilizatorul să nu înregistreze efecte negative.
ERROR | A apărut o eroare care va fi observată de către utilizator.
CRITICAL | A apărut o eroare critică care va duce la o anomalie în funcţionarea programului.
FATAL | O eroare fatală va face ca Tech2Win să se oprească imediat din funcţionare.

Toate nivelurile superioare 'Avertismentului' sunt colorate aşa încât pot fi găsite cu uşurinţă.

În plus, fişierele Tipărire şi Video vor fi prezente în subdirectorul Logs, dar şi dacă au fost utilizate opţiunile de meniu Tipărire ecran sau Capturi de ecran automate.
aaaa-ll-zz_hhmmss_print_nnnnn.bmp
aaaa-ll-zz_hhmmss_video_nnnnn.png
Imaginile Capturi de ecran automate sunt legate de către fişierul HTML, aşadar folosiţi jurnalul HTML pentru a vizualiza succesiunea acestor imagini.

Utilizatorul este informat în bara de stare dacă în jurnal există o înregistrare de avertizare ( yellow lightning bolt) sau o înregistrare cu gravitate mai mare ( red lightning bolt).


Mesaje de eroare şi coduri de ieşire

În casetele de dialog pot apărea mesaje de eroare. Tech2Win permite totuşi rularea programului Tech2 în paralel cu apariţia casetelor de dialog. Codurile de ieşire sunt erori fatale care duc la întreruperea anormală a aplicaţiei Tech2Win. Codurile de ieşire pot fi utilizate în fişierele batch pentru a afla cauza întreruperii programului.

Mesaje de eroare

Pot apărea următoarele mesaje de eroare. Aici se prezintă o scurtă explicaţie asupra situaţiei şi modul în care se poate rezolva problema.

Emulator too slow Emulator failed to start

Coduri de ieşire

Cod de ieşire | Valoare | Semnificaţie
OPCODE_ERROR | -7 | S-a detectat o comandă nevalidă a microprocesorului Tech2 (68332). Este posibil ca imaginea PCMCIA să se fi corupt cumva.
ATA_PROBLEM | -6 | A apărut o problemă în timpul emulării ATA. Dacă întâmpinaţi o astfel de problemă după ce aţi fost instruit să utilizaţi cardul ATA, vă rugăm să contactaţi serviciul de asistenţă.
DEMO_TIME_IS_UP | -5 | Nu trebuie să apară în versiunea oficială a Tech2Win.
DLL_NOT_LOADED | -3 | Unul din fişierele DLL necesare nu a putut fi încărcat. Se pare că aveţi o copie incompletă a aplicaţiei Tech2Win. Vă rugăm să efectuaţi o nouă instalare şi/sau să alegeţi o altă limbă.
EXIT_INIT_FAILED | -2 | Iniţializare nereuşită. Căutaţi în fişierul jurnal cauza exactă. Dacă nu găsiţi un fişier jurnal, vă rugăm să verificaţi dacă aveţi drepturile corecte de scriere/citire pe toate directoarele.
normal | 0 | Tech2Win s-a închis normal.


Card ATA

Cardul ATA este utilizat în general în Tech2 numai în scopuri de depanare în timpul dezvoltării aplicaţiei software. Toate datele ATA necesare sunt stocate în subdirectorul C:\Users\Public\General Motors\Tech2Win\ataCapture. În mod normal acest director nu are importanţă şi poate fi şters fără probleme, dacă nu se indică în mod specific altfel.

Deoarece directorul ataCapture este fix, conţinutul său va fi identic pentru toate configuraţiile.


Fişiere

Următoarele fişiere şi directoare sunt utilizate de Tech2Win:

Director | Locaţie înainte de Vista | Locaţie pentru Vista şi versiuni ulterioare
Instalare | Conform definirii din timpul instalării
Date utilizator | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Date aplicaţie | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Fişier | Utilizare
[Date utilizator]\atacapture | Conţine fişiere care sunt prezente pe cartela ATA. Aceste fişiere nu sunt necesare decât dacă este specificat altfel.
[Instalare]\bin | Conţine fişierul executabil efectiv şi fişierele DLL şi imaginile necesare pentru execuţie.
[Instalare]\bin\emulator.exe | Fişierul executabil principal care rulează codul Tech2.
[Instalare]\bin\emulator_xx_XX.dll | Fişier DLL cu resurse specifice de limbă.
[Instalare]\bin\T2Configurator.exe | Partea de configurare pentru Tech2Win.
[Instalare]\bin\Pictures | Conţine pictogramele de care are nevoie Tech2Win.
[Date utilizator]\config | Conţine toate fişierele de configurare.
[Date utilizator]\data | Conţine fişiere care sunt modificate în timpul execuţiei Tech2Win. Aceste fişiere sunt necesare pentru funcţionarea corectă a aplicaţiei Tech2Win. În mod normal, nu trebuie să vă atingeţi de aceste fişiere dacă nu vi se spune în mod explicit acest lucru.
[Date aplicaţie]\data | Conţine fişiere care sunt modificate în timpul execuţiei Tech2Win. Aceste fişiere sunt necesare pentru funcţionarea corectă a aplicaţiei Tech2Win. În mod normal, nu trebuie să vă atingeţi de aceste fişiere dacă nu vi se spune în mod explicit acest lucru.
[Date aplicaţie]\data\emulator.sec | Fişier de securitate . Nu modificaţi acest fişier.
[Date aplicaţie]\data\emulator.card | Fişier cartelă. Conţine toate cartelele PCMCIA cunoscute programului Tech2Win. Nu modificaţi acest fişier.
[Date utilizator]\data\emulator.disp | Acest fişier conţine poziţia şi dimensiunea ecranului Tech2Win. Dacă ştergeţi acest fişier, el va fi recreat şi ecranul Tech2Win va fi afişat la pornire în colţul din stânga sus, cu o dimensiune de 640x480.
[Date aplicaţie]\data\emulator.lic | Fişier de licenţă. Conţine informaţii despre duratele valabilităţii licenţelor dumneavoastră. Nu modificaţi acest fişier.
[Date aplicaţie]\data\emulator.rtc | Fişier ceas timp real. Acest fişier este utilizat pentru stocarea datelor găsite în RTC-ul din Tech2Win.
[Date aplicaţie]\data\emulator.dta | Un fişier cu informaţii „Nu doresc să mi se spună din nou”.. Acest fişier stochează versiunile software PCMCIA care nu ar (mai) trebui să arate avertismentul despre incapacitatea de a realiza autoteste care necesită un adaptor cu reacţie în buclă.
[Date aplicaţie]\data\candi.bin | Fişier aplicaţie CANdi. Păstrează aplicaţia CANdi care este ataşată la Tech2.
[Date aplicaţie]\data\eprom.bin | Fişier EPROM intern Tech2. Include conţinutul memoriei flash Tech2 interne.
[Instalare]\driver | Fişierele de instalare pentru driverul portului COM.
[Instalare]\help\emulator_xx_XX.chm | Fişiere de ajutor specifice pentru limbă.
[Date utilizator]\Logs | Conţine fişiere jurnal. Fişierele mai vechi de o săptămână vor fi şterse automat.
[Date utilizator]\pcmcia | Conţine fişierele imagine PCMCIA. Fiecare fişier corespunde la un card PCMCIA Tech2, la figurat vorbind. Aceste fişiere pot fi salvate într-o locaţie diferită, dacă se doreşte.


Managementul configuraţiei

Fişierele de configurare se află întotdeauna în subdirectorul C:\Users\Public\General Motors\Tech2Win\config şi au extensia de fişier *.conf. Tech2Win poate fi utilizat numai pentru a genera fişiere de configurare noi sau pentru a modifica fişierele de configurare existente care nu sunt marcate ca fiind 'numai-citire'. Pentru restul sarcinilor de administrare a fişierelor de configurare, vă rugăm să utilizaţi Windows Explorer sau un program similar. Acesta va fi necesar pentru următoarele activităţi.

  • ştergerea fişierelor de configurare
  • redenumirea fişierelor de configurare
  • modificarea atributului 'numai-citire' pentru un fişier de configurare

Vă recomandăm cu căldură să aveţi întotdeauna un fişier de configurare default.conf. Acest fişier trebuie să aibă în mod normal atributul 'numai-citire', pentru a evita suprascrierea sa greşită. În orice caz, dacă doriţi să modificaţi acest fişier conform nevoilor dumneavoastră specifice, va trebui ca pentru scurt timp să îndepărtaţi atributul 'numai-citire'.

Imaginile PCMCIA se află în subdirectorul C:\Users\Public\General Motors\Tech2Win\pcmcia. Fiecare din aceste fişiere corespunde unui card PCMCIA, cu care sunteţi deja familiarizat de la lucru cu Tech2. Cu Tech2Win, puteţi avea câte imagini doriţi. Copiaţi pur şi simplu o imagine existentă sub un nou nume de fişier.

Dacă doriţi să lansaţi o anumită configuraţie direct de pe desktop, creaţi o comandă rapidă care execută "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Programul trebuie lansat din următorul director de lucru: 'C:\Program Files\General Motors\Tech2Win\bin'

Numărul fişierelor de configurare nu depinde de numărul de imagini pcmcia pe care le utilizaţi. Puteţi avea câteva fişiere de configurare utilizând aceeaşi imagine PCMCIA. Acest lucru simulează îndeaproape o situaţie dintr-un atelier de reparaţii în care mai mulţi mecanici folosesc acelaşi Tech2 (şi acelaşi card PCMCIA).

De asemenea, puteţi opta pentru ca fiecare configuraţie să folosească propria imagine PCMCIA dedicată. Acest lucru măreşte independenţa configuraţiilor. Cu toate acestea, este posibil ca efortul necesar pentru actualizarea fiecărei imagini PCMCIA să nu fie unul acceptabil.

Când creaţi o configuraţie nouă prin copierea uneia existente, configuratorul va afişa un avertisment dacă nu s-a modificat imaginea PCMCIA. În acest caz veţi avea două configuraţii utilizând aceeaşi imagine PCMCIA. Dacă doriţi acest lucru, apăsaţi pe OK. Dacă doriţi să se utilizeze o altă imagine PCMCIA sau una nouă pentru configuraţia nouă, apăsaţi pe Revocare. Apoi puteţi alege crearea unei imagini noi utilizând Copiere card de memorie ...

Iată aici două exemple de moduri în care vă puteţi administra configuraţiile şi imaginile PCMCIA.

O configuraţie per utilizator

Aveţi ocazia de a salva configuraţia pentru fiecare utilizator. Numele configuraţiei va fi de exemplu numele utilizatorilor. Avantajele acestui concept este acela că sunt posibile setări specifice fiecărui utilizator, cum ar fi interfeţele personale de comunicare cu vehiculul (MDI-uri), setări ale afişajului şi ale limbii. Dezavantajul este acela că va trebui să copiaţi fişierele PCMCIA dacă acelaşi software va fi folosit de câţiva utilizatori. Desigur, configuraţiile specifice utilizatorului pot folosi un fişier central PCMCIA.

O configuraţie pentru aplicaţia Tech2

Puteţi alege să realizaţi o nouă configuraţie pentru fiecare software pe care îl descărcaţi. Astfel, chiar şi versiunile mai vechi ale software-ului sunt disponibile dacă sunt necesare. Adesea, în asemenea cazuri, numele şi numărul versiunii software-ului sunt alese ca nume al configuraţiei.

  • Primii paşi: Interfaţa pentru comunicaţii a vehiculului
  • Primii paşi: Cale
  • Subiecte avansate: Fişier de configurare
  • Instalare: Paşii de instalare


Întrebări frecvente (FAQ)

  • Cum pot stabili ce port com trebuie să folosesc pentru Tech2Win?
  • Comunicarea între Tech2Win şi TIS2Web
  • Licenţă valabilă
  • Ce indică numărul licenţei?
  • Care este diferenţa dintre o licenţă Tech2Win şi Accesul de Securitate?
  • TIS2Web afişează o eroare nespecifică atunci când Software-ul iniţial utilizează accesul de securitate
  • Tech2Win nu execută software-ul Tech2 din altă zonă.
  • Cum pot folosi mai mult decât un MDI?
  • Fişierul jurnal conţine eroarea 'CPU32: Too many 0000/FFFF Commands encountered'
  • Nu este vizibilă nicio fereastră Tech2
  • SPS nu funcţionează
  • Unele autoteste nu funcţionează
  • Indicatorul de viteză fluctuează
  • Oprire bruscă
  • Limba suedeză este afişată pentru software 15.001
  • Pierderea comunicaţiei cu MDI
  • Tech2Win nu a găsit MDI-ul meu
  • Doresc să lansez imediat Tech2Win fără intervenţia sistemului de configurare
  • Unde sunt funcţiile de imprimare?
  • Un folder PCMCIA „neutilizat” este prezent pe computerul meu
  • Primesc un mesaj „cale de fişier ilegală”

Cum pot stabili ce port com trebuie să folosesc pentru Tech2Win?

Puteţi folosi 'Managerul de dispozitive' din Windows, căutaţi 'Porturi (COM & LPT)'. Dar unele computere au modemuri interne sau dispozitive bluetooth instalate care nu sunt prezentate în această categorie.
O altă cale este de a folosi o comandă de mici dimensiuni, livrată împreună cu configuratorul. O puteţi executa prin intermediul meniului de pornire (folderul Tech2Win), făcând clic pe 'show com ports'.
Ambele metode arată porturile com care sunt instalate pe computerul dumneavoastră şi pe care NU ar trebui să le folosiţi.

Comunicarea între Tech2Win şi TIS2Web

Este important ca Tech2Win să ruleze înainte de începerea comunicării cu TIS2Web pentru acces de securitate sau descărcare software. TIS2Web poate recunoaşte numai portul COM virtual la pornirea Tech2Win.

Licenţă valabilă

În mod normal, o descărcare software de la TIS2Web vă va furniza deja o licenţă valabilă. Dacă nu aveţi în continuare o licenţă, 'Acces de securitate (Securitate)' prin TIS2Web (nu TIS2000) trebuie realizat pentru a obţine o licenţă valabilă. Nu efectuaţi nicio altă comunicare TIS2Web cu Tech2Win, cum ar fi 'Descărcare software (SWDL)' înainte de a obţine o licenţă prin 'Acces de securitate (Securitate)'.

Ce indică numărul licenţei?

Numărul licenţei din dreapta barei de stare arată numărul de zile complete în care este valabilă licenţa. Imediat după realizarea unei descărcări sau a unui acces de securitate, se afişează un număr de 30 de zile. Totuşi, după o nouă pornire a Tech2Win, este afişat 29, deoarece durata licenţei este probabil de felul 29 de zile, 23 de ore şi 55 de minute. Dacă numărul zilelor de valabilitate a licenţei este mai mic de 24 de ore, este afişată o durată a licenţei de <1. 0 este afişat dacă licenţa a expirat.

Care este diferenţa dintre o licenţă Tech2Win şi Accesul de Securitate?

Licenţa Tech2Win vă permite să folosiţi Tech2Win. Pentru a obţine o asemenea licenţă, fie trebuie să descărcaţi software-ul, fie să realizaţi un acces de siguranţă la intervale regulate (cel mai adesea: la fiecare 30 de zile). Abilitatea de a realiza o asemenea descărcare prin intermediul TIS2Web informează Tech2Win că este prezent un utilizator valabil. Accesul de securitate aşa cum este cunoscut de la Tech2 informează Tech2Win că sunt permise anumite activităţi referitoare la securitate, cum ar fi dezactivarea unui airbag. Atât licenţa Tech2Win cât şi accesul de securitate se pot realiza prin aplicaţia de acces de securitate TIS2Web. Tech2Win afişează durata rămasă a licenţei pe bara de stare din dreapta. Din păcate, Tech2Win nu poate afişa durata accesului de securitate în timp ce Tech2Win execută pur şi simplu software-ul Tech2 şi nu înţelege software-ul Tech2.

TIS2Web afişează o eroare nespecifică atunci când Software-ul iniţial utilizează accesul de securitate

Se comportă la fel ca Tech2. Din cauza vechimii, Software-ul iniţial nu poate să obţină o licenţă de la TIS2Web. Totuşi, aceasta nu reprezintă o problemă în adevăratul sens al cuvântului, deoarece acest software de încercare nu comunică cu un vehicul pentru care ar fi necesară licenţa. Şi, întrucât licenţele depind de descărcarea programului TS2Web, trebuie oricum să obţineţi o licenţă pentru fiecare descărcare în parte după ce descărcaţi software-ul Tech2. O „licenţă” pentru Software-ul iniţial nu vă conferă dreptul la comunicaţii cu autovehicule cu software-ul North American Operations sau Opel/Vauxhall.

Tech2Win nu execută software-ul Tech2 din altă zonă.

Versiunea dvs. Tech2 este probabil limitată la una sau mai multe descărcări ale programului TIS2Web (regiuni). Apăsaţi pe Ajutor / Despre pentru a vedea ce limitări se aplică versiunii dvs. de Tech2Win. Versiunile anterioare ale Tech2Win permiteau numai executarea software-ului Opel/Vauxhall. Vor urma şi alte regiuni GM. În orice caz, Tech2Win poate în prezent executa software-ul Tech2 de la General Motors.

Cum pot folosi mai mult decât un MDI?

Dacă doriţi să atribuiţi MDI-uri specifice anumitor utilizatori, vă propunem să permiteţi fiecărui utilizator să îţi aibă propria configuraţie. Evident, aceste configuraţii trebuie numite conform respectivului utilizator. În fiecare dintre configuraţii, trebuie să introduceţi numărul de serie al MDI-ului specific utilizatorului din filă 'Interfaţa pentru comunicaţii a vehiculului'. Imediat ce utilizatorul îşi porneşte configuraţia, Tech2Win va încerca să contacteze MDI-ul specific. Doar dacă acel MDI nu este prezent, o casetă de selectare va fi prezentată, arătând toate MDI-urile pe care le-a putut găsi Tech2Win.

Dacă aveţi câteva MDI-uri pentru utilizare generală, vă propunem să folosiţi configuraţii la care numărul de serie a Interfeţei pentru comunicaţii a vehiculului din fila 'Interfaţa pentru comunicaţii a vehiculului' este lăsat liber. Apoi utilizatorul va vedea întotdeauna caseta de selectare a MDI-urilor disponibile.

Fişierul jurnal conţine eroarea 'CPU32: Too many 0000/FFFF Commands encountered'

Fişierul 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' sau fişierul pcmcia curent este deteriorat. Vă rugăm să realizaţi o reinstalare a Tech2Win şi să descărcaţi noul software Tech2.

Nu este vizibilă nicio fereastră Tech2

Dacă nu este vizibilă nicio fereastră Tech2, probabil aceasta se află într-o zonă care în prezent nu se află pe afişaj. Veţi constata asemenea efecte când folosiţi mai mult decât un ecran sau după modificarea rezoluţiei ecranului. Apăsaţi tasta Shift de pe tastatură în timpul începerii configurării. În acest caz, rezoluţia ferestrei va fi resetată la 640x480, iar fereastra Tech2 va fi afişată în colţul superior stânga al ecranului. Mai puteţi şterge fişierul C:\Users\Public\General Motors\Tech2Win\emulator.disp pentru a obţine acelaşi rezultat.

Am văzut cazuri în care fereastra Tech2 pur şi simplu nu va fi redesenată pe ecran după închiderea ferestrelor tuturor celorlalte aplicaţii. În toate cazurile pe care le-am văzut până acum, utilizarea tastei Alt-Tab pentru a comuta între aplicaţiile Windows a putut aduce ecranul Tech2. Apăsarea butonului Tech2Win din bara de sarcini în partea de jos a ecranului PC-ului nu funcţionează uneori. În prezent investigăm această problemă şi sperăm să avem o soluţie într-o versiune ulterioară a Tech2Win.

SPS nu funcţionează

Da, suntem la curent. Şi nu intenţionăm să schimbăm acest lucru. Nu ar trebui să folosiţi Tech2Win ca substitut pentru Tech2 pentru a realiza SPS. Utilizaţi MDI direct cu programarea SPS prin TIS.

Unele autoteste nu funcţionează

Autotestele Tech2 au rolul de a testa fiecare piesă în parte a hardware-ului Tech2. Unele dintre aceste teste necesită folosirea unui adaptor cu reacţie în buclă. Aceste teste nu vor funcţiona în Tech2Win deoarece funcţionalitatea adaptorului cu reacţie în buclă nu este implementată (şi nu există planuri pentru a face acest lucru). Vă rugăm să nu executaţi asemenea teste care nu au sens în Tech2Win. Dacă le executaţi, veţi obţine rezultate eronate sau Tech2Win se va bloca, aşa cum ar face Tech2 fără adaptor cu reacţie în buclă. Folosiţi Ctrl-R pentru resetarea Tech2Win în acest caz.

Indicatorul de viteză fluctuează

Indicatorul de viteză din partea stângă jos a barei de stare indică numărul de 'Comenzi Tech2' care poate fi executat înainte ca Tech2Win să poată 'trece în stare de repaus' din nou. Această metodă este folosită pentru asigurarea că durata de pe Tech2Win corespunde duratei reale: calculatoarele mai rapide rămân în stare de repaus mai mult decât calculatoarele mai lente. Dacă indicatorul de viteză fluctuează, alte aplicaţii ar putea folosi puterea de calcul sau ceasul calculatorului variază. Vitezele ridicate de fluctuaţie au un impact negativ asupra comunicaţiei vehiculului şi a comunicaţiei TIS2Web. Vă rugăm să vă asiguraţi că nu rulează alte aplicaţii.

Majoritatea laptopurilor pot reduce automat ceasul CPU pentru a extinde durata de funcţionare a acumulatorului. Şi aceasta ar putea fi o cauză a fluctuaţiei vitezei detectată de Tech2Win. În acest caz, vă rugăm să nu lăsaţi laptopul să funcţioneze cu acumulatorul, ci folosiţi o sursă externă de alimentare cu curent. Puteţi de asemenea încerca să schimbaţi setările de putere, aşa încât sistemul de operare să nu reducă viteza ceasului.

Oprire bruscă

Dacă nu găsiţi niciun motiv în interiorul fişierului jurnal pentru care programul s-a încheiat, atunci mecanismele de securitate interne Tech2Win ar putea fi activate. Vă rugăm să nu modificaţi următoarele fişiere: emulator.sec, emulator.lic, emulator.card. Dacă Tech2Win identifică o breşă de securitate, este foarte posibil să fie necesară realizarea unei reinstalări.

Limba suedeză este afişată pentru software 15.001

Software-ul iniţial livrat împreună cu Tech2Win este un software demonstrativ, prezent pe fiecare cartelă PCMCIA. TIS2Web indică faptul că este în limba suedeză, deoarece TIS2Web afişează numai ultima limbă din lista de patru limbi suportate de acest software demo (engleză, franceză, germană, suedeză). Folosiţi modul de actualizare 'Particularizare' în loc de 'Standard' pentru a suprascrie acest software demonstrativ cu cel mai nou software diagnostic.

Pierderea comunicaţiei cu MDI

O pierdere a comunicaţiei MDI poate avea câteva cauze.

  • Conexiune de proastă calitate prin cablu (atât Ethernet cât şi USB).
  • Conexiune wireless inconsistentă
  • Calculatorul trece în stare de veghe.

Tech2Win nu a găsit MDI-ul meu

Vă rugăm să utilizaţi următoarele puncte:

    1. Este MDI activ?
    2. MDI Manager funcţionează?
    3. Software-ul MDI este utilizat de o altă aplicaţie, cum ar fi SPS?
Puteţi porni MDI Manager utilizând pictograma de pe desktop sau de la „Start/Toate programele/General Motors/GM MDI Software”.: Vă rugăm să apelaţi Helpdesk dacă punctul 2 nu funcţionează.

Doresc să lansez imediat Tech2Win fără intervenţia sistemului de configurare

Executaţi "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Utilizaţi următorul director de lucru: 'C:\Program Files\General Motors\Tech2Win\bin' Puteţi utiliza în continuare sistemul de configurare pentru modificarea configuraţiei.

Unde sunt funcţiile de imprimare?

Tech2Win nu permite imprimarea directă. În schimb, creează fişierele temporare şi accesează programe asociate cu extensiile de fişier. Aceste programe se pot utiliza pentru imprimare, permiţându-vă să reglaţi aspectul imprimării.

Print Report | Print Report

Pentru a imprima ecranul Tech2Win curent, utilizaţi acelaşi element de meniu Fişier / Tipărire ecran sau butonul de pe tastatură cu simbolul unei imprimante. Dacă doriţi să imprimaţi mai multe ecrane Tech2Win, se poate utiliza elementul de meniu Opţiuni / Capturi de ecran automate, deoarece creează fişiere PNG pentru fiecare ecran Tech2Win. Aceste fişiere PNG sunt încorporate în fişierul jurnal.

De asemenea, puteţi imprima conţinuturi care afişează date (se activează utilizând elementul de meniu Ferestre / Afişaj de date Tech2Win). Utilizaţi butonul Imprimare/Pornire HTML pentru a porni şi apoi opri achiziţia datelor. După oprirea achiziţiei, se porneşte fişierul executabil asociat cu HTML (în general Internet Explorer), care vă oferă multe funcţii de imprimare a datelor.

Data Display | Data Display

Un folder PCMCIA „neutilizat” este prezent pe computerul meu

Versiunile anterioare ale Tech2Win au avut întotdeauna un duplicat al fişierelor PCMCIA stocat într-un director separat. Acest director era frecvent C:\PCMCIA. Acum, acest director nu mai este utilizat, deoarece descărcarea rapidă din TIS2Web face nenecesară o a doua stocare a acestor descărcări. Puteţi şterge în siguranţă acest director.

Primesc un mesaj „cale de fişier ilegală”

Numele fişierului pare să conţină caractere ilegale, cum ar fi semnul pentru procent (%). Dacă întâlniţi această problemă direct după o instalare, cel mai bine ar fi să efectuaţi, pur şi simplu, o dezinstalare şi o reinstalare nouă. Majoritatea cazurilor pot fi remediate fără această metodă.

În cursul instalărilor normale, variabila de mediu „Tech2WinUserData” este setată la „PUBLIC” (pentru versiuni Windows începând cu Vista) şi la „ALLUSERSPROFILE\Documents” (pentru versiuni Windows anterioare Vista). În unele cazuri rare, variabila de mediu nu a fost setată în cursul procesului de instalare, însă a funcţionat bine la a doua încercare. De asemenea, puteţi alege să setaţi manual variabila de mediu. Cereţi ajutor administratorului dacă nu ştiţi cum să setaţi o variabilă de mediu.


Intrări de regiştri

Prin instalare sunt generate următoarele intrări în regiştri. Vă rugăm să nu modificaţi manual aceste intrări. Ţineţi cont de măsurile de precauţie standard Windows atunci când lucraţi în regiştri.

cheie registru | nume | tip | semnificaţie
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Numărul versiunii interne
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Limbă | REG_SZ | limba instalată
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Calea directoarelor copiei PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Rădăcină (Root) | REG_SZ | cale de instalare
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Opţiunea dezinstalare | REG_DWORD | Setarea pentru dezinstalare
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Versiunea fişierului de configurare
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Versiunea driver-ului portului COM virtual
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Nume afişat (DisplayName) | REG_SZ | Numele aplicaţiei software din lista Adăugare/Eliminare programe
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Şir dezinstalare (UninstallString) | REG_SZ | Calea către dezinstalarea programului


Reinstalare

În urma reinstalării, se va şterge întregul director de instalare a Tech2Win, cu următoarele excepţii.

  1. Nu se şterge subdirectorul config care conţine configuraţiile.
  2. Nu se şterge subdirectorul pcmcia, care conţine de obicei imaginile PCMCIA.
  3. Nu se şterge subdirectorul ATA, care poate conţine informaţii de depanare.
Este posibil ca fişierele de configurare să devină incompatibile: nu există nicio garanţie că fişierele de configurare dintr-o versiune mai veche de Tech2Win pot fi citite de o versiune mai nouă de Tech2Win. Imaginile PCMCIA nu pot deveni incompatibile, din principiu.

Directorul PCMCIA secundar nu este afectat de reinstalare.

Este posibil ca anumite medii să ofere o instalare automată a unei versiuni Tech2Win mai noi. Deoarece informaţiile despre ultima instalare sunt stocate în regiştri, aceste setări vor fi preluate ca setări implicite în timpul reinstalării.

Puteţi aplica reinstalarea Tech2Win folosind scriptul enable reinstallation. Acest script este instalat împreună cu Tech2Win. De fapt, acest script doar setează valoarea tastei CurrentVersion care se găseşte în regiştri la HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win la valoarea '1.000'.