Manual do Utilizador do Tech2Win

Bem-vindo ao Manual do Utilizador do Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Todos os Direitos Reservados.

  • Introdução:
  • Licença:
  • Instalação:Uma descrição do procedimento de instalação do Tech2Win.
    • Passos da Instalação
    • Interface de Comunicação com o Veículo
  • Primeiros Passos
    • Selecção de uma Configuração
      • Teclado
      • Processamento Windows
    • Novas Configurações
    • Modificar Configurações
      • Língua
      • Caminho
      • Visor
      • Guardar uma Configuração
    • Obter uma licença Tech2Win válida.
  • Trabalhar com Tech2Win: Detalhes para o trabalho diário.
    • Menu
    • Transferir uma imagem PCMCIA
    • Segurança
    • Ver Relatórios
    • Processamento de imagens PCMCIA
    • Barra de Estado
  • Tópicos Avançados: Informações não necessárias para a utilização normal do Tech2Win. Frequentemente apenas com interesse para pessoas com tarefas de administração.
    • Reinstalação
    • Desinstalação
    • Formato do Ficheiro de Configuração
    • Ficheiro de Registo
    • Mensagens de Erro e Códigos de Erros
    • Cartão ATA
    • Entradas do Registo
    • Ficheiros
    • Gestão de Configuração
  • FAQ


Introdução

O Tech2Win é uma aplicação do Windows capaz de emular a funcionalidade Tech2. Essencialmente, o software Tech2 é executado num PC. Para executar este programa, o PC tem de satisfazer os seguintes requisitos técnicos:

  • Uma interface de comunicação do veículo tem de ser instalada e ligada ao PC. A lista de interfaces aceitáveis pode variar de região para região. Na maior parte dos casos, é possível utilizar a Interface de Diagnóstico Múltiplo (MDI) da GM.
  • A aplicação Tech2Win requer 150MBytes de espaço no disco rígido durante a instalação. São necessários mais 32MB por cartão flash PCMCIA.
  • Para executar a aplicação Tech2Win, são necessários 100MB livres na RAM física. O PC tem obrigatoriamente de ter memória suficiente para manter a aplicação dentro da RAM durante todo o tempo de execução.
  • O PC tem de ter o poder de computação equivalente ao de um Pentium 1.2 GHz (de núcleo único). Sugerimos vivamente que não seja utilizada qualquer outra aplicação em paralelo.
  • Não é necessário teclado. O Tech2Win também pode ser utilizado através do ecrã táctil. Para gestão da configuração, sugerimos vivamente a utilização de um teclado, uma vez que é necessário introduzir nomes de ficheiros.
  • O ecrã gráfico deve ter uma resolução mínima de 800 x 600 com uma profundidade de cor de 256. Sem o teclado numérico, uma resolução de 640 x 480 poderá ser aceitável.

Quando for utilizado o Tech2Win (um portátil em vez do Tech2) garantir que o portátil tenha potência que baste. Normalmente, o portátil não é alimentado pela bateria do carro, tal como o Tech2.

  • Instalação
  • Primeiros Passos


Licença

General Motors - Condições de Licenciamento do Tech2Win

Leia atentamente os seguintes termos e condições antes de utilizar este programa. Se não aceitar ou não compreender os termos ou as condições, consulte o representante de Pós-venda local. O direito de utilizar este software só é licenciado pela General Motors na condição de o utilizador concordar com esta licença, aceitando estes termos e condições durante a instalação do Tech2Win.
A General Motors concede o direito de utilizar o software Tech2Win e as informações incluídas juntamente com o TIS2Web ou o GlobalTIS ou o TIS2000 exclusivamente aos utilizadores da rede de reparadores autorizados da General Motors, conforme determinado no Contrato de Reparadores Autorizados localmente aplicável com as Empresas Comerciais Nacionais da General Motors.
A licença do Tech2Win entra em vigor desde que o Contrato de Reparadores Autorizados esteja em vigor e a licença do TIS2Web, GlobalTIS e do TIS2000 esteja no local. A licença Tech2Win terminará conjuntamente com o TIS2Web e a licença GlobalTIS imediatamente quando o Contrato do Reparador Autorizado terminar.

Os reparadores independentes, conforme definido no Artigo 4, parágrafo 2 do Regulamento de Isenção por Categoria da União Europeia (BER) de 1400/2002, podem comprar uma licença Tech2Win como parte das subscrições oferecidas fornecidas pelo GM Europe Info Tech Portal da General Motors Europe.

A licença Tech2Win não abrange a interface de comunicação do veículo ou o hardware do PC.

O software Tech2Win não deverá ser distribuído, vendido nem colocado on-line para qualquer terceiro fora das instalações do reparador autorizado (conforme descrito no anexo relevante do Contrato de Reparador Autorizado) sem o consentimento por escrito das Empresas Comerciais Nacionais relevantes da General Motors. Isto aplica-se tanto a dados actuais como a dados não actuais (tais como DVD expirados).

As Empresas Comerciais Nacionais da General Motors terão direito a fechar imediatamente o acesso e avisar da cessação imediata do Contrato de Reparador Autorizado no caso de utilização não autorizada ou abusiva. Neste caso, o direito a reclamar reembolso dos balanços de crédito remanescentes e/ou das taxas anuais básicas ficará excluído.

As informações fornecidas servem para a execução de trabalhos de assistência técnica e reparação de forma especializada nos veículos não alterados da General Motors. É necessária formação na área de técnicos automóveis e formação regular como condição prévia à execução dos trabalhos acima mencionados. Quando for indicada a utilização de ferramentas especiais nas informações fornecidas, essas ferramentas especiais são obrigatórias para todas as reparações a serem realizadas de forma especializada.

As informações publicadas no Global TIS da General Motors (texto e imagens, música, gráficos, animação, vídeos, etc.) e a disposição destas no Global TIS estão protegidas por direitos de autor. Não será permitida a reprodução, divulgação, comunicação e/ou transmissão ou outra utilização a não ser com o consentimento prévio por escrito da General Motors.

  • Instalação: Passos da Instalação
  • Primeiros Passos


Installation

Instalação

A instalação do Tech2Win requer direitos administrativos locais no PC. Sem licenciamento adequado, a instalação não funcionará. Nesse caso, contacte o administrador do PC para obter ajuda.

Para utilizar o Tech2Win com êxito, tem de concluir os passos que se seguem:

  • Instalação do Tech2Win.
  • A instalação de uma Interface de Comunicação com o Veículo.
  • Instalação: Passos da Instalação
  • Primeiros Passos


Passos da Instalação

A instalação demora apenas alguns minutos e requer que o utilizador introduza o seguinte:

  1. Acordo de Licença
  2. Directório de Instalação

Língua

Por predefinição a IU do Tech2Win exibir-se-á no idioma do seu sistema operativo. As línguas que se seguem são, geralmente, suportadas. Se o seu idioma não for suportado, o instalador é iniciado em inglês como idioma de instalação predefinido.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Inglês (Reino Unido ou Estados Unidos)*
  • el_GR (EL)Greek
  • es_ES (ES)espanhol
  • fi_FI (FI)Finnish
  • fr_FR (FR)francês
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Português (Brasil)
  • pt_PT (PT)Português (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Chinês (Simplificado)
  • zh_TW (ZH)Chinês (Tradicional)

* O idioma do Tech2Win é o inglês do Reino Unido. No entanto, o software Tech2 e o instalador que está a utilizar podem estar em inglês (E.U.A.), consoante a origem do software.

Acordo de Licença

Tem de aceitar o Acordo de Licença.

Directório de Instalação

Pode escolher qualquer directório como localização de instalação do Tech2Win. O directório de instalação por defeito é <o directório do seu programa>\General Motors\Tech2Win ou, no caso de reinstalação, a localização previamente especificada.

Por último, confirme a instalação.

Controlador de Porta de Comunicação Virtual

O controlador de porta de comunicação virtual só será instalado uma vez no seu computador e mantém-se até à actualização da versão do controlador (o que acontece raramente) ou quando desinstalar o Tech2Win do seu computador.
Se o controlador for instalado, aparecerá uma caixa do DOS durante breves instantes. Fechar-se-á automaticamente e não requer qualquer acção. Os ficheiros do controlador são colocados adicionalmente na subpasta 'controlador' no directório de instalação do seu Tech2Win.
É possível, mas não recomendado, instalar ou desinstalar manualmente os controladores da porta de comunicação virtual. Utilize um dos comandos seguintes a partir do 'shell' CMD:

  • chame 'vbsetup7' para instalar o controlador
  • chame 'vbsetup7 /u' para desinstalar o controlador
  • Primeiros Passos


Interface de Comunicação com o Veículo

O dispositivo de comunicação do veículo tem de ser instalado separadamente. É favor consultar o respectivo guia de instalação entregue com a Interface de Comunicação com o Veículo.

  • Primeiros Passos: Interface de Comunicação com o Veículo
  • Tópicos Avançados: Ficheiro de Configuração
  • Instalação: Passos da Instalação
  • FAQ: Como posso utilizar mais do que uma MDI?
  • FAQ: O Tech2Win não encontrou a minha MDI


Primeiros Passos

Estes primeiros passos mostram como utilizar o Tech2Win. Pressupõe o conhecimento do Tech2. A comunicação do veículo não é necessária durante estes primeiros passos.

Para ir para o Guia de Introdução siga os passos seguintes:

  1. Execute o software Tech2Win utilizando o atalho Guia de Introdução a partir do seu Ambiente de trabalho.
  2. Obtenha uma licença válida descarregando o novo software Tech2 da TIS2Web.

Para utilizar uma configuração seleccionável:

  1. Inicie o configurador utilizando o atalho Tech2Win a partir do seu Ambiente de trabalho. Após uma instalação, deve estar presente uma configuração por defeito.
  2. Para efectuar uma configuração nova, de preferência, copie a configuração default.
  3. Modifique uma configuração existente de acordo com os seus requisitos.
  4. Obter uma licença válida.

Não inicie o Tech2Win num modo de compatibilidade. Nesse caso, aparecerá um aviso no ficheiro de registo. O Tech2Win só utiliza as funções do Windows existentes a partir do XP, e não funcionará em versões do Windows anteriores.

  • Primeiros Passos: Novas Configurações
  • Primeiros Passos: Modificar Configurações
  • Primeiros Passos: Interface de Comunicação com o Veículo
  • Trabalhar com Tech2Win: Menu
  • Trabalhar com Tech2Win: Segurança
  • Trabalhar com Tech2Win: Barra de Estado
  • Tópicos Avançados: Ficheiro de Configuração


Selecção de uma Configuração

Da primeira vez que iniciar a aplicação Tech2Win, aparece o ecrã que se segue. Pode optar por iniciar o Tech2Win directamente sem uma configuração por defeito. Esta configuração por defeito funciona sem qualquer comunicação do veículo.

Start First Time

A caixa de mensagem de informação sobre a licença aparecerá, mas pode ser ignorada para dar início à configuração da predefinição.

Ao trabalhar com um ecrã táctil, poderá ser vantajoso iniciar o programa de teclado do PC para conseguir introduzir letras através desta aplicação que simula um teclado.


Teclado

As teclas e os botões do PC, se presentes, são mapeados para as teclas conhecidas do Tech2. O Tech2Win disponibiliza mais algumas teclas, que não são encontradas no Tech2 original. O teclado numérico no PC pode não funcionar sob todas as condições. Caso haja quaisquer problemas, é favor verificar se o esquema de teclado padrão no seu PC foi alterado. Especialmente a tecla SHIFT pode estar danificada neste caso.

Teclado do PC | Botão | Funcionalidade
Tecla de função F1 | n.d. | Ajuda do Tech2Win
Teclas de função F5 .. F8 | Usar a área de visualização do Tech2Win ocupada pelas teclas virtuais | Teclas de função do Tech2
Teclas Cima, Baixo, Esquerda, Direita do cursor |  | Teclas Cima, Baixo, Esquerda, Direita do Tech2. Só estas teclas têm repetição automática.
Tecla 0 .. 9 | F0 • • • F9 | Teclas F0 .. F9 do Tech2
Retrocesso | Exit | Tecla Sair do Tech2
Enter / Return | Enter | Tecla Enter do Tech2
Y | Yes | Tecla Sim do Tech2
N | No | Tecla Não do Tech2
Q | ? | Tecla ? do Tech2
S | Shift | Tecla Shift do Tech2; O indicador Shift na barra de estado ou o indicador por cima do botão Shift indica o estado.
ctrl-P | PWR | Tecla Energia do Tech2; Esta tecla desliga apenas a aplicação Tech2Win.
ctrl-R | não disponível | Reactiva o Tech2Win Semelhante a um ciclo Desligar/Ligar num Tech2. Contudo, uma Interface de Comunicação com o Veículo que esteja ligada não é reinicializada. Ficheiros tais como a imagem PCMCIA não são carregados novamente.
Home | Home | Uma tecla Home. Suportado apenas por algumas aplicações.
apenas disponível através da opção Ficheiro do menu. | Print Screen | Imprime um instantâneo do ecrã Tech2 criando um ficheiro BMP e chamando a aplicação associada com ficheiros BMP. Utilize esta aplicação para redimensionar ou rodar a imagem antes de imprimir.
apenas disponível através da opção Ficheiro do menu. | Save Screen | Guarda uma captura de ecrã do ecrã do Tech2 como ficheiro BMP ou PNG.
apenas disponível através da opção Ficheiro do menu. | View Report | Apresenta todos os relatórios no cartão flash PCMCIA para que o utilizador os possa ver.


Processamento Windows

Pode redimensionar as janelas que utilizam mecanismos Windows padrão, arrastando as linhas limitadoras da janela principal. Adicionalmente, o item do menu Opções/Resolução suporta vários tamanhos predefinidos. Durante um redimensionamento da janela principal através do item menu, a janela do teclado auxiliar permanecerá automaticamente activa.

O aspecto das janelas é modificado alterando a configuração no separador Visor.


Novas Configurações

Clique no botão Criar novo para criar uma nova configuração. Aparece o menu de uma caixa de diálogo que lhe pede para seleccionar um ficheiro de configuração existente como origem. Normalmente, é escolhida a configuração por defeito. Após introduzir o nome do novo ficheiro de configuração, toque no botão Copiar.

Se estiver a trabalhar com um ecrã táctil, poderá preferir activar a simulação de um teclado de PC através do botão Teclado do PC.

O botão Cancelar permite cancelar o processo de criação.

A configuração nova utilizará o mesmo ficheiro PCMCIA que a configuração de origem existente. Se desejar alterar, terá de modificar a configuração para que seja utilizado um ficheiro PCMCIA diferente. Na maioria dos casos, basta copiar o ficheiro PCMCIA existente para um ficheiro novo e utilizar esse ficheiro novo. Poderá preferir que a sua configuração nova utilize o mesmo ficheiro PCMCIA que a sua configuração de origem. Nesse caso, aparecerá um ecrã de aviso quando clicar no botão Gravar.

  • Modificar Configurações


Modificar Configurações

As configurações mostradas a azul estão marcadas como só de leitura e não pode ser modificadas. Estas configurações podem apenas ser visualizadas. É claro que é possível utilizar o método de modificação para ver simplesmente o respectivo conteúdo, mas não é possível Gravar

Para modificar uma configuração, seleccione a definição individual nos quatro tabuladores Língua, Interface de Comunicação com o Veículo, Caminho, Visor. Pode seleccionar o tabulador pretendido ou simplesmente escolher accionar o botão Seguinte que activará o tabulador seguinte. Após efectuar as modificações, prima o botão Gravar para guardar a configuração.

Sempre que for necessário utilizar o teclado, também pode chamar uma aplicação do PC que simule um teclado do PC. Este procedimento é especialmente útil em portáteis com ecrã táctil, se não estiver disponível um teclado.


Língua

O tabulador Língua permite seleccionar o idioma de execução do Tech2Win. A selecção não tem influência na língua do software Tech2 na imagem PCMCIA. Ao transferir o software Tech2 do TIS, tem de seleccionar a língua correcta.

Nalgumas regiões, nem todas as línguas estão disponíveis. Nesse caso, é utilizado o inglês. Verifique se existe um idioma idêntico disponível (PT Português-Portugal em vez de PB Português-Brasil).


Caminho

O tabulador Caminho permite definir os caminhos de ambas as imagens PCMCIA, bem como o caminho para o teclado de software. Adicionalmente, é disponibilizado o botão Copiar cartão de memória para copiar imagens PCMCIA. Se acabou de criar uma configuração nova, poderá querer utilizar este botão para evitar várias configurações utilizando a mesma imagem da PCMICA.

Memory Card Options

Copiar cartão de memória ...

Este botão permite copiar uma imagem PCMCIA para outro ficheiro. A sua funcionalidade é muito semelhante à compra de uma nova placa PCMCIA para o Tech2. A função copiar só funciona para ficheiros no directório C:\Users\Public\General Motors\Tech2Win\pcmcia.

Ranhura 0: Localização da imagem do cartão de memória

Pode especificar aqui o ficheiro que contém a sua imagem PCMCIA para a ranhura 0. Normalmente, esse tipo de ficheiro deverá encontrar-se em C:\Users\Public\General Motors\Tech2Win\pcmcia, no então, são possíveis outras localizações.

Ranhura 1: Cartão de memória ou ATA

Tal como o Tech2, o Tech2Win também suporta duas placas PCMCIA (imagens). Contudo, a segunda imagem PCMCIA numa configuração não tem, em geral, grande utilidade. Um segundo software seria provavelmente utilizado numa segunda configuração.

Tal como no Tech2, é utilizado um cartão ATA para fins de depuração. O cartão ATA só deverá ser activado se forrem recebidas instruções do suporte técnico. O suporte técnico fornecer-lhe-á mais informações.

Localização do teclado de software do PC

O valor por defeito deste ficheiro é obtido a partir do registo do Windows e deve apontar para uma aplicação capaz de simular um teclado de PC com o rato. Se tiver uma aplicação especial com esta funcionalidade para o portátil que está a utilizar, pode especificar a aplicação aqui.


Interface de Comunicação com o Veículo

  • Porta COM para Emulação do Tech2-RS232
  • Número de Série de MDI a utilizar
  • Protocolo

Porta COM para Emulação do Tech2-RS232

É favor escolher uma porta COM livre que possa ser usada para a emulação Tech2. Para sua comodidade, o Configurador tenta descobrir quais as portas série que já estão a ser utilizadas e apresenta-as.

Se for escolhida uma porta COM existente, o Tech2Win ligar-se-á a essa porta COM existente. Usando um cabo modem nulo, pode ser usada esta porta COM para transferir o software Tech2 de um segundo computador a executar a aplicação TIS. É favor notar que a utilização de uma porta COM física pode não funcionar fiavelmente a 115 200 baud devido a limitações do Windows.

Se for seleccionada uma porta COM não existente, o Tech2Win cria automaticamente uma porta virtual. Esta porta virtual pode ser usada a partir do TIS a executar no mesmo PC para estabelecer a comunicação com o Tech2Win. Quando uma porta virtual for usada não existe limitação de velocidade de transmissão.

Se escolher 'procurar' como porta COM, o Tech2Win criará uma porta COM virtual no primeiro número de porta livre, no intervalo de 9 a 1.

Número de Série de MDI a utilizar

Introduzir o número de série do MDI. O número pode ser encontrado na face posterior do MDI. Usar o número depois o hífen.

Se não introduzir um número de série, o Tech2Win apresentará automaticamente a lista das MDIs detectados na rede para o utilizador escolher uma MDI. A mesma caixa de selecção aparecerá quando a MDI especificada não é encontrada.

Protocolo

'ISO22900-2 / PDU-API' é seleccionado e o J2534-2 é apresentado a cinzento. No futuro o Tech2Win poderá suportar também o protocolo J2534.

  • Tópicos Avançados: Ficheiro de Configuração
  • FAQ: Como posso determinar qual a porta com que devo usar para o Tech2Win?
  • FAQ: Comunicação entre o Tech2Win e o TIS2Web
  • FAQ: Como posso utilizar mais do que uma MDI?
  • FAQ: O Tech2Win não encontrou a minha MDI


Visor

O separador Visor é utilizado principalmente para alterar as definições de apresentação do Tech2Win:

  • Teclado numérico
  • Cores
  • Som
Display and Key Options

Teclado numérico

Pode indicar aqui se o teclado numérico deverá ser apresentado. O teclado numérico é desenhado à esquerda ou à direita do ecrã Tech2Win. A cor de fundo é seleccionável através de uma caixa de diálogo de cor padrão.

Cores

A cor do fundo e do primeiro plano do ecrã Tech2 pode ser individualmente seleccionada aqui. Estas são as combinações de cores mais usuais:

Screen with background 0000FF, foreground FFFFFF | Fundo do Teclado Numérico branco; Fundo azul; Primeiro Plano branco
Screen with background 000000, foreground C0C0C0 | Fundo azul do Teclado numérico; Fundo preto; Primeiro Plano cinzento claro

Som

Pode escolher aqui desligar o som. Sempre que o programa Tech2 emitir som, é utilizado o altifalante do PC.


Guardar a Configuração

A configuração activa pode ser guardada premindo o botão Gravar <configuração> no canto inferior esquerdo. O botão não aparece, se estiver a visualizar uma configuração só de leitura.


Validar a licença através da TIS2Web

Normalmente, a transferência do Software Tech2 para o Tech2Win disponibilizará uma licença válida. Para além disso, pode obter uma executando um 'Acesso de Segurança (Segurança)' através do TIS2Web (não do TIS2000). Contudo, a pré-condição é a selecção da porta COM virtual dentro do Configurador sob Interface de Comunicação do Veículo.

Após uma entrada através do acesso de segurança pode ser vista um cadeado aberto no lado direito da barra de estado. Dentro do parêntesis é visualizado o número de dias de validade da licença. Quando iniciar novamente o Tech2Win o indicador de segurança não é visualizado desde que não exista comunicação com o veículo a ser executada. Durante a primeira comunicação com um veículo a licença será verificada e o indicador ou muda para um cadeado aberto ou fechado.

  • Trabalhar com Tech2Win:Segurança
  • FAQ:Como posso determinar qual a porta com que devo usar para o Tech2Win?
  • FAQ:Comunicação entre o Tech2Win e o TIS2Web
  • FAQ:Licença válida
  • FAQ:Qual a diferença entre uma licença Tech2Win e um Acesso de Segurança?


Trabalhar com Tech2Win

Os tópicos que se seguem são utilizados pela maior parte dos técnicos ao trabalhar com o Tech2Win:

  • Menu: O esquema do ecrã e os itens de menu individuais.
  • Transferência de uma imagem PCMCIA: A actualização do software de diagnóstico para o Tech2Win é muito semelhante ao método utilizado para o Tech2.
  • Segurança: As medidas de segurança evitam que o Tech2Win efectue comunicações com o veículo em ambientes não autorizados.
  • Ver Relatórios: O teclado do Tech2 foi ligeiramente melhorado no Tech2Win. O botão 'Ver Relatórios' é o exemplo mais proeminente.
  • Processamento de imagens PCMCIA: Assim como tem múltiplas placas PCMCIA para o Tech2, pode ter várias imagens PCMCIA em utilização no Tech2Win.
  • Barra de Estado: A barra de estado informa o utilizador sobre as partes individuais da barra de estado.
    • Tópicos Avançados
    • FAQ


Menu

A aplicação Tech2Win tem as seguintes entradas de menu:

  • Ficheiro
  • Opções
  • Ecrãs de Visualização
  • Ajuda

Ficheiro

O menu Ficheiro disponibiliza as seguintes possibilidades:

  • Guardar o T2-Screen (320x240) é utilizado para guardar o T2-Screen com uma dimensão de 320x240 píxeis como ficheiro monocromático no seu PC. A localização do armazenamento e o formato do ficheiro (BMP, GIF, JPG, PNG) são livremente seleccionáveis.
  • Impressão do Ecrã cria um negativo da imagem BMP monocromática no ecrã Tech2 e chama o programa associado com os ficheiros BMP. Pode então utilizar este programa para imprimir a imagem.
  • Ver Ficheiros de Relatório disponibiliza a possibilidade de visualizar (e imprimir) ficheiros de relatório sem usar o TIS2Web.
  • Sair encerra o Tech2Win.

Opções

As Opções disponibilizam as seguintes escolhas:

  • Resolução pode ser usada para escolher um dos três tamanhos padrão de ecrã.
  • ROM-Write from 0x00003ED76 é usado para fins de depuração interna.
  • Capturas Automáticas de Ecrã para armazenar uma imagem em cada ecrã Tech2 diferente no directório de registo de eventos.
  • Desactivar CANdi E Reiniciar para emular um Tech2 que não tem um CANdi entre ele próprio e o veículo. Isto é necessário no caso de incidentes raros onde o CANdi interrompe as linhas de comunicação com o veículo que não são normalizadas.

Ecrãs de Visualização

O menu Ecrãs de Visualização dá-lhe a possibilidade de ativar as seleções Visor de dados do Tech2Win e Visor de DTC do Tech2Win. Todas as outras selecções estão a cinzento na versão actual do Tech2Win.

Se o software Tech2 suportar a Visor de dados do Tech2Win pode ativar esta entrada de menu. Ao entrar na Exibição de Dados, o Tech2Win exibirá uma janela adicional de Exibição de Dados paralela à Exibição de Dados do Tech2. Logo que o ecrã Tech2 esteja exibido na Exibição de Dados, não é possível ativar a entrada de menu. Nesse caso, tem de sair da Exibição de Dados, ativar a entrada de menu e reiniciar a Exibição de Dados.

Aplicam-se restrições idênticas para o Visor de dados do Tech2Win e o Visor de DTC do Tech2Win. Se o software Tech2 suportar a Visor de DTC do Tech2Win pode ativar esta entrada de menu. Aparecerá uma janela Exibir DTC paralelamente à Exibir DTC Tech2. Logo que o ecrã Tech2 esteja exibido em Exibir DTC, não é possível ativar a entrada de menu. Nesse caso, tem de sair de Exibir DTC, ativar a entrada de menu e reiniciar Exibir DTC.

Ajuda

As seguintes escolhas estão disponíveis:

  • Tópicos de Ajuda... chama a Ajuda do Tech2Win.
  • Parâmetro da Linha de Comandos apresenta os parâmetros da linha de comando usada no Tech2Win.
  • Acerca de mostra o número da versão actual do TIS2Web e as limitações de transferência do Tech2Win.


Transferir

Primeiro, inicie o Tech2Win e deixe-o no ecrã principal. Inicie o TIS2Web ou GlobalTIS e execute a transferência através da porta COM especificada no separador Interface de Comunicação com o Veículo.

É possível utilizar portas COM integradas para transferir software Tech2 de outro PC a executar o TIS. Certifique-se de que utiliza um cabo RS232 cruzado. Dependendo do hardware do PC que está a executar o Tech2Win, a velocidade de transferência de dados pode ter de ser reduzida para 57.600 baud, dado que o Windows pode perder dados a uma velocidade de transferência superior.

A versão mais recente do Tech2Win também suporta uma transferência rápida quando o TIS2Web e o Tech2Win são executados no mesmo computador. Ainda é efectuada uma comunicação mínima entre o TIS2Web e o Tech2Win sobre a porta COM, mas o tempo da transferência de dados para o Tech2Win foi substituído por uma transferência de ficheiro interna. Neste caso, o tempo de transferência é reduzido drasticamente para menos de um minuto.

  • Tópicos Avançados: Ficheiro de Configuração
  • Primeiros Passos: Interface de Comunicação com o Veículo
  • FAQ: Como posso determinar qual a porta com que devo usar para o Tech2Win?
  • FAQ: Comunicação entre o Tech2Win e o TIS2Web


Segurança

O mecanismo de segurança usado pelo Tech2Win baseia-se num valor do relógio do PC correcto. Garantir que o relógio do PC está sempre correctamente definido. Pequenas variações do relógio que poderão ocorrer durante a troca para horário de Verão serão toleradas pelo Tech2Win

O Tech2Win não fará qualquer comunicação com o veículo sem uma licença válida e activa. Na barra de estado o seguinte indicador apresenta o estado da licença.

  • green smiley A licença é válida.
  • Sem indicador: A licença ainda não foi verificada.
  • red smiley A licença expirou.

Para obter uma licença, execute uma atualização 'Acesso de Segurança (Segurança)' utilizando a aplicação TIS2Web. Na maioria dos casos, uma Transferência de Software através do TIS2Web também será suficiente para ser obtida a nova licença. Dado que a licença se torna inválida após um determinado período de tempo (em algumas zonas geográficas: quatro semanas), uma tal actualização deve ser feita a intervalos regulares.

As licenças são específicas para zonas geográficas/software. O computador poderá estar licenciado se for usado o Tech2Win com diferentes versões do software Tech2.

O número de dias remanescentes antes da data de expiração da licença é apresentado na barra de estado.

  • ( 0) indica que a licença expirou ou é inexistente.
  • (<1) A licença expirará dentro das próximas 24 horas.
  • (20) A licença expirará dentro dos próximos 20 dias.

É favor não adulterar o ficheiro da licença. Modificações fraudulentas deste ficheiro são detectadas usando medidas internas de segurança e conduzirão à perda de todas as licenças instaladas no computador. Além disso, o Tech2Win comportar-se-á de forma errática. Isto só pode ser ultrapassado fazendo uma nova instalação.

  • Tópicos Avançados: Mensagens de Erro e Códigos de Saída
  • Tópicos Avançados: Ficheiro de Registo
  • Trabalhar com Tech2Win: Janela de Estado
  • FAQ: Licença válida
  • FAQ: Qual a diferença entre uma licença Tech2Win e um Acesso de Segurança?
  • FAQ: Paragem Súbita


Ver Relatórios

View Report Este botão pode ser utilizado para ver o conteúdo de quaisquer ficheiros PRT contidos na placa PCMCIA. É apresentada uma caixa de diálogo com uma lista de ficheiros PRT. Se tiver sido associado um programa à extensão PRT, este programa associado será executado. De outro modo, o editor Bloco de Notas é aberto para mostrar o ficheiro seleccionado.

Na maioria dos casos, o ficheiro PRT é um ficheiro ASCII que utiliza as páginas de código específicas da língua. Para Chinês, Japonês, Coreano e Tailandês, o ficheiro está em Unicode com uma marcação de ordem de bytes (BOM) à esquerda.

Para a visualização de relatórios, o Tech2Win funciona com um subdirectório C:\Users\Public\General Motors\Tech2Win\reports Este subdirectório só existe se os relatórios tiverem sido vistos pelo menos uma vez. O directório é automaticamente apagado e funciona como um directório de trabalho temporário para os ficheiros PRT na placa PCMCIA activa. Continua a conter estes ficheiros mesmo que o Tech2Win deixe de ser executado. Se quiser guardar um desses ficheiros, copie-o para outro directório, dado que pode ser substituído quando outro utilizador optar por ver relatórios.


Imagens PCMCIA

Normalmente, as imagens da PCMCIA encontram-se no subdirectório C:\Users\Public\General Motors\Tech2Win\pcmcia. O ficheiro tem de ter um tamanho exacto de 32Mbyte (33,554,432 bytes) ou 10Mbyte (10,485,760 bytes) e uma extensão de ficheiro *.bin. As imagens são modificadas (como em qualquer placa PCMCIA normal), se se verificar uma transferência ou se o Tech2Win guardar alguns dados no cartão flash. A modificação pode ser desactivada utilizando o interruptor de protecção de escrita (comando -W0 ou -W1) ou omitindo o valor 'p' na opção '-W'(Ficheiro de Configuração). Através do configurador não é possível aceder ao interruptor de protecção contra escrita. Terá de modificar manualmente o ficheiro de configuração se pretender utilizar as opções '-W0', '-W1' ou '-W'.


Barra de Estado

A barra de estado é apresentada debaixo do ecrã Tech2. Os itens que se seguem são apresentados na barra de estado.

  1. Um indicador de velocidade
  2. Estado da Comunicação do Veículo
  3. Estado da Porta Série
  4. Tecla SHIFT
  5. Capturas Automáticas de Ecrã
  6. Aviso de Registo
  7. Licença

Status Bar

Indicador de Velocidade

O indicador de velocidade mostra quanto tempo da CPU é gasto a emular o software Tech2 Um número baixo (indicador à esquerda) é melhor do que um número alto (indicador à direita). Qualquer indicador verde é aceitável. O indicador pode mudar para amarelo durante um curto período de tempo, se outra tarefa do Windows se tornar subitamente activa. Tal actividade deve ser evitada.

Estado da Comunicação do Veículo

O estado de comunicação com o veículo indica se a Interface de Comunicação com o Veículo (MDI) está presente bem como a comunicação entre o veículo e o Tech2Win.

Estado da Porta Série

Ao comunicar com o Tech2Win através de uma porta COM, este indicador mostra se a comunicação na porta COM está ou não activa.

Tecla SHIFT

Este indicador mostra se a tecla SHIFT está activa. Poderá alternar, utilizando a tecla 'S' do teclado, ou a tecla SHIFT no teclado.

Capturas Automáticas de Ecrã

As Capturas de ecrã Automáticas podem ser accionadas no menu Opções. De cada vez que o ecrã muda, um novo ficheiro contendo a captura de ecrã é armazenado no directório de registo de eventos. Isto é indicado pela volta que dá a manivela da máquina fotográfica vermelha existente na barra de estado. Logo que a Captura de ecrã Automática é desactivada a máquina fotográfica desaparece.

Aviso de Registo

O indicador do estado do Registo de eventos pode ter três estados diferentes.

  • gray log status indicator O ficheiro de registo de eventos não inclui avisos ou erros.
  • yellow log status indicator O registo de eventos contém uma mensagem de aviso.
  • red log status indicator O registo de eventos contém uma mensagem de erro.

Licença

O indicador da licença pode ter três estados:

  • green smiley A licença está activa e é válida.
  • Sem indicador: A licença ainda não foi verificada.
  • red smiley A licença expirou ou é inexistente.
Utilize o link Segurança para obter mais detalhes.

Descrições na Barra de Estado

Para alguns ícones, descrições são apresentadas para disponibilizar alguma informação adicional:

Descrição para o número de série VCI:
Tooltip VCI

Descrição para a Versão do Software TECH2 (Electrical Programming and Diagnose Unit)
Tooltip TECH2

Descrição para o Comport
Tooltip Comport

Descrição para o número da próxima imagem de ecrã (se os 'Capturas Automáticas de Ecrã' estiverem activos)
Tooltip Camera

Descrição que mostra a última entrada no registo de eventos com o nível 'Atenção' ou superior
Tooltip Logfile

Descrição para a duração exacta da licença
Tooltip License

As descrições são apresentadas se o cursor estiver sobre um ícone durante mais de 0,5 segundos sem se deslocar. As descrições desaparecem ao fim de 5 segundos ou quando o cursor é deslocado.

  • Tópicos Avançados: Mensagens de Erro e Códigos de Erros
  • Tópicos Avançados: Ficheiro de Registo


Tópicos Avançados

Os tópicos aqui discutidos são de menor importância para o utilizador comum do Tech2Win. As informações que se seguem poderão ser úteis para quem executar a configuração e gestão do Tech2Win.

  • Reinstalação
  • Desinstalação
  • Modificação directa dos ficheiros de configuração
  • Ficheiro de Registo
  • Mensagens de Erro e Códigos de Saída
  • Cartão ATA
  • Entradas do Registo
  • Descrição dos ficheiros
  • Exemplos de gestão da configuração


Desinstalação

O directório de instalação, o directório que contém os dados do utilizador (C:\Users\Public\General Motors\Tech2Win) e o directório que contém os dados da aplicação (C:\ProgramData\General Motors\Tech2Win) são eliminados na totalidade.

  • Tópicos Avançados: Reinstalação
  • Instalação


Ficheiro de Configuração

Os ficheiros de configuração ficarão sempre no subdirectório C:\Users\Public\General Motors\Tech2Win\config e têm a extensão de ficheiro *.conf. Pode optar por modificar manualmente o ficheiro de configuração, dado que nem todas as opções do ficheiro são acessíveis através do Tech2Win. O ficheiro de configuração é um ficheiro Unicode com uma marcação de ordem de bytes (BOM) à esquerda. Sugerimos vivamente a utilização de um editor compatível com Unicode, tal como o Notepad, ao efectuar alterações manuais.

O ficheiro de configuração é orientado para linhas. As linhas vazias são ignoradas. A linha começa sempre por uma opção e é geralmente seguida por um valor. Como exemplo, repare no ficheiro default.conf. Consulte a tabela que se segue que discute todas as opções disponíveis.

Se quiser lançar uma determinada configuração directamente a partir do ambiente de trabalho, faça um atalho que execute 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. O programa deverá ser lançado a partir do seguinte directório de trabalho: 'C:\Program Files\General Motors\Tech2Win\bin'

opção | Valor / Significado
; Um comentário
@ Um número de versão decimal no formato major.minor.
Os ficheiros de configuração com um número major diferente do Tech2Win não serão aceites. Os ficheiros de configuração com um número minor inferior a Tech2Win serão aceites.
-W0
-W1 		A placa PCMCIA na ranhura 0/1 tem um interruptor de protecção de escrita activado.
-B0
-B1 		O tamanho do bloco em Kbytes da placa PCMCIA na ranhura 0/1. Os valores aceitáveis são 128 (por defeito) ou 256.
-P0
-P1 		O ficheiro que contém a imagem binária de uma placa PCMCIA para a ranhura 0/1. O tamanho do ficheiro tem de ser exactamente 10MB ou 32MB. As Variáveis do ambiente como %ProgramData% estão expandidas.
Se esta opção não estiver presente, pressupõe-se que a ranhura esteja vazia.
-A0
-A1 		O ficheiro que contém os valores dos atributos da placa PCMCIA na ranhura 0/1. Se não estiverem presentes, serão utilizados atributos por defeito de acordo com o tamanho da placa e do bloco.
-W | Ao sair do Tech2Win, todos os dados persistentes são escritos nos respectivos ficheiros. Os valores p/f/r/c podem ser combinados para indicar PCMCIA/Flash-ROM/RTC/CANDI-App respectivamente.
-H | Funcionalidade de gestão da área dinâmica para dados. Os valores 0/r/w/t podem combinar-se para ativar a Colocação a Zero, Verificações de Leitura, Verificações de Escrita e Verificações de Tarefas, respetivamente. Utiliza-se o valor I para forçar sempre uma alocação de memória da área dinâmica para dados em endereços mais baixos uma vez que está implementado um esquema de alocação. Normalmente, esta opção é utilizada apenas num ambiente de desenvolvimento.
-PC | Anteriormente o caminho para a cópia do cartão PCMCIA. Esta opção é ignorada actualmente.
-MS | Identificação da Interface de Comunicação com o Veículo (MDI) com Número de Série. Se não estiverem registados, uma lista das MDIs disponíveis será apresentada.
-CT | A cor do texto (primeiro plano) em 3 valores de bytes hexadecimais O valor por defeito é 000000 (branco).
-CB | A cor do fundo em 3 valores de bytes hexadecimais O valor por defeito é FFFFFF (preto).
-ATA | Utilizar esta opção para activar o cartão de captura ATA. Retirá-lo para desactivar o cartão de captura ATA.
-C | O número da porta COM (1..9) a utilizar como a porta de comunicação RS232C do Tech2Win. COM9 é frequentemente utilizada para a porta COM virtual que é instalada pelo Tech2Win. Se esta opção não estiver presente, faz-se uma procura descendente de uma porta COM livre a partir da COM9. Use a ferramenta de sugestões na barra de estado entre o ícone Tech2 e o ícone TIS2Web para ver qual a porta COM utilizada.
-WR | Um endereço de PC (normalmente 253558) o qual tem autorização de escrita na Área do PCMCIA e do FLASH ROM. Esta funcionalidade também tem de ser activada sobre o menu (ou usando a opção WA). É necessário para o Depurador SingleStep depurar código na memória permanente.
-WA | Permitir que o Depurador SingleStep escrever na memória não-alterável.
-OF | Ficheiro de Opções contendo pares de opção/ valor.
-TP | Regulação de temporização (Valor Proporcional). Por defeito o valor passa a ser de 5000. Diminuir este valor para que o número de ciclos executados se adapte mais rapidamente ao tempo real.
-TD | Regulação de temporização (Valor diferencial). Por defeito o valor passa a ser de 100. Diminuir este valor para reagir mais depressa a variações de temporização instantânea. AVISO: a adulteração dos valores de TP e TD pode originar problemas de velocidade.
-PJ
-PP 		Especificar o protocolo que deve ser usado:
PJ para comunicação J2534.
PP para ISO22900-2 / PDU-API (predefinição)
-S | A presença desta opção activa a saída de som no pager do PC.
-L | A língua da aplicação Tech2Win. Se esta entrada estiver em falta, por predefinição utiliza-se o idioma do Windows activo. Utilize o link que se segue para ver uma lista das línguas que podem ser especificadas: Línguas. A janela de emulação Tech2 apresentará o idioma que estiver no cartão PCMCIA (i.e. o que foi transferido para o cartão PCMCIA).
-UD | Substituição do directório de dados do utilizador. No Win7, normalmente está em C:\Users\Public\General Motors\Tech2Win
-AD | Substituição do directório de dados da aplicação. No Win7, normalmente está em C:\ProgramData\General Motors\Tech2Win
-US | Utilize um semáforo específico do utilizador para a detecção de mais de uma instância do Tech2Win. Esta opção permitirá a cada utilizador executar o Tech2Win em paralelo com a mesma máquina, presumivelmente um servidor. Quando utilizar esta opção, deverá especificar também as opções -UD e -AD.
-SS | Opção para especificar o tamanho geral da janela do Tech2Win, incluindo o teclado (se presente). O primeiro parâmetro tem de ser uma cadeia (de caracteres), rodeada por aspas duplas (') e utilizar-se-á como o nome do tamanho no menu Opções / Resolução. O segundo parâmetro é o número total de pixéis horizontais do ecrã do Tech2Win, incluindo o teclado. O terceiro parâmetro é o número total de pixéis verticais do ecrã do Tech2Win. O quarto parâmetro opcional é a largura do teclado em pixéis.
-SH opção para controlar a utilização do ecrã. Utiliza-se o número decimal seguinte para especificar quais as possibilidades de utilização do ecrã devem desactivar-se.
  • Bit 0: N.º mín./máx. possível
  • Bit 1: Sem reposicionamento no ecrã.
  • Bit 2: Sem redimensionamento. Neste caso, o menu Opções / Resolução está a cinzento.
  • Bit 3: As janelas do Ecrã de Dados e de DTC terão o mesmo tamanho que a do Tech2Win (sem teclado)


Registo

De cada vez que é iniciada uma configuração do Tech2Win, é criado um novo ficheiro de registo de eventos em formato HTML no subdirectório C:\Users\Public\General Motors\Tech2Win\Logs. Para evitar congestionamento do disco duro os ficheiros de registo de eventos com antiguidade superior a uma semana são eliminados.

Os ficheiros de registo são automaticamente identificados de acordo com a data (ano, mês, dia) e a hora (hora, minuto, segundo) da respectiva criação:
aaaa-mm-dd_hhmmss.html

As entradas do ficheiro de registo estão sempre em inglês, mas em formato Unicode com uma marcação de ordem de bytes (BOM) à esquerda. Cada linha do ficheiro de registo é de um dos níveis seguintes:

Nível de Registo | Significado
Informação | Apenas informação Sem efeito na execução do programa.
Atenção | Ocorreu uma situação desconhecida. O utilizador poderá não ver quaisquer efeitos adversos.
ERROR | Ocorreu um erro perceptível pelo utilizador.
CRITICAL | Ocorreu um erro crítico que causa um comportamento incorrecto do programa.
FATAL | Um erro fatal causa a interrupção imediata do Tech2Win.

Todos os níveis acima de 'Atenção' são coloridos de modo a serem facilmente encontrados.

Além disso, os ficheiros de Impressão e Vídeo também farão parte do sub directório de registo de eventos Logs, se as opções do menu Impressão do Ecrã ou Capturas Automáticas de Ecrã fossem utilizadas.
aaaa-mm-dd_hhmmss_print_nnnnn.bmp
aaaa-mm-dd_hhmmss_video_nnnnn.png
As imagens Capturas Automáticas de Ecrã estão ligadas pelo ficheiro HTML - pelo que deve usar o registo HTML para visualizar a sequência destas imagens.

Na Barra de Estado, o utilizador é informado da existência de uma chamada de Atenção ( yellow lightning bolt) ou de uma entrada de registo mais grave ( red lightning bolt).


Mensagens de Erro e Códigos de Saída

Podem aparecer mensagens de erro nas caixas de diálogo. Estas caixas de diálogo ainda permitem que o Tech2Win execute o programa Tech2 em paralelo. Os Códigos de Saída são erros fatais que forçam o Tech2Win a terminar anormalmente. Os códigos de saída podem ser utilizados em ficheiros batch para detectar a razão pela qual um programa foi forçado a terminar.

Mensagens de Erro

Podem ser apresentadas as seguintes mensagens de erro. Segue-se uma breve explicação da situação e o modo como o problema pode ser resolvido.

Emulator too slow Emulator failed to start

Códigos de Saída

Código de Saída | Valor | Significado
OPCODE_ERROR | -7 | Foi detectado um comando inválido do microprocessador Tech2 (68332). A imagem do PCMCIA pode ter sido danificada.
ATA_PROBLEM | -6 | Ocorreu um problema durante a emulação ATA. Se esse problema ocorrer após recepção de instruções para utilizar o cartão ATA, contacte o help desk.
DEMO_TIME_IS_UP | -5 | Não deve aparecer na versão oficial do Tech2Win.
DLL_NOT_LOADED | -3 | Não foi possível carregar uma das DLLs necessárias. A cópia do Tech2Win parece incompleta. Efectue uma nova instalação e/ou escolha uma língua diferente.
EXIT_INIT_FAILED | -2 | A inicialização falhou. Procure a causa exacta no ficheiro de registo. Se um ficheiro de registo não existir, verifique se tem acesso de leitura/escrita correcto para todos os directórios.
normal | 0 | O Tech2Win terminou normalmente.


Cartão ATA

Geralmente, o cartão ATA no Tech2, é utilizado apenas para fins de depuração durante o desenvolvimento do software. Todos os dados ATA necessários encontram-se guardados no subdirectório C:\Users\Public\General Motors\Tech2Win\ataCapture. Normalmente, este directório não é importante e pode ser eliminado com segurança, salvo se houver instruções em contrário.

Dado que o directório ataCapture é fixo, o respectivo conteúdo será o mesmo para todas as configurações.


Ficheiros

Os ficheiros e directórios que se seguem são utilizados pelo Tech2Win.

Directório | Localização antes do Vista | Localização para o Vista e posterior
Instalação | Conforme definido durante a utilização
Dados do Utilizador | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Dados da Aplicação | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Ficheiro | Utilizar
[Dados do Utilizador]\atacapture | Contém ficheiros que estão presentes no cartão ATA. Se forem dadas indicações diferentes estes ficheiros não são necessários.
[Instalação]\bin | Contém o executável real, bem como as DLLs e as imagens necessárias para a execução.
[Instalação]\bin\emulator.exe | O executável principal que executa o código Tech2.
[Instalação]\bin\emulator_xx_XX.dll | DLL do recurso de língua específico.
[Instalação]\bin\T2Configurator.exe | A parte de configuração do Tech2Win.
[Instalação]\bin\Pictures | Contém os ícones de que o Tech2Win necessita.
[Dados do Utilizador]\config | Contém todas os ficheiros de configuração.
[Dados do Utilizador]\data | Contém ficheiros que são modificados durante a execução do Tech2Win. Estes ficheiros são necessários para execução correcta do Tech2Win. Normalmente, não deve tocar nestes ficheiros salvo se receber instruções explícitas para o fazer.
[Dados da Aplicação]\data | Contém ficheiros que são modificados durante a execução do Tech2Win. Estes ficheiros são necessários para execução correcta do Tech2Win. Normalmente, não deve tocar nestes ficheiros salvo se receber instruções explícitas para o fazer.
[Dados da Aplicação]\data\emulator.sec | Ficheiro de segurança . Não modifique este ficheiro.
[Dados da Aplicação]\data\emulator.card | Ficheiro do Cartão. Contém todos os cartões PCMCIA conhecidos pelo programa Tech2Win Não modifique este ficheiro.
[Dados do Utilizador]\data\emulator.disp | Este ficheiro contém a localização e o tamanho do ecrã Tech2Win. Se for eliminado, este ficheiro será recriado e o ecrã Tech2Win é iniciado no canto superior esquerdo com um tamanho de 640x480.
[Dados da Aplicação]\data\emulator.lic | Ficheiro de Licença. Contém informação sobre a duração de validade das licenças. Não modifique este ficheiro.
[Dados da Aplicação]\data\emulator.rtc | Ficheiro do Relógio em Tempo Real. Este ficheiro é utilizado como armazenamento para dados localizados no RTC do Tech2.
[Dados da Aplicação]\data\emulator.dta | Um ficheiro de informação 'Não voltar a dizer'.. Este ficheiro armazena as versões de software PCMCIA que não devem (nunca) apresentar o aviso sobre a incapacidade de executar o auto-diagnóstico que requer a presença da placa loopback.
[Dados da Aplicação]\data\candi.bin | Ficheiro de aplicação do CANdi. Contém a aplicação do CANdi que está ligado ao Tech2.
[Dados da Aplicação]\data\eprom.bin | Ficheiro EPROM interno do Tech2. Guarda o conteúdo da memória flash interna do Tech2.
[Instalação]\driver | Ficheiros de instalação do controlador da Porta COM virtual.
[Instalação]\help\emulator_xx_XX.chm | Ficherios de ajuda específicos de idiomas.
[Dados do Utilizador]\Logs | Contém registos de eventos. Ficheiros com antiguidade superior a uma semana serão automaticamente eliminados.
[Dados do Utilizador]\pcmcia | Contém ficheiros de imagens PCMCIA. Figurativamente, cada ficheiro corresponde a uma placa PCMCIA do Tech2. Estes ficheiros podem ser guardados em diferentes localizações.


Gestão da Configuração

Os ficheiros de configuração ficarão sempre no subdirectório C:\Users\Public\General Motors\Tech2Win\config e têm a extensão de ficheiro *.conf. O Tech2Win só pode ser utilizado para gerar novos ficheiros de configuração ou para modificar os ficheiros de configuração existentes que não são só de leitura. Para a restante gestão dos ficheiros de configuração, utilize o Windows Explorer ou um programa de processamento de ficheiros semelhante. Este procedimento é necessário para as seguintes actividades:

  • eliminação de ficheiros de configuração
  • mudança de nome dos ficheiros de configuração
  • alteração do atributo só de leitura de um ficheiro de configuração

Sugerimos vivamente que tenha sempre disponível um ficheiro de configuração default.conf. Este ficheiro deverá, normalmente, ter o atributo só de leitura definido para evitar substituições erradas. Contudo, ao alterar este ficheiro para satisfazer as suas necessidades especiais, terá rapidamente de eliminar o atributo só de leitura.

As imagens da PCMCIA encontram-se no subdirectório C:\Users\Public\General Motors\Tech2Win\pcmcia. Cada um destes ficheiros corresponde a uma placa PCMCIA com a qual já está familiarizado ao trabalhar com o Tech2. Tech2Win permite ter tantas imagens quantas quiser. Basta copiar uma imagem existente para um ficheiro com outro nome.

Se quiser lançar uma determinada configuração directamente a partir do ambiente de trabalho, faça um atalho que execute "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". O programa deverá ser lançado a partir do seguinte directório de trabalho: 'C:\Program Files\General Motors\Tech2Win\bin'

O número de ficheiros de configuração não depende do número de imagens PCMCIA que está a utilizar. A mesma imagem PCMCIA pode ser utilizada por vários ficheiros de configuração. Isto simula com fidelidade uma situação numa oficina onde vários mecânicos partilham o mesmo Tech2 (e a mesma placa PCMCIA).

Também pode optar pela alternativa de cada configuração utilizar a sua própria imagem PCMCIA dedicada. Esta opção tornaria as configurações individuais mais independentes umas das outras. Contudo, o esforço de actualizar cada imagem PCMCIA poderá não ser aceitável.

Quando efectuar uma configuração nova copiando alguma existente, o configurador exibirá um aviso, se a imagem da PCMCIA não tiver sido alterada. Nesse caso, terá duas configurações utilizando a mesma imagem da PCMCIA. Se for isso que pretende, basta pressionar OK. Se pretender que a configuração nova utilize uma imagem da PCMCIA diferente ou nova, clique em Cancelar. Pode então escolher fazer uma imagem nova utilizando Copiar cartão de memória ...

Seguem-se dois exemplos de métodos de gestão de configurações e imagens PCMCIA.

Uma configuração por utilizador

Existe a possibilidade de salvaguardar uma configuração por utilizador. O nome da configuração será, por exemplo, o do utilizador. As vantagens deste conceito são que, as definições específicas para cada utilizador, tais como as interfaces de comunicação com o veículo (MDIs) pessoais, definições de visualização e de idioma são possíveis. A desvantagem é que é necessário copiar os ficheiros PCMCIA se vários utilizadores tiverem de utilizar o mesmo software. Claro que as configurações específicas do utilizador podem usar um ficheiro PCMCIA central.

Uma configuração por software Tech2

Pode escolher fazer uma nova configuração para cada software que seja transferido. Portanto, mesmo as versões mais antigas do software estão disponíveis, se necessário. Muitas vezes o nome do software e o número da versão são escolhidos como o nome da configuração em tal caso.

  • Primeiros Passos: Interface de Comunicação com o Veículo
  • Primeiros Passos: Caminho
  • Tópicos Avançados: Ficheiro de Configuração
  • Instalação: Passos da Instalação


Perguntas mais frequentes (FAQ)

  • Como posso determinar qual a porta com que devo usar para o Tech2Win?
  • Comunicação entre o Tech2Win e o TIS2Web
  • Licença válida
  • O que é que indica o número de licença?
  • Qual a diferença entre uma licença Tech2Win e um Acesso de Segurança?
  • TIS2Web mostra um erro não específico ao realizar o acesso de segurança ao Software Inicial
  • O Tech2Win não executa software Tech2Win de outra área
  • Como posso utilizar mais do que uma MDI?
  • O Ficheiro de Registo de eventos contém o erro 'CPU32: Too many 0000/FFFF Commands encountered'
  • Nenhuma janela Tech2 está visível
  • O SPS não funciona
  • Alguns Auto-Diagnósticos não funcionam
  • O velocímetro oscila
  • Paragem Súbita
  • O idioma sueco é apresentado para o Software 15.001
  • Perda de comunicação com o MDI
  • O Tech2Win não encontrou a minha MDI
  • Quero iniciar imediatamente o Tech2Win sem me preocupar com o configurador
  • Onde se encontram as funções de impressão?
  • Em 'O meu computador' existe uma pasta chamada 'não utilizado'.
  • Estou a receber uma mensagem 'caminho de ficheiro ilegal'

Como posso determinar qual a porta com que devo usar para o Tech2Win?

Pode ser usado o 'Gestor de Dispositivos' do Windows, procurar 'Portas (COM & LPT)'. Mas alguns computadores têm modems internas os dispositivos bluetooth instalados que não são apresentados nesta categoria.
Outra maneira é utilizar um pequeno comando que é entregue juntamente com o configurador. Pode executá-lo através do seu menu de arranque (pasta Tech2Win) clicando em 'show com ports'.
Ambos os métodos mostram as portas que estão instaladas no computador e que NÃO devem ser usadas.

Comunicação entre o Tech2Win e o TIS2Web

É importante que o Tech2Win execute antes do arranque da comunicação com o TIS2Web para um acesso seguro ou transferência de software. O TIS2Web pode apenas reconhecer a porta-COM virtual quando o Tech2Win é iniciado.

Licença válida

Normalmente, a Transferência do Software do Tech2Win já disponibilizará uma licença válida. Se ainda não tem uma licença, tem de fazer um 'Acesso de Segurança (Segurança)' através do TIS2Web (não do TIS2000) para obter uma licença válida. Não execute qualquer outra comunicação TIS2Web com o Tech2Win como o 'Importação de Software (SWDL)' antes de obter uma licença através da 'Acesso de Segurança (Segurança)'.

O que é que indica o número de licença?

O número da licença à direita da barra de estado mostra o número de dias de licença completos. Imediatamente após a execução de uma transferência ou acesso de segurança, é apresentado o número de 30 dias. No entanto, depois de um novo arranque do Tech2Win, é apresentado 29 porque a duração da licença é algo como 29 dias, 23 horas e 55 minutos. Se o número de dias da licença baixar das 24 horas, é apresentada uma duração da licença de <1. Se a licença tiver expirado, é apresentado um 0.

Qual a diferença entre uma licença Tech2Win e um Acesso de Segurança?

A licença do Tech2Win permite que utilize o Tech2Win. Para obter tal licença, ou executa uma transferência do software ou um acesso de segurança a intervalos regulares (o mais comum: a cada 30 dias). A capacidade para executar uma dessas transferências através do TIS2Web informa o Tech2Win que um utilizador autorizado está presente. O Acesso de Segurança tal como é conhecido pelo Tech2 informa o Tech2Win que algumas actividades relacionadas com a segurança, tal como a desactivação de um Airbag, são permitidas. Tanto a licença Tech2Win bem como o Acesso de Segurança são executados através da aplicação Acesso de Segurança do TIS2Web. O Tech2Win exibe o tempo de duração remanescente da licença na barra de estado localizada à direita. Infelizmente, o Tech2Win não pode exibir o tempo de duração de um Acesso de Segurança visto que o Tech2Win apenas executa o software Tech2, mas não tem compreensão intrínseca do software Tech2.

TIS2Web mostra um erro não específico ao realizar o acesso de segurança ao Software Inicial

O comportamento é o mesmo que num Tech2. Devido à sua antiguidade, o Software Inicial não é capaz de obter uma licença a partir da TIS2Web. Contudo, esse não é um problema real uma vez que o software de demonstração não comunica com um veículo para o qual a licença é necessária. E uma vez que as licenças são específicas da transferência do TS2Web, teria sempre de obter uma licença para cada transferência individual depois de descarregar o software Tech2. Uma 'licença' para o Software Inicial não lhe daria o direito de realizar comunicações do veículo com um software de Operações Norte-americanas ou do Opel/Vauxhall.

O Tech2Win não executa software Tech2Win de outra área

A sua versão Tech2Win provavelmente está limitada a um ou várias transferências do TIS2Web (regiões). Prima Ajuda / Acerca de para ver quais as limitações que se aplicam à sua versão do Tech2Win. Versões mais antigas do Tech2Win só permitiam a execução do software do Opel/Vauxhall. Brevemente seguir-se-ão outras regiões da GM. De qualquer modo, actualmente o Tech2Win pode executar o software Tech2 da General Motors.

Como posso utilizar mais do que uma MDI?

Se pretender atribuir MDIs específicas a utilizadores específicos então sugerimos que cada utilizador tenha a sua própria configuração. Obviamente que estas configurações devem identificadas de acordo com o respectivo utilizador. Em cada configuração deve ser introduzido o número de série da MDI específica do utilizador no separador 'Interface de Comunicação com o Veículo'. Logo que o utilizador inicia a respectiva configuração, o Tech2Win tentará o contacto com a MDI específica. Apenas se a MDI não está presente, uma caixa de selecção será apresentada exibindo todos as MDIs que o Tech2Win conseguiu encontrar.

Se tiver várias MDIs para utilização geral propomos que utilize configurações onde o número de série da Interface de Comunicação com o Veículo no separador 'Interface de Comunicação com o Veículo' é deixado em branco. Então o utilizador verá sempre a caixa de selecção das MDIs disponíveis.

O Ficheiro de Registo de eventos contém o erro 'CPU32: Too many 0000/FFFF Commands encountered'

O ficheiro 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' ou o ficheiro pcmcia actual está corrompido. É favor executar uma reinstalação do Tec2Win e transferir um novo software Tech2Win.

Nenhuma janela Tech2 está visível

Se não for visível alguma janela Tech2 é porque este está provavelmente numa área inexistente na visualização actual. Podem ser encontrados tais efeitos quando mais do que um ecrã é utilizado ou após modificação da resolução do ecrã. Premir a tecla Shift no teclado durante o arranque da configuração. Neste caso a resolução gráfica da janela será reposta a 640 x 480 e a janela do Tech2 será apresentada no canto superior esquerdo do ecrã. Poderá também eliminar o ficheiro C:\Users\Public\General Motors\Tech2Win\emulator.disp para obter o mesmo efeito.

Já vimos casos onde a janela do Tech2Win não será reposta no ecrã após o fecho das janelas de todas as outras aplicações. Em todos os casos até agora vistos, a utilização da tecla Alt-Tab (Alt-Tabulação) para comutar entre as aplicações Windows conseguiu activar o ecrã do Tech2. Premir o botão do Tech2Win na barra de tarefas na parte inferior do ecrã do PC por vezes não funcionava. Actualmente estamos ainda a investigar este problema e esperamos ter uma solução num versão posterior do Tech2Win.

O SPS não funciona

Sim, temos conhecimento. Não temos quaisquer planos para alterar isto. Não deve utilizar o Tech2Win como substituto do Tech2 para executar o SPS. É favor usar o MDI directamente com a Programação do SPS através do TIS.

Alguns Auto-Diagnósticos não funcionam

Os Auto-diagnósticos do Tech2 têm como fim o ensaio de componentes individuais do hardware do Tech2. Alguns destes ensaios requerem a utilização de uma placa loopback. Estes ensaios não funcionarão no Tech2Win porque a funcionalidade da placa loopback não está implementada (e não há planos para o fazer). È favor não executar esses ensaios sem sentido no Tech2Win. Se forem executados, resultados erróneos poderão ser obtidos e o Tech2Win bloqueará tal como aconteceria com o Tech2 sem a placa loopback. Usar Ctrl-R para, em tal caso, reinicializar o Tech2Win.

O velocímetro oscila

O velocímetro à esquerda em baixo da barra de estado indica quantos 'comandos Tech2' podem ser executados antes de o Tech2Win ter de 'suspender' novamente. Este método é utilizado para garantir que a hora no Tech2Win corresponde à hora real: PCs mais rápidos ficam em suspensão mais tempo do que os PCs mais lentos. Se o velocímetro oscilar, então qualquer outra aplicação poderá estar a utilizar capacidade de computação ou o relógio do PC apresenta variações. Taxas de oscilação altas têm um impacto negativo na comunicação com o veículo e na comunicação TIS2Web. É favor certificar-se de que nenhuma outra aplicação está a ser executada.

A maioria dos portáteis pode reduzir automaticamente o relógio CPU para aumentar o tempo da bateria. Também isto pode ser a razão da oscilação de velocidade detectada pelo Tech2Win. Nesse caso, é favor não fazer funcionar o seu portátil a partir da bateria, mas utilize uma alimentação externa. Também pode tentar mudar as suas definições de alimentação, para que o sistema operativo não reduza a velocidade do relógio.

Paragem Súbita

Se, no ficheiro de registo de eventos, não encontrar qualquer razão para a terminação do programa, é porque os mecanismos de segurança interna do Techj2Win foram activados. Não adulterar os seguintes ficheiros: emulator.sec, emulator.lic, emulator.card. Se o Tech2Win identificar uma quebra de segurança possivelmente terá que proceder a uma reinstalação.

O idioma sueco é apresentado para o Software 15.001

O software inicial que é fornecido com o Tech2Win é um software de demonstração presente em todos os cartões PCMCIA novos. TIS2Web indica que é o idioma sueco porque TIS2Web apenas apresenta o último idioma na lista de quatro idiomas suportados por este software de demonstração (Inglês, Francês, Alemão, Sueco). Utilize o Modo de Actualização 'Personalizada' em vez de 'Standard' para escrever sobre este software de demonstração com o mais recente software de diagnóstico.

Perda de comunicação com o MDI

Uma perda de comunicação de MDI pode ter várias razões.

  • Má ligação por cabo (tanto Ethernet como USB).
  • Ligação sem fios irregular.
  • O PC passa a modo de espera.

O Tech2Win não encontrou a minha MDI

Por favor verificar os seguintes pontos:

    1. A MDI está activa?
    2. O Gestor de MDI está a funcionar?
    3. O MDI está a ser utilizado por outra aplicação, como o SPS?
Pode iniciar o Gestor de MDI usando o ícone respectivo no ambiente de trabalho ou através do Software existente em Iniciar/Todos os Programas/General Motors/GM MDI.: Por favor telefone aos Serviços de Apoio (Helpdesk) se o ponto 2 não funcionar.

Quero iniciar imediatamente o Tech2Win sem me preocupar com o configurador

Execute "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Use o seguinte directório de trabalho: 'C:\Program Files\General Motors\Tech2Win\bin' Também pode usar o configurador para efectuar quaisquer alterações à configuração.

Onde se encontram as funções de impressão?

O Tech2Win não disponibiliza funcionalidade de impressão directa. Em vez disso, cria ficheiros temporários e chama os programas associados com extensões de ficheiro. Podem utilizar-se estes programas para funções de impressão, permitindo-lhe ajustar a apresentação da sua impressão.

Print Report | Print Report

Para imprimir o ecrã do Tech2Win actual, utilize o item do menu Ficheiro / Impressão do Ecrã ou o botão no teclado que contém o ícone de uma impressora. Se necessitar de imprimir vários ecrãs do Tech2Win, pode utilizar o item do menu Opções / Capturas Automáticas de Ecrã, uma vez que cria ficheiros PNG para todos os ecrãs do Tech2Win. Estes ficheiros PNG estão incluídos no ficheiro de registo.

Também pode imprimir o conteúdo da exibição de dados (activado utilizando o item do menu Ecrãs de Visualização / Visor de dados do Tech2Win). Utilize o botão Iniciar Imprimir/HTML para iniciar e parar a aquisição de dados. Após parar a aquisição, o inicia-se executável associado a HTML (normalmente o Internet Explorer), que lhe disponibiliza todas as funcionalidades para impressão dos seus dados.

Data Display | Data Display

Em 'O meu computador' existe uma pasta chamada 'não utilizado'.

As versões anteriores do Tech2Win acrescentam sempre um armazenamento duplo dos ficheiros PCMCIA no directório separado. Frequentemente este directório era C:\PCMCIA. Actualmente já não se utiliza este directório porque a transferência rápida do TIS2Web torna desnecessário um segundo armazenamento dessas transferências. Pode apagar este directório com segurança.

Estou a receber uma mensagem 'caminho de ficheiro ilegal'

Parece que o nome de ficheiro contém caracteres ilegais, como o sinal de percentagem (%). Se observar este problema diretamente após uma instalação seria melhor fazer uma desinstalação e uma reinstalação. A maioria dos casos fica resolvida com este método.

Durante as instalações normais, a variável ambiente 'Tech2WinUserData' está definida para 'PÚBLICO' (para versões do Windows >= Vista) e para 'ALLUSERSPROFILE\Documents' (para versões do Windows antes do Vista). Em alguns casos raros a variável ambiente não foi definida durante o processo de instalação, mas funcionou bem na segunda tentativa. Poderá também optar por definir manualmente a variável ambiente. Se não souber como definir uma variável ambiente, peça ajuda ao seu administrador.


Entradas do Registo

As entradas de registo que se seguem são geradas pelo instalador. Não modifique estas entradas manualmente. Tenha atenção aos avisos do Windows ao processar entradas de registo.

chave de registo | nome | tipo | significado
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Número da versão interna
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Língua | REG_SZ | língua instalada
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Caminho dos directórios de cópia do PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Raiz | REG_SZ | caminho da instalação
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Opção de Desinstalação | REG_DWORD | Desinstalar Definição
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Versão do ficheiro Config
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Versão do Controlador Virtual da Porta-COM
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Nome a Apresentar | REG_SZ | Nome do software incluído na lista de programas Adicionar/Remover
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Cadeia da Desinstalação (UninstallString) | REG_SZ | Caminho até ao programa de desinstalação


Reinstalação

A reinstalação apagará o directório de instalação completo do Tech2Win com as excepções que se seguem.

  1. o subdirectório config que contém as configurações não é apagado.
  2. O subdirectório pcmcia que normalmente contém as imagens PCMCIA não é apagado.
  3. O Subdirectório ATA que pode conter informações de depuração não é apagado.
Os ficheiros de configuração poderão tornar-se incompatíveis: não há garantia de que os ficheiros de configuração de uma versão antiga do Tech2 possam ser lidos por uma nova versão do Tech2. Por princípio, as imagens PCMCIA não se tornam incompatíveis.

O directório PCMCIA secundário não é afectado pela reinstalação.

Alguns ambientes poderão oferecer a instalação automática de uma versão mais recente do Tech2Win. Dado que as últimas informações de instalação se encontram guardadas no registo, estas definições serão apresentadas como predefinição durante a reinstalação.

Pode forçar a reinstalação do Tech2Win usando um script enable reinstallation. Este script é instalado conjuntamente com o Tech2Win. Basicamente, este script define simplesmente o valor da chave CurrentVersion encontrada no registo em HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win como '1.000'.