Instrukcja obsługi Tech2Win

Witamy w Instrukcji obsługi Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Wszystkie prawa zastrzeżone.

  • Wprowadzenie:
  • Licencja:
  • Instalacja:Opis procedury instalacji Tech2Win.
    • Etapy instalacji
    • Interfejs komunikacyjny pojazdu
  • Pierwsze kroki
    • Wybór konfiguracji
      • Klawiatura
      • Obsługa w środowisku Windows
    • Nowe konfiguracje
    • Modyfikacja konfiguracji
      • Język
      • Ścieżka
      • Wyświetlacz
      • Zapis konfiguracji
    • Uzyskaj ważną licencję Tech2Win.
  • Obsługa Tech2Win: Obsługa codzienna.
    • Menu
    • Pobieranie obrazu PCMCIA
    • Bezpieczeństwo
    • Przeglądanie raportów
    • Obsługa obrazów PCMCIA
    • Pasek stanu
  • Nagłówki zaawansowane: Informacje nie wymagane przy normalnej obsłudze Tech2Win. Często potrzebne tylko osobom z uprawnieniami administratora.
    • Ponowna instalacja
    • Odinstalowanie
    • Format pliku konfiguracyjnego
    • Plik logowania
    • Komunikaty o błędach i kody błędów
    • Karta ATA
    • Wpisy rejestru
    • Pliki
    • Zarządzanie konfiguracją
  • FAQ


Wprowadzenie

Tech2Win jest aplikacją Windows, która może emulować działanie Tech2. Oprogramowanie Tech2 działa na komputerze PC. W celu uruchomienia tego programu, Państwa komputer musi spełniać następujące wymagania:

  • W komputerze musi być zainstalowany i podłączony interfejs do komunikacji z pojazdem. Lista dopuszczonych interfejsów może zmieniać się w zależności od regionu. W większości przypadków można używać Multiple Diagnostic Interface (MDI) GM.
  • Aplikacja Tech2Win wymaga do instalacji 150 MB wolnego miejsca na twardym dysku. Dodatkowo potrzebnych jest 32MB na każdą kartę błyskową PCMCIA, jaką chcą Państwo zarządzać.
  • Przed uruchomieniem aplikacji Tech2Win potrzebnych będzie minimum 100MB wolnej fizycznej pamięci RAM. Obowiązkowo Państwa komputer musi posiadać wystarczającą pamięć do przechowywania aplikacji w pamięci RAM przez cały czas działania programu.
  • Państwa komputer powinien posiadać mikroprocesor o mocy obliczeniowej odpowiadającej 1.2GHz Pentium (jednordzeniowy). Zdecydowanie sugerujemy, aby nie korzystać jednocześnie z innych aplikacji.
  • Klawiatura nie jest potrzebna. Tech2Win można również obsługiwać poprzez ekran dotykowy. Do zarządzania konfiguracją zdecydowanie zalecamy, aby używać klawiatury w celu wprowadzenia nazwy pliku.
  • Twój kolorowy ekran graficzny musi mieć rozdzielczość co najmniej 800 x 600 pikseli i minimalną głębię kolorów wynoszącą 256. Bez klawiatury dopuszczalna jest rozdzielczość 640 x 480 pikseli.

Jeżeli korzystasz z Tech2Win (laptop zamiast Tech2), upewnij się, że twój laptop ma wystarczającą rezerwę zasilania. Zwykle, Państwa laptop nie będzie zasilany z akumulatora samochodu jak Tech2.

  • Instalacja
  • Pierwsze kroki


Licencja

General Motors - Umowa Licencyjna Tech2Win

Przed użyciem tego programu, przeczytaj uważnie poniższe warunki. Jeśli nie akceptujesz lub nie rozumiesz niniejszych warunków, skontaktuj się z lokalnym przedstawicielem sieci Posprzedażnej. Prawo do korzystania z tego oprogramowania jest udzielane w ramach licencji General Motors jedynie pod warunkiem zaakceptowania jej warunków przez użytkownika podczas instalacji Tech2Win.
General Motors udziela prawa do korzystania z oprogramowania Tech2Win i z dołączonych informacji w połączeniu z TIS2Web lub GlobalTIS lub TIS2000 wyłącznie użytkownikom autoryzowanej sieci napraw General Motors zgodnie z właściwą lokalnie Umową z Autoryzowaną Stacją Napraw zawartą z Krajowymi Spółkami Sprzedażnymi General Motors.
Licencja Tech2Win jest ważna przez okres obowiązywania Umowy z Autoryzowaną Stacją Napraw oraz przez okres posiadania licencji TIS2Web, GlobalTIS i TIS2000. Licencja Tech2Win wygaśnie razem z licencją TIS2Web i GlobalTIS wraz z wygaśnięciem umowy z autoryzowanym warsztatem.

Niezależne stacje napraw zdefiniowane w art. 4 sekcji 2 European Union Block Exemption Regulation (BER) 1400/2002 mogą zakupić licencję Tech2Win jako część oferowanych subskrypcji dostępnych na portalu GM Europe Info Tech Portal firmy General Motors Europe.

Licencja Tech2Win nie obejmuje interfejsu komunikacyjnego pojazdu, ani sprzętu PC.

Oprogramowania Tech2Win nie wolno dystrybuować, sprzedawać ani umieszczać na witrynach internetowych w celu udostępnienia stronie trzeciej nie należącej do grupy autoryzowanych stacji napraw (zgodnie z opisem w odnośnym aneksie do Umowy z Autoryzowaną Stacją Napraw) bez pisemnej zgody właściwych Krajowych Spółek Sprzedażnych General Motors. Zastrzeżenie to dotyczy wszystkich danych - aktualnych i nieaktualnych. (np. płyt DVD, których ważność wygasła).

W razie nieautoryzowanego użytkowania lub nadużycia, Krajowe Spółki Sprzedażne General Motors będą uprawnione do natychmiastowego pozbawienia użytkownika dostępu do systemu i do natychmiastowego wypowiedzenia Umowy z Autoryzowaną Stacją Napraw. W takim przypadku użytkownik traci prawo do uzyskania zwrotu za opłacony, niewykorzystany okres subskrypcji i\lub podstawowe opłaty roczne.

Dostarczone niniejszym informacje służą realizacji usług i napraw w sposób profesjonalny w niezmodyfikowanych pojazdach General Motors. Ukończenie szkolenia technika mechanika samochodowego i dalsze regularne szkolenia są warunkiem wstępnym wykonywania wyżej wymienionych prac. Gdziekolwiek wskazuje się użycie specjalistycznych narzędzi, użycie takich narzędzi jest wymagane podczas wszystkich napraw, aby zapewnić ich fachowość.

Informacje publikowane na stronach Global TIS firmy General Motors (teksty, zdjęcia, muzyka, grafiki, animacje, filmy itp.) i ich układ na stronach Global TIS podlegają ochronie prawa autorskiego. Powielanie, rozpowszechnianie, przekazywanie i/lub transmisja lub jakiekolwiek inne wykorzystywanie bez uprzedniej, wyrażonej na piśmie zgody firmy General Motors jest zabronione.

  • Instalacja: Etapy instalacji
  • Pierwsze kroki


Installation

Instalacja

Instalacja Tech2Win wymaga posiadania uprawnień lokalnego administratora komputera. Bez uprawnień administracyjnych instalacja nie będzie działać. W takim przypadku prosimy skontaktować się z Państwa lokalnym administratorem PC w celu uzyskania pomocy.

Do pomyślnej obsługi Tech2Win konieczne jest wykonanie dwóch kroków:

  • Instalacja samego Tech2Win.
  • Instalacja interfejsu komunikacyjnego pojazdu.
  • Instalacja: Etapy instalacji
  • Pierwsze kroki


Etapy instalacji

Sama instalacja zabiera tylko kilka minut i wymaga następujących danych wejściowych od użytkownika:

  1. Umowa licencyjna
  2. Katalog instalacyjny

Język

Domyślnie interfejs użytkownika aplikacji Tech2Win zostanie wyświetlony w języku Twojego systemu operacyjnego. Ogólnie mogą być dostępne wymienione poniżej wersje językowe. Jeżeli Twój język nie jest obsługiwany, instalator uruchomi się w języku angielskim jako domyślnym języku instalacyjnym.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Angielski (Brytyjski lub Amerykański)*
  • el_GR (EL)Greek
  • es_ES (ES)hiszpański
  • fi_FI (FI)Finnish
  • fr_FR (FR)francuski
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugalski (Brazylia)
  • pt_PT (PT)Portugalski (Portugalia)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Chiński (Uproszczony)
  • zh_TW (ZH)Chiński (Tradycyjny)

* Językiem aplikacji Tech2Win jest brytyjski angielski. Jednakże oprogramowanie Tech2 i instalator, z którego korzystasz, mogą być w języku amerykańskim angielskim, zależnie od źródła oprogramowania.

Umowa licencyjna

Musisz zaakceptować umowę licencyjną.

Katalog instalacyjny

Jako lokalizację do instalacji Tech2Win można wybrać dowolny katalog. Katalog instalacyjny jest standardowo ustawiany na <Państwa katalog programowy>General Motors\Tech2Win lub w przypadku ponownej instalacji na wcześniej podaną lokalizację.

Na końcu musisz potwierdzić instalację.

Sterownik wirtualnego portu COM

Sterownik wirtualnego portu COM zostanie zainstalowany na Twoim komputerze tylko raz i pozostanie na nim do czasu aktualizacji wersji sterownika (co zdarza sie rzadko) lub do momentu odinstalowania Tech2Win z Twojego komputera.
W przypadku instalacji sterownika, przez krótką chwilę zobaczysz okienko DOS. Zamknie się ono automatycznie i nie wymaga żadnego działania. Pliki sterownika zostaną dodatkowo umieszczone w podfolderze „sterownik” w Twoim katalogu instalacyjnym Tech2Win.
Istnieje możliwość (choć nie jest to zalecane) ręcznego zainstalowania lub odinstalowania sterowników wirtualnego portu COM. Należy użyć jednego z następujących poleceń z poziomu powłoki CMD:

  • Wywołaj „vbsetup7”, aby zainstalować sterownik
  • Wywołaj „vbsetup7 /u”, aby odinstalować sterownik
  • Pierwsze kroki


Interfejs komunikacyjny pojazdu

Urządzenie do komunikacji z pojazdem musi być zainstalowane osobno. Patrz odpowiednia instrukcja instalacji, która była dołączona do interfejsu komunikacyjnego pojazdu.

  • Pierwsze kroki: Interfejs komunikacyjny pojazdu
  • Nagłówki zaawansowane: Plik konfiguracyjny
  • Instalacja: Etapy instalacji
  • FAQ: W jaki sposób mogę korzystać z więcej niż jednego MDI?
  • FAQ: Tech2Win nie znalazł mojego MDI


Pierwsze kroki

Poniżej opisane pierwsze kroki pokażą Państwu, jak korzystać z Tech2Win. W opisie założono, że są Państwo zaznajomieni z obsługą samego Tech2. Komunikacja z pojazdem nie jest wymagana podczas tych pierwszych kroków.

W celu szybkiego rozpoczęcia pracy należy wykonać następujące czynności:

  1. Uruchom oprogramowanie Tech2Win za pomocą skrótu Szybki start znajdującego się na pulpicie.
  2. Uzyskaj ważną licencję, pobierając oprogramowanie Tech2 z TIS2Web.

Aby użyć dostępnej konfiguracji:

  1. Uruchom konfigurator za pomocą skrótu Tech2Win znajdującego się na pulpicie. Po zainstalowaniu, konfiguracja standardowa powinna być obecna.
  2. Aby utworzyć nową konfigurację, najlepiej skopiuj konfigurację domyślną.
  3. Zmodyfikuj istniejącą konfigurację odpowiednio do własnych wymogów.
  4. Uzyskaj ważną licencję.

Nie uruchamiaj programu Tech2Win w trybie zgodności. W takim przypadku w pliku dziennika pojawi się ostrzeżenie. Program Tech2Win wykorzystuje tylko te funkcje Windows, które istnieją od wersji XP i nie będzie działał we wcześniejszych wersjach Windows.

  • Pierwsze kroki: Nowe konfiguracje
  • Pierwsze kroki: Modyfikacja konfiguracji
  • Pierwsze kroki: Interfejs komunikacyjny pojazdu
  • Obsługa Tech2Win: Menu
  • Obsługa Tech2Win: Bezpieczeństwo
  • Obsługa Tech2Win: Pasek stanu
  • Nagłówki zaawansowane: Plik konfiguracyjny


Wybór konfiguracji

Przy pierwszym uruchomieniu aplikacji Tech2Win pojawi się następujący ekran. Dostępna jest opcja uruchomienia Tech2Win bezpośrednio z konfiguracją standardową. Konfiguracja standardowa działa bez komunikacji z pojazdem.

Start First Time

Pojawi się okno z informacją o licencji, ale można je zignorować i uruchomić konfigurację standardową.

W przypadku pracy z ekranem dotykowym, może okazać się korzystne uruchomienie programu klawiatury PC, aby za pomocą aplikacji symulującej klawiaturę można było wpisywać litery.


Klawiatura

Klawisze oraz przyciski PC, jeśli występują, są przypisane podobnym klawiszom Tech2. Tech2Win zawiera kilka dodatkowych klawiszy, których nie ma w oryginalnym Tech2. Klawiatura numeryczna komputera PC może nie działać we wszystkich warunkach. Jeżeli wystąpią jakiekolwiek problemy, sprawdź, czy standardowy układ klawiatury na Twoim komputerze nie został zmieniony. W takim przypadku uszkodzeniu może ulec w szczególności klawisz SHIFT.

Klawiatura PC | Przycisk | Działanie
Klawisz funkcyjny F1 | nie dostępny | Pomoc Tech2Win
Klawisze funkcyjne F5...F8 | Użyj obszaru wyświetlania Tech2Win, w którym znajdują się klawisze programowalne | Cztery klawisze programowalne Tech2
Klawisze kursora Góra, Dół, Lewo, Prawo |  | Klawisze Góra, Dół, Lewo, Prawo Tech2; Tylko te klawisze mają automatyczne powtórzenie.
Klawisze 0...9 | F0 • • • F9 | Klawisze F0...F9 Tech2
Backspace | Exit | Klawisz Exit (Wyjście) Tech2
Enter/Return | Enter | Klawisz Enter Tech2
Y | Yes | Klawisz Yes (Tak) Tech2
N | No | Klawisz No (Nie) Tech2
Q | ? | Klawisz ? Tech2
S | Shift | Klawisz Shift Tech2. Stan sygnalizuje wskaźnik Shift na pasku stanu lub wskaźnik nad przyciskiem Shift.
ctrl-P | PWR | Klawisz Power (Zasilanie) Tech2; Oczywiście, tylko ten klawisz może wyłączyć aplikację Tech2Win.
ctrl-R | nie dostępny | Resetuje Tech2Win. Podobnie do cyklu Wyłączenia/włączenia zasilania na Tech2. Podłączony interfejs komunikacyjny pojazdu nie zostaje jednak zresetowany. Pliki, takie jak obraz PCMCIA, nie zostają ponownie załadowane.
Strona macierzysta | Home | Klawisz strony macierzystej. Wspierany tylko przez niektóre aplikacje.
Dostępne tylko za pośrednictwem menu Plik. | Print Screen | Drukuje zrzut ekranu Tech2, tworząc tymczasowy plik BMP i wywołując aplikację skojarzoną z plikami BMP. Korzystając z tej aplikacji, można zmienić rozmiar obrazu lub obrócić go przed wydrukowaniem.
Dostępne tylko za pośrednictwem menu Plik. | Save Screen | Zapisuje zrzut ekranowy ekranu Tech2 w formacie pliku BMP lub PNG.
Dostępne tylko za pośrednictwem menu Plik. | View Report | Wyświetla wszystkie raporty na aktywnej karcie błyskowej PCMCIA, umożliwiając ich przeglądanie przez użytkownika.


Obsługa w środowisku Windows

Wielkość obrazu można zmieniać korzystając ze standardowych mechanizmów Windows, przeciągając linie skrajne okna głównego. Dodatkowo opcja menu Opcje/Rozdzielczość oferuje kilka zdefiniowanych rozmiarów. Podczas zmiany wielkości okna za pośrednictwem opcji menu okno klawiatury numerycznej pozostanie automatycznie podłączone.

Wygląd okien jest modyfikowany poprzez zmianę konfiguracji w zakładce Wyświetlacz.


Nowe konfiguracje

Kliknąć przycisk Utwórz nowy, aby utworzyć nową konfigurację. Pojawi się menu dialogowe z zapytaniem, czy wybrać istniejący plik konfiguracyjny jako źródłowy. Normalnie, wybrana zostanie konfiguracja standardowa. Po wprowadzeniu nazwy nowego pliku konfiguracyjnego należy wcisnąć przycisk Skopiuj.

Jeżeli pracują Państwo przy użyciu ekranu dotykowego, przydatna może okazać się aktywacja symulacji klawiatury PC przyciskiem Klawiatura PC.

Przycisk Unieważnij umożliwia unieważnienie procesu tworzenia.

W nowej konfiguracji będzie używany ten sam plik PCMCIA co w istniejącej konfiguracji źródłowej. Chcąc to zmienić, należy zmodyfikować konfigurację, tak aby używany był inny plik PCMCIA. W większości przypadków polega to po prostu na skopiowaniu istniejącego pliku PCMCIA do nowego pliku i użycie tego nowego pliku. Czasami użytkownik woli, aby nowa konfiguracja korzystała z tego samego pliku PCMCIA co konfiguracja źródłowa. W takim przypadku po kliknięciu przycisku Zapisz pojawi się ekran ostrzeżenia.

  • Modyfikacja konfiguracji


Modyfikacja konfiguracji

Konfiguracje zaznaczone niebieskim kolorem są tylko do odczytu i nie można ich modyfikować. Te konfiguracje można tylko przeglądać. Oczywiście można użyć metody modyfikacji w celu łatwego przejrzenia ich zawartości, ale ich zapis funkcją Zapisz będzie niemożliwy.

Konfigurację modyfikuje się wybierając indywidualne ustawienia w czterech tabulatorach Język, Interfejs komunikacyjny pojazdu, Ścieżka, Wyświetlacz. Możesz albo wybrać żądane pole albo po prostu nacisnąć przycisk Następne, co spowoduje uaktywnienie następnego pola. Po dokonaniu własnych modyfikacji, naciśnij przycisk Zapisz, aby zapisać swoją konfigurację.

Jeżeli konieczny jest wpis przy użyciu klawiatury można otworzyć aplikację PC symulującą klawiaturę PC. Jest to szczególnie poręczne w przypadku laptopów z ekranem dotykowym, gdzie nie ma klawiatury.


Język

Tabulator Język umożliwia wybranie wersji językowej, w jakiej ma pracować Tech2Win. Ten wybór nie ma wpływu na wersję językową oprogramowania Tech2 na obrazie PCMCIA. Podczas pobierania oprogramowania Tech2 z TIS również trzeba będzie wybrać właściwą wersję językową.

W niektórych regionach nie będą dostępne wszystkie wersje językowe. W takim przypadku, wyświetlona zostanie wersja w języku angielskim. Należy sprawdzić, czy jest dostępny podobny język (PT, czyli podstawowa odmiana portugalskiego, a nie PB, czyli portugalski brazylijski).


Ścieżka

Tabulator Ścieżka umożliwia ustawienie ścieżek obrazów PCMCIA oraz ścieżki do klawiatury lokalnego oprogramowania. Dodatkowo, przycisk Kopiuj kartę pamięci umożliwia kopiowanie obrazów PCMCIA. W przypadku utworzenia nowej konfiguracji można użyć tego przycisku, aby uniknąć stosowania tego samego obrazu PCMCIA w kilku konfiguracjach.

Memory Card Options

Kopiuj kartę pamięci ...

Ten przycisk umożliwia skopiowanie obrazu PCMCIA do innego pliku. Jego działanie jest bardzo podobne do dostarczania nowej karty PCMCIA do Tech2. Funkcja kopiowania działa tylko w przypadku plików w katalogu C:\Users\Public\General Motors\Tech2Win\pcmcia.

Gniazdo 0: Lokalizacja obrazu karty pamięci

Tutaj można zaznaczyć plik, który zawiera obraz Państwa PCMCIA dla gniazda 0. Zazwyczaj taki plik powinien znajdować się w katalogu C:\Users\Public\General Motors\Tech2Win\pcmcia, ale możliwe są inne lokalizacje.

Gniazdo 1: Karta pamięci lub ATA

Podobnie jak Tech2, Tech2Win również obsługuje dwie karty PCMCIA (obrazy). Jednak, drugi obraz PCMCIA w konfiguracji zwykle nie jest za bardzo użyteczny. W drugiej konfiguracji należałoby prawdopodobnie użyć drugiego oprogramowania.

Podobnie jak w Tech2, dla celów usuwania błędów programowych używa się karty ATA. Kartę ATA należy aktywować tylko w przypadku otrzymania takiej instrukcji z działu wsparcia technicznego. Pracownicy działu przekażą Państwu dalsze informacje.

Lokalizacja klawiatury oprogramowania PC

Wartość standardowa tego pliku jest wyszukiwana z rejestru Windows i powinna wskazywać na aplikację zdolną do symulacji klawiatury PC z myszką. Jeżeli posiadają Państwo specjalną aplikację o takim działaniu do używanego przez Państwa laptopa, tutaj można wskazać tę aplikację.


Interfejs komunikacyjny pojazdu

  • Port COM do emulacji Tech2-RS232
  • Numer seryjny MDI do użycia
  • Protokół

Port COM do emulacji Tech2-RS232

Wybierz wolny port COM, który może zostać wykorzystany do emulacji Tech2. Dla wygody użytkownika Konfigurator stara się ustalić, które porty szeregowe są już używane, po czym wyświetla je.

Jeżeli wybierzesz istniejący port COM, Tech2Win przypisze się do tego istniejącego portu COM. Możesz wykorzystać ten port COM do pobrania oprogramowania Tech2 z drugiego komputera, na którym jest uruchomiona aplikacja TIS, korzystając z kabla bezmodemowego. Pamiętaj, że wykorzystanie rzeczywistego portu COM może nie zapewnić prawidłowego działania przy szybkości transmisji 115200 bps ze względu na ograniczenia systemu Windows.

Jeżeli zostanie wybrany nieistniejący port COM, Tech2Win automatycznie utworzy port wirtualny. Ten port wirtualny może zostać wykorzystany przez TIS uruchomiony na tym samym komputerze PC do ustanowienia komunikacji z Tech2Win. W przypadku korzystania z portu wirtualnego nie ma żadnego ograniczenia związanego z szybkością transmisji.

Jeżeli wybierzesz opcję „wyszukaj” jako ustawienie dla portu COM, Tech2Win utworzy wirtualny port COM pod pierwszym wolnym numerem portu w zakresie od 9 do 1.

Numer seryjny MDI do użycia

Wprowadź numer seryjny MDI. Numer ten można znaleźć z tyłu MDI. Użyj numeru podanego po łączniku.

Jeśli nie wprowadzisz numeru seryjnego, Tech2Win automatycznie wyświetli listę MDI wykrytych w sieci, umożliwiając użytkownikowi wybranie jednego MDI. To samo okno wyboru pojawia się, gdy podany MDI nie zostanie znaleziony.

Protokół

Zaznaczona jest opcja 'ISO22900-2 / PDU-API', a opcja J2534-2 jest zawsze wygaszona. W przyszłości Tech2Win może również obsługiwać protokół J2534.

  • Nagłówki zaawansowane: Plik konfiguracyjny
  • FAQ: W jaki sposób mogę określić, którego portu COM mogę użyć dla Tech2Win?
  • FAQ: Komunikacja między Tech2Win a TIS2Web
  • FAQ: W jaki sposób mogę korzystać z więcej niż jednego MDI?
  • FAQ: Tech2Win nie znalazł mojego MDI


Wyświetlacz

Zakładka Wyświetlacz służy głównie do zmiany ustawień dotyczących wyświetlacza Tech2Win:

  • Blok klawiszy
  • Kolory
  • Dźwięk
Display and Key Options

Blok klawiszy

Tutaj można wybrać, czy ma być wyświetlany blok klawiszy. Blok klawiszy znajduje się z lewej lub z prawej strony ekranu Tech2Win. Kolor tła wybiera się z kolorów standardowych w oknie dialogowym.

Kolory

Tutaj można indywidualnie dobrać kolor tła oraz pierwszego planu ekranu Tech2. Istnieją dwie najczęściej używane kombinacje kolorów:

Screen with background 0000FF, foreground FFFFFF | Tło bloku klawiszy w kolorze białym; Tło niebieskie; Pierwszy plan w kolorze białym
Screen with background 000000, foreground C0C0C0 | Tło klawiatury niebieskie; Tło w kolorze czarnym; Pierwszy plan w kolorze jasnym szarym

Dźwięk

Tutaj możesz wyłączyć dźwięk. Każdorazowo, gdy program Tech2 uruchomi brzęczyk, użyty zostanie głośnik komputera.


Zapisywanie konfiguracji

Aktywną konfigurację można zapisać naciskając przycisk Zapisz <configuration> w dolnym lewym rogu. Przycisk nie pojawi się przy przeglądaniu konfiguracji przeznaczonej tylko od odczytu.


Ważna licencja za pośrednictwem TIS2Web

Normalnie pobranie oprogramowania Tech2 do Tech2Win zapewni ci ważną licencję. Ponadto można ją uzyskać, wykonując procedurę 'Dostęp do funkcji Bezpieczeństwa (Bezpiecz.)' za pośrednictwem TIS2Web (nie TIS2000). Warunkiem tego jest wybranie wirtualnego portu COM w Konfiguratorze w opcji Interfejs komunikacyjny pojazdu.

Po udanym uzyskaniu bezpiecznego dostępu po prawej stronie paska stanu widoczny jest symbol otwartej kłódki. W nawiasach widoczna jest liczba dni ważności licencji. Po ponownym uruchomieniu Tech2Win wskaźnik zabezpieczenia nie jest wyświetlany, jeżeli nie ma miejsca komunikacja z pojazdem. Podczas pierwszej komunikacji z pojazdem zostanie sprawdzona licencja i wskaźnik zmieni się w otwartą lub zamkniętą kłódkę.

  • Obsługa Tech2Win:Bezpieczeństwo
  • FAQ:W jaki sposób mogę określić, którego portu COM mogę użyć dla Tech2Win?
  • FAQ:Komunikacja między Tech2Win a TIS2Web
  • FAQ:Ważna licencja
  • FAQ:Jaka jest różnica między licencją Tech2Win a dostępem zabezpieczonym?


Obsługa Tech2Win

Większość techników pracujących z Tech2Win korzysta z następujących nagłówków:

  • Menu: Widok ekranu i poszczególne pozycje menu.
  • Pobieranie obrazu PCMCIA: Aktualizacja oprogramowania diagnostycznego Tech2Win jest bardzo podobna do metody stosowanej w Tech2.
  • Bezpieczeństwo: Tech2Win posiada zabezpieczenia uniemożliwiające nawiązanie komunikacji z pojazdem w środowiskach nie posiadających autoryzacji.
  • Przeglądanie raportów: Tech2Win ma nieco ulepszoną klawiaturę Tech2. Przycisk 'Przeglądanie raportów' jest najbardziej widocznym przykładem.
  • Obsługa obrazów PCMCIA: Podobnie, jak w przypadku kilku kart PCMCIA do Tech2, w Tech2Win można korzystać z wielu obrazów PCMCIA.
  • Pasek stanu: Pasek stanu informuje użytkownika o poszczególnych elementach pasku stanu.
    • Nagłówki zaawansowane
    • FAQ


Menu

Aplikacja Tech2Win posiada następujące pozycje menu:

  • Plik
  • Opcje
  • Okna
  • Pomoc

Plik

Menu Plik oferuje następujące możliwości:

  • Zapisz ekran T2 (320x240) służy do zapisywania aktualnego ekranu T2 na komputerze PC w postaci pliku zawierającego czarno-biały obraz o rozmiarze 320x240 pikseli. Miejsce przechowywania i format pliku (BMP, GIF, JPG, PNG) można wybrać samodzielnie.
  • Drukuj ekran tworzy negatyw ekranu Tech2 (czarny kolor na białym tle) w postaci obrazu BMP i wywołuje program przypisany do plików w formacie BMP. Program ten można następnie wykorzystać do wydrukowania tego obrazu.
  • Przeglądaj pliki raportów umożliwia przeglądanie (i drukowanie) plików raportów bez użycia TIS2Web.
  • Exit służy do zamykania Tech2Win.

Opcje

Opcje zawiera następujące opcje:

  • Rozdzielczość służy do wyboru jednego z trzech standardowych rozmiarów ekranu.
  • ROM-Write from 0x00003ED76 służy do wykonywania wewnętrznych procedur debugowania.
  • Automatyczne zrzuty ekranowe służy do zapisu obrazu każdego odmiennego ekranu Tech2 w katalogu dziennika.
  • Wyłącz CANdi i uruchom ponownie służy do emulacji Tech2, który nie ma CANdi między sobą a pojazdem. Jest to konieczne w rzadkich przypadkach, w których CANdi przerywa działanie niestandardowych linii komunikacyjnych pojazdu.

Okna

Menu Okna umożliwia aktywowanie opcji Wyświetlanie danych Tech2Win i Wyświetlanie kodów DTC Tech2Win. W bieżącej wersji Tech2Win wszystkie inne opcje są nieaktywne.

Jeśli program Tech2 obsługuje Wyświetlanie danych Tech2Win, możesz włączyć tę pozycję menu. Po wybraniu opcji Data Display Tech2Win wyświetla dodatkowe okno danych równoległe do okna Tech2 Data Display. Dopóki ekran Tech2 wyświetla Data Display, nie można włączyć pozycji menu. W takim przypadku musisz wyjść z trybu Data Display, włączyć pozycję menu i ponownie uruchomić Data Display.

Takie same ograniczenia jak dla Wyświetlanie danych Tech2Win obowiązują również dla Wyświetlanie kodów DTC Tech2Win. Jeśli program Tech2 obsługuje Wyświetlanie kodów DTC Tech2Win, możesz włączyć tę pozycję menu. Równolegle do Tech2 DTC Display pojawi się dodatkowe okno DTC Display. Dopóki ekran Tech2 wyświetla DTC Display, nie można włączyć pozycji menu. W takim przypadku musisz wyjść z trybu DTC Display, włączyć pozycję menu i ponownie uruchomić DTC Display.

Pomoc

Dostępne są następujące opcje:

  • Tematy pomocy... wyświetla system pomocy Tech2Win.
  • Parametr wiersza polecenia wyświetla parametry wiersza polecenia używane dla Tech2Win.
  • Okno O przedstawia bieżący numer wersji i ograniczenia systemu Tech2Win związane z pobraniem TIS2Web.


Pobieranie danych

Najpierw należy uruchomić Tech2Win i pozostawić go na głównym ekranie. Uruchom TIS2Web lub GlobalTIS i przeprowadź operację pobierania za pośrednictwem portu COM zdefiniowanego na karcie Interfejs komunikacyjny pojazdu.

Można użyć zintegrowanych portów COM do pobrania oprogramowania Tech2 z innego komputera obsługującego TIS. Należy używać przewodu dwużyłowego RS232. W zależności od osprzętu komputera obsługującego Tech2Win, może być konieczne ograniczenie szybkości przesyłu danych do 57.600 bodów, ponieważ przy wyższej szybkości transmisji danych w bodach Windows może gubić dane.

Najnowsza wersja Tech2Win umożliwia również szybkie pobieranie, gdy TIS2Web i Tech2Win działają na tym samym komputerze. Wciąż przesyłana jest minimalna ilość danych między TIS2Web i Tech2Win przez port COM, ale czasochłonny transfer danych do Tech2Win został zastąpiony wewnętrznym transferem plików. W takiej sytuacji czas pobierania jest znacznie krótszy i wynosi dużo mniej niż minutę.

  • Nagłówki zaawansowane: Plik konfiguracyjny
  • Pierwsze kroki: Interfejs komunikacyjny pojazdu
  • FAQ: W jaki sposób mogę określić, którego portu COM mogę użyć dla Tech2Win?
  • FAQ: Komunikacja między Tech2Win a TIS2Web


Bezpieczeństwo

Mechanizmy zabezpieczeń wykorzystywane przez Tech2Win wymagają prawidłowego ustawienia zegara komputera PC. Zadbaj o to, by zegar twojego komputera PC był zawsze prawidłowo nastawiony. Niewielkie zmiany godziny, jakie mogą wystąpić przy przechodzeniu na czas letni lub zimowy, są tolerowane przez Tech2Win.

Tech2Win nie nawiąże żadnej komunikacji z pojazdem bez ważnej i aktywnej licencji. Poniższy wskaźnik w pasku stanu pokazuje, jaki jest status licencji:

  • green smiley Licencja jest ważna.
  • Brak wskaźnika: Licencja nie została jeszcze sprawdzona.
  • red smiley Licencja wygasła.

W celu uzyskania licencji wykonaj procedurę aktualizacji 'Dostęp do funkcji Bezpieczeństwa (Bezpiecz.)', korzystając z aplikacji TIS2Web. W większości przypadków pobranie oprogramowania za pośrednictwem TIS2Web będzie również wystarczające do uzyskania nowej licencji. Ponieważ licencja utraci ważność po upływie pewnego okresu (w niektórych regionach: cztery tygodnie), musisz przeprowadzać taką aktualizację w regularnych odstępach czasu.

Licencje są przypisane do regionu/oprogramowania. Możesz posiadać licencje na swoim komputerze, jeżeli używasz Tech2Win z różnymi wersjami oprogramowania Tech2.

Liczba dni pozostałych do wygaśnięcia licencji jest pokazywana na pasku stanu.

  • (0) oznacza, że licencja wygasła lub nie istnieje.
  • (<1) oznacza, że licencja wygaśnie w ciągu najbliższych 24 godzin.
  • (20) oznacza, że licencja wygaśnie za 20 dni.

Nie manipuluj przy pliku licencji. Nielegalne modyfikacje tego pliku są wykrywane przez wewnętrzne zabezpieczenia i spowodują utratę licencji na danym komputerze. Ponadto Tech2Win będzie się zachowywać w nieprzewidywalny sposób. Można temu zaradzić wyłączone poprzez przeprowadzenie nowej instalacji.

  • Nagłówki zaawansowane: Komunikaty o błędach i kody wyjścia
  • Nagłówki zaawansowane: Plik logowania
  • Obsługa Tech2Win: Okno stanu
  • FAQ: Ważna licencja
  • FAQ: Jaka jest różnica między licencją Tech2Win a dostępem zabezpieczonym?
  • FAQ: Nagłe wyłączenie


Przeglądanie raportów

View Report Tego przycisku można używać do przeglądania zawartości plików PRT obecnych na karcie PCMCIA. Otworzy się okno dialogowe z listą plików PRT. Jeżeli z rozszerzeniem PRT został powiązany jakiś program, uruchomiony zostanie program powiązany. W przeciwnym razie otworzy się edytor Notatnika w celu wskazania wybranego pliku.

W większości przypadków plik PRT jest plikiem ASCII, używającym stron językowych lub kodowych. W chińskiej, japońskiej, koreańskiej i tajskiej wersji językowej plik ma format unicode z zarządzającym znacznikiem porządku bajtów (BOM).

Podczas wyświetlania raportów Tech2Win korzysta z podkatalogu C:\Users\Public\General Motors\Tech2Win\reports. Ten katalog podrzędny zostanie utworzony tylko w przypadku co najmniej jednorazowego podglądu raportów. Katalog jest kasowany automatycznie i funkcjonuje jako tymczasowy katalog roboczy dla plików PRT na aktywnej karcie PCMCIA. Te pliki będą tam nadal przechowywane nawet, jeżeli Tech2Win przestanie działać. W celu zapisania tego typu pliku trzeba skopiować go do innego katalogu, ponieważ plik może zostać nadpisany, jak tylko inny użytkownik zacznie przeglądać raporty.


Obrazy PCMCIA

Zazwyczaj obrazy PCMCIA znajdują się w podkatalogu C:\Users\Public\General Motors\Tech2Win\pcmcia. Plik musi mieć rozmiar dokładnie 32MB (33,554,432 bajtów) lub 10MB (10,485,760 bajtów) i rozszerzenie pliku *.bin. Obrazy zostaną zmodyfikowane (tak samo jak każda standardowa karta PCMCIA) w przypadku poboru danych lub, gdy Tech2Win dokona zapisu na karcie błyskowej. Modyfikację można dezaktywować używając przełącznika zabezpieczenia przed zapisem (polecenie nasterowania -W0 lub -W1) lub omijając wartość 'p' w opcji 'W'.(Plik konfiguracyjny). Przełącznik zabezpieczający przed zapisem nie jest dostępny z poziomu konfiguratora. Chcąc użyć opcji '-W0', '-W1' lub '-W', należy ręcznie zmodyfikować plik konfiguracji.


Pasek stanu

Pasek stanu jest wyświetlany poniżej ekranu Tech2. Na pasku stanu wskazywane są następujące pozycje:

  1. Wskaźnik szybkości
  2. Status komunikacji z pojazdem
  3. Status portu szeregowego
  4. Klawisz SHIFT
  5. Automatyczne zrzuty ekranowe
  6. Ostrzeżenie logowania
  7. Licencja

Status Bar

Wskaźnik szybkości

Wskaźnik szybkości pokazuje, ile czasu jednostce centralnej komputera zajęła emulacja oprogramowania Tech2. Niska wartość (wskaźnik z lewej strony) jest lepsza od wartości wysokiej (wskaźnik z prawej strony). Dopuszczalny jest kolor zielony wskaźnika. Wskaźnik może na krótko zmienić kolor na żółty po aktywacji innego zadania Windows. Należy unikać tego rodzaju sytuacji.

Status komunikacji z pojazdem

Stan komunikacji pojazdu wskazuje, czy obecny jest interfejs komunikacyjny pojazdu (MDI) i czy występuje komunikacja między pojazdem a Tech2Win.

Status portu szeregowego

Przy komunikacji z Tech2Win przez port COM, ten wskaźnik pokazuje, czy komunikacja na porcie COM jest aktywna, czy nie.

Klawisz SHIFT

Ten wskaźnik określa, czy klawisz SHIFT jest aktywny. Można go przełączać za pomocą klawisza 'S' na klawiaturze lub klawisza SHIFT na klawiaturze numerycznej.

Automatyczne zrzuty ekranowe

Funkcję automatycznych zrzutów ekranowych można włączyć w menu Opcje. Za każdym razem, gdy zmienia się ekran, w katalogu dziennika zostaje zapisany nowy plik ze zrzutem ekranowym. Jest to sygnalizowane obróceniem się uchwytu korbki czerwonej kamery na pasku stanu. Kamera ta znika, gdy tylko funkcja automatycznych zrzutów ekranowych zostanie wyłączona.

Ostrzeżenie logowania

Wskaźnik statusu dziennika może przybierać trzy różne stany.

  • gray log status indicator Plik dziennika nie zawiera żadnych ostrzeżeń lub błędów.
  • yellow log status indicator Plik dziennika zawiera komunikat ostrzegawczy.
  • red log status indicator Plik dziennika zawiera komunikat o błędzie.

Licencja

Wskaźnik licencji może przybierać trzy stany:

  • green smiley Licencja jest aktywna i ważna.
  • Brak wskaźnika: Licencja nie została jeszcze sprawdzona.
  • red smiley Licencja wygasła lub nie istnieje.
Więcej informacji można znaleźć pod łączem Bezpieczeństwo.

Etykietki narzędzi na pasku stanu

Dla niektórych ikon wyświetlane są etykietki narzędzi, które zawierają pewne dodatkowe informacje:

Etykietka narzędzia dla numeru seryjnego VCI:
Tooltip VCI

Etykietka narzędzia dla wersji oprogramowania TECH2
Tooltip TECH2

Etykietka narzędzia dla portu COM
Tooltip Comport

Etykietka narzędzia dla numeru następnego zrzutu ekranowego (jeśli opcja 'Automatyczne zrzuty ekranowe' jest aktywna)
Tooltip Camera

Etykietka narzędzia pokazująca ostatni wpis w pliku dziennika, który ma poziom 'Ostrzeżenie' lub wyższy
Tooltip Logfile

Etykietka narzędzia dla dokładnego czasu trwania licencji
Tooltip License

Etykietki narzędzi są wyświetlane, jeżeli kursor pozostanie nieruchomy na ikonie przez dłużej niż 0,5 sekundy. Etykietki narzędzi znikają po upływie 5 sekund lub gdy kursor zostanie przesunięty.

  • Nagłówki zaawansowane: Komunikaty o błędach i kody błędów
  • Nagłówki zaawansowane: Plik logowania


Nagłówki zaawansowane

Omówione tutaj tematy mają mniejsze znaczenie dla standardowego użytkownika Tech2Win. Niniejsze informacje mogą okazać się użyteczne dla osób zajmujących się ustawieniami, zarządzaniem oraz konfiguracją Tech2Win.

  • Ponowna instalacja
  • Odinstalowanie
  • Bezpośrednia modyfikacja plików konfiguracyjnych
  • Plik logowania
  • Komunikaty o błędach i kody wyjścia
  • Karta ATA
  • Wpisy rejestru
  • Opis pliku
  • Przykłady zarządzania konfiguracją


Odinstalowanie

Pełny katalog instalacji, katalog zawierający dane użytkowników (C:\Users\Public\General Motors\Tech2Win) i katalog zawierający dane aplikacji (C:\ProgramData\General Motors\Tech2Win) są usuwane.

  • Nagłówki zaawansowane: Ponowna instalacja
  • Instalacja


Plik konfiguracyjny

Pliki konfiguracji zawsze znajdują się w podkatalogu C:\Users\Public\General Motors\Tech2Win\config i mają rozszerzenie *.conf. Istnieje w razie potrzeby możliwość manualnej modyfikacji pliku konfiguracyjnego, ponieważ nie wszystkie opcje pliku są dostępne poprzez Tech2Win. Plik konfiguracyjny jest plikiem Unicode z zarządzającym znacznikiem porządku bajtów (BOM). Zdecydowanie sugerujemy, aby do manualnego wprowadzania zmian używać edytora obsługującego format Unicode, przykładowo Notatnika.

Plik konfiguracyjny jest wierszowany. Puste rzędy są ignorowane. Poszczególne rzędy wierszy zaczynają się od opcji, po której w większości jest wprowadzona wartość. Jako przykład można obejrzeć plik default.com. Przy omawianiu wszystkich dostępnych opcji prosimy opierać się na zamieszczonej poniżej tabeli.

Chcąc uruchamiać określoną konfigurację bezpośrednio z pulpitu, należy utworzyć skrót służący do wykonywania polecenia 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe -OF ..\config\plik_konfiguracji.conf'. Program powinien być uruchamiany z następującego katalogu roboczego: „C:\Program Files\General Motors\Tech2Win\bin”'

opcja | Wartość / Znaczenie
; Komentarz
@ Numer wersji w dziesiętnych w formacie główny.dodatkowy.
Pliki konfiguracyjne z numerami głównymi innymi od Tech2Win nie będą akceptowane. Pliki konfiguracyjne z numerami dodatkowymi niższymi od Tech2Win będą akceptowane.
-W0
-W1 		Karta PCMCIA w gnieździe 0/1 posiada aktywowany włącznik zabezpieczenia przed zapisem.
-B0
-B1 		Rozmiar bloku w kilobajtach karty PCMCIA w gnieździe 0/1. Akceptowane wartości to 128 (domyślna) lub 256.
-P0
-P1 		Plik zawierający obraz binarny karty PCMCIA w gnieździe 0/1. Rozmiar pliku musi wynosić dokładnie 10MB lub 32MB. Zmienne środowiskowe takie jak %ProgramData% są rozwinięte.
Jeżeli ta opcja nie występuje, zakłada się, że gniazdo jest puste.
-A0
-A1 		Plik zawierający wartości atrybutów karty PCMCIA w gnieździe 0/1. Jeżeli nie występuje, zostaną użyte atrybuty domyślne w oparciu o rozmiar karty i bloku.
-W | Po wyjściu z Tech2Win, wszystkie dane trwałe zostaną zapisane w ich właściwych plikach. Wartości p/f/r/c można łączyć w celu oznaczenia kolejno PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | Funkcja zarządzania stosem Wartości 0/r/w/t można łączyć ze sobą w celu aktywacji odpowiednio funkcji zerowania, kontroli odczytu, kontroli zapisu i kontroli zadań. Wartość I jest wykorzystywana zawsze do wymuszenia alokacji stosu pamięci na niższych adresach, ponieważ stosowana jest metoda alokacji naprzemiennej. Normalnie opcja ta jest używana tylko w środowisku programowania.
-PC | Dawniej ścieżka dostępu do kopii karty PCMCIA. Obecnie ta opcja jest ignorowana.
-MS | Identyfikacja interfejsu komunikacyjnego pojazdu (MDI) za pomocą numeru seryjnego. Jeżeli nie jest ustawiony, zostanie zaprezentowana lista dostępnych MDI.
-CT | Kolor tekstu (na pierwszym planie) w 3 wartościach szesnastobitowych. Wartość standardowa wynosi 000000 (biały).
-CB | Kolor tła w 3 wartościach szesnastobitowych. Wartość standardowa wynosi FFFFFF (czarny).
-ATA | Użyj tej opcji, by włączyć kartę przechwytującą ATA. Usuń ją, by wyłączyć kartę przechwytującą ATA.
-C | Numer portu COM (1..9) do użycia jako port komunikacyjny RS232C Tech2. COM9 jest często używany pod wirtualny port COM, instalowany przez Tech2Win. Jeżeli ta opcja nie jest dostępna, to zostaje przeprowadzone wyszukiwanie wolnego portu COM, począwszy od COM9 w dół. Skorzystaj z podpowiedzi na pasku stanu między ikoną Tech2 a ikoną TIS2Web, aby zobaczyć, który port COM jest używany.
-WR | Adres PC (zwykle 253558), który ma prawo do zapisu w obszarze PCMCIA i FLASH ROM. Tę funkcję należy dodatkowo aktywować w menu (lub za pomocą opcji -WA). Konieczne jest debugowanie kodu w pamięci niemodyfikowalnej metodą pojedynczych instrukcji (SingleStep Debugger).
-WA | Zezwalaj debugerowi SingleStep Debugger na zapis w pamięci niemodyfikowalnej.
-OF | Plik opcji zawierający pary opcja/wartość.
-TP | Regulacja taktowania (Wartość proporcjonalna). Wartość standardowa to 5000. Zmniejsz tę wartość, aby liczba wykonanych cykli szybciej dostosowywała się do czasu rzeczywistego.
-TD | Regulacja taktowania (Wartość różnicowa). Wartość standardowa to 100. Zmniejsz tę wartość, aby reagować szybciej na zmiany taktowania chwilowego. OSTRZEŻENIE: Manipulowanie przy wartościach TP i TD może doprowadzić do problemów z szybkością.
-PJ
-PP 		Podaj protokół, który powinien zostać użyty:
PJ dla komunikacji J2534.
PP dla ISO22900-2 / PDU-API (wartość standardowa)
-S | Występowanie tej opcji umożliwia wyjście dźwięku na brzęczyku komputera.
-L | Wersja językowa aplikacji Tech2Win. W przypadku braku tej pozycji, jako język domyślny zostaje użyty język systemu Windows. Do podglądu listy dostępnych wersji językowych służy następujące łącze: Język. Okno emulacji Tech2 samo wyświetli język znajdujący się na karcie PCMCIA (tzn. załadowany na kartę PCMCIA).
-UD | Zastąp katalog danych użytkownika. W systemie Windows 7 ścieżka do tego katalogu to zazwyczaj C:\Users\Public\General Motors\Tech2Win
-AD | Zastąp katalog danych aplikacji. W systemie Windows 7 ścieżka do tego katalogu to zazwyczaj C:\ProgramData\General Motors\Tech2Win
-US | Użyj wskaźnika związanego z użytkownikiem do wykrywania więcej niż jednego wystąpienia Tech2Win. Ta opcja umożliwia każdemu użytkownikowi uruchomienie Tech2Win równolegle na tym samym komputerze, najczęściej na serwerze. W przypadku użycia tej opcji należy również określić opcje -UD i -AD.
-SS | Opcja umożliwiająca określenie całkowitego rozmiaru okna Tech2Win łącznie z klawiaturą numeryczną (jeśli występuje). Pierwszy parametr musi być ciągiem znaków umieszczonym w cudzysłowie podwójnym (') i będzie używany jako nazwa rozmiaru w menu Opcje / Rozdzielczość. Drugi parametr określa całkowitą liczbę pikseli poziomych ekranu Tech2Win łącznie z klawiaturą numeryczną. Trzeci parametr określa całkowitą liczbę pikseli pionowych ekranu Tech2Win. Czwarty opcjonalny parametr określa szerokość klawiatury numerycznej w pikselach.
-SH Opcja sterująca obsługą ekranu. Poniższe wartości dziesiętne umożliwiają określenie, które funkcje obsługi ekranu należy wyłączyć.
  • Bit 0: Bez wartości minimalnej/maksymalnej.
  • Bit 1: Bez zmiany położenia na ekranie.
  • Bit 2: Bez zmiany rozmiaru. W takim przypadku menu Opcje / Rozdzielczość jest nieaktywne.
  • Bit 3: Okna wyświetlania danych i DTC mają mieć dokładnie taki sam rozmiar jak Tech2Win (bez klawiatury numerycznej)


Logowanie

Przy każdym uruchomieniu konfiguracji programu Tech2Win w podkatalogu C:\Users\Public\General Motors\Tech2Win\Logs zostaje utworzony nowy plik dziennika w formacie HTML. Aby uniknąć nadmiernego zapełnienia twardego dysku, pliki dziennika starsze niż jeden tydzień są usuwane.

Pliki logowania są automatycznie nazywane bieżącą datą (rok, miesiąc, dzień) i czasem (godzina, minuta, sekunda) ich utworzenia:
rrrr-mm-dd_ggmmss.html

Wpisy pliku logowania są zawsze w języku angielskim, ale w formacie Unicode z zarządzającym znacznikiem porządku bajtów (BOM). Każdy rząd wierszy w pliku logowania opisuje jeden z poniższych poziomów logowania:

Poziom logowania | Znaczenie
Info | Tylko informacja. Brak wpływu na działanie programu.
Uwaga | Wystąpiła niezwykła sytuacja. Użytkownik może nie zauważyć żadnych niepomyślnych efektów.
ERROR | Wystąpił błąd, który zostanie zauważony przez użytkownika.
CRITICAL | Wystąpił błąd krytyczny, który spowoduje niezwykłe zachowanie programu.
FATAL | Wystąpił poważny błąd, który spowoduje natychmiastowe przerwanie działania Tech2Win.

Wszystkie poziomy powyżej 'Ostrzeżenia' są oznaczone kolorami, aby ułatwić ich znalezienie.

Ponadto w podkatalogu Logs będą również obecne pliku drukowania i wideo, jeżeli była używana opcja Drukuj ekran lub Automatyczne zrzuty ekranowe.
rrrr-mm-dd_ggmmss_print_nnnnn.bmp
rrrr-mm-dd_ggmmss_video_nnnnn.png
Ilustracje typu Automatyczne zrzuty ekranowe są powiązane w pliku HTML – aby obejrzeć kolejność tych ilustracji, należy zatem skorzystać z dziennika HTML.

Użytkownik zostanie poinformowany na pasku Stanu o pojawieniu się zapisu Uwaga ( yellow lightning bolt) lub bardziej poważnego zapisu logowania ( red lightning bolt).


Komunikaty o błędach i kody wyjścia

Komunikaty o błędach mogą pojawiać się w oknach dialogowych. Te okna dialogowe nadal umożliwiają Tech2Win równoległe wykonywanie operacji programu Tech2. Kody wyjścia są błędami krytycznymi, uniemożliwiającymi kontynuację programu, które powodują nieprawidłowe zakończenie działania Tech2Win. Kody wyjścia mogą służyć w plikach wsadowych do wykrywania przyczyny zakończenia działania programu.

Komunikaty o błędach

Mogą pojawić się następujące komunikaty o błędach. Poniżej zamieszczono krótkie objaśnienie sytuacji oraz sposobu rozwiązania problemu.

Emulator too slow Emulator failed to start

Kody wyjścia

Kod wyjścia | Wartość | Znaczenie
OPCODE_ERROR | -7 | Wykryto nieważne polecenie mikroprocesora Tech2 (68332). Być może obraz PCMCIA został w jakiś sposób zakłócony.
ATA_PROBLEM | -6 | Wystąpił problem w trakcie emulacji ATA. Jeżeli problem ten wystąpi po wcześniejszym poleceniu użycia karty ATA, prosimy o kontakt z infolinią wsparcia technicznego.
DEMO_TIME_IS_UP | -5 | Nie powinno pojawiać się w oficjalnej wersji Tech2Win.
DLL_NOT_LOADED | -3 | Jedna z niezbędnych bibliotek dołączanych dynamicznie (DLL) mogła nie zostać załadowana. Posiadana kopia Tech2Win może być niekompletna. Prosimy wykonać nową instalację i/lub wybrać inną wersję językową.
EXIT_INIT_FAILED | -2 | Nieudana inicjalizacja. Sprawdź plik logowania, aby znaleźć dokładną przyczynę. Jeżeli plik logowania nie występuje, prosimy sprawdzić, czy posiadany dostęp do odczytu/zapisu we wszystkich katalogach jest prawidłowy.
normalny | 0 | Tech2Win został zamknięty normalnie.


Karta ATA

Karta ATA w Tech2 służy generalnie tylko do celów usuwania błędów programowych w trakcie opracowywania oprogramowania. Wszystkie potrzebne dane ATA są przechowywane w podkatalogu C:\Users\Public\General Motors\Tech2Win\ataCapture. Ten katalog zwykle jest bez znaczenia i można go bezpiecznie usunąć, chyba że specjalne instrukcje zalecą inaczej.

Ponieważ ataCapture jest katalogiem stałym, jego zawartość będzie taka sama we wszystkich konfiguracjach.


Pliki

Tech2Win korzysta z następujących plików i katalogów:

Katalog | Lokalizacja przed systemem Vista | Lokalizacja w systemie Vista i nowszych
Instalacja | Zgodnie z ustawieniem określonym podczas instalacji
Dane użytkowników | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Dane aplikacji | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Plik | Roboczy
[Dane użytkowników]\atacapture | Zawiera ona pliki obecne na karcie ATA. O ile instrukcja nie będzie inna, pliki te są niepotrzebne.
[Instalacja]\bin | Zawiera aktualnie uruchamiane oraz niezbędne DLL, jak również obrazy potrzebne do uruchomienia.
[Instalacja]\bin\emulator.exe | Główne uruchomienie z kodem Tech2.
[Instalacja]\bin\emulator_xx_XX.dll | DLL z zasobami danej wersji językowej.
[Instalacja]\bin\T2Configurator.exe | Część konfiguracyjna programu Tech2Win.
[Instalacja]\bin\Pictures | Zawiera ikony niezbędne dla Tech2Win.
[Dane użytkowników]\config | Zawiera wszystkie pliki konfiguracji.
[Dane użytkowników]\data | Zawiera pliki, które są modyfikowane w trakcie działania Tech2Win. Te pliki są niezbędne do prawidłowego działania Tech2Win. Normalnie, nie należy tych plików ruszać, chyba że pojawią się wyraźne instrukcje, aby to zrobić.
[Dane aplikacji]\data | Zawiera pliki, które są modyfikowane w trakcie działania Tech2Win. Te pliki są niezbędne do prawidłowego działania Tech2Win. Normalnie, nie należy tych plików ruszać, chyba że pojawią się wyraźne instrukcje, aby to zrobić.
[Dane aplikacji]\data\emulator.sec | Plik bezpieczeństwa . Nie wolno modyfikować tego pliku.
[Dane aplikacji]\data\emulator.card | Plik kart. Zawiera wszystkie karty PCMCIA znane programowi Tech2Win. Nie wolno modyfikować tego pliku.
[Dane użytkowników]\data\emulator.disp | Ten plik zawiera lokalizację i rozmiar ekranu Tech2Win. W przypadku usunięcia tego pliku, zostanie on utworzony ponownie i ekran Tech2Win uruchomi się w górnym lewym narożniku w rozmiarze 640x480.
[Dane aplikacji]\data\emulator.lic | Plik licencyjny. Zawiera informacje o okresach ważności twoich licencji. Nie wolno modyfikować tego pliku.
[Dane aplikacji]\data\emulator.rtc | Plik zegara czasu rzeczywistego. Ten plik służy do przechowywania danych, znalezionych w RTC Tech2.
[Dane aplikacji]\data\emulator.dta | Plik „Nie informuj mnie ponownie”.. Ten plik przechowuje wersje oprogramowania PCMCIA, które nie powinny (już) wyświetlać ostrzeżenia o braku możliwości wykonania testu samodiagnostycznego wymagającego adaptera do testów zwrotnych.
[Dane aplikacji]\data\candi.bin | Plik aplikacji CANdi. Przechowuje aplikację CANdi, który jest mocowany do Tech2.
[Dane aplikacji]\data\eprom.bin | Plik pamięci wewnętrznej EPROM Tech2. Przechowuje zawartość wewnętrznej pamięci błyskowej Tech2.
[Instalacja]\driver | Pliki instalacyjne sterownika wirtualnego portu COM.
[Instalacja]\help\emulator_xx_XX.chm | Pliki pomocy specyficzne dla języka.
[Dane użytkowników]\Logs | Zawiera pliki dziennika. Pliki starsze niż jeden tydzień będą automatycznie kasowane.
[Dane użytkowników]\pcmcia | Zawiera pliki obrazów PCMCIA. Mówiąc obrazowo, każdy plik odpowiada karcie PCMCIA Tech2. Te pliki można w razie potrzeby zapisać w innych lokalizacjach.


Zarządzanie konfiguracją

Pliki konfiguracji zawsze znajdują się w podkatalogu C:\Users\Public\General Motors\Tech2Win\config i mają rozszerzenie *.conf. Tech2Win można używać wyłącznie do wygenerowania nowych plików konfiguracyjnych lub do modyfikacji istniejących plików konfiguracyjnych, przeznaczonych tylko do odczytu. Do celów innego zarządzania plikami konfiguracyjnymi należy korzystać z programu Windows Explorer lub podobnego programu do obsługi plików. Będzie to konieczne w przypadku następujących czynności:

  • usuwanie plików konfiguracyjnych
  • zmiana nazwy plików konfiguracyjnych
  • zmiana atrybutu tylko do odczytu pliku konfiguracyjnego

Zdecydowanie zalecamy, aby zawsze zachować plik konfiguracyjny default.confg. Ten plik powinien normalnie mieć ustawiony atrybut tylko do odczytu, aby uniknąć niezamierzonego nadpisania. Jednakże, w przypadku zmiany tego pliku w celu dostosowania do Państwa specyficznych potrzeb, konieczne będzie tymczasowe usunięcie atrybutu tylko do odczytu.

Obrazy PCMCIA znajdują się w podkatalogu C:\Users\Public\General Motors\Tech2Win\pcmcia. Każdy z tych plików odpowiada karcie PCMCIA, z którą już się Państwo zapoznali podczas obsługi Tech2. Dzięki Tech2Win mogą Państwo uzyskać dowolną liczbę obrazów. Wystarczy po prostu skopiować istniejący obraz do nowej nazwy pliku.

Chcąc uruchomić określoną konfigurację bezpośrednio z pulpitu, należy utworzyć skrót służący do wykonywania polecenia "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Program powinien być uruchamiany z następującego katalogu roboczego: 'C:\Program Files\General Motors\Tech2Win\bin'

Liczba plików konfiguracyjnych jest niezależna od liczby używanych obrazów pcmcia. Na podstawie tego samego obrazu PCMCIA można uzyskać różne pliki konfiguracyjne. Przypomina to blisko sytuację w warsztacie, gdzie różni mechanicy wspólnie korzystają z tego samego Tech2 (i tej samej karty PCMCIA).

Można również wybrać opcję, gdzie każda konfiguracja korzysta z własnego dedykowanego obrazu PCMCIA. W ten sposób poszczególne konfiguracje będą bardziej niezależne od siebie. Jednakże, wysiłek związany z aktualizacją każdego obrazu PCMCIA może być nie do zaakceptowania.

Gdy nowa konfiguracja jest tworzona przez skopiowanie konfiguracji już istniejącej, a obraz PCMCIA nie zostanie zmieniony, konfigurator wyświetli ostrzeżenie. W takim przypadku powstałyby dwie konfiguracje korzystające z tego samego obrazu PCMCIA. Jeśli jest to zgodne z zamierzeniem, wystarczy nacisnąć OK. Jeśli w nowej konfiguracji ma być używany inny lub nowy obraz PCMCIA, należy nacisnąć Unieważnij. Następnie można zdecydować się na utworzenie nowego obrazu, korzystając z opcji Kopiuj kartę pamięci ....

Poniżej przedstawiono dwie przykładowe metody zarządzania konfiguracjami i obrazami PCMCIA.

Jedna konfiguracja na użytkownika

Możesz zapisać jedną konfigurację na każdego użytkownika. Nazwa konfiguracji może być na przykład taka sama jak nazwa użytkownika. Zaletą tego rozwiązania jest to, że możliwe są indywidualne ustawienia użytkownika, takie jak osobiste interfejsu komunikacyjne pojazdu (MDI) oraz ustawienia ekranu i języka. Niedogodność polega na tym, że konieczne jest wykonanie kopii plików PCMCIA, jeżeli wielu użytkowników ma używać tego samego oprogramowania. Oczywiście w indywidualnych konfiguracjach użytkowników może być używany centralny plik PCMCIA.

Jedna konfiguracja na oprogramowanie Tech2

Można utworzyć nową konfigurację dla każdego pobranego oprogramowania. Dzięki temu również starsze wersje oprogramowania będą w razie potrzeby od razu dostępne. W takim przypadku na nazwę konfiguracji wybiera się często nazwę i numer wersji danego oprogramowania.

  • Pierwsze kroki: Interfejs komunikacyjny pojazdu
  • Pierwsze kroki: Ścieżka
  • Nagłówki zaawansowane: Plik konfiguracyjny
  • Instalacja: Etapy instalacji


Często zadawane pytania (FAQ)

  • W jaki sposób mogę określić, którego portu COM mogę użyć dla Tech2Win?
  • Komunikacja między Tech2Win a TIS2Web
  • Ważna licencja
  • Co oznacza numer licencji?
  • Jaka jest różnica między licencją Tech2Win a dostępem zabezpieczonym?
  • TIS2Web zgłasza nieokreślony błąd w przypadku wykonywania dostępu zabezpieczonego do oprogramowania początkowego
  • Tech2Win nie uruchamia oprogramowania Tech2 z innego obszaru
  • W jaki sposób mogę korzystać z więcej niż jednego MDI?
  • Plik dziennika zawiera błąd 'CPU32: Too many 0000/FFFF Commands encountered'
  • Nie jest widoczne żadne okno Tech2
  • SPS nie działa
  • Niektóre testy samodiagnostyczne nie działają
  • Stan wskaźnika prędkości jest zmienny
  • Nagłe wyłączenie
  • Dla oprogramowania 15.001 wyświetlany jest język szwedzki
  • Utrata komunikacji z MDI
  • Tech2Win nie znalazł mojego MDI
  • Chcę od razu uruchomić Tech2Win bez zajmowania się konfiguratorem
  • Gdzie znajdują się funkcje drukowania?
  • Na moim komputerze występuje „nieużywany” folder PCMCIA
  • Wyświetla się komunikat „niedozwolona ścieżka pliku”

W jaki sposób mogę określić, którego portu COM mogę użyć dla Tech2Win?

Możesz użyć programu 'Menedżer urządzeń' systemu Windows, poszukaj opcji 'Porty (COM i LPT)'. Niektóre komputery mają jednak zainstalowane modemy wewnętrzne lub urządzenia Bluetooth, które nie są pokazywane w tej kategorii.
Innym sposobem jest użycie krótkiego polecenia, które jest dostarczane razem z konfiguratorem. Możesz je uruchomić w menu Start (folder Tech2Win), klikając opcję 'show com ports'.
Obie metody pokazują porty COM, które są zainstalowane w twoim komputerze i których NIE powinieneś używać.

Komunikacja między Tech2Win a TIS2Web

Ważne jest, aby Tech2Win został uruchomiony przed nawiązaniem komunikacji z TIS2Web w celu uzyskania bezpiecznego dostępu lub pobrania oprogramowania. TIS2Web jest w stanie rozpoznać wirtualny port COM tylko wtedy, gdy Tech2Win jest uruchomiony.

Ważna licencja

Normalnie pobranie oprogramowania z TIS2Web zapewni ci już ważną licencję. Jeżeli nadal nie masz licencji, to w celu uzyskania ważnej licencji konieczne jest wykonanie procedury 'Dostęp do funkcji Bezpieczeństwa (Bezpiecz.)' za pośrednictwem TIS2Web (nie TIS2000). Przed uzyskaniem licencji za pośrednictwem procedury 'Dostęp do funkcji Bezpieczeństwa (Bezpiecz.)' nie wykorzystuj żadnej innej funkcji komunikacji TIS2Web z Tech2Win, na przykład 'Ładowanie oprogramowania (SWDL)'.

Co oznacza numer licencji?

Numer licencji po prawej stronie paska stanu pokazuje liczbę pełnych dni ważności licencji. Bezpośrednio po zakończeniu pobierania lub uzyskaniu bezpiecznego dostępu wyświetlana jest liczba 30 dni. Jednak po ponownym uruchomieniu Tech2Win wyświetlana jest liczba 29, ponieważ okres ważności licencji wynosi prawdopodobnie przykładowo 29 dni, 23 godziny i 55 minut. Jeżeli liczba dni ważności licencji spadnie poniżej 24 godzin, wyświetlany będzie okres ważności licencji <1. Po wygaśnięciu licencji wyświetlane jest 0.

Jaka jest różnica między licencją Tech2Win a dostępem zabezpieczonym?

Licencja Tech2Win umożliwia korzystanie z Tech2Win. Aby uzyskać taką licencję, trzeba przeprowadzać pobieranie oprogramowania lub uzyskiwać dostęp zabezpieczony w regularnych odstępach czasu (najczęściej: co 30 dni). Możliwość przeprowadzenia takiej operacji pobrania za pośrednictwem TIS2Web informuje Tech2Win, że istnieje uprawniony użytkownik. Dostęp zabezpieczony, w postaci znanej z Tech2, informuje Tech2Win, że pewne działania związane z bezpieczeństwem, takie jak wyłączenie poduszki powietrznej, są dozwolone. Zarówno licencja Tech2Win, jak i dostęp zabezpieczony, mogą być realizowane za pośrednictwem aplikacji TIS2Web Security Access. Tech2Win wyświetla pozostały czas ważności licencji na pasku stanu po prawej stronie. Tech2Win nie może niestety wyświetlić czasu trwania dostępu zabezpieczonego, ponieważ Tech2Win po prostu emuluje oprogramowanie Tech2, ale nie potrafi go interpretować.

TIS2Web zgłasza nieokreślony błąd w przypadku wykonywania dostępu zabezpieczonego do oprogramowania początkowego

Postępowanie jest takie same jak w Tech2. Ze względu na swój wiek oprogramowanie początkowe nie jest w stanie uzyskać licencji z TIS2Web. Jednak w rzeczywistości nie jest to problemem, ponieważ oprogramowanie pokazowe nie komunikuje się z pojazdem, dla którego potrzebna jest licencja. A ponieważ licencje są związane z pobraniami TS2Web, po pobraniu oprogramowania Tech2 i tak konieczne byłoby uzyskanie licencji dla każdego pobrania. „Licencja” na oprogramowanie początkowe nie uprawniałaby użytkownika do komunikowania się z pojazdem za pomocą oprogramowania North American Operations lub Opel/Vauxhall.

Tech2Win nie uruchamia oprogramowania Tech2 z innego obszaru

Posiadana wersja Tech2Win jest prawdopodobnie ograniczona do jednego lub kilku pobrań TIS2Web (regiony). Naciśnij Pomoc / O, aby sprawdzić, jakie ograniczenia odnoszą się do danej wersji Tech2Win. Pierwsze wersje Tech2Win umożliwiały uruchamianie tylko oprogramowania Opel/Vauxhall. Niedługo będzie to dotyczyć innych regionów GM. W każdym razie, Tech2Win jest obecnie w stanie uruchomić oprogramowanie Tech2 dostarczane przez General Motors.

W jaki sposób mogę korzystać z więcej niż jednego MDI?

Jeżeli chcesz przypisać konkretne MDI konkretnym użytkownikom, proponujemy, aby przydzielić każdemu z użytkowników własną konfigurację. Konfiguracje te powinny być oczywiście nazwane w sposób umożliwiający identyfikację danego użytkownika. W każdej z konfiguracji na karcie 'Interfejs komunikacyjny pojazdu' należy podać numer seryjny MDI przydzielonego danemu użytkownikowi. W momencie uruchomienia konfiguracji przez jej użytkownika Tech2Win podejmie próbę skontaktowania się z danym MDI. Jedynie w przypadku, gdy dany MDI nie będzie obecny, pojawi się okno wyboru zawierające wszystkie MDI, które zostały znalezione przez Tech2Win.

Jeżeli posiadasz większą liczbę MDI do wspólnego użytku, proponujemy korzystanie z konfiguracji, w których numer seryjny interfejsu komunikacyjnego pojazdu na karcie 'Interfejs komunikacyjny pojazdu' jest pozostawiony pusty. Wtedy użytkownik zawsze zobaczy okno wyboru z dostępnymi MDI.

Plik dziennika zawiera błąd 'CPU32: Too many 0000/FFFF Commands encountered'

Plik 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' lub aktualny plik PCMCIA jest uszkodzony. Przeprowadź ponowną instalację Tech2Win i pobierz nowe oprogramowanie Tech2.

Nie jest widoczne żadne okno Tech2

Jeżeli nie jest widoczne żadne okno Tech2, znajduje się ono prawdopodobnie na obszarze nieobjętym aktualnie zasięgiem ekranu. Tego rodzaju objawy występują w przypadku korzystania z więcej niż jednego ekranu lub po zmianie rozdzielczości ekranu. Naciśnij klawisz Shift na klawiaturze podczas uruchamiania twojej konfiguracji. W takim przypadku rozdzielczość okna zostanie przywrócona do wartości 640x480 i okno Tech2 zostanie wyświetlone w lewym górnym rogu ekranu. Ten sam skutek można osiągnąć, usuwając plik C:\Users\Public\General Motors\Tech2Win\emulator.disp.

Znane są nam przypadki, w których okno Tech2 nie było odświeżane na ekranie po zamknięciu okien wszystkich innych aplikacji. We wszystkich znanych nam dotąd przypadkach, skorzystanie z kombinacji klawiszy Alt-Tab do przełączenia się między aplikacjami Windows pozwalało wyświetlić ekran Tech2. Kliknięcie przycisku Tech2Win na pasku zadań w dolnej części ekranu komputera PC czasami nie działało. Obecnie nadal badamy ten problem i mamy nadzieję, że w jednej z kolejnych wersji Tech2Win zostanie on naprawiony.

SPS nie działa

Tak, wiemy o tym. Nie planujemy tego zmieniać. Nie powinieneś używać Tech2Win w miejsce Tech2 do wykonywania SPS. MDI należy używać bezpośrednio z programowaniem SPS za pośrednictwem TIS.

Niektóre testy samodiagnostyczne nie działają

Testy samodiagnostyczne Tech2 mają za zadanie sprawdzić poszczególne elementy sprzętu Tech2. Niektóre z tych testów wymagają użycia adaptera do testów zwrotnych. Testy te nie będą działać w Tech2Win, ponieważ funkcja adaptera do testów zwrotnych nie została w nim zaimplementowana (i nie jest planowane jej wprowadzenie). Należy po prostu powstrzymać się od wykonywania w Tech2Win takich nic niedających testów. W przypadku wykonania takiego testu możliwe jest uzyskanie błędnego wyniku lub zawieszenie się Tech2Win, podobnie jak zawiesza się Tech2 bez adaptera do testów zwrotnych. W takim przypadku użyj polecenia Ctrl-R, aby zresetować Tech2Win.

Stan wskaźnika prędkości jest zmienny

Wskaźnik prędkości u dołu po lewej stronie paska stanu pokazuje ile 'poleceń Tech2' może zostać wykonanych, zanim Tech2Win będzie musiał przejść ponownie w stan 'uśpienia'. Metoda ta jest wykorzystywana w celu zagwarantowania, że czas w Tech2Win odpowiada czasowi rzeczywistemu: szybsze komputery pozostają w stanie uśpienia dłużej niż wolne komputery. Jeżeli stan wskaźnika prędkości jest zmienny, może to oznaczać, że inna aplikacja korzysta z mocy obliczeniowej komputera lub prędkość zegara komputera zmienia się. Duże wahania mogą mieć negatywny wpływ na komunikację z pojazdem lub z TIS2Web. Upewnij się, że nie są uruchomione żadne inne aplikacje.

Większość laptopów może automatycznie zmniejszać prędkość zegara procesora w celu wydłużenia czasu pracy baterii. To także może być przyczyną zmian prędkości wykrywanych przez Tech2Win. W takim przypadku nie pracuj na baterii, lecz podłącz laptop do zewnętrznego źródła zasilania. Możesz także spróbować zmienić ustawienia zasilania w taki sposób, by system operacyjny nie zmniejszał prędkości zegara.

Nagłe wyłączenie

Jeżeli w pliku dziennika nie znajdziesz żadnego powodu wyłączenia się programu, może to oznaczać, że uruchomione zostały wewnętrzne mechanizmy bezpieczeństwa Tech2Win. Nie ruszaj następujących plików: emulator.sec, emulator.lic, emulator.card. Jeżeli Tech2Win stwierdzi naruszenie zabezpieczeń, jest bardzo prawdopodobne, że będziesz musiał przeprowadzić ponowną instalację.

Dla oprogramowania 15.001 wyświetlany jest język szwedzki

Oprogramowanie, które początkowo jest dołączone do Tech2Win, jest oprogramowaniem demonstracyjnym, które znajduje się na każdej nowej karcie PCMCIA. TIS2Web pokazuje, że jest ono w języku szwedzkim, ponieważ TIS2Web wyświetla tylko ostatni język z listy czterech języków obsługiwanych przez to oprogramowanie demonstracyjne (angielski, francuski, niemiecki, szwedzki). Użyj trybu aktualizacji 'Uzytkownika' zamiast 'Standardowy', aby zastąpić to oprogramowanie demonstracyjne najnowszym oprogramowaniem diagnostycznym.

Utrata komunikacji z MDI

Utrata komunikacji z MDI może mieć kilka przyczyn.

  • Niesprawne połączenie kablowe (dotyczy Ethernetu i USB).
  • Niepewne połączenie bezprzewodowe.
  • Komputer przechodzi w stan wstrzymania.

Tech2Win nie znalazł mojego MDI

Sprawdź następujące punkty:

    1. Czy MDI jest aktywny?
    2. Czy MDI Manager działa?
    3. Czy z MDI korzysta inna aplikacja, np. SPS?
Program MDI Manager można uruchomić za pomocą ikony na pulpicie lub za pomocą menu „Start/Wszystkie programy/General Motors/GM MDI Software”.: Jeżeli punkt 2 nie działa, skontaktuj się z działem pomocy technicznej Helpdesk.

Chcę od razu uruchomić Tech2Win bez zajmowania się konfiguratorem

Wykonaj polecenie "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Użyj następującego katalogu roboczego: C:\Program Files\General Motors\Tech2Win\bin W dalszym ciągu możesz używać konfiguratora w celu wprowadzania ewentualnych zmian w konfiguracji.

Gdzie znajdują się funkcje drukowania?

Tech2Win nie udostępnia funkcji drukowania bezpośredniego. Tworzy natomiast pliki tymczasowe i wywołuje programy skojarzone z rozszerzeniami tych plików. Programów tych można używać do drukowania, dostosowując w nich również wygląd wydruku.

Print Report | Print Report

Aby wydrukować aktualny ekran Tech2Win, należy użyć pozycji menu Plik / Drukuj ekran lub przycisku na klawiaturze przedstawiającego drukarkę. Chcąc wydrukować kilka ekranów Tech2Win, można użyć pozycji menu Opcje / Automatyczne zrzuty ekranowe, ponieważ tworzy ona pliki PNG dla poszczególnych ekranów. Te pliki PNG są osadzane w pliku dziennika.

Ponadto można wydrukować zawartość ekranu danych (aktywowaną przy użyciu pozycji menu Okna / Wyświetlanie danych Tech2Win). Pozyskiwanie danych należy rozpoczynać i kończyć przyciskiem Rozpoczęcie wydruku/HTML. Gdy pozyskiwanie zostanie zakończone, uruchomi się program skojarzony z formatem HTML (zazwyczaj Internet Explorer), który udostępnia liczne funkcje drukowania danych.

Data Display | Data Display

Na moim komputerze występuje „nieużywany” folder PCMCIA

We wcześniejszych wersjach Tech2Win zawsze występował duplikat plików PCMCIA w osobnym katalogu. Często był to katalog C:\PCMCIA. Teraz ten katalog nie jest już używany, ponieważ duża szybkość pobierania z TIS2Web powoduje, że drugie miejsce na przechowywanie pobranych plików nie jest potrzebne. Ten katalog można bezpiecznie usunąć.

Wyświetla się komunikat „niedozwolona ścieżka pliku”

Nazwa pliku może zawierać niedozwolone znaki np. znak procentów (%). Jeśli ten problem pojawia się bezpośrednio po instalacji, najlepszym rozwiązaniem będzie odinstalowanie programu i zainstalowanie go od nowa. W większości przypadków ta metoda pozwala naprawić usterkę.

Podczas zwykłych instalacji zmienna środowiskowa „Tech2WinUserData” jest ustawiana na „PUBLIC” (Dla wersji Windows >= Vista) i na „ALLUSERSPROFILE\Documents” (dla wersji Windows starszych od Vista). W niektórych rzadkich przypadkach podczas instalacji zmienna środowiskowa nie zostaje ustawiona, lecz przy drugiej próbie wszystko działa prawidłowo. Możesz również wybrać ręczne ustawienie zmiennej środowiskowej. Jeśli nie wiesz, jak ustawić zmienną środowiskową, poproś o pomoc administratora systemu.


Wpisy rejestru

Poniższe wpisy rejestru są generowane przez instalatora. Prosimy nie modyfikować tych wpisów manualnie. Prosimy wziąć pod uwagę standardowe ostrzeżenia Windows podczas dokonywania wpisów rejestru.

klucz rejestracyjny | nazwa | typ | znaczenie
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Wewnętrzny numer wersji
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Język | REG_SZ | zainstalowana wersja językowa
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Ścieżka dostępu do katalogów kopii PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Root | REG_SZ | ścieżka instalacyjna
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Odinstaluj opcję | REG_DWORD | Ustawienie dezinstalacji
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Wersja pliku konfiguracji
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Wersja sterownika wirtualnego portu COM
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Nazwa oprogramowania na liście Dodaj/Usuń program
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Ścieżka dostępu do programu odinstalowującego


Ponowna instalacja

Ponowna instalacja spowoduje usunięcie całego katalogu instalacyjnego Tech2Win z poniższymi wyjątkami.

  1. Podkatalog config zawierający konfiguracje nie jest kasowany.
  2. Podkatalog pcmcia, który zazwyczaj zawiera obrazy PCMCIA, nie jest kasowany.
  3. Podkatalog ATA, który może zawierać informacje o debugowaniu, nie jest kasowany.
Pliki konfiguracyjne mogą stać się nie kompatybilne: nie ma gwarancji, że pliki konfiguracyjne starej wersji Tech2Win będą odczytywane przez nowszą wersję Tech2Win. Obrazy PCMCIA z zasady nie mogą stać się nie kompatybilne.

Ponowna instalacja nie ma wpływu na dodatkowy katalog PCMCIA.

Niektóre środowiska mogą oferować automatyczną instalację nowszej wersji Tech2Win. Ponieważ informacje z ostatniej instalacji są zapisane w rejestrze, ustawienia te zostaną użyte jako domyślne przy ponownej instalacji.

Można wymusić ponowną instalację Tech2Win, korzystając ze skryptu enable reinstallation. Skrypt ten jest instalowany razem z Tech2Win. Zasadniczo, skrypt ten po prostu ustawia wartość klucza CurrentVersion znajdującego się w rejestrze pod HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win na wartość '1.000'.