Tech2Win brukerhåndbok

Velkommen til brukerhåndboken for Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Alle rettigheter forbeholdt.

  • Introduksjon:
  • Lisens:
  • Installasjon:En beskrivelse av installasjonsprosedyren for Tech2Win.
    • Installasjonstrinn
    • Bilkommunikasjonsgrensesnitt
  • De første trinnene
    • Velge konfigurasjon
      • Tastatur
      • Vindushåndtering
    • Nye konfigurasjoner
    • Endring av konfigurasjoner
      • Språk
      • Bane
      • Display
      • Lagre en konfigurasjon
    • Anskaff en gyldig Tech2Win-lisens.
  • Arbeide med Tech2Win: Informasjoner om daglig bruk.
    • Meny
    • Nedlasting av et PCMCIA-bilde
    • Sikkerhet
    • Vis rapporter
    • Håndtering av PCMCIA-bilder
    • Statuslinje
  • Avanserte emner: Informasjon ikke påkrevet for normal bruk av Tech2Win. Som oftest bare av interesse for personer med administrative oppgaver.
    • Ny installasjon
    • Avinstallasjon
    • Format for konfigurasjonsfilen
    • Loggfil
    • Feilmeldinger og feilkoder
    • ATA-kort
    • Registeroppføringer
    • Filer
    • Konfigurasjonsadministrasjon
  • Vanlige spørsmål


Introduksjon

Tech2Win er en Windows-applikasjon som kan emulere Tech2-funksjonalitet. I hovedsak kjøres Tech2-programvaren på en PC. For å kjøre dette programmet må PC-en din tilfredsstille følgende tekniske krav:

  • Et grensesnitt for bilkommunikasjon må installeres og kobles til PC-en. Listen av godkjente grensesnitt kan variere fra område til område. I de fleste tilfeller kan GMs Multiple Diagnostic Interface (MDI) benyttes.
  • Tech2Win-applikasjonen krever 150 MByte plass på harddisken ved installasjonen. Ytterligere 32 MB er påkrevet for hvert PCMCIA-flashkort som du ønsker å administrere.
  • Før kjøring av Tech2Win-applikasjonen trenger du minst 100 MB ledig fysisk RAM. Det er absolutt påkrevet av din PC har tilstrekkelig minne til at hele applikasjonen skal kunne finnes inne i RAM under hele kjøretiden.
  • PC-en din skal ha beregningskapasitet tilsvarende 1,2 GHz Pentium (enkel kjerne). Vi anbefaler sterkt at du ikke kjører noen andre applikasjoner samtidig.
  • Et tastatur er ikke påkrevet. Tech2Win kan også betjenes med en berøringsskjerm. For administrasjon av konfigurasjoner anbefaler vi sterkt at du bruker et tastatur da du vil ha behov for å skrive inn filnavn.
  • Fargegrafikkdisplayet må minst ha en oppløsning på 800 x 600, med en minste fargedybde på 256. Uten tastatur kan en oppløsning på 640 x 480 være akseptabelt.

Ved bruk av Tech2Win (bærbar i stedet for Tech2), må du sørge for at den bærbare maskinen har nok strøm. Vanligvis vil den bærbare maskinen ikke få tilført strøm fra bilens batteri slik som med Tech2.

  • Installasjon
  • De første trinnene


Lisens

General Motors - Tech2Win Lisensavtale

Les de følgende vilkårene og betingelsene nøye før du tar i bruk dette programmet. Hvis du ikke aksepterer eller forstår vilkårene eller betingelsene, bes du kontakte din lokale Ettermarkeds-representant. Retten til å bruke denne programvaren er lisensiert av General Motors kun på betingelse av at brukeren er inneforstått med denne lisensen ved å akseptere disse vilkår og betingelser under installasjonen av Tech2Win.
General Motors overdrar rettigheten til å bruke Tech2Win-programvaren og den medfølgende informasjonen i sammenheng med TIS2Web eller GlobalTIS eller TIS2000 eksklusivt for brukere i General Motors's nettverk av autoriserte verksteder, slik som bestemt i den lokale Avtalen for autoriserte verksteder med General Motors's nasjonale salgsselskaper.
Tech2Win-lisensen er gyldig så lenge Avtalen for autoriserte verksteder er gyldig og TIS2Web-, GlobalTIS- og TIS2000-lisensen foreligger. Tech2Win-lisensen avsluttes umiddelbart i sammenheng med TIS2Web og GlobalTIS-lisensen når den autoriserte reparasjonsavtalen avsluttes.

Uavhengige verksteder som beskrevet i artikkel 4, paragraf 2 i EUs gruppeunntaksdirektiv (BER) 1400/2002, kan kjøpe en Tech2Win-lisens som del av de tilbudte abonnementer som finnes i GM Europe Info Tech Portal hos General Motors Europe.

Tech2Win-lisensen innbefatter ikke grensesnitt for bilkommunikasjon eller PC-maskinvare.

Tech2Win-programvaren må ikke distribueres videre, selges eller overlates på nettet til noen tredjepart utenfor lokalene til det autoriserte verkstedet (som beskrevet i det relevante tillegget til Avtalen for autoriserte verksteder), med mindre det foreligger skriftlig tillatelse fra de relevante nasjonale salgsselskaper for General Motors. Dette gjelder både nåværende og tidligere data (som for eksempel utgåtte DVD-er).

General Motors's nasjonale salgsselskaper er berettiget til å stenge tilgangen umiddelbart og til å varsle umiddelbart opphør av Avtale for autoriserte verksteder, ved uautorisert eller ulovlig bruk. I så fall vil retten til kreve refusjon for gjenværende saldo og/eller årsavgifter falle bort.

Den utleverte informasjonen skal benyttes for service- og reparasjonsarbeider på en profesjonell måte i umodifiserte biler fra General Motors. En fullført tekniker-opplæring og vanlig etterutdanning er en obligatorisk betingelse for gjennomføring av de nevnte arbeider. Dersom det henvises til bruk av spesialverktøy i den utleverte informasjonen, vil dette spesialverktøyet være obligatorisk for alle reparasjoner som skal utføres på en profesjonell måte.

Informasjonen som er publisert i Global TIS hos General Motors (tekst og bilder, musikk, grafikk, animasjon, videoer osv.) og sammenstillingen av disse er beskyttet av opphavsretten. Ingen reproduksjon, spredning, kommunikasjon og/eller videresending eller annen bruk er tillatt uten skriftlig forhåndstillatelse fra General Motors.

  • Installasjon: Installasjonstrinn
  • De første trinnene


Installation

Installasjon

Installasjon av Tech2Win krever lokale administrative rettigheter på PC-en. Installasjonen vil ikke virke uten administrative rettigheter. I slike tilfeller kontaktes din lokale PC-administrator for hjelp.

For å kunne bruke Tech2Win må du utføre følgende to trinn:

  • Installasjon av Tech2Win.
  • Installasjon av bilkommunikasjonsgrensesnitt.
  • Installasjon: Installasjonstrinn
  • De første trinnene


Installasjonstrinn

Selve installasjonen tar bare noen få minutter og krever følgende brukerregistreringer:

  1. Lisensavtale
  2. Installasjonsmappe

Språk

Som standard vil Tech2Win UI bli vist i operativsystemets språk. Vanligvis vil følgende språk være støttet. Hvis språket ditt ikke støttes, vil installasjonsprogrammet starte med engelsk som standard installasjonsspråk.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Engelsk (enten britisk eller amerikansk)*
  • el_GR (EL)Greek
  • es_ES (ES)Spansk
  • fi_FI (FI)Finnish
  • fr_FR (FR)Fransk
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugisisk (Brasil)
  • pt_PT (PT)Portugisisk (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Kinesisk (forenklet)
  • zh_TW (ZH)Kinesisk (tradisjonell)

* Tech2Win-språket er britisk engelsk. Men Tech2-programvaren og installasjonsprogrammet kan bruke amerikansk engelsk, avhengig av hvordan programvaren er anskaffet.

Lisensavtale

Du må akseptere lisensavtalen.

Installasjonsmappe

Du kan velge en hvilken som helst mappe som plassering ved installasjon av Tech2Win. Installasjonsmappen er som standard enten <din programmappe>\General Motors\Tech2Win eller den tidligere angitte plasseringen i tilfelle ny installasjon.

Som siste punkt bekreftes installasjonen.

Virtuell COM-port-driver

Den virtuelle COM-port-driveren installeres bare en gang på datamaskinen, og den vil være der inntil driver-versjonen oppgraderes (skjer sjelden) eller inntil Tech2Win avinstalleres fra datamaskinen.
Hvis driveren blir installert, vil det vises et DOS-vindu en liten stund. Dette lukkes automatisk og krever ingen handlinger. Driver-filene plasseres også i 'driver'-undermappen i installasjonsmappen til Tech2Win.
Det er mulig å installere eller avinstallere de virtuelle COM-port-driverne manuelt, men dette anbefales ikke. Bruk en av følgende kommandoer fra CMD-skallet:

  • Kjør 'vbsetup7' for å installere driveren
  • Kjør 'vbsetup7 /u' for å avinstallere driveren
  • De første trinnene


Bilkommunikasjonsgrensesnitt

Bilkommunikasjonsenheten din må installeres separat. Se den aktuelle installasjonsveiledningen som ble levert sammen med bilkommunikasjonsgrensesnittet.

  • De første trinnene: Bilkommunikasjonsgrensesnitt
  • Avanserte emner: Konfigurasjonsfil
  • Installasjon: Installasjonstrinn
  • Vanlige spørsmål: Hvordan kan jeg bruke mer enn en MDI?
  • Vanlige spørsmål: Tech2Win finner ikke min MDI


De første trinnene

Disse første trinnene viser hvordan Tech2Win brukes. Det forutsettes at du er kjent med Tech2 fra før. Bilkommunikasjon er ikke påkrevet under disse første trinnene.

For hurtigstart utføres følgende trinn:

  1. Kjør Tech2Win-programvaren med QuickStart-snarveien fra skrivebordet.
  2. Få tak i en gyldig lisens ved å laste ned ny Tech2-programvare fra TIS2Web.

For å bruke en valgbar konfigurasjon:

  1. Start konfiguratoren med Tech2Win-snarveien fra skrivebordet. Etter en installasjon skal det finnes en default-konfigurasjon.
  2. For å lage en ny konfigurasjon bør standard-konfigurasjonen (default) kopieres.
  3. Modifiser en eksisterende konfigurasjon slik at den dekker dine behov.
  4. Anskaff en gyldig lisens.

Ikke start Tech2Win i en kompatibilitetsmodus. I så fall vil det vises en advarsel i logg-filen. Tech2Win bruker bare Windows-funksjoner som finnes fra og med XP, og vil ikke virke med tidligere Windows-versjoner.

  • De første trinnene: Nye konfigurasjoner
  • De første trinnene: Endring av konfigurasjoner
  • De første trinnene: Bilkommunikasjonsgrensesnitt
  • Arbeide med Tech2Win: Meny
  • Arbeide med Tech2Win: Sikkerhet
  • Arbeide med Tech2Win: Statuslinje
  • Avanserte emner: Konfigurasjonsfil


Velge konfigurasjon

Første gang Tech2Win-applikasjonen startes opp vises følgende skjermbilde. Du kan velge å starte Tech2Win direkte med en standard konfigurasjon. Denne standard-konfigurasjonen virker uten noen bilkommunikasjon.

Start First Time

Meldingsboksen for lisensinformasjon vil vises, men du kan ignorere denne for å starte en standard-konfigurasjon.

Ved arbeid med en berøringsskjerm kan det være en fordel å starte PC-tastaturprogrammet for å kunne skrive inn bokstaver ved hjelp av denne applikasjonen som simulerer et tastatur.


Tastatur

Både PC-tastene og knappene - hvis disse finnes, er tilordnet de kjente Tech2-knappene. Tech2Win har noen ekstra knapper som ikke finnes på den originale Tech2. Det numeriske tastaturet på PC-en vil kanskje ikke virke under alle forhold. Hvis det dukker opp noen problemer, kontrolleres at standardoppsettet for tastaturet på PC-en ikke er endret. Spesielt kan SHIFT-knappen være skadet i slike tilfeller.

PC-tastatur | Knapp | Funksjonalitet
F1-funksjonstast | ikke tilgjengelig | Tech2Win-hjelp
F5 .. F8-funksjonstaster | Bruk Tech2Win-visningsområdet med programknapper | Tech2's fire programknapper
Opp, Ned, Venstre, Høyre-piltaster |  | Tech2 Opp, Ned, Venstre, Høyre-taster. Kun disse tastene har automatisk repetisjon.
0 .. 9-taster | F0 • • • F9 | Tech2 F0 .. F9-taster
Tilbake | Exit | Tech2 Avslutt-tast
Enter / Return | Enter | Tech2 Enter-tast
Y | Yes | Tech2 Ja-tast
N | No | Tech2 Nei-tast
Q | ? | Tech2 ?-tast
S | Shift | Tech2 Skift-tast. Shift-indikatoren i statuslinjen eller indikatoren over Shift-knappen viser statusen.
ctrl-P | PWR | Tech2 Strøm-knapp; Denne knappen kan selvfølgelig bare skru av Tech2Win-applikasjonen.
ctrl-R | ikke tilgjengelig | Tilbakestiller Tech2Win. Tilsvarer Strøm På/Av-syklusen i en Tech2. Men et tilknyttet bilkommunikasjons-grensesnitt tilbakestilles ikke. Filer som for eksempel PCMCIA-bildet, blir ikke lastet på nytt.
Hjem | Home | Hjem-tast. Støttes bare av noen applikasjoner.
bare tilgjengelig gjennom menyalternativet Fil. | Print Screen | Skriver ut et øyeblikksbilde av Tech2Win-skjermen ved å opprette en midlertidig BMP-fil og deretter kalle opp programmet som er knyttet til BMP-filer. Bruk denne applikasjonen for å endre størrelse eller rotere bildet før det skrives ut.
bare tilgjengelig gjennom menyalternativet Fil. | Save Screen | Lagrer en skjermkopi av Tech2-skjermbildet som BMP- eller PNG-fil.
bare tilgjengelig gjennom menyalternativet Fil. | View Report | Viser alle rapporter på det aktive PCMCIA-flashkortet slik at brukeren kan se dem.


Vindushåndtering

Du kan endre størrelsen på vinduene ved å bruke standard Windows-mekanismer ved å trekke kantlinjene i hovedvinduet. Menyelementet Alternativer/Oppløsning vil dessuten støtte flere forhåndsinnstilte størrelser. Under endring av størrelsen på hovedvinduet via menyalternativet, vil tastaturvinduet automatisk forbli fast.

Visningen av vinduene endres ved å endre konfigurasjonen i fliken Display.


Nye konfigurasjoner

Klikk på knappen Opprett ny for å opprette en ny konfigurasjon. Det vises en dialogmeny som ber deg om å velge en eksisterende konfigurasjonsfil som utgangspunkt. Vanligvis vil default-konfigurasjonen bli valgt. Etter registrering av navnet på den nye konfigurasjonsfilen klikkes Kopier-knappen.

Hvis du arbeider med en berøringsskjerm, vil du kanskje foretrekke å aktivere PC-tastatursimuleringen med PC-tastatur-knappen.

Avbryt-knappen gir deg mulighet til å avbryte opprettelsesprosessen.

Den nye konfigurasjonen bruker den samme PCMCIA-filen som den eksisterende kildekonfigurasjonen. Hvis du ønsker å endre det, må du modifisere konfigurasjonen slik at det benyttes en annen PCMCIA-fil. I de fleste tilfeller vi du ganske enkelt kopiere den eksisterende PCMCIA-filen og bruke den nye filen. Du vil kanskje foretrekke at den nye konfigurasjonen bruker den PCMCIA-filen som kildekonfigurasjonen. I så fall vil det vises et skjermbilde med advarsel, dersom du trykker Lagre-knappen.

  • Endring av konfigurasjoner


Endring av konfigurasjoner

Konfigurasjoner som er merket med blått, er merket som skrivebeskyttet og kan ikke endres. Disse konfigurasjonene kan bare leses. Du kan selvfølgelig bruke endringsmetoden for å lese innholdet, men kommandoen Lagre vil ikke være mulig.

En konfigurasjon endres ved å velge de enkelte innstillingene i de fire tabellene Språk, Bilkommunikasjonsgrensesnitt, Bane, Display. Du kan enten velge ønsket tabulator eller bare velge å trykke Neste-knappen, som vil aktivere den neste tabulatoren. Etter at du har utført endringene, trykkes Lagre-knappen for å lagre konfigurasjonen.

Når det er nødvendig med en tastatur-oppføring, kan du også starte en PC-applikasjon som simulerer et PC-tastatur. Det er spesielt nyttig på bærbare maskiner med berøringsskjermer når det ikke finnes noe tilgjengelig tastatur.


Språk

Tabellen Språk lar deg velge det språket som skal brukes i Tech2Win. Dette valget påvirker ikke språket inne i Tech2-programvaren i PCMCIA-bildet. Ved nedlasting av Tech2-programvare fra TIS vil du fortsatt måtte velge korrekt språk.

I noen områder vil ikke alle språkene være tilgjengelige. I så fall vil det brukes engelsk i stedet. Kontroller om det finnes et lignende språk (PT Portugisisk-Portugal i stedet for PB Portugisisk-Brasil).


Bane

Tabellen Bane gir deg mulighet til å velge stiene både for PCMCIA-bilder og stien for ditt lokale programvaretastatur. I tillegg finnes knappen Kopier minnekort for å kopiere PCMCIA-bilder. Hvis du nettopp har opprettet en ny konfigurasjon, er det mulig at du ønsker å bruke denne knappen for å unngå at flere konfigurasjoner bruker det samme PCMCIA-bildet.

Memory Card Options

Kopier minnekort ...

Denne knappen gir deg mulighet til å kopiere et PCMCIA-bilde til en annen fil. Funksjonaliteten ligner et kjøp av et nytt PCMCIA-kort for Tech2. Kopieringsfunksjonen virker bare for filer i mappen C:\Users\Public\General Motors\Tech2Win\pcmcia.

Spor 0 : Plassering minnekort-bilde

Her kan du angi den filen som inneholder PCMCIA-bildet ditt for spor 0. Vanligvis vil en slik fil være plassert i C:\Users\Public\General Motors\Tech2Win\pcmcia, men andre plasseringer er også mulig.

Spor 1 : Minnekort eller ATA

På samme måte som i Tech2 støtter også Tech2Win to PCMCIA-kort (bilder). Men det sekundære PCMCIA-bildet innenfor en konfigurasjon av vanligvis ikke særlig nyttig. Det benyttes sannsynligvis en annen programvare i en sekundær konfigurasjon.

På samme måte som i en Tech2 benyttes et ATA-kort for feilsøkingsformål. Aktiver kun ATA-kortet dersom du blir bedt om det av teknisk støtte. De vil gi deg flere opplysninger.

Plassering PC-programvare tastatur

Standardverdien for denne filen hentes fra Windows-registeret og skal peke på en applikasjon som kan simulere et PC-tastatur med musen. Hvis du har en egen applikasjon med denne funksjonaliteten i den bærbare maskinen du bruker, kan du angi applikasjonen her.


Bilkommunikasjonsgrensesnitt

  • COM-port for Tech2-RS232-emulering
  • Serienummer for MDI som skal benyttes
  • Protokoll

COM-port for Tech2-RS232-emulering

Velg en ledig COM-port som kan brukes for Tech2-emuleringen. For å lette arbeidet forsøker Configurator å finne ut hvilke serielle porter som allerede er i bruk, og viser disse.

Hvis du velger en eksisterende COM-port, vil Tech2Win knytte seg til denne eksisterende COM-porten. Du kan bruke denne COM-porten for å laste ned Tech2-programvare fra en annen datamaskin som kjører en TIS-applikasjon, ved å bruke en null-modem-kabel. Merk at bruken av en ekte COM-port ikke nødvendigvis vil virke stabilt med 115 200 baud, på grunn av Windows-begrensninger.

Hvis det velges en ikke-eksisterende COM-port, vil Tech2Win automatisk opprette en virtuell port. Denne virtuelle porten kan brukes fra TIS og kjøre på den samme PC-en for å etablere kommunikasjon med Tech2Win. Ved bruk av en virtuell port er det ingen baud-hastighets-begrensninger.

Hvis du velger 'søk' som COM-port, vil Tech2Win opprette en virtuell COM-port på det første ledige nummeret i området fra 9 til 1.

Serienummer for MDI som skal benyttes

Skriv serienummer for MDI. Nummeret finnes på baksiden av MDI-en. Bruk nummeret etter bindestreken.

Hvis du ikke skriver inn et serienummer, vil Tech2Win automatisk vise en liste med MDI-er som er registrert på nettverket for å la brukeren velge en MDI. Den samme valgboksen vises når den oppgitte MDI-en ikke finnes.

Protokoll

'ISO22900-2 / PDU-API' er valgt og J2534-2 er alltid gråfarget.. I framtiden vil Tech2Win muligens også kunne støtte J2534-protokollen.

  • Avanserte emner: Konfigurasjonsfil
  • Vanlige spørsmål: Hvordan kan jeg finne ut hvilken COM-port som skal brukes for Tech2Win?
  • Vanlige spørsmål: Kommunikasjon mellom Tech2Win og TIS2Web
  • Vanlige spørsmål: Hvordan kan jeg bruke mer enn en MDI?
  • Vanlige spørsmål: Tech2Win finner ikke min MDI


Display

Display-tabellen benyttes i hovedsak for å endre innstillingene som berører skjermen i Tech2Win:

  • Tastatur
  • Farger
  • Lyd
Display and Key Options

Tastatur

Her kan du velge om tastaturet skal vises. Tastaturet vises enten til venstre eller til høyre i Tech2Win-skjermbildet. Bakgrunnsfargen kan velges via en standard farge-dialogboks.

Farger

Bakgrunns- og forgrunnsfargen i Tech2-skjermen kan velges individuelt her. Dette er de to vanligste fargekombinasjonene:

Screen with background 0000FF, foreground FFFFFF | Tastaturbakgrunn hvit; Bakgrunn blå; Forgrunn hvit
Screen with background 000000, foreground C0C0C0 | Tastatur Bakgrunn blå; Bakgrunn sort; Forgrunn lysegrå

Lyd

Du kan velge å slå av lyden her. Hver gang Tech2-programmet piper, vil PC-høyttaleren bli brukt.


Lagre konfigurasjonen

Den aktive konfigurasjonen kan lagres ved å trykke på Lagre <configuration>-knappen i nedre venstre hjørne. Knappen vil ikke bli vist hvis du ser på en skrivebeskyttet konfigurasjon.


Gyldig lisens via TIS2Web

Vanligvis vil få en gyldig lisens ved nedlastingen av Tech2-programvaren til Tech2Win. Du kan også lage en ved å gjennomføre en 'Sikkerhetstilgang (sikkerhet)' via TIS2Web (ikke TIS2000). Det er derfor nødvendig å velge den virtuelle COM-porten inne i Configurator under Vehicle Communication Interface.

Etter vellykket sikkerhetstilgang ser du en åpen lås på høyre side i statuslinjen. Inne i parentesen ser du antall dager som lisensen vil være gyldig. Når du starter Tech2Win igjen, vises ikke sikkerhetsindikatoren, da det ikke utføres noen bilkommunikasjon. Ved den første kommunikasjonen med en bil, vil license bli kontrollert og indikatoren endres enten til en åpen eller en stengt lås.

  • Arbeide med Tech2Win:Sikkerhet
  • Vanlige spørsmål:Hvordan kan jeg finne ut hvilken COM-port som skal brukes for Tech2Win?
  • Vanlige spørsmål:Kommunikasjon mellom Tech2Win og TIS2Web
  • Vanlige spørsmål:Gyldig lisens
  • Vanlige spørsmål:Hva er forskjellen mellom en Tech2Win-lisens og sikkerhetstilgang?


Arbeide med Tech2Win

De følgende emnene brukes av de fleste teknikere ved arbeid med Tech2Win:

  • Meny: Utformingen av skjermbilder og de enkelte menyelementene.
  • Nedlasting av et PCMCIA-bilde: Oppdateringen av diagnoseprogramvaren for Tech2Win er svært lik framgangsmåten som brukes i Tech2.
  • Sikkerhet: Sikkerhetstiltak hindrer Tech2Win fra å gjennomføre bilkommunikasjoner med ikke-autoriserte omgivelser.
  • Vis rapporter: Tech2-tastaturet er noe forbedret i Tech2Win. 'Vis rapporter'-knappen er det beste eksemplet.
  • Håndtering av PCMCIA-bilder: På samme måte som ved multiple PCMCIA-kort i Tech2, kan du ha flere PCMCIA-bilder i bruk for Tech2Win.
  • Statuslinje: Statuslinjen informerer brukeren om de enkelte delene av statuslinjen.
    • Avanserte emner
    • Vanlige spørsmål


Meny

Tech2Win-applikasjonen har følgende menyoppføringer:

  • Fil
  • Alternativer
  • Vinduer
  • Hjelp

Fil

Menyen Fil gir følgende muligheter:

  • Lagre T2-skjerm (320x240) benyttes for å lagre det aktuelle T2-skjermbildet med en størrelse på 320x240 piksler som en svart-hvit bildefil på PC-en. Lagringsplasseringen og filformatet (BMP, GIF, JPG, PNG) kan velges fritt.
  • Skriv ut skjermbilde oppretter et invertert svart på hvitt BMP-bilde av Tech2-skjermbildet og starter programmet som er knyttet til BMP-filene. Du kan deretter bruke dette programmet for å skrive ut bildet.
  • Vis rapportfiler gir mulighet til å vise (og skrive ut) rapportfiler uten å bruke TIS2Web.
  • Avslutt avslutter Tech2Win.

Alternativer

Alternativer gir følgende valgmuligheter:

  • Oppløsning kan benyttes for å velge en av tre standard skjermstørrelser.
  • ROM-Write from 0x00003ED76 brukes for interne feilsøkingsformål.
  • Automatiske skjermbilder for å lagre et bilde av hvert enkelt Tech2-skjermbilde i loggmappen.
  • Deaktiver CANdi og start på nytt for å etterligne en Tech2 som ikke har en CANdi mellom seg selv og bilen. Dette er nødvendig i sjeldne tilfeller hvor CANdi avbryter uvanlige bilkommunikasjonslinjer.

Vinduer

Menyen Vinduer gir deg mulighet til å aktivere valgene Tech2Win datadisplay og Tech2Win feilkodedisplay. Alle andre valg er gråfarget i den aktuelle Tech2Win-versjonen.

Hvis Tech2-programvaren støtter Tech2Win datadisplay, kan du aktivere dette menyvalget. Etter å ha startet datadisplayet vil Tech2Win vise et ekstra datadisplay-vindu parallelt med Tech2-datadisplayet. Så lenge Tech2-skjermen viser Data-displayet, kan menyvalget ikke aktiveres. I dette tilfellet må du gå ut av Data-displayet, aktivere menyvalget og starte Data-displayet på nytt.

Lignende begrensninger som for Tech2Win datadisplay gjelder også for Tech2Win feilkodedisplay. Hvis Tech2-programvaren støtter Tech2Win feilkodedisplay, kan du aktivere dette menyvalget. Et ekstra DTC Display-vindu vises parallelt med Tech2 DTC-displayet. Så lenge Tech2-skjermen viser DTC-displayet, kan menyvalget ikke aktiveres. I dette tilfellet må du gå ut av DTC-displayet, aktivere menyvalget og starte DTC-displayet på nytt.

Hjelp

Følgende valgmuligheter finnes:

  • Hjelp-emner... starter Tech2Win-Hjelp.
  • Kommandolinjeparameter viser kommandolinjeparametrene som brukes for Tech2Win.
  • Om viser aktuelt versjonsnummer og TIS2Web nedlastings-begrensinger i Tech2Win.


Last ned

Start først Tech2Win og la denne være på hovedskjermen. Start TIS2Web eller GlobalTIS og gjennomfør nedlastingen via COM-porten som er angitt i kategorien Bilkommunikasjonsgrensesnitt.

Bruken av innebygde COM-porter er mulig for å laste ned Tech2-programvare fra en annen PC som kjører TIS. Sørg for at det brukes en krysskoblet RS232-kabel. Avhengig av maskinvaren i PC-en som kjører Tech2Win, vil dataoverføringshastigheten muligens måtte reduseres til 57 600 baud, da Windows kan miste data ved høyere baud-hastigheter.

Den siste Tech2Win-versjonen støtter også en rask nedlasting når TIS2Web og Tech2Win kjøres på den samme PC-en. En mindre kommunikasjon mellom TIS2Web og Tech2Win gjennomføres fortsatt via COM-porten, men den tidkrevende overføringen av data til Tech2Win er erstattet av en intern filoverføring. I slike tilfeller reduseres nedlastingstiden betydelig til mye mindre enn et minutt.

  • Avanserte emner: Konfigurasjonsfil
  • De første trinnene: Bilkommunikasjonsgrensesnitt
  • Vanlige spørsmål: Hvordan kan jeg finne ut hvilken COM-port som skal brukes for Tech2Win?
  • Vanlige spørsmål: Kommunikasjon mellom Tech2Win og TIS2Web


Sikkerhet

Sikkerhetsmekanismene som benyttes av Tech2Win stoler på en korrekt klokkeverdi i PC-en. Sørg for at PC-klokkens verdi alltid er korrekt. Mindre klokke-endringer som skjer ved overgang til sommertid, aksepteres av Tech2Win.

Tech2Win gjennomfører ingen bilkommunikasjoner uten at det foreligger en gyldig og aktiv lisens. Den følgende indikatoren i statuslinjen viser lisensstatusen:

  • green smiley Lisensen er gyldig.
  • Ingen indikator: Lisensen er ikke kontrollert ennå.
  • red smiley Lisensen er utløpt.

For å motta en lisens må du gjennomføre en 'Sikkerhetstilgang (sikkerhet)' oppdatering ved hjelp av TIS2Web-applikasjonen. I de fleste tilfeller vil en nedlasting av programvare via TIS2Web være tilstrekkelig for å anskaffe en ny lisens. Da lisensen blir ugyldig etter en bestemt tidsperiode (i noen områder: fire uker), må du gjennomføre en slik oppdatering med jevne mellomrom.

Lisenser er område/programvare-spesifikke. Du vil kunne ha lisenser i datamaskinen din hvis du bruker Tech2Win med forskjellige Tech2-programvareversjoner.

Antall gjenstående dager før lisensen utløper vises i statuslinjen.

  • (0) betyr at lisensen er utløpt eller ikke finnes.
  • (<1) Lisensen utløper i løpet av de neste 24 timene.
  • (20) Lisensen utløper om 20 dager.

Ikke foreta endringer i lisensfilen. Ulovlige endringer i denne filen blir oppdaget ved hjelp av interne sikkerhetstiltak og vil medføre tap av alle lisenser i datamaskinen. I tillegg vil Tech2Win oppføre seg uventet. Dette kan bare repareres ved å gjennomføre en ny installasjon.

  • Avanserte emner: Feilmeldinger og avslutningskoder
  • Avanserte emner: Loggfil
  • Arbeide med Tech2Win: Statusvindu
  • Vanlige spørsmål: Gyldig lisens
  • Vanlige spørsmål: Hva er forskjellen mellom en Tech2Win-lisens og sikkerhetstilgang?
  • Vanlige spørsmål: Uventet stopp


Visning av rapporter

View Report Denne knappen kan brukes for å se innholdet av enhver PRT-fil som finnes på PCMCIA-kortet. En dialogboks med en liste med PRT-filer vil bli åpnet. Dersom et program er tilordnet til PRT-filtypen, vil det tilordnede programmet bli startet. Ellers vil redigeringsprogrammet Notepad bli åpnet for å vise den valgte filen.

I de fleste tilfellene vil PRT-filen være en ASCII-fil som bruker kodesider med det aktuelle språket. For kinesisk, japansk, koreansk og thai vil filen være i Unicode med et innledende Byte-Order-Mark (BOM).

Når det vises rapporter, bruker Tech2Win undermappen C:\Users\Public\General Motors\Tech2Win\reports. Denne undermappen finnes bare dersom du har vist rapporter minst en gang. Mappen slettes automatisk og fungerer som en midlertidig arbeidsmappe for PRT-filene på det aktive PCMCIA-kortet. Den vil fortsatt inneholde disse filene selv om Tech2Win slutter å kjøre. Hvis du ønsker å lagre en slik fil, må du kopiere den til et annet område, da den kan bli overskrevet så snart en annen bruker velger å vise rapporter.


PCMCIA-bilder

PCMCIA-bilder finnes vanligvis i undermappen C:\Users\Public\General Motors\Tech2Win\pcmcia. Filen må ha en størrelse på nøyaktig 32 Mbytes (33 554 432 bytes) eller 10 Mbytes (10 485 760 bytes) og filtypen *.bin. Bildene modifiseres (på samme måte som med alle normale PCMCIA-kort), dersom en nedlasting gjennomføres eller dersom Tech2Win lagrer noe i flash-minnet. En modifisering kan deaktiveres ved å bruke skrivebeskyttelse-bryteren (kommandoen -W0 eller -W1) eller ved å fjerne 'p'-verdien i '-W'-alternativet(Konfigurasjonsfil). Skrivebeskyttelsesbryteren er ikke tilgjengelig via konfiguratoren. Du må modifisere konfigurasjonsfilen manuelt hvis du ønsker å bruke alternativene '-W0', '-W1' eller '-W'.


Statuslinje

Statuslinjen vises under Tech2-skjermbildet. Følgende elementer vises i statuslinjen:

  1. En hastighetsindikator
  2. Bilkommunikasjonsstatus
  3. Serieportstatus
  4. SHIFT-knapp
  5. Automatiske skjermbilder
  6. Logg-varsling
  7. Lisens

Status Bar

Hastighetsindikator

Hastighetsindikatoren viser hvor mye CPU-tid som er brukt ved simuleringen av Tech2-programvare. Et lavt tall (indikator til venstre) er bedre enn et høyt tall (indikator til høyre). Alle grønne indikatorer er akseptable. Indikatoren kan bli gul i en kort tidsperiode, dersom forskjellige Windows-oppgaver plutselig blir aktive. Slike aktiviteter bør unngås.

Bilkommunikasjonsstatus

Bilkommunikasjonsstatusen indikerer om både bilkommunikasjons-grensesnittet (MDI) og kommunikasjonen mellom bilen og Tech2Win er til stede.

Serieportstatus

Ved kommunikasjon med Tech2Win via en COM-port viser denne indikatoren om kommunikasjonen i COM-porten er aktiv eller ikke.

SHIFT-knapp

Denne indikatoren viser om SHIFT-knappen er aktiv. Du kan veksle den med 'S'-knappen på tastaturet eller SHIFT-knappen på tastaturet.

Automatiske skjermbilder

Automatiske skjermkopier kan aktiveres i Alternativer-menyen. Hver gang et skjermbilde endres, lagres en ny skjermbildefil i loggmappen. Dette indikeres med et håndtak på det røde kameraet i statuslinjen. Så snart den automatiske skjermbildekopieringen blir deaktivert, forsvinner kameraet.

Logg-varsling

Loggstatusindikatoren kan ha tre forskjellige tilstander.

  • gray log status indicator Loggfilen inneholder ingen varslinger eller feil.
  • yellow log status indicator Loggfilen inneholder en varselmelding.
  • red log status indicator Loggfilen inneholder en feilmelding.

Lisens

Lisensindikatoren kan ha tre tilstander:

  • green smiley Lisensen er aktiv og gyldig.
  • Ingen indikator: Lisensen er ikke kontrollert ennå.
  • red smiley Lisensen er utløpt eller finnes ikke.
Se linken Sikkerhet for flere informasjoner.

Verktøytips på statuslinjen

For noen ikoner vises verktøytips for å gi noe tilleggsinformasjon:

Verktøytips for VCI-serienummer:
Tooltip VCI

Verktøytips for TECH2 programvareversjon
Tooltip TECH2

Verktøytips for COM-port
Tooltip Comport

Verktøytips for nummer for neste skjermbilde (hvis 'Automatiske skjermbilder' er aktivt)
Tooltip Camera

Verktøytips som viser den siste loggfil-registreringen med nivå 'advarsel' eller høyere
Tooltip Logfile

Verktøytips for nøyaktig varighet av lisensen
Tooltip License

Verktøytipset vises hvis markøren står mer enn 0,5 sekunder på et ikon uten å beveges. Verktøytipset forsvinner etter 5 sekunder eller dersom markøren beveges.

  • Avanserte emner: Feilmeldinger og feilkoder
  • Avanserte emner: Loggfil


Avanserte emner

Emnene som er beskrevet her, er mindre viktige for gjennomsnittsbrukeren av Tech2Win. Alle som er berørt av en innstilling, administrasjon og konfigurasjon av Tech2Win vil finne den følgende informasjonen nyttig.

  • Ny installasjon
  • Avinstallasjon
  • Direkte endring av konfigurasjonsfilene
  • Loggfil
  • Feilmeldinger og avslutningskoder
  • ATA-kort
  • Registeroppføringer
  • Filbeskrivelse
  • Eksempler på administrasjon av konfigurasjon


Avinstallasjon

Hele installasjonsmappen, mappen som inneholder brukerdata (C:\Users\Public\General Motors\Tech2Win) og mappen som inneholder applikasjonsdata (C:\ProgramData\General Motors\Tech2Win) blir slettet.

  • Avanserte emner: Ny installasjon
  • Installasjon


Konfigurasjonsfil

Konfigurasjonsfilene finnes alltid i undermappen C:\Users\Public\General Motors\Tech2Win\config, og de har filtypen *.conf. Du kan velge om du vil endre konfigurasjonsfilen manuelt, da noen av alternativene i filen ikke er tilgjengelig gjennom Tech2Win. Konfigurasjonsfilen er en Unicode-fil med innledende Byte-Order_Mark (BOM). Vi anbefaler sterkt at du bruker et redigeringsprogram for Unicode, for eksempel Notepad, når det gjennomføres manuelle endringer.

Konfigurasjonsfilen er linjeorientert. Tomme linjer ignoreres. En linje begynner alltid med et alternativ og følges vanligvis av en verdi. Som eksempel vises filen default.conf. Se følgende tabell som viser alle tilgjengelige alternativer.

Hvis du ønsker å starte en bestemt konfigurasjon direkte fra skrivebordet, lager du en snarvei som utfører 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Programmet skal startes fra følgende arbeidsmappe: 'C:\Program Files\General Motors\Tech2Win\bin'

alternativ | Verdi / Beskrivelse
; En kommentar
@ Et desimalt versjonsnummer i formatet major.minor.
Konfigurasjonsfiler med et annet major-nummer enn Tech2Win aksepteres ikke. Konfigurasjonsfiler med et lavere minor-nummer enn Tech2Win aksepteres.
-W0
-W1 		PCMCIA-kortet i spor 0/1 har en aktivert skrivebeskyttelses-bryter.
-B0
-B1 		Blokkstørrelsen i Kbytes for PCMCIA-kortet i spor 0/1. Akseptable verdier er 128 (standard) eller 256.
-P0
-P1 		Filen inneholder binærbildet for et PCMCIA-kort i spor 0/1. Størrelsen på filen må være nøyaktig 10 MB eller 32 MB. Miljøvariabler som for eksempel %ProgramData% er utvidet.
Dersom dette alternativet ikke finnes, antas sporet å være tomt.
-A0
-A1 		Filen inneholder attributtverdiene for PCMCIA-kortet i spor 0/1. Dersom det ikke finnes, vil standardattributtene benyttes basert på kort og blokkstørrelse.
-W | Ved avslutning av Tech2Win vil alle gjenværende data bli skrevet til sine respektive filer. Verdiene p/f/r/c kan kombineres for å angi henholdsvis PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | Hjelp-administrasjon funksjonalitet Verdiene 0/r/w/t kan kombineres for å aktivere henholdsvis nullstilling, lesekontroller, skrivekontroller og oppgavekontroller. Verdien I brukes for alltid å tvinge en tildeling av minne med lavere adresser da et alternativt tildelingsskjema er implementert. Vanligvis blir dette alternativet bare benyttet i et utviklingsmiljø.
-PC | Tidligere sti for kopiering av PCMCIA-kort. Dette alternativet ignoreres for øyeblikket.
-MS | Identifikasjon for bilkommunikasjons-grensesnittet (MDI) med serienummer. Hvis ikke innstilt, vil det vises en liste med tilgjengelig MDI-er.
-CT | Fargen på teksten (forgrunn) i 3 heksadesimale byte-verdier. Standardverdien er 000000 (hvit).
-CB | Fargen på bakgrunnen i 3 heksadesimale byte-verdier. Standardverdien er FFFFFF (sort).
-ATA | Bruk dette alternativet for å aktivere et ATA-fangstkort. Fjern det for å deaktivere ATA-fangstkort.
-C | Nummeret på COM-porten (1..9) som skal brukes som Tech2's RS232C-kommunikasjonsport. COM9 brukes ofte for den virtuelle COM-porten som installeres av Tech2Win. Hvis dette alternativet ikke finnes, gjennomføres søking etter en ledig COM-port nedover fra COM9. Bruk verktøytipset på statuslinjen mellom Tech2-ikonet og TIS2Web-ikonet for å se hvilken COM-port som benyttes.
-WR | En PC-adresse (vanligvis 253558) som er tillatt for skriving til PCMCIA og flash-ROM-område. Denne funksjonaliteten må også aktiveres i menyen (eller ved å bruke alternativet -WA). Den er nødvendig for å feilsøke koden i ikke-identifiserbart minne med SingleStep Debugger.
-WA | Tillat at SingleStep Debugger skriver til ikke-modifiserbart minne.
-OF | Alternativ-fil som inneholder alternativer / verdipar.
-TP | Tidsstyrings-justering (Proporsjonalverdi). Standard verdi 5000. Reduser denne verdien for å la antall utførte sykler tilpasses raskere til sanntid.
-TD | Tidsstyrings-justering (Differanseverdi). Standard verdi 100. Reduser denne verdien for å reagere raskere på endringer i momentantidsstyring. ADVARSEL: Endring av TP- og TD-verdiene kan medføre hastighetsproblemer.
-PJ
-PP 		Angi protokoll som skal benyttes:
PJ for J2534-kommunikasjon.
PP for ISO22900-2 / PDU-API (standard)
-S | Tilstedeværelsen av dette alternativet aktiverer lyd ut til PC-ens høyttaler.
-L | Språket i Tech2Win-applikasjonen. Det aktive Windows-språket benyttes som standard dersom denne registreringen mangler. Se følgende link for en liste med språk som kan angis: Språk. Tech2-emuleringsvinduet vil bli vist uansett hvilket språk som ligger på PCMCIA-kortet (dvs. ble lastet ned til PCMCIA-kortet).
-UD | Overstyring av brukerens datamappe. I Win7 er det vanligvis C:\Users\Public\General Motors\Tech2Win
-AD | Overstyring av applikasjonens datamappe. I Win7 er det vanligvis C:\ProgramData\General Motors\Tech2Win
-US | Bruk en brukerspesifikk semafor for å registrere mer enn en hendelse med Tech2Win. Dette alternativet lar hver bruker kjøre sin Tech2Win parallelt på den samme maskinen, vanligvis en server. Ved bruk av dette alternativet bør du også spesifisere alternativene -UD og -AD samtidig.
-SS | Alternativ for å spesifisere totalstørrelsen på Tech2Win-vinduet inkludert tastaturet (hvis det finnes). Den første parameteren må være en streng som er omgitt av anførselstegn (') og denne brukes som navn på størrelsen i menyen Alternativer / Oppløsning. Den andre parameteren er det totale antallet med horisontale piksler i Tech2Win-skjermbildet inkludert tastaturet. Den tredje parameteren er det totale antallet med vertikale piksler i Tech2Win-skjermbildet. Den fjerde alternative parameteren er bredden på tastaturet i piksler.
-SH Alternativ for å kontrollere skjermhåndteringen. Det følgende desimaltallet benyttes for å spesifisere hvilke skjermhåndteringsmuligheter som skal deaktiveres.
  • Bit 0: Ingen min/maks mulig.
  • Bit 1: Ingen ny plassering på skjermen.
  • Bit 2: Ingen endring av størrelse. I dette tilfellet er menyen Alternativer / Oppløsning deaktivert og gråfarget.
  • Bit 3: Datadisplay og feilkodevinduer skal ha nøyaktig den samme størrelsen som Tech2Win (uten tastatur).


Logging

Hver oppstart av en Tech2Win-konfigurasjon oppretter en ny loggfil i HTML-format i undermappen C:\Users\Public\General Motors\Tech2Win\Logs. For å unngå oppfylling av harddisken vil filer som er eldre enn en uke bli fjernet.

Loggfilene navngis automatisk i henhold til datoen (year (år), month (måned), day (dag)) og tidspunktet (hour (time), minute (minutt), second (sekund)) for opprettelsen:
yyyy-mm-dd_hhmmss.html

Oppføringer i loggfilen er alltid på engelsk, men i Unicode-format med et innledende Byte-Order-Mark (BOM). Hver av linjene i loggfilen har et av følgende loggnivåer:

Loggnivå | Beskrivelse
Info | Kun informasjon. Ingen påvirkning på kjøringen av programmet.
Advarsel | En uvanlig situasjon er oppstått. Brukeren ser ikke nødvendigvis noen uheldige effekter.
ERROR | Det har oppstått en feil som vil merkes av brukeren.
CRITICAL | Det er oppstått en kritisk feil som vil medføre at programmet oppfører seg unormalt.
FATAL | En alvorlig feil vil medføre at Tech2Win stanser umiddelbart.

Alle nivåer over 'Advarsel' er fargelagt slik at de er enkle å finne.

I tillegg vil det finnes utskrifts- og videofiler i undermappen Logs, samt dersom menyalternativene Skriv ut skjermbilde eller Automatiske skjermbilder er brukt.
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
Automatiske skjermbilder-bilder er linket i HTML-filen - bruk derfor HTML-loggen for å se denne bildesekvensen.

I statuslinjen informeres brukeren dersom det foreligger en varselmelding ( yellow lightning bolt) eller en mer alvorlig loggmelding ( red lightning bolt).


Feilmeldinger og avslutningskoder

Feilmeldinger kan opptre i dialogbokser. Disse dialogboksene tillater fortsatt at Tech2Win kan kjøre Tech2-programmet samtidig. Avslutningskoder er alvorlige feil som medfører at Tech2Win avsluttes på en unormal måte. Avslutningskodene kan brukes i satsfiler for å avdekke hvorfor et program er avsluttet.

Feilmeldinger

Følgende feilmeldinger kan forekomme. Her er en kort forklaring av situasjonen og hvordan problemet kan løses.

Emulator too slow Emulator failed to start

Avslutningskoder

Avslutningskode | Verdi | Beskrivelse
OPCODE_ERROR | -7 | En ugyldig kommando er registrert i Tech2-mikroprosessoren (68332). Det er mulig at PCMCIA-bildet er ødelagt på en eller annen måte.
ATA_PROBLEM | -6 | Det er oppstått et problem under ATA-emuleringen. Hvis du oppdager et slikt problem etter at du har fått beskjed om å bruke ATA-kortet, må du ta kontakt med kundestøtten.
DEMO_TIME_IS_UP | -5 | Bør ikke forekomme i den offisielle versjonen av Tech2Win.
DLL_NOT_LOADED | -3 | En av de nødvendige DLL-ene kunne ikke lastes inn. Det ser ut til at du har en ufullstendig kopi av Tech2Win. Gjennomfør en ny installasjon og/eller velg et annet språk.
EXIT_INIT_FAILED | -2 | Mislykket initialisering. Se i loggfilen for å finne den nøyaktige årsaken. Dersom det ikke finnes noen loggfil, kontrolleres om du har korrekt lese/skrive-tilgang til alle mappene.
normal | 0 | Tech2Win er avsluttet på normal måte.


ATA-kort

ATA-kortet i Tech2 benyttes vanligvis bare for feilsøkingsformål ved utvikling av programvaren. Alle nødvendige ATA-data er lagret i undermappen C:\Users\Public\General Motors\Tech2Win\ataCapture. Denne mappen har vanligvis ingen betydning og kan gjerne slettes, med mindre du er spesielt bedt om noe annet.

Siden ataCapture-mappen er fast, vil innholdet være det samme for alle konfigurasjoner.


Filer

De følgende filene og mappene benyttes av Tech2Win:

Mappe | Plassering før Vista | Plassering med Vista og senere
Installasjon | Som definert under installasjonen
Brukerdata | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Applikasjonsdata | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Fil | Bruk
[Brukerdata]\atacapture | Inneholder filer som finnes på ATA-kortet. Med mindre du får beskjed, vil disse filene ikke være nødvendige.
[Installasjon]\bin | Inneholder de aktuelle kjørbare og nødvendige DLL-ene og bildene som er nødvendige for kjøringen.
[Installasjon]\bin\emulator.exe | Hovedprogrammet som utfører Tech2-koden.
[Installasjon]\bin\emulator_xx_XX.dll | Språkspesifikk ressurs-DLL.
[Installasjon]\bin\T2Configurator.exe | Konfigurasjonsdelen av Tech2Win.
[Installasjon]\bin\Pictures | Inneholder de nødvendige ikonene for Tech2Win.
[Brukerdata]\config | Inneholder alle konfigurasjonsfiler.
[Brukerdata]\data | Inneholder filer som endres ved bruk av Tech2Win. Disse filene er nødvendige for korrekt bruk av Tech2Win. Vanligvis bør du ikke røre disse filene, med mindre du blir uttrykkelig bedt om det.
[Applikasjonsdata]\data | Inneholder filer som endres ved bruk av Tech2Win. Disse filene er nødvendige for korrekt bruk av Tech2Win. Vanligvis bør du ikke røre disse filene, med mindre du blir uttrykkelig bedt om det.
[Applikasjonsdata]\data\emulator.sec | Sikkerhetsfil . Denne filen må ikke endres.
[Applikasjonsdata]\data\emulator.card | Kort-fil. Inneholder alle PCMCIA-kort som er kjent for Tech2Win-programmet. Denne filen må ikke endres.
[Brukerdata]\data\emulator.disp | Denne filen inneholder plasseringen og størrelsen av Tech2Win-skjermbildet. Hvis du sletter denne filen, vil den bli gjenopprettet og Tech2Win-skjermbildet vil starte i øvre venstre hjørne med en størrelse på 640x480.
[Applikasjonsdata]\data\emulator.lic | Lisensfil. Inneholder informasjon om varigheten for gyldigheten av dine lisenser. Denne filen må ikke endres.
[Applikasjonsdata]\data\emulator.rtc | Sanntidsklokke-fil. Denne filen benyttes som lagringssted for data som finnes i RTC-en i Tech2.
[Applikasjonsdata]\data\emulator.dta | En informasjonsfil med 'Ikke be meg om dette senere'.. Denne filen lagrer PCMCIA-programvareversjoner som ikke (lenger) skal vise advarsel om at selvtest ikke kan utføres fordi dette krever en tilbakemeldingsadapter.
[Applikasjonsdata]\data\candi.bin | CANdi-applikasjonsfil. Inneholder applikasjonen for CANdi som er knyttet til Tech2.
[Applikasjonsdata]\data\eprom.bin | Tech2 intern EPROM-fil. Inneholder innholdet i det interne Tech2-flashminnet.
[Installasjon]\driver | Installasjonsfiler for den virtuelle COM-port-driveren.
[Installasjon]\help\emulator_xx_XX.chm | Språkspesifikke hjelpefiler.
[Brukerdata]\Logs | Inneholder loggfiler. Filer som er eldre enn en uke vil automatisk bli slettet.
[Brukerdata]\pcmcia | Inneholder PCMCIA-bildefiler. I overført betydning vil hver fil tilsvare et Tech2 PCMCIA-kort. Disse filene kan lagres på forskjellige steder etter ønske.


Konfigurasjonsstyring

Konfigurasjonsfilene finnes alltid i undermappen C:\Users\Public\General Motors\Tech2Win\config, og de har filtypen *.conf. Tech2Win kan bare brukes for å generere nye konfigurasjonsfiler eller for å endre eksisterende konfigurasjonsfiler som ikke bare er lesbare. For all annen administrasjon av konfigurasjonsfilene benyttes Windows Explorer eller et lignende filhåndteringsprogram. Dette vil være nødvendig for følgende aktiviteter:

  • sletting av konfigurasjonsfiler
  • nytt navn på konfigurasjonsfiler
  • endring av lesbarhetsattributtet for en konfigurasjonsfil

Vi anbefaler sterkt at du alltid har en konfigurasjonsfil som heter default.conf. Denne filen skal normalt ha attributtet skrivebeskyttet for å unngå feilaktig overskriving. Men dersom du skal endre denne filen for tilpasse til dine spesielle behov, må skrivebeskyttelses-attributtet fjernes midlertidig.

PCMCIA-bildene finnes i undermappen C:\Users\Public\General Motors\Tech2Win\pcmcia. Hver av disse filene tilsvarer et PCMCIA-kort som du allerede er kjent med når du arbeider med Tech2. Med Tech2Win kan du ha så mange bilder du ønsker. Kopier ganske enkelt et eksisterende bilde til et nytt filnavn.

Hvis du ønsker å starte en bestemt konfigurasjon direkte fra skrivebordet, lager du en snarvei som utfører "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Programmet skal startes fra følgende arbeidsmappe: 'C:\Program Files\General Motors\Tech2Win\bin'

Antall konfigurasjonsfiler er ikke avhengig av det antall pcmcia-bilder du bruker. Du kan ha flere konfigurasjonsfiler som bruker det samme PCMCIA-bildet. Dette likner mye på situasjonen i et verksted hvor flere mekanikere deler den samme Tech2 (og det samme PCMCIA-kortet).

Du kan også velge å la hver av konfigurasjonsfilene ha sitt eget PCMCIA-bilde. Dette vil gjøre de enkelte konfigurasjonene mer uavhengige av hverandre. Men arbeidet med oppdateringen av hvert enkelt PCMCIA-bilde kan være uakseptabelt.

Når du lager en ny konfigurasjon ved å kopiere en eksisterende, vil konfiguratoren vise en advarsel hvis PCMCIA-bildet ikke er endret. I så fall ville du hatt to konfigurasjoner som bruker det samme PCMCIA-bildet. Hvis det er slik du vil ha det, trykker du bare OK. Hvis du ønsker at den nye konfigurasjonen skal bruke et annet eller et nytt PCMCIA-bilde, trykker du Avbryt. Du kan deretter velge å lage et nytt bilde ved å bruke Kopier minnekort ...

Her er to eksempler på metoder for hvordan du kan administrere dine konfigurasjoner og PCMCIA-bilder.

En konfigurasjon per bruker

Du har mulighet til å lagre en konfigurasjon per bruker. Navnet på konfigurasjonen vil for eksempel kunne være brukerens navn. Fordelene med dette konseptet er at brukerspesifikke innstillinger, som for eksempel personlige bilkommunikasjons-grensesnitt (MDI-er), skjerm- og språkinnstillinger, er mulig. Ulempen er at du må kopiere PCMCIA-filer dersom flere brukere skal bruke den samme programvaren. Den brukerspesifikke konfigurasjonen kan selvfølgelig bruke en sentral PCMCIA-fil.

En konfigurasjon per Tech2-programvare

Du vil kanskje ønske å lage en ny konfigurasjon for hver ny programvare du laster ned. I så fall vil også eldre programvareversjoner være umiddelbart tilgjengelige, ved behov. Programvarenavnet og versjonsnummeret blir ofte valgt som konfigurasjonsnavn i slike tilfeller.

  • De første trinnene: Bilkommunikasjonsgrensesnitt
  • De første trinnene: Bane
  • Avanserte emner: Konfigurasjonsfil
  • Installasjon: Installasjonstrinn


Ofte stilte spørsmål (FAQ)

  • Hvordan kan jeg finne ut hvilken COM-port som skal brukes for Tech2Win?
  • Kommunikasjon mellom Tech2Win og TIS2Web
  • Gyldig lisens
  • Hva betyr lisensnummeret?
  • Hva er forskjellen mellom en Tech2Win-lisens og sikkerhetstilgang?
  • TIS2Web viser en uspesifisert feil ved utførelse av sikkerhetstilgang til den opprinnelige programvaren
  • Tech2Win kjører ikke Tech2-programvare fra et annet område
  • Hvordan kan jeg bruke mer enn en MDI?
  • Loggfilen inneholder feilen 'CPU32: Too many 0000/FFFF Commands encountered'
  • Ingen synlige Tech2-vinduer
  • SPS virker ikke
  • Noen selvtester virker ikke
  • Hastighetsindikatoren varierer
  • Uventet stopp
  • Det vises svensk språk i Programvare 15.001
  • Tap av kommunikasjon med MDI-en
  • Tech2Win finner ikke min MDI
  • Jeg ønsker å starte Tech2Win med en gang uten å bruke konfigureringen
  • Hvor er skriverfunksjonene?
  • En 'ubrukt' PCMCIA-mappe finnes på min datamaskin
  • Ulovlig filsti

Hvordan kan jeg finne ut hvilken COM-port som skal brukes for Tech2Win?

Du kan bruke 'Enhetsbehandling' i Windows, se etter 'Porter (COM og LPT)'. Men noen datamaskiner har interne modemer eller Bluetooth-enheter som ikke vises i denne kategorien.
En annen måte er å bruke en liten kommando som leveres sammen med konfiguratoren. Du kan kjøre denne i startmenyen (Tech2Win-mappen) ved å klikke på 'show com ports'.
Begge metoder viser COM-portene som er installert på din datamaskin og som du IKKE skal bruke.

Kommunikasjon mellom Tech2Win og TIS2Web

Det er viktig at Tech2Win kjører før du starter kommunikasjonen med TIS2Web, på grunn av sikkerhetstilgang og for å kunne laste ned programvare. TIS2Web gjenkjenner bare den virtuelle COM-porten når Tech2Win er startet.

Gyldig lisens

Vanligvis vil du allerede ha fått en gyldig lisens ved nedlasting av programvaren fra TIS2Web. Hvis du ennå ikke har en lisens, må det gjennomføres en 'Sikkerhetstilgang (sikkerhet)' via TIS2Web (ikke TIS2000) for å få en gyldig lisens. Vennligst ikke gjennomfør andre TIS2Web-kommunikasjoner med Tech2Win som f.eks. en 'Programvarenedlasting (PVNL)' før du mottar en lisens via 'Sikkerhetstilgang (sikkerhet)'.

Hva betyr lisensnummeret?

Lisensnummeret til høyre i statuslinjen viser antall hele lisensdager. Rett etter nedlasting eller sikkerhetstilgang vises antallet 30 dager. Men etter ny oppstart av Tech2Win vises 29, da lisensvarigheten sannsynligvis er noe slikt som 29 dager, 23 timer og 55 minutter. Hvis antall lisensdager blir mindre enn 24 timer, vil det vises en lisensvarighet på <1. Hvis lisensen er utløpt, vises en 0.

Hva er forskjellen mellom en Tech2Win-lisens og sikkerhetstilgang?

Tech2Win-lisensen gir deg mulighet til å bruke Tech2Win. For å anskaffe en slik lisens må du enten gjennomføre en programvarenedlasting eller en sikkerhetstilgang med jevne mellomrom (vanligst: hver 30. dag). Muligheten til å gjennomføre en slik nedlasting via TIS2Web gir Tech2Win informasjon at dette er en gyldig bruker. Sikkerhetstilgang slik det er kjent fra Tech2, gir Tech2Win informasjon om at bestemte sikkerhetsrelaterte aktiviteter som for eksempel deaktivering av en kollisjonspute, er tillatt. Både Tech2Win-lisensen og sikkerhetstilgangen kan gjennomføres med TIS2Web-sikkerhetstilgang-applikasjonen. Tech2Win viser den gjenværende lisensvarigheten i statuslinjen til høyre. Dessverre kan Tech2Win ikke vise varigheten for en sikkerhetstilgang, da Tech2Win bare kjører Tech2-programvare, men har ingen forståelse av selve Tech2-programvaren.

TIS2Web viser en uspesifisert feil ved utførelse av sikkerhetstilgang til den opprinnelige programvaren

Framgangsmåten er den samme som i en Tech2. På grunn av alderen kan den opprinnelige programvaren ikke skaffe en lisens fra TIS2Web. Men dette er ikke noe stort problem da demonstrasjonsprogramvaren ikke kommuniserer med en bil hvor det er behov for lisensen. Og siden lisenser er spesifikke for hver TIS2Web-nedlasting, ville du uansett trenge en lisens for hver enkelt nedlasting etter nedlasting av Tech2-programvaren. En 'lisens' for opprinnelig programvare vil ikke gi deg rett til å gjennomføre bilkommunikasjoner med programvare for North American Operations eller Opel/Vauxhall.

Tech2Win kjører ikke Tech2-programvare fra et annet område

Tech2Win-versjonen din er sannsynligvis begrenset til en eller flere TIS2Web-nedlastinger (områder). Trykk Hjelp / Om for å se hvilke begrensinger som gjelder for din Tech2Win. Tidlige versjoner av Tech2Win tillot bare at programvare for Opel/Vauxhall ble brukt. Andre GM-områder følger etter hvert. Uansett kan Tech2Win for øyeblikket kjøre Tech2-programvare fra General Motors.

Hvordan kan jeg bruke mer enn en MDI?

Hvis du ønsker å tilordne spesielle MDI-er til spesielle brukere, foreslår vi at du lar hver bruker ha sin egen konfigurasjon. Disse konfigurasjonene bør selvfølgelig ha navn i henhold til sine respektive brukere. I hver av konfigurasjonene bør du registrere serienummeret for den brukerspesifikke MDI-en i fliken 'Bilkommunikasjonsgrensesnitt'. Så snart brukeren starter sin konfigurasjon vil Tech2Win prøve å få kontakt med den spesielle MDI-en. Det vil bare vises en valgboks som viser alle MDI-er som det var mulig for Tech2Win å finne, dersom den spesielle MDI-en ikke er til stede.

Hvis du har flere MDI-er for generell bruk, foreslår vi at du bruker konfigurasjoner hvor serienummeret for bilkommunikasjonsgrensesnitt i fliken 'Bilkommunikasjonsgrensesnitt' ikke er registrert. Da vil brukeren alltid se valgboksen for tilgjengelige MDI-er.

Loggfilen inneholder feilen 'CPU32: Too many 0000/FFFF Commands encountered'

Filen 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' eller den aktuelle PCMCIA-filen er ødelagt. Gjennomfør ny installasjon av Tech2Win og last ned ny Tech2-programvare.

Ingen synlige Tech2-vinduer

Hvis det ikke finnes noen synlige Tech2-vinduer, er de sannsynligvis i et område utenfor skjermbildet ditt. Du kan oppleve slike hendelser når du bruker mer enn en skjerm eller etter at du har endret skjermoppløsning. Trykk på Shift-knappen på tastaturet ved oppstart av konfigurasjonen. I dette tilfellet vil vinduets oppløsning tilbakestilles til 640x480 og Tech2-vinduet vil bli vist i øverste venstre hjørne i skjermbildet. Du kan også slette filen C:\Users\Public\General Motors\Tech2Win\emulator.disp for å oppnå den samme effekten.

Vi har sett tilfeller hvor Tech2-vinduet rett og slett ikke blir oppfrisket på skjermen etter at vinduer fra andre applikasjoner blir lukket. I alle tilfeller vi har sett til nå, medførte bruk av Alt-Tab-knappene for å veksle mellom Windows-applikasjoner at Tech2-skjermbildet ble hentet fram igjen. Trykking på Tech2Win-knappen i oppgavelinjen i nedre del av PC-skjermen, virket i noen tilfeller ikke. Vi undersøker fortsatt dette problemet og håper å ha en fiks i en senere versjon av Tech2Win.

SPS virker ikke

Ja, vi vet. Vi har ingen planer om å endre dette. Du bør ikke bruke Tech2Win som en erstatning for Tech2 for å gjennomføre SPS. Bruk MDI-en direkte med SPS-programmering gjennom TIS.

Noen selvtester virker ikke

Tech2-selvtester er beregnet for testing av de enkelte delene i Tech2-programvaren. Noen av disse testene krever bruk av en tilbakemeldingsadapter. Disse testene vil ikke virke i Tech2Win da tilbakemeldingsadapter-funksjonaliteten ikke er implementert (og det foreligger ingen planer om dette). Unngå å kjøre slike meningsløse tester i Tech2Win. Hvis du kjører dem, kan du muligens få feil resultater eller Tech2Win vil kunne stoppe opp, på samme måte som i Tech2 uten en tilbakemeldingsadapter. Bruk Ctrl-R for å tilbakestille Tech2Win hvis dette skulle skje.

Hastighetsindikatoren varierer

Hastighetsindikatoren nederst til venstre på statuslinjen indikerer hvor mange 'Tech2-kommandoer' som kan kjøres før Tech2Win må 'hvile' igjen. Denne metoden benyttes for å sikre at tiden i Tech2Win stemmer overens med reell tid: Hurtige PC-er hviler mer enn lansommere PC-er. Hvis hastighetsindikatoren varierer, kan det hende at andre applikasjoner bruker datakraft eller at PC-klokken varierer. Store variasjoner påvirker bilkommunikasjonen og Tech2Web-kommunikasjonen negativt. Sørg for at det ikke kjøres noen andre applikasjoner.

De fleste bærbare PC-er kan redusere CPU-klokken automatisk for å forlenge batteritiden. Dette kan også være årsaken til hastighetsvariasjonene som registreres av Tech2Win. I slike tilfeller bør den bærbare PC-en ikke kjøres fra batteriet, men det bør benyttes en ekstern strømforsyning. Du kan også prøve å endre strøminnstillingene slik at operativsystemet ikke reduserer klokkehastigheten.

Uventet stopp

Hvis du ikke finner noen årsak inne i loggfilen til hvorfor programmet ble avsluttet, kan de interne sikkerhetsmekanismene i Tech2Win være aktivert. Ikke gjør noen endringer i følgende filer: emulator.sec, emulator.lic, emulator.card. Hvis Tech2Win identifiserer et sikkerhetsbrudd, vil du sannsynligvis måtte gjennomføre en reinstallasjon.

Det vises svensk språk i Programvare 15.001

Den opprinnelige programvaren som leveres med Tech2Win, er en demonstrasjonsprogramvare som finnes på alle nye PCMCIA-kort. TIS2Web indikerer at dette er på svensk språk, da TIS2Web bare viser det siste språket i listen med fire språk som støttes av denne demonstrasjonsprogramvaren (engelsk, fransk, tysk, svensk). Bruk oppdateringsmodusen 'Tilpass' i stedet for 'Standard' for å skrive over denne demonstrasjonsprogramvaren med den nyeste diagnoseprogramvaren.

Tap av kommunikasjon med MDI-en

Tap av MDI-kommunikasjon kan ha flere årsaker.

  • Dårlig kabeltilkobling (både ethernet og USB).
  • Ujevn trådløs tilkobling.
  • PC-en går i hvilemodus.

Tech2Win finner ikke min MDI

Kontroller følgende punkter:

    1. Er MDI-en aktiv?
    2. Virker MDI-administratoren?
    3. Brukes MDI av andre applikasjoner, som f.eks. SPS?
Du kan starte MDI-administratoren med skrivebord-ikonet eller via 'Start/Alle programmer/General Motors/GM MDI Software'.: Ta kontakt med Hjelp-tjenesten dersom punkt 2 ikke virker.

Jeg ønsker å starte Tech2Win med en gang uten å bruke konfigureringen

Utfør "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Bruk følgende arbeidsmappe: 'C:\Program Files\General Motors\Tech2Win\bin' Du kan fortsatt bruke konfigureringen for å gjøre endringer i konfigurasjonen.

Hvor er skriverfunksjonene?

Tech2Win har ikke funksjonalitet for direkte utskrift. Det opprettes i stedet midlertidige filer og programmene som er knyttet til filtypene, kalles opp. Disse programmene kan benyttes for utskriftsformål, og du kan der bestemme hvordan utskriften skal se ut.

Print Report | Print Report

For å skrive ut det aktuelle Tech2Win-skjermbildet brukes menyalternativet Fil / Skriv ut skjermbilde eller knappen på tastaturet som viser en skriver. Hvis du har behov for å skrive ut flere Tech2Win-skjermbilder, kan menyalternativet Alternativer / Automatiske skjermbilder benyttes, da dette oppretter PNG-filer for hvert Tech2Win-skjermbilde. Disse PNG-filene legges inn i loggfilen.

Du kan også skrive ut dataskjerm-innhold (aktiveres med menyalternativet Vinduer / Tech2Win datadisplay). Bruk Skriv/HTML start-knappen for å starte og deretter for å stoppe datainnsamlingen. Etter å ha stoppet datainnsamlingen vil det HTML-tilknyttede programmet (vanligvis Internet Explorer) bli startet opp, og dette gir mengder av funksjonalitet for å skrive ut dataene.

Data Display | Data Display

En 'ubrukt' PCMCIA-mappe finnes på min datamaskin

Tidligere versjoner av Tech2Win hadde alltid et duplisert lagringssted for PCMCIA-filer i en egen mappe. Denne mappen var ofte C:\PCMCIA. Nå brukes ikke denne mappen mer da den raske nedlastingen fra TIS2Web gjør en dobbel lagring av slike nedlastinger unødvendig. Du kan trygt slette denne mappen.

Ulovlig filsti

Filnavnet ser ut til å inneholde ulovlige tegn som for eksempel prosenttegnet (%). Hvis du opplever dette problemet rett etter en installering, er det enklest å gjennomføre en avinstallering og deretter installere på nytt. I de fleste tilfeller vil problemet rettes med denne framgangsmåten.

Under normale installeringer settes omgivelsesvariabelen 'Tech2WinUserData' til 'PUBLIC' (for Windows-versjoner >= Vista) og til 'ALLUSERSPROFILE\Documents' (for Windows-versjoner før Vista). I noen sjeldne tilfeller settes ikke omgivelsesvariabelen under installeringsprosessen, mens dette virker bra i neste forsøk. Du kan også velge å sette omgivelsesvariabelen manuelt. Spør din administrator om hjelp hvis du ikke vet hvordan du skal sette en omgivelsesvariabel.


Registeroppføringer

Følgende registeroppføringer er generert ved installasjonen. Disse oppføringene må ikke endres manuelt. Vær oppmerksom på Windows' standardadvarsler ved behandling av registeroppføringer.

registernøkkel | navn | type | beskrivelse
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Internt versjonsnummer
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Språk | REG_SZ | installert språk
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Sti for PCMCIA-kopieringsmapper
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Rot | REG_SZ | installasjonssti
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Avinstalleringsalternativ | REG_DWORD | Avinstallere Innstilling
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Versjon for Config-fil
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Versjon for virtuell COM-port-driver
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Programvarenavn inne i Legg til/Fjern program-listen
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Sti til avinstalleringsprogram


Ny installasjon

Den nye installasjonen vil slette hele installasjonsmappen for Tech2Win med følgende unntak.

  1. config-undermappen som inneholder konfigurasjonene, blir ikke slettet.
  2. pcmcia-undermappen som normalt inneholder PCMCIA-bildene, blir ikke slettet.
  3. ATA-undermappen som kan inneholde debuggings-informasjon, blir ikke slettet.
Konfigurasjonsfiler kan bli inkompatible: Det er ingen garanti for at konfigurasjonsfiler for en gammel Tech2Win-versjon vil være lesbare av en nyere Tech2Win-versjon. PCMCIA-bilder er prinsipielt ikke inkompatible.

Den sekundære PCMCIA-mappen påvirkes ikke av den nye installasjonen.

Noen omgivelser kan ha en automatisk installasjon av en nyere versjon av Tech2Win. Da den siste installasjonsinformasjonen er lagret i registeret, vil disse innstillingene bli presentert som standard ved den nye installasjonen.

Du kan forenkle en reinstallasjon i Tech2Win ved å bruke skriptet enable reinstallation. Skriptet installeres sammen med Tech2Win. I hovedsak setter dette skriptet ganske enkelt verdien av nøkkelen CurrentVersion som finnes i registeret under HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win til verdien '1.000'.