Gebruiksaanwijzing Tech2Win

Welkom bij de gebruiksaanwijzing van Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Alle rechten voorbehouden.

  • Introductie:
  • Licentie:
  • Installeren:Een beschrijving van de installatieprocedure van Tech2Win.
    • Installatiestappen
    • Autocommunicatie-interface
  • Eerste stappen
    • Een configuratie selecteren
      • Toetsenbord
      • Gebruik van vensters
    • Nieuwe configuraties
    • Configuraties aanpassen
      • Taal
      • Pad
      • Weergave
      • Configuratie opslaan
    • Zorg ervoor dat u een geldige Tech2Win-licentie hebt.
  • Werken met Tech2Win: Details voor de dagelijkse werkzaamheden.
    • Menu
    • PCMCIA-afbeelding downloaden
    • Beveiliging
    • Rapporten weergeven
    • Werken met PCMCIA-afbeeldingen
    • Statusbalk
  • Geavanceerde onderwerpen: Informatie die niet vereist is bij normaal gebruik van Tech2Win. Vaak alleen van belang voor mensen met beheerstaken.
    • Herinstalleren
    • Verwijderen
    • Indeling van het configuratiebestand
    • Logboekbestand
    • Foutberichten en foutcodes
    • ATA-kaart
    • Registervermeldingen
    • Bestanden
    • Configuratiebeheer
  • Veelgestelde vragen


Introductie

Tech2Win is een Windows-toepassing die Tech2-functionaliteit kan emuleren. Tech2 wordt in wezen uitgevoerd op een pc. Om dit programma te kunnen starten dient uw pc aan de volgende technische eisen te voldoen:

  • Er dient een autocommunicatie-interface geïnstalleerd te zijn en aangesloten te worden op de pc. De lijst met goedgekeurde interfaces kan per regio verschillen. In de meeste gevallen is de MDI (Multiple Diagnostic Interface) van GM te gebruiken.
  • Bij de installatie van de Tech2Win-toepassing is 150 MB aan vrije ruimte op de harde schijf vereist. Per PCMCIA-flashkaart is nog eens 32 MB extra vereist.
  • Om de Tech2Win-toepassing te kunnen starten is minimaal 100 MB aan RAM-geheugen vereist. Uw pc dient over voldoende geheugen te beschikken, zodat de toepassing tijdens het gebruik altijd in het RAM-geheugen kan blijven.
  • Uw pc dient een minimale processorsnelheid te hebben overeenkomend met 1,2 GHz Pentium (single core). Het wordt afgeraden andere toepassingen op de achtergrond te gebruiken.
  • Een toetsenbord is niet vereist. Tech2Win is tevens via een touchscreen te bedienen. Voor configuratiebeheer wordt geadviseerd een toetsenbord te gebruiken voor de invoer van bestandsnamen.
  • Uw kleurenbeeldscherm moet over een minimale resolutie van 800 bij 600 beschikken, met een kleurdiepte van 256. Zonder een toetsenbord is een resolutie van 640x480 acceptabel.

Let er bij het gebruik van Tech2Win (een laptop in plaats van een Tech2) op dat de laptopaccu is opgeladen. Normaal gesproken wordt uw laptop namelijk niet gevoed door de accu van de accu zoals het geval is bij Tech2.

  • Installeren
  • Eerste stappen


Licentie

General Motors - Tech2Win-licentieovereenkomst

Lees de volgende voorwaarden en bepalingen rustig door voordat u dit programma gaat gebruiken. Wanneer u de voorwaarden of bepalingen niet accepteert of begrijpt, dient u contact op te nemen met uw lokale aftersales-vertegenwoordiger. Het recht om deze software te gebruiken, wordt uitsluitend door General Motors in licentie gegeven op voorwaarde dat de gebruiker instemt met deze licentie door deze voorwaarden en bepalingen te accepteren tijdens de installatie van Tech2Win.
General Motors biedt het recht om de Tech2Win-software en de daarin opgenomen gegevens in combinatie met TIS2Web of GlobalTIS of TIS2000 uitsluitend te gebruiken door gebruikers van het door General Motors geautoriseerde reparatienetwerk zoals vastgelegd in de van toepassing zijnde overeenkomst voor erkende reparateurs met de landelijke verkooporganisaties van General Motors.
De Tech2Win-licentie geldt zolang de overeenkomst voor erkende reparateurs van kracht is en TIS2WEB, GlobalTIS en TIS2000-licentie aanwezig zijn. De Tech2Win-licentie wordt onmiddellijk beëindigd in combinatie met TIS2Web- en GlobalTIS-licentie wanneer de Erkende reparateur-overeenkomst wordt beëindigd.

Onafhankelijke reparateurs zoals vastgelegd in artikel 4, paragraaf 2 van de European Union Block Exemption Regulation (BER) 1400/2002 mogen een Tech2Win-licentie kopen als onderdeel van de abonnementen die in het Info Tech Portal van GM Europe van General Motors Europe worden aangeboden.

De Tech2Win-licentie omvat niet de voertuigcommunicatie-interface of de pc-hardware.

De Tech2Win-software mag niet verder worden verspreid, verkocht of online word geplaatst voor derden buiten de erkende reparateursfaciliteiten (zoals beschreven in het betreffende aanhangsel bij de overeenkomst voor erkende reparateurs) zonder schriftelijke toestemming van de betreffende landelijke verkooporganisatie van General Motors. Dit is van toepassing op zowel actuele als verouderde gegevens (zoals verlopen DVD's).

De landelijke verkooporganisaties van General Motors hebben het recht om de toegang per direct te beëindigen en de onmiddellijke beëindiging van de overeenkomst voor erkende reparateurs aan te kondigen in geval van onbevoegd gebruik of misbruik. In dat geval komt het recht tot terugvordering van de resterende uitstaande tegoeden en/of jaarlijkse basiskosten te vervallen.

De geleverde informatiediensten zijn bedoeld voor het uitvoeren van onderhouds- en reparatiewerkzaamheden op een professionele wijze voor niet-aangepaste General Motors-voertuigen. Een voltooide automonteursopleiding en regelmatige aanvullende opleidingen zijn vereist als voorwaarde voor het uitvoeren van voornoemde werkzaamheden. Waar het gebruik van speciale gereedschappen is aangegeven in de geleverde informatie, zijn dergelijke gereedschappen verplicht voor alle reparaties om ze op een vakkundige wijze uit te voeren.

De informatie die gepubliceerd is op Global TIS van General Motors (tekst en afbeeldingen, muziek, tekeningen, animatie, video's enz.) en de opstelling ervan op Global TIS zijn beschermd door auteursrechten. Reproductie, verspreiding, communicatie en/of verzending of ander gebruik is niet toegestaan, tenzij vooraf schriftelijke toestemming is verkregen van General Motors.

  • Installeren: Installatiestappen
  • Eerste stappen


Installation

Installeren

Voor de installatie van Tech2Win dient u de beheerdersrechten op de pc te hebben. Zonder beheerdersrechten zal de installatie niet werken. Neem in een dergelijk geval contact op met uw lokale pc-beheerder voor hulp.

Om Tech2Win goed te kunnen gebruiken dient u de twee volgende stappen door te nemen:

  • Tech2Win installeren.
  • Installatie van een autocommunicatie-interface.
  • Installeren: Installatiestappen
  • Eerste stappen


Installatiestappen

De installatie zelf duurt slechts enkele minuten en vereist de volgende invoeren van de gebruiker:

  1. Gebruiksrechtovereenkomst
  2. Installatiemap

Taal

Standaard wordt de Tech2Win-gebruikersinterface weergegeven in de taal van uw besturingssysteem. De volgende talen worden doorgaans ondersteund. Wanneer uw taal niet wordt ondersteund, start het installatieprogramma in het Engels als de standaard installatietaal.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Engels (Brits of Amerikaans)*
  • el_GR (EL)Greek
  • es_ES (ES)Spaans
  • fi_FI (FI)Finnish
  • fr_FR (FR)Frans
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugees (Brazilië)
  • pt_PT (PT)Portugees (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Chinees (Vereenvoudigd)
  • zh_TW (ZH)Chinees (Traditioneel)

* De Tech2Win-taal is Brits-Engels. De Tech2-software en het installatieprogramma dat u gebruikt, kunnen echter Amerikaans-Engels zijn, afhankelijk van de bron van de software.

Gebruiksrechtovereenkomst

U moet de gebruiksrechtovereenkomst accepteren.

Installatiemap

U kunt een willekeurige map kiezen als installatielocatie voor Tech2Win. Als standaardwaarde voor de installatiemap wordt <uw programmamap>\General Motors\Tech2Win gehanteerd, of, in geval van herinstallatie, de eerder gespecificeerde locatie.

Bevestig ten slotte de installatie.

Stuurprogramma virtuele COM-poort

Het stuurprogramma van de virtuele COM-poort wordt slechts eenmaal op uw computer geïnstalleerd en blijft tot de stuurprogrammaversie wordt bijgewerkt (gebeurt zelden) of Tech2Win van uw computer wordt verwijderd
Wanneer het stuurprogramma wordt geïnstalleerd ziet u even een DOS-veld. Dit sluit automatisch en hiervoor hoeft u niets te doen. De stuurprogrammabestanden worden tevens in de submap 'stuurprogramma' geplaatst in uw Tech2Win-installatiedirectory.
Het is mogelijk, maar niet raadzaam, om de stuurprogramma's voor de virtuele COM-poort handmatig te installeren of te verwijderen. Gebruik een van de volgende opdrachten uit de CMD-shell:

  • Voer de opdracht 'vbsetup7' uit om het stuurprogramma te installeren
  • Voer de opdracht 'vbsetup7 /u' uit om het stuurprogramma te verwijderen
  • Eerste stappen


Autocommunicatie-interface

Uw autocommunicatie-apparaat dient afzonderlijk geïnstalleerd te worden. Raadpleeg de desbetreffende installatiehandleiding die met de Autocommunicatie-interface werd meegeleverd.

  • Eerste stappen: Autocommunicatie-interface
  • Geavanceerde onderwerpen: Configuratiebestand
  • Installeren: Installatiestappen
  • Veelgestelde vragen: Hoe kan ik meer dan één MDI gebruiken?
  • Veelgestelde vragen: Tech2Win heeft mijn MDI niet gevonden.


Eerste stappen

Deze eerste stappen tonen hoe u Tech2Win kunt gebruiken. Er wordt verondersteld dat u bekend bent met Tech2. Tijdens deze eerste stappen is geen autocommunicatie vereist.

Voor een snelle start voert u de volgende stappen uit:

  1. Voer Tech2Win-software uit met behulp van de snelkoppeling QuickStart vanaf uw bureaublad.
  2. Een geldige licentie verkrijgen door nieuwe Tech2 software van TIS2Web te downloaden.

Voor het gebruik van een selecteerbare configuratie:

  1. Start de configurator met behulp van de Tech2Win-snelkoppeling vanaf uw bureaublad. Na een installatie dient een standaardconfiguratie aanwezig te zijn.
  2. Om een nieuwe configuratie te maken, kopieert u bij voorkeur de standaard configuratie.
  3. Pas een bestaande configuratie aan zodat hij aan uw specifieke voorwaarden voldoet.
  4. Zorg ervoor dat u een geldige licentie hebt.

Start Tech2Win niet in de compatibiliteitsmodus. In zo'n geval zal er een waarschuwing verschijnen in het logboekbestand. Tech2Win maakt alleen gebruik van Windows-functies die bestaan sinds XP en zal niet werken onder oudere Windows-versies.

  • Eerste stappen: Nieuwe configuraties
  • Eerste stappen: Configuraties aanpassen
  • Eerste stappen: Autocommunicatie-interface
  • Werken met Tech2Win: Menu
  • Werken met Tech2Win: Beveiliging
  • Werken met Tech2Win: Statusbalk
  • Geavanceerde onderwerpen: Configuratiebestand


Een configuratie selecteren

De eerste keer dat u de Tech2Win-toepassing opstart verschijnt het volgende scherm. U hebt dan de optie om Tech2Win rechtstreeks op te staren met een standaardconfiguratie. Deze standaardconfiguratie werkt zonder enige vorm van autocommunicatie.

Start First Time

Het dialoogvenster met licentie-informatie verschijnt, maar u kunt dit negeren om de standaardconfiguratie te starten.

Bij het gebruik van een touchscreen is het misschien handig om de software voor het pc-toetsenbord te starten om letters in te voeren via deze toepassing die een toetsenbord simuleert.


Toetsenbord

De pc-toetsen en de knoppen, indien aanwezig, zijn gekoppeld aan de bekende Tech2-toetsen. Tech2Win heeft enkele extra toetsen die niet aanwezig zijn op de oorspronkelijke Tech2. Het numerieke toetsenblok op de pc werkt mogelijk niet altijd. Controleer in geval van eventuele problemen of de standaard toetsenbordindeling van uw pc is gewijzigd. In zulke gevallen kan in het bijzonder de SHIFT-toets niet werken.

Pc-toetsenbord | Knop | Functionaliteit
Functietoets F1 | n.v.t. | Help Tech2Win
Functietoetsen F5 .. F8 | Gebruik het Tech2Win-weergavegebied met de softkeys. | Vier softtoetsen Tech2
Cursortoetsen omhoog, omlaag, links, rechts |  | Tech2-toetsen omhoog, omlaag, links, rechts. Alleen deze toetsen hebben een automatische herhaling.
Toetsen 0 .. 9 | F0 • • • F9 | Tech2-toetsen F0 .. F9
Backspace | Exit | Tech2-toets EXIT
Enter / Terug | Enter | Tech2-toets ENTER
Y | Yes | Tech2-toets Ja
N | No | Tech2-toets Nee
Q | ? | Tech2-toets ?
S | Shift | Tech2-toets Shift. De Shift-indicator in de statusbalk of de indicator boven de Shift-knop geeft de status aan.
ctrl-P | PWR | Tech2-toets Voeding; Uiteraard kunt u met deze toets de Tech2Win-toepassing alleen uitschakelen.
ctrl-R | niet beschikbaar | Reset Tech2Win. Vergelijkbaar met een cyclus stroom uit/aan bij een Tech2. De aangesloten Autocommunicatie wordt echter niet gereset. Bestanden zoals de PCMCIA-kopie worden niet opnieuw geladen.
Start | Home | Toets voor de startpositie. Alleen ondersteund door bepaalde toepassingen.
alleen beschikbaar via de menuoptie Bestand. | Print Screen | Hiermee wordt een screenshot afgedrukt van het Tech2-scherm door een tijdelijk BMP-bestand te maken en vervolgens de toepassing te openen die verbonden is met BMP-bestanden. Gebruik deze toepassing om voor het afdrukken de afbeelding van formaat te veranderen of te draaien.
alleen beschikbaar via de menuoptie Bestand. | Save Screen | Sla de schermafdruk van het Tech2-scherm op als BMP- of PNG-bestand.
alleen beschikbaar via de menuoptie Bestand. | View Report | Geeft alle rapporten weer voor de actieve PCMCIA-flashkaart zodat de gebruiker ze kan bekijken.


Gebruik van vensters

U kunt de afmetingen van uw vensters aanpassen met de standaardmethoden binnen Windows door de randlijnen van het hoofdvenster te verslepen. Bovendien zijn onder de menu-optie Opties/Resolutie meerdere vooraf ingestelde groottes te vinden. Wanneer het formaat van het hoofdvenster wordt aangepast met het menu-item, zal het toetsenblokvenster automatisch vastgezet blijven staan.

De weergave van de vensters is te wijzigen door de configuratie aan te passen in de tab Weergave (weergave).


Nieuwe configuraties

Klik op de knop Nieuw (nieuw aanmaken) om een nieuwe configuratie aan te maken. Er verschijnt een dialoogmenu met de vraag een bestaand configuratiebestand als bron te kiezen. Normaal wordt de standaardconfiguratie gekozen. Klik nadat u de naam van het nieuwe configuratiebestand hebt ingevoerd op de knop Kopiëren (kopiëren).

Als u met een touchscreen werkt, wilt u misschien liever een gesimuleerde pc-toetsenbord activeren via de knop Pc-toetsenbord (pc-toetsenbord).

Met de knop Annuleren (annuleren) kunt u het aanmaakproces annuleren.

De nieuwe configuratie gebruikt hetzelfde PCMCIA-bestand als de bestaande bronconfiguratie. Wanneer u die wilt veranderen, moet u de configuratie aanpassen, zodat een ander PCMCIA-bestand wordt gebruikt. In de meeste gevallen kopieert u eenvoudigweg het bestaande PCMCIA-bestand naar een nieuw bestand en gebruikt u het nieuwe bestand. Wellicht geeft u er de voorkeur aan om uw nieuwe configuratie hetzelfde PCMCIA-bestand te laten gebruiken als uw bronconfiguratie. In dat geval wordt er een waarschuwingscherm weergegeven wanneer u op de knop Opslaan drukt.

  • Configuraties aanpassen


Configuraties aanpassen

Configuraties in het blauw hebben het kenmerk Alleen-lezen en kunnen niet worden gewijzigd. Deze configuraties kunnen alleen worden bekeken. Uiteraard kunt u de aanpassingsmethode gebruiken om de inhoud te bekijken, maar Opslaan (opslaan) is niet mogelijk.

Een configuratie wordt aangepast door een afzonderlijke instelling te selecteren in de vier tabulatoren Taal, Autocommunicatie-interface, Pad, Weergave. U kunt de gewenste tab uitkiezen of gewoon op de knop Volgende drukken om de volgende tab te laten verschijnen. Klik na afloop van de wijziging op de knop Opslaan (opslaan) om uw configuratie op te slaan.

Wanneer invoer via een toetsenbord vereist is, kunt u ook een pc-toepassing aanroepen die een pc-toetsenbord simuleert. Dit is met name handig bij laptops met een touchscreen wanneer er geen toetsenbord voorhanden is.


Taal

De tabulator Taal (taal) maakt het mogelijk te taal te kiezen waarin Tech2Win werkt. Deze selectie heeft geen invloed op de taal binnen de Tech2-software op de PCMCIA-afbeelding. Bij het downloaden van Tech2-software van TIS dient u nog steeds de juiste taal te selecteren.

Voor bepaalde regio’s zijn niet alle talen beschikbaar. In dergelijke gevallen wordt Engels weergegeven. Controleer of een vergelijkbare taal beschikbaar is (PT Portugees-Portugal in plaats van PB Portugees-Brazilië).


Pad

De tabulator Pad (paden) maakt het mogelijk om de paden naar de PCMCIA-afbeeldingen en die naar het lokale softtoetsenbord in te stellen. Bovendien is er de knop Geheugenkaart kopiëren (geheugenkaart kopiëren) om PCMCIA-afbeeldingen te kopiëren. Wanneer u net een nieuwe configuratie hebt gemaakt, kunt u deze knop gebruiken om te voorkomen dat verschillende configuraties gebruikmaken van dezelfde PCMCIA-kopie.

Memory Card Options

Geheugenkaart kopiëren ...

Met deze knop kunt u de PCMCIA-afbeelding kopiëren naar een ander bestand. Deze functie heeft veel weg van de aanschaf van een nieuwe PCMCIA-kaart voor Tech2. De kopieerfunctie werkt alleen voor bestanden in de map C:\Users\Public\General Motors\Tech2Win\pcmcia.

Sleuf 0 : Locatie afbeelding geheugenkaart

Hier kunt u het bestand aangeven dat de PCMCIA-afbeelding voor sleuf 0 bevat. Gewoonlijk bevindt een dergelijk bestand zich in C:\Users\Public\General Motors\Tech2Win\pcmcia, maar andere locaties zijn ook mogelijk.

Sleuf 1 : Geheugenkaart of ATA

Net als Tech2 biedt Tech2Win ook ondersteuning voor twee PCMCIA-kaarten (afbeeldingen). De secundaire PCMCIA-afbeelding van een configuratie wordt normaal echter niet vaak gebruikt. Voor een tweede configuratie wordt waarschijnlijk andere software gebruikt.

Net als bij een Tech2 wordt een ATA-kaart gebruikt voor het opsporen van fouten. Activeer de ATA-kaart alleen indien de technische helpdesk dat van u verlangt. Ze zullen u daar meer informatie verstrekken.

Locatie softtoetsenbord pc

De standaardwaarde van dit bestand wordt opgehaald uit het Windowsregister en dient te zijn gekoppeld aan een toepassing die een pc-toetsenbord kan simuleren met behulp van de muis. Als u een speciale toepassing hebt met een dergelijke functionaliteit voor de door u gebruikte laptop, kunt u deze toepassing hier specificeren.


Autocommunicatie-interface

  • COM-poort voor Tech2-RS232-emulatie
  • Serienummer van te gebruiken MDI
  • Protocol

COM-poort voor Tech2-RS232-emulatie

Kies een vrije COM-poort die voor de Tech2-emulatie kan worden gebruikt. Voor uw gemak probeert de Configurator te achterhalen welke seriële poorten al in gebruik zijn. Deze worden weergegeven.

Als u een bestaande COM-poort selecteert, wijst Tech2Win zichzelf aan deze bestaande COM-poort toe. U kunt deze COM-poort gebruiken om Tech2-software vanaf een tweede computer met een TIS-applicatie via een null-modemkabel te downloaden. Vanwege beperkingen in Windows is het mogelijk dat een echte COM-poort niet betrouwbaar werkt met 115.200 baud.

Als er een niet-bestaande COM-poort wordt geselecteerd, maakt Tech2Win automatisch een virtuele poort. Deze virtuele poort kan vanuit TIS dat op dezelfde pc draait, worden gebruikt om verbinding met Tech2Win te maken. Als er een virtuele poort wordt gebruikt, bestaan er geen beperkingen voor de baud-snelheid.

Wanneer u 'zoeken' kiest voor COM-poort, dan zal Tech2Win een virtuele COM-poort creëren op het eerste vrije poortnummer in het bereik van 9 tot 1.

Serienummer van te gebruiken MDI

Voer het serienummer van de MDI in. Dit nummer staat op de achterkant van de MDI. Gebruik het nummer na het liggende streepje.

Als u geen serienummer invoert, geeft Tech2Win automatisch een lijst weer met MDI's die in het netwerk zijn gevonden. De gebruiker kan dan een MDI uitkiezen. Ditzelfde keuzevak verschijnt ook als de aangegeven MDI niet is gevonden.

Protocol

'ISO22900-2 / PDU-API' is geselecteerd en J2534-2 wordt altijd in grijs weergegeven. Het is mogelijk dat in de toekomst Tech2Win het J2534-protocol ook al kunnen ondersteunen.

  • Geavanceerde onderwerpen: Configuratiebestand
  • Veelgestelde vragen: Hoe kan ik bepale welke com-poort ik voor Tech2Win moet gebruiken?
  • Veelgestelde vragen: Communicatie tussen Tech2Win en TIS2Web
  • Veelgestelde vragen: Hoe kan ik meer dan één MDI gebruiken?
  • Veelgestelde vragen: Tech2Win heeft mijn MDI niet gevonden.


Weergave

De tab Weergave (weergave) wordt voornamelijk gebruikt om de instellingen te wijzigen voor de weergave van Tech2Win:

  • Toetsenblok
  • Kleuren
  • Geluid
Display and Key Options

Toetsenblok

Hier kunt u aangeven of het Toetsenblok moet worden weergegeven. Het Toetsenblok wordt links of rechts van het Tech2Win-scherm weergegeven. Via een standaarddialoogvenster voor kleur is de achtergrondkleur te specificeren.

Kleuren

Hier kunt u de kleur van de voor- en achtergrond van het Tech2-scherm afzonderlijk instellen. Dit zijn de twee meest gebruikte kleurcombinaties:

Screen with background 0000FF, foreground FFFFFF | Achtergrond toetsenblok wit; Achtergrond blauw; Voorgrond wit
Screen with background 000000, foreground C0C0C0 | Toetsenbordachtergrond blauw; Achtergrond zwart; Voorgrond lichtgrijs

Geluid

Hier kunt u kiezen om het geluid uit te schakelen. Iedere keer dat het Tech2-programma piept worden de luidsprekers van de pc gebruikt.


Configuratie opslaan

De actieve configuratie kan worden opgeslagen door te klikken op de knop b>Opslaan <configuration> (configuratie opslaan) in de linker onderhoek. Deze knop verschijnt niet, als u een configuratie met het kenmerk Alleen-lezen bekijkt.


Geldige licentie via TIS2Web

Gewoonlijk ontvangt u een geldige licentie bij het downloaden van Tech2-software naar de Tech2Win. Daarnaast kunt u er een krijgen door een 'Toegangsbeveiliging (Beveiliging)' uit te voeren via TIS2Web (niet TIS2000). Voorwaarde hiervoor is dat de virtuele COM-poort in de configurator bij Autocommunicatie-interface wordt geselecteerd.

Nadat u beveiligingstoegang hebt verkregen, ziet u een geopend slot aan de rechterkant van de statsubalk. Binnen de haakjes ziet u het aantal dagen dat de licentie nog geldig is. Als u Tech2Win opnieuw opstart, wordt de beveiligingsindicator niet weergegeven zolang communicatie met de auto plaatsvindt. Tijdens de eerste communicatiepoging met een voertuig wordt de licentie gecontroleerd en verandert het pictogram in een geopend of gesloten slot.

  • Werken met Tech2Win:Beveiliging
  • Veelgestelde vragen:Hoe kan ik bepale welke com-poort ik voor Tech2Win moet gebruiken?
  • Veelgestelde vragen:Communicatie tussen Tech2Win en TIS2Web
  • Veelgestelde vragen:Geldige licentie
  • Veelgestelde vragen:Wat is het verschil tussen een Tech2Win-licentie en Beveiligingstoegang?


Werken met Tech2Win

De volgende onderwerpen zijn van belang voor de meeste technici tijdens het werken met Tech2Win:

  • Menu: De schermindeling en de afzonderlijke menuonderdelen.
  • PCMCIA-afbeelding aan het downloaden: Het updaten van de diagnosesoftware voor Tech2Win verloopt in grote lijnen identiek aan de manier van updaten van Tech2.
  • Beveiliging: Beveiligingsmaatregelen voorkomen dat Tech2Win autocommunicatie opstart in niet-geautoriseerde milieus.
  • Rapporten weergeven: Het toetsenbord van Tech2 is iets verbeterd in Tech2Win. De knop “Rapporten weergeven” is het belangrijkste voorbeeld.
  • Werken met PCMCIA-afbeeldingen: Vergelijkbaar met het gebruik van meerdere PCMCIA-kaarten bij Tech2 kunt u bij Tech2Win meerdere PCMCIA-afbeeldingen gebruiken.
  • Statusbalk: De statusbalk informeert de gebruiker over de afzonderlijke onderdelen van de statusbalk.
    • Geavanceerde onderwerpen
    • Veelgestelde vragen


Menu

De Tech2Win-toepassing heeft de volgende menu-items:

  • Bestand
  • Opties
  • Vensters
  • Help

Bestand

In het menu Bestand worden de volgende opties gegeven:

  • T2-scherm (320x240) opslaan (T2-scherm opslaan (320x240)) wordt gebruikt om het huidige T2-scherm op te slaan op uw pc als een zwart-wit afbeeldingsbestand met 320x240 pixels. De opslaglocatie en de bestandsindeling (BMP, GIF, JPG, PNG) zijn vrij te kiezen.
  • Met Scherm afdrukken (Scherm afdrukken) wordt een omgekeerde zwart-op-wit BMP-afbeelding van het Tech2-scherm gemaakt en het gekoppelde programma voor BMP-bestanden wordt opgestart. U kunt dit programma dan gebruiken om de afbeelding af te drukken.
  • Met Rapportbestanden weergeven kunt u rapportbestanden bekijken (en afdrukken) zonder TIS2Web te moeten gebruiken.
  • Met EXIT sluit u Tech2Win af.

Opties

De Opties (Opties) bieden de volgende selecties:

  • Resolutie kan worden gebruikt om een van de drie standaardschermformaten te kiezen.
  • ROM-Write from 0x00003ED76 wordt gebruikt voor het intern debuggen.
  • Automatische screenshots (Automatische schermafbeeldingen) om een afbeelding van elk Tech2-scherm op te slaan in de logboekmap.
  • CANdi uitschakelen en opnieuw opstarten (CANdi uitschakelen en Opnieuw opstarten) om een Tech2 na te bootsen waarbij geen CANdi-verbinding met het voertuig aanwezig is. Dit is noodzakelijk in de zeldzame gevallen dat de CANdi niet-standaard communicatieverbindingen met de auto onderbreekt.

Vensters

In het menu Vensters kunt u de opties Gegevensweergave Tech2Win en DTC-weergave Tech2Win activeren. In de huidige versie van Tech2Win worden alle andere opties uitgegrijsd.

Wanneer de Tech2-software Gegevensweergave Tech2Win ondersteunt, kunt u deze menu-optie inschakelen. Bij invoeren van Data Display verschijnt er op Tech2Win een extra Data Display-venster naast het Tech2 Data Display. Zolang het Tech2-scherm de Data Display weergeeft, kan de menu-optie niet worden ingeschakeld. In zo'n geval moet u Data Display afsluiten, de menu-optie inschakelen en Data Display opnieuw opstarten.

Soortgelijke beperkingen voor Gegevensweergave Tech2Win gelden ook voor DTC-weergave Tech2Win. Wanneer de Tech2-software DTC-weergave Tech2Win ondersteunt, kunt u deze menu-optie inschakelen. Er wordt een extra DTC Display-venster weergegeven naast het Tech2 DTC Display. Zolang het Tech2-scherm de DTC Display weergeeft, kan de menu-optie niet worden ingeschakeld. In zo'n geval moet u DTC Display afsluiten, de menu-optie inschakelen en DTC Display opnieuw opstarten.

Help

De volgende opties zijn beschikbaar:

  • Helponderwerpen... roept Tech2Win Help op.
  • Opdrachtregelparameter geeft de opdrachtregelparameters voor Tech2Win weer.
  • Over toont het huidige versienummer en de beperkingen van de TIS2Web-download van Tech2Win.


Downloaden

Start om te beginnen Tech2Win op en laat het in het hoofdscherm. Start TIS2Web of GlobalTIS en voer de download uit via de COM-poort die staat aangegeven onder het tabblad Autocommunicatie-interface.

Het is mogelijk ingebouwde COM-poorten te gebruiken om Tech2-software te downloaden van een andere pc met TIS. Let erop dat u een intern gekruiste RS232-kabel gebruikt. Afhankelijk van de hardware van de pc met Tech2Win erop, moet de snelheid van de gegevensoverdracht beperkt worden tot 57.600 baud, aangezien Windows gegevens kan verliezen bij een hogere baudrate.

De nieuwste Tech2Win-versie ondersteunt tevens een snelle download wanneer TIS2Web en Tech2Win op dezelfde pc worden uitgevoerd. Een minimale communicatie tussen TIS2Web en Tech2Win via de COM-poort wordt nog steeds uitgevoerd, maar de tijdrovende overdracht van gegevens naar Tech2Win is vervangen door een interne bestandsoverdracht. In zo'n geval wordt de downloadtijd aanzienlijk verkort tot veel minder dan een minuut.

  • Geavanceerde onderwerpen: Configuratiebestand
  • Eerste stappen: Autocommunicatie-interface
  • Veelgestelde vragen: Hoe kan ik bepale welke com-poort ik voor Tech2Win moet gebruiken?
  • Veelgestelde vragen: Communicatie tussen Tech2Win en TIS2Web


Beveiliging

De beveiligingsmechanisme die door Tech2Win worden gebruikt, zijn afhankelijk van een correcte pc-klokwaarde. Uw pc-klokwaarde moet daarom altijd zijn ingesteld. Kleine klokwijzigingen, zoals bij het ingaan van de zomer- of wintertijd, worden door Tech2Win getolereerd.

Tech2Win communiceert alleen met het voertuig als er sprake is van een geldige licentie. Het volgende pictogram in de statusbalk geeft de status van de licentie aan:

  • green smiley De licentie is geldig.
  • Geen indicator: De licentie is nog niet gecontroleerd.
  • red smiley De licentie is verlopen.

Voor het verkrijgen van een licentie voert u een 'Toegangsbeveiliging (Beveiliging)'-update uit met behulp van de TIS2Web-toepassing. In de meeste gevallen is het downloaden van software via TIS2Web ook voldoende voor een nieuwe licentie. Aangezien de licentie na een bepaalde periode verloopt (in sommige regio's na vier weken), moet u een dergelijke update regelmatig uitvoeren.

Licenties zijn regio-/softwarespecifiek. U kunt licenties op uw computer hebben als u Tech2Win met verschillende Tech2-softwareversies gebruikt.

Het aantal resterende dagen voordat de licentie verloopt, wordt in de statusbalk aangegeven.

  • (0) geeft aan dat de licentie is verlopen of niet bestaat.
  • (<1) De licentie verloopt over 24 uur.
  • (20) De licentie verloopt over 20 dagen.

Knoei niet met het licentiebestand. Frauduleuze wijzigingen aan dit bestand worden door interne beveiligingsmaatregelen opgemerkt, waarna alle licenties op de computer verloren gaan. Bovendien zal Tech2Win zich niet op de aangewezen wijze gedragen. Dit kan alleen worden verholpen door de installatie opnieuw uit te voeren.

  • Geavanceerde onderwerpen: Foutberichten en afsluitcodes
  • Geavanceerde onderwerpen: Logboekbestand
  • Werken met Tech2Win: Statusvenster
  • Veelgestelde vragen: Geldige licentie
  • Veelgestelde vragen: Wat is het verschil tussen een Tech2Win-licentie en Beveiligingstoegang?
  • Veelgestelde vragen: Plotseling stoppen


Rapporten weergeven

View Report Met deze knop kunt u de inhoud bekijken van willekeurige PRT-bestanden op de PCMCIA-kaart. Er verschijnt een dialoogvenster met een lijst van PRT-bestanden. Als er een programma gekoppeld is aan de PRT-extensie, wordt het geassocieerde programma gestart. Anders wordt Kladblok geopend om het geselecteerde bestand weer te geven.

In de meeste gevallen is het PRT-bestand een ASCII-bestand met de taalspecifieke codetabellen. Voor Chinees, Japans, Koreaans en Thai is het bestand een Unicode-bestand met een markering voor de volgorde van bytes (BOM).

Tijdens het bekijken van rapporten werkt Tech2Win met een submap C:\Users\Public\General Motors\Tech2Win\reports. Deze submap bestaat alleen als u minstens eenmaal rapporten hebt weergegeven. De map wordt automatisch verwijderd en doet dienst als tijdelijke werkmap voor de PRT-bestanden op de actieve PCMCIA-kaart. Deze bestanden blijven ook als Tech2Win wordt uitgeschakeld aanwezig. Als u een dergelijk bestand wilt opslaan, dient u het naar een andere map te kopiëren om te voorkomen dat het overschreven wordt wanneer een andere gebruiker rapporten wenst weer te geven.


PCMCIA-afbeeldingen

PCMCIA-kopieën bevinden zich gewoonlijk in de submap C:\Users\Public\General Motors\Tech2Win\pcmcia. Het bestand dient exact 32 MB (33.554.432 bytes) of 10 MB (10.485.760 bytes) groot te zijn en de bestandsextensie *.bin te hebben. De afbeeldingen worden aangepast (net als iedere andere PCMCIA-kaart) bij het uitvoeren van een download of als Tech2Win wat opslaat op de flashkaart. Een wijziging is te deactiveren met de schakeloptie schrijfbeveiliging (commando -W0 of -W1) of door de ‘p’-waarde in de ‘-W’-optie achterwege te laten.(Configuratiebestand). De schrijfbeveiligingsschakelaar is niet toegangelijk via de configurator. U moet het configuratiebestand handmatig aanpassen wanneer u de opties '-W0', '-W1' of '-W' wilt gebruiken.


Statusbalk

De statusbalk wordt onder het Tech2-scherm weergegeven. De volgende items verschijnen op de statusbalk:

  1. Een snelheidsindicator
  2. Status autocommunicatie
  3. Status seriële poort
  4. SHIFT-toets
  5. Automatische screenshots
  6. Logboekwaarschuwing
  7. Licentie

Status Bar

Snelheidsindicator

De snelheidsindicator geeft aan hoeveel tijd de CPU besteedt aan het emuleren van de Tech2-software. Een lage waarde (indicator links) is betere dan een hoge waarde (indicator rechts). Een groene indicator is goedgekeurd. De indicator kan korte tijd oranje worden, als er plotseling meerdere Windows-opdrachten tegelijkertijd geactiveerd worden. Dergelijke activiteit dient te worden vermeden.

Status autocommunicatie

De status van de autocommunicatie geeft aan of de Autocommunicatie-interface (MDI) en de verbinding tussen het voertuig en Tech2Win aanwezig zijn.

Status seriële poort

Wanneer er via een COM-poort met Tech2Win gecommuniceerd wordt, geeft deze indicator aan of de communicatie via de COM-poort wel of niet actief is.

SHIFT-toets

Deze indicator geeft aan of de SHIFT-toets actief is. U kunt de instelling wisselen met behulp van de 'S' -toets van het toetsenbord of de SHIFT-toets op het toetsenbord.

Automatische screenshots

Automatische schermafbeeldingen kunnen in het Opties-menu (Optie) worden geactiveerd. Bij elke schermwisseling wordt een nieuw schermafbeeldingsbestand in de logboekmap opgeslagen. Dit wordt aangegeven door de draai aan de hendel van de rode camera in de statusbalk. De camera verdwijnt zodra de Automatische schermafbeeldingen worden gedeactiveerd.

Logboekwaarschuwing

Het logboekstatuspictogram kan drie verschillende statussen aangeven.

  • gray log status indicator Het logboekbestand bevat geen waarschuwingen of fouten.
  • yellow log status indicator Het logboekbestand bevat een waarschuwing.
  • red log status indicator Het logboekbestand bevat een foutbericht.

Licentie

Het licentiepictogram kan drie verschillende statussen aangeven:

  • green smiley De licentie is geldig.
  • Geen indicator: De licentie is nog niet gecontroleerd.
  • red smiley De licentie is verlopen of bestaat niet.
Zie voor meer details de link Beveiliging.

Knopinfo op statusbalk

Bij sommige pictogrammen wordt knopinfo met aanvullende informatie weergegeven:

Knopinfo voor VCI-serienummer:
Tooltip VCI

Knopinfo voor TECH2-softwareversie
Tooltip TECH2

Knopinfo voor COM-poort
Tooltip Comport

Knopinfo voor het nummer van de volgende schermafbeelding (indien 'Automatische screenshots' actief zijn)
Tooltip Camera

Knopinfo die de laatste invoer van het logboekbestand met niveau 'waarschuwing' of hoger weergeeft
Tooltip Logfile

Knopinfo voor de exacte licentieduur
Tooltip License

De knopinfo wordt weergegeven indien de cursor langer dan 0,5 seconden boven een pictogram wordt gehouden zonder te worden verplaatst. De knopinfo verdwijnt na 5 seconden of indien de cursor wordt verplaatst.

  • Geavanceerde onderwerpen: Foutberichten en foutcodes
  • Geavanceerde onderwerpen: Logboekbestand


Geavanceerde onderwerpen

De hier besproken onderwerpen zijn minder belangrijk voor de standaardgebruiker van Tech2Win. Wie zich echter bezighoudt met het instellen, beheren en configureren van Tech2Win heeft wellicht baat bij de volgende informatie.

  • Herinstalleren
  • Verwijderen
  • Directe aanpassing van de configuratiebestanden
  • Logboekbestand
  • Foutberichten en afsluitcodes
  • ATA-kaart
  • Registervermeldingen
  • Bestandsbeschrijving
  • Voorbeeld van configuratiebeheer


Verwijderen

De complete installatiemap, de map die de gebruikersgegevens bevat (C:\Users\Public\General Motors\Tech2Win) en de map die de toepassingsgegevens bevat (C:\ProgramData\General Motors\Tech2Win) worden gewist.

  • Geavanceerde onderwerpen: Herinstalleren
  • Installeren


Configuratiebestand

De configuratiebestanden bevinden zich altijd in de submap C:\Users\Public\General Motors\Tech2Win\config en hebben de bestandsextensie *.conf. U kunt het configuratiebestand handmatig aanpassen, aangezien niet alle opties van het bestand toegankelijk zijn via Tech2Win. Het configuratiebestand is een Unicode-bestand met een markering voor de volgorde van bytes (BOM). Het wordt aangeraden een editor te gebruiken die met Unicode kan werken, zoals Notepad, bij het uitvoeren van eventuele wijzigingen.

Het configuratiebestand is regel-georiënteerd. Lege regels worden genegeerd. Een regel begint altijd met een optie en wordt veelal gevolgd door een waarde. Bekijk bijvoorbeeld het bestand default.conf. Raadpleeg de volgende tabel waarin alle beschikbare opties worden beschreven.

Als u een bepaalde configuratie rechtstreeks vanaf het bureaublad wilt starten, maakt u een snelkoppeling voor 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -VAN ..\config\your_configuration_file.conf'. Voer het programma uit vanuit de volgende werkmap: 'C:\Program Files\General Motors\Tech2Win\bin'

Optie | Waarde / Betekenis
; Een beschrijving
@ Een decimaal versienummer met de notatie hoofdnummer.subnummer.
Configuratiebestanden met een ander hoofdnummer dan dat van Tech2Win worden niet geaccepteerd. Configuratiebestanden met een lager subnummer dan dat van Tech2Win worden wel geaccepteerd.
-W0
-W1 		De schrijfbeveiligingsschakeloptie van de PCMCIA-kaart in sleuf 0/1 is geactiveerd.
-B0
-B1 		De blokgrootte in kB van de PCMCIA-kaart in sleuf 0/1. Acceptabele waarden zijn 128 (standaard) of 256.
-P0
-P1 		Het bestand met het binaire beeld een PCMCIA-kaart in sleuf 0/1. De grootte van het bestand moet exact 10 MB of 32 MB zijn. Omgevingsvariabelen zoals %ProgramData% zijn uitgebreid.
Als deze optie niet aanwezig is, wordt verondersteld dat de sleuf leeg is.
-A0
-A1 		Het bestand met de kenmerkwaarden van de PCMCIA-kaart in sleuf 0/1. Indien niet aanwezig worden er standaardkenmerken gehanteerd op basis van de kaart en de blokgrootte.
-W | Bij het afsluiten van Tech2Win worden alle permanente gegevens weggeschreven naar de bijbehorende bestanden. De waarden p/f/r/c zijn te combineren om een PCMCIA/Flash-ROM/RTC/CANDI-toepassing aan te geven.
-H | Heap Management-functie De waarden 0/r/w/t kunnen worden gecombineerd om achtereenvolgens nulstellen, uitlezen van controles, schrijven van controles en taakcontroles te activeren. De waarde l wordt gebruikt om altijd een toewijzing van heap-geheugen af te dwingen bij lagere adressen wanneer een alternatief toewijzingsschema wordt geïmplementeerd. Gewoonlijk wordt deze optie alleen gebruikt in ontwikkelingsomgevingen.
-PC | Voorheen het pad voor het kopiëren van de PCMCIA-kaart. Deze optie wordt momenteel genegeerd.
-MS | Identificatie van de Autocommunicatie-interface (MDI) met een Serienummer. Als er niets is ingesteld, verschijnt er een lijst met de beschikbare MDI's.
-CT | De kleur van de tekst (voorgrond) in 3 hexadecimale bytewaarden. De standaardwaarde is 000000 (wit).
-CB | De kleur van de achtergrond in 3 hexadecimale bytewaarden. De standaardwaarde is FFFFFF (zwart).
-ATA | Gebruik deze optie om een ATA-capture card. Verwijder het om de ATA-capture card uit te schakelen.
-C | Het nummer van de COM-poort (1..9) dat gebruikt dient te worden als RS232C-communicatiepoort van Tech2. Vaak wordt COM9 gebruikt als virtuele COM-poort, die door Tech2Win wordt geïnstalleerd. Wanneer deze optie niet aanwezig is, wordt er vanaf COM9 omlaag naar een vrije COM-poort gezocht. Gebruik de knopinfo op de statusbalk tussen het Tech2-pictogram en het TIS2Web-pictogram om te zien welke COM-poort wordt gebruikt.
-WR | Een PC-adres (gewoonlijk 253558) dat naar de PCMCIA en het FLASH ROM-gebied mag schrijven. Deze functionaliteit moet ook worden geactiveerd via het menu (of via optie -WA) Deze is nodig voor het debuggen van de code in het niet-wijzigbare geheugen door de Single Step Debugger.
-WA | Laat het foutopsporingsprogramma SingleStep naar het niet-wijzigbare geheugen schrijven.
-OF | Optiebestand bevat optie/waardeparen.
-TP | Timingafstelling (proportionele waarde). Standaard 5000. Verlaag deze waarde, zodat het aantal uitgevoerde cycli zich sneller aan de realtime aanpast.
-TD | Timingafstelling (verschilwaarde). Standaard 100. Verlaag deze waarde om sneller te reageren op veranderingen in de momentele timing. WAARSCHUWING: Knoeien met de TP- en TD-waarden kan tot problemen met de snelheid leiden.
-PJ
-PP 		Geef het te gebruiken protocol aan:
PJ voor J2534-communicatie.
PP voor ISO22900-2 / PDU-API (standaard)
-S | De aanwezigheid van deze optie schakelt de geluidsuitvoer van de pieper van de pc in.
-L | De taal van de Tech2Win-toepassing. De actieve Windows-taal wordt gebruikt als de standaardtaal wanneer deze vermelding ontbreekt. Zie de volgende link om een lijst te zien met de talen die gespecificeerd kunnen worden: Talen. Het Tech2-emulatiescherm wordt weergegeven in de taal van de PCMCIA-kaart (d.w.z.. werd naar de PCMCIA-kaart gedownload).
-UD | Negeren van de map met de gebruikersgegevens. Onder Win7 bevindt zich dit gewoonlijk in C:\Users\Public\General Motors\Tech2Win
-AD | Negeren van de map met de toepassingsgegevens. Onder Win7 bevindt zich die gewoonlijk in C:\ProgramData\General Motors\Tech2Win
-US | Gebruik een gebruikerspecifieke markering voor detectie van meer dan één geval van Tech2Win. Met deze optie kan elke gebruiker Tech2Win parallel op dezelfde machine gebruiken, naar aller waarschijnlijkheid een server. Wanneer deze optie wordt gebruikt, moet u ook de opties -UD en -AD opgeven.
-SS | Optie om de totale grootte van het Tech2Win-venster op te geven inclusief het toetsenbord (mits aanwezig). De eerste parameter moet een tekenreeks zijn die ingesloten is door dubbele aanhalingstekens ('), die wordt gebruikt als de naam van de grootte in het menu Opties / Resolutie. De tweede parameter is het totaal aantal horizontale pixels van het Tech2Win-scherm inclusief het toetsenbord. De derde parameter is het totaal aantal verticale pixels van het Tech2Win-scherm. De vierde, optionele, parameter is de breedte van het toetsenbord in pixels.
-SH Optie om de schermhantering te controleren. Het volgende decimale nummer wordt gebruikt om op te geven welke schermhanteringsmogelijkheden er moeten worden uitgeschakeld.
  • Bit 0: Geen min/max mogelijk.
  • Bit 1: Geen plaatswijziging in het scherm.
  • Bit 2: Geen grootteaanpassing. In dat geval is het menu Opties / Resolutie grijs gearceerd.
  • Bit 3: Gegevensdisplay en DTC-vensters moeten volledig dezelfde afmeting hebben als de Tech2Win (zonder toetsenbord)


Logboekregistratie

Bij elke start van een Tech2Win-configuratie wordt in de submap C:\Users\Public\General Motors\Tech2Win\Logs een nieuw logboekbestand in HTML-indeling aangemaakt. Om te voorkomen dat de vaste schijf te vol raakt, worden logboekbestanden die ouder zijn dan een week, verwijderd.

De logboekbestanden krijgen automatisch een naam op basis van de datum (jaar, maand, dag) en het tijdstip (uur, minuut, seconde) van aanmaak:
jjjj-mm-dd_uummss.html

De vermeldingen in de logboekbestanden zijn altijd in het Engels, maar in Unicode-notatie met een markering voor de volgorde van bytes (BOM). Elke regel van het logboekbestand is van een van de volgende logboekregistratieniveaus:

Logboekregistratieniveau | Betekenis
Info | Alleen informatie. Geen invloed op de uitvoering van het programma.
Waarschuwing | Er is een ongewone situatie opgetreden. De gebruiker hoeft geen negatieve effecten te merken.
ERROR | Er is een fout opgetreden die merkbaar is voor de gebruiker.
CRITICAL | Er is een kritieke fout opgetreden waardoor het programma niet normaal reageert.
FATAL | Door een fatale fout zal Tech2Win onmiddellijk uitvallen.

Alle niveaus boven 'Waarschuwing' zijn gekleurd, zodat ze eenvoudig zijn te herkennen.

Bovendien zullen de afdruk- en videobestanden ook in de submap Logs beschikbaar zijn, wanneer de menuoptie Scherm afdrukken of Automatische screenshots is gebruikt.
jjjj-mm-dd_uummss_print_nnnnn.bmp
jjjj-mm-dd_uummss_video_nnnnn.png
Automatische screenshots-afbeeldingen zijn gekoppeld met het HTML-bestand. Gebruik daarom het HTML-logboekbestand om de volgorde van deze afbeeldingen te bekijken.

Op de statusbalk wordt de gebruiker ingelicht over een eventuele Waarschuwing ( yellow lightning bolt) of een ernstiger logboekvermelding ( red lightning bolt).


Foutberichten en afsluitcodes

Er verschijnen mogelijk foutberichten in dialoogvensters. Ondanks deze dialoogvensters kan Tech2Win het Tech2-programma nog steeds parallel blijven uitvoeren. Afsluitcodes zijn fatale fouten waardoor Tech2Win niet normaal werd beëindigd. De afsluitcodes zijn te gebruiken in batch-bestanden om te bepalen waarom een programma werd beëindigd.

Foutberichten

De volgende foutberichten kunnen verschijnen. Hier volgt een beknopte uitleg van de situatie en de wijze waarop het probleem kan worden opgelost.

Emulator too slow Emulator failed to start

Afsluitcodes

Afsluitcode | Waarde | Betekenis
OPCODE_ERROR | -7 | Er is een ongeldige opdracht van de Tech2-microprocessor (68332) ontdekt. Wellicht is de PCMCIA-afbeelding beschadigd.
ATA_PROBLEM | -6 | Er is een probleem opgetreden tijdens de ATA-emulatie. Als u met een dergelijk probleem te maken krijgt nadat u opgedragen werd de ATA-kaart te gebruiken, neem dan contact op met de helpdesk.
DEMO_TIME_IS_UP | -5 | Mogen niet verschijnen in de officiële versie van Tech2Win.
DLL_NOT_LOADED | -3 | Een van de vereiste DLL’s kan niet worden geladen. U hebt mogelijk een onvolledige kopie van Tech2Win. Installeer opnieuw en/of kies een andere taal.
EXIT_INIT_FAILED | -2 | Initialiseren mislukt Bekijk het logboekbestand om de exacte oorzaak te bepalen. Als er geen logboekbestand aanwezig is, controleer dan of u de vereiste lees-/schrijftoegang tot alle mappen hebt.
normaal | 0 | Tech2Win is normaal beëindigd.


ATA-kaart

De ATA-kaart in Tech2 wordt normaal gesproken alleen gebruikt voor het opsporen van fouten tijdens het ontwikkelen van de software. Alle noodzakelijke ATA-gegevens zijn opgeslagen in de submap C:\Users\Public\General Motors\Tech2Win\ataCapture. Deze map is normaal niet van belang en kan zonder problemen worden verwijderd, tenzij anders opgedragen.

Omdat de submap ataCapture statisch is, is de inhoud ervan gelijk voor alle configuraties.


Bestanden

De volgende bestanden en mappen worden gebruikt door Tech2Win:

Map | Locatie voorafgaand aan Vista | Locatie voor Vista en hoger
Installeren | Zoals vastgelegd tijdens de installatie
Gebruikersgegevens | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Toepassingsgegevens | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Bestand | Gebruik
[Gebruikersgegevens]\atacapture | Bevat bestanden die op de ATA-kaart staan. Tenzij anders aangegeven, zijn deze bestanden niet nodig.
[Installeren]\bin | Bevat de werkelijke, uitvoerbare en vereiste DLL’s en de benodigde afbeeldingen voor de uitvoering.
[Installeren]\bin\emulator.exe | Het uitvoerbestand dat de Tech2-code uitvoert.
[Installeren]\bin\emulator_xx_XX.dll | Taalspecifiek DLL-bronbestand.
[Installeren]\bin\T2Configurator.exe | Het configuratiegedeelte van Tech2Win.
[Installeren]\bin\Pictures | Bevat de vereiste pictogrammen voor Tech2Win.
[Gebruikersgegevens]\config | Bevat alle configuratiebestanden.
[Gebruikersgegevens]\data | Bevat bestanden die gewijzigd worden tijdens de uitvoering van Tech2Win. Deze bestanden zijn nodig voor de juiste uitvoering van Tech2Win. Normaal dient u deze bestanden met rust te laten, tenzij uitdrukkelijk anders opgedragen.
[Toepassingsgegevens]\data | Bevat bestanden die gewijzigd worden tijdens de uitvoering van Tech2Win. Deze bestanden zijn nodig voor de juiste uitvoering van Tech2Win. Normaal dient u deze bestanden met rust te laten, tenzij uitdrukkelijk anders opgedragen.
[Toepassingsgegevens]\data\emulator.sec | Beveiligingsbestand . Pas dit bestand niet aan.
[Toepassingsgegevens]\data\emulator.card | Kaartbestand. Bevat alle PCMCIA-kaarten in het Tech2Win-programma. Pas dit bestand niet aan.
[Gebruikersgegevens]\data\emulator.disp | Dit bestand bevat de locatie en grootte van het Tech2Win-scherm. Als u dit bestand verwijdert, wordt het opnieuw aangemaakt waarna het Tech2Win-scherm in de linker bovenhoek wordt geopend met de afmetingen 640x480.
[Toepassingsgegevens]\data\emulator.lic | Licentiebestand. Bevat informatie over de geldigheidsduur van uw licenties. Pas dit bestand niet aan.
[Toepassingsgegevens]\data\emulator.rtc | Real-timeklokbestand. Dit bestand dient als opslag voor gegevens die in de RTC van Tech2 worden aangetroffen.
[Toepassingsgegevens]\data\emulator.dta | Een infobestand 'Niet meer tonen'.. In dit bestand worden PCMCIA-softwareversies opgeslagen die de waarschuwing over het niet kunnen uitvoeren van de zelftest waarvoor een loopback-adapter nodig is, niet (meer) moeten laten zien.
[Toepassingsgegevens]\data\candi.bin | CANdi-toepassingsbestand. Bevat de toepassing van de CANdi die aangesloten is op Tech2.
[Toepassingsgegevens]\data\eprom.bin | Intern EPROM-bestand Tech2. Bevat de inhoud van het interne flashgeheugen van Tech2.
[Installeren]\driver | Installatiebestanden voor het virtuele COM-poortstuurprogramma.
[Installeren]\help\emulator_xx_XX.chm | Taalspecifieke Help-bestanden
[Gebruikersgegevens]\Logs | Bevat logboekbestanden. Bestanden die ouder zijn dan een week, worden automatisch gewist.
[Gebruikersgegevens]\pcmcia | Bevat de afbeeldingsbestanden van de PCMCIA. In figuurlijke zin komt ieder bestand overeen met een PCMCIA-kaart van Tech2. Deze bestanden kunnen desgewenst naar verschillende locaties worden weggeschreven.


Configuratiebeheer

De configuratiebestanden bevinden zich altijd in de submap C:\Users\Public\General Motors\Tech2Win\config en hebben de bestandsextensie *.conf. Tech2Win is alleen te gebruiken om nieuwe configuratiebestanden aan te maken of bestaande configuratiebestanden aan te passen die niet alleen-zijn zijn. Gebruik voor alle overige vormen van beheer van de configuratiebestanden de Windows Verkenner of een soortgelijk programma voor bestandsbeheer. Dit is nodig voor de volgende activiteiten:

  • wissen van configuratiebestanden
  • wijzigen van naam van configuratiebestanden
  • wijzigen van kenmerk Alleen-lezen van een configuratiebestand

Het wordt aangeraden altijd een configuratiebestand met de naam default.conf te hebben. Dit bestand dient normaal het kenmerk Alleen-lezen te hebben om onbedoeld overschrijven tegen te gaan. Als u dit bestand echter aanpast aan uw specifieke behoeften, moet u het kenmerk Alleen-lezen tijdelijk verwijderen.

De PCMCIA-kopieën bevinden zich in de submap C:\Users\Public\General Motors\Tech2Win\pcmcia. Elk van deze bestanden komt overeen met een PCMCIA-kaart die bij u bekend zijn bij het gebruik van Tech2. Met Tech2Win kunt u zoveel afbeeldingen hebben als u wilt. Kopieer gewoon een bestaande afbeelding naar een nieuwe bestandsnaam.

Als u een bepaalde configuratie rechtstreeks vanaf het bureaublad wilt starten, maakt u een snelkoppeling voor "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Voer het programma uit vanuit de volgende werkmap: 'C:\Program Files\General Motors\Tech2Win\bin'

Het aantal configuratiebestanden is niet afhankelijk van het aantal PCMCIA-afbeeldingen dat u gebruikt. Meerdere configuratiebestanden kunnen gebruik maken van dezelfde PCMCIA-afbeelding. Dit simuleert een werkplaatssituatie waarbij meerdere monteurs gebruik maken van dezelfde Tech2 (en daarmee dezelfde PCMCIA-kaart).

U kunt iedere configuratie ook zijn eigen PCMCIA-afbeelding laten gebruiken. Daarmee zijn individuele configuraties minder afhankelijk van elkaar. Het extra werk dat echter gemoeid is met het bijwerken van elke afzonderlijke PCMCIA-afbeelding wordt wellicht niet op prijs gesteld.

Wanneer u een nieuwe configuratie maakt door een bestaande te kopiëren, geeft de configurator een waarschuwing weer wanneer de PCMCIA-kopie niet gewijzigd is. In zo'n geval hebt u twee configuraties die dezelfde PCMCIA-kopie gebruiken. Wanneer u dat wilt, drukt u gewoon op OK. Wanneer u wilt dat de nieuwe configuratie een andere of een nieuwe PCMCIA-kopie gebruikt, drukt u op Annuleren. U kunt vervolgens kiezen om een nieuwe kopie te maken met behulp van Geheugenkaart kopiëren ...

Hier volgen twee voorbeeldmethoden voor het beheer van uw configuraties en PCMCIA-afbeeldingen.

Een configuratie per gebruiker

U kunt per gebruiker een configuratie opslaan. De naam van de configuratie kan dan bijvoorbeeld de naam van de gebruiker zijn. Deze werkwijze biedt als voordeel dat gebruikersspecifieke instellingen mogelijk zijn, zoals voor persoonlijke autocommunicatie-interfaces (MDI's) en scherm- en taalinstellingen. Het nadeel is dat u de PCMCIA-bestanden moet kopiëren als verschillende gebruikers dezelfde software gebruiken. Natuurlijk kunnen gebruikersspecifieke configuraties een centraal PCMCIA-bestand gebruiken.

Een configuratie per Tech2-software

U kunt ervoor kiezen een nieuwe configuratie te maken voor iedere software die u downloadt. Dat betekent dat ook oudere softwareversies, indien nodig, onmiddellijk beschikbaar zijn. In dergelijke gevallen worden de softwarenaam en het versienummer vaak als configuratienaam gebruikt.

  • Eerste stappen: Autocommunicatie-interface
  • Eerste stappen: Pad
  • Geavanceerde onderwerpen: Configuratiebestand
  • Installeren: Installatiestappen


Veelgestelde vragen (FAQ)

  • Hoe kan ik bepale welke com-poort ik voor Tech2Win moet gebruiken?
  • Communicatie tussen Tech2Win en TIS2Web
  • Geldige licentie
  • Wat geeft de licentietijd aan?
  • Wat is het verschil tussen een Tech2Win-licentie en Beveiligingstoegang?
  • TIS2Web toont een niet-specifieke fout bij beveiligingstoegang tot de beginsoftware
  • Tech2Win voert geen Tech2-software uit van een ander gebied
  • Hoe kan ik meer dan één MDI gebruiken?
  • Logboekbestand bevat de fout 'CPU32: Too many 0000/FFFF Commands encountered'
  • Geen Tech2-venster te zien
  • Het SPS functioneert niet.
  • Sommige zelftests werken niet
  • De snelheidsindicator schommelt
  • Plotseling stoppen
  • Software 15.001 wordt in het Zweeds weergegeven
  • Communicatie met de MDI verbroken
  • Tech2Win heeft mijn MDI niet gevonden.
  • Ik wil Tech2Win meteen starten zonder tussenkomst van de configurator.
  • Waar bevinden zich de afdrukfuncties?
  • Een 'ongebruikte' PCMCIA-map is aanwezig op mijn computer
  • Ik krijg de melding 'ongeldig bestandspad' te zien

Hoe kan ik bepale welke com-poort ik voor Tech2Win moet gebruiken?

U kunt 'Apparaatbeheer' van Windows gebruiken: Poorten (COM & LPT). Maar sommige computers hebben een interne modem of een bluetooth-apparaat die niet in deze categorie zijn opgenomen.
Een andere mogelijkheid is om het kleine programmaatje uit te voeren dat met de configurator is meegeleverd. U kunt dit uitvoeren via het startmenu (Tech2Win-map) door op 'show com ports' te klikken.
Bij beide methoden worden de com-poorten getoond die op uw computer zijn geïnstalleerd en die u NIET moet gebruiken.

Communicatie tussen Tech2Win en TIS2Web

Tech2Win moet draaien, voordat u de communicatie met TIS2Web start voor een beveiligingstoegang of het downloaden van software. TIS2Web kan de virtuele COM-poort alleen herkennen wanneer Tech2Win is gestart.

Geldige licentie

Gewoonlijk ontvangt u bij het downloaden van software vanaf TIS2Web een geldige licentie. Als u nog steeds geen licentie hebt, moet u een 'Toegangsbeveiliging (Beveiliging)' uitvoeren via TIS2Web (niet TIS2000) om een geldige licentie te verkrijgen. Voer geen andere TIS2Web-communicatie uit met Tech2Win, zoals een 'Software laden (SWDL)' voordat u een licentie hebt verkregen via 'Toegangsbeveiliging (Beveiliging)'.

Wat geeft de licentietijd aan?

De licentietijd aan de rechterkant van de statusbalk geeft het aantal dagen aan dat de licentie nog geldig is. Als het downloaden net is voltooid of in geval van een beveiligingstoegang wordt een aantal van 30 dagen weergegeven. Als Tech2Win echter opnieuw wordt gestart, staat hier 29. Dit komt omdat de licentietijd dan bijvoorbeeld nog 29 dagen, 23 uur en 55 minuten bedraagt. Indien de tijd dat de licentie nog geldig is lager is dan 24 uur, wordt een licentietijd van <1 weergegeven. Indien de licentie is verstreken, verschijnt er een 0.

Wat is het verschil tussen een Tech2Win-licentie en Beveiligingstoegang?

De Tech2Win-licentie stelt u in staat om Tech2Win te gebruiken. Om een dergelijke licentie te verkrijgen, moet u regelmatig de software downloaden of een beveiligingstoegang uitvoeren (standaard: elke maand). Als deze download via TIS2Web kan worden uitgevoerd, weet Tech2Win dat het om een geldige gebruiker gaat. Door middel van de Beveiligingstoegang, zoals die bekend is van Tech2, weet Tech2Win dat bepaalde veiligheidsgerelateerde handelingen zijn toegestaan, zoals het uitschakelen van een airbag. Zowel de Tech2Win-licentie als de Beveiligingstoegang kan worden uitgevoerd met het programma TIS2Web Security Access. Rechts op de statusbalk van Tech2Win wordt de resterende licentieduur getoond. Helaas kan Tech2Win niet de duur van de Beveiligingstoegang weergeven, aangezien Tech2Win alleen de Tech2-software uitvoert en niet de inhoud van de Tech2-software kent.

TIS2Web toont een niet-specifieke fout bij beveiligingstoegang tot de beginsoftware

Het systeem werkt hetzelfde als op een Tech2. Door de leeftijd van de beginsoftware kan deze geen licentie van TIS2Web verkrijgen. Dit is echter geen probleem, omdat deze demonstratiesoftware niet communiceert met een auto waarvoor de licentie nodig is. En omdat licenties specifiek voor de TIS2Web-download zijn, hebt u na het downloaden van de Tech2-software hoe dan ook een licentie voor elk afzonderlijke download nodig. Met een 'licentie' voor beginsoftware is geen boordcommunicatie met software van North American Operations of Opel/Vauxhall mogelijk.

Tech2Win voert geen Tech2-software uit van een ander gebied

Uw Tech2Win-versie is waarschijnlijk beperkt tot een of meerdere TIS2Web-downloads (gebieden). Druk op Help / Over om te zien welke beperkingen gelden voor uw versie van Tech2Win. Eerdere versies van Tech2Win werkten alleen met Opel/Vauxhall software. Andere GM-gebieden volgen binnenkort. In elk geval kunt u Tech2Win op dit moment gebruiken voor de Tech2-software van General Motors.

Hoe kan ik meer dan één MDI gebruiken?

Als u specifieke MDI's aan bepaalde gebruikers wilt toekennen, adviseren wij dat elke gebruiker zijn/haar eigen configuratie krijgt. Deze configuraties moeten dan naar hun overeenkomstige gebruikers worden vernoemd. U moet voor elk van deze configuraties het serienummer van de gebruikersspecifieke MDI invoeren in de tab 'Autocommunicatie-interface'. Zodra de gebruiker met de configuratie start, zal Tech2Win proberen om een verbinding met de specifieke MDI tot stand te brengen. Alleen als de betreffende MDI niet aanwezig is, zal een keuzevak worden getoond met alle MDI's die Tech2Win wel heeft gevonden.

Indien u meerdere MDI's voor algemeen gebruik hebt, adviseren wij om configuraties te gebruiken waarbij het serienummer van de Autocommunicatie-interface in de tab 'Autocommunicatie-interface' niet is ingevuld. In dat geval ziet de gebruiker altijd het keuzevak met beschikbare MDI's.

Logboekbestand bevat de fout 'CPU32: Too many 0000/FFFF Commands encountered'

Het bestand 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' of het huidige pcmcia-bestand is beschadigd. Installeer Tech2Win opnieuw en download de nieuwe Tech2-software.

Geen Tech2-venster te zien

Als er geen Tech2-venster te zien is, dan staat dit waarschijnlijk in een gebied dat niet op uw beeldscherm te zien is. Dit kan gebeuren wanneer u meer dan één scherm gebruikt of nadat u de schermresolutie hebt gewijzigd. Druk op Shift op het toetsenbord tijdens het starten van de configuratie. In dat geval wordt de schermresolutie teruggesteld op 640x480 en verschijnt het Tech2-venster linksboven op het scherm. U kunt ook het bestand C:\Users\Public\General Motors\Tech2Win\emulator.disp verwijderen om hetzelfde effect te bereiken.

We zijn situaties tegengekomen waarbij het Tech2-venster niet meer op het scherm terugkwam nadat de vensters van alle andere toepassingen waren gesloten. In alle tot nu toe bekende gevallen was het met de toetsencombinatie Alt+Tab wel mogelijk om tussen Windows-toepassingen te schakelen om het Tech2-scherm op te roepen. Als in de taakbalk op de onderste regel van het pc-scherm op de Tech2Win-knop wordt gedrukt, gebeurt er soms niets. Op dit moment onderzoeken wij dit probleem en we hopen dit te hebben verholpen in een volgende versie van Tech2Win.

Het SPS functioneert niet.

Ja, hiervan zijn we op de hoogte. We zijn niet voornemens om dit te wijzigen. U moet Tech2Win niet gebruiken ter vervanging van Tech2 om SPS-werkzaamheden uit te voeren. Gebruik de MDI rechtstreeks met SPS programmeren via TIS.

Sommige zelftests werken niet

Tech2-zelftests zijn bedoeld om verschillende delen van de Tech2-hardware te testen. Voor sommige van deze tests is een loopback-adapter nodig. Deze tests werken niet in Tech2Win, omdat de loopback-adapterfunctie niet is geïmplementeerd (en hiervoor zijn ook geen plannen). U wordt gevraagd dergelijke betekenisloze tests niet in Tech2Win uit te voeren. Als u dit wel doet, kunt u foute resultaten krijgen of kan Tech2Win blijven hangen, net zoals Tech2 dat zou doen zonder loopback-adapter. Stel Tech2Win in een dergelijk geval terug met Ctrl-R.

De snelheidsindicator schommelt

De snelheidsindicator linksonder op de statusbalk geeft aan hoeveel 'Tech2-opdrachten' kunnen worden uitgevoerd voordat Tech2Win weer in de 'slaapstand' moet gaan. Deze methode wordt gebruikt om er zeker van te zijn dat de tijd op de Tech2Win overeenkomt met de werkelijke tijd: snellere pc's zullen vaker naar de slaapstand gaan dan langzame pc's. Indien de snelheidsindicator schommelt, kan het zijn dat een andere toepassing rekenvermogen gebruikt, of dat de processorsnelheid afwijkt. Sterke schommelingen hebben een negatieve invloed op de communicatie met de auto en met TIS2Web. Zorg ervoor dat er geen andere toepassingen zijn gestart.

Bij de meeste laptops kan de processorsnelheid automatisch worden verlaagd, zodat de accu minder snel leegraakt. Dit kan ook de oorzaak zijn van de wisselende snelheden die door Tech2Win worden vastgesteld. Gebruik in dat geval netspanning voor uw laptop, in plaats van de interne accu. U kunt ook proberen om de energie-instellingen aan te passen, zodat de processorsnelheid niet wordt verlaagd door het besturingssysteem.

Plotseling stoppen

Als u geen reden in het logboekbestand kunt vinden waarom het programma werd afgesloten, dan is het mogelijk dat de interne beveiligingsmechanismen van Tech2Win werden geactiveerd. Knoei niet met de volgende bestanden: emulator.sec, emulator.lic, emulator.card. Als Tech2Win een schending van de beveiliging waarneemt, zult u de software waarschijnlijk opnieuw moeten installeren.

Software 15.001 wordt in het Zweeds weergegeven

Het beginprogramma dat met Tech2Win wordt meegeleverd, is een demonstratieprogramma dat op elke nieuwe PCMCIA-kaart staat. TIS2Web geeft aan dat dit in de Zweedse taal is, aangezien TIS2Web alleen de laatste taal weergeeft uit de lijst met de vier ondersteunde talen van dit demonstratieprogramma (Engels, Frans, Duits en Zweeds). Gebruik de Updatemodus 'Aangepast' in plaats van 'Standaard' om dit demonstratieprogramma te overschrijven met het nieuwste diagnoseprogramma.

Communicatie met de MDI verbroken

Een onderbreking in de MDI-communicatie kan verschillende oorzaken hebben.

  • Slechte kabelverbinding (zowel Ethernet als USB).
  • Instabiele draadloze verbinding.
  • Pc gaat in stand-by.

Tech2Win heeft mijn MDI niet gevonden.

Gelieve de volgende punten te controleren:

    1. Is de MDI actief?
    2. Functioneert de MDI Manager?
    3. Wordt de MDI gebruikt door een andere applicatie, bijv. SPS?
U kunt de MDI Manager starten met het bureaubladpictogram of via 'Starten/Alle programma's/General Motors/GM MDI Software'.: Gelieve de Helpdesk te bellen indien punt 2 niet werkt.

Ik wil Tech2Win meteen starten zonder tussenkomst van de configurator.

Voer "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf" uit. Gebruik de volgende werkmap: 'C:\Program Files\General Motors\Tech2Win\bin' U kunt met de configurator nog steeds wijzigingen in de configuratie aanbrengen.

Waar bevinden zich de afdrukfuncties?

Tech2Win biedt geen rechtstreekse afdrukfunctie. In plaats daarvan maakt het tijdelijke bestanden en opent het de programma's die verbonden zijn met de bestandsextensies. Deze programma's kunnen worden gebruikt voor afdrukdoeleinden, waarmee u de weergave van uw afdruk kunt aanpassen.

Print Report | Print Report

Om het huidige Tech2Win-scherm af te drukken, gebruikt u het menu-item Bestand / Scherm afdrukken of de knop op het toetsenbord waarop een printer staat afgebeeld. Wanneer u verschillende Tech2Win-schermen moet afdrukken, dan kan het menu-item Opties / Automatische screenshots worden gebruikt omdat hiermee PNG-bestanden worden gemaakt voor elk Tech2Win-scherm. Deze PNG-bestanden worden in het logboekbestand opgenomen.

U kunt ook de inhoud van de gegevensweergave afdrukken (wordt geactiveerd met behulp van menu-item Vensters / Gegevensweergave Tech2Win). Gebruik de toets Afdruk/HTML starten om de gegevensacquisitie te starten en te stoppen. Nadat de acquisitie is gestopt, wordt het uitvoerbare programma dat gekoppeld is aan HTML-bestanden (gewoonlijk Internet Explorer) gestart, waarmee u over voldoende functies beschikt om uw gegevens af te drukken.

Data Display | Data Display

Een 'ongebruikte' PCMCIA-map is aanwezig op mijn computer

Vorige versies van Tech2Win hadden altijd een dubbele opslag van PCMCIA-bestanden in een afzonderlijke map. Deze map heette vaak C:\PCMCIA. Nu wordt deze map niet meer gebruikt, omdat de snelle download vanaf TIS2Web een tweede opslag van dergelijke downloads overbodig heeft gemaakt. U kunt deze map nu veilig wissen.

Ik krijg de melding 'ongeldig bestandspad' te zien

De bestandsnaam lijkt ongeldige tekens te bevatten, zoals het procentteken (%). Wanneer u dit probleem direct na de installatie constateert, kunt u het beste de installatie ongedaan maken en een nieuwe installatie uitvoeren. In de meeste gevallen kan het probleem met behulp van deze methode worden opgelost.

Tijdens normale installaties wordt de omgevingsvariabele 'Tech2WinUserData' ingesteld in 'PUBLIC' (voor Windows-versies >= Vista) en in 'ALLUSERSPROFILE\Documents' (voor Windows-versies ouder dan Vista). In enkele uitzonderlijke gevallen is de omgevingsvariabele niet ingesteld tijdens het installatieproces, maar werkte het prima tijdens een tweede poging. U kunt er ook voor kiezen om de omgevingsvariabele met de hand in te stellen. Vraag uw systeembeheerder om hulp wanneer u niet weet hoe u een omgevingsvariabele moet instellen.


Registervermeldingen

De volgende registervermeldingen worden aangemaakt door het installatieprogramma. Wijzig deze vermeldingen niet handmatig. Houd rekening met de standaardwaarschuwing in Windows bij het werken met registervermeldingen.

registersleutel | naam | type | betekenis
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Intern versienummer
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Taal | REG_SZ | geïnstalleerde taal
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Pad voor de PCMCIA-kopieerdirectory's
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Hoofdmap | REG_SZ | installatiepad
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Verwijderoptie | REG_DWORD | Instelling voor verwijderen
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Versie van het configuratiebestand
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Versie van het virtuele COM-poortstuurprogramma
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Softwarenaam in de Softwarelijst
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Pad naar het uninstall-programma


Herinstalleren

Bij de herinstallatie wist u de complete installatiemap van Tech2Win met de volgende uitzonderingen.

  1. De submap config met de configuraties wordt niet gewist.
  2. De submap pcmcia met daarin gewoonlijk de PCMCIA-kopieën wordt niet gewist.
  3. De submap ATA met wellicht foutopsporingsinformatie wordt niet gewist.
Configuratiebestanden worden mogelijk incompatibel: er is geen garantie dat configuratiebestanden van een oude versie van Tech2Win leesbaar zijn door een nieuwere versie van Tech2Win. PCMCIA-afbeeldingen kunnen in principe niet incompatibel worden.

De map met de secundaire PCMCIA wordt intact gelaten bij het herinstalleren.

Sommige milieus bieden de mogelijkheid tot automatische installatie van een nieuwere versie van Tech2Win. Aangezien de recentste installatie-informatie opgeslagen ligt in het register, worden deze instellingen aangedragen als standaardinstellingen tijdens het herinstalleren.

U kunt het opnieuw installeren van Tech2Win forceren met het script enable reinstallation. Dit script wordt samen met Tech2Win geïnstalleerd. Eenvoudig gezegd, stelt dit script de waarde in van de sleutel CurrentVersion die in het register te vinden is bij HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win met een waarde van '1.000'