Tech2Win 사용자 매뉴얼

Tech2Win 사용자 매뉴얼을 시작합니다.

Copyright (C) 2010..2016 SPO Engineering General Motors 모든 권한 보유.

  • 소개:
  • 라이선스:
  • 설치:Tech2Win의 설치 절차 설명.
    • 설치 단계
    • 차량 통신 인터페이스
  • 첫 번째 단계
    • 구성 선택
      • 키보드
      • 창 처리
    • 새 구성
    • 구성 수정
      • 언어
      • 경로
      • 디스플레이
      • 구성 저장
    • 유효한 Tech2Win 라이선스가 필요합니다.
  • Tech2Win으로 작업하기: 일상 작업 세부 정보.
    • 메뉴
    • PCMCIA 이미지 다운로드
    • 보안
    • 보고서 보기
    • PCMCIA 이미지 처리
    • 상태 표시줄
  • 고급 주제: Tech2Win의 정상적인 사용에 필요하지 않은 정보. 관리를 수행하는 사람들이나 관심을 가질 정보일 수 있습니다.
    • 재설치
    • 제거
    • 구성 파일의 형식
    • 로그 파일
    • 오류 메시지 및 오류 코드
    • ATA 카드
    • 레지스트리 항목
    • 파일
    • 구성 관리
  • FAQ


소개

Tech2Win은 Tech2 기능을 에뮬레이션하는 Windows 응용 프로그램입니다. 기본적으로 Tech2 소프트웨어는 PC에서 실행됩니다. 이 프로그램을 PC에서 실행하려면 다음 기술 요구 사항을 만족해야 합니다.

  • 차량 통신 인터페이스가 설치되고 PC에 연결되어야 합니다. 허용되는 인터페이스 목록은 지역에 따라 다를 수 있습니다. 대부분의 경우 GM MDI(Multiple Diagnostic Interface: 다중 진단 인터페이스)가 사용됩니다.
  • Tech2Win 응용 프로그램은 설치 시 150MB의 하드 디스크 공간이 필요합니다. 관리하려는 PCMCIA 플래시 카드당 추가 32MB가 필요합니다.
  • Tech2Win을 실행하기 전에 최소 100MB의 비어 있는 물리적 RAM이 필요합니다. PC에 전체 실행 시간에 걸쳐서 RAM 내부에 응용 프로그램을 수용할 수 있을 정도의 충분한 메모리가 필요합니다.
  • PC는 1.2GHz Pentium (싱글 코어)에 해당하는 성능이어야 합니다. 다른 응용 프로그램을 동시에 사용하지 않는 것이 좋습니다.
  • 키보드가 필요합니다. Tech2Win은 터치스크린으로도 작동할 수 있습니다. 구성을 관리하기 위해서는 파일 이름을 입력해야 하므로 키보드를 사용하는 게 좋습니다.
  • 컬러 그래픽 디스플레이에는 최소 800 x 600의 해상도 및 최소 256의 색 농도가 있어야 합니다. 키패드가 없으면 640 x 480의 해상도도 허용될 수 있습니다.

Tech2Win을 사용(Tech2 대신 랩톱)할 때에는 랩톱에 충분한 전원이 있어야 합니다. Tech2와 마찬가지로 차량 배터리를 랩톱 전원으로 사용할 수 없습니다.

  • 설치
  • 첫 번째 단계


라이선스

Genearl Motors Europe - Tech2Win 라이센스 협약

이 프로그램을 사용하기 전 다음 조건을 주의깊게 읽어주시기 바랍니다. 이와 같은 조건에 동의하거나 이를 이해하지 못한 경우, 해당 지역 A/S 대리점으로 문의해 주십시오. 이 소프트웨어를 사용하는 권한은 사용자가 Tech2Win 설치 시 위와 같은 조건을 수락하여 이 라이센스에 동의한다는 전제 하에서만 Genearl Motors Europe을 통해 허가됩니다.
지역 해당 공식 정비업체가 Genearl Motors Europe 각국 판매업체와의 협약을 통해 결정된 대로 Genearl Motors Europe은 Tech2Win 소프트웨어 및 TIS2Web 또는 GlobalTIS 또는 TIS2000 관련하여 포함된 정보의 사용 권한을 Genearl Motors Europe 공식 정비업체 네트워크의 사용자에 한해 인정하고 있습니다.
Tech2Win 라이센스는 승인된 수리업체 협약이 효력이 있고 TIS2Web, GlobalTIS 또는 TIS2000 라이센스가 유효한 한 효력이 있습니다. 수리 공장 계약 승인이 끝나는 것과 동시에 Tech2Win 라이센스는 TIS2Web 및 GlobalTIS 계약과 함께 종료됩니다.

EU의 BER(Block Exemption Regulation) 1400/2002의 제 4조 2항에 규정된 독립 수리업체는 General Motors Europe의 GM Europe Info Tech Portal에 제공된 가입 계정의 일부로 Tech2Win 라이센스를 구매할 수 있습니다.

이 Tech2Win 라이센스에는 차량 통신 인터페이스 또는 PC 하드웨어가 포함되지 않습니다.

Tech2Win 소프트웨어는 관련 General Motors 각국 판매업체의 서면 동의 없이 (공식 정비업체 협약에 대한 관련 부록에 설명된 대로) 공식 정비업체 설비 이외의 제 3자에 추가적으로 배포, 판매 또는 온라인 상에 공시되지 않습니다. 이 사항은 현재 유효한 데이터는 물론 현재 유효하지 않은 데이터(예: 만료된 DVD)에 모두 적용됩니다.

General Motors 각국 판매업체는 무단 사용 또는 악용 시 공식 정비업체 협약 접근을 바로 중단시키고 즉각적으로 차단시킨다는 통보를 할 수 있습니다. 이 경우, 잔액 및 연간 기본료에 대한 보상 청구 권한은 포함되지 않습니다.

제공된 정보는 변경되지 않은 General Motors 차량을 전문적인 방식으로 서비스 및 수리 작업을 실시하는데 도움이 됩니다. 앞서 언급된 작업을 실시하기 위한 전제 조건으로는 완전한 자동차 정비사 교육 및 정기 추가 교육이 필요합니다. 특수 공구 사용이 이 정보에 언급된 경우, 이와 같은 공구가 있어야 모든 수리 작업을 전문적으로 실시할 수 있습니다.

General Motors의 Global TIS에 수록된 정보(텍스트 및 그림, 음악, 그래픽, 동영상, 비디오 등) 및 구성 방식은 저작권의 보호를 받습니다. General Motors의 사전 동의가 없는 경우, 복제, 배포, 전달 및/또는 전송이나 기타 사용은 불가능합니다.

  • 설치: 설치 단계
  • 첫 번째 단계


Installation

설치

Tech2Win을 설치하려면 PC에 대한 관리자 권한이 필요합니다. 관리자 권한이 없으면 설치를 실시할 수 없습니다. 이러한 경우, PC 관리자에게 연락하여 도움을 요청하십시오.

Tech2Win을 성공적으로 사용하려면 다음 두 단계를 완료해야 합니다.

  • Tech2Win 자체의 설치.
  • 차량 통신 인터페이스의 설치.
  • 설치: 설치 단계
  • 첫 번째 단계


설치 단계

설치 자체는 몇 분밖에 걸리지 않으며 다음과 같은 사용자 입력이 필요합니다.

  1. 사용권 계약
  2. 설치 디렉터리

언어

기본 설정에 따라 Tech2Win UI는 운영 체제 언어로 표시됩니다. 일반적으로 다음 언어가 지원됩니다. 사용자 언어가 지원되지 않는 경우, 설치 프로그램은 기본 설치 언어인 영어로 시작됩니다.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)영어 (영국 또는 미국)*
  • el_GR (EL)Greek
  • es_ES (ES)스페인어
  • fi_FI (FI)Finnish
  • fr_FR (FR)프랑스어
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)포르투갈어 (브라질)
  • pt_PT (PT)포르투갈어 (포르투갈)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)중국어 (간체)
  • zh_TW (ZH)중국어 (번체)

* Tech2Win 언어는 영국 영어입니다. 그러나 Tech2 소프트웨어 및 사용되는 설치 프로그램은 소프트웨어의 소스에 따라 미국 영어일 수도 있습니다.

사용권 계약

사용권 계약을 승인해야 합니다.

설치 디렉터리

Tech2Win이 설치될 장소로 어느 디렉터리든 선택할 수 있습니다. 설치 디렉터리는 <프로그램 디렉터리>\General Motors\Tech2Win로 기본 설정되어 있습니다. 재설치인 경우, 이전에 지정된 위치로 기본 설정됩니다.

마지막 단계에서 설치를 확인합니다.

가상 COM 포트 드라이버

가상 COM 포트 드라이버는 컴퓨터에 한 번만 설치되며, 드라이버 버전이 업그레이드되거나(가끔 발생함) 컴퓨터에서 Tech2win이 제거될 때까지 유지됩니다.
드라이버가 설치되는 경우, DOS 상자가 잠깐 표시됩니다. 이는 자동으로 닫히며, 별도의 작업이 필요하지 않습니다. 드라이버 파일은 Tech2Win 설치 디렉터리의 '드라이버' 하위 폴더에 추가로 저장됩니다.
가상 COM 포트 드라이버는 수동으로 설치하거나 제거할 수 있으나 이를 권장하지 않습니다. CMD 셸에서 다음 명령들 중 하나를 사용합니다.

  • 드라이버를 설치하려면 'vbsetup7'을 호출합니다.
  • 드라이버를 제거하려면 'vbsetup7 /u'를 호출합니다.
  • 첫 번째 단계


차량 통신 인터페이스

차량 통신 장치가 별도로 설치되어 있어야 합니다. 차량 통신 인터페이스와 함께 제공되는 해당 설치 안내를 참조하십시오.

  • 첫 번째 단계: 차량 통신 인터페이스
  • 고급 주제: 구성 파일
  • 설치: 설치 단계
  • FAQ: 하나가 넘는 MDI를 사용하려면 어떻게 합니까?
  • FAQ: Tech2Win가 내 MDI를 찾지 못합니다


첫 번째 단계

이들 첫 번째 단계에서는 Tech2Win 사용법을 보여줍니다. 사용자가 Tech2 자체와 친근하다고 가정합니다. 이들 첫 번째 단계에서는 차량 통신이 필요하지 않습니다.

빠르게 시작하려면 다음 단계를 실행하십시오.

  1. 바탕 화면에서 빠른 시작 바로 가기를 사용하여 Tech2Win 소프트웨어를 실행하십시오.
  2. TIS2Web에서 새 Tech2 소프트웨어를 다운로드하여 유효한 라이선스를 받으십시오.

선택 가능 구성을 사용하려면 다음을 실시하십시오.

  1. 바탕 화면에서 Tech2Win 바로 가기를 사용하여 구성자를 시작합니다. 설치 후에는 기본 구성이 있어야 합니다.
  2. 새 구성을 만들려면 기본 구성을 복사하는 것이 좋습니다.
  3. 사용자의 특정 요구 사항이 있는 경우 기존 구성을 수정합니다.
  4. 유효한 라이선스가 필요합니다.

Tech2Win을 호환 모드로 시작하지 마십시오. 그러한 경우 로그 파일에 경고가 나타납니다. Tech2Win은 XP 이후 버전에 있는 윈도우 기능만 사용하고, 이전 버전의 윈도우에서는 작동되지 않습니다.

  • 첫 번째 단계: 새 구성
  • 첫 번째 단계: 구성 수정
  • 첫 번째 단계: 차량 통신 인터페이스
  • Tech2Win으로 작업하기: 메뉴
  • Tech2Win으로 작업하기: 보안
  • Tech2Win으로 작업하기: 상태 표시줄
  • 고급 주제: 구성 파일


구성 선택

Tech2Win 응용 프로그램을 최초로 시작하면 다음 화면이 나타납니다. 기본 구성을 이용하여 Tech2Win을 직접 시작할 수도 있습니다. 이러한 기본 구성은 차량 통신이 없이도 작동합니다.

Start First Time

라이선스 정보 메시지 상자가 나타납니다. 그러나 이를 무시하고 기본 구성을 시작할 수 있습니다.

터치스크린으로 작업하는 경우, 키보드를 시뮬레이션하는 이 응용 프로그램을 통해 PC 키보드 프로그램을 시작하여 문자를 입력할 수 있도록 하는 것이 좋습니다.


키보드

단추는 물론 PC 키들이 친근한 Tech2 키들로 매핑됩니다. Tech2에는 없는 일부 추가적인 키들이 Tech2Win에 의해 제공됩니다. PC의 숫자 키패드가 모든 조건에서 작동하지는 않을 수도 있습니다. 문제가 있는 경우, PC의 표준 키보드 레이아웃이 변경되었는지 확인하십시오. 특히 그러한 경우 SHIFT 키가 손상되었을 수도 있습니다.

PC 키보드 | 단추 | 기능
F1 기능 키 | 해당 없음 | Tech2Win 도움말
F5 .. F8 기능 키 | 소프트키가 표시된 Tech2Win 디스플레이 영역을 사용하십시오 | Tech2의 네 가지 소프트키
위로, 아래로, 왼쪽, 오른쪽 커서 키 |  | Tech2 위로, 아래로, 왼쪽, 오른쪽 키. 이들 키에만 자동 반복 기능이 있습니다.
0 .. 9 키 | F0 • • • F9 | Tech2 F0 .. F9 키
백스페이스 | Exit | Tech2 종료 키
Enter / Return | Enter | Tech2 Enter 키
Y | Yes | Tech2 Yes 키
N | No | Tech2 No 키
Q | ? | Tech2 ? 키
S | Shift | Tech2 Shift 키. 상태 표시줄의 Shift 표시기 또는 Shift 단추 위의 표시기는 상태를 나타냅니다.
ctrl-P | PWR | Tech2 Power 키; 이 키는 Tech2Win 응용 프로그램을 끌 수만 있습니다.
ctrl-R | 사용할 수 없음 | Tech2Win 초기화. Tech2의 전원 Off/On 주기와 유사합니다. 그러나 부착된 차량 통신 인터페이스는 초기화되지 않습니다. PCMCIA 이미지 등과 같은 파일은 다시 로드되지 않습니다.
홈 | Home | 홈 키 일부 응용 프로그램에 의해서만 지원됩니다.
메뉴 옵션 파일을 통해서만 이용할 수 있습니다. | Print Screen | 임시 BMP 파일을 만들고 BMP 파일과 연결된 응용 프로그램을 호출하여 Tech2 화면의 스크린샷을 인쇄합니다. 인쇄 전에 이미지 크기를 변경하거나 회전시키려면 이 응용 프로그램을 사용하십시오.
메뉴 옵션 파일을 통해서만 이용할 수 있습니다. | Save Screen | Tech2 화면 스크린샷을 BMP 또는 PNG 파일로 저장합니다.
메뉴 옵션 파일을 통해서만 이용할 수 있습니다. | View Report | 활성 상태인 PCMCIA 플래시 카드에 대한 모든 보고서가 표시되며 따라서 사용자가 볼 수 있습니다.


창 처리

표준 Windows 메커니즘을 사용하여 메인 창의 테두리 줄을 끌어 창들의 크기를 수정할 수 있습니다. 또한, 메뉴 항목 옵션/해상도은 여러 사전 설정된 크기를 지원합니다. 메뉴 항목을 통해 메인 창의 크기를 변경하는 동안 키패드 창이 자동으로 도킹 상태로 유지될 수 있습니다.

창들의 모양은 디스플레이 탭의 구성을 변경하여 수정할 수 있습니다.


새 구성

새 구성을 만들려면 새로 만들기 단추를 클릭합니다. 대화 메뉴가 나타나 기존 구성 파일을 소스로 선택할 것을 요청합니다. 일반적으로 기본 구성을 선택합니다. 새 구성 파일 이름을 입력한 후 복사 단추를 누릅니다.

터치스크린으로 작업 중인 경우, PC 키보드 단추를 통해 PC 키보드 시뮬레이션을 활성화할 수도 있습니다.

취소 단추를 이용해 만드는 과정을 취소할 수 있습니다.

새 구성은 동일한 PCMCIA 파일을 기존 원본 구성으로 사용합니다. 이를 변경하려면 다른 PCMCIA 파일이 사용되도록 구성을 수정해야 합니다. 대부분의 경우 기존 PCMCIA 파일을 새 파일로 복사하고, 이 새 파일을 사용합니다. 새 구성이 동일한 PCMCIA 파일을 원본 구성으로 사용하도록 할 수도 있습니다. 이러한 경우, 저장 단추를 누르면 경고 화면이 나타납니다.

  • 구성 수정


구성 수정

청색으로 표시된 구성은 읽기 전용으로 표시된 것으로서 수정할 수 없습니다. 이들 구성은 볼 수만 있습니다. 수정 방법을 사용하여 그 내용을 볼 수는 있지만 저장는 불가능합니다.

구성은 네 개의 태뷸레이터 언어, 차량 통신 인터페이스, 경로, 디스플레이에서 개별 설정을 선택하여 수정합니다. 원하는 태뷸레이터를 선택하거나 다음 태뷸레이터를 활성화시키는 다음 단추를 누를 수도 있습니다. 수정을 한 후에는 저장 단추를 눌러 구성을 저장하십시오.

키보드 입력이 필요한 경우, PC 응용 프로그램을 불러와 PC 키보드를 시뮬레이션할 수 있습니다. 이는 키보드가 없는 터치스크린 랩톱 컴퓨터의 경우 특히 편리합니다.


언어

태뷸레이터 언어를 통해 Tech2Win이 실행될 언어를 선택할 수 있습니다. 이 선택으로 인해 PCMCIA 이미지의 Tech2 소프트웨어 내의 언어가 영향을 받지는 않습니다. TIS에서 Tech2 소프트웨어를 다운로드할 때 올바른 언어를 선택해야 합니다.

일부 지역의 경우, 모든 언어가 제공되지는 않습니다. 그러한 경우, 영어가 표시됩니다. 유사 언어를 사용할 수 있는지 확인하십시오 (예: PB 브라질 포르투갈어 대신 PB 포르투갈 포르투갈어).


경로

태뷸레이터 경로를 통해 PCMCIA 이미지 둘 모두의 경로와 로컬 소프트웨어 키보드 경로를 설정할 수 있습니다. 또한, PCMCIA 이미지를 복사하기 위해 복사 메모리 카드 ... 단추가 제공됩니다. 새 구성을 만든 경우, 이 단추를 사용하여 동일한 PCMCIA 이미지를 사용하는 여러 구성들을 방지할 수 있습니다.

Memory Card Options

복사 메모리 카드 ...

이 단추를 통해 PCMCIA 이미지를 다른 파일로 복사할 수 있습니다. 이 기능은 마치 Tech2용으로 새로운 PCMCIA 카드를 구입하는 것이나 마찬가지입니다. 복사 기능은 디렉터리 C:\Users\Public\General Motors\Tech2Win\pcmcia의 파일에 대해서만 작동합니다.

슬롯 0 : 메모리 카드 이미지 위치

여기서는 슬롯 0의 PCMCIA 이미지를 포함하는 파일을 지정할 수 있습니다. 일반적으로 이러한 파일은 C:\Users\Public\General Motors\Tech2Win\pcmcia에 있으나 다른 위치도 가능합니다.

슬롯 1: 메모리 카드 또는 ATA

Tech2와 마찬가지로 Tech2Win도 두 개의 PCMCIA 카드(이미지)를 지원합니다. 그러나 구성 내의 두 번째 PCMCIA 이미지는 일반적으로 그리 유용하지 않습니다. 두 번째 소프트웨어는 두 번째 구성에서 사용할 수도 있습니다.

Tech2와 마찬가지로 ATA 카드는 디버깅 목적으로 사용됩니다. 기술지원 팀의 지시가 있는 경우에만 ATA 카드를 활성화시키십시오. 기술지원 팀이 추가 정보를 제공할 것입니다.

PC 소프트웨어 키보드 위치

이 파일의 기본값을 Windows 레지스트리에서 검색하여 마우스로 PC 키보드를 시뮬레이션할 수 있는 프로그램이 표시됩니다. 사용 중인 랩톱용으로 이 기능을 가진 특수 응용 프로그램이 있는 경우, 여기서 그 응용 프로그램을 지정할 수 있습니다.


차량 통신 인터페이스

  • Tech2-RS232-에뮬레이션용 COM-포트
  • 사용을 위한 MDI 시리얼 번호:
  • 프로토콜

Tech2-RS232-에뮬레이션용 COM-포트

Tech2 에뮬레이션용으로 사용할 수 있는 사용 중이지 않은 COM 포트를 선택하십시오. 사용자의 편의를 도모하기 위해 구성자는 어떤 직렬 포트들이 이미 사용 중인지를 알아내어 이들을 표시합니다.

기존 COM 포트를 선택하는 경우, Tech2Win은 이 기존 COM 포트로 연결됩니다. 이 COM 포트를 사용하여 null 모뎀 케이블을 통해 TIS 응용 프로그램을 실행하는 두 번째 컴퓨터로부터 Tech2 소프트웨어를 다운로드할 수 있습니다. 실제 COM 포트를 사용하는 경우, Windows 제한으로 인해 115.200 보드로 안정적으로 작동하지 않을 수도 있습니다.

존재하지 않는 COM 포트를 선택하면 Tech2Win은 자동으로 가상 포트를 만듭니다. 동일한 PC에서 실행되는 TIS에서 이 가상 포트를 사용하여 Tech2Win과 통신을 설정할 수 있습니다. 가상 포트를 사용하는 경우에는 전송 속도 제한이 없습니다.

'검색'을 COM 포트로 선택하면 Tech2Win은 9~1 범위 내에서 첫 번째 사용되지 않는 포트를 가상 COM 포트로 만듭니다.

사용을 위한 MDI 시리얼 번호:

MDI의 일련번호를 입력하십시오. 번호는 MDI의 뒤쪽에 있습니다. 하이픈 뒤의 번호를 사용하십시오.

일련번호를 입력하지 않는 경우, Tech2Win은 네트워크에서 감지된 MDI의 목록을 자동으로 표시하여 사용자가 MDI를 선택할 수 있도록 합니다. 지정된 MDI를 찾을 수 없는 경우, 동일한 선택 상자가 나타납니다.

프로토콜

'ISO22900-2 / PDU-API'이 선택되었으며 J2534-2은 항상 회색으로 표시됩니다. 향후에는 Tech2Win이 J2534 프로토콜도 지원할 수 있게 될 것입니다.

  • 고급 주제: 구성 파일
  • FAQ: Tech2Win용으로 어느 COM 포트를 사용해야 하는지 어떻게 판단합니까?
  • FAQ: Tech2Win과 TIS2Web 간의 통신
  • FAQ: 하나가 넘는 MDI를 사용하려면 어떻게 합니까?
  • FAQ: Tech2Win가 내 MDI를 찾지 못합니다


디스플레이

디스플레이 탭은 주로 Tech2Win의 디스플레이 관련 설정을 변경하는 데 사용됩니다.

  • 키패드
  • 색상
  • 사운드
Display and Key Options

키패드

여기서 키패드가 표시되어야 하는지 여부를 선택할 수 있습니다. 키패드는 Tech2Win 화면의 좌측 또는 우측에 표시됩니다. 백그라운드 색은 표준 색 대화 상자를 통해 선택할 수 있습니다.

색상

여기서 Tech2 스크린의 백그라운드 및 포그라운드 색을 개별적으로 선택할 수 있습니다. 다음과 같은 두 개의 가장 일반적인 색 조합이 있습니다.

Screen with background 0000FF, foreground FFFFFF | 키패드 백그라운드 백색; 백그라운드 청색; 포그라운드 백색
Screen with background 000000, foreground C0C0C0 | 키패드 백그라운드 청색; 백그라운드 흑색; 포그라운드 연한 회색

사운드

여기서 사운드를 끌 수 있습니다. Tech2프로그램에서 경고음이 울릴 때마다 PC 스피커가 사용됩니다.


구성 저장

활성 상태인 구성은 좌측 하단 모서리의 저장 <구성> 단추를 눌러 저장할 수 있습니다. 읽기 전용 구성을 보고 있는 경우, 이 단추가 나타나지 않습니다.


TIS2Web을 통한 유효한 라이선스

일반적으로 Tech2 소프트웨어를 Tech2Win으로 다운로드하면 유효한 라이선스가 제공됩니다. 또한 TIS2Web (TIS2000 아님)을 통해 '보안 액세스 (보안)' 를 실행하여 보안 액세스 권한을 얻을 수도 있습니다. 따라서 전제 조건은 Vehicle Communication Interface에서 구성자 내의 가상 COM 포트를 선택하는 것입니다.

보안 액세스가 성공적으로 완료되면 상태 표시줄 우측에 열려 있는 자물쇠 표시가 나타납니다. 괄호 안에는 라이선스가 유효한 일수가 표시됩니다. Tech2Win을 다시 시작하면 차량 통신 실시 중이 아닌 한 보안 표시기가 표시되지 않습니다. 차량과의 첫 번째 통신 시 라이선스가 확인되고, 표시기에 열린 자물쇠나 잠긴 자물쇠가 표시됩니다.

  • Tech2Win으로 작업하기:보안
  • FAQ:Tech2Win용으로 어느 COM 포트를 사용해야 하는지 어떻게 판단합니까?
  • FAQ:Tech2Win과 TIS2Web 간의 통신
  • FAQ:유효한 라이선스
  • FAQ:Tech2Win 라이선스와 보안 액세스의 차이는 무엇입니까?


Tech2Win으로 작업하기

다음 주제들은 Tech2Win으로 작업할 때 대부분의 정비사들에 의해 사용됩니다.

  • 메뉴: 화면 레이아웃 및 개별 메뉴 항목.
  • PCMCIA 이미지 다운로드: Tech2Win용 진단 소프트웨어의 업데이트 방법은 Tech2에 사용되는 방법과 유사합니다.
  • 보안: 보안 조치로 인해 Tech2Win이 인가되지 않은 환경에서 차량 통신을 실시하는 것이 금지됩니다.
  • 보고서 보기: Tech2 키보드가 Tech2Win에서 다소 향상되었습니다. '보고서 보기' 단추가 가장 대표적인 예입니다.
  • PCMCIA 이미지 처리: Tech2용으로 복수의 PCMCIA 카드가 있는 것과 마찬가지로 Tech2Win용으로 여러 PCMCIA 이미지가 있을 수 있습니다.
  • 상태 표시줄: 상태 표시줄에는 상태 표시줄의 개별적인 부분에 대한 정보가 표시됩니다.
    • 고급 주제
    • FAQ


메뉴

Tech2Win 응용 프로그램에는 다음과 같은 메뉴 항목이 있습니다.

  • 파일
  • 옵션
  • 창
  • 도움말

파일

파일 메뉴는 다음과 같은 가능성을 제공합니다.

  • T2-화면 (320x240)을 저장하십시오.은 320x240 픽셀 크기의 실제 T2-화면을 흑백 사진 파일로 PC에 저장하는 데 사용됩니다. 저장 위치와 파일 형식(BMP, GIF, JPG, PNG)은 자유롭게 선택할 수 있습니다.
  • 화면을 프린트하십시오.은 Tech2 화면의 반전된 흑백 BMP-이미지를 만들고 BMP 파일과 연결된 프로그램을 불러옵니다. 그런 다음 이 프로그램을 사용해서 이미지를 인쇄할 수 있습니다.
  • 보고서 파일 보기: TIS2Web을 사용하지 않고 보고서 파일 보기 (및 인쇄) 가능성 제공.
  • 종료: Tech2Win 종료.

옵션

옵션은 다음과 같은 선택 항목을 제공합니다.

  • 해상도: 세 가지 표준 화면 크기 중 하나를 선택하는 데 사용 가능.
  • ROM-Write from 0x00003ED76: 내부 디버깅 목적으로 사용.
  • 자동 스크린샷: 모든 다른 Tech2 화면의 이미지를 로그 디렉터리에 저장.
  • CANdi를 사용불가하게 하고 다시 부팅한다: 차량과의 사이에 CANdi가 없는 Tech2 모방. 이는 CANdi가 비표준 차량 통신 라인을 방해하는 이례적인 경우에 필요합니다.

창

메뉴창를 통해 선택 항목 Tech2Win 데이터 디스플레이 및 Tech2Win DTC 디스플레이을 활성화할 수 있습니다. 다른 모든 선택 항목은 현재 Tech2Win 버전에서는 회색으로 표시됩니다.

Tech2 소프트웨어가 Tech2Win 데이터 디스플레이 를 지원하는 경우 이 메뉴 항목을 활성화할 수 있습니다. 데이터 디스플레이를 입력하면 Tech2Win은 Tech2 데이터 디스플레이와 병렬로 추가 데이터 디스플레이 창을 표시합니다. Tech2 화면에 Data Display가 표시되는 한 메뉴 항목을 활성화할 수 없습니다. 이러한 경우 '데이터 디스플레이'를 종료하고, 메뉴 항목을 활성화한 후 '데이터 디스플레이'를 다시 시작합니다.

비슷한 Tech2Win 데이터 디스플레이에 대한 제한 사항이 Tech2Win DTC 디스플레이에도 적용됩니다. Tech2 소프트웨어가 Tech2Win DTC 디스플레이 를 지원하는 경우 이 메뉴 항목을 활성화할 수 있습니다. 추가 DTC 디스플레이 창이 Tech2 DTC 디스플레이와 병행으로 나타납니다. Tech2 화면에 DTC Display가 표시되는 한 메뉴 항목을 활성화할 수 없습니다. 이러한 경우 'DTC 디스플레이'를 종료하고, 메뉴 항목을 활성화한 후 'DTC 디스플레이'를 다시 시작합니다.

도움말

다음과 같은 선택 항목을 사용할 수 있습니다.

  • 도움말 제목...: Tech2Win 도움말 불러오기.
  • 명령 라인 매개변수: Tech2Win용으로 사용되는 명령 줄 매개 변수 표시.
  • 정보는 Tech2Win의 현재 버전 번호 및 TIS2Web 다운로드 제한을 표시합니다.


다운로드

먼저 Tech2Win을 시작하고 메인 화면 상태로 놔둡니다. TIS2Web 또는 GlobalTIS를 시작하고 차량 통신 인터페이스 탭에서 지정된 COM 포트를 통해 다운로드를 실시하십시오.

내장 COM 포트가 사용되어 TIS가 실행 중인 다른 PC로부터 Tech2 소프트웨어를 다운로드합니다. RS232 크로스와이어 케이블을 사용해야 합니다. Tech2Win이 실행되는 PC의 하드웨어에 따라 빠른 전송 속도에서는 Windows가 데이터를 손실할 수 있기 때문에 데이터 전송 속도가 57.600보드로 낮아질 수 있습니다.

최신 Tech2Win 버전은 또한 TIS2Web 및 Tech2Win가 동일한 PC에서 실행되는 경우, 빠른 다운로드를 지원합니다. COM 포트를 통한 TIS2Web과 Tech2Win 간의 최소 통신이 실시 중입니다. 그러나 시간이 많이 걸리는 Tech2Win에 대한 데이터 전송이 내부 파일 전송으로 교체되었습니다. 이러한 경우, 다운로드 시간은 1분 미만으로 급격히 감소합니다.

  • 고급 주제: 구성 파일
  • 첫 번째 단계: 차량 통신 인터페이스
  • FAQ: Tech2Win용으로 어느 COM 포트를 사용해야 하는지 어떻게 판단합니까?
  • FAQ: Tech2Win과 TIS2Web 간의 통신


보안

Tech2Win에 의해 사용되는 보안 메커니즘의 작동에는 PC 시계 값이 중요합니다. PC 시계 값이 항상 설정되어 있도록 하십시오. 일광절약 시간이 적용되는 기간 동안의 사소한 시계 변경은 Tech2Win에 영향을 미치지 않습니다.

Tech2Win은 유효한 활성 상태의 라이선스가 없는 경우 차량 통신을 실시하지 않습니다. 상태 표시줄의 다음 표시기는 라이선스의 상태를 표시합니다.

  • green smiley 라이선스가 유효합니다.
  • 표시기 없음: 라이선스가 확인되지 않았습니다.
  • red smiley 라이선스가 만료되었습니다.

라이센스를 획득하려면 TIS2Web 응용 프로그램을 사용해 '보안 액세스 (보안)' 업데이트를 실행하십시오. 대부분의 경우, 새 라이선스를 얻는 데에는 TIS2Web을 통한 '소프트웨어 다운로드 (SWDL)'이면 충분합니다. 라이선스는 특정 기간(일부 지역의 경우 4주) 후에는 유효하지 않게 되기 때문에 정기적인 간격으로 이러한 업데이트를 실시해야 합니다.

라이선스는 지역/소프트웨어별로 되어 있습니다. 다른 Tech2 소프트웨어 버전이 있는 Tech2Win을 사용 중인 경우, 컴퓨터에 라이선스가 있을 수 있습니다.

라이선스가 만료되기까지 남은 일수는 상태 표시줄에 표시됩니다.

  • ( 0)은 라이선스가 만료되었거나 존재하지 않는다는 것을 표시합니다.
  • (<1) 라이선스가 24시간 이내에 만료됩니다.
  • (20) 라이선스가 20일 이내에 만료됩니다.

리이선스 파일을 임의로 수정하지 마십시오. 이 파일의 불법적인 임의 수정은 내부 보안 조치를 통해 감지되며, 컴퓨터의 모든 라이선스를 잃게 됩니다. 또한 Tech2Win이 예기치 않은 작동을 하게 됩니다. 이는 새 설치를 통해서만 해결할 수 있습니다.

  • 고급 주제: 오류 메시지 및 종료 코드
  • 고급 주제: 로그 파일
  • Tech2Win으로 작업하기: 상태 창
  • FAQ: 유효한 라이선스
  • FAQ: Tech2Win 라이선스와 보안 액세스의 차이는 무엇입니까?
  • FAQ: 갑작스런 중지


보고서 보기

View Report 이 단추를 사용하여 PCMCIA 카드에 있는 PRT-파일의 내용을 볼 수 있습니다. 대화 상자가 열려 PRT-파일의 목록을 표시합니다. 프로그램이 PRT-확장자와 연결되어 있는 경우, 관련 프로그램이 실행됩니다. 그렇지 않은 경우, 메모장 편집기가 열리고 선택된 파일이 표시됩니다.

대부분의 경우, PRT 파일은 해당 코드 페이지 언어를 사용하는 ASCI I 파일입니다. 중국어, 일본어, 한국어, 태국어의 경우, 파일은 선행 바이트 순서 표식(BOM)이 있는 유니코드로 되어 있습니다.

보고서를 볼 때에는 Tech2Win이 하위 디렉터리 C:\Users\Public\General Motors\Tech2Win\reports에서 작동됩니다. 이 하위 디렉터리는 보고서를 최소 한 번 이상 본 경우에만 존재합니다. 디렉터리는 자동으로 삭제되며, 활성 상태인 PCMCIA 카드의 PRT-파일용 임시 작업 디렉터리 기능을 합니다. Tech2Win 실행이 중지된 경우에도 계속해서 이들 파일이 포함됩니다. 이러한 파일을 저장하려면 이를 다른 디렉터리로 복사해야 합니다. 다른 사용자가 보고서 보기를 선택하면 덮어쓰기가 되기 때문입니다.


PCMCIA 이미지

일반적으로 PCMCIA 이미지는 하위 디렉터리 C:\Users\Public\General Motors\Tech2Win\pcmcia에 있습니다. 파일 크기는 정확히 32MB (33,554,432 바이트) 또는 10MB (10,485,760 바이트)이어야 하고 파일 확장자는 *.bin이어야 합니다. 다운로드가 발생하거나 Tech2Win이 플래시 카드에 무언가를 저장을 하는 경우, (모든 일반 PCMCIA 카드와 마찬가지로) 이미지가 수정됩니다. 쓰기 금지 스위치(명령: -W0 또는 -W1)를 사용하거나 '-W'-옵션에서 'p'-값을 생략하여 수정 기능을 사용 안 함으로 설정할 수 있습니다.(구성 파일). 쓰기 금지 스위치는 구성자를 통해 액세스할 수 없습니다. 옵션 '-W0', '-W1' 또는 '-W'를 사용하려면 구성 파일을 수동으로 수정해야 합니다.


상태 표시줄

Tech2 화면 밑에는 상태 표시줄이 표시됩니다. 상태 표시줄에는 다음 항목들이 표시됩니다.

  1. 속도 표시기
  2. 차량 통신 상태
  3. 직렬 포트 상태
  4. SHIFT 키
  5. 자동 스크린샷
  6. 로그 경고
  7. 라이선스

Status Bar

속도 표시기

속도 표시기는 Tech2 소프트웨어 에뮬레이션에 CPU 시간이 얼마나 사용되는지를 표시합니다. 낮은 수치(표시기 좌측 위치)는 높은 수치(표시기 우측 위치)보다 좋습니다. 녹색 표시기는 적절한 것입니다. 다른 Windows 작업이 갑자기 활성화 되면 표시기가 순간적으로 황색으로 바뀝니다. 이러한 작업은 피해야 합니다.

차량 통신 상태

차량 통신 상태는 차량과 Tech2Win 사이에 통신은 물론 차량 통신 인터페이스(MDI)가 존재하는지 여부를 표시합니다.

직렬 포트 상태

COM 포트를 통해 Tech2Win과 통신할 때에는 COM 포트의 통신이 활성화 상태인지 아닌지 여부가 이 표시기에 표시됩니다.

SHIFT 키

이 표시기는 SHIFT 키가 활성 상태인지 여부를 표시합니다. 키보드의 'S' 키를 사용하거나 키패드의 SHIFT 키를 사용하여 이를 변경할 수 있습니다.

자동 스크린샷

'자동 스크린샷'는 '옵션' 메뉴에서 활성화할 수 있습니다. 화면이 변경될 때마다 새 스크린샷이 로그 디렉터리에 저장됩니다. 이는 상태 표시줄에 있는 적색 카메라의 크랭크 핸들 회전을 통해 표시됩니다. '자동 스크린샷'이 비활성화되는 즉시 카메라가 사라집니다.

로그 경고

로그 상태 표시기에는 세 가지 다른 상태가 있을 수 있습니다.

  • gray log status indicator 로그 파일에 경고 또는 오류가 포함되어 있지 않습니다.
  • yellow log status indicator 로그 파일에 경고 메시지가 포함되어 있습니다.
  • red log status indicator 로그 파일에 오류 메시지가 포함되어 있습니다.

라이선스

라이선스 표시기에는 다음과 같은 세 개의 상태가 있을 수 있습니다.

  • green smiley 라이선스가 활성 상태이며 유효합니다.
  • 표시기 없음: 라이선스가 확인되지 않았습니다.
  • red smiley 라이선스가 만료되었거나 존재하지 않습니다.
상세 정보는 보안 링크를 참조하십시오.

상태 표시줄의 도구 설명

일부 아이콘의 경우, 도구 설명이 표시되어 다음과 같은 추가 정보를 제공합니다.

VCI 일련번호 도구 설명:
Tooltip VCI

Tech2 소프트웨어 버전 도구 설명
Tooltip TECH2

COM 포트 도구 설명
Tooltip Comport

다음 스크린샷의 번호에 대한 도구 설명 ('자동 스크린샷'이 활성 상태인 경우)
Tooltip Camera

'경고' 또는 그 이상 수준의 마지막 로그 파일을 표시하는 도구 설명
Tooltip Logfile

정확한 라이선스 기간에 대한 도구 설명
Tooltip License

도구 설명은 커서를 0.5초 넘게 아이콘 위에 놓고 움직이지 않으면 표시됩니다. 도구 설명은 5초 후에 또는 커서를 움직이면 사라집니다.

  • 고급 주제: 오류 메시지 및 오류 코드
  • 고급 주제: 로그 파일


고급 주제

여기서 논의되는 주제는 Tech2Win의 표준 사용자에게는 그리 중요하지 않습니다. Tech2Win의 설치, 관리 및 구성과 관련된 사람에게는 다음 정보가 유용할 수도 있습니다.

  • 재설치
  • 제거
  • 구성 파일의 직접 수정
  • 로그 파일
  • 오류 메시지 및 종료 코드
  • ATA 카드
  • 레지스트리 항목
  • 파일 설명
  • 구성 관리의 예


제거

완료된 설치 디렉터리, 사용자 데이터가 포함된 디렉터리 (C:\Users\Public\General Motors\Tech2Win) 및 응용 프로그램 데이터가 포함된 디렉터리 (C:\ProgramData\General Motors\Tech2Win)은 삭제됩니다.

  • 고급 주제: 재설치
  • 설치


구성 파일

구성 파일은 항상 하위 디렉터리 C:\Users\Public\General Motors\Tech2Win\config에 있으며 확장자는 *.conf입니다. Tech2Win을 통해 파일의 모든 옵션을 액세스할 수 있는 것은 아니기 때문에 구성 파일을 수동으로 수정할 수도 있습니다 구성 파일은 선행 바이트 순서 표식(BOM)이 있는 유니코드 파일입니다. 수동으로 수정할 때에는 메모장 등과 같은 유니코드 가능 편집기를 사용하는 게 좋습니다.

구성 파일은 줄 방향입니다. 빈 줄은 무시됩니다. 줄은 항상 옵션으로 시작하며 대개의 경우 값이 다음에 옵니다. default.conf 파일 예를 참조하십시오. 모든 이용 가능한 옵션이 설명되어 있는 다음 표를 참조하십시오.

바탕 화면에서 직접 특정 구성을 시작하려면 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf를 실행하는 바로 가기를 만드십시오. 프로그램은 다음 작업 디렉터리에서 시작해야 합니다: 'C:\Program Files\General Motors\Tech2Win\bin'

옵션 | 값 / 의미
; 주석
@ '주.부' 형식으로 된 소수점 버전 번호.
Tech2Win과 다른 주 번호가 있는 구성 파일은 허용되지 않습니다. Tech2Win보다 낮은 부 번호가 있는 구성 파일은 허용됩니다.
-W0
-W1 		슬롯 0/1에 있는 PCMCIA 카드에 있는 쓰기 금지 스위치가 활성화되어 있습니다.
-B0
-B1 		슬롯 0/1에 있는 PCMCIA 카드의 KB 단위 블록 크기. 허용되는 값은 128(기본값) 또는 256입니다.
-P0
-P1 		슬롯 0/1용 PCMCIA 카드의 이진 이미지가 포함된 파일. 파일 크기는 정확히 10MB 또는 32MB이어야 합니다. %ProgramData% 등과 같은 환경 변수는 확장됩니다.
이 옵션이 없는 경우 슬롯은 빈 것으로 간주됩니다.
-A0
-A1 		슬롯 0/1에 있는 PCMCIA 카드의 특성 값이 포함된 파일. 없는 경우, 카드 및 블록 크기에 따른 기본 특성 값이 사용됩니다.
-W | Tech2Win을 끝내면 모든 영구 데이터는 해당 파일에 기록됩니다. p/f/r/c 값들은 결합되어 각각 PCMCIA/Flash-ROM/RTC/CANDI-App를 나타냅니다.
-H | 힙 관리 기능 제로화, 판독 체크, 쓰기 체크 및 각각 작업 체크를 활성화하기 위해 0/r/w/t의 값이 조합되어야 합니다. 다른 할당 방식이 도입되기 때문에 항상 낮은 주소에 힙 메모리 할당을 시행하는데 값 l 이 사용됩니다. 보통, 이 옵션은 개발 환경에서만 사용됩니다.
-PC | PCMCIA 카드 사본의 이전 경로. 이 옵션은 현재 무시됩니다.
-MS | 일련번호로 차량 통신 인터페이스(MDI) 식별. 설정되지 않은 경우, 사용 가능한 MDI의 목록이 표시됩니다.
-CT | 3개의 16진수 바이트 값으로 된 텍스트(포그라운드)의 색. 기본값은 000000 (백색)입니다.
-CB | 3개의 16진수 바이트 값으로 된 백그라운드의 색. 기본값은 FFFFFF (흑색)입니다.
-ATA | 이 옵션을 이용하여 ATA 캡처 카드를 활성화시킵니다. ATA 캡처 카드를 비활성화시키려면 이를 제거합니다.
-C | Tech2의 RS232C 통신 포트로 사용될 COM 포트(1..9)의 개수. 주로 COM9가 Tech2Win에 의해 설치된 가상 COM 포트용으로 사용됩니다. 이 옵션이 업는 경우, 사용되지 않는 COM 포트에 대한 검색이 COM9에서부터 밑으로 실시됩니다. 어떤 COM 포트가 사용 중인지 보려면 Tech2 아이콘과 TIS2Web 사이에 있는 상태 표시줄에 있는 도구 설명을 이용하십시오.
-WR | PCMCIA 및 FLASH ROM 영역에 쓰기가 허용된 PC 주소(일반적으로 253558). 이 기능은 메뉴에서 (또는 옵션 -WA를 사용하여) 추가적으로 활성화시켜야 합니다. 단일 단계 디버거를 통해 수정 불가능 메모리의 코드를 디버그하는 데 필요합니다.
-WA | 단일 단계 디버거가 수정 불가능 메모리에 쓰기를 할 수 있도록 허용하십시오.
-OF | 옵션 /값 쌍이 포함된 옵션 파일.
-TP | 타이밍 조절 (비례 값). 5000으로 기본 설정. 실행된 주기 수를 신속하게 실시간에 맞추려면 이 값을 감소시킵니다.
-TD | 타이밍 조절 (편차 값). 100으로 기본 설정. 현재 타이밍의 변화에 신속하게 반응하려면 이 값을 감소시킵니다. 경고: TP 및 TD 값을 임의로 수정하면 속도 문제가 발생할 수 있습니다.
-PJ
-PP 		사용할 프로토콜을 다음과 같이 지정하십시오.
PJ: J2534 통신용.
ISO22900-2 / PDU-API용 PP (기본값)
-S | 이 옵션이 있으면 PC 비퍼의 사운드 출력을 사용할 수 있게 됩니다.
-L | Tech2Win 응용 프로그램의 언어. 이 항목이 없는 경우, 활성 상태의 Windows 언어가 기본값으로 사용됩니다. 다음 링크에서 지정할 수 있는 언어의 목록을 참조하십시오: Languages. PCMCIA 카드에 있는(PCMCIA 카드로 다운로드된) 언어가 Tech2 에뮬레이션 창에 표시됩니다.
-UD | 사용자 데이터 디렉터리 재정의 Windows 7의 경우, 일반적으로 이는 C:\Users\Public\General Motors\Tech2Win 에 있습니다.
-AD | 응용 프로그램 데이터 디렉터리 재정의 Windows 7의 경우, 일반적으로 이는 C:\ProgramData\General Motors\Tech2Win 에 있습니다.
-US | 한 개가 넘는 Tech2Win 인스턴스를 감지하려면 사용자별 세마포를 사용하십시오. 이 옵션을 통해 각 사용자는 서버 등 동일한 컴퓨터에서 Tech2Win을 병렬로 실행할 수 있습니다. 이 옵션을 사용할 때에는 옵션 -UD 및 -AD 도 명시해야 합니다.
-SS | 키패드(있는 경우)를 포함하여 Tech2Win 윈도우의 전반적인 크기를 명시하기 위한 옵션. 첫 번째 매개변수는 겹따옴표(')로 둘러쌓인 문자열이어야 하며, 옵션 / 해상도 메뉴에서 크기의 이름으로 사용됩니다. 두 번째 매개변수는 Tech2Win 화면(키패드 포함)의 가로 픽셀 전체 개수입니다. 세 번째 매개변수는 Tech2Win 화면의 세로 픽셀 전체 개수입니다. 네 번째 선택적 매개변수는 픽셀 단위의 키패드 폭입니다.
-SH 화면 처리 컨트롤 옵션 다음 십진수는 어느 화면 처리 가능성을 비활성화시킬 것인지 명시하는 데 사용됩니다.
  • 비트 0: 최소/최대 불가능.
  • 비트 1: 화면상의 위치 변경 불가능.
  • 비트 2: 크기 변경 불가능. 이 경우, 옵션 / 해상도 메뉴가 회색으로 비활성화됩니다.
  • 비트 3: 데이터 디스플레이 및 DTC 윈도우가 Tech2Win(키패드 포함)과 동일한 크기가 됨.


로깅

Tech2Win 구성을 시작할 때마다 C:\Users\Public\General Motors\Tech2Win\Logs 하위 디렉터리에 HTML 형식의 새 로그 파일이 만들어집니다. 하드 디스크가 차는 것을 방지하기 위해 한 주일 이상 된 로그 파일이 제거됩니다.

로그 파일은 자동으로 만들어진 날짜(연, 월, 일) 및 시간 (시, 분, 초)에 따라 다음과 같이 이름 지어집니다.
yyyy-mm-dd_hhmmss.html

로그 파일 항목은 항상 영어로 되어 있으나 선행 바이트 순서 표식(BOM)이 있는 유니코드 형식입니다. 로그 파일의 각 줄은 다음 로그 수준 중 하나입니다:

로그 수준 | 의미
정보 | 정보 전용. 프로그램의 실행에 영향 없음.
경고 | 비정상적인 상황이 발생했습니다. 사용자는 영향을 느끼지 못할 수 있습니다.
ERROR | 사용자가 알아차릴 수 없는 오류가 발생했습니다.
CRITICAL | 프로그램의 비정상적인 작동을 초래하는 치명적인 오류가 발생했습니다.
FATAL | 치명적인 오류는 Tech2Win의 즉각적인 작동 정지를 초래합니다.

'경고'보다 높은 수준은 쉽게 알아볼 수 있도록 색으로 표시됩니다.

또한, 화면을 프린트하십시오. 또는 자동 스크린샷 메뉴 옵션이 사용된 경우, 인쇄 및 비디오 파일은 Logs 하위 디렉터리에도 있습니다.
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
자동 스크린샷 사진들은 HTML 파일에 의해 연결됩니다. 따라서 이들 사진의 순서를 보려면 HTML 로그를 사용하십시오.

경고 항목( yellow lightning bolt) 또는 심각한 로그 항목( red lightning bolt)이 있는 경우, 상태 표시줄을 통해 사용자에게 알립니다.


오류 메시지 및 종료 코드

대화 상자에 오류 메시지가 나타날 수 있습니다. 그러나 이들 대화 상자는 Tech2Win이 병렬로 Tech2 프로그램을 실행할 수 있도록 허용합니다. 종료 코드는 Tech2Win을 비정상적으로 종료시키는 치명적 오류입니다. 종료 코드를 배치 파일로 사용하여 프로그램이 종료된 원인을 검색할 수 있습니다.

오류 메시지

다음 오류 메시지가 나타날 수 있습니다. 상황에 대한 간단한 설명과 문제를 해결할 수 있는 방법이 제시되어 있습니다.

Emulator too slow Emulator failed to start

종료 코드

종료 코드 | 값 | 의미
OPCODE_ERROR | -7 | Tech2 마이크로프로세서(68332)의 잘못된 명령이 검색되었습니다. PCMCIA 이미지가 손상된 것일 수 있습니다.
ATA_PROBLEM | -6 | ATA 에뮬레이션 중 문제가 발생했습니다. ATA 카드를 사용하라는 지시를 받은 후에 이러한 문제가 발생하는 경우, 기술지원 팀으로 연락하십시오.
DEMO_TIME_IS_UP | -5 | Tch2Win의 공식 버전에서는 나타나지 않아야 합니다.
DLL_NOT_LOADED | -3 | 필요한 DLL 중 하나를 로드할 수 없습니다. 완전하지 않은 Tech2Win 사본인 것 같습니다. 새로 설치하거나 다른 언어를 선택하십시오.
EXIT_INIT_FAILED | -2 | 설치하지 못했습니다. 로그 파일을 확인하여 정확한 원인을 찾으십시오. 로그 파일이 없는 경우, 모든 디렉터리에 대한 올바른 읽기/쓰기 액세스 권한이 있는지 확인하십시오.
정상 | 0 | Tech2Win이 정상 종료되었습니다.


ATA 카드

Tech2의 ATA 카드는 일반적으로 소프트웨어 개발 중 디버깅용으로만 사용됩니다. 필요한 모든 ATA 데이터는 하위 디렉터리 C:\Users\Public\General Motors\Tech2Win\ataCapture에 저장됩니다. 이 디렉터리는 그리 중요하지 않으며, 달리 구체적인 지시가 없는 경우 안전하게 삭제할 수 있습니다.

ataCapture 디렉터리는 고정되어 있기 때문에 모든 구성에서 그 내용이 동일합니다.


파일

다음 파일과 디렉터리가 Tech2Win에 의해 사용됩니다:

디렉터리 | Vista 이전 위치 | Vista 및 이후 버전 위치
설치 | 설치 시 지정
사용자 데이터 | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
응용 프로그램 데이터 | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

파일 | 사용
[사용자 데이터]\atacapture | ATA 카드에 있는 파일이 포함되어 있습니다. 달리 지침이 없는 한 이들 파일은 필요하지 않습니다.
[설치]\bin | 실행에 필요한 실제 실행 DLL 파일이 포함되어 있습니다.
[설치]\bin\emulator.exe | Tech2 코드를 실행하는 메인 실행 파일.
[설치]\bin\emulator_xx_XX.dll | 언어별 리소스 DLL.
[설치]\bin\T2Configurator.exe | Tech2Win의 구성 부분.
[설치]\bin\Pictures | Tech2Win이 필요한 아이콘들이 포함되어 있습니다.
[사용자 데이터]\config | 모든 구성 파일이 포함되어 있습니다.
[사용자 데이터]\data | Tech2Win 실행 중 수정된 파일이 포함되어 있습니다. 이들 파일은 Tech2Win의 올바른 실행을 위해 필요합니다. 일반적으로 이들 파일은 달리 명시되어 있지 않은 한 건드리지 않아야 합니다.
[응용 프로그램 데이터]\data | Tech2Win 실행 중 수정된 파일이 포함되어 있습니다. 이들 파일은 Tech2Win의 올바른 실행을 위해 필요합니다. 일반적으로 이들 파일은 달리 명시되어 있지 않은 한 건드리지 않아야 합니다.
[응용 프로그램 데이터]\data\emulator.sec | 보안 파일 . 이 파일을 수정하지 마십시오.
[응용 프로그램 데이터]\data\emulator.card | 카드 파일. Tech2Win 프로그램에 알려진 모든 PCMCIA 카드가 포함되어 있습니다. 이 파일을 수정하지 마십시오.
[사용자 데이터]\data\emulator.disp | 이 파일에는 Tech2Win 화면의 위치와 크기가 있습니다. 이 파일을 삭제하는 경우, 파일이 다시 만들어지며, Tech2Win 화면은 좌측 상단 모퉁이에서 640x480의 크기로 시작됩니다.
[응용 프로그램 데이터]\data\emulator.lic | 라이선스 파일. 라이선스 유효 기간에 대한 정보가 포함되어 있습니다. 이 파일을 수정하지 마십시오.
[응용 프로그램 데이터]\data\emulator.rtc | 실시간 시계 파일. 이 파일은 Tech2의 RTC에 있는 데이터의 저장용으로 사용됩니다.
[응용 프로그램 데이터]\data\emulator.dta | '다시 알리지 않음' 정보 파일.. 이 파일은 루프백 어댑터가 필요한 자체 테스트 실시가 불가능하다는 것에 대한 경고를 표시하지 않아야 하는 PCMCIA 소프트웨어 버전을 저장합니다.
[응용 프로그램 데이터]\data\candi.bin | CANdi 응용 프로그램 파일. Tech2에 부착된 CANdi의 응용 파일이 포함되어 있습니다.
[응용 프로그램 데이터]\data\eprom.bin | Tech2 내부 EPROM 파일. 내부 Tech2 플래시 메모리 내용이 포함되어 있습니다.
[설치]\driver | 가상 COM 포트 드라이버용 설치 파일.
[설치]\help\emulator_xx_XX.chm | 언어별 도움말 파일.
[사용자 데이터]\Logs | 로그 파일이 포함되어 있습니다. 한 주일 이상 된 파일은 자동으로 삭제됩니다.
[사용자 데이터]\pcmcia | PCMCIA 이미지 파일이 포함되어 있습니다. 각 파일이 Tech2 PCMCIA 카드에 해당한다고 할 수 있습니다. 이들 파일은 다른 장소에 저장할 수도 있습니다.


구성 관리

구성 파일은 항상 하위 디렉터리 C:\Users\Public\General Motors\Tech2Win\config에 있으며 확장자는 *.conf입니다. Tech2Win은 새로운 구성 파일을 만들거나 기존의 읽기 전용 구성 파일을 수정하는 데만 사용할 수 있습니다. 구성 파일의 기타 모든 관리용으로는 Windows 탐색기 또는 유사 파일 처리 프로그램을 사용하십시오. 이는 다음과 같은 작업에 필요합니다.

  • 구성 파일의 삭제
  • 구성 파일의 이름 수정
  • 구성 파일의 읽기 전용 특성 변경

항상 구성 파일 default.conf가 있는 것이 좋습니다. 이 파일의 특성을 읽기 전용으로 설정하여 덮어쓰기를 하는 실수를 방지해야 합니다. 그러나 특정한 필요에 따라 이 파일을 변경하는 경우, 읽기 전용 특성을 제거해야 합니다.

PCMCIA 이미지는 하위 디렉터리 C:\Users\Public\General Motors\Tech2Win\pcmcia에 있습니다. 이들 파일 각각은 Tech2를 이용한 작업 시 이미 익숙해진 PCMCIA 카드에 해당합니다. Tech2Win을 이용하여 원하는 만큼의 이미지를 가질 수 있습니다. 기존의 이미지를 새로운 파일 이름으로 복사하기만 하면 됩니다.

바탕 화면에서 직접 특정 구성을 시작하려면 "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf"를 실행하는 바로 가기를 만드십시오. 프로그램은 다음 작업 디렉터리에서 시작해야 합니다: 'C:\Program Files\General Motors\Tech2Win\bin'

구성 파일의 개수는 사용하는 PCMCIA 이미지의 개수에 따라 달라지지 않습니다. 동일한 PCMCIA 이미지를 사용하는 여러 개의 구성 파일을 가질 수 있습니다. 이는 여러 정비사가 동일한 Tech2 (및 동일한 PCMCIA 카드)를 공유하는 정비소의 환경에 따른 것입니다.

또한 모든 구성 파일이 전용 PCMCIA 이미지를 사용하도록 선택할 수도 있습니다. 이렇게 하면 개별적인 구성이 서로 더욱 독립적인 특성을 갖게 됩니다. 그러나 각 PCMCIA 이미지를 업데이트하는 데 어려움이 있을 수 있습니다.

기존 구성을 복사하여 새 구성을 만들 때 PCMCIA 이미지가 변경되지 않은 경우, 구성자는 경고를 표시합니다. 이러한 경우, 동일한 PCMCIA 이미지를 사용하는 두 개의 구성이 있는 것입니다. 이러한 구성을 원하는 경우, 확인를 누르십시오. 새 구성이 다르거나 새로운 PCMCIA 이미지를 사용하기를 원하는 경우, 취소을 누르십시오. 그런 다음 복사 메모리 카드 ...를 이용하여 새 이미지를 만들 수도 있습니다.

구성과 PCMCIA 이미지를 관리하는 방법에 대해 제시된 두 가지 예를 참조하십시오.

사용자별 단일 구성

사용자별 구성을 저장할 수 있습니다. 예를 들어, 구성의 이름은 사용자 이름이 됩니다. 이러한 개념의 장점으로는 개인 차량 통신 인터페이스(MDI) 등과 같은 사용자별 설정, 디스플레이 및 언어 설정이 가능하다는 점입니다. 단점으로는, 여러 사용자가 동일한 소프트웨어를 사용하는 경우, PCMCIA 파일을 복사해야 하는 점을 들 수 있습니다. 사용자별 구성은 중앙 PCMCIA 파일을 사용할 수도 있습니다.

Tech2 소프트웨어별 단일 구성

선택을 통해 다운로드하는 모든 소프트웨어에 대해 새 구성을 만들 수도 있습니다. 따라서 필요한 경우 오래된 소프트웨어 버전도 즉시 사용할 수 있습니다. 이러한 경우 소프트웨어 이름과 버전 번호가 구성 이름으로 선택됩니다.

  • 첫 번째 단계: 차량 통신 인터페이스
  • 첫 번째 단계: 경로
  • 고급 주제: 구성 파일
  • 설치: 설치 단계


질문과 대답(FAQ)

  • Tech2Win용으로 어느 COM 포트를 사용해야 하는지 어떻게 판단합니까?
  • Tech2Win과 TIS2Web 간의 통신
  • 유효한 라이선스
  • 라이선스 번호는 무엇을 가리킵니까?
  • Tech2Win 라이선스와 보안 액세스의 차이는 무엇입니까?
  • TIS2Web은 초기 소프트웨어에 대한 보안 액세스를 실시할 때 불특정한 오류를 표시합니다.
  • Tech2Win이 다른 영역으로부터 Tech2 소프트웨어를 실행시키지 않습니다
  • 하나가 넘는 MDI를 사용하려면 어떻게 합니까?
  • 로그 파일에 오류 'CPU32: Too many 0000/FFFF Commands encountered'가 포함되어 있습니다
  • Tech2 창이 보이지 않습니다
  • SPS가 작동하지 않습니다
  • 일부 차체 테스트가 작동하지 않습니다
  • 속도 표시기가 변동됩니다
  • 갑작스런 중지
  • 소프트웨어 15.001용으로 스웨덴어가 표시됩니다
  • MDI와 통신 두절
  • Tech2Win가 내 MDI를 찾지 못합니다
  • 구성자를 사용하지 않고 Tech2Win을 바로 시작하고 싶습니다.
  • 인쇄 기능은 어디에 있습니까?
  • 내 컴퓨터에 '사용되지 않은' PCMCIA 폴더가 있습니다.
  • 'illegal filepath' (부정한 파일 경로) 메시지가 표시됩니다

Tech2Win용으로 어느 COM 포트를 사용해야 하는지 어떻게 판단합니까?

Windows의 '장치 관리자'를 이용할 수 있습니다. '포트 (COM & LPT)'를 찾으십시오. 그러나 일부 컴퓨터에는 이 범주 내에서 표시되지 않는 내부 모뎀 또는 블루투스 장치가 설치되어 있습니다.
다른 방법으로는 구성자와 함께 전달되는 작은 명령을 사용하는 것이 있습니다. 'show com ports'를 클릭하여 시작 메뉴(Tech2Win 폴더)를 통해 이를 실행할 수 있습니다.
두 방법 모두 컴퓨터에 설치되어 있으나 사용하지 않아야 하는 COM 포트를 표시합니다.

Tech2Win과 TIS2Web 간의 통신

보안 액세스 또는 소프트웨어 다운로드를 위해 TIS2Web과 통신을 시작하기 전에 Tech2Win이 실행 중이어야 합니다. TIS2Web은 Tech2Win가 시작될 때 가상 COM 포트만 인식할 수 있습니다.

유효한 라이선스

일반적으로 TIS2Web으로부터 '소프트웨어 다운로드 (SWDL)'를 통해 유효한 라이선스가 제공됩니다. 아직도 라이선스가 없는 경우, TIS2Web(TIS2000 아님)를 통한 '보안 액세스 (보안)'를 실시하여 유효한 라이선스를 받아야 합니다. '보안 액세스 (보안)' 액세스를 통해 라이선스를 받기 전에는 Tech2Win과 다른 어떤 TIS2Web 통신(예: '소프트웨어 다운로드 (SWDL)')도 실시하지 마십시오.

라이선스 번호는 무엇을 가리킵니까?

상태 표시줄 우측의 라이선스 번호는 남아있는 라이선스 일수를 표시합니다. 다운로드 또는 보안 액세스를 실시한 직후 30일에 해당하는 숫자가 표시됩니다. 그러나 Tech2Win의 새로운 시작 후에는 29가 표시됩니다. 예를 들어, 라이선스 기간이 29일 23시간 55초일 수 있기 때문입니다. 라이선스 일수가 24시간 아래로 떨어지면 라이선스 기간이 <1로 표시됩니다. 라이선스가 만료되는 경우, 0이 표시됩니다.

Tech2Win 라이선스와 보안 액세스의 차이는 무엇입니까?

Tech2Win 라이선스는 사용자가 Tech2Win을 사용할 수 있도록 해줍니다. 이러한 라이선스를 얻으려면 정기적으로(대개의 경우 30일마다) 소프트웨어 다운로드 또는 보안 액세스를 실시해야 합니다. TIS2Web을 통해 이러한 다운로드를 실시할 수 있게 되면 Tech2Win는 유효한 사용자가 존재한다는 것을 알게 됩니다. Tech2에서와 마찬가지로, 보안 액세스는 Tech2Win에게 에어백 작동 해제 등과 같은 특정 보안 관련 작업이 허용된다는 점을 알려줍니다. Tech2Win 라이선스와 보안 액세스는 TIS2Web '보안 액세스 (보안)' 응용 프로그램을 통해서 실시할 수 있습니다. Tech2Win은 상태 표시줄 우측에 잔여 라이선스 기간을 표시합니다. 그러나 Tech2Win은 보안 액세스 기간을 표시할 수 없습니다. Tech2Win은 단순히 Tech2 소프트웨어를 실행할 뿐 Tech2 소프트웨어 자체에 대해서는 모르기 때문입니다.

TIS2Web은 초기 소프트웨어에 대한 보안 액세스를 실시할 때 불특정한 오류를 표시합니다.

동작은 Tech2에서와 동일합니다. 시간의 경과로 인해 초기 소프트웨어는 TIS2Web으로부터 라이선스를 받을 수 없습니다. 그러나 이는 문제가 되지 않습니다. 데모 소프트웨어는 라이선스가 필요한, 차량과의 통신을 하지 않기 때문입니다. 라이선스는 TS2Web 다운로드별로 되어 있기 때문에 Tech2 소프트웨어를 다운로드한 후 각 개별 다운로드용으로 라이선스를 받아야 합니다. 초기 소프트웨어용 '라이선스'로는 북미 운영 또는 Opel/Vauxhall 소프트웨어와 차량 통신을 실시할 수 없습니다.

Tech2Win이 다른 영역으로부터 Tech2 소프트웨어를 실행시키지 않습니다

사용자의 Tech2Win 버전은 한번 또는 여러 번의 TIS2Web 다운로드 (지역)으로 제한되어 있을 수 있습니다. 사용자의 Tech2Win 버전에 어떤 제한이 적용되는지 보려면 도움말 / 정보를 누르십시오. 초기 버전의 Tech2Win은 Opel/Vauxhall 소프트웨어 실행만을 허용했습니다. 다른 GM 지역도 나올 것입니다. 어떠한 경우에도 Tech2Win은 현재 GM의 Tech2 소프트웨어를 실행할 수 있습니다.

하나가 넘는 MDI를 사용하려면 어떻게 합니까?

특정 MDI를 특정 사용자에게 할당하려는 경우, 모든 사용자가 각자의 고유 구성을 갖도록 해야 합니다. 따라서 이들 구성은 해당 사용자에 따라 이름을 붙여야 합니다. 각 구성에서, '차량 통신 인터페이스' 탭에 사용자별 MDI의 일련번호를 입력해야 합니다. 사용자가 자신의 구성을 시작하면 Tech2Win은 즉시 해당 특정 MDI 접촉을 시도합니다. 해당 MDI가 있는 경우에만 선택 상자가 제시되고 Tech2Win이 찾을 수 있는 모든 MDI가 표시됩니다.

일반 용도로 여러 MDI가 있는 경우, '차량 통신 인터페이스' 탭의 차량 통신 인터페이스 일련번호를 공백으로 남겨 놓는 구성을 사용하는 것이 좋습니다. 그러면 사용자는 사용 가능한 MDI의 선택 상자를 항상 보게 됩니다.

로그 파일에 오류 'CPU32: Too many 0000/FFFF Commands encountered'가 포함되어 있습니다

파일 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' 또는 현재 PCMCIA 파일이 손상되었습니다. Tech2Win을 다시 설치하고 새 Tech2 소프트웨어를 다운로드하십시오.

Tech2 창이 보이지 않습니다

Tech2 창이 보이지 않는 경우, 이는 디스플레이가 아닌 영역에 있을 가능성이 있습니다. 하나가 넘는 화면을 사용하거나 화면 해상도를 수정한 후에 이러한 문제가 발생합니다. 구성 시작 시 키보드의 Shift 키를 누르십시오. 그렇게 하면 창 해상도가 640x480으로 초기화되고 Tech2 창이 화면의 좌측 상단 모서리에 표시됩니다. 파일 C:\Users\Public\General Motors\Tech2Win\emulator.disp를 삭제해도 동일한 효과가 발생합니다.

다른 모든 응용 프로그램을 닫은 후에 Tech2 창이 화면이 다시 표시되지 않는 경우가 있었습니다. 지금까지 목격한 모든 경우에서는, Windows 응용 프로그램들 간의 전환을 위한 Alt-Tab 키를 사용하면 Tech2 화면을 다시 불러올 수 있었습니다. PC 화면 하단의 작업 표시줄에서 Tech2Win 단추를 누르는 것으로는 문제가 해결이 되지 않는 경우도 있습니다. 이러한 문제에 대한 조사가 현재 진행 중에 있으며 Tech2Win의 이후 버전에서는 이러한 문제를 해결할 수 있을 것입니다.

SPS가 작동하지 않습니다

네, 알고 있습니다. 이러한 사항을 변경할 계획은 없습니다. SPS를 실행하기 위해 Tech2Win을 Tech2 대신 사용하지 않아야 합니다. TIS를 통한 SPS 프로그래밍으로 직접 MDI를 사용하십시오.

일부 차체 테스트가 작동하지 않습니다

Tech2 자체 테스트는 Tech2 하드웨어의 개별 부품을 테스트하기 위한 것입니다. 이들 테스트 중 일부는 루프백 어댑터를 사용해야 합니다. 이들 테스트는 Tech2Win에서는 작동하지 않습니다. 루프백 어탭터 기능이 구현되지 않았기 때문입니다(앞으로도 그러한 계획이 없습니다). Tech2Win에서는 그러한 의미 없는 테스트들을 실행하지 마십시오. 루프백 어댑터 없기 때문에 이들을 실행하면 잘못된 결과가 나오거나 Tech2와 마찬가지로 Tech2Win이 중지됩니다. 그러한 경우 Tech2Win을 초기화하려면 Ctrl-R을 사용하십시오.

속도 표시기가 변동됩니다

상태 표시줄의 좌측 하단에 있는 속도 표시기는 Tech2Win '대기' 상태로 돌아가기 전에 얼마나 많은 'Tech2 명령'이 실행될 수 있는지를 표시합니다. 이러한 방법은 Tech2Win의 시간을 실제 시간에 일치시키는 데 사용됩니다. 빠른 PC는 느린 PC보다 대기 시간이 깁니다. 속도 표시기가 변동되는 경우, 일부 다른 응용 프로그램이 컴퓨터를 사용 중이거나 PC 시계가 변경되는 중일 수 있습니다. 변동률이 높은 경우, 차량 통신 및 TIS2Web 통신에 부정적인 영향을 주게 됩니다. 다른 응용 프로그램이 실행되지 않도록 하십시오.

대부분의 랩톱은 배터리 시간을 연장하기 위해 자동으로 CPU 클럭을 낮출 수 있습니다. 이 또한 Tech2Win에 의해 감지되는 속도 변동의 원인이 될 수 있습니다. 이러한 경우, 랩톱의 배터리 전원을 사용하지 말고 외부 전원 공급장치를 사용하십시오. 또한 전원 설정값을 변경하여 운영 체계가 클럭 속도를 낮추지 않도록 할 수도 있습니다.

갑작스런 중지

로그 파일에서 프로그램이 종료된 이유를 찾지 못한 경우, Tech2Win 내부 보안 메커니즘이 활성화되어 있기 때문일 수도 있습니다. 다음 파일을 임의로 수정하지 마십시오: emulator.sec, emulator.lic, emulator.card. Tech2Win이 보안 훼손을 확인하는 경우, 재설치를 실시해야 할 수 있습니다.

소프트웨어 15.001용으로 스웨덴어가 표시됩니다

Tech2Win과 함께 공급되는 초기 소프트웨어는 모든 새 PCMCIA 카드에 있는 데모 소프트웨어 입니다. TIS2Web은 스웨덴어로 되어 있다고 표시합니다. TIS2Web은 이 데모 소프트웨어가 지원하는 네 가지 언어(영어, 프랑스어, 독일어, 스웨덴어)의 목록 중 마지막 언어만을 표시하기 때문입니다. '표준' 대신에 '사용자' 업데이트 모드를 사용하여, 이 데모 소프트웨어에 최신의 진단 소프트웨어를 덮어 씁니다.

MDI와 통신 두절

MDI 통신 두절의 원인은 여러 가지가 있을 수 있습니다.

  • 케이블 연결 불량 (이더넷 및 USB).
  • 무선 연결 불량.
  • 대기 모드 중인 PC.

Tech2Win가 내 MDI를 찾지 못합니다

다음 사항을 점검하십시오.

    1. MDI가 활성 상태입니까?
    2. MDI 관리자가 작동합니까?
    3. MDI가 SPS 등과 같은 다른 응용 프로그램에 의해서도 사용됩니까?
바탕 화면 아이콘을 사용하여, 또는 '시작/모든 프로그램/General Motors/GM MDI 소프트웨어'를 통해 MDI 관리자를 시작할 수 있습니다.: 2번 항목의 관리자가 작동하지 않는 경우, 기술지원 팀에 연락하십시오.

구성자를 사용하지 않고 Tech2Win을 바로 시작하고 싶습니다.

"C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf"를 실행합니다. 다음 작업 디렉터리를 사용하십시오: 'C:\Program Files\General Motors\Tech2Win\bin' 구성자를 사용해서도 구성을 변경할 수 있습니다.

인쇄 기능은 어디에 있습니까?

Tech2Win는 직접 인쇄 기능을 제공하지 않습니다. 대신 임시 파일을 만들고 그 파일 확장자와 연결된 프로그램을 호출합니다. 이들 프로그램은 인쇄 목적으로 사용되며, 사용자는 인쇄물의 모양을 조절할 수 있습니다.

Print Report | Print Report

현재 Tech2Win 화면을 인쇄하려면 메뉴 항목 파일 / 화면을 프린트하십시오.을 사용하거나 프린터가 표시된 키패드 단추를 사용하십시오. 여러 Tech2Win 화면을 인쇄하려면 메뉴 항목 옵션 / 자동 스크린샷을 사용할 수 있습니다. 이를 통해 모든 Tech2Win 화면에 대한 PNG 파일이 만들어지기 때문입니다. PNG 파일은 로그 파일에 포함됩니다.

데이터 디스플레이 내용을 인쇄할 수도 있습니다(메뉴 항목 창 / Tech2Win 데이터 디스플레이를 사용해 활성화됨). 데이터 인식을 시작 및 중지하려면 인쇄/HTML 시작 버튼을 사용하십시오. 인식을 중지한 후 사용자가 데이터를 인쇄하도록 많은 기능을 제공하는 HTML-연결 실행 파일(일반적으로 Internet Explorer)이 시작됩니다.

Data Display | Data Display

내 컴퓨터에 '사용되지 않은' PCMCIA 폴더가 있습니다.

이전 버전의 Tech2Win에는 항상 별도 디렉터리에 PCMCIA 파일의 중복 저장 위치가 있습니다. 대개의 경우 이 디렉터리는 C:\PCMCIA 입니다. 이 디렉터리는 이제 사용되지 않습니다. TIS2Web로부터 다운로드가 신속하게 이루어지기 때문에 다운로드용으로 보조 저장 위치가 필요 없습니다. 이 디렉터리를 지울 수 있습니다.

'illegal filepath' (부정한 파일 경로) 메시지가 표시됩니다

파일 이름에 퍼센트(%) 등과 같은 부정한 문자가 포함된 것처럼 보입니다. 설치한 바로 직후 이러한 문제가 보이는 경우, 설치한 것을 제거하고 새로 다시 설치 하는 것이 최상입니다. 대부분의 경우 이 방법으로 문제를 해결할 수 있습니다.

표준 설치를 하는 동안, 환경 변수 'Tech2WinUserData'가 'PUBLIC' 또는 (Vista 또는 이후 윈도우 버전) 또는 'ALLUSERSPROFILE\Documents' (Vista 이전 버전 윈도우)으로 설정됩니다. 드문 경우에, 설치를 실행하는 동안 환경 변수가 설정되지 않으나 두 번째로 시도하면 잘 작동됩니다. 환경 변수 수동 설정을 선택할 수도 있습니다. 환경 변수 설정 방법을 모르는 경우 관리자에게 도움을 청하십시오.


레지스트리 항목

다음 레지스트리 항목들은 설치 프로그램에 의해 만들어졌습니다. 이들 항목들을 수동으로 수정하지 마십시오. 레지스트리 항목들을 다룰 때는 표준 Windows 주의사항을 지키십시오.

레지스트리 키 | 이름 | 유형 | 의미
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | 내부 버전 번호
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 언어 | REG_SZ | 설치된 언어
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | PCMCIA 사본 디렉터리 경로
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 루트 | REG_SZ | 설치 경로
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 제거 옵션 | REG_DWORD | 제거 설정
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | 구성 파일 버전
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | 가상 COM 포트 드라이버의 버전
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | 표시이름 | REG_SZ | 추가/제거 프로그램 목록 내의 소프트웨어 이름
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | 제거 스트링 | REG_SZ | 제거 프로그램 경로


재설치

재설치를 하면 다음 항목을 제외하고 Tech2Win의 모든 설치 디렉터리를 삭제합니다.

  1. 구성이 포함되어 있는 config 하위 디렉터리는 삭제되지 않습니다.
  2. PCMCIA 이미지가 포함되어 있는 pcmcia 하위 디렉터리는 삭제되지 않습니다.
  3. 디버그 정보가 포함되어 있을 수 있는 ATA 하위 디렉터리는 삭제되지 않습니다.
다음과 같이 구성 파일이 호환되지 않을 수도 있습니다. 이전 Tech2Win 버전의 구성 파일을 새로운 Tech2Win 버전이 읽지 못 할 수도 있습니다. 원칙상 PCMCIA 이미지가 호환되지 않을 수는 없습니다.

보조 PCMCIA 디렉터리는 재설치로 인해 영향을 받지 않습니다.

일부 환경에서는 새로운 Tech2Win 버전의 자동 설치가 제공될 수도 있습니다. 마지막 설치 정보가 레지스트리에 저장되어 있기 때문에 재설치 시 이들 설정이 기본값으로 제시됩니다.

enable reinstallation 스크립트를 사용하여 Tech2Win의 재설치를 적용할 수 있습니다. 이 스크립트는 Tech2Win과 함께 설치됩니다. 기본적으로 이 스크립트는 HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win의 레지스트리에 있는 CurrentVersion 키의 값을 '1.000'으로 설정합니다.