Tech2Winユーザーマニュアル

Tech2Winのユーザーマニュアルへようこそ。

Copyright (C) 2010..2016 SPO Engineering General Motors All Rights Reserved.

  • イントロダクション:
  • ライセンス:
  • インストール:Tech2Winのインストール手順の説明。
    • インストール手順
    • Vehicle Communication Interface
  • 最初の手順
    • 構成を選択する
      • キーボード
      • Windowsのハンドリング
    • 新規構成
    • 構成を変更する
      • 言語
      • パス
      • ディスプレイ
      • 構成を保存する
    • 有効なTech2Winライセンスを取得する
  • Tech2Winで作業する: 日々の作業のための詳細。
    • メニュー
    • PCMCIAイメージをダウンロードする
    • セキュリティ
    • レポートを表示
    • PCMCIAイメージのハンドリング
    • ステータスバー
  • アドバンストトピック: 通常のTech2Win使用では必要のない情報。 管理タスクの関係者のみ対象。
    • 再インストール
    • アンインストール
    • 構成ファイル形式
    • ログファイル
    • エラーメッセージ及びエラーコード
    • ATAカード
    • レジストリエントリ
    • ファイル
    • 構成管理
  • FAQ


イントロダクション

Tech2WinはTech2機能をエミュレートできるWindowsアプリケーションです。 基本的にTech2ソフトウェアはPC上で実行されます。 このプログラムを実行するには、ご使用のPCが以下の技術要件を満たしている必要があります。

  • 車両通信インターフェースがインストールされ、PCに接続されている必要があります。 使用可能なインターフェースは地域によって異なる場合があります。 ほとんどの場合、GMのMultiple Diagnostic Interface (MDI) が使用できます。
  • Tech2Winアプリケーションはインストール中にハードディスク上に150MBの空き容量を必要とします。 管理したいPCMCIAフラッシュカードそれぞれにつき、さらに32MGが必要です。
  • Tech2Winアプリケーションを実行する前に、物理メモリ (RAM) に最低100MBの空き容量が必要です。 PCには実行中を通じてRAM内にアプリケーションを保持できる十分なメモリ容量があることが必須です。
  • ご使用のPCのCPUは1.2GHz Pentium（シングルコア）相当である必要があります。 その他のアプリケーションを並行して使用しないことが強く推奨されます。
  • キーボードは不要です。 Tech2Winはタッチスクリーンでも操作できます。 構成管理では、ファイル名の入力が必要となるためキーボードの使用が強く推奨されます。
  • ご使用のカラーグラフィックディスプレイの解像度は最低でも800 x 600、色数は256が必要です。 キーパッドがないものは、解像度640 x 480でも使用できます。

Tech2Win（Tech2ではなくラップトップ）の使用時はラップトップに十分な電力があることを確認してください。 通常、ご使用のラップトップはTech2と同様、車両のバッテリーから電源供給を受けません。

  • インストール
  • 最初の手順


ライセンス

General Motors - Tech2Winライセンス同意書

このプログラムをご利用になる前に、以下の諸条件を注意深くお読みください。 この諸条件にご同意いただけない場合、または不明な点がある場合には、最寄りのアフターサービス担当者にご連絡ください。 本ソフトウエアを利用する権利は、Tech2Winインストール時に、ユーザーがこれらの諸条件を受諾し、本ライセンスに同意されることを唯一の条件として、General Motorsから供与されるものです。
General Motorsは、現地で適用される、General Motors国内販売会社との指定修理業者同意書によって規定されるGeneral Motors指定修理業者ネットワークのユーザーに対し独占的に、TIS2WebまたはGlobalTISまたはTIS2000に関連して、Tech2Winソフトウエアと含まれる情報を利用する権利を付与します。
Tech2Winライセンスは、指定修理業者同意書が施行されており、TIS2WebおよびGlobalTISおよびTIS2000ライセンスが付与されている限り有効です。 Tech2Winライセンスは、指定修理業者同意書の終了時にTIS2Web及びGlobalTISライセンスと共に終了します。

EU集団適用免除規定(BER) 1400/2002の第4条第2項で定義されている独立修理業者は、General Motors EuropeのGM Europe Info Tech Portalが提供するサブスクリプションの一部としてTech2Winライセンスを購入することができます。

Tech2Winライセンスには、車両通信インターフェースやPCのハードウェアは含まれていません。

該当のGeneral Motors国内販売会社からの書面による許可がない場合、Tech2Winソフトウエアのそれ以上の配布、転売、または指定修理業者の施設（指定修理業者同意書の関連添付書類に記載の通り）外の第三者へのオンラインでの提供は禁止されています。 この項は、現行のデータのみでなく、現行でないデータ（失効したDVDなど）にも当てはまります。

不正使用や濫用があった場合には、General Motors国内販売会社は、そのアクセス権を直ちに閉鎖すると共に、指定修理業者同意書の即時の終結を通知する権利を有します。この場合、クレジット残高や年間基本料金の残高の払い戻しを請求する権利は排除されます。

提供される情報は、改造されていないGeneral Motors車両に対し、専門的なサービスと修理作業を実行するためのものです。 前述の作業を実行するには、自動車整備士教育を完了し、定期的な研修を受けていることが事前条件となります。 提供される情報の中で特殊工具の使用が示唆されている場合には、専門的に修理を遂行する上では、そのような特殊工具の使用が不可欠となります。

General MotorsのTech2Winで公表されている情報（テキスト及び画像、音楽、グラフィック、アニメーション、ビデオなど）及びTech2Win上でのそうした情報の配置は、著作権で保護されています。 複製、配布、通信、送信、その他の使用は、General Motorsから事前の書面での許可がある場合を除き、禁止されています。

  • インストール: インストール手順
  • 最初の手順


Installation

インストール

Tech2Winのインストールには、PCのローカル管理者権限が必要です。 管理者権限がなければインストールができません。 そのような場合は、PCのローカル管理者に連絡してください。

Tech2Winを正しく使用するために、以下の2つの手順を完了する必要があります。

  • Tech2Winのインストール。
  • 車両通信インターフェースのインストール。
  • インストール: インストール手順
  • 最初の手順


インストール手順

インストール自体の所要時間は数分のみです。ユーザーによる以下の入力が必要です。

  1. ライセンス同意
  2. インストールディレクトリ

言語

オペレーティングシステムの言語はデフォルトではTech2Win UIが表示されます。 通常、以下の言語に対応します。 ご使用の言語に対応していない場合は、インストーラがデフォルトインストール言語の英語で起動します。

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)英語（英または米）*
  • el_GR (EL)Greek
  • es_ES (ES)スペイン語
  • fi_FI (FI)Finnish
  • fr_FR (FR)フランス語
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)ポルトガル語（ブラジル）
  • pt_PT (PT)ポルトガル語（ポルトガル）
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)簡体字中国語
  • zh_TW (ZH)繁体字中国語

* Tech2Winの言語は英語（英）です。 ただし、ソフトウェアのソースによってTech2ソフトウェア及び使用のインストーラが英語（米）の場合があります。

ライセンス同意

ライセンス同意を承諾する必要があります。

インストールディレクトリ

Tech2Winのインストール先のディレクトリは自由に選択できます。 インストールディレクトリのデフォルトは、<プログラムディレクトリ>\General Motors\Tech2Winか、再インストールの場合は前回に指定された場所になっています。

最後にインストールが確認されます。

仮想COMポートドライバ

仮想COMポートドライバはご使用のコンピュータに1回のみインストールされ、ドライバのバージョンが更新される（更新はほとんどない）まで、またはTech2Winがアンインストールされるまで維持されます。
ドライバがインストールされると、DOSボックスが短時間表示されます。 これは自動的に閉じるため、特に対処は必要ありません。 また、ドライバファイルがTech2Winインストールディレクトリの'driver'サブフォルダに置かれます。
仮想COMポートドライバは手動でインストールまたはアンインストールできますが、これは推奨されません。 CMDシェルから以下のコマンドのひとつを使用します。

  • 'vbsetup7'を呼び出してドライバをインストールする
  • 'vbsetup7 /u'を呼び出してドライバをアンインストールする
  • 最初の手順


Vehicle Communication Interface

ご使用の車両通信デバイスは別にインストールする必要があります。 それぞれの車両通信インターフェース付属のインストールガイドを参照してください。

  • 最初の手順: Vehicle Communication Interface
  • アドバンストトピック: 構成ファイル
  • インストール: インストール手順
  • FAQ: 複数のMDIを使用するにはどうすればよいですか？
  • FAQ: Tech2Winが専用のMDIを検索しませんでした


最初の手順

これらの最初の手順はTech2Winの使い方を示します。 Tech2自体を使い慣れていることを前提としています。 これらの最初の手順では車両通信は必要ありません。

クイック起動は以下の手順に従います。

  1. デスクトップのクイック起動のショートカットからTech2Winソフトウェアを実行します。
  2. 新しいTech2ソフトウェアをTIS2Webからダウンロードして有効なライセンスを取得します。

選択可能な構成を使用するには、

  1. デスクトップのTech2Winショートカットを使用してコンフィギュレータを起動します。 インストール後には、デフォルト構成が存在するはずです。
  2. 新規構成を作成するには、デフォルト構成をコピーすることが推奨されます。
  3. 既存の構成を要求に従って変更します。
  4. 有効なライセンスを取得します。

互換モードでTech2Winを起動しないでください。 そのような場合はログファイルに警告が表示されます。 Tech2Winは、XP以降のWindows関数のみを使用し、それより前のWindowsバージョンでは機能しません。

  • 最初の手順: 新規構成
  • 最初の手順: 構成を変更する
  • 最初の手順: Vehicle Communication Interface
  • Tech2Winで作業する: メニュー
  • Tech2Winで作業する: セキュリティ
  • Tech2Winで作業する: ステータスバー
  • アドバンストトピック: 構成ファイル


構成を選択する

初めてTech2Winアプリケーションを起動すると以下の画面が表示されます。 デフォルト構成でTech2Winを直接起動するオプションがあります。 デフォルト構成は車両通信がなくても機能します。

Start First Time

ライセンス情報のメッセージボックスが表示されますが、これを無視してデフォルト構成を起動することができます。

タッチスクリーンを使用している場合は、PCキーボードプログラムを起動してキーボードをシミュレーションするアプリケーションから文字入力を可能にするのが有効です。


キーボード

PCキーとボタン（ある場合）は、従来のTech2キーと同様にマップされています。 Tech2Winでは、オリジナルのTech2にはなかった追加のキーがあります。 PCの番号キーパッドはすべての条件で機能しないことがあります。 問題が発生したら、PC上の標準キーボードレイアウトが変更されているかを確認してください。 その場合は、特にShiftキーが損傷している可能性があります。

PCキーボード | ボタン | 機能
F1ファンクションキー | 該当なし | Tech2Winヘルプ
F5～F8ファンクションキー | ソフトキーのあるTech2Win表示エリアを使用する | Tech2の4つのソフトキー
上下左右のカーソルキー |  | Tech2上下左右のキー; これらのキーにのみ自動リピートがある。
0～9番号キー | F0 • • • F9 | Tech2 F0～F9キー
バックスペース | Exit | Tech2 Exitキー
入力/改行 | Enter | Tech2 Enterキー
Y | Yes | Tech2 Yesキー
N | No | Tech2 Noキー
Q | ? | Tech2 ?キー
S | Shift | Tech2 Shiftキー; ステータスバーのShiftインジケータまたはShiftボタンの上のインジケータがステータスを示す。
ctrl-P | PWR | Tech2 Powerキー; このキーは当然Tech2WinアプリケーションのみをOFFにする。
ctrl-R | なし | Tech2Winをリセットする。 Tech2の電源OFF/ONサイクルに相当。 ただし、アタッチされた車両通信インターフェースはリセットされない。 PCMCIAイメージなどのファイルはリロードされない。
Home | Home | ホームキー。 一部のアプリケーションのみ対応。
メニューオプションのファイルからのみ使用可能。 | Print Screen | BMP一時ファイルを作成し、BMPに関連付けられたアプリケーションを呼び出して、Tech2画面のスクリーンショットを印刷する。 このアプリケーションを使用して印刷前にイメージのサイズを変更、あるいはイメージを回転する。
メニューオプションのファイルからのみ使用可能。 | Save Screen | Tech2画面のスクリーンショットをBMPまたはPNGファイルで保存する。
メニューオプションのファイルからのみ使用可能。 | View Report | ユーザーが確認できるようアクティブなPCMCIAフラッシュカード上のすべてのレポートを表示する。


Windowsのハンドリング

標準のWindowsの操作でメインウィンドウの罫線をドラッグしてウィンドウのサイズを変更することができます。 また、メニュー項目オプション/解像度は複数のプリセットサイズに対応します。 メニュー項目からメインウィンドウのサイズの変更中、キーパッドは自動的にドッキングされたままになります。

ディスプレイタブで構成を変更するとウィンドウの外観が変更されます。


新規構成

新規作成ボタンをクリックして新規構成を作成します。 既存の構成ファイルをソースとして使用するかどうかをたずねるダイアログメニューが表示されます。 通常は、デフォルト構成を選択します。 新規構成のファイル名を入力してからコピーボタンを押します。

タッチスクリーンを使用している場合は、 PCキーボードシミュレーションをPCキーボードボタンから起動するのが有効です。

キャンセルボタンを押すと作成プロセスを取り消すことができます。

新規構成はソースの既存の構成と同じPCMCIAファイルを使用します。 それを変更したい場合は、別のPCMCIAファイルを使用するように構成を変更する必要があります。 ほとんどの場合、既存のPCMCIAファイルを新規ファイルに単純にコピーして、その新規ファイルを使用します。 ソースの構成と同じPCMCIAファイルを新規構成で使用したい場合があります。 そのような場合は、 保存ボタンを押すと警告画面が表示されます。

  • 構成を変更する


構成を変更する

青表示の構成は読み取り専用に指定されているため変更できません。 これらの構成は表示のみ可能です。 もちろん、単純にコンテンツを表示するために変更メソッドを使用しても構いませんが、保存は使用できません。

構成は、4つのタブ言語、Vehicle Communication Interface、パス、ディスプレイの個別設定を選択して変更します。 希望のタブを選択しても、単純に次へボタンを押して次のタブをアクティブにすることもできます。 変更を加えた後、保存ボタンを押して構成を保存します。

キーボード入力が必要な場合には、PCキーボードをシミュレーションするPCアプリケーションを呼び出すこともできます。 キーボードが使用できないタッチスクリーン式のラップトップでは特に有効です。


言語

言語タブでは、Tech2Winの実行言語の選択が可能です。 この選択はPCMCIAイメージ上のTech2ソフトウェア内の言語には影響しません。 Tech2ソフトウェアをTISからダウンロードする場合には、正しい言語を選択する必要があります。

地域によっては、使用できない言語があります。 そのような場合は代わりに英語が表示されます。 同じような言語があるか確認してください（PBポルトガル語（ブラジル）ではなくPTポルトガル語（ポルトガル） ）。


パス

パスタブでは、PCMCIAイメージとローカルソフトウェアキーボードのパスの両方が設定できます。 また、メモリーカードのコピー ...ボタンを使用するとPCMCIAイメージをコピーすることができます。 新規構成を作成した場合、複数の構成が同じPCMICAイメージを使用するのを避けるためにこのボタンを使用することができます。

Memory Card Options

メモリーカードのコピー ...

このボタンを使用するとPCMCIAイメージを別ファイルにコピーすることができます。 この機能はTech2の新規PCMCIAカード購入と非常によく似ています。 コピー関数はディレクトリC:\Users\Public\General Motors\Tech2Win\pcmciaのファイルにのみ機能します。

スロット0 : メモリーカード画像ロケーション

ここではスロット0のPCMCIAイメージを含むファイルを指定することができます。 通常、そのようなファイルはC:\Users\Public\General Motors\Tech2Win\pcmciaにありますが、その他の場所にある場合もあります。

スロット1 : メモリーカードまたはATA

Tech2と同様、Tech2Winも2つのPCMCIAカード（イメージ）に対応します。 ただし、１つの構成内での2つ目のPCMCIAイメージは、通常あまり有効ではありません。 2つ目のソフトウェアはおそらく2つ目の構成で使用されます。

Tech2と同様、ATAカードはデバッグを目的として使用されます。 ATAカードはテクニカルサポートの指示があった場合のみ起動してください。 詳しい情報が提供されます。

PCソフトウエアキーボードロケーション

このファイルの既定値はWindowsのレジストリから取得し、マウスでPCキーボードのシミュレーションが可能なアプリケーションをポイントします。 ご使用のラップトップにこの機能を持つ特別なアプリケーションがある場合は、そのアプリケーションをここで指定することができます。


Vehicle Communication Interface

  • Tech2-RS232-エミュレーション用COMポート
  • 使用するMDIシリアルナンバー
  • プロトコル

Tech2-RS232-エミュレーション用COMポート

Tech2エミュレーションに使用可能な空いているCOMポートを選択してください。 便利な機能として、すでに使用中のシリアルポートを構成が検索して表示します。

既存のCOMポートを選択すると、その既存のCOMポートにTech2Winがアタッチします。 このCOMポートを使用してヌルモデムケーブルを接続し、Tech2ソフトウェアをTISアプリケーションを実行するもう一台のコンピュータからダウンロードすることができます。 Windowsの制限により、実COMポートを115.200ボーで使用した場合には確実な動作が得られない場合があります。

存在しないCOMポートを選択した場合は、Tech2Winが自動的に仮想ポートを作成します。 この仮想ポートは、Tech2Winとの通信を確立するために同じPCで実行中のTISから使用されることがあります。 仮想ポートの使用ではボーレートの制限はありません。

COMポートに「検索」を選択した場合、Tech2Winが9～1の中で空いている最初のポート番号に仮想COMポートを作成します。

使用するMDIシリアルナンバー

MDIのシリアル番号を入力します。 番号はMDIの裏側に記載されています。 ハイフンの後の番号を使用してください。

シリアル番号を入力しない場合は、Tech2Winが自動的にネットワーク内で検出したMDIの一覧を表示します。ユーザーはその中からMDIを選択することができます。 指定したMDIが見つからない場合は同じ選択ボックスが表示されます。

プロトコル

'ISO22900-2 / PDU-API'が選択され、J2534-2は常にグレー表示されます。 将来的には、Tech2WinはJ2534プロトコルにも対応するようになります。

  • アドバンストトピック: 構成ファイル
  • FAQ: Tech2Winに使用するCOMポートを決定するにはどうすればよいですか？
  • FAQ: Tech2WinとTIS2Web間の通信
  • FAQ: 複数のMDIを使用するにはどうすればよいですか？
  • FAQ: Tech2Winが専用のMDIを検索しませんでした


ディスプレイ

ディスプレイタブは主にTech2Winのディスプレイの設定変更に使用します。

  • キーパッド
  • 色
  • 音声
Display and Key Options

キーパッド

ここではキーパッドを表示するかどうかを選択できます。 キーパッドはTech2Win画面の左側または右側に表示されます。 背景色は標準色のダイアログボックスから選択が可能です。

色

Tech2画面の背景及び前景色はここからそれぞれ選択できます。 これらは最も標準的な色の組み合わせの2つです。

Screen with background 0000FF, foreground FFFFFF | キーパッド背景 - 白; 背景 - 青; 前景 - 白
Screen with background 000000, foreground C0C0C0 | キーパッド背景 - 青; 背景 - 黒; 前景 - 薄灰色

音声

ここで音声OFFを選択することができます。 Tech2プログラムのビープ音にはPCのラウドスピーカーが使用されます。


構成を保存する

左下にある保存 <構成>ボタンを使用してアクティブな構成を保存します。 読み取り専用の構成を表示している場合はこのボタンは表示されません。


TIS2Webを介した有効なライセンス

通常、Tech2ソフトウェアをTech2Winにダウンロードすると有効なライセンスが提供されます。 また、TIS2Web（TIS2000ではない）から'セキュリティアクセス (Security)'を実行するとライセンスを取得することができます。 そのため、車両通信インターフェースのコンフィギュレータ内の仮想COMポートの選択が前提です。

セキュリティアクセスに成功すると、ステータスバーの右側に解除されたロックのアイコンが表示されます。 カッコ内にはライセンスの有効日数が表示されます。 Tech2Winを再起動すると、実行中の車両通信がない限りセキュリティインジケータは表示されません。 最初の車両通信中に、ライセンスがチェックされ、インジケータに解除されたロックまたは解除されていないロックが表示されます。

  • Tech2Winで作業する:セキュリティ
  • FAQ:Tech2Winに使用するCOMポートを決定するにはどうすればよいですか？
  • FAQ:Tech2WinとTIS2Web間の通信
  • FAQ:有効なライセンス
  • FAQ:Tech2Winライセンスとセキュリティアクセスの違いは何ですか？


Tech2Winで作業する

以下のトピックは、Tech2Winで作業するほとんどのテクニシャンが使用するものです。

  • メニュー: 画面のレイアウトと個別メニュー項目。
  • PCMCIAイメージをダウンロードする: Tech2Winの診断ソフトウェアの更新は、Tech2で使用されるメソッドと非常によく似ています。
  • セキュリティ: セキュリティ対策はTech2Winが認証されていない環境で車両通信を実行するのを防ぎます。
  • レポートを表示: Tech2WinではTech2キーボードが若干拡張されています。 「レポートを表示」のボタンは最も分かりやすい例です。
  • PCMCIAイメージのハンドリング: Tech2で複数のPCMCIAカードを持つのと同様に、Tech2Winで複数のPCMCIAイメージを持つ場合があります。
  • ステータスバー: ステータスバーはステータスバーの各部分についてユーザーに知らせます。
    • アドバンストトピック
    • FAQ


メニュー

Tech2Winアプリケーションには以下のメニューエントリがあります。

  • ファイル
  • オプション
  • ウィンドウ
  • ヘルプ

ファイル

ファイルメニューでは以下が可能です。

  • T2-画面（320x240）の保存 実際のT2-Screenを320x240ピクセルの白黒ファイルでPCに保存するのに使用します。 保管場所とファイル形式（BMP、GIF、JPG、PNG）は自由に選択できる。
  • 画面の印刷 Tech2画面の白黒反転のBMPイメージを作成し、BMPファイルに関連付けられたプログラムを呼び出します。 このプログラムをイメージの印刷に使用することができます。
  • レポートファイルを表示 TIS2Webを使用せずにレポートファイルを表示（及び印刷）することが可能です。
  • 終了 Tech2Winを終了します。

オプション

オプションには以下の選択があります。

  • 解像度 3つの標準画面サイズからサイズを選択する場合に使用できます。
  • ROM-Write from 0x00003ED76 内部のデバッグ目的で使用します。
  • 自動スクリーンショット ログディレクトリに異なるTech2画面のイメージを保管します。
  • CANdi および Reboot を無効にします 車両との間にCANdiを持たないTech2をイミテートします。 これは、標準ではない車両通信ラインにCANdiが割り込みを行うまれなケースで必要です。

ウィンドウ

ウィンドウメニューからはTech2Winデータディスプレイ及びTech2Win DTCディスプレイの選択を起動できます。 その他の選択は現在のTech2Winバージョンではグレー表示されます。

Tech2ソフトウェアがTech2Winデータディスプレイに対応している場合、このメニューのエントリを有効にすることができます。 Data Displayに入るとTech2WinがもうひとつのData DisplayウィンドウをTech2 Data Displayと並行して表示します。 Tech2画面がData Displayを表示している限り、メニューエントリを有効にすることはできません。 そのような場合は、Data Displayを終了し、メニューエントリを有効にしてData Displayを再起動する必要があります。

Tech2Winデータディスプレイと同様の制限がTech2Win DTCディスプレイに適用されます。 Tech2ソフトウェアがTech2Win DTCディスプレイに対応トしている場合、このメニューのエントリを有効にすることができます。 もうひとつのDTC DisplayウィンドウがTech2 DTC Displayと並行して表示されます。 Tech2画面がDTC Displayを表示している限り、メニューエントリを有効にすることはできません。 そのような場合は、DTC Displayを終了し、メニューエントリを有効にしてDTC Displayを再起動する必要があります。

ヘルプ

以下の選択が可能です。

  • ヘルプのトピック... Tech2Winヘルプを呼び出します。
  • コマンドラインパラメータ Tech2Winに使用されるコマンドラインパラメータを表示します。
  • 以下について 現在のバージョン番号とTech2WinのTIS2Webダウンロード制限を表示します。


ダウンロードする

まず、Tech2Winを起動し、メインスクリーンに表示しておきます。 TIS2WebまたはGlobalTISを起動し、Vehicle Communication Interfaceタブで指定されたCOMポートを介してダウンロードを実施します。

ビルトインのCOMポートを使用すると、TISを実行する別のPCからTech2ソフトウェアをダウンロードすることができます。 必ずRS232のクロスケーブルを使用してください。 Tech2Win実行中のPCのハードウェアによって、データ転送速度を57.600ボーまで下げなければならない場合があります。ボーレートがこれより高いとWindowsがデータを紛失することがあるためです。

最新のTech2Winバージョンは、TIS2Web及びTech2Winが同じPCで実行している場合、高速ダウンロードに対応します。 その間、COMポートを介したTIS2Web/Tech2Win間の最低限の通信が実行されますが、時間のかかるTech2Winへのデータ送信は内部のファイル転送に置き換わります。 そのような場合、ダウンロード時間が1分未満に大幅に短縮されます。

  • アドバンストトピック: 構成ファイル
  • 最初の手順: Vehicle Communication Interface
  • FAQ: Tech2Winに使用するCOMポートを決定するにはどうすればよいですか？
  • FAQ: Tech2WinとTIS2Web間の通信


セキュリティ

Tech2Winが使用するセキュリティメカニズムは正しいPCクロック値に依存します。 PCクロック値が常に設定されていることを確認してください。 Tech2Winは夏時間によるクロックの小さな変更に対応します。

有効なアクティブのライセンスがない場合、Tech2Winは車両通信を実行しません。 以下のステータスバーインジケータはライセンスのステータスを示します。

  • green smiley ライセンスが有効。
  • インジケータなし： ライセンスのチェック未実施。
  • red smiley ライセンスが有効期限切れ。

ライセンスを取得するには、TIS2Webアプリケーションを使用して'セキュリティアクセス (Security)'更新を実施します。 ほとんどの場合、TIS2Webを介した'ソフトウェア ダウンロード (SWDL)'でも新しいライセンスの取得に十分です。 ライセンスは一定期間（一部の地域では4週間）を過ぎると無効になるため、定期的にそのような更新を実施する必要があります。

ライセンスは地域/ソフトウェア固有です。 異なるTech2ソフトウェアバージョンのTech2Winを使用している場合は、コンピュータ上にライセンスがある場合があります。

ライセンスの有効期限までの日数はステータスバーに表示されます。

  • (0) はライセンスの有効期限切れ、またはライセンスがないことを示します。
  • (<1) は24時間以内にライセンスの有効期限が切れることを示します。
  • (20) は20日後にライセンスの有効期限が切れることを示します。

ライセンスファイルを改ざんしてはいけません。 ファイルの不正変更は、内部セキュリティ対策によって検知され、それによってコンピュータ上のすべてのライセンスが失われます。 また、Tech2Winに予期せぬ挙動が現れます。 これを修正するには新規インストールを実施しなければなりません。

  • アドバンストトピック: エラーメッセージ及び終了コード
  • アドバンストトピック: ログファイル
  • Tech2Winで作業する: ステータスウィンドウ
  • FAQ: 有効なライセンス
  • FAQ: Tech2Winライセンスとセキュリティアクセスの違いは何ですか？
  • FAQ: 急停止


レポートを表示する

View Report このボタンを使用するとPCMCIAカード上に存在するPRTファイルのコンテンツを表示できます。 ダイアログボックスが開き、 PRTファイル一覧が表示されます。 プログラムがPRT拡張子に関連付けられている場合は、関連のプログラムが実行されます。 そうでない場合は、テキストエディタが開いて選択ファイルが表示されます。

ほとんどの場合、PRTファイルは各言語のコードページを使用するASCIIファイルです。 中国語、日本語、韓国語、タイ語については、先頭にバイトオーダーマーク(BOM)が付いたUnicodeファイルです。

レポートの表示では、Tech2WinはサブディレクトリC:\Users\Public\General Motors\Tech2Win\reportsで動作します。 レポートを1回以上表示した場合のみ、このサブディレクトリが存在します。 ディレクトリは自動的に消去され、アクティブなPCMCIAカード上のPRTファイルの一時ディレクトリとして機能します。 そこにはTech2Winが実行を停止してもこれらのファイルが維持されます。 そのようなファイルを保存したい場合は、別のディレクトリにコピーする必要があります。別のユーザーがレポートの表示を選択するとすぐに上書きされることがあるためです。


PCMCIAイメージ

通常、PCMCIAイメージはサブディレクトリC:\Users\Public\General Motors\Tech2Win\pcmciaにあります。 ファイルのサイズは32MB（33,554,432 バイト）または10MB（10,485,760バイト）ちょうどで、拡張子は*.binでなければなりません。 ダウンロードが実施された場合、またはTech2Winがフラッシュカードに保存を行った場合には、（通常のPCMCIAカードと同様に）イメージが変更されます。 変更は、書込み禁止スイッチ（コマンド -W0 または -W1）を使用するか、'-W'-オプションの'p'-値を省略することによって禁止することができます。(構成ファイル). 書き込み禁止スイッチはコンフィギュレータからアクセスできません。 '-W0'または'-W1'または'-W'のオプションを使用したい場合は、構成ファイルを手動で変更する必要があります。


ステータスバー

ステータスバーがTech2画面の下に表示されます。 以下の項目がステータスバーに表示されます。

  1. 速度インジケータ
  2. 車両通信状態
  3. シリアルポート状態
  4. SHIFTキー
  5. 自動スクリーンショット
  6. ログ警告
  7. ライセンス

Status Bar

速度インジケータ

速度インジケータはTech2ソフトウェアのエミュレーションに使用されるCPU時間を示します。 数値が低い（インジケータ左側）方が高い（インジケータ右側）よりもよい状態を示します。 インジケータが緑の場合は許容範囲内です。 別のWindowsのタスクが急にアクティブになると、インジケータが一時的に黄色を示すことがあります。 そのようなアクティビティは避けてください。

車両通信状態

車両通信状態は車両通信インターフェース (MDI) と車両/Tech2Win間の通信が存在するかを示します。

シリアルポート状態

インジケータは、COMポートを介したTech2Winとの通信中にCOMポート上の通信がアクティブかどうかを示します。

SHIFTキー

このインジケータはSHIFTキーがアクティブかどうかを示します。 キーボードの'S'キーまたはキーパッドのSHIFTキーを使用してこれを切り替えることもできます。

自動スクリーンショット

'自動スクリーンショット'は'オプション'メニューで起動できます。 画面が変更されるたびに新しいスクリーンショットファイルがログディレクトリに保管されます。 するとステータスバーの赤いカメラのクランクハンドルがONになります。 '自動スクリーンショット'が解除されるとカメラが非表示になります。

ログ警告

ログステータスインジケータには3つの状態があります。

  • gray log status indicator ログファイルに警告やエラーは含まれていません。
  • yellow log status indicator ログファイルに警告メッセージが含まれています。
  • red log status indicator ログファイルにエラーメッセージが含まれています。

ライセンス

ライセンスインジケータには3つの状態があります。

  • green smiley ライセンスが有効でアクティブです。
  • インジケータなし： ライセンスのチェック未実施。
  • red smiley ライセンスの有効期限切れまたはライセンスがありません。
詳しくはセキュリティのリンクを参照してください。

ステータスバーのツールチップ

アイコンの中には ツールチップが表示されて追加情報を表示するものがあります。

VCIシリアル番号のツールチップ
Tooltip VCI

TECH2ソフトウェアバージョンのツールチップ
Tooltip TECH2

COMポートのツールチップ
Tooltip Comport

次のスクリーンショット番号のツールチップ（'自動スクリーンショット'がアクティブの場合）
Tooltip Camera

「警告」以上のレベルを持つ最後のログファイルエントリを示すツールチップ
Tooltip Logfile

正確なライセンス有効期間のツールチップ
Tooltip License

ツールチップはカーソルをアイコン上に0.5秒以上乗せると表示されます。5秒後またはカーソルが移動するとツールチップが非表示になります。

  • アドバンストトピック: エラーメッセージ及びエラーコード
  • アドバンストトピック: ログファイル


アドバンストトピック

ここに記載されるトピックはTech2Winの標準的なユーザーにはあまり重要ではありません。 Tech2Winのセットアップ、管理、構成の関係者には以下の情報が役立つ場合があります。

  • 再インストール
  • アンインストール
  • 構成ファイルの直接変更
  • ログファイル
  • エラーメッセージ及び終了コード
  • ATAカード
  • レジストリエントリ
  • ファイル記述
  • 構成管理の例


アンインストール

インストールディレクトリ一式、ユーザーデータを含むディレクトリ(C:\Users\Public\General Motors\Tech2Win)及びアプリケーションデータを含むディレクトリ(C:\ProgramData\General Motors\Tech2Win)が消去されます。

  • アドバンストトピック: 再インストール
  • インストール


構成ファイル

構成ファイルは常にサブディレクトリC:\Users\Public\General Motors\Tech2Win\configにあり、拡張子は*.confです。 ファイルのオプションにはTech2Winからアクセスできないものがあるため、構成ファイルを手動で変更したい場合があります。 構成ファイルは先頭にバイトオーダーマーク(BOM)が付いたUnicodeファイルです。 手動で変更する際は、メモ帳などのUnicode対応エディタを使用することを強くお勧めします。

構成ファイルは行指向です。 空行は無視されます。 行は常にオプションで開始し、ほとんどの場合はその後に値が続きます。 例として、default.conf ファイルを参照してください。 使用できるオプションについては下表を参照してください。

特定の構成をデスクトップから直接起動したい場合は、'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.confを実行するショートカットを作成します。 プログラムがワーキングディレクトリ'C:\Program Files\General Motors\Tech2Win\bin'から起動するはずです。

オプション | 値/意味
; コメント
@ メジャーバージョン.マイナーバージョンの形式を取る10進数バージョン番号。
メジャーバージョン番号がTech2Winと異なる構成ファイルは不可。 マイナーバージョン番号がTech2Winより低い構成ファイルは可。
-W0
-W1 		スロット0/1のPCMCIAカードは書き込み禁止スイッチがオンになっている。
-B0
-B1 		スロット0/1のPCMCIAカードのブロックサイズ(Kbytes)。 許可されている値は128（既定値）または256。
-P0
-P1 		スロット0/1のPCMCIAのバイナリイメージを含むファイル。 ファイルサイズは10MBまたは32MBちょうどであること。 %ProgramData%などの環境変数はエクスパンションされる。
このオプションがない場合、スロットは空と見なされる。
-A0
-A1 		スロット0/1のPCMCIAカードの属性値を含むファイル。 ない場合は、カードとブロックサイズに基づいてデフォルト属性が使用される。
-W | Tech2Win終了時、すべての永続データがそれぞれのファイルに書き込まれる。 p/f/r/cの値は組み合わせて、それぞれ PCMCIA/Flash-ROM/RTC/CANDI-Appを示すことができる。
-H | ヒープ管理機能 0/r/w/tの値をそれぞれアクティブなゼロ設定、読み取りチェック、書き込みチェック、タスクチェックに組み合わせることができる。 lの値は、代替割り当てスキームが実装されているため、常に下位アドレスでのヒープメモリの割り当てを実施するために使用される。 通常、このオプションは開発環境でのみ使用される。
-PC | 以前のPCMCIAカードのコピーパス。 このオプションは現在は無視される。
-MS | シリアル番号による車両通信インターフェース(MDI)の識別。 設定されていない場合は、使用可能なMDI一覧が表示される。
-CT | 3桁の16進数バイト値による文字（前景）色。 既定値は000000（白）である。
-CB | 3桁の16進数バイト値による背景色。 既定値はFFFFFF（黒）である。
-ATA | ATAキャプチャカードを有効にする場合はこのオプションを使用する。 ATAキャプチャカードを無効にする場合はこれを除外する。
-C | Tech2のRS232C通信ポートとして使用されるCOMポート番号 (1..9)。 COM9はたいていTech2Winによってインストールされる仮想COMポートに使用される。 このオプションがない場合は、空いているCOMポートの検索がCOM9から降順に実施される。 Tech2アイコンとTIS2Webアイコンの間のステータスバーツールチップを使用して使用中のCOMポートを確認する。
-WR | PCMCIA及びFLASH ROM領域に書き込みが許可されているPCアドレス（通常は253558）。 この機能はメニューで（またはオプション-WAを使用して）別に起動する必要がある。 変更不可のメモリのコードをシングルステップデバッガでデバッグする必要がある。
-WA | シングルステップデバッガの変更不可のメモリへの書き込みを許可する。
-OF | オプション/値のペアを含むオプションファイル。
-TP | タイミング調整 （比例値）. 既定値5000に設定する。 この値を下げて実行サイクル数を速めてリアルタイムに合わせる。
-TD | タイミング調整 （微分値）. 既定値100に設定する。 この値を下げて瞬時タイミングの変化に速く反応するようにする。 警告: TP及びTDの値の改ざんは速度の問題を引き起こすことがある。
-PJ
-PP 		使用するプロトコルを指定する。
PJはJ2534通信。
PPはISO22900-2 / PDU-API（規定値）
-S | このオプションがあれば、PCのビーパーの音声出力が可能になる。
-L | Tech2Winアプリケーションの言語。 このエントリがない場合はデフォルトとしてアクティブなWindows言語が使用される。 指定可能な言語一覧はリンク言語を参照。 Tech2エミュレーションウィンドウ自体はPCMCIAカード上の（PCMCIAカードにダウンロードされた）言語を表示する。
-UD | ユーザーデータディレクトリの無効化。 Win7では、通常C:\Users\Public\General Motors\Tech2Winにある
-AD | アプリケーションデータディレクトリの無効化。 Win7では、通常C:\ProgramData\General Motors\Tech2Winにある
-US | Tech2Winの複数のインスタンスの検出にユーザー固有のセマフォを使用する。 このオプションは各ユーザーがサーバーなどの同一マシン上でTech2Winを並行して実行できるようにする。 このオプションを使用する場合は、オプション-UD及び-ADも指定する必要がある。
-SS | キーパッド（ある場合）を含むTech2Winウィドウのサイズ全体を指定するオプション。 最初のパラメータはダブルコーテーションマーク(')で囲んだ文字列であること。これはオプション / 解像度メニューのサイズ名に使用される。 2番目のパラメータはキーパッドを含むTech2Win画面の水平方向の合計ピクセル数。 3番目のパラメータはTech2Win画面の垂直方向の合計ピクセル数。 4番目のオプションパラメータはキーパッド幅のピクセル数。
-SH 画面ハンドリングをコントロールするオプション。 以下の10進数を使用して無効にする画面ハンドリングを指定する。
  • Bit 0: 最小/最大無効。
  • Bit 1: 画面の位置変更無効。
  • Bit 2: サイズ変更無効。 この場合、オプション / 解像度メニューはグレー表示になる。
  • Bit 3: Data Display及びDTCウィンドウはTech2Win（キーパッドなし）と同一サイズ


ログ

Tech2Win構成を起動するたびに新しいログファイルがHTML形式でC:\Users\Public\General Motors\Tech2Win\Logsサブディレクトリに作成されます。 ハードディスク上のログファイルの増加を防ぐため1週間以上前のファイルは削除されます。

ログファイルは日付（year（年）、month（月）、day（日）） と 時刻（hour（時）minute（分）、second（秒））に基づいて自動的に命名されます。
yyyy-mm-dd_hhmmss.html

ログファイルのエントリは常に英語で、先頭にバイトオーダーマーク(BOM)が付いたUnicode形式です。 ログファイルの各行は以下のログレベルのいずれかです。

ログレベル | 意味
インフォメーション | インフォメーションのみ。 プログラム実行に影響なし。
警告 | まれな状況が発生。 ユーザーはその影響に気付かない場合がある。
ERROR | ユーザーが気付くエラー発生。
CRITICAL | プログラムに異常挙動が現れる致命的エラー発生。
FATAL | 致命的エラーによりTech2Winの動作がただちに停止する。

「警告」から上のレベルはすべて色付けされて見つけやすくなっています。

また、画面の印刷または自動スクリーンショットメニューオプションが使用されると、プリントファイルやビデオファイルもLogsサブディレクトリに現れます。
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
自動スクリーンショット画像はHTMLファイルにリンクされているため、これらの画像のシーケンスを表示するにはHTMLログを使用します。

ステータスバーが警告エントリ( yellow lightning bolt)またはさらに重大なログエントリ( red lightning bolt)の有無をユーザーに知らせる。


エラーメッセージ及び終了コード

ダイアログボックスにエラーメッセージが表示されることがあります。 これらのダイアログボックスが表示されても、Tech2WinはTech2プログラムを並行して実行することが可能です。 終了コードはTech2Winが異常終了する致命的エラーです。 終了コードをバッチファイルで使用してプログラムが終了した原因を検出することができます。

エラーメッセージ

以下のエラーメッセージが表示されることがあります。 簡単な状況の説明と問題の解消方法が記載されています。

Emulator too slow Emulator failed to start

終了コード

終了コード | 値 | 意味
OPCODE_ERROR | -7 | Tech2マイクロプロセッサ(68332)の無効コマンドが検出されました。 PCMCIAイメージがおそらく何らかの理由で破損しています。
ATA_PROBLEM | -6 | ATAエミュレーション中に問題が発生しました。 ATAカード使用の指示の後にこのような問題が発生した場合はヘルプデスクに連絡してください。
DEMO_TIME_IS_UP | -5 | Tech2Winの公式バージョンでは現れないはずです。
DLL_NOT_LOADED | -3 | 必要なDLLのひとつがロードできません。 ご使用のTech2Winのコピーが不完全である可能性があります。 新規インストールを実施して、別の言語を選択してください。
EXIT_INIT_FAILED | -2 | 初期化が失敗しました。 ログファイルを確認して原因を究明してください。 ログファイルがない場合は、すべてのディレクトリに対して正しい読み書きアクセスがあるか確認してください。
正常 | 0 | Tech2Winが正常に終了しました。


ATAカード

Tech2のATAカードは、原則としてソフトウェア開発中のデバッグのみを目的として使用します。 必要なATAデータはすべてサブディレクトリC:\Users\Public\General Motors\Tech2Win\ataCaptureに保管されています。 通常、このディレクトリは重要ではないため、特に指示がない限り安全に消去することができます。

ataCapture ディレクトリは固定のため、そのコンテンツはすべての構成と同じになります。


ファイル

Tech2Winは以下のファイル及びディレクトリを使用します。

ディレクトリ | Vistaより前のバージョンでの場所 | Vista以降のバージョンでの場所
インストール | インストール時の定義の通り。
ユーザーデータ | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
アプリケーションデータ | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

ファイル | 用途
[ユーザーデータ]\atacapture | ATAカード上に存在するファイルが含まれる。 別途指示がない限り、これらのファイルは不要。
[インストール]\bin | 実行可能ファイル、必要なDLL、実行に必要なイメージが含まれる。
[インストール]\bin\emulator.exe | Tech2コードを実行する主な実行可能ファイル。
[インストール]\bin\emulator_xx_XX.dll | 言語固有のリソースDLL。
[インストール]\bin\T2Configurator.exe | Tech2Winの構成部分
[インストール]\bin\Pictures | Tech2Winが必要とするアイコンが含まれる。
[ユーザーデータ]\config | すべての構成ファイルが含まれる。
[ユーザーデータ]\data | Tech2Win実行中に変更されたファイルが含まれる。 これらのファイルはTech2Winを正しく実行するために必要である。 特に指示がない限り、通常はこれらのファイルは触らないこと。
[アプリケーションデータ]\data | Tech2Win実行中に変更されたファイルが含まれる。 これらのファイルはTech2Winを正しく実行するために必要である。 特に指示がない限り、通常はこれらのファイルは触らないこと。
[アプリケーションデータ]\data\emulator.sec | セキュリティファイル . このファイルは変更しないこと。
[アプリケーションデータ]\data\emulator.card | カードファイル. Tech2Winプログラム既知のすべてのPCMCIAカードが含まれる。 このファイルは変更しないこと。
[ユーザーデータ]\data\emulator.disp | このファイルにはTech2Win画面の場所とサイズが含まれる。 このファイルを削除するとファイルが復元され、Tech2Win画面が左上で640x480のサイズで起動する。
[アプリケーションデータ]\data\emulator.lic | ライセンスファイル. ライセンスの有効期限に関する情報が含まれる。 このファイルは変更しないこと。
[アプリケーションデータ]\data\emulator.rtc | リアルタイムクロックファイル. このファイルはTech2のRTCで見つかったデータの保管場所として使用される。
[アプリケーションデータ]\data\emulator.dta | 「今後通知しない」インフォメーションファイル。. このファイルは、ループバックアダプタを必要とするセルフテスト実行不可の警告を表示しない（今後表示しない） PCMCIAソフトウェアバージョンを保管する。
[アプリケーションデータ]\data\candi.bin | CANdiアプリケーションファイル. Tech2にアタッチするCANdiアプリケーションが含まれる。
[アプリケーションデータ]\data\eprom.bin | Tech2内部EPROMファイル. 内部Tech2フラッシュメモリのコンテンツが含まれる。
[インストール]\driver | 仮想COMポートドライバのインストールファイル。
[インストール]\help\emulator_xx_XX.chm | 言語固有のヘルプファイル。
[ユーザーデータ]\Logs | ログファイルが含まれる。 1週間以上前のファイルは自動的に消去される。
[ユーザーデータ]\pcmcia | PCMCIAイメージファイルが含まれる。 例えるとそれぞれのファイルはTech2 PCMCIAカードに相当する。 これらのファイルは任意の場所に保存できる。


構成管理

構成ファイルは常にサブディレクトリC:\Users\Public\General Motors\Tech2Win\configにあり、拡張子は*.confです。 Tech2Winは、新規構成ファイルの作成または読み取り専用ではない既存の構成ファイルの変更にのみ使用できます。 構成ファイルのその他の管理すべてについては、Windows Explorerまたは同様のファイルハンドルプログラムを使用してください。 これは以下のアクティビティで必要になります。

  • 構成ファイルの消去
  • 構成ファイル名変更
  • 構成ファイルの読み取り専用属性の変更

常に構成ファイルdefault.confを保持することが強く推奨されます。 通常、このファイルは誤った上書きを避けるため読み取り専用属性に設定されています。 ただし、特定のニーズに合わせてこのファイルを変更する場合は、読み取り専用属性を削除する必要があります。

PCMCIAイメージはサブディレクトリC:\Users\Public\General Motors\Tech2Win\pcmciaにあります。 これらの各ファイルは、Tech2従来のPCMCIAカードに相当します。 Tech2Winでは、イメージをいくつでも持つことができます。 既存のイメージを単純に新しいファイル名にコピーします。

特定の構成をデスクトップから直接起動したい場合は、"C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf"を実行するショートカットを作成します。 プログラムがワーキングディレクトリ'C:\Program Files\General Motors\Tech2Win\bin'から起動するはずです。

構成ファイル数は使用しているPCMCIAイメージ数に依存しません。 同じPCMCIAイメージを使用する構成ファイルを複数持つことができます。 これは数名の整備士が同じTech2（及び同じPCMCIAカード）を共有する修理工場での状況を厳密にシミュレーションします。

各構成に専用のPCMCIAイメージを使用することもできます。 そうすることによって、各構成の独立性が高まります。 ただし、各PCMCIAイメージ更新に要する労力ががかかりすぎる場合もあります。

既存の構成をコピーして新規構成を作成する場合は、PCMCIAイメージが変更されるとコンフィギュレータが警告を表示します。 そのような場合は、同じPCMCIAイメージを使用した2つの構成ができます。 それでよい場合は、単純にOKを押します。 新規構成に新しいあるいは別のPCMCIAイメージを使用したい場合は、キャンセルを押します。 すると、メモリーカードのコピー ...を使用して新しいイメージが選択できます。

ここに、構成とPCMCIAイメージの管理メソッドの例を2つ記載します。

各ユーザーに対して構成1つ

各ユーザー構成を保存する機会があります。 構成名は例えばユーザー名などでです。 この概念のメリットは、パーソナル車両通信インターフェース(MDI) 、ディスプレイ設定、言語設定などのユーザー固有の設定が可能な点です。 デメリットは、複数のユーザーが同じソフトウェアを使用している場合は、PCMCIAファイルをコピーする必要がある点です。 もちろん、ユーザー固有の構成にはセントラルPCMCIAファイルを使用できます。

各Tech2ソフトウェアに対して構成1つ

ダウンロードするソフトウェアごとに新規構成を作成したい場合があります。 そのため、必要であれば古いソフトウェアバージョンもすぐに使用することができます。 そのような場合は、たいていソフトウェア名とバージョン番号が構成名として選択されます。

  • 最初の手順: Vehicle Communication Interface
  • 最初の手順: パス
  • アドバンストトピック: 構成ファイル
  • インストール: インストール手順


よく寄せられる質問 (FAQ)

  • Tech2Winに使用するCOMポートを決定するにはどうすればよいですか？
  • Tech2WinとTIS2Web間の通信
  • 有効なライセンス
  • ライセンスの番号は何を示しているのですか？
  • Tech2Winライセンスとセキュリティアクセスの違いは何ですか？
  • 初期ソフトウェアへのセキュリティアクセス実行時にTIS2Webが不明なエラーを表示します
  • Tech2Winが別領域からTech2ソフトウェアを実行しません
  • 複数のMDIを使用するにはどうすればよいですか？
  • ログファイルにエラー'CPU32: Too many 0000/FFFF Commands encountered'が含まれています
  • Tech2ウィンドウが表示されません
  • SPSが機能しません
  • 実行できないセルフテストがあります
  • 速度インジケータが変動します
  • 急停止
  • ソフトウェア15.001でスウェーデン語が表示されます
  • MDIとの通信喪失
  • Tech2Winが専用のMDIを検索しませんでした
  • コンフィギュレータを使用せずにすぐにTech2Winを起動したいのですが
  • 印刷関数はどこにありますか？
  • 「使用していない」PCMCIAフォルダがコンピュータ上にあります
  • 「不正ファイルパス」のメッセージが表示されます

Tech2Winに使用するCOMポートを決定するにはどうすればよいですか？

Windowsのデバイスマネージャを使用して、「ポート (COM & LPT)」を探すことができます。 ただし、コンピュータによってはこのカテゴリに表示されない内部モデムを持つ場合やBluetoothデバイスがインストールされている場合があります。
もうひとつの方法はコンフィギュレータと共に提供されたスモールコマンドを使用することです。 これはスタートメニュー（Tech2Winフォルダ）から'show com ports'をクリックして起動できます。
どちらのメソッドもコンピュータにインストールされている使用するべきではないCOMポートを表示します。

Tech2WinとTIS2Web間の通信

'セキュリティアクセス (Security)'または'ソフトウェア ダウンロード (SWDL)'のためにTIS2Webとの通信を開始する前に、Tech2Winが実行していることが重要です。 Tech2Winが起動すると、TIS2Webは仮想COMポートのみを識別することができます。

有効なライセンス

通常、TIS2Webからの'ソフトウェア ダウンロード (SWDL)'によってすでに有効なライセンスが提供されます。 それでもライセンスがない場合は、TIS2Web（TIS2000ではない）から、'セキュリティアクセス (Security)'を実行して有効なライセンスを取得する必要があります。 'セキュリティアクセス (Security)'を介してライセンスを取得する前に、'ソフトウェア ダウンロード (SWDL)'などTech2Win/TIS2Web間の他の通信を実行しないでください。

ライセンスの番号は何を示しているのですか？

ステータスバーの右側のライセンスの番号はライセンス有効期間を示します。 ダウンロードまたは'セキュリティアクセス (Security)'を実行した直後は30（日）が表示されます。 ただし、Tech2Winの再起動後には29と表示されます。これはライセンスの有効期間が例えば29日と23時間55分だからです。 ライセンス有効期間が24時間を切ると、<1と表示されます。 ライセンスの有効期限が切れると0が表示されます。

Tech2Winライセンスとセキュリティアクセスの違いは何ですか？

Tech2WinライセンスによってTech2Winの使用が可能になります。 そのようなライセンスを取得するには、'ソフトウェア ダウンロード (SWDL)'または'セキュリティアクセス (Security)'を定期的に実行する必要があります（通常30日ごと）。 TIS2Webを介してそのようなダウンロードの実施が可能であることによって、有効なユーザーが存在することがTech2Winに通知されます。 セキュリティアクセスはTech2と同様に、Tech2Winにエアバッグ解除などの特定のセキュリティ関連アクティビティが許可されていることを知らせます。 Tech2WinライセンスとセキュリティアクセスのどちらもTIS2Web の'セキュリティアクセス (Security)'アプリケーションを通して実行可能です。 Tech2Winは右側のステータスバーにライセンスの残り有効期間を表示します。 残念ながら、Tech2Winはセキュリティアクセスの有効期間を表示することはできません。Tech2WinはTech2ソフトウェアを実行するだけで、Tech2ソフトウェア自体をまったく理解しないためです。

初期ソフトウェアへのセキュリティアクセス実行時にTIS2Webが不明なエラーを表示します

この挙動はTech2と同じです。 期日が経過しているため初期ソフトウェアがTIS2Webからライセンスを取得できません。 ただし、デモンストレーションソフトウェアはライセンスが必要な車両との通信を行わないためこれは特に問題ではありません。 また、ライセンスはTS2Webダウンロード固有のため、Tech2ソフトウェアのダウンロード後はいずれにしても各ダウンロードのライセンスの取得が必要になります。 初期ソフトウェアの「ライセンス」では、North American OperationsまたはOpel/Vauxhallソフトウェアとの車両通信は実行できません。

Tech2Winが別領域からTech2ソフトウェアを実行しません

ご使用のTech2WinバージョンではおそらくTIS2Webダウンロード（地域）が1回または複数回に制限されています。 ヘルプ / 以下についてを押してそのTech2Winバージョンに適用される制限を確認してください。 Tech2Winの初期のバージョンではOpel/Vauxhallソフトウェアの実行のみが許可されています。 その他のGM地域にも同様になります。 いずれの場合も、現在ではTech2WinはGeneral MotorsのTech2ソフトウェアを実行することができます。

複数のMDIを使用するにはどうすればよいですか？

特定のMDIを特定のユーザーに割り当てたい場合は、それぞれのユーザーが各自の構成を持つようにします。 当然、これらの構成にはそれぞれのユーザーに従って名前を付けます。 各構成で'Vehicle Communication Interface'タブにユーザー固有のMDIのシリアル番号を入力する必要があります。 ユーザーがその構成を起動するとすぐにTech2Winがその特定のMDIにコンタクトを試みます。 そのMDIが存在しない場合のみ、Tech2Winが検出したすべてのMDI一覧の選択ボックスが表示されます。

汎用のMDIが複数ある場合は、'Vehicle Communication Interface'タブの車両通信インターフェースのシリアル番号が空白になっている構成を使用することが推奨されます。 すると、ユーザーは利用できるMDIの選択ボックスが常に確認できるようになります。

ログファイルにエラー'CPU32: Too many 0000/FFFF Commands encountered'が含まれています

ファイル'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin'または現在のPCMCIAファイルが破損しています。 Tech2Winを再インストールして、新しいTech2ソフトウェアをダウンロードしてください。

Tech2ウィンドウが表示されません

Tech2ウィンドウが表示されない場合は、おそらく現在ディスプレイ上にない領域にウィンドウがあります。 これは、複数の画面を使用している場合や画面の解像度を変更した後に起こる現象です。 構成起動中にキーボードのShiftキーを押します。 その場合、ウィンドウの解像度が640x480にリセットされ、Tech2ウィンドウが画面左上に表示されます。 同じ効果を得るためにファイルC:\Users\Public\General Motors\Tech2Win\emulator.dispを削除することもできます。

その他すべてのアプリケーションのウィンドウを閉じた後、画面にTech2ウィンドウが表示されないケースが確認されています。 確認されたすべてのケースでは、Alt-Tabキーを使用してWindowsアプリケーションを切り替えるとTech2の画面を表示することができました。 PC画面の下側のタスクバーのTech2Winボタンを押しても機能しない場合があります。 この問題はTech2Winの今後のバージョンで修正されるよう、現在も調査中です。

SPSが機能しません

はい、その通りです。 これを変更する予定はありません。 SPSを実行するためにTech2の代わりにTech2Winを使用するべきではありません。 TISからSPSプログラミングでMDIを直接使用してください。

実行できないセルフテストがあります

Tech2のセルフテストはTech2ハードウェアの各部分をテストします。 ループバックアダプタを使用しなければならないテストがあります。 これらのテストはTech2Winでは動作しません。ループバックアダプタの機能が実装されていないためです（実装の予定はありません）。 そのような意味のないテストをTech2Winで実行しないようにしてください。 実行すると、誤った結果が出たり、ループバックアダプタなしではTech2と同様にTech2Winがハングすることがあります。 そのような場合は、Ctrl-Rを使用してTech2Winをリセットします。

速度インジケータが変動します

ステータスバー左下の速度インジケータは、Tech2Winが再度スリープ状態に入ることが必要になるまでに実行可能な「Tech2のコマンド数」を示します。 このメソッドはTech2Win上の時間がリアルタイムに対応していることを確認するために使用されます。速いPCは遅いPCよりスリープ状態が多くなります。 速度インジケータが変動する場合は、その他のアプリケーションがCPUを使用しているか、PCクロックが変化している可能性があります。 変動率が高いと車両通信とTIS2Web通信にマイナスの影響があります。 その他のアプリケーションが実行していないことを確認してください。

大半のラップトップは自動的にCPUクロックを下げてバッテリー時間を延長することができます。 これもTech2Winが速度の変動を検出する原因である可能性があります。 そのような場合は、バッテリーを使用してラップトップを実行せず、外部の電源供給を使用してください。 また、電源設定を変更してオペレーティングシステムがクロック速度を下げないようにすることもできます。

急停止

ログファイル内にプログラム終了の理由が見つからない場合は、Tech2Winの内部セキュリティメカニズムが起動していることがあります。 emulator.sec、emulator.lic、emulator.cardのファイルを改ざんしてはいけません。 Tech2Winがセキュリティ違反を検出するとおそらく再インストールが必要になります。

ソフトウェア15.001でスウェーデン語が表示されます

Tech2Win付属の初期ソフトウェアはデモンストレーションソフトウェアで、すべての新しいPCMCIAカード上に存在します。 TIS2Webは、デモソフトウェアが対応する4言語（英語、フランス語、ドイツ語、スウェーデン語）の一覧の最後の言語のみを表示するため、TIS2Webは、これがスウェーデン語であることを示します。 'スタンダード'の代わりに更新モード'カスタム'を使用して、このデモンストレーションソフトウェアに最新の診断ソフトウェアを上書きします。

MDIとの通信喪失

MDI通信喪失にはいくつかの理由が考えられます。

  • ケーブル接続が適切ではない（イーサネット及びUSBの両方）
  • 不安定なワイヤレス接続
  • PCがスタンバイに入る

Tech2Winが専用のMDIを検索しませんでした

以下を確認してください。

    1. そのMDIはアクティブか？
    2. そのMDIマネージャは機能するか？
    3. そのMDIがSPSなどの別のアプリケーションに使用されているか？
MDIマネージャはデスクトップアイコンまたは'Start/All Programs/General Motors/GM MDI Software'から起動できます。: 上記の2が機能しない場合はヘルプデスクへ連絡してください。

コンフィギュレータを使用せずにすぐにTech2Winを起動したいのですが

"C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf"を実行します。 ワーキングディレクトリ'C:\Program Files\General Motors\Tech2Win\bin'を使用します。 コンフィギュレータを使用して構成を変更することもできます。

印刷関数はどこにありますか？

Tech2Winは直接印刷機能を提供しません。 その代わり、一時ファイルを作成し、そのファイル拡張子に関連付けられたプログラムを呼び出します。 これらのプログラムを印刷に使用し、印刷の外観を調整することができます。

Print Report | Print Report

現在のTech2Win画面を印刷するには、メニュー項目ファイル / 画面の印刷またはプリンターを示すキーパッド上のボタンを使用します。 複数のTech2Win画面を印刷する必要がある場合は、メニュー項目のオプション / 自動スクリーンショットが使用できます。これはそれぞれのTech2Win画面のPNGファイルを作成します。 これらのPNGファイルはログファイルに組み込まれます。

また、データディスプレイのコンテンツ（メニュー項目ウィンドウ / Tech2Winデータディスプレイを使用して起動）も印刷することができます。 印刷/HTML 開始ボタンを使用して起動してから、データ取得を停止します。 データ取得を停止した後、HTML関連の実行ファイル（通常はInternet Explorer）が起動され、データを印刷する様々な機能が提供されます。

Data Display | Data Display

「使用していない」PCMCIAフォルダがコンピュータ上にあります

以前のTech2Winバージョンは常にPCMCIAファイルを異なるディレクトリに複製していました。 このディレクトリは多くの場合、C:\PCMCIAでした。 現在、このディレクトリは使用されていません。TIS2Webからの高速ダウンロードによってそのダウンロードを二重保存する必要がなくなったためです。 このディレクトリは安全に消去することができます。

「不正ファイルパス」のメッセージが表示されます

ファイル名にパーセント記号 (%) などの不正文字が含まれている可能性があります。 インストール直後にこの問題が現れる場合は、単純にアンインストールを行い、再インストールを実施してください。 ほとんどの場合、これでこの問題は解消されます。

通常のインストール中には、環境変数'Tech2WinUserData'が'PUBLIC'（Windowsバージョン >= Vista）または'ALLUSERSPROFILE\Documents'（Vistaより前のWindowsバージョン）に設定されます。 まれに、この環境変数がインストール中に設定されなかったものの、2度目には正常に行われるというケースがあります。 また、環境変数は手動で設定することもできます。 環境変数の設定方法が分からない場合は管理者に連絡してください。


レジストリエントリ

以下のレジストリエントリがインストーラによって生成されます。 これらのエントリは手動で変更しないでください。 レジストリエントリを扱う場合は、標準的なWindowsの注意事項を考慮してください。

レジストリキー | 名前 | タイプ | 意味
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | 内部バージョン番号
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | 言語 | REG_SZ | インストール言語
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | PCMCIAコピーディレクトリのパス
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | ルート | REG_SZ | インストールパス
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | アンインストールオプション | REG_DWORD | アンインストール設定
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | 構成ファイルのバージョン
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | 仮想COMポートドライバのバージョン
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | 表示名 | REG_SZ | プログラムの追加と削除の一覧内のソフトウェア名
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | アンインストールストリング | REG_SZ | アンインストールプログラムへのパス


再インストール

再インストールは以下を除いて、Tech2Winのインストレーションディレクトリ一式を削除します。

  1. 構成を含むconfigサブディレクトリは消去されません。
  2. 通常PCMCIAイメージを含むpcmciaサブディレクトリは消去されません。
  3. デバッグインフォメーションを含む可能性のあるATAサブディレクトリは消去されません。
構成ファイルの互換性が失われる場合があります。 古いTech2Winバージョンの構成ファイルをそれより新しいTech2Winバージョンで読めるという保証はありません。 原則としてPCMCIAイメージの互換性は失われません。

二次PCMCIAディレクトリは再インストールの影響を受けません。

環境によっては、新しいバージョンのTech2Winを自動インストールができる場合があります。 最後のインストールの情報がレジストリに保管されているため、これらの設定が再インストール中に既定値として表示されます。

スクリプトenable reinstallationを使用してTech2Winの再インストールを実施することができます。 このスクリプトはTech2Winと共にインストールされます。 基本的に、このスクリプトはレジストリHKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2WinにあるCurrentVersionキーの値を単純に1.000に設定します。