Manuale utente Tech2Win

Benvenuti al manuale utente di Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Tutti i diritti riservati.

  • Introduzione:
  • Licenza:
  • Installazione:Una descrizione della procedura di installazione di Tech2Win.
    • Passi dell'installazione
    • Interfaccia di comunicazione veicolo
  • Primi passi
    • Selezione di una configurazione
      • Tastiera
      • Windows Handling
    • Nuove Configurazioni
    • Modifica configurazioni in corso
      • Lingua
      • Percorso
      • Display
      • Salvare una configurazione
    • Ottenere una licenza valida Tech2Win.
  • Lavorare con Tech2Win: Dettagli per il lavoro ordinario.
    • Menù
    • Scaricare un'immagine PCMCIA
    • SIcurezza
    • Visualizza rapporti
    • Gestione immagini PCMCIA
    • Barra di Stato
  • Sezione avanzata: Informazioni non richieste per l'uso normale di Tech2Win. Spesso rilevante solo per chi abbia incarichi amministrativi.
    • Reinstallazione
    • Disinstallazione
    • Formato del file di configurazione
    • File di log
    • Messaggi di errore e codici di errore
    • Scheda ATA
    • Eventi di registro
    • File
    • Configuration Management
  • Domande frequenti


Introduzione

Tech2Win è un'applicazione Windows che può emulare la funzionalità Tech2. Fondamentalmente, il software Tech2 viene eseguito su di un PC. Per eseguire questo programma, il vostro PC deve soddisfare i seguenti requisiti tecnici:

  • Un interfaccia comunicazione veicolo dev'essere installato e collegato al PC. La lista di interfaccia accettabili potrebbe variare da regione a regione. Nella maggior parte dei casi, GMs Multiple Diagnostic Interface (MDI) può essere usato.
  • L'applicazione Tech2Win richiede 150MByte di spazio hard disk durante l'installazione. È necessario uno spazio addizionale di 32MB per ogni flash card PCMCIA che vogliate gestire.
  • Prima dell'esecuzione dell'applicazione Tech2Win, avete bisogno di almeno 100MB di RAM fisica libera. Il vostro PC deve obbligatoriamente avere memoria sufficiente per mantenere l'applicazione nella RAM per tutta la durata dell'esecuzione.
  • Il vostro PC dovrebbe avere una potenza di calcolo equivalente ad un 1.2GHz Pentium (single core). Raccomandiamo vivamente di non usare nessun'altra applicazione parallelamente.
  • Non c'è bisogno di tastiera. Tech2Win può anche essere utilizzato attraverso touch screen. Per la gestione di configurazione, raccomandiamo vivamente di usare una tastiera dovendosi inserire nomi di file.
  • Il display grafico a colori deve avere una risoluzione minima di 800 x 600 con un'intensità minima di colore di 256. Senza tastierino numerico, è accettabile la risoluzione 640 x 480.

Quando si utilizza Tech2Win (un laptop al posto di Tech2), verificare che la potenza del laptop sia sufficiente. Normalmente, il vostro laptop non sarà alimentato dalla batteria dell'auto, quando lo è Tech2.

  • Installazione
  • Primi passi


Licenza

General Motors - Contratto di licenza per Tech2Win

Leggere attentamente i seguenti termini e condizioni prima di utilizzare il programma. In caso di mancata accettazione o comprensione dei termini e delle condizioni, contattare il proprio agente locale Aftersales. La licenza d'uso per il presente software viene concessa esclusivamente da General Motors a condizione che l'utente accetti i presenti termini e condizioni nel corso della procedura di installazione di Tech2Win.
General Motors concede il diritto di utilizzo del software Tech2Win e delle informazioni ivi incluse, assieme a TIS2Web o GlobalTIS o TIS2000, esclusivamente agli utenti appartenenti alla rete di riparatori autorizzati General Motors come specificato nel Contratto per Riparatori Autorizzati applicabile a livello locale con le società nazionali di vendita General Motors.
La licenza Tech2Win è valida fino alla scadenza del Contratto per Riparatore Autorizzato e della licenza di TIS2Web, GlobalTIS e TIS2000. La licenza Tech2Win terminerà insieme alla licenza TIS2Web e GlobalTIS non appena sia terminato l'accordo con il riparatore autorizzato.

I riparatori indipendenti, come definiti al paragrafo 2 dell'articolo 4 dell'European Union Block Exemption Regulation (BER) 1400/2002 possono acquistare una licenza Tech2Win quale parte delle sottoscrizioni offerte al portale Info Tech GM Europe di General Motors Europe.

La licenza Tech2Win non include l'interfaccia di comunicazione con il veicolo o l'hardware PC.

È vietata la distribuzione, la vendita o la messa a disposizione online del software a terzi al di fuori dei locali autorizzati del riparatore (come specificato nel relativo allegato al Contratto per Riparatori Autorizzati) senza previo consenso scritto delle società nazionali di vendita General Motors competenti. Quanto sopra vale sia per dati in corso di validità sia per i dati storici (come DVD scaduti).

In caso di utilizzo non autorizzato o abusivo, le società nazionali di vendita General Motors avranno il diritto di bloccare immediatamente l'accesso e di notificare all’utente la risoluzione immediata del contratto. In tal caso, l’utente non avrà diritto al rimborso del credito residuo e/o dell’importo base annuale.

Le informazioni fornite sono necessarie per l'esecuzione a regola d’arte degli interventi di manutenzione e riparazione di autoveicoli General Motors non modificati. La formazione tecnica completa e i successivi aggiornamenti sono requisiti essenziali per l'esecuzione dei predetti interventi. Nel caso le istruzioni fornite richiedano l'uso di attrezzi speciali, tali attrezzi speciali sono da considerarsi requisito indispensabile affinché tutte le riparazioni siano effettuate a regola d’arte.

Le informazioni pubblicate su Tech2Win di General Motors (testo ed immagini, musica, grafica, animazione, video ecc.) nonché il loro adattamento in Tech2Win sono protette da copyright. Non sono consentite riproduzioni, diffusioni, comunicazioni e/o trasmissioni o altri usi, salvo previo consenso scritto di General Motors.

  • Installazione: Passi dell'installazione
  • Primi passi


Installation

Installazione

L'installazione di Tech2Win richiede diritti amministrativi locali sul PC. L'installazione non sarà possibile se non si dispone dei diritti di amministratore. In tal caso, vi preghiamo di contattare il vostro amministratore PC locale per supporto.

Per usare Tech2Win con successo, dovete completare i due passi seguenti:

  • Installazione di Tech2Win.
  • Installazione di un'interfaccia di comunicazione veicolo.
  • Installazione: Passi dell'installazione
  • Primi passi


Passi dell'installazione

L'installazione in sé richiede solo pochi minuti e necessita dell'immissione dei seguenti dati da parte dell'utente:

  1. Contratto di licenza
  2. Directory di Installazione

Lingua

Di default Tech2Win UI verrà visualizzato nella lingua del vostro sistema operativo. Generalmente, le seguenti lingue possono essere garantite. Se la vostra lingua non è supportata, l'installatore si avvierà in inglese come lingua d'installazione di default.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Inglese (britannico oppure americano)*
  • el_GR (EL)Greek
  • es_ES (ES)spagnolo
  • fi_FI (FI)Finnish
  • fr_FR (FR)francese
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portoghese (Brasile)
  • pt_PT (PT)Portoghese (Portogallo)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Cinese (semplificato)
  • zh_TW (ZH)Cinese (tradizionale)

* La lingua di Tech2Win è l'inglese britannico. Tuttavia il software Tech2 e l'installatore che state utilizzando potrebbe essere in inglese americano, a seconda della fonte del software.

Contratto di licenza

Dovete accettare i termini del Contratto di licenza.

Directory di Installazione

Potete scegliere qualsiasi directory come ubicazione nella quale Tech2Win dovrà essere installato. La directory di installazione default è <your program directory>\General Motors\Tech2Win oppure, in caso di reinstallazione, l'ubicazione precedentemente specificata.

Come ultima parte confermate l'installazione.

Driver della porta COM virtuale

Il driver della porta COM virtuale verrà installato solo una volta sul vostro computer dove resterà impostato fino all'aggiornamento della sua versione (accade raramente) o fino a quando Tech2Win non venga disinstallato dal vostro computer.
Se il driver viene installato vedrete una finestra DOS per un breve momento. Si chiuderà automaticamente e non richiederà nessuna azione. I file del driver vengono inoltre posizionati nella sottocartella 'driver' nella vostra directory d'installazione di Tech2Win.
E' possibile, ma non consigliato, installare o disinstallare manualmente i driver delle porte COM virtuali. Usare uno dei comandi seguenti dallo shell CMD:

  • richiamate 'vbsetup7' per installare il driver
  • richiamate 'vbsetup7 /u' per disinstallare il driver
  • Primi passi


Interfaccia di comunicazione veicolo

Il vostro dispositivo di comunicazione veicolo dev'essere installato separatamente. Fare riferimento alla guida all'installazione fornita con l'interfaccia di comunicazione veicolo.

  • Primi passi: Interfaccia di comunicazione veicolo
  • Sezione avanzata: File di configurazione
  • Installazione: Passi dell'installazione
  • Domande frequenti: Come posso utilizzare molteplici MDI?
  • Domande frequenti: Tech2Win non ha trovato l'MDI cercato


Primi passi

Questi primi passi vi mostrano come usare Tech2Win. Presume che abbiate dimestichezza con Tech2. Comunicazione veicolo non richiesta durante questi primi passi.

Per un avvio veloce procedere come segue:

  1. Avviare il softare Tech2Win tramite il collegamento QuickStart sul desktop.
  2. Ottenere una licenza valida per scaricare il nuovo software Tech2 da TIS2Web.

Per usare una configurazione selezionabile:

  1. Avviare il configuratore tramite il collegamento Tech2Win sul desktop. Dopo un'installazione dovrebbe essere presente una configurazione default.
  2. Per creare una nuova configurazione, si consiglia di copiare la configurazione di default.
  3. Modificare una configurazione esistente per soddisfare requisiti particolari.
  4. Ottenere una licenza valida.

Non avviare Tech2Win in una modalità di compatibilità. In tal caso apparirà un avviso nel file di registro. Tech2Win utilizza solo le funzioni Windows esistenti a partire da XP e non funzionerà con versioni precedenti.

  • Primi passi: Nuove Configurazioni
  • Primi passi: Modifica configurazioni in corso
  • Primi passi: Interfaccia di comunicazione veicolo
  • Lavorare con Tech2Win: Menù
  • Lavorare con Tech2Win: SIcurezza
  • Lavorare con Tech2Win: Barra di Stato
  • Sezione avanzata: File di configurazione


Selezione di una configurazione

La prima volta che si avvia l'applicazione Tech2Win, appare la seguente schermata. Avete l'opzione di avviare Tech2Win direttamente con una configurazione default. Questa configurazione default funziona senza alcuna comunicazione veicolo.

Start First Time

Apparirà la finestra di messaggio con le informazioni sulla licenza ma può essere ignorata per iniziare la configurazione predefinita.

Quando si lavora su di un touchscreen, potrebbe essere utile avviare il programma della tastiera del PC per poter inserire lettere attraverso quest'applicazione che simula una tastiera.


Tastiera

I tasti del PC, così come i pulsanti se presenti, sono assegnati ai già noti tasti Tech2. Tech2Win fornisce alcuni tasti addizionali che non sono presenti nel Tech2 originario. Il tastierino numerico del PC potrebbe non funzionare sempre. In presenza di problemi, verificare se si è modificato il layout di tastiera standard sul PC. In tal caso ne risentirebbe in particolare il tasto MAIUSC.

Tastiera PC | Pulsante | Funzionalità
Tasto di funzione F1 | n.a. | Aiuto Tech2Win
Tasti di funzione F5 .. F8 | Utilizzare l'area di visualizzazione di Tech2Win occupata dai pulsanti. | Le quattro chiavi software di Tech2.
Tasti cursore Su, Giù, Sinistra, Destra |  | Tasti Tech2 Su, Giù, Sinistra, Destra. Solo questi tasti hanno una ripetizione automatica.
Tasto 0 .. 9 | F0 • • • F9 | Tasti Tech2 F0 .. F9
Tasto di ritorno | Exit | Tasto Exit Tech2
Enter / Return | Enter | Tasto Enter Tech2
Y | Yes | Tasto Yes Tech2
N | No | Tasto No Tech2
Q | ? | Tasto ? Tech2
S | Shift | Tasto Shift Tech2. L'indicatore Shift nella barra di stato e l'indicatore sopra il pulsante Shift indicano lo stato.
ctrl-P | PWR | Tasto Power Tech2; Ovviamente, questo tasto può spegnere solo l'applicazione Tech2Win.
ctrl-R | non disponibile | Resetta Tech2Win. Simile ad un ciclo Corrente Off/On su di un Tech2. Tuttavia, l'interfaccia di comunicazione veicolo non viene azzerata. File quali le immagini PCMCIA non vengono ricaricati.
Home | Home | Un tasto home Compatibile solo con alcune applicazioni.
solo disponibile attraverso l'opzione di menu File. | Print Screen | Stampa uno screenshot della schermata Tech2 creando un file temporaneo BMP e richiamando l'applicazione associata ai file BMP. Usare questa applicazione per ridimensionare o ruotare l'immagine prima di stamparla.
solo disponibile attraverso l'opzione di menu File. | Save Screen | Salva una schermata della videata di Tech2 in un file formato BMP o PNG.
solo disponibile attraverso l'opzione di menu File. | View Report | Mostra tutti i rapporti sulla flash card PCMCIA attiva in modo che l'utente possa visualizzarli.


Windows Handling

Potete ridimensionare il vostro windows utilizzando meccanismi standard di Windows trascinando le linee esterne della finestra principale. Inoltre, la voce di menu Opzioni/Risoluzione supporta diversi formati preimpostati. Durante il ridimensionamento della finestra principale dalla voce di menu, la finestra del tastierino numerico rimarrà automaticamente ancorata.

L'aspetto delle finestre viene modificato cambiando configurazione nel tab Display.


Nuove Configurazioni

Premere il pulsante Crea nuova per creare una nuova configurazione. Un menù dialogo apparirà chiedendo di selezionare un file di configurazione esistente come sorgente. Normalmente, verrà selezionata la configurazione default. Dopo aver inserito il nome del nuovo file di configurazione, premere il pulsante Copia.

Se state lavorando con un touchscreen, può essere preferibile attivare una simulazione tastiera PC attraverso il pulsante Tastiera PC.

Il pulsante Annulla vi permette di cancellare il processo di creazione.

La nuova configurazione utilizzerà lo stesso file PCMCIA della configurazione di origine esistente. Se si vogliono apportare modifiche, è necessario modificare la configurazione in modo da utilizzare un diverso file PCMCIA. Nella maggior parte dei casi sarà sufficiente copiare il file PCMCIA esistente in un nuovo file e utilizzare quello nuovo. È anche possibile richiedere che la nuova configurazione usi lo stesso file PCMCIA della configurazione di origine. In questo caso il sistema visualizzerà una schermata di segnalazione alla pressione del pulsante Salva.

  • Modifica configurazioni in corso


Modifica configurazioni in corso

Le configurazioni mostrate in blu sono sola lettura marcati e non possono essere modificati. Queste configurazioni possono solo essere visualizzate. Naturalmente potete usare il metodo di modifica semplicemente per visualizzare il loro contenuto, ma un Salva non sarà possibile.

Una configurazione viene modificata selezionando l'impostazione individuale nei quattro tabulatori Lingua, Interfaccia di comunicazione veicolo, Percorso, Display. È possibile selezionare la tabulazione desiderata o semplicemente scegliere di premere il pulsante Successivo, il quale attiverà la tabulazione successiva. Dopo aver effettuato le modifiche, premete il pulsante Salva per salvare la vostra configurazione.

Nel caso in cui sia necessaria un ingresso di tastiera, potete sempre richiamare un'applicazione PC per la simulazione di una tastiera del PC. Quest'opzione è particolarmente pratica con laptop touchscreen quando non vi sia nessuna tastiera disponibile.


Lingua

Il tabulatore Lingua vi permette di selezionare la lingua di funzionamento di Tech2Win. Questa selezione non influisce sulla lingua del software Tech2 sull'immagine PCMCIA. Anche scaricando il software Tech2 da TIS dovrete selezionare la lingua corretta.

Per alcune regioni, non tutte le lingue saranno disponibili. In tal caso, verrà perciò presentato in inglese. Controllare se è disponibile una lingua analoga (PT Portoghese-Portogallo piuttosto che PB Portoghese-Brasile).


Percorso

Il tabulatore Percorso permette di impostare sia i percorsi delle immagini PCMCIA che quelli della tastiera del software locale. Inoltre, con il pulsante Copia memory card è possibile copiare immagini PCMCIA. Se è stata creata una nuova configurazione è possibile utilizzare questo pulsante per evitare diverse configurazioni con la stessa immagine PCMCIA.

Memory Card Options

Copia memory card ...

Questo pulsante permette di copiare un'immagine PCMCIA su di un altro file. La sua funzionalità è molto simile all'acquisto di una nuova scheda PCMCIA per Tech2. La funzione Copia funziona solo per i file nella directory C:\Users\Public\General Motors\Tech2Win\pcmcia.

Slot 0 : Ubicazione immagine memory card

Qui potete specificare il file che contiene la vostra immagine PCMCIA per lo slot 0. Di solito un file di questo tipo deve essere in C:\Users\Public\General Motors\Tech2Win\pcmcia, anche se altre ubicazioni sono possibili.

Slot 1 : Memory card o ATA

Così come Tech2, anche Tech2Win è compatibile con due schede PCMCIA (immagini). Tuttavia, la seconda immagine PCMCIA nella configurazione non è normalmente molto utile. In una seconda configurazione si userebbe probabilmente un secondo software.

Come su un Tech2, viene usata una scheda ATA per il debugging. Si prega di attivare la scheda ATA solo se specificato dal supporto tecnico. Riceverete così ulteriori informazioni.

Ubicazione tastiera software PC

Il valore default di questo file viene recuperato dal registro Windows e dovrebbe indicare un'applicazione capace di simulare una tastiera di PC con il mouse. Se avete un'applicazione speciale con questa funzionalità per il laptop che state usando, potete specificare l'applicazione qui.


Interfaccia di comunicazione veicolo

  • Porta COM per Emulazione Tech2 RS232
  • Numero seriale di MDI da usare
  • Protocollo

Porta COM per Emulazione Tech2 RS232

Scegliete una porta COM disponibile da utilizzare per l'emulazione di Tech2. Per comodità, il Configuratore tenta di trovare quali porte seriali sono già in uso e le visualizza.

Scegliendo una porta COM esistente, Tech2Win si legherà ad essa. Questa porta COM può essere utilizzata per scaricare il software Tech2 da un secondo computer che esegue un'applicazione TIS utilizzando un cavo null modem. Tenere presente che l'uso di una porta COM reale potrebbe non offrire garanzia massima di affidabilità alla velocità di 115,200 in baud a causa delle restrizioni di Windows.

Selezionando una porta COM non esistente, Tech2Win creerà automaticamente una porta virtuale. Questa porta virtuale può essere utilizzata da TIS in esecuzione sullo stesso PC per stabilire la comunicazione con Tech2Win. Quando si utilizzano le porte virtuali, non esistono restrizioni di velocità in baud.

Se scegliete 'search' (ricerca) come porta COM, Tech2Win creerà una porta COM virtuale sul primo numero di porta libero da 9 a 1.

Numero seriale di MDI da usare

Inserire il numero di serie del MDI. Il numero è presente sul retro del MDI. Utilizzare il numero dopo il segno meno.

Se non si inserisce il numero di serie, Tech2Win visualizzerà automaticamente l'elenco dei MDI rilevati nella rete, affinché sia possibile per l'utente selezionarne uno. Quando il MDI specificato non viene trovato, apparirà la medesima casella di selezione.

Protocollo

'ISO22900-2 / PDU-API' è selezionato e J2534-2 è sempre inattivo. In futuro, Tech2Win sarà probabilmente in grado di supportare anche il protocollo J2534.

  • Sezione avanzata: File di configurazione
  • Domande frequenti: Come posso determinare quale porta COM utilizzare per Tech2Win?
  • Domande frequenti: Comunicazione tra Tech2Win e TIS2Web
  • Domande frequenti: Come posso utilizzare molteplici MDI?
  • Domande frequenti: Tech2Win non ha trovato l'MDI cercato


Display

Il tab Display è usato principalmente per cambiare le impostazioni circa il display di Tech2Win:

  • Keypad
  • Colori
  • Audio
Display and Key Options

Keypad

Qui potete scegliere se il Keypad dev'essere mostrato. Il Keypad viene tracciato sulla sinistra oppure sulla destra dello schermo di Tech2Win. Il colore di fondo è selezionabile attraverso una finestra di dialogo con colori standard.

Colori

Il colore di fondo e quello principale dello schermo di Tech2 possono essere selezionati individualmente qui. Queste sono le due combinazioni di colore più comuni.

Screen with background 0000FF, foreground FFFFFF | Fondo Keypad bianco; Sfondo blu; Principale bianco
Screen with background 000000, foreground C0C0C0 | Tastierino numerico su sfondo blu; Fondo nero; Principale grigio chiaro

Audio

Qui potete scegliere di disattivare il suono. Ogni volta che il programma Tech2 emette un segnale acustico, saranno usati gli altoparlanti del PC.


Salvataggio della configurazione in corso

La configurazione attiva può essere salvata premendo il pulsante Salva <configuration> nell'angolo in basso a sinistra. Il pulsante non apparirà se si sta visualizzando una configurazione sola lettura.


Licenza valida via TIS2Web

Di solito, scaricando il software Tech2 in Tech2Win verrà fornita all'utente una licenza valida. Inoltre potete ottenerne una affettuando 'Accesso alle funzioni di sicurezza (Sicurezza)' mediante TIS2Web (non TIS2000). La condizione preliminare è quindi la selezione della porta COM virtuale all'interno del configuratore nell'interfaccia di comunicazione veicolo.

Dopo aver eseguito con successo l'accesso di protezione, sul lato destro della barra di stato è possibile vedere un lucchetto aperto. All'interno della parentesi si trova il numero indicante i giorni per i quali è ancora valida la licenza. Quando si riavvia Tech2Win, l'indicatore di sicurezza rimane invisibile fino a che non viene stabilita la comunicazione veicolo. Durante la prima comunicazione con il veicolo, verrà controllata la licenza e l'indicatore assumerà l'aspetto di un lucchetto aperto oppure uno chiuso.

  • Lavorare con Tech2Win:SIcurezza
  • Domande frequenti:Come posso determinare quale porta COM utilizzare per Tech2Win?
  • Domande frequenti:Comunicazione tra Tech2Win e TIS2Web
  • Domande frequenti:Licenza valida
  • Domande frequenti:Qual è la differenza tra una licenza Tech2Win e l'accesso di sicurezza?


Lavorare con Tech2Win

I seguenti argomenti vengono usati dalla maggior parte dei tecnici quando lavorano con Tech2Win:

  • Menù: Il layout dello schermo e gli item menù individuali.
  • Scaricamento dell'immagine PCMCIA: L'aggiornamento del software diagnostico per Tech2Win è molto simile al metodo usato per Tech2.
  • SIcurezza: Misure di sicurezza impediscono che Tech2Win effettui comunicazioni veicolo in condizioni non autorizzate.
  • Visualizza rapporti: La tastiera Tech2 è stata leggermente incrementata in Tech2Win. Il pulsante 'Visualizza rapporti' è l'esempio più importante.
  • Gestione immagini PCMCIA: Così come si possono avere svariate schede PCMCIA per Tech2, potete avere diverse immagini PCMCIA in uso per Tech2Win.
  • Barra di Stato: La barra di stato informa l'utente sulle parti individuali della barra di stato.
    • Sezione avanzata
    • Domande frequenti


Menù

L'applicazione Tech2Win possiede i seguenti eventi menù:

  • File
  • Opzioni
  • Finestre
  • Guida

File

Il menu File offre le seguenti possibilità:

  • Salva T2 (320x240) è utilizzato per salvare sul PC la schermata T2 in un formato di 320x240 pixel, come file di immagini in bianco e nero. Il percorso di archiviazione e il formato del file (BMP, GIF, JPG, PNG) possono essere selezionati liberamente.
  • Stampa schermo crea un'immagine BMP invertita nero su bianco della schermata di Tech2 e richiama il programma associato ai file BMP. Questo programma può poi essere utilizzato per stampare l'immagine.
  • Visualizza file rapporto offre la possibilità di visualizzare (e stampare) i file di report senza utilizzare TIS2Web.
  • Esci chiude Tech2Win.

Opzioni

Opzioni fornisce le seguenti selezioni:

  • Risoluzione può essere utilizzata per scegliere uno dei tre formati standard dello schermo.
  • ROM-Write from 0x00003ED76 è utilizzata per finalità di debugging interno.
  • Screenshot automatici per salvare l'immagine di ciascuna diversa schermata di Tech2 nella directory di registro.
  • Disabilita CANdi e riavvia per simulare un Tech2 senza disporre di CANdi tra esso e il veicolo. Ciò è necessario per i casi rari in cui la rete CANdi interrompe le linee di comunicazione non standard del veicolo.

Finestre

Il menu Finestre vi offre la possibilità di attivare le selezioni Visualizzazione dei dati su Tech2Win e Visualizzazione dei DTC su Tech2Win. Ogni altra selezione appare in grigio nell'attuale versione del Tech2Win.

Se il software Tech2 supporta Visualizzazione dei dati su Tech2Win si può abilitare questa voce di menu. Inserendo Display Dati, Tech2Win visualizzerà una finestra aggiuntiva di visualizzazione dati parallela al display dati Tech2. Finché lo schermo Tech2 mostra la visualizzazione dati, la voce di menu non può essere abilitata. In tale caso si deve uscire dalla visualizzazione dati, abilitare la voce di menu e riavviare la visualizzazione dati.

Limitazioni simili per Visualizzazione dei dati su Tech2Win valgono anche per Visualizzazione dei DTC su Tech2Win. Se il software Tech2 supporta Visualizzazione dei DTC su Tech2Win si può abilitare questa voce di menu. Una ulteriore finestra di visualizzazione dei DTC apparirà parallela alla visualizzazione dei DTC di Tech2. Finché lo schermo Tech2 mostra la visualizzazione dei DTC, la voce di menu non può essere abilitata. In tale caso si deve uscire dalla visualizzazione dei DTC, abilitare la voce di menu e riavviare la visualizzazione dei DTC.

Guida

Sono disponibili le seguenti selezioni:

  • Argomenti aiuto... richiama la guida Tech2Win.
  • Parametro riga di comando indica i parametri della riga di comando utilizzati per Tech2Win.
  • Informazioni su mostra il numero di versione corrente e le limitazioni di di download TIS2Web di Tech2Win.


Download

Innanzitutto, avviare Tech2Win e lasciarlo sulla schermata principale. Avviare TIS2Web o GlobalTIS, quindi eseguire lo scaricamento via porta COM, specificata nella scheda Interfaccia di comunicazione veicolo.

L'uso di COM-Ports incorporate è possibile per scaricare software Tech2 da un PC diverso che usa TIS. Assicurarsi di usare un cavo RS232 incrociato. A seconda dell'hardware del PC che usa Tech2Win, la velocità di trasmissione dati potrebbe dover essere ridotta a 57.600 baud dato che Windows può perdere dati ad una velocità di trasmissione superiore.

L'ultima versione Tech2Win supporta inoltre il download veloce se TIS2Web e Tech2Win sono eseguiti sullo stesso PC. Tra TIS2Web e Tech2Win rimane un minimo di comunicazione tramite la porta COM, ma il trasferimento dei dati a Tech2Win (dispendioso in termini di tempo) è stato sostituito con un trasferimento interno di file. In questo modo il tempo di download viene notevolmente ridotto a meno di un minuto.

  • Sezione avanzata: File di configurazione
  • Primi passi: Interfaccia di comunicazione veicolo
  • Domande frequenti: Come posso determinare quale porta COM utilizzare per Tech2Win?
  • Domande frequenti: Comunicazione tra Tech2Win e TIS2Web


SIcurezza

I meccanismi di protezione utilizzati da Tech2Win utilizzano un valore di orologio del PC corretto. Verificare quindi che il valore orologio del PC sia sempre impostato. Eventuali variazioni minori dell'orologio, ad esempio, al cambio dell'ora, sono tollerate da Tech2Win.

Tech2Win non eseguirà alcuna comunicazione veicolo senza una licenza valida e attiva. L'indicatore che segue, presente nella barra di stato, indica lo stato della licenza:

  • green smiley La licenza è valida.
  • Nessun indicatore: La licenza non è ancora stata verificata.
  • red smiley La licenza è scaduta.

Per ottenere una licenza eseguire un agigornamento 'Accesso alle funzioni di sicurezza (Sicurezza)' utilizzando l'applicazione TIS2Web. Nella maggior parte dei casi, lo scaricamento del software via TIS2Web sarà sufficiente anche per ottenere una nuova licenza. Poiché la licenza non sarà più valida dopo un certo periodo di tempo (in alcune regioni, quattro settimane), è necessario eseguire l'aggiornamento ad intervalli regolari.

Le licenze variano in base alla regione/software. Se si sta utilizzando Tech2Win con versioni di software Tech2 diverse, è possibile che sul computer siano presenti le licenze.

Il numero di giorni restanti, prima della scadenza della licenza, è indicato nella barra di stato.

  • (0) indica che la licenza è scaduta o che non esiste.
  • (<1) La licenza scadrà entro le prossime 24 ore.
  • (20) La licenza scadrà nel giro di 20 giorni.

Non manomettere il file della licenza. Le modifiche fraudolente di questo file vengono rilevate attraverso le misure di protezione interne e causano la perdita di tutte le licenze del computer. Inoltre, Tech2Win si comporterà in maniera inattesa. Ciò può essere superato soltanto eseguendo una nuova installazione.

  • Sezione avanzata: Messaggi di errore e codici di uscita
  • Sezione avanzata: File di log
  • Lavorare con Tech2Win: Finestra di Stato
  • Domande frequenti: Licenza valida
  • Domande frequenti: Qual è la differenza tra una licenza Tech2Win e l'accesso di sicurezza?
  • Domande frequenti: Arresto improvviso


Visualizzare rapporti

View Report Questo pulsante può essere usato per vedere il contenuto di ogni file PRT presente sulla scheda PCMCIA. Una finestra di dialogo si aprirà per mostrare una lista di file PRT. Se un programma è stato associato con l'estensione PRT, questo programma associato verrà eseguito. Diversamente, l'editor notepad si aprirà per mostrare il file selezionato.

Il file PRT è per lo più un file ASCII che usa le pagine di codice relative alla lingua. Per cinese, giapponese, coreano e thailandese, il file è in unicode con una sequenza Byte-Order-Mark (BOM).

Durante la visualizzazione dei rapporti, Tech2Win funziona con una sottodirectory C:\Users\Public\General Motors\Tech2Win\reports. Questa sottodirectory esisterà solo se avete visualizzato rapporti almeno una volta. La directory viene cancellata automaticamente e funziona come directory temporanea per i file PRT sulla scheda PCMCIA attiva. Continuerà a contenere questi file anche se Tech2Win smette di operare. Se volete salvare questo tipo di file dovete copiarlo su un'altra directory dato che potrebbe essere sovrascritta non appena un altro utente scegliesse di visualizzare rapporti.


Immagini PCMCIA

Di solito le immagini PCMCIA sono nella sottodirectory C:\Users\Public\General Motors\Tech2Win\pcmcia. Il file deve avere la dimensione esatta di 32Mbyte (33,554,432 byte) o 10Mbyte (10,485,760 byte) ed un'estensione file *.bin. Le immagini vengono modificate (così come ogni scheda PCMCIA normale) se avviene un download o se Tech2Win registra qualcosa sulla flash card. Una modifica può essere disabilitata usando l'interruttore di protezione scrittura (comando -W0 o -W1) oppure omettendo il valore 'p' nell'opzione 'W'(File di configurazione). Non è possibile accedere all'interruttore di protezione da scrittura dal configuratore. È necessario modificare manualmente il file di configurazione se si desidera utilizzare le opzioni '-W0', '-W1' o '-W'.


Barra di Stato

La barra di stato viene mostrata al di sotto della schermata Tech2. I seguenti item vengono mostrati sulla barra di stato:

  1. Un indicatore di velocità
  2. Stato comunicazione veicolo
  3. Stato porta seriale
  4. Tasto SHIFT
  5. Screenshot automatici
  6. Messaggio d'errore
  7. Licenza

Status Bar

Indicatore di velocità

L'indicatore di velocità mostra quanto tempo CPU viene impiegato per l'emulazione del software Tech2. Un numero basso (indicatore di sinistra) è meglio di un numero alto (indicatore di destra). Ogni indicatore verde è accettabile. L'indicatore può diventare giallo per un breve lasso di tempo se si attivano improvvisamente diverse operazioni Windows. Questo tipo di attività dev'essere evitato.

Stato comunicazione veicolo

Lo stato della comunicazione del veicolo indica se è presente l'interfaccia di comunicazione veicolo (MDI) e la comunicazione tra il veicolo e Tech2Win.

Stato porta seriale

Quando comunica con Tech2Win su una COM-port, questo indicatore mostra se la comunicazione sulla COM port è attiva o no.

Tasto SHIFT

Questo indicatore indica che il tasto SHIFT è attivo. È possibile effettuare l'attivazione tramite il tasto 'S' sulla tastiera o il tasto SHIFT sul tastierino.

Screenshot automatici

Nel menu Opzioni, è possibile attivare le schermate automatiche. Ogni volta che cambia lo schermo, nella directory di registro viene salvato un nuovo file della schermata. Ciò è indicato da una rotazione della manovella sulla telecamera rossa, nella barra di stato. Non appena le schermate automatiche vengono disattivate, la telecamera scompare.

Messaggio d'errore

L'indicatore stato del registro può assumere tre diverse condizioni.

  • gray log status indicator Il file di registro non contiene messaggi di attenzione o di errore.
  • yellow log status indicator Il file di registro contiene un messaggio di attenzione.
  • red log status indicator Il file di registro contiene un messaggio di errore.

Licenza

L'indicatore licenza può assumere tre condizioni:

  • green smiley La licenza è attiva e valida.
  • Nessun indicatore: La licenza non è ancora stata verificata.
  • red smiley La licenza è scaduta o non esiste.
Si prega di vedere il link Security per ulteriori dettagli.

Descrizioni comandi sulla barra di stato

Per alcune icone, appaiono le descrizioni comandi al fine di fornire maggiori informazioni:

Descrizione comandi per numero di serie VCI:
Tooltip VCI

Descrizione comandi per versione software TECH2
Tooltip TECH2

Descrizione comandi per porta COM
Tooltip Comport

Descrizione comandi per numero della schermata successiva (se le 'Screenshot automatici' sono attive)
Tooltip Camera

Descrizione comandi che mostra l'ultima voce del file registro con livello 'avviso' o superiore
Tooltip Logfile

Descrizione comandi per la durata esatta della licenza
Tooltip License

Le descrizioni comandi vengono visualizzate se il cursore permane per oltre 0,5 secondi sopra un'icona senza essere spostato. Le descrizioni comandi scompaiono dopo 5 secondi o dopo aver spostato il cursore.

  • Sezione avanzata: Messaggi di errore e codici di errore
  • Sezione avanzata: File di log


Sezione avanzata

Gli argomenti discussi qui sono di minore importanza per l'utente standard di Tech2Win. Chiunque sia impegnato in setup, gestione e configurazione di Tech2Win potrebbe trovare utili le seguenti informazioni.

  • Reinstallazione
  • Disinstallazione
  • Modifica diretta dei file di configurazione
  • File di log
  • Messaggi di errore e codici di uscita
  • Scheda ATA
  • Eventi di registro
  • Descrizione file
  • Esempi di Gestione configurazione


Disinstallazione

La directory di installazione completa, la directory contenente i dati utente (C:\Users\Public\General Motors\Tech2Win) e la directory contenente i dati dell'applicazione (C:\ProgramData\General Motors\Tech2Win) sono cancellati.

  • Sezione avanzata: Reinstallazione
  • Installazione


File di configurazione

I file di configurazione sono sempre nella sottodirectory C:\Users\Public\General Motors\Tech2Win\config e hanno l'estensione *.conf. È possibile decidere di modificare manualmente il file di configurazione dato che non tutte le opzioni del file sono accessibili attraverso Tech2Win. Il file di configurazione è un file Unicode con una sequenza Byte-Order_Mark (BOM). Si consiglia vivamente di usare un editor Unicode pratico come Notepad quando si effettua qualsiasi cambio manuale.

Il file di configurazione è a riga di comando. Le righe vuote sono ignorate. Una riga comincia sempre con un'opzione ed è per lo più seguita da un valore. A mo' d'esempio, si veda il file default.conf. Si prega di consultare la seguente tabella contenente tutte le opzioni disponibili.

Se volete lanciare una certa configurazione direttamente dal desktop, create un collegamento a 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Il programma dovrebbe essere lanciato dalla seguente directory di lavoro: 'C:\Program Files\General Motors\Tech2Win\bin'

Opzione | Valore / Significato
; Un commento
@ Un numero di versione decimale nel formato major.minor.
I file di configurazione con un major number diverso da Tech2Win non sono ammessi. I file di configurazione con un minor number più basso di Tech2Win sono ammessi.
-W0
-W1 		La scheda PCMCIA dello slot 0/1 ha un interruttore di protezione dalla scrittura attivato.
-B0
-B1 		Dimensione di blocco in Kbytes della scheda PCMCIA nello slot 0/1. Valori accettabili sono 128 (default) o 256.
-P0
-P1 		Il file contenente l'immagine binaria di una scheda PCMCIA per lo slot 0/1. La dimensione del file dev'essere esattamente 10MB o 32MB. Le variabili di ambiente come %ProgramData% sono estese.
Se quest'opzione è assente, si presume che lo slot sia vuoto.
-A0
-A1 		Il file contenente i valori di attributo della scheda PCMCIA nello slot 0/1. Se non sono presenti, gli attributi default sono usati secondo le dimensioni della scheda e del blocco.
-W | Uscendo da Tech2Win, tutti i dati che permangono da una sessione all'altra sono messi in memoria nei rispettivi file. I valori p/f/r/c possono essere combinati per denotare rispettivamente PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | Funzionalità della gestione degli heap I valori 0/r/w/t possono essere combinati per attivare rispettivamente l'azzeramento, i controlli di lettura, i controlli di scrittura e i controlli delle mansioni. Il valore l viene utilizzato per applicare una ripartizione della memoria degli heap a indirizzi inferiori quando viene implementato uno schema di ripartizione alternativo. Normalmente questa opzione si utilizza solo in un ambiente di sviluppo.
-PC | In precedenza il percorso per la copia della scheda PCMCIA. Questa opzione è attualmente ignorata.
-MS | Identificazione dell'interfaccia di comunicazione veicolo (MDI) con numero di serie. Se non è impostata, verrà mostrato un elenco dei MDI disponibili.
-CT | Il colore del testo (primo piano) in 3 valori esadecimali (byte). Il valore default è 000000 (bianco).
-CB | Il colore dello sfondo in 3 valori esadecimali (byte). Il valore default è FFFFFF (nero).
-ATA | Utilizzare questa opzione per abilitare la scheda di cattura ATA. Rimuoverla per disabilitare la scheda di cattura ATA.
-C | Il numero della COM-port (1..9) da usare come porta di comunicazione RS232C di Tech2. Spesso COM9 viene usato per la porta COM virtuale, installata da Tech2Win. Se questa opzione non è presente, da COM9 viene effettuata una ricerca di una porta COM libera. Utilizzate il tooltip sulla barra di stato tra l'icona Tech2 e l'icona TIS2Web per vedere quale porta COM è in uso.
-WR | Un indirizzo PC (normalmente 253558) che è autorizzato a scrivere nell'area PCMCIA e FLASH ROM. Questa funzionalità deve inoltre essere attivata attraverso il menu (o utilizzando l'opzione - WA). È necessaria per eseguire il debug del codice nella memoria non modificabile mediante il debugger single step.
-WA | Consentite al SingleStep Debugger di scrivere nella memoria non modificabile.
-OF | File di opzioni contenente coppie opzione / valore.
-TP | Regolazione sincronizzazione (valore proporzionale). Predefinito a 5000. Diminuire questo valore per fare in modo che il numero di cicli eseguiti si adatti più rapidamente al tempo reale.
-TD | Regolazione sincronizzazione (valore differenziale). Predefinito a 100. Diminuire questo valore per reagire più velocemente alle modifiche della sincronizzazione istantanea. ATTENZIONE: la manomissione dei valori TP e TD può portare a problemi di velocità.
-PJ
-PP 		Specificare il protocollo da utilizzare:
PJ per la comunicazione J2534.
PP per ISO22900-2 / PDU-API (predefinito)
-S | La presenza di quest'opzione abilita l'uscita di suono sul cicalino del PC.
-L | La lingua dell'applicazione Tech2Win. Se manca questa voce, viene utilizzata di default la lingua attiva di Windows. Si veda il seguente link per una lista delle lingue che possono essere indicate: Languages. La finestra di emulazione Tech2 visualizza la lingua presente nella scheda PCMCIA (ossia quella scaricata nella scheda PCMCIA).
-UD | Override della directory dei dati utente. In Win7, di solito è in C:\Users\Public\General Motors\Tech2Win
-AD | Override dell'applicazione dei dati utente. In Win7, di solito è in C:\ProgramData\General Motors\Tech2Win
-US | Utilizzare un semaphore specifico per il rilevamento di più di una occorrenza di Tech2Win. Questa opzione consentirà, a ciascun utente, l'esecuzione di Tech2Win in parallelo sulla stessa macchina, presumibilmente un server. Quando si usa questa opzione, è inoltre necessario specificare le opzioni -UD e -AD.
-SS | Opzione per specificare la dimensione totale della finestra di Tech2Win incluso il tastierino (se presente). Il primo parametro deve essere una stringa tra virgolette ('), da usarsi come nome delle dimensioni nel menu Opzioni / Risoluzione. Il secondo parametro è il numero totale di pixel orizzontali dello schermo di Tech2Win, incluso il tastierino. Il terzo parametro è il numero totale di pixel verticali dello schermo di Tech2Win. Il quarto parametro opzionale è la larghezza del tastierino in pixel.
-SH opzione per controllare la gestione dello schermo. Il seguente numero decimale è utilizzato per specificare quali possibilità di gestione dello schermo devono essere disabilitate.
  • Bit 0: min/max non possibile.
  • Bit 1: nessun riposizionamento dello schermo.
  • Bit 2: nessun ridimensionamento. In questo caso il menu Opzioni / Risoluzione sarà di colore grigio.
  • Bit 3: Finestre per la visualizzazione dei dati e dei DTC esattamente delle stesse dimensioni di Tech2Win (senza tastierino)


Logging

Ogni volta che viene avviata una configurazione di Tech2Win il sistema crea un nuovo file di registro in formato HTML nella sottodirectory C:\Users\Public\General Motors\Tech2Win\Logs. Per evitare congestioni del disco rigido, i file di registro più vecchi di una settimana vengono rimossi.

I file di log ricevono il loro nome automaticamente, secondo la data (year, month, day) e l'ora (hour, minute, second) della loro creazione:
yyyy-mm-dd_hhmmss.html

Gli eventi dei file di log sono sempre in inglese, ma in formato Unicode con una sequenza Byte-Order-Mark (BOM). Ogni riga del file di log è di uno dei seguenti livelli di log:

Log Level | Significato
Info | Solo informazione. Nessun effetto sull'esecuzione del programma.
Attenzione | La situazione attuale è insolita. L'utente potrebbe non vedere nessun effetto dannoso.
ERROR | L'errore occorso sarà percepibile dall'utente.
CRITICAL | L'errore critico occorso provocherà il comportamento anormale del programma.
FATAL | Un errore irreversibile provocherà lo stop immediato dell'operatività di Tech2Win.

Tutti i livelli superiori a 'Avviso' sono colorati in maniera da poter essere individuati con facilità.

Inoltre, utilizzando l'opzione di menu Stampa schermo o Screenshot automatici, i file Stampa e Video saranno anche presenti nella sottodirectory Logs.
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
Le immagini Screenshot automatici sono collegate dal file HTML, pertanto utilizzare il registro HTML per visualizzare la sequenza di queste immagini.

Nella Barra di Stato l'utente viene informato dell'esistenza di un Messaggio d'errore ( yellow lightning bolt) o di un messaggio di log più grave ( red lightning bolt).


Messaggi di errore e codici di uscita

I messaggi di errore possono apparire sulle finestre di dialogo. Queste finestre di dialogo permettono a Tech2Win di eseguire anche il programma Tech2 nello stesso tempo. I codici di uscita sono errori irreversibili che provocano la chiusura anormale di Tech2Win. I codici di uscita possono essere usati in file batch per rivelare perché un programma è terminato.

Messaggi di errore

I seguenti messaggi di errore potrebbero apparire. Segue una breve spiegazione della situazione e di come il problema può essere risolto.

Emulator too slow Emulator failed to start

Codici di uscita

Codice di uscita | Valore | Significato
OPCODE_ERROR | -7 | È stato rilevato un comando non valido del microprocessore Tech2 (68332). L'immagine PCMCIA è stata forse alterata in qualche modo.
ATA_PROBLEM | -6 | È emerso un problema durante l'emulazione ATA. Se si sta osservando un problema simile dopo aver ricevuto istruzioni di usare la scheda ATA, si prega di contattare il servizio di assistenza.
DEMO_TIME_IS_UP | -5 | Non dovrebbe apparire nella versione ufficiale di Tech2Win.
DLL_NOT_LOADED | -3 | Non si è potuto caricare uno dei DLL necessari. Pare che abbiate una copia incompleta di Tech2Win. Si prega di eseguire una nuova installazione e/o di scegliere una lingua diversa.
EXIT_INIT_FAILED | -2 | Inizializzazione non riuscita Guardare nel file di log per trovare l'esatta causa. Se un file di log non esiste, si prega di controllare di avere l'accesso lettura/scrittura corretto per tutte le directory.
normale | 0 | Tech2Win è terminato normalmente.


Scheda ATA

La scheda ATA della Tech2 in genere è usata solo a scopo di debugging durante lo sviluppo del software. Tutti i dati ATA necessari sono memorizzati nella sottodirectory C:\Users\Public\General Motors\Tech2Win\ataCapture. Normalmente questa directory è priva di importanza e può essere cancellata senza rischi quando non specificato altrimenti.

Poiché la directory ataCapture è fissa, il suo contenuto sarà lo stesso per tutte le configurazioni.


File

I seguenti file e le seguenti directory sono usati da Tech2Win:

Directory | Ubicazione prima di Vista | Ubicazione per Vista e versioni successive
Installazione | Come definito durante l'installazione
Dati utente | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Dati dell'applicazione | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

File | Uso
[Dati utente]\atacapture | Contiene i file che sono presenti nella scheda ATA. Se non altrimenti specificato, questi file non sono necessari.
[Installazione]\bin | Contiene i DLL presenti, eseguibili e necessari, e le immagini necessarie per l'esecuzione.
[Installazione]\bin\emulator.exe | L'eseguibile principale sta effettuando il codice Tech2.
[Installazione]\bin\emulator_xx_XX.dll | DLL risorse specifiche della lingua.
[Installazione]\bin\T2Configurator.exe | Parte della configurazione di Tech2Win.
[Installazione]\bin\Pictures | Contiene le icone di cui ha bisogno Tech2Win.
[Dati utente]\config | Contiene tutti i file di configurazione.
[Dati utente]\data | Contiene file che vengono modificati durante l'esecuzione di Tech2Win. Questi file sono necessari per la corretta esecuzione di Tech2Win. Normalmente, non dovreste toccare questi file a meno che non venga esplicitamente specificato di farlo.
[Dati dell'applicazione]\data | Contiene file che vengono modificati durante l'esecuzione di Tech2Win. Questi file sono necessari per la corretta esecuzione di Tech2Win. Normalmente, non dovreste toccare questi file a meno che non venga esplicitamente specificato di farlo.
[Dati dell'applicazione]\data\emulator.sec | Security file . Non modificare questo file.
[Dati dell'applicazione]\data\emulator.card | File scheda. Contiene tutte le schede PCMCIA note al programma Tech2Win. Non modificare questo file.
[Dati utente]\data\emulator.disp | Questo file contiene l'ubicazione e le dimensioni dello schermo Tech2Win. Se cancellate questo file, verrà ricreato e lo schermo Tech2Win si avvierà nell'angolo in alto a sinistra con dimensioni 640x480.
[Dati dell'applicazione]\data\emulator.lic | License File. Contiene tutte le informazioni sulla durata della validità delle licenze. Non modificare questo file.
[Dati dell'applicazione]\data\emulator.rtc | Real Time Clock file. Questo file è usato come memoria di dati che si trovano nel RTC di Tech2.
[Dati dell'applicazione]\data\emulator.dta | File informativo 'Non ricordarmelo più'.. Questo file registra le versioni del software PCMCIA che non devono (più) visualizzare il messaggio di attenzione circa l'impossibilità di eseguire il test automatico, e che richiedono un adattatore loopback.
[Dati dell'applicazione]\data\candi.bin | CANdi application file. Contiene l'applicazione del CANdi che è allegata a Tech2.
[Dati dell'applicazione]\data\eprom.bin | Tech2 internal EPROM file. Contiene il contenuto della memoria flash Tech2 interna.
[Installazione]\driver | File di installazione per il driver della porta COM virtuale.
[Installazione]\help\emulator_xx_XX.chm | File di aiuto specifici per lingua.
[Dati utente]\Logs | Contiene i file di registro. I file più vecchi di una settimana saranno automaticamente cancellati.
[Dati utente]\pcmcia | Contiene file immagine PCMCIA. In senso figurato, ogni file corrisponde ad una scheda PCMCIA Tech2. Questi file possono essere salvati in posizioni diverse a piacere.


Gestione della configurazione

I file di configurazione sono sempre nella sottodirectory C:\Users\Public\General Motors\Tech2Win\config e hanno l'estensione *.conf. Tech2Win può essere usato solo per generare nuovi file di configurazione o per modificare file di configurazione esistenti che non siano sola lettura. Per ogni altra gestione dei file di configurazione, si prega di usare Windows Explorer o un programma di gestione file simile. Questo sarà necessario per le seguenti attività:

  • cancellazione file di configurazione
  • modifica nome file di configurazione
  • modifica attributo sola lettura di un file di configurazione

Si raccomanda vivamente di avere sempre un file di configurazione default.conf. Normalmente questo file dovrebbe avere il set di attributi sola lettura per evitare di sovrascrivere erroneamente. Tuttavia, se modificate questo file per soddisfare i vostri bisogni specifici, dovrete presto rimuovere l'attributo sola lettura.

Le immagini PCMCIA sono nella sottodirectory C:\Users\Public\General Motors\Tech2Win\pcmcia. Ciascuno di questi file corrisponde ad una scheda PCMCIA con cui avete già dimestichezza se lavorate con Tech2. Con Tech2Win potete avere tutte le immagini che volete. Dovete semplicemente copiare un'immagine esistente su di un nuovo nome file.

Se si desidera lanciare una certa configurazione direttamente dal desktop, è necessario creare un collegamento a "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Il programma dovrebbe essere lanciato dalla seguente directory di lavoro: 'C:\Program Files\General Motors\Tech2Win\bin'

Il numero dei file di configurazione non dipende dal numero delle immagini pcmcia che state usando. Potete avere svariati file di configurazione usando sempre la stessa immagine PCMCIA. Questo simula accuratamente la situazione di un'officina di riparazioni in cui diversi meccanici condividono lo stesso Tech2 (e la stessa scheda PCMCIA).

Potete anche scegliere di avere ogni configurazione, ciascuna con la propria immagine PCMCIA personalizzata. Ciò renderebbe le configurazioni individuali più indipendenti le une dalle altre. Tuttavia, aggiornare ciascuna immagine PCMCIA potrebbe richiedere uno sforzo troppo elevato.

Se si effettua una nuova configurazione copiandone una esistente, il configuratore visualizzerà un messaggio se l'immagine PCMCIA non è stata modificata. In tal caso, si avranno due configurazioni con la stessa immagine PCMCIA. Se questo è ciò che si desidera, è sufficiente premere OK. Se si desidera che la nuova configurazione usi un'immagine PCMCIA nuova o diversa, premere Annulla. Quindi si potrà scegliere di creare una nuova immagine con Copia memory card ...

Qui di seguito, due metodi esemplificativi di come potete gestire le vostre configurazioni e immagini PCMCIA.

Una configurazione per utente

È possibile salvare una configurazione per utente. Il nome della configurazione sarà, ad esempio, il nome dell'utente. I vantaggi di questo concetto sono che le impostazioni specifiche dell'utente quali le interfacce di comunicazione veicolo (MDI), lo schermo e lingua sono possibili. Lo svantaggio è che, se fossero diversi gli utenti ad utilizzare lo stesso software, sarà necessario copiare i file PCMCIA. Ovviamente, per le configurazioni specifiche dell'utente, sarà possibile utilizzare un file PCMCIA centrale.

Una configurazione per software Tech2

È anche possibile scegliere di creare una nuova configurazione per ciascun software che si scarica. Così facendo, anche le versioni di software più vecchie saranno immediatamente disponibili, secondo necessità. Spesso, in questo caso, il nome e il numero versione del software vengono scelti come nome di configurazione.

  • Primi passi: Interfaccia di comunicazione veicolo
  • Primi passi: Percorso
  • Sezione avanzata: File di configurazione
  • Installazione: Passi dell'installazione


Domande frequenti

  • Come posso determinare quale porta COM utilizzare per Tech2Win?
  • Comunicazione tra Tech2Win e TIS2Web
  • Licenza valida
  • Che cosa indica il numero di licenza?
  • Qual è la differenza tra una licenza Tech2Win e l'accesso di sicurezza?
  • TIS2Web mostra un errore generico quando si effettua l'accesso di sicurezza al Software iniziale
  • Tech2Win non esegue software Tech2 da un'altra area
  • Come posso utilizzare molteplici MDI?
  • Il file di registro contiene l'errore 'CPU32: Too many 0000/FFFF Commands encountered'
  • Nessuna finestra Tech2 visibile
  • L'SPS non funziona
  • Alcuni test automatici non funzionano
  • L'indicatore di velocità è variabile
  • Arresto improvviso
  • La lingua indicata sul software 15.001 è quella svedese
  • Comunicazione assente con l'MDI
  • Tech2Win non ha trovato l'MDI cercato
  • Voglio avviare subito Tech2Win senza utilizzare il configuratore
  • Dove sono le funzioni di stampa?
  • Una cartella PCMCIA 'inutilizzata' è presente sul mio computer
  • Sto ricevendo un messaggio di 'percorso file non consentito'

Come posso determinare quale porta COM utilizzare per Tech2Win?

È possibile utilizzare 'Gestione periferiche' di Windows, cercare 'Porte (COM e LPT)'. Tuttavia, alcuni computer integrano modem interni o dispositivi Bluetooth che non sono indicati in questa categoria.
Un altro modo consiste nell'utilizzare un piccolo comando fornito insieme al configuratore. È possibile eseguirlo dal menu Start (cartella Tech2Win) facendo clic su 'show com ports'.
Entrambi i metodi mostrano le porte COM installate sul computer, che NON vanno utilizzate.

Comunicazione tra Tech2Win e TIS2Web

È importante che Tech2Win sia in esecuzione prima che venga avviata la comunicazione con TIS2Web per l'accesso di protezione o lo scaricamento del software. TIS2Web è in grado di riconoscere la porta COM virtuale solo quando è avviato Tech2Win.

Licenza valida

Di solito, scaricando un software da TIS2Web, viene fornita una licenza valida. Se, tuttavia, non ne possedesse ancora una, occorre eseguire un 'Accesso alle funzioni di sicurezza (Sicurezza)' via TIS2Web (non TIS2000) ed ottenere quindi la licenza valida. Non eseguire nessun'altra comunicazione TIS2Web con Tech2Win come ad esempio un 'Download del software (DLSW)' prima di ottenere una licenza mediante 'Accesso alle funzioni di sicurezza (Sicurezza)'.

Che cosa indica il numero di licenza?

Il numero di licenza a destra della barra di stato mostra il numero di giorni totali della licenza. Subito dopo aver eseguito un download o un accesso di sicurezza, viene visualizzato il numero 30. Dopo un nuovo avvio di Tech2Win, tuttavia, viene visualizzato il numero 29 poiché la durata della licenza è più vicina a qualcosa come 29 giorni, 23 ore e 55 minuti. Se il numero dei giorni di licenza è inferiore a 24 ore, viene visualizzata una durata pari a <1. Se la licenza è scaduta, viene visualizzato 0.

Qual è la differenza tra una licenza Tech2Win e l'accesso di sicurezza?

La licenza Tech2Win consente all'utente di utilizzare Tech2Win. Per ottenere la licenza è necessario scaricare il software oppure effettuare l'accesso di sicurezza ad intervalli regolari (più comunemente, ogni 30 giorni). Eseguendo lo scaricamento via TIS2Web, Tech2Win viene informato che è presente un utente valido. L'accesso di sicurezza, così come conosciuto da Tech2, informa Tech2Win che sono ammesse alcune attività relative alla sicurezza quali la disabilitazione di un airbag. Sia la licenza Tech2Win che l'accesso di sicurezza sono eseguibili attraverso l'applicativo TIS2Web Security Access. Sulla barra di stato a destra, Tech2Win visualizza la durata rimanente della licenza. Sfortunatamente, Tech2Win non è in grado di visualizzare la durata di un accesso di sicurezza in quanto esegue semplicemente il software Tech2, senza, però, comprenderlo.

TIS2Web mostra un errore generico quando si effettua l'accesso di sicurezza al Software iniziale

Il comportamento è lo stesso di un Tech2. Poiché è datato, il Software iniziale non è in grado di ottenere una licenza dal TIS2Web. Tuttavia non costituisce un vero e proprio problema poiché tale software in versione demo non comunica con un veicolo per il quale sia necessaria la licenza. E poiché le licenze sono specificatamente legate al download di TIS2Web, avreste comunque bisogno di una licenza per ogni singolo download dopo aver scaricato il software Tech2. Una 'licenza' per il Software iniziale non vi autorizza ad effettuare comunicazioni del veicolo con un software North American Operations od Opel/Vauxhall.

Tech2Win non esegue software Tech2 da un'altra area

La versione di Tech2Win in uso è probabilmente limitata a uno o più download di TIS2Web (regioni). Premere Guida / Informazioni su per conoscere le limitazioni valide per la versione di Tech2Win in uso. Le prime versioni del Tech2Win consentivano solo l'esecuzione del software Opel/Vauxhall. Seguiranno altre regioni GM. In ogni caso, attualmente Tech2Win è in grado di eseguire il software Tech2 di General Motors.

Come posso utilizzare molteplici MDI?

Se si desidera assegnare MDI specifici ad utenti specifici, è consigliabile consentire a ciascun utente di avere la propria configurazione. Ovviamente, queste configurazioni devono essere denominate in base al rispettivo utente. In ciascuna configurazione occorre inserire il numero di serie dell'MDI specifico dell'utente nella scheda 'Interfaccia di comunicazione veicolo'. Non appena l'utente avvia la configurazione, Tech2Win tenterà di contattare quello specifico MDI. Soltanto nel caso in cui quell'MDI non fosse presente, si aprirebbe una casella di selezione indicante tutti gli MDI che Tech2Win ha trovato.

Se si possiedono diversi MDI per uso generico, è consigliabile utilizzare le configurazioni in cui il numero di serie nella scheda 'Interfaccia di comunicazione veicolo' è lasciato vuoto. Successivamente, l'utente vedrà sempre la casella di selezione degli MDI disponibili.

Il file di registro contiene l'errore 'CPU32: Too many 0000/FFFF Commands encountered'

Il file 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' o il file PCMCIA corrente è corrotto. Eseguire la reinstallazione di Tech2Win e scaricare il nuovo software Tech2.

Nessuna finestra Tech2 visibile

Se la finestra Tech2 non è visibile, si trova probabilmente in un'area al momento non presente sullo schermo. Questi effetti si verificano quando si utilizza più di uno schermo oppure dopo aver modificato la risoluzione dello schermo stesso. Durante l'avvio della configurazione, premere il tasto Shift sulla tastiera. In questo caso, la risoluzione della finestra sarà ripristinata su 640x480 e la finestra Tech2 sarà visualizzata nell'angolo in alto a sinistra dello schermo. È inoltre possibile cancellare il file C:\Users\Public\General Motors\Tech2Win\emulator.disp per ottenere lo stesso risultato.

Sono capitati casi in cui, a seguito della chiusura delle finestre di tutte le altre applicazioni, la finestra Tech2 non è stata ridisegnata sullo schermo. In tutti i casi esaminati finora, per ripristinare la schermata di Tech2, è stato sufficiente utilizzare i tasti Alt-Tab per passare da un'applicazione all'altra di Windows. La pressione del tasto Tech2Win nella barra delle applicazioni in basso sullo schermo del PC potrebbe, talvolta, non funzionare. Al momento, stiamo cercando di approfondire questa problematica e speriamo di risolverla nella versione successiva di Tech2Win.

L'SPS non funziona

Sì, lo sappiamo. Non prevediamo modifiche. Tech2Win non andrebbe utilizzato in sostituzione di Tech2 per eseguire l'SPS. Usare MDI direttamente con programmazione SPS mediante TIS.

Alcuni test automatici non funzionano

I test automatici di Tech2 hanno la finalità di testare le singole parti dell'hardware di Tech2. Alcuni di questi test richiedono l'uso di un adattatore di loopback. Questi test non funzionano in Tech2Win perché la funzionalità adattatore loopback non è implementata (e non vi sono progetti che ne prevedono l'implementazione). Non eseguire questi test inutili in Tech2Win. In assenza di adattatore loopback, la loro esecuzione potrebbe fornire risultati erronei o potrebbe far bloccare Tech2Win e Tech2. In questo caso, utilizzare Ctrl-R per ripristinare Tech2Win.

L'indicatore di velocità è variabile

L'indicatore di velocità presente nella parte inferiore sinistra della barra di stato indica il numero di 'comandi Tech2' che è possibile eseguire prima che Tech2Win ritorni in modalità di sospensione. Questo metodo viene utilizzato per garantire una corrispondenza tra i tempi di Tech2Win e la realtà: PC più veloci passano in modalità di sospensione più frequentemente dei PC più lenti. Se l'indicatore di velocità è variabile, è possibile che altre applicazioni stiano utilizzando la potenza di calcolo o che il clock del PC stia cambiando. Elevati tassi di variabilità hanno un impatto negativo sulla comunicazione con il veicolo e con TIS2Web Assicurarsi che non vi siano altre applicazioni in esecuzione.

La maggior parte dei computer portatili è in grado di ridurre automaticamente il clock della CPU per estendere la durata della batteria. Anche questa potrebbe essere la causa della variabilità di velocità rilevata da Tech2Win. In tal caso, non alimentare il portatile con la sola batteria ma utilizzare una fonte di energia esterna. È anche possibile provare a modificare le impostazioni di alimentazione, in modo che il sistema operativo non riduca la velocità di clock.

Arresto improvviso

Se il file di registro non indica motivi che hanno generato l'arresto del programma, è possibile che si siano attivati i meccanismi di protezione interni di Tech2Win. Non manomettere i seguenti file: emulator.sec, emulator.lic, emulator.card. Se tech2Win identifica una violazione della protezione, sarà altamente probabile dover ripetere la reinstallazione.

La lingua indicata sul software 15.001 è quella svedese

Il software iniziale in dotazione con Tech2Win è un software dimostrativo presente su ogni nuova scheda PCMCIA. In TIS2Web viene indicato che il software è in svedese perché questo visualizza solo l'ultima lingua di un elenco di lingue supportate da questo software dimostrativo (inglese, francese, tedesco, svedese). Utilizzare la modalità di aggiornamento 'Personalizza' anziché quella 'Standard' per sovrascrivere il software dimostrativo con il nuovo software diagnostico.

Comunicazione assente con l'MDI

La mancata comunicazione con l'MDI può essere dovuta a diverse cause.

  • Connessione via cavo errata (Ethernet e USB)
  • Connessione wireless instabile.
  • Passaggio alla modalità standby sul PC.

Tech2Win non ha trovato l'MDI cercato

Appurare quanto segue:

    1. L'MDI è attiva?
    2. L'MDI Manager funziona?
    3. MDI viene usato con un'altra applicazione come ad es. SPS?
È possibile avviare l'MDI Manager usando l'icona sul desktop o mediante 'Start/Tutti i programmi/General Motors/GM Software MDI'.: Se il punto 2 non funziona, contattare il servizio di assistenza.

Voglio avviare subito Tech2Win senza utilizzare il configuratore

Eseguire "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Usare la seguente directory di lavoro: 'C:\Program Files\General Motors\Tech2Win\bin' Potete ancora usare il configuratore per effettuare modifiche alla configurazione.

Dove sono le funzioni di stampa?

Tech2Win non dispone di funzioni dirette di stampa. Invece crea file temporanei e richiama i programmi associati alle estensioni dei file in questione. Questi programmi possono essere successivamente usati per effettuare la stampa, consentendo la messa a punto della stampa stessa.

Print Report | Print Report

Per stampare la schermata Tech2Win corrente, utilizzare la voce di menu File / Stampa schermo o il pulsante sulla tastiera indicante una stampante. Se fosse necessario stampare più schermate Tech2Win, è possibile utilizzare la voce di menu Opzioni / Screenshot automatici in quanto questta crea file PNG per ogni schermata Tech2Win. Questi file PNG sono inclusi nel file di registro.

È inoltre possibile stampare contenuti di visualizzazione dati (attivati tramite la voce di menu Finestre / Visualizzazione dei dati su Tech2Win). Usare il pulsante Stampa/Avvio HTML per avviare e interrompere l'acquisizione dei dati. Al termine dell'acquisizione il file eseguibile associato HTML (di solito Internet Explorer) viene avviato, con totale funzionalità di stampa dei dati.

Data Display | Data Display

Una cartella PCMCIA 'inutilizzata' è presente sul mio computer

Le versioni precedenti di Tech2Win prevedevano sempre una doppia memorizzazione dei file PCMCIA in una directory separata. Frequentemente questa directory era C:\PCMCIA. Ora questa directory non viene più utilizzata in quanto il download veloce da TIS2Web rende inutile una seconda memorizzazione. È possibile cancellare questa directory senza problemi.

Sto ricevendo un messaggio di 'percorso file non consentito'

Il nome del file sembra contenere caratteri non consentiti come il segno di percentuale (%). Se si riscontra questo problema subito dopo un'installazione, sarebbe meglio eseguire semplicemente una installazione e una nuova reinstallazione. La maggior parte dei problemi possono essere risolti con questo metodo.

Durante le normali installazioni, la variabile ambiente 'Tech2WinUserData' è impostata su 'PUBLIC' (per le versioni Windows >= Vista) e su 'ALLUSERSPROFILE\Documents' (per le versioni di Windows precedenti a Vista). In alcuni rari casi la variabile ambiente non veniva impostata durante il processo d'installazione, ma funzionava bene al secondo tentativo. Si potrebbe anche scegliere di impostare la variabile ambiente manualmente. Chiedere assistenza al proprio amministratore se non si sa come impostare una variabile ambiente.


Eventi di registro

I seguenti eventi di registro sono generati dall'installatore. Si prega di non modificare questi eventi manualmente. Informarsi sulle avvertenze standard di Windows quando si ha a che fare con eventi di registro.

chiave di registro | nome | tipo | significato
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Numero versione interna
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Lingua | REG_SZ | lingua installata
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Percorso delle directory copia PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Radice | REG_SZ | percorso d'installazione
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | OpzioneDisinstallazione | REG_DWORD | Impostazioni di disinstallazione
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Versione del file Config
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Versione del driver della porta COM virtuale
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Nome software all'interno della lista di programmi Add/Remove
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Disinstalla stringa | REG_SZ | Percorso al programma di disinstallazione


Reinstallazione

La reinstallazione cancellerà l'intera directory d'installazione del Tech2Win con le seguenti eccezioni.

  1. la sottodirectory config contenente le configurazioni non viene cancellata.
  2. La sottodirectory pcmcia che normalmente contiene le immagini PCMCIA non viene cancellata.
  3. La sottodirectory ATA che potrebbe contenere informazioni di debug non viene cancellata.
I file di configurazione possono diventare incompatibili: non c'è alcuna garanzia che i file di configurazione di una versione precedente di Tech2Win siano leggibili da una versione più nuova di Tech2Win. In linea di principio, le immagini PCMCIA non possono diventare incompatibili.

La reinstallazione non influisce sulla directory PCMCIA secondaria.

Determinate circostanze potrebbero offrire un'installazione automatica di una nuova versione di Tech2Win. Dato che l'informazione dell'ultima installazione è registrata nel registry, queste impostazioni saranno presentate come default durante la reinstallazione.

È possibile imporre la reinstallazione di Tech2Win utilizzando lo script enable reinstallation. Questo script è installato insieme a Tech2Win. Fondamentalmente, questo script definisce solo il valore della chiave CurrentVersion trovata nel registro in HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win sul valore di '1.000'.