Tech2Win - Felhasználói útmutató

Üdvözöljük! Ez a Tech2Win alkalmazás felhasználói útmutatója.

Copyright (C) 2010..2016 SPO Engineering General Motors Minden jog fenntartva.

  • Bevezetés:
  • Licenc:
  • Telepítés:A Tech2Win alkalmazás telepítési folyamatának leírása.
    • A telepítés lépései
    • Gépjármű kommunikációs felület
  • Első lépések
    • Konfiguráció kiválasztása
      • Billentyűzet
      • Az ablakok kezelése
    • Új konfigurációk
    • A konfigurációk módosítása
      • Nyelv
      • Útvonal
      • Kijelző
      • Konfiguráció mentése
    • Szerezzen be érvényes Tech2Win licencet.
  • A Tech2Win alkalmazás használata: Részletek a mindennapi munkához.
    • Menü
    • PCMCIA-kép letöltése
    • Biztonság
    • Jelentések megtekintése
    • PCMCIA-képek kezelése
    • Állapotsor
  • Speciális témakörök: A Tech2Win alkalmazás szokásos használatához nem szükséges információk. Gyakran csak a rendszergazda-tevékenységet végző felhasználókat érinti.
    • Újratelepítés
    • Eltávolítás
    • A konfigurációs fájl formátuma
    • Naplófájl
    • Hibaüzenetek és hibakódok
    • ATA-kártya
    • Bejegyzések a rendszerleíró adatbázisban
    • Fájlok
    • Konfigurációkezelés
  • GYIK


Bevezetés

A Tech2Win program egy Windows alkalmazás, amely a Tech2 készülék működését emulálja. Tulajdonképpen a Tech2 szoftver végrehajtása számítógépen történik. Az alkalmazás használatához a számítógépnek az alábbi műszaki követelményeknek kell megfelelnie:

  • A számítógépen telepíteni és csatlakoztatni kell gépjármű-kommunikációs eszközt. Az elfogadható interfészek listája régióról régióra változhat. A legtöbb esetben a GM MDI (többszörös diagnosztikai interfész) eszköze használható.
  • A Tech2Win alkalmazás telepítése 150 MB tárhelyet igényel a merevlemezen. További 32 MB hely szükséges a kezelendő PCMCIA-kártyánként.
  • A Tech2Win alkalmazás indítása előtt legalább 100 MB szabad fizikai RAM-mal kell rendelkeznie a számítógépnek. Fontos, hogy a számítógép elegendő memóriával rendelkezzen ahhoz, hogy az alkalmazás a működése alatt végig a RAM-ból fusson.
  • A számítógépnek 1,2 GHz-es egymagos Pentuim processzorral megegyező teljesítménnyel kell rendelkeznie. Javasoljuk, hogy párhuzamosan ne használjon más alkalmazást.
  • Billentyűzet nem szükséges. A Tech2Win alkalmazás érintőképernyővel is használható. Konfigurációkezeléshez ajánlott a billentyűzet használata, mert fájlneveket kell beírni.
  • Az Ön színes kijelzőjének minimum 800 x 600 felbontása kell legyen, minimum 256 színű színmélységgel. Számbillentyűzet nélkül a 640 x 480 felbontás elfogadható lehet.

Amikor a Tech2Win alkalmazást használja (horodzható számítógépen Tech2 helyett), kérjük, győződjön meg róla, hogy a hordozható számítógép megfelelően fel van töltve. A hordozható számítógép táplálása általában nem az autó akkumulátoráról történik, mint a Tech2 eszközé.

  • Telepítés
  • Első lépések


Licenc

General Motors - Tech2Win licenc megegyezés

Gondosan olvassa végig a következő szerződési feltételeket, mielőtt ezt a programot használná. Ha nem fogadja el, vagy nem érti meg a szerződési feltételeket, kérjük lépjen kapcsolatba a helyi Vevőszolgálat képviselőjével. General Motors csak azon feltétel mellett engedélyezi a felhasználó számára ennek a szoftvernek a használatát, hogy a felhasználó egyetért ezen licenc szerzőséssel és a Tech2Win telepítése során beleegyezik ezen szerződési feltételekbe.
A General Motors a Tech2Win szoftver és az abban található, a TIS2Web-bel vagy GlobalTIS-szel vagy TIS2000 kapcsolatos információ használati jogát kizárólag a General Motors felhatalmazott javítói hálózat felhasználóinak engedi át, amint az az adott helyen érvényes, és a General Motors helyi értékesítési vállalatával kötött Felhatalmazott Javítói Szerződésben le van fektetve.
A Tech2Win licensz addig érvényes, míg a Felhatalmazott Javítói Szerződés hatályban van és a TIS2Web, GlobalTIS és TIS2000 licensz jelen van. A Tech2Win licenc a TIS2Web és GlobalTIS licencszel együtt jár le, amikor lejár a hivatalos javítói szerződés.

Az Európai Unió Block Exemption Regulation (BER) 1400/2002 4. cikkely 2. bekezdésében meghatározott független javítók a General Motors Europe GM Europe Info Tech Portálján meglévő felkínált előfizetések részeként vásárolhatnak Tech2Win licenszet.

A Tech2Win licensz nem tartalmazza a gépjármű kommunikációs interfészt vagy PC-hardvert.

A Tech2Win szoftvert tilos tovább terjeszteni, eladni vagy a Feljogosított Javító telepein kívül (amint ezek a Felhatalmazott Javítói Szerződés megfelelő Függelékében leírásra kerültek) bármely harmadik félnek a General Motors erre illetékes nemzeti értékesítési vállalata előzetes írásos beleegyezése nélkül on-line elérhetővé tenni. Ez mind az aktuális, mind a már nem aktuális adatokra (mint például egy már lejárt DVD) érvényes.

General Motors nemzeti értékesítési vállalati jogosultak a a hozzáférés azonnali lezárására és a Felhatalmazott Javítói Szerződés érvényességének azonnali megszűntetésére, ha a licencet arra fel nem jogosított személyek vagy nem a rendeltetésnek megfelelően használják. Ebben az esetben a fennmaradó befizetett összeg visszaszolgáltatására és/vagy az évi előfizetési díjak visszaszolgáltatára vonatkozó jog is megszűnik.

A rendelkezésre bocsátott információ a a meg nem változtatott General Motors gépjárműveken végzett szerviz és javítási munkák szakszerű kivitelezésére szolgál. A fentebbiekben leírt munkák kivitelezéséhez egy már befejezett autószerelői kiképzésre és rendszeres további oktatásra van szükség. Ha a rendelkezésre bocsátott információban célszerszámok használata van leírva, a megadott célszerszámok használata valamennyi javítás szakszerű kiviteléhez kötelező.

A General Motors Tech2Win programmjában található információkra (szövegekre és ábrákra, zenékre, grafikákra, animációkra, filmekre stb.) és ezeknek a Tech2Win-en belüli elrendezésére megfelelő szerzői jogok érvényesek. Az anyag reprodukálása, terjesztése, kommunikációs és/vagy adatátviteli vagy bármely más úton történő továbbadása a General Motors előzetes írásbeli beleegyezése nélkül tilos.

  • Telepítés: A telepítés lépései
  • Első lépések


Installation

Telepítés

A Tech2Win telepítéséhez rendszergazdai jogosultságokkal kell rendelkezni a számítógépen. Adminisztrátori jogok nélkül a telepítés nem fog működni. Ebben az esetben forduljon a helyi rendszergazdához segítségért.

A Tech2Win alkalmazás sikeres használatához a következő két lépést kell végrehajtani:

  • A Tech2Win alkalmazás telepítése.
  • Gépjármű kommunikációs felület telepítése.
  • Telepítés: A telepítés lépései
  • Első lépések


A telepítés lépései

A telepítés önmagában csak néhány percet vesz igénybe és az alábbi felhasználói beviteleket igényli:

  1. Licenszszerződés
  2. Telepítési könyvtár

Nyelv

Alapértelmezetta a Tech2Win felhasználói felülete az operációs rendszer nyelvét használja. A program általában a következő nyelveket támogatja: Ha az ön nyelve nem támogatott, akkor a telepítő az angolt használja alapértelmezett telepítési nyelvként.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)angol (egyesült államokbeli vagy egyesült királyságbeli)*
  • el_GR (EL)Greek
  • es_ES (ES)spanyol
  • fi_FI (FI)Finnish
  • fr_FR (FR)francia
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)portugál (brazíliai)
  • pt_PT (PT)portugál (portugáliai)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)kínai (egyszerűsített)
  • zh_TW (ZH)kínai (hagyományos)

* A Tech2Win nyelve brit angol. Azonban, az ön által használt Tech2 szoftver és a telepítő nyelve lehet amerikai angol is, a szoftver forrásától függően.

Licenszszerződés

El kell fogadnia a licenszszerződést.

Telepítési könyvtár

A Tech2Win alkalmazás telepítési helyének bármely könyvtárat megadhatja. A telepítési könyvtár alapbeállításként a <programkönyvtár>\General Motors\Tech2Win könyvtár, vagy újratelepítés esetén a legutóbb megadott hely.

A telepítés utolsó megerősítéseként.

Virtuális COM port illesztőprogram

A virtuális com port illesztőprogram csak egyszer kerül telepítésre a számítógépén és az illesztőprogram frissítéséig (ritkán történik) vagy addig megmarad, amíg el nem távolítja a Tech2Win alkalmazást a számítógépről.
Ha az illesztőprogram telepítése megtörténik, akkor rövid időre megjelenik egy DOS ablak. Ez automatikusan bezárul és nem igényel beavatkozást. Az illesztőprogram a Tech2Win mappa 'illesztőprogram' almappájába kerül.
Lehetséges, de nem ajánlott a virtuális com port illesztőprogramok manuális telepítése. Használja az alábbi utasítások valamelyikét a CMD keretprogramban:

  • írja be a 'vbsetup7' parancsot az illesztőprogram telepítéséhez
  • írja be a 'vbsetup7 /u' parancsot az illesztőprogram eltávolításához
  • Első lépések


Gépjármű kommunikációs felület

A gépjármű-kommunikációs eszköz telepítését külön kell elvégezni. Lásd a Gépjármű kommunikációs felülethez mellékelt, vonatkozó telepítési útmutatót.

  • Első lépések: Gépjármű kommunikációs felület
  • Speciális témakörök: Konfigurációs fájl
  • Telepítés: A telepítés lépései
  • GYIK: Hogyan használhatok egynél több MDI-t?
  • GYIK: Tech2Win nem találja az MDI-met


Első lépések

Az első lépések bemutatják a Tech2Win alkalmazás használatát. Az útmutató feltételezi, hogy a Tech2 készüléket a felhasználó már ismeri. Az első lépések alatt gépjármű-kommunikáció nem szükséges.

A QuickStart eléréséhez, használja az alábbi lépéseket:

  1. Indítsa el a Tech2Win szoftvert az asztalon található QuickStart parancsikonnal.
  2. Egy érvényes licensz beszerzáse az új Tech2 szoftver TIS2Web-ről törénő letöltésével.

Egy választható konfiguráció használatához:

  1. Indítsa el a konfigurátort az asztal Tech2Win parancsikonjának használatával. Telepítést követően rendelkezésre áll az alapértelmezett konfiguráció.
  2. Új konfiguráció létrehozásához, lehetőleg másolja az alapértelmezett konfigurációt.
  3. Egy létező konfiguráció módosításához az egyedi követelményeinek megfelelően.
  4. Szerezzen be érvényes licencet.

Ne indítsa el a Tech2Win alkalmazást kombatibilitási módban. Ilyen esetekben egy figyelmeztetés jelenik meg a naplófájlban. A Tech2Win csak az XP óta létező Windows funkciókat használ, ezért korábbi Windows verziók esetében nem működik.

  • Első lépések: Új konfigurációk
  • Első lépések: A konfigurációk módosítása
  • Első lépések: Gépjármű kommunikációs felület
  • A Tech2Win alkalmazás használata: Menü
  • A Tech2Win alkalmazás használata: Biztonság
  • A Tech2Win alkalmazás használata: Állapotsor
  • Speciális témakörök: Konfigurációs fájl


Konfiguráció kiválasztása

A Tech2Win alkalmazás első indításakor a következő képernyő jelenik meg. Lehetőség van a Tech2Win indítására az alapértelmezett konfigurációval. Az alapértelmezett konfiguráció gépjármű-kommunikáció nélkül is működik.

Start First Time

Megjelenik a licencinformáció szövegdoboz, de ezt figyelmen kívül hagyhatja az alapértelmezett konfiguráció indításához.

Ha érintőképernyőt használ, hasznos lehet a számítógép billentyűzetprogramjának elindítása a betűk beírásának megkönnyítése érdekében.


Billentyűzet

Ha a számítógéphez van billentyűzet, a billentyűket a program a megfelelő Tech2-gombokhoz rendeli. A Tech2Win alkalmazás néhány további gombot biztosít, amelyek a Tech2 készüléken nem találhatók meg. Megtörténhet, hogy a PC számbillentyűzete nem minden körülmények között működik. Egyéb problémák esetén ellenőrizze, hogy megváltozott-e a számítógépén a szabványos billentyűzetkiosztás. Ilyen esetben főleg a SHIFT billentyű károsodhat.

Számítógép-billentyűzet | Gomb | Funkció
F1 funkcióbillentyű | - | Tech2Win súgó
F5 - F8 funkcióbillentyűk | Használja a Tech2Win kijelzőfelületnek a gyorsbillentyűk által elfoglalt részét. | A Tech2 négy funkciógombja
Fel, le, balra, jobbra kurzorbillentyűk |  | Tech2 fel, le, balra, jobbra gombjai. Csak ezek a gombok rendelkeznek automatikus ismétléssel.
0 - 9 billentyűk | F0 • • • F9 | Tech2 F0 - F9 gombok
Backspace | Exit | Tech2 Exit gomb
Enter / Return | Enter | Tech2 Enter gomb
Y | Yes | Tech2 Yes gomb
N | No | Tech2 No gomb
Q | ? | Tech2 ? gomb
S | Shift | Tech2 Shift gomb; Az állapotsáv Shift jelzője vagy a Shift gomb feletti jelző mutatja az állapotot.
ctrl-P | PWR | Tech2 be- és kikapcsoló gomb; Természetesen a gombbal csak a Tech2Win alkalmazás kapcsolható ki.
ctrl-R | nem hozzáférhető | Újraindítja a Tech2Win alkalmazást. Hasonló a Tech2 ki-/bekapcsolási ciklusához. A kapcsolódó jármű kommunikációs interfész azonban nincs visszaállítva. PCMCIA és hasonló fájlok nincsenek újratöltve.
Home | Home | Home gomb. Csak egyes alkalmazások támogatják.
csak a menüopciókon keresztül elérhető Fájl. | Print Screen | Kinyomtatja a Tech2 képernyőképét egy ideiglenes BMP fájl létrehozásával és a BMP fájlokhoz kapcsolódó alkalmazás meghívásával. Ez az alkalmazás használható a kép nyomtatás előtti átméretezéséhez vagy elforgatásához.
csak a menüopciókon keresztül elérhető Fájl. | Save Screen | Menti a Tech2 képernyőképét BMP vagy PNG fájlként.
csak a menüopciókon keresztül elérhető Fájl. | View Report | Megjeleníti az aktív PCMCIA-kártyán található összes jelentést, hogy a felhasználó megtekinthesse.


Az ablakok kezelése

Az ablakok a Windows rendszerben szokásos eljárással, a főablak határvonalait húzva átméretezhetők. Továbbá az Beállítások/Felbontás menüpont több előbeállított méretet támogat. A főablak menüponttal történő átméretezése közben a billentyűzet ablak automatikusan zárolt marad.

Az ablakok megjelenése a Kijelző lap beállításaival módosítható.


Új konfigurációk

Új konfiguráció létrehozásához kattintson a Új létrehozása gombra. Megjelenik egy párbeszédpanel, amelyen a program a forrásként szolgáló konfigurációs fájl kijelölésére kéri. Normál esetben az alapértelmezett konfiguráció lesz kijelölve. Az új konfigurációs fájl nevének megadását követően nyomja meg a Másolás gombot.

Ha érintőképernyőt használ, hasznos lehet a számítógép billentyűzetprogramjának elindítása a Billentyűzetprogram gombbal.

A Mégse gombbal megszakítható a folyamat.

Az új konfiguráció ugyanazt a PCMCIA fájlt használja, mint a meglévő forrás konfiguráció. Ha ezt meg szeretné változtatni, akkor úgy kell módosítania a konfigurációt, hogy ettől eltérő PCMCIA fájlt használjon. Legtöbb esetben egyszerűen átmásolja a meglévő PCMCIA fájlt egy új fájlba és ezt az új fájlt használja. Úgy is dönthet, hogy az új konfiguráció ugyanazt a PCMCIA fájlt használja, mint a forrás konfiguráció. Ebben az esetben egy figyelmeztető képernyő jelenik meg a Mentés gomb használatakor.

  • A konfigurációk módosítása


A konfigurációk módosítása

A kék színű konfigurációk írásvédett fájlok és nem módosíthatók. Ezeket a konfigurációkat csak megtekinteni lehet. A módosítási eljárás természetesen használható a fájlok tartalmának megtekintéséhez, azonban a Mentés parancs nem lesz elérhető.

A konfiguráció módosítása a következő négy lapon található egyes beállítások kijelölésével történik: Nyelv, Gépjármű kommunikációs felület, Útvonal, Kijelző. Válassza ki a kívánt tabulátort, vagy egyszerűen csak nyomja meg a Következő gombot, mely aktiválja a következő tabulátort. A módosítások végeztével nyomja meg a Mentés gombot a konfiguráció mentéséhez.

Ha a beállítás billentyűzetbevitelt igényel, betöltheti a számítógép billentyűzetprogramját. Ez kimondottan hasznos olyan érintőképernyős hordozható számítógépeken, amelyeken nincs billentyűzet.


Nyelv

A Tech2Win alkalmazás nyelvét a Nyelv lapon lehet kijelölni. A kijelölt beállítás nem befolyásolja a Tech2 szoftver vagy a PCMCIA-képfájl nyelvét. A Tech2 eszköz nyelvét meg kell adni, amikor letölti a TIS rendszerről.

Egyes régiókban nem áll rendelkezésre az összes nyelv. Ebben az esetben a program az angolt jeleníti meg. Kérjük, ellenőrizze, hogy rendelkezésre áll-e hasonló nyelv (PT Portuguese-Portugal rather than PB Portuguese-Brazil).


Útvonal

A Útvonal lapon a PCMCIA-képfájlok illetve a helyi billentyűzetprogram elérési útvonala adható meg. A Memóriakártya másolása gombbal a PCMCIA-képfájlok másolása végezhető el. Ha éppen most hozott létre egy új konfigurációt, akkor ezzel a gombbal elkerülheti, hogy több konfiguráció is ugyanazt a PCMCIA képet használja.

Memory Card Options

Memóriakártya másolása ...

A gomb lehetővé teszi a PCMCIA-kép átmásolását másik fájlba. A funkciója hasonlít az új PCMCIA-kártya vásárlásához a Tech2 eszköz esetén. A másolás funkció csak a C:\Users\Public\General Motors\Tech2Win\pcmcia könyvtárban elhelyezkedő fájlok esetében működik.

0. bővítőhely: memóriakártyakép helye

Ebben a részben lehet megadni a 0. bővítőhelyen található PCMCIA-képet tartalmazó fájlt. Normális esetben, az ilyen fájlok a C:\Users\Public\General Motors\Tech2Win\pcmcia könyvtárban vannak, azonban máshol is lehetnek.

1. bővítőhely: memóriakártya vagy ATA

A Tech2 eszközhöz hasonlóan a Tech2Win alkalmazás is két PCMCIA-kártyát (képet) támogat. Egy második PCMCIA-képfájl egy konfiguráción belül azonban nem kimondottan hasznos. Második konfigurációban általában második szoftver lenne használva.

A Tech2 készülékhez hasonlóan az ATA-kártya itt is hibakeresési célokat szolgál. Csak akkor engedélyezze az ATA-kártyát, ha az ügyfélszolgálat erre kifejezetten megérte. Az ügyfélszolgálat erről további információkkal szolgálhat.

Számítógép billentyűzetprogramjának helye

Az alapértelmezett értéket a program a Windows rendszerleíró adatbázisából olvassa be, és a billentyűzet egérrel való szimulálására képes programra kell mutatnia. Ha a hordozható számítógépen található külön erre a célra használható alkalmazás, akkor itt lehet megadni az elérési útvonalát.


Gépjármű kommunikációs felület

  • A Tech2 RS232-emuláció COM-portja
  • A használandó MDI sorozatszáma
  • Protokoll

A Tech2 RS232-emuláció COM-portja

Kérem, válasszon egy szabad COM-portot, amely használható a Tech2 emulációhoz. Az Ön kényelme érdekében, a konfiguráló megpróbálja megkeresni és kilistázza a már használatban lévő soros portokat.

Ha egy létező COM-portot választ, a Tech2Win hozzárendeli magát ehhez a létező COM-porthoz. Használhatja ezt a COM-portot a Tech2 szoftver letöltésére egy másik számítógépről, amelye egy TIS alkalmazás fut, egy nullmodem kábel segítségével. A Windows korlátozásai miatt, kérjük, jegyezze meg, hogy a valódi COM-port megtörténhet, hogy nem működik megbízatóan 115.200 baud sebességen.

Ha egy nem létező COM-portot választ, a Tech2Win automatikusan létrehoz egy virtuális portot. Ez a virtuális port használható a TIS alkalmazásból, amely ugyanazon a PC-n fut, a Tech2Win kommunikáció létrehozására. Virtuális port használatakor nincs átviteli sebességkorlátozás.

Ha a 'keresést' választja COM portként, akkor a Tech2Win létrehoz egy virtuális COM portot a 9 és 1 közötti első szabad portszámon.

A használandó MDI sorozatszáma

Adja meg az MDI sorozatszámát. Ez a szám az MDI hátoldalán található. Használja a kötőjel után levő számot.

Ha nem ad meg sorozatszámot, a Tech2Win automatikusan megjeleníti a hálózaton észlelt MDI-k listáját, hogy a felhasználó ezek közül válasszon egyet. Ugyanaz a kiválasztó doboz jelenik meg, ha a megadott MDI nem található.

Protokoll

'ISO22900-2 / PDU-API' a kiválasztott és a J2534-2 mindig szürke. A jövőben a Tech2Win képes lehet a J2534 protokoll támogatására is.

  • Speciális témakörök: Konfigurációs fájl
  • GYIK: Hogyan határozhatom meg, melyik com-portot használjam a Tech2Win alkalmazáshoz?
  • GYIK: Kommunikáció a Tech2Win és TIS2Web között
  • GYIK: Hogyan használhatok egynél több MDI-t?
  • GYIK: Tech2Win nem találja az MDI-met


Kijelző

A Kijelző lapon a Tech2Win alkalmazás megjelenítésére vonatkozó beállítások találhatók:

  • Billentyűzet
  • Színek
  • Hang
Display and Key Options

Billentyűzet

Itt lehet megadni, hogy megjelenjen-e a billentyűzet. A program a Tech2Win képernyőjétől balra vagy jobbra helyezi el a billentyűzetet. A háttérszínt szokásos színválasztó párbeszédpanelen lehet kijelölni.

Színek

A Tech2 képernyő hátterének és előterének színét lehet itt külön megadni. A két leggyakoribb színkombináció:

Screen with background 0000FF, foreground FFFFFF | Fehér billentyűzetháttér; Kék háttér; Fehér előtér
Screen with background 000000, foreground C0C0C0 | Számbillentyűzet háttere kék; Fekete háttér; Világosszürke előtér

Hang

Itt kikapcsolhatja a hangot. A Tech2 program hangjelzései a számítógép csipogóján hallhatóak.


A konfiguráció mentése

Az aktív konfiguráció a bal alsó sarokban található Mentés <konfiguráció> gombbal menthető. A gomb nem jelenik meg, ha írásvédett konfiguráció beállításait tekinti meg.


Érvényes licenc TIS2Web-en keresztül

Normálisan a Tech2 Software letöltése a Tech2Win alkalmazásba, érvényes licencet szolgáltat. Ezenfelül, szerezhet egyet egy 'Védelmi hozzáférés (Biztonság)' végrehajtásával a TIS2Web alkalmazáson keresztül (nem TIS2000). Emiatt előfeltétel a virtuális COM-port választása a Konfigurálón belül, a Gépjármű kommunikációs felület pont alatt.

A sikeres biztonsági hozzáférés után egy nyitott lakat látható at állapotsor jobb oldalán. A zárójeleken belül látható a licenc érvényességi napjainak száma. Ha ismét indítja a Tech2Wint, a biztonsági jelző addig nem jelenik meg, amíg nincs gépjármű kommunikáció. Az első, járművel való kommunikálás alatt, az licence ellenőrzésre kerül és a jelző egy nyitott vagy zárt lakatra vált.

  • A Tech2Win alkalmazás használata:Biztonság
  • GYIK:Hogyan határozhatom meg, melyik com-portot használjam a Tech2Win alkalmazáshoz?
  • GYIK:Kommunikáció a Tech2Win és TIS2Web között
  • GYIK:Érvényes licenc
  • GYIK:Mi a különbség egy Tech2Win licensz és a biztonsági hozzáférés között?


A Tech2Win alkalmazás használata

A következő témakörök a Tech2Win alkalmazást használó legtöbb szerelőt érintik:

  • Menü: A képernyő elrendezése és az egyes menüelemek.
  • PCMCIA lemezkép letöltése: A Tech2Win diagnosztikai szoftverének frissítése hasonló a Tech2 eszköznél használt módszerhez.
  • Biztonság: A biztonsági intézkedéseknek köszönhetően a Tech2Win alkalmazás nem végez gépjármű-kommunikációt hitelesítés nélküli környezetben.
  • Jelentések megtekintése: A Tech2 billentyűzete ki lett egészítve a Tech2Win alkalmazásban. Erre a 'Jelentés megtekintése' gomb a legjobb példa.
  • PCMCIA-képek kezelése: Ahogy a Tech2 eszköz is képes egyszerre több PCMCIA-kártyát kezelni, a Tech2Win alkalmazásban is számos PCMCIA-képfájl használható.
  • Állapotsor: Részletes tudnivalók az állapotsor egyes részeiről.
    • Speciális témakörök
    • GYIK


Menü

A Tech2Win alkalmazás a következő menükkel rendelkezik:

  • Fájl
  • Beállítások
  • Ablakok
  • Súgó

Fájl

A Fájl menü a következő lehetőségeket nyújtja:

  • T2-képernyő mentése (320x240) segítségével menthető el az aktuális T2-képernyő 320x240 pixel méretben, fekete-fehér képfájlként a számítógépen. A elmentés helye és a fájlformátum (BMP, GIF, JPG, PNG) szabadon választható.
  • Képernyő nyomtatás egy fordított fekete-fehér BMP képet készít a Tech2 képernyőről, és behívja a BMP fájlokhoz rendelt programot. Ezzel a programmal kinyomtathatja a képet.
  • A Jelentésfájlok megtekintése lehetőség a jelentésfájlok megtekintését (és nyomtatását) teszi lehetővé a TIS2Web használata nélkül.
  • Az Kilépés bezárja a Tech2Win alkalmazást.

Beállítások

Az Beállítások az alábbi választásokat kínálja:

  • A Felbontás segítségével három standard képernyőméret között választhat.
  • A ROM-Write from 0x00003ED76 belső hibakeresési célokat szolgál.
  • Automatikus képernyőképek, mely minden különböző Tech2 képernyő képét elmenti a napló könyvtárban.
  • CANdi letiltása és újraindítás, mely olyan Tech2-t utánoz, amelynél nincs CANdi a Tech2 és a gépjármű között. Erre azokban a ritka esetekben van szükség, amikor a CANdi megszakítja a nem-szabványos gépjármű kommunikációs vonalakat.

Ablakok

A Ablakok menü segítségével aktiválhatja a Tech2Win adatok megjelenítése és Tech2Win hibakód megjelenítése lehetőségeket. Az összes egyéb választási lehetőség szürkén jelenik meg a tech2Win jelenlegi változatában.

Ha a Tech2 szoftver támogatja a Tech2Win adatok megjelenítése funkciót, akkor engedélyezhető ez a menüelem. Az adatkijelzőbe (Data Display) lépve, a tech2Win egy további adatkijelzőt jelenít meg a Tech2Win adatkijelzőjével párhuzamosan. Amíg a Tech2 képernyő az adatkijelzőt mutatja, addig ez a menüelem nem engedélyezhető. Ebben az esetben ki kell lépnie az adatkijelzőből, engedélyezni a menüelemet, majd újraindítani az adatkijelzőt.

Ugyanazek a korlátozások vonatkoznak a Tech2Win adatok megjelenítése esetében a Tech2Win hibakód megjelenítése kijelzőre. Ha a Tech2 szoftver támogatja a Tech2Win hibakód megjelenítése funkciót, akkor engedélyezhető ez a menüelem. A további hibakódkijelző ablak a Tech2 hibakódkijelzővel párhuzamosan jelenik meg. Amíg a Tech2 képernyő a hibakódkijelzőt mutatja, addig ez a menüelem nem engedélyezhető. Ebben az esetben ki kell lépnie a hibakódkijelzőből, engedélyezni a menüelemet, majd újraindítani a hibakódkijelzőt.

Súgó

A követlkező választások állnak rendelkezésére:

  • A Súgótémakörök... előhívja a Tech2Win Súgót.
  • A Parancssori paraméter megmutatja a Tech2Win alkalmazáshoz használt parancssor paramétereit.
  • Az Névjegy mutatja a Tech2Win aktuális verziószámát TIS2Web letöltési korlátozásait.


Letöltés

Indítsa a Tech2Win alkalmazást és maradjon a főképernyőn. Indítsa el a TIS2Web vagy GlobalTIS alkalmazásokat és végezze el a letöltést a Gépjármű kommunikációs felület fülön megadott COM-porton keresztül.

Beépített COM-portok használatával is lehetséges Tech2 szoftvert letölteni a TIS szolgáltatást használó másik számítógéppel. Ellenőrizze, hogy kereszthuzalos RS232 kábelt használ-e. A Tech2Win alkalmazást futtató számítógép hardverétől függően lehet, hogy az adatátviteli sebességet csökkenteni kell 57 600 baudra, mert a Windows rendszeren adatveszteség léphet fel magasabb átviteli sebesség esetén.

A legújabb Tech2Win verzió egy gyors letöltést is támogat, ahol a TIS2Web és a Tec2Win ugyanazon a számítógépen fut. Ez is használ egy minimális kommunikációt a TIS2Web és a Tech2Win között a COM porton, de egy belső fájlátvitel váltja fel az időigényes adatátvitelt a Tech2Win-be. Ilyen esetekben a letöltési idő jelentősen lecsökken jóval kevesebb mint egy percre.

  • Speciális témakörök: Konfigurációs fájl
  • Első lépések: Gépjármű kommunikációs felület
  • GYIK: Hogyan határozhatom meg, melyik com-portot használjam a Tech2Win alkalmazáshoz?
  • GYIK: Kommunikáció a Tech2Win és TIS2Web között


Biztonság

A Tech2Win által használt biztonsági mechanizmusok a számítógép helye órabeállítására alapozódnak. Kérjük, ellenőrizze, hogy a számítógép órája mindig be legyen állítva. A kismértékű változásokat az időbeállításokon, amelyek a nyári időszámítási napon előfordulhatnak, a Tech2Win elnézi.

A Tech2Win nem hajt végre semmilyen járműkommunikációt egy érvényes és aktív licenc nélkül. Az állapotsorban levő következő jelző a licenc állapotát mutatja:

  • green smiley A licenc érvényes.
  • Nincs jelző: A licenc még nem volt ellenőrizve.
  • red smiley A licenc lejárt.

Licenc szerzéséhez, kérük, hajtson végre 'Védelmi hozzáférés (Biztonság)' frissítést a TIS2Web alkalmazás használatával. Legtöbb esetben a szoftver letöltése a TIS2Web alkalmazással elegendő egy új licenc megszerzéséhez. Lévén, hogy a licenc egy bizonyos idő után (egyes területeken négy hét) érvényét veszti, ezt a frissítést szabályos időközönként el kell végeznie.

A licencek terület/szoftver-specifikusak. Megtörténhet, hogy van licence a számítógépén, ha már használja a Tech2Win alkalmazást más Tech2 szoftver-verzióval.

A licenc lejárásáig hátralevő napok száma az állapotsorban jelnnek meg.

  • ( 0) jelentése, hogy a licenc lejárt vagy nem létezik.
  • (<1) A licenc az elkövetkező 24 órában lejár.
  • (20) A licenc 20 napon belül lejár.

Kérjük, ne módosítsa a licencfájlt. A fájl tisztességtelen módosítását a belső biztonság érzékeli, és a számítógépen levő összes licenc érvényességének elvesztéséhez vezet. Mindezek mellett, a Tech2Win kiszámíthatatlanul fog viselkedni. Ezt csak egy új telepítés elvégzésével lehet megoldani.

  • Speciális témakörök: Hibaüzenetek és kilépési kódok
  • Speciális témakörök: Naplófájl
  • A Tech2Win alkalmazás használata: Állapotablak
  • GYIK: Érvényes licenc
  • GYIK: Mi a különbség egy Tech2Win licensz és a biztonsági hozzáférés között?
  • GYIK: Hirtelen leállítás


Jelentések megtekintése

View Report Ezzel a gombbal tekinthetők meg a PCMCIA-kártyákon tárolt PRT-fájlok tartalma. Megjelenik a PRT-fájlok listáját tartalmazó párbeszédpanel. Ha a PRT kiterjesztéshez hozzá van rendelve program, a rendszer elindítja ezt a programot. Egyéb esetben a kijelölt fájl tartalma a Jegyzettömbben jelenik meg.

Általában a PRT-fájl a nyelvnek megfelelő kódlapot használó ASCII fájl. Kínai, japán, koreai és thai esetén vezető BOM-ot (bájtsorrendjelölést) tartalmazó Unicode kódolású fájl.

Amikor jelentéseket tekint meg, akkor a Tech2Win a C:\Users\Public\General Motors\Tech2Win\reports alkönyvtárral működik. Az alkönyvtár csak akkor létezik, ha már legalább egyszer tekintett meg jelentéseket. A könyvtárt automatikusan törli a rendszer, és ideiglenes munkakönyvtárként működik az aktív PCMCIA-kártyán tárolt PRT-fájlok számára. A könyvtár akkor is tartalmazza a fájlokat, ha a Tech2Win alkalmazás már be lett zárva. Ha jelentésfájlt szeretne elmenteni, másik könyvtárba kell másolnia a fájlt, mert, amint másik felhasználó is megtekinti a jelentéseket, a fájlt felülírhatja a rendszer.


PCMCIA-képek

A PCMCIA képek normális esetben a C:\Users\Public\General Motors\Tech2Win\pcmcia alkönyvtárban helyezkednek el. A fájl méretének pontosan 32 MB-nak (33 554 432 bájt) vagy 10 MB-nak (10,485,760) kell lennie, és *.bin kiterjesztéssel kell rendelkeznie. Ha letöltés történik, vagy a Tech2Win alkalmazás adatot tárol flash kártyán, a rendszer módosítja a képfájlokat (ahogy a szokásos PCMCIA-kártyákkal történne). A módosítás letiltható az írásvédett kapcsolóval (-W0 vagy -W1 utasítás), vagy a 'p' érték elhagyásával a 'W' beállításban.(Konfigurációs fájl). Az írásvédelmi kapcsoló nem érhető el a konfigurátoron keresztül. Manuálisan kell módosítania a konfigurációs fájlt, ha használni szeretné a '-W0', '-W1' vagy '-W' opciókat.


Állapotsor

Az állapotsor a Tech2 képernyő alatt található. Az állapotsoron a következő elemek jelennek meg:

  1. Sebességjelző
  2. A gépjármű-kommunikáció állapota
  3. A soros port állapota
  4. SHIFT gomb
  5. Automatikus képernyőképek
  6. Napló - figyelmeztetés
  7. Licenc

Status Bar

Sebességjelző

A sebességjelző mutatja, hogy a Tech2 szoftver emulációja mennyi processzoridőt vesz igénybe. Egy alacsony érték (jelző a bal oldalon) jobb a magas értéknél (jelző a jobb oldalon). Az érték elfogadható, ha a jelző zöld. Ha különböző Windows-feladatok aktiválódnak, a jelző rövidebb időre sárgára válthat. Az ilyen rendszertevékenységeket érdemes kerülni.

A gépjármű-kommunikáció állapota

A jármű kommunikációs státusz jelzi, hogy a jármű kommunikációs interfész (MDI) jelen van, valamint megvan a kommunikáció a gépjármű és a Tech2Win között.

A soros port állapota

A jelző a COM-port aktivitását mutatja, ha a Tech2Win alkalmazással történő kommunikáció COM-porton keresztül történik.

SHIFT gomb

Ez a jelző mutatja, hogy aktív-e a SHIFT gomb. Átválthatja a billentyűzet 'S' gombjának használatával vagy a SHIFT gombbal.

Automatikus képernyőképek

Az automatikus képernyőkép (Automatic Screenshots) funkció az Beállítások menüben aktiválható. Valahányszor a képernyő változik, egy új képernyőkép fájl tárolódik el a napló könyvtárban. Ezt az állapotsorban látható piros kamera forgatókarjának forgása jelzi. Amint az automatikus képernyőkép funkció kikapcsol, a kamera eltűnik.

Napló - figyelmeztetés

A Naplóállapot jelzőnek három különböző állapota lehet.

  • gray log status indicator A naplófájl nem tartalmaz hibákat vagy figyelmeztetéseket.
  • yellow log status indicator A naplófájl egy figyelmeztetést tartalmaz.
  • red log status indicator A naplófájl egy hibaüzenetet tartalmaz.

Licenc

A licencállapot-jelzőnek három állapota lehet:

  • green smiley A licenc aktív és érvényes.
  • Nincs jelző: A licenc még nem volt ellenőrizve.
  • red smiley A licenc lejárt vagy nem létezik.
További tudnivalók a Biztonság témakörben olvashatók.

Elemleírás az állapotsorban

Egyes elemeknél további információt tartalmazó elemleírások láthatók:

VCI sorozatszám elemleírása:
Tooltip VCI

TECH2 szoftververzió sorozatszáma
Tooltip TECH2

Comport sorozatszáma
Tooltip Comport

A következő képernyőfelvétel számára elemlírása (ha 'Automatikus képernyőképek' aktív)
Tooltip Camera

Az utolsó 'figyelmeztetés' vagy magasabb szintű naplófájl bejegyzést mutató elemleírás
Tooltip Logfile

A pontos licensz időtartam leírása
Tooltip License

Az elemleírások akkor jelennek meg, ha a kurzor 0,5 másodpercig mozdulatlanul az ikonon van Az elemleírás 5 másodperc múlva, vagy ha a kurzort elmozdítjuk, eltűnik.

  • Speciális témakörök: Hibaüzenetek és hibakódok
  • Speciális témakörök: Naplófájl


Speciális témakörök

A Tech2Win alkalmazás normál felhasználói számára az alábbi témakörök kevésbe fontosak. Az alkalmazás telepítésében, kezelésében és konfigurációjában részt vevő felhasználók számára azonban hasznosnak bizonyulhatnak.

  • Újratelepítés
  • Eltávolítás
  • A konfigurációs fájl közvetlen módosítása
  • Naplófájl
  • Hibaüzenetek és kilépési kódok
  • ATA-kártya
  • Bejegyzések a rendszerleíró adatbázisban
  • A fájlok leírása
  • Példák a konfigurációkezelésre


Eltávolítás

A teljes telepítési könyvtár, a felhasználói adatokat tartalmazó könyvtár (C:\Users\Public\General Motors\Tech2Win) és az alkalmazás adatait tartalmazó könyvtár (C:\ProgramData\General Motors\Tech2Win) törölve van.

  • Speciális témakörök: Újratelepítés
  • Telepítés


Konfigurációs fájl

A konfigurációs fájl mindig a C:\Users\Public\General Motors\Tech2Win\config and have the file extension *.conf alkönyvtárban helyezkedik el. Előfordulhat, hogy manuálisan szeretné módosítani a konfigurációs fájlt, mert a Tech2Win alkalmazáson keresztül nem áll rendelkezésre a fájl összes beállítási lehetősége. A konfigurációs fájl vezető BOM-ot (bájtsorrendjelölést) tartalmazó Unicode kódolású fájl. Javasoljuk, hogy manuális módosítások esetén Unicode-kompatibilis szövegszerkesztőt, például Jegyzettömböt használjon.

A konfigurációs fájl sororientált. Az üres sorokat a rendszer figyelmen kívül hagyja. A sorok minden esetben beállítással kezdődnek, amelyet általában érték követ. Példaként tekintse meg a default.conf fájlt. Az alábbi táblázat a rendelkezésre álló beállításokat és a leírásukat tartalmazza.

Ha egy bizonyos konfigurációt közvetlenül az asztalról szeretne indítani, akkor hozzpn létre egy parancsikont, amely futtatja a 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf' állományt. A programot az alábbi munkakönyvtárból kell elindítani: 'C:\Program Files\General Motors\Tech2Win\bin'

Beállítások | Érték/Leírás
; Megjegyzés
@ Tizedes verziószám főverzió.alverzió formátumban.
A Tech2Win verziószámától eltérő főverzióval rendelkező konfigurációs fájlokat a rendszer nem fogadja el. A Tech2Win verziószámánál alacsonyabb alverzióval rendelkező konfigurációs fájlokat a rendszer elfogadja.
-W0
-W1 		A 0/1 bővítőhelyen található PCMCIA-kártyán írásvédett kapcsoló van aktiválva.
-B0
-B1 		A 0/1 bővítőhelyen található PCMCIA-kártya blokkmérete kilobájtban. Az elfogadható értékek 128 (alapérték) vagy 256.
-P0
-P1 		A 0/1 bővítőhelyen található PCMCIA-kártya bináris képét tartalmazó fájl. A fájl méretének pontosan 10MB-nak vagy 32MB-nak kell lennie. A környezeti változók, mint a %ProgramData% ki vannak terjesztve.
Ha a beállítás nincs jelen, a rendszer a bővítőhelyet üresnek tekinti.
-A0
-A1 		A 0/1 bővítőhelyen található PCMCIA-kártya attribútumértékeit tartalmazó fájl. Ha nincs jelen, a rendszer a kártya és a blokkméret alapján meghatározott alapértelmezett attribútumokat használ.
-W | A Tech2Win alkalmazásból való kilépéskor a rendszer a megfelelő fájlokba írja a tartós adatokat. A p/f/r/c értékek kombinálhatók sorrendben a következők jelentésére: PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | Halommemória-kezelési funkció A 0/r/w/t értékek kombinálása használható a nullázás, olvasási ellenőrzések, írási ellenőrzések és feladatellenőrzések aktiválásához. Az l érték mindig a halommemória egy allokációjának kényszerítésére szolgál az alsóbb címeken, egy alternatív allokációs minta megvalósításaként. Normális esetekben ez a lehetőség csak fejlesztői környezetben használatos.
-PC | Régebben az elérési útvonal a PCMCIA kártya másolásához. Ez az opció jelenleg figyelmen kívül van hagyva.
-MS | Jármű kommunikációs interfész (MDI) azonosítása sorozatszámmal. Ha nincs beállítva, a rendelkezésre álló MDI-k listája jelenik meg.
-CT | A szöveg színe (előtér) 3 hexadecimális bájtértékben megadva. Az alapértelmezett érték 000000 (fehér).
-CB | A háttér színe 3 hexadecimális bájtértékben megadva. Az alapértelmezett érték FFFFFF (fekete.)
-ATA | Használja ezt az opciót az ATA rögzítő kártya engedélyezésére. Távolítsa el, hogy letiltsa az ATA rögzítő kártyát.
-C | A Tech2 RS232C kommunikációs portjaként használt COM-port száma (1..9). A Tech2Win alkalmazás által telepített virtuális COM-porthoz gyakran a COM9-es port van hozzárendelve. Ha ez a lehetőség nincs jelen, akkor keressen egy szabad COM portot a COM9-től lefelé. Használja az egérmutatót az állapotsávon a Tech2 ikon és a TIS2Web ikon között, hogy megtekintse, melyik COM port van használatban.
-WR | Egy PC-cím (szokványosan 253558), amely írásra engedélyezett a PCMCIA és FLASH ROM területen. Ezt a funkciót még aktiválni kell a menüben is (vagy a -WA opció használatával). Szükség van rá a kód hibakeresésénél a nem változtatható memóriában a SingleStep hibakeresővel.
-WA | Annak engedélyezése, hogy a SingleStep hibakereső írjon a nem módosítható memóriába.
-OF | Opciófájl, amely tartalmazz az opció/érték párokat.
-TP | Időzítés beállítás (Arányos érték). Alapértelmezett 5000 Csökkentse ezt az értéket, hogy a végrehajtott ciklusok száma gyorsabban alkalmazkodjon a valós időhöz.
-TD | Időzítés beállítás (Különbözeti érték). Alapértelmezett 100 Csökkentse ezt az értéket, hogy gyorsabban reagáljon az azonnali időzítések változására. FIGYELMEZTETÉS: a TP és TD értékek változtatása sebességproblémákhoz vezethet.
-PJ
-PP 		Határozza meg a protokollt, amelyet használni kell:
PJ a J2534 kommunikációhoz.
PP a ISO22900-2 / PDU-API esetében (alapértelmezett)
-S | A beállítás jelenléte hangkimenetet tesz lehetővé a számítógép csipogóján.
-L | A Tech2Win alkalmazás nyelve. Az aktív Windows nyelv van használatban, ha ez a bejegyzés hiányzik. Ha meg szeretné tekinteni a beállítható nyelvek listáját, kattintson a következő hivatkozásra: Nyelvek. A Tech2 emulációs ablak minden, a PCMCIA kártyán levő nyelvet megjelenít (ú.m. amit letöltöttek a PCMCIA kártyára).
-UD | A felhasználói adatok könyvtárának megváltoztatása. Win7 alatt ez normál esetben a C:\Users\Public\General Motors\Tech2Win könyvtárban van.
-AD | Az alkalmazás adatkönyvtárának megváltoztatása. Win7 alatt ez normál esetben a C:\ProgramData\General Motors\Tech2Win könyvtárban van.
-US | Felhasználóspecifikus jelzés használata a Tech2Win több mint egy példányának észleléséhez. Ez az opció lehetővé teszi az egyes felhasználóknak a Tech2Win párhuzamos futtatását ugyanazon a gépen, jellemzően egy kiszolgálón. Amikor ezt az opciót használja, akkor az -UD és -AD opciókat is meg kell adnia.
-SS | A Tech2Win ablak teljes méretének, beleértve a billentyűzetet is (ha van) megadására szolgáló opció. Az első paraméternek idézőjelek (') közötti karakterláncnak kell lennie és a méret neveként fog szolgálni az Beállítások / Felbontás menüben. A második paraméter a Tech2Win képernyő vízszintes képpontjainak száma a számbillentyűzetet is beleértve. A harmadik paraméter a Tech2Win képernyő függőleges képpontjainak száma. A negyedik, opcionális paraméter a számbillentyűzet szélessége képpontokban.
-SH A képernyőkezelés szabályozásának opciója. Az alábbi tizes számrendszerbeli szám adja meg, hogy mely képernyőkezelési lehetőségek legyenek kiiktatva.
  • 0. bit: Nem lehetséges min./max. érték.
  • 1. bit: Nem lehetséges áthelyezés a képernyőn.
  • 2. bit: Nincs átméretezés. Ebben az esetben a Beállítások / Felbontás menü ki van szürkítve.
  • 3. bit: Az adatkijelző és DTC (diagnosztikai hibakód) ablakok pontosan megegyeznek a Tech2Win méretével (a számbillentyűzet nélkül).


Naplózás

A Tech2Win konfiguráció minden indítása egy új, HTML formátumú naplófájlt készít a C:\Users\Public\General Motors\Tech2Win\Logs alkönyvtárban. A merevlemez túlterhelésének elkerülése végett az egy hétnél régebbi naplófájlok törlődnek.

A naplófájlok elnevezése automatikusan történik a létrehozásuk dátuma (év, hónap, nap) és időpontja (óra, perc, másodperc) alapján:
éééé-hh-nn_óóppmm.html

A naplófájlbejegyzések mindig angol nyelven készülnek, de Unicode formátumban és vezető BOM-ot (bájtsorrendjelölést) tartalmaznak. A naplófájl minden sora a következő naplószintek egyikébe tartozik:

Naplószint | Leírás
Info (Információ) | Csak tájékoztató. Nincs hatással a program végrehajtására.
Warning (Figyelmeztetés) | Szokatlan esemény történt. A felhasználó nem biztos, hogy tapasztal kedvezőtlen hatásokat.
ERROR | A felhasználó számára észrevehető hiba történt.
CRITICAL | A program hibás működését okozó kritikus hiba történt.
FATAL | Végzetes hiba, amely a Tech2Win alkalmazás azonnali leállását okozza.

Minden 'Figyelmeztetés' feletti szint színes, hogy könnyen meg lehessen találni.

Emellett, ha használták a Képernyő nyomtatás vagy az Automatikus képernyőképek menüopciókat, Nyomtatás és Video fájlok lesznek a Logs alkönyvtárban.
éééé-hh-nn_óóppmm_print_nnnnn.bmp
éééé-hh-nn_óóppmm_video_nnnnn.png
A HTML fájl Automatikus képernyőképek (automatikus képernyőfelvétel) képeket linkel - a képek sorozata megtekinthető a HTML naplóban.

A felhasználót a rendszer az állapotsorban tájékoztatja a figyelmeztetésekről ( yellow lightning bolt) és a súlyosabb naplóbejegyzésekről ( red lightning bolt).


Hibaüzenetek és kilépési kódok

Előfordulhat, hogy hibaüzeneteket tartalmazó párbeszédpanelek jelennek meg. A párbeszédpanelek megjelenése mellett a Tech2Win párhuzamosan tovább működteti a Tech2 programot. A kilépési kódok végzetes hibák, amelyek a Tech2Win alkalmazás szabálytalan leállását okozzák. A kilépési kódok kötegelt fájlokban használhatók a program leállási okának meghatározására.

Hibaüzenetek

Az alkalmazásban a következő hibaüzenetek fordulhatnak elő. Az alábbi táblázatban olvashatók a hibaüzenetek, a leírásuk és a lehetséges megoldások.

Emulator too slow Emulator failed to start

Kilépési kódok

Kilépési kód | Érték | Leírás
OPCODE_ERROR | -7 | A rendszer érvénytelen utasítást érzékelt a Tech2 mikroprocesszortól (68332). Előfordulhat, hogy a PCMCIA-kártya képe megsérült.
ATA_PROBLEM | -6 | Probléma történt az ATA-emuláció közben. Ha ilyen problémával találkozik azután, hogy az ATA-kártya használatára lett utasítva, kérjük forduljon az ügyfélszolgálathoz.
DEMO_TIME_IS_UP | -5 | Nem szabadna előfordulnia a Tech2Win alkalmazás hivatalos verziójában.
DLL_NOT_LOADED | -3 | A szükséges DLL-fájlok egyikét nem lehetett betölteni. Úgy tűnik, hiányos a Tech2Win alkalmazás példánya. Telepítse ismét az alkalmazást és/vagy válasszon másik nyelvet.
EXIT_INIT_FAILED | -2 | Az inicializálás nem sikerült. A pontos okért tekintse meg a naplófájlt. Ha nem létezik a naplófájl, ellenőrizze, hogy az összes könyvtárhoz megfelelő írási és olvasási jogokkal rendelkezik-e.
normális | 0 | A Tech2Win alkalmazás normálisan állt le.


ATA-kártya

A Tech2 készülékben található ATA-kártyát általában csak diagnosztikai célokra használják a szoftver fejlesztése alatt. Az összes szükséges ATA adat a C:\Users\Public\General Motors\Tech2Win\ataCapture alkönyvtárban van. A könyvtár általában nem kiemelt fontosságú és nyugodtan törölhető, kivéve, ha ellenkező képen rendelkeznek.

Mivel az ataCapture könyvtár rögzített, a tártalma minden konfiguráció esetén megegyezik.


Fájlok

A Tech2Win alkalmazás a következő fájlokat és könyvtárakat használja:

Könyvtár | Vista előtti hely | Vista és az utáni hely
Telepítés | A telepítés során megadottak szerint
Felhasználói adatok | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Alkalmazás adatai | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Fájl | Leírás
[Felhasználói adatok]\atacapture | Olyan fájlokat tartalmaz, amelyek jelen vannak az ATA kártyán. Ha más utasítás nincs, törölje ezeket a fájlokat, mert nem szükségesek.
[Telepítés]\bin | Az alkalmazás végrehajtásához szükséges tényleges végrehajtható fájl, DLL és képfájlokat tartalmazza.
[Telepítés]\bin\emulator.exe | A Tech2 kódot futtató fő végrehajtható fájl.
[Telepítés]\bin\emulator_xx_XX.dll | Nyelvspecifikus forrás DLL.
[Telepítés]\bin\T2Configurator.exe | A Tech2Win konfigurációs része.
[Telepítés]\bin\Pictures | A Tech2Win alkalmazáshoz szükséges ikonokat tartalmazza.
[Felhasználói adatok]\config | Tartalmaz minden konfigurációs fájlt.
[Felhasználói adatok]\data | A Tech2Win végrehajtása közben módosított fájlokat tartalmazza. A fájlok szükségesek a Tech2Win alkalmazás megfelelő működéséhez. Normál esetben a fájlokkal nincs tennivaló, hacsak erre kimondottan nem kapott utasítást.
[Alkalmazás adatai]\data | A Tech2Win végrehajtása közben módosított fájlokat tartalmazza. A fájlok szükségesek a Tech2Win alkalmazás megfelelő működéséhez. Normál esetben a fájlokkal nincs tennivaló, hacsak erre kimondottan nem kapott utasítást.
[Alkalmazás adatai]\data\emulator.sec | Biztonsági fájl . Ezt a fájlt ne módosítsa.
[Alkalmazás adatai]\data\emulator.card | Kártyafájl. Tartalmaz minden, a Tech2Win program által ismert PCMCIA kártyát. Ezt a fájlt ne módosítsa.
[Felhasználói adatok]\data\emulator.disp | A fájl tartalmazza a Tech2Win képernyőjének helyzetét és méretét. A fájl törlése esetén, a rendszer ismét létrehozza a fájlt, és a Tech2Win alkalmazás képernyője a bal felső sarokban, 640x480 méretben fog megjelenni.
[Alkalmazás adatai]\data\emulator.lic | Licencfájl. Információt tartalmaz a licencei érvényességének időtartamáról. Ezt a fájlt ne módosítsa.
[Alkalmazás adatai]\data\emulator.rtc | Valós idejű óra fájl. A fájlt a rendszer a Tech2 valós idejű órájában található adatok tárolására használja.
[Alkalmazás adatai]\data\emulator.dta | Egy 'Ne figyelmeztessen újra' információs fájl.. Ez a fájl azokat a PCMCIA szoftververziókat tartalmazza amelyek (többé) nem jelenítik meg a figyelmeztetést azoknak az ellenőrzéseknek az elvégezhetetlenségéről, amelyek visszacsatolt adaptert igényelnek.
[Alkalmazás adatai]\data\candi.bin | CANdi alkalmazásfájl. A Tech2 eszközhöz kapcsolt CANdi alkalmazást tartalmazza.
[Alkalmazás adatai]\data\eprom.bin | Tech2 belső EPROM fájl. A belső Tech2 flash memória tartalmát tartalmazza.
[Telepítés]\driver | Telepítőfájlok a virtuális COM-port illesztőprogramhoz.
[Telepítés]\help\emulator_xx_XX.chm | Nyelvspecifikus súgófájlok.
[Felhasználói adatok]\Logs | Naplófájlokat tartalmaz. Az egy hétnél régebbi fájlok automatikusan törlődnek.
[Felhasználói adatok]\pcmcia | A PCMCIA-képfájlokat tartalmazza. Tulajdonképpen minden egyes fájl egy Tech2 PCMCIA-kártyának felel meg. A fájlok tetszés szerint átmásolhatók más helyre.


Konfiguráció-kezelés

A konfigurációs fájl mindig a C:\Users\Public\General Motors\Tech2Win\config alkönyvtárban helyezkedik el és *.conf kiterjesztésű. A Tech2Win alkalmazás csak új konfigurációs fájlok létrehozására vagy nem írásvédett konfigurációs fájlok módosítására használható. A konfigurációs fájlokkal végzett minden további művelethez Windows Intéző vagy hasonló fájlkezelő program használata ajánlott. Ez a következő műveletek esetén szükséges:

  • a konfigurációs fájlok törlése
  • a konfigurációs fájlok átnevezése
  • a konfigurációs fájlok írásvédett attribútumának módosítása

Javasoljuk, hogy mindig legyen egy default.conf konfigurációs fájl a könyvtárban. Az esetleges felülírás elkerülése érdekében ajánlott a fájl írásvédett beállítását engedélyezni. A fájl módosításához azonban ideiglenesen el kell távolítani az attribútumot.

A PCMCIA képek a C:\Users\Public\General Motors\Tech2Win\pcmcia alkönyvtárban vannak. Minden képfájl egy PCMCIA-kártyának felel meg, amelyet már ismer a Tech2 eszközzel végzett munkából. A Tech2Win alkalmazás korlátlan számú képfájl létrehozását támogatja. Egyszerűen csak másolja a létező képet új fájlnévre.

Ha egy bizonyos konfigurációt közvetlenül az asztalról szeretne indítani, akkor hozzon létre egy parancsikont, amely futtatja a "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf" állományt. A programot az alábbi munkakönyvtárból kell elindítani: 'C:\Program Files\General Motors\Tech2Win\bin'

A konfigurációs fájlok számát nem befolyásolja a használt PCMCIA-képek száma. Számos konfigurációs fájl használhatja egyazon PCMCIA-képet. Ez hasonlít arra a helyzetre, amikor a szervizben több szerelő használja ugyanazt a Tech2 készüléket (és egyazon PCMCIA-kártyát).

Beállíthatja azonban azt is, hogy minden egyes konfiguráció saját PCMCIA-képet használjon. Ezáltal az egyes konfigurációs egymástól még függetlenebbek lesznek. A PCMCIA-képfájlok frissítésével járó erőfeszítés viszont nem minden esetben elfogadható.

Amikor új konfigurációs fájlt hoz létre vagy egy létezőt másol, akkor a konfigurátor megjelenít egy figyelmeztetést, ha a PCMCIA kép nem változott meg. Ilyen esetekben két konfiguráció használja ugyanazt a PCMCIA képet. Ha ez az amit szeretne, akkor egyszerűen nyomja meg az OK gombot. Ha azt szeretné, hogy az új konfiguráció ettől eltérő vagy új PCMCIA képet használjon, akkor nyomja meg a Mégse gombot. Ezután létrehozhat egy új képet a Memóriakártya másolása ... használatával.

Alább két módszert olvashat a konfigurációk és a PCMCIA-képfájlok kezelésére:

Felhasználónként egy konfiguráció

Lehetősége van felhasználónként egy konfiguráció elmentésére. A konfiguráció neve lehet például a felhasználó neve. Ennek a rendszernek az előnye az, hogy lehetőség van a felhasználónak sajátos beállításokra, pl. személyes jármű kommunikációs interfészek (MDI-k), kijelző és nyelvbeállítások. A hátránya, hogy át kell másolnia a PCMCIA fájlokat, ha több felhasználó használja ugyanazt a szoftvert. Természetesen, a felhasználóspecifikus konfigurációk használhatnak egy központi PCMCIA fájlt.

Tech2 alkalmazásonként egy konfiguráció

Választhatja, hogy új konfigurációt készítsen minden letöltött szoftvernek. Így akár a régebbi szoftververziók is azonnal rendelkezésre állnak, ha szükség van rá. Gyakran a szoftvernév és a verziószám az, amit ilyen esetben a konfiguráció nevének választanak.

  • Első lépések: Gépjármű kommunikációs felület
  • Első lépések: Útvonal
  • Speciális témakörök: Konfigurációs fájl
  • Telepítés: A telepítés lépései


Gyakran ismételt kérdések (GYIK)

  • Hogyan határozhatom meg, melyik com-portot használjam a Tech2Win alkalmazáshoz?
  • Kommunikáció a Tech2Win és TIS2Web között
  • Érvényes licenc
  • Mit jelez a licencszám?
  • Mi a különbség egy Tech2Win licensz és a biztonsági hozzáférés között?
  • A TIS2Web meghatározatlan hibát jelenít meg az eredeti szoftver biztonsági hozzáférésének végrehajtásakor
  • A Tech2Win nem futtatja a Tech2 szoftvert egy másik területről
  • Hogyan használhatok egynél több MDI-t?
  • A naplófájl a következő hibát tartalmazza: 'CPU32: Too many 0000/FFFF Commands encountered'
  • Nincs látható Tech2 ablak
  • SPS nem működik
  • Egyes önellenőrzések nem működnek.
  • A sebességjelző ingadozik
  • Hirtelen leállítás
  • A 15.001 verziójú szoftver svédül van
  • Megszakadt a kommunikáció az MDI-vel
  • Tech2Win nem találja az MDI-met
  • Közvetlenül szeretném indítani a Tech2Win alkalmazást anélkül, hogy a konfigurátorral kellene bajlódnom
  • Hol vannak a nyomtatási funkciók?
  • A sajátgépben van egy 'nem használt' PCMCIA könyvtár.
  • Az 'illegal filepath' érvénytelen elérési útvonal üzenetet kapom

Hogyan határozhatom meg, melyik com-portot használjam a Tech2Win alkalmazáshoz?

Használhatja a Windows 'Eszközkezelő'-t, keresse a 'Portok (COM&LPT)' alpontot. De egyes számítógépen belső modem, vagy bluetooth eszköz van telepítve, amelyek nem jelennek meg ebben a kategóriában.
Egy másik módszer egy, a konfigurálóval érkezett, kis parancs használata. Ezt a Start menün (Tech2Win mappa) keresztül futtathatja, a 'show com ports' parancsra kattintva.
Mindkét módszer megmutatja a számítógépén telepített COM-portokat, amelyeket NEM szabad használni.

Kommunikáció a Tech2Win és TIS2Web között

Fontos, hogy a Tech2Win fusson, mielőtt megkezdené a kommunikációt a TIS2Web alkalmazással biztonsági hozzáférés, vagy szoftver letöltése céljából. A TIS2Web csak akkor ismeri fel a vituális COM-portot, ha a Tech2Win el van indítva.

Érvényes licenc

Normálisan a szoftver letöltése a TIS2Web-ről már szolgáltat érvényes licencet. Ha még mindig nem rendelkezik licencszel, akkor 'Védelmi hozzáférés (Biztonság)' végrehajtására van szükség a TIS2Web alkalmazáson keresztül (nem TIS2000), hogy érvényes licenchez jusson. Kérjük, ne hajtson végre semmilyen más TIS2Web kommunikációt, például 'Szoftver letöltés (SWDL)' eljárást, a Tech2Win használatával, mielőtt licencet szerezne 'Védelmi hozzáférés (Biztonság)' végrehajtásán keresztül.

Mit jelez a licencszám?

Az állapotsor jobb szélén látható licencszám a teljes licencnapok számát mutatja. Közvetlenül a letöltés vagy biztonsági hozzáférés kivitelezése után a szám 30 napot mutat. A Tech2Win újraindítása után azonban 29 látható, mivel a licenc időtartama 29 nap, 23 óra és 55 perc körül van. Ha a licencnapok száma 24 óra alá ér, a <1 licencidőtartam látható. Ha a licenc lejárt, 0 látható.

Mi a különbség egy Tech2Win licensz és a biztonsági hozzáférés között?

A Tech2Win licensz engedélyezi a Tech2Win használatát. Ahhoz hogy hozzájusson ehhez a licenszhez, rendszeres időközönként (általában 30 naponként) le kell töltenie a szoftverfrissítést vagy a biztonsági hozzáférést. A képesség, hogy ezeket a letöltéseket a TIS2Weben keresztül el tudja végezni, tájékoztatja a Tech2Wint, hogy érvényes felhasználó van jelen. A biztonsági hozzáférés, mint a Tech2-ből ismeretes, tájékoztatja a Tech2Win alkalmazást, hogy bizonyos biztonsággal kapcsolatos tevékenységek, például egy légzsák kiiktatása, engedélyezettek. Mind a Tech2Win licensz, mind a biztonsági hozzáférés a TIS2Web biztonsági hozzáférés alkalmazáson keresztül kivitelezhető. A Tech2Win a licensz maradék élettartamát az állapotsor jobb oldalán mutatja. Sajnos, a Tech2Win nem tudja mutatni a biztonsági hozzáférés időtartamát, mivel a Tech2Win csak végrehajtja a Tech2 szoftvert, de nem érti magát a Tech2 szoftvert.

A TIS2Web meghatározatlan hibát jelenít meg az eredeti szoftver biztonsági hozzáférésének végrehajtásakor

A viselkedés ugyanaz mint a Tech2 esetében. A kiinduló szovfter kora miatt nem képes licenszhez jutni a TIS2Web alkalmazásból. Azonban, ez nem tényleges probléma, mert a bemutató szoftver nem kommunikál járművel, amelyhez licenszre lenne szükség. Ezen kívül, mivel a licenszek TIS2Web letöltés specifikusak, mindenképpen licenszet kell beszereznie az egyes letöltésekhez, miután letöltötte a Tech2 szoftvert. A kezdő szoftver 'licensze' nem jogosítja fel járműkommunikáció végrehajtására egy észak-amerikai vagy Opel/Vauxhall szoftverrel.

A Tech2Win nem futtatja a Tech2 szoftvert egy másik területről

Az Ön Tech2Win verziója valószínűleg egy vagy több TIS2Web letöltésre (területek) korlátozódik. Az Ön Tech2Win verziójához tartozó korlátozásokat a Súgó / Névjegy megnyomásával tekintheti meg. A Tech2Win korai változatai csak Opel/Vauxhall szoftver végrehajtását engedik. További GM régiók következnek. Mindenesetre, a Tech2Win jelenleg a General Motors Tech2 szoftverének futtatására alkalmas.

Hogyan használhatok egynél több MDI-t?

Ha meghatározott felhasználóknak meghatározott MDI-ket akar megadni, akkor javasoljuk, hogy minden felhasználónak legyen saját konfigurációja. Ezeket a konfigurációkat nyilvánvalóan a hozzájuk tartozó felhasználónak megfelelően kell elnevezni. Minden egyes konfigurációban meg kell adni a felhasználóra vonatkozó MDI sorozatszámát a 'Gépjármű kommunikációs felület' fülön. Amint a felhasználó megkezdi a konfigurációját, a Tech2Win megpróbál kapcsolatba kerülni a meghatározott MDI-vel Csak akkor jelenik meg a Tech2Win által fellelhető összes MDI-t kiválasztó doboz, ha ez a meghatározott MDI nincs meg.

Ha több általános felhasználású MDI van, javasoljuk, hogy olyan konfigurációkat használjon, ahol a Gépjármű kommunikációs felület sorozatszáma a 'Gépjármű kommunikációs felület' fülön üresen maradt. Ekkor a felhasználó mindig látni fogja az MDI-k kiválasztó dobozát.

A naplófájl a következő hibát tartalmazza: 'CPU32: Too many 0000/FFFF Commands encountered'

A 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' fájl vagy az aktuális pcmcia fájl sérült. Kérjük, végezze el a Tech2Win újratelepítését és töltsön le egy új Tech2 szoftvert.

Nincs látható Tech2 ablak

Ha nincs látható Tech2 ablak, ez valószínűleg egy olyan területen van, amely nincs a kijelzőn. Ilyen effektusokkal akkor fog találkozni, ha több képernyőt használ, vagy a képernyő felbontásának módosítása után. Nyomja meg a Shift gombot a billentyűzeten a konfiguráció indítása alatt. Ebben az esetben az ablak felbontása visszaáll 640x480-ra és a Tech2 ablak a képernyő bal felső sarkában jelenik meg. A C:\Users\Public\General Motors\Tech2Win\emulator.disp törlésével is ugyanezt az eredményt érheti el.

Találkoztunk olyan esetekkel, amikor a Tech2 ablak, az összes többi alkalmazás ablakainak bezárása utána, egyszerűen nem rajzolódott ki ismét a képernyőn. Minden esetben, amivel eddig találkoztunk, a Windows alkalmazások közt kapcsoló Alt-Tab billentyűkombináció segítségével elő lehetett hozni a Tech2 képernyőt. A számítógép képernyőjének alsó részén található Taskbar-on lévő Tech2Sin gomb megnyomása néha nem működik. Még fejlesztjük ezt a részt, és reméljük, hogy a Tech2Win egy későbbi verziójában már lesz megoldás rá.

SPS nem működik

Igen, tudjuk. Ennek megváltoztatását nem tervezzük. Ne használja az SPS elvégzésére a Tech2Win-t a Tech2 helyett. Kérjük, használja az MDI-t közvetlenül SPS programozással a TIS rendszeren keresztül.

Egyes önellenőrzések nem működnek.

A Tech2 önellenőrzések célja a Tech2 hardver különböző részeinek tesztelése. Egyes ellenőrzésekhez visszacsatolt adapter használata szükséges. Ezek az ellenőrzések nem működnek a Tech2Win alkalmazásban, mert a visszacsatolt adapter működése nincs kivitelezve (és nincs is tervbe véve). Kérjük, tartózkodjon ilyen értelmetlen ellenőrzések végrehajtásától a Tech2Win alkalmazásban. Ha végrehajtja ezeket, hibás eredményeket kaphat vagy a Tech2Win lefagy, akár csak a Tech2 tenné visszacsatolt adapter nélkül. Ilyen esetben állítsa vissza Tech2Win alkalmazást a Ctrl-R billentyűkombinációval.

A sebességjelző ingadozik

Az állapotsor bal alsó részében látható sebességjelző mutatja hány 'Tech2 parancs' futtatható mielőtt a Tech2Winnek ismét 'aludnia' kell. Ez a módszer biztosítja, hogy a Tech2Winen töltött idő megfelel a valós időnek: gyorsabb számítógépek többet alszanak, mint a lassabbak. Ha a sebességjelző ingadozik, akkor lehet, hogy más alkalmazások használják a számítási teljesítményt, vagy a számítógép órája változik. Nagy ingadozások negatív hatással vannak a gépjármű kommunikációra és a TIS2Web kommunikációra. Győződjön meg arról, hogy más alkalmazás nem fut.

A legtöbb laptop, az akkumulátor idő megnövelése érdekében, képes a CPU óra automatikus csökkentésére. Ez is okozhatja a Tech2Win által észlelt sebesség ingadozást. Ilyen esetben ne akkumulátorról, hanem külső energiaforrásról működtesse a laptopját. Megpróbálhatja megváltoztatni az energia beállításokat is, hogy a működő rendszer ne csökkentse az óra sebességét.

Hirtelen leállítás

Ha a naplófájlban nem talál okot, amiért a program leállt, lehetséges, hogy a Tech2Win belső biztonsági mechanizmusa aktiválódott. Kérjük, ne módosítsa a következő fájlokat: emulator.sec, emulator.lic, emulator.card. Ha a Tech2Win a biztonság megsértését észleli, nagyon valószínű, hogy újratelepítést kell végezzen.

A 15.001 verziójú szoftver svédül van

A Tech2Winnel érkező kezdő szoftver egy bemutatószoftver, amelyet minden új PCMCIA kártya tartalmaz. A TIS2Web azt mutatja, hogy ez svéd nyelvű, mivel a TIS2Web a demo szoftver által támogatott négy nyelvet (angol, francia, német, svéd) tartalmazó listából csak az utolsó nyelvet mutatja. Ahhoz, hogy a bemutató szoftver a frissebb diagnosztikai szoftverrel felülírja, használja a 'Szabvány' frissítési mód helyett a 'Egyéni' módot.

Megszakadt a kommunikáció az MDI-vel

Az MDI kommunikáció megszakadásának számos oka lehet.

  • Rossz kábelkapcsolat (akár Ethernet, akár USB).
  • Megbízhatatlan vezeték nélküli kapcsolat.
  • A számítógép készenléti állapotba kapcsol.

Tech2Win nem találja az MDI-met

Ellenőrizze az alábbi pontokat:

    1. Az MDI aktív?
    2. Működik az MDI Manager?
    3. Az MDI-t egy másik alkalmazás, például az SPS használja?
Az MDI Managert indíthatja az asztali ikonról vagy a startmenüből: 'Start/Minden program/General Motors/GM MDI szoftver' (Start/All Programs/General Motors/GM MDI Software).: Ha a 2. pont nem működik, hívja fel az ügyfélszolgálati központot.

Közvetlenül szeretném indítani a Tech2Win alkalmazást anélkül, hogy a konfigurátorral kellene bajlódnom

Futtassa a "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf" állományt. Használja az alábbi munkakönyvtárat: 'C:\Program Files\General Motors\Tech2Win\bin' Mindig használhatja a konfigurátort a konfiguráció változtatásához.

Hol vannak a nyomtatási funkciók?

A Tech2Win nem rendelkezik nyomtatási funkcióval. Ehelyett ideiglenes fájlokat hoz létre és meghívja a fájlkiterjesztéshez társított alkalmazást. Ezek a programok használhatók nyomtatási célokra, lehetővé téve a nyomtatási kép megjelenésének beállítását.

Print Report | Print Report

A pillanatnyi Tech2Win képernyő nyomtatásához, használja a Fájl / Képernyő nyomtatás menüpontot vagy a billentyűzet nyomtatót ábrázoló gombját. Ha több Tech2Win képernyőt szeretne kinyomtatni, akkor az Beállítások / Automatikus képernyőképek menüponttal PNG fájlokat hozhat létre az összes Tech2Win képernyőhöz. Ezek a PNG fájlok a naplófájlba vannak ágyazva.

Az adatkijelző tartalmakat is kinyomtathatja (a Ablakok / Tech2Win adatok megjelenítése menüelem használatával aktiválva). Használja a Nyomtatás/HTML start gombot az adatgyűjtés indításához, majd leállításához. Az adatgyűjtés leállítását követően megnyílik a HTML fájlokhoz társított alkalmazás (általában Internet Explorer), amely számos funkciót tartalmat az adatok nyomtatásához.

Data Display | Data Display

A sajátgépben van egy 'nem használt' PCMCIA könyvtár.

A Tech2Win korábbi verziói mindig rendelkeztek egy duplikált tárolóval a PCMCIA fájlok számára egy külön könyvtárban. Ez a könyvtár gyakran volt a C:\PCMCIA. Ez a könyvtár már nincs használatban, mert a TIS2Web gyors adatletöltése ezt a második tárolóhelyet szükségtelenné teszi. Ezt a könyvtárat biztonságosan törölheti.

Az 'illegal filepath' érvénytelen elérési útvonal üzenetet kapom

Úgy tűnik, hogy a fájlnév érvénytelen karaktereket, például százalékjelet (%) tartalmaz. Ha közvetlenül a telepítést követően látja ezt a problémát, akkor a legegyszerűbb eltávolítani és újratelepíteni a szoftvert. A legtöbb esetben ez megoldja a problémát.

A normál telepítés során a 'Tech2WinUserData' környezeti változó a 'PUBLIC' értékre (a >= Vista Windows verziók esetében) és az 'ALLUSERSPROFILE\Documents' értékre (A Vista előtti Windows verziók esetében) van állítva. Bizonyos ritka esetekben a környezeti változó értéke nem kerül beállításra a telepítési eljárás során, de második alkalommal megfelelően működik. A környezeti változó értéke manuálisan is beállítható. Kérje meg rendszergazdáját, hogy segítsen Önnek, ha nem tudja, hogyan kell beállítani a környezeti változót.


Bejegyzések a rendszerleíró adatbázisban

A telepítő a következő bejegyzéseket hozza létre a rendszerleíró adatbázisban. A bejegyzéseket ne módosítsa manuálisan. A rendszerleíró kulcsok kezelése közben vegye figyelembe a szokásos Windows figyelmeztetéseket.

rendszerleíró kulcs | név | típus | leírás
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Belső verziószám
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Nyelv | REG_SZ | a telepített nyelv
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | A PCMCIA másolási könyvtárainak elérési útvonala
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Root | REG_SZ | telepítési útvonal
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | EltávolításOpció | REG_DWORD | Eltávolítás beállítása
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | A konfigurációs fájl verziója
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | A virtuális COM-port illesztőprogramjának verziója
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | A szoftver neve a Programok hozzáadása/eltávolítása listában.
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Az eltávolító program elérési útvonala


Újratelepítés

Az eltávolítás törli a Tech2Win teljes telepítési könyvtárát az alábbi kivételekkel.

  1. a konfigurációkat tartalmazó config alkönyvtár nem kerül törlésre.
  2. A normál esetben a PCMCIA képeket tartalmazó pcmcia alkönyvtár nem kerül törlésre.
  3. A hibakeresési információkat tartalmazó ATA alkönyvtár nem kerül törlésre.
A konfigurációs fájlok inkompatibilissá válhatnak: nincs arra garancia, hogy a régebbi Tech2Win alkalmazás konfigurációs fájljait képes olvasni a Tech2Win újabb verziója. A PCMCIA-képfájlok esetében elvileg nem fordulhat elő inkompatibilitás.

Az újratelepítés nem érinti a másodlagos PCMCIA-könyvtárat.

Egyes környezetekben előfordulhat a Tech2Win alkalmazás új verzióinak automatikus telepítése. Mivel a rendszer a rendszerleíró adatbázisban tárolja az utolsó telepítés adatait, az újratelepítésnél alapértelmezettként ezek az adatok lesznek felkínálva.

Kényszerítheti a Tech2Win újratelepítését a enable reinstallation parancsfájl használatával. Ez a parancsfájl a Tech2Win alkalmazással együtt kerül telepítésre. Alapjában véve, ez a parancsfájl egyszerűen a rendszerleíró adatbázis HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win CurrentVersion kulcs értékét '1.000'-re állítja.