Korisnički priručnik za Tech2Win

Dobrodošli u korisnički priručnik za Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Sva prava pridržana.

  • Uvod:
  • Licenca:
  • Instalacija:Opis instalacije aplikacije Tech2Win.
    • Koraci instalacije
    • Sučelje za komunikaciju s vozilom
  • Prvi koraci
    • Odabir konfiguracije
      • Tipkovnica
      • Rukovanje sustavom Windows
    • Nove konfiguracije
    • Mijenjanje konfiguracija
      • Jezik
      • Staza
      • Prikaz
      • Spremanje konfiguracije
    • Pribavite valjanu licencu za Tech2Win.
  • Rad s Tech2Win: Detalji svakodnevnog rada.
    • Izbornik
    • Preuzimanje PCMCIA preslike
    • Zaštita
    • Pregled izvješća
    • Rukovanje PCMCIA preslikama
    • Statusna traka
  • Napredne teme: Informacije nisu potrebne za normalnu upotrebu Tech2Win. Često potrebno samo osobama s administrativnim zadacima.
    • Reinstalacija
    • Deinstalacija
    • Format konfiguracijske datoteke
    • Datoteka zapisa
    • Poruke o pogreškama i kôdovi pogrešaka
    • ATA kartica
    • Unosi registra
    • Datoteke
    • Upravljanje konfiguracijom
  • FAQ


Uvod

Tech2Win je Windows aplikacija koja može emulirati funkcionalnost Tech2. U osnovi se softver Tech2 izvodi na računalu. Da biste pokrenuli ovaj program vaše računalo mora zadovoljavati sljedeće tehničke uvjete.

  • Mora biti instalirano sučelje za komunikaciju s vozilom te isto mora biti priključeno na računalo. Popis prihvatljivih sučelja razlikuje se od regije do regije. U većini slučajeva koristi se GM-ovo MDI sučelje (Višestruko dijagnostičko sučelje).
  • Aplikacija Tech2Win zahtijeva 150 MB prostora na tvrdom disku tijekom instalacije. Potrebno je dodatnih 32 MB za svaku PCMCIA flash karticu kojom želite rukovati.
  • Prije izvođenja aplikacije Tech2Win potrebno vam je najmanje 100 MB slobodne stvarne RAM memorije. Vaše računalo obvezno mora imati dovoljno memorije za držanje aplikacije u RAM memoriji tijekom izvođenja.
  • Vaše računalo treba imati procesor snage 1,2 GHz Pentium (jedna jezgra). Svakako preporučujemo da istovremeno ne koristite druge aplikacije.
  • Tipkovnica nije potrebna. Aplikacijom Tech2Win možete rukovati putem zaslona osjetljivog na dodir. Za upravljanje konfiguracijom svakako preporučujemo upotrebu tipkovnice jer ćete trebati unositi nazive datoteka.
  • Vaš zaslon u boji mora biti najmanje razlučivosti 800x600 uz minimalnu dubinu boje vrijednosti 256. Bez tipkovnice bila bi prihvatljiva i razlučivost 640x480.

Prilikom upotrebe Tech2Win (na prijenosnom računalu umjesto na Tech2), pazite da prijenosno računalo ima dovoljno energije. Vaše prijenosno računalo ne može napajati akumulator automobila, kao u slučaju Tech2.

  • Instalacija
  • Prvi koraci


Licenca

General Motors - suglasnost za Tech2Win licencu

Prije uporabe ovog programa, pažljivo pročitajte sljedeće uvjete za korištenje. Ako ne prihvaćate ili ne razumijete uvjete korištenja, kontaktirajte svojega lokalnog predstavnika Službe održavanja (postprodaje). General Motors daje licencu za korištenje ovog softvera samo u slučaju korisnikove suglasnosti s ovom licencom tako što, tijekom instalacije Tech2Win-a, prihvati ove uvjete korištenja.
General Motors dodjeljuje pravo korištenja Tech2Win softvera i uključenih informacija, zajedno s TIS2Web-om ili GlobalTIS-om ili TIS2000-om, isključivo za korisnike mreže ovlaštenih servisera General Motors, kako je utvrđeno u lokalno primjenjivom sporazumu ovlaštenih servisera s nacionalnim prodajnim društvima General Motors.
Tech2Win licenca vrijedi toliko dugo, koliko je na snazi sporazum ovlaštenog servisera i koliko dugo traje licenca za TIS2Web, GlobalTIS i TIS2000. Licenca za Tech2Win prestat će vrijediti zajedno s licencom za TIS2Web i Global TIS odmah po okončanju sporazuma s ovlaštenim serviserom.

Nezavisni serviseri, kako je definirano u članku 4, paragrafu 2 Uredbe EU o skupnom izuzeću 1400/2002 (BER), mogu kupiti Tech2Win licencu kao dio ponuđene pretplate, ponuđene na GM Europe Info portalu General Motors Europe.

Tech2Win licenca ne obuhvaća komunikacijsko sučelje vozila ili PC hardver.

Tech2Win softver ne smije se dalje distribuirati, prodavati ili staviti online (na mrežu) za bilo koju treću stranu izvan prostorija ovlaštenog servisera (kao što je opisano u važećem aneksu sporazuma s ovlaštenim serviserom), bez pismene suglasnosti relevantnih nacionalnih prodajnih društava General Motors. Ovo se odnosi na tekuće i na stare podatke (kao što su istekli DVD-i).

Nacionalna prodajna društva General Motors imaju pravo trenutno zatvoriti pristup i dati obavijest o trenutnom prekidu sporazuma s ovlaštenim serviserom, u slučaju neovlaštenog korištenja ili zlouporabe. U tom slučaju, isključuje se pravo zahtijevati povrat novca za preostale odobrene iznose i/ili godišnje naknade.

Pružene informacije služe za obavljanje servisa i popravka na stručan način za nemodificirana vozila General Motors. Potpuna obuka automehaničara i daljnje redovne obuke potrebne su kao preduvjet za izvršenje prethodno spomenutog rada. Tamo, gdje je u datim informacijama naznačena uporaba specijalnih alata, takvi specijalni alati su obvezni za sve popravke koji se moraju obaviti na stručan način.

Informacije, objavljene na Tech2Win-u General Motors (tekst i slike, glazba, crteži, animacije, filmovi, itd.) i raspored istih na Global TIS-u, zaštićeni su autorskim pravom. Nije dozvoljena reprodukcija, širenje, komunikacija i/ili emitiranje ili drugi način korištenja, osim ako postoji prethodno pisano odobrenje od strane društva General Motors.

  • Instalacija: Koraci instalacije
  • Prvi koraci


Installation

Instalacija

Instalacija softvera Tech2Win zahtijeva lokalna administrativna prava na računalu. Instalacija neće raditi bez administratorskih prava. U takvom slučaju obratite se administratoru računala za pomoć.

Da biste uspješno koristili Tech2Win morate proći sljedeća dva koraka:

  • Instalaciju softvera Tech2Win.
  • Instalacija sučelje za komunikaciju s vozilom.
  • Instalacija: Koraci instalacije
  • Prvi koraci


Koraci instalacije

Sama instalacija traje samo nekoliko minuta i od korisnika zahtijeva sljedeće unose:

  1. Suglasnost o licenci
  2. Instalacijski direktorij

Jezik

Zadano je de se Tech2Win UI prikaže na jeziku vašeg operacijskog sustava. Podržani su sljedeći jezici. Ako vaš jezik nije podržan, program za instalaciju pokreće se na engleskom, kao zadanom jeziku za instalaciju.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Engleski (britanski ili američki)*
  • el_GR (EL)Greek
  • es_ES (ES)Španjolski
  • fi_FI (FI)Finnish
  • fr_FR (FR)Francuski
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugalski (Brazil)
  • pt_PT (PT)Portugalski (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Kineski (pojednostavljeni)
  • zh_TW (ZH)Kineski (tradicionalni)

* Jezik Tech2Win-a je britanski engleski. Međutim, Tech2 softver i program za instalaciju, koje koristite, mogli bi biti na američkom engleskom, ovisno o izvoru softvera.

Suglasnost o licenci

Morate prihvatiti suglasnost o licenci.

Instalacijski direktorij

Možete odabrati bilo koji direktorij za instalaciju Tech2Win. Instalacijski direktorij obično je <vaš programski direktorij>\General Motors\Tech2Win ili u slučaju ponovne instalacije, prethodno odabrana lokacija.

Kao posljednji dio, potvrdite instalaciju.

Pogonski program virtualnog COM ulaza

Pogonski program virtualnog COM ulaza instalirat će se na vaše računalo samo jedanput i ostaje na njemu, dok se ne nadogradi verzija pogonskog programa (rijetko se događa) ili dok se Tech2Win ne deinstalira s vašeg računala.
Ako se pogonski program instalira, na trenutak ćete vidjeti DOS okvir. On će se automatski zatvoriti i ne zahtijeva nikakvu aktivnost. Datoteke pogonskog programa dodatno su smještene u podmapi 'upravljački program', u imeniku za instalaciju vašeg Tech2Win-a.
Moguće je, ali nije preporučljivo, ručno instalirati ili deinstalirati pogonske programe za virtualne COM ulaze. Koristite jednu od sljedećih naredbi iz CMD školjke:

  • pozovite 'vbsetup7' za instaliranje pogonskog programa
  • pozovite 'vbsetup7 /u' za deinstaliranje pogonskog programa
  • Prvi koraci


Sučelje za komunikaciju s vozilom

Komunikacijski uređaj vozila mora se posebno instalirati. Konzultirajte odgovarajuće upute za instalaciju priložene uz Sučelje za komunikaciju s vozilom.

  • Prvi koraci: Sučelje za komunikaciju s vozilom
  • Napredne teme: Konfiguracijska datoteka
  • Instalacija: Koraci instalacije
  • FAQ: Kako mogu koristiti više MDI-ja?
  • FAQ: Tech2Win nije pronašao moj MDI


Prvi koraci

Ovi prvi koraci pokazuju vam kako koristiti aplikaciju Tech2Win. Podrazumijeva se da ste upoznati sa softverom Tech2. Tijekom ovih prvih koraka nije potrebna komunikacija s vozilom.

Za Quick Start (brzo pokretanje) načinite sljedeće korake:

  1. S vaše radne površine pokrenite Tech2Win softver pomoću prečaca QuickStart.
  2. Pribavite važeću licencu preuzimanjem Tech2 softvera s TIS2Web-a.

Za uporabu konfiguracije koja se može odabrati:

  1. Pokrenite program za konfiguraciju pomoću prečaca Tech2Win s vaše radne površine. Nakon instalacije mora biti prisutna zadana konfiguracija.
  2. Za izradu nove konfiguracije, bolje je da kopirate zadanu konfiguraciju.
  3. Modificirajte postojeću konfiguraciju kako biste zadovoljili specifične zahtjeve.
  4. Pribavite valjanu licencu.

Ne pokrećite Tech2Win u kompatibilnom načinu rada. U takvom slučaju, u datoteci prijava (Log) pojavit će se upozorenje. Tech2Win koristi Windows funkcije koje postoje samo od inačice XP, pa neće raditi na ranijim inačicama Windows-a.

  • Prvi koraci: Nove konfiguracije
  • Prvi koraci: Mijenjanje konfiguracija
  • Prvi koraci: Sučelje za komunikaciju s vozilom
  • Rad s Tech2Win: Izbornik
  • Rad s Tech2Win: Zaštita
  • Rad s Tech2Win: Statusna traka
  • Napredne teme: Konfiguracijska datoteka


Odabir konfiguracije

Prilikom prvog pokretanja aplikacije Tech2Win prikazuje se sljedeći zaslon. Imate mogućnost pokrenuti aplikaciju izravno sa zadanom konfiguracijom. Zadana konfiguracija radi bez komunikacije s vozilom.

Start First Time

Prikazat će se okvir s podacima o licenci, ali možete ga zanemariti da biste pokrenuli zadanu konfiguraciju.

Kada radite sa zaslonom osjetljivim na dodir, korisno je pokrenuti program za tipkovnicu kako biste mogli unositi slova putem aplikacije koja simulira tipkovnicu.


Tipkovnica

Tipke računala kao i gumbi, ako postoje, mapirane su slično tipkama aplikacije Tech2. Aplikacija Tech2Win nudi dodatne tipke koje nije moguće pronaći u originalnom softveru Tech2. Numerička tipkovnica na računalu možda neće raditi u svim uvjetima. Ako imate problema, provjerite je li na vašem računalu promijenjen standardni raspored tipaka na tipkovnici. Posebno provjerite je li tipka SHIFT oštećena.

Računalna tipkovnica | Gumb | Funkcija
Funkcijska tipka F1 | nije raspoloživo | Pomoć za Tech2Win
Funkcijske tipke F5...F8 | Koristite područje prikaza Tech2Win i softverske tipke | Softverske tipke Tech2
Tipke pokazivača za gore, dolje, lijevo i desno |  | Tipke Tech2 za gore, dolje, lijevo, desno. Samo se ove tipke mogu automatski ponavljati.
Tipka 0...9 | F0 • • • F9 | Tech2 tipke F0...F9
Backspace | Exit | Tech2 tipka za izlaz
Enter/Povratak | Enter | Tech2 tipka Enter
Y | Yes | Tech2 tipka Da
N | No | Tech2 tipka Ne
Q | ? | Tech2 tipka ?
S | Shift | Tech2 tipka Shift; Shift Indikator u statusnoj traci ili indikator iznad tipke Shift pokazuju status.
ctrl-P | PWR | Tech2 tipka Power; Ova tipka može samo isključiti aplikaciju Tech2Win.
ctrl-R | nije raspoloživo | Ponovno pokreće Tech2Win. Slično ciklusu Isključeno/Uključeno na Tech2. Međutim, pridruženo sučelje za komunikaciju s vozilom (VCI) neće biti poništeno. Datoteke kao što je slika PCMCIA nije moguće ponovno učitati.
Početak | Home | Tipka Početak. Podržavaju samo nekee aplikacije.
dostupno samo putem opcije izbornika Datoteka. | Print Screen | Ispisuje snimku Tech2 ekrana, kreirajući privremenu BMP datoteku i pozivajući aplikaciju povezanu s BMP datotekama. Ovu aplikaciju koristite za promjenu veličine ili okretanje slike prije ispisa.
dostupno samo putem opcije izbornika Datoteka. | Save Screen | Sprema snimak zaslona Tech2 kao BMP ili PNG datoteku.
dostupno samo putem opcije izbornika Datoteka. | View Report | Prikazuje sva izvješća aktivne PCMCIA flash kartice da ih korisnik može pregledavati.


Rukovanje sustavom Windows

Svoje prozore možete preoblikovati uobičajenim mehanizmima sustava Windows, odnosno povlačenjem obruba glavnog prozora. Osim toga, stavka izbornika Izbori/Rezolucija podržava nekoliko unaprijed postavljenih veličina. Tijekom promjene veličine glavnog prozora putem stavke izbornika, prozor tipkovnice automatski se umeće.

Prikaz prozora mijenja se promjenom konfiguracije na kartici Prikaz (Prikaz).


Nove konfiguracije

Kliknite na gumb Kreiraj novi da biste stvorili novu konfiguraciju. Prikazat će se dijaloški izbornik za odabir postojeće konfiguracijske datoteke kao izvor. Obično je odabrana zadana konfiguracija. Nakon unosa naziva nove konfiguracijske datoteke kliknite gumb Kopirajte (Kopiraj).

Ako radite sa zaslonom osjetljivim na dodir, možda će vam biti jednostavnije aktivirati simulaciju tipkovnice gumbom PC-tipkovnica (PC tipkovnica).

Gumb Poništite (Poništi) omogućuje vam poništavanje postupka stvaranja.

Nova konfiguracija će koristiti istu PCMCIA datoteku, kao i postojeća izvorna konfiguracija. Ako to želite promijeniti, morat ćete modificirati konfiguraciju, tako da se koristi različita PCMCIA datoteka. U većini slučajeva, jednostavno ćete kopirati postojeću PCMCIA datoteku u novu datoteku i koristiti novu datoteku. Mogli biste preferirati da vaša nova konfiguracija koristi istu PCMCIA datoteku, kao i vaša izvorna konfiguracija. U tom slučaju pojavit će se ekran s upozorenjem ako pritisnete tipku Spremite.

  • Mijenjanje konfiguracija


Mijenjanje konfiguracija

Konfiguracije prikazane plavom bojom imaju oznaku samo za čitanje i nije ih moguće mijenjati. Ove konfiguracije moguće je samo pregledati. Možete se poslužiti načinom za mijenjanje da biste im vidjeli sadržaj, ali neće biti moguće odabrati Spremite.

Konfiguracija se mijenja odabirom pojedine postavke s četiri kartice Jezik, Sučelje za komunikaciju s vozilom, Staza, Prikaz. Možete izabrati željeni tabulator ili odabrati gumb Slijedeći (Dalje) da biste uključili sljedeći tabulator. Nakon unosa promjena pritisnite gumb Spremite da biste spremili konfiguraciju.

Kad god je potreban unos s tipkovnice, možete pozvati računalnu aplikaciju koja simulirati tipkovnicu. To je posebno praktično na računalima sa zaslonima osjetljivim na dodir koja nemaju tipkovnicu.


Jezik

Kartica Jezik omogućuje vam odabir jezika na kojem će se aplikacija Tech2Win izvoditi. Ovaj odabir nema nikakvog utjecaja na jezik softvera Tech2 na PCMCIA preslici. Prilikom preuzimanja softvera Tech2 s TIS-a morate odabrati ispravan jezik.

U nekim regijama neće biti dostupni svi jezici. U tom slučaju prikazivat će se engleski jezik. Molimo provjerite je li dostupan sličan jezik (PT Portugalski-Portugal, a ne PB Portugalski-Brazil).


Staza

Kartica Staza omogućuje vam podešavanje putanja obje PCMCIA preslike kao i putanju do lokalne softverske tipkovnice. Osim toga za potrebe kopiranja PCMCIA preslika tu je gumb Kopiraj memorijsku karticu (Kopiraj memorijsku karticu). Ako ste upravo kreirali novu konfiguraciju, mogli biste poželjeti koristiti ovaj gumb za izbjegavanje nekoliko konfiguracija pomoću iste PCMCIA kartice.

Memory Card Options

Kopiraj memorijsku karticu ...

Ovaj gumb omogućuje kopiranje PCMCIA preslike u drugu datoteku. Njegova je funkcionalnost slična kupnji nove PCMCIA kartice za Tech2. Funkcija za kopiranje radi samo za datoteke u imeniku C:\Users\Public\General Motors\Tech2Win\pcmcia.

Utor 0 : Lokacija slike memorijske kartice

Ovdje možete specificirati datoteku koja sadrži presliku PCMCIA kartice za utor 0. Normalno, takva datoteka treba se nalaziti u C:\Users\Public\General Motors\Tech2Win\pcmcia, međutim, moguće su i druge lokacije.

Utor 1 : Memorijska kartica ili ATA

Kao i Tech2, aplikacija Tech2Win podržava dvije PCMCIA kartice (preslike). Međutim druga PCMCIA preslika u konfiguraciji obično nije posebno korisna. Drugi softver vjerojatno bi bio korišten u drugoj konfiguraciji.

Kao u softveru Tech2, ATA kartica se koristi u svrhu rješavanja problema. ATA karticu aktivirajte samo ako vas to zatraži tehnička podrška. Oni će vam pružiti više informacija.

Lokacija PC softverske tipkovnice

Zadana vrijednost ove datoteke preuzima se iz Window registra i treba ukazivati na aplikaciju koja može simulirati računalnu tipkovnicu s mišem. Ako imate posebnu aplikaciju s ovom funkcijom na svom prijenosnom računalu, ovdje možete navesti tu aplikaciju.


Sučelje za komunikaciju s vozilom

  • COM-ulaz za Tech2-RS232-emulaciju
  • Serijski broj MDI za uporabu
  • Protokol

COM-ulaz za Tech2-RS232-emulaciju

Molimo odaberite slobodan COM ulaz koji se može koristiti za Tech2 emulaciju. Radi lakše upotrebe, konfigurator pokušava pronaći koji su serijski priključci već u upotrebi i prikazuje ih.

Ako odaberete postojeći COM ulaz, Tech2Win će se vezati na taj postojeći COM ulaz. Možete upotrijebiti ovaj COM ulaz za preuzimanje softvera Tech2 s drugog računala na kojemu se izvodi aplikacija TIS, pomoću null modemskog kabela. Imajte na umu da upotreba pravog COM ulaza možda nije pouzdana sa 115.200 bauda zbog ograničenja sustava Windows.

Ako odaberete nepostojeći COM ulaz, Tech2Win automatski će izraditi virtualni ulaz. Ovaj virtualni ulaz može se koristiti iz aplikacije TIS koja se izvodi na istom računalu kako bi se uspostavila komunikacija s Tech2Win. Prilikom upotrebe virtulanog ulaza nema ograničenja brzine prijenosa podataka u bodima.

Ako odaberete 'search' (traži) kao COM ulaz, Tech2Win će kreirati virtualni COM ulaz na broju prvog slobodnog ulaza u rasponu od 9 do 1.

Serijski broj MDI za uporabu

Unesite serijski broj MDI-a. Broj možete pronaći na stražnjoj strani MDI-a. Upotrijebite broj nakon crtice.

Ako ne unesete serijski broj, Tech2Win automatski će prikazati popis u mreži otkrivenih MDI-ja kako bi korisnik sam mogao odabrati jedan. Isti okvir za odabir pojavit će se i kada određeni MDI ne bude pronađen.

Protokol

'ISO22900-2 / PDU-API' je odabran, a J2534-2 je uvijek zasivljeno. U budućnosti će Tech2Win možda podržavati i protokol J2534.

  • Napredne teme: Konfiguracijska datoteka
  • FAQ: Kako mogu utvrditi koji ulaz trebam koristiti za Tech2Win?
  • FAQ: Komunikacija između Tech2Win i aplikacije TIS2Web
  • FAQ: Kako mogu koristiti više MDI-ja?
  • FAQ: Tech2Win nije pronašao moj MDI


Prikaz

Kartica Prikaz uglavnom se koristi za promjenu postavki vezanih uz prikaz aplikacije Tech2Win:

  • Tipkovnica
  • Boje
  • Zvuk
Display and Key Options

Tipkovnica

Ovdje možete odabrati hoće li se prikazivati tipkovnica. Tipkovnica se prikazuje s lijeve ili desne strane zaslona Tech2Win. Pozadinsku boju moguće je odabrati putem standardnog dijaloškog okvira.

Boje

Ovdje možete zasebno odabrati boju prednjeg plana i pozadine zaslona Tech2. Ovo su dvije najuobičajenije kombinacije boja:

Screen with background 0000FF, foreground FFFFFF | Bijela pozadina tipkovnice; Plava pozadina; Bijeli prednji plan
Screen with background 000000, foreground C0C0C0 | Plava pozadina tipkovnice; Crna pozadina; Svijetlo sivi prednji plan

Zvuk

Ovdje možete odabrati da isključite zvuk. Svaki puta kada se program Tech2 oglasi signalom, čut ćete ga putem zvučnika računala.


Spremanje konfiguracije

Aktivnu konfiguraciju možete spremiti pritiskom na gumb Spremite < (Spremi) <konfiguraciju> u donjem lijevom kutu. Gumb se neće prikazati ako pregledavate konfiguraciju samo za čitanje.


Valjana licenca putem aplikacije TIS2Web

U normalnim okolnostima preuzimanjem softvera Tech2 na Tech2Win pribavit će vam i valjanu licencu. Osim toga, možete je dobiti provodeći 'Sigurnosni pristup (Sigurnost)' putem TIS2Web-a (ne TIS2000). Preduvjet je odabir virtualnog COM ulaza u Konfiguratoru u odjeljku Vehicle Communication Interface (Sučelje za komunikaciju s vozilom).

Nakon uspješnog pristupa i sigurnosne provjere vidjet ćete otključanu bravu s desne strane trake stanja. Unutar zagrada vidjet ćete broj dana valjanosti licence. Kada ponovno pokrenete Tech2Win, sigurnosni indikator neće se prikazati sve dok nema nikakve komunikacije s vozilom. Tijekom prve komunikacije s vozilom licenca se provjerava, a indikator se mijenja u otključan ili zaključan lokot.

  • Rad s Tech2Win:Zaštita
  • FAQ:Kako mogu utvrditi koji ulaz trebam koristiti za Tech2Win?
  • FAQ:Komunikacija između Tech2Win i aplikacije TIS2Web
  • FAQ:Valjana licenca
  • FAQ:Koja je razlika između licence za Tech2Win i sigurnosnog pristupa?


Rad s Tech2Win

Sljedeće teme uglavnom se odnose na tehničare koji rade na Tech2Win:

  • Izbornik: Izgled zaslona i pojedinačnih stavki izbornika.
  • Preuzimanje slike PCMCIA: Ažuriranje dijagnostičkog softvera za Tech2Win slično je načinu koji se koristi za Tech2.
  • Zaštita: Sigurnosne mjere sprječavaju Tech2Win u komunikaciji s vozilom u neovlaštenim okruženjima.
  • Pregled izvješća: Tipkovnica Tech2 donekle je poboljšana u Tech2Win. Gumb 'Pregled izvješća' najočitiji je primjer.
  • Rukovanje PCMCIA preslikama: Slično kao što u Tech2 možete imati više PCMCIA kartica, u Tech2Win imate nekoliko PCMCIA preslika.
  • Statusna traka: Traka statusa informira korisnika o individualnim dijelovima trake statusa.
    • Napredne teme
    • FAQ


Izbornik

Aplikacija Tech2Win ima sljedeće unose na izborniku:

  • Datoteka
  • Izbori
  • Prozor
  • Pomoć

Datoteka

Izbornik Datoteka nudi sljedeće mogućnosti:

  • Naredba Spremi T2-zaslon (320x240) koristi se za spremanje stvarnog T2-zaslona u veličini 320x240 piksela kao crno-bijele slikovne datoteke na vaše računalo. Mjesto spremanja i format datoteke (BMP, GIF, JPG, PNG) možete sami odabrati.
  • Naredba Ispis zaslona stvara obrnutu crno na bijelom BPM sliku zaslona aplikacije Tech2 i poziva program vezan za BPM datoteke. Ovaj program možete upotrijebiti za ispis slike.
  • Pogledaj datoteke izvještaja omogućuje pregled (ispis) datoteka izvješća bez upotrebe aplikacije TIS2Web.
  • Izlaz zatvara Tech2Win.

Izbori

Izbori (Mogućnosti) pružaju sljedeće mogućnosti:

  • Rezolucija se može koristiti za odabir jedne od tri standardne veličine zaslona.
  • ROM-Write from 0x00003ED76 koristi se za interno ispravljanje pogrešaka.
  • Automatske snimke zaslona (Autom. slike zaslona) za pohranu slike različitih Tech2 zaslona u direktorij zapisnika.
  • Onemogući CANdi i ponovno pokreni za oponašanje Tech2 bez CANdi-ja između aplikacije i vozila. Ovo je neophodno u rijetkim slučajevima kada CANdi ometa nestandardne linije komunikacije s vozilom.

Prozor

Izbornik Prozor daje vam mogućnost aktiviranja odabira Podatkovni prikaz Tech2Win (prikaz podataka) i Prikaz DTC-a Tech2Win (prikaz DTC-ova). Svi drugi odabiri su zasjenjeni sivo u tekućoj Tech2Win verziji.

Ako softver za Tech2 podržava Podatkovni prikaz Tech2Win (prikaz podataka), možete uključiti ovu stavku izbornika. Po ulasku u Data Display (prikaz podataka), Tech2Win će prikazati dodatni prozor Data Display (prikaz podataka), usporedan s Tech2 Data Display. Sve dok ekran Tech2 pokazuje Data Display (prikaz podataka), ne možete uključiti stavku izbornika. U takvom slučaju morate izaći iz Data Display (prikaza podataka), uključiti stavku izbornika i ponovno pokrenuti Data Display (prikaz podataka).

Slilčna ograničenja kao za Prikaz DTC-a Tech2Win, također se odnose i na Podatkovni prikaz Tech2Win. Ako softver za Tech2 podržava Prikaz DTC-a Tech2Win (prikaz DTC-ova), možete uključiti ovu stavku izbornika. Dodatni prozor DTC Display (prikaz DTC-ova) pojavit će se usporedno s DTC Display-em na Tech2. Sve dok ekran Tech2 pokazuje DTC Display (prikaz DTC-ova), ne možete uključiti stavku izbornika. U takvom slučaju morate izaći iz DTC Display (prikaza DTC-ova), uključiti stavku izbornika i ponovno pokrenuti DTC Display (prikaz DTC-ova).

Pomoć

Mogući su sljedeći odabiri:

  • Teme pomoći... poziva Pomoć za program Tech2Win.
  • Parametar komandne crte prikazuje parametre naredbenog retka koji se koriste za Tech2Win.
  • O pokazuje broj tekuće verzije i ograničenja Tech2Win-a kod preuzimanja kopiranjem TIS2Web-a.


Preuzimanje

Prvo pokrenite Tech2Win i ostavite ga u glavnom zaslonu. Pokrenite aplikacije TIS2Web ili GlobalTIS i provedite preuzimanje kopiranjem putem COM ulaza navedenog na kartici Sučelje za komunikaciju s vozilom.

Upotreba ugrađenih COM-ulaza omogućuje preuzimanje softvera Tech2 s drugog računala s pokrenutim TIS-om. Svakako koristite isprepleteni RS232 kabel. Ovisno o hardveru računala na kojemu se izvodi Tech2Win, možda će trebati smanjiti propusnost podataka na 57.600 jer sustav Window može gubiti podatke pri većoj propusnosti.

Najnovija inačica Tech2Win podržava i brzo preuzimanje, ako TIS2Web i Tech2Win rade na istom PC-u. Minimalna komunikacija između TIS2Web-a i Tech2Win-a preko COM ulaza i dalje se provodi, ali dugotrajan prijenos podataka u Tech2Win zamijenjen je unutarnjim prijenosom datoteka. U takvom slučaju, vrijeme preuzimanja drastično se smanjuje, na manje od jedne minute.

  • Napredne teme: Konfiguracijska datoteka
  • Prvi koraci: Sučelje za komunikaciju s vozilom
  • FAQ: Kako mogu utvrditi koji ulaz trebam koristiti za Tech2Win?
  • FAQ: Komunikacija između Tech2Win i aplikacije TIS2Web


Zaštita

Sigurnosni mehanizmi na koje se oslanja Tech2Win oslanjaju se na točne vrijednosti računalnog sata. Pazite da sat vašeg računala uvijek bude točan. Manje promjene u vremenu mogu se dogoditi tijekom promjene ljetnog u zimskog vrijeme, njih Tech2Win tolerira.

Tech2Win neće komunicirati s vozilom bez valjane i aktivne licence. Sljedeći indikator na traci stanju prikazuje status licence:

  • green smiley Licenca je valjana.
  • Nema indikatora: Licenca još nije provjerena.
  • red smiley Licenca je istekla.

Za dobivanje licence, provedite ažuriranje 'Sigurnosni pristup (Sigurnost)' pomoću aplikacije TIS2Web. U većini slučajeva samim preuzimanjem softvera putem aplikacije TIS2Web dobit ćete novu licencu. Budući da licenca istječe nakon nekog vremena (u nekim regijama nakon četiri tjedna), ovo ažuriranje morate redovito obavljati.

Licence se vezuju uz regiju/softver. Možda na računalu imate licence ako Tech2Win koristite s različitim verzijama softvera Tech2.

Na traci stanja prikazan je broj dana do isteka licence.

  • (0) znači da je licenca istekla ili ne postoji.
  • (<1) Licenca će isteći u sljedeća 24 sata.
  • (20) Licenca će isteći za 20 dana.

Ne mijenjajte licenčne datoteke. Prevarantsko mijenjanje ovih datoteka moguće je otkriti internim sigurnosnim mjerama i dovest će do gubitka svih licenci na računalu. Osim toga, Tech2Win neće se ponašati uobičajeno. To je moguće ispraviti isključivo novom instalacijom.

  • Napredne teme: Poruke o pogreškama i izlazne šifre
  • Napredne teme: Datoteka zapisa
  • Rad s Tech2Win: Prozor statusa
  • FAQ: Valjana licenca
  • FAQ: Koja je razlika između licence za Tech2Win i sigurnosnog pristupa?
  • FAQ: Naglo zaustavljanje


Pregledavanje izvješća

View Report Ovaj gumb se koristi za pregled sadržaja svih PRT datoteka koje se nalaze na PCMCIA kartici. Otvorit će se dijaloški okvir za prikaz popisa PRT datoteka. Ako je neki program povezan s datotečnim nastavkom PRT, program će se pokrenuti. U protivnom, otvorit će se uređivač teksta kako bi prikazao odabranu datoteku.

U većini slučajeva PRT datoteka je ASCII datoteka koja koristi kodne stranice određenog jezika. Za kineski, japanski, korejski i tajski datoteka je unicode s vodećim Byte-Order-Mark (BOM).

Prilikom pregledavanja izvještaja, Tech2Win radi s podimenikom C:\Users\Public\General Motors\Tech2Win\reports. Ovaj poddirektorij postojat će samo ako ste barem jednom pregledavali izvješća. Direktorij se automatski briše i funkcionira kao privremeni radni direktorij za PRT datoteke na aktivnoj PCMCIA kartici. Sadržavat će ove datoteke čak i ako se Tech2Win prestane izvoditi. Ako želite spremiti takvu datoteku, morat ćete je kopirati u drugi direktorij jer se može dogoditi da bude prepisana čim drugi korisnik odabere pregled izvješća.


PCMCIA preslike

PCMCIA slike normalno se nalaze u podimeniku C:\Users\Public\General Motors\Tech2Win\pcmcia. Datoteka mora imati točno 32 MB (33,554,432 bajta) ili 10 MB (10,485,760 bajta) i datotečni nastavak *.bin. Preslike se mijenjaju (kao i svaka PCMCIA kartica) ako se dogodi preuzimanje ili Tech2Win spremi nešto na flash karticu. Promjena se može onemogućiti upotrebom prekidača za zaštitu od pisanja (naredba -W0 ili -W1) ili izostavljanjem 'p'-value u izboru '-W'-(Konfiguracijska datoteka). Prekidaču za zaštitu od pisanja ne možete pristupiti kroz program za konfiguriranje. Ako želite koristiti opcije '-W0', '-W1' ili '-W', morat ćete ručno modificirati datoteku za konfiguriranje.


Statusna traka

Traka statusa prikazana je ispod zaslona Tech2. U traci statusa prikazane su sljedeće stavke:

  1. Pokazivač brzine
  2. Status komunikacije s vozilom
  3. Status serijskog ulaza
  4. Tipka SHIFT
  5. Automatske snimke zaslona
  6. Zapis - Upozorenje
  7. Licenca

Status Bar

Pokazivač brzine

Pokazivač brzine pokazuje koliko vremena procesor emulira softver Tech2. Mali broj (pokazivač lijevo) je bolji od velikog broja (pokazivač desno). Zeleni pokazivač je prihvatljiv. Pokazivač može nakratko postati žut ako se uključi neki drugi zadatak sustava Windows. To je potrebno izbjegavati.

Status komunikacije s vozilom

Stanje komunikacije s vozilom pokazuje postoji li Sučelje za komunikaciju s vozilom (MDI) te postoji li komunikacija između vozila i aplikacije Tech2Win.

Status serijskog ulaza

Prilikom komuniciranja s Tech2Win putem COM ulaza pokazivač pokazuje je li komunikacija putem COM ulaza aktivna ili ne.

Tipka SHIFT

Ovaj indikator pokazuje je li aktivna tipka SHIFT. Možete je prebacivati pomoću tipka 'S' na tastaturi ili tipke SHIFT na tipkovnici.

Automatske snimke zaslona

Automatske snimke zaslona moguće je uključiti putem izbornika Izbori (Mogućnosti). Kod svake promjene zaslona u direktorij zapisnika sprema se nova snimka zaslona. To je naznačeno okretom pokazivača na crvenoj kameri na traci stanja. Čim se isključi mogućnost Automatskih snimaka zaslona, kamera nestaje.

Zapis - Upozorenje

Indikator stanja zapisnika može imati tri stanja.

  • gray log status indicator Datoteka zapisnika ne sadrži upozorenja, ni pogreške.
  • yellow log status indicator Datoteka zapisnika sadrži poruku upozorenja.
  • red log status indicator Datoteka zapisnika sadrži poruku o pogrešci.

Licenca

Indikator stanja može imati tri stanja:

  • green smiley Licenca je aktivna i valjana.
  • Nema indikatora: Licenca još nije provjerena.
  • red smiley Licenca je istekla ili ne postoji.
Više detalja potražite na vezi Sigurnost.

Opisi elemenata na traci stanja

Za neke ikone prikazuju se opisi elemenata kako biste dobili dodatne informacije.

Opis elementa za serijski broj VCI.
Tooltip VCI

Opis elementa za verziju softvera TECH2.
Tooltip TECH2

Opis elementa za Comport
Tooltip Comport

Opis elementa za sljedeći snimak zaslona (ako je uključena značajka 'Automatske snimke zaslona')
Tooltip Camera

Opis elementa koji pokazuje da posljednji unos zapisnika ima razinu 'warning' (upozorenja) ili višu
Tooltip Logfile

Opis elementa za točno trajanje licence
Tooltip License

Opisi elemenata prikazuju se ako pokazivač zadržite više od 0,5 sekundi na ikoni bez pomicanja. Opis elementa nestaje 5 sekundi nakon pomicanja pokazivača.

  • Napredne teme: Poruke o pogreškama i kôdovi pogrešaka
  • Napredne teme: Datoteka zapisa


Napredne teme

Ovdje navedene teme nisu pretjerano važne za standardne korisnike aplikacije Tech2Win. Sljedeće informacije možda će biti korisne svim korisnicima uključenim u postav, upravljanje i konfiguriranje aplikacije Tech2Win.

  • Reinstalacija
  • Deinstalacija
  • Izravna promjena konfiguracijskih datoteka
  • Datoteka zapisa
  • Poruke o pogreškama i izlazne šifre
  • ATA kartica
  • Unosi registra
  • Opis datoteke
  • Primjer Upravljanja konfiguracijom


Deinstalacija

Izbrisani su imenik za potpunu instalaciju, imenik koji sadrži podatke o korisniku (C:\Users\Public\General Motors\Tech2Win) i imenik koji sadrži podatke o aplikaciji (C:\ProgramData\General Motors\Tech2Win).

  • Napredne teme: Reinstalacija
  • Instalacija


Konfiguracijska datoteka

Datoteke za konfiguraciju uvijek se nalaze u podimeniku C:\Users\Public\General Motors\Tech2Win\config i imaju ekstenziju datoteke *.conf. Možete odlučiti ručno promijeniti konfiguracijsku datoteku jer vam u Tech2Win nisu dostupne sve opcije datoteke. Konfiguracijska datoteke je Unicode datoteka s vodećim Byte-Order_Mark (BOM). Svakako preporučujemo da koristite Unicode uređivač poput programa Notepad prilikom ručnog unošenja promjena.

Konfiguracijska datoteka je linijski orijentirana. Prazne linije bivaju zanemarene. Linija uvijek započinje nekom opcijom nakon koje slijedi vrijednost. Pogledajte, na primjer, datoteku default.conf. Pogledajte sljedeću tablicu u kojoj se nalaze svi raspoloživi izbori.

Ako želite pokrenuti određenu konfiguraciju izravno s radne površine, načinite prečac koji izvršava 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Program bi se trebao pokrenuti iz sljedećeg radnog imenika: 'C:\Program Files\General Motors\Tech2Win\bin'

izbor | Vrijednost/značenje
; Napomena
@ Decimalna verzija broja u obliku cijeli veći.manji broj.
Konfiguracijske datoteke s drukčijim većim (major) brojem u odnosu na Tech2Win neće biti prihvaćene. Konfiguracijske datoteke s nižim manjim (minor) brojem u odnosu na Tech2Win neće biti prihvaćene.
-W0
-W1 		Na PCMCIA kartici u utoru 0/1 aktiviran je prekidač za zaštitu od pisanja.
-B0
-B1 		Veličina bloka u kilobajtima PCMCIA kartice u utoru 0/1. Prihvatljive vrijednosti su 128 (zadana) ili 256.
-P0
-P1 		Datoteka koja sadrži binarnu sliku PCMCIA kartice za utor 0/1. Veličina datoteke mora biti točno 10 MB ili 32 MB. Proširene su varijable okruženja poput %ProgramData%.
Ako ovaj izbor nije prisutan, utor se smatra praznim.
-A0
-A1 		Datoteka s vrijednostima atributa PCMCIA kartice u utoru 0/1. Ako nije prisutna, zadani atributi rabit će se na temelju veličine kartice i bloka.
-W | Po izlasku iz Tech2Win svi trajni podaci bit će zapisani u svoje datoteke. Vrijednosti p/f/r/c mogu se kombinirati kako bi značile PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | Funkcija upravljanja heap memorijom Vrijednosti 0/r/w/t mogu se kombinirati za aktiviranje svođenja na nulu, provjera očitavanja, provjera upisivanja i provjera zadataka. Vrijednost I koristi se za stalnu prisilnu primjenu alociranja heap memorije na nižim adresama kao alternativnu shemu alokacije. U pravilu, ova opcija koristi se samo u razvojnim okruženjima.
-PC | Prijašnja staza za kopiju PCMCIA kartice. Ova opcija je trenutno zanemarena.
-MS | Identifikacija sučelja za komunikaciju s vozilom (MDI) serijskim brojem. Ako to nije podešeno, neće vam biti dostupan popis raspoloživih MDI-ja.
-CT | Boja teksta (bliži plan) u vrijednosti 3 heksadecimalnih bajtova. Zadana vrijednost je 000000 (bijelo).
-CB | Boja teksta u pozadini u vrijednosti 3 heksadecimalnih bajtova. Zadana vrijednost je FFFFFF (crno).
-ATA | Koristite ovu opciju da omogućite ATA karticu za snimanje. Uklonite je da biste onemogućili ATA karticu za snimanje.
-C | Broj COM ulaza (1...9) koji će se rabiti kao RS232C komunikacijski ulaz za Tech2. Često se COM9 koristi kao virtualni COM ulaz koji instalira aplikacija Tech2Win. Ako ova opcija ne postoji, pretraživanje slobodnog COM ulaza obavlja se prema dolje od COM9. Za pregled koji se COM ulaz trenutno koristi, koristite tooltip (savjet) na statusnoj traci, između ikone Tech2 i ikone TIS2Web.
-WR | Adresa PC-a (obično 253558) s kojeg je dopušteno pisati u područje PCMCIA i FLASH ROM. Ova funkcionalnost mora se dodatno aktivirati preko izbornika (ili korištenjem opcije -WA). Potrebno je kako bi SingleStep Debugger ispravio pogreške u kodu nepromjenjive memorije.
-WA | Dopustite da SingleStep program za ispravljanje grešaka upiše u stalnu memoriju.
-OF | Opcijska datoteka koja sadrži opcijske/vrijednosne parove.
-TP | Podešavanje vremena (Proporcionalna vrijednost). Zadano na 5000. Povećajte ovu vrijednost da bi se broj izvršenih ciklusa brže primijenio na realno vrijeme.
-TD | Podešavanje vremena (Diferencijalna vrijednost). Zadano na 100. Smanjite ovu vrijednost za bržu reakciju na promjene trenutnog vremena. !UPOZORENJE!: Promjene vrijednosti TP-a i TD-a mogu dovesti do problema s brzinom.
-PJ
-PP 		Specificirajte protokol koji je potrebno koristiti:
PJ za komunikaciju J2534.
PP za ISO22900-2 / PDU-API (zadano)
-S | Prisutnost ovog izbora omogućuje zvučni signal na dojavljivaču računala.
-L | Jezik aplikacije Tech2Win. Ako ova stavka nedostaje, koristi se aktivan Windows jezik kao zadani jezik. Na sljedećoj vezi pogledajte popis jezika koje je moguće specificirati: Jezici. Emulacijsko okno Tech2 prikazat će jezik koji se nalazi na PCMCIA kartici (odnosno, koji je preuzet na PCMIA karticu).
-UD | Poništenje imenika s korisničkim podacima. Pod Win7, oni su normalno u C:\Users\Public\General Motors\Tech2Win
-AD | Poništenje imenika s podacima aplikacije. Pod Win7, oni su normalno u C:\ProgramData\General Motors\Tech2Win
-US | Za detekciju više od jednog slučaja Tech2Win-a, koristite specifičan semafor za korisnika. Ova opcija omogućit će svakom korisniku paralelan rad Tech2Win-a na istom stroju, po svoj prilici poslužitelju. Ako koristite ovu opciju, također trebate zadati i opcije -UD and -AD.
-SS | Opcija za zadavanje ukupne veličine prozora Tech2Win-a, uključujući tipkovnicu (ako postoji). Prvi parametar mora biti niz znakova omeđen dvostrukim navodnicima (') i koristit će se kao naziv veličine u izborniku Izbori / Rezolucija. Drugi parametar je ukupan broj vodoravnih piksela ekrana Tech2Win-a uključujući tipkovnicu. Treći parametar je ukupan broj okomitih piksela Tech2Win ekrana. Četvrti parametar, kao opcija, širina je tipkovnice u pikslima.
-SH Opcija za kontrolu rukovanja ekranom. Sljedeći decimalni broj koristi se za zadavanje koje će se mogućnosti rukovanja ekranom isključiti.
  • Bit 0: Nije moguć min/maks.
  • Bit 1: Nema premještanja po ekranu.
  • Bit 2: Nema promjene veličine. U ovom slučaju zasivljen je izbornik Izbori / Rezolucija.
  • Bit 3: Prikaz podataka i DTC prozori bit će posve jednake veličine kao i Tech2Win (bez tipkovnice)


Prijava

Prilikom svakog pokretanja konfiguracije Tech2Win-a, nastaje nova datoteka prijave u HTML obliku u podimeniku C:\Users\Public\General Motors\Tech2Win\Logs. Da biste izbjegli zagušenje tvrdog diska, datoteke zapisnika starije od tjedan dana bit će uklonjene.

Datoteke zapisa automatski dobivaju naziv prema datumu (godina, mjesec, dan) i vremenu (sat, minuta, sekunda) nastanka:
yyyy-mm-dd_hhmmss.html

Unosi datoteka zapisa uvijek su na engleskom, ali u formatu Unicode s vodećim Byte-Order-Mark (BOM). Svaka linija datoteke zapisa pripada jednoj od razina zapisa:

Razina zapisa | Značenje
Info | Samo informacije. Ne utječe na izvođenje programa.
Upozorenje | Dogodila se neuobičajena situacija. Korisnik možda neće primijetiti negativne učinke.
ERROR | Dogodila se pogreška koju će korisnik primijetiti.
CRITICAL | Dogodila se ključna pogreška koja će uzrokovati neuobičajeno ponašanje programa.
FATAL | Fatalna pogreška uzrokovat će prekid rada aplikacije Tech2Win.

Sve razine iznad 'Warning' (Upozorenje) obojene su kako biste ih lako razlikovali.

Nadalje, u poddirektoriju Logs (Zapisnici) nalazit će se datoteke za Print (Ispis) i videodatoteke, kao i ako upotrijebite mogućnosti izbornika Ispis zaslona (Ispis zaslona) ili Automatske snimke zaslona (Autom. snimke zaslona).
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
Automatske snimke zaslona Automatske slike zaslona povezane su HTML datotekom - stoga koristite zapisnik HTML-a kako biste vidjeli slijed slika.

Na traci statusa korisnik vidi upozorenje u Unosu upozorenja ( yellow lightning bolt) ili postoji nešto ozbiljniji unos zapisa ( red lightning bolt).


Poruke o pogreškama i izlazne šifre

Poruke o pogreškama prikazuju se u dijaloškim okvirima. Dijaloški okviri omogućuju aplikaciji Tech2Win da istovremeno izvodi program Tech2. Izlazne šifre su fatalne pogreške koje uzrokuju neuobičajeno rušenje aplikacije Tech2Win. Izlazne šifre mogu se koristiti u skupnim datotekama za utvrđivanje razloga rušenja programa.

Poruke o pogreškama

Mogu se pojaviti sljedeće poruke o pogreškama. Donosimo kratak opis situacije i kako je problem moguće riješiti.

Emulator too slow Emulator failed to start

Izlazne šifre

Izlazna šifra | Vrijednost | Značenje
OPCODE_ERROR | -7 | Otkrivena je nevažeća naredba mikroprocesora Tech2 (68332). Možda je PCMCIA slika nekako korumpirana.
ATA_PROBLEM | -6 | Iskrsnuo je problem tijekom ATA emulacije. Ako se navedeni problem prikaže nakon upute da koristite ATA karticu, obratite se službi za pomoć.
DEMO_TIME_IS_UP | -5 | Ne bi se smjelo pojavljivati u službenoj verziji aplikacije Tech2Win.
DLL_NOT_LOADED | -3 | Nije moguće učitati jedan od neophodnih DLL-ova. Čini se da imate nepotpunu kopiju aplikacije Tech2Win. Ponovite instalaciju i/ili odaberite drugi jezik.
EXIT_INIT_FAILED | -2 | Inicijalizacija nije uspjela. Pogledajte datoteku sa zapisnikom da biste utvrdili uzrok. Ako datoteka sa zapisnikom ne postoji, provjerite da imate ispravan pristup za čitanje/pisanje u sve direktorije.
normalno | 0 | Aplikacija Tech2Win normalno je zatvorena.


ATA kartica

U Tech2 ATA kartica se uglavnom koristi samo za potrebe rješavanja problema tijekom razvoja softvera. Svi potrebni ATA podaci spremljeni su u podimeniku C:\Users\Public\General Motors\Tech2Win\ataCapture. Ovaj direktorij nema nikakvu važnost i može se izbrisati osim ako ne postoje drukčije upute.

Budući da je direktorij ataCapture fiksan, njegov sadržaj će biti isti za sve konfiguracije.


Datoteke

Sljedeće datoteke i direktorije koristi aplikacija Tech2Win:

Imenik | Lokacija prije Viste | Lokacija za Vistu i iza nje
Instalacija | Kako je definirano tijekom instalacije
Podaci o korisniku | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Podaci o aplikaciji | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Datoteka | Koristi
[Podaci o korisniku]\atacapture | Sadrži datoteke prisutne na ATA kartici. Ako nije drukčije navedeno, ove datoteke nisu neophodne.
[Instalacija]\bin | Sadrži izvršne datoteke, neophodne DLL-ove i slike neophodne za izvođenje.
[Instalacija]\bin\emulator.exe | Glavna izvršna datoteka koja izvodi kod aplikacije Tech2.
[Instalacija]\bin\emulator_xx_XX.dll | Izvorni DLL na određenom jeziku.
[Instalacija]\bin\T2Configurator.exe | Konfiguracijski dio Tech2Win-a.
[Instalacija]\bin\Pictures | Sadrži ikone potrebne aplikaciji Tech2Win.
[Podaci o korisniku]\config | Sadrži sve konfiguracijske datoteke.
[Podaci o korisniku]\data | Sadrži datoteke koje su doživjele promjene tijekom izvođenja aplikacije Tech2Win. Ove su datoteke neophodne za ispravno izvođenje aplikacije Tech2Win. U osnovi ne biste smjeli dirati ove datoteke osim ako vam to nije izričito rečeno.
[Podaci o aplikaciji]\data | Sadrži datoteke koje su doživjele promjene tijekom izvođenja aplikacije Tech2Win. Ove su datoteke neophodne za ispravno izvođenje aplikacije Tech2Win. U osnovi ne biste smjeli dirati ove datoteke osim ako vam to nije izričito rečeno.
[Podaci o aplikaciji]\data\emulator.sec | Sigurnosna datoteka . Ne mijenjajte ovu datoteku.
[Podaci o aplikaciji]\data\emulator.card | Kartična datoteka. Sadrži sve PCMCIA kartice poznate programu Tech2Win. Ne mijenjajte ovu datoteku.
[Podaci o korisniku]\data\emulator.disp | Ova datoteka sadrži lokaciju i veličinu zaslona aplikacije Tech2Win. Ako obrišete ovu datoteku, ponovno će se stvoriti, a zaslon aplikacije Tech2Win pokrenut će se u gornjem lijevom kutu u veličini 640x480.
[Podaci o aplikaciji]\data\emulator.lic | Licencna datoteka. Sadrži informacije o trajanju valjanosti vaših licenci. Ne mijenjajte ovu datoteku.
[Podaci o aplikaciji]\data\emulator.rtc | Datoteka sa stvarnim vremenom. Datoteka se koristi kao spremište za podatke pronađene u RTC-u aplikacije Tech2.
[Podaci o aplikaciji]\data\emulator.dta | Datoteka informacija 'Don't tell me again' (nemoj mi reći ponovno).. Ova datoteka pohranjuje softverske verzije PCMCIA kartice koje više ne bi trebale prikazivati upozorenje o nemogućnosti sustava da izvede samotestiranje za koje je potreban prilagodnik povratne obrade.
[Podaci o aplikaciji]\data\candi.bin | Aplikacijska datoteka CANdi. Sadrži aplikaciju za CANdi koja je dodatak aplikaciji Tech2.
[Podaci o aplikaciji]\data\eprom.bin | Interna EPROM datoteka Tech2. Sadrži sadržaj interne flash memorije Tech2.
[Instalacija]\driver | Instalacijske datoteke za upravljački program virtualnog COM ulaza.
[Instalacija]\help\emulator_xx_XX.chm | Datoteke za pomoć na raznim jezicima.
[Podaci o korisniku]\Logs | Sadrži datoteke zapisnika. Datoteke starije od tjedan dana bit će automatski izbrisane.
[Podaci o korisniku]\pcmcia | Sadrži datoteke PCMCIA slika. Figurativno govoreći svaka datoteka odgovara jednoj Tech2 PCMCIA kartici. Ove datoteke moguće je po želji spremiti na različite lokacije.


Upravljanje konfiguracijom

Datoteke za konfiguraciju uvijek se nalaze u podimeniku C:\Users\Public\General Motors\Tech2Win\config i imaju ekstenziju datoteke *.conf. Aplikacija Tech2Win može se koristiti samo za stvaranje novih konfiguracijskih datoteka ili promjenu postojećih konfiguracijskih datoteka koji nisu samo za čitanje. Za sve druge oblike upravljanja konfiguracijskim datotekama upotrijebite Windows Explorer ili sličan program za upravljanje datotekama. To je potrebno za sljedeće aktivnosti:

  • brisanje konfiguracijskih datoteka
  • preimenovanje konfiguracijskih datoteka
  • promjenu atributa samo za čitanje konfiguracijske datoteke

Svakako preporučujemo da uvijek imate konfiguracijsku datoteku default.conf. Ova datoteka treba imati atribut samo za čitanje kako bi se izbjeglo slučajno prepisivanje. Međutim, ako mijenjate datoteku za svoje potrebe, morat ćete nakratko isključiti atribut samo za čitanje.

PCMCIA slike su u podimeniku C:\Users\Public\General Motors\Tech2Win\pcmcia. Svaka datoteka odgovara PCMCIA kartici s kojom ste se veće upoznali tijekom rada s Tech2. S aplikacijom Tech2Win možete imati preslika koliko želite. Samo kopirajte postojeću presliku pod novim nazivom.

Ako želite pokrenuti određenu konfiguraciju izravno s radne površine, načinite prečac koji izvršava "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Program bi se trebao pokrenuti iz sljedećeg radnog imenika: 'C:\Program Files\General Motors\Tech2Win\bin'

Broj konfiguracijskih datoteka ne ovisi o broju pcmcia preslika koje koristite. Možete imati nekoliko konfiguracijskih datoteka uz istu PCMCIA presliku. Na ovaj se način simulira situacija u servisnoj radionici kada nekoliko mehaničara dijeli istu aplikaciju Tech2 (i istu PCMCIA karticu).

Možete odabrati da svaka konfiguracija koristi svoju PCMCIA presliku. Tako ćete pojedine konfiguracije učiniti međusobno neovisnima. Međutim, možda vam se neće isplatiti ažurirati svaku PCMCIA presliku.

Ako radite novu konfiguraciju kopiranjem postojeće, program za konfiguraciju će prikazati upozorenje, ako PCMCIA slika nije promijenjena. U takvom slučaju imali biste dvije konfiguracije koje koriste istu PCMCIA sliku. Ako je to ono što želite, samo pritisnite OK. Ako želite da nova konfiguracija koristi različitu ili novu PCMCIA sliku, tada pritisnite Poništite. Zatim možete izabrati izradu nove slike pomoću Kopiraj memorijsku karticu ...

Donosimo dva primjera načina rukovanja konfiguracijama i PCMCIA preslikama.

Jedna konfiguracija po korisniku

Imate mogućnost spremiti konfiguraciju za korisnika. Naziv konfiguracije bit će korisnikovo ime za tu sesiju. Prednosti ovog koncepta ogledaju se u tome što je moguće podesiti postavke specifične za korisnika kao što su osobno sučelje za komunikaciju s vozilom (MDI) te postavke prikaza i jezika. Nedostatak je što ćete morati kopirati PCMCIA datoteke ako isti softver koristi nekoliko korisnika. Naravno, korisnički definirane konfiguracije mogu koristiti središnju PCMCIA datoteku.

Jedna konfiguracija po Tech2 softveru

Možete odlučiti napraviti novu konfiguraciju za svaki softver koji preuzmete. Tako će vam i starije verzije softvera biti odmah dostupne ako vam je potrebno. Često se u tim slučajevima za naziv konfiguracije postavlja naziv i broj verzije softvera.

  • Prvi koraci: Sučelje za komunikaciju s vozilom
  • Prvi koraci: Staza
  • Napredne teme: Konfiguracijska datoteka
  • Instalacija: Koraci instalacije


Često postavljana pitanja (FAQ)

  • Kako mogu utvrditi koji ulaz trebam koristiti za Tech2Win?
  • Komunikacija između Tech2Win i aplikacije TIS2Web
  • Valjana licenca
  • Što označava broj licence?
  • Koja je razlika između licence za Tech2Win i sigurnosnog pristupa?
  • Prilikom sigurnosnog pristupanja inicijalnom softveru, TIS2Web pokazuje nespecifičnu grešku.
  • Tech2Win ne izvodi Tech2 softver s drugog područja
  • Kako mogu koristiti više MDI-ja?
  • Datoteka zapisnika sadrži pogrešku 'CPU32: Too many 0000/FFFF Commands encountered'
  • Ne vidi se prozor Tech2
  • SPS ne radi
  • Neki samotestovi ne rade
  • Pokazivač brzine se mijenja
  • Naglo zaustavljanje
  • Software 15.001 prikazuje se na švedskom jeziku
  • Gubitak komunikacije s MDI-em
  • Tech2Win nije pronašao moj MDI
  • Želim odmah pokrenuti Tech2Win, bez gubljenja vremena s konfiguratorom
  • Gdje su funkcije za ispis?
  • Na mojem računalu nalazi se 'nekorišena' PCMCIA mapa
  • Dobivam poruku 'nelegalan put do datoteke'

Kako mogu utvrditi koji ulaz trebam koristiti za Tech2Win?

Možete upotrijebiti 'Upravitelj uređaja' sustava Windows, potražite 'Ulazi (COM&LPT)'. Neka računala imaju ugrađene interne modeme ili bluetooth uređaje koji nisu prikazani u ovoj kategoriji.
Drugi je način upotreba male naredbe koja se isporučuje uz konfigurator. Možete je pokrenuti putem startnog izbornika (mapa Tech2Win) klikom na 'show com ports'.
Obje metode prikazuju com ulaze instalirane na računalu koje NE biste trebali koristiti.

Komunikacija između Tech2Win i aplikacije TIS2Web

Važno je da prvo pokrenete Tech2Win prije nego što uspostavite komunikaciju s aplikacijom TIS2Web radi sigurnosnog pristupa ili preuzimanja softvera. TIS2Web može prepoznati virtualni COM ulaz samo kada se Tech2Win izvodi.

Valjana licenca

Obično ćete s preuzimanjem softvera iz aplikacije TIS2Web dobiti i valjanu licencu. Ako još nemate licencu, prijavite se u aplikaciju TIS2Web (ne TIS2000) pomoću 'Sigurnosni pristup (Sigurnost)' da biste dobili valjanu licencu. Nemojte provoditi nijednu drugu TIS2Web komunikaciju s Tech2Win-om, poput 'Učitavanje softvera (SWDL)', prije nego što dobijete licencu putem 'Sigurnosni pristup (Sigurnost)'.

Što označava broj licence?

Licencni broj s desne strane trake stanja pokazuje broj dana valjanosti licence. Odmah po preuzimanju ili sigurnosnom pristupu prikazuje se 30 dana. Nakon novog pokretanja Tech2Win, prikazuje se broj 29 jer licenca vrijedi još otprilike 29 dana, 23 sata i 55 minuta. Ako broj dana valjanosti licence padne ispod 24 sata, prikazuje se trajanje licence <1. 0 se prikazuje ako je licenca istekla.

Koja je razlika između licence za Tech2Win i sigurnosnog pristupa?

Licenca Tech2Win omogućuje vam upotrebu programa Tech2Win. Da biste dobili licencu, morate preuzeti softver ili sigurnosni pristup u redovnim intervalima (obično svakih 30 dana). Preuzimanjem putem lokacije TIS2Web program Tech2Win dobiva obavijest da postoji valjani korisnik. Sigurnosni pristup, kakav postoji u Tech2, obavještava Tech2Win da su dopuštene određene aktivnosti vezane uz sigurnost, kao na primjer isključenje rada zračnog jastuka. Licencu za Tech2Win i sigurnosni pristup moguće je dobiti putem aplikacije TIS2Web Security Access. Tech2Win prikazuje preostalo trajanje licence na traci stanja s desne strane. Nažalost, Tech2Win ne može prikazati trajanje sigurnosnog pristupa jer Tech2Win jednostavno izvodi softver Tech2, ali nema nikakav uvid u sam softver Tech2.

Prilikom sigurnosnog pristupanja inicijalnom softveru, TIS2Web pokazuje nespecifičnu grešku.

Ponašanje je jednako kao na Tech2. Zbog svoje starosti, inicijalni softver nije u mogućnosti pribaviti licencu od TIS2Web-a. Međutim, to nije stvarni problem, budući da taj softver za demonstraciju ne komunicira s vozilom, za koje je potrebna licenca. I budući da licence važe za preuzimanje kopiranjem TIS2Web-a, svakako biste, nakon preuzimanja Tech2 softvera, trebali pribaviti licencu za svako pojedino preuzimanje. 'Licenca' za inicijalni softver ne bi vam dala pravo da uspostavite komunikacije vozila sa Sjevernoameričkim operacijama ili Opel/Vauxhallovim softverom

Tech2Win ne izvodi Tech2 softver s drugog područja

Vaša verzija Tech2Win-a vjerojatno je ograničena na jedno ili nekoliko preuzimanja kopiranjem TIS2Web-a (regije). Pritisnite Pomoć / O da vidite koja se ograničenja primjenjuju na vašu verziju Tech2Win-a. Ranije verzije Tech2Win-a dopuštale su samo izvršavanje Opel/Vauxhallovog softvera. Druge GM regije će uslijediti. U svakom slučaju, Tech2Win trenutačno može izvoditi softver Tech2 tvrtke General Motors.

Kako mogu koristiti više MDI-ja?

Ako želite dodijeliti određene MDI-je određenim korisnicima, predlažemo vam da svaki korisnik ima svoju konfiguraciju. Naravno, konfiguracije je potrebno nazvati u skladu sa svakim korisnikom. U svaku konfiguraciju treba unijeti serijski broj specifičnog MDI-ja korisnika na karticu 'Sučelje za komunikaciju s vozilom' (Sučelje za komunikaciju s vozilom). Čim korisnik pokrene ovu konfiguraciju, Tech2Win će pokušati uspostaviti kontakt sa specifičnim MDI-jem. Samo ako traženi MDI nije pronađen, u okviru za odabir prikazat će se svi MDI-jevi koje je program Tech2Win uspio pronaći.

Ako imate nekoliko MDI-ja za opću upotrebu, predlažemo da koristite konfiguracije u kojima nije upisan serijski broj sučelja za komunikaciju s vozilom na kartici 'Sučelje za komunikaciju s vozilom' (Sučelje za komunikaciju s vozilom). Tako će korisnik uvijek vidjeti okvir za odabir dostupnih MDI-ja.

Datoteka zapisnika sadrži pogrešku 'CPU32: Too many 0000/FFFF Commands encountered'

Datoteka 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' ili trenutačna PCMCIA datoteka su oštećene. Napravite reinstalaciju Tech2Win i preuzmite novi Tech2 softver.

Ne vidi se prozor Tech2

Ako ne vidite Tech2 prozor, vjerojatno se nalazi u području koje nije prikazano na vašem zaslonu. To se može dogoditi nakon upotrebe više zaslona ili nakon promjene razlučivosti zaslona. Pritisnite tipku Shift na tipkovnici tijekom pokretanja konfiguracije. U slučaju da razlučivost prozora postavite na 640x480, prozor Tech2 bit će prikazan u gornjem lijevom kutu zaslona. Također možete izbrisati datoteku C:\Users\Public\General Motors\Tech2Win\emulator.disp kako biste postigli nekakav učinak.

U nekim slučajevima dogodilo se da se prozor aplikacije Tech2Win ne bi ponovno prikazao na zaslonu nakon zatvaranja prozora svih drugih aplikacija. U svim dosadašnjim slučajevima zaslon programa Tech2Win uspjeli smo vratiti upotrebom tipki Alt+Tab za prebacivanje između prozora Windows aplikacija. Može se dogoditi da gumb Tech2Win na alatnoj traci u donjem dijelu zaslona vašeg računala ne radi. Ovaj problem još proučavamao i nadamo se da ćemo ga riješiti u novijim verzijama aplikacije Tech2Win.

SPS ne radi

Da, znamo. Ne planiramo to promijeniti. Ne biste trebali koristiti Tech2Win kao Tech2 zamjenu za izvođenje SPS-a. Koristite MDI izravno sa SPS programiranjem kroz TIS.

Neki samotestovi ne rade

Samotestovi programa Tech2 namijenjeni su testiranju pojedinačnih dijelova hardvera Tech2. Neki od ovih testova zahtijevaju upotrebu prilagodnika za povratnu obradu. Ovi testovi neće raditi u programu Tech2Win jer nije implementirana funcija povratne obrade (niti je to u planu). Suzdržavajte se od takvih besmislenih testova u programu Tech2Win. Ako ih krenete izvoditi, možete dobiti neispravne rezultate ili će Tech2Win prestati raditi, kao što bi i Tech2 bez prilagodnika za povratnu obradu. U tom slučaju upotrijebite Ctrl-R za ponovno pokretanje Tech2Win.

Pokazivač brzine se mijenja

Pokazivač brzine na donjem lijevom dijelu trake stanja pokazuje koliko je 'naredbi Tech2' moguće izvesti prije nego što Tech2Win ponovno ode u stanje mirovanja. Ova se metoda koristi kako bi vrijeme na Tech2Win odgovaralo stvarnom vremenu: brža računala duže su u stanju mirovanja od sporijih. Ako se pokazivač brzine mijenja, tada možda neki drugi programi koriste snagu računala ili sat PC-a nije ispravan. Visoke stope fluktuacije imaju negativan učinak na komunikaciju s vozilom i komunikacijom s TIS2Webom. Uvjerite se da drugi programi nisu otvoreni.

Većina prijenosnih računala može automatski smanjiti takt procesora kako bi se produžilo trajanje baterije. I to može utjecati na varijacije u brzini koje je uočio Tech2Win. U tom slučaju prijenosno računalo ne pokrećite na bateriju, već koristiti vanjski izvor napajanja. Možete pokušati promijeniti postavke upotrebe snage tako da operativni sustav ne smanjuje brzinu takta.

Naglo zaustavljanje

Ako u datoteci zapisnika ne pronađete nikakav razlog za prekid programa, možda su aktivirani interni sigurnosni mehanizmi softvera Tech2Win. Ne mijenjajte sljedeće datoteke: emulator.sec, emulator.lic, emulator.card. Ako Tech2Win utvrdi da je došlo do povrede sigurnosti, vrlo vjerojatno ćete morati napraviti reinstalaciju.

Software 15.001 prikazuje se na švedskom jeziku

Inicijalni softver koji stiže s Tech2Win demonstracijski je softvere koji se nalazi na svakoj PCMCIA kartici. TIS2Web naznačuje da je na švedskom jeziku jer TIS2Web prikazuje samo posljednji jezik s popisa četiri jezika koje ovaj pokazni softver podržava (engleski, francuski, njemački, švedski). Upotrijebite način ažuriranja 'Prilagođeno' (Prilagođeni) umjesto 'Standardno' (Standardni) da biste prepisali ovaj pokazni softver najnovijim dijagnostičkim softverom.

Gubitak komunikacije s MDI-em

Gubitak komunikacijse s MDI-em može se dogoditi iz nekoliko razloga.

  • Loša kabelska veza (mrežni kabel i USB).
  • Nepostojana bežična veza.
  • Računalo je u stanju čekanja.

Tech2Win nije pronašao moj MDI

Provjerite sljedeće:

    1. Je li MDI aktivan?
    2. Radi li Upravitelj MDI-ja?
    3. Da li MDI koristi neka druga aplikacija, kao što je to SPS?
MDI menadžera možete pokrenuti pomoću njegove ikone na radnoj površini ili putem 'Start/All Programs/General Motors/GM MDI Software'.: Nazovite korisničku službu za pomoć ako točka 2 ne radi.

Želim odmah pokrenuti Tech2Win, bez gubljenja vremena s konfiguratorom

Izvršite "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Koristite sljedeći radni imenik: 'C:\Program Files\General Motors\Tech2Win\bin' I dalje možete koristiti konfigurator, kako biste načinili promjene u konfiguraciji.

Gdje su funkcije za ispis?

Tech2Win ne nudi funkcionalnost izravnog ispisa. Umjesto toga, on kreira privremene datoteke i poziva programe povezane s nastavcima datoteka. Ti programi se mogu koristiti u svrhu ispisivanja, omogućujući vam podešavanje izgleda vašeg ispisa.

Print Report | Print Report

Za ispis trenutnog Tech2Win ekrana, koristite stavku izbornika Datoteka / Ispis zaslona ili tipku na tipkovnici koja na sebi ima pisač. Ako trebate ispisati nekoliko Tech2Win ekrana, tada možete koristiti stavku izbornika Izbori / Automatske snimke zaslona, jer ona kreira PNG datoteke za svaki Tech2Win ekran. Ove PNG datoteke spremaju se u datoteku prijava.

Također možete ispisati sadržaje prikaza podataka (aktivira se pomoći stavke izbornika Prozor / Podatkovni prikaz Tech2Win). Za pokretanje, a zatim zaustavljanje dobave podataka koristite tipku Ispiši/početak HTML-a. Nakon zaustavljanja dobave, pokreće se izvršni program povezan s HTML-om (uobičajeno Internet Explorer), koji vam pruža puno mogućnosti za ispis vaših podataka.

Data Display | Data Display

Na mojem računalu nalazi se 'nekorišena' PCMCIA mapa

Prijašnje verzije Tech2Win-a uvijek su imale spremanje duplikata PCMCIA datoteka u zasebnom imeniku. Ovaj imenik je često bio C:\PCMCIA. Sada se taj imenik više ne koristi, jer brzo kopiranje s TIS2Web-a čini drugo spremanje takvih kopiranih datoteka nepotrebnim. Možete posve sigurno izbrisati ovaj imenik.

Dobivam poruku 'nelegalan put do datoteke'

Čini se da naziv datoteke sadrži nelegalan znak, poput znaka za postotak (%) Ako uočite problem odmah nakon instaliranja, bilo bi najbolje da jednostavno provedete deinstaliranje i ponovno instaliranje. Većina slučajeva mogla bi se riješiti ovom metodom.

Tijekom normalnih instaliranja, varijabla okruženja 'Tech2WinUserData' postavlja se na 'PUBLIC' (za inačice Windows >= Vista) i na 'ALLUSERSPROFILE\Documents' (za inačice Windows prije Vista). U nekim rijetkim slučajevima, varijabla okruženja nije bila postavljena tijekom procesa instaliranja, ali je radila dobro pri drugom pokušaju. Mogli biste izabrati i ručno postavljanje varijable okruženja. Ako ne znate kako postaviti varijablu okruženja, zatražite pomoć od svojeg administratora.


Unosi registra

Sljedeće unose registra generira instalater. Ne mijenjajte ove unose ručno. Imajte na umu standardna Windows upozorenja prilikom rukovanja s unosima u registar.

ključ registra | naziv | vrsta | značenje
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Broj interne verzije
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Jezik | REG_SZ | instalirani jezik
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Staza do direktorija kopije PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Korijen | REG_SZ | putanja instalacije
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Opcija Deinstalacija | REG_DWORD | Postavka za deinstalaciju
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Verzija konfiguracijske datoteke
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Verzija upravljačkog programa Virtualnog COM-Porta
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Naziv softvera na popisu Dodaj/Ukloni program
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Staza do programa za deinstalaciju


Reinstalacija

Ponovna instalacija će obrisati kompletan imenik za instalaciju Tech2Win-a, uz sljedeće izuzetke.

  1. Podimenik config koji sadrži konfiguracije nije obrisan.
  2. Podimenik pcmcia, koji normalno sadrži PCMCIA slike, nije obrisan.
  3. Podimenik ATA, koji bi mogao sadržavati informacije o traženju i ispravljanju grešaka, nije obrisan.
Konfiguracijske datoteke mogu postati nekompatibilne: nema jamstva da će konfiguracijske datoteke starije verzije aplikacije Tech2Win biti čitljive u novijoj verziji aplikacije Tech2Win. PCMCIA preslike u načelu ne mogu postati nekompatibilne.

Reinstalacija ne utječe na sekundarni PCMCIA direktorij.

Neka okruženja mogu ponuditi automatsku instalaciju novije verzije aplikacije Tech2Win. Budući da su informacije o posljednjoj instalaciji pohranjene u registru, ove postavke postavit će se kao zadane tijekom ponovno instalacije.

Možete potaknuti reinstalaciju Tech2Win upotrebom skripte enable reinstallation. Skripta se instalira zajedno s Tech2Win. U osnovi ova skripta postavlja tipku CurrentVersion u registru na poziciji HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win na vrijednost '1.000'.