Manuel d'utilisation de Tech2Win

Bienvenue dans le manuel d'utilisation de Tech2Win

Copyright (C) 2010..2016 SPO Engineering General Motors Touts droits réservés

  • Présentation:
  • Licence:
  • Installation:Description de la procédure d'installation de Tech2Win.
    • Étapes d'installation
    • Interface VCI (Vehicle Communication Interface)
  • Premières étapes
    • Sélection d'une configuration
      • Clavier
      • Gestion Windows
    • Nouvelles configurations
    • Modification des configurations
      • Langue
      • Chemin
      • Affichage
      • Enregistrement d'une configuration
    • Obtenez une licence Tech2Win valide.
  • Utilisation de Tech2Win: Décrit le travail quotidien
    • Menu
    • Téléchargement d'une image PCMCIA
    • Sécurité
    • Afficher les rapports
    • Gestion des images PCMCIA
    • Barre d'état
  • Rubriques avancées: Informations non nécessaires pour l'utilisation normale de Tech2Win. Concernent généralement les personnes chargées des tâches d'administration.
    • Réinstallation
    • Désinstallation
    • Format du fichier de configuration
    • Fichier journal
    • Messages d'erreur et codes d'erreur
    • Carte ATA
    • Entrées de registre
    • Fichiers
    • Configuration
  • FAQ


Présentation

Tech2Win est une application Windows qui peut émuler la fonctionnalité Tech2. Généralement, le logiciel Tech2 est exécuté sur un PC. Pour exécuter ce programme, vous devez utiliser un PC ayant la configuration suivante :

  • Une interface de communication véhicule doit être installée sur le PC et connectée au PC. La liste des interfaces compatibles varie en fonction des régions. Dans la plupart des cas, l'interface MCI (Multiple Diagnostic Interface) de GM peut être utilisée.
  • L'application Tech2Win nécessite un espace disque de 150 Mo pour l'installation. 32 Mo supplémentaires sont nécessaires par carte flash PCMCIA à gérer.
  • Avant d'exécuter l'application TechWin2, vous devez disposer au minimum de 100 Mo de mémoire RAM physique libres Le PC doit disposer d'une mémoire suffisante pour placer l'application dans la mémoire RAM pendant toute la durée d'exécution.
  • Le PC doit disposer d'un processeur Pentium de 1,2 GHz (un seul coeur) ou équivalent. Il est vivement recommandé de ne pas utiliser d'autres applications simultanément.
  • Un clavier n'est pas nécessaire. Tech2Win fonctionne également avec un écran tactile. Pour la gestion de la configuration, il est vivement recommandé d'utiliser un clavier, car vous devrez entrer des noms de fichier.
  • Votre écran graphique couleur doit avoir une résolution de 800 x 600 avec une palette de 256 couleurs minimum. Sans pavé numérique, une résolution de 640 x 480 peut être acceptable.

Lorsque vous utilisez Tech2Win (un ordinateur portable au lieu d'un Tech2), vérifiez que l'ordinateur est suffisamment puissant. Normalement, l'ordinateur portable ne doit pas être alimenté par la batterie du véhicule, contrairement à Tech2.

  • Installation
  • Premières étapes


Licence

General Motors - Contrat de licence du logiciel Tech2Win

Lisez attentivement les conditions du contrat de licence avant d'utiliser ce programme. Si vous n'acceptez pas les conditions du contrat de licence ou que vous ne les comprenez pas, contactez le représentant du service après-vente le plus proche. Le droit d'utiliser ce logiciel n'est accordé par General Motors que si l'utilisateur consent à accepter les conditions du contrat de licence lors de l'installation du logiciel Tech2Win.
General Motors accorde le droit d'utiliser le logiciel Tech2Win et les informations qu'il contient en conjonction avec TIS2Web ou GlobalTIS ou TIS2000 exclusivement aux utilisateurs du réseau de réparateurs agréés de General Motors comme cela est déterminé dans le Contrat de réparateur agréé en vigueur sur le lieu d'utilisation avec les points de vente nationaux de General Motors.
La licence Tech2Win est effective tant que le Contrat de réparateur agréé est en vigueur et que la licence TIS2Web, GlobalTIS et TIS2000 est en place. La licence Tech2Win expirera conjointement avec TIS2Web et la licence GlobalTIS, immédiatement une fois l'Accord réparateur autorisé terminé.

Les réparateurs indépendants comme définis dans l'article 4, paragraphe 2 de l'European Union Block Exemption Regulation (BER) 1400/2002 peuvent acheter une licence Tech2Win comme partie des abonnements offerts dans le GM Europe Info Tech Portal de General Motors Europe.

La licence Tech2Win n'inclut ni l'interface de communication du véhicule ni le matériel informatique.

Une tierce partie quelconque en dehors du réseau de réparateurs agréés (voir description dans l'annexe correspondante du Contrat de réparateur agréé) ne doit pas avoir accès au logiciel Tech2Win après que celui-ci ait été redistribué, vendu ou publié en ligne sans l'autorisation écrite des points de vente nationaux concernés de General Motors. Cela s'applique à la fois aux données en cours et celles non en cours (notamment les DVD périmés).

Les points de vente nationaux de General Motors doivent avoir le droit de fermer immédiatement l'accès et de donner un préavis d'abrogation immédiate du Contrat de réparateur autorisé en cas d'utilisation non autorisée ou abusive. Si cela devait se produire, le droit de réclamer le remboursement du solde créditeur et/ou des frais de base annuels doit être refusé.

Les informations fournies servent à la réalisation des travaux de maintenance et de réparation de manière professionnelle sur les véhicules General Motors non modifiés. La réalisation de tels travaux requiert le respect de certaines conditions préalables, à savoir le suivi d'une formation technique automobile et de formations continues régulières. Lorsque les informations fournies font référence à l'utilisation d'outils spéciaux, le recours à ces outils est obligatoire lors de toutes les réparations réalisées de manière professionnelle.

Les informations publiées sur le logiciel Tech2Win de General Motors (notamment, le texte et les images, les enregistrements audio, les graphiques, les animations et les séquences vidéo) et la présentation de ces dernières sur le logiciel Global TIS sont protégées par le copyright. Aucune reproduction, diffusion, communication et/ou transmission ou toute autre utilisation n'est autorisée sans l'autorisation écrite préalable de General Motors.

  • Installation: Étapes d'installation
  • Premières étapes


Installation

L'installation de Tech2Win nécessite de disposer de droits d'administration sur le PC. L'installation ne peut pas être effectuée sans droits d'administrateur. Dans ce cas, contactez l'administrateur du PC local pour demander une assistance.

Pour utiliser correctement Tech2Win, exécutez les deux étapes suivantes :

  • Installation de Tech2Win.
  • Installation d'une interface VCI (Vehicle Communication Interface).
  • Installation: Étapes d'installation
  • Premières étapes


Étapes d'installation

L'installation elle-même prend à peine quelques minutes et requiert les entrées utilisateur suivantes :

  1. Contrat de licence
  2. Répertoire d'installation

Langue

Par défaut, Tech2Win UI s'affichera dans la langue de votre système d'exploitation. Les langues suivantes sont généralement prises en charge. Si votre langue n'est pas prise en charge, l'installateur démarre en anglais, comme langue d'installation par défaut.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Anglais (britannique ou américain)*
  • el_GR (EL)Greek
  • es_ES (ES)Espagnol
  • fi_FI (FI)Finnish
  • fr_FR (FR)Français
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugais (Brésil)
  • pt_PT (PT)Portugais (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Chinois (simplifié)
  • zh_TW (ZH)Chinois (traditionnel)

* La langue de Tech2Win est l'Anglais Britannique. Cependant, l'installateur et le logiciel Tech2 que vous utilisez peut être réglé sur Anglais Américain, en fonction de l'origine du logiciel.

Contrat de licence

Vous devez accepter le contrat de licence.

Répertoire d'installation

Vous pouvez choisir n'importe quel répertoire pour installer Tech2Win. Par défaut, le répertoire d'installation est <votre répertoire des programmes>\General Motors\Tech2Win ou, dans le cas d'une réinstallation, l'emplacement défini précédemment.

La dernière étape consiste à confirmer l'installation.

Pilote du port de communication virtuel

Le pilote du port de communication virtuel n'est installé qu'une fois sur votre ordinateur et y demeure jusqu'à ce que la version de pilote soit mise à niveau (se produit rarement) ou lorsque Tech2Win est désinstallé de votre ordinateur.
Si le pilote est en cours d'installation, vous apercevrez brièvement une fenêtre DOS. Elle se ferme automatiquement et ne nécessite aucune action. Les fichiers du pilote sont ajoutés dans le sous-dossier 'pilote' de votre répertoire d'installation de Tech2Win.
Il est possible, mais non recommandé, d'installer ou désinstaller manuellement les pilotes de port de communication virtuel. Utilisez l'une des commandes suivantes de l'interpréteur de commandes CMD :

  • Appelez 'vbsetup7' pour installer le pilote
  • Appelez 'vbsetup7 /u' pour désinstaller le pilote
  • Premières étapes


Interface VCI (Vehicle Communication Interface)

Le périphérique de communication véhicule doit être installé séparément. Reportez-vous au guide d'insallation fourni avec l'interface VCI (Vehicle Communication Interface).

  • Premières étapes: Interface VCI (Vehicle Communication Interface)
  • Rubriques avancées: Fichier de configuration
  • Installation: Étapes d'installation
  • FAQ: Comment utiliser plusieurs interfaces MDI ?
  • FAQ: Tech2Win n'a pas trouvé mon interface MDI.


Premières étapes

Ces premières étapes expliquent comment utiliser TechWin2. Elles supposent que vous savez utiliser Tech2. La communication véhicule n'est pas nécessaire au cours de ces étapes.

Pour effectuer un démarrage rapide, procédez ainsi :

  1. Exécutez le logiciel Tech2Win à l'aide du raccourci QuickStart situé sur le Bureau.
  2. Obtention d'une licence valide en téléchargeant le nouveau logiciel Tech2 à partir de TIS2Web.

Pour utiliser une configuration sélectionnable :

  1. Démarrez le configurateur via le raccourci Tech2Win situé sur le Bureau. Après l'installation, une configuration par défaut doit exister.
  2. Pour créer une configuration, il est recommandé de copier la configuration par défaut.
  3. Modifiez une configuration existante pour répondre à vos exigences spécifiques.
  4. Obtenez une licence valide.

Ne démarrez pas Tech2Win en mode compatibilité. Dans le cas contraire, un avertissement apparaît dans le fichier journal. Tech2Win utilise uniquement des fonctions Windows existant depuis XP, et ne fonctionne pas sous des versions Windows antérieures.

  • Premières étapes: Nouvelles configurations
  • Premières étapes: Modification des configurations
  • Premières étapes: Interface VCI (Vehicle Communication Interface)
  • Utilisation de Tech2Win: Menu
  • Utilisation de Tech2Win: Sécurité
  • Utilisation de Tech2Win: Barre d'état
  • Rubriques avancées: Fichier de configuration


Sélection d'une configuration

Lorsque vous démarrez l'application Tech2Win pour la première fois, l'écran suivant apparaît. Vous pouvez démarrer Tech2Win directement avec une configuration par défaut. Cette configuration par défaut fonctionne sans communication véhicule.

Start First Time

Le message d'information de licence s'affiche, mais vous pouvez l'ignorer pour démarrer la configuration par défaut.

Lorsque vous utilisez un écran tactile, il peut être utile de démarrer le programme de clavier PC pour entrer des caractères via cette application qui simule un clavier.


Clavier

Les touches du clavier PC, ainsi que les boutons, sont associés aux touches familières Tech2. Tech2Win fournit des touches supplémentaires qui ne se trouvent pas dans Tech2. Le pavé numérique du PC peut ne pas fonctionner dans tous les cas. En cas de problème, vérifiez que la configuration de clavier standard du PC n'a pas été modifiée. Dans ce cas, la touche MAJ, notamment, peut être endommagée.

Clavier PC | Bouton | Fonction
Touche de fonction F1 | s/o | Aide Tech2Win
Touches de fonction F5..F8 | Utilisez la zone d'affichage Tech2Win occupée par les touches programmables. | Quatre touches de programmation Tech2
Touches de direction Haut, Bas, Gauche, Droite |  | Touches Tech2 Haut, Bas, Gauche, Droite. Seules ces touches ont une répétition automatique
Touches 0..9 | F0 • • • F9 | Touches Tech2 F0..F9
Retour arrière | Exit | Touche Quitter Tech2
Entrée/Retour | Enter | Touche Entrée Tech2
Y | Yes | Touche Oui Tech2
N | No | Touche Non Tech2
Q | ? | Touche ? Tech2
S | Shift | Touche Majuscules Tech2; L'indicateur Maj situé dans la barre d'état ou au-dessus du bouton Maj indique l'état correspondant.
ctrl-P | PWR | Touche Marche Tech2; À l'évidence, cette touche peut uniquement arrêter l'application Tech2Win.
ctrl-R | non disponible | Réinitialise Tech2Win. Similaire à un cycle Arrêt/Marche sur Tech2. Toutefois, une interface VCI (Vehicle Communication Interface) attachée n'est réinitialisée. Des fichiers, tels que l'image PCMCIA, ne sont pas rechargés.
Origine | Home | Touche Origine Prise en charge par certaines applications uniquement.
disponible uniquement via l'option de menu Fichier. | Print Screen | Imprime une capture de l'écran Tech2 en créant un fichier temporaire BMP et en exécutant l'application associée aux fichiers BMP. Utilisez cette application pour redimensionner ou faire pivoter l'image avant de l'imprimer.
disponible uniquement via l'option de menu Fichier. | Save Screen | Enregistre une capture de l'écran Tech2 sous la forme d'un fichier BMP ou PNG.
disponible uniquement via l'option de menu Fichier. | View Report | Affiche tous les rapports dans la carte flash PCMCIA active pour permettre à l'utlisateur de les afficher.


Gestion Windows

Vous pouvez redimensionner les fenêtres en utilisant les fonctions Windows en faisant glisser les bords de la fenêtre principale. En outre, l'option de menu Options/Résolution prend en charge plusieurs tailles prédéfinies. Au cours du redimensionnement de la fenêtre principale via l'option de menu, la fenêtre du pavé numérique reste systématiquement ancrée.

Pour changer l'apparence des fenêtres, changez la configuration dans l'onglet Affichage.


Nouvelles configurations

Cliquez sur le bouton Créer pour créer une configuration. Un menu apparaît avec un message demandant de sélectionner un fichier de configuration existant comme source. Normalement, la configuration par défaut est sélectionnée. Après avoir entré le nom du nouveau fichier de configuration, cliquez sur le bouton Copier.

Si vous utilisez un écran tactile, il est préférable d'activer une simulation de clavier PC en utilisant le bouton Clavier PC.

Le bouton Annuler permet d'annuler la procédure de création.

La nouvelle configuration utilise le même fichier PCMCIA que la configuration source existante. Pour modifier cela, vous devez modifier la configuration afin qu'un autre fichier PCMCIA soit utilisé. Il suffit généralement de copier le fichier PCMCIA existant vers un nouveau fichier puis d'utiliser ce dernier. Vous préférez peut-être que votre nouvelle configuration utilise le même fichier PCMCIA que votre configuration source. Dans ce cas, un écran d'avertissement s'affiche lorsque vous appuyez sur le bouton Enregistrer.

  • Modification des configurations


Modification des configurations

Les configurations en bleu sont en lecture seule et elles ne peuvent pas être modifiées. Ces configurations peuvent être uniquement affichées. Naturellement, vous pouvez utiliser la méthode de modification pour afficher simplement leur contenu, mais vous ne pouvez pas utiliser Enregistrer.

Pour modifier une configuration, sélectionnez l'option dans les quatre onglets Langue, Interface VCI (Vehicle Communication Interface), Chemin, Affichage. Vous pouvez sélectionner le tabulateur approprié ou simplement cliquer sur le bouton Suivant qui activera le tabulateur suivant. Après avoir effectué les modifications, cliquez sur Enregistrer pour enregistrer la configuration.

Lorsque vous devez entrer des données au clavier, vous pouvez également appeler une application PC qui simule un clavier PC. Cela est particulièrement pratique sur les ordinateurs à écran tactile lorsque aucun clavier n'est disponible.


Langue

L'onglet Langue permet de sélectionner la langue de Tech2Win. Cette sélection n'a aucun impact sur la langue dans le logiciel Tech2 dans l'image PCMCIA. Lorsque vous téléchargez le logiciel Tech2 depuis TIS, vous devez toujours sélectionner la langue appropriée.

Les langues ne sont pas toutes disponibles pour certaines régions. Dans ce cas, l'anglais s'affiche. Vérifiez si une langue similaire est disponible (PT portugais du Portugal au lieu de PB portugais brésilien).


Chemin

L'onglet Chemin permet de définir les chemins des images PCMCIA et le chemin d'accès au clavier logiciel local. En outre, le bouton Copier carte mémoire permet de copier les images PCMCIA. Si vous venez de créer une configuration, utilisez ce bouton afin d'éviter la présence de plusieurs configurations utilisant la même imag PCMICA.

Memory Card Options

Copier carte mémoire ...

Ce bouton permet de copier une imager PCMCIA vers un fichier. Sa fonctionnalité est très similaire à l'achat d'une nouvelle carte PCMCIA pour Tech2. La fonction de copie fonctionne uniquement pour les fichiers du répertoire C:\Users\Public\General Motors\Tech2Win\pcmcia.

Emplacement 0 : emplacement de l'image de la carte mémoire

Ici, vous pouvez spécifier le fichier qui contient l'image PCMCIA pour l'emplacement 0. Ce type de fichier se trouve généralement dans C:\Users\Public\General Motors\Tech2Win\pcmcia ; cependant, il est possible qu'il se trouve à un autre emplacement.

Emplacement 1 : carte mémoire ou ATA

À l'instar de Tech2, Tech2Win prend en charge deux cartes (images) PCMCIA. Toutefois, la seconde image PCMCIA dans une configuration n'est généralement pas très utile. Un second logiciel sera probablement utilisé dans une seconde configuration.

Comme c'est le cas avec Tech2, une carte ATA est utilisée pour le débogage. Activez uniquement la carte ATA si l'assistance technique vous le demande. Elle vous fournira des informations supplémentaires.

Emplacement du clavier logiciel PC

La valeur par défaut de ce fichier est extraite du registre Windows et doit désigner une application pouvant simuler un clavier PC avec la souris. Si vous disposez d'une application spéciale avec cette fonctionnalité pour l'ordinateur portable que vous utilisez, définissez l'application ici.


Interface VCI (Vehicle Communication Interface)

  • Port Com pour l'émulation Tech2 RS232
  • Numéro de série MDI à utiliser
  • Protocole

Port Com pour l'émulation Tech2 RS232

Choisissez un port COM libre pouvant être utilisé pour l'émulation Tech2. Pour faciliter les opérations, le configurateur tente de déterminer les ports série en cours d'utilisation et il les affiche

Si vous choisissez un port de communication existant, Tech2Win se connecte à ce port de communication. Vous pouvez utiliser ce port de communication pour télécharger le logiciel Tech2 depuis un second ordinateur exécutant l'application TIS en utilisant un câble simulateur de modem. Notez que si vous utilisez un port de communication réel, le port peut ne pas fonctionner correctement à un débit de 115 200 bauds du fait de restrictions Windows.

Si vous sélectionnez un port de communication non existant, Tech2Win crée un port virtuel automatiquement. Ce port virtuel peut être utilisé depuis TIS sur le même PC pour communiquer avec Tech2Win. Un port virtuel n'impose aucune restriction de débit.

Si vous choisissez 'Rechercher' comme port COM, Tech2Win créera un port de communication virtuel sur le premier port libre sur une gamme de 1 à 9.

Numéro de série MDI à utiliser

Entrez le numéro de série de MDI. Le numéro se trouve à l'arrière de MDI. Utilisez le numéro après le tiret.

Si vous n'entrez pas un numéro de série, Tech2Win affiche la liste des DC détectées dans le réseau pour que l'utilisateur en choisisse une. La même boîte de sélection s'affiche lorsque l'interface MDI spécifiée est introuvable.

Protocole

'ISO22900-2 / PDU-API' est sélectionné et J2534-2 est toujours estompé. Dans le futur, Tech2Win pourrait prendre en charge le protocole J2534 également.

  • Rubriques avancées: Fichier de configuration
  • FAQ: Comment déterminer le port de communication à utiliser pour Tech2Win ?
  • FAQ: Communication entre Tech2Win et TIS2Web
  • FAQ: Comment utiliser plusieurs interfaces MDI ?
  • FAQ: Tech2Win n'a pas trouvé mon interface MDI.


Affichage

L'onglet Affichage permet principalement de changer les paramètres d'affichage de Tech2Win :

  • Clavier
  • Couleurs
  • Son
Display and Key Options

Clavier

Ici, vous pouvez indiquer si vous voulez afficher le clavier. Le clavier est positionné dans la partie gauche ou droite de l'écran TechWin2. Vous pouvez sélectionner la couleur d'arrière-plan via une boîte de dialogue de couleurs standard.

Couleurs

Vous pouvez sélectionner ici la couleur d'arrière-plan et la couleur de premier plan de l'écran Tech2. Les deux combinaisons de couleurs les plus courantes sont les suivantes :

Screen with background 0000FF, foreground FFFFFF | Arrière-plan blanc pour le clavier; Arrière-plan bleu; Premier plan blanc
Screen with background 000000, foreground C0C0C0 | Arriière-plan bleu de pavé numérique; Arrière-plan noir; Premier plan gris clair

Son

Vous pouvez ici opter pour désactiver le son. Chaque vois que le programme Tech2 émet un bip, le haut-parleur du PC est utilisé.


Enregistrement de la configuration

La configuration active peut être enregistrée en cliquant sur le bouton Enregistrer <configuration> dans l'angle inférieur gauche. Le bouton n'apparaît pas si vous affichez une configuration en lecture seule.


Licence valide via TIS2Web

Normalement, le téléchargement du logiciel Tech2 vers Tech2Win fournit une licence valide. De plus, vous pouvez l'obtenir en effectuant un 'Autorisation d'accès (Sécurité)' par l'intermédiaire de TIS2Web (et non TIS2000). Précondition ; il s'agit donc de la sélection du port de communication virtuel dans le configurateur sous Interface VCI (Vehicle Communication Interface).

Lorsque l'accès sécurisé aboutit, un verrou ouvert s'affiche dans la partie droite de la barre d'état. Le nombre de jours de validité de la licence figure dans le crochet. Lorsque vous redémarrez Tech2Win, l'indicateur de sécurité ne s'affiche pas si aucune communication de véhicule n'est disponible. Lors de la première communication avec un véhicule, la licence est vérifiée et l'indicateur est remplacé par un verrou ouvert ou fermé.

  • Utilisation de Tech2Win:Sécurité
  • FAQ:Comment déterminer le port de communication à utiliser pour Tech2Win ?
  • FAQ:Communication entre Tech2Win et TIS2Web
  • FAQ:Licence valide
  • FAQ:Quelle est la différence entre une licence Tech2Win et l'accès de sécurité ?


Utilisation de Tech2Win

Les rubriques suivantes sont généralement utilisées par les techniciens lors de l'utilisation de Tech2Win :

  • Menu: Présentation de l'écran et options de menu individuelles
  • Téléchargement d'une image PCMCIA.: La mise à jour du logiciel de diagnostic de Tech2Win est très similaire à la méthode utilisée pour Tech2.
  • Sécurité: Les mesures de sécurité empêchent Tech2Win d'entrer en communication avec les véhicules dans les environnements non autorisés.
  • Afficher les rapports: Le clavier Tech2 a été légèrement amélioré dans Tech2Win. Le bouton d'affichage des rapports est un exemple type.
  • Gestion des images PCMCIA: Vous pouvez utiliser plusieurs images PCMCIA dans Tech2Win, ce qui revient pratiquement à utiliser plusieurs cartes PCMCIA pour Tech2.
  • Barre d'état: La barre d'état informe l'utilisateur sur les différentes parties de cette dernière.
    • Rubriques avancées
    • FAQ


Menu

L'application Tech2Win dispose des menus suivants :

  • Fichier
  • Options
  • Fenêtres
  • Aide

Fichier

Le menu Fichier contient les options suivantes :

  • Enregistrer l'écran T2 (320 x 240) permet d'enregistrer l'écran T2 en cours dans le format 320 x 240 pixels dans un fichier monochome sur le PC. Il est possible de sélectionner l'emplacement de stockage et le format de fichier (BMP, GIF, JPG, PNG).
  • Imprimer l'écran crée un fichier image BMP monochrome inversée de l'écran Tech2 et appelle le programme associé aux fichiers BMP. Ensuite, vous pouvez utiliser ce programme pour imprimer l'image.
  • Afficher les fichiers de rapport : permet d'afficher (et d'imprimer) les rapports sans utiliser TIS2Web.
  • Quitter : arrête Tech2Win.

Options

Options fournit les options suivantes :

  • Résolution : permet de choisir l'une des trois tailles d'écran standard
  • ROM-Write from 0x00003ED76 : pour exécuter des débogages internes.
  • Captures d'écrans automatiques pour stocker une image de chaque écran Tech2 dans le répertoire log.
  • Désactiver CANdi et redémarrer simule un Tech2 sans CANdi entre lui-même et le véhicule. Cela est nécessaire dans les rares cas dans lesquels CANdi interrompt les communications véhicule non standard.

Fenêtres

Le menu Fenêtres vous offre la possibilité d'activer les sélections Affichage des données Tech2Win et Affichage DTC Tech2Win. Toutes les autres sélections sont grisées dans la version Tech2Win actuelle.

Si le logiciel Tech2 prend en charge Affichage des données Tech2Win, vous pouvez activer cette entrée de menu. Lors de l'ouverture de Data Display, Tech2Win affiche une fenêtre Data Display additionnelle parallèle au Data Display de Tech2. L'entrée de menu ne peut être activée tant que l'écran Tech2 présente l'Affichage de données. Dans ce cas, vous devez quitter l'Affichage de données, activer l'entrée de menu et redémarrer l'Affichage de données.

Des restrictions similaires à celles pour Affichage des données Tech2Win s'appliquent également pour Affichage DTC Tech2Win. Si le logiciel Tech2 prend en charge Affichage DTC Tech2Win, vous pouvez activer cette entrée de menu. Une fenêtre Affichage des DTC supplémentaire apparaît parallèle à la fenêtre Tech2 Affichage des DTC. L'entrée de menu ne peut être activée tant que l'écran Tech2 présente l'Affichage des DTC. Dans ce cas, vous devez quitter l'Affichage des DTC, activer l'entrée de menu et redémarrer l'Affichage des DTC.

Aide

Les sélections suivantes sont disponibles :

  • Rubriques d'aide... : appelle l'aide Tech2Win.
  • Paramètre de ligne de commande : affiche les paramètres de ligne de commande utilisés pour Tech2Win.
  • A propos de affiche le numéro de version actuelle et les limites de téléchargement TIS2Web de Tech2Win.


Téléchargement

Démarrez Tech2Win et restez dans l'écran principal. Démarrez TIS2Web ou GlobalTIS et effectuez le téléchargement via le port de communication défini dans l'onglet Interface VCI (Vehicle Communication Interface).

Vous pouvez utiliser les ports COM intégrés pour télécharger le logiciel Tech2 depuis un PC différent exécutant TIS. Veillez à utiliser un câble croisé RS232. Selon le matériel installé sur le PC qui exécute Tech2Win, il peut être nécessaire de ramener le débit du transfert des données à 57 600 bauds étant donné que Windows peut perdre des données à un débit plus élevé.

La dernière version Tech2Win prend également en charge un téléchargement rapide lorsque TIS2Web et Tech2Win sont exécutés sur le même PC. Une communication minimale entre TIS2Web et Tech2Win sur le port COM est toujours effective, mais le long transfert de données vers Tech2Win a été remplacé par un transfert de fichiers interne. La durée du téléchargement est alors considérablement réduite ; en effet, elle dure beaucoup moins d'une minute.

  • Rubriques avancées: Fichier de configuration
  • Premières étapes: Interface VCI (Vehicle Communication Interface)
  • FAQ: Comment déterminer le port de communication à utiliser pour Tech2Win ?
  • FAQ: Communication entre Tech2Win et TIS2Web


Sécurité

Les mécanismes de sécurité utilisés par Tech2Win reposent sur une valeur d'horloge PC correcte. Vérifiez que la valeur d'horloge PC est toujours définie. Tech2Win accepte les changements mineurs d'horloge, tels que le passage à l'heure d'été.

Tech2Win n'établit aucune communication de véhicule sans une licence valide et active. L'indicateur suivant dans la barre d'état montre l'état de la licence :

  • green smiley La licence est valide.
  • Aucun indicateur : La licence n'a pas encore été vérifiée.
  • red smiley La licence a expiré.

Pour obtenir une licence, veuillez effectuer une mise à jour de 'Autorisation d'accès (Sécurité)' en utilisant l'application TIS2Web. Dans la plupart des cas, un téléchargement logiciel via TIS2Web est également suffisant pour obtenir une nouvelle licence. Etant donné que la licence n'est plus valide après un délai donné (quatre semaines dans certaines régions), vous devez exécuter cette mise à jour régulièrement.

Les licences varient en fonction de la région/du logiciel. Des licences peuvent figurer sur votre ordinateur si vous utilisiez Tech2Win avec des versions logicielles Tech2 différentes.

Le nombre de jours restants avant l'expiration de la licence est indiqué dans la barre d'état.

  • ( 0) indique que la licence a expiré ou qu'elle n'existe pas.
  • (<1) La licence expirera dans les prochaines 24 heures.
  • (20) La licence expirera dans 20 jours.

Ne modifiez pas le fichier de licence. La modification frauduleuse de ce fichier est détectée par des mesures de sécurité internes et entraîne la perte de toutes les licences sur l'ordinateur. En outre, le comportement de Tech2Win sera imprévisible. La solution consiste à effectuer nouvelle installation.

  • Rubriques avancées: Messages d'erreur et codes exit.
  • Rubriques avancées: Fichier journal
  • Utilisation de Tech2Win: Fenêtre d'état
  • FAQ: Licence valide
  • FAQ: Quelle est la différence entre une licence Tech2Win et l'accès de sécurité ?
  • FAQ: Arrêt soudain


Affichage des rapports

View Report Ce bouton permet d'afficher le contenu des fichiers PRT qui se trouvent dans la carte PCMCIA. Une boîte de dialogue s'affiche avec la liste des fichiers PRT. Si un programme a été associé à l'extension PRT, le programme correspondant est exécuté. Autrement, l'éditeur Bloc-notes s'affiche avec le fichier sélectionné.

Dans la plupart des cas, le fichier PRT est un fichier ASCII qui utilise les pages de codes de la langue. Pour le chinois, le japonais, le thaï et le coréen, le fichier est un fichier Unicode avec un BOM (Byte-Order-Mark) de début.

Lors de l'affichage de rapports, Tech2Win utilise un sous-répertoire C:\Users\Public\General Motors\Tech2Win\reports. Ce sous-répertoire existe uniquement si vous avez déjà affiché des rapports. Le répertoire est effacé automatiquement et fonctionne comme répertoire de travail temporaire pour les fichiers PRT dans la carte PCMCIA active. Il contient ces fichiers, même si l'exécution de Tech2Win s'arrête. Si vous voulez sauvegarder un fichier de ce type, vous devez le copier vers un répertoire différent, car il pourrait être remplacé dès qu'un autre utilisateur affiche des rapports.


Images PCMCIA

Les images PCMCIA sont généralement situées dans le répertoire C:\Users\Public\General Motors\Tech2Win\pcmcia. La taille du fichier doit être exactement de 32 Mo (33 554 432 octets) ou de 10 Mo (10 485 760) et le fichier doit porter l'extension *.bin. Les images sont modifiées (à l'instar de n'importe quelle carte PCMCIA standard) si vous effectuez un téléchargement ou que Tech2Win stocke des données dans la carte flash. Les modifications peuvent être désactivées en utilisant l'option de protection (commande -W0 ou -W1) ou en ne définissant pas la valeur 'p' dans l'option '-W'-(Fichier de configuration). Il est impossible d'accéder au commutateur de protection en écriture via le configurateur. Vous devez modifier manuellement le fichier de configuration pour pouvoir utiliser les options '-W0', '-W1' ou '-W'.


Barre d'état

La barre d'état se trouve sous l'écran Tech2. La barre d'état contient les éléments suivants :

  1. Indicateur de vitesse
  2. État de la communication avec le véhicule
  3. État du port série
  4. Touche SHIFT
  5. Captures d'écrans automatiques
  6. Avertissement de journal
  7. Licence

Status Bar

Indicateur de vitesse

L'indicateur de vitesse indique le temps UC nécessaire à l'émulation du logiciel Tech2. Une valeur faible (indicateur de gauche) est préférable à une valeur élevée (indicateur de droite). Tout indicateur vert est acceptable. L'indicateur peut devenir jaune brièvement si une tâche Windows différente s'active soudainement. Une telle activité doit être évitée.

État de la communication avec le véhicule

L'état de communication véhicule indique si l'interface MDI (Vehicle Communication Interface) est présent et si une connexion est établie entre le véhicule et Tech2Win.

État du port série

Lorsque vous communiquez avec Tech2Win sur un port COM, cet indicateur signale si la communication sur le port est active.

Touche SHIFT

Cet indicateur indique si la touche SHIFT est active. Vous pouvez l'activer ou le désactiver en appuyant sur la touche 'S' du clavier ou la touche SHIFT du pavé numérique.

Captures d'écrans automatiques

Les captures d'écrans automatiques peuvent être activées dans le menu Options. Chaque fois que l'écran change une nouvelle capture d'écran est stockée dans le répertoire Log. Cela est indiqué par la manivelle sur la caméra rouge dans la barre d'état. Lorsque les captures d'écrans automatiques sont désactivées la caméra disparaît.

Avertissement de journal

L'indicateur Etat de journal peut avoir trois états.

  • gray log status indicator Le fichier journal contient des avertissements ou des erreurs.
  • yellow log status indicator Le fichier journal contient un message d'avertissement.
  • red log status indicator Le fichier journal contient un message d'erreur.

Licence

L'indicateur de licence peut avoir trois états :

  • green smiley La licence est active et valide.
  • Aucun indicateur : La licence n'a pas encore été vérifiée.
  • red smiley La licence a expiré ou elle n'existe pas.
Voir le lien Sécurité pour plus d'informations.

Info-bulles dans la barre d'état

Pour certaines icônes, des info-bulles apparaissent pour fournir des informations supplémentaires :

Info-bulle du numéro de série VCI :
Tooltip VCI

Info-bulle de la version du logiciel TECH2
Tooltip TECH2

Info-bulle du port de communication
Tooltip Comport

Info-bulle du numéro de la capture d'écran suivante (si les 'Captures d'écrans automatiques' sont actives)
Tooltip Camera

Info-bulle qui indique la dernière entrée de fichier journal ayant le niveau 'warning' ou un niveau supérieur
Tooltip Logfile

Info-bulle de validité exacte de la licence
Tooltip License

Les info-bulles s'affichent lorsque vous maintenez le pointeur de la souris pendant plus d'une demi seconde sur une icône. Elles disparaissent après 5 secondes ou lorsque vous déplacez le pointeur de la souris.

  • Rubriques avancées: Messages d'erreur et codes d'erreur
  • Rubriques avancées: Fichier journal


Rubriques avancées

Les rubriques abordées ici sont moins importantes pour l'utilisateur standard de TechWin2. Les informations suivantes s'adressent aux personnes impliquées dans l'installation, la gestion et la configuration de Tech2Win.

  • Réinstallation
  • Désinstallation
  • Modification directe des fichiers de configuration
  • Fichier journal
  • Messages d'erreur et codes exit.
  • Carte ATA
  • Entrées de registre
  • Description du fichier
  • Exemples de gestion de configuration


Désinstallation

Le répertoire d'installation complet, le répertoire contenant les données utilisateur (C:\Users\Public\General Motors\Tech2Win) et le répertoire contenant des données d'application (C:\ProgramData\General Motors\Tech2Win) sont effacés.

  • Rubriques avancées: Réinstallation
  • Installation


Fichier de configuration

Les fichiers de configuration sont toujours situés dans le sous-répertoire C:\Users\Public\General Motors\Tech2Win\config et portent l'extension *.conf. Vous pouvez modifier manuellement le fichier de configuration étant donné que les options du fichier ne sont pas toutes accessibles via Tech2Win. Le fichier de configuration est un fichier Unicode avec un BOM (Byte-Order_Mark) de début. Il est vivement recommandé d'utiliser un éditeur compatible Unicode, tel que Bloc-notes, lorsque vous effectuez des modifications manuellement.

Le fichier de configuration est orienté ligne. Les lignes vides sont ignorées. Une ligne commence toujours par une option, suivie généralement d'une valeur. Pour un exemple, consultez le fichier default.conf. Reportez-vous au tableau suivant qui répertorie toutes les options.

Si vous souhaitez lancer une certaine configuration directement à partir du bureau, créez un raccourci exécutant 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Le programme doit être lancé à partir du répertoire de travail suivant : 'C:\Program Files\General Motors\Tech2Win\bin'

option | Valeur/Signification
; Commentaire
@ Numéro de version décimale de format major.minor.
Les fichiers de configuration avec un numéro majeur différent de Tech2Win ne sont pas acceptés. Les fichiers de configuration avec un numéro mineur inférieur à Tech2Win sont acceptés.
-W0
-W1 		La carte PCMCIA dans l'emplacement 0/1 est protégée contre l'écriture.
-B0
-B1 		Taille de bloc en kilo-octets de la carte PCMCIA dans l'emplacement 0/1. Les valeurs valides sont 128 (valeur par défaut) ou 256.
-P0
-P1 		Fichier contenant l'image binaire de la carte PCMCIA de l'emplacement 0/1. La taille du fichier doit être exactement de 10 Mo ou 32 Mo. Les variables d'environnement telles que %ProgramData% sont développées.
Si cette option n'est pas présente, l'emplacement est considéré vide.
-A0
-A1 		Fichier contenant les valeurs d'attribut de la carte PCMCIA dans l'emplacement 0/1. S'il n'existe pas, les attributs par défaut sont utilisés en fonction de la taille de la carte et de bloc.
-W | Lors de la sortie de TechWin2, toutes les données persistantes sont écrites dans leurs fichiers respectifs. Les valeurs p/f/r/c peuvent être combinées pour indiquer PCMCIA/Flash-ROM/RTC/CANDI-App respectivement.
-H | Fonction Gestion de la mémoire de tas Les valeurs 0/r/w/t peuvent être combinées pour activer la Remise à zéro, les Vérifications de lecture, Vérifications d'écriture et Vérifications des tâches, respectivement. La valeur l est utilisée pour imposer dans tous les cas l'allocation de la mémoire de tas à des adresses plus basses pendant qu'un schéma d'allocation alternatif est mis en place. Normalement, cette option est seulement utilisée dans le cadre d'un environnement de développement.
-PC | Ancien chemin de copie de la carte PCMCIA. Cette option n'est pas prise en compte actuellement.
-MS | Identification de l'interface MDI (Vehicle Communication Interface) avec numéro de série. Si non défini, la liste des interfaces MDI disponibles s'affiche.
-CT | Couleur du texte (premier plan) dans 3 valeurs d'octet hexadécimales. La valeur par défaut est 000000 (blanc).
-CB | Couleur de l'arrière-plan dans 3 valeurs d'octet hexadécimales. La valeur par défaut est FFFFFF (noir).
-ATA | Utilisez cette option pour activer la carte de capture ATA. Retirez-la pour désactiver la carte de capture ATA.
-C | Numéro du port COM (1..9) à utiliser comme port de communication RS232C Tech2. En règle générale, TechWin2 utilise le port COM 9 comme port COM virtuel. Si cette option n'est pas présente, une recherche de port COM libre est effectuée vers le bas depuis COM9. Utilisez l'outil conseil de la barre d'état entre l'icône Tech2 et l'icône TIS2Web pour consulter le port COM utilisé.
-WR | Adresse PC (normalement 253558) autorisée à écrire dans la carte PCMCIA et la zone FLASH ROM. Cette fonctionnalité doit de plus être activée par le menu (ou en utilisant l'option -WA) Elle est nécessaire pour déboguer le code dans la mémoire non modifiable par le débogueur SingleStep.
-WA | Autorisez le SingleStep Debugger à enregistrer sur mémoire non modifiable.
-OF | Fichiers d'options contenant des paires option-valeur
-TP | Ajustement de timing (Valeur proportionnelle). Utilise 5 000 comme valeur par défaut. Diminuez cette valeur pour que le nombre de cycles exécutés s'adapte plus rapidement au temps réel.
-TD | Ajustement de timing (Valeur différentielle). Utilise 100 comme valeur par défaut. Diminuez cette valeur pour réagir plus rapidement aux modifications de timing instantanées. AVERTISSEMENT: la modification des valeurs TP et TD peut générer des problèmes de vitesse.
-PJ
-PP 		Indiquez le protocole à utiliser :
PJ pour communication J2534.
PP pour ISO22900-2 / PDU-API (valeur par défaut)
-S | Cette option permet d'activer le son du bipeur du PC.
-L | Langue de l'application Tech2Win. La langue active de Windows est utilisée par défaut si cette entrée est manquante. Voir le lien suivant pour la liste des langues pouvant être définies : Langues. La fenêtre d'émulation Tech2 affiche la langue qui se trouve dans la carte PCMCIA (à savoir, téléchargée vers la carte PCMCIA).
-UD | Écraser le répertoire de données utilisateur. Avec Win7, il est normalement situé dans C:\Users\Public\General Motors\Tech2Win
-AD | Écraser le répertoire de données application. Avec Win7, il est normalement situé dans C:\ProgramData\General Motors\Tech2Win
-US | Utilisez un sémaphore spécifique à l'utilisateur pour détecter plusieurs instances de Tech2Win. Cette option permettra à chaque utilisateur d'utiliser Tech2Win en parallèle sur la même machine, vraisemblablement un serveur. Lorsque vous utilisez cette option, vous devez également spécifier les options -UD and -AD.
-SS | Option permettant de spécifier la taille générale de l'écran Tech2Win, clavier numérique inclus (si présent). Le premier paramètre doit être une chaîne entre guillemets (') qui sera utilisée comme nom de la taille dans le menu Options / Résolution. Le second paramètre est le nombre total de pixels horizontaux de l'écran Tech2Win, clavier numérique inclus. Le troisième paramètre est le nombre total de pixels verticaux de l'écran Tech2Win. Le quatrième paramètre optionnel est la largeur du clavier numérique en pixels.
-SH Option de contrôle du comportement de l'écran. Le chiffre décimal suivant est utilisé pour spécifier les possibilités de manipulation d'écran à désactiver.
  • Bit 0 : Pas de min/max possible.
  • Bit 1 : Pas de repositionnement à l'écran.
  • Bit 2 : Pas de redimensionnement. Dans ce cas, le menu Options / Résolution est grisé.
  • Bit 3 : Écrans Affichage des données et DTC de taille identique à l'écran Tech2Win (sans clavier numérique)


Journalisation

Chaque fois que vous démarrez une configuration Tech2Win, vous créez un fichier journal au format HTLM dans le sous-répertoire C:\Users\Public\General Motors\Tech2Win\Logs. Pour éviter d'encombrer le disque dur, les fichiers journaux de plus d'une semaine sont supprimés.

Les fichiers journaux sont nommés automatiquement en fonction de leur date (année, mois, jour) et heure (heure, minutes, seconde) de création:
aaaa-mm-jj_hhmmss.html

Les entrées de fichier journal sont toujours en anglais, mais dans le format Unicode avec un BOM (Byte-Order Mark) de début. Chaque ligne dans le fichier journal correspond à l'un des niveaux suivants :

Niveau de journal | Signification
Infos | Informations uniquement. Aucun impact sur l'exécution du programme.
Avertissement | Une situation inhabituelle existe. Il se peut que l'utilisateur ne soit pas affecté.
ERROR | Une erreur s'est produite et elle affecte l'utilisateur.
CRITICAL | Une erreur critique s'est produite et affecte le fonctionnement du programme.
FATAL | Une erreur irrécupérable provoque l'arrêt immédiat de Tech2Win.

Tous les niveaux au-dessus de 'Warning' sont colorés pour les identifier aisément.

En outre, les fichiers d'impression et vidéo se trouveront dans le sous-répertoire Logs si l'option de menu Imprimer l'écran ou Captures d'écrans automatiques a été utilisée.
aaaa-mm-jj_hhmmss_print_nnnnn.bmp
aaaa-mm-jj_hhmmss_video_nnnnn.png
Les images Captures d'écrans automatiques sont liées par un fichier HTML. Par conséquent, utilisez le journal HTML pour afficher la séquence de ces images.

La barre d'état indique à l'utilisateur si une entrée d'avertissement ( yellow lightning bolt) ou plusieurs entrées de journal graves ( red lightning bolt) existent.


Messages d'erreur et codes exit.

Des messages d'erreur peuvent s'afficher dans les boîtes de dialogue. Ces boîtes de dialogue permettent toujours à Tech2Win d'exécuter le programme Tech2 en parallèle. Les codes exit sont des erreurs irrécupérables qui provoquent l'arrêt anormal de TechWin2. Les codes exit peuvent être utilisés dans des fichiers batch pour déterminer la raison de la fin de l'exécution d'un programme.

Messages d'erreur

Les messages d'erreur suivants peuvent s'afficher. Voici une brève explication de la situation accompagnée de la solution.

Emulator too slow Emulator failed to start

Codes exit

Code exit | Valeur | Signification
OPCODE_ERROR | -7 | Commande non valide du microprocesseur Tech2 (68332) détectée. Il se peut que l'image PCMCIA soit endommagée.
ATA_PROBLEM | -6 | Un incident s'est produit lors de l'émulation ATA. Si vous êtes confronté à ce problème après que l'on vous a indiqué d'utiliser la carte ATA, contactez l'assistance technique.
DEMO_TIME_IS_UP | -5 | Ne doit pas apparaître dans la version officielle de Tech2 Win.
DLL_NOT_LOADED | -3 | L'une des bibliothèques DLL nécessaires n'a pas pu être chargée. Il semble que vous utilisiez une copie incomplète de Tech2Win. Effectuez une nouvelle installation et/ou choisissez une langue différente.
EXIT_INIT_FAILED | -2 | L'initialisation a échoué. Recherchez la cause dans le fichier journal. S'il n'existe aucun fichier journal, vérifiez que vous disposez d'un accès en lecture/écriture sur tous les répertoires.
normal | 0 | TechWin2 s'est terminé normalement.


Carte ATA

En règle générale la carte ATA dans Tech2 est utilisée uniquement à des fins de débogage au cours du développement du logiciel. Toutes les données ATA nécessaires sont stockées dans le sous-répertoire C:\Users\Public\General Motors\Tech2Win\ataCapture. Ce répertoire n'a normalement pas d'importance et vous pouvez l'effacer en toute sécurité, sauf indication contraire.

Étant donné que le répertoire ataCapture est fixe, son contenu est identique pour toutes les configurations.


Fichiers

Tech2Win utilise les fichiers et les répertoires suivants :

Répertoire | Emplacement pour systèmes antérieurs à Vista | Emplacement pour systèmes Vista ou postérieurs
Installation | Tel que défini lors de l'installation
Données utilisateur | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Données d'application | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Fichier | Utilisation
[Données utilisateur]\atacapture | Contient les fichiers figurant dans la carte ATA. Sauf indication contraire, ces fichiers ne sont pas nécessaires.
[Installation]\bin | Contient l'exécutable, ainsi que les fichiers DLL et les images nécessaires à l'exécution.
[Installation]\bin\emulator.exe | Principal exécutable exécutant le code Tech2.
[Installation]\bin\emulator_xx_XX.dll | DDL de ressource spécifique de la langue.
[Installation]\bin\T2Configurator.exe | La partie configuration de Tech2Win.
[Installation]\bin\Pictures | Contient les icônes nécessaires à Tech2Win.
[Données utilisateur]\config | Contient tous les fichiers de configuration.
[Données utilisateur]\data | Contient les fichiers modifiés au cours de l'exécution de Tech2Win. Ces fichiers sont nécessaires au fonctionnement correct de Tech2Win. Normalement, vous ne devez pas modifier ces fichiers, sauf indication contraire.
[Données d'application]\data | Contient les fichiers modifiés au cours de l'exécution de Tech2Win. Ces fichiers sont nécessaires au fonctionnement correct de Tech2Win. Normalement, vous ne devez pas modifier ces fichiers, sauf indication contraire.
[Données d'application]\data\emulator.sec | Fichier de sécurité . Ne modifiez pas ce fichier.
[Données d'application]\data\emulator.card | Fichier de cartes. Contient toutes les cartes PCMCIA reconnues par le programme Tech2Win. Ne modifiez pas ce fichier.
[Données utilisateur]\data\emulator.disp | Ce fichier contient l'emplacement et la taille de l'écran Tech2Win. Si vous supprimez ce fichier, il est recréé et l'écran Tech2Win commence dans l'angle supérieur gauche et sa taille est 640 x 480.
[Données d'application]\data\emulator.lic | Fichier de licence. Contient des informations sur la durée de validité de vos licences. Ne modifiez pas ce fichier.
[Données d'application]\data\emulator.rtc | Fichier RTC (Real Time Clock). Ce fichier est utilisé pour stocker les données qu se trouvent dans la RTC de Tech2.
[Données d'application]\data\emulator.dta | Un fichier info 'Ne pas me rappeler'.. Ce fichier contient les versions logicielles PCMCIA qui ne doivent plus afficher l'avertissement sur l'impossibilité d'exécuter l'autotest qui nécessite une carte loopback.
[Données d'application]\data\candi.bin | Fichier d'application CANdi. Contient l'application CANdi liée à Tech2.
[Données d'application]\data\eprom.bin | Fichier EPROM interne Tech2. Contient les données de la mémoire flash Tech2 interne.
[Installation]\driver | Fichiers d'installation du pilote de port de communication virtuel.
[Installation]\help\emulator_xx_XX.chm | Fichiers d'aide spécifiques à une langue
[Données utilisateur]\Logs | Contient les fichiers journaux. Les fichiers de plus d'une semaine sont effacés automatiquement.
[Données utilisateur]\pcmcia | Contient les fichiers images PCMCIA. Chaque fichier correspond à une carte PCMCIA Tech2. Ces fichiers peuvent être enregistrés dans différents emplacements de votre choix.


Gestion de la configuration

Les fichiers de configuration sont toujours situés dans le sous-répertoire C:\Users\Public\General Motors\Tech2Win\config et portent l'extension *.conf. Tech2Win peut être utilisé uniquement pour créer des fichiers de configuration ou modifier des fichiers de configuration existants qui ne sont pas en lecture seule. Pour toutes les autres opérations de gestion des fichiers de configuration, utilisez l'Explorateur Windows ou un programme similaire. Ce programme est nécessaire pour exécuter les opérations suivantes :

  • suppression de fichiers de configuration
  • changement des noms des fichiers de configuration
  • modification de l'attribut Lecture seule d'un fichier de configuration

Il est vivement recommandé de toujours disposer d'un fichier de configuration default.conf. Ce fichier doit être normalement affecté de l'attribut Lecture seule pour éviter de le supprimer par erreur. Toutefois, si vous devez modifier le fichier, retirez temporairement l'attribut.

Les images PCMCIA se trouvent dans le sous-répertoire C:\Users\Public\General Motors\Tech2Win\pcmcia. Chacun de ces fichiers correspond à une carte PCMCIA qui vous est familière lorsque vous utilisez Tech2. Tech2Win ne limite pas le nombre d'images. Copiez simplement une image existante sous un nouveau nom de fichier.

Si vous souhaitez lancer une configuration directement à partir du Bureau, créez un raccourci exécutant "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Le programme doit être lancé à partir du répertoire de travail suivant : 'C:\Program Files\General Motors\Tech2Win\bin'

Le nombre de fichiers de configuration ne dépend pas du nombre d'images PCMCIA que vous utilisez. Une même image PCMCIA peut utiliser plusieurs fichiers de configuration. Cela permet de simuler précisément une situation dans un atelier de réparation où plusieurs mécaniciens partagent le même Tech2 (et la même carte PCMCIA).

Vous pouvez également associer chaque configuration à sa propre image PCMCIA. Cela permet de rendre les configurations indépendantes les unes des autres. Toutefois, les opérations de mise à jour de chaque image PCMCIA peuvent prendre du temps.

Si vous créez une configuration à partir d'une configuration existante alors que l'image PCMCIA n'a pas été modifiée, le configurateur affiche un avertissement. Si tel est le cas, vous disposerez de deux configurations utilisant la même image PCMCIA. Si tel est votre souhait, appuyez sur OK. Si vous souhaitez que la nouvelle configuration utilise une image PCMCIA nouvelle/différente, appuyez sur Annuler. Vous pouvez alors choisir de créer une nouvelle image via la fonction Copier carte mémoire ...

Voici deux exemples de méthodes de gestion des configurations et des images PCMCIA.

Une configuration par utilisateur

Vous pouvez enregistrer une configuration par utilisateur. Le nom de la configuration peut être le nom de l'utilisateur, par exemple. Ce concept offre l'avantage de pouvoir utiliser des paramètres utilisateur spécifiques, tels que les interfaces de communication véhicule (MDI) personnelles, d'affichage et de langue. L'inconvénient réside dans le fait que vous devez copier les fichiers PCMCIA si plusieurs utilisateurs utilisent le même logiciel. Naturellement, les configurations utilisateur peuvent utiliser un fichier PCMCIA central.

Une configuration par logiciel Tech2

Vous pouvez créer une configuration pour chaque logiciel que vous téléchargez. Ainsi, même les anciennes versions logicielles sont immédiatement disponibles, si nécessaire. Généralement, le nom et le numéro de version du logiciel sont utilisés comme nom de configuration dans ce cas.

  • Premières étapes: Interface VCI (Vehicle Communication Interface)
  • Premières étapes: Chemin
  • Rubriques avancées: Fichier de configuration
  • Installation: Étapes d'installation


Forum Aux Questions

  • Comment déterminer le port de communication à utiliser pour Tech2Win ?
  • Communication entre Tech2Win et TIS2Web
  • Licence valide
  • Qu'indique le numéro de licence ?
  • Quelle est la différence entre une licence Tech2Win et l'accès de sécurité ?
  • TIS2Web affiche une erreur spécifique lorsqu'est effectué l'accès de sécurité à Initial Software.
  • Tech2Win n'exécute pas le logiciel Tech2 depuis un autre emplacement
  • Comment utiliser plusieurs interfaces MDI ?
  • Le fichier journal contient l'erreur 'CPU32: Too many 0000/FFFF Commands encountered'
  • Aucune fenêtre Tech2 visible
  • SPS ne fonctionne pas.
  • Certains autotests ne fonctionnent pas
  • L'indicateur de vitesse fluctue
  • Arrêt soudain
  • Le suédois s'affiche pour le logiciel 15.001
  • Perte de communication avec l'interface MDI
  • Tech2Win n'a pas trouvé mon interface MDI.
  • Je souhaite démarrer immédiatement Tech2Win sans passer par le configurateur
  • Où se trouvent les fonctions d'impression ?
  • Un dossier PCMCIA 'non utilisé' est présent sur mon ordinateur.
  • Je reçois le message 'chemin de fichier illégal'

Comment déterminer le port de communication à utiliser pour Tech2Win ?

Vous pouvez utiliser le 'Gestionnaire de périphériques' de Windows ; recherchez 'Ports (COM & LPT)'. Toutefois, certains ordinateurs disposent d'un modem interne ou de périphériques Bluetooth qui ne figurent pas dans cette catégorie.
Une autre méthode consiste à utiliser une petite commande fournie avec le configurateur. Vous pouvez l'exécuter via le menu de démarrage (dossier Tech2Win) en cliquant sur 'show com ports'.
Les deux méthodes montrent les ports de communication installés sur votre ordinateur et que vous NE DEVEZ PAS utiliser.

Communication entre Tech2Win et TIS2Web

Tech2Win doit être en cours d'exécution lorsque vous démarrez la communication avec TIS2Web pour l'accès sécurisé ou le téléchargement de logiciel. TIS2Web peut reconnaître uniquement le port de communication virtuel lorsque Tech2Win est démarré.

Licence valide

Normalement, le téléchargement logiciel depuis TIS2Web fournit une licence valide. Si vous n'avez toujours pas de licence, vous devez établir un 'Autorisation d'accès (Sécurité)' via TIS2Web (et non TIS2000) pour obtenir une licence valide. Veillez à n'effectuer aucune autre communication TIS2Web avec Tech2Win telle qu'un 'Transfert logiciel (SWDL)' avant d'obtenir une licence via un 'Autorisation d'accès (Sécurité)'.

Qu'indique le numéro de licence ?

Le numéro de version à droite de la barre d'état indique le nombre de jours expiré de la licence. Immédiatement après avoir effectué un téléchargement ou accédé à la sécurité, '30 jours' s'affiche. Toutefois, après un nouveau démarrage de Tech2Win, 29 s'affiche, car la durée de la licence est de 29 jours, 23 heures et 55 minutes. Si le nombre de jours de validité de la licence tombe en dessous de 24 heures, la durée de licence <1 s'affiche. 0 s'affiche si la licence a expiré.

Quelle est la différence entre une licence Tech2Win et l'accès de sécurité ?

La licenceTech2Win permet d'utiliser Tech2Win. Pour obtenir une licence, vous devez effectuer un téléchargement de logiciel ou effectuer un accès de sécurité régulièrement (tous les 30, en général). La possibilité d'exécuter ce téléchargement via TIS2Web indique à Tech2Win qu'un utilisateur valide est présent. L'accès de sécurité connu de Tech2 indique à Tech2Win que des activités de sécurité associées, telles que la désactivation d'un Airbag, sont autorisées. La licence et l'accès de sécuirté Tech2Win peuvent être exécutés via l'application TIS2Web Security Access. Tech2Win affiche la durée restante de la licence dans la barre d'état sur la droite. Malheureusement, Tech2Win ne peut pas afficher la durée d'un accès de sécurité lorsque Tech2Win exécute smplement le logiciel Tech2, mais ne comprend pas le logiciel Tech2 lui-même.

TIS2Web affiche une erreur spécifique lorsqu'est effectué l'accès de sécurité à Initial Software.

Le fonctionnement est identique à celui de Tech2. En raison de son ancienneté, le logiciel initial ne peut obtenir de licence à partir de Tis2Web. Ce n'est cependant pas un problème, étant donné que le logiciel de démonstration ne communique pas avec des véhicules, action pour laquelle une licence est nécessaire. Et étant donné que les licences sont spécifiques au téléchargement TS2Web, il vous faudrait de toute manière une licence pour chaque téléchargement après avoir téléchargé le logiciel Tech2. Une 'licence' du logiciel initial ne vous autorise pas à effectuer de communications véhicule avec un logiciel Opérations Nord Américaines ou Opel/Vauxhall.

Tech2Win n'exécute pas le logiciel Tech2 depuis un autre emplacement

Il est probable que votre version Tech2Win soit limitée à un ou plusieurs téléchargements TIS2Web (régions). Appuyez sur Aide / A propos de pour afficher les limitations qui s'appliquent à votre version de Tech2Win. Les versions antécédentes de Tech2Win permettaient uniquement l'exécution du logiciel Opel/Vauxhall. Les autres régions GM suivront. Dans tous les cas, Tech2Win peut actuellement exécuter le logiciel Tech2 de General Motors.

Comment utiliser plusieurs interfaces MDI ?

Si vous voulez affecter des interfaces MDI à des utilisateurs, il est conseillé de permettre à chaque utilisateur d'utiliser sa propre configuration. A l'évidence, ces configurations doivent être nommées en fonction de l'utilisateur. Dans chacune des configurations, vous devez entrer le numéro de série de l'interface MDI utilisateur dans l'onglet 'Interface VCI (Vehicle Communication Interface)'. Lorsque l'utilisateur commence sa configuration, Tech2Win tente de contacter cette interface MDI. Ce n'est que lorsque l'nterface MDI n'est pas présente qu'une zone de sélection s'affiche en indiqunt toutes les interfaces MDI que Tech2Win a trouvées.

Si vous disposez de plusieurs interfaces MDI pour une utilisation générale, il est conseillé d'utiliser les configurations dans lesquelles le numéro de série de l'interface VCI (Vehicle Communication Interface) dans l'onglet 'Interface VCI (Vehicle Communication Interface)' n'est pas défini. Dans ce cas, l'utilisateur voit toujours la zone de sélection des MDI disponibles.

Le fichier journal contient l'erreur 'CPU32: Too many 0000/FFFF Commands encountered'

Le fichier 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' ou le fichier PCMCIA en cours est endommagé. Réinstallez Tech2Win et téléchargez le nouveau logiciel Tech2.

Aucune fenêtre Tech2 visible

Si la fenêtre Tech2 n'est pas visible, elle figure probablement dans une zone non affichée actuellement. Cette situation se produit lorsque vous utilisez plusieurs écrans ou après avoir modifié la résolution d'écran. Appuyez sur la touche Shift du clavier pendant le démarrage de votre configuration. Dans ce cas, la résolution de fenêtre revient à 640 x 480 et la fenêtre Tech2 s'affiche dans l'angle supérieur gauche de l'écran. Vous pouvez également supprimer le fichier C:\Users\Public\General Motors\Tech2Win\emulator.disp pour arriver au même résultat.

Dans certains cas, la fenêtre Tech2 ne s'affiche simplement pas après avoir fermé les fenêtres de toutes les autres applications. Dans tous les cas, la combinaison de touches Alt-Tab, qui pemet de passer d'une application à une autre, peret d'affichier l'écran Tech2. L'utilisation du bouton Tech2Win dans la barre des tâches dans le bas de l'écran du PC ne fonctionne pas parfois. Nous sommes en train d'étudier le problème et espérons qu'il aura disparu dans la prochaine version de Tech2Win.

SPS ne fonctionne pas.

Oui, nous le savons. Nous n'envisageons pas de le changer. Utilisez Tech2Win à la place de Tech2 pour SPS. Veuillez utiliser le MDI directement avec SPS Programming dans TIS.

Certains autotests ne fonctionnent pas

Les autotests Tech2 visent à tester les parties du matériel Tech2. Certains de ces tests nécessitent d'utiliser une carte loopback. Ces tests ne fonctionnent pas dans Tech2Win, car la fonctionalité de la carte loopback n'est pas mise en oeuvre (et rien n'est prévu en la matière). N'exécutez pas ces tests non significatifs dans Tech2Win. Si vous les exécutez, vous pouvez obtenir des résultats erronés ou Tech2Win se bloque comme le fait Tech2 sans carte loopback. Dans ce cas, utilisez Ctrl-R pour réinitialiser Tech2Win.

L'indicateur de vitesse fluctue

L'indicateur de vitesse dans la partie inférieure gauche de la barre d'état signale le nombre de 'commandes Tech2' pouvant être exécutées avant le retour 'en veille' de Tech2Win. Cette méthode permet de vérifier que le temps dans Tech2Win correspond au temps réel : les PC rapides restent plus longtemps en veille que les PC lents. Si l'indicateur de vitesse fluctue, il est probable qu'une autre application utilise le processeur ou que l'horloge du PC varie. Des taux de fluctuation importants ont un impact négatif sur la communication Véhicule et la communication TIS2Web. Vérifiez qu'aucune autre application n'est en cours d'exécution.

La plupart des ordinateurs portables peuvent réduire automatiquement la vitesse de l'horloge du processeur pour allonger l'autonomie de la batterie. Cela peut être également à l'origine des fluctuations de vitesses détectées par Techn2Win. Dans ce cas, ne faites pas fonctionner l'ordinateur portable sur la batterie ; branchez-le sur le secteur. Vous pouvez également essayer de changer les paramètres d'alimentation pour que le système d'exploitation ne réduise pas la vitesse de l'horloge.

Arrêt soudain

Si le fichier journal n'indique pas la raison pour laquelle le programme s'est terminé, il se peut que les mécanismes de sécurité Tech2Win aient été activés. Ne modifiez pas les fichiers suivants : emulator.sec, emulator.lic, emulator.card. Si Tech2Win détecté une faille de sécurité, vous devez effectuer une réinstallation.

Le suédois s'affiche pour le logiciel 15.001

Le logiciel initial fourni avec TechWin2 est un logiciel de démonstration présent dans toutes les nouvelles cartes PCMCIA. TIS2Web l'indique en suédois, car TIS2Web affiche la dernière langue de la liste des quatre langues prises en charge par le logiciel de démonstration (anglais, français, allemand, suédois). Utilisez le mode de mise à jour 'Personnel' à la place de 'Standard' pour remplacer le logiciel de démonstration par le nouveau logiciel de diagnostic.

Perte de communication avec l'interface MDI

Une perte de communication MDI peut avoir plusieurs origines.

  • Câble de communication défectueux (Ethernet et USB)
  • Connexion sans fil défaillante.
  • Passage en veille du PC.

Tech2Win n'a pas trouvé mon interface MDI.

Vérifiez les points suivants :

    1. L'interface MDI est-elle active ?
    2. Le gestionnaire MDI fonctionne-t-il ?
    3. Le MDI est-il utilisé par une autre application telle que SPS ?
Vous pouvez démarrer le gestionnaire MDI en utilisant l'icône du bureau ou par l'intermédiaire de 'Démarrer/Tous les programmes/General Motors/GM MDI Software'.: Contacez l'assistance technique si le gestionnaire MDI ne fonctionne pas.

Je souhaite démarrer immédiatement Tech2Win sans passer par le configurateur

Exécutez "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Utilisez le répertoire de travail suivant : 'C:\Program Files\General Motors\Tech2Win\bin' Vous pouvez toujours utiliser le configurateur pour effectuer des modifications à la configuration.

Où se trouvent les fonctions d'impression ?

Tech2Win ne propose pas de fonction d'impression directe. Il crée des fichiers temporaires et exécute les programmes associés à l'extension du fichier. Utilisez ces programmes pour imprimer et ajuster l'apparence de votre document.

Print Report | Print Report

Pour imprimer l'écran Tech2Win actuel, utilisez l'élément de menu Fichier / Imprimer l'écran ou appuyez sur le bouton du clavier représentant une imprimante. Si vous devez imprimer plusieurs écrans Tech2Win, vous pouvez utiliser l'élément de menu Options / Captures d'écrans automatiques car celui-ci crée des fichiers PNG pour chaque écran Tech2Win. Ces fichiers PNG sont intégrés au fichier journal.

Il est également possible d'imprimer des contenus d'affichage de données (activation à l'aide de l'élément de menu Fenêtres / Affichage des données Tech2Win). Appuyez sur le bouton Démarrage impression/HTML pour démarrer ou arrêter l'acquisition de données. L'acquisition arrêtée, l'exécutable associé au HTML (généralement l'Internet Explorer) démarre, dans lequel vous avez accès à de nombreuses fonctions pour imprimer vos données.

Data Display | Data Display

Un dossier PCMCIA 'non utilisé' est présent sur mon ordinateur.

Les anciennes versions de Tech2Win enregistraient systématiquement en double les fichiers PCMCIA dans un répertoire séparé. Ce répertoire était généralement C:\PCMCIA. Ce répertoire n'est désormais plus utilisé car le téléchargement rapide de TIS2Web rend inutile l'enregistrement en double de ces téléchargements. Vous pouvez effacer ce répertoire en toute sécurité.

Je reçois le message 'chemin de fichier illégal'

Il semble que le nom de fichier contienne des caractères non autorisés tels que le signe pour cent (%). Si ce problème est constaté immédiatement après une installation, le plus efficace est d'effectuer simplement une désinstallation suivie d'une nouvelle réinstallation. La plupart des cas sont résolus avec cette méthode.

Lorsque l'installation est effectuée normalement, la variable d'environnement 'Tech2WinUserData' est définie sur 'PUBLIC' (versions Windows Vista et ultérieures) et sur 'ALLUSERSPROFILE\Documents' (versions Windows antérieures à Vista). Dans de rares cas, la variable d'environnement n'a pas été définie pendant l'opération d'installation, mais a fonctionné correctement au second essai. Vous pouvez également choisir de définir la variable d'environnement manuellement. Si vous ne savez pas comment définir une variable d'environnement, demandez de l'aide à votre administrateur.


Entrées de registre

Le programme d'installation crée les entrées suivantes dans le registre. Ne modifiez pas ces entrées manuellement. Tenez compte des avertissements Windows standard lorsque vous gérez les entrées du registre.

clé de registre | nom | type | signification
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Numéro de version interne
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Langue | REG_SZ | langue installée
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Chemin des répertoires de copie PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Racine | REG_SZ | chemin d'installation
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | UninstallOption | REG_DWORD | Paramètre Désinstaller
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Version du fichier de configuration
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Version du pilote de port de communication virtuel
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName (Nom d'affichage) | REG_SZ | Nom du logiciel dans la liste Ajout/Suppression de programmes
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UnstallString (Chaîne de désinstallation) | REG_SZ | Chemin d'accès au programme de désinstallation


Réinstallation

La réinstallation supprimera le répertoire entier d'installation de Tech2Win avec les exceptions suivantes.

  1. Le sous-répertoire config contenant les configurations n'est pas effacé.
  2. Le sous-répertoire pcmcia qui contient habituellement les images PCMCIA n'est pas effacé.
  3. Le sous-répertoire ATA qui peut contenir des informations de débogage n'est pas effacé.
Les fichiers de configuration peuvent devenir incompatibles : une nouvelle version Tech2Win peut ne pas pouvoir lire les fichiers de configuration d'une version antérieure Tech2Win. Par nature, les images PCMCIA ne peuvent pas devenir incompatibles.

Le répertoire PCMCIA secondaire n'est pas affecté par une réinstallation.

Certains environnements peuvent fournir une option d'installation automatique d'une nouvelle version de Tech2Win. Étant donné que les informations de la dernière installation sont enregistrées dans le registre, ces paramètres sont proposés par défaut lors de la réinstallation.

Vous pouvez forcer la réinstallation de Tech2Win en utilisant le script enable reinstallation. Ce script est installé avec Tech2Win. En règle générale, ce script affecte simplement la valeur '1.000' à la clé CurrentVersion found in the registry at HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win.