Tech2Win-käyttöopas

Tervetuloa Tech2Winin käyttäjäksi.

Copyright (C) 2010..2016 SPO Engineering General Motors Kaikki oikeudet pidätetään.

  • Johdanto:
  • Käyttöoikeus:
  • Asennus:Tech2Win-ohjelman asennustoimien kuvaus.
    • Asennusvaiheet
    • Ajoneuvon tiedonsiirtoliittymä
  • Ensimmäiset vaiheet
    • Kokoonpanon valinta
      • Näppäimistö
      • Ikkunoiden käsittely
    • Uudet konfiguraatiot
    • Konfiguraatioiden muokkaaminen
      • Kieli
      • Polku
      • Näyttö
      • Konfiguraation tallennus
    • Hanki voimassa oleva Tech2Win-käyttöoikeus
  • Tech2Win-ohjelman käyttö: Päivittäisen työn tietoja.
    • Valikko
    • PCMCIA-kuvan lataaminen
    • Turvallisuus
    • Raporttien tarkastelu
    • PCMCIA-kuvien käsittely
    • Tilarivi
  • Lisäaiheet: Tietoja, joita ei tarvita Tech2Winin normaalissa käytössä. Yleensä tarkoitettu vain hallintaa tekeville henkilöille.
    • Uudelleenasennus
    • Asennuksen purku
    • Konfiguraatiotiedoston muoto
    • Lokitiedosto
    • Virhesanomat ja virhekoodit
    • ATA-kortti
    • Rekisterimerkinnät
    • Tiedostot
    • Konfiguraation hallinta
  • Usein kysytyt kysymykset


Johdanto

Tech2Win on Windows-sovellus, jolla voidaan emuloida Tech2-toimintoja. Lyhyesti ilmaistuna Tech2-ohjelmistoa ajetaan PC:llä. Ohjelman suoritusta varten PC:n on täytettävä seuraavat vaatimukset:

  • Tietokoneelle on oltava asennettuna ja kytkettynä ajoneuvon tiedonsiirtoliittymä. Hyväksyttävien liittymien luettelo voi vaihdella alueittain. Useimmissa tapauksissa voidaan käyttää GM:n Multiple Diagnostic Interface (MDI) -liittymää.
  • Tech2Win-sovellus edellyttää 150 Mtavua kiintolevytilaa asennuksessa. Lisäksi kutakin käytettävää PCMCIA-flash-korttia varten tarvitaan 32 Mt.
  • Tech2Win-ohjelman ajaminen edellyttää vähintään 100 Mt vapaata fyysistä RAM-muistia. On välttämätöntä, että PC:n muisti on riittävä koko sovelluksen pitämiseksi RAM-muistissa ohjelman koko ajamisen aikana.
  • Lisäksi PC:n laskentakyvyn on vastattava 1,2 GHz Pentium-tietokonetta (yksi ydin). Suosittelemme vahvasti, että et käytä samanaikaisesti muita sovelluksia.
  • Näppäimistöä ei tarvita. Tech2Win-ohjelmaa voidaan käyttää myös kosketusnäytöllä. Konfiguraatioiden hallintaa varten suosittelemme näppäimistön käyttöä, koska joudut syöttämään tiedostonimiä.
  • Värinäyttösi tarkkuuden täytyy olla vähintään 800 x 600 ja värien määrän vähintään 256. Ilman näppäimistöä voi tarkkuus 640 x 480 olla hyväksyttävä.

Kun käytät Tech2Winiä (kannettava tietokone Tech2:n asemesta), varmista että kannettavassa tietokoneessa on riittävästi tehoa. Kannettava ei yleensä saa virtaa auton akusta siten kuin Tech2 saa.

  • Asennus
  • Ensimmäiset vaiheet


Käyttöoikeus

General Motors - Tech2Win -lisenssisopimus

Lue seuraavat ehdot ja säännöt huolellisesti ennen tämän ohjelman käyttöä. Jos et hyväksy tai ymmärrä ehtoja tai sääntöjä, ota yhteys paikalliseen jälkimarkkinointiedustajaan. General Motors myöntää tämän ohjelmiston käyttöoikeuden vain sillä ehdolla, että käyttäjä sitoutuu noudattamaan tämän Tech2Win -lisenssisopimuksen ehtoja ja sääntöjä.
General Motors myöntää General Motorsn valtuuttaman korjaamoverkoston työntekijöille yksinoikeudellisen oikeuden käyttää Tech2Win-ohjelmistoa ja sen sisältämiä tietoja TIS2Web:n tai GlobalTIS:n tai TIS2000:n yhteydessä, kuten on määritetty paikallisen valtuutetun korjaamon ja General Motorsn kansallisten myyntiyhtiöiden välisessä sopimuksessa.
Tech2Win-lisenssi on voimassa niin kauan kuin paikallisen valtuutetun korjaamon sopimus on voimassa ja kun TIS2Web-, GlobalTIS- ja TIS2000-lisenssit ovat kunnossa. Tech2Win-lisenssi umpeutuu välittömästi TIS2Web- ja GlobalTIS-lisenssien käyttöönoton yhteydessä, silloin kuin valtuutettu korjaussopimus umpeutuu.

Riippumattomat korjaamot, sillä tavalla kuin ne on määritelty Euroopan unionin ryhmäpoikkeusasetuksessa (BER) 1400/2002, voivat ostaa Tech2Win-lisenssin osana tarjottuja tilauksia, jotka ovat tarjolla Euroopan General Motorsin GM Europe Info Tech Portal -portaalissa.

Tech2Win-lisenssi ei käsitä ajoneuvon tietoliikenneliitäntää eikä PC-laitteistoa.

Tech2Win -ohjelmistoa ei saa jakaa eteenpäin, myydä tai tarjota verkossa valtuutetun korjaamon ulkopuolisille kolmansille osapuolille (kuten selostettu valtuutetun korjaamon sopimuksen liitteessä) ilman General Motorsn kansallisen myyntiyhtiön kirjallista suostumusta. Tämä koskee sekä ajan tasalla olevia että muita (kuten vanhoja DVD-levyjä) tietoja.

General Motorsn kansallisilla myyntiyhtiöillä on oikeus lopettaa valtuutetun korjaamon sopimus ja estää järjestelmän käyttö välittömästi, mikäli järjestelmää käytetään valtuuttamattomasti tai väärin. Tällöin jäljellä olevaa sopimusaikaa ja/tai vuosimaksuja ei hyvitetä.

Annetut tiedot on tarkoitettu muuntamattomien General Motors -ajoneuvojen huolto- ja korjaustöiden ammattimaista suorittamista varten. Suoritettu automekaanikon tutkinto ja säännölliset jatkokoulutukset ovat edellytyksiä näiden töiden suorittamista varten. Jos annetuissa tiedoissa mainitaan erikoistyökaluja, niiden käyttäminen on pakollista korjaus- tai huoltotyön suorittamiseksi oikealla tavalla.

General Motorsn Global TIS -ohjelmiston sisältämät tiedot (teksti ja kuvat, musiikki, grafiikka, animaatiot, videot jne.) ja niiden ulkoasut ovat tekijänoikeusuojattuja. Toisto, levitys, jakelu, siirto tai muu käyttö on sallittua vain General Motorsn etukäteen myöntämällä kirjallisella suostumuksella.

  • Asennus: Asennusvaiheet
  • Ensimmäiset vaiheet


Installation

Asennus

Tech2Win-ohjelman asennus edellyttää PC:n paikallisen pääkäyttäjän oikeuksia. Asennus epäonnistuu, jos sitä ei suoriteta järjestelmänvalvojana. Ota tällöin yhteyttä PC:n paikalliseen pääkäyttäjään.

Tech2Win-ohjelman käyttäminen edellyttää seuraavien kahden vaiheen tekemistä:

  • Tech2Win-ohjelman asennus.
  • Ajoneuvon tiedonsiirtoliittymän asennus.
  • Asennus: Asennusvaiheet
  • Ensimmäiset vaiheet


Asennusvaiheet

Itse asennus kestää vain muutaman minuutin ja asettaa seuraavat vaatimukset käyttäjälle:

  1. Lisenssisopimus
  2. Asennushakemisto

Kieli

Tech2WIN UI näytetään oletuksena käyttöjärjestelmäsi kielellä. Seuraavat kielet ovat tuetut: Ellei asennusohjelmassa ole tukea kielellesi, asennusohjelma käyttää oletusarvoisesti englantia asennuskielenä.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)English (BR tai US)*
  • el_GR (EL)Greek
  • es_ES (ES)espanja
  • fi_FI (FI)Finnish
  • fr_FR (FR)ranska
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portuguese (Brasilia)
  • pt_PT (PT)Portuguese (Portugali)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Chinese (yksinkertaistettu)
  • zh_TW (ZH)Chinese (perinteinen)

* Tech2Winin kieli on englanninenglanti. Käyttämäsi Tech2-ohjelmisto ja asennusohjelma saattavat kuitenkin valita amerikanenglannin lähdeohjelmistosta riippuen.

Lisenssisopimus

Sinun on hyväksyttävä lisenssisopimus.

Asennushakemisto

Voit valita minkä tahansa hakemiston Tech2Win-asennushakemistoksi. Asennuksen oletushakemisto on joko <omat ohjelmatiedostot>\General Motors\Tech2Win tai uudelleenasennuksen yhteydessä aiemmin määritetty hakemisto.

Vahvista lopuksi asennus.

Virtuaalisen Com-portin ajuri

Virtuaalisen Com-portin ajuri asennetaan tietokoneeseesi vain kerran ja se on käytössä, kunnes sen versio päivitetään (tapahtuu harvoin) tai kun Tech2Winin asennus puretaan tietokoneeltasi.
Jos ajuri asennetaan, näet DOS-ruudun näytöllä hetken ajan. Se sulkeutuu automaattisesti eikä vaadi mitään lisätoimenpiteitä. Ajuritiedostot sijoitetaan lisäksi 'ohjain'-alikansioon Tech2Win-asennuskansiossa.
Virtuaalisen Com-portin ajurien manuaalinen asennus ja asennuksen purkaminen on mahdollista, mutta ei suositeltavaa. Käytä jotakin seuraavista komennoista CMD solusta:

  • Avaa 'vbsetup7' ajurin asentamiseksi
  • Avaa 'vbsetup7 /u' ajurin asennuksen purkamiseksi
  • Ensimmäiset vaiheet


Ajoneuvon tiedonsiirtoliittymä

Ajoneuvon tiedonsiirtolaite on asennettava erikseen. Saat lisätietoja Ajoneuvon tiedonsiirtoliittymän mukana toimitetusta asennusoppaasta.

  • Ensimmäiset vaiheet: Ajoneuvon tiedonsiirtoliittymä
  • Lisäaiheet: Konfiguraatiotiedosto
  • Asennus: Asennusvaiheet
  • Usein kysytyt kysymykset: Kuinka voin käyttää useampia kuin yhtä MDI-liittymää?
  • Usein kysytyt kysymykset: Tech2Win ei löydä minun MDI:täni


Ensimmäiset vaiheet

Näiden ensimmäisten vaiheiden avulla esitetään Tech2Winin käyttö. Oletuksena on, että tunnet jo Tech2:n. Tiedonsiirtoa ajoneuvon kanssa ei tarvita näiden ensimmäisten vaiheiden aikana.

Pikakäynnistyksen suorittamiseksi tee seuraavat kohdat:

  1. Suorita Tech2Win-ohjelmisto käyttämällä pikakäynnistyskuvaketta työpöydältäsi.
  2. Hanki voimassa oleva lisenssi lataamalla uusi Tech2-ohjelmisto TIS2Webistä.

Valittavan konfiguroinnin käyttämiseksi:

  1. Käynnistä konfiguraattori käyttämällä Tech2Win-pikakuvaketta työpöydältäsi. Asennuksen jälkeen käytössä on yleensä oletus konfiguraatio.
  2. Uuden konfiguraation tekemiseksi kopioi mieluiten oletus-konfiguraatio.
  3. Muuta käytössä olevaa konfiguraatiota omien vaatimustesi mukaiseksi.
  4. Hanki voimassa oleva käyttöoikeus.

Älä käynnistä Tech2Winiä yhteensopivuustilassa. Varoitus ilmestyy tällöin lokitiedostoon. Tech2Win käyttää vain XP:n jälkeisiä Windows-toimintoja, eikä se toimi aikaisemmissa Windowsin versioissa.

  • Ensimmäiset vaiheet: Uudet konfiguraatiot
  • Ensimmäiset vaiheet: Konfiguraatioiden muokkaaminen
  • Ensimmäiset vaiheet: Ajoneuvon tiedonsiirtoliittymä
  • Tech2Win-ohjelman käyttö: Valikko
  • Tech2Win-ohjelman käyttö: Turvallisuus
  • Tech2Win-ohjelman käyttö: Tilarivi
  • Lisäaiheet: Konfiguraatiotiedosto


Kokoonpanon valinta

Tech2Win-sovelluksen ensimmäisellä käyttökerralla avautuu seuraava näyttö. Voit valita, käynnistetäänkö Tech2Win suoraan oletuskonfiguraatiota käyttäen. Oletuskonfiguraatio toimii ilman tiedonsiirtoa ajoneuvon kanssa.

Start First Time

Käyttöoikeustiedon sanomaruutu tulee näkyviin, mutta voit jättää sen huomiotta käynnistääksesi oletuskokoonpanon.

Käytettäessä kosketusnäyttöä voi olla hyödyksi käynnistää PC-näppäimistöohjelma, jolla voi syöttää kirjaimia.


Näppäimistö

PC:n näppäimet sekä mahdolliset painikkeet määritetään vastaamaan tuttuja Tech2-näppäimiä. Tech2Win sisältää joitakin lisänäppäimiä, joita ei ole alkuperäisessä Tech2:ssa. Tietokoneen numeronäppäimistö ei ehkä toimi kaikissa olosuhteissa. Ongelmatapauksissa tarkista, onko PC-tietokoneen standardinäppäimistöasettelua muutettu. Erityisesti VAIHTONÄPPÄIN voi vahingoittua tällaisessa tilanteessa.

PC-näppäimistö | Painike | Toiminto
F1-funktionäppäin | n.a. | Tech2Win ohje
F5 .. F8-funktionäppäimet | Käytä Tech2Win-näyttöaluetta, jossa on kosketusnäppäimet | Tech2:n neljä ohjelmoitavaa näppäintä
Ylös, Alas, Vasen, Oikea kohdistinnäppäin |  | Tech2 :n Ylös, Alas, Vasen, Oikea näppäin; Vain näissä näppäimissä on automaattinen toisto.
0 .. 9-näppäimet | F0 • • • F9 | Tech2 F0 .. F9-näppäimet
Askelpalautin | Exit | Tech2 Exit -näppäin
Enter / Return | Enter | Tech2 Enter-näppäin
Y | Yes | Tech2 Yes-näppäin
N | No | Tech2 No-näppäin
Q | ? | Tech2 ?-näppäin
S | Shift | Tech2 Shift-näppäin. Tilarivin Vaihto-ilmaisin tai Vaihto-painikkeen yläpuolella oleva ilmaisin ilmaisee tilan.
ctrl-P | PWR | Tech2 virtanäppäin; Tällä voi tietenkin vain sammuttaa Tech2Win-sovelluksen.
ctrl-R | ei saatavilla | Nollaa Tech2Winin. Samanlainen toiminto kuin virran katkaisu ja kytkeminen Tech2:ssa. Liitettyä ajoneuvon tiedonsiirtoliittymää ei kuitenkaan ole palautettu. Tiedostoja kuten PCMCIA-kuvaa ei ole ladattu uudelleen.
Alkuun | Home | Alkuun-näppäin Tuki vain joissakin sovelluksissa.
käytettävissä vain valikkovalinnan Tiedosto kautta. | Print Screen | Tulostaa Tech2-näytön näyttökuvan luomalla väliaikaisen bmp-tiedoston ja noutamalla sovellukseen liittyvät bmp-tiedostot. Käytä tätä sovellusta kuvan koon muuttamiseksi tai kuvan kääntämiseksi ennen tulostamista.
käytettävissä vain valikkovalinnan Tiedosto kautta. | Save Screen | Tallentaa Tech2-näytön näyttökuvan BMP- tai PNG-tiedostona.
käytettävissä vain valikkovalinnan Tiedosto kautta. | View Report | Näyttää käyttäjän tarkasteltavaksi kaikki aktiivisen PCMCIA-flash-kortin raportit.


Ikkunoiden käsittely

Voit muuttaa ikkunoiden kokoa Windowsin tapaan vetämällä pääikkunan reunoista. Lisäksi valikkokohta Asetukset/Resoluutio tukee useita esiasetettuja kokoja. Jos pääikkunan kokoa muutetaan valikkotoiminnolla, numeronäppäimistöikkuna pysyy automaattisesti kiinnittyneenä.

Ikkunoiden ulkoasua voi muokata muuttamalla konfiguraatiota välilehdessä Näyttö.


Uudet konfiguraatiot

Luo uusi konfiguraatio valitsemalla Luo uusi. Avautuva valintaikkuna pyytää valitsemaan nykyisen konfiguraatiotiedoston lähteeksi. Yleensä valitaan oletus konfiguraatio. Kun olet antanut uuden konfiguraatiotiedoston nimen, valitse Kopioi.

Jos käytät kosketusnäyttöä, haluat ehkä aktivoida PC-näppäimistön simuloinnin painikkeella PC-näppäimistö.

Voit peruuttaa luontiprosessin painikkeella Paluu.

Uusi konfiguraatio käyttää samaa PCMCIA-tiedostoa kuin käytössä oleva lähdekonfiguraatio. Jos haluat vaihtaa tämän asetuksen, sinun on muutettava konfiguraatiota, jotta eri PCMCIA-tiedostoa voitaisiin käyttää. Useimmissa tapauksissa voit kopioida käytössä olevan PCMCIA-tiedoston uudeksi tiedostoksi ja käyttää sitä uutena tiedostona. Haluat mahdollisesti, että uusi konfiguraatiosi käyttää samaa PCMCIA-tiedostoa kuin lähdekonfiguraatiosi. Siinä tapauksessa esiin tulee varoitusnäyttö Tallenna-painiketta painaessasi.

  • Konfiguraatioiden muokkaaminen


Konfiguraatioiden muokkaaminen

Sinisellä merkityt konfiguraatiot on merkitty vain luku -tilaan eikä niitä voi muuttaa. Näitä konfiguraatioita voi vain tarkastella. Voit tietysti käyttää muokkaustapaa niiden sisällön tarkastelemiseen, mutta Tallenna ei ole mahdollista.

Konfiguraatiota muokataan valitsemalla yksittäinen asetus yhdessä neljästä välilehdestä Kieli, Ajoneuvon tiedonsiirtoliittymä, Polku, Näyttö. Voit joko valita haluamasi sarkaimen tai painaa painiketta Seuraava, joka aktivoi seuraavan sarkaimen. Muutosten jälkeen tallenna konfiguraatio painamalla Tallenna-painiketta.

Aina kun on tarpeen syöttää tietoja näppäimistöllä, voit kutsua näppäimistöä simuloivaa PC-sovellusta. Tämä on erityisen kätevää kosketusnäytöllisillä kämmenlaitteilla, kun näppäimistöä ei ole käytettävissä.


Kieli

Välilehdessä Kieli voit valita Tech2Win-ohjelmassa käytettävän kielen. Tämä valinta ei vaikuta kieleen, joka on käytössä Tech2-ohjelmalla PCMCIA-kuvassa. Kun Tech2-ohjelmisto ladataan TIS:stä, on kieli kuitenkin vielä valittava.

Joillakin alueilla kaikki kielet eivät ole käytettävissä. Tällöin käytössä on englanti. Tarkista, onko samantyyppinen kieli käytettävissä (PT Portugalin kieli-Portugal mieluummin kuin PB Portugalin kieli- Brasilia).


Polku

Välilehdessä Polku voit määrittää sekä PCMCIA-kuvien hakupolun että paikallisen ohjelmanäppäimistön hakupolun. Lisäksi painikkeella Kopioi muistikortti voidaan kopioida PCMCIA-kuvia. Jos olet juuri luonut uuden konfiguraation, voit ehkä haluta käyttää tätä painiketta estääksesi useita eri konfiguraatioita käyttämästä samaa PCMCIA-kuvaa.

Memory Card Options

Kopioi muistikortti ...

Tällä painikkeella voit myös kopioida PCMCIA-kuvan toiseen tiedostoon. Sen toiminta on hyvin samanlainen kuin uuden PCMCIA-kortin ostaminen Tech2:een. Kopiointitoiminto toimi ainoastaan tiedostoissa, jotka ovat kansiossa C:\Users\Public\General Motors\Tech2Win\pcmcia.

Paikka 0: muistikortin kuvan sijainti

Tässä voit määrittää tiedoston, joka sisältää paikan 0 PCMCIA-kuvan. Normaalisti tällainen tiedosto on tallennettu kansioon C:\Users\Public\General Motors\Tech2Win\pcmcia, muut sijainnit ovat kuitenkin mahdollisia.

Paikka 1: muistikortti tai ATA

Kuten Tech2, myös Tech2Win tukee kahta PCMCIA-korttia (kuvia). Konfiguraation toinen PCMCIA-kuva ei yleensä kuitenkaan ole kovin käytännöllinen. Toisessa konfiguraatiossa käytettäisiin luultavasti toista ohjelmaa.

Samoin Tech2:ssa, vianmääritykseen käytetään ATA-korttia. Aktivoi ATA-kortti vain, jos tekninen tuki näin neuvoo. Saat tuelta lisätietoja.

PC-ohjelmistonäppäimistön sijainti

Tiedoston oletusarvo haetaan Windowsin rekisteristä ja sen tulee viitata sovellukseen, joka osaa simuloida PC:n näppäimistöä hiiren avulla. Jos käytössäsi on erityinen sovellus tätä toimintoa varten käytössä olevassa kannettavassa tietokoneessa, voit määrittää sovelluksen tässä.


Ajoneuvon tiedonsiirtoliittymä

  • Tech2-RS232-emulaation COM-portti
  • Käytettävä MDI:n sarjanumero
  • Protokolla

Tech2-RS232-emulaation COM-portti

Valitse vapaa COM-portti, jota voidaan käyttää Tech2-emulointia varten. Käytön helpottamiseksi määritysohjelma tarkistaa, mitkä sarjaportit ovat jo käytössä, ja luettelee ne näytöllä.

Jos valitset olemassa olevan COM-portin, Tech2Win liittää itsensä tähän COM-porttiin. Voit käyttää tätä COM-porttia Tech2-ohjelmiston lataamiseen toiselta TIS-sovellusta käyttävältä tietokoneelta käyttämällä nollamodeemikaapelia. Huomaa, että todellisen COM-portin käyttö ei ehkä toimi luotettavasti 115.200 baudilla Windows-rajoitusten takia.

Jos ei-oleva COM-portti valitaan, Tech2Win luo automaattisesti virtuaalisen portin. Tätä virtuaalista porttia voidaan käyttää samalla tietokoneella käytettävästä TIS:stä viestintäyhteyden muodostamiseksi Tech2Winin kanssa. Käytettäessä virtuaalista porttia ei ole mitään baudimäärän rajoitusta.

Jos valitset 'search' COM-portin kohdalla, Tech2Win luo virtuaalisen COM-portin ensimmäiseen vapaaseen portin numeroon alueelta 9–1.

Käytettävä MDI:n sarjanumero

Syötä MDI:n sarjanumero. Numero löytyy MDI:n takasivulta. Käytä tavuviivan jälkeen olevaa numeroa.

Jos et syötä sarjanumeroa, Tech2Win näyttää automaattisesti luettelon verkossa tunnistetuista MDI-liittymistä, joista käyttäjä voi valita MDI:n. Sama valintaruutu tulee näkyviin, jos määritettyä MDI:tä ei löytynyt.

Protokolla

'ISO22900-2 / PDU-API' valitaan ja J2534-2 ei ole käytettävissä. Tulevaisuudessa Tech2Win voi pystyä tukemaan myös J2534-protokollaa.

  • Lisäaiheet: Konfiguraatiotiedosto
  • Usein kysytyt kysymykset: Kuinka voin määrittää, mitä COM-porttia minun tulee käyttää Tech2Winiä varten?
  • Usein kysytyt kysymykset: Tiedonsiirto Tech2Winin ja TIS2Webin välillä
  • Usein kysytyt kysymykset: Kuinka voin käyttää useampia kuin yhtä MDI-liittymää?
  • Usein kysytyt kysymykset: Tech2Win ei löydä minun MDI:täni


Näyttö

Välilehdessä Näyttö muutetaan lähinnä Tech2Winiin liittyviä näyttöasetuksia:

  • Näppäimistö
  • Värit
  • Ääni
Display and Key Options

Näppäimistö

Voit valita, näytetäänkö näppäimistö. Näppäimistö on Tech2Win-näytön vasemmalla tai oikealla puoliskolla. Taustaväri voidaan valita värinvalintaikkunassa.

Värit

Tech2-näytön tausta- ja edustavärit voidaan voita tässä. Nämä ovat kaksi yleisintä väriyhdistelmää:

Screen with background 0000FF, foreground FFFFFF | Näppäimistön tausta valkoinen; Tausta sininen; Edusta valkoinen
Screen with background 000000, foreground C0C0C0 | Näppäimistön tausta sininen; Tausta musta; Edusta vaaleanharmaa

Ääni

Voit halutessasi sulkea äänentoiston tässä kohdassa. Tech2-ohjelman äänimerkki annetaan PC:n kaiuttimella.


Konfiguraation tallennus

Aktiivinen konfiguraatio voidaan tallentaa painamalla Tallenna <konfiguraatio> -painiketta vasemmassa alanurkassa. Tämä painike ei ole näkyvissä, jos käytössä on vain luku -konfiguraatio.


Voimassa oleva käyttöoikeus TIS2Webin kautta

Normaalisti Tech2-ohjelmiston lataaminen Tech2Winiin antaa sinulle voimassa olevan käyttöoikeuden. Tämän lisäksi voit luoda yhden luomalla 'Pääsyoikeus (Suojaus)' TIS2Webin (ei TIS2000-ohjelman) avulla. Edellytyksenä on tällöin virtuaalisen COM-portin valinta konfiguraattorista kohdasta Vehicle Communication Interface.

Onnistuneen käyttöoikeustarkistuksen jälkeen näet avoimen lukon tilarivissä oikealla puolella. Sulkeisten sisällä näet niiden päivien lukumäärän, jotka käyttöoikeus on voimassa. Kun käynnistät Tech2Winin uudelleen, suojausilmaisinta ei näy niin kauan kuin auton yhteyttä ei ole muodostettu. Ensimmäisen tiedonsiirron tapahduttua auton kanssa käyttöoikeus tarkistetaan ja ilmaisin muuttuu joko avatuksi tai suljetuksi lukoksi.

  • Tech2Win-ohjelman käyttö:Turvallisuus
  • Usein kysytyt kysymykset:Kuinka voin määrittää, mitä COM-porttia minun tulee käyttää Tech2Winiä varten?
  • Usein kysytyt kysymykset:Tiedonsiirto Tech2Winin ja TIS2Webin välillä
  • Usein kysytyt kysymykset:Voimassa oleva käyttöoikeus
  • Usein kysytyt kysymykset:Mikä on ero Tech2Winin käyttöluvan ja Security Access -sovelluksen välillä?


Tech2Win-ohjelman käyttö

Seuraavia aiheita käyttävät useimmat asentajat Tech2Win-työssä:

  • Valikko: Näytön asettelu ja yksittäiset valikkovaihtoehdot.
  • PCMCIA-kuvan lataaminen: Tech2Winin vianmääritysohjelman päivitys on hyvin samanlainen kuin mitä Tech2 käyttää.
  • Turvallisuus: Turvatoimet estävät Tech2Winiä olemasta yhteydessä ajoneuvoon valtuuttamattomissa ympäristöissä.
  • Raporttien tarkastelu: Tech2-näppäimistö on hieman parannettu Tech2Winissä. Selkein esimerkki on painike 'Raporttien tarkastelu'.
  • PCMCIA-kuvien käsittely: Samoin kuin Tech2:ssa voi olla useita PCMCIA-kortteja, Tech2Winissä voi käyttää useita PCMCIA-kuvia.
  • Tilarivi: Tilarivi antaa käyttäjälle tietoja eri osista.
    • Lisäaiheet
    • Usein kysytyt kysymykset


Valikko

Tech2Win-sovelluksessa on seuraavat valikot:

  • Tiedosto
  • Asetukset
  • Näkymät
  • Ohje

Tiedosto

Tiedosto-valikko tarjoaa seuraavat mahdollisuudet:

  • Tallenna T2-näyttö (320x240) -komennolla tallennetaan nykyinen T2-näyttö 320x240 kuvapisteen koossa mustavalkoisena kuvana PC:lle. Tallennuksen sijainti ja tiedostomuoto (BMP, GIF, JPG, PNG) ovat vapaasti valittavissa.
  • Tulosta näyttö luo käänteisen mustavalkoisen Tech2-näytön BMP-kuvan ja kutsuu BMP-tiedostoihin liitetyn ohjelman. Voit sitten käyttää tätä ohjelmaa kuvan tulostamiseksi.
  • Näytä raporttitiedostot tarjoaa mahdollisuuden katsoa (ja tulostaa) raportitiedostoja käyttämättä TIS2Webiä.
  • Lopeta sulkee Tech2Winin.

Asetukset

Asetukset tarjoaa seuraavat valinnat:

  • Resoluutio mahdollistaa valinnan kolmesta näytön vakiokoosta.
  • ROM-Write from 0x00003ED76 on tarkoitettu sisäisiin virheenkorjauksiin.
  • Automaattiset kuvakaappaukset jokaisen eri Tech2-näyttökuvan tallentaminen lokikansioon.
  • Poista CANdi käytöstä ja käynnistä uudelleen jäljittää Tech2:n, jolla ei ole CANdia itsensä ja auton välillä. Tämä on tarpeen hyvin harvoissa tilanteissa, joissa CANdi keskeyttää standardista poikkeavat tiedonsiirtolinjat.

Näkymät

Valikko Näkymät antaa sinulle mahdollisuuden aktivoida valinnat Tech2Win tietojen näyttö ja Tech2Win DTC-näyttö. Mitkään muut valinnat eivät onnistu Tech2Win-versiossa.

Jos Tech2-ohjelmistossa on tuki Tech2Win tietojen näyttö -toiminnolle, voit aktivoida tämän valikkoasetuksen. Data Display -toimintoon siirryttäessä Tech2Win näyttää Data Display -lisäikkunan Tech2 Data Display -näytön lisäksi. Silloin kun Tech2-näytössä on esillä 'Data Display' -näyttö, valikkoasetusta ei voi aktivoida. Tällöin sinun on suljettava 'Data Display' -näyttö, aktivoitava valikkoasetus ja käynnistettävä uudelleen 'Data Display' -näyttö.

Näyttöä Tech2Win tietojen näyttö koskevat rajoitukset ovat myös voimassa näytössä Tech2Win DTC-näyttö. Jos Tech2-ohjelmistossa on tuki Tech2Win DTC-näyttö -toiminnolle, voit aktivoida tämän valikkoasetuksen. Ylimääräinen 'DTC Display' -näyttö ilmestyy 'Tech2 DTC Display' -näytön rinnalle. Silloin kun Tech2-näytössä on esillä 'DTC Display' -näyttö, valikkoasetusta ei voi aktivoida. Tällöin sinun on suljettava 'DTC Display' -näyttö, aktivoitava valikkoasetus ja käynnistettävä uudelleen 'DTC Display' -näyttö.

Ohje

Seuraavat valinnat ovat käytettävissä:

  • Ohjeaiheet... tuo näyttöön Tech2Winin ohjeen.
  • Komentorivin parametri näyttää Tech2Winissä käytettävät komentorivin parametrit.
  • Tietoja-ikkuna näyttää nykyisen version numeron jaTech2Winin TIS2Web-latauksen rajoitukset.


Lataa

Käynnistä ensin Tech2Win ja anna sen olla päänäytössä. Käynnistä TIS2Web tai GlobalTIS ja suorita lataus välilehdellä Ajoneuvon tiedonsiirtoliittymä määritetyn COM-portin kautta.

Sisäänrakennettujen COM-porttien avulla voidaan Tech2-ohjelma ladata toisesta PC:stä, jossa TIS on käynnissä. Käytä ristiinkytkettyä RS232-kaapelia. Sen mukaan millainen laitteisto Tech2Winiä ajavassa PC:ssä on, datan siirtonopeus on ehkä rajoitettava arvoon 57600 baudia, koska Windows voi menettää dataa suuremmalla nopeudella.

Uusin Tech2Win-versio tukee myös nopeaa latausta silloin kun TIS2Web ja Tech2Win ovat käytössä samassa tietokoneessa. COM-portin kautta suoritetaan edelleen jonkin verran TIS2Web- ja Tech2Win-ohjelmien välistä tietoliikennettä, mutta aikaa vievä tietojen siirto Tech2Winiin on korvattu sisäisellä tiedostonsiirrolla. Tässä tapauksessa lataamisaika on vähentynyt huomattavasti runsaasti alle minuuttiin.

  • Lisäaiheet: Konfiguraatiotiedosto
  • Ensimmäiset vaiheet: Ajoneuvon tiedonsiirtoliittymä
  • Usein kysytyt kysymykset: Kuinka voin määrittää, mitä COM-porttia minun tulee käyttää Tech2Winiä varten?
  • Usein kysytyt kysymykset: Tiedonsiirto Tech2Winin ja TIS2Webin välillä


Turvallisuus

Tech2Winin käyttämät suojausmekanismit perustuvat tietokoneen oikeaan kellonaika-arvoon. Varmista, että tietokoneesi kello on aina oikein asetettu. Pienet kellonajan muutokset, joita voi sattua päivän aikaisissa tallennuksissa, Tech2Win hyväksyy.

Tech2Win ei suorita mitään auton tiedonsiirtoja ilman voimassa olevaa ja aktiivista käyttöoikeutta. Seuraava ilmaisin tilarivillä näyttää käyttöoikeustilan:

  • green smiley Käyttöoikeus on voimassa.
  • Ei ilmaisinta: Käyttöoikeutta ei ole vielä tarkistettu.
  • red smiley Käyttöoikeus on päättynyt.

Lisenssin saamiseksi suorita 'Pääsyoikeus (Suojaus)' -päivitys käyttämällä TIS2Web-sovellusta. Useimmissa tapauksissa ohjelmiston lataus TIS2Webin kautta riittää myös uuden käyttöoikeuden saamiseen. Koska käyttöoikeuden voimassaolo lakkaa tietyn ajanjakson jälkeen (joillakin alueilla: neljän viikon), sinun on suoritettava tällainen päivitys säännöllisin väliajoin.

Käyttöoikeudet ovat alue-/ohjelmistokohtaisia. Sinun tietokoneessasi saattaa olla käyttöoikeudet, jos käytät tech2Winiä eri Tech2-ohjelmistoversioin.

Tilarivillä näkyy, kuinka monta päivää on jäljellä ennen käyttöoikeuden päättymistä.

  • ( 0) osoittaa, että käyttöoikeus on päättynyt tai sitä ei ole.
  • (<1) Käyttöoikeus päättyy 24 tunnin kuluessa.
  • (20) Käyttöoikeus päättyy 20 päivän kuluttua.

Älä käsittele luvattomasti käyttöoikeustiedostoa. Tämän tiedoston vilpilliset muutokset havaitaan sisäisten turvatoimien avulla ja tällöin kaikki käyttöoikeudet häviävät tietokoneesta. Lisäksi Tech2Win käyttäytyy odottamattomasti. Tämä tilanne voidaan korjata vain suorittamalla uusi asennus.

  • Lisäaiheet: Virhesanomat ja lopetuskoodit
  • Lisäaiheet: Lokitiedosto
  • Tech2Win-ohjelman käyttö: Tilaikkuna
  • Usein kysytyt kysymykset: Voimassa oleva käyttöoikeus
  • Usein kysytyt kysymykset: Mikä on ero Tech2Winin käyttöluvan ja Security Access -sovelluksen välillä?
  • Usein kysytyt kysymykset: Äkillinen pysäytys


Raporttien tarkastelu

View Report Tällä painikkeella voidaan tarkastella PCMCIA-kortin minkä tahansa PRT-tiedoston sisältöä. Valintaruutu näyttää PRT-tiedostojen luettelon. Jos ohjelmaan on kytketty PRT-tunniste, tämä ohjelma käynnistyy. Muutoin Notepad käynnistyy ja näyttää valitun tiedoston.

Useimmiten PRT-tiedosto on ASCII-tiedosto, jossa käytetään kielikohtaista koodisivua. Kiinan, japanin, korean ja thain osalta tiedosto on Unicode-muodossa, jossa on alussa Byte-Order_Mark (BOM).

Raportteja tarkistaessasi Tech2Win käyttää alikansiota C:\Users\Public\General Motors\Tech2Win\reports. Tämä hakemisto on olemassa vain, jos ole tarkastellut raportteja vähintään kerran. Hakemisto poistetaan automaattisesti ja se toimii väliaikaisena työhakemistona aktiivisen PCMCIA-kortin PRT-tiedostoille. Tiedostot pysyvät hakemistossa silloinkin jos Tech2Winin suoritus pysähtyy. Jos haluat tallentaa tällaisen tiedoston, se on kopioitava toiseen hakemistoon, koska sen yli voidaan kirjoittaa heti kun toinen käyttäjä tarkastelee raportteja.


PCMCIA-kuvat

PCMCIA-kuvat sijaitsevat normaalisti alikansiossa C:\Users\Public\General Motors\Tech2Win\pcmcia. Tiedoston koon on oltava tarkalleen 32 Mt (33,554,432 tavua) tai 10 Momentinmuuntimen (10,485,760 tavua) ja sen tunnisteen *.bin. Kuvia muokataan (kuten tavallista PCMCIA-korttia), jos tehdään lataus tai jos Tech2Win tallentaa jotain flash-kortille. Muokkaus voidaan estää käyttämällä kirjoitussuojauskytkintä (käsky -W0 tai -W1) tai jättämällä pois arvo 'p' valinnasta '-W'(Konfiguraatiotiedosto). Päällekirjoitussuojakytkintä ei voi käyttää konfiguraattorin kautta Sinun on muutettava manuaalisesti konfiguraatiotiedostoa, jos haluat käyttää vaihtoehtoja '-W0', '-W1' tai '-W'.


Tilarivi

Tilarivi näkyy Tech2-näytön alapuolella. Tilarivillä näkyvät seuraavat:

  1. Nopeusosoitin
  2. Ajoneuvon tiedonsiirron tila
  3. Sarjaportin tila
  4. SHIFT-näppäin
  5. Automaattiset kuvakaappaukset
  6. Loki-varoitus
  7. Käyttöoikeus

Status Bar

Nopeusosoitin

Nopeusosoitin näyttää, miten paljon CPU:n aikaa kuluu Tech2-ohjelmiston emulointiin. Pieni luku (osoitin vasemmalla) on parempi kuin suuri luku (osoitin oikealla). Kaikki vihreät osoittimet ovat hyväksyttäviä. Osoitin voi muuttua keltaiseksi hetkittäin, jos Windowsin eri tehtävät aktivoituvat. Tällaisia toimintoja on vältettävä.

Ajoneuvon tiedonsiirron tila

Ajoneuvon yhteystila osoittaa, onko ajoneuvon tiedonsiirtoliittymä (MDI) sekä ajoneuvon ja Tech2Winin välinen tiedonsiirto käytössä.

Sarjaportin tila

Tiedonsiirrossa Tech2Winin kanssa COM-portin avulla tämä osoitin näyttää, onko COM-portin tiedonsiirto aktiivinen.

SHIFT-näppäin

Tämä ilmaisin näyttää, onko SHIFT-näppäin aktivoituna. Voit painella sitä käyttämällä näppäimistön 'S'-kirjainta tai painikkeiston SHIFT-näppäintä.

Automaattiset kuvakaappaukset

Automaattiset ruudunkaappaukset voidaan aktivoida valikossa Asetukset. Joka kerta kun näyttökuva vaihtuu, uusi näyttökuvatiedosto tallennetaan lokikansioon. Tämä osoitetaan kääntämällä tilarivillä olevan punaisen kameran kahvaa. Heti kun automaattiset ruudunkaappaukset on deaktivoitu, kamera häviää.

Loki-varoitus

Lokin tilailmaisimella voi olla kolme eri tilaa.

  • gray log status indicator Lokitiedosto ei sisällä varoituksia eikä virheitä.
  • yellow log status indicator Lokitiedosto sisältää varoitussanoman.
  • red log status indicator Lokitiedosto sisältää virhesanoman.

Käyttöoikeus

Käyttöoikeuden ilmaisimella on kolme tilaa:

  • green smiley Käyttöoikeus on aktiivinen ja voimassa.
  • Ei ilmaisinta: Käyttöoikeutta ei ole vielä tarkistettu.
  • red smiley Käyttöoikeus on päättynyt tai sitä ei ole.
Katso lisätietoja linkistä Turvallisuus.

Tilarivin työkaluvihjeet

Määrätyille kuvakkeille on erilliset työkaluvihjeet, jotka sisältävät lisätietoja:

VCI-sarjanumeron työkaluvihje:
Tooltip VCI

TECH2-ohjelmistoversion työkaluvihje
Tooltip TECH2

Com-portin työkaluvihje
Tooltip Comport

Seuraavan kuvankaappauksen työkaluvihje (jos 'Automaattiset kuvakaappaukset' on kytketty päälle)
Tooltip Camera

Työkaluvihje, joka osoittaa viimeisen lokitiedoston kohdan, jonka taso on 'varoitus' tai korkeampi
Tooltip Logfile

Käyttöoikeuden tarkan keston työkaluvihje
Tooltip License

Työkaluvihjeet näytetään, jos kohdistin on kuvakkeen päällä liikkumatta yli 0,5 sekuntia. Työkaluvihjeet häviävät 5 sekunnin kuluttua tai sitten kun kohdistinta siirretään.

  • Lisäaiheet: Virhesanomat ja virhekoodit
  • Lisäaiheet: Lokitiedosto


Lisäaiheet

Tässä esitetyt aiheet eivät yleensä ole tärkeitä Tech2Win-ohjelman vakiokäyttäjälle. Sen sijaan Tech2Winin asetuksia, hallintaa ja konfigurointia tekeville seuraavista tiedoista voi olla hyötyä.

  • Uudelleenasennus
  • Asennuksen purku
  • Konfiguraatiotiedostojen suora muokkaus
  • Lokitiedosto
  • Virhesanomat ja lopetuskoodit
  • ATA-kortti
  • Rekisterimerkinnät
  • Tiedoston kuvaus
  • Esimerkkejä konfiguraatioiden hallinnasta


Asennuksen purku

Täydellinen asennuskansio, käyttäjätiedot sisältävä (C:\Users\Public\General Motors\Tech2Win) ja sovellustiedot sisältävä kansio (C:\ProgramData\General Motors\Tech2Win) poistetaan.

  • Lisäaiheet: Uudelleenasennus
  • Asennus


Konfiguraatiotiedosto

Konfiguraatiotiedostot sijaitsevat aina alikansiossa C:\Users\Public\General Motors\Tech2Win\config, ja niiden tiedostotarkenne on *.conf. Käyttäjä voi halutessaan muokata manuaalisesti Konfiguraatiotiedostoa, koska tiedoston kaikkia valintoja ei voi tehdä Tech2Winillä. Konfiguraatiotiedosto on Unicode-tiedosto, jossa on alussa Byte-Order_Mark (BOM). Suosittelemme manuaalisten muutosten tekemisessä Unicode-tuen sisältävän editorin kuten Notepadin käyttämistä.

Konfiguraatiotiedosto on rivipohjainen. Tyhjät rivit ohitetaan. Rivi alkaa aina valinnalla ja useimmiten sitä seuraa arvo. Katso esimerkiksi tiedostoa default.conf. Katso seuraavaa taulukkoa, jossa käsitellään kaikki käytettävissä olevat valinnat.

Jos haluat käynnistää tietyn kokoonpanon suoraan työpöydältä, luo pikakuvake, joka suorittaa toiminnon 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Ohjelma tulee käynnistää seuraavasta työtiedostosta: 'C:\Program Files\General Motors\Tech2Win\bin'

valinta | Arvo / merkitys
; Huomautus
@ Desimaaliversionumero muodossa suuri.pieni.
Sellaisia konfiguraatiotiedostoja, joiden suuri numero on muu kuin Tech2Win-ohjelman, ei hyväksytä. Sellaiset konfiguraatiotiedostot, joiden pieni numero on muu kuin Tech2Win-ohjelman, hyväksytään.
-W0
-W1 		PCMCIA-kortilla paikassa 0/1 on kirjoitussuojaus aktivoituna.
-B0
-B1 		Paikassa 0/1 olevan PCMCIA-kortin lohkon koko yksikkönä Ktavua. Hyväksyttävät arvot ovat 128 (oletus) ja 256.
-P0
-P1 		Paikassa 0/1 olevan PCMCIA-kortin binäärikuvan sisältävä tiedosto. Tiedoston koon on oltava tarkalleen 10 Mt tai 32 Mt. Ympäristömuuttujat, kuten %ProgramData% on avattu.
Mikäli tätä valintaa ei ole, paikka oletetaan tyhjäksi.
-A0
-A1 		Paikassa 0/1 olevan PCMCIA-kortin attribuuttiarvot sisältävä tiedosto. Mikäli sitä ei ole, käytössä on oletusattribuutit kortin ja lohkon koon mukaisesti.
-W | Kun Tech2Win lopetetaan, kaikki pysyvä data kirjoitetaan vastaaviin tiedostoihin. Arvot p/f/r/c voidaan yhdistää osoittamaan vastaavasti arvoja PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | Kekohallinnan toiminta Arvot 0/r/w/t voidaan voidaan yhdistää nollaamisen, lukutarkistusten, kirjoitustarkistusten ja tehtävätarkistusten kanssa. Arvoa I käytetään aina pakottamaan kekomuistin varaaminen alemmissa osoitteissa, kun vaihtoehtoinen varaamistaulukko on asennettu. Normaalisti tätä vaihtoehtoa käytetään vain kehitystoiminnoissa.
-PC | Aikaisempi polku PCMCIA-kortin kopioimiseksi. Tätä vaihtoehtoa ei nykyisin käytetä.
-MS | Ajoneuvon tiedonsiirtoliittymän (MDI) tunnistaminen sarjanumeron perusteella. Jos ei asetettuna, sinulle näytetään käytettävissä olevien MDI-liittymien luettelo.
-CT | Tekstin väri (etualalla) 3 heksadesimaalitavuarvona. Oletusarvo on 000000 (valkoinen).
-CB | Taustan väri 3 heksadesimaalitavuarvona. Oletusarvo on FFFFFF (musta).
-ATA | Käytä tätä asetusta ATA-kaapparikortin käyttöönottoa varten. Poista se poistaaksesi ATA-kaapparikortin käytöstä.
-C | Sen COM-portin numero (1..9), jota käytetään Tech2:n RS232C-tiedonsiirtoporttina. COM9 on usein käytössä virtuaalisena COM-porttina, jonka Tech2Win asentaa. Jos tämä vaihtoehto ei ole käytettävissä, vapaan COM-portin haku suoritetaan alaspäin COM9:stä. Käytä työkalurivin työkalun kärkeä Tech2- ja TIS2Web-kuvakkeiden välissä tarkistaaksesi, mikä COM-portti on käytössä.
-WR | PC-osoite (yleensä 253558), joka voidaan kirjoittaa PCMCIA- ja FLASH ROM -alueelle. Tämä toiminto pitää lisätä erikseen valikosta (tai käyttämällä asetusta - WA) Singlestep-virheenkorjausohjelman tulee korjata koodi ei-muutettavassa muistissa.
-WA | Anna SingleStep Debuggerin kirjoittaa ei-päällekirjoitettavaan muistiin.
-OF | Asetus / arvo -parit sisältävä asetustiedosto.
-TP | Ajoituksen säätö (proportionaalinen arvo). Oletus on 5000. Pienennä tätä arvoa saadaksesi mukautettua suoritettujen jaksojen määrän nopeammin reaaliaikaan.
-TD | Ajoituksen säätö (Eroarvo). Oletus on 100. Pienennä tätä arvoa saadaksesi nopeamman vasteen hetkellisiin ajoituksen muutoksiin. VAROITUS: TP- ja TD-arvojen muuttaminen voi johtaa nopeusongelmiin.
-PJ
-PP 		Määritä käytettävä protokolla:
PJ J2534-tiedonsiirtoa varten.
PP ISO22900-2 / PDU-API:a varten (oletus)
-S | Tämän valinnan avulla voidaan käyttää äänentoistoa PC:n kaiuttimesta.
-L | Tech2Win-sovelluksen kieli. Aktiivista Windows-kieltä käytetään oletuksena, jos tämä kohta puuttuu. Käytettävissä olevat kielet näkyvät seuraavan linkin avulla: Kielet. Tech2:n emulointi-ikkuna näyttää itse, mikä kieli on PCMCIA-kortilla (eli mikä ladattiin PCMCIA-kortille).
-UD | Käyttäjätietokansion ohitus. Se on Win7-käytöjärjestelmässä normaalisti polulla C:\Users\Public\General Motors\Tech2Win
-AD | Sovellustietokansion ohitus. Se on Win7-käytöjärjestelmässä normaalisti polulla C:\ProgramData\General Motors\Tech2Win
-US | Käytä käyttäjäkohtaista semaforia usemman kuin yhden Tech2Win-yksikön tunnistamiseen. Tämä asetus mahdollistaa kullekin käyttäjälle Tech2Winin käytön yhtä aikaa samassa koneessa, oletettavasti palvelimessa. Tätä asetusta käytettäessä sinun tulisi myös määritellä asetukset -UD ja -AD.
-SS | Asetus, jolla määritellään Tec2Winin täydellinen koko, mukaan lukien näppäimistö (jos esillä). Ensimmäinen parametri pitää olla kaksoislainausmerkkien (') sisällä oleva merkkijono, ja sitä käytetään koon nimenä Asetukset / Resoluutio -valikossa. Toinen parametri tarkoittaa vakaakuvapisteiden kokonaismäärää Tec2Win-näytössä, näppäimistö mukaan lukien. Kolmas parametri tarkoittaa pystykuvapisteiden kokonaismäärää Tech2Win-näytössä. Neljäs valinnainen parametri on näppäimistön leveys kuvapisteinä.
-SH Asetus näyttötoimintojen ohjauksesta. Seuraavaa desimaalilukua käytetään määrittämään, mitkä näyttötoimintopiirteet pitää passivoida.
  • Bitti 0: Min./maks. ei ole mahdollista.
  • Bitti 1: Ei uutta sijaintia näytöllä.
  • Bitti 2: Ei koon muutosta. Tässä tapauksessa Asetukset / Resoluutio -valikko on harmaa.
  • Bitti 3: Tietonäyttö ja DTC-ruudut voivat olla tarkalleen samankokoisia kuin Tech2Win (ilman näppäimistöä)


Lokitiedot

Jokainen Tech2Win-konfiguroinnin käynnistys luo uuden, HTML-muotoisen lokitiedoston C:\Users\Public\General Motors\Tech2Win\Logs-alikansioon. Kiintolevyn täyttymisen estämiseksi yli viikon vanhat lokitiedostot poistetaan.

Lokitiedostot nimetään automaattisesti luontihetken päivämäärän (vuosi, kuukausi, päivä) ja kellonajan (tunti, minuutti, sekunti) mukaan:
vvvv-kk-pp_ttmmss.html

Lokitiedoston merkinnät ovat aina englanninkieliset ja Unicode-muodossa, jossa on alussa Byte-Order_Mark (BOM). Kukin lokitiedoston rivi kuuluu johonkin seuraavista lokitasoista:

Lokitaso | Merkitys
Info | Vain tietoja. Ei vaikutusta ohjelman suoritukseen.
Varoitus | Poikkeava tilanne ilmentynyt. Käyttäjä ei ehkä havaitse mitään häiriöitä.
ERROR | Ilmeni virhe, jonka käyttäjä havaitsee.
CRITICAL | Ilmeni kriittinen virhe, jonka vuoksi ohjelma toimii epätavallisesti.
FATAL | Vakava virhe aiheuttaa Tech2Winin toiminnan välittömän loppumisen.

Kaikki Varoitus-tason yläpuoliset tasot ovat värillisiä, jotta ne löytyvät helposti.

Lisäksi tulostus- ja video-tiedostot ovat Logs-alahakemistossa myös, jos Tulosta näyttö tai Automaattiset kuvakaappaukset valikkovaihtoehtoa käytettiin.
vvvv-kk-pp_ttmmss_print_nnnnn.bmp
vvvv-kk-pp_ttmmss_video_nnnnn.png
Automaattiset kuvakaappaukset -kuvat linkitetään HTML-tiedoston avulla - voit tarkastella kuvien järjestystä HTML-lokitiedoston avulla.

Käyttäjä näkee tilariviltä, mikäli tiedossa on varoitusmerkintä ( yellow lightning bolt) tai vakavampi lokimerkintä ( red lightning bolt).


Virhesanomat ja lopetuskoodit

Virhesanomat voivat näkyvä valintaikkunoissa. Näiden valintaikkunoiden lisäksi Tech2Win voi edelleen ajaa Tech2-ohjelmaa rinnan. Lopetuskoodit merkitsevät vakavia virheitä, joiden vuoksi Tech2Win-ohjelman ajo päättyy epänormaalisti. Lopetuskoodeja voidaan käyttää erätiedostoissa sen selvittämiseksi, miksi ohjelman ajo keskeytyi.

Virhesanomat

Seuraavat virheilmoitukset voivat tulla näkyviin. Tässä on tilanteen lyhyt selitys ja ongelman ratkaisuehdotus.

Emulator too slow Emulator failed to start

Lopetuskoodit

Lopetuskoodi | Arvo | Merkitys
OPCODE_ERROR | -7 | Tech2-mikroprosessorin (68332) virheellinen käsky havaittu. PCMCIA-kuva on voinut vaurioitua.
ATA_PROBLEM | -6 | Virhe ATA-emuloinnissa. Mikäli tällainen ongelma ilmenee sen jälkeen kun olet saanut ohjeen käyttää ATA-korttia, ota yhteys helpdeskiin.
DEMO_TIME_IS_UP | -5 | Ei pitäisi ilmetä Tech2Winin virallisessa versiossa.
DLL_NOT_LOADED | -3 | Yhtä tarvittavista DLL:istä ei voitu ladata. Vaikuttaa siltä, että Tech2Win-kopiosi on puutteellinen. Asenna ohjelma uudelleen ja/tai valitse jokin toinen kieli.
EXIT_INIT_FAILED | -2 | Alustus epäonnistui. Katso tarkka syy lokitiedostosta. Jos lokitiedostoa ei ole, tarkista kaikkien hakemistojen luku-/kirjoitusoikeutesi.
normaali | 0 | Tech2Win päättyi normaalisti.


ATA-kortti

Tech2:n ATA-korttia käytetään yleensä virheenetsintään ohjelmistokehityksessä. Kaikki tarpeelliset ATA-tiedot on tallennettu alikansioon C:\Users\Public\General Motors\Tech2Win\ataCapture. Tällä hakemistolla ei yleensä ole merkitystä ja se voidaan huoletta poistaa, ellei muuta ole nimenomaan ilmoitettu.

Koska ataCapture-hakemisto on kiinteä, sen sisältö on sama kaikissa konfiguraatiossa.


Tiedostot

Tech2Win käyttää seuraavia tiedostoja ja hakemistoja:

Kansio | Sijainti ennen Vistaa | Sijainti Vistassa ja sen jälkeen
Asennus | Asennuksen aikana tehdyn valinnan mukaisesti
Käyttäjätiedot | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Sovellustiedot | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Tiedosto | Käyttö
[Käyttäjätiedot]\atacapture | Sisältää tiedostot, jotka ovat ATA-kortilla. Nämä tiedostot eivät ole tarpeen, jos ei toisin ilmoiteta.
[Asennus]\bin | Sisältää varsinaisen ohjelmatiedoston ja tarvittavat DLL:t ja kuvat, joita ohjelman ajossa tarvitaan.
[Asennus]\bin\emulator.exe | Pääohjelmatiedosto, josta Tech2-koodi ajetaan.
[Asennus]\bin\emulator_xx_XX.dll | Kielikohtaiset resurssi-DLL:t
[Asennus]\bin\T2Configurator.exe | Tech2Winin konfiguraatio-osa.
[Asennus]\bin\Pictures | Sisältää Tech2Winin tarvitsema kuvakkeet.
[Käyttäjätiedot]\config | Sisältää kaikki kokoonpanotiedostot.
[Käyttäjätiedot]\data | Sisältää tiedostoja, joita muokataan Tech2Winin ajon aikana. Nämä tiedostot ovat tarpeelliset Tech2Winin oikean toiminnan kannalta. Tavallisesti näitä tiedostoja ei tule käsitellä, ellei siihen ole nimenomaan neuvottu.
[Sovellustiedot]\data | Sisältää tiedostoja, joita muokataan Tech2Winin ajon aikana. Nämä tiedostot ovat tarpeelliset Tech2Winin oikean toiminnan kannalta. Tavallisesti näitä tiedostoja ei tule käsitellä, ellei siihen ole nimenomaan neuvottu.
[Sovellustiedot]\data\emulator.sec | Suojaustiedosto . Älä muokkaa tätä tiedostoa.
[Sovellustiedot]\data\emulator.card | Korttitiedosto. Sisältää Tech2Win-ohjelman tunnistamat PCMCIA-kortit. Älä muokkaa tätä tiedostoa.
[Käyttäjätiedot]\data\emulator.disp | Tiedostossa on tiedot Tech2Win-näytön sijainnista ja koosta. Jos poistat tiedoston, se luodaan uudelleen ja Tech2Win-näyttö käynnistyy vasempaan yläkulmaan koossa 640x480.
[Sovellustiedot]\data\emulator.lic | Lisenssitiedosto. Sisältää tiedot käyttöoikeuslupiesi voimassaoloajoista. Älä muokkaa tätä tiedostoa.
[Sovellustiedot]\data\emulator.rtc | Reaaliaikakellotiedosto. Tiedostoa käytetään niiden tietojen tallentamiseen, jotka ovat Tech2:n RTC:ssä.
[Sovellustiedot]\data\emulator.dta | 'Don't tell me again' -tietotiedosto.. Tämä tiedosto tallentaa PCMCIA-ohjelmistoversiot, joiden ei pitäisi (enää) näyttää varoituksia koskien kyvyttömyyttä suorittaa itsetestiä, joka edellyttää silmukkasovitinta.
[Sovellustiedot]\data\candi.bin | CANdi-sovellustiedosto. Sisältää Tech2:een liittyvän CANdi-sovelluksen.
[Sovellustiedot]\data\eprom.bin | Tech2:n sisäinen EPROM-tiedosto. Sisältää Tech2:n sisäisen flash-muistin tiedot.
[Asennus]\driver | Asennustiedostot virtuaalisen COM-portin ohjainta varten.
[Asennus]\help\emulator_xx_XX.chm | Kielikohtaiset ohjetiedostot.
[Käyttäjätiedot]\Logs | Sisältää lokitiedostot. Yli viikon vanhat tiedostot poistetaan automaattisesti.
[Käyttäjätiedot]\pcmcia | Sisältää PCMCIA-kuvatiedostot. Kuvaannollisesti ilmaistuna kukin tiedosto vastaa Tech2 PCMCIA -korttia. Nämä tiedostot voidaan tallentaa eri sijaintiin.


Kokoonpanon hallinta

Konfiguraatiotiedostot sijaitsevat aina alikansiossa C:\Users\Public\General Motors\Tech2Win\config, ja niiden tiedostotarkenne on *.conf. Tech2Winiä voi käyttää ainoastaan uusien konfiguraatiotiedostojen luontiin tai sellaisten konfiguraatiotiedostojen muokkaamiseen, jotka eivät ole vain luku -tilassa. Tee kaikki muu konfiguraatiotiedostojen hallinta Windowsin resurssienhallintahjelmalla tai vastaavalla tiedostonkäsittelyohjelmalla. Tämä on tarpeen seuraavissa toimissa:

  • konfiguraatiotiedostojen poisto
  • konfiguraatiotiedostojen uudelleennimeäminen
  • konfiguraatiotiedoston vain luku -attribuutin muuttaminen

Suosittelemme vahvasti säilyttämään aina konfiguraatiotiedoston default.conf. Tämän tiedoston vain luku -attribuutti on yleensä asetettu, jotta tiedostoa ei vahingossa poistettaisi. Jos kuitenkin haluat muokata tiedostoa tiettyyn tarpeeseen, poista ensin vain luku -attribuutti.

PCMCIA-kuvat sijaitsevat alikansiossa C:\Users\Public\General Motors\Tech2Win\pcmcia. Kukin näistä tiedostoista vastaa PCMCIA-korttia, jotka tunnet Tech2-työskentelystä. Tech2Winin avulla voit käyttää haluamasi määrää kuvia. Kopioit vain kuvatiedoston toisen nimiseen tiedostoon.

Jos haluat käynnistää tietyn kokoonpanon suoraan työpöydältä, luo pikakuvake, joka suorittaa toiminnon "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Ohjelma tulee käynnistää seuraavasta työtiedostosta: 'C:\Program Files\General Motors\Tech2Win\bin'

Konfiguraatiotiedostojen lukumäärä ei määräydy käytettävien pcmcia-kuvien mukaan. Voit pitää useita konfiguraatiotiedostoja, jotka käyttävät samaa PCMCIA-kuvaa. Tämä simuloi hyvin tilannetta korjaamossa, kun useiden asentajien käytössä on sama Tech2 (ja sama PCMCIA-kortti).

Voit halutessasi käyttää jokaista konfiguraatiota kohti omaa PCMCIA-kuvaa. Tällöin yksittäiset konfiguraatiot ovat toisistaan enemmän riippumattomat. Jokaisen PCMCIA-kuvan päivittäminen voi kuitenkin osoittautua työlääksi.

Tehdessäsi uuden konfiguraation kopioimalla jo käytössä olevan, konfiguraatio näyttää varoituksen, jos PCMCIA-kuva ei ole vaihtunut. Siinä tapauksessa sinulla saattaa olla kaksi konfiguraatiota, jotka käyttävät samaa PCMCIA-kuvaa. Jos tämä on OK, paina OK-painiketta. Jos haluat uuden konfiguraation käyttävän eri tai uutta PCMCIA-kuvaa, paina Paluu-painiketta. Voit sen jälkeen valita uuden kuvan luomisen käyttämällä Kopioi muistikortti ... -toimintoa

Tässä kaksi esimerkkimenetelmää konfiguraatioiden ja PCMCIA-kuvien hallinnointiin.

Yksi konfiguraatio käyttäjää kohti

Sinulla on mahdollisuus tallentaa kokoonpano käyttäjäkohtaisesti. Kokoonpanon nimi voi olla esimerkiksi käyttäjän nimi. Tämän menettelyn etuina on, että käyttäjäkohtaiset asetukset kuten henkilökohtaiset ajoneuvon tiedonsiirtoliittymät (MDI:t), näyttö- ja kieliasetukset ovat mahdollisia. Haittapuolena on, että PCMCIA-tiedostot on kopioitava, jos useat käyttäjät käyttävät samaa ohjelmistoa. Käyttäjäkohtaisia kokoonpanoja varten voidaan kuitenkin käyttää PCMCIA-keskustiedostoa.

Yksi konfiguraatio Tech2-ohjelmaa kohti

Voit halutessasi tehdä uuden kokoonpanon jokaista lataamaasi ohjelmistoa varten. Näin myös vanhemmat ohjelmistoversiot ovat tarvittaessa heti käytettävissä Usein ohjelmiston nimi ja versionumero valitaan tällöin kokoonpanon nimeksi.

  • Ensimmäiset vaiheet: Ajoneuvon tiedonsiirtoliittymä
  • Ensimmäiset vaiheet: Polku
  • Lisäaiheet: Konfiguraatiotiedosto
  • Asennus: Asennusvaiheet


Usein kysytyt kysymykset (FAQ)

  • Kuinka voin määrittää, mitä COM-porttia minun tulee käyttää Tech2Winiä varten?
  • Tiedonsiirto Tech2Winin ja TIS2Webin välillä
  • Voimassa oleva käyttöoikeus
  • Mihin lisenssinumero viittaa?
  • Mikä on ero Tech2Winin käyttöluvan ja Security Access -sovelluksen välillä?
  • TIS2Web näyttää määrittelemättömän virheen silloin kun se suorittaa alkuperäisen ohjelmiston turvallisuustarkistuksen
  • Tech2Win ei suorita muiden alueiden Tech2-ohjelmistoja.
  • Kuinka voin käyttää useampia kuin yhtä MDI-liittymää?
  • Lokitiedostossa on virhe 'CPU32: Too many 0000/FFFF Commands encountered'
  • Yhtään Tech2-sivua ei näkyvillä
  • SPS ei toimi
  • Jotkin itsetestit eivät toimi
  • Nopeusmittarin näyttämä vaihtelee
  • Äkillinen pysäytys
  • Ohjelmistoversio 15.001 näkyy ruotsinkielisenä
  • MDI-tiedonsiirtokatkos
  • Tech2Win ei löydä minun MDI:täni
  • Haluan käynnistää välittömästi Tech2Win-ohjelmiston ilman konfigurointitoimintoa
  • Missä ovat tulostustoiminnot?
  • 'Käyttämätön' PCMCIA-kansio on esillä tietokoneessa
  • Saan viestin 'luvaton tiedostopolku'.

Kuinka voin määrittää, mitä COM-porttia minun tulee käyttää Tech2Winiä varten?

Voit käyttää Windows 'Laitehallintaa', katso 'Portit (COM & LPT)'. Mutta joissakin tietokoneissa on asennettuina sisäiset modeemit tai Bluetooth-laitteet, jotka eivät näy tässä luokassa.
Toinen tapa on käyttää konfiguraattorin mukana toimitettua pientä komentoa. Voit suorittaa sen käynnistysvalikosta (Tech2Win-kansio) napsauttamalla 'show com ports'.
Molemmat menetelmät näyttävät COM-portit, jotka on asennettu tietokoneeseesi ja joita sinun EI tule käyttää.

Tiedonsiirto Tech2Winin ja TIS2Webin välillä

On tärkeätä, että Tech2Win ajetaan ennen kuin käynnistät tiedonsiirron TIS2Webin kanssa käyttöoikeutta tai ohjelmistolatausta varten. TIS2Web voi tunnistaa vain virtuaalisen COM-portin, kun Tech2Win käynnistetään.

Voimassa oleva käyttöoikeus

Normaalisti jo ohjelmiston lataaminen TIS2Webistä antaa sinulle voimassa olevan käyttöoikeuden. Jos sinulla ei vielä ole käyttöoikeutta, sinun tulee suorittaa 'Pääsyoikeus (Suojaus)' TIS2Webin (ei TIS2000:n) kautta saadaksesi voimassa olevan käyttöoikeuden. Älä suorita mitään muuta TIS2Web-tietoliikennetoimintaa Tech2Winin kanssa, kuten 'Ohjelmiston lataus (Ohj.lataus)' ennen kuin olet saanut lisenssin 'Pääsyoikeus (Suojaus)' -toiminnon kautta.

Mihin lisenssinumero viittaa?

Tilarivin oikeassa reunassa oleva lisenssinumero osoittaa lisenssin kokonaisten käyttöoikeuspäivien lukumäärän. Välittömästi latauksen jälkeen tai turvakäytön yhteydessä näyttämä on 30 päivää. Kun Tech2Win käynnistetään uudellen, näyttämäksi tulee kuitenkin 29, koska käyttöoikeuden kesto on todennäköisesti noin 29 päivää, 23 tuntia ja 55 minuuttia. Jos käyttöoikeuspäivien lukumäärä putoaa alle 24 tunnin, näytössä näkyvä käyttöoikeuden kesto on <1. Kun käyttöoikeus on vanhentunut, näytössä näkyy 0.

Mikä on ero Tech2Winin käyttöluvan ja Security Access -sovelluksen välillä?

Tech2Winin käyttölupa sallii sinun käyttää Tech2Winiä. Saadaksesi tällaisen käyttöluvan sinun täytyy joko suorittaa ohjelmiston lataus tai Security Access säännöllisin väliajoin (yleisin tapa: 30 päivän välein). Mahdollisuus suorittaa tällainen lataus TIS2Webin kautta osoittaa Tech2Winille, että kyseessä on hyväksytty käyttäjä. Kuten tunnettua Tech2:sta, Security Access ilmaisee Tech2Win:lle, että tietyt turvallisuuteen liittyvät toimenpiteet, kuten turvatyynyn käytöstäpoisto, ovat sallittuja. Sekä Tech2Winin käyttöoikeus että Security Access voidaan suorittaa TIS2Web Security Access -sovelluksen kautta. Tech2Win näyttää käyttöluvan jäljellä olevan kestoajan tilarivissä oikealla. Valitettavasti Tech2Win ei voi näyttää Security Access -kestoa, koska Tech2Win vain suorittaa Tech2-ohjelmiston, mutta se ei ymmärrä itse Tech2-ohjelmistoa.

TIS2Web näyttää määrittelemättömän virheen silloin kun se suorittaa alkuperäisen ohjelmiston turvallisuustarkistuksen

Menettely on sama kuin Tech2:ssa. Ikänsä vuoksi alkuperäinen ohjelmisto ei pysty saamaan lisenssiä TIS2Webistä. Tämä ei kuitenkaan ole todellinen ongelma, koska esittelyohjelmisto ei luo yhteyttä ajoneuvoon, joka tarvitsee lisenssin. Koska lisenssit ovat TS2Web-latauskohtaisia, sinun pitää joka tapauksessa saada lisenssi jokaiselle lataukselle sen jälkeen kun olet ladannut Tech2-ohjelmiston. Alkuperäisen ohjelmiston 'lisenssi' ei anna sinulle oikeuksia suorittaa yhteyden luomista ajoneuvosta Pohjois-Amerikan toimintoihin- tai Opel/Vauxhall-ohjelmistoon.

Tech2Win ei suorita muiden alueiden Tech2-ohjelmistoja.

Tech2Win-versiosi on todennäköisesti rajoitettu yhteen tai useaan TIS2Web-lataukseen(alueeseen). Paina Ohje / Tietoja tarkastellaksesi, mitkä rajoitukset ovat voimassa Tech2Win-versiossasi. Tech2Win-ohjelmiston varhaiset versioit sallivat ainoastaan Opel/Vauxhallin ohjelmiston käytön. Muut GM-alueet tulevat vähitellen. Joka tapauksessa Tech2Win pystyy tällä hetkellä suorittamaan General Motorsin valmistamia Tech2-ohjelmia.

Kuinka voin käyttää useampia kuin yhtä MDI-liittymää?

Jos haluat siirtää tietyt MDI:t tietyille käyttäjille, ehdotamme että annat jokaisen käyttäjän tehdä oman kokoonpanonsa. Nämä kokoonpanot on parasta nimetä niiden käyttäjien mukaan. Sinun tulee syöttää jokaiseen kokoonpanoon käyttäjäkohtainen MDI:n sarjanumero välilehdellä 'Ajoneuvon tiedonsiirtoliittymä'. Heti kun käyttäjä käynnistää kokoonpanonsa, Tech2Win yrittää ottaa yhteyden tähän kyseiseen MDI:hin. Vain jos MDI:tä ei löydy, tulee näyttöön valintaruutu, joka näyttää kaikki MDI:t, jotka Tech2Win pystyi löytämään.

Jos sinulla on useita MDI-liittymiä yleiseen käyttöön, ehdotamme että käytät kokoonpanoja, joissa Vehicle Communication Interfacen sarjanumeron kohta välilehdellä 'Ajoneuvon tiedonsiirtoliittymä' on jätetty tyhjäksi. Tällöin käyttäjä voi aina nähdä käytettävissä olevien MDI-liitäntöjen valintaruudun.

Lokitiedostossa on virhe 'CPU32: Too many 0000/FFFF Commands encountered'

Tiedosto 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' tai nykyinen PCMCIA-tiedosto on virheellinen. Suorita Tech2Winin uudelleenasennus ja lataa uusi Tech2-ohjelmisto.

Yhtään Tech2-sivua ei näkyvillä

Jos yhtään Tech2-ikkunaa ei ole näkyvillä, se on todennäköisesti alueella, joka ei näy näytölläsi tällä hetkellä. Kohtaat tällaisia tilanteita käyttäessäsi useampia kuin yhtä näyttöä tai muutettuasi näytön tarkkuutta. Paina Shift-näppäintä näppäimistössä käynnistäessäsi kokoonpanosi. Tällöin ikkunan tarkkuusarvoksi palautuu 640x480 ja Tech2-ikkuna näkyy näytön vasemmassa yläkulmassa. Voit myös poistaa tiedoston C:\Users\Public\General Motors\Tech2Win\emulator.disp saman tuloksen saamiseksi.

Olemme nähneet tilanteita, joissa Tech2-ikkunaa ei yksinkertaisesti voitu piirtää uudelleen näytölle kaikkien muiden sovelluksien ikkunoiden sulkemisen jälkeen. Kaikissa tähän asti esiintyneissä tapauksissa Alt-Tab-näppäimien käyttö Windows-sovelluksien vaihtamiseksi mahdollisti Tech2-ikkunan näyttämisen. PC-näytön alareunassa olevan tehtäväpalkin Tech2Win-painikkeen painaminen ei aina toimi oikein. Tämä ongelma on parhaillaan tutkimuksen alla ja me toivomme sen olevan korjattuna myöhäisemmässä Tech2Win-versiossa.

SPS ei toimi

Kyllä, tiedämme. Eikä meillä ole suunnitelmia muuttaa sitä. Sinun ei tule käyttää Tech2Winiä Tech2:n korvaajana SPS:n käytössä. Käytä MDI-kansiota SPS-ohjelmointiin TIS:n avulla.

Jotkin itsetestit eivät toimi

Tech2-itsetestit on tarkoitettu Tech2-laitteiston yksittäisten osien testaamiseen. Jotkut näistä testeistä edellyttävät silmukkasovittimen käyttöä. Nämä testit eivät toimi Tech2Winissä, koska silmukkasovittimen toiminnallisuutta ei ole toteutettu (eikä suunnitteilla ole näin tehdäkään). Vältä vain suorittamasta tällaisia tarkoituksettomia testejä Tech2Winissä. Jos suoritat ne, saattaa olla että tulokset ovat virheellisiä tai että Tech2Win jumiutuu aivan kuten Tech2 tekisi ilman silmukkasovitinta. Palauta Tech2Win tässä tapauksessa käyttämällä Ctrl-R.

Nopeusmittarin näyttämä vaihtelee

Tilarivin vasemmassa alareunassa oleva nopeusmittari osoittaa, kuinka monta 'Tech2-komentoa' voidaan suorittaa ennen kuin Tech2Win-ohjelman on jälleen siirryttävä lepotilaan. Tällä menetelmällä voidaan varmistaa, että Tech2Win toimii reaaliaikaisesti: nopeammat PC-tietokoneet ovat useammin levossa kuin hitaammat PC-tietokoneet. Jos nopeusmittarin näyttämä vaihtelee, jokin muu sovellus saattaa käyttää PC-tietokoneen laskentatehoa, tai PC-tietokoneen kellotaajuus vaihtelee. Suuret vaihtelut voivat heikentää ajoneuvon ja TIS2Web-järjestelmän tiedonsiirtoa. Varmista, ettei muita sovelluksia ole käynnissä.

Useimmat kannettavat tietokoneet alentavat suorittimen kellotaajuutta automaattisesti akkuvirran säästämiseksi. Tämä voi myös aiheuttaa Tech2Win-ohjelman havaitsemat nopeudenvaihtelut. Jos näin tapahtuu, käytä kannettavaa tietokonetta akkuvirran sijaan ulkoisella virtalähteellä. Voit myös yrittää muuttaa virta-asetuksia, jolloin käyttöjärjestelmä ei alenna kellotaajuutta.

Äkillinen pysäytys

Jos et löydä lokitiedoston sisältä mitään syytä, miksi ohjelma lopetettiin, niin Tech2Winin sisäinen suojausmekanismi on voinut aktivoitua. Älä yritä käsitellä luvattomasti seuraavia tiedostoja: emulator.sec, emulator.lic, emulator.card. Jos Tech2Win tunnistaa tietoturva-aukon, on hyvin todennäköistä että sinun on suoritettava asennus uudelleen.

Ohjelmistoversio 15.001 näkyy ruotsinkielisenä

Tech2Win-ohjelman mukana toimitettava alkuohjelma on esittelyohjelma, joka on jokaisella uudella PCMCIA-kortilla. TIS2Web osoittaa kieleksi ruotsin, koska TIS2Web näyttää vain viimeisen kielen tämän esittelyohjelmiston neljästä tuetusta kielestä (englanti, ranska, saksa, ruotsi). Käytä päivitystilassa 'Mukauta'-tilaa 'Vakio'-tilan sijaan, kun päivität esittelyohjelmiston uusimpaan diagnostiikkaohjelmaversioon.

MDI-tiedonsiirtokatkos

MDI-tiedonsiirtokatkos voi johtua useasta eri syystä.

  • Huono kaapeliyhteys (sekä Ethernet että USB).
  • Heikko langaton yhteys.
  • PC on siirtynyt valmiustilaan.

Tech2Win ei löydä minun MDI:täni

Tarkista seuraavat kohdat:

    1. Onko MDI aktiivinen?
    2. Toimiiko MDI Manager?
    3. Käyttääkö MDI:tä jokin toinen sovellusohjelma, kuten SPS?
Voit käynnistää MDI Managerin sen työpöydän kuvakkeesta tai kohdasta Käynnistä/Kaikki Ohjelmat/General Motors/GM MDI-ohjelmisto.: Soita tukipalveluun, jos kohta 2 ei toimi.

Haluan käynnistää välittömästi Tech2Win-ohjelmiston ilman konfigurointitoimintoa

Suorita "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Käytä seuraavaa työkansiota: 'C:\Program Files\General Motors\Tech2Win\bin' Voit aina käyttää konfigurointitoimintoa minkä tahansa muutoksen tekemiseen kokoonpanoon.

Missä ovat tulostustoiminnot?

Tech2Win ei tarjoa suoratulostustoimintoa. Se luo sen sijaan väliaikaisia tiedostoja ja käyttää ohjelmia, jotka liittyvät tiedostotarkenteisiin. Näitä ohjelmia voidaan käyttää tulostustarkoituksiin, ja ne antavat sinulle mahdollisuuden säätää tulostuksesi muotoa.

Print Report | Print Report

Nykyinen Tech2Win-näytön tulostamiseksi käytä valikkoyksikköä Tiedosto / Tulosta näyttö tai näppäimistön sitä painiketta, jossa on tulostimien kuva. Jos sinun pitää tulostaa useita Tech2Win-näyttöjä, voit käyttää tällöin valikkoyksikköä Asetukset / Automaattiset kuvakaappaukset, koska se luo PNG-tiedostot jokaiselle Tech2Win-näytölle. Nämä PNG-tiedostot sisältyvät lokitiedostoon.

Voit myös tulostaa tietonäytön sisällön (aktivoidaan käyttämällä valikkoyksikköä Näkymät / Tech2Win tietojen näyttö. Käytä Tulosta/HTML-käynnistys -painiketta käynnistääksesi ja sen jälkeen pysäyttääksesi tietojen siirron. Kun olet lopettanut tiedonsiirron, HTML-tyyppinen suoritettava tiedosto (tavallisesti Internet Explorer) käynnistyy, mikä mahdollistaa useiden toimintojen käytön tietojen tulostamiseen.

Data Display | Data Display

'Käyttämätön' PCMCIA-kansio on esillä tietokoneessa

Tech2Winin aikaisemmissa versioissa on PCMCIA-tiedostojen kaksoistallennus omaan kansioon. Tämän kansion nimi oli usein C:\PCMCIA. Nyt tätä kansiota ei enää käytetä, koska TIS2WEBistä tehtävä nopea tallennus tekee tällaisten lataamisten toisen tallennuksen tarpeettomaksi. Voit huoletta poistaa tämän kansion.

Saan viestin 'luvaton tiedostopolku'.

Tiedostonimessä tuntuu olevan luvattomia merkkejä, kuten prosenttimerkki (%). Jos tämä ongelma tulee esiin heti asennuksen jälkeen, on ehkä parempi purkaan ensin asennus ja suorittaa sen jälkeen asennus uudelleen. Useimmat ongelmat ratkevat tällä tavalla.

Normaalin asennuksen aikana ympäristömuuttujan 'Tech2WinUserData' asetuksena on 'PUBLIC' (Vistassa tai sen jälkeisissä Windowsin versioissa) tai 'ALLUSERSPROFILE\Documents' (Vistaa edeltävissä Windowsin versioisissa). Joissakin harvoissa tapauksissa ympäristömuuttuja ei ole tullut asetetuksi asennusprosessin aikana, mutta kylläkin toisella yrittämällä. Voit myös asettaa ympäristömuuttujan manuaalisesti. Kysy neuvoa verkonvalvojaltasi, ellet osaa asettaa ympäristömuuttujaa.


Rekisterimerkinnät

Asennusohjelma luo seuraavat rekisterimerkinnät. Älä muuta näitä merkintöjä manuaalisesti. Huomioi Windowsin varoitukset rekisterimerkintöjen käsittelystä.

rekisteriavain | nimi | tyyppi | merkitys
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Sisäinen versionumero
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Kieli | REG_SZ | asennettu kieli
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | PCMCIA:n kopiokansioiden polku
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Juuri | REG_SZ | asennuspolku
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PoistaAsennus | REG_DWORD | Pura asetus
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Kokoonpanotiedoston versio
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Virtuaalisen COM-portin ohjainversio
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Ohjelman nimi Lisää/poista ohjelmia -luettelossa
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Polku ohjelman asennuksen poistamiseksi


Uudelleenasennus

Uudelleenasennus poistaa koko Tech2Win-asennuskansion seuraavin poikkeuksin.

  1. (config)-alikansiota, jossa on kokoonpanot, ei poisteta.
  2. (pcmcia)-alikansiota, jossa normaalisti on PCMCIA-kuvia, ei poisteta.
  3. (ATA)-alikansiota, jossa saattaa olla virheenkorjaustietoja, ei poisteta.
Konfiguraatiotiedostot eivät ehkä ole yhteensopivat: ei ole takuuta siitä, että vanhemman Tech2Win-version konfiguraatiotiedostot voidaan lukea uudemmalla Tech2Win-versiolla. PCMCIA-kuvat eivät periaatteessa voi muuttua epäyhteensopiviksi.

Uudelleenasennus ei vaikuta toissijaiseen PCMCIA-hakemistoon.

Jotkin ympäristöt tarjoavat ehkä Tech2Win-ohjelman uuden version automaattisen asennuksen. Koska edellisen asennuksen tiedot on tallennettu järjestelmärekisteriin, nämä asetukset ovat oletuksena uudelleenasennuksen aikana.

Voit suorittaa Tech2Winin uudelleenasennuksen käyttämällä skriptiä enable reinstallation. Tämä skripti asennetaan yhdessä Tech2Winin kanssa. Periaatteessa tämä skripti vain asettaa rekisteristä HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win löytyvälle näppäimelle CurrentVersion arvon '1.000'