Manual del usuario de Tech2Win

Bienvenido al manual de usuario de Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Reservados todos los derechos.

  • Introducción:
  • Licencia:
  • Instalación:Una descripción del procedimiento de instalación de Tech2Win.
    • Pasos de la instalación
    • Interfaz de comunicación de vehículos
  • Primeros pasos
    • Selección de una configuración
      • Teclado
      • Manejo de las ventanas
    • Nuevas configuraciones
    • Modificar las configuraciones
      • Idioma
      • Ruta de acceso
      • Pantalla
      • Guardar una configuración
    • Obtenga una licencia de Tech2Win válida.
  • Uso de Tech2Win: Detalles para el uso diario.
    • Menú
    • Descargar una imagen PCMCIA
    • Seguridad
    • Ver informes
    • Manejo de las imágenes PCMCIA
    • Barra de estado
  • Temas avanzados: Información no requerida para uso normal de Tech2Win. A menudo sólo será de interés para las personas con tareas de administradores.
    • Reinstalación
    • Desinstalación
    • Formato del archivo de configuración
    • Archivo de registro
    • Mensajes de error y códigos de error
    • Tarjeta ATA
    • Entradas del registro de Windows
    • Archivos
    • Administración de las configuraciones
  • P+F


Introducción

Tech2Win es una aplicación de Windows que puede emular la funcionalidad del Tech2. Esencialmente, se ejecuta el software del Tech2 sobre un PC. Para ejecutar este programa, su PC debe cumplir los siguientes requisitos técnicos:

  • Se debe instalar y conectar una interfaz de comunicación con el vehículo al PC. La lista de interfaces aceptables puede variar de una región a otra. En la mayoría de los casos se puede utilizar la Interfaz de Diagnóstico Múltiple (MDI por sus siglas en inglés) de GM.
  • La aplicación Tech2Win requiere 150 MB de espacio libre en el disco duro durante su instalación. Hacen falta otros 32 MB por cada tarjeta flash PCMCIA que desee administrar.
  • Antes de ejecutar la aplicación Tech2Win, necesita un mínimo de 100 MB de RAM física libres. Es obligatorio que su PC tenga suficiente memoria para mantener la aplicación en la RAM durante todo el tiempo de ejecución.
  • Su PC debe tener una potencia equivalente a un procesador Pentium a 1,2 GHz (de núcleo simple). Le sugerimos encarecidamente que no utilice otras aplicaciones en paralelo.
  • No es necesario ningún teclado. Tech2Win se puede utilizar también mediante una pantalla táctil. Para administrar las configuraciones, le sugerimos encarecidamente que utilice un teclado ya que tendrá que introducir nombres de archivo.
  • La pantalla de gráficos en color debe tener una resolución mínima de 800 x 600 con una profundidad de color mínima de 256. Sin un teclado numérico, se puede aceptar una resolución de 640 x 480.

Cuando utilice Tech2Win (un portátil en vez de Tech2), asegúrese de que el portátil tenga suficiente energía. Normalmente, su portátil no recibirá alimentación de la batería del vehículo como ocurre con el Tech2.

  • Instalación
  • Primeros pasos


Licencia

General Motors - Acuerdo de licencia para Tech2Win

Lea atentamente los siguientes términos y condiciones antes de utilizar este programa. Si usted no acepta o comprende los términos y condiciones, póngase en contacto con su representante local del Servicio Postventa. General Motors otorga el derecho a utilizar este software mediante licencia sólo si el usuario acepta los términos y condiciones durante la instalación de Tech2Win.
General Motors concede el derecho a utilizar el software Tech2Win y la información incluida junto con TIS2Web o GlobalTIS o TIS2000 exclusivamente a los usuarios de la red de reparadores autorizados de General Motors, según se determina en el contrato de reparador autorizado aplicable localmente con las Compañías Nacionales de Ventas de General Motors.
La licencia de Tech2Win será válida mientras el contrato de reparador autorizado esté en vigor y se disponga de una licencia de TIS2Web, GlobalTIS y TIS2000. La licencia de Tech2Win se anulará, junto con la licencia de TIS2Web y GlobalTIS, con carácter inmediato cuando se extinga el contrato de reparador autorizado.

Los reparadores independientes, conforme al Artículo 4 párrafo 2 del Reglamento 1400/2002 de la Unión Europea, pueden adquirir una licencia de Tech2Win como parte de las suscripciones que se ofrecen en el Portal GM Europe Info Tech de General Motors Europe.

La licencia de Tech2Win no incluye la interfaz de comunicación del vehículo ni el hardware informático.

El software de Tech2Win no se podrá distribuir, vender ni facilitar el acceso online a terceros fuera de las instalaciones del reparador autorizado (como se describe en el correspondiente anexo del contrato de reparador autorizado) sin el consentimiento por escrito de las Compañías Nacionales de Ventas de General Motors relevantes. Esto se aplica tanto a datos actuales como no actuales (por ejemplo, discos DVD caducados).

En caso de uso abusivo o no autorizado, las Compañías Nacionales de Ventas de General Motors tendrán derecho a cancelar inmediatamente el acceso y a notificar la extinción inmediata del contrato de reparador autorizado. En tal caso, queda excluido el derecho a reclamar el reembolso de saldos pendientes y/o cuotas básicas anuales.

La información facilitada sirve para la realización de trabajos de reparación y servicio, de manera profesional, en vehículos de General Motors no modificados. Se requerirá haber completado una formación técnica en automoción y formación continuada como condición previa para la realización de los citados trabajos. Siempre que en la información facilitada se indique el uso de herramientas especiales, dichas herramientas especiales son obligatorias para todas las reparaciones a realizar de manera profesional.

Tanto la información publicada en Tech2Win de General Motors (texto y fotografías, música, gráficos, animaciones, videos, etc.) como su disposición en Global TIS está protegida por los derechos de autor. Queda prohibida la reproducción, difusión, comunicación y/o transmisión o cualquier otro uso sin el consentimiento previo por escrito de General Motors.

  • Instalación: Pasos de la instalación
  • Primeros pasos


Installation

Instalación

La instalación de Tech2Win requiere derechos de administrador en el PC local. Sin derechos administrativos, la instalación no funcionará. En tal caso, póngase en contacto con el administrador de sistemas local.

Para usar con éxito el programa Tech2Win, debe completar los dos pasos siguientes:

  • Instalación del propio Tech2Win.
  • Instalación de una interfaz de comunicación de vehículos.
  • Instalación: Pasos de la instalación
  • Primeros pasos


Pasos de la instalación

La instalación por sí misma tarda sólo unos minutos y requiere las siguientes entradas del usuario:

  1. Acuerdo de licencia
  2. Directorio de instalación

Idioma

El Tech2Win se mostrará por defecto en el idioma de su sistema operativo. Generalmente, son compatibles los siguientes idiomas. Si su idioma no es soportado el instalador arrancará en inglés como idioma de instalación por defecto.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Inglés (británico o americano)*
  • el_GR (EL)Greek
  • es_ES (ES)español
  • fi_FI (FI)Finnish
  • fr_FR (FR)francés
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugués (Brasil)
  • pt_PT (PT)Portugués (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Chino (simplificado)
  • zh_TW (ZH)Chino (tradicional)

* El idioma de Tech2Win es inglés británico. Sin embargo, el software Tech2 y el instalador que usted utiliza pueden ser en inglés americano, dependiendo de la fuente del software.

Acuerdo de licencia

Tiene que aceptar el acuerdo de licencia.

Directorio de instalación

Puede elegir cualquier directorio como ubicación donde instalar el programa Tech2Win. El directorio de instalación predeterminado será <su directorio de programas>\General Motors\Tech2Win o, en caso de una reinstalación, la ubicación especificada previamente.

Por último confirme la instalación.

Driver del puerto COM virtual

El driver del puerto COM virtual sólo se instalará una vez en su ordenador y continuará ahí hasta que la versión del driver sea actualizada (ocurre en raras ocasiones) o el Tech2Win sea desinstalado de su ordenador.
Si se instala el driver verá una ventana de DOS por un momento. Se cerrará automáticamente y no requiere de ninguna acción. Los archivos del driver son guardados adicionalmente en la subcarpeta 'controlador' en el directorio de instalación de Tech2Win.
Es posible, pero no recomendable, instalar o desinstalar manualmente los drivers del puerto COM virtual. Utilice uno de los siguientes comandos de la interfaz CMD:

  • seleccione 'vbsetup7' para instalar el driver
  • seleccione 'vbsetup7 /u' para desinstalar el driver
  • Primeros pasos


Interfaz de comunicación de vehículos

Su dispositivo de comunicación con el vehículo debe instalarse por separado. Consulte la guía de instalación pertinente entregada junto con la interfaz de comunicación de vehículos.

  • Primeros pasos: Interfaz de comunicación de vehículos
  • Temas avanzados: Archivo de configuración
  • Instalación: Pasos de la instalación
  • P+F: ¿Cómo puedo utilizar más de una MDI?
  • P+F: Tech2Win no ha encontrado mi MDI


Primeros pasos

Estos primeros pasos le muestran cómo usar el programa Tech2Win. Se asume que usted ya está familiarizado con el propio Tech2. para estos primeros pasos no es necesario disponer de comunicación con el vehículo.

Para un inicio rápido, haga lo siguiente:

  1. Ejecute el software de Tech2Win utilizando el acceso directo de inicio rápido desde su Escritorio.
  2. Obtener una licencia válida descargando el nuevo software de Tech2 desde TIS2Web.

Para usar una configuración seleccionable:

  1. Inicie el configurador utilizando el acceso directo a Tech2Win desde su Escritorio. Después de una instalación, debería estar presente una configuración predeterminada (default).
  2. Para crear una nueva configuración, es preferible que copie la configuración predeterminada (default).
  3. Modifique una configuración existente para adaptarla a sus requisitos específicos.
  4. Obtenga una licencia válida.

No inicie el Tech2Win en un modo de compatibilidad. En ese caso, en el Archivo de registro aparecerá un mensaje de advertencia. El Tech2Win sólo utiliza las funciones de Windows que existen desde el lanzamiento del XP, y no funcionará con versiones de Windows anteriores.

  • Primeros pasos: Nuevas configuraciones
  • Primeros pasos: Modificar las configuraciones
  • Primeros pasos: Interfaz de comunicación de vehículos
  • Uso de Tech2Win: Menú
  • Uso de Tech2Win: Seguridad
  • Uso de Tech2Win: Barra de estado
  • Temas avanzados: Archivo de configuración


Selección de una configuración

La primera vez que inicie la aplicación Tech2Win aparece la siguiente pantalla. Tiene la opción de iniciar Tech2Win directamente con una configuración predeterminada. Esta configuración predeterminada funciona sin comunicación con el vehículo.

Start First Time

Aparecerá el cuadro de mensaje de información de la licencia, aunque puede omitirlo para iniciar la configuración predeterminada.

Cuando trabaje con una pantalla táctil, podría resultar útil iniciar el programa de teclado del PC para poder escribir letras mediante dicha aplicación, que simula un teclado.


Teclado

Las teclas del PC y los botones, si están presentes, se asignan según las conocidas teclas del Tech2. Tech2Win ofrece algunas teclas adicionales que no se encuentran en el Tech2 original. Es posible que el teclado numérico del PC no funcione en todas las condiciones. Si se produce algún problema, compruebe que no se haya cambiado la distribución del teclado estándar del PC. En concreto, es posible que la tecla Mayús esté dañada.

Teclado del PC | Botón | Funcionalidad
Tecla de función F1 | no disponible | Ayuda de Tech2Win
Teclas de función F5 a F8 | Utilice el área de visualización de Tech2Win ocupado por las teclas | Las cuatro teclas programables del Tech2
Teclas del cursor: arriba, abajo, a la izquierda, a la derecha |  | Teclas arriba, abajo, a la izquierda, a la derecha del Tech2; Sólo estas teclas tienen una repetición automática.
Teclas del 0 al 9 | F0 • • • F9 | Teclas F0 a F9 del Tech2
Tecla de retroceso | Exit | Tecla Exit del Tech2
Tecla Intro / retorno | Enter | Tecla Enter del Tech2
Y | Yes | Tecla Yes del Tech2
N | No | Tecla No del Tech2
Q | ? | Tecla ? del Tech2
S | Shift | Tecla SHIFT del Tech2. El indicador SHIFT en la barra de estado o el indicador encima del botón Shift indican el estado.
ctrl-P | PWR | Tecla PWR del Tech2; Obviamente, esta tecla sólo puede apagar la aplicación Tech2Win.
ctrl-R | no disponible | Reinicia el Tech2Win. Similar a un ciclo de apagado / encendido en un Tech2. No obstante, no se restablecerá una interfaz de comunicación de vehículo. No se volverán a cargar archivos como la imagen PCMCIA.
Inicio | Home | Una tecla para ir al inicio. Sólo es compatible con algunas aplicaciones.
disponible únicamente mediante la opción de menú Archivo. | Print Screen | Imprime una captura de la pantalla del Tech2 creando un archivo temporal BMP y abriendo la aplicación asociada con los archivos BMP. Utilice dicha aplicación para rotar o cambiar el tamaño de la imagen antes de imprimirla.
disponible únicamente mediante la opción de menú Archivo. | Save Screen | Guarda una captura de la pantalla del Tech2 como un archivo BMP o PNG.
disponible únicamente mediante la opción de menú Archivo. | View Report | Muestra todos los informes de la tarjeta PCMCIA activa para que el usuario pueda verlos.


Manejo de las ventanas

Puede cambiar el tamaño de las ventanas usando los métodos estándar de Windows, es decir, arrastrando las líneas del borde de la ventana principal. Asimismo, el elemento de menú Opciones/Resolución da soporte a varias medidas preestablecidas. Si se cambia la medida de la ventana principal mediante un elemento del menú, la ventana del teclado permanecerá anclada automáticamente.

La apariencia de las ventanas se modifica cambiando la configuración en la pestaña Pantalla.


Nuevas configuraciones

Haga clic en el botón Crear nueva para crear una nueva configuración. Aparecerá un cuadro de diálogo pidiéndole que seleccione un archivo de configuración existente como fuente. Normalmente se seleccionará la configuración predeterminada (default). Después de introducir el nombre del nuevo archivo de configuración, pulse el botón Copiar.

Si trabaja con una pantalla táctil, puede que prefiera activar una simulación del teclado mediante el botón Teclado PC.

El botón Cancelar le permite cancelar el proceso de creación.

La nueva configuración utilizará el mismo archivo PCMCIA que la configuración original ya existente. Si desea cambiar esto, tendrá que modificar la configuración para utilizar un archivo PCMCIA diferente. En la mayoría de los casos, simplemente tendrá que copiar el archivo PCMCIA existente en un archivo nuevo y utilizar dicho archivo nuevo. Es posible que prefiera que su nueva configuración utilice el mismo archivo PCMCIA que su configuración original. En tal caso, aparecerá una pantalla de advertencia cuando pulse el botón Guardar.

  • Modificar las configuraciones


Modificar las configuraciones

Las configuraciones mostradas en color azul tienen el atributo de sólo lectura y no pueden modificarse. Estas configuraciones sólo pueden verse. Por supuesto, puede usar el método de modificación simplemente para ver sus contenidos, pero no podrá usar la función Guardar.

Para modificar una configuración, hay que seleccionar el ajuste individual mediante las cuatro pestañas Idioma, Interfaz de comunicación de vehículos, Ruta de acceso, Pantalla. Puede seleccionar el tabulador deseado o simplemente pulsar el botón Siguiente para activar el siguiente tabulador. Después de realizar las modificaciones, pulse el botón Guardar para guardar su configuración.

Siempre que sea necesaria una entrada mediante el teclado, puede también iniciar una aplicación del PC que simula un teclado de PC. Esto es especialmente útil en portátiles con pantalla táctil cuando no hay un teclado disponible.


Idioma

La pestaña Idioma le permite seleccionar el idioma en que se ejecutará Tech2Win. Esta selección no influye en el idioma del software de Tech2 en la imagen PCMCIA. Cuando descargue el software de Tech2 del TIS, todavía tendrá que seleccionar el idioma correcto.

En algunas regiones no estarán disponibles todos los idiomas. En tal caso, se mostrará el idioma inglés. Compruebe si hay disponible un idioma similar (PT portugués de Portugal en vez de PB portugués de Brasil).


Ruta de acceso

La pestaña Ruta de acceso le permite establecer las rutas de ambas imágenes PCMCIA, así como la ruta al software del teclado local. Además, se proporciona el botón Copiar tarjeta de memoria para copiar imágenes PCMCIA. Si acaba de crear una nueva configuración, tal vez desee usar este botón para evitar que varias configuraciones utilicen la misma imagen PCMCIA.

Memory Card Options

Copiar tarjeta de memoria ...

Este botón le permite copiar una imagen PCMCIA en otro archivo. Esta función es similar a la compra de una nueva tarjeta PCMCIA para el Tech2. La función de copia sólo sirve para archivos en el directorio C:\Users\Public\General Motors\Tech2Win\pcmcia.

Ranura 0: Ubicación de la imagen de la tarjeta de memoria

Aquí puede especificar el archivo que contiene su imagen PCMCIA para la ranura 0. Normalmente, dicho archivo debería estar en C:\Users\Public\General Motors\Tech2Win\pcmcia; sin embargo, es posible que se encuentre en otra ubicación.

Ranura 1: Tarjeta de memoria o ATA

Como el Tech2, Tech2Win también admite dos tarjetas PCMCIA (imágenes). Sin embargo, normalmente la segunda imagen PCMCIA dentro de una configuración no es muy útil. Probablemente se usaría un segundo software en una segunda configuración.

Como en el Tech2, se utiliza una tarjeta ATA con fines de depuración. La tarjeta ATA sólo debe activarse si se lo pide el servicio de asistencia técnica. El personal del servicio le proporcionará más información.

Ubicación del software del teclado del PC

El valor predeterminado de este archivo se obtiene del registro de Windows y debería apuntar a una aplicación capaz de simular un teclado de PC con el ratón. Si dispone de una aplicación especial con esta función para el portátil que use, puede especificar aquí dicha aplicación.


Interfaz de comunicación de vehículos

  • Puerto COM para emulación Tech2-RS232
  • Número de serie de la MDI a usar
  • Protocolo

Puerto COM para emulación Tech2-RS232

Elija un puerto COM libre que se pueda utilizar para la emulación de Tech2. Para mayor comodidad, el configurador intenta saber qué puertos serie ya se están utilizando y los visualiza.

Si elige un puerto COM ya existente, Tech2Win se conectará a dicho puerto COM. Puede utilizar este puerto COM para descargar el software Tech2 de otro PC que ejecute una aplicación TIS que utilice un cable de módem nulo. Tenga en cuenta que es posible que el uso de un puerto COM real no funcione de forma fiable a 115.200 baudios debido a las restricciones de Windows.

Si se selecciona un puerto COM que no existe, Tech2Win creará automáticamente un puerto virtual. Este puerto virtual se puede utilizar desde el TIS que se ejecute en el mismo PC para establecer comunicación con Tech2Win. Si se utiliza un puerto virtual no hay restricciones en la velocidad en baudios.

Si escoge 'búsqueda' como puerto COM Tech2Win creará un puerto COM virtual en el primer número de puerto libre en un rango de 9 a 1.

Número de serie de la MDI a usar

Introduzca el número de serie del MDI. El número se puede encontrar en la parte posterior del MDI. Utilice el número que figura después del guión.

Si no introduce un número de serie, Tech2Win mostrará automáticamente una lista de las MDI detectadas en la red para que el usuario pueda elegir una. El mismo cuadro de selección aparecerá cuando no se encuentre la MDI especificada.

Protocolo

'ISO22900-2 / PDU-API' está seleccionado y el J2534-2 está siempre atenuado. En el futuro, Tech2Win también podrá dar soporte al protocolo J2534.

  • Temas avanzados: Archivo de configuración
  • P+F: ¿Cómo puedo determinar qué puerto com puedo utilizar para Tech2Win?
  • P+F: Comunicación entre Tech2Win y TIS2Web
  • P+F: ¿Cómo puedo utilizar más de una MDI?
  • P+F: Tech2Win no ha encontrado mi MDI


Pantalla

La pestaña Pantalla se usa principalmente para cambiar los ajustes relacionados con la visualización de Tech2Win:

  • Teclado
  • Colores
  • Sonido
Display and Key Options

Teclado

Aquí puede seleccionar si se muestra el teclado virtual. El teclado aparece a la izquierda o a la derecha de la pantalla de Tech2Win. El color de fondo se puede seleccionar mediante un cuadro de diálogo estándar para colores.

Colores

Aquí puede seleccionar individualmente el color del fondo y del texto (primer plano) de la pantalla del Tech2. A continuación, indicamos las dos combinaciones en color más habituales:

Screen with background 0000FF, foreground FFFFFF | Fondo del teclado en blanco; Fondo azul; Texto en blanco
Screen with background 000000, foreground C0C0C0 | Fondo azul de teclado numérico; Fondo en negro; Texto en gris claro

Sonido

Aquí puede elegir desconectar el sonido. Cada vez que el programa Tech2 emita un pitido, se usará el altavoz del PC.


Guardar la configuración

La configuración activa se puede guardar pulsando el botón Guardar <configuración> en la esquina inferior izquierda. Este botón no aparecerá si está viendo una configuración de sólo lectura.


Licencia válida mediante TIS2Web

Normalmente, la descarga del software Tech2 a Tech2Win le proporcionará una licencia válida. Además, puede obtener una realizando un 'Acceso de seguridad (Seguridad)' a través de TIS2Web (no con TIS2000). Por consiguiente, la precondición es la selección del puerto COM virtual del interior del configurador bajo Interfaz de comunicación de vehículos.

Después de acceder correctamente a la seguridad, podrá ver un cerrojo abierto en el lado derecho de la barra de estado. Dentro del corchete se indica el número de días que será válida la licencia. Cuando vuelva a iniciar Tech2Win, el indicador de seguridad no se visualizará mientras no se ejecute ninguna comunicación de vehículo. Durante la primera comunicación con un vehículo, se comprobará la licencia y el indicador cambiará y será un cerrojo abierto o cerrado.

  • Uso de Tech2Win:Seguridad
  • P+F:¿Cómo puedo determinar qué puerto com puedo utilizar para Tech2Win?
  • P+F:Comunicación entre Tech2Win y TIS2Web
  • P+F:Licencia válida
  • P+F:¿Cuál es la diferencia entre una licencia de Tech2Win y el acceso de seguridad?


Uso de Tech2Win

Los siguientes temas son los más utilizados por los técnicos cuando trabajan con Tech2Win:

  • Menú: El diseño de pantalla y las distintas opciones de los menús.
  • Descarga de una imagen PCMCIA: La actualización del software de diagnóstico para el Tech2Win es muy similar al método usado para el Tech2.
  • Seguridad: Medidas de seguridad para evitar que Tech2Win establezca comunicación con un vehículo en entornos no autorizados.
  • Ver informes: El teclado del Tech2 ha sido mejorado ligeramente en Tech2Win. El botón 'Ver informes' es el ejemplo más prominente.
  • Manejo de las imágenes PCMCIA: Lo mismo que puede tener múltiples tarjetas PCMCIA para el Tech2, podría tener varias imágenes PCMCIA en uso para el Tech2Win.
  • Barra de estado: La barra de estado informa al usuario sobre las distintas partes de la barra de estado.
    • Temas avanzados
    • P+F


Menú

La aplicación Tech2Win tiene las siguientes entradas de menú:

  • Archivo
  • Opciones
  • Ventanas
  • Ayuda

Archivo

El menú Archivo proporciona las posibilidades siguientes:

  • Guardar la pantalla T2 (320x240) se utiliza para guardar la pantalla T2 real en un tamaño de 320x240 píxels y como archivo de imagen en blanco y negro, en el PC. La ubicación de almacenamiento y el formato de archivo (BMP, GIF, JPG, PNG) se pueden seleccionar libremente.
  • Imprimir pantalla crea una imagen BMP inversa en negro sobre blanco en la pantalla de Tech2 y llama al programa asociado a los archivos BMP. Puede utilizar este programa para imprimir la imagen.
  • Ver archivos de informes proporciona la posibilidad de visualizar (e imprimir) archivos de informe sin utilizar TIS2Web.
  • Salir cierra Tech2Win.

Opciones

La opción Opciones proporciona las siguientes selecciones:

  • Resolución se puede utilizar para elegir entre tres medidas de pantalla estándar.
  • ROM-Write from 0x00003ED76 se utiliza por motivos de depuración interna.
  • Capturas automáticas para almacenar una imagen de cada pantalla de Tech2 diferente en el directorio de registro.
  • Inhabilitar CANdi i reiniciar para imitar un Tech2 que no tenga un CANdi entre si mismo y el vehículo. Esta opción es necesaria para los raros casos en los que el CANdi interrumpe las líneas de comunicación de vehículos no estándares.

Ventanas

El menú Ventanas le ofrece la posibilidad de activar las selecciones Pantalla de datos de Tech2Win y Pantalla de códigos de avería de Tech2Win. Todas las demás opciones están deshabilitadas en la versión actual de Tech2Win.

Si el software Tech2 soporta la selección Pantalla de datos de Tech2Win, usted puede activar esta entrada de menú. Al entrar en la opción Pantalla de datos (Data Display), Tech2Win mostrará una ventana de visualización de datos adicional en paralelo a la Pantalla de datos de Tech2. Mientras que en la pantalla de Tech2 aparezca la Pantalla de Datos, no se podrá habilitar la entrada del menú. En ese caso, usted deberá salid de la Pantalla de Datos, activar la entrada del menú, y volver a la Pantalla de Datos.

A la selección Pantalla de códigos de avería de Tech2Win se aplican restricciones similares a las que se aplican a Pantalla de datos de Tech2Win. Si el software Tech2 soporta la selección Pantalla de códigos de avería de Tech2Win, usted puede activar esta entrada de menú. En paralelo a la Pantalla de DTC de Tech2, aparecerá una ventana adicional con la Pantalla de DTC. Mientras que en la pantalla de Tech2 aparezca la Pantalla de DTC, no se podrá habilitar la entrada del menú. En ese caso, usted deberá salir de la Pantalla de DTC, activar la entrada del menú, y volver a la Pantalla de DTC.

Ayuda

Están disponibles las selecciones siguientes:

  • Temas de Ayuda... llama a la ayuda de Tech2Win.
  • Parámetros de línea de comandos muestra los parámetros de la línea de comandos utilizada para Tech2Win.
  • Acerca de muestra el número de la versión actual y las limitaciones de descarga de TIS2Web aplicables a Tech2Win.


Descarga

Primero inicie Tech2Win y déjelo en la pantalla principal. Inicie TIS2Web o GlobalTIS y realice la descarga a través del puerto COM especificado en la pestaña Interfaz de comunicación de vehículos.

Es posible el uso de los puertos CPM integrados para descargar software de Tech2 desde un PC diferente que esté ejecutando el TIS. Asegúrese de usar un cable cruzado RS232. Dependiendo del hardware del PC donde se ejecuta Tech2Win, podría ser necesario reducir la tasa de transferencia de datos a 57.600 baudios, ya que Windows puede perder datos a una tasa de baudios más alta.

La última versión de Tech2Win también es compatible con un descarga rápida cuando TIS2Web y Tech2Win se están ejecutando en el mismo PC. Se sigue realizando una comunicación mínima entre TIS2Web y Tech2Win a través del puerto COM, pero la lenta transferencia de datos a Tech2Win se ha sustituidos por una transferencia de archivos interna. En este caso, el tiempo de descarga se ha reducido drásticamente a menos de un minuto.

  • Temas avanzados: Archivo de configuración
  • Primeros pasos: Interfaz de comunicación de vehículos
  • P+F: ¿Cómo puedo determinar qué puerto com puedo utilizar para Tech2Win?
  • P+F: Comunicación entre Tech2Win y TIS2Web


Seguridad

Los mecanismos de seguridad utilizados por Tech2Win se basan en un valor de reloj de PC correcto. Asegúrese que el valor del reloj del PC esté siempre establecido. Tech2Win tolerará los cambios de reloj menores como los que se producen en horario de verano.

Tech2Win no ejecutará ninguna comunicación de vehículo sin una licencia válida y activa. El indicador siguiente de la barra de estado muestra el estado de la licencia:

  • green smiley La licencia es válida.
  • Sin indicador: Todavía no se ha comprobado la licencia.
  • red smiley La licencia ha caducado.

Para obtener una licencia, realice una actualización del 'Acceso de seguridad (Seguridad)' usando la aplicación TIS2Web. En la mayoría de casos, también será suficiente una descarga de software mediante TIS2Web para obtener una nueva licencia. Dado que la licencia dejará de ser válida después de un determinado período de tiempo (en algunas regiones: cuatro semanas), debe efectuar dicha actualización a intervalos regulares.

Las licencias son específicas de las regiones/software. Puede tener licencias en su PC si utiliza Tech2Win con versiones de software de Tech2 diferentes.

El número de días que quedan antes de que caduque la licencia se muestra en la barra de estado.

  • (0) muestra que la licencia ha caducado o que no existe.
  • (<1) La licencia caducará en las próximas 24 horas.
  • (20) La licencia caducará en el plazo de 20 días.

No manipule el archivo de licencia. Las modificaciones fraudulentas de este archivo se detectan mediante medidas de seguridad interna y producen la pérdida de todas las licencias del PC. Adicionalmente, Tech2Win se comportará de forma inesperada. Esta situación sólo se puede superar ejecutando una nueva instalación.

  • Temas avanzados: Mensajes de error y códigos de salida
  • Temas avanzados: Archivo de registro
  • Uso de Tech2Win: Ventana de estado
  • P+F: Licencia válida
  • P+F: ¿Cuál es la diferencia entre una licencia de Tech2Win y el acceso de seguridad?
  • P+F: Detención repentina


Ver informes

View Report Este botón se puede usar para ver los contenidos de los archivos PRT presentes en la tarjeta PCMCIA. Se abrirá un cuadro de diálogo para mostrar una lista de archivos PRT. Si se ha asociado un programa a la extensión PRT, se ejecutará dicho programa asociado. En caso contrario, se abrirá el editor Bloc de notas para mostrar el archivo seleccionado.

En la mayoría de los casos, el archivo PRT es un archivo ASCII que utiliza las páginas de códigos del idioma respectivo. Para el chino, japonés, coreano y tailandés, el archivo está en formato Unicode con una marca de orden de bytes (BOM) inicial.

Cuando se visualizan informes, Tech2Win funciona con el subdirectorio C:\Users\Public\General Motors\Tech2Win\reports. Este subdirectorio sólo existirá se ha visto informes al menos una vez. El directorio se borra automáticamente y funciona como un directorio de uso temporal para los archivos PRT en la tarjeta PCMCIA activa. Continuará conteniendo dichos archivos aunque Tech2Win deje de ejecutarse. Si desea guardar alguno de estos archivos, deberá copiarlo a un directorio diferente ya que podría sobrescribirse en cuanto otro usuario decida ver informes.


Imágenes PCMCIA

Las imágenes PCMCIA normalmente están en el subdirectorio C:\Users\Public\General Motors\Tech2Win\pcmcia. El archivo debe tener un tamaño de 32 MB (33.554.432 bytes) o de 10 MB (10.485.760 bytes) exactamente y una extensión de archivo *.bin. Las imágenes se modifican (como ocurriría con una tarjeta PCMCIA normal), si se produce una descarga o si Tech2Win almacena algo en la tarjeta flash. Se puede impedir cualquier modificación usando el parámetro de protección contra escritura (comando -W0 o -W1) u omitiendo el valor 'p' en la opción '-W'.(Archivo de configuración). No se puede acceder a la opción de protección contra escritura a través del configurador. Tendrá que modificar manualmente el archivo de configuración si quiere usar las opciones '-W0', '-W1' o '-W'.


Barra de estado

La barra de estado se muestra debajo de la pantalla del Tech2. La barra de estado muestra los siguientes elementos:

  1. Un indicador de velocidad
  2. El estado de la comunicación con el vehículo
  3. El estado del puerto serie
  4. Tecla SHIFT
  5. Capturas automáticas
  6. La advertencia del registro
  7. Licencia

Status Bar

Indicador de velocidad

El indicador de velocidad muestra cuánto tiempo de CPU se consume emulando el software del Tech2. Un número bajo (indicador a la izquierda) es mejor que un número alto (indicador a la derecha). Cualquier indicador verde es aceptable. El indicador se puede volver amarillo durante un breve periodo de tiempo si se activan diferentes tareas de Windows a la vez. Dicha actividad debería evitarse.

El estado de la comunicación con el vehículo

El estado de comunicación del vehículo indica si la interfaz de comunicación del vehículo (MDI) está presente, así como la comunicación entre el vehículo y Tech2Win.

El estado del puerto serie

Cuando se establece comunicación con el Tech2Win a través de un puerto COM, este indicador muestra si la comunicación en el puerto COM está activa o no.

Tecla SHIFT

Este indicador muestra si la tecla SHIFT está activa. Puede alternar esta función mediante la tecla 'S' del teclado o la tecla SHIFT del teclado numérico.

Capturas automáticas

Se pueden activar capturas automáticas en el menú Opciones. Cada vez que la pantalla cambie, se guardará una archivo de captura nuevo en el directorio de registro. Esto se indica mediante un giro del asa de la manivela de la cámara roja de la barra de estado. Tan pronto como se desactiven las capturas automáticas, la cámara desaparecerá.

La advertencia del registro

El indicador del estado de registro puede tener tres estados diferentes.

  • gray log status indicator El archivo de registro no contiene avisos ni errores.
  • yellow log status indicator El archivo de registro contiene un mensaje de aviso.
  • red log status indicator El archivo de registro contiene un mensaje de error.

Licencia

El indicador de licencia puede estar en uno de los tres estados siguientes:

  • green smiley La licencia es valida y está activa.
  • Sin indicador: Todavía no se ha comprobado la licencia.
  • red smiley La licencia ha caducado o no existe.
Consulte el vínculo Seguridad para más detalles.

Información sobre herramientas de la barra de estado

En el caso de algunos iconos, se muestra información sobre herramientas para proporcionar información adicional:

Información sobre el número de serie VCI:
Tooltip VCI

Información sobre la versión de software de TECH2
Tooltip TECH2

Información sobre el puerto Com
Tooltip Comport

Información sobre el número de la captura siguiente (si 'Capturas automáticas' está activo)
Tooltip Camera

Información que muestra la última entrada del archivo de registro cuyo nivel sea 'warning' (aviso) o superior
Tooltip Logfile

Información sobre la duración exacta de la licencia
Tooltip License

La información se muestra si el cursor está durante más de 0,5 segundos sobre un icono sin moverlo. Esta información desaparece al cabo de 5 segundos o cuando se mueve el cursor.

  • Temas avanzados: Mensajes de error y códigos de error
  • Temas avanzados: Archivo de registro


Temas avanzados

Los temas que se tratan aquí son menos importantes para el usuario normal de Tech2Win. La siguiente información resultará útil para las personas implicadas en la instalación, administración y configuración de Tech2Win.

  • Reinstalación
  • Desinstalación
  • Modificación directa de los archivos de configuración
  • Archivo de registro
  • Mensajes de error y códigos de salida
  • Tarjeta ATA
  • Entradas del registro de Windows
  • Descripción de los archivos
  • Ejemplos de administración de las configuraciones


Desinstalación

Se borran el directorio de instalación completo, el directorio que contiene los datos del usuario (C:\Users\Public\General Motors\Tech2Win) y el directorio que contiene los datos de la aplicación (C:\ProgramData\General Motors\Tech2Win).

  • Temas avanzados: Reinstalación
  • Instalación


Archivo de configuración

Los archivos de configuración siempre se guardan en el subdirectorio C:\Users\Public\General Motors\Tech2Win\config y tienen la extensión de archivo *.conf. Podría decidir modificar manualmente el archivo de configuración porque no todas las opciones del archivo son accesibles mediante Tech2Win. El archivo de configuración es un archivo Unicode con una marca de orden de bytes (BOM) inicial. Le sugerimos encarecidamente que utilice un editor compatible con Unicode, como el Bloc de notas de Windows, cuando realice cualquier cambio manual.

El archivo de configuración está orientado a líneas. Las líneas vacías son ignoradas. Una línea empieza siempre con una opción y en la mayoría de casos va seguida por un valor. A modo de ejemplo, eche un vistazo al archivo default.conf. Consulte la siguiente tabla que relaciona todas las opciones disponibles.

Si desea iniciar una determinada configuración directamente desde el Escritorio, cree un acceso directo que ejecute 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. El programa debería iniciarse desde el siguiente directorio de trabajo: 'C:\Program Files\General Motors\Tech2Win\bin'

Opción | Valor / Significado
; Un comentario
@ Un número de versión decimal, con el formato 'major.minor'.
Los archivos de configuración con un número 'major' diferente al de Tech2Win no serán aceptados. Los archivos de configuración con un número 'minor' inferior al de Tech2Win serán aceptados.
-W0
-W1 		La tarjeta PCMCIA en la ranura 0/1 tiene un mecanismo de protección de escritura activado.
-B0
-B1 		El tamaño de bloques en Kbytes de la tarjeta PCMCIA en la ranura 0/1. Los valores aceptables son 128 (predeterminado) o 256.
-P0
-P1 		El archivo que contiene la imagen binaria de una tarjeta PCMCIA para la ranura 0/1. El tamaño del archivo debe ser de 10 MB o 32 MB exactamente. Las variables de entorno, tales como %ProgramData%, se expanden.
Si esta opción no está presente, se asume que la ranura está vacía.
-A0
-A1 		El archivo que contiene los valores de los atributos de la tarjeta PCMCIA en la ranura 0/1. Si no está presente, se utilizarán los atributos predeterminados según el tamaño de la tarjeta y de los bloques.
-W | Al salir de Tech2Win, todos los datos persistentes se escriben en sus archivos respectivos. Los valores p/f/r/c se pueden combinar para denotar PCMCIA/Flash-ROM/RTC/CANDI-App respectivamente.
-H | Función de gestión de la pila Los valores 0/r/w/t se pueden combinar puestas a cero, comprobaciones de lectura, comprobaciones de escritura y comprobaciones de tareas, respectivamente. El valor l se utiliza para forzar siempre una asignación de memoria de la pila a direcciones inferiores cuando se implementa un esquema de asignación alternativo. Normalmente, esta opción sólo se utiliza en un entorno de desarrollo.
-PC | Anteriormente, la ruta para la copia de la tarjeta PCMCIA. Esta opción se ignora actualmente.
-MS | Identificación de la interfaz de comunicación del vehículo (MDI) mediante el número de serie. Si no se establece, se mostrará una lista de todas las MDI disponibles.
-CT | El color del texto (primer plano) en valores de 3 bytes hexadecimales. El valor predeterminado es 000000 (blanco).
-CB | El color del fondo en valores de 3 bytes hexadecimales. El valor predeterminado es FFFFFF (negro).
-ATA | Utilice esta opción para habilitar una tarjeta de capturas ATA. Quítelo para inhabilitar la tarjeta de capturas ATA.
-C | El número del puerto COM (1..9) que se usará como el puerto de comunicaciones RS232C del Tech2. A menudo se utiliza COM9 para el puerto COM virtual instalado por Tech2Win. Si esta opción no está presente la búsqueda de un puerto COM libre se realiza hacia atrás desde COM9. Use la descripción de herramienta de la barra de estado entre el icono Tech2 y el icono TIS2Web para ver qué puerto COM está siendo utilizado.
-WR | Una dirección de PC (por lo general 253558) que tiene permiso de escritura en PCMCIA y en el área FLASH ROM. Esta función debe activarse adicionalmente a través del menú (o usando la opción -WA). Se necesita para depurar código en la memoria no modificable mediante el depurador de paso único.
-WA | Permita que depurador paso a paso (SingleStep Debugger) escriba en la memoria no modificable.
-OF | Archivo de opciones que contiene pares de opción / valor.
-TP | Ajuste del tiempo (Valor proporcional). Toma 5000 como valor predeterminado. Disminuya este valor para que el número de ciclos ejecutados se adapte más deprisa al tiempo real.
-TD | Ajuste del tiempo (Valor diferencial). Toma 100 como valor predeterminado. Disminuya este valor para reaccionar más deprisa a los cambios del tiempo instantáneo. AVISO: si manipula los valores TP y TD puede tener problemas de velocidad
-PJ
-PP 		Especifique el protocolo que debe utilizarse:
PJ para comunicación J2534
PP para ISO22900-2 / PDU-API (valor predeterminado)
-S | La presencia de esta opción permite la salida de sonido por el altavoz del PC.
-L | El idioma de la aplicación Tech2Win. El lenguaje activo Windows se utiliza por defecto si no se encuentra esta entrada. Para una lista de los idiomas que se pueden especificar, consulte el siguiente vínculo: Idiomas. La misma ventana de emulación Tech2 se mostrará independientemente del idioma que haya en la tarjeta PCMCIA (por ejemplo, se descargó en la tarjeta PCMCIA).
-UD | Invalidación del directorio de datos de usuarios. Bajo Win7, normalmente se encuentra en C:\Users\Public\General Motors\Tech2Win
-AD | Invalidación del directorio de datos de aplicación. Bajo Win7, normalmente se encuentra en C:\ProgramData\General Motors\Tech2Win
-US | Utilice un marcador específico de usuario para la detección de más de una instancia de Tech2Win. Esta opción permitirá a cada usuario ejecutar Tech2Win en paralelo en la misma máquina, presumiblemente un servidor. Al utilizar esta opción, también debe especificar las opciones -UD y -AD además.
-SS | Opción para especificar el tamaño global de la ventana de Tech2Win incluyendo el teclado numérico (si está presente). El primer parámetro debe ser una cadena entre comillas dobles (') y se utilizará como el nombre del tamaño en el menú Opciones / Resolución. El segundo parámetro es el número total de píxeles horizontales de la pantalla Tech2Win incluyendo el teclado numérico. El tercer parámetro es el número total de píxeles verticales de la pantalla Tech2Win. El cuarto parámetro opcional es el ancho del teclado numérico en píxeles.
-SH Opción para controlar la manipulación de la pantalla. El siguiente número decimal se utiliza para especificar qué posibilidades de manipulación de pantalla deben deshabilitarse.
  • Bit 0: Sin máx./mín. posible.
  • Bit 1: Sin reposicionamiento en la pantalla.
  • Bit 2: Sin redimensionado. En este caso, el menú Opciones / Resolución se muestra en color gris.
  • Bit 3: Las ventanas de la pantalla de datos y DTC deben tener exactamente el mismo tamaño que Tech2Win (sin teclado numérico)


Registros

En cada inicio de una configuración de Tech2Win se crea un nuevo archivo de registro en formato HTML en el subdirectorio C:\Users\Public\General Motors\Tech2Win\Logs. Para evitar la congestión del disco duro, se eliminan los archivos de registro de más de una semana.

Los archivos de registro se nombran automáticamente según la fecha (año, mes, día) y la hora (hora, minuto, segundo) de su creación:
aaaa-mm-dd_hhmmss.html

Las entradas del archivo de registro siempre están en inglés, pero en formato Unicode con una marca de orden de bytes (BOM) inicial. Cada línea del archivo de registro pertenece a uno de los siguientes niveles:

Nivel de registro | Significado
Info | Sólo para su información. No afecta a la ejecución del programa.
Advertencia | Se ha producido una situación inusual. Es posible que el usuario no observe efectos adversos.
ERROR | Ha ocurrido un error que será percibido por el usuario.
CRITICAL | Ha ocurrido un error crítico que causará un comportamiento anómalo del programa.
FATAL | Un error fatal hará que Tech2Win deje de funcionar inmediatamente.

Todos los niveles superiores a 'Warning' (Aviso) están coloreados, por lo que es fácil encontrarlos.

Asimismo, también habrá archivos de impresión y vídeo en el subdirectorio Logs si se ha utilizado la opción de menú Imprimir pantalla o Capturas automáticas.
aaaa-mm-dd_hhmmss_print_nnnnn.bmp
aaaa-mm-dd_hhmmss_video_nnnnn.png
Las imágenes de Capturas automáticas están enlazadas por el archivo HTML; por lo que deberá utilizar el registro HTML para ver la secuencia de estas imágenes.

En la barra de estado se informa al usuario si existe una entrada de advertencia ( yellow lightning bolt) o una entrada más grave en ( red lightning bolt) en el archivo de registro.


Mensajes de error y códigos de salida

Los mensajes de error pueden aparecer en cuadros de diálogo. No obstante, dichos cuadros de diálogo aún permiten a Tech2Win ejecutar el programa Tech2 en paralelo. Los códigos de salida son errores fatales que causan una terminación anómala de Tech2Win. Los códigos de salida se pueden utilizar en archivos por lotes para detectar por qué se ha interrumpido un programa.

Mensajes de error

Pueden aparecer los siguientes mensajes de error. Aquí se explica brevemente la situación y cómo se puede resolver el problema.

Emulator too slow Emulator failed to start

Códigos de salida

Código de salida | Valor | Significado
OPCODE_ERROR | -7 | Se ha detectado un comando no válido del microprocesador del Tech2 (68332). Tal vez se haya corrompido la imagen de la tarjeta PCMCIA de algún modo.
ATA_PROBLEM | -6 | Ha ocurrido un problema durante la emulación ATA. Si observa este problema después de recibir la orden de usar la tarjeta ATA, póngase en contacto con el servicio de asistencia.
DEMO_TIME_IS_UP | -5 | No debería aparecer en la versión oficial de Tech2Win.
DLL_NOT_LOADED | -3 | No se pudo cargar una de las DLL (bibliotecas de vínculos dinámicos) necesarias. Parece que tiene una copia incompleta de Tech2Win. Realice una nueva instalación o seleccione un idioma diferente.
EXIT_INIT_FAILED | -2 | Falló la inicialización. Mire el archivo de registro para descubrir la causa exacta. Si no existe archivo de registro, compruebe si tiene el debido permiso de lectura / escritura para todos los directorios.
normal | 0 | Tech2Win ha terminado normalmente.


Tarjeta ATA

Generalmente, la tarjeta ATA del Tech2 sólo se usa con fines de depuración durante el desarrollo del software. Todos los datos ATA necesarios se almacenan en el subdirectorio C:\Users\Public\General Motors\Tech2Win\ataCapture. Este directorio normalmente carece de importancia y se puede borrar salvo indicación expresa en contrario.

Como el directorio ataCapture es fijo, sus contenidos serán los mismos para todas las configuraciones.


Archivos

Tech2Win utiliza los siguientes archivos y directorios.

Directorio | Ubicación antes del sistema operativo Vista | Ubicación en Vista y sistemas posteriores
Instalación | Según lo especificado durante la instalación
Datos del usuario | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Datos de la aplicación | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Archivo | Uso
[Datos del usuario]\atacapture | Contiene archivos que están presentes en la tarjeta ATA. A menos que se indique lo contrario, estos archivos no son necesarios.
[Instalación]\bin | Contiene el archivo ejecutable y las DLL e imágenes necesarias para la ejecución.
[Instalación]\bin\emulator.exe | El archivo ejecutable principal que ejecuta el código del Tech2.
[Instalación]\bin\emulator_xx_XX.dll | DLL de recursos específica del idioma.
[Instalación]\bin\T2Configurator.exe | La parte de configuración de Tech2Win.
[Instalación]\bin\Pictures | Contiene los iconos que necesita Tech2Win.
[Datos del usuario]\config | Contiene todos los archivos de configuración.
[Datos del usuario]\data | Contiene archivos que son modificados durante la ejecución de Tech2Win. Estos archivos son necesarios para la correcta ejecución de Tech2Win. Normalmente, no debería tocar estos archivos salvo que se le pida expresamente.
[Datos de la aplicación]\data | Contiene archivos que son modificados durante la ejecución de Tech2Win. Estos archivos son necesarios para la correcta ejecución de Tech2Win. Normalmente, no debería tocar estos archivos salvo que se le pida expresamente.
[Datos de la aplicación]\data\emulator.sec | Archivo de seguridad . No modifique este archivo.
[Datos de la aplicación]\data\emulator.card | Archivo de tarjetas. Contiene todas las tarjetas PCMCIA conocidas para el programa Tech2Win. No modifique este archivo.
[Datos del usuario]\data\emulator.disp | Este archivo contiene la posición y el tamaño de la pantalla de Tech2Win. Si borra este archivo, se volverá a crear y la pantalla de Tech2Win aparecerá en la esquina superior izquierda con un tamaño de 640 x 480.
[Datos de la aplicación]\data\emulator.lic | Archivo de licencia. Contiene información de las duraciones de validez de las licencias. No modifique este archivo.
[Datos de la aplicación]\data\emulator.rtc | Archivo del reloj de tiempo real. Este archivo se usa para almacenar datos del reloj de tiempo real (RTC) del Tech2.
[Datos de la aplicación]\data\emulator.dta | Un archivo de información 'No mostrar de nuevo'.. Este archivo almacena las versiones de software PCMCIA que no deben mostrar (más) el aviso sobre la incapacidad de efectuar la autoprueba que necesita un adaptador de bucle invertido.
[Datos de la aplicación]\data\candi.bin | Archivo de la aplicación CANdi. Contiene la aplicación del dispositivo CANdi acoplado al Tech2.
[Datos de la aplicación]\data\eprom.bin | Archivo de la EPROM interna del Tech2. Guarda los contenidos de la memoria flash interna del Tech2.
[Instalación]\driver | Archivos de instalación del controlador del puerto COM virtual.
[Instalación]\help\emulator_xx_XX.chm | Archivos de ayuda específicos por idioma.
[Datos del usuario]\Logs | Contiene archivos de registro. Los archivos que tengan más de una semana se borrarán automáticamente.
[Datos del usuario]\pcmcia | Contiene los archivos de imágenes de la PCMCIA. Hablando en sentido figurado, cada archivo corresponde a una tarjeta PCMCIA del Tech2. Estos archivos se pueden guardar en diferentes ubicaciones si lo desea.


Administración de configuración

Los archivos de configuración siempre se guardan en el subdirectorio C:\Users\Public\General Motors\Tech2Win\config y tienen la extensión de archivo *.conf. Tech2Win solamente se puede usar para generar nuevos archivos de configuración o para modificar los archivos de configuración existentes que no sean de sólo lectura. Para todas las demás tareas de administración de los archivos de configuración, utilice el Explorador de Windows o un gestor de archivos similar. Esto será necesario para las siguientes acciones:

  • eliminar archivos de configuración
  • renombrar archivos de configuración
  • cambiar el atributo de sólo lectura de un archivo de configuración

Le sugerimos encarecidamente que conserve siempre un archivo de configuración default.conf. Este archivo debería tener normalmente el atributo de sólo lectura activado para evitar sobrescribirlo por error. Sin embargo, si usted cambia este archivo para adaptarlo a sus necesidades específicas, deberá desactivar el citado atributo de sólo lectura.

Las imágenes de PCMCIA están en el subdirectorio C:\Users\Public\General Motors\Tech2Win\pcmcia. Cada uno de estos archivos corresponde a una tarjeta PCMCIA con las que ya está familiarizado cuando trabaja con el Tech2. Con Tech2Win puede tener tantas imágenes como desee. Simplemente copie una imagen existente con un nuevo nombre de archivo.

Si desea iniciar una determinada configuración directamente desde el Escritorio, cree un acceso directo que ejecute "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". El programa debería iniciarse desde el siguiente directorio de trabajo: 'C:\Program Files\General Motors\Tech2Win\bin'

El número de archivos de configuración no depende del número de imágenes PCMCIA que utilice. Puede tener varios archivos de configuración usando la misma imagen PCMCIA. Esto simula una situación habitual en un taller de reparaciones, donde varios mecánicos comparten el mismo Tech2 (y la misma tarjeta PCMCIA).

También puede elegir que cada configuración utilice su propia imagen PCMCIA dedicada. Esto haría que las configuraciones individuales fuesen más independientes entre sí. Sin embargo, el esfuerzo de actualizar cada imagen PCMCIA podría no ser aceptable.

Si crea una nueva configuración copiando una ya existente, el configurador mostrará una advertencia si no hubiera cambiado la imagen PCMCIA. En dicho caso, tendría dos configuraciones usando la misma imagen PCMCIA. Si lo desea así, sólo tiene que pulsar Aceptar. Si quiere que la nueva configuración utilice una imagen PCMCIA nueva o diferente, pulse Cancelar. A continuación, podrá optar por crear una imagen nueva con Copiar tarjeta de memoria ...

A modo de ejemplo, he aquí dos métodos para administrar sus configuraciones e imágenes PCMCIA.

Una configuración por usuario

Tiene la posibilidad de guardar una configuración por usuario. El nombre de la configuración sería, por ejemplo, el nombre de los usuarios. Las ventajas de este concepto radican en que es posible tener una configuración específica de usuario como, por ejemplo, interfaces de comunicación de vehículos (MDI), valores de pantalla y de idioma. El inconveniente, por el contrario, radica en que tendrá que copiar archivos PCMCIA si varios usuarios utilizan el mismo software. Por supuesto, las configuraciones específicas de los usuarios pueden utilizar un archivo PCMCIA central.

Una configuración por cada software de Tech2

Puede, por ejemplo, optar por tener una nueva configuración por cada software que descargue. Por consiguiente, incluso las versiones de software más antiguas estás disponibles inmediatamente, si es preciso. En dicho caso, a menudo se elige el nombre del software y el número de versión como nombre de configuración.

  • Primeros pasos: Interfaz de comunicación de vehículos
  • Primeros pasos: Ruta de acceso
  • Temas avanzados: Archivo de configuración
  • Instalación: Pasos de la instalación


Preguntas más frecuentes (P+F)

  • ¿Cómo puedo determinar qué puerto com puedo utilizar para Tech2Win?
  • Comunicación entre Tech2Win y TIS2Web
  • Licencia válida
  • ¿Qué indica el número de licencia?
  • ¿Cuál es la diferencia entre una licencia de Tech2Win y el acceso de seguridad?
  • TIS2Web muestra un error no específico cuando se realiza el acceso de seguridad al software inicial
  • Tech2Win no ejecuta el software Tech2 de otra área
  • ¿Cómo puedo utilizar más de una MDI?
  • El archivo de registro contiene el error 'CPU32: Too many 0000/FFFF Commands encountered'
  • No hay ninguna ventana Tech2 visible
  • El SPS no funciona
  • Algunas autopruebas no funcionan
  • El indicador de velocidad fluctúa
  • Detención repentina
  • El software 15.001 se visualiza en sueco
  • Pérdida de comunicación con la MDI
  • Tech2Win no ha encontrado mi MDI
  • Quiero iniciar inmediatamente Tech2Win sin preocuparme por el configurador
  • ¿Dónde están las funciones de impresión?
  • Una carpeta PCMCIA 'sin usar' se encuentra en mi ordenador
  • Estoy recibiendo un mensaje de 'ruta de acceso de archivo ilegal'

¿Cómo puedo determinar qué puerto com puedo utilizar para Tech2Win?

Puede utilizar el 'Administrador de dispositivos' de Windows, busque 'Puertos (COM & LPT)'. Aunque algunos PC tienen módems internos o dispositivos bluetooth instalados que no se muestran dentro de esta categoría.
Otra forma de utilizar un pequeño comando que se entrega junto con el configurador. Puede ejecutarlo mediante el menú de inicio (carpeta Tech2Win) haciendo clic en 'show com ports'.
Ambos métodos muestran los puertos com que están instalados en el PC y que NO deben utilizarse.

Comunicación entre Tech2Win y TIS2Web

Es importante que Tech2Win esté ejecutándose antes de iniciar la comunicación con TIS2Web para un acceso de seguridad o una descarga de software. TIS2Web sólo puede reconocer el puerto COM virtual cuando se ha iniciado Tech2Win.

Licencia válida

Normalmente, una descarga de software de TIS2Web le proporcionará una licencia válida. Si aún no tiene una licencia, debe efectuar un 'Acceso de seguridad (Seguridad)' a través de TIS2Web (no con TIS2000) para obtener una licencia válida. No realice otro tipo de comunicación de TIS2Web con Tech2Win, como una 'Descarga de software (D/SW)', antes de obtener una licencia a través de un 'Acceso de seguridad (Seguridad)'.

¿Qué indica el número de licencia?

El número de licencia ubicado a la derecha de la barra de estado muestra el número de días de licencia completos. Justo después de efectuar una descarga o realizar un acceso de seguridad, se muestra un período de 30 días. No obstante, después de un nuevo inicio de Tech2Win, aparece un 29, ya que la duración de la licencia es, probablemente, algo parecido a 29 días, 23 horas y 55 minutos. Si el número de días de licencia cae por debajo de las 24 horas, se visualiza una duración de licencia de <1. Si la licencia ha caducado, se visualiza un 0.

¿Cuál es la diferencia entre una licencia de Tech2Win y el acceso de seguridad?

La licencia de Tech2Win permite utilizar Tech2Win. Para utilizar dicha licencia tiene dos opciones: descargar el software o ejecutar un acceso de seguridad a intervalos regulares (habitualmente cada 30 minutos). La capacidad de ejecución de dicha descarga mediante TIS2Web informa a Tech2Win que hay un usuario válido presente. El Acceso de seguridad, ya conocido del Tech2, informa a Tech2Win de que determinadas actividades relacionadas con la seguridad, tales como la desactivación de un airbag, están permitidas. Tanto la licencia de Tech2Win como el acceso de seguridad se pueden ejecutar mediante la aplicación de acceso de seguridad TIS2Web. Tech2Win muestra en la barra de estado de la derecha el tiempo de duración restante de la licencia. Desgraciadamente, Tech2Win no puede mostrar la duración de un acceso de seguridad, ya que simplemente ejecuta el software Tech2, pero no tiene una comprensión del software Tech2 en si.

TIS2Web muestra un error no específico cuando se realiza el acceso de seguridad al software inicial

El comportamiento es el mismo que en un Tech2. Debido a su edad, el software inicial no puede obtener una licencia de TIS2Web. Sin embargo, esto no es un problema realmente porque ese software de demostración no se comunica con un vehículo para el que es necesaria la licencia. Como las licencias son específicas según la descarga de TIS2Web, en cualquier caso necesitaría obtener una licencia para cada descarga individual después de descargar el software del Tech2. Una 'licencia' para el software inicial no le daría derecho a realizar comunicaciones con vehículos mediante el software de North American Operations o de Opel/Vauxhall.

Tech2Win no ejecuta el software Tech2 de otra área

Su versión de Tech2Win probablemente esté limitada a una o varias descargas (regiones) de TIS2Web. Pulse Ayuda / Acerca de para ver qué limitaciones son aplicables a su versión de Tech2Win. Las versiones anteriores de Tech2Win sólo permitían la ejecución del software de Opel/Vauxhall. Otras regiones de GM estarán disponibles pronto. De todas formas, actualmente Tech2Win es capaz de ejecutar el software Tech2 de General Motors.

¿Cómo puedo utilizar más de una MDI?

Si desea asignar una MDI concreta a usuarios específicos, proponemos que deje que cada usuario tenga su propia configuración. Evidentemente, a dichas configuraciones se asignará un nombre que esté en concordancia con el usuario respectivo. En cada una de las configuraciones, debe introducir el número de serie de la MDI específica del usuario en la pestaña 'Interfaz de comunicación de vehículos'. Tan pronto como el usuario inicie la configuración, Tech2Win intentará ponerse en contacto con dicha MDI. Sólo si la MDI no está presente, el sistema presentará un cuadro de selección que muestre todas las MDI que Tech2Win haya encontrado.

Si dispone de varias MDI para uso general, le proponemos que utilice configuraciones en las que el número de serie de la interfaz de comunicación de vehículos de la ficha 'Interfaz de comunicación de vehículos' se haya dejado en blanco. De esta manera, el usuario siempre verá el cuadro de selección de todas las MDI disponibles.

El archivo de registro contiene el error 'CPU32: Too many 0000/FFFF Commands encountered'

El archivo 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' o el archivo PCMCIA actual están corruptos. Ejecute una reinstalación de Tech2Win y descargue un nuevo software Tech2.

No hay ninguna ventana Tech2 visible

Si no se ve ninguna ventana de Tech2, se encuentra probablemente en una área que no está actualmente en la pantalla. Encontrará tales efectos cuando utilice más de una pantalla o después de modificar la resolución de la pantalla. Pulse la tecla Shift del teclado durante el inicio de la configuración. En dicho caso, la resolución de la ventana se restablecerá en 640x480 y la ventana de Tech2 se visualizará en la esquina superior izquierda de la pantalla. También puede borrar el archivo C:\Users\Public\General Motors\Tech2Win\emulator.disp para lograr el mismo efecto.

Hemos detectado casos en los que la ventana de Tech2 no se vuelve a dibujar en la pantalla después de cerrar las ventanas de las aplicaciones restantes. En todos los casos, hemos podido visualizar de nuevo la pantalla de Tech2 utilizando la tecla Alt-Tab para desplazarse entre aplicaciones de Windows. En ocasiones, pulsar el botón de Tech2Win ubicado en la barra de tareas de la parte inferior de la pantalla del PC no funciona. En estos momentos, estamos estudiando el problema y esperamos disponer de una solución en una versión posterior de Tech2Win.

El SPS no funciona

Sí, lo sabemos No tenemos previsto cambiar esto. No utilice Tech2Win como sustituto de Tech2 para ejecutar SPS. Utilice la MDI directamente con la programación SPS a través de TIS.

Algunas autopruebas no funcionan

Las autopruebas de Tech2 tienen como objetivo probar las partes individuales del hardware de Tech2. Algunas de estas pruebas precisan el uso de un adaptador de bucle invertido. Estas pruebas no funcionarán en Tech2Win porque la funcionalidad del adaptador de bucle invertido no está implementada (y no hay planes para ello). Simplemente, absténgase de ejecutar este tipo de pruebas sin sentido en Tech2Win. Si las ejecuta, podría obtener resultados erróneos o Tech2Win podría no responder, al igual que pasaría con Tech2 sin un adaptador de bucle invertido. Utilice Ctrl-R para restablecer Tech2Win en dicho caso.

El indicador de velocidad fluctúa

El indicador de velocidad de la parte inferior izquierda de la barra de estado indica cuántos 'comandos de Tech2' se pueden ejecutar antes de que Tech2Win pase de nuevo a estado de 'suspensión'. Este método se usa para garantizar que el tiempo de Tech2Win corresponde a tiempo real: los PC más rápidos entran más veces en suspensión que los PC más lentos. Si el indicador de velocidad fluctúa, es posible que otra aplicación esté utilizando energía del ordenador o que se estén produciendo variaciones en el reloj del PC. Una velocidad de fluctuación elevada tiene un impacto negativo sobre la comunicación del vehículo y la comunicación del TIS2Web. Compruebe que no haya otra aplicación ejecutándose.

La mayoría de los portátiles pueden reducir automáticamente el reloj de la CPU para ampliar el tiempo de duración de la batería. Esto, a su vez, puede producir la fluctuación de velocidad detectada por Tech2Win. En dicho caso, no utilice el portátil con la batería, sino que recurra a una fuente de energía exterior. También puede intentar cambiar la configuración de la alimentación para que el sistema operativo no reduzca la velocidad del reloj.

Detención repentina

Si dentro del archivo de registro no encuentra ningún motivo que le explique por qué el programa ha terminado, es posible que se hayan activado los mecanismos de seguridad interna de Tech2Win. No modifique ninguno de los archivos siguientes: emulator.sec, emulator.lic y emulator.card. Si Tech2Win identifica una infracción de seguridad, probablemente deberá volver a efectuar una reinstalación.

El software 15.001 se visualiza en sueco

El software inicial que se entrega con Tech2Win es un software de demostración presente en toda tarjeta PCMCIA nueva. TIS2Web indica que está en sueco porque TIS2Web sólo se visualiza en el último idioma de la lista de cuatro idiomas admitidos por este software de demostración (inglés, francés, alemán, sueco). Utilice el modo de actualización 'Personalizar' en vez de 'Normal' para sobrescribir este software de demostración con el diagnóstico más nuevo.

Pérdida de comunicación con la MDI

La pérdida de comunicación con la MDI puede producirse por varios motivos.

  • Una conexión de cable errónea (tanto Ethernet como USB).
  • Una conexión inalámbrica poco fiable.
  • El PC se pone en modo de espera.

Tech2Win no ha encontrado mi MDI

Compruebe los puntos siguientes:

    1. ¿Está activa la MDI?
    2. ¿Funciona el gestor de MDI?
    3. ¿Se utiliza la MDI con otra aplicación, como SPS?
Puede iniciar el MDI Manager usando el icono correspondiente del Escritorio o desde 'Inicio/Todos los programas/General Motors/GM MDI Software'.: Si el punto 2 no funciona, póngase en contacto con el servicio de atención.

Quiero iniciar inmediatamente Tech2Win sin preocuparme por el configurador

Ejecute "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Utilice el siguiente directorio de trabajo: 'C:\Program Files\General Motors\Tech2Win\bin' No obstante, puede utilizar el configurador para realizar cambios en la configuración.

¿Dónde están las funciones de impresión?

Tech2Win no ofrece funciones de impresión directamente. En vez de eso, genera archivos temporales y abre los programas asociados con las extensiones de archivo correspondientes. Estos programas se pueden usar para imprimir, permitiéndole ajustar el aspecto de la impresión.

Print Report | Print Report

Para imprimir la pantalla actual de Tech2Win, utilice la opción del menú Archivo / Imprimir pantalla o el botón correspondiente del teclado que muestra una impresora. Si necesita imprimir varias pantallas de Tech2Win, se puede usar la opción Opciones / Capturas automáticas, que crea archivos PNG para cada pantalla de Tech2Win. Dichos archivos PNG se insertan en el archivo de registro.

También puede imprimir los contenidos de la pantalla de datos (se activa mediante la opción del menú Ventanas / Pantalla de datos de Tech2Win). Utilice el botón Imprimir/HTML - Iniciar para iniciar y detener la adquisición de datos. Después de detener la adquisición de datos, se inicia el programa asociado con los archivos HTML (normalmente Internet Explorer) que le ofrece las funciones necesarias para imprimir sus datos.

Data Display | Data Display

Una carpeta PCMCIA 'sin usar' se encuentra en mi ordenador

Las versiones anteriores de Tech2Win siempre disponían de almacenamiento duplicado de los archivos PCMCIA en un directorio independiente. Con frecuencia, este directorio era C:\PCMCIA. Ahora este directorio ya no se utiliza porque la descarga rápida desde TIS2Web hace que un segundo almacenamiento de dichas descargas sea innecesario. Puede eliminar este directorio sin peligro.

Estoy recibiendo un mensaje de 'ruta de acceso de archivo ilegal'

El nombre de archivo parece contener caracteres ilegales como, por ejemplo, el signo de por ciento (%). Si está teniendo este problema inmediatamente después de una instalación, lo mejor sería, sencillamente, realizar una desinstalación y una nueva reinstalación. La mayoría de los casos podrían solucionarse utilizando este método.

Durante la instalación normal, se establece 'PUBLIC' para la variable de entorno 'Tech2WinUserData' (para versiones de Windows >= Vista), y 'ALLUSERSPROFILE\Documents' (para versiones de Windows anteriores al Vista). En algunos casos, no se estableció la variable de entorno durante el proceso de instalación, pero funcionó bien al segundo intento. También puede optar por establecer la variable de entorno manualmente. Si no sabe cómo establecer una variable de entorno, pida ayuda a su administrador.


Entradas del registro de Windows

El programa de instalación genera las siguientes entradas del registro. No modifique estas entradas manualmente. Tenga en cuenta las advertencias habituales de Windows cuando manipule entradas del registro.

clave del registro | nombre | tipo | significado
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Número de la versión interna
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Idioma | REG_SZ | idioma instalado
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Ruta de acceso de los directorios de copia de PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Root | REG_SZ | ruta de la instalación
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Opción de desinstalación | REG_DWORD | Configuración de desinstalación
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Versión del archivo de configuración
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Versión del controlador del puerto COM virtual
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | nombre del software en la lista de Agregar / Quitar programas.
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Ruta de acceso al programa de desinstalación


Reinstalación

Durante la reinstalación se borrará todo el directorio de instalación de Tech2Win con las siguientes excepciones.

  1. El subdirectorio config, que contiene las configuraciones, no se borra.
  2. El subdirectorio pcmcia, que normalmente contiene las imágenes de las tarjetas PCMCIA, no se borra.
  3. El subdirectorio ATA, que podría contener información sobre depuración de errores, no se borra.
Los archivos de configuración podrían llegar a ser incompatibles. No existe garantía de que los archivos de configuración de una versión antigua de Tech2Win puedan ser leídos por una versión más reciente de Tech2Win. En principio, las imágenes PCMCIA no pueden volverse incompatibles.

El directorio secundario de la PCMCIA no resulta afectado por la reinstalación.

Algunos entornos pueden ofrecer una instalación automática de una versión más reciente de Tech2Win. Como la información de la última instalación se guarda en el registro, dichas opciones se presentarán como predeterminadas durante la reinstalación.

Puede poner en práctica una reinstalación de Tech2Win utilizando el script enable reinstallation. Este script se instala junto con Tech2Win. Básicamente, este script establece el valor de la clave CurrentVersion encontrado en el registro en HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win en el valor '1.000'.