Εγχειρίδιο χρήσης Tech2Win

Καλώς ήλθατε στο Εγχειρίδιο χρήσης του Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Με επιφύλαξη παντός δικαιώματος.

  • Εισαγωγή:
  • Άδεια χρήσης:
  • Εγκατάσταση:Περιγραφή της διαδικασία εγκατάστασης του Tech2Win.
    • Βήματα εγκατάστασης
    • Περιβάλλον εργασίας επικοινωνίας οχήματος
  • Πρώτα βήματα
    • Επιλογή ρυθμίσεων
      • Πληκτρολόγιο
      • Διαχείριση παραθύρων
    • Νέες παραμετροποιήσεις
    • Τροποποίηση παραμετροποιήσεων
      • Γλώσσα
      • Διαδρομή
      • Οθόνη
      • Αποθήκευση μιας παραμετροποίησης
    • Πάρτε έγκυρη άδεια χρήσης Tech2Win.
  • Εργασία με το Tech2Win: Λεπτομέρειες καθημερινής εργασίας.
    • Μενού
    • Λήψη (Download) μιας εικόνας PCMCIA
    • Ασφάλεια
    • Προβολή αναφορών
    • Διαχείριση εικόνων PCMCIA
    • Γραμμή κατάστασης
  • Προηγμένα θέματα: Πληροφορίες που δεν είναι απαραίτητες για τη συνήθη χρήση του Tech2Win. Συνήθως είναι χρήσιμες μόνο στα άτομα με ρόλο διαχειριστή.
    • Επανεγκατάσταση
    • Απεγκατάσταση
    • Μορφή του αρχείου παραμετροποίησης
    • Αρχείο καταγραφής
    • Μηνύματα σφάλματος και κωδικοί σφάλματος
    • Κάρτα ATA
    • Καταχωρήσεις μητρώου
    • Αρχεία
    • Διαχείριση παραμετροποίησης
  • Συχνές ερωτήσεις


Εισαγωγή

Το Tech2Win είναι μια εφαρμογή Windows που μπορεί να προσομοιώσει τη λειτουργία του Tech2. Ουσιαστικά, το λογισμικό Tech2 εκτελείται σε έναν Η/Υ. Για να εκτελέσετε αυτό το πρόγραμμα, ο Η/Υ σας πρέπει να πληροί τις παρακάτω τεχνικές προδιαγραφές:

  • Πρέπει να έχει εγκατασταθεί ένα περιβάλλον αμφίδρομης επικοινωνίας του χρήστη για την επικοινωνία με το όχημα, και να είναι συνδεδεμένο με τον Η/Υ. Η λίστα με τα αποδεκτά περιβάλλοντα αμφίδρομης επικοινωνίας του χρήστη μπορεί να διαφέρει από περιοχή σε περιοχή. Στις περισσότερες περιπτώσεις, μπορείτε να χρησιμοποιήσετε το Multiple Diagnostic Interface (MDI) της GM.
  • Η εφαρμογή Tech2Win χρειάζεται 150MByte χώρου στο σκληρό δίσκο κατά την εγκατάσταση. Χρειάζονται ακόμη 32MB για κάθε κάρτα PCMCIA flash που θέλετε να διαχειριστείτε.
  • Πριν από την εκτέλεση της εφαρμογής Tech2Win, πρέπει να υπάρχουν κατ' ελάχιστον 100MB ελεύθερης φυσικής RAM. Πρέπει οπωσδήποτε ο Η/Υ σας να έχει αρκετή μνήμη για να διατηρήσει την εφαρμογή ενός της RAM σε όλη τη διάρκεια της εκτέλεσης.
  • Ο Η/Υ σας πρέπει να διαθέτει επεξεργαστική ισχύ ισοδύναμη με 1.2GHz Pentium (μονού πυρήνα). Συνιστούμε να μη χρησιμοποιείτε άλλες εφαρμογές παράλληλα.
  • Δεν χρειάζεται πληκτρολόγιο. Ο χειρισμός του Tech2Win είναι επίσης εφικτός μέσω της οθόνης αφής. Για τη διαχείριση παραμετροποίησης, συνιστούμε να χρησιμοποιείτε ένα πληκτρολόγιο διότι θα χρειαστεί να εισάγετε ονόματα αρχείων.
  • Η έγχρωμη οθόνη γραφικών πρέπει να έχει ελάχιστη ανάλυση 800 x 600 με ελάχιστο βάθος χρώματος 256. Χωρίς πληκτρολόγιο, ανάλυση 640 x 480 ενδέχεται να είναι αποδεκτή.

Όταν χρησιμοποιείτε το Tech2Win (φορητός υπολογιστής αντί για Tech2) βεβαιωθείτε ότι ο φορητός υπολογιστής έχει επαρκή ισχύ. Κανονικά, το laptop σας δεν τροφοδοτείται από την μπαταρία του αυτοκινήτου, όπως το Tech2.

  • Εγκατάσταση
  • Πρώτα βήματα


Άδεια χρήσης

General Motors – Συμφωνία εκμετάλλευσης του Tech2Win

Διαβάστε προσεκτικά τους ακόλουθους όρους και τις προϋποθέσεις προτού χρησιμοποιήσετε αυτό το πρόγραμμα. Εάν δεν αποδέχεστε ή δεν συμφωνείτε με τους όρους ή τις προϋποθέσεις, επικοινωνήστε με τον τοπικό αντιπρόσωπο Aftersales. Η άδεια εκμετάλλευσης για το δικαίωμα χρήσης αυτού του λογισμικού παρέχεται μόνο από τη General Motors υπό την προϋπόθεση ότι ο χρήστης συμφωνεί με αυτή την άδεια εκμετάλλευσης με την αποδοχή των παρόντων όρων και προϋποθέσεων κατά την εγκατάσταση του Tech2Win.
Η General Motors χορηγεί το δικαίωμα χρήσης του λογισμικού Tech2Win και των συμπεριλαμβανομένων πληροφοριών σε συνδυασμό με το TIS2Web ή το GlobalTIS ή το TIS2000 αποκλειστικά για χρήστες του δικτύου εξουσιοδοτημένων επισκευαστών της General Motors, όπως καθορίζεται στο τοπικό ισχύον Συμφωνητικό Εξουσιοδοτημένου Επισκευαστή με τις εθνικές εταιρίες πωλήσεων της General Motors.
Η άδεια χρήσης του Tech2Win ισχύει για το χρονικό διάστημα ισχύος του Συμφωνητικού Εξουσιοδοτημένου Επισκευαστή και των αδειών χρήσης του TIS2Web, GlobalTIS και του TIS2000. Η άδεια χρήσης Tech2Win θα λήξει μαζί με τις άδειες χρήσης των TIS2Web και GlobalTIS, αμέσως όταν λήξει η Συμφωνία εξουσιοδοτημένων επισκευών.

Οι ανεξάρτητοι επισκευαστές, όπως ορίζεται στο Άρθρο 4 παράγραφος 2 του Κανονισμού Απαλλαγής κατά Κατηγορία (ΚΑΚ) της Ευρωπαϊκής Ένωσης 1400/2002, μπορούν να αγοράσουν μια άδεια χρήσης του Tech2Win ως μέρος των προσφερόμενων συνδρομών που παρέχονται στην πύλη τεχνικών πληροφοριών της General Motors Europe.

Η άδεια χρήσης Tech2Win δεν καλύπτει το σύστημα αμφίδρομης επικοινωνίας του οχήματος ή τα μηχανικά μέρη του υπολογιστή.

Απαγορεύεται η περαιτέρω διανομή, πώληση ή τοποθέτηση σε δίκτυο προς οποιονδήποτε τρίτο που βρίσκεται εκτός των εγκαταστάσεων του εξουσιοδοτημένου επισκευαστή (όπως περιγράφεται στο σχετικό παράρτημα του Συμφωνητικού Εξουσιοδοτημένου Επισκευαστή) του λογισμικού Global TIS χωρίς τη γραπτή συναίνεση των αντίστοιχων εθνικών εταιρειών πωλήσεων της General Motors. Το ίδιο ισχύει και για τα τρέχοντα και μη τρέχοντα δεδομένα (όπως DVD που έχουν λήξει).

Οι εθνικές εταιρείες πωλήσεων της General Motors θα δικαιούνται να αποκλείσουν αμέσως την πρόσβαση και να παράσχουν ειδοποίηση άμεσου τερματισμού του Συμφωνητικού Εξουσιοδοτημένου Επισκευαστή σε περίπτωση μη εξουσιοδοτημένης ή καταχρηστικής χρήσης. Σε αυτή την περίπτωση, θα αποκλείεται το δικαίωμα διεκδίκησης αποζημίωσης των πιστωτικών υπολοίπων ή/και των βασικών ετήσιων αμοιβών.

Οι παρεχόμενες πληροφορίες εξυπηρετούν την εκτέλεση εργασιών συντήρησης και επισκευής με επαγγελματικό τρόπο για μη τροποποιημένα οχήματα της General Motors. Προϋπόθεση για την εκτέλεση των παραπάνω εργασιών είναι η ολοκληρωμένη εκπαίδευση τεχνικού αυτοκινήτων και τακτική περαιτέρω εκπαίδευση. Όπου ενδείκνυται η χρήση ειδικών εργαλείων στις παρεχόμενες πληροφορίες, τα εν λόγω ειδικά εργαλεία είναι υποχρεωτικά για όλες τις επισκευές που θα εκτελούνται με επαγγελματικό τρόπο.

Οι πληροφορίες που δημοσιεύονται στο Tech2Win της General Motors (κείμενο και εικόνες, μουσική, γραφικά, κινούμενες εικόνες, βίντεο, κ.λπ.) και η διάταξη αυτών στο Tech2Win προστατεύονται από πνευματικά δικαιώματα. Απαγορεύεται οποιαδήποτε αναπαραγωγή, διασπορά, επικοινωνία ή/και μετάδοση ή άλλη χρήση, εκτός εάν συνοδεύεται από προηγούμενη γραπτή συναίνεση της General Motors.

  • Εγκατάσταση: Βήματα εγκατάστασης
  • Πρώτα βήματα


Installation

Εγκατάσταση

Για την εγκατάσταση του Tech2Win, χρειάζονται δικαιώματα διαχειριστή στον Η/Υ. Χωρίς διαχειριστικά δικαιώματα η εγκατάσταση δεν θα πραγματοποιηθεί. Σε αυτή την περίπτωση, απευθυνθείτε στο διαχειριστή του Η/Υ για βοήθεια.

Για να χρησιμοποιήσετε το Tech2Win με επιτυχία, πρέπει να ολοκληρώσετε τα δύο ακόλουθα βήματα:

  • Εγκατάσταση του Tech2Win.
  • Εγκατάσταση περιβάλλοντος εργασίας επικοινωνίας οχήματος.
  • Εγκατάσταση: Βήματα εγκατάστασης
  • Πρώτα βήματα


Βήματα εγκατάστασης

Η ίδια η εγκατάσταση χρειάζεται μόλις λίγα λεπτά και απαιτεί τις ακόλουθες καταχωρήσεις από τον χρήστη:

  1. Σύμβαση άδειας χρήσης
  2. Τον κατάλογο της εγκατάστασης

Γλώσσα

Από προεπιλογή, θα εμφανίζεται το περιβάλλον εργασίας του Tech2Win στη γλώσσα του λειτουργικού συστήματός σας. Γενικά υποστηρίζονται οι παρακάτω γλώσσες. Εάν η γλώσσα σας δεν υποστηρίζεται, το πρόγραμμα εγκατάστασης ξεκινά με Αγγλικά ως προεπιλεγμένη γλώσσα εγκατάστασης.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Αγγλικά (Βρετανικά ή Αμερικανικά)*
  • el_GR (EL)Greek
  • es_ES (ES)Ισπανικά
  • fi_FI (FI)Finnish
  • fr_FR (FR)Γαλλικά
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Πορτογαλικά (Βραζιλία)
  • pt_PT (PT)Πορτογαλικά (Πορτογαλία)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Κινέζικα (Απλοποιημένα)
  • zh_TW (ZH)Κινέζικα (Παραδοσιακά)

* Η γλώσσα στο Tech2Win είναι Βρετανικά Αγγλικά. Ωστόσο, το λογισμικό Tech2 και το πρόγραμμα εγκατάστασης που χρησιμοποιείτε μπορεί να είναι σε Αμερικάνικα Αγγλικά, ανάλογα με την πηγή του λογισμικού.

Σύμβαση άδειας χρήσης

Χρειάζεται να αποδεχθείτε τη Σύμβαση άδειας χρήσης

Τον κατάλογο της εγκατάστασης

Μπορείτε να επιλέξετε έναν οποιονδήποτε κατάλογο ως θέση εγκατάστασης του Tech2Win. Η κατάλογος εγκατάστασης ορίζεται ως προεπιλογή είτε στον <κατάλογο προγραμμάτων σας>\General Motors\Tech2Win ή, σε περίπτωση επανεγκατάστασης, στη θέση που είχε οριστεί προηγουμένως.

ως τελευταίο βήμα επιβεβαίωσης της εγκατάστασης.

Πρόγραμμα οδήγησης εικονικής θύρας Com

Αυτό το πρόγραμμα οδήγησης εικονικής θύρας com εγκαθίσταται μόνο μία φορά στον υπολογιστή σας και παραμένει μέχρι η έκδοση του προγράμματος οδήγησης να αναβαθμιστεί (συμβαίνει σπάνια) ή μέχρι να καταργηθεί η εγκατάσταση του Tech2Win από τον υπολογιστή σας.
Εάν το πρόγραμμα οδήγησης εγκατασταθεί, θα δείτε στιγμιαία ένα πλαίσιο DOS. Θα κλείσει αυτόματα και δεν απαιτεί καμία ενέργεια. Τα αρχεία προγράμματος οδήγησης τοποθετούνται επιπλέον στον υποφάκελο 'πρόγραμμα οδήγησης' στον κατάλογο εγκατάστασης του Tech2Win.
Είναι δυνατό, αλλά δεν συνίσταται, να εγκαταστήσετε ή να καταργήσετε την εγκατάσταση των προγραμμάτων οδήγησης εικονικής θύρας com με μη αυτόματο τρόπο. Χρησιμοποιήστε μία από τις ακόλουθες εντολές από το κέλυφος CMD:

  • εκτελέστε το 'vbsetup7' για να εγκαταστήσετε το πρόγραμμα οδήγησης
  • εκτελέστε το 'vbsetup7 /u' για να καταργήσετε την εγκατάσταση του προγράμματος οδήγησης
  • Πρώτα βήματα


Περιβάλλον εργασίας επικοινωνίας οχήματος

Η συσκευή επικοινωνία του οχήματος πρέπει να εγκατασταθεί ξεχωριστά. Ανατρέξτε στον αντίστοιχο οδηγό εγκατάστασης που παρέχεται με το περιβάλλον εργασίας επικοινωνίας οχήματος.

  • Πρώτα βήματα: Περιβάλλον εργασίας επικοινωνίας οχήματος
  • Προηγμένα θέματα: Αρχείο παραμετροποίησης
  • Εγκατάσταση: Βήματα εγκατάστασης
  • Συχνές ερωτήσεις: Πώς μπορώ να χρησιμοποιήσω περισσότερες από μία MDI;
  • Συχνές ερωτήσεις: Το Tech2Win δεν βρήκε την MDI που χρησιμοποιώ


Πρώτα βήματα

Αυτά τα πρώτα βήματα δείχνουν πώς να χρησιμοποιήσετε το Tech2Win. Υποτίθεται ότι είστε εξοικειωμένοι με το Tech2. Δεν απαιτείται επικοινωνία με το όχημα στη διάρκεια αυτών των πρώτων βημάτων.

Για Γρήγορο ξεκίνημα, ακολουθήστε τα παρακάτω βήματα:

  1. Εκτελέστε το λογισμικό Tech2Win χρησιμοποιώντας τη συντόμευση QuickStart από την επιφάνεια εργασίας σας.
  2. Λήψη έγκυρης άδειας χρήσης με τη λήψη (download) του νέου λογισμικού Tech2 από το TIS2Web.

Για να χρησιμοποιήσετε μια επιλέξιμη ρύθμιση παραμέτρων:

  1. Ξεκινήστε το ρυθμιστή χρησιμοποιώντας τη συντόμευση Tech2Win από την επιφάνεια εργασίας. Μετά από την εγκατάσταση, πρέπει να υπάρχει μια προεπιλεγμένη παραμετροποίηση.
  2. Για να δημιουργήσετε μια νέα ρύθμιση, αντιγράψτε κατά προτίμηση την προεπιλεγμένη ρύθμιση παραμέτρων.
  3. Τροποποιήστε μια υπάρχουσα ρύθμιση για να ικανοποιήσετε τις συγκεκριμένες απαιτήσεις σας.
  4. Πάρτε έγκυρη άδεια χρήσης.

Μην εκκινήσετε το Tech2Win σε κατάσταση λειτουργίας συμβατότητας. Σε μια τέτοια περίπτωση, θα εμφανιστεί μια προειδοποίηση στο αρχείο καταγραφής. Το Tech2Win χρησιμοποιεί μόνο λειτουργίες των Windows που υπάρχουν από την έκδοση XP και δεν θα συνεργαστεί με προηγούμενες εκδόσεις.

  • Πρώτα βήματα: Νέες παραμετροποιήσεις
  • Πρώτα βήματα: Τροποποίηση παραμετροποιήσεων
  • Πρώτα βήματα: Περιβάλλον εργασίας επικοινωνίας οχήματος
  • Εργασία με το Tech2Win: Μενού
  • Εργασία με το Tech2Win: Ασφάλεια
  • Εργασία με το Tech2Win: Γραμμή κατάστασης
  • Προηγμένα θέματα: Αρχείο παραμετροποίησης


Επιλογή ρυθμίσεων

Την πρώτη φορά που ενεργοποιείται η εφαρμογή Tech2Win, εμφανίζεται η παρακάτω οθόνη. Έχετε την επιλογή να γίνεται εκκίνηση του Tech2Win με μια προεπιλεγμένη παραμετροποίηση. Αυτή η προεπιλεγμένη παραμετροποίηση λειτουργεί χωρίς να υπάρχει επικοινωνία με το όχημα.

Start First Time

Θα εμφανιστεί το παράθυρο μηνύματος πληροφοριών άδειας χρήσης, αλλά μπορείτε να το αγνοήσετε για να ξεκινήσετε τις προεπιλεγμένες ρυθμίσεις.

Όταν χρησιμοποιείτε οθόνη αφής, μπορεί να σας φανεί χρήσιμο να ενεργοποιήσετε το πρόγραμμα πληκτρολογίου του Η/Υ για να μπορείτε να εισάγετε γράμματα μέσω αυτής της εφαρμογής που προσομοιώνει ένα πληκτρολόγιο.


Πληκτρολόγιο

Τα πλήκτρα του Η/Υ καθώς και τα κουμπιά, εάν υπάρχουν, επισημαίνονται στα γνωστά πλήκτρα του Tech2. Διατίθενται κάποια πρόσθετα πλήκτρα του Tech2Win τα οποία δεν υπάρχουν στο αρχικό Tech2. Το αριθμητικό πληκτρολόγιο του υπολογιστή ενδέχεται να μη λειτουργεί υπό όλες τις συνθήκες. Εάν αντιμετωπίσετε προβλήματα, ελέγξτε εάν η τυπική διάταξη του πληκτρολογίου του υπολογιστή σας έχει αλλάξει. Συγκεκριμένα, σ' αυτή την περίπτωση ενδέχεται να έχει υποστεί ζημιά το πλήκτρο SHIFT.

Πληκτρολόγιο Η/Υ | Κουμπί | Λειτουργία
Πλήκτρο λειτουργίας F1 | μ.δ. | Βοήθεια Tech2Win
Πλήκτρα λειτουργιών F5 .. F8 | Χρησιμοποιήστε την περιοχή οθόνης του Tech2Win με τα πλήκτρα συντόμευσης | Τέσσερα πλήκτρα προγραμματιζόμενων λειτουργιών Tech2
Πλήκτρα κέρσορα Επάνω, Κάτω, Αριστερά, Δεξιά |  | Πλήκτρα Επάνω, Κάτω, Αριστερά, Δεξιά του Tech2; Μόνο αυτά τα πλήκτρα διαθέτουν αυτόματη επανάληψη.
Πλήκτρα 0 .. 9 | F0 • • • F9 | Πλήκτρα Tech2 F0 .. F9
Backspace | Exit | Πλήκτρο εξόδου Tech2
Enter / Return | Enter | Πλήκτρο Enter Tech2
Y | Yes | Πλήκτρο Ναι Tech2
N | No | Πλήκτρο Όχι Tech2
Q | ? | Πλήκτρο ? Tech2
S | Shift | Πλήκτρο Shift Tech2. Ο δείκτης Shift στη γραμμή κατάστασης ή ο δείκτης πάνω από το πλήκτρο Shift, υποδεικνύουν την κατάσταση.
ctrl-P | PWR | Πλήκτρο λειτουργίας του Tech2; Προφανώς, αυτό το πλήκτρο μπορεί μόνο να κλείσει την εφαρμογή Tech2Win.
ctrl-R | μη διαθέσιμο | Επαναρυθμίζει το Tech2Win. Παρόμοιο με έναν κύκλο απενεργοποίησης/ενεργοποίησης στο Tech2. Ωστόσο, δεν γίνεται επανεκκίνηση ενός συνδεδεμένου Περιβάλλοντος Εργασίας Επικοινωνίας Οχήματος. Αρχεία όπως η εικόνα PCMCIA δεν επαναφορτώνονται.
Αρχική | Home | Πλήκτρο μετάβασης στην αρχική σελίδα. Υποστηρίζεται μόνο από ορισμένες εφαρμογές.
διαθέσιμο μόνο μέσω της επιλογής μενού Αρχείο. | Print Screen | Εκτυπώνει ένα στιγμιότυπο της οθόνης Tech2, δημιουργώντας ένα προσωρινό αρχείο BMP και καλώντας την εφαρμογή που σχετίζεται με αρχεία BMP. Χρησιμοποιήστε αυτήν την εφαρμογή για να αλλάξετε το μέγεθος ή να περιστρέψετε την εικόνα πριν την εκτύπωση.
διαθέσιμο μόνο μέσω της επιλογής μενού Αρχείο. | Save Screen | Αποθηκεύει ένα στιγμιότυπο της οθόνης Tech2 ως αρχείο BMP ή PNG.
διαθέσιμο μόνο μέσω της επιλογής μενού Αρχείο. | View Report | Εμφανίζει όλες τις αναφορές στην ενεργή κάρτα PCMCIA flash έτσι, ώστε ο χρήστης να μπορεί να τις προβάλει.


Διαχείριση παραθύρων

Μπορείτε να ρυθμίσετε τις διαστάσεις των παραθύρων χρησιμοποιώντας τους τυπικούς μηχανισμούς των Windows, σύροντας το περίγραμμα του κύριου παραθύρου. Επιπλέον, το στοιχείο μενού Επιλογές/Ανάλυση υποστηρίζει αρκετά προεπιλεγμένα μεγέθη. Κατά την αλλαγή μεγέθους του κύριου παραθύρου μέσω στοιχείου του μενού, το παράθυρο του πληκτρολογίου θα παραμείνει αυτόματα αγκυρωμένο.

Η εμφάνιση των παραθύρων τροποποιείται, αλλάζοντας τη ρύθμιση στην καρτέλα Οθόνη.


Νέες παραμετροποιήσεις

Κάντε κλικ στο κουμπί Δημιουργία νέου/νέας για να δημιουργήσετε μια νέα παραμετροποίηση. Θα εμφανιστεί ένα μενού διαλόγου, το οποίο θα σας ζητά να επιλέξετε ένα υπάρχον αρχείο παραμετροποίησης ως πηγή. Συνήθως είναι επιλεγμένη η προεπιλεγμένη παραμετροποίηση. Αφού εισάγετε το όνομα του νέου αρχείου παραμετροποίησης, πατήστε το κουμπί Αντιγραφή.

Εάν χρησιμοποιείτε οθόνη αφής, μπορεί να βρείτε πιο εύχρηστη την προσομοίωση πληκτρολογίου Η/Υ - για να την ενεργοποιήσετε πατήστε το κουμπί Πληκτρολόγιο Η/Υ.

Με το κουμπί Ακύρωση, μπορείτε να ακυρώσετε τη διαδικασία δημιουργίας.

Η νέα ρύθμιση παραμέτρων θα χρησιμοποιεί το ίδιο αρχείο PCMCIA με την υπάρχουσα ρύθμιση παραμέτρων προέλευσης. Εάν επιθυμείτε να την αλλάξετε, θα χρειαστεί να τροποποιήσετε τη ρύθμιση, έτσι ώστε να χρησιμοποιείται ένα διαφορετικό αρχείο PCMCIA. Στις περισσότερες περιπτώσεις, θα αντιγράψετε απλά το υπάρχον αρχείο PCMCIA σε νέο αρχείο και θα χρησιμοποιήσετε αυτό το νέο αρχείο. Μπορείτε να προτιμάτε η νέα σας ρύθμιση να χρησιμοποιεί το ίδιο αρχείο PCMCIA με τη ρύθμιση προέλευσης. Σε αυτήν την περίπτωση, θα εμφανιστεί μια προειδοποιητική οθόνη όταν πατήσετε το κουμπί Αποθήκευση.

  • Τροποποίηση παραμετροποιήσεων


Τροποποίηση παραμετροποιήσεων

Οι παραμετροποιήσεις με μπλε χρώμα είναι 'μόνο για ανάγνωση' και δεν μπορούν να τροποποιηθούν. Μπορείτε μόνο να εμφανίσετε αυτές τις παραμετροποιήσεις. Φυσικά μπορείτε να χρησιμοποιήσετε τη μέθοδο παραμετροποίησης απλώς για να δείτε τα περιεχόμενα, ωστόσο η επιλογή Αποθήκευση (Αποθήκευση) δεν είναι διαθέσιμη.

Η παραμετροποίηση τροποποιείται εάν επιλέξετε την κάθε ρύθμιση στις τέσσερις καρτέλες Γλώσσα, Περιβάλλον εργασίας επικοινωνίας οχήματος, Διαδρομή, Οθόνη. Μπορείτε είτε να τσιμπήσετε το στυλοθέτη που θέλετε είτε απλώς να επιλέξετε να πατήσετε το κουμπί Επόμενο που θα ενεργοποιήσει τον επόμενο στυλοθέτη. Αφού κάνετε τις τροποποιήσεις που θέλετε, πατήστε το κουμπί Αποθήκευση για να αποθηκεύσετε την παραμετροποίησή σας.

Όποτε είναι απαραίτητο να κάνετε μια καταχώρηση μέσω του πληκτρολογίου, μπορείτε επίσης να ενεργοποιήσετε μια εφαρμογή προσομοίωσης ένα πληκτρολόγιο Η/Υ. Αυτό εξυπηρετεί ιδιαίτερα στις οθόνες αφής των laptop όταν δεν υπάρχει διαθέσιμο πληκτρολόγιο.


Γλώσσα

Η καρτέλα Γλώσσα σας επιτρέπει να επιλέξετε τη γλώσσα στην οποία θα λειτουργεί το Tech2Win. Η επιλογή αυτή δεν επηρεάζει τη γλώσσα του λογισμικού Tech2 στην εικόνα PCMCIA. Κατά τη λήψη (download) λογισμικού Tech2 από το TIS, θα πρέπει να επιλέξετε τη σωστή γλώσσα.

Για ορισμένες περιοχές, δεν είναι διαθέσιμες όλες οι γλώσσες. Σε αυτή την περίπτωση, όλα εμφανίζονται στα Αγγλικά (English). Ελέγξτε εάν μια παρόμοια γλώσσα είναι διαθέσιμη (PT Πορτογαλικά-Πορτογαλίας αντί για PB Πορτογαλικά-Βραζιλίας).


Διαδρομή

Η καρτέλα Διαδρομή σας δίνει τη δυνατότητα να ορίσετε τις διαδρομές και των δύο εικόνων PCMCIA καθώς και τη διαδρομή προς το τοπικό πληκτρολόγιο του λογισμικού. Επίσης, το κουμπί Αντιγραφή κάρτας μνήμης παρέχεται για την αντιγραφή εικόνων PCMCIA. Εάν μόλις δημιουργήσατε μια νέα ρύθμιση παραμέτρων, ενδέχεται να επιθυμείτε να χρησιμοποιήσετε αυτό το κουμπί για να αποτρέψετε πολλές ρυθμίσεις να κάνουν χρήση της ίδιας εικόνας PCMCIA.

Memory Card Options

Αντιγραφή κάρτας μνήμης ...

Το κουμπί αυτό σας επιτρέπει να αντιγράψετε μια εικόνα PCMCIA σε ένα άλλο αρχείο. Η λειτουργία μοιάζει πολύ με την αγορά μιας νέας κάρτας PCMCIA για το Tech2. Η λειτουργία αντιγραφής λειτουργεί μόνο για αρχεία στον κατάλογο C:\Users\Public\General Motors\Tech2Win\pcmcia.

Υποδοχή 0 : Θέση εικόνας κάρτας μνήμης

Εδώ μπορείτε να καθορίσετε το αρχείο που περιέχει την εικόνα σας PCMCIA για την υποδοχή 0. Υπό φυσιολογικές συνθήκες, αυτό το αρχείο θα πρέπει να βρίσκεται στον κατάλογο C:\Users\Public\General Motors\Tech2Win\pcmcia, άλλες θέσεις, ωστόσο, είναι δυνατό να υπάρχουν.

Υποδοχή 1 : Κάρτα μνήμης ή ATA

Όπως το Tech2, το Tech2Win υποστηρίζει επίσης δύο κάρτες PCMCIA (εικόνες). Ωστόσο, η δεύτερη κάρτα PCMCIA στην παραμετροποίηση συνήθως δεν είναι ιδιαίτερα χρήσιμη. Ένα δεύτερο λογισμικό ενδεχομένως να χρησιμοποιηθεί σε μια δεύτερη παραμετροποίηση.

Όπως στο Tech2, η κάρτα ATA χρησιμοποιείται για λόγους διόρθωσης σφαλμάτων. Ενεργοποιείτε την κάρτα ATA μόνο μετά από σχετική οδηγία του τμήματος τεχνικής υποστήριξης. Το προσωπικό θα σας δώσει περισσότερες πληροφορίες.

Θέση πληκτρολογίου λογισμικού Η/Υ

Η προεπιλεγμένη τιμή αυτού του αρχείου ανακτάται από το μητρώο των Windows και πρέπει να αναφέρεται σε μια εφαρμογή ικανή να προσομοιώσει ένα πληκτρολόγιο PC με το ποντίκι. Εάν έχετε κάποια ειδική εφαρμογή με τέτοια λειτουργία για το laptop που χρησιμοποιείτε, μπορείτε να ορίσετε την εφαρμογή αυτή εδώ.


Περιβάλλον εργασίας επικοινωνίας οχήματος

  • Θύρα COM για την προσομοίωση Tech2-RS232
  • Αύξων αριθμός του MDI προς χρήση
  • Πρωτόκολλο

Θύρα COM για την προσομοίωση Tech2-RS232

Επιλέξτε μία ελεύθερη θύρα COM που να μπορεί να χρησιμοποιηθεί για την προσομοίωση Tech2. Για τη διευκόλυνσή σας, ο διαμορφωτής προσπαθεί να βρει ποιες σειριακές θύρες χρησιμοποιούνται ήδη και τις εμφανίζει.

Εάν επιλέξετε υπάρχουσα θύρα COM, το Tech2Win θα επισυναφθεί σε αυτήν την υπάρχουσα θύρα COM. Μπορείτε να επιλέξετε αυτή τη θύρα COM για να πραγματοποιήσετε λήψη του λογισμικού Tech2 από ένα δεύτερο υπολογιστή εκτελώντας μία εφαρμογή TIS με τη χρήση καλωδίου μόντεμ τύπου null. Η χρήση πραγματικής θύρας COM ενδέχεται να μη λειτουργεί αξιόπιστα με ταχύτητα baud 115.200 λόγω περιορισμών των Windows.

Εάν επιλεχθεί μη υπάρχουσα θύρα COM, το Tech2Win θα δημιουργήσει αυτόματα εικονική θύρα. Αυτή η εικονική θύρα ενδέχεται να χρησιμοποιηθεί από την εφαρμογή TIS στον ίδιο υπολογιστή ώστε να επιτευχθεί επικοινωνία με το Tech2Win. Όταν χρησιμοποιείτε εικονική θύρα, δεν υπάρχει περιορισμός ταχύτητας baud.

Εάν επιλέξετε 'αναζήτηση' ως θύρα COM, το Tech2Win θα δημιουργήσει μια εικονική θύρα COM στον πρώτο ελεύθερο αριθμό θύρας στην περιοχή από 9 έως 1.

Αύξων αριθμός του MDI προς χρήση

Πληκτρολογήστε το σειριακό αριθμό της MDI. Ο αριθμός αναγράφεται στην πίσω πλευρά της MDI. Χρησιμοποιήστε τον αριθμό μετά το ενωτικό.

Εάν δεν πληκτρολογήσετε σειριακό αριθμό, το Tech2Win θα εμφανίσει αυτόματα μία λίστα MDI που βρέθηκαν στο δίκτυο ώστε ο χρήστης να επιλέξει μία MDI. Το ίδιο πλαίσιο επιλογής θα εμφανιστεί όταν η καθορισμένη MDI δεν βρεθεί.

Πρωτόκολλο

Επιλέγεται το 'ISO22900-2 / PDU-API' και το J2534-2 είναι πάντα απενεργοποιημένο. Μελλοντικά, το Tech2Win ενδέχεται να μπορεί να υποστηρίξει και πρωτόκολλο J2534.

  • Προηγμένα θέματα: Αρχείο παραμετροποίησης
  • Συχνές ερωτήσεις: Πώς μπορώ να καθορίσω ποια θύρα com πρέπει να χρησιμοποιήσω για το Tech2Win;
  • Συχνές ερωτήσεις: Επικοινωνία μεταξύ Tech2Win και TIS2Web
  • Συχνές ερωτήσεις: Πώς μπορώ να χρησιμοποιήσω περισσότερες από μία MDI;
  • Συχνές ερωτήσεις: Το Tech2Win δεν βρήκε την MDI που χρησιμοποιώ


Οθόνη

Η καρτέλα Οθόνη χρησιμοποιείται κυρίως για την αλλαγή των ρυθμίσεων σχετικά με την οθόνη του Tech2Win:

  • Πληκτρολόγιο
  • Χρώματα
  • Ήχος
Display and Key Options

Πληκτρολόγιο

Εδώ μπορείτε να επιλέξετε εάν θέλετε να εμφανίζεται το πληκτρολόγιο. Το πληκτρολόγιο εμφανίζεται είτε στα αριστερά είτε στα δεξιά της οθόνης του Tech2Win. Μπορείτε να επιλέξετε το χρώμα του φόντου μέσω ενός τυπικού παραθύρου διαλόγου χρώματος.

Χρώματα

Εδώ μπορείτε να επιλέξετε ξεχωριστά το χρώμα του φόντου και του προσκήνιου της οθόνης του Tech2. Αυτοί είναι οι συνηθέστεροι χρωματικοί συνδυασμοί:

Screen with background 0000FF, foreground FFFFFF | Πληκτρολόγιο φόντο λευκό; Φόντο μπλε; Προσκήνιο λευκό
Screen with background 000000, foreground C0C0C0 | Φόντο πληκτρολογίου μπλε; Φόντο μαύρο; Προσκήνιο ανοικτό γκρι

Ήχος

Μπορείτε να επιλέξετε να απενεργοποιήσετε εδώ τον ήχο. Κάθε φορά που το πρόγραμμα Tech2 ενεργοποιεί έναν ήχο 'μπιπ', χρησιμοποιείται το ηχείο του Η/Υ.


Αποθήκευση της παραμετροποίησης

Μπορείτε να αποθηκεύσετε την ενεργή παραμετροποίηση, πατώντας το κουμπί Αποθήκευση <για την παραμετροποίηση> στην κάτω αριστερή γωνία. Το κουμπί δεν εμφανιστεί εάν έχετε εμφανίσει μια παραμετροποίηση 'μόνο για ανάγνωση'.


Έγκυρη άδεια χρήσης μέσω TIS2Web

Συνήθως, η λήψη του λογισμικού Tech2 στο Tech2Win θα σας δώσει μία έγκυρη άδεια χρήσης. Επιπλέον, μπορείτε να λάβετε μία εκτελώντας 'Πρόσβαση σε Λειτουργίες Ασφαλείας (Ασφάλεια)' μέσω του TIS2Web (όχι TIS2000). Προϋπόθεση επομένως είναι η επιλογή της εικονικής θύρας COM μέσα στον Διαμορφωτή (Configurator) κάτω από το Περιβάλλον εργασίας επικοινωνίας οχήματος.

Μετά την επιτυχή πρόσβαση ασφαλείας θα δείτε ένα ανοικτό λουκέτο στη δεξιά πλευρά της γραμμής κατάστασης. Μέσα στην παρένθεση θα δείτε τον αριθμό των ημερών που ισχύει η άδεια χρήσης. Κατά την επανεκκίνηση του Tech2Win η ένδειξη ασφαλείας δεν θα εμφανιστεί εφόσον δεν πραγματοποιείται επικοινωνία με όχημα. Κατά τη διάρκεια της πρώτης επικοινωνίας με όχημα η άδεια θα ελεγχθεί και η ένδειξη θα αλλάξει σε ανοικτό ή κλειστό λουκέτο.

  • Εργασία με το Tech2Win:Ασφάλεια
  • Συχνές ερωτήσεις:Πώς μπορώ να καθορίσω ποια θύρα com πρέπει να χρησιμοποιήσω για το Tech2Win;
  • Συχνές ερωτήσεις:Επικοινωνία μεταξύ Tech2Win και TIS2Web
  • Συχνές ερωτήσεις:Έγκυρη άδεια χρήσης
  • Συχνές ερωτήσεις:Ποια είναι η διαφορά μεταξύ της Άδειας Χρήσης του Tech2Win και της Πρόσβασης Ασφαλείας;


Εργασία με το Tech2Win

Τα παρακάτω θέματα χρησιμοποιούνται από τους περισσότερους τεχνικούς όταν πραγματοποιούν εργασίες με το Tech2Win:

  • Μενού: Διάταξη της οθόνης και μεμονωμένα στοιχεία του μενού.
  • Λήψη εικόνας PCMCIA: Η ενημέρωση του λογισμικού διαγνωστικού ελέγχου για το Tech2Win μοιάζει σε μεγάλο βαθμό με τη μέθοδο που χρησιμοποιείται για το Tech2.
  • Ασφάλεια: Τα μέτρα ασφαλείας αποτρέπουν το Tech2Win να ενεργοποιήσει την επικοινωνία με το όχημα σε μη εξουσιοδοτημένα περιβάλλοντα.
  • Προβολή αναφορών: Το πληκτρολόγιο του Tech2 έχει βελτιωθεί ελαφρά στο Tech2Win. Το κουμπί 'Προβολή αναφορών' είναι το πιο χαρακτηριστικό παράδειγμα.
  • Διαχείριση εικόνων PCMCIA: Όπως όταν έχετε πολλαπλές κάρτες PCMCIA για το Tech2, μπορείτε να έχετε σε χρήση αρκετές εικόνες PCMCIA για το Tech2Win.
  • Γραμμή κατάστασης: Η γραμμή κατάστασης πληροφορεί το χρήστη σχετικά με κάθε μέρος της γραμμής κατάστασης.
    • Προηγμένα θέματα
    • Συχνές ερωτήσεις


Μενού

Η εφαρμογή Tech2Win διαθέτει τα παρακάτω στοιχεία μενού:

  • Αρχείο
  • Επιλογές
  • Παράθυρα
  • Βοήθεια

Αρχείο

Το μενού Αρχείο παρέχει τις ακόλουθες δυνατότητες:

  • Η επιλογή Αποθηκεύστε την Οθόνη Τ2 (320x240) χρησιμοποιείται για να αποθηκεύσετε την τρέχουσα Οθόνη T2 σε μέγεθος 320x240 pixel ως αρχείο ασπρόμαυρης εικόνας στον υπολογιστή σας. Η θέση αποθήκευσης και η μορφή αρχείου (BMP, GIF, JPG, PNG) μπορούν να επιλεχθούν ελεύθερα.
  • Η επιλογή Εκτυπώστε την οθόνη δημιουργεί ένα αρνητικό ασπρόμαυρης εικόνας BMP της οθόνης Tech2 και ανοίγει το πρόγραμμα που σχετίζεται με αρχεία BMP. Μπορείτε τότε να χρησιμοποιήσετε αυτό το πρόγραμμα για να εκτυπώσετε την εικόνα.
  • Το Εμφάνιση αρχείων αναφοράς παρέχει τη δυνατότητα προβολής (και εκτύπωσης) αρχείων εκθέσεων χωρίς τη χρήση του TIS2Web.
  • Το Έξοδος τερματίζει το Tech2Win.

Επιλογές

Από το Επιλογές έχετε τις ακόλουθες επιλογές:

  • Το Ανάλυση μπορεί να χρησιμοποιηθεί για να επιλέξετε ένα από τα τρία τυπικά μεγέθη οθόνης.
  • Το ROM-Write from 0x00003ED76 χρησιμοποιείται για εντοπισμό εσωτερικών σφαλμάτων.
  • Αυτόματα στιγμιότυπα οθόνης για να αποθηκεύσετε μία εικόνα για κάθε διαφορετική οθόνη Tech2 στον κατάλογο αρχείου καταγραφής.
  • Απενεργοποιήστε το CANdi και κάντε επανεκκίνηση για να προσομοιώσει την κατάσταση όπου δεν υπάρχει CANdi μεταξύ του Tech2 και του οχήματος. Αυτό είναι απαραίτητο για τις σπάνιες περιπτώσεις όπου το CANdi διακόπτει μη τυπικές γραμμές επικοινωνίας οχήματος.

Παράθυρα

Το μενού Παράθυρα σας δίνει τη δυνατότητα να ενεργοποιήσετε τις επιλογές Οθόνη δεδομένων Tech2Win και Οθόνη ΚΒΔΕ Tech2Win. Όλες οι υπόλοιπες επιλογές εμφανίζονται με αχνό γκρι χρώμα στην τρέχουσα έκδοση του Tech2Win.

Αν το λογισμικό Tech2 υποστηρίζει Οθόνη δεδομένων Tech2Win, μπορείτε να ενεργοποιήσετε αυτήν την καταχώρηση μενού. Κατά την είσοδο στην Οθόνη δεδομένων, το Tech2Win εμφανίζει ένα πρόσθετο παράθυρο Οθόνης δεδομένων δίπλα στην Οθόνη δεδομένων Tech2. Εφόσον η οθόνη του Tech2 εμφανίζει την Οθόνη δεδομένων, η καταχώρηση μενού δεν μπορεί να ενεργοποιηθεί. Σε μια τέτοια περίπτωση πρέπει να εξέλθετε της Οθόνης δεδομένων, να ενεργοποιήσετε την καταχώρηση μενού και να κάνετε επανεκκίνηση της Οθόνης δεδομένων.

Για Οθόνη δεδομένων Tech2Win ισχύουν επίσης παρόμοιοι περιορισμοί για Οθόνη ΚΒΔΕ Tech2Win. Αν το λογισμικό Tech2 υποστηρίζει Οθόνη ΚΒΔΕ Tech2Win, μπορείτε να ενεργοποιήσετε αυτήν την καταχώρηση μενού. Θα εμφανιστεί ένα επιπλέον παράθυρο 'Οθόνη ΚΒΔΕ' παράλληλα της 'Οθόνης ΚΒΔΕ Tech2'. Εφόσον η οθόνη του Tech2 εμφανίζει την Οθόνη ΚΒΔΕ, η καταχώρηση μενού δεν μπορεί να ενεργοποιηθεί. Σε μια τέτοια περίπτωση, πρέπει να εξέλθετε της Οθόνης ΚΒΔΕ, να ενεργοποιήσετε την καταχώρηση μενού και να κάνετε επανεκκίνηση της Οθόνης ΚΒΔΕ.

Βοήθεια

Είναι διαθέσιμες οι παρακάτω επιλογές:

  • Το Θέματα Βοήθειας... καλεί τη Βοήθεια Tech2Win.
  • Το Παράμετρος γραμμής εντολών εμφανίζει τις παραμέτρους της γραμμής εντολών που χρησιμοποιούνται για το Tech2Win.
  • Πληροφορίες εμφανίζει τον αριθμό της τρέχουσας έκδοσης και τους περιορισμούς λήψης του TIS2Web του Tech2Win.


Λήψη (download)

Πρώτα, εκκινήστε το Tech2Win και αφήστε το στη βασική οθόνη. Εκκινήστε το TIS2Web ή το GlobalTIS και εκτελέστε τη λήψη μέσω της θύρας COM που προσδιορίστηκε στην καρτέλα Περιβάλλον εργασίας επικοινωνίας οχήματος.

Μπορείτε να χρησιμοποιήσετε τις ενσωματωμένες θύρες COM για τη λήψη (download) του λογισμικού Tech2 από ένα άλλο PC στο οποίο λειτουργεί το TIS. Βεβαιωθείτε ότι χρησιμοποιείτε καλώδιο RS232. Ανάλογα με τα μηχανικά μέρη (hardware) του Η/Υ στον οποίο λειτουργεί το Tech2Win, ο ρυθμός μεταφοράς δεδομένων μπορεί να χρειαστεί να μειωθεί στα 57.600 baud διότι τα Windows μπορεί να παρουσιάσουν απώλεια δεδομένων σε υψηλότερη ταχύτητα.

Η τελευταία έκδοση Tech2Win υποστηρίζει επίσης γρήγορη λήψη, όταν εκτελούνται τα TIS2Web και Tech2Win στον ίδιο υπολογιστή. Μια ελάχιστη επικοινωνία ανάμεσα στα TIS2Web και Tech2Win μέσω της θύρας COM εκτελείται ακόμη, αλλά η χρονοβόρα μεταφορά των δεδομένων στο Tech2Win έχει αντικατασταθεί από μια εσωτερική μεταφορά αρχείων. Σε μια τέτοια περίπτωση, ο χρόνος λήψης μειώνεται δραστικά σε πολύ λιγότερο του λεπτού.

  • Προηγμένα θέματα: Αρχείο παραμετροποίησης
  • Πρώτα βήματα: Περιβάλλον εργασίας επικοινωνίας οχήματος
  • Συχνές ερωτήσεις: Πώς μπορώ να καθορίσω ποια θύρα com πρέπει να χρησιμοποιήσω για το Tech2Win;
  • Συχνές ερωτήσεις: Επικοινωνία μεταξύ Tech2Win και TIS2Web


Ασφάλεια

Οι μηχανισμοί ασφαλείας που χρησιμοποιούνται από το Tech2Win βασίζονται στη σωστή ρύθμιση του ρολογιού του υπολογιστή. Βεβαιωθείτε ότι το ρολόι του υπολογιστή σας είναι πάντα σωστά ρυθμισμένο. Μικρές αλλαγές στο ρολόι που μπορεί να συμβούν κατά τη διάρκεια θερινής ώρας είναι ανεκτές από το Tech2Win.

Το Tech2Win δεν θα εκτελέσει καμία επικοινωνία με όχημα χωρίς έγκυρη και ενεργή άδεια χρήσης. Η ακόλουθη ένδειξη στη γραμμή κατάστασης δείχνει την κατάσταση της άδειας χρήσης:

  • green smiley Η άδεια χρήσης είναι έγκυρη.
  • Δεν εμφανίζεται ένδειξη: Η άδεια χρήσης δεν έχει ελεγχθεί ακόμη.
  • red smiley Η άδεια χρήσης έληξε.

Προκειμένου να λάβετε μία άδεια χρήσης, εκτελέστε μία ενημέρωση 'Πρόσβαση σε Λειτουργίες Ασφαλείας (Ασφάλεια)' μέσω της εφαρμογής TIS2Web. Στις περισσότερες περιπτώσεις, η λήψη λογισμικού μέσω TIS2Web θα είναι επίσης αρκετή για να πάρετε νέα άδεια χρήσης. Επειδή η άδεια χρήσης δεν θα είναι έγκυρη μετά από μια συγκεκριμένη χρονική περίοδο (σε ορισμένες περιοχές: τέσσερις εβδομάδες), πρέπει να εκτελείτε αυτή την ενημέρωση σε τακτά χρονικά διαστήματα.

Οι άδειες χρήσης είναι ειδικές ανάλογα με την περιοχή /το λογισμικό. Ενδέχεται να έχετε άδειες χρήσης στον υπολογιστή σας εάν χρησιμοποιείτε Tech2Win με διαφορετικές εκδόσεις λογισμικού Tech2.

Ο αριθμός των ημερών που υπολείπονται μέχρι τη λήξη της άδειας χρήσης εμφανίζεται στη γραμμή κατάστασης.

  • (0) Δείχνει ότι η άδεια χρήσης έχει λήξει ή δεν υπάρχει.
  • (<1) Η άδεια χρήσης θα λήξει εντός των επόμενων 24 ωρών.
  • (20) Η άδεια χρήσης θα λήξει σε 20 ημέρες.

Μην παραποιείτε το αρχείο άδειας χρήσης. Δόλιες τροποποιήσεις αυτού του αρχείου ανιχνεύονται με τη χρήση εσωτερικών μέτρων ασφαλείας και θα οδηγήσουν σε απώλεια όλων των αδειών χρήσης που υπάρχουν στον υπολογιστή. Επιπλέον, το Tech2Win θα δεν συμπεριφέρεται με τον αναμενόμενο τρόπο. Η κατάσταση αυτή μπορεί να αντιμετωπιστεί μόνο εκτελώντας νέα εγκατάσταση.

  • Προηγμένα θέματα: Μηνύματα σφάλματος και κωδικοί εξόδου
  • Προηγμένα θέματα: Αρχείο καταγραφής
  • Εργασία με το Tech2Win: Παράθυρο κατάστασης
  • Συχνές ερωτήσεις: Έγκυρη άδεια χρήσης
  • Συχνές ερωτήσεις: Ποια είναι η διαφορά μεταξύ της Άδειας Χρήσης του Tech2Win και της Πρόσβασης Ασφαλείας;
  • Συχνές ερωτήσεις: Ξαφνική διακοπή


Εμφάνιση αναφορών

View Report Μπορείτε να χρησιμοποιήσετε αυτό το κουμπί για να δείτε τα περιεχόμενα οποιωνδήποτε αρχείων PRT που υπάρχουν στην κάρτα PCMCIA. Θα ανοίξει ένα παράθυρο διαλόγου για να εμφανιστεί μια λίστα αρχείων PRT. Εάν κάποιο πρόγραμμα έχει συσχετιστεί με την προέκταση PRT, αυτό το συσχετισμένο πρόγραμμα θα εκτελεστεί. Διαφορετικά, θα ανοίξει το Notepad για να εμφανιστεί το επιλεγμένο αρχείο.

Στις περισσότερες περιπτώσεις, το αρχείο PRT είναι ένα αρχείο ASCII που χρησιμοποιεί τις κωδικοσελίδες κάθε γλώσσας. Για τα Κινέζικα, Ιαπωνικά, Κορεατικά και Ταϊλανδικά, το αρχείο είναι υπό μορφή unicode με Byte-Order-Mark (BOM) στην αρχή του αρχείου.

Όταν προβάλλετε αναφορές, το Tech2Win λειτουργεί με υποκατάλογο C:\Users\Public\General Motors\Tech2Win\reports. Αυτός ο υποκατάλογος υπάρχει μόνο εάν έχετε εμφανίσει αναφορές έστω και μία φορά. Ο κατάλογος διαγράφεται αυτόματα και λειτουργεί ως προσωρινός κατάλογος εργασίας για τα αρχεία PRT στην ενεργή κάρτα PCMCIA. Θα εξακολουθήσει να περιέχει αυτά τα αρχεία ακόμη κι αν το Tech2Win σταματήσει να εκτελείται. Εάν θέλετε να αποθηκεύσετε ένα τέτοιο αρχείο, θα χρειαστεί να το αντιγράψετε σε έναν διαφορετικό κατάλογο διότι μπορεί να αντικατασταθεί μόλις κάποιος άλλος χρήστης επιλέξει να εμφανίσει τις αναφορές.


Εικόνες PCMCIA

Οι εικόνες PCMCIA βρίσκονται φυσιολογικά στον υποκατάλογο C:\Users\Public\General Motors\Tech2Win\pcmcia. Το αρχείο πρέπει να έχει μέγεθος ακριβώς 32Mbyte (33.554.432 bytes) ή 10Mbyte (10.485.760 bytes) και προέκταση αρχείου *.bin. Οι εικόνες τροποποιούνται (όπως συμβαίνει με κάθε συνήθη κάρτα PCMCIA), σε περίπτωση λήψης (download) ή εάν το Tech2Win αποθηκεύσει δεδομένα στην κάρτα flash. Μπορείτε να απενεργοποιήσετε την τροποποίηση, χρησιμοποιώντας το διακόπτη προστασίας εγγραφής (εντολή -W0 ή -W1) ή παραλείποντας την τιμή 'p' στην επιλογή '-W'(Αρχείο παραμετροποίησης). Δεν είναι δυνατή η πρόσβαση στο διακόπτη προστασίας εγγραφής μέσω του ρυθμιστή. Θα χρειαστεί να τροποποιήσετε με μη αυτόματο τρόπο το αρχείο ρύθμισης παραμέτρων, εάν επιθυμείτε να χρησιμοποιήσετε τις επιλογές '-W0', '-W1' ή 'W'.


Γραμμή κατάστασης

Η γραμμή κατάστασης εμφανίζεται κάτω από την οθόνη Tech2. Τα παρακάτω στοιχεία εμφανίζονται στη γραμμή κατάστασης:

  1. Ένδειξη ταχύτητας
  2. Κατάσταση επικοινωνίας με το όχημα
  3. Κατάσταση σειριακής θύρας
  4. Πλήκτρο SHIFT
  5. Αυτόματα στιγμιότυπα οθόνης
  6. Προειδοποίηση καταγραφής
  7. Άδεια χρήσης

Status Bar

Ένδειξη ταχύτητας

Η ένδειξη ταχύτητας δείχνει πόσος χρόνος CPU δαπανάται κατά την προσομοίωση του λογισμικού Tech2. Ο μικρός αριθμός (ένδειξη στα αριστερά) είναι καλύτερος από ένα μεγάλο αριθμό (ένδειξη στα δεξιά). Οποιαδήποτε πράσινη ένδειξη είναι αποδεκτή. Η ένδειξη μπορεί να γίνει κίτρινη για ένα μικρό χρονικό διάστημα, εάν ενεργοποιηθεί κάποια διαφορετική εργασία των Windows. Τέτοιες δραστηριότητες πρέπει να αποφεύγονται.

Κατάσταση επικοινωνίας με το όχημα

Η κατάσταση επικοινωνίας του οχήματος δείχνει εάν υπάρχει Περιβάλλον Εργασίας Επικοινωνίας Οχήματος (MDI) καθώς και την επικοινωνία μεταξύ οχήματος και Tech2Win.

Κατάσταση σειριακής θύρας

Κατά την επικοινωνία ανάμεσα στο Tech2Win μέσω θύρας COM, αυτή η ένδειξη δείχνει εάν η επικοινωνία στη θύρα COM είναι ενεργή ή όχι.

Πλήκτρο SHIFT

Αυτός ο δείκτης δείχνει εάν το πλήκτρο SHIFT είναι ενεργό. Μπορείτε να το ενεργοποιείτε χρησιμοποιώντας το πλήκτρο 'S' του πληκτρολογίου ή το πλήκτρο SHIFT στο πληκτρολόγιο οθόνης.

Αυτόματα στιγμιότυπα οθόνης

Αυτόματα στιγμιότυπα μπορούν να ενεργοποιηθούν στο μενού Επιλογές. Κάθε φορά που η οθόνη αλλάζει, ένα νέο αρχείο στιγμιότυπου αποθηκεύεται στον κατάλογο αρχείου καταγραφής. Αυτό υποδεικνύεται από μία στροφή της μανιβέλας στην κόκκινη κάμερα που εικονίζεται στη γραμμή κατάστασης. Μόλις απενεργοποιηθούν τα αυτόματα στιγμιότυπα, η κάμερα εξαφανίζεται.

Προειδοποίηση καταγραφής

Η ένδειξη κατάστασης αρχείου καταγραφής μπορεί να υποδεικνύει τρεις διαφορετικές καταστάσεις.

  • gray log status indicator Το αρχείο καταγραφής δεν περιέχει προειδοποιήσεις ή σφάλματα.
  • yellow log status indicator Το αρχείο καταγραφής περιέχει προειδοποιητικό μήνυμα.
  • red log status indicator Το αρχείο καταγραφής περιέχει μήνυμα σφάλματος.

Άδεια χρήσης

Η ένδειξη άδειας χρήσης μπορεί να υποδεικνύει τρεις καταστάσεις:

  • green smiley Η άδεια χρήσης είναι ενεργή και έγκυρη.
  • Δεν εμφανίζεται ένδειξη: Η άδεια χρήσης δεν έχει ελεγχθεί ακόμη.
  • red smiley Η άδεια χρήσης έχει λήξει ή δεν υπάρχει.
Δείτε το σύνδεσμο Ασφάλεια για περισσότερες λεπτομέρειες.

Συμβουλές εργαλείου στη γραμμή κατάστασης

Για ορισμένα εικονίδια, εμφανίζονται συμβουλές εργαλείου για να σας παράσχουν πρόσθετες πληροφορίες:

Συμβουλή εργαλείου για σειριακό αριθμό VCI:
Tooltip VCI

Συμβουλή εργαλείου για έκδοση λογισμικού TECH2
Tooltip TECH2

Συμβουλή εργαλείου για θύρα Com
Tooltip Comport

Συμβουλή εργαλείου για έναν αριθμό του επόμενου στιγμιότυπου (εάν οι 'Αυτόματα στιγμιότυπα οθόνης' είναι ενεργοποιημένες)
Tooltip Camera

Συμβουλή εργαλείου που δείχνει την τελευταία καταχώρηση του αρχείου καταγραφής με επίπεδο 'προειδοποίηση' και πάνω
Tooltip Logfile

Συμβουλή εργαλείου για την ακριβή διάρκεια της άδειας χρήσης
Tooltip License

Οι συμβουλές εργαλείου εμφανίζονται εάν ο δρομέας παραμείνει περισσότερο από 0,5 δευτερόλεπτο πάνω σε ένα εικονίδιο χωρίς να μετακινηθεί. Οι συμβουλές εργαλείου εξαφανίζονται μετά από 5 δευτερόλεπτα ή όταν κινηθεί ο δρομέας.

  • Προηγμένα θέματα: Μηνύματα σφάλματος και κωδικοί σφάλματος
  • Προηγμένα θέματα: Αρχείο καταγραφής


Προηγμένα θέματα

Τα θέματα που αναλύθηκαν εδώ έχουν μικρότερη σημασία για τον τυπικό χρήστη του Tech2Win. Οποιοσδήποτε μετάσχει στην εγκατάσταση, τη διαχείριση και την παραμετροποίηση του Tech2Win μπορεί να βρει τις παρακάτω πληροφορίες χρήσιμες.

  • Επανεγκατάσταση
  • Απεγκατάσταση
  • Απευθείας τροποποίηση των αρχείων παραμετροποίησης
  • Αρχείο καταγραφής
  • Μηνύματα σφάλματος και κωδικοί εξόδου
  • Κάρτα ATA
  • Καταχωρήσεις μητρώου
  • Περιγραφή αρχείου
  • Παραδείγματα διαχείρισης παραμετροποίησης


Απεγκατάσταση

Ο πλήρης κατάλογος εγκατάστασης, ο κατάλογος που περιέχει τα δεδομένα χρήστη (C:\Users\Public\General Motors\Tech2Win) και ο κατάλογος που περιέχει τα δεδομένα εφαρμογών (C:\ProgramData\General Motors\Tech2Win) διαγράφονται.

  • Προηγμένα θέματα: Επανεγκατάσταση
  • Εγκατάσταση


Αρχείο παραμετροποίησης

Τα αρχεία ρύθμισης παραμέτρων βρίσκονται πάντα στον υποκατάλογο C:\Users\Public\General Motors\Tech2Win\config και φέρουν την επέκταση αρχείου *.conf. Μπορεί να αποφασίσετε να τροποποιήσετε το αρχείο παραμετροποίησης χειροκίνητα, καθώς δεν είναι όλες οι επιλογές αρχείου προσβάσιμες μέσω του Tech2Win. Το αρχείο παραμετροποίησης είναι αρχείο Unicode, στην αρχή του οποίου υπάρχει Byte-Order_Mark (BOM). Συνιστούμε να χρησιμοποιείτε έναν κειμενογράφο (editor) ο οποίος να μπορεί να επεξεργαστεί Unicode όπως το Notepad, όταν πραγματοποιείτε αλλαγές χειροκίνητα.

Το αρχείο παραμετροποίησης είναι διαμορφωμένο κατά σειρές. Οι άδειες σειρές παραβλέπονται. Μια σειρά αρχίζει πάντοτε με μια επιλογή και, συνήθως, ακολουθεί μια τιμή. Για παράδειγμα, ανατρέξτε στο αρχείο default.conf. Ανατρέξτε στον παρακάτω πίνακα, όπου παρατίθενται όλες οι διαθέσιμες επιλογές.

Εάν θέλετε να ανοίξετε ένα αρχείο ρύθμισης παραμέτρων απευθείας από την επιφάνεια εργασίας, δημιουργήστε μια συντόμευση που εκτελεί το 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Το πρόγραμμα πρέπει να εκτελεστεί από τον παρακάτω κατάλογο: 'C:\Program Files\General Motors\Tech2Win\bin'

επιλογή | Τιμή / Σημασία
; Σχόλιο
@ Δεκαδικός αριθμός έκδοσης υπό μορφή major.minor.
Αρχεία παραμετροποίησης με διαφορετικό αριθμό major από το Tech2Win δεν θα γίνονται αποδεκτά. Αρχεία παραμετροποίησης με μικρότερο αριθμό minor από το Tech2Win θα γίνονται αποδεκτά.
-W0
-W1 		Η κάρτα PCMCIA στην υποδοχή 0/1 διαθέτει έναν ενεργοποιημένο διακόπτη προστασίας εγγραφής.
-B0
-B1 		Το μέγεθος ομάδας δεδομένων σε Kbytes της κάρτας PCMCIA στην υποδοχή 0/1. Αποδεκτές τιμές είναι το 128 (προεπιλεγμένη) ή το 256.
-P0
-P1 		Το αρχείο που περιέχει τη δυαδική εικόνα της κάρτας PCMCIA για την υποδοχή 0/1. Το μέγεθος του αρχείου πρέπει να είναι ακριβώς 10MB ή 32MB. Οι μεταβλητές περιβάλλοντος, όπως %ProgramData%, επεκτείνονται.
Εάν αυτή η επιλογή δεν υπάρχει, η υποδοχή υποτίθεται ότι είναι κενή.
-A0
-A1 		Το αρχείο που περιέχει τις τιμές των χαρακτηριστικών της κάρτας PCMCIA στην υποδοχή 0/1. Εάν δεν υπάρχει, θα χρησιμοποιηθούν τα προεπιλεγμένα χαρακτηριστικά βάσει του μεγέθους της κάρτας και των ομάδων πληροφοριών.
-W | Κατά την έξοδο από το Tech2Win, όλα τα διατηρούμενα δεδομένα εγγράφονται στα αντίστοιχα αρχεία τους. Οι τιμές p/f/r/c μπορούν να συνδυαστούν για να υποδηλώσουν τα PCMCIA/Flash-ROM/RTC/CANDI-App αντίστοιχα.
-H | Λειτουργικότητα διαχείρισης σωρού Οι τιμές 0/r/w/t μπορούν να συνδυαστούν για την ενεργοποίηση Μηδενισμού, Ελέγχων ανάγνωσης, Ελέγχων εγγραφής και Ελέγχων εργασιών αντίστοιχα. Η τιμή I χρησιμοποιείται για να εξαναγκάζεται πάντα μία εκχώρηση μνήμης σωρού σε χαμηλότερες διευθύνσεις, καθώς υλοποιείται ένα εναλλακτικό σχέδιο εκχώρησης. Κανονικά, η επιλογή αυτή χρησιμοποιείται μόνο σε περιβάλλον ανάπτυξης.
-PC | Πρώην διαδρομή για αντιγραφή της κάρτας PCMCIA. Αυτή η επιλογή αυτήν τη στιγμή παραβλέπεται.
-MS | Αναγνώριση του Περιβάλλοντος Εργασίας Επικοινωνίας Οχήματος (MDI) με Σειριακό Αριθμό. Εάν δεν έχει ορισθεί, θα εμφανιστεί μία λίστα διαθέσιμων MDI για να επιλέξετε.
-CT | Το χρώμα του κειμένου (προσκήνιο) σε τιμές 3 δεκαεξαδικών byte. Η προεπιλεγμένη τιμή είναι 000000 (λευκό χρώμα).
-CB | Το χρώμα του φόντου σε τιμές 3 δεκαεξαδικών byte. Η προεπιλεγμένη τιμή είναι FFFFFF (μαύρο χρώμα).
-ATA | Χρησιμοποιήστε αυτή την επιλογή για να ενεργοποιήσετε μία κάρτα καταγραφής ΑΤΑ. Αφαιρέστε την για να απενεργοποιήσετε την κάρτα καταγραφής ΑΤΑ.
-C | Ο αριθμός της θύρας COM (1..9) που πρόκειται να χρησιμοποιηθεί ως η θύρα επικοινωνίας RS232C του Tech2. Συχνά η COM9 χρησιμοποιείται για την εικονική θύρα COM, η οποία εγκαθίσταται από το Tech2Win. Εάν αυτή η επιλογή δεν είναι παρούσα, εκτελείται μια αναζήτηση για ελεύθερη θύρα COM προς τα κάτω από το COM9. Χρησιμοποιήστε τη συμβουλή εργαλείου στη γραμμή κατάστασης μεταξύ του εικονιδίου Tech2 και του εικονιδίου TIS2Web για να δείτε ποια θύρα COM χρησιμοποιείται.
-WR | Μία διεύθυνση υπολογιστή (συνήθως 253558) στην οποία επιτρέπεται η εγγραφή στην PCMCIA και την περιοχή FLASH ROM. Αυτή η λειτουργία πρέπει να ενεργοποιηθεί επιπρόσθετα στο μενού (ή μέσω της επιλογής -WA). Πρέπει να εντοπιστούν σφάλματα κωδικού σε μη τροποποιήσιμη μνήμη μέσω του προγράμματος εντοπισμού σφαλμάτων ενός βήματος (SingleStep).
-WA | Επιτρέψτε στο πρόγραμμα εντοπισμού σφαλμάτων SingleStep να πραγματοποιήσει εγγραφή σε μη τροποποιήσιμη μνήμη.
-OF | Αρχείο επιλογών που περιέχει ζεύγη επιλογών / τιμών.
-TP | Ρύθμιση χρονισμού (Αναλογική τιμή). Προεπιλέγεται στο 5000. Μειώστε αυτή την τιμή ώστε να επιτευχθεί ταχύτερη προσαρμογή του αριθμού εκτελεσθέντων κύκλων σε πραγματικό χρόνο.
-TD | Ρύθμιση χρονισμού (Διαφορική τιμή). Προεπιλέγεται στο 100. Μειώστε αυτή την τιμή για ταχύτερη ανταπόκριση στις αλλαγές του στιγμιαίου χρονισμού. ΠΡΟΣΟΧΗ: Η παραποίηση των τιμών TP και TD μπορεί να οδηγήσει σε προβλήματα στην ταχύτητα.
-PJ
-PP 		Προσδιορίστε το πρωτόκολλο που πρέπει να χρησιμοποιηθεί:
PJ για επικοινωνία J2534.
PP για ISO22900-2 / PDU-API (προεπιλογή)
-S | Εάν αυτή η επιλογή υπάρχει, επιτρέπει την έξοδο ήχου στο βομβητή του Η/Υ.
-L | Η γλώσσα της εφαρμογής Tech2Win. Η ενεργή γλώσσα των Windows χρησιμοποιείται ως προεπιλογή εάν απουσιάζει αυτή η καταχώρηση. Ανατρέξτε στον παρακάτω σύνδεσμο για μια λίστα με τις γλώσσες που μπορούν να καθοριστούν: Γλώσσες. Το ίδιο το παράθυρο προσομοίωσης Tech2 θα εμφανίσει οποιαδήποτε γλώσσα υπάρχει στην κάρτα PCMCIA (δηλ. που έχετε κατεβάσει στην κάρτα PCMCIA).
-UD | Παράκαμψη του καταλόγου δεδομένων χρήστη. Στα Win7, η φυσιολογική θέση του είναι στο φάκελο C:\Users\Public\General Motors\Tech2Win
-AD | Παράκαμψη του καταλόγου δεδομένων εφαρμογής. Στα Win7, η φυσιολογική θέση του είναι στο φάκελο C:\ProgramData\General Motors\Tech2Win
-US | Χρησιμοποιήστε ένα συγκεκριμένο σηματοφορέα για την ανίχνευση περισσότερων από μία παρουσιών του Tech2Win. Αυτή η επιλογή θα επιτρέπει σε κάθε χρήστη να εκτελεί το Tech2Win παράλληλα στο ίδιο μηχάνημα, λογικά ένα διακομιστή. Όταν γίνεται χρήση της επιλογής αυτής, θα ορίσετε επίσης επιλογές -UD και -AD.
-SS | Επιλογή ορισμού του συνολικού μεγέθους του παραθύρου Tech2Win, συμπεριλαμβανομένου του πληκτρολογίου (αν υπάρχει). Η πρώτη παράμετρος πρέπει να είναι μια συμβολοσειρά που περιβάλλεται από διπλά εισαγωγικά (') και θα χρησιμοποιηθεί ως το όνομα του μεγέθους στο μενού Επιλογές / Ανάλυση. Η δεύτερη παράμετρος είναι ο συνολικός αριθμός οριζόντιων pixel της οθόνης Tech2Win, συμπεριλαμβανομένου του πληκτρολογίου. Η τρίτη παράμετρος είναι ο συνολικός αριθμός κάθετων pixel της οθόνης Tech2Win. Η τέταρτη, προαιρετική, παράμετρος είναι το πλάτος του πληκτρολογίου σε pixel.
-SH Επιλογή ελέγχου του χειρισμού οθόνης. Ο παρακάτω δεκαδικός αριθμός χρησιμοποιείται για τον ορισμό των δυνατοτήτων χειρισμού οθόνης που θα απενεργοποιηθούν.
  • Bit 0: Μη δυνατό ελάχ./μέγ..
  • Bit 1: Μη επανατοποθέτηση της οθόνης.
  • Bit 2: Μη αλλαγή μεγέθους. Σε αυτήν την περίπτωση, το μενού Επιλογές / Ανάλυση απενεργοποιείται.
  • Bit 3: Τα παράθυρα οθόνης δεδομένων και ΚΒΔΕ θα έχουν ακριβώς το ίδιο μέγεθος με το Tech2Win (χωρίς πληκτρολόγιο).


Καταγραφή

Κάθε φορά που γίνεται εκκίνηση της διαμόρφωσης Tech2Win δημιουργείται ένα νέο αρχείο καταγραφής σε μορφή HTML στον υποκατάλογο C:\Users\Public\General Motors\Tech2Win\. Για να αποφευχθεί ο κορεσμός του σκληρού δίσκου, αρχεία καταγραφής παλαιότερα από μία εβδομάδα διαγράφονται.

Τα αρχεία καταγραφής ονοματίζονται αυτόματα με βάση την ημερομηνία (έτος, μμήνας, ημέρα) και την ώρα (ώρα, λεπτά, δευτερόλεπτα) που δημιουργήθηκαν:
εεεε-μμ-ηη_ωωλλδδ.html

Οι καταχωρήσεις στο αρχείο καταγραφής είναι πάντοτε στα Αγγλικά, αλλά υπό μορφή Unicode με Byte-Order-Mark (BOM) στην αρχή του αρχείου. Σε κάθε σειρά στο αρχείο καταγραφής υπάρχει ένα από τα ακόλουθα επίπεδα καταγραφής:

Επίπεδο καταγραφής | Σημασία
Πληροφ. | Μόνο πληροφορίες. Δεν επηρεάζει την εκτέλεση του προγράμματος.
Προειδοποίηση | Έχει σημειωθεί μια ασυνήθιστη κατάσταση. Ο χρήστης μπορεί να μην παρατηρήσει τυχόν αρνητικές συνέπειες.
ERROR | Σημειώθηκε σφάλμα το οποίο θα γίνει αντιληπτό από το χρήστη.
CRITICAL | Σημειώθηκε σοβαρό σφάλμα το οποίο θα προκαλέσει τη μη φυσιολογική συμπεριφορά του προγράμματος.
FATAL | Κάποιο σφάλμα που δεν επιδέχεται διόρθωση θα αναγκάσει το Tech2Win να διακόψει αυτόματα τη λειτουργία του.

Όλα τα επίπεδα πάνω από το επίπεδο 'Προειδοποίηση' εμφανίζονται έγχρωμα, ώστε να μπορούν να εντοπιστούν εύκολα.

Επιπλέον, θα εμφανιστούν επίσης αρχεία Εκτύπωσης και Βίντεο στον υποκατάλογο Logs εάν χρησιμοποιήθηκε η επιλογή μενού Εκτυπώστε την οθόνη ή η Αυτόματα στιγμιότυπα οθόνης.
εεεε-μμ-ηη_ωωλλδδ_print_nnnnn.bmp
εεεε-μμ-ηη_ωωλλδδ_video_nnnnn.png
Οι εικόνες Αυτόματα στιγμιότυπα οθόνης συνδέονται μέσω του αρχείου HTML - επομένως χρησιμοποιήστε το αρχείο καταγραφής HTML για να προβάλλετε την ακολουθία αυτών των εικόνων.

Στη γραμμή κατάστασης, ο χρήστης ενημερώνεται εάν υπάρχει κάποια καταχώρηση προειδοποίησης ( yellow lightning bolt) ή άλλη πιο σοβαρή καταγραφή ( red lightning bolt).


Μηνύματα σφάλματος και κωδικοί εξόδου

Τα μηνύματα σφάλματος ενδέχεται να εμφανίζονται σε παράθυρα διαλόγου. Αυτά τα παράθυρα διαλόγου εξακολουθούν να επιτρέπουν στο Tech2Win να εκτελεί το πρόγραμμα Tech2 παράλληλα. Οι κωδικοί εξόδου είναι σφάλματα που δεν επιδέχονται διόρθωση τα οποία αναγκάζουν το Tech2Win να τερματίσει τη λειτουργία του μη φυσιολογικά. Οι κωδικοί εξόδου μπορούν να χρησιμοποιηθούν σε αρχεία για να εντοπιστεί ποιου προγράμματος η λειτουργία τερματίστηκε.

Μηνύματα σφάλματος

Μπορεί να εμφανιστούν τα παρακάτω μηνύματα σφάλματος. Ακολουθεί μια σύντομη επεξήγηση της κατάστασης και πώς το πρόβλημα μπορεί να αντιμετωπιστεί.

Emulator too slow Emulator failed to start

Κωδικοί εξόδου

Κωδικός εξόδου | Τιμή | Σημασία
OPCODE_ERROR | -7 | Ανιχνεύτηκε μη αποδεκτή εντολή του μικροεπεξεργαστή του Tech2 (68332). Πιθανόν η εικόνα PCMCIA να έχει αλλοιωθεί με κάποιο τρόπο.
ATA_PROBLEM | -6 | Σημειώθηκε πρόβλημα κατά την προσομοίωση ATA. Εάν παρατηρήσετε τέτοιο πρόβλημα αφότου σας ζητηθεί να χρησιμοποιήσετε την κάρτα ATA, απευθυνθείτε στο τμήμα τεχνικής εξυπηρέτησης.
DEMO_TIME_IS_UP | -5 | Δεν πρέπει να εμφανίζεται στην επίσημη έκδοση του Tech2Win.
DLL_NOT_LOADED | -3 | Η φόρτωση ενός από τα απαραίτητα DLL δεν ήταν εφικτή. Απ' ό,τι φαίνεται το αντίγραφο του Tech2Win που έχετε δεν είναι πλήρες. Πραγματοποιήστε νέα εγκατάσταση ή/και επιλέξτε μια διαφορετική γλώσσα.
EXIT_INIT_FAILED | -2 | Η διαδικασία προετοιμασίας απέτυχε. Αναζητήστε στο αρχείο καταγραφής την ακριβή αιτία. Εάν δεν υπάρχει αρχείο καταγραφής, ελέγξτε εάν έχετε τη σωστή πρόσβαση ανάγνωσης/εγγραφής σε όλους τους καταλόγους.
κανονική | 0 | Η λειτουργία του Tech2Win τερματίστηκε κανονικά.


Κάρτα ATA

Η κάρτα ATA στο Tech2 γενικά χρησιμοποιείται μόνο για λόγους διόρθωσης σφαλμάτων κατά το σχεδιασμό του λογισμικού. Όλα τα απαραίτητα δεδομένα ATA αποθηκεύονται στον υποκατάλογο C:\Users\Public\General Motors\Tech2Win\ataCapture. Ο κατάλογος αυτός συνήθως δεν είναι σημαντικός και μπορείτε να τον διαγράψετε με ασφάλεια εκτός εάν υπάρχουν σαφείς αντίθετες οδηγίες.

Επειδή ο κατάλογος ataCapture είναι σταθερός, τα περιεχόμενά του θα είναι ίδια για όλες τις παραμετροποιήσεις.


Αρχεία

Τα παρακάτω αρχεία και οι κατάλογοι χρησιμοποιούνται από το Tech2Win:

Κατάλογος | Θέση πριν τα Vista | Θέση για Vista και νεότερες εκδόσεις
Εγκατάσταση | Όπως ορίζεται κατά την εγκατάσταση
Δεδομένα χρήστη | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Δεδομένα εφαρμογών | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Αρχείο | Χρήση
[Δεδομένα χρήστη]\atacapture | Περιέχει αρχεία που υπάρχουν στην κάρτα ΑΤΑ. Εάν δεν υπάρχουν διαφορετικές οδηγίες αυτά τα αρχεία δεν είναι απαραίτητα.
[Εγκατάσταση]\bin | Περιέχει τα τρέχοντα εκτελέσιμα αρχεία και τα απαραίτητα αρχεία DLL και τις εικόνες που απαιτούνται για την εκτέλεση.
[Εγκατάσταση]\bin\emulator.exe | Το κύριο εκτελέσιμο αρχείο που εκτελεί τον κώδικα του Tech2.
[Εγκατάσταση]\bin\emulator_xx_XX.dll | Ειδικό για τη γλώσσα αρχείο DLL πόρων.
[Εγκατάσταση]\bin\T2Configurator.exe | Το τμήμα ρυθμίσεων του Tech2Win.
[Εγκατάσταση]\bin\Pictures | Περιέχει τα εικονίδια που απαιτούνται από το Tech2Win.
[Δεδομένα χρήστη]\config | Περιέχει όλα τα αρχεία ρύθμισης παραμέτρων.
[Δεδομένα χρήστη]\data | Περιέχει αρχεία που τροποποιούνται κατά τη λειτουργία του Tech2Win. Αυτά τα αρχεία είναι απαραίτητα για τη σωστή λειτουργία του Tech2Win. Συνήθως, δεν χρειάζεται να ασχοληθείτε με αυτά τα αρχεία εκτός εάν υπάρχουν σαφείς οδηγίες να κάνετε κάτι τέτοιο.
[Δεδομένα εφαρμογών]\data | Περιέχει αρχεία που τροποποιούνται κατά τη λειτουργία του Tech2Win. Αυτά τα αρχεία είναι απαραίτητα για τη σωστή λειτουργία του Tech2Win. Συνήθως, δεν χρειάζεται να ασχοληθείτε με αυτά τα αρχεία εκτός εάν υπάρχουν σαφείς οδηγίες να κάνετε κάτι τέτοιο.
[Δεδομένα εφαρμογών]\data\emulator.sec | Αρχείο ασφάλειας . Μην τροποποιείτε αυτό το αρχείο.
[Δεδομένα εφαρμογών]\data\emulator.card | Αρχείο κάρτας. Περιέχει όλες τις κάρτες PCMCIA που αναγνωρίζει το πρόγραμμα Tech2Win. Μην τροποποιείτε αυτό το αρχείο.
[Δεδομένα χρήστη]\data\emulator.disp | Αυτό το αρχείο περιέχει τη θέση και το μέγεθος της οθόνης του Tech2Win. Εάν διαγράψετε αυτό το αρχείο, θα δημιουργηθεί ξανά και η οθόνη του Tech2Win θα εμφανιστεί στην επάνω αριστερή γωνία σε διαστάσεις 640x480.
[Δεδομένα εφαρμογών]\data\emulator.lic | Αρχείο άδειας χρήσης. Περιέχει πληροφορίες σχετικά με τη διάρκεια εγκυρότητας των αδειών χρήσης που κατέχετε. Μην τροποποιείτε αυτό το αρχείο.
[Δεδομένα εφαρμογών]\data\emulator.rtc | Αρχείο ρολογιού πραγματικού χρόνου. Το αρχείο αυτό χρησιμοποιείται για την αποθήκευση των δεδομένων που βρίσκονται στο RTC του Tech2.
[Δεδομένα εφαρμογών]\data\emulator.dta | Ένα αρχείο 'Να μην ενημερωθώ ξανά'.. Αυτό το αρχείο αποθηκεύει εκδόσεις λογισμικών PCMCIA που δεν εμφανίζουν (πια) την προειδοποίηση σχετικά με την αδυναμία εκτέλεσης αυτοδιαγνωστικού ελέγχου που απαιτεί προσαρμογέα βρόχου επιστροφής.
[Δεδομένα εφαρμογών]\data\candi.bin | Αρχείο εφαρμογής CANdi. Περιέχει την εφαρμογή του CANdi, το οποίο είναι συνδεδεμένο στο Tech2.
[Δεδομένα εφαρμογών]\data\eprom.bin | Αρχείο εσωτερικής EPROM του Tech2. Περιέχει τα περιεχόμενα της εσωτερικής μνήμης flash του Tech2.
[Εγκατάσταση]\driver | Αρχεία εγκατάστασης για το πρόγραμμα οδήγησης εικονικής θύρας COM.
[Εγκατάσταση]\help\emulator_xx_XX.chm | Αρχεία βοήθειας ειδικά για κάθε γλώσσα.
[Δεδομένα χρήστη]\Logs | Περιέχει αρχεία καταγραφής. Αρχεία παλαιότερα από μία εβδομάδα θα διαγραφούν αυτόματα.
[Δεδομένα χρήστη]\pcmcia | Περιέχει αρχεία εικόνας PCMCIA. Με τη μεταφορική έννοια της λέξης, κάθε αρχείο αντιστοιχεί σε μια κάρτα PCMCIA του Tech2. Μπορείτε να αποθηκεύσετε τα αρχεία αυτά σε διαφορετικά σημεία, όπως σας εξυπηρετεί.


Διαχείριση ρυθμίσεων

Τα αρχεία ρύθμισης παραμέτρων βρίσκονται πάντα στον υποκατάλογο C:\Users\Public\General Motors\Tech2Win\config και φέρουν την επέκταση αρχείου *.conf. Το Tech2Win μπορεί να χρησιμοποιηθεί μόνο για τη δημιουργία νέων αρχείων παραμετροποίησης ή για την τροποποίηση των υπαρχόντων αρχείων παραμετροποίησης που δεν είναι μόνο για ανάγνωση (readonly). Για όλη την υπόλοιπη διαχείριση των αρχείων παραμετροποίησης, χρησιμοποιήστε τον Windows Explorer ή παρόμοιο πρόγραμμα διαχείρισης αρχείων. Αυτό θα χρειαστεί για τις παρακάτω δραστηριότητες:

  • διαγραφή αρχείων παραμετροποίησης
  • μετονομασία αρχείων παραμετροποίησης
  • αλλαγή του χαρακτηριστικού 'μόνο για ανάγνωση' ενός αρχείου παραμετροποίησης

Συνιστούμε να έχετε πάντοτε ένα αρχείο παραμετροποίησης default.conf. Σε αυτό το αρχείο, το χαρακτηριστικό 'μόνο για ανάγνωση' πρέπει κανονικά να είναι ενεργοποιημένο για να αποφευχθεί η ακούσια αντικατάσταση του αρχείου. Ωστόσο, εάν πρόκειται να αλλάξετε αυτό το αρχείο ώστε να πληροί τις συγκεκριμένες ανάγκες σας, θα πρέπει να αποεπιλέξετε για λίγο το χαρακτηριστικό 'μόνο για ανάγνωση'.

Οι εικόνες PCMCIA βρίσκονται στον υποκατάλογο C:\Users\Public\General Motors\Tech2Win\pcmcia. Κάθε ένα από αυτά τα αρχεία αντιστοιχεί σε μια κάρτα PCMCIA την οποία γνωρίζετε από την ενασχόλησή σας με το Tech2. Με το Tech2Win μπορείτε να έχετε όσες εικόνες επιθυμείτε. Απλώς αντιγράψτε μια υπάρχουσα εικόνα σε ένα νέο όνομα αρχείου.

Εάν θέλετε να ανοίξετε ένα αρχείο ρύθμισης παραμέτρων απευθείας από την επιφάνεια εργασίας, δημιουργήστε μια συντόμευση που εκτελεί το "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Το πρόγραμμα πρέπει να εκτελεστεί από τον παρακάτω κατάλογο: 'C:\Program Files\General Motors\Tech2Win\bin'

Ο αριθμός των αρχείων παραμετροποίησης δεν εξαρτάται από τον αριθμό των εικόνων pcmcia που χρησιμοποιείτε. Μπορείτε να έχετε αρκετά αρχεία παραμετροποίησης να χρησιμοποιούν την ίδια εικόνα PCMCIA. Πρόκειται για μια κατάσταση αντίστοιχη ενός συνεργείου όπου αρκετοί τεχνικοί χρησιμοποιούν το ίδιο Tech2 (και την ίδια κάρτα PCMCIA).

Μπορείτε επίσης να επιλέξετε κάθε παραμετροποίηση να χρησιμοποιεί τη δική της συγκεκριμένη εικόνα PCMCIA. Με αυτό τον τρόπο, κάθε μεμονωμένη παραμετροποίηση θα ήταν πιο ανεξάρτητη από τις υπόλοιπες. Ωστόσο, η προσπάθεια ενημέρωσης κάθε εικόνας PCMCIA μπορεί να μην ήταν αποδεκτή.

Όταν πραγματοποιείτε μια νέα ρύθμιση παραμέτρων αντιγράφοντας μια υπάρχουσα, ο ρυθμιστής θα εμφανίζει μια προειδοποίηση, αν η εικόνα PCMCIA δεν έχει αλλάξει. Σε μια τέτοια περίπτωση, θα χρειαστείτε δύο ρυθμίσεις που χρησιμοποιούν την ίδια εικόνα PCMCIA. Εάν αυτό επιθυμείτε, απλά πατήστε OK. Εάν επιθυμείτε η νέα ρύθμιση παραμέτρων να χρησιμοποιεί διαφορετική ή νέα εικόνα PCMCIA, τότε πατήστε Ακύρωση. Μπορείτε έπειτα να επιλέξετε δημιουργία νέας εικόνας, χρησιμοποιώντας την επιλογή Αντιγραφή κάρτας μνήμης ...

Παρακάτω ακολουθούν δύο ενδεικτικές μέθοδοι πώς μπορείτε να διαχειριστείτε τις παραμετροποιήσεις σας και τις εικόνες PCMCIA.

Μία παραμετροποίηση ανά χρήστη

Μπορείτε να αποθηκεύσετε ρυθμίσεις ανά χρήστη. Μπορείτε να ονομάσετε τις ρυθμίσεις με το όνομα του εκάστοτε χρήστη, για παράδειγμα. Πλεονέκτημα αυτής της ιδέας είναι ότι υπάρχει δυνατότητα χρήσης ρυθμίσεων χρήστη, όπως ρυθμίσεις προσωπικών περιβάλλοντων εργασίας επικοινωνίας οχήματος (MDI) ή ρυθμίσεις οθόνης και γλώσσας. Το μειονέκτημα είναι ότι θα χρειαστεί να αντιγράψετε αρχεία PCMCIA εάν πρόκειται να χρησιμοποιηθεί το ίδιο λογισμικό από αρκετούς χρήστες. Φυσικά, για τις ρυθμίσεις παραμέτρων κάθε χρήστη μπορεί να χρησιμοποιηθεί ένα κεντρικό αρχείο PCMCIA.

Μία παραμετροποίηση ανά λογισμικό Tech2

Μπορείτε να επιλέξετε να κάνετε νέες ρυθμίσεις για κάθε λογισμικό που λαμβάνετε. Επομένως, ακόμη και παλαιότερες εκδόσεις λογισμικού είναι άμεσα διαθέσιμες, εάν χρειάζεται. Σ' αυτή την περίπτωση, για την ονομασία των ρυθμίσεων χρησιμοποιείται συχνά το όνομα και ο αριθμός έκδοσης του λογισμικού.

  • Πρώτα βήματα: Περιβάλλον εργασίας επικοινωνίας οχήματος
  • Πρώτα βήματα: Διαδρομή
  • Προηγμένα θέματα: Αρχείο παραμετροποίησης
  • Εγκατάσταση: Βήματα εγκατάστασης


Συνήθεις ερωτήσεις

  • Πώς μπορώ να καθορίσω ποια θύρα com πρέπει να χρησιμοποιήσω για το Tech2Win;
  • Επικοινωνία μεταξύ Tech2Win και TIS2Web
  • Έγκυρη άδεια χρήσης
  • Τι δείχνει ο αριθμός Άδειας Χρήσης;
  • Ποια είναι η διαφορά μεταξύ της Άδειας Χρήσης του Tech2Win και της Πρόσβασης Ασφαλείας;
  • Το TIS2Web εμφανίζει ένα γενικό σφάλμα όταν επιχειρηθεί πρόσβαση ασφαλείας στο Αρχικό Λογισμικό.
  • Το Tech2 δεν εκτελεί το λογισμικό Tech2 από άλλη περιοχή
  • Πώς μπορώ να χρησιμοποιήσω περισσότερες από μία MDI;
  • Το αρχείο καταγραφής περιέχει το σφάλμα 'CPU32: Too many 0000/FFFF Commands encountered'
  • Δεν υπάρχει ορατό παράθυρο Tech2
  • Το SPS δεν λειτουργεί
  • Ορισμένοι αυτοδιαγνωστικοί έλεγχοι δεν λειτουργούν
  • Ο δείκτης ταχύτητας παρουσιάζει διακυμάνσεις
  • Ξαφνική διακοπή
  • Η γλώσσα που εμφανίζεται για το Λογισμικό 15.001 είναι τα Σουηδικά
  • Απώλεια επικοινωνίας με την MDI
  • Το Tech2Win δεν βρήκε την MDI που χρησιμοποιώ
  • Θέλω να αρχίσει αμέσως το TIS2Win χωρίς να ασχοληθώ με το πρόγραμμα ρύθμισης παραμέτρων
  • Πού βρίσκονται οι λειτουργίες εκτύπωσης;
  • Ένας μη χρησιμοποιημένος φάκελος PCMCIA βρίσκεται στον υπολογιστή μου.
  • Λαμβάνω ένα μήνυμα 'μη έγκυρη διαδρομή αρχείου'

Πώς μπορώ να καθορίσω ποια θύρα com πρέπει να χρησιμοποιήσω για το Tech2Win;

Μπορείτε να χρησιμοποιήσετε τη 'Διαχείριση Συσκευών' των Windows, αναζητήστε 'Θύρες (COM & LPT)'. Αλλά ορισμένοι υπολογιστές έχουν εγκατεστημένα εσωτερικά μόντεμ ή συσκευές bluetooth που δεν εμφανίζονται σ' αυτή την κατηγορία.
Εναλλακτικά μπορείτε να χρησιμοποιήσετε μία μικρή εντολή που παρέχεται μαζί με το διαμορφωτή. Μπορείτε να την εκτελέσετε μέσω του μενού έναρξης (φάκελος Tech2Win) κάνοντας κλικ στο 'show com ports'.
Και οι δύο μέθοδοι εμφανίζουν τις θύρες com που είναι εγκατεστημένες στον υπολογιστή σας και ΔΕΝ πρέπει να χρησιμοποιηθούν.

Επικοινωνία μεταξύ Tech2Win και TIS2Web

Είναι σημαντικό να είναι σε λειτουργία το Tech2Win πριν ξεκινήσετε την επικοινωνία με το TIS2Web για ασφαλή πρόσβαση ή λήψη του λογισμικού. Το TIS2Web μπορεί να αναγνωρίσει μόνο την εικονική θύρα COM μετά την εκκίνηση του Tech2Win.

Έγκυρη άδεια χρήσης

Συνήθως, η λήψη λογισμικού από το TIS2Web θα σας δώσει μία έγκυρη άδεια χρήσης. Αν δεν έχετε άδεια, πρέπει να πραγματοποιήσετε 'Πρόσβαση σε Λειτουργίες Ασφαλείας (Ασφάλεια)' μέσω του TIS2Web και (όχι μέσω του TIS2000) για να πάρετε έγκυρη άδεια χρήσης. Μην εκτελείτε οποιαδήποτε άλλη επικοινωνία TIS2Web με το Tech2Win, όπως 'Λήψη Λογισμικού (SWDL)', πριν να λάβετε μία άδεια χρήσης μέσω 'Πρόσβαση σε Λειτουργίες Ασφαλείας (Ασφάλεια)'.

Τι δείχνει ο αριθμός Άδειας Χρήσης;

Ο αριθμός Άδειας Χρήσης στη δεξιά πλευρά της γραμμής κατάστασης δείχνει τον αριθμό των ημερών της άδειας χρήσης που έχουν συμπληρωθεί. Αμέσως μόλις εκτελέσετε λήψη ή πρόσβαση ασφαλείας θα εμφανιστεί ο αριθμός 30 ημερών. Μετά από νέα εκκίνηση του Tech2Win, ωστόσο, θα εμφανιστεί ο αριθμός 29, επειδή η διάρκεια της Άδειας Χρήσης είναι περίπου 29 ημέρες, 23 ώρες και 55 λεπτά. Εάν ο αριθμός ημερών της Άδειας Χρήσης πέσει κάτω από 24 ώρες, εμφανίζεται διάρκεια Άδειας Χρήσης <1. Ο αριθμός 0 εμφανίζεται εάν η Άδεια Χρήσης έχει λήξει.

Ποια είναι η διαφορά μεταξύ της Άδειας Χρήσης του Tech2Win και της Πρόσβασης Ασφαλείας;

Η Άδεια Χρήσης του Tech2Win σας επιτρέπει να χρησιμοποιήσετε το Tech2Win. Για να πάρετε μια τέτοια άδεια χρήσης πρέπει να πραγματοποιείτε είτε λήψη λογισμικού είτε πρόσβαση ασφαλείας ανά τακτά διαστήματα (συνηθέστερο διάστημα: κάθε 30 ημέρες). Η δυνατότητα εκτέλεσης τέτοιας λήψης μέσω του TIS2Web πληροφορεί το Tech2Win ότι υπάρχει έγκυρος χρήστης. Η Πρόσβαση Ασφαλείας, όπως είναι γνωστό από το Tech2, πληροφορεί το Tech2Win ότι ορισμένες ενέργειες που σχετίζονται με την ασφάλεια, όπως η απενεργοποίηση αερόσακου, επιτρέπονται. Τόσο η Άδεια Χρήσης του Tech2Win όσο και η Πρόσβαση Ασφαλείας μπορούν να πραγματοποιηθούν μέσω της εφαρμογής Πρόσβασης Ασφαλείας του TIS2Web. Το Tech2Win εμφανίζει την υπολειπόμενη διάρκεια ισχύος της Άδειας Χρήσης στη γραμμή κατάστασης στα δεξιά. Δυστυχώς, το Tech2Win δεν μπορεί να εμφανίσει τη διάρκεια μιας Πρόσβασης Ασφαλείας καθώς το Tech2Win απλώς εκτελεί το λογισμικό Tech2, αλλά δεν κατανοεί το ίδιο το λογισμικό Tech2.

Το TIS2Web εμφανίζει ένα γενικό σφάλμα όταν επιχειρηθεί πρόσβαση ασφαλείας στο Αρχικό Λογισμικό.

Η συμπεριφορά είναι ίδια με αυτή του Tech2. Λόγω της ηλικίας του, το Αρχικό Λογισμικό δεν μπορεί να λάβει άδεια από το TIS2Web. Ωστόσο, αυτό δεν αποτελεί πραγματικό πρόβλημα καθώς το λογισμικό επίδειξης δεν επικοινωνεί με όχημα για το οποίο απαιτείται άδεια χρήσης. Και επειδή οι άδειες χρήσης είναι ειδικές για κάθε λήψη TS2Web, θα έπρεπε ούτως ή άλλως να εξασφαλίζατε άδεια χρήσης για κάθε λήψη μετά τη λήψη (download) του λογισμικού Tech2. Μια 'άδεια χρήσης' για το Αρχικό Λογισμικό δεν θα σας έδινε τη δυνατότητα να συνάψετε επικοινωνία του οχήματος με λογισμικό North American Operations ή λογισμικό Opel/Vauxhall.

Το Tech2 δεν εκτελεί το λογισμικό Tech2 από άλλη περιοχή

Η έκδοση του Tech2Win που χρησιμοποιείτε ίσως έχει περιορισμό χρήσης σε μία ή περισσότερες λήψεις TIS2Web (περιοχές). Πατήστε Βοήθεια / Πληροφορίες για να δείτε τους περιορισμούς που ισχύουν για την έκδοση Tech2Win που χρησιμοποιείτε. Οι αρχικές εκδόσεις του Tech2Win επέτρεπαν την εκτέλεση μόνο λογισμικού Opel/Vauxhall. Άλλες περιοχές GM θα ακολουθήσουν. Σε κάθε περίπτωση, το Tech2Win μπορεί προς το παρόν να εκτελεί λογισμικό Tech2 από τη General Motors.

Πώς μπορώ να χρησιμοποιήσω περισσότερες από μία MDI;

Εάν θέλετε να εκχωρήσετε συγκεκριμένες MDI σε συγκεκριμένους χρήστες τότε σας προτείνουμε να αφήσετε κάθε χρήστη να έχει τις δικές του ρυθμίσεις. Προφανώς, οι ρυθμίσεις αυτές θα πρέπει να ονομαστούν ανάλογα με τον αντίστοιχο χρήστη τους. Σε κάθε μία από τις ρυθμίσεις θα πρέπει να πληκτρολογήσετε το σειριακό αριθμό της MDI του συγκεκριμένου χρήστη στην καρτέλα 'Περιβάλλον εργασίας επικοινωνίας οχήματος'. Μόλις ο χρήστης ξεκινήσει τις ρυθμίσεις του, το Tech2Win θα επιχειρήσει να επικοινωνήσει με τη συγκεκριμένη MDI. Μόνο εάν αυτή η MDI δεν είναι παρούσα, θα εμφανιστεί ένα πλαίσιο επιλογής που θα δείχνει όλες τις MDI που μπόρεσε να βρει το Tech2Win.

Εάν έχετε πολλές MDI για γενική χρήση σας προτείνουμε να χρησιμοποιήσετε ρυθμίσεις στις οποίες ο σειριακός αριθμός του περιβάλλοντος εργασίας επικοινωνίας οχήματος στην καρτέλα 'Περιβάλλον εργασίας επικοινωνίας οχήματος' έχει αφεθεί κενός. Τότε ο χρήστης θα βλέπει πάντα το πλαίσιο επιλογής διαθέσιμων MDI.

Το αρχείο καταγραφής περιέχει το σφάλμα 'CPU32: Too many 0000/FFFF Commands encountered'

Το αρχείο 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' ή το τρέχον αρχείο pcmcia είναι κατεστραμμένο. Επανεγκαταστήστε το Tech2Win και πραγματοποιήστε λήψη νέου λογισμικού Tech2.

Δεν υπάρχει ορατό παράθυρο Tech2

Εάν δεν υπάρχει ορατό παράθυρο Tech2 ενδεχομένως να βρίσκεται σε περιοχή που δεν εμφανίζεται αυτή τη στιγμή στην οθόνη σας. Παρόμοια προβλήματα θα αντιμετωπίσετε όταν χρησιμοποιείτε περισσότερες από μία οθόνες ή μετά από τροποποίηση της ανάλυσης της οθόνης. Πατήστε το πλήκτρο Shift στο πληκτρολόγιο κατά την έναρξη των ρυθμίσεων. Σ' αυτή την περίπτωση η ανάλυση του παραθύρου θα επαναρυθμιστεί στα 640x480 και το παράθυρο Tech2 θα εμφανιστεί στην επάνω αριστερή γωνία της οθόνης. Μπορείτε, επίσης, να διαγράψετε το αρχείο C:\Users\Public\General Motors\Tech2Win\emulator.disp για να επιτύχετε το ίδιο αποτέλεσμα.

Έχουμε δει περιπτώσεις όπου το παράθυρο του Tech2 δεν μπορεί να τραβηχτεί πάλι στην οθόνη αφού κλείσετε τα παράθυρα όλων των άλλων εφαρμογών. Σε όλες τις περιπτώσεις που έχουμε δει μέχρι στιγμής, η χρήση του πλήκτρου Alt-Tab για την εναλλαγή μεταξύ εφαρμογών Windows επανέφερε το παράθυρο Tech2. Το πλήκτρο Tech2Win στη γραμμή εργασίας στην κάτω πλευρά της οθόνης του υπολογιστή σας μερικές φορές ενδέχεται να μη λειτουργεί όταν το πατήσετε. Προς το παρόν ερευνούμε αυτό το πρόβλημα και ελπίζουμε ότι θα το έχουμε διορθώσει σε επόμενη έκδοση του Tech2Win.

Το SPS δεν λειτουργεί

Ναι, το ξέρουμε. Αυτό δεν σχεδιάζουμε να το αλλάξουμε. Δεν πρέπει να χρησιμοποιείτε το Tech2Win ως υποκατάστατο του Tech2 για να κάνετε SPS. Χρησιμοποιήστε τον κατάλογο MDI με τον Προγραμματισμό SPS μέσω TIS.

Ορισμένοι αυτοδιαγνωστικοί έλεγχοι δεν λειτουργούν

Οι αυτοδιαγνωστικοί έλεγχοι του Tech2 προορίζονται για έλεγχο μεμονωμένων τμημάτων του υλικού Tech2. Ορισμένοι από αυτούς τους ελέγχους απαιτούν τη χρήση προσαρμογέα βρόχου επιστροφής. Οι έλεγχοι αυτοί δεν θα λειτουργήσουν στο Tech2Win γιατί η λειτουργία του προσαρμογέα βρόχου επιστροφής δεν έχει ενσωματωθεί (και δεν υπάρχει πρόγραμμα για κάτι τέτοιο). Απλώς αποφεύγετε τη διενέργεια τέτοιων άσκοπων ελέγχων στο Tech2Win. Εάν εκτελέσετε αυτούς τους ελέγχους ενδέχεται να πάρετε εσφαλμένα αποτελέσματα ή το Tech2Win ενδέχεται να πάψει να ανταποκρίνεται όπως θα συνέβαινε με το Tech2 χωρίς προσαρμογέα βρόχου επιστροφής. Σ' αυτή την περίπτωση χρησιμοποιήστε το Ctrl-R για να επανεκκινήσετε το Tech2Win.

Ο δείκτης ταχύτητας παρουσιάζει διακυμάνσεις

Ο δείκτης ταχύτητας στην κάτω αριστερή πλευρά της γραμμής κατάστασης δείχνει πόσες 'εντολές Tech2' μπορούν να εκτελεστούν προτού το Tech2Win πρέπει να περάσει σε ξανά 'νάρκη'. Η μέθοδος αυτή χρησιμοποιείται για να διασφαλίσει ότι ο χρόνος στο Tech2Win αντιστοιχεί στον πραγματικό χρόνο: ταχύτεροι υπολογιστές παραμένουν σε νάρκη περισσότερο απ' ό,τι υπολογιστές που λειτουργούν με πιο αργό ρυθμό. Εάν ο δείκτης ταχύτητας παρουσιάζει διακυμάνσεις, τότε ίσως κάποια άλλη εφαρμογή είναι σε χρήση ή το ρολόι του υπολογιστή παρουσιάζει διακυμάνσεις. Μεγάλες διακυμάνσεις έχουν αρνητική επίπτωση στην επικοινωνία του οχήματος και στην επικοινωνία TIS2Web. Βεβαιωθείτε ότι δεν εκτελούνται άλλες εφαρμογές.

Οι περισσότεροι φορητοί υπολογιστές μπορούν να μειώσουν αυτόματα την ταχύτητα του ρολογιού της CPU για να εξοικονομήσουν μπαταρία. Αυτό, επίσης, ενδέχεται να είναι η αιτία των διακυμάνσεων της ταχύτητας που ανιχνεύονται από το Tech2Win. Σ' αυτή την περίπτωση, μη χρησιμοποιείτε το φορητό υπολογιστή σας με μπαταρία αλλά συνδέστε τον στο ρεύμα. Θα μπορούσατε επίσης να δοκιμάσετε να αλλάξετε τις ρυθμίσεις ισχύος ώστε το λειτουργικό σύστημα να μη μειώνει την ταχύτητα του ρολογιού.

Ξαφνική διακοπή

Εάν η αιτία τερματισμού του προγράμματος δεν βρεθεί μέσα στο αρχείο καταγραφής, τότε ενδεχομένως να πρέπει να ενεργοποιηθούν οι εσωτερικοί μηχανισμοί ασφάλειας του Tech2Win. Μην παραποιείτε τα ακόλουθα αρχεία: emulator.sec, emulator.lic, emulator.card. Εάν το Tech2Win εντοπίσει διαρροή ασφαλείας είναι πολύ πιθανό να πρέπει να εκτελέσετε επανεγκατάσταση.

Η γλώσσα που εμφανίζεται για το Λογισμικό 15.001 είναι τα Σουηδικά

Το αρχικό λογισμικό που παρέχεται μαζί με το Tech2Win είναι ένα λογισμικό επίδειξης που υπάρχει σε κάθε νέα κάρτα PCMCIA. Το TIS2Web δείχνει ότι είναι στα Σουηδικά γιατί το TIS2Web εμφανίζει μόνο την τελευταία γλώσσα στη λίστα των τεσσάρων γλωσσών που υποστηρίζονται από αυτό το λογισμικό επίδειξης (Αγγλικά, Γαλλικά, Γερμανικά, Σουηδικά). Χρησιμοποιήστε τη λειτουργία Ενημέρωση 'Προσαρμογή' αντί της 'Τυπική' για να αντικαταστήσετε αυτό το λογισμικό επίδειξης με το πιο πρόσφατο διαγνωστικό λογισμικό.

Απώλεια επικοινωνίας με την MDI

Απώλεια επικοινωνίας με την MDI μπορεί να προκύψει για διάφορους λόγους.

  • Κακή καλωδιακή σύνδεση (Ethernet και USB).
  • Ασταθής ασύρματη σύνδεση.
  • Το PC περνά σε κατάσταση αναμονής.

Το Tech2Win δεν βρήκε την MDI που χρησιμοποιώ

Ελέγξτε τα παρακάτω σημεία:

    1. Είναι ενεργοποιημένη η MDI;
    2. Λειτουργεί ο MDI Manager;
    3. Χρησιμοποιείται το MDI από άλλη εφαρμογή όπως το SPS;
Μπορείτε να ξεκινήσετε τον MDI Manager από το εικονίδιο στην επιφάνεια εργασίας ή από το 'Start/All programs/General Motors/GM/MDI Software'.: Καλέστε το Helpdesk εάν το σημείο 2 δεν λειτουργεί.

Θέλω να αρχίσει αμέσως το TIS2Win χωρίς να ασχοληθώ με το πρόγραμμα ρύθμισης παραμέτρων

Εκτελέστε "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Χρησιμοποιήστε τον παρακάτω κατάλογο: 'C:\Program Files\General Motors\Tech2Win\bin' Μπορείτε να εξακολουθείτε να χρησιμοποιείτε το πρόγραμμα ρύθμισης παραμέτρων για να κάνετε αλλαγές στις παραμέτρους.

Πού βρίσκονται οι λειτουργίες εκτύπωσης;

Το Tech2Win δεν προσφέρει δυνατότητα άμεσης εκτύπωσης. Αντίθετα, δημιουργεί προσωρινά αρχεία και καλεί τα προγράμματα που σχετίζονται με τις επεκτάσεις αρχείων. Αυτά τα προγράμματα μπορούν να χρησιμοποιηθούν για σκοπούς εκτύπωσης, επιτρέποντας να ρυθμίσετε την εμφάνιση της εκτύπωσης σας.

Print Report | Print Report

Για να εκτυπώσετε την τρέχουσα οθόνη Tech2Win, χρησιμοποιήστε το στοιχείο μενού Αρχείο / Εκτυπώστε την οθόνη ή το πλήκτρο στο πληκτρολόγιο οθόνης που δείχνει έναν εκτυπωτή. Εάν χρειάζεται να εκτυπώσετε πολλές οθόνες του Tech2Win, τότε το στοιχείο μενού Επιλογές / Αυτόματα στιγμιότυπα οθόνης μπορεί να χρησιμοποιηθεί, καθώς δημιουργεί αρχεία PNG για κάθε οθόνη Tech2Win. Αυτά τα αρχεία PNG εμπεριέχονται στο αρχείο καταγραφής.

Μπορείτε, επίσης, να εκτυπώσετε περιεχόμενα εμφάνισης δεδομένων (ενεργοποιούνται μέσω του στοιχείου μενού Παράθυρα / Οθόνη δεδομένων Tech2Win). Χρησιμοποιήστε το κουμπί Εκτύπωση/Εκκίνηση HTML για εκκίνηση και έπειτα διακοπή της λήψης δεδομένων. Αφού διακόψετε τη λήψη, το εκτελέσιμο που σχετίζεται με HTML (κανονικά το Internet Explorer) ξεκινά, το οποίο σας προσφέρει αρκετές δυνατότητες εκτύπωσης των δεδομένων σας.

Data Display | Data Display

Ένας μη χρησιμοποιημένος φάκελος PCMCIA βρίσκεται στον υπολογιστή μου.

Προγενέστερες εκδόσεις του Tech2Win είχαν πάντα μια διπλότυπη αποθήκευση αρχείων PCMCIA σε ξεχωριστό κατάλογο. Αυτός ο κατάλογος ήταν συχνά ο C:\PCMCIA. Πλέον, ο κατάλογος αυτός δεν χρησιμοποιείται καθώς η γρήγορη λήψη από το TIS2Web καθιστά μια δεύτερη αποθήκευση αυτών των λήψεων μη απαραίτητη. Μπορείτε να διαγράψετε με ασφάλεια αυτόν τον κατάλογο.

Λαμβάνω ένα μήνυμα 'μη έγκυρη διαδρομή αρχείου'

Το όνομα αρχείου φαίνεται να περιέχει μη έγκυρους χαρακτήρες, όπως το σύμβολο ποσοστού (%). Αν βλέπετε αυτό το πρόβλημα απευθείας μετά από μια εγκατάσταση, θα είναι καλύτερο απλά να εκτελέσετε μια κατάργηση εγκατάστασης και μια νέα εγκατάσταση. Οι περισσότερες περιπτώσεις μπορούν να αντιμετωπιστούν με αυτήν τη μέθοδο.

Κατά τη διάρκεια φυσιολογικών εγκαταστάσεων, η μεταβλητή περιβάλλοντος 'Tech2WinUserData' ορίζεται σε 'PUBLIC' (για εκδόσεις Windows >= Vista) και σε 'ALLUSERSPROFILE\Documents' (για εκδόσεις Windows προγενέστερες των Vista). Σε ορισμένες σπάνιες περιπτώσεις, η μεταβλητή περιβάλλοντος δεν έχει οριστεί κατά τη διαδικασία εγκατάστασης, αλλά λειτούργησε κανονικά με τη δεύτερη προσπάθεια. Μπορείτε επίσης να επιλέξετε να ορίσετε τη μεταβλητή περιβάλλοντος χειροκίνητα. Ζητήστε από τον διαχειριστή σας βοήθεια αν δεν γνωρίζετε τον τρόπο ορισμού μιας μεταβλητής περιβάλλοντος.


Καταχωρήσεις μητρώου

Οι παρακάτω καταχωρήσεις μητρώου δημιουργούνται από το πρόγραμμα εγκατάστασης. Μην τροποποιείτε αυτές τις καταχωρήσεις χειροκίνητα. Δώστε προσοχή στις τυπικές επισημάνσεις προσοχής των Windows όσον αφορά στις καταχωρήσεις του μητρώου.

κλειδί μητρώου | όνομα | τύπος | σημασία
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Εσωτερικός αριθμός έκδοσης
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Γλώσσα | REG_SZ | εγκατεστημένη γλώσσα
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Διαδρομή των καταλόγων αντιγραφής PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Root | REG_SZ | διαδρομή εγκατάστασης
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | ΕπιλογήΚατάργησηςεγκατάστασης | REG_DWORD | Ρύθμιση απεγκατάστασης
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Έκδοση του αρχείου παραμέτρων
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Έκδοση του προγράμματος οδήγησης εικονικής θύρας COM
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Όνομα λογισμικού στη λίστα Προσθαφαίρεση προγραμμάτων
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Διαδρομή για το πρόγραμμα κατάργησης εγκατάστασης


Επανεγκατάσταση

Με την επανεγκατάσταση θα διαγραφεί ολόκληρος ο κατάλογος του Tech2Win με τις παρακάτω εξαιρέσεις.

  1. ο υποκατάλογος config που περιέχει τις ρυθμίσεις παραμέτρων δεν διαγράφεται.
  2. Ο υποκατάλογος pcmcia που συνήθως περιέχει τις εικόνες PCMCIA δεν διαγράφεται.
  3. Ο υποκατάλογος ATA που ενδέχεται να περιέχει πληροφορίες εντοπισμού σφαλμάτων δεν διαγράφεται.
Τα αρχεία παραμετροποίησης μπορεί να καταλήξουν μη συμβατά: δεν υπάρχει εγγύηση ότι τα αρχεία παραμετροποίησης μιας παλιάς έκδοσης του Tech2Win είναι αναγνώσιμα από το Tech2Win νεότερης έκδοσης. Οι εικόνες PCMCIA είναι δεδομένο ότι δεν μπορούν να καταλήξουν μη συμβατές.

Ο δευτερεύων κατάλογος PCMCIA δεν επηρεάζεται από την επανεγκατάσταση.

Ορισμένα περιβάλλοντα μπορεί να παρέχουν αυτόματη εγκατάσταση νεότερης έκδοσης του Tech2Win. Οι πληροφορίες από την τελευταία εγκατάσταση αποθηκεύονται στο μητρώο, αυτές οι ρυθμίσεις θα εμφανιστούν ως προεπιλεγμένες κατά την επανεγκατάσταση.

Μπορείτε να κάνετε υποχρεωτική επανεγκατάσταση του Tech2Win χρησιμοποιώντας τη δέσμη ενεργειών enable reinstallation. Αυτή η δέσμη ενεργειών έχει εγκατασταθεί μαζί με το Tech2Win. Βασικά, αυτή η δέσμη ενεργειών απλώς ορίζει την τιμή του πλήκτρου CurrentVersion που βρίσκεται στο μητρώο HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win στην τιμή '1.000'.