Tech2Win Benutzerhandbuch

Willkommen zum Benutzerhandbuch von Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors All Rights Reserved.

  • Einleitung:
  • Lizenz:
  • Installation:Eine Beschreibung der Installationsroutine von Tech2Win.
    • Installationsschritte
    • Diagnoseschnittstelle
  • Erste Schritte
    • Auswahl einer Konfiguration
      • Tastatur
      • Fensterhandhabung
    • Neue Konfiguration
    • Änderung der Konfiguration
      • Sprache
      • Pfad
      • Anzeige
      • Konfiguration sichern
    • Erwerben einer gültigen Tech2Win Lizenz
  • Arbeiten mit Tech2Win: Details für die tägliche Arbeit.
    • Menu
    • Herunterladen eines PCMCIA Abbildes
    • Sicherheit
    • Berichte sehen
    • Handhabung der PCMCIA Abbilder
    • Statusleiste
  • Weitere Themen: Information wird für die übliche Nutzung von Tech2Win nicht benötigt. Meist nur für Nutzer mit Administrationsrechten von Bedeutung.
    • Reinstallation
    • Deinstallation
    • Format der Konfigurationsdatei
    • Log Datei
    • Fehlermeldungen und Fehlercodes
    • ATA-Karte
    • Registry Einträge
    • Dateien
    • Konfigurationen verwalten
  • FAQ


Einleitung

Tech2Win ist eine Windows Applikation die Tech2 Funktionalitäten emulieren kann. Die Tech2 Software wird hauptsächlich auf dem PC ausgeführt. Ihr PC benötigt folgende technische Voraussetzungen damit das Programm ausgeführt werden kann:

  • Eine Fahrzeug-Kommunikationsschnittstelle muss installiert werden und mit Ihrem PC verbunden sein. Die Liste der akzeptablen Schnittstellen kann variieren von Region zu Region. In den meisten Fällen kann das GMs Multiple Diagnostic Interface (MDI) genutzt werden.
  • Die Tech2Win Applikation benötigt während der Installation 150MByte freien Festplattenspeicher. Zusätzlich sind pro zu nutzender Speicherkarte 32MB notwendig.
  • Zur Ausführung der Tech2Win Applikation werden mindestens 100 MB physikalischer Speicher (RAM) benötigt. Es ist notwendig, dass Ihr PC über genügend RAM verfügt um die Applikation während der ganzen Zeit im RAM halten zu können.
  • Ihr PC sollte über eine Rechenleistung entsprechend eines 1.2GHz Pentium (single core) verfügen. Wir empfehlen dringend, keine anderen Applikationen parallel laufen zu lassen.
  • Eine Tastatur wird nicht benötigt. Tech2Win kann auch über einen Touch Screen benutzt werden. Für Konfigurations Mangement empfehlen wir dringend eine Tastatur zu nutzen falls Sie Dateinamen vergeben wollen.
  • Ihre farbige Grafikanzeige muss eine minimale Auflösung von 800 x 600 haben und minimale Farbtiefe von 256 aufweisen. Ohne Tastatur kann eine Auflösung von 640 x 480 akzeptabel sein.

Wenn Sie Tech2Win verwenden (also ein Laptop anstelle eines Tech2), so vergewissern Sie sich, dass der Laptop genug Akkulaufzeit hat. Normalerweise wird Ihr Laptop nicht durch die Autobatterie gespeist, wie ein Tech2.

  • Installation
  • Erste Schritte


Lizenz

General Motors - Tech2Win Lizenzvereinbarungen

Bitte lesen Sie die folgenden Lizenzbestimmungen sorgfältig durch bevor Sie die Anwendung benutzen. Bitte sprechen Sie Ihre zuständige General Motors Europe Servicevertretung an, wenn Sie die Bedingungen nicht akzeptieren oder nicht verstehen. Das Recht auf Nutzung dieser Software wird von General Motors unter der Bedingung erteilt, dass der Nutzer die während der Installation von Tech2Win angezeigten Lizenzvereinbarungen anerkennt.
General Motors gewährt das Recht auf Nutzung der Tech2Win Software und der inbegriffenen Informationen in Verbindung mit TIS2Web, GlobalTIS oder TIS2000 ausschließlich den autorisierten Händlern wie es in dem lokal zutreffenden Händlervertrag mit den nationalen Vertriebsgesellschaften von General Motors festgelegt ist.
Die Tech2Win Lizenz ist solange gültig wie die Händlervereinbarung in Kraft ist und TIS2Web, GlobalTIS und TIS2000 Lizenzen installiert sind. Mit dem Ende der Händlervereinbarung endet automatisch die Tech2Win Lizenz ebenso wie TIS2Web und GlobalTIS.

Unabhängige Händler gemäß Artikel 4 Paragraph 2 der Gruppenfreistellungsverordnung (GVO) 1400/2002 können neben anderen im GM Europe Info Tech Portal der General Motors Europe angebotenen Subskription eine Tech2Win Lizenz erwerben.

Die Tech2Win Lizenz beinhaltet weder die Schnittstelle zur Fahrzeugkommunikation noch die PC Hardware.

Die Tech2Win Software darf nicht an Dritte außerhalb des autorisierten Händlernetzes (wie in der entsprechenden Anlage zu der Händlervereinbarung dargelegt) verkauft oder online gestellt werden ohne schriftliche Genehmigung der zuständigen nationalen Vertriebsgesellschaft von General Motors. Dies gilt sowohl für aktuelle als auch nicht aktuelle Daten (wie z.B. ältere TIS 2000 DVD).

Jede unzulässige oder missbräuchliche Nutzung berechtigt die nationale Vertriebsgesellschaft von General Motors zur sofortigen Sperrung des Zugangs und zur fristlosen Kündigung des Vertrages. Ein Anspruch auf Rückerstattung von nicht aufgebrauchten Guthaben bzw. der Jahresgrundgebühr ist in diesem Fall ausgeschlossen.

Die bereitgestellten Informationen dienen der fachgerechten Ausführung von Wartungs- und Instandsetzungsarbeiten für unveränderte Fahrzeuge von General Motors. Voraussetzung für die Durchführung der oben genannten Arbeiten ist eine abgeschlossene Ausbildung als Kfz-Handwerker sowie regelmäßige Weiterbildung. Wenn in den bereitgestellten Informationen auf die Verwendung von Spezialwerkzeugen hingewiesen wird, so sind diese für eine fachgerechte Reparatur zwingend erforderlich.

Die von General Motors auf Tech2Win veröffentlichten Informationen (Text- und Bildmaterialien, Musik, Grafiken, Animationen, Videos etc.) sowie deren Anordnung in Tech2Win genießen urheberrechtlichen Schutz. Die Vervielfältigung, Verbreitung, Wieder- bzw. Weitergabe und sonstige Nutzung ist ohne die schriftliche Genehmigung von General Motors nicht gestattet.

  • Installation: Installationsschritte
  • Erste Schritte


Installation

Zur Installation von Tech2Win benötigen Sie lokale Administrationsrechte auf dem PC. Die Installation wird ohne Administrationsrechte misslingen. In einem solchen Fall wenden Sie sich bitte an den Administrator ihres PCs.

Um Tech2Win benutzen zu können, müssen folgende zwei Schritte durchgeführt werden:

  • Installation von Tech2Win.
  • Installation einer Diagnoseschnittstelle.
  • Installation: Installationsschritte
  • Erste Schritte


Installationsschritte

Die Installation selbst dauert nur einige Minuten und benötigt die folgenden Eingaben:

  1. Lizenzvereinbarung
  2. Installationsverzeichnis

Sprache

Als Standard wird die Tech2Win Oberfläche in der Sprache Ihres Betriebssystems angezeigt. Die folgenden Sprachen werden generell unterstützt. Falls Ihre Sprache nicht unterstützt wird, startet der Installer in Englisch als Standardinstallationssprache.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Englisch (GB or USA)*
  • el_GR (EL)Greek
  • es_ES (ES)Spanisch
  • fi_FI (FI)Finnish
  • fr_FR (FR)Französisch
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugiesisch (Brasilien)
  • pt_PT (PT)Portugiesisch (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Chinesisch (Vereinfacht)
  • zh_TW (ZH)Chinesisch (Traditionell)

* Die Tech2Win Sprache ist (britisches) Englisch. In Abhängigkeit von der Herkunft kann die Tech2 Software und der Installer, welche Sie nutzen, auch im Amerikanischen Englisch sein.

Lizenzvereinbarung

Sie müssen die Lizenzvereinbarung bestätigen.

Installationsverzeichnis

Sie können das Verzeichnis auswählen, in das Tech2Win installiert werden soll. Das default Installationsverzeichnis ist <Ihr Programm Verzeichnis>\General Motors\Tech2Win oder im Falle einer Reinstallation das vorher ausgewählte Verzeichnis.

Im letzten Schritt müssen Sie nur noch die Installation bestätigen.

Virtueller Com Port Treiber

Der virtuelle COM-Port Treiber wird nur einmal auf Ihrem Computer eingerichtet und bleibt dann solange erhalten bis die Treiberversion erneuert wird (passiert selten) oder Tech2Win deinstalliert wird.
Während der Treiberinstallation sehen Sie für einen kurzen Moment eine DOS Box. Diese wird automatisch geschlossen und benötigt kein weiteres Zutun. Die Treiberdateien werden zusätzlich im "Treiber" Unterordner ihres Tech2Win Installationsverzeichnisses abgelegt.
Es ist möglich, wird aber nicht empfohlen, manuell den virtuellen COM-Port Treiber zu installieren bzw. zu deinstallieren. Verwenden Sie eines der folgenden Kommandos von der CMD Eingabeaufforderung:

  • Führen Sie "vbsetup7" aus, um den Treiber zu installieren
  • Führen Sie "vbsetup7 /u" aus, um den Treiber zu deinstallieren
  • Erste Schritte


Diagnoseschnittstelle

Ihre Fahrzeugkommunikationseinheit muss separat installiert werden. Bitte verwenden Sie die Installationsanweisungen, die mit der Diagnoseschnittstelle ausgeliefert wurde.

  • Erste Schritte: Diagnoseschnittstelle
  • Weitere Themen: Konfigurationsdatei
  • Installation: Installationsschritte
  • FAQ: Wie kann man mehr als ein MDI verwenden?
  • FAQ: Tech2Win hat das MDI nicht gefunden


Erste Schritte

Diese ersten Schritte sollen zeigen wie man mit Tech2Win arbeiten kann. Vorausgesetzt werden Erfahrungen mit dem Tech2. Während der Durchführung der ersten Schritte ist keine Fahrzeugkommunikation notwendig.

Um den Quickstart zu nutzen gehen Sie wie folgt vor:

  1. Starten Sie Tech2Win direkt mit dem QuickStart Shortcut auf ihrem Desktop.
  2. Holen Sie eine gültige Lizenz indem Sie Tech2 Software von TIS herunterladen.

Um eine auswählbare Konfiguration zu nutzen:

  1. Starten Sie den Konfigurator mit dem Tech2Win Shortcut auf ihrem Desktop. Nach der Installation ist eine default Konfiguration vorhanden.
  2. Um eine neue Konfiguration herzustellen, kopieren Sie normalerweise die default Konfiguration.
  3. Eine bestehende Konfiguration können Sie Ihren Anforderungen beliebig anpassen.
  4. Erwerben einer gültigen Lizenz.

Starten Sie Tech2Win nicht im Kompatibilitätsmodus. In einem solchen Fall wird eine Warnung in der Log-Datei angezeigt. Tech2Win verwendet nur Windows Funktionen die seit XP vorhanden sind und wird deshalb auf früheren Windows-Versionen nicht funktionieren.

  • Erste Schritte: Neue Konfiguration
  • Erste Schritte: Änderung der Konfiguration
  • Erste Schritte: Diagnoseschnittstelle
  • Arbeiten mit Tech2Win: Menu
  • Arbeiten mit Tech2Win: Sicherheit
  • Arbeiten mit Tech2Win: Statusleiste
  • Weitere Themen: Konfigurationsdatei


Auswahl einer Konfiguration

Beim ersten Start der Tech2Win Application erscheint der folgende Bildschirm. Sie können Tech2Win sofort mit der default Konfiguration starten. Diese default Konfiguration arbeitet ohne Fahrzeugkommunikation.

Start First Time

Eine Meldung über eine abgelaufene Lizenz wird erscheinen, kann aber ignoriert werden um die Standardkonfiguration zu starten.

Wenn Sie einen tastaturlosen PC haben, so kann ein PC Programm zur Simulation einer Tastatur hilfreich sein.


Tastatur

Die PC Tasten wie auch die Schaltflächen, falls vorhanden, entsprechen den Tech2 Tasten. Es gibt auch einige zusätzliche Tasten welche für den Tech2Win bereitgestellt werden, die aber nicht auf dem Orignal Tech2 zu finden sind. Der Ziffernblock auf der PC Tastatur wird nicht in allen Situationen funktionieren. Falls es irgendwelche Probleme gibt, prüfen Sie bitte, ob sich das Standard Tastatur Layout Ihres PC's geändert hat. Speziell die SHIFT-Taste kann in so einem Fall umprogrammiert sein.

PC Tastatur | Schaltfläche | Funktionalität
F1 Funktions Taste | n.a. | Tech2Win Hilfe
F5 .. F8 Funktions Tasten | Der Tech2 Anzeige Bereich der Softkeys | Tech2's vier Softkeys
Hoch, Runter, Links, Rechts Cursor Tasten |  | Tech2 hoch, runter, links, rechts Tasten. Nur diese Tasten haben eine automatische Wiederholung.
0 .. 9 Taste | F0 • • • F9 | Tech2 F0 .. F9 Tasten
Zurück Taste | Exit | Tech2 Exit Taste
Enter / Return | Enter | Tech2 Enter Taste
Y | Yes | Tech2 Yes Taste
N | No | Tech2 No Taste
Q | ? | Tech2 ? Taste
S | Shift | Tech2 Shift Taste. Die Shift-Anzeige in der Statusleiste bzw. der Indikator oberhalb der SHIFT Taste zeigen den Zustand an.
ctrl-P | PWR | Tech2 Power key; Offensichtlich kann damit das Tech2Win Programm nur beendet werden.
ctrl-R | nicht vorhanden | Rücksetzen des Tech2 Emulators. Ähnlich einem Aus- und wieder Einschalten eines Tech2. Allerdings wird die Fahrzeugkommunikationsschnittstelle (MDI) nicht erneut initialisiert. Dateien wie das PCMCIA Abbild werden nicht erneut geladen.
Home | Home | Die Pos1 Taste. Die Taste wird nur von manchen Tech2 Programmen unterstützt.
Nur verfügbar über den Menüpunkt Datei. | Print Screen | Druckt eine Kopie des Tech2 Bildschirmes, indem eine temporäre BMP Datei erzeugt wird und die damit verknüpfte Applikation aufgerufen wird. Mit diesem Programm kann man vor dem Drucken notwendige Größenanpassungen oder Drehungen durchführen.
Nur verfügbar über den Menüpunkt Datei. | Save Screen | Speichert eine Bildschirmkopie des Tech2 Bildschirms als BMP oder PNG Datei.
Nur verfügbar über den Menüpunkt Datei. | View Report | Zeigt alle Reportdateien der aktiven PCMCIA Karte an.


Fensterhandhabung

Sie können die Größe Ihres Fensters unter Verwendung des Standard Windows Mechanismus ändern durch Ziehen des Fensterrahmens. Zusätzlich unterstützt der Menüpunkt Optionen/Auflösung mehrere vorgegebene Größen. Auch bei einer Größenordnung des Hauptfensters durch die Menüanwahl bleibt das Tastenfenster am Hauptfenster angedockt.

Das Erscheinungsbild des Fensters kann über eine Änderung im Konfigurationstab Anzeige angepasst werden.


Neue Konfiguration

Mit der Schaltfläche Neu erstellen ... wird eine neue Konfiguration erzeugt. Eine Dialogbox erscheint, worin nach der Quellkonfiguration gefragt wird. Standardmäßig ist hier die Konfiguration default ausgewählt. Nach der Eingabe des Namens der neuen Konfiguration wird der Kopiervorgang durch das Drücken der Schaltfläche Kopieren ausgeführt.

Ist keine Tastatur am Laptop angeschlossen, so ist die Aktivierung eines Tastatur-Simulators mit der PC-Tastatur Schaltfläche sinnvoll.

Die Schaltfläche Abbrechen bricht den Vorgang ab.

Die neue Konfiguration wird die gleiche PCMCIA Datei verwenden, wie die ursprüngliche Konfigurationsdatei. Wenn Sie dies ändern wollen, werden Sie mittels Änderung der Konfiguration eine andere PCMCIA Datei einstellen müssen. In den meisten Fällen wird man eine existierende PCMCIA Datei in eine neue Datei kopieren und diese dann nutzen. Möglicherweise möchten Sie, dass ihre neue Konfigurationsdatei dieselbe PCMCIA Datei verwendet wie die ursprüngliche Konfiguration. In diesem Fall erscheint eine Warnmeldung, wenn die Speichern Schaltfläche gedrückt wird.

  • Änderung der Konfiguration


Änderung der Konfiguration

Konfigurationen, die in blauer Schrift dargestellt sind, haben den Schreibschutz aktiv und können nicht geändert werden. Diese Konfigurationen können nur gelesen werden. Auch dazu verwendet man die Modifizierungsmöglichkeiten, allerdings wird die Schaltfläche Speichern nicht verfügbar sein.

Eine Konfiguration wird modifiziert, indem man eine der vier Tab-Reiter auswählt: Sprache, Diagnoseschnittstelle, Pfad, Anzeige. Sie können einen beliebigen Tabulator auswählen oder mittels Drücken der Weiter Schaltfläche den nächsten Tabulator aktivieren. Nach einer Änderung müssen Sie die Schaltfläche Speichern drücken um die Konfiguration abzuspeichern.

Sobald eine Tastatureingabe notwendig ist können Sie die PC Applikation zur Simulation einer PC-Tastatur aufrufen. Dies ist besonders bei Touchscreen Laptops von Vorteil wo manchmal keine Tastatur vorhanden ist.


Sprache

Im Tab-Reiter Sprache kann man die Sprache auswählen, in der Tech2Win ausgeführt wird. Diese Auswahl hat keinen Einfluss auf die Sprache innerhalb der Tech2 Software auf der PCMCIA Karte. Während des Überspielens neuer Tech2 Software von TIS muss immer noch die richtige Sprache ausgewählt werden.

Für manche Regionen kann es sein, dass nicht alle Sprachen vorliegen. In einem solchen Fall wird an Stelle der gewünschten Sprache Englisch benutzt. Prüfen Sie dann ob eine ähnliche Sprache möglicherweise vorhanden ist (PT Portugiesisch-Portugal anstelle von PB Portugiesisch-Brasilien).


Pfad

Beim Reiter Pfad kann man die Pfade beider PCMCIA Dateien als auch den Pfad für die Emulation der Tastatur setzen. Zusätzlich gibt es die Schaltfläche Kopiere Speicherkarte ... womit man PCMCIA Dateien kopieren kann. Haben Sie eine neue Konfiguration erstellt, so können Sie mit dieser Schaltfläche verhindern, dass mehrere Konfigurationen dieselbe PCMCIA Datei verwenden.

Memory Card Options

Kopiere Speicherkarte ...

Diese Schaltfläche ermöglicht das Kopieren einer PCMCIA Datei in eine zweite Datei. Dies entspricht dem Kauf einer neuen PCMCIA Karte für den Tech2. Die Kopierfunktion arbeitet allerdings nur auf Dateien im Verzeichnis C:\Benutzer\Öffentlich\General Motors\Tech2Win\pcmcia.

Schacht 0 : Position für Abbild Speicherkarte

Hier gibt man die PCMCIA Datei für den Einschubschacht 0 an. Normalerweise sollte die Datei im Verzeichnis C:\Benutzer\Öffentlich\General Motors\Tech2Win\pcmcia sein, aber auch andere Verzeichnisse können hier angegeben sein.

Schacht 1 : Speicherkarte oder ATA-Karte falls verwendet

Wie der Tech2 unterstützt auch Tech2Win zwei PCMCIA Karten/Dateien. Allerdings wird eine zweite PCMCIA Datei innerhalb einer Konfiguration meist nicht gebraucht. Sinnvoller wäre es, diese zweite Software in einer zweiten Konfiguration zu verwenden.

Wie auf dem Tech2 kann eine ATA Karte zur Fehlersuche eingesetzt werden. Bitte aktivieren Sie die ATA Karte nur, wenn Sie dazu aufgefordert worden sind. Sie erhalten dabei genauere Informationen.

Position der PC Software Tastatur

Die Standarddatei wird aus der Windows Registry ausgelesen und zeigt normalerweise auf ein Programm, das eine Tastatur mittels Software zur Benutzung mit einer Maus nachbildet. Wenn ihr Laptop dafür ein eigenes Programm hat, so kann man dieses Programm hier einstellen.


Diagnoseschnittstelle

  • COM-Port für Tech2-RS232-Emulation
  • Seriennummer des genutzten MDI's
  • Protokoll

COM-Port für Tech2-RS232-Emulation

Bitte wählen Sie einen freien COM-Port welcher für die Tech2 Emulation benutzt werden kann. Zu Ihrer Information zeigt der Konfigurator an, welche seriellen Schnittstellen bereits benutzt werden.

Wenn Sie einen existierenden COM-Port auswählen, so wird Tech2Win diese existierende Schnittstelle verwenden. Diesen COM Port kann man verwenden, um von einem zweiten Rechner worauf TIS läuft, Tech2 Software mittels Nullmodemkabel herunterzuladen. Beachten Sie, dass bei Einsatz einer physisch vorhandenen COM Schnittstelle diese aufgrund von Windows-Einschränkungen nicht zuverlässig mit 115.200 Baud arbeitet.

Wird ein nicht existierender COM-Port ausgewählt, so erzeugt Tech2Win automatisch eine virtuelle Schnittstelle. Dieser virtuelle Port kann von TIS, welches auf demselben Rechner läuft, verwendet werden, um mit Tech2Win Kommunikation aufzubauen. Wird ein virtueller Port verwendet, so gibt es keinerlei Einschränkung bzgl. der Verwendung von hohen Baudraten.

Falls Sie "Suche" als COM-Port auswählen, wird Tech2Win einen virtuellen COM Port an der ersten freien Portnummer im Bereich von 9 bis 1 erstellen.

Seriennummer des genutzten MDI's

Geben Sie die Seriennummer des MDI's ein. Die Nummer befindet sich auf der Rückseite des MDI's. Verwenden Sie die Nummer nach dem Bindestrich.

Ist keine Seriennummer angegeben, wird Tech2Win eine Liste der im Netzwerk verfügbaren MDIs anzeigen und den Benutzer auswählen lassen. Die gleiche Auswahlbox erscheint, wenn das angegebene MDI nicht gefunden wurde.

Protokoll

"ISO22900-2 / PDU-API" ist ausgewählt und J2534-2 ist immer ausgegraut. Zukünftig soll das MDI auch in der Lage sein das J2534 Protokoll zu unterstützen.

  • Weitere Themen: Konfigurationsdatei
  • FAQ: Wie erkennt man die COM Schnittstelle, die man für Tech2Win nutzen kann?
  • FAQ: Kommunikation zwischen Tech2Win und TIS2Web
  • FAQ: Wie kann man mehr als ein MDI verwenden?
  • FAQ: Tech2Win hat das MDI nicht gefunden


Anzeige

Der Tab-Reiter Anzeige wird verwendet um Display-Eigenschaften von Tech2Win einzustellen:

  • Tastenfeld
  • Farben
  • Sound
Display and Key Options

Tastenfeld

Hier kann man auswählen, ob das Keypad angezeigt werden soll. Das Keypad wird entweder links oder rechts den Tech2Win Bildschirms gezeigt. Die Hintergrundfarbe ist mittels eines Farbauswahldialoges einstellbar.

Farben

Die Vorder- und Hintergrundfarbe des Tech2 Bildschirms kann hier eingestellt werden. Dies sind die zwei am häufigsten vorkommenden Farbkombinationen:

Screen with background 0000FF, foreground FFFFFF | Keypad Hintergrund weiß; Hintergrund Blau; Vordergrund weiß
Screen with background 000000, foreground C0C0C0 | Tastatur Hintergrund Blau; Hintergrund schwarz; Vordergrund hell grau

Sound

Sie können hier den Ton ausschalten. Jede Sound-Ausgabe des Tech2 wird dann an die PC Lautsprecher weitergeleitet.


Konfiguration sichern

Die aktive Konfiguration wird mit der Schaltfläche Speichern <Konfiguration> unten links gespeichert. Die Schaltfläche erscheint nicht, wenn eine Nur-Lese Konfiguration ausgewählt wurde.


Gültige Lizenz mittels TIS2Web

In den meisten Fällen wird Tech2Win bereits durch den Software Download eine gültige Lizenz erhalten. Zusätzlich erhalten Sie eine durch Ausführen der 'Zugangsberechtigung (Sicherheit)' via TIS2Web (nicht TIS2000). Voraussetzung dafür ist die Auswahl eines virtuellen COM-Ports im Konfigurator unter Diagnoseschnittstelle.

Ein geöffnetes Schloss rechts in der Statusleiste zeigt eine erfolgreich durchgeführte Sicherheitsabfrage an. Innerhalb der Klammern wird die Gültigkeit der Lizenz in Tagen angegeben. Nach dem erneuten Start von Tech2Win und bis zum Aufbau der Fahrzeugkommunikation wird die Sicherheitsanzeige nicht angezeigt. Während des ersten Kommunikationsversuchs mit dem Fahrzeug wird die Lizenz geprüft. Als Indikator wird dann entweder ein geschlossenes oder offenes Schloss zeigen.

  • Arbeiten mit Tech2Win:Sicherheit
  • FAQ:Wie erkennt man die COM Schnittstelle, die man für Tech2Win nutzen kann?
  • FAQ:Kommunikation zwischen Tech2Win und TIS2Web
  • FAQ:Gültige Lizenz
  • FAQ:Was ist der Unterschied zwischen einer Tech2Win Lizenz und der Zugangsberechtigung?


Arbeiten mit Tech2Win

Die folgenden Kapitel werden von Technikern genutzt, die mit Tech2Win arbeiten:

  • Menu: Das Bildschirmlayout und individuelle Menüpunkte.
  • Herunterladen eines PCMCIA Abbildes: Die Aktualisierung der Diagnosesoftware für Tech2Win verläuft annähernd identisch zu der bei Tech2.
  • Sicherheit: Sicherheitsmaßnahmen verhindern, dass Tech2Win Fahrzeugkommunikation mit nicht autorisierten Umgebungen durchführt.
  • Berichte sehen: Das Tech2 Bedienfeld ist in Tech2Win geringfügig erweitert worden. Der "View Reports" Knopf ist das bekannteste Beispiel.
  • Handhabung der PCMCIA Abbilder: Ähnlich wie man mehrere PCMCIA Karten für den Tech2 haben konnte, kann man auch verschiedene PCMCIA Images für Tech2Win nutzen.
  • Statusleiste: Die Statusleiste informiert den Benutzer über individuelle Teile der Statusleiste.
    • Weitere Themen
    • FAQ


Menu

Die Tech2Win Applikation hat folgende Menüpunkte:

  • Datei
  • Optionen
  • Fenster
  • Hilfe

Datei

Das Datei Menü hat folgende Möglichkeiten:

  • Tech2-Bildschirm speichern (320x240) speichert den Tech2 Bildschirm in einer Größe von 320x240 Pixel als Schwarzweißbild ab. Der Ort und das Format der Datei (BMP, GIF, JPG, PNG) lassen sich einstellen.
  • Tech2-Bildschirm drucken erzeugt eine inverse BMP Datei mit schwarzer Schrift auf weißem Hintergrund und ruft das Programm auf, das mit BMP Dateien assoziiert ist. Dieses Programm können Sie nutzen um das Bild auszudrucken.
  • Report Dateien ansehen ermöglicht das Anzeigen (und Ausdrucken) von Report Datei ohne TIS2Web dafür einzusetzen.
  • Beenden beendet Tech2Win.

Optionen

'Optionen' bietet folgende Auswahlmöglichkeiten:

  • Auflösung erlaubt die Auswahl von drei Standard Bildschirmgrößen.
  • ROM-Write from 0x00003ED76 wird für die Fehlersuche eingesetzt.
  • Automatische Screenshots um eine Bildschirmkopie jedes geänderten Bildschirm im Logs Verzeichnis abzulegen.
  • CANdi deaktivieren und Reboot durchführen um ein Tech2 ohne CANdi nachzubilden. Dies wird in seltenen Fällen benutzt wo das CANdi nicht standardisierte Fahrzeugkommunikationsleitungen nicht durchleitet.

Fenster

Das Menü Fenster bietet Ihnen die Möglichkeit der Aktivierung von Tech2Win Datenliste und Tech2Win Fehlercodeanzeige. Alle anderen Auswahlmöglichkeiten sind in der aktuellen Tech2Win Version nicht anwählbar.

Wenn die Tech2 Software Tech2Win Datenliste unterstützt, können Sie diesen Menüpunkt einschalten. Sobald die Datenliste aufgerufen wird, zeigt Tech2Win ein zusätzliches Fenster mit einer eigenen Datenliste an. Solange der Tech2 Bildschirm die Datenliste zeigt kann der Menüpunkt nicht aktiviert werden. In solch einem Fall müssen Sie die Datenliste zuerst beenden, aktivieren dann den Menüpunkt und starten die Datenliste erneut.

Ähnliche Beschränkungen wie für Tech2Win Datenliste gelten auch für Tech2Win Fehlercodeanzeige. Wenn die Tech2 Software Tech2Win Fehlercodeanzeige unterstützt, können Sie diesen Menüpunkt einschalten. Ein zusätzliches Fenster zur DTC Anzeige wird parallel zur Tech2 DTC Anzeige erscheinen. Solange der Tech2 Bildschirm die DTC-Anzeige zeigt kann der Menüpunkt nicht aktiviert werden. In solch einem Fall müssen Sie die DTC-Anzeige zuerst beenden, aktivieren dann den Menüpunkt und starten die DTC-Anzeige erneut.

Hilfe

Folgendes steht zur Auswahl:

  • Hilfethemen... ruft die Tech2Win Hilfe auf.
  • Kommandozeilenparameter zeigt die Kommandozeilenparameter womit Tech2Win aufgerufen wurde.
  • Info über zeigt die aktuelle Version und TIS2Web Download Beschränkungen an.


Download

Erstens, starten Sie Tech2Win und bleiben Sie im Startbildschirm. Starten Sie TIS2Web oder GlobalTIS und führen Sie einen Download mit der COM Schnittstelle durch, die im Diagnoseschnittstelle Reiter eingestellt wurde.

Die Benutzung eingebauter COM-Ports ermöglicht das Herunterladen der Tech2 Software über einen anderen PC, auf dem TIS läuft. Achten Sie auf Einsatz eines gekreuzten RS232-Kabels. Abhängig von der Hardware des Tech2Win PC's kann es sein, dass die Datentransferrate auf 57.600 Baud reduziert werden muss, da es unter Windows bei einer höheren Datentransferrate zu Datenverlust kommen kann.

Die neueste Tech2Win Version unterstützt ein schnelles Laden von Tech2 Software, sofern TIS2Web und Tech2Win auf demselben PC laufen. Etwas Kommunikation zwischen TIS2Web und Tech2Win findet immer noch über die COM Schnittstelle statt, aber die lang andauernde Übertragung der eigentlichen Daten zum Tech2Win wurde durch einen PC internen Dateitransfer ersetzt. In einem solchen Fall wird die Downloadzeit auf weniger als eine Minute reduziert.

  • Weitere Themen: Konfigurationsdatei
  • Erste Schritte: Diagnoseschnittstelle
  • FAQ: Wie erkennt man die COM Schnittstelle, die man für Tech2Win nutzen kann?
  • FAQ: Kommunikation zwischen Tech2Win und TIS2Web


Sicherheit

Die Sicherheitsmechanismen in Tech2Win benötigen eine richtige Uhrzeit. Vergewissern Sie sich, dass ihre PC Uhr richtig gesetzt ist. Kleinere Unterschiede in der Uhrzeit wie sie bei der Umschaltung zwischen Sommer- und Winterzeit vorkommen können, werden toleriert.

Tech2Win wird keinerlei Fahrzeugkommunikation ohne gültige und aktive Lizenz durchführen. Das Symbol in der Statusanzeige gibt den Zustand der Lizenz an:

  • green smiley Die Lizenz ist gültig.
  • Keine Lizenzanzeige: Die Lizenz ist noch nicht überprüft.
  • red smiley Die Lizenz ist abgelaufen.

Um eine Lizenz zu erhalten führen Sie bitte die 'Zugangsberechtigung (Sicherheit)' in TIS2Web oder TIS2000 aus. In den meisten Fällen wird ein Software Download via TIS2Web ausreichend sein, um die Lizenz zu erneuern. Da die Lizenz nach einer gewissen Zeit abläuft (in manchen Regionen sind dies vier Wochen), müssen Sie diese entsprechend regelmäßig erneuern.

Lizenzen sind regions- und softwarespezifisch. Sie können mehrere Lizenzen auf dem Rechner haben wenn Sie mit mehreren Tech2 Software Versionen arbeiten.

Die Anzahl der Tage vor Ablauf der Lizenz wird in der Statusanzeige ausgegeben.

  • ( 0) zeigt an, dass die Lizenz abgelaufen ist bzw. nicht existiert.
  • (<1) Die Lizenz wird innerhalb der nächsten 24 Stunden ablaufen.
  • (20) Die Lizenz wird in zwanzig Tagen ablaufen.

Bitte nehmen Sie an der Lizenzdatei keinerlei Änderungen vor. Betrügerische Änderungen in dieser Datei werden mittels integrierter Sicherheitsmechanismen entdeckt und resultieren im Verlust aller Lizenzen auf dem jeweiligen Rechner. Zusätzlich wird Tech2Win sich sonderbar verhalten. Dies kann nur durch eine Neuinstallation behoben werden.

  • Weitere Themen: Fehlermeldungen und Rückgabewerte
  • Weitere Themen: Log Datei
  • Arbeiten mit Tech2Win: Statusfenster
  • FAQ: Gültige Lizenz
  • FAQ: Was ist der Unterschied zwischen einer Tech2Win Lizenz und der Zugangsberechtigung?
  • FAQ: Plötzliches Anhalten


Anzeigen von Reports

View Report Diese Schaltfläche kann genutzt werden um die Inhalte der PRT-Dateien der PCMCIA Karte anzuschauen. Eine Dialogbox wird geöffnet welche die Liste der PRT-Dateien angezeigt. Falls ein Programm mit der Dateiendung *.prt verknüft ist wird dieses ausgeführt. Ansonsten wird der Notepad Editor geöffnet um die Dateien anzuzeigen.

In den meisten Fällen ist die PRT-Datei eine ASCII Datei welche die entsprechenden Sprachdatei nutzt. Für Chinesisch, Japanisch, Koreanisch und Thai sind die Dateien in Unicode mit führender Byte-Order-Mark (BOM).

Während der Anzeige der Reports arbeitet Tech2Win mit einem Unterverzeichnis C:\Benutzer\Öffentlich\General Motors\Tech2Win\reports. Dieses Unterverzeichnis existiert nur wenn man sich Reports angeschaut hat. Das Verzeichnis wird automatisch gelöscht und dient nur als temporäres Arbeitsverzeichnis für PRT-Dateien bei aktiven PCMCIA Karten. Die Erstellung der Dateien wird beendet sobald Tech2Win nicht mehr ausgeführt wird. Falls Sie Dateien sichern möchten müssen Sie diese kopieren und in ein anderes Verzeichnis damit diese nicht überschrieben werden sobald ein anderer Nutzer sich Reports anschaut.


PCMCIA Abbilder (Images)

PCMCIA Dateien liegen normalerweise im Unterverzeichnis C:\Benutzer\Öffentlich\General Motors\Tech2Win\pcmcia. Die Datei muss eine exakte Größe von 32Mbyte (33,554,432 bytes) oder 10Mbyte (10,485,760 bytes) haben und eine Dateiendung *.bin. Die Images werden modifiziert (wie auch die normalen PCMCIA Karten), sobald ein Download durchgeführt wird oder Tech2Win irgendwas auf der Flashkarte speichert. Eine Veränderung kann durch Einschalten des Schreibschutzes (Parameter -W0 oder -W1) verhindert werden oder bei Unterlassen des 'p'-Wertes in der '-W'-Option(Konfigurationsdatei). Der Schreibschutzschalter ist über den Konfigurator nicht zugänglich. Die Konfigurationsdatei muss manuell geändert werden, wenn man die Optionen '-W0', '-W1' oder '-W' verwenden will.


Statusleiste

Die Statusleiste wird unterhalb des Tech2 Fensters angezeigt. Die folgenden Punkte werden in der Statusleiste angezeigt:

  1. Ein Geschwindigkeits Indikator
  2. Fahrzeugkommunikations Status
  3. Seriell-Port Status
  4. SHIFT Taste
  5. Automatische Screenshots
  6. Log-Warnung
  7. Lizenz

Status Bar

Geschwindigkeits Indikator

Der Geschwindigkeitsindikator zeigt an, wie viel CPU Zeit zur Emulation von Tech2 Software benötigt wird. Eine kleine Nummer (Indikator links) ist besser als eine hohe Nummer (Indikator rechts). Jeder grüne Indikator ist akzeptabel. Der Indikator kann für kurze Zeit gelb werden, falls verschiedene Windows Tasks zwischendurch aktiv werden. Solche Aktivitäten sollten vermieden werden.

Fahrzeugkommunikations Status

Die Statusanzeige bzgl. Fahrzeugkommunikation zeigt an, ob das MDI vorhanden ist und ob Kommunikation mit dem Fahrzeug stattfindet.

Seriell-Port Status

Wenn man mit Tech2Win über den COM-Port kommuniziert, zeigt dieser Indikator ob die Kommunikation aktiv ist oder nicht.

SHIFT Taste

Diese Anzeige zeigt an ob die SHIFT Taste aktiv ist. Sie können mittels der 'S' Taste der Tastatur oder SHIFT Taste auf dem Keypad umschalten.

Automatische Screenshots

Automatische Bildschirmkopien können im Menüpunkt 'Optionen' aktiviert werden. Bei jeder Bildschirmänderung wird eine neue Datei im Log Verzeichnis angelegt. Dies wird durch eine Umdrehung der Kurbel in der roten Kamera in der Statuszeile sichtbar gemacht. Sobald die Funktion 'Automatische Screenshots' abgeschaltet wird, verschwindet auch die Kamera in der Statuszeile.

Log-Warnung

Der Log Status Indikator kann drei unterschiedliche Zustände haben.

  • gray log status indicator Die Logdatei enthält keine Warnungen oder Fehler.
  • yellow log status indicator Die Logdatei enthält Warnungen.
  • red log status indicator Die Logdatei enthält Fehlermeldungen.

Lizenz

Die Lizenzanzeige kann drei verschiedene Zustände annehmen:

  • green smiley Die Lizenz ist aktiv und gültig.
  • Keine Lizenzanzeige: Die Lizenz ist noch nicht überprüft.
  • red smiley Die Lizenz ist abgelaufen oder existiert nicht.
Siehe Link Sicherheit für mehr Informationen.

Tooltips in der Statuszeile

Manche Icons haben Tooltips, um zusätzliche Information anzuzeigen

Tooltip der VCI Seriennummer
Tooltip VCI

Tooltip der TECH2 Software Version
Tooltip TECH2

Tooltip des verwendeten COMPorts
Tooltip Comport

Tooltip um die nächste Bildnummer zu erfahren (nur falls "Automatische Screenshots" aktiv ist)
Tooltip Camera

Tooltip um die letzte Meldung in der Logdatei zu sehen, die mindestens die Schwere 'Warning' hat.
Tooltip Logfile

Tooltip für die genaue Dauer der Lizenz
Tooltip License

Tooltips werden angezeigt, wenn der Cursor mehr als 0.5 Sekunden unbeweglich über einem Icon steht. Der Tooltip verschwindet nach 5 Sekunden bzw. wenn der Cursor bewegt wird.

  • Weitere Themen: Fehlermeldungen und Fehlercodes
  • Weitere Themen: Log Datei


Weitere Themen

Folgende Themen sind für den normalen Benutzer von Tech2Win wohl weniger interessant. Die Information ist für alle, die mit der Installation, der Verwaltung und der Konfiguration von Tech2Win verantwortlich sind möglicherweise wichtig.

  • Reinstallation
  • Deinstallation
  • Direkte Abänderung der Konfigurations Datei
  • Log Datei
  • Fehlermeldungen und Rückgabewerte
  • ATA-Karte
  • Registry Einträge
  • Dateibeschreibung
  • Beispiele des Konfigurationsmanagements


Deinstallation

Das gesamte Installationsverzeichnis, das Verzeichnis mit den Benutzerdaten (C:\Benutzer\Öffentlich\General Motors\Tech2Win) sowie das Verzeichnis mit den Applikationsdaten (C:\ProgramData\General Motors\Tech2Win) wird gelöscht.

  • Weitere Themen: Reinstallation
  • Installation


Konfigurationsdatei

Die Konfigurations Dateien befinden sich alle im Unterverzeichnis C:\Benutzer\Öffentlich\General Motors\Tech2Win\config und haben die Dateiendung *.conf. Die Konfigurations Dateien können manuell geändert werden, da nicht alle Optionen der Datei über Tech2Win zugänglich sind. Die Datei ist im Unicode Format mit einer vorangestellten Byte-Order-Markierung (BOM). Sie sollten einen Unicode-fähigen Editor wie Notepad verwenden, wenn Sie an der Datei manuelle Änderungen vornehmen.

Die Konfigurations Datei ist zeilenorientiert aufgebaut. Leere Zeilen werden ignoriert. Eine Zeile beginnt immer mit einer Option, die meist von einem Wert gefolgt wird. Als Beispiel orientieren Sie sich bitte an der Datei default.conf. Die folgende Tabelle zeigt alle möglichen Optionen.

Wenn Sie eine bestimmte Konfiguration direkt starten wollen, so stellen sie einen Shortcut her, der folgendes ausführt: "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF ..\config\die_konfigurationsdatei.conf. Das Programm sollte folgendes Verzeichnis als Arbeitsverzeichnis verwenden: "C:\Program Files\General Motors\Tech2Win\bin"

Option | Wert / Bedeutung
; Ein Kommentar
@ Die Versionsnummer im Format haupt.neben.
Konfigurations Dateien mit einer unterschiedlichen Hauptnummer, als von Tech2Win gefordert, werden nicht akzeptiert. Konfigurations Dateien mit einer tieferen Nebennummer, als von Tech2Win gefordert, werden als kompatibel angesehen.
-W0
-W1 		Die PCMCIA Karte im Einschubschacht 0/1 hat den Schreibschutz Schalter aktiviert.
-B0
-B1 		Die Blockgröße in KBytes der PCMCIA Karte in Schacht 0/1. Die Größen 128 (Standardwert) oder 256 sind möglich.
-P0
-P1 		Die Datei mit der Binärkopie der PCMCIA Karte in Schacht 0/1. Die Dateigröße mit genau 10MB bzw. 32MB betragen. Umgebungsvariablen wie %ProgramData% werden mit ihrem entsprechenden Wert ersetzt.
Wenn diese Option nicht vorhanden ist, so wird der Einschubschacht als leer angesehen.
-A0
-A1 		Datei mit den Attributwerten der PCMCIA Karte in Schacht 0/1. Ist diese Option nicht angegeben, so werden, basierend auf Karten- und Blockgröße, Standardwerte verwendet.
-W | Beim Verlassen von Tech2Win werden alle speicherfähigen Daten in ihre jeweiligen Dateien geschrieben. Die Werte p/f/r/c können beliebig kombiniert werden, um die Speicherung von PCMCIA/Flash-ROM/RTC/CANDI-App zu ermöglichen.
-H | Heap Verwaltungsfunktionalität Die Werte 0/r/w/t können miteinander kombiniert werden, um Aktives Löschen, Leseprüfungen, Schreibprüfungen und Taskprüfungen einzuschalten. Mit dem Wert l wird die Allozierung bei niedrigen Addressen erzwungen im Gegensatz zu einer alternierenden Allozierung. Normalerweise wird diese Option nur bei der Entwicklung eingesetzt.
-PC | Früher der Pfad für die Kopie der PCMCIA Karte. Diese Option wird zur Zeit ignoriert.
-MS | Identifikation der Fahrzeugkommunikationsschnittstelle (MDI) mittels Seriennummer. Falls nicht angegeben wird eine Liste vorhandener MDIs angezeigt.
-CT | Die Farbe des Textes (Vordergrund) in 3 hexadezimalen Byte Werten. Der Standardwert ist 000000 (weiß).
-CB | Die Farbe des Hintergrundes in 3 hexadezimalen Byte Werten. Der Standardwert ist FFFFFF (schwarz).
-ATA | Diese Option aktiviert eine ATA Karte. Entfernen Sie diese Option um die ATA Karte zu deaktivieren.
-C | Die Nummer der COM Schnittstelle (1..9), die zur Nachbildung des RS232C-Ports des Tech2 verwendet wird. Meist wird COM9 verwendet um die virtuelle COM-Schnittstelle von Tech2Win anzusprechen. Falls diese Option nicht gesetzt ist wird ein freier COM-Port von COM9 abwärts gesucht. Benutzen Sie den Tooltip in der Statuszeile zwischen dem Tech2 Icon und dem TIS2Web Icon um zu sehen welcher COM Port gerade benutzt wird.
-WR | Eine PCAdresse (normalerweise 253558) von wo aus das Schreiben auf die PCMCIA Karte und den FLASH ROM Bereich erlaubt ist. Diese Funktionalität muss zusätzlich über das Menü aktiviert werden (bzw. mit der Option -WA). Dies wird benötigt, um nicht-modifizierbaren Code mittels SingleStep Debugger zu debuggen.
-WA | Dem SingleStep Debugger gestatten, auf einen nicht modifizierbaren Speicherbereich zu schreiben.
-OF | Option Datei mit Option / Werte Paaren.
-TP | Zeitanpassung (Proportional Anteil). Standardwert beträgt 5000. Erniedrigen Sie diesen Wert, um die ausgeführten Zyklen schneller an die Realzeit anzupassen.
-TD | Zeitanpassung (Differential Anteil). Standardwert beträgt 100. Ein niedrigerer Wert erhöht das Ansprechverhalten bei plötzlichen Zeitänderungen. WARNUNG: Das Herumspielen mit den TP und TD Werten kann zu Geschwindigkeitsproblemen führen.
-PJ
-PP 		Angabe des benutzten Protokolls:
PJ für das J2534 Kommunikationsprotokoll.
PP für das ISO22900-2 / PDU-API Kommunikationsprotokoll (Standardwert)
-S | Das Vorhandensein dieser Option schaltet die Soundausgabe auf dem PC Beeper ein.
-L | Die Sprache der Tech2Win Applikation. Falls dieser Eintrag fehlt wird die aktive Windows Sprache als Standard verwendet. Der folgende Link gibt an, welche Sprachen angegeben werden können: Sprachen. Das Tech2 Emulationsfenster wird die Sprache darstellen, die auf der PCMCIA Karte gespeichert ist (also die Sprache, die auf die PCMCIA Karte heruntergeladen worden ist).
-UD | Angabe des Benutzer Datenverzeichnisses. Bei Win7 ist das Verzeichnis normalerweise bei C:\Users\Public\General Motors\Tech2Win
-AD | Angabe des Datenverzeichnisses der Applikation. Bei Win7 ist das Verzeichnis normalerweise bei C:\ProgramData\General Motors\Tech2Win
-US | Verwendung einer benutzerspezifischen Semaphore zur Entdeckung mehrerer parallel laufenden Tech2Win-Programme. Diese Option gestattet jedem Benutzer Tech2Win gleichzeitig auf einem Rechner laufen zu lassen, vermutlich auf einem Server. Dabei sollte man die Optionen -UD und -AD auch verwenden.
-SS | Angabe der Bruttogröße des Tech2Win Fensters einschließlich der Tastatur (sofern aktiviert). Der erste Parameter muss ein in Gänsefüßchen eingeschlossener Text sein. Er wird im Menü unter Optionen / Auflösung dann zu sehen sein. Der zweite Parameter ist die Gesamtzahl der horizontalen Pixel einschließlich der Tastatur. Der dritte Parameter ist die Höhe (vertikale Pixel) des Tech2WIn Fensters. Der optionale vierte Parameter ist die Breite der Tastatur in Pixel.
-SH Das Fensterbehandlung wird mit dieser Option kontrolliert. Die folgende Dezimalzahl gibt an welche Fensteraktivitäten abgeschaltet sind.
  • Bit 0: Keine Minimierung/Maximierung erlaubt.
  • Bit 1: Keine Verschiebung auf dem Bildschirm.
  • Bit 2: Keine Größenveränderung. In diesem Fall ist der Menüpunkt Optionen / Auflösung ausgegraut.
  • Bit 3: Die zusätzlichen Fenster für Datenausgabe und Fehlercodes sind genauso groß wie das Tech2Win Fenster (ohne Tastatur).


Protokollierung (Logging)

Jeder Start einer Tech2Win Konfiguration erstellt eine neue Logdatei im HTML-Format im Unterverzeichnis C:\Benutzer\Öffentlich\General Motors\Tech2Win\Logs. Um einen Festplattenüberlauf zu vermeiden werden die Dateien entfernt, die älter als eine Woche sind.

Die Logdateien werden automatisch benannt nach Erstellungsdatum (year (Jahr), month (Monat), day) (Tag) und Zeit (hour, minute, second):
yyyy-mm-dd_hhmmss.html

Der Inhalt der Logdateien ist immer in Englisch, in Unicode Format mit führender Bytereihenfolgen-Markierung (BOM). Jede Zeile der Logdatei entspricht einem der folgenden Loglevels:

Log Level | Bedeutung
Info | Nur Information. Kein Effekt auf die Ausführung des Programms.
Warnung | Eine ungewöhnliche Situation ist eingetreten. Der Nutzer kann keine nachteiligen Effekte feststellen.
ERROR | Ein Fehler trat auf welcher dem Nutzer bemerkbar gemacht wurde.
CRITICAL | Ein kritischer Fehler trat auf, welcher zum vorzeitigem Beenden des Programms geführt hat.
FATAL | Ein schwerwiegender Fehler veranlasst Tech2Win unverzüglich zu stoppen.

Alle Ausgaben, deren Schwere über der 'Warning' Schwelle liegen, sind zum besseren Erkennen eingefärbt.

Zusätzlich sind Druck- und Videodateien im Logs Unterverzeichnis vorhanden, falls die Funktion Tech2-Bildschirm drucken oder die Menüfunktion Automatische Screenshots verwendet wurde.
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
Automatische Screenshots-Bilder werden in der HTML Datei verlinkt. Verwenden Sie die HTML Logdatei um diese Bilder in der Reihenfolge ihres Auftretens zu sehen.

Über die Statusleiste wird der Nutzer informiert falls Warnungen ( yellow lightning bolt) oder Fehler ( red lightning bolt) aufgetreten sind.


Fehlermeldungen und Rückgabewerte

Fehlermeldungen erscheinen in Dialogboxen. Diese Dialogboxen erlauben Tech2Win das Tech2 Programm parallel auszuführen. Rückgabewerte (Exit Codes) sind schwerwiegende Fehler die zu einer sofortigen Beendigung des Programms führen. Rückgabewerte können in Batch-Dateien genutzt werden um festzustellen warum das Programm beendet wurde.

Fehlermeldungen

Die folgende Fehlermeldung kann auftauchen. Hier eine kurze Erklärung der Situation und wie man das Problem lösen kann.

Emulator too slow Emulator failed to start

Rückgabewerte

Rückgabewert | Wert | Bedeutung
OPCODE_ERROR | -7 | Ein falscher Befehl des Tech2 Microprozessors (68332) wurde festgestellt. Vielleicht wurde das PCMCIA Abbild irgendwie verändert.
ATA_PROBLEM | -6 | Es ist ein Problem während der ATA Emulation aufgetreten. Wenn Sie solch ein Problem sehen nachdem Sie aufgefordert wurden die ATA-Karte zu nutzen, kontaktieren Sie bitte den Helpdesk.
DEMO_TIME_IS_UP | -5 | Darf nicht in der offiziellen Tech2Win Version auftauchen.
DLL_NOT_LOADED | -3 | Eine wichtige DLL konnte nicht geladen werden. Es könnte sein, dass Sie eine unvollständige Kopie von Tech2Win haben. Bitte führen Sie eine neue Installation durch und/oder nutzen eine andere Sprache.
EXIT_INIT_FAILED | -2 | Initialisierung fehlgeschlagen. Schauen sie bitte in die Logdatei für die genaue Ursache. Falls keine Logdatei existiert, prüfen Sie bitte ob Sie die Schreib-/Leserechte für alle Verzeichnisse haben.
normal | 0 | Tech2Win wurde normal beendet.


ATA-Karte

Die ATA-Karte im Tech2 wird generell für die Fehlersuche während der Entwicklung der Software genutzt. Alle notwendigen ATA-Daten sind in einem Unterverzeichnis C:\Benutzer\Öffentlich\General Motors\Tech2Win\ataCapture gespeichert. Dieses Verzeichnis hat normalerweise keine Bedeutung und kann ohne Bedenken gelöscht werden sofern nicht anders angeordnet.

Da das ataCapture Verzeichnis fest ist, ist sein Inhalt für alle Konfigurationen gleich.


Dateien

Die folgenden Dateien und Verzeichnisse werden von Tech2Win genutzt:

Verzeichnis | Ort (vor Vista) | Ort (Vista und folgende)
Installation | Wie bei der Installation festgelegt
User Data | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Application Data | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Datei | im Einsatz für
[User Data]\atacapture | Enthält Dateien, die sich auf der (emulierten) ATA Karte befinden. Wenn nicht ausdrücklich hingewiesen wird so sind diese Dateien nicht notwendig.
[Installation]\bin | Enthält aktuelle *.exe Dateien sowie notwendige DLLs und Bilder welche notwendig für die Ausführung sind.
[Installation]\bin\emulator.exe | Die Haupt *.exe Datei zum Ausführen von Tech2 Code.
[Installation]\bin\emulator_xx_XX.dll | Sprachabhängige Resource DLL.
[Installation]\bin\T2Configurator.exe | Der Konfigurationsteil von Tech2Win.
[Installation]\bin\Pictures | Enthält die Symbole welche von Tech2Win genutzt werden.
[User Data]\config | Enthält alle Konfigurationsdateien.
[User Data]\data | Beinhaltet Dateien welche zum Zeitpunkt der Ausführung von Tech2Win verändert werden. Diese Dateien sind für eine einwandfreie Ausführung von Tech2Win notwendig. Normalerweise, sollten Sie diese Dateien nicht anfassen, es sei denn Sie wurden ausdrücklich dafür instruiert.
[Application Data]\data | Beinhaltet Dateien welche zum Zeitpunkt der Ausführung von Tech2Win verändert werden. Diese Dateien sind für eine einwandfreie Ausführung von Tech2Win notwendig. Normalerweise, sollten Sie diese Dateien nicht anfassen, es sei denn Sie wurden ausdrücklich dafür instruiert.
[Application Data]\data\emulator.sec | Sicherheits-Datei . Diese Datei darf nicht verändert werden.
[Application Data]\data\emulator.card | Card Datei. Eine Liste aller PCMCIA Karten, die dem Tech2Win Programm bekannt sind. Diese Datei darf nicht verändert werden.
[User Data]\data\emulator.disp | In dieser Datei werden Ort und Größe des Tech2Win Bildschirms festgehalten. Falls Sie diese Datei löschen wird sie neu angelegt und der Tech2Win Bildschirm startet in der oberen linken Ecke mit einer Größe von 640x480.
[Application Data]\data\emulator.lic | Lizenz-Datei. Enthält Informationen bezüglich der Dauer der einzelnen Lizenzen. Diese Datei darf nicht verändert werden.
[Application Data]\data\emulator.rtc | Echtzeituhr-Datei. Diese Datei wird genutzt zur Speicherung der Daten welche im RTC des Tech2 anfallen.
[Application Data]\data\emulator.dta | Eine "Don't tell me again" Infodatei.. Diese Datei enthält Software Versionen, die nicht (mehr) die Warnung über die Beschränkung der Selbsttestmöglichkeiten wegen fehlendem Selbsttestadapter anzeigen sollen.
[Application Data]\data\candi.bin | CANdi Anwendungs-Datei. Hält die Anwendung des CANdi's welches mit dem Tech2 verbunden ist.
[Application Data]\data\eprom.bin | Tech2 interne EPROM-Datei. Beinhaltet den Inhalt des internen Tech2 Flashspeichers.
[Installation]\driver | Installationsdateien für die virtuelle Schnittstelle.
[Installation]\help\emulator_xx_XX.chm | Sprachabhängige Hilfedateien.
[User Data]\Logs | Enthält Log Dateien (Protokolldateien). Dateien, die älter als eine Woche sind, werden automatisch entfernt.
[User Data]\pcmcia | Beinhaltet PCMCIA Abbild Dateien. Bildlich gesprochen, jede Datei entspricht eine Tech2 PCMCIA Karte. Diese Dateien können an verschiedenen Stellen gespeichert sein.


Konfigurations-Management

Die Konfigurations Dateien befinden sich alle im Unterverzeichnis C:\Benutzer\Öffentlich\General Motors\Tech2Win\config und haben die Dateiendung *.conf. Mit Tech2Win kann man lediglich neue Konfigurationen erzeugen bzw. modifizieren, wenn kein Schreibschutz vorliegt. Alle anderen Verwaltungsaufgaben bezüglich der Konfigurations Dateien muss man mit dem Windows Explorer oder einem anderen Datei-Verwaltungsprogramm durchführen. Dies gilt für folgende Vorgänge:

  • Löschung von Konfigurations Dateien.
  • Umbenennungen von Konfigurations Dateien.
  • Änderung des Schreib/Lese-Attributes einer Konfigurations Datei.

Man sollte immer eine Konfigurations Datei default.conf haben. Normalerweise sollte diese Datei immer schreibgeschützt sein, um fehlerhaftes Überschreiben zu verhindern. Natürlich muss der Schreibschutz kurzfristig aufgehoben werden, wenn man die Datei an spezifische Bedingungen anpasst.

Die PCMCIA Dateien befinden sich im Unterverzeichnis C:\Benutzer\Öffentlich\General Motors\Tech2Win\pcmcia. Jede dieser Dateien ist vergleichbar mit einer PCMCIA Karte, die man vom Tech2 her kennt. Tech2Win gestattet die Verwendung von so vielen Dateien wie Sie nötig erachten. Kopieren Sie dazu einfach eine bereits bestehende Datei zu einer neuen Datei.

Wenn Sie eine bestimmte Konfiguration direkt starten wollen, so stellen sie einen Shortcut her, der folgendes ausführt: "C:\Programme\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Das Programm sollte folgendes Verzeichnis als Arbeitsverzeichnis verwenden: 'C:\Program Files\General Motors\Tech2Win\bin'

Die Anzahl der Konfigurations Dateien ist nicht abhängig von der Anzahl der verwendeten PCMCIA Dateien. Mehrere Konfigurations Dateien können dieselbe PCMCIA Datei verwenden. Dies entspricht dem Verfahren, wo in einer Werkstatt mehrere Nutzer sich den gleichen Tech2 (und somit auch die gleiche PCMCIA Karte) teilen.

Sie können natürlich jeder Konfigurations Datei ihre eigene PCMCIA Datei zuweisen. Dadurch werden die einzelnen Konfigurationen unabhängiger voneinander. Natürlich steigt dann der Aufwand beim Laden einzelner PCMCIA Karten an, was möglicherweise nicht akzeptabel ist.

Beim Anlegen einer neuen Konfiguration durch das Kopieren einer bestehenden gibt der Konfigurator immer dann eine Warnung aus, wenn die PCMCIA Datei identisch ist. In einem solchen Fall haben Sie zwei Konfigurationen, die dieselbe PCMCIA Datei verwenden. Wenn Sie das wirklich wünschen, so drücken Sie OK. Soll die neue Konfiguration eine andere oder neue PCMCIA Datei verwenden, so drücken Sie Abbrechen. Sie können dann mittels Kopiere Speicherkarte ... eine neue PCMCIA Datei erstellen.

Die folgenden zwei Beispiele zeigen, wie man die Konfigurations Dateien und PCMCIA Dateien verwalten kann.

Eine Konfiguration pro Nutzer

Sie haben die Möglichkeit eine Konfiguration pro Benutzer anzulegen. Als Name der Konfiguration ist der Benutzername wohl am sinnvollsten. Vorteil dieser Vorgehensweise sind die benutzerspezifischen Einstellungen wie ein benutzerbezogenes MDI, Anzeige und Spracheinstellung. Der Nachteil ist, dass die PCMCIA Dateien kopiert werden müssen, wenn sie von verschiedenen Benutzern verwendet werden soll. Natürlich können benutzerspezifische Konfigurationen eine zentrale PCMCIA Datei verwenden.

Eine Konfiguration pro Tech2 Software-Version

Für jede Software, die man herunterlädt kann man eine neue Konfiguration herstellen. Auf diese Weise sind dann sogar ältere Software Versionen sofort verfügbar. Oftmals wird in einer Konstellation der Name der Software mit der Versionsnummer als Konfigurationsname verwendet.

  • Erste Schritte: Diagnoseschnittstelle
  • Erste Schritte: Pfad
  • Weitere Themen: Konfigurationsdatei
  • Installation: Installationsschritte


Häufig gestellte Fragen (FAQ)

  • Wie erkennt man die COM Schnittstelle, die man für Tech2Win nutzen kann?
  • Kommunikation zwischen Tech2Win und TIS2Web
  • Gültige Lizenz
  • Was sagt die Lizenznummer aus?
  • Was ist der Unterschied zwischen einer Tech2Win Lizenz und der Zugangsberechtigung?
  • TIS2Web zeigt einen unspezifischen Fehler an bei der Durchführung der Zugangsberechtigung mit der Initialsoftware
  • Tech2Win führt Tech2 Software, die aus einer anderen Vertriebsorganisation stammt, nicht aus.
  • Wie kann man mehr als ein MDI verwenden?
  • Logdatei enthält den Fehler "CPU32: Too many 0000/FFFF Commands encountered"
  • Kein Tech2 Fenster sichtbar
  • SPS funktioniert nicht
  • Manche Selbsttests funktionieren nicht
  • Die Geschwindigkeitsanzeige fluktuiert
  • Plötzliches Anhalten
  • Bei Software 15.001 wird Schwedisch angezeigt
  • Kommunikationsverlust mit MDI
  • Tech2Win hat das MDI nicht gefunden
  • Ich möchte Tech2Win direkt starten, ohne mich mit dem Konfigurator zu beschäftigen
  • Wo sind die Druckfunktionen?
  • Ein nicht verwendetes Verzeichnis PCMCIA existiert auf meinem Rechner.
  • Ich erhalte eine Nachricht 'illegaler Dateipfad'.

Wie erkennt man die COM Schnittstelle, die man für Tech2Win nutzen kann?

Der Gerätemanager von Windows kann hierfür verwendet werden. Suchen Sie nach "Ports (COM & LPT)". Manche Computer haben interne Modems oder Bluetooth Anschlüsse, die leider in dieser Übersicht nicht auftauchen.
Eine andere Methode ist die Verwendung eines kleinen Programms, das mit dem Konfigurator ausgeliefert wird. Führen Sie es über Ihr Startmenü aus (Tech2Win Verzeichnis) indem Sie auf "show com ports" klicken.
Beide Methoden zeigen die COM-Ports, die auf dem Rechner im Gebrauch sind und nicht genutzt werden sollten.

Kommunikation zwischen Tech2Win und TIS2Web

Tech2Win muss bereits laufen bevor die Kommunikation mit TIS2Web für Sicherheitsabfragen oder Software Download durchgeführt wird. TIS2Web kann den virtuellen COM-Port nur erkennen, wenn Tech2Win zuvor gestartet wurde.

Gültige Lizenz

Normalerweise erteilt bereits die Anwendung 'Übertragung Diagnosesoftware (SWDL)' innerhalb von TIS2Web eine gültige Lizenz. Sollten Sie noch immer keine Lizenz erhalten haben, so muss die 'Zugangsberechtigung (Sicherheit)' mittels TIS2Web durchgeführt werden um eine gültige Lizenz zu erhalten. Bitte führen Sie keine TIS2Web Kommunikation mit dem Tech2Win durch, wie 'Übertragung Diagnosesoftware (SWDL)' bevor Sie eine Lizenz mittels 'Zugangsberechtigung (Sicherheit)' geholt haben.

Was sagt die Lizenznummer aus?

Die Lizenzdauer rechts in der Statuszeile zeigt die Anzahl der vollständigen Lizenztage. Sofort nach dem Herunterladen neuer Tech2 Software bzw. dem Durchführen einer Zugangsberechtigung werden 30 Lizenztage angezeigt. Nach einem Neustart von Tech2Win werden allerdings nur 29 Lizenztage angezeigt, da die Lizenzdauer vermutlich nur noch etwa 29 Tage, 23 Stunden und 55 Minuten beträgt. Ist die Lizenzdauer kleiner als 24 Stunden, so wird als Dauer <1 angezeigt. Eine 0 wird angezeigt wenn die Lizenz abgelaufen ist.

Was ist der Unterschied zwischen einer Tech2Win Lizenz und der Zugangsberechtigung?

Die Tech2Win Lizenz ermöglicht die Benutzung von Tech2Win. Um eine solche Lizenz zu erhalten muss man entweder 'Übertragung Diagnosesoftware (SWDL)' oder 'Zugangsberechtigung (Sicherheit)' in regelmäßigen Abständen durchführen (meistens: alle 30 Tage). Bereits der mögliche Download via TIS2Web zeigt, dass ein gültiger Benutzer vorliegt. Die Zugangsberechtigung, bekannt vom Tech2, teilt auch dem Tech2Win mit, dass bestimmte sicherheitskritische Tätigkeiten wie das Abschalten eines Airbags erlaubt sind. Beides, die TechWin Lizenz und der Zugriff auf sicherheitsrelevante Funktionen, werden mit dem Modul Zugangsberechtigung ermöglicht. Tech2Win zeigt die verbleibende Lizenzdauer rechts in der Statuszeile an. Leider kann Tech2Win die verbleibende Dauer für sicherheitsrelevante Funktionen nicht anzeigen, da Tech2Win lediglich Tech2 Code ausführt, aber die Internas dieses Codes nicht kennt.

TIS2Web zeigt einen unspezifischen Fehler an bei der Durchführung der Zugangsberechtigung mit der Initialsoftware

Das Verhalten ist mit dem des Tech2 identisch. Aufgrund seines Alters kann die Initialsoftware keine Lizenz von TIS2Web erhalten. Allerdings ist dies kein Problem, da diese Demonstrationssoftware mit einem Fahrzeug kommuniziert wofür keine Lizenz notwendig ist. Weil Lizenzen immer für einen TIS2Web Downloadbereich spezifisch sind, würden Sie nach einem Download der Tech2 Software sowieso erneut eine Lizenz benötigen. Eine "Lizenz" für die Initialsoftware würde Ihnen also die Fahrzeugkommunikation mit einem Fahrzeug von North American Operations oder Opel/Vauxhall Software nicht gestatten.

Tech2Win führt Tech2 Software, die aus einer anderen Vertriebsorganisation stammt, nicht aus.

Ihre Tech2Win Version ist vermutlich auf eine Anzahl von TIS2Web Downloads (Regionen) beschränkt. Drücken Sie Hilfe / Info über um die Beschränkungen ihrer Tech2Win Version zu sehen. Frühe Versionen von Tech2Win erlaubten lediglich das Ausführen von Opel/Vauxhall Software. Andere GM Regionen werden im Laufe der Zeit folgen. Tech2Win ist in jedem Fall in der Lage, Tech2 Software von General Motors auszuführen.

Wie kann man mehr als ein MDI verwenden?

Will man spezifische MDIs bestimmten Personen zuordnen, so sollte jeder Benutzer seine eigene Konfiguration haben. Zur Übersichtlichkeit sollten diese Konfigurationen auch nach dem jeweiligen Benutzer benannt sein. Sie sollten in jeder Konfiguration im Tab 'Diagnoseschnittstelle' die benutzerspezifische Seriennummer des MDI angeben. Sobald der Benutzer die Konfiguration startet, wird Tech2Win versuchen mit dem angegebenen MDI zu kommunizieren. Falls das MDI nicht gefunden wird, wird eine Auswahlbox mit den gefundenen MDIs angezeigt.

Haben Sie mehrere MDIs für den allgemeinen Gebrauch, so schlagen wir vor, dass Sie Konfigurationen verwenden, worin die Seriennummer der Schnittstelle im Tab 'Diagnoseschnittstelle' nicht angegeben wird. Eine Auswahlbox mit allen verfügbaren MDIs wird angezeigt.

Logdatei enthält den Fehler "CPU32: Too many 0000/FFFF Commands encountered"

Die Datei 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' oder die aktuelle PCMCIA Datei sind kaputt. Bitte führen Sie eine Reinstallation von Tech2Win durch und einen neuen Tech2 Software Download.

Kein Tech2 Fenster sichtbar

Falls kein Tech2 Fenster sichtbar ist, befindet sich dieses vielleicht in einem Bereich außerhalb des dargestellten Bildschirms. Sie werden auf solche Effekte treffen wenn Sie mehr als einen Bildschirm verwenden oder nach Veränderung der Bildschirmauflösung. Drücken Sie die Shift Taste auf Ihrer Tastatur während des Starts Ihrer Konfiguration. Im diesem Falle wird die Bildschirmauflösung auf 640x480 gesetzt und das Tech2 Fenster wird in der oberen linken Ecke des Fensters angezeigt. Sie können, um den gleichen Effekt zu erreichen, auch die Datei C:\Benutzer\Öffentlich\General Motors\Tech2Win\emulator.disp löschen.

Verschiedentlich kam es vor, dass der Tech2-Bildschirm nicht neu aufgebaut wurde, nachdem alle anderen Fenster minimiert wurden. Bislang war es in allen Fällen möglich, mittels der Alt-Tab Taste zur Tech2Win Applikation umzuschalten um damit das Fenster neu anzeigen zu lassen. Manchmal führte das Drücken der Tech2Win Schaltfläche in der Taskleiste nicht zum Erfolg. Das Problem wird zurzeit untersucht und vermutlich in einer Folgeversion behoben sein.

SPS funktioniert nicht

Ja, das ist bekannt. Es gibt keine Pläne, dies zu ändern. Bitte benutzen Sie Tech2Win nicht als Tech2-Ersatz bei SPS. Bitte verwenden Sie das MDI direkt in der SPS Programmierung.

Manche Selbsttests funktionieren nicht

Tech2 Selbsttests sollen die individuellen Teile der Tech2 Hardware testen. Einige dieser Tests benötigen einen Loopback Adapter. Diese Tests funktionieren jedoch nicht in Tech2Win, da die Loopback Adapter Funktionalität nicht implementiert ist (und hierzu auch keine Pläne existieren). Bitte nehmen Sie Abstand von diesen Tests in Tech2Win. Falls Sie diese dennoch ausführen, kann es zu fehlerhaften Ergebnissen oder Abstürzen kommen. Benutzen Sie Ctrl-R um Tech2Win in solchen Fällen zurückzusetzen.

Die Geschwindigkeitsanzeige fluktuiert

Die Geschwindigkeitsanzeige in der Statuszeile unten links gibt an, wie viele 'Tech2 Befehle' noch ausgeführt werden können bevor Tech2Win wieder 'schlafen' muss. Auf diese Weise wird die Geschwindigkeit von Tech2Win an die reale Zeit angepasst: schnellere PCs 'schlafen mehr' als langsamere PCs. Wandert die Geschwindigkeitsanzeige hin- und her, so verwendet ein anderes Programm PC Leistung oder die PC Taktung variiert. Hohe Fluktuationsraten können sich auf die Fahrzeugkommunikation und die TIS2Web-Verbindung negativ auswirken. Vergewissern Sie sich, dass keine anderen Applikationen laufen.

Die meisten Laptops reduzieren die Taktung um Akkulaufzeiten zu maximieren. Auch dies kann der Grund für die von Tech2Win angezeigten Geschwindigkeitsfluktuationen sein. In einem solchen Fall lassen Sie Ihren Laptop bitte nicht über Akku sondern über die externe Stromversorgung laufen. Versuchen Sie bitte auch, die Energie-Einstellungen so vorzunehmen, dass das Betriebssystem die Taktung nicht reduziert.

Plötzliches Anhalten

Erkennen Sie innerhalb der LOG Datei keinerlei Grund warum Tech2Win beendet wurde, so könnten eingebaute Sicherheitsmechanismen aktiv geworden sein. Bitte modifizieren Sie folgende Dateien unter keinen Umständen: emulator.sec, emulator.lic, emulator.card. Erkennt Tech2Win eine Verletzung seiner internen Sicherheitsmechanismen, so wird sehr wahrscheinlich eine Neuinstallation notwendig.

Bei Software 15.001 wird Schwedisch angezeigt

Die Initialsoftware, die bei Tech2Win mit installiert wird, ist eine Demo-Software, welche auf jeder neuen PCMCIA Karte aufgespielt ist. TIS2Web gibt an, dass diese in schwedischer Sprache vorliegt, da TIS2Web immer nur die letzte Sprache anzeigt, die von dieser Demo Software unterstützt wird (Englisch, Französisch, Deutsch, Schwedisch). Benutzen Sie den Aktualisierungsmodus 'Benutzerdefiniert' anstelle von 'Standard' um die Demo Software mit der neuesten Diagnose Software zu überschreiben.

Kommunikationsverlust mit MDI

Ein Verlust der MDI-Kommunikation kann verschiedene Gründe haben.

  • Verbindungsprobleme beim Ethernet oder USB Kabel.
  • Unzuverlässige Funkverbindung.
  • PC geht in den Standby-Modus.

Tech2Win hat das MDI nicht gefunden

Überprüfen Sie folgende Punkte:

    1. Ist das MDI aktiv?
    2. Funktioniert der MDI Manager?
    3. Wird das MDI gerade von einer anderen Applikation wie beispielsweise SPS verwendet?
Der MDI Manager wird mittels seines Desktop Icons oder mittels "Start/All Programs/General Motors/GM MDI Software" gestartet.: Rufen Sie den Helpdesk an, wenn Sie mit Punkt 2 Schwierigkeiten haben.

Ich möchte Tech2Win direkt starten, ohne mich mit dem Konfigurator zu beschäftigen

Führen Sie "C:\Programme\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf" aus. Verwenden Sie das Arbeitsverzeichnis "C:\Program Files\General Motors\Tech2Win\bin". Der Konfigurator kann weiterhin verwendet werden, um diese Konfiguration abzuändern.

Wo sind die Druckfunktionen?

Tech2Win bietet keine direkte Druckfunktionen an. Stattdessen erzeugt Tech2Win temporäre Dateien und ruft die mit der Dateiendung verknüpften Programme auf. Diese Programme können sowohl zum Ausdrucken genutzt werden als auch zum Ändern der Darstellung.

Print Report | Print Report

Um den aktuellen Tech2Win Bildschirm auszudrucken, verwenden Sie bitte Datei / Tech2-Bildschirm drucken oder die Schaltfläche auf der Tastatur mit einem Druckersymbol. Um mehrere Tech2Win Bildschirme zu drucken, können Sie den Menüeintrag Optionen / Automatische Screenshots verwenden, da dieser PNG Dateien bei jeder Bildschirmänderung erzeugt. Diese PNG Dateien sind in der log Datei eingebettet.

Die Datenliste kann man ebenfalls ausdrucken (aktivierbar durch den Menüeintrag Fenster / Tech2Win Datenliste). Verwenden Sie dafür die Schaltfläche Drucken/HTML Start um die Datenaufnahme zu starten und danach zu stoppen. Nach dem Stoppen der Datenaufnahme wird ein HTML-verknüpftes Programm (meistens Internet Explorer) gestartet, das ausreichend Druckmöglichkeiten bietet.

Data Display | Data Display

Ein nicht verwendetes Verzeichnis PCMCIA existiert auf meinem Rechner.

Frühere Versionen von Tech2Win legten immer eine zweite Kopie von PCMCIA Dateien in eine solchen Verzeichnis ab. Oft war der Name des Verzeichnisses C:\PCMCIA. Inzwischen ist dieses Zweitverzeichnis nicht mehr notwendig, da der schnelle Download von TIS2Web eine zusätzliche Speicherung überflüssig macht. Das Verzeichnis kann also gelöscht werden.

Ich erhalte eine Nachricht 'illegaler Dateipfad'.

Der Dateiname scheint unzulässige Zeichen wie das Prozentzeichen (%) zu enthalten. Wenn Sie dieses Problem direkt nach einer Installation sehen, führen Sie am besten eine Deinstallation durch und danach eine erneute Installation. Die meisten Fälle können mit dieser Methode gelöst werden.

Während einer normalen Installation wird die Umgebungsvariable 'Tech2WinUserData' auf 'PUBLIC' gesetzt (für Windows Versionen >= Vista) oder auf 'ALLUSERSPROFILE\Documents' (für Windows Versionen vor Vista). In einigen seltenen Fällen wurde die Umgebungsvariable während der Installation nicht gesetzt aber bei einem zweiten Versuch funktionierte es. Sie können auch die Umgebungsvariable manuell setzen. Fragen Sie Ihren Administrator um Hilfe, wenn Sie nicht wissen, wie man eine Umgebungsvariable setzt.


Registry Einträge

Folgende Registry Einträge werden vom Installer hergestellt. Bitte ändern Sie diese Einträge nicht per Hand ab. Beachten Sie bitte die Windows-Hinweise im Umgang mit Registry Einträgen.

Schlüssel | Name | Typ | Bedeutung
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Interne Versionsnummer
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Sprache | REG_SZ | Sprache während der Installation
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Der Pfad des PCMCIA Kopieverzeichnisses
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Root | REG_SZ | Installationspfad
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | UninstallOption | REG_DWORD | Deinstallation Einstellungen
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Version der Config Datei
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Version des virtuellen COM-Port Treibers
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Name der Software in der Hinzufügen/Ändern Liste von Software
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Pfad auf das Deinstallationsprogramm


Reinstallation

Die Reinstallation löscht das gesamte Installationsverzeichnis von Tech2Win, mit folgenden Ausnahmen.

  1. Das config Unterverzeichnis, welches die Konfigurationen enthält, wird nicht gelöscht.
  2. Das pcmcia Unterverzeichnis, wo normalerweise die PCMCIA Abbilder liegen, wird nicht gelöscht.
  3. Das ATA Unterverzeichnis, welches manchmal Debug Information enthält, wird nicht gelöscht.
Konfigurations Dateien können inkompatibel werden: Es gibt keine Garantie, dass die Konfigurations Dateien einer alten Tech2Win Version auch mit einer neuen Tech2Win Version lesbar sind. Per Prinzip können PCMCIA Images nicht inkompatibel werden.

Das zweite PCMCIA Verzeichnis wird nicht beeinflusst von einer Reinstallation.

Manche Umgebungen bieten eine automatische Installation neuerer Tech2Win Versionen an. Die letzten Installationsinformationen welche in der Registry stehen, diese Einstellungen werden als Standardwert für eine Reinstalltion genutzt.

Eine Neuinstallation kann durch die Verwendung des enable reinstallation Skripts erzwungen werden. Das Skript wird mit Tech2Win zusammen installiert. Dieses Skript setzt den Wert des Schlüssels CurrentVersion im Bereich HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win der Registry auf den Wert "1.000".