Brugervejledning til Tech2Win

Velkommen til brugervejledningen til Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Alle rettigheder forbeholdes.

  • Introduktion:
  • Licens:
  • Installation:En beskrivelse af installationsproceduren til Tech2Win.
    • Installationstrin
    • Grænseflade til køretøjskommunikation
  • De indledende trin
    • Valg af konfiguration
      • Tastatur
      • Sådan håndteres vinduer
    • Nye konfigurationer
    • Ændring af konfigurationer
      • Sprog
      • Sti
      • Billedskærm
      • Sådan gemmes en konfiguration
    • Anskaf en gyldig Tech2Win-licens
  • Sådan arbejdes der med Tech2Win: Detaljer vedrørende det daglige arbejde.
    • Menu
    • Sådan hentes et PCMCIA-billede
    • Sikkerhed
    • Vis rapporter
    • Sådan håndteres PCMCIA-billeder
    • Statuslinjen
  • Avancerede emner: Oplysninger som ikke kræves ved almindelig anvendelse af Tech2Win. Oftest er det kun af interesse for personer med administrative opgaver.
    • Geninstallation
    • Afinstallation
    • Konfigurationsfilens format
    • Logfil
    • Fejlmeldinger og -koder
    • ATA-kort
    • Poster i registreringsdatabasen
    • Filer
    • Konfigurationsstyring
  • Ofte stillede spørgsmål


Introduktion

Tech2Win er et Windowsbaseret program, der kan emulere Tech2's funktioner. I al væsentlighed afvikles Tech2-softwaren på en pc. For at kunne køre dette program, stilles der følgende tekniske krav til pc'en:

  • Der skal være installeret og tilkoblet et grænsesnit til køretøjskommunikation til pc'en. Listen over acceptable græsesnit kan variere fra land til land. I det fleste tilfælde kan GM's Multiple Diagnostic Interface (MDI) anvendes.
  • Tech2Win-programmet kræver 150 MB ledig harddiskkapacitet under installationen. Yderligere 32 MB er nødvendigt for hvert PCMCIA-kort, der skal administreres.
  • Før afviklingen af Tech2Win-programmet skal der være mindst 100 MB ledig fysisk RAM-kapacitet. Det er obligatorisk, at pc'en har tilstrækkelig med hukommelse til at indeholde programmet i RAM-hukommelsen hele tiden under afviklingen.
  • Pc'en skal være udstyret med en regnekraft svarende til en 1,2 GHz Pentium (enkelt kerne). Det anbefales kraftigt at ikke benytte andre programmer i parallel anvendelse.
  • Det er ikke behov for et tastatur. Tech2Win kan også betjenes via en berøringsskærm. Til brug for konfigurationsstyring anbefales det kraftigt at anvende et tastatur, da det er nødvendigt at indtaste filnavne.
  • Den grafiske farveskærm skal mindst have en opløsning på 800 x 600 og mindst en farvedybde på 256. Uden et tastatur kan der accepteres en opløsning på 640 x 480.

Når Tech2Win anvendes (på en bærbar pc i stedet for Tech2) skal det sikres, at der er tilstrækkelig strøm på den bærebare pc. Normalt forsynes den bærbare computer ikke med strøm fra bilakkumulatoren, sådan som Tech2 gør det.

  • Installation
  • De indledende trin


Licens

General Motors - Tech2Win Licensaftale

Læs omhyggeligt følgende vilkår og betingelser igennem før brug af programmet. Hvis du ikke kan acceptere eller ikke forstår disse vilkår og betingelser, kontakt da din lokale Eftersalgs-repræsentant. Retten til at bruge denne software er givet i licens af General Motors på den betingelse, at brugeren accepterer denne licens ved at acceptere disse vilkår og betingelser under installationen af Tech2Win.
General Motors tildeler retten til at benytte Tech2Win og de medfølgende informationer sammen med TIS2Web eller GlobalTIS eller TIS2000 udelukkende til brugere af General Motors's netværk af autoriserede værksteder, som er fastlagt i den lokalt gældende aftale for autoriserede værksteder med General Motors's nationale salgsselskaber.
Tech2Win-licensen er gyldig så længe den autoriserede værkstedsaftale er i kraft og TIS2Web-, GlobalTIS- og TIS2000-licensen er på plads. Tech2Win-licensen ophører samtidig med TIS2Web og GlobalTIS-licensen, så snart aftalen som autoriseret værksted ophører.

Uafhængige værksteder som defineret i Artikel 4, stk. 2 i European Union Block Exemption Regulation (BER) 1400/2002 kan købe en Tech2Win-licens som en del af de tilbudte abonnementer, der stilles til rådighed på General Motors Europe's GM Europe Info Tech Portal.

Tech2Win-licensen omfatter ikke bilkommunikations-interfacet eller pc-hardwaren.

Tech2Win-softwaren må ikke distribueres videre, sælges eller lægges online for nogen tredjepart uden for det autoriserede værksteds faciliteter (som beskrevet i det relevante tillæg til den autoriserde værkstedsaftale) uden skriftlig accept fra det relevante salgsselskab for General Motors. Dette gælder både for aktuelle og ikkeaktuelle data (så som udløbne dvd'er).

General Motors's nationale salgsselskaber har ret til straks at lukke adgangen og varsle øjeblikkelig ophævelse af den autoriserede værkstedsaftale i tilfælde af ulovlig brug eller misbrug. I så tilfælde vil retten til at kræve refusion af udestående kredit og/eller årsabonnementer bortfalde.

De leverede informationer tjener til sagkyndig udførelse af service- og reparationsarbejde på umodificerede General Motors-køretøjer. En gennemført uddannelse som mekaniker samt regelmæssig videreuddannelse kræves som forudsætning for udførelsen af førnævnte arbejde. Hvor brugen af specialværktøjer er angivet i de leverede informationer, er sådanne specialværktøjer obligatoriske for alle reparationer, som skal udføres på sagkyndig måde.

De informationer, som offentliggøres på Tech2Win for General Motors (tekst og billeder, musik, grafik, animationer, videoer mv.) og organiseringen deraf på Global TIS er copyright-beskyttet. Ingen reproduktion, udbredelse, kommunikation og/eller udsendelse eller anden brug er tilladt uden forudgående skriftlig tilladelse fra General Motors.

  • Installation: Installationstrin
  • De indledende trin


Installation

Installation af Tech2Win kræver lokale administratorrettigheder til pc'en. Installationen fungerer ikke uden administrative rettigheder. Kontakt i så fald den lokale pc-administrator for yderligere hjælp.

For at lykkes med anvendelsen af Tech2Win skal følgende 2 trin fuldføres:

  • Installation af selve Tech2Win.
  • Installation af grænseflade til køretøjskommunikation
  • Installation: Installationstrin
  • De indledende trin


Installationstrin

Selve installeringen tager kun et par minutter og kræver følgende brugerindtastninger:

  1. Licensaftale
  2. Installationsmappe

Sprog

Som standard vises brugergrænsefladen i Tech2Win på det sprog, der anvendes i operativsystemet. Følgende sprog understøttes almindeligvis. Hvis sproget ikke understøttes, starter installeringen på engelsk som standardsprog.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Engelsk (enten britisk eller amerikansk)*
  • el_GR (EL)Greek
  • es_ES (ES)Spansk
  • fi_FI (FI)Finnish
  • fr_FR (FR)Fransk
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugisisk (Brasilien)
  • pt_PT (PT)Portugisisk (Portugal)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Kinesisk (forenklet)
  • zh_TW (ZH)Kinesisk (traditionelt)

* Sproget i Tech2Win er britisk engelsk. Det kan dog være, at det Tech2-programmel og installeringsprogram, der anvendes, er på amerikansk engelsk, alt afhængig af kilden til programmellet.

Licensaftale

Licensaftalens indhold skal accepteres.

Installationsmappe

Der kan vælges en hvilken som helst mappe, som den placering hvortil Tech2Win installeres. Installationsmappen har enten som standardindstilling <Programmappe>\General Motors\Tech2Win, eller i tilfælde af en geninstallation den placering, der valgtes forrige gang.

Bekræft til allersidst installationen.

Virtuel com-portdriver

Den virtuelle com-portdriver installeres kun én gang på computeren og forbliver der, indtil driverversionen opgradereres, hvilket sjældent sker, eller Tech2Win afinstalleres af computeren.
Hvis driveren installeres, vises der en DOS-boks et kort øjeblik. Den lukkes automatisk og kræver ingen yderligere handling. Driverfilerne placeres yderligere i undermappen 'driver' i installationsmappen på Tech2Win.
Det er muligt, men kan ikke anbefales, at installere og afinstallere de virtuelle com-portdrivere manuelt. Anvend én af de efterfølgende kommandoer fra CMD-shell'en:

  • Kald 'vbsetup7' for at installere driveren
  • Kald 'vbsetup7 /u' for at afinstallere driveren
  • De indledende trin


Grænseflade til køretøjskommunikation

Køretøjskommunikationsudstyret skal installeres særskilt. Se i den medfølgende installationsvejledning til Grænseflade til køretøjskommunikation for at få flere oplysninger

  • De indledende trin: Grænseflade til køretøjskommunikation
  • Avancerede emner: Konfigurationsfil
  • Installation: Installationstrin
  • Ofte stillede spørgsmål: Hvordan er det muligt at benytte mere end én MDI?
  • Ofte stillede spørgsmål: Tech2Win kunne ikke finde MDI'en


De indledende trin

Disse indledende trin viser, hvordan Tech2Win anvendes. Det forudsættes, at du har kendskab til selve Tech2. Der kræves ingen køretøjskommunikation under disse først trin.

Gør følgende for en hurtig start:

  1. Kør Tech2Win-programmet ved hjælp af genvejstasten Hurtig Start på skrivebordet.
  2. Få en gyldig licens ved at hente ny Tech2-programmel fra TIS2Web.

Sådan anvendes en valgbar konfiguration:

  1. Start konfiguratoren via genvejstasten Tech2Win på skrivebordet. Efter en installation bør der findes en standardindstillet konfiguration.
  2. Kopier fortrinsvis default konfigurationen for at lave en ny konfiguration.
  3. Rediger en eksisterende konfiguration til at imødekomme de specifikke krav.
  4. Anskaf en gyldig licens.

Du må ikke starte Tech2Win i kompatibilitetstilstand. Der vises i så fald en advarsel i logfilen. Tech2Win bruger kun Windows-funktioner, der har eksisteret siden XP, og fungerer ikke på tidligere versioner af Windows.

  • De indledende trin: Nye konfigurationer
  • De indledende trin: Ændring af konfigurationer
  • De indledende trin: Grænseflade til køretøjskommunikation
  • Sådan arbejdes der med Tech2Win: Menu
  • Sådan arbejdes der med Tech2Win: Sikkerhed
  • Sådan arbejdes der med Tech2Win: Statuslinjen
  • Avancerede emner: Konfigurationsfil


Valg af konfiguration

Første gang Tech2Win-programmet startes, fremkommer følgende skærmbillede. Der er mulighed for at starte Tech2Win direkte med en standardindstillet konfiguration. Denne standardindstillede konfiguration fungerer uden nogen køretøjskommunikation.

Start First Time

Meddelelsesboksen med licensoplysninger vises, men den kan ignoreres ved start af standardkonfigurationen

Hvis der anvendes en berøringsskærm, kan der nok med fordel aktiveres et program, som simulerer et pc-tastatur til indtastning af bogstaver.


Tastatur

Både pc-tasterne og knapperne, hvis de vises, tilknyttes til de kendte Tech2-taster. Der findes nogle ekstra taster på Tech2Win, som ikke findes på det originale Tech2. Pc’ens numeriske tastatur fungerer ikke i alle tilfælde. Kontroller, om der har været ændret på pc'ens standardtastaturlayout, hvis der opstår problemer. Især kan skift-tasten blive beskadiget i sådanne tilfælde.

Pc-tastatur | Knap | Funktion
Funktionstasten F1 | ikke angivet | Tech2Win-Hjælp
Funktionstasterne F5 .. F8 | Anvend Tech2Win-visningsområdet, som optages af skærmtasterne | Tech2's 4 SK-taster
Piletasterne Op, Ned, Venstre og Højre |  | Tech2-tasterne Op, Ned, Venstre og Højre. Det er kunne disse taster, der er udstyret med en automatisk gentagelsesfunktion.
Numeriske taster 0 .. 9 | F0 • • • F9 | Tech2-tasterne F0 .. F9
Tasten Tilbage | Exit | Tech2-tasten Afslut
Enter/Retur | Enter | Tech2-tasten Enter
Y | Yes | Tech2-tasten Ja
N | No | Tech2-tasten Nej
Q | ? | Tech2-tasten ?
S | Shift | Tech2-tasten Skift. Skift-angivelsen i statuslinjen eller angivelsen over knappen Skift angiver den aktuelle status.
ctrl-P | PWR | Tech2-tasten Strøm; Det er oplagt, at denne taste kun kan afslutte Tech2Win-programmet.
ctrl-R | ikke tilgængelig | Nulstiller Tech2Win. Svarer til en tænd-sluk-cyklus på en Tech2. En tilknyttet grænseflade til køretøjskommunikation nulstilles dog ikke. Filer som PCMCIA-billedet genindlæses ikke.
Til start | Home | En starttaste. Understøttes kun af nogle programmer.
kun tilgængelig via menuindstillingen Fil. | Print Screen | Udskriv et skærmudklip af Tech2-skærmbilledet ved at oprette en midlertidig BMP-fil og kalde det program, der er tilknyttet BMP-filer. Anvend det program til at tilpasse størrelsen på billedet eller rotere det, inden det skrives ud.
kun tilgængelig via menuindstillingen Fil. | Save Screen | Gemmer et skærmbillede af Tech2-skærmen som en BMP- eller PNG-fil.
kun tilgængelig via menuindstillingen Fil. | View Report | Viser alle rapporter om de aktive PCMCIA-flashkort, så brugeren kan få dem vist.


Sådan håndteres vinduer

Det er muligt at tilpasse størrelsen på vinduerne ved hjælp af Windows standardmekanismer ved trække i kantlinjerne på hovedvinduet. Desuden understøtter menupunktet Indstillinger/Opløsning flere forudindstillede størrelser. Ved en ændring af hovedvinduets størrelse via et menupunkt forbliver vinduet med det numeriske tastatur automatisk forankret.

Vinduernes udseende ændres ved at skifte konfiguration i Fanebladet Billedskærm.


Nye konfigurationer

Klik på knappen Opret ny for at oprette en ny konfiguration. Der fremkommer en dialogmenu, hvori der bedes om at vælge en eksisterende konfigurationsfil som kilde. Normalt vælges den standardindstillede konfiguration. Når navnet på den nye konfigurationsfil er indtastet, så tryk på knappen Kopier.

Hvis der anvendes en berøringsskærm, kan der nok med fordel aktiveres et simuleret pc-tastatur med knappen Pc-tastatur.

Oprettelsen kan annulleres med knappen Annuller.

Den ny konfiguration anvender samme PCMCIA-fil som den eksisterende kildekonfiguration. Hvis der skal laves om på det, skal konfigurationen ændres sådan, at der anvendes en anden PCMCIA-fil. I de fleste tilfælde er det enkleste at kopiere den eksisterende PCMCIA-fil til en ny fil og anvende den nye fil. Måske foretrækker du, at den nye konfiguration anvender den samme PCMCIA-fil som kildekonfigurationen. I så fald fremkommer der en advarselsbesked, når der trykkes på knappen Gem.

  • Ændring af konfigurationer


Ændring af konfigurationer

Konfigurationer, der er vist med blå tekst, er mærket Skrivebeskyttet og kan ikke ændres. Disse konfigurationer kan kun vises. Naturligvis kan ændringsmetoden anvendes blot til at vise deres indhold, men det er ikke muligt at gemme dem med Gem.

Der foretages ændringer på en konfiguration ved at markere den enkelte indstilling under de 4 faneblade Sprog, Grænseflade til køretøjskommunikation, Sti og Billedskærm. Du kan enten vælge den ønskede tabulator eller blot klikke på knappen næste, som aktiverer den næste tabulator. Tryk på knappen Gem for at gemme konfigurationen efter at have foretaget ændringerne.

Når det er nødvendigt at indtaste data, kan der desuden fremkaldes et pc-program, som simulerer et pc-tastatur. Det er især praktisk på bærbare pc'er med berøringsskærme, når der ikke findes noget tastatur.


Sprog

Fanebladet Sprog giver mulighed for at vælge det sprog, som Tech2Win skal køre på. Dette valg påvirker ikke sproget i Tech2-programmet på PCMCIA-billedet. Ved hentning af Tech2-software fra TIS skal det korrekte sprog stadigvæk vælges.

I nogle lande kan ikke alle sprog vælges. I sådanne tilfældes er sproget i stedet for engelsk. Kontroller om, der er et lignende sprog tilgængeligt (PT portugisisk (Portugal) i stedet for PB portugisisk (Brasilien)).


Sti

Fanebladet Sti giver mulighed for at indstille stierne til både PCMCIA-billeder og det lokale softwaretastatur. Desuden findes knappen Kopier hukommelseskortet til kopiering af PCMCIA-billeder. Hvis der lige er oprettet en ny konfiguration, kunne det være hensigtsmæssigt at anvende denne knap for at undgå, at flere konfigurationer benytter det samme PCMCIA-billede.

Memory Card Options

Kopier hukommelseskortet ...

Denne knap giver mulighed for at kopiere et PCMCIA-billede til en anden fil. Den funktions er meget lig anskaffelsen af et nyt PCMCIA-kort til Tech2. Kopifunktionen virker kun for filer, der ligger i mappen C:\Users\Public\General Motors\Tech2Win\pcmcia.

Kortplads nr. 0: Placering af hukommelseskortafbildning

Her kan den fil angives, der indholder PCMCIA-billedet til kortplads nr. 0. Normalt skal en sådan fil findes i C:\Users\Public\General Motors\Tech2Win\pcmcia, men andre placeringer er også mulige.

Kortplads nr. 1: Hukommelseskort eller ATA

Ligesom Tech2 understøtter Tech2Win også 2 PCMCIA-kort (-billeder). Dog er det andet PCMCIA-billede inden for en konfiguration normalt ikke særlig nyttigt. Der anvendes formodentligt en anden software i en anden konfiguration.

Ligesom på et Tech2 anvendes der et ATA-kort til fejlfindingsformål. ATA-kortet må kun aktiveres, hvis den tekniske støtte anmoder om det. De giver nærmere oplysninger om det.

Placering af pc-softwarens tastatur

Denne fils standardværdi hentes fra Windows registreringsdatabasen og skal pege på et program, som er i stand til at simulere et pc-tastatur med musen. Hvis du har et særligt program med denne funktion til den benyttede bærbare pc, kan programmet angives her:


Grænseflade til køretøjskommunikation

  • COM-port til Tech2-RS232-emulering
  • Det MDI-serienummer, der skal anvendes
  • Protokol

COM-port til Tech2-RS232-emulering

Vælg en ledig COM-port, der kan anvendes til Tech2-emuleringen. Konfiguratoren forsøger af praktiske hensyn at finde ud af, hvilke serielle porte, der allerede benyttes, og viser dem.

Hvis der vælges en eksisterende COM-port, hæfter Tech2Win sig på denne eksisterende COM-port. Denne COM-port kan benyttes til at hente Tech2-programmer med fra en anden computer, der kører et TIS-program ved hjælp af et null-modemkabel. Vær opmærksom på, at anvendelsen af en rigtig COM-port muligvis ikke virker pålideligt med 115.200 baud som følge af begrænsninger under Windows.

Hvis der vælges en ikke-eksisterende COM-port, opretter Tech2Win automatisk en virtuel port. Denne virtuelle port kan anvendes fra TIS, der kører på same pc, til kommunikation med Tech2Win. Når der anvendes en virtuel port, er den ingen begrænsning i baudhastigheden.

Hvis ”søg” vælges som COM-port, opretter Tech2Win en virtuel COM-port på det første ledige portnummer i rækken fra 9 ned til 1.

Det MDI-serienummer, der skal anvendes

Indtast MDI-serienummeret. Nummeret findes på bagsiden af MDI’en. Anvend nummeret efter bindestregen.

Hvis serienummeret ikke indtastes, viser Tech2Win automatisk en liste over MDI'er, der er fundet på netværket, så brugeren kan vælge en MDI. Den samme markeringsboks fremkommer, når den angivne MDI ikke er fundet.

Protokol

'ISO22900-2 / PDU-API' markeres og J2534-2 nedtones altid. I fremtiden er det muligt, at Tech2Win vil være i stand til også at understøtte J2534-protokollen.

  • Avancerede emner: Konfigurationsfil
  • Ofte stillede spørgsmål: Hvordan kan man afgøre, hvilken COM-port, der skal anvendes til Tech2Win?
  • Ofte stillede spørgsmål: Kommunikation mellem Tech2Win og TIS2Web
  • Ofte stillede spørgsmål: Hvordan er det muligt at benytte mere end én MDI?
  • Ofte stillede spørgsmål: Tech2Win kunne ikke finde MDI'en


Billedskærm

Fanebladet Billedskærm anvendes hovedsageligt til at ændre på indstillinger af visningen af Tech2Win:

  • Tastatur
  • Farver
  • Lyd
Display and Key Options

Tastatur

Her er det muligt at vælge, om tastaturet skal vises. Tastaturet trækkes enten til venstre eller højre for Tech2Win-skærmbilledet. Baggrundsfarven kan vælges i en dialogboks med standardfarver.

Farver

Tech2- skærmbilledets bag- og forgrundsfarve kan vælges separat her. Dette er de to mest almindelig farvekombinationer:

Screen with background 0000FF, foreground FFFFFF | Tastaturbaggrunden er hvid; Baggrund blå; Forgrunden er hvid
Screen with background 000000, foreground C0C0C0 | Tastaturbaggrund blå; Baggrunden er sort; Forgrunden er lysegrå

Lyd

Her kan lyden slås fra. Hver gang Tech2-programmet giver et bip, anvendes pc-højttaleren.


Sådan gemmes en konfiguration

Den aktive konfiguration kan gemmes ved at trykke på knappen Gem <konfiguration> i nederst venstre hjørne. Knappen fremkommer ikke ved visning af en skrivebeskyttet konfiguration.


Gyldig licens via TIS2Web

Normalt følger der en gyldig licens med ved hentning af Tech2-programmer til Tech2Win. Det er desuden muligt at få én ved at foretage en 'Sikkerhedsadgang (Sikkerhed)' via TIS2Web (ikke TIS2000). En betingelse for det er, at den virtuelle COM-port vælges inde i konfiguratoren under Grænseflade til køretøjskommunikation.

Efter en fuldført sikkerhedsadgang vises der en lås, som er åben, til højre i statuslinjen. Klammen angiver det antal dage, som licensen er gyldig. Når Tech2Win startes igen vises der ingen sikkerhedsindikator så længe, der ikke foregår nogen køretøjskommunikation. Under den første kommunikation med et køretøj, kontrolleres licensen, og indikatoren skifter enten til en åben eller låst lås.

  • Sådan arbejdes der med Tech2Win:Sikkerhed
  • Ofte stillede spørgsmål:Hvordan kan man afgøre, hvilken COM-port, der skal anvendes til Tech2Win?
  • Ofte stillede spørgsmål:Kommunikation mellem Tech2Win og TIS2Web
  • Ofte stillede spørgsmål:Gyldig licens
  • Ofte stillede spørgsmål:Hvad er forskellen på en Tech2Win-licens og en sikkerhedsadgang?


Sådan arbejdes der med Tech2Win

Følgende emner anvendes af de fleste teknikkere, når de arbejder med Tech2Win:

  • Menu: Skærmlayoutet og de enkelt menupunkter.
  • Sådan hentes et PCMCIA-billede: Opdateringen af diagnosticeringssoftwaren til Tech2Win er meget lig den metode, der anvendes til Tech2.
  • Sikkerhed: Sikkerhedsforanstaltningerne forhindrer Tech2Win i at udføre køretøjskommunikationer i uautoriserede miljøer.
  • Vis rapporter: Tech2-tastaturet er lettere forbedret i Tech2Win. Knappen Vis rapporter er det mest synlige eksempel.
  • Sådan håndteres PCMCIA-billeder: Ligesom at have flere PCMCIA-kort til Tech2 kan der være flere PCMCIA-billeder i brug til Tech2Win.
  • Statuslinjen: Statuslinjen oplyser brugeren om de enkelte del af statuslinjen.
    • Avancerede emner
    • Ofte stillede spørgsmål


Menu

Der findes følgende menupunkter i Tech2Win-programmet:

  • Fil
  • Indstillinger
  • Vinduer
  • Hjælp

Fil

Fil-menuen giver følgende muligheder:

  • Gem T2-skærmen (320x240) anvendes til at gemme den aktuelle T2-skærm med i en størrelse på 320x240 punkter, som en sort-hvid billedfil på pc'en. Lagerplaceringen og filformatet (BMP, GIF, JPG eller PNG) kan vælges frit.
  • print screen opretter et sort på hvidt inverteret billede i BMP-format af Tech2-skærmen og kalder det program, der er tilknyttet BMP-filer. Derefter kan programmet anvendes til at skrive billedet ud med.
  • Vis rapportfilerne gør det muligt at vise (og udskrive) rapportfiler uden anvendelse af TIS2Web.
  • Afslut lukker Tech2Win.

Indstillinger

Indstillinger giver følgende valgmuligheder:

  • Opløsning kan benyttes til at vælge én af tre standard skærmstørrelser.
  • ROM-Write from 0x00003ED76 anvendes til brug for intern fejlfinding.
  • Automatiske skærmbilleder til at gemme et billede af hvert enkel Tech2-skærm i logmappen.
  • Deaktiver CANdi og genstart til at imitere en Tech2, der ikke har nogen CANdi mellem sig og køretøjet. Det kan i sjældne tilfælde være nødvendigt, hvis CANdi'en afbryder køretøjskommunikationslinjer, som ikke er standard.

Vinduer

Menuen Vinduer gør det muligt at aktivere valgene Tech2Win visning af data og Tech2Win visning af diagnosticeringsfejlkoder. Andre andre valg vises gråtonede i den nuværende Tech2Win-version.

Hvis Tech2 softwaren understøtter Tech2Win visning af data, kan du aktivere dette menupunkt. Når datavisningen er startet, viser Tech2Win yderligere et datavisningsvindue parallelt med datavisningen i Tech2. Så længe Tech2-skærmen viser Data Display, kan menupunktet ikke aktiveres. I så fald skal du afslutte Data Display, aktivere menupunktet og genstarte Data Display.

Lignende begrænsninger for Tech2Win visning af data gælder også for Tech2Win visning af diagnosticeringsfejlkoder. Hvis Tech2 softwaren understøtter Tech2Win visning af diagnosticeringsfejlkoder, kan du aktivere dette menupunkt. Der vises et yderligere DTC Display-vindue parallelt med Tech2 DTC Display. Så længe Tech2-skærmen viser DTC Display, kan menupunktet ikke aktiveres. I så fald skal du afslutte DTC Display, aktivere menupunktet og genstarte DTC Display.

Hjælp

Der er følgende valgmuligheder tilrådighed:

  • Emner i Hjælp... fremkalder Tech2Win Hjælp.
  • Kommandolinjeparameter viser de kommandolinjeparametre, der anvendes til Tech2Win.
  • Om viser det nuværende versionsnummer og begrænsningerne for TIS2Web-overførsel i Tech2Win.


Hent

Allerførst start Tech2Win og lad det forblive på hovedskærmen. Start TIS2Web eller GlobalTIS, og hent dataene via den COM-port, der er angivet under fanen Grænseflade til køretøjskommunikation.

Ved hjælp af de indbyggede COM-porte er det muligt at hente Tech2-software fra en anden pc, der kører under TIS. Sørg for at anvende et RS232-kabel med trådkors. Alt afhængigt af den pc-hardware, som Tech2Win kører på, kan det være nødvendigt at overførselshastigheden reduceres til 57.600 baud, da Windows kan tabe data ved en højere baudhastighed.

Den nyeste Tech2Win-version understøtter også en hurtig overførsel, når TIS2Web og Tech2Win kører på samme pc. Der foregår stadigvæk en minimal kommunikation mellem TIS2Web og Tech2Win via COM-porten, men den tidsrøvende dataoverførsel til Tech2Win er blevet erstattet af en intern filoverførsel. I sådanne tilfælde er overførselstiden mindsket væsentligt til langt under ét minut.

  • Avancerede emner: Konfigurationsfil
  • De indledende trin: Grænseflade til køretøjskommunikation
  • Ofte stillede spørgsmål: Hvordan kan man afgøre, hvilken COM-port, der skal anvendes til Tech2Win?
  • Ofte stillede spørgsmål: Kommunikation mellem Tech2Win og TIS2Web


Sikkerhed

De sikkerhedsmekanismer, der anvendes af Tech2Win, er afhængige af et korrekt klokkeslæt på pc'en. Kontrollér, at pc’ens klokkeslæt altid er stillet korrekt. Mindre ændringer af klokkeslættet tolereres af Tech2Win i forbindelse med ændring til og fra sommertid.

Tech2Win kan ikke udføre køretøjskommunikationer uden en gyldig og aktiv licens. Følgende indikator på statuslinjen viser licensen status:

  • green smiley Licensen er gyldig.
  • Ingen indikator: Licensen er endnu ikke kontrolleret.
  • red smiley Licensen er udløbet.

For at få en licens skal du udføre en opdatering af 'Sikkerhedsadgang (Sikkerhed)' ved hjælp af TIS2Web-programmet. I de fleste tilfælde vil det være tilstrækkelig at hente et program via TIS2Web for at få en ny licens. Eftersom licensen udløber inden for et vist tidsrum (i nogle lande: 4 uger), skal en sådan opdatering udføres med jævne mellemrum.

Licenser er lande-/programspecifikke. Der kan være flere licenser på computeren, hvis du anvender Tech2Win med forskellige Tech2-programversioner.

Antallet resterende dage, inden licensen udløber, vises på statuslinjen.

  • ( 0) angiver, at licensen er udløbet eller ikke eksisterer.
  • (<1) Licensen udløber inden for det næste døgn.
  • (20) Licensen udløber om 20 dage.

Licensfilen må ikke manipuleres. Ændringer med forfalskninger af denne fil afsløres ved hjælp af interne sikkerhedsforanstaltninger og leder til tab af alle licenser på computeren. Derudover fungerer Tech2Win ikke som forventet. Dette kan kun løses ved at foretage en helt ny installation.

  • Avancerede emner: Fejlmeddelelser og afslutningskoder
  • Avancerede emner: Logfil
  • Sådan arbejdes der med Tech2Win: Statusvindue
  • Ofte stillede spørgsmål: Gyldig licens
  • Ofte stillede spørgsmål: Hvad er forskellen på en Tech2Win-licens og en sikkerhedsadgang?
  • Ofte stillede spørgsmål: Pludseligt stop


Sådan vises rapporter

View Report Denne knap kan anvendes til at vise indholdet af alle de PRT-filer, der befinder sig på PCMCIA-kort. Der fremkommer en dialogboks, som viser en liste over PRT-filer. Hvis et program er associeret med PRT-filtypenavnet, afvikles dette associerede program. Ellers åbnes tekstbehandlingsprogrammet Notepad for at vise den markerede fil.

I de fleste tilfælde er PRT-filen en ASCII-fil, som anvender de sprogrelaterede tegntabeller. I forbindelse med japansk, kinesisk, koreansk og thailandsk er filen i Unicode-format med et foranstillet byterækkefølgemærke (BOM).

Ved visning af rapporter arbejder Tech2Win med en undermappe med navnet C:\Users\Public\General Motors\Tech2Win\reports. Denne undermappe eksisterer kun, hvis der har været vist rapporter mindst én gang tidligere. Mappen slettes automatisk og fungerer som midlertidig arbejdsmappe til PRT-filer på det aktive PCMCIA-kort. Den indeholder fortsat disse filer, selv om Tech2Win ophører med at køre. Hvis en sådan fil skal gemmes, skal den først kopieres til en anden mappe, da den kan blive overskrevet, så snart en anden bruger starter en rapportvisning.


PCMCIA-billeder

PCMCIA-billeder findes normalt i mappen C:\Users\Public\General Motors\Tech2Win\pcmcia. Størrelsesmæssigt skal filen være på nøjagtigt 32 MB (33.554.432 byte) eller 10 MB (10.485.760 byte) og af filtypen *.bin. Billederne ændres (som ethvert normalt PCMCIA-kort ville blive), hvis der hentes data, eller hvis Tech2Win lagrer noget på flashkortet. En ændring kan deaktiveres ved hjælp af skrivespærren (kommando -W0 eller -W1) eller ved at udelade 'p'-værdien i '-W'-parameteret(Konfigurationsfil). Der er ikke adgang til skrivebeskyttelsestappen via konfiguratoren. Derfor skal konfigurationsfilen ændres manuelt, hvis indstillingerne '-W0', '-W1' eller '-W' skal benyttes.


Statuslinjen

Statuslinjen vises under Tech2-skærmbiledet. Følgende punkter vises i statuslinjen:

  1. En hastighedsindikator
  2. Statussen på køretøjskommunikationen
  3. Statussen på den serielle port
  4. Tasten SHIFT
  5. Automatiske skærmbilleder
  6. Logført advarsel
  7. Licens

Status Bar

Hastighedsindikator

Hastighedsindikatoren viser, hvor meget CPU-tid, der er brugt til emulering af Tech2-softwaren. Et lavt tal (angivelse til venstre) er bedre end et højere tal (angivelse til højre). Ethvert grønt symbol er acceptabelt. Symbolet kan i en kortere periode blive gult, hvis en anden Windows opgave pludselig aktiveres. En sådan aktivitet skal helt undgås.

Statussen på køretøjskommunikationen

Status for køretøjskommunikationen angiver, hvorvidt brugerfladen til køretøjskommunikation (MDI) er til stede, såvel som kommunikationen mellem køretøjet og Tech2Win.

Statussen på den serielle port

Ved kommunikation med Tech2Win via en COM-port viser denne indikator, om der er aktiv kommunikation på den COM-port eller ej.

Tasten SHIFT

Denne indikator vises, hvis tasten SHIFT er aktiveret. Den kan slås til og fra ved hjælp af tastaturtasten 'S' eller tasten SHIFT på det numeriske tastatur.

Automatiske skærmbilleder

Automatiske skærmbilleder kan aktiveres i menuen Indstillinger. Hver gang skærmen ændres, gemmes der en ny fil med et skærmbillede i logmappen. Dette angives ved at dreje på håndsvinget på det røde kamera i statuslinjen. Så snart de automatiske skærmbilleder deaktiveres, forsvinder kameraet.

Logført advarsel

Logstatusindikatoren kan have 3 forskellige tilstande.

  • gray log status indicator Logfilen indeholder ingen advarsler eller fejl.
  • yellow log status indicator Logfilen indeholder en advarsel.
  • red log status indicator Logfilen indeholder en fejlmelding.

Licens

Licensindikatoren har tre tilstande:

  • green smiley Licensen er aktiv og gyldig.
  • Ingen indikator: Licensen er endnu ikke kontrolleret.
  • red smiley Licensen er udløbet eller ikke eksisterer.
Se linket Sikkerhed for yderligere detaljer.

Værktøjstip på statuslinjen

Ved nogle ikoner vedkommende vises der værktøjstip for at give yderligere oplysninger:

Værktøjstip til VCI-serienummeret:
Tooltip VCI

Værktøjstip til TECH2-softwareversionen
Tooltip TECH2

Værktøjstip til COM-porten
Tooltip Comport

Værktøjstip til nummeret på det næste skærmklip (hvis 'Automatiske skærmbilleder' er aktiveret)
Tooltip Camera

Værktøjstip, som viser den sidste post i logfilen med niveauet 'advarsel' eller højere
Tooltip Logfile

Værktøjstip til licensens nøjagtige gyldighedsperiode
Tooltip License

Værktøjstippene vises, hvis markøren er placeret på et ikon i mere end 0,5 sekunder uden at blive flyttet. Værktøjstippene forsvinder i løbet af 5 sekunder, eller snart der røres ved markøren.

  • Avancerede emner: Fejlmeldinger og -koder
  • Avancerede emner: Logfil


Avancerede emner

De emner, som behandles her, er knapt så vigtige for standardbrugeren af Tech2Win. Enhver, der har med installationen, styringen og konfigureringen af Tech2Win at gøre, finder sikkert følgende oplysninger nyttige.

  • Geninstallation
  • Afinstallation
  • Direkte ændring af konfigurationsfilerne
  • Logfil
  • Fejlmeddelelser og afslutningskoder
  • ATA-kort
  • Poster i registreringsdatabasen
  • Filbeskrivelse
  • Eksempler på konfigurationsstyring


Afinstallation

Den samlede installeringsmappe, mappen indeholdende brugerdata (C:\Users\Public\General Motors\Tech2Win) og mappen indeholdende programdata (C:\ProgramData\General Motors\Tech2Win) slettes.

  • Avancerede emner: Geninstallation
  • Installation


Konfigurationsfil

Konfigurationsfiler findes altid i undermappen C:\Users\Public\General Motors\Tech2Win\config og har filtypen *.conf. Det er muligt at foretage en ændring af konfigurationsfilen, da ikke alle indstillinger i filen er tilgængelige via Tech2Win. Konfigurationsfilen en er en Unicode-fil med et foranstillet byterækkefølgemærke (BOM). Det anbefales kraftigt at benytte et Unicode-kompatibelt tekstbehandlingsprogram, såsom Notepad, når der foretages manuelle ændringer.

Konfigurationsfilen er linjeorienteret. Tomme linjer ignoreres. En linje begynder altid med en indstilling efterfølges for det meste af en værdi. Som et eksempel se nærmere på filen default.conf. Se følgende tabel, der beskriver alle tilgængelige indstillinger.

Hvis en bestemt konfiguration skal startes direkte fra skrivebordet, skal der oprettes en genvej, som udfører 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Programmet skal startes fra følgende arbejdsmappe: 'C:\Program Files\General Motors\Tech2Win\bin'

indstilling | Værdi/forklaring
; En kommentar
@ Et decimalopbygget versionsnummer med formatet overordnet.underordnet.
Konfigurationsfiler med et andet overordnet nummer end Tech2Win accepteres ikke. Konfigurationsfiler med et lavere underordnet nummer end Tech2Win accepteres.
-W0
-W1 		PCMCIA-kortet på kortplads nr. 0/1 har en skrivespærre, der er aktiveret.
-B0
-B1 		Blokstørrelsen i KB på PCMCIA-kortet i på kortplads nr. 0/1. De gyldige værdier er 128 (standardindstilling) eller 256.
-P0
-P1 		Filen med det binære billede af PCMCIA-kortet i på kortplads nr. 0/1. Filstørrelsen skal være nøjagtigt 10 MB eller 32 MB. Miljøvariabler, såsom %ProgramData%, er udvidet.
Hvis denne indstilling mangler, antages det, at kortpladsen er tom.
-A0
-A1 		Filen med attributværdierne på PCMCIA-kortet i på kortplads nr. 0/1. Hvis den mangler, anvendes der standardindstillede attributværdier baseret på kort- og blokstørrelse.
-W | Når Tech2Win afsluttes, skrives alle faste data i deres respektive filer. Værdierne p/f/r/c kan kombineres til at angive hhv. PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | Heap-styringsfunktion Værdierne 0/r/w/t kan kombineres for at aktivere hhv. Nulstilling, Læsekontrol, Skrivekontrol og Opgavekontrol. Værdien l bruges til altid at håndhæve en tildeling af heap-hukommelse ved lavere adresser, når der er indført en alternativ tildelingsordning. Normalt bliver denne indstilling kun brugt i udviklermiljø.
-PC | Den tidligere sti til kopien af PCMCIA-kortet. Dette ignoreres i øjeblikket.
-MS | Identificering af grænsefladen til køretøjskommunikation (MDI) med serienummer. Hvis der ikke er angivet noget, vises der en liste over tilgængelige MDI'er.
-CT | Tekstfarven (forgrund) i 3 hexadecimale byteværdier. Standardværdien er 000000 (hvid).
-CB | Baggrundsfarven i 3 hexadecimale byteværdier. Standardværdien er FFFFFF (sort).
-ATA | Benyt denne indstilling for at aktivere et ATA-registreringskort. Fjern det for at deaktivere ATA-registreringskortet.
-C | Det COM-portnummer (1..9), der skal anvendes som RS232C-kommunikationsport for Tech2. COM9 anvendes ofte til den virtuelle COM-port, der installeres af Tech2Win. Hvis denne valgmulig er ikke til stede, søges der efter en ledig COM-port i nedadgående rækkefølge fra COM9. Anvend værktøjstippet på statuslinjen mellem ikonet Tech2 og ikonet TIS2Web for at se, hvilken COM-port der anvendes.
-WR | En pc-adresse (normalt 253558), som har lov til at skrive på PCMCIA- og FLASH ROM-området. Denne funktion skal yderligere aktiveres via menuen (eller ved at anvende indstillingen -WA). Den kræves for at fejlfinde koder i hukommelse, som ikke kan ændres, af fejlfindingsprogrammet SingleStep.
-WA | Tillad fejlfindingsprogrammet Enkelt trin at skrive på den hukommelse, der ikke kan ændres.
-OF | Indstillingsfil, der indeholder parameter- og værdipar.
-TP | Tidsindstilling (Proportionalværdi). Standardindstillet til 5000. Angiv en mindre værdi for at få de talafviklede cyklusser tilpasset hurtigere til realtiden.
-TD | Tidsindstilling (Differentialværdi). Standardindstillet til 100. Angiv en mindre værdi for at reagere hurtigere på ændringer i den øjeblikstidsindstillingen. ADVARSEL: manipulation med TP- og TD-værdierne kan medføre hastighedsproblemer.
-PJ
-PP 		Angiv den protokol, der skal anvendes:
PJ for J2534-kommunikation.
PP for ISO22900-2 / PDU-API (standardindstilling)
-S | Tilstedeværelsen af denne indstilling aktiverer lydudgangen på pc'ens advarselssignal.
-L | Sproget på Tech2Win-programmet. Det sprog, der er aktivt i Windows, er det sprog, der anvendes som standard, hvis angivelsen af det mangler. Se følgende link for en liste over de sprog, der kan angives: Sprog. Selve Tech2-emulationsvinduet vises, uanset hvilket sprog, der findes på PCMCIA-kortet (dvs. var overført til PCMCIA-kortet).
-UD | Tilsidesættelse af mappen med brugerdata Under Windows 7 er det normalt ved C:\Users\Public\General Motors\Tech2Win
-AD | Tilsidesættelse af mappen med programdata Under Windows 7 er det normalt ved C:\ProgramData\General Motors\Tech2Win
-US | Anvend en brugerspecifik semafor til registrering af mere end én forekomst af Tech2Win. Denne indstilling tillader, at hver bruger kan køre Tech2Win parallelt på den samme computer, f.eks. på en server. Når denne indstilling benyttes, skal indstillingerne -UD og -AD også angives.
-SS | Indstilling til nærmere angivelse af den samlede størrelse på Tech2Win-vinduet, inklusive det numeriske tastatur, hvis det vises. Det første parameter skal være en streng, der er omgivet af dobbelte anførselstegn (”) og anvendes som navnet på størrelsen i menuen Indstillinger / Opløsning. Det andet parameter angiver det samlede antal vandrette pixler på Tech2Win-skærmen inklusive det numeriske tastatur. Det tredje parameter angiver det samlede antal lodrette pixler på Tech2Win-skærmen. Det fjerde valgfri parameter angiver bredden på det numeriske tastatur i pixler.
-SH Indstilling til styring af skærmbilledet. Følgende decimaltal anvendes til angivelse af, hvilke styringsmuligheder til håndtering af skærmbilledet, der skal deaktiveres.
  • Bit 0: Det er ikke muligt at angive nogen min./maks.
  • Bit 1: Det er ikke muligt at foretage flytninger på skærmen.
  • Bit 2: Ingen ændring af størrelsen. I dette tilfælde nedtones menuen Indstillinger / Opløsning.
  • Bit 3: Vinduerne med datavisning og fejlkoder skal være af samme størrelse som Tech2Win (uden det numeriske tastatur)


Logføring

Hver gang en Tech2Win-konfiguration startes, oprettes der en ny logfil i HTML-format i undermappen C:\Users\Public\General Motors\Tech2Win\Logs. For at undgå overbelastning af harddisken fjernes logfiler, der er mere end én uge gamle.

Logfilerne opkaldes automatisk efter oprettelsesdatoen og -tidspunktet, dvs. (år, måned, dag) og (time, minut, sekund):
åååå-mm-dd_ttmmss.html

Logfilangivelserne er altid på engelsk, men i Unicode-format med et foranstillet byterækkefølgemærke (BOM). Hver linje i logfilen er ét af de efterfølgende logføringsniveauer:

Logføringsniveau | Forklaring
Info | Kun informativ. Påvirker ikke eksekveringen af programmet.
Advarsel | Der er opstået en usædvanlig situation. Brugeren bemærker ikke nødvendigvis nogen uønskede effekter.
ERROR | Der opstod en fejl, som kan bemærkes af brugeren.
CRITICAL | Der opstod en alvorlig fejl, som får programmet til at fungere unormalt.
FATAL | En alvorlig fejl får Tech2Win til straks at ophøre med at virke.

Alle niveauer over 'advarsel' er farvelagt, så de nemt kan genkendes.

Derudover findes der også print- og videofiler i undermappen Logs, hvis menuvalget print screen eller Automatiske skærmbilleder har været benyttet.
åååå-mm-dd_ttmmss_print_nnnnn.bmp
åååå-mm-dd_ttmmss_video_nnnnn.png
Automatiske skærmbilleder-billederne er sammenkædet med HMTL-filen. Benyt derfor HMTL-loggen til at vise denne række billeder.

Bruger oplyses i statuslinjen, hvis der forekommer en advarselspost ( yellow lightning bolt) eller en alvorligere logpost ( red lightning bolt).


Fejlmeddelelser og afslutningskoder

Fejlmeddelser kan forekomme i dialogbokse. Disse dialogbokse tillader stadigvæk, at Tech2Win kører programmet Tech2 parallelt. Afslutningskoder er alvorlige fejl, som får Tech2Win til at afsluttes på unormal vis. Afslutningskoderne kan anvendes i kommandofiler til at finde ud af, hvorfor et program er afsluttet.

Fejlmeddelelser

Følgende fejlmeddelelser kan fremkomme med et popop-vindue. Heri forklares situationen kort, og hvordan problemet kan løses.

Emulator too slow Emulator failed to start

Afslutningskoder

Afslutningskode | Værdi | Forklaring
OPCODE_ERROR | -7 | Der blev fundet en ugyldig kommando af Tech2-mikroprocessoren (68332). PCMCIA-billedet er måske beskadiget på en eller anden måde.
ATA_PROBLEM | -6 | Der opstod et problem under ATA-emuleringen. Hvis et sådant problem skulle opstå efter en anvisning om at anvende ATA-kortet, så kontakt en it-medarbejder.
DEMO_TIME_IS_UP | -5 | Bør ikke forekomme i den officielle Tech2Win-version.
DLL_NOT_LOADED | -3 | Én af de nødvendige DLL-filer kunne ikke indlæses. Det ser ud til at være en ufuldendt kopi af Tech2Win. Udfør en ny installation og/eller vælg et andet sprog.
EXIT_INIT_FAILED | -2 | Initialiseringen mislykkedes. Undersøg logfilen for at finde ud af den nøjagtige årsag. Hvis der mangler en logfil, så kontroller, om du har den rette har læse- og skriveadgang til alle mapper.
normal | 0 | Tech2Win er afsluttet uden fejl.


ATA-kort

ATA-kort i Tech2 anvendes almindeligvis udelukkende til fejlfindingsformål under softwarens udvikling. Alle nødvendige ATA-data gemmes i undermappen C:\Users\Public\General Motors\Tech2Win\ataCapture. Denne mappe er normalt ikke særlig vigtig og kan uden videre slettes, med mindre der anmodes om andet.

Eftersom mappen ataCapture er fast, indeholder den det samme for alle konfigurationer.


Filer

Følgende filer og mapper anvendes af Tech2Win:

Mappe | Placering før Vista | Placering af Vista og derefter
Installation | Som defineret under installationen
Brugerdata | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Programdata | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Fil | Anvendelse
[Brugerdata]\atacapture | Indeholder filer, som findes på ATA-kortet. Med mindre andet er anvist, er der ikke brug for disse filer.
[Installation]\bin | Indeholder de aktuelle eksekverbare og nødvendige DLL-filer og billeder, som er nødvendige for kørslen.
[Installation]\bin\emulator.exe | Den hovedeksekverbare der udfører Tech2-koden.
[Installation]\bin\emulator_xx_XX.dll | Sprogspecifik ressource-DLL.
[Installation]\bin\T2Configurator.exe | Konfigurationsdelen af Tech2Win.
[Installation]\bin\Pictures | Indeholder de ikoner, som Tech2Win har behov for.
[Brugerdata]\config | Indeholder alle konfigurationsfiler.
[Brugerdata]\data | Indeholder filer, der foretages ændringer på under kørslen af Tech2Win. Disse filer er nødvendige for at kunne køre Tech2Win korrekt. Normalt skal der ikke røres ved disse filer, med mindre der udtrykkeligt bedes om det.
[Programdata]\data | Indeholder filer, der foretages ændringer på under kørslen af Tech2Win. Disse filer er nødvendige for at kunne køre Tech2Win korrekt. Normalt skal der ikke røres ved disse filer, med mindre der udtrykkeligt bedes om det.
[Programdata]\data\emulator.sec | Sikkerhedsfil . Der må ikke ændres ved denne fil.
[Programdata]\data\emulator.card | Kortfil. Indeholder alle de PCMCIA-kort, som Tech2Win-programmet kender. Der må ikke ændres ved denne fil.
[Brugerdata]\data\emulator.disp | Filen indeholder Tech2Win-skærmbilledets placering og størrelse. Hvis filens slettes, genskabes den, hvorefter Tech2Win-skærmbilledet starter i det øverste venstre hjørne med størrelsen 640x480.
[Programdata]\data\emulator.lic | Licensfil. Indeholder oplysninger om gyldighedsperioderne for licenserne. Der må ikke ændres ved denne fil.
[Programdata]\data\emulator.rtc | Fil med realtidsur. Filen anvendes til lagring af data, som findes i realtidsuret på Tech2.
[Programdata]\data\emulator.dta | En fil med oplysningen 'Vis ikke denne besked igen'.. Denne fil gemmer PCMCIA-programversioner, som ikke (længere) skulle vise advarslen om den manglende evne til at udføre en selvtest, der kræver et tilbagekoblingskort.
[Programdata]\data\candi.bin | Programfilen CANdi. Indeholder programmet CANdi, som er tilknyttet Tech2.
[Programdata]\data\eprom.bin | Intern Tech2-EPROM-fil. Indeholder indholdet af den interne Tech2-flashhukommelse.
[Installation]\driver | Installationsfiler til den virtuelle COM-portdriver.
[Installation]\help\emulator_xx_XX.chm | Sprogspecifikke hjælp-filer.
[Brugerdata]\Logs | Indeholder logfiler. Filer, der er mere end én uge gamle, slettes automatisk.
[Brugerdata]\pcmcia | Indeholder PCMCIA-billedfiler. Hver enkelt fil svarer bogstaveligt talt til et Tech2-PCMCIA-kort. Filerne kan gemmes forskellige steder alt efter ønske.


Konfigurationsstyring

Konfigurationsfiler findes altid i undermappen C:\Users\Public\General Motors\Tech2Win\config og har filtypen *.conf. Tech2Win kan kun anvendes til at oprette nye konfigurationsfiler eller til at foretage ændringer på eksisterende konfigurationsfiler, som ikke er skrivebeskyttede. Benyt Windows Explorer eller et modsvarende filbehandlingsprogram til al anden styring af konfigurationsfilerne. Dette er nødvendigt i forbindelse med følgende aktiviteter:

  • Sletning af konfigurationsfiler
  • Omdøbning af konfigurationsfiler
  • Ændring af attributten Skrivebeskyttet på en konfigurationsfil.

Det anbefales kraftigt altid at have en konfigurationsfil med navnet default.conf. Denne fil bør almindeligvis have attributten Skrivebeskyttet indstillet for at undgå, at den overskrives ved en fejltagelse. Hvis filen imidlertid ændres, så den passer til bestemte behov, er det nødvendigt et kort øjeblik at fjerne indstillingen af attributten Skrivebeskyttet.

PCMCIA-billederne findes i undermappen C:\Users\Public\General Motors\Tech2Win\pcmcia. Hver enkelt af disse filer svarer til et PCMCIA-kort, som allerede er en kendt sag i forbindelse med arbejdet med Tech2. Ved hjælp af Tech2Win er det muligt at modtage lige så mange billeder, som det ønskes. Kopier blot et eksisterende billede til et nyt filnavn.

Hvis en bestemt konfiguration skal startes direkte fra skrivebordet, skal der oprettes en genvej, som udfører "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Programmet skal startes fra følgende arbejdsmappe: 'C:\Program Files\General Motors\Tech2Win\bin'

Antallet af konfigurationsfiler afhænger ikke af det antal PCMCIA-billeder, der anvendes. Det er muligt at have adskillige konfigurationsfiler, som anvender det samme PCMCIA-billede. Dette simulerer nøje en situation på et værksted med flere mekanikere, som deles om det samme Tech2-program - og det samme PCMCIA-kort.

Det er desuden muligt at vælge at have hver enkelt konfiguration til at anvende sit eget dedikerede PCMCIA-billede. Det ville gøre de enkelt konfigurationer mere uafhængige af hinanden. Imidlertid kan det være, at indsatsen med at opdatere hver t PCMCIA-billede ikke er acceptabelt.

Når der laves en ny konfiguration ved at kopiere en allerede eksisterende, viser konfiguratoren en advarselsbesked, hvis PCMCIA-billedet ikke er blevet ændret. I sådanne tilfælde ville der være to konfigurationer, som benytter samme PCMCIA-billede. Såfremt det er meningen, så tryk på OK. Hvis den nye konfiguration skal anvende et andet eller et nyt PCMCIA-billede, så tryk på Annuller. Derefter er det muligt at lave et nyt billede ved hjælp af Kopier hukommelseskortet ...

Her findes to metodeeksempler på, hvordan konfigurationerne og PCMCIA-billederne kan administeres.

Én konfiguration pr. bruger

Det er muligt at gemme én konfiguration pr. bruger. Konfigurationsnavnet kunne f.eks. være brugerens navn. Fordelene ved dette koncept er, at det er muligt at have brugerspecifikke indstillinger, såsom personlige brugerflader til køretøjskommunikation (MDI'er) og skærm- og sprogindstillinger. Ulempen er, at PCMCIA-filer skal kopieres, hvis det skal være muligt for flere brugere at benytte de samme programmer. Det er naturligvis muligt, at de brugerspecifikke konfigurationer kan anvende en central PCMCIA-fil.

Én konfiguration pr. Tech2-program

Det var måske en idé at lave en ny konfiguration for hvert enkelt program, der hentes. Derved er selv ældre programversioner straks tilgængelige, hvis det er nødvendigt. I sådanne tilfælde vælges programnavnet og -versionsnummeret ofte som konfigurationsnavn.

  • De indledende trin: Grænseflade til køretøjskommunikation
  • De indledende trin: Sti
  • Avancerede emner: Konfigurationsfil
  • Installation: Installationstrin


Ofte stillede spørgsmål

  • Hvordan kan man afgøre, hvilken COM-port, der skal anvendes til Tech2Win?
  • Kommunikation mellem Tech2Win og TIS2Web
  • Gyldig licens
  • Hvad angiver licensnummeret?
  • Hvad er forskellen på en Tech2Win-licens og en sikkerhedsadgang?
  • TIS2Web viser en ikke nærmere angivet fejl, når der foretages en sikkerhedsmæssig adgang til det allerførste programmel.
  • Tech2Win kører ikke Tech2-programmer fra et andet område
  • Hvordan er det muligt at benytte mere end én MDI?
  • Logfilen indeholder fejlen 'CPU32: Too many 0000/FFFF Commands encountered'
  • Intet Tech2-vindue
  • SPS fungerer ikke
  • Nogle af selvtesterne virker ikke
  • Hastighedsindikatoren giver udsving
  • Pludseligt stop
  • Der vises svensk som sprog til 15.001-programmet
  • Kommunikationen med MDI'en forsvinder
  • Tech2Win kunne ikke finde MDI'en
  • Tech2Win skal kunne startes straks uden, at det er nødvendigt at bekymre sig om konfiguratoren
  • Hvor findes udskriftsfunktionerne?
  • Der findes en ”ubrugt” PCMCIA-mappe på denne computer
  • Der vises en meddelelse om 'illegal filepath' (ulovlig filsti)

Hvordan kan man afgøre, hvilken COM-port, der skal anvendes til Tech2Win?

Enhedshåndtering i Windows kan anvendes; se under Porte (COM og LPT). Men nogle computere har indbygget modem eller Bluetooth-udstyr, som ikke vises i denne kategori.
En anden udvej er at bruge en lille kommando, som følger med konfiguratoren. Den kan udføres via startmenuen (i mappen Tech2Win) ved at klikke på 'show com ports'.
Begge metoder vise de COM-porte, der er installeret på computeren, og som du IKKE skal anvende.

Kommunikation mellem Tech2Win og TIS2Web

Det er vigtigt, at Tech2Win kører, inden kommunikationen med TIS2Web startes til sikkerhedsadgang eller hentning af programmer. TIS2Web kan kun genkende den virtuelle COM-port, når Tech2Win er startet.

Gyldig licens

Normalt følger der allerede en gyldig licens med, når der hentes programmer fra TIS2Web. Hvis du stadig ikke har en licens, skal der udføres en 'Sikkerhedsadgang (Sikkerhed)' via TIS2Web (ikke TIS2000) for at få en gyldig licens. Udfør venligst ingen anden TIS2Web-kommunikation med Tech2Win, såsom en 'Softwareindlæsning (SWDL)', før du har modtaget din licens via 'Sikkerhedsadgang (Sikkerhed)'.

Hvad angiver licensnummeret?

Licensnummeret til højre på statuslinjen viser antal samlede licensdage. Umiddelbart efter en overføring eller sikkerhedsadgang er der angivet 30 dage. Efter at have startet Tech2Win på ny, er angivelsen dog kun på 29 dage, eftersom licensens gyldighedsperiode sandsynligvis allerede er noget i retning af f.eks. 29 dage, 23 timer og 55 minutter. Hvis antal licensdage kommer under ét døgn, angives der en licensgyldighed på <1. Hvis licensen er udløbet, angives det med et 0.

Hvad er forskellen på en Tech2Win-licens og en sikkerhedsadgang?

Tech2Win-licensen gør det muligt at anvende Tech2Win. For at opnå en licens skal der enten foretages en overførsel af programmer eller en sikkerhedsadgang med regelmæssige mellemrum (almindeligvis hver 30. dag). Muligheden for at udføre sådanne overførelser via TIS2Web informerer Tech2Win om, at der er en gyldig bruger til stede. Sikkerhedsadgangen, som den kendes fra Tech2, oplyser Tech2Win om, at visse sikkerhedsrelaterede aktiviteter tillades, såsom deaktivering af en sikkerhedspude. Både Tech2Win-licens og sikkerhedsadgang kan udføres ved hjælp af programmet TIS2Web's sikkerhedsadgang. Tech2Win viser den resterende licensperiode til højre på statuslinjen. Desværre kan Tech2Win ikke vise varigheden af en sikkerhedsadgang, da Tech2Win ganske enkelt kører Tech2-programmet, men ikke forstår selve Tech2-programmet.

TIS2Web viser en ikke nærmere angivet fejl, når der foretages en sikkerhedsmæssig adgang til det allerførste programmel.

Adfærden er den samme som på Tech2. Da det allerførste programmel er gammelt, er det ikke i stand til at opnå en licens fra TIS2Web. Det er dog ikke noget reelt problem, eftersom demonstrationsprogrammellet ikke kommunikerer med en bil, hvortil licensen er nødvendig. Og eftersom licenser er TS2Web-overførselsspecifikke, er det trods alt nødvendigt at indhente en licens til hver enkelt overførsel efter at have hentet Tech2-programmellet. En ”licens” til det allerførste programmel ville ikke berettige dig til at udføre bilkommunikationer med et programmel til nordamerikanske virksomheder eller Opel/Vauxhall.

Tech2Win kører ikke Tech2-programmer fra et andet område

Din Tech2Win-udgave er formodentligt begrænset til én eller flere TS2Web-overførsler (områder). Tryk på Hjælp / Om for at se hvilke begrænsninger, der gælder for din Tech2Win-version. Tidlige versioner af Tech2Win tillod kun kørsel af programmel til Opel/Vauxhall. Der følger snarest andre GM-områder. Tech2Win er under alle omstændigheder i stand til at køre Tech2-programmer fra General Motors i øjeblikket.

Hvordan er det muligt at benytte mere end én MDI?

Hvis der skal tildeles specifikke MDI'er til specifikke brugere, foreslår vi, at hver enkel bruger tildeles deres egen konfiguration. Selvsagt skal disse konfigurationer navngives efter deres respektive brugere. I hver af disse konfigurationer skal serienummeret på den brugerspecifikke MDI angives i fanen 'Grænseflade til køretøjskommunikation'. Så snart brugeren starter sin konfiguration forsøger Tech2Win at kontakte den specifikke MDI. Kun hvis denne MDI ikke er til stede, fremkommer der en markeringsboks, som viser alle de MDI'er, som Tech2Win kunne finde.

Hvis der er flere MDI'er til almen benyttelse, foreslår vi, at der anvendes konfigurationer, hvor serienummer til grænseflade til køretøjskommunikation i fanen 'Grænseflade til køretøjskommunikation' står tomt. Så kan brugeren altid se markeringsboksen med tilgængelige MDI'er.

Logfilen indeholder fejlen 'CPU32: Too many 0000/FFFF Commands encountered'

Filen 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' eller den aktuelle PCMCIA-fil er beskadiget. Geninstallér Tech2Win og hent nye Tech2 programmer.

Intet Tech2-vindue

Hvis der ikke kan ses noget Tech2-vindue, er det sikkert i et område, som ikke er på skærmen lige nu. Den slags sker, når der anvendes mere end én skærm, eller når der har været ændret på skærmopløsningen. Tryk på tasten Shift på tastaturet, når konfigurationen startes. I så fald nulstilles opløsningen i Windows til 640x480, og Tech2-vinduet vises i øverste venstre hjørne af skærmen. Filen C:\Users\Public\General Motors\Tech2Win\emulator.disp kan også slettes for at opnå samme virkning.

Der har været tilfælde, hvor Tech2-vinduet ganske enkelt ikke genskabes på skærmen efter, at vinduerne til alle andre programmer er lukket. I alle hidtidige tilfælde har det været muligt at fremkalde Tech2-skærmen ved at benytte tasten Alt-Tab til at skifte mellem Windowsprogrammerne. Sommetider virker det ikke at trykke på knappen Tech2Win i proceslinjen forneden på pc-skærmen. Vi er stadigvæk i gang med at undersøge dette problem og håber at have en løsning klar i en senere version af Tech2Win.

SPS fungerer ikke

Ja, vi er klar over det. Vi har ingen planer om at ændre på dette. Tech2Win bør ikke anvendes som en Tech2-erstatning til at udføre SPS med. Anvend MDI direkte med SPS-programmering gennem TIS.

Nogle af selvtesterne virker ikke

Tech2-selvtester er beregnet til at teste de enkelte dele af Tech2-hardwaren. Nogle af disse tester kræver anvendelse af et tilbagekoblingskort. Disse tester virker ikke i Tech2Win, da tilbagekoblingskortets funktioner ikke er implementeret (og det er der heller ingen planer om at gøre). Derfor skal der helt afstås fra, at udføre sådanne formålsløse tester i Tech2Win. Hvis de alligevel udføres, kan der opstå fejlagtige resultater, eller Tech2Win hænger fast på samme måde, som Tech2 ville gøre uden et tilbagekoblingskort. Benyt Ctrl-R til at nulstille Tech2Win med i sådanne tilfælde.

Hastighedsindikatoren giver udsving

Hastighedsindikatoren nederst til venstre i statuslinjen angiver, hvor mange 'Tech2-kommandoer' der kan udføres, før Tech2Win igen skal 'slumre'. Denne metode anvendes til at sikre, at tiden på Tech2Win stemmer overens med realtiden: Hurtigere pc'er slumre mere end langsommere pc'er. Hvis der er udsving på hastighedsindikatoren, kan der være et andet program, som bruger computerkraft, eller også afviger tiden på pc'en. Større udsving indvirker negativt på kommunikationen med køretøjet og TIS2Web. Sørg for, at der ikke kører andre programmer.

De fleste bærbare computere er i stand til at mindske CPU-klokfrekvensen automatisk for at forlænge batteriets levetid. Det kan også være medårsag til, at Tech2Win registrerer et udsving i hastigheden. I sådanne tilfælde må den bærbare computer ikke køre på batteridrift, men skal bruge en ekstern strømforsyning. Du kan også prøve ændre på indstillingerne til strømstyringen, så operativsystemet ikke mindsker klokfrekvensen.

Pludseligt stop

Hvis der ikke fremgår nogen anden årsag af logfilen for hvorfor programmet blev afbrudt, så kan de interne sikkerhedsmekanismer i Tech2Win være aktiveret. Der må ikke manipuleres med følgende filer: emulator.sec, emulator.lic og emulator.card. Hvis Tech2Win konstaterer brud på sikkerheden, er det højest sandsynligt nødvendigt at foretage en geninstallation.

Der vises svensk som sprog til 15.001-programmet

De oprindelige programmer, som følger med Tech2Win, er demonstrationsprogrammer, som findes på alle nye PCMCIA-kort. TIS2Web angiver, at det er på svensk, fordi TIS2Web kun viser det sprog, der står sidst på listen over de fire sprog, og som understøttes af denne demonstrationsudgave, nemlig engelsk, fransk, tysk og svensk. Brug opdateringstilstanden 'Tilpas' i stedet for 'Standard' til at overskrive dette demonstrationsprogram med det nyeste diagnosticeringsprogram.

Kommunikationen med MDI'en forsvinder

Der kan være flere grunde til, at MDI-kommunikationen forsvinder.

  • En dårlig kabelforbindelse (både Ethernet og USB)
  • En ustabil trådløs forbindelse
  • Pc'en går i standbytilstand.

Tech2Win kunne ikke finde MDI'en

Kontroller følgende punkter:

    1. Er MDI'en aktiv?
    2. Fungerer MDI-styringen?
    3. Anvendes MDI af et andet program, som f.eks. SPS?
MDI-styringen kan startes ved at anvende det tilhørende skrivebordsikon, eller via Start/Alle programmer/General Motors/GM MDI-programmer.: Kontakt teknisk støtte, hvis punkt 2 ikke virker.

Tech2Win skal kunne startes straks uden, at det er nødvendigt at bekymre sig om konfiguratoren

Udfør "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Anvend følgende arbejdsmappe: 'C:\Program Files\General Motors\Tech2Win\bin' Det er stadig muligt at anvende konfiguratoren til at foretage ændringer på konfigurationen med.

Hvor findes udskriftsfunktionerne?

Tech2Win har ingen direkte udskriftsfunktion. Den opretter i stedet for midlertidige filer og kalder de programmer, der er knyttet til filtypen. De programmer kan anvendes til udskrivning og gør det muligt at indstille udseendet på udskriften.

Print Report | Print Report

Anvend menupunktet Fil / print screen eller knappen på tastaturet, som viser en printer, til at udskrive det aktuelle Tech2Win-skærmbillede. Hvis der skal udskrives flere Tech2Win-skærmbilleder, kan menupunktet Indstillinger / Automatiske skærmbilleder anvendes, da det opretter PNG-filer til hvert enkelt Tech2Win-skærmbillede. Disse PNG-filer indgår i logfilen.

Det er desuden muligt at udskrive dataskærmens indhold (aktiveres via menupunktet Vinduer / Tech2Win visning af data). Anvend knappen Udskriv/HTML-start til at starte og derefter standse datafangsten. Når datafangsten er standset, startes det HTML-tilknyttede program (normalt Internet Explorer), som giver masser af muligheder for udskrivning af dataene.

Data Display | Data Display

Der findes en ”ubrugt” PCMCIA-mappe på denne computer

Tidligere versioner af Tech2Win havde altid en duplikeret lagring af PCMCIA-filer i en særskilt mappe. Det var oftest mappen C:\PCMCIA. Nu anvendes mappen ikke længere, da den hurtige overførsel fra TIS2Web gør en duplikeret lagring unødvendig. Denne mappe kan slettes uden problemer.

Der vises en meddelelse om 'illegal filepath' (ulovlig filsti)

Filnavnet synes at indeholde ulovlige tegn såsom procenttegn (%). Hvis du ser dette problem direkte efter en installation, anbefales det bare at udføre en afinstallation og en ny installation. De fleste tilfælde kan rettes ved hjælp af denne metode.

Under normale installationer er miljøvariablen 'Tech2WinUserData' indstillet til 'PUBLIC' (for Windows-versioner >= Vista) og til 'ALLUSERSPROFILE\Documents' (for Windows-versioner før Vista). I nogle sjældne tilfælde er miljøvariablen ikke blevet indstillet under installationen, men virkede fint ved det andet forsøg. Du kan også vælge at indstille miljøvariablen manuelt. Spørg administratoren om hjælp, hvis du ikke ved, hvordan du indstiller en miljøvariabel.


Poster i registreringsdatabasen

Følgende poster i registreringsdatabasen oprettes af installationsprogrammet. Disse poster må ikke ændres manuelt! Vær opmærksom på de gængse Windows-advarsler, når der arbejdes med poster i registerdatabasen.

Registreringsdatabasenøgle | Navn | Type | Forklaring
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Internt versionsnummer
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Sprog | REG_SZ | Det sprog, som er installeret
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Stien til PCMCIA-kopieringsmapperne
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Rod | REG_SZ | Installationssti
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Indstillingen for fjernelse | REG_DWORD | Fjern indstillingen
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Konfigurationsfilens version
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Den virtuelle COM-portdriverversion
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Programnavn på listen over Tilføj/fjern programmer
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Sti til afinstallationsprogrammet


Geninstallation

Geninstallationen sletter hele installationsmappen til Tech2Win med følgende undtagelser.

  1. Undermappen config, der indeholder konfigurationerne, slettes ikke.
  2. Undermappen pcmcia, der normalt indeholder PCMCIA-billederne, slettes ikke.
  3. Undermappen ATA, der kan indeholde fejlfindingsoplysninger, slettes ikke.
Konfigurationsfiler kan miste kompatibiliteten: Der er ingen garanti for, at konfigurationsfiler, som stammer fra en gammel Tech2Win-version, kan læses ved hjælp af en nyere Tech2Win-version. PCMCIA-billeder kan i princippet ikke miste kompatibiliteten.

Den sekundære PCMCIA-mappe påvirkes ikke af geninstallationen.

Nogle miljøer kan foreslå en automatisk installation af en nyere Tech2Win-version. Eftersom de seneste installationsoplysninger lagres i registreringsdatabasen vises disse indstillinger som standardindstilling under geninstallationen.

Der er muligt at gennemtvinge en geninstallation af Tech2Win ved hjælp af scriptet enable reinstallation. Dette script installeres sammen med Tech2Win. Faktisk sætter dette script bare værdien på nøglen CurrentVersion, der findes i registreringsdatabasen ved HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win til en værdi af '1.000'.