Uživatelská příručka k aplikaci Tech2Win

Vítejte v uživatelské příručce k aplikaci Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Všechna práva vyhrazena.

  • Úvod:
  • Licence:
  • Instalace:Popis procesu instalace aplikace Tech2Win.
    • Kroky instalace
    • Komunikační rozhraní vozidla
  • První kroky
    • Výběr konfigurace
      • Klávesnice
      • Práce se systémem Windows
    • Nové konfigurace
    • Úprava konfigurací
      • Jazyk
      • Cesta
      • Displej
      • Uložení konfigurace
    • Získejte platnou licenci pro aplikaci Tech2Win.
  • Práce s aplikací Tech2Win: Informace o každodenní práci.
    • Nabídka
    • Stažení obrazu PCMCIA
    • Zabezpečení
    • Zobrazení zpráv
    • Manipulace s obrazy PCMCIA
    • Stavový řádek
  • Pokročilá témata: Informace nepotřebné pro normální používání aplikace Tech2Win. Často užitečné pouze pro lidi zajišťující správu systému.
    • Opětovná instalace
    • Odinstalování
    • Formát konfiguračního souboru
    • Soubor záznamu
    • Chybová hlášení a chybové kódy
    • Karta ATA
    • Položky registru
    • Soubory
    • Správa konfigurace
  • Nejčastější dotazy


Úvod

Tech2Win je aplikace pro systém Windows, která dokáže emulovat funkce programu Tech2. Program Tech2 je spouštěn na počítači. Pokud chcete tento program používat, musí váš počítač splňovat následující technické požadavky:

  • Do počítače musí být nainstalováno a zapojeno rozhraní pro komunikaci s vozidlem. Seznam dostupných rozhraní se liší v jednotlivých regionech. Ve většině případů lze používat Multiple Diagnostic Interface (MDI) od společnosti GM.
  • Aplikace Tech2Win vyžaduje v průběhu instalace 150 MB volného místa na disku. Na každou kartu flash PCMCIA, kterou chcete používat, budete potřebovat dalších 32 MB.
  • Před spuštěním aplikace Tech2Win budete potřebovat minimálně 100 MB volné fyzické paměti RAM. Počítač musí míst dostatek paměti, aby mohla aplikace zůstávat v RAM po celou dobu svého spuštění.
  • Počítač by měl mít výkon odpovídající procesoru Pentium 1,2 GHz (jednojádrový). Nedoporučujeme současné používání žádných dalších aplikací.
  • Klávesnice není potřeba. Aplikaci Tech2Win lze také ovládat pomocí dotykové obrazovky. Při správě konfigurací doporučujeme používat klávesnici, protože budete muset zadávat názvy souborů.
  • Vaše barevná obrazovka musí mít minimální rozlišení 800 x 600 a musí být schopna zobrazit minimálně 256 barev. Bez klávesnice je přijatelné rozlišení 640 x 480.

Používáte-li aplikaci Tech2Win (laptop místo Tech2), zajistěte, aby měl tento laptop dostatečný výkon. Obvykle nelze laptop napájet pomocí automobilové baterie jako Tech2.

  • Instalace
  • První kroky


Licence

General Motors - Licenční smlouva na aplikaci Tech2Win

Před použitím tohoto programu si pozorně přečtěte následující podmínky a ustanovení. Pokud těmto podmínkám a ustanovením nerozumíte nebo je neakceptujete, kontaktujte prosím místního zástupce oddělení Aftersales. Právo používat tento software poskytuje společnost General Motors výhradně pod podmínkou, že uživatel souhlasí s touto licencí a akceptuje během instalace softwaru Tech2Win tyto podmínky a ustanovení.
Společnost General Motors poskytuje právo používat software Tech2Win a informace související s aplikací TIS2Web nebo GlobalTIS nebo TIS2000 výhradně uživatelům sítě autorizovaných servisních opraven společnosti General Motors dle ustanovení místně příslušné smlouvy o autorizovaných servisních opravnách, která byla uzavřena s národními obchodními společnostmi General Motors.
Licence na software Tech2Win platí po celou dobu, kdy je v platnosti dohoda s autorizovanou opravnou a kdy platí licence na aplikace TIS2Web, GlobalTIS a TIS2000. Platnost licence Tech2Win skončí v souvislosti s licencí TIS2Web a GlobalTIS, jakmile skončí platnost smlouvy s autorizovaným servisem.

Nezávislé opravny tak, jak jsou definovány v čl. 4 odst. 2 předpisu BER (European Union Block Exemption Regulation) 1400/2002, si mohou zakoupit licenci na software Tech2Win v rámci nabízeného předplatného, které je k dispozici na portálu GM Europe Info Tech Portal společnosti General Motors Europe.

Licence Tech2Win neodpovídá komunikačnímu rozhraní ve vozidle nebo počítačovému hardwaru.

Software Tech2Win nesmí být dále distribuován, prodáván ani umísťován online a být k dispozici třetím stranám mimo autorizované servisní opravny (dle popisu v příslušné příloze ke smlouvě o autorizované servisní opravně) bez písemného souhlasu příslušných národních prodejních společností General Motors. To platí pro aktuální i neaktuální data (např. DVD s ukončenou platností).

Národní prodejní společnosti General Motors jsou oprávněny s okamžitou platností zrušit přístup a okamžitě vypovědět smlouvu o autorizované servisní opravně v případě neoprávněného nebo nezákonného použití. V tomto případě je vyloučeno nárokovat úhradu zůstatků resp. celoročních základních poplatků.

Poskytnuté informace slouží k odbornému provádění servisních prací a oprav neupravených motorových vozidel společnosti General Motors. Ukončené školení automechaniků a pravidelné další školení je nezbytným předpokladem pro vykonávání výše uvedených prací. Pokud je v poskytnutých informacích uvedeno, že je potřeba použít speciální nástroje, musí být pro všechny odborně prováděné opravy použity takové speciální nástroje.

Informace uvedené v aplikaci Global TIS společnosti General Motors (text a obrázky, hudba, grafika, animace, videa atd.) a uspořádání stránek jsou chráněny autorským právem. Reprodukce, šíření, předávání a/nebo přenos nebo jiné použití je možné pouze po předcházejícím písemném svolení společnosti General Motors.

  • Instalace: Kroky instalace
  • První kroky


Installation

Instalace

Instalace aplikace Tech2Win vyžaduje lokální práva správce pro daný počítač. Instalace nebude fungovat bez oprávnění správce. V takovém případě kontaktujte svého místního správce počítačů a požádejte jej o pomoc.

Pokud chcete úspěšně používat aplikaci Tech2Win, musíte provést následující dva kroky:

  • Instalaci samotné aplikace Tech2Win.
  • Instalace komunikačního rozhraní vozidla.
  • Instalace: Kroky instalace
  • První kroky


Kroky instalace

Samotná instalace trvá několik minut a uživatel musí zadat následující:

  1. Licenční smlouva
  2. Instalační adresář

Jazyk

Ve výchozím nastavení se jako jazyk operačního systému nastaví Tech2Win UI. Obecně jsou podporovány následující jazyky. Pokud váš jazyk není podporován, instalace se spustí v angličtině, která je nastavena jako výchozí jazyk pro instalaci.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Angličtina (buď britská nebo americká)*
  • el_GR (EL)Greek
  • es_ES (ES)španělština
  • fi_FI (FI)Finnish
  • fr_FR (FR)francouzština
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Portugalština (Brazílie)
  • pt_PT (PT)Portugalština (Portugalsko)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Čínština (zjednodušená)
  • zh_TW (ZH)Čínština (tradiční)

* Jazykem systému Tech2Win je britská angličtina. Software Tech2 a instalace však v závislosti na zdroji softwaru může používat americkou angličtinu.

Licenční smlouva

Musíte akceptovat Licenční smlouvu.

Instalační adresář

Jako místo pro nainstalování aplikace Tech2Win si můžete zvolit jakýkoli adresář. Výchozí nastavení instalačního adresáře je buď <adresář s vašim programem>\General Motors\Tech2Win nebo v případě opětovné instalace předchozí umístění.

Nakonec potvrďte instalaci.

Virtuální ovladač portu COM

Virtuální ovladač portu COM se na váš počítač instaluje pouze jednou a zůstává zde do doby, než bude verze ovladače aktualizována (což se děje málokdy) resp. než systém Tech2Win odinstalujete ze svého počítače.
Po nainstalování ovladače se na chvíli zobrazí rámeček DOS. Tento rámeček se automaticky zavře a není zapotřebí žádná další akce. Soubory ovladače se dále umístí do vnořené složky 'ovladač' do které se instaluje Tech2Win.
Je možné, nicméně to nedoporučujeme, ovladače virtuálních portů COM instalovat resp. odinstalovat manuálně. Použijte jeden z následujících povelů ze systému CMD:

  • pomocí 'vbsetup7' nainstalujte ovladač
  • pomocí 'vbsetup7 /u' odinstalujte ovladač
  • První kroky


Komunikační rozhraní vozidla

Zařízení pro komunikaci s vozidlem je nutné nainstalovat odděleně. Projděte si odpovídající instalační příručku dodávanou s komunikačním rozhraním vozidla.

  • První kroky: Komunikační rozhraní vozidla
  • Pokročilá témata: Konfigurační soubor
  • Instalace: Kroky instalace
  • Nejčastější dotazy: Jak mohu používat více než jedno rozhraní MDI?
  • Nejčastější dotazy: Aplikace Tech2Win nenalezla moje rozhraní MDI


První kroky

Tyto první kroky vám ukáží, jak používat aplikaci Tech2Win. Předpokládá se, že znáte program Tech2. Při těchto prvních krocích není nutná komunikace s vozidlem.

Rychlé spuštění:

  1. Spusťte software Tech2Win pomocí zkratky Quickstart na pracovní ploše.
  2. Získání platné licence při stáhnutí nového softwaru Tech2 ze systému TIS2Web.

Použijte volitelnou konfiguraci:

  1. Spusťte konfigurátor pomocí zkratky Tech2Win na pracovní ploše. Po instalaci by měla být připravena výchozí konfigurace.
  2. Chcete-li vytvořit novou konfiguraci, zkopírujte, pokud možno, výchozí konfiguraci.
  3. Tuto konfiguraci upravte tak, aby odpovídala vašim konkrétním požadavkům.
  4. Získejte platnou licenci.

Nespouštějte systém Tech2Win v režimu kompatibility. V tomto případě se v souboru protokolu zobrazí varování. Tech2Win používá pouze funkce systému Windows, které existují od systému XP, přičemž u starších verzí systému Windows tyto verze nefungují.

  • První kroky: Nové konfigurace
  • První kroky: Úprava konfigurací
  • První kroky: Komunikační rozhraní vozidla
  • Práce s aplikací Tech2Win: Nabídka
  • Práce s aplikací Tech2Win: Zabezpečení
  • Práce s aplikací Tech2Win: Stavový řádek
  • Pokročilá témata: Konfigurační soubor


Výběr konfigurace

Při prvním spuštění aplikace Tech2Win se objeví následující obrazovka. Můžete spustit aplikaci Tech2Win přímo s výchozí konfigurací. Výchozí konfigurace funguje bez používání jakékoli komunikace s vozidlem.

Start First Time

Zobrazí se okno s licenčními informacemi, ale můžete jej přeskočit a spustit výchozí konfiguraci.

Při práci s dotykovou obrazovkou může být lepší si spustit program simulující klávesnici počítače, abyste mohli zadávat písmena.


Klávesnice

Klávesy počítače, včetně všech tlačítek, se namapují na známá tlačítka programu Tech2. Aplikace Tech2Win obsahuje několik dalších kláves, které nejsou obsaženy v původním programu Tech2. Numerická klávesnice počítače nemusí za všech podmínek fungovat správně. Pokud nastanou nějaké problémy, tak zkontrolujte, jestli nedošlo ke změně standardního rozložení klávesnice vašeho počítače. Nejčastěji dochází k poškození klávesy SHIFT.

Klávesnice počítače | Tlačítko | Funkce
Funkční klávesa F1 | nedostupná | Nápověda k aplikaci Tech2Win
Funkční klávesy F5 .. F8 | Používejte obrazovku aplikace Tech2Win se zobrazenými tlačítky | Čtyři softwarové klávesy programu Tech2
Klávesy kurzor nahoru, dolů, vlevo, vpravo |  | Klávesy programu Tech2 nahoru, dolů, vlevo, vpravo. Pouze tyto klávesy mají automatické opakování.
Klávesy 0 .. 9 | F0 • • • F9 | Klávesy programu Tech2 F0 .. F9
Backspace | Exit | Klávesa programu Tech2 Konec
Enter / Return | Enter | Klávesa programu Tech2 Enter
Y | Yes | Klávesa programu Tech2 Ano
N | No | Klávesa programu Tech2 Ne
Q | ? | Klávesa programu Tech2 ?
S | Shift | Klávesa programu Tech2 Shift. Stav poznáte podle kontrolky Shift na stavovém řádku nebo podle kontrolky nad tlačítkem Shift.
ctrl-P | PWR | Klávesa programu Tech2 Napájení; Pomocí této klávesy můžete pochopitelně aplikaci Tech2Win pouze vypnout.
ctrl-R | není k dispozici | Provede reset aplikace Tech2Win. Podobné jako cyklus Vypnout/Zapnout napájení u programu Tech2. Nedojde ale k resetování připojeného komunikačního rozhraní vozidla. Soubory, jako je například bitová kopie PCMCIA se znovu nenačtou.
Domů | Home | Klávesa domů. Podporována pouze některými aplikacemi.
Dostupné pouze pomocí možnosti nabídky Soubor. | Print Screen | Vytiskne screenshot obrazovky aplikace Tech 2: vytvoří dočasný soubor BMP a vyvolá aplikaci pracující se soubory BMP. Použijte tuto aplikaci k úpravě velikosti nebo otočení obrázku před tiskem.
Dostupné pouze pomocí možnosti nabídky Soubor. | Save Screen | Uloží snímek obrazovky programu Tech2 jako soubor BMP nebo PNG.
Dostupné pouze pomocí možnosti nabídky Soubor. | View Report | Zobrazí všechny zprávy uložené na aktivní kartě flash PCMCIA tak, aby si je uživatel mohl prohlédnout.


Práce se systémem Windows

Velikost oken můžete upravovat přetažením okrajových čar hlavního okna tak, jak je obvyklé v systému Windows. Navíc položka nabídky Možnosti/Rozlišení podporuje několik přednastavených velikostí. Při změně velikosti hlavního okna pomocí položky nabídky zůstane okno s klávesnicí automaticky na svém původním místě.

Vzhled oken můžete upravovat změnou konfigurace na kartě Displej.


Nové konfigurace

Klepnutím na tlačítko Vytvořit novou vytvořte novou konfiguraci. Zobrazí se dialog s nabídkou, ve které můžete vybrat existující konfigurační soubor, který se použije jako zdroj. Obvykle se používá výchozí konfigurace. Po zadání názvu nového konfiguračního souboru stiskněte tlačítko Kopírovat.

Pokud pracujete s dotykovou obrazovkou, můžete si raději stisknutím tlačítka Klávesnice počítače aktivovat simulaci počítačové klávesnice.

Pomocí tlačítka Zrušit můžete proces vytváření stornovat.

Nová konfigurace bude používat stejný soubor PCMCIA jako původní zdrojová konfigurace. Pokud to chcete změnit, musíte upravit konfiguraci tak, aby byl použit jiný soubor PCMCIA. Ve většině případů jednoduše zkopírujete stávající soubor PCMCIA do nového souboru a použijete nový soubor. Možná budete chtít, aby nová konfigurace používala stejný soubor PCMCIA jako zdrojová konfigurace. V tomto případě se po kliknutí na tlačítko Uložit objeví varovná obrazovka.

  • Úprava konfigurací


Úprava konfigurací

Konfigurace vypsané modrým písmem jsou určeny pouze ke čtení a nelze je tedy upravovat. Tyto konfigurace si můžete pouze zobrazit. Samozřejmě, že můžete postup pro úpravy použít k zobrazování jejich obsahu, ale nebude možné použít funkci Uložit.

Konfiguraci můžete upravit vybráním jednotlivých nastavení v následujících čtyřech položkách Jazyk, Komunikační rozhraní vozidla, Cesta, Displej. Můžete buď zvolit požadovaný tabulátor nebo jednoduše klepnout na tlačítko Další, které aktivuje následující tabulátor. Po provedení požadovaných úprav uložte konfiguraci stisknutím tlačítka Uložit.

Pokud potřebujete zadávat informace pomocí klávesnice, můžete si vyvolat aplikaci počítače simulující klávesnici. Tato možnost se obzvláště hodí u laptopů s dotykovou obrazovkou, které nemají žádnou klávesnici.


Jazyk

Položka Jazyk umožňuje zvolit jazyk, který bude aplikace Tech2Win po spuštění používat. Tato volba nemá žádný vliv na jazyk softwaru Tech2 nacházejícího se na obrazu PCMCIA. Při stahování programu Tech2 z TIS si budete muset znovu zvolit správný jazyk.

V některých regionech nejsou k dispozici všechny jazyky. V takovém případě se zobrazí angličtina. Zkontrolujte prosím, zda je k dispozici podobný jazyk(např. PT Portugalština - Portugalsko místo možnosti PB Portugalština - Brazílie).


Cesta

Položka Cesta umožňuje nastavit jak cestu obou obrazů PCMCIA, tak cestu k lokální softwarové klávesnici. Pro kopírování obrazů PCMCIA je zde také tlačítko Kopírovat paměťovou kartu. Pokud jste zrovna vytvořili novou konfiguraci, můžete pomocí tohoto tlačítka zabránit tomu, aby stejný obrázek PCMCIA používalo několik konfigurací.

Memory Card Options

Kopírovat paměťovou kartu ...

Pomocí tohoto tlačítka můžete zkopírovat obraz PCMCIA do jiného souboru. Jeho funkce je velice podobná zakoupení nové karty PCMCIA pro program Tech2. Funkce kopírování funguje jenom u souborů v adresáři C:\Users\Public\General Motors\Tech2Win\pcmcia.

Slot 0: Umístění obrazu paměťové karty

Zde můžete určit soubor, obsahující obraz PCMCIA pro slot 0. Obvykle se tento soubor nachází ve složce C:\Users\Public\General Motors\Tech2Win\pcmcia. Jiné umístění je však také možné.

Slot 1: Paměťová karta nebo ATA

Podobně jako program Tech2, Tech2Win také podporuje dvě karty PCMCIA (obrazy). Nicméně druhý obraz PCMCIA v jedné konfiguraci není obvykle příliš užitečný. V druhé konfiguraci by se pravděpodobně používal druhý software.

Podobně jako u programu Tech2 se i zde pro účely ladění používá karta ATA. Kartu ATA aktivujte pouze v případě, že vás k tomu vyzvou pracovníci technické podpory. Ti vám dají další informace.

Umístění softwarové klávesnice počítače

Výchozí hodnota tohoto souboru se načítá z registru Windows a měla by ukazovat na aplikaci schopnou simulovat klávesnici počítače s myší. Pokud používáte ve vašem laptopu speciální aplikaci nabízející tyto funkce, můžete zde tuto aplikaci určit.


Komunikační rozhraní vozidla

  • Port COM pro emulaci Tech2-RS232
  • Výrobní číslo používaného MDI
  • Protokol

Port COM pro emulaci Tech2-RS232

Vyberte volný port COM, který lze používat k emulaci Tech2. Pro ulehčení vaší práce se konfigurační program pokusí vyhledat používané sériové porty a zobrazí je.

Vyberete-li již existující port COM, aplikace Tech2Win se připojí k tomuto existujícímu portu COM. Tento port COM můžete použít ke stažení programu Tech2 z jiného počítače se spuštěnou aplikací TIS pomocí kabelu nulového modemu. Pamatujte prosím, že používání skutečného portu COM nemusí být při přenosové rychlosti 115 200 baudů spolehlivé z důvodu omezení systému Windows.

Vyberete-li neexistující port COM, aplikace Tech2Win automaticky vytvoří virtuální port. Tento virtuální port lze použít pomocí aplikace TIS spuštěné na stejném počítači k navázání komunikace s aplikací Tech2Win. Při používání virtuálního portu neexistuje žádné omezení přenosové rychlosti.

Pokud nastavíte 'hledání' portu COM, Tech2Win vytvoří virtuální port COM na prvním portu s volným číslem od 9 do 1.

Výrobní číslo používaného MDI

Zadejte sériové číslo rozhraní MDI. Toto číslo naleznete na zadní straně rozhraní MDI. Použijte číslo za pomlčkou.

Pokud nezadáte sériové číslo, zobrazí aplikace Tech2Win automaticky seznam rozhraní MDI detekovaných v síti a nechá uživatele, aby rozhraní MDI vybral. Stejné okno pro výběr se zobrazí v případě, když zadané rozhraní MDI nebylo nalezeno.

Protokol

Je vybráno rozhraní „ISO22900-2 / PDU-API“ a možnost J2534-2 je vždy zobrazena šedě. V budoucnu bude aplikace Tech2Win pravděpodobně podporovat také protokol J2534.

  • Pokročilá témata: Konfigurační soubor
  • Nejčastější dotazy: Jak mám zjistit, který port COM mám používat pro aplikaci Tech2Win?
  • Nejčastější dotazy: Komunikace mezi aplikacemi Tech2Win a TIS2Web
  • Nejčastější dotazy: Jak mohu používat více než jedno rozhraní MDI?
  • Nejčastější dotazy: Aplikace Tech2Win nenalezla moje rozhraní MDI


Displej

Karta Displej se převážně používá k upravování nastavení týkajících se zobrazení aplikace Tech2Win:

  • Klávesnice
  • Barvy
  • Zvuk
Display and Key Options

Klávesnice

Zde si můžete zvolit, jestli se má zobrazovat klávesnice. Klávesnice se vykreslí buď v levé nebo v pravé části obrazovky aplikace Tech2Win. Barvu pozadí si můžete zvolit pomocí standardního dialogového okna pro nastavení barvy.

Barvy

Zde si můžete nezávisle zvolit barvu popředí a pozadí obrazovky Tech2. Nejběžnější kombinace barev:

Screen with background 0000FF, foreground FFFFFF | Pozadí klávesnice bílá; Modrá na pozadí; Popředí bílá
Screen with background 000000, foreground C0C0C0 | Modrá na pozadí klávesnice; Pozadí černá; Popředí světle šedá

Zvuk

Zde můžete vypnout zvuk. Pokud program Tech2 pípne, použije se reproduktor počítače.


Uložení konfigurace

Aktivní konfiguraci můžete uložit stisknutím tlačítka Uložit <konfigurace> v levém spodním rohu. Pokud máte zobrazenou konfiguraci určenou pouze ke čtení, potom se toto tlačítko nezobrazí.


Platná licence pomocí aplikace TIS2Web

Při stažení programu Tech2 to aplikace Tech2Win obvykle získáte platnou licenci. Další můžete získat pomocí 'Povolit programování (Bezpečnost)' přes TIS2Web (nikoliv TIS2000). Předpokladem je proto výběr virtuálního portu COM v konfigurátoru pod položkou Komunikační rozhraní vozidla.

Po úspěšném navázání zabezpečeného připojení uvidíte na pravé straně stavového řádku otevřený zámek. Uvnitř závorek vidíte počet dní platnosti licence. Při opětovném spuštění aplikace Tech2Win se indikátor zabezpečení nezobrazí, pokud neprobíhá komunikace s vozidlem. Při první komunikaci s vozidlem proběhne kontrola licence a indikátor se změní buď na otevřený nebo zavřený zámek.

  • Práce s aplikací Tech2Win:Zabezpečení
  • Nejčastější dotazy:Jak mám zjistit, který port COM mám používat pro aplikaci Tech2Win?
  • Nejčastější dotazy:Komunikace mezi aplikacemi Tech2Win a TIS2Web
  • Nejčastější dotazy:Platná licence
  • Nejčastější dotazy:Jaký je rozdíl mezi licencí aplikace Tech2Win a zabezpečeným přístupem?


Práce s aplikací Tech2Win

Většina techniků pracujících s aplikací Tech2Win využije následující témata:

  • Nabídka: Rozložení obrazovky a jednotlivé položky nabídky.
  • Stahování bitové kopie PCMCIA: Aktualizace diagnostického softwaru pro aplikaci Tech2Win je velice podobná metodě používané u programu Tech2.
  • Zabezpečení: Bezpečnostní opatření brání aplikaci Tech2Win provádět komunikaci s vozidlem v nepovoleném prostředí.
  • Zobrazení zpráv: Klávesnice z programu Tech2 byla v aplikaci Tech2Win lehce rozšířena. Nejvýznamnějším příkladem je tlačítko 'Zobrazit zprávy'.
  • Manipulace s obrazy PCMCIA: Podobně jako můžete mít v programu Tech2 více karet PCMCIA, můžete také v aplikaci Tech2Win používat několik obrazů PCMCIA.
  • Stavový řádek: Stavový řádek informuje uživatele o jednotlivých částech stavového řádku.
    • Pokročilá témata
    • Nejčastější dotazy


Nabídka

Aplikace Tech2Win nabízí následující položky nabídky:

  • Soubor
  • Možnosti
  • Okna
  • Nápověda

Soubor

Nabídka Soubor obsahuje následující možnosti:

  • Možnost Uložit obrazovku T2 (320x240) se používá k uložení aktuální obrazovky T2 v rozlišení 320x240 bodů do souboru s černobílým obrázkem. Umístění pro uložení souboru a formát souboru (BMP, GIF, JPG, PNG) si můžete zvolit.
  • Možnost Vytisknout obrazovku vytvoří inverzní černobílý snímek ve formátu BMP obrazovky programu Tech2 a zavolá program asociovaný se soubory BMP. Tento program můžete poté použít k vytištění snímku.
  • Zobrazit soubory zpráv umožňuje zobrazení (a tisk) souborů sestav bez použití aplikace TIS2Web.
  • Konec zavře aplikaci Tech2Win.

Možnosti

Nabídka Možnosti obsahuje následující možnosti:

  • Rozlišení můžete použít k vybrání jedné ze tří standardních velikostí obrazovky.
  • ROM-Write from 0x00003ED76 se používá k účelům vnitřního ladění.
  • Automatické snímky obrazovky uloží snímek každé odlišné obrazovky Tech2 do adresáře protokolu.
  • Zakázat CANdi a restartovat imituje program Tech2 v situaci, kdy není mezi tímto programem a vozidlem rozhraní CANdi. Tento postup je nutný ve vzácných případech, kdy rozhraní CANdi přerušuje nestandardní komunikační vedení vozidla.

Okna

Nabídka Okna umožní aktivovat možnosti Zobrazení dat aplikace Tech2Win a Zobrazení DTC aplikace Tech2Win. Všechny ostatní možnosti jsou v aktuální verzi aplikace Tech2Win šedé.

Pokud software Tech2 podporuje Zobrazení dat aplikace Tech2Win, můžete tento záznam v nabídce povolit. Po spuštění datového displeje zobrazí Tech2 souběžně s datovým displejem Tech2 další okno datového displeje. Dokud obrazovka systému Tech2 ukazuje zobrazení dat, záznam nabídky nelze povolit. V tomto případě musíte opustit zobrazení dat, povolit záznam nabídky a zobrazení dat znovu spustit.

Podobná omezení jako pro Zobrazení dat aplikace Tech2Win platí také pro Zobrazení DTC aplikace Tech2Win. Pokud software Tech2 podporuje Zobrazení DTC aplikace Tech2Win, můžete tento záznam v nabídce povolit. Souběžně se zobrazením DTC v systému Tech2 se zobrazí další okno zobrazení DTC. Dokud obrazovka systému Tech2 ukazuje zobrazení DTC, záznam nabídky nelze povolit. V tomto případě musíte opustit zobrazení DTC, povolit záznam nabídky a zobrazení DTC znovu spustit.

Nápověda

Máte k dispozici následující volby:

  • Témata nápovědy... vyvolá nápovědu aplikace Tech2Win.
  • Parametr příkazového řádku zobrazuje parametry příkazového řádku používané aplikací Tech2Win.
  • V části O se zobrazí aktuální verze a omezení stahování aplikace Tech2Win přes TIS2Web.


Stažení

Nejprve spusťte aplikaci Tech2Win a nechte ji na hlavní obrazovce. Spusťte aplikaci TIS2Web nebo GlobalTIS a proveďte stažení přes port COM tak, jak je uvedeno na kartě Komunikační rozhraní vozidla.

Pomocí vestavěných portů COM můžete stahovat software Tech2 z jiných počítačů, na kterých je spuštěn TIS. Je nutné použít překřížený kabel RS232. V závislosti na hardwaru počítače, na kterém je spuštěna aplikace Tech2Win, může být nutné snížit přenosovou rychlost na 57 600 baudů, protože systém Windows může při vyšší rychlosti ztrácet data.

Nejnovější verze aplikace Tech2Win rovněž umožňuje rychlé stahování dat v případě, že aplikace TIS2Web a Tech2Win jsou spuštěny na stejném počítači. TIS2Web a Tech2Win spolu přes port COM stále komunikují minimálně, nicméně časově náročný přenos dat do systému Tech2Win byl nahrazen interním přenosem souborů. V tomto případě se čas stahování výrazně sníží, a to na necelou minutu.

  • Pokročilá témata: Konfigurační soubor
  • První kroky: Komunikační rozhraní vozidla
  • Nejčastější dotazy: Jak mám zjistit, který port COM mám používat pro aplikaci Tech2Win?
  • Nejčastější dotazy: Komunikace mezi aplikacemi Tech2Win a TIS2Web


Zabezpečení

Mechanizmus zabezpečení používaný aplikací Tech2Win je založen na správné hodnotě hodin počítače. Zajistěte, aby byly hodiny počítače vždy správně nastavené. Malé úpravy hodin, jako například při přechodu na letní čas, bude aplikace Tech2Win tolerovat.

Aplikace Tech2Win nezahájí komunikaci s vozidlem bez platné a aktivní licence. Následující indikátor na stavovém řádku označuje stav licence:

  • green smiley Licence je platná.
  • Bez indikátoru: Licence ještě nebyla zkontrolovaná.
  • red smiley Platnost licence vypršela.

Chcete-li získat licenci, proveďte prosím aktualizaci 'Povolit programování (Bezpečnost)' přes aplikaci TIS2Web. Ve většině případů bude k získání nové licence stačit stažení softwaru pomocí aplikace TIS2Web. Jelikož platnost licence po určité době vyprší (v některých regionech za čtyři týdny), musíte tyto aktualizace provádět v pravidelných intervalech.

Licence jsou specifické pro určité regiony a pro určité programy. Můžete mít ve svém počítači licence spojené s aplikací Tech2Win a s odlišnými verzemi programu Tech2.

Počet dní do vypršení platnosti licence je zobrazen na stavovém řádku.

  • ( 0) označuje, že platnost licence vypršela nebo že licence neexistuje.
  • (<1) Platnost licence vyprší do 24 hodin.
  • (20) Platnost licence vyprší za 20 dní.

Nepokoušejte se nijak pozměnit licenční soubor. Neoprávněná změna tohoto souboru bude zjištěna pomocí interních operací zabezpečení a povede ke ztrátě všech licencí v daném počítači. Aplikace Tech2Win se navíc může chovat neočekávaným způsobem. Tento problém lze překonat pouze provedením nové instalace.

  • Pokročilá témata: Chybová hlášení a kódy ukončení
  • Pokročilá témata: Soubor záznamu
  • Práce s aplikací Tech2Win: Stavové okno
  • Nejčastější dotazy: Platná licence
  • Nejčastější dotazy: Jaký je rozdíl mezi licencí aplikace Tech2Win a zabezpečeným přístupem?
  • Nejčastější dotazy: Náhlé zastavení


Zobrazování zpráv

View Report Pomocí tohoto tlačítka si můžete zobrazit obsah všech souborů PRT nacházejících se na kartě PCMCIA. Otevře se dialogové okno se seznamem všech souborů PRT. Pokud byl s koncovkou PRT asociován nějaký program, dojde ke spuštění tohoto programu. Jinak se otevře editor Poznámkový blok a zobrazí zvolený soubor.

Ve většině případů je soubor PRT souborem ASCII používajícím příslušné jazykové kódové stránky. U čínštiny, japonštiny, korejštiny a thajštiny je tento soubor ve formátu unicode se značkou BOM.

Při prohlížení zpráv pracuje aplikace Tech2Win s podadresářem C:\Users\Public\General Motors\Tech2Win\reports. Tento podadresář existuje pouze tehdy, pokud jste si již někdy zobrazili zprávy. Adresář je automaticky vymazáván a slouží jako dočasný pracovní adresář pro soubory PRT na aktivní kartě PCMCIA. Bude obsahovat tyto soubory i v případě přerušení běhu aplikace Tech2Win. Pokud si chcete takový soubor uložit, musíte jej zkopírovat do jiného adresáře, protože pokud by se jiný uživatel rozhodl zobrazit si zprávy, bude tento soubor přepsán.


Obrazy PCMCIA

Obrázky PCMCIA jsou obvykle uloženy v podadresáři C:\Users\Public\General Motors\Tech2Win\pcmcia. Soubor musí mít velikost přesně 32 MB (33.554.432 bajtů) nebo 10 MB (10.485.760 bajtů) a koncovku *.bin. Ke změně v obrazu dojde (stejně jako by došlo u normální karty PCMCIA) v případě stažení nebo pokud aplikace Tech2Win něco uloží na flash kartu. Změně můžete zabránit pomocí přepínače pro ochranu proti zápisu (příkaz -W0 nebo -W1) nebo vynecháním hodnoty 'p' v možnosti '-W'.(Konfigurační soubor). Spínač ochrany proti zápisu nelze pomocí tohoto konfigurátoru zpřístupnit. Chcete-li použít možnost '-W0', '-W1' nebo '-W', musíte konfigurační soubor manuálně upravit.


Stavový řádek

Stavový řádek se nachází pod obrazovkou programu Tech2. Na stavovém řádku jsou uvedeny následující položky:

  1. Indikátor rychlosti
  2. Stav komunikace s vozidlem
  3. Stav sériového portu
  4. Klávesa SHIFT
  5. Automatické snímky obrazovky
  6. Záznam-Výstraha
  7. Licence

Status Bar

Indikátor rychlosti

Indikátor rychlosti udává, kolik času CPU se věnuje emulaci programu Tech2. Nízká hodnota (indikátor vlevo) je lepší než vysoká hodnota (indikátor vpravo). Všechny zelené indikátory jsou přijatelné. Barva indikátoru se na chvíli může změnit na žlutou, pokud se aktivuje nějaká jiná úloha v rámci systému Windows. Takovým situacím je ale vhodné se vyhýbat.

Stav komunikace s vozidlem

Stav komunikace vozidla udává, jestli je přítomné komunikační rozhraní vozidla (MDI) a jestli probíhá komunikace mezi vozidlem a aplikací Tech2Win.

Stav sériového portu

Pokud komunikace s Tech2Win probíhá přes port COM, udává tento indikátor, jestli je komunikace na portu COM aktivní nebo ne.

Klávesa SHIFT

Tato kontrolka indikuje, zda je klávesa SHIFT aktivní. K přepínání můžete použít klávesu 'S' nebo klávesu SHIFT na klávesnicích.

Automatické snímky obrazovky

Automatické ukládání snímků obrazovky můžete nastavit v nabídce Možnosti. Při každé změně obrazovky se do adresáře protokolu uloží nový soubor se snímkem obrazovky. Označuje to otočení kliky červeného fotoaparátu na stavovém řádku. Pokud dojde k vypnutí funkce automatického snímkování obrazovky, fotoaparát zmizí.

Záznam-Výstraha

Indikátor Stav protokolu udává jeden ze tří různých stavů.

  • gray log status indicator Soubor protokolu neobsahuje žádné výstrahy ani chyby.
  • yellow log status indicator Soubor protokolu obsahuje výstražné hlášení.
  • red log status indicator Soubor protokolu obsahuje chybové hlášení.

Licence

Indikátor licence udává jeden ze tří stavů:

  • green smiley Licence je aktivní a platná.
  • Bez indikátoru: Licence ještě nebyla zkontrolovaná.
  • red smiley Platnost licence vypršela nebo licence neexistuje.
Podrobnosti naleznete v odkazu Zabezpečení.

Popisy tlačítek na stavovém řádku

U některých ikon se zobrazují popisy tlačítek obsahující další informace.

Popis tlačítka pro sériové číslo VCI:
Tooltip VCI

Popis tlačítka pro verzi softwaru TECH2
Tooltip TECH2

Popis tlačítka pro port COM
Tooltip Comport

Popis tlačítka pro číslo následujícího snímku obrazovky (pokud je zapnutá funkce 'Automatické snímky obrazovky')
Tooltip Camera

Popis tlačítka zobrazující poslední položku souboru protokolu s úrovní 'výstraha' nebo vyšší
Tooltip Logfile

Popis tlačítka pro přesnou délku trvání licence
Tooltip License

Popisy tlačítek se zobrazí, pokud kurzor zůstane bez pohybu nad ikonou po dobu delší než 0,5 sekundy. Popisy tlačítek zmizí po 5 sekundách nebo po pohnutí kurzorem.

  • Pokročilá témata: Chybová hlášení a chybové kódy
  • Pokročilá témata: Soubor záznamu


Pokročilá témata

Zde probíraná témata nejsou tak důležitá pro standardního uživatele aplikace Tech2Win. Následující informace mohou být užitečné pro osoby provádějící nastavení, správu a konfigurování aplikace Tech2Win.

  • Opětovná instalace
  • Odinstalování
  • Přímá úprava konfiguračních souborů
  • Soubor záznamu
  • Chybová hlášení a kódy ukončení
  • Karta ATA
  • Položky registru
  • Popis souboru
  • Ukázky správy konfigurací


Odinstalování

Je vymazán celý instalační adresář, adresář obsahující uživatelská data (C:\Users\Public\General Motors\Tech2Win) a adresář obsahující data aplikace (C:\ProgramData\General Motors\Tech2Win).

  • Pokročilá témata: Opětovná instalace
  • Instalace


Konfigurační soubor

Konfigurační soubory jsou vždy uloženy v podadresáři C:\Users\Public\General Motors\Tech2Win\config a mají příponu *.conf. Konfigurační soubor můžete upravit i ručně, protože ne všechny možnosti nabízené tímto souborem jsou nastavitelné pomocí aplikace Tech2Win. Konfigurační soubor je soubor ve formátu Unicode se značkou BOM. Při provádění ručních změn důrazně doporučujeme používat editor schopný pracovat s kódem Unicode, jako je například Poznámkový blok.

Konfigurační soubor je řádkový soubor. Prázdné řádky jsou ignorovány. Řádek vždy začíná nějakou možností, po které většinou následuje nějaká hodnota. Podívejte se například na soubor default.conf. V následující tabulce naleznete všechny dostupné možnosti.

Chcete-li spustit konkrétní konfiguraci přímo z plochy, vytvořte zkratku, kterou konfiguraci spustíte 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\your_configuration_file.conf'. Program se musí spouštět z následujícího adresáře: 'C:\Program Files\General Motors\Tech2Win\bin'

možnost | Hodnota / Význam
; Komentář
@ Desetinné číslo verze ve formátu hlavní.vedlejší.
Konfigurační soubory s odlišným hlavním číslem verze než má aplikace Tech2Win nebudou akceptovány. Konfigurační soubory s nižším vedlejším číslem verze než má aplikace Tech2Win budou akceptovány.
-W0
-W1 		Karta PCMCIA ve slotu 0/1 má aktivovaný přepínač ochrany proti zápisu.
-B0
-B1 		Velikost bloku v Kb karty PCMCIA ve slotu 0/1. Přijatelné hodnoty jsou 128 (výchozí) nebo 256.
-P0
-P1 		Soubor obsahující binární obraz karty PCMCIA pro slot 0/1. Velikost tohoto souboru musí být přesně 10 MB nebo 32 MB. Proměnné prostředí jako např. %ProgramData% lze rozšířit.
Pokud není tato možnost uvedena, bude se předpokládat, že slot je prázdný.
-A0
-A1 		Soubor obsahující hodnoty atributů karty PCMCIA ve slotu 0/1. Pokud není přítomen, použijí se výchozí atributy založené na velikosti karty a bloku.
-W | Po ukončení aplikace Tech2Win se všechna stálá data zapíší do odpovídajících souborů. Hodnoty p/f/r/c lze kombinovat a označují PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | Funkcionalita Heap Management Hodnoty 0/r/w/t lze kombinovat a aktivovat tak Nulování, Načtení kontrol, Zápis kontrol a Kontroly úkolů. Hodnota l se používá vždy k vynucenému přiřazení paměti heap na nižší adrese, když se realizuje alternativní přiřazování. Obvykle se tato možnost používá pouze ve vývojařském prostředí.
-PC | Původně cesta pro kopii karty PCMCIA. Tato možnost je v současnosti ignorována.
-MS | Označení komunikačního rozhraní vozidla (MDI) pomocí sériového čísla. Pokud není nastaveno, zobrazí se vám seznam dostupných rozhraní MDI.
-CT | Barva textu (na popředí) je představována třemi hexadecimálními bajtovými hodnotami. Výchozí hodnota je 000000 (bílá).
-CB | Barva pozadí je představována třemi hexadecimálními bajtovými hodnotami. Výchozí hodnota je FFFFFF (černá).
-ATA | Pomocí této možnosti můžete zapnout digitalizační kartu ATA. Vyjmutím vypnete digitalizační kartu ATA.
-C | Číslo COM-portu (1..9), který bude program Tech2 používat jako komunikační port RS232C. Pro virtuální COM port nainstalovaný aplikací Tech2Win se často používá COM9. Pokud tato možnost není k dispozici, počínaje portem COM9 směrem dolů se bude hledat volný port. Pomocí špičky nástroje na stavové liště mezi ikonou Tech2 a ikonou TIS2Web zjistěte, jaký port COM se používá.
-WR | Adresa PC (obvykle 253558), která může zapisovat do oblasti PCMCIA a FLASH ROM. Tato funkcionalita musí být dodatečně aktivována v nabídce (nebo pomocí položky -WA). Je nutná k ladění kódu v neupravitelné paměti ladicím programem SingleStep Debugger.
-WA | Umožní aplikaci SingleStep Debugger zapisovat do nepřepisovatelné paměti.
-OF | Soubor s možnostmi obsahující dvojice možnost / hodnota.
-TP | Nastavení časování (poměrná hodnota). Změní se na výchozí hodnotu 5000. Snížíte-li tuto hodnotu, přizpůsobí se počet prováděných cyklů rychleji reálnému času.
-TD | Nastavení časování (rozdílová hodnota). Změní se na výchozí hodnotu 100. Snížením této hodnoty dosáhnete rychlejší reakce na změny okamžitého časování. VÝSTRAHA: Změna hodnot TP a TD může vést k problémům s rychlostí.
-PJ
-PP 		Určete protokol, který se má používat:
PJ pro komunikaci J2534.
PP pro ISO22900-2 / PDU-API (výchozí)
-S | Tato možnost umožňuje zvukový výstup na bzučák počítače.
-L | Jazyk používaný aplikací Tech2Win. Pokud toto zadání chybí, jako výchozí se nastaví aktivní jazyk systému Windows. Seznam dostupných jazyků naleznete pomocí následujícího odkazu: Jazyky. Samotné okno emulace Tech2 zobrazí jakýkoli jazyk obsažený na kartě PCMCIA (tj. jazyk, který byl stažen na kartu PCMCIA).
-UD | Přepsání adresáře uživatelských dat. V systému Win7 je normálně nastaven na C:\Users\Public\General Motors\Tech2Win
-AD | Přepsání adresáře aplikačních dat. V systému Win7 je normálně nastaven na C:\ProgramData\General Motors\Tech2Win
-US | Pomocí uživatelského semaforu detekujte více než jednu instanci Tech2Win. Tato možnost umožní všem uživatelům mít puštěný na stejném zařízení, zpravidla serveru, souběžně systém Tech2Win. U této možnosti byste měli rovněž specifikovat -UD a -AD.
-SS | Možnost nastavit celkovou velikost okna Tech2Win včetně klávesnice (je-li k dispozici). První parametr musí být řetězec ve dvojitých uvozovkách ('). Používá se rovněž k označení velikosti v nabídce Možnosti / Rozlišení. Druhý parametr je celkový počet vodorovných pixlů obrazovky Tech2Win včetně klávesnice. Třetí parametr je celkový počet svislých pixlů obrazovky Tech2Win. Čtvrtý volitelný parametr představuje šířku klávesnice v pixlech.
-SH Možnost regulovat ovládání obrazovky. Pomocí následujícího desetinného čísla se specifikuje zákaz možnosti ovládání obrazovky.
  • Bit 0: Není povoleno min/max.
  • Bit 1: Není povoleno přemístění obrazovky.
  • Bit 2: Není povolena změna velikosti. V tomto případě je nabídka Možnosti / Rozlišení šedá.
  • Bit 3: Naprosto stejná velikost oken DTC a zobrazení dat jako u okna Tech2Win (bez klávesnice)


Uchovávání záznamů

Při každém spuštění konfigurace aplikace Tech2Win dojde v podadresáři C:\Users\Public\General Motors\Tech2Win\Logs k vytvoření nového souboru protokolu ve formátu HTML. Z důvodu uvolnění místa na pevném disku jsou soubory protokolu starší než jeden týden odstraňovány.

Soubory záznamu jsou automaticky pojmenovávány podle data (y (rok), měsíc, den) a času (hodina, minuta, sekunda) vytvoření:
yyyy-mm-dd_hhmmss.html

Položky souboru záznamu jsou vždy v angličtině, ve formátu Unicode s úvodní značkou BOM. Každý řádek souboru záznamu představuje jednu z následujících úrovní záznamu:

Úroveň záznamu | Význam
Info | Pouze informace. Žádný vliv na provádění programu.
Výstraha | Došlo k neobvyklé situaci. Uživatel si nemusí všimnout žádného nežádoucího efektu.
ERROR | Nastala chyba, které si všimne i uživatel.
CRITICAL | Nastala kritická chyba, která způsobí abnormální chování programu.
FATAL | Závažná chyba způsobí okamžité přerušení běhu aplikace Tech2Win.

Všechny úrovně nad položkou 'Výstraha' jsou označeny barevně, aby je bylo snadné nalézt.

Pokud byla použita možnost nabídky Vytisknout obrazovku nebo Automatické snímky obrazovky, budou se v podadresáři Logs nacházet také soubory tisku a videa.
yyyy-mm-dd_hhmmss_print_nnnnn.bmp
yyyy-mm-dd_hhmmss_video_nnnnn.png
Obrázky Automatické snímky obrazovky jsou vzájemně propojeny souborem HTML - k zobrazení sekvence těchto obrázků tedy používejte protokol HTML.

Na stavovém řádku se uživateli zobrazuje, jestli existuje výstražná položka ( yellow lightning bolt) nebo ještě závažnější položka ( red lightning bolt) záznamu.


Chybová hlášení a kódy ukončení

V dialogových oknech se mohou zobrazit chybová hlášení. Tato dialogová okna nebrání aplikaci Tech2Win v paralelním provádění programu Tech2. Kódy ukončení představují závažně chyby způsobující abnormální ukončení aplikace Tech2Win. Kódy ukončení lze používat v dávkových souborech ke zjišťování důvodu ukončení programu.

Chybová hlášení

Mohou se zobrazit následující chybová hlášení. Uvádíme stručné vysvětlení situace a způsob vyřešení problému.

Emulator too slow Emulator failed to start

Kódy ukončení

Kód ukončení | Hodnota | Význam
OPCODE_ERROR | -7 | Byl detekován neplatný příkaz mikroprocesoru Tech2 (68332). Možná došlo k nějakému poškození obrazu karty PCMCIA.
ATA_PROBLEM | -6 | Došlo k problému při emulování karty ATA. Pokud se tento problém zobrazí poté, co jste obdrželi instrukce k použití karty ATA, obraťte se na pracovníky odborné pomoci.
DEMO_TIME_IS_UP | -5 | Neměl by se objevit v oficiální verzi aplikace Tech2Win.
DLL_NOT_LOADED | -3 | Nebylo možné načíst jeden z potřebných souborů DLL. Zdá se, že vaše kopie aplikace Tech2Win není kompletní. Zopakujte instalaci nebo zvolte jiný jazyk.
EXIT_INIT_FAILED | -2 | Chyba inicializace Přesnou příčinu naleznete v souboru záznamu. Pokud soubor záznamu neexistuje, zkontrolujte, jestli máte správný přístup pro čtení/psaní do všech adresářů.
normální | 0 | Aplikace Tech2Win byla ukončena normálně.


Karta ATA

Karta ATA se u programu Tech2 obvykle používá pouze k účelům ladění v průběhu vývoje softwaru. Veškerá potřebná data ATA jsou uložena v podadresáři C:\Users\Public\General Motors\Tech2Win\ataCapture. Tento adresář není obvykle nijak důležitý a můžete jej vymazat, pokud ovšem neobdržíte pokyn, abyste tak nečinili.

Jelikož je adresář ataCapture pevný, je jeho obsah stejný ve všech konfiguracích.


Soubory

Aplikace Tech2Win používá následující soubory a adresáře:

Adresář | Umístění před systémem Vista | Umístění pro systém Vista a další verze
Instalace | Podle definice během instalace
Uživatelská data | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Data aplikace | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Soubor | Použití
[Uživatelská data]\atacapture | Obsahuje soubory nacházející se na kartě ATA. Pokud neobdržíte další pokyny, nebudete tyto soubory potřebovat.
[Instalace]\bin | Obsahuje vlastní spustitelný soubor a soubory DLL a obrazy potřebné k běhu programu.
[Instalace]\bin\emulator.exe | Hlavní spustitelný soubor vykonávající kód programu Tech2.
[Instalace]\bin\emulator_xx_XX.dll | Zdrojový soubor DLL specifický pro určitý jazyk.
[Instalace]\bin\T2Configurator.exe | Konfigurační část systému Tech2Win.
[Instalace]\bin\Pictures | Obsahuje ikony používané aplikací Tech2Win.
[Uživatelská data]\config | Obsahuje všechny konfigurační soubory.
[Uživatelská data]\data | Obsahuje soubory, které jsou upravovány při běhu aplikace Tech2Win. Tyto soubory jsou nutné ke správnému fungování aplikace Tech2Win. S těmito soubory nic nedělejte, pokud k tomu nedostanete výslovné pokyny.
[Data aplikace]\data | Obsahuje soubory, které jsou upravovány při běhu aplikace Tech2Win. Tyto soubory jsou nutné ke správnému fungování aplikace Tech2Win. S těmito soubory nic nedělejte, pokud k tomu nedostanete výslovné pokyny.
[Data aplikace]\data\emulator.sec | Soubor zabezpečení . Tento soubor neupravujte.
[Data aplikace]\data\emulator.card | Soubor karty. Obsahuje všechny karty PCMCIA, které aplikace Tech2Win zná. Tento soubor neupravujte.
[Uživatelská data]\data\emulator.disp | Tento soubor obsahuje umístění a velikost obrazovky Tech2Win. Pokud tento soubor odstraníte, dojde k jeho opětovnému vytvoření a obrazovka aplikace Tech2Win se zobrazí v levém horním rohu s velikostí 640x480.
[Data aplikace]\data\emulator.lic | Licenční soubor. Obsahuje informace o délce platnosti vašich licencí. Tento soubor neupravujte.
[Data aplikace]\data\emulator.rtc | Soubor hodin reálného času. Tento soubor se používá jako úložiště dat nacházejících se v RTC programu Tech2.
[Data aplikace]\data\emulator.dta | Soubor s informací 'Neupozorňovat znovu'.. Tento soubor obsahuje verze softwaru PCMCIA, které by (již) neměly zobrazovat výstrahu ohledně nemožnosti provést automatický test vyžadující adaptér zpětné smyčky.
[Data aplikace]\data\candi.bin | Soubor aplikace CANdi. Obsahuje aplikaci CANdi, která je připojena k programu Tech2.
[Data aplikace]\data\eprom.bin | Soubor interní paměti EPROM programu Tech2. Obsahuje obsah interní paměti flash programu Tech2.
[Instalace]\driver | Instalační soubory pro ovladač virtuálního portu COM.
[Instalace]\help\emulator_xx_XX.chm | Soubory nápovědy pro konkrétní jazyk.
[Uživatelská data]\Logs | Obsahuje soubory protokolu. Soubory starší než jeden týden budou automaticky smazány.
[Uživatelská data]\pcmcia | Obsahuje soubory obrazů karty PCMCIA. Obrazně řečeno, každý soubor odpovídá jedné kartě PCMCIA programu Tech2. Tyto soubory můžete ukládat do různých umístění, podle svého přání.


Správa konfigurace

Konfigurační soubory jsou vždy uloženy v podadresáři C:\Users\Public\General Motors\Tech2Win\config a mají příponu *.conf. Pomocí aplikace Tech2Win lze vytvářet nové konfigurační soubory nebo upravovat stávající konfigurační soubory, které nejsou určeny pouze ke čtení. Pro správu ostatních konfiguračních souborů používejte program Průzkumník Windows nebo jiný program pro práci se soubory. Jedná se o následující úkony:

  • odstranění konfiguračních souborů
  • přejmenování konfiguračních souborů
  • změnu atributu pouze ke čtení konfiguračního souboru

Důrazně doporučujeme neustále používat konfigurační soubor default.conf. U tohoto souboru by měl být obvykle nastaven atribut pouze ke čtení, aby se zabránilo jeho neúmyslnému přepsání. Pokud ale potřebujete tento soubor změnit za účelem dosažení určitých specifických požadavků, budete muset dočasně odstranit atribut pouze ke čtení.

Obrázky PCMCIA se nacházejí v podadresáři C:\Users\Public\General Motors\Tech2Win\pcmcia. Každý z těchto souborů odpovídá jedné kartě PCMCIA, kterou již znáte z práce s programem Tech2. Při práci s aplikací Tech2Win můžete používat kolik obrazů chcete. Jednoduše zkopírujte stávající obraz do souboru s novým názvem.

Chcete-li spustit konkrétní konfiguraci přímo z plochy, vytvořte zkratku, kterou konfiguraci spustíte "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Program se musí spouštět z následujícího adresáře: 'C:\Program Files\General Motors\Tech2Win\bin'

Počet konfiguračních souborů nezávisí na počtu používaných obrazů pcmcia. S jedním obrazem PCMCIA můžete používat několik konfiguračních souborů. Dochází tak k věrné simulaci situace v servisu, kde několik mechaniků pracuje s jedním programem Tech2 (a tedy i se stejnou kartou PCMCIA).

Můžete si také nastavit, aby každá konfigurace používala svůj vlastní obraz PCMCIA. Tak budou jednotlivé konfigurace více vzájemně nezávislé. Nicméně nemusí být přijatelná námaha nutná k aktualizování jednotlivých obrazů PCMCIA.

Jestliže se nezměnil obrázek PCMCIA a zkopírujete existující konfiguraci, čímž vytvoříte novou konfiguraci, konfigurátor zobrazí varování. V tomto případě byste měli dvě konfigurace se stejným obrázkem PCMCIA. Pokud toto chcete, stačí stisknout OK. Chcete-li, aby nová konfigurace používala jiný nebo nový obrázek PCMCIA, stiskněte Zrušit. Potom se můžete rozhodnout vytvořit nový obrázek pomocí příkazu Kopírovat paměťovou kartu ...

Dále uvádíme dvě ukázkové metody, které můžete používat ke spravování konfigurací a obrazů PCMCIA.

Jedna konfigurace pro každého uživatele

Můžete uložit konfiguraci pro daného uživatele. Názvem konfigurace může být například uživatelské jméno. Výhodou tohoto přístupu je, že můžete vytvořit nastavení, jako například komunikační rozhraní vozidla (MDI), zobrazení a jazyk, specifická pro určitého uživatele. Nevýhodou je, že pokud bude stejný program používat více uživatelů, budete muset kopírovat soubory PCMCIA. Je samozřejmě, že uživatelské konfigurace mohou využívat hlavní soubor PCMCIA.

Jedna konfigurace na každý program Tech2

Můžete si vytvořit novou konfiguraci pro každý stažený program. Tak budete mít v případě potřeby k dispozici i starší verze programů. V takovém případě je vhodné zvolit jako název konfigurace název tohoto programu a číslo verze.

  • První kroky: Komunikační rozhraní vozidla
  • První kroky: Cesta
  • Pokročilá témata: Konfigurační soubor
  • Instalace: Kroky instalace


Nejčastější dotazy

  • Jak mám zjistit, který port COM mám používat pro aplikaci Tech2Win?
  • Komunikace mezi aplikacemi Tech2Win a TIS2Web
  • Platná licence
  • Co označuje číslo licence?
  • Jaký je rozdíl mezi licencí aplikace Tech2Win a zabezpečeným přístupem?
  • Pokud provedete zabezpečený přístup k výchozímu softwaru, na TIS2Web se zobrazí nespecifikovaná chyba.
  • Aplikace Tech2Win nespouští software Tech2 z jiného místa
  • Jak mohu používat více než jedno rozhraní MDI?
  • Soubor protokolu obsahuje chybu 'CPU32: Too many 0000/FFFF Commands encountered'
  • Není zobrazené žádné okno programu Tech2
  • Systém SPS nefunguje
  • Některé automatické testy nefungují
  • Ukazatel rychlosti kolísá
  • Náhlé zastavení
  • U Software 15.001 se zobrazuje švédština
  • Ztráta komunikace s rozhraním MDI
  • Aplikace Tech2Win nenalezla moje rozhraní MDI
  • Chci okamžitě spustit Tech2Win bez konfigurátoru
  • Kde se nacházejí funkce tisku?
  • Na mém počítači se nachází 'nepoužívaná' složka PCMCIA
  • Zobrazuje se mi zpráva 'nesprávná cesta'.

Jak mám zjistit, který port COM mám používat pro aplikaci Tech2Win?

Pomocí „Správce zařízení“ systému Windows můžete vyhledat „Porty (COM a LPT)“. U některých počítačů jsou ale nainstalovány interní modemy a zařízení bluetooth, které nejsou v této kategorii zobrazeny.
Dalším způsobem je použít malý příkaz dodávaný společně s konfigurátorem. Můžete jej spustit pomocí nabídky Start (složka Tech2Win) klepnutím na možnost 'show com ports'.
Pomocí obou těchto způsobů si zobrazíte porty COM nainstalované ve vašem počítači, které byste NEMĚLI použít.

Komunikace mezi aplikacemi Tech2Win a TIS2Web

Je důležité, aby před zahájením komunikace s aplikací TIS2Web za účelem zabezpečeného přístupu nebo stažení softwaru byla spuštěna aplikace Tech2Win. Aplikace TIS2Web dokáže rozpoznat virtuální port COM pouze, když je spuštěná aplikace Tech2Win.

Platná licence

Stažením programu z aplikace TIS2Web obvykle získáte platnou licenci. Pokud stále nemáte platnou licenci, musíte ji získat navázáním 'Povolit programování (Bezpečnost)' pomocí aplikace TIS2Web (nikoliv TIS2000). Než dostanete licenci přes 'Povolit programování (Bezpečnost)', neprovádějte prosím žádnou jinou komunikaci TIS2Web s Tech2Win jako např. 'Download softwaru (SWDL)'.

Co označuje číslo licence?

Číslo licence v pravé části stavového řádku udává počet celých licenčních dní. Ihned po provedení stažení nebo zabezpečeného přístupu se zobrazí hodnota 30 dní. Po novém spuštění aplikace Tech2Win se ale zobrazí hodnota 29, protože délka licence je pravděpodobně něco jako 29 dní, 23 hodin a 55 minut. Pokud počet licenčních dní poklesne pod 24 hodin, zobrazí se jako doba trvání licence hodnota <1. Pokud platnost licence vyprší, zobrazí se 0.

Jaký je rozdíl mezi licencí aplikace Tech2Win a zabezpečeným přístupem?

Licence Tech2Win vám umožňuje používat aplikaci Tech2Win. Tuto licenci můžete získat buď stažením softwaru nebo pravidelným používáním zabezpečeného přístupu (nejčastěji každých 30 dní). Možnost provést takové stažení pomocí aplikace TIS2Win informuje aplikaci Tech2Win o přítomnosti platného uživatele. Zabezpečený přístup známý z programu Tech2 informuje aplikaci Tech2Win, že jsou povoleny určité činnosti týkající se bezpečnosti, jako například vypnutí airbagu. Licenci i zabezpečený přístup aplikace Tech2Win můžete zajistit pomocí aplikace TIS2Web Security Access. Aplikace Tech2Win zobrazuje v pravé části stavového řádku zbývající dobu trvání licence. Bohužel aplikace Tech2Win nemůže zobrazovat délku trvání zabezpečeného přístupu, protože aplikace Tech2Win pouze spouští program Tech2 a jinak se samotným programem Tech2 nijak nespolupracuje.

Pokud provedete zabezpečený přístup k výchozímu softwaru, na TIS2Web se zobrazí nespecifikovaná chyba.

Aplikace se chová stejně jako Tech2. Výchozí software není schopen vzhledem ke svému stáří získat licenci z TIS2Web. Ve skutečnosti to však není problém, protože demonstrační software nekomunikuje s vozidlem, pro které je zapotřebí licence. Jelikož jsou licence specifické pro konkrétní stáhnutí aplikace TS2Web, stejně byste po stáhnutí softwaru Tech2 potřebovali licenci na konkrétní stáhnutí. 'Licence' na výchozí software vás neopravňuje ke komunikaci vozidla se softwarem severoamerických provozoven a provozoven Opel/Vauxhall.

Aplikace Tech2Win nespouští software Tech2 z jiného místa

Vaše verze aplikace Tech2Win je pravděpodobně omezená na jedno nebo několik stáhnutí aplikace TIS2Web (regionů). Stisknutím možnosti Nápověda / O můžete zjistit, jaká omezení platí pro vaší verzi aplikace Tech2Win. Starší verze aplikace Tech2Win umožnili spustit pouze software Opel/Vauxhall. Další regiony GM budou následovat. Aplikace Tech2Win je každopádně v současnosti schopná spouštět software Tech2 od společnosti General Motors.

Jak mohu používat více než jedno rozhraní MDI?

Pokud chcete přiřazovat specifická rozhraní MDI specifickým uživatelům, potom doporučujeme nastavit vlastní konfiguraci pro každého uživatele. Tyto konfigurace by měly být pojmenovány podle svých příslušných uživatelů. V každé konfiguraci zadejte na kartě 'Komunikační rozhraní vozidla' sériové číslo rozhraní MDI specifického pro daného uživatele. Jakmile uživatel spustí svoji konfiguraci, aplikace Tech2Win se pokusí kontaktovat příslušné rozhraní MDI. Pokud se toto rozhraní MDI nepodaří nalézt, zobrazí se okno pro výběr obsahující všechna rozhraní MDI nalezená aplikací Tech2Win.

Pokud máte několik rozhraní MDI určených pro obecné používání, doporučujeme používat konfigurace, ve kterých je sériové číslo komunikačního rozhraní vozidla na kartě 'Komunikační rozhraní vozidla' nevyplněné. Tak se uživateli pokaždé zobrazí okno s výběrem všech dostupných rozhraní MDI.

Soubor protokolu obsahuje chybu 'CPU32: Too many 0000/FFFF Commands encountered'

Soubor 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' nebo aktuální soubor pcmcia je poškozený. Znovu nainstalujte aplikaci Tech2Win a stáhněte si nový program Tech2.

Není zobrazené žádné okno programu Tech2

Pokud nevidíte okno programu Tech2, nachází se pravděpodobně v oblasti mimo vaši obrazovku. S touto situací se můžete setkat používáte-li více obrazovek nebo po úpravě rozlišení obrazovky. Při spuštění konfigurace stiskněte klávesu Shift na klávesnici. Rozlišení okna se nastaví na 640x480 a okno programu Tech2 se zobrazí v levém horním rohu obrazovky. Stejného efektu dosáhnete také, pokud vymažete soubor C:\Users\Public\General Motors\Tech2Win\emulator.disp.

Setkali jsme se s případy, kdy nedošlo k překreslení okna programu Tech2 na obrazovce po uzavření oken všech ostatních aplikací. Ve všech případech, se kterými jsme se dosud setkali, bylo možné pomocí kombinace kláves Alt-Tab pro přepínání mezi aplikacemi systému Windows přenést obrazovku programu Tech2 do popředí. Stisknutí tlačítka aplikace Tech2Win na panelu úloh ve spodní části obrazovky počítače někdy nefunguje. V současnosti se tímto problémem zabýváme a další verze aplikace Tech2Win již bude obsahovat opravu tohoto problému.

Systém SPS nefunguje

Ano, víme o tom. Nechystáme to nijak měnit. Nepoužívejte aplikaci Tech2Win místo programu Tech2 k provádění SPS. Používejte prosím rozhraní MDI přímo s programováním SPS přes TIS.

Některé automatické testy nefungují

Automatické testy programu Tech2 jsou určeny k testování jednotlivých částí hardwaru Tech2. Některé tyto testy vyžadují použití adaptéru zpětné smyčky. Tyto testy nebudou fungovat v aplikaci Tech2Win, protože funkce adaptéru zpětné smyčky zde není implementovaná (a tato implementace se ani nepřipravuje). Proto jednoduše nespouštějte tyto zbytečné testy v aplikaci Tech2Win. Pokud je spustíte, můžete získat chybné výsledky nebo se aplikace Tech2Win zablokuje podobně jako program Tech2 bez adaptéru zpětné smyčky. V takovém případě resetujte aplikaci Tech2Win stisknutím kláves Ctrl-R.

Ukazatel rychlosti kolísá

Ukazatel rychlosti v levé spodní části stavového řádku udává, kolik 'příkazů programu Tech2' lze spustit předtím, než bude muset aplikace Tech2Win znovu 'spát'. Tato metoda se používá k zajištění toho, aby čas aplikace Tech2Win odpovídal skutečnému času: rychlejší počítače spí více než pomalejší počítače. Pokud ukazatel rychlosti kolísá, znamená to, že nějaké jiné aplikace využívají výkon počítače nebo kolísá výkon procesoru počítače. Vysoká míra kolísání má nepříznivý vliv na komunikaci s vozidlem a na komunikaci v rámci aplikace TIS2Web. Zajistěte, aby nebyly spuštěné žádné další aplikace.

Většina přenosných počítačů může automaticky snížit výkon procesoru, aby se prodloužila životnost jejich baterie. To může také způsobovat kolísání rychlosti detekované aplikací Tech2Win. V takovém případě nenechávejte běžet přenosný počítač na baterii, ale připojte jej k externímu zdroji napájení. Můžete také změnit nastavení výkonu tak, aby operační systém neomezoval výkon procesoru.

Náhlé zastavení

Pokud v souboru protokolu nenaleznete žádný důvod, proč došlo k ukončení programu Tech2Win, mohlo dojít k aktivaci mechanizmů vnitřního zabezpečení. Neměňte následující soubory: emulator.sec, emulator.lic, emulator.card. Pokud aplikace Tech2Win zjistí porušení zabezpečení, budete muset pravděpodobně provést opětovnou instalaci.

U Software 15.001 se zobrazuje švédština

Úvodní software dodávaný s aplikací Tech2Win je demonstrační software přítomný na každé nové kartě PCMCIA. Aplikace TIS2Web udává, že se jedná o švédštinu, protože aplikace TIS2Web zobrazuje pouze poslední jazyk ze seznamu čtyř jazyků podporovaných tímto demonstračním softwarem (angličtina, francouzština, němčina, švédština). Přepište tento demonstrační software nejnovější verzí diagnostického softwaru pomocí režimu aktualizace 'Vlastní', a nikoli 'Standardní'.

Ztráta komunikace s rozhraním MDI

Ztráta komunikace s rozhraním MDI může mít několik důvodů.

  • Špatné kabelové propojení (jak Ethernet, tak USB).
  • Slabé bezdrátové připojení.
  • Počítač přešel do úsporného režimu.

Aplikace Tech2Win nenalezla moje rozhraní MDI

Zkontrolujte následující body:

    1. Je rozhraní MDI aktivní?
    2. Funguje program MDI Manager?
    3. Používá rozhraní MDI jiná aplikace jako např. SPS?
Program MDI Manager můžete spustit pomocí ikony na ploše nebo pomocí nabídky 'Start/Všechny programy/General Motors/GM MDI Software'.: Pokud nefunguje bod 2, zavolejte asistenční středisko.

Chci okamžitě spustit Tech2Win bez konfigurátoru

Spusťte soubor "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". V následujícím pracovním adresáři: 'C:\Program Files\General Motors\Tech2Win\bin' Stále můžete použít konfigurátor k provádění změn v konfiguraci.

Kde se nacházejí funkce tisku?

Tech2Win neumožňuje přímý tisk. Místo toho vytvoří dočasné soubory a vyvolá programy, které umí se soubory s těmito příponami pracovat. Tyto programy lze použit k tisku. Přitom lze upravit vzhled výtisku.

Print Report | Print Report

Chcete-li tisknout aktuální obrazovku aplikace Tech2Win, použijte v nabídce položku Soubor / Vytisknout obrazovku nebo na klávesnici tlačítko, na kterém je zobrazena tiskárna. Pokud potřebujete vytisknout několik obrazovek aplikace Tech2Win, můžete použít v nabídce položku Možnosti / Automatické snímky obrazovky, která vytvoří soubory PNG pro jednotlivé obrazovky Tech2Win. Tyto soubory PNG jsou začleněny do souboru protokolu.

Můžete rovněž tisknout obsah zobrazených dat tisku (aktivuje se pomocí položky nabídky Okna / Zobrazení dat aplikace Tech2Win). Pomocí tlačítka Spustit HTML/Tisk spouštíte a ukončujete sběr dat. Po zastavení sběru dat se spustí příslušný soubor pro dané HTML (zpravidla soubor ve formátu Internet Explorer), ve kterém je k dispozici celá řada funkcí umožňujících tisk dat.

Data Display | Data Display

Na mém počítači se nachází 'nepoužívaná' složka PCMCIA

U starších verzí Tech2Win byly soubory PCMCIA vždy duplicitně uloženy v samostatném adresáři. Tento adresář často byl C:\PCMCIA. Nyní se tento adresář již nepoužívá, protože při rychlém stáhnutí z TIS2Web by druhé úložiště pro stažené soubory bylo zbytečné. Tento adresář můžete klidně vymazat.

Zobrazuje se mi zpráva 'nesprávná cesta'.

Zdá se, že název souboru obsahuje neplatné znaky jako je například symbol procent (%). Pokud se tento problém vyskytne hned po nainstalování, doporučujeme jednoduše systém odinstalovat a potom znovu nainstalovat. Většinou se tento problém vyřeší.

Během normální instalace se proměnná prostředí 'Tech2WinUserData' nastaví na 'PUBLIC' (v případě verzí Windows >= Vista) a na 'ALLUSERSPROFILE\Documents' (u verzí Windows před systémem Vista). V některých výjimečných případech se proměnná během instalace nenastaví, ale při druhém pokusu je vše v pořádku. Můžete rovněž nastavit proměnnou prostředí manuálně. Pokud nevíte, jak nastavit proměnnou prostředí, požádejte o pomoc svého správce.


Položky registru

Instalační program vytvoří následující položky registru. Neupravujte tyto položky ručně. Při práci s položkami registru pamatujte na standardní zásady práce se systémem Windows.

klíč registru | název | typ | význam
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Číslo interní verze
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Jazyk | REG_SZ | instalovaný jazyk
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Cesta adresářů kopie PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Kořen | REG_SZ | instalační cesta
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Možnost Odinstalovat | REG_DWORD | Nastavení pro odinstalování
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Verze konfiguračního souboru
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Verze ovladače virtuálního portu COM
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Název displeje | REG_SZ | Název softwaru v seznamu Přidat/Odebrat program
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | Odinstalační řetězec | REG_SZ | Cesta k odinstalačnímu programu


Opětovná instalace

Během odinstalování se vymaže celý adresář s instalací aplikace Tech2Win až na následující výjimky.

  1. Podadresář config s konfiguracemi, které se nemažou.
  2. Nemaže se podadresář pcmcia, který zpravidla obsahuje obrázky PCMCIA.
  3. Nemaže se podadresář ATA, který může obsahovat informace 'debug'.
Konfigurační soubory již nemusí být kompatibilní: neexistuje žádná záruka, že konfigurační soubory ze staré verze aplikace Tech2Win budou čitelné i pro novou verzi aplikace Tech2Win. Obrazy PCMCIA již z principu nemohou přestat být kompatibilní.

Opětovná instalace nijak nezasáhne sekundární adresář PCMCIA.

Některá prostředí mohou nabízet automatickou instalaci nové verze aplikace Tech2Win. Jelikož jsou informace o instalaci uloženy v registru, použijí se při opětovné instalaci tato nastavení jako výchozí.

Opětovnou instalaci aplikace Tech2Win můžete vynutit pomocí skriptu enable reinstallation. Tento skript se nainstaluje společně s aplikací Tech2Win. Tento skript v podstatě nastaví hodnotu klíče CurrentVersion, nacházející se v registru na adrese HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win, na hodnotu „1.000“.