Потребителско ръководство на Tech2Win

Добре дошли в потребителското ръководство на Tech2Win.

Copyright (C) 2010..2016 SPO Engineering General Motors Всички права запазени.

  • Въведение:
  • Лиценз:
  • Инсталация:Описание на инсталационната процедура на Tech2Win.
    • Стъпки за инсталация
    • Интерфейс за комуникация с автомобил
  • Първи стъпки
    • Избиране на конфигурация
      • Клавиатура
      • Боравене с прозорците
    • Нови конфигурации
    • Модифициране на конфигурации
      • Език
      • Пътека
      • Дисплей
      • Записване на конфигурация
    • Вземете валиден лиценз за Tech2Win
  • Работа с Tech2Win: Детайли за ежедневната работа
    • Меню
    • Сваляне на PCMCIA имидж
    • Сигурност
    • Виж доклади
    • Работа с PCMCIA имиджи
    • Лента за състояние
  • Разширени теми: Информация, която не е необходима за нормалната работа на Tech2Win. Често върши работа само на хората с административни задачи.
    • Преинсталация
    • Деинсталация
    • Формат на конфигурационния файл
    • Лог-файл
    • Съобщения за грешки и кодове на грешки.
    • ATA карта
    • Регистрационни записи
    • Файлове
    • Работа с конфигурации
  • ЧЗВ


Въведение

Tech2Win е приложение за Windows, което може да емулира функционалността на Tech2. Общо взето, софтуерът Tech2 се изпълнява на компютър PC. За да стартирате тази програма, вашият компютър трябва да отговаря на следните технически изисквания:

  • Към компютъра трябва да има инсталиран и свързан интерфейс за комуникация с автомобил. Списъкът с допустимите интерфейси може да варира в различните региони. В повечето случаи може да се използва Множественият диагностичен интерфейс (Multiple Diagnostic Interface, MDI) на GM.
  • Приложението Tech2Win изисква 150 MB пространство на твърдия диск при инсталацията. Необходими са още 32 MB за всяка PCMCIA флаш карта, която желаете да управлявате.
  • Преди изпълнението на приложението Tech2Win, трябва да имате минимум 100 MB свободна физическа RAM памет. Задължително е вашия компютър да има достатъчно памет да събере цялото приложение в RAM през цялото време на изпълнение на приложението.
  • Компютърът ви трябва да има изчислителна мощност, еквивалентна на Pentium 1.2GHz (едноядрен). Силно препоръчваме да не използвате едновременно и други приложения.
  • Не е необходима клавиатура. С Tech2Win може да се работи и чрез сензорен екран. За управление на конфигурации обаче силно препоръчваме да използвате клавиатура, тъй като ще се налага да въвеждате имена на файлове.
  • Вашият цветен дисплей трябва да има минимална разделителна способност от 800 х 600 и да поддържа минимум 256 цвята. Ако не се използва цифрова клавиатура, може да е приемлива и разделителна способност от 640 х 480.

Когато използвате Tech2Win (лаптоп вместо Tech2), моля, уверете се, че батерията на лаптопа има достатъчен заряд. Обикновено лаптопът ви няма да се захранва от акумулатора на автомобила, както при Tech2.

  • Инсталация
  • Първи стъпки


Лиценз

General Motors - Лицензионно споразумение за Tech2Win

Внимателно прочетете следните положения и условия, преди да използвате програмата. Ако не приемате или не разбирате положенията или условията, моля, свържете се с местния представител за поддръжка след продажби. Правото да използвате този софтуер е лицензирано от General Motors само при условие, че потребителят се съгласи с този лиценз, като приеме настоящите положения и условия при инсталацията на Tech2Win.
General Motors дава правото за използване на софтуера Tech2Win и включената в него информация заедно с TIS2Web или GlobalTIS или TIS2000 ексклузивно за потребители на оторизираната ремонтна мрежа на General Motors, както е посочено в приложимото Споразумение за оторизиран извършител на ремонтни дейности с националните компании за продажби на General Motors.
Tech2Win лицензът е ефективен, докато Споразумението за оторизиран извършител на ремонтни дейности е в сила и лицензът за TIS2Web, GlobalTIS и TIS2000 важи. Лицензът за Tech2Win ще се прекрати в синхрон с лиценза за TIS2Web и GlobalTIS непосредствено след изтичане на Договора за оторизирани ремонти.

Независимите извършители на ремонтни дейности, дефинирани в чл. 4 ал. 2 от Регламента за групово освобождаване на Европейския съюз (European Union Block Exemption Regulation, BER) 1400/2002, могат да закупят Tech2Win лиценз като част от предлаганите абонаменти в портала GM Europe Info Tech Portal на General Motors Europe.

Tech2Win лицензът не разбира комуникационния интерфейс на автомобила или PC хардуера.

Софтуерът Tech2Win не бива да се разпространява, продава или предоставя онлайн на никоя трета страна извън оторизираните ремонтни служби (както са описани в съответния анекс към споразумението за оторизиран извършител на ремонтни дейности) без писменото съгласие на съответните национални компании за продажби на General Motors. Това важи както за актуални, така и за неактуални данни (като DVD дискове с изтекъл срок за употреба).

Националните компании за продажби на General Motors имат право незабавно да прекратят достъп и да уведомят за незабавно прекратяване на споразумението за оторизиран извършител на ремонтни дейности в случай на неупълномощено или злоумишлено ползване. В такъв случай, правото да се търси възстановяване на оставащи кредитни баланси и/или основни годишни такси се губи.

Предоставената информация служи за извършването на сервизни и ремонтни дейности по експертен начин върху немодифицирани автомобили на General Motors. Като предварително условие за извършването на горепосочените дейности са необходими пълно обучение за автомобилен техник и редовно допълнително обучение. Когато в предоставената информация е указано използването на специални инструменти, използването на тези специални инструменти е задължително за професионалното изпълнение на всички ремонти

Информацията, публикувана на интернет страницата на General Motors (текст и изображения, музика, графика, анимация, видео и т.н.) и подреждането й в Global TIS са защитени от авторското право. Репродукцията, разпространението, свързването и/или предаването, или друг начин на използване не е разрешено и може да стане само с предварителното писмено съгласие на General Motors.

  • Инсталация: Стъпки за инсталация
  • Първи стъпки


Installation

Инсталация

Инсталацията на Tech2Win изисква локални администраторски права на компютъра. Инсталирането не може да се извърши без права на администратор. В такива случаи най-добре поискайте помощ от локалния администратор на компютъра.

За да използвате успешно Tech2Win, трябва да извършите следните две неща:

  • Инсталация на самия Tech2Win.
  • Инсталиране на интерфейс за комуникация с автомобил.
  • Инсталация: Стъпки за инсталация
  • Първи стъпки


Стъпки за инсталация

Самата инсталация отнема няколко минути и изисква потребителят да въведе следното:

  1. Лицензионно споразумение
  2. Въвеждане на инсталационна директория

Език

По подразбиране потребителският интерфейс на Tech2Win ще се показва на езика на операционната система. Налице е обща поддръжка на следните езици. Ако езикът ви не се поддържа, инсталационната програма стартира на английски, тъй като той е езикът й по подразбиране.

  • bg_BG (BG)Bulgarian
  • cs_CZ (CS)Czech
  • da_DK (DA)Danish
  • de_DE (DE)German
  • en_GB (EN)Английски (британски и американски)*
  • el_GR (EL)Greek
  • es_ES (ES)Испански
  • fi_FI (FI)Finnish
  • fr_FR (FR)Френски
  • hr_HR (HR)Croatian
  • hu_HU (HU)Hungarian
  • it_IT (IT)Italian
  • ja_JP (JA)Japanese
  • ko_KR (KO)Korean
  • nl_NL (NL)Dutch
  • no_NO (NO)Norwegian
  • pl_PL (PL)Polish
  • pt_BR (PB)Португалски (Бразилия)
  • pt_PT (PT)Португалски (Португалия)
  • ro_RO (RO)Romanian
  • ru_RU (RU)Russian
  • sl_SI (SL)Slovenian
  • sv_SE (SV)Swedish
  • th_TH (TH)Thai
  • tr_TR (TR)Turkish
  • zh_CN (ZS)Китайски (опростен)
  • zh_TW (ZH)Китайски (традиционен)

* Езикът на Tech2Win е британски английски. Софтуерът Tech2 и инсталационната ви програма обаче може да са на американски английски, в зависимост от източника на софтуера.

Лицензионно споразумение

Трябва да приемете Лицензионното споразумение.

Въвеждане на инсталационна директория

Можете да изберете всяка директория като локация, в която да се инсталира Tech2Win. Инсталационната директория по подразбиране е или <вашата програмна директория>General Motors\Tech2Win, или, в случай на преинсталиране - локацията, посочена при предишната инсталация.

Накрая потвърдете инсталацията.

Драйвер за виртуален COM порт

Драйверът за виртуален COM порт ще се инсталира на компютъра ви само веднъж и ще си остане, докато версията на драйвера бъде ъпгрейдната (случва се рядко) или Tech2Win бъде деинсталирана от компютъра.
Ако драйверът бъде инсталиран, за кратко ще видите прозорец на DOS. Той ще се затвори автоматично и не изисква никакви действия от вас. Файловете на драйвера се поставят допълнително в под-папка 'драйвер' в инсталационната директория на Tech2Win.
Възможно е, но не се препоръчва, ръчно да инсталирате или деинсталирате драйверите за виртуалния COM порт. Използвайте една от следните команди от командния интерпретатор CMD:

  • повикайте 'vbsetup7' за инсталиране на драйвера
  • повикайте 'vbsetup7 /u' за деинсталиране на драйвера
  • Първи стъпки


Интерфейс за комуникация с автомобил

Вашето устройство за комуникация с автомобил трябва да бъде инсталирано отделно. Моля, направете справка със съответното ръководство за инсталиране, доставено с интерфейса за комуникация с автомобил.

  • Първи стъпки: Интерфейс за комуникация с автомобил
  • Разширени теми: Конфигурационен файл
  • Инсталация: Стъпки за инсталация
  • ЧЗВ: Как мога да използвам повече от един MDI?
  • ЧЗВ: Tech2Win не откри моя MDI


Първи стъпки

Тези първи стъпки ви показват как да използвате Tech2Win. За тях изхождаме от факта, че сте запознати с Tech2. По време на тези първи стъпки не е необходима комуникация с автомобила.

За бърз старт Quick Start изпълнете следните действия:

  1. Пуснете софтуера Tech2Win посредством бързата команда QuickStart от работния плот на екрана.
  2. Вземете валиден лиценз, като свалите новия софтуер Tech2 от TIS2Web.

За да използвате избираема конфигурация:

  1. Стартирайте конфигуратора посредство бързата команда на Tech2Win от работния плот. След инсталация трябва да има конфигурация по подразбиране (default).
  2. За да направите нова конфигурация, по-добре копирайте конфигурацията default.
  3. Променете съществуващата конфигурация според изискванията си.
  4. Вземете валиден лиценз.

Не стартирайте Tech2Win в режим на съвместимост. В такъв случай във файла Log ще се появи предупреждение. Tech2Win използва само функции на Windows, които съществуват от XP насам и няма да работи върху по-ранни версии на Windows.

  • Първи стъпки: Нови конфигурации
  • Първи стъпки: Модифициране на конфигурации
  • Първи стъпки: Интерфейс за комуникация с автомобил
  • Работа с Tech2Win: Меню
  • Работа с Tech2Win: Сигурност
  • Работа с Tech2Win: Лента за състояние
  • Разширени теми: Конфигурационен файл


Избиране на конфигурация

Първия път, когато стартирате приложението Tech2Win, се появява следният екран. Имате опцията да стартирате Tech2Win директно с конфигурация по подразбиране. Тази конфигурация по подразбиране работи без комуникация с автомобила.

Start First Time

Показва се поле за съобщения с информация за лиценза, но можете да го пренебрегнете и да стартирате конфигурацията по подразбиране.

Когато работите със сензорен екран, може да е удобно да стартирате програмата за PC клавиатура, за да можете да въвеждате букви чрез това приложение, което симулира клавиатура.


Клавиатура

Клавишите на компютъра, както и бутоните, ако има такива, се осъответстват към познатите от Tech2 клавиши. В Tech2Win има някои допълнителни клавиши, които не са били налични в оригиналния Tech2. Цифровата клавиатура на компютъра не винаги работи. Ако има някакви проблеми, моля, проверете дали стандартната клавиатурна подредба на компютъра не е променена. Много вероятно в този случай да е повреден клавишът SHIFT.

PC клавиатура | Бутон | Функционалност
Функционален клавиш F1 | n.a. | Помощ за Tech2Win
Функционални клавиши F5 .. F8 | Използвайте зоната на дисплея на Tech2Win, заета от софтуерните клавиши | Четирите меки бутона на Tech2
Курсорни клавиши нагоре, надолу, наляво, надясно |  | Клавиши нагоре, надолу, наляво, надясно на Tech2. Само тези клавиши имат автоматична функция за повтаряне.
Клавиш 0 .. 9 | F0 • • • F9 | Клавиши F0 .. F9 на Tech2
Клавиш Backspace | Exit | Клавиш за изход на Tech2
Enter / Return | Enter | Клавиш Enter на Tech2
Y | Yes | Клавиш Yes (Да) на Tech2
N | No | Клавиш No (Не) на Tech2
Q | ? | Клавиш ? на Tech2
S | Shift | Клавиш Shift на Tech2; Индикаторът Shift на лентата за състоянието или индикаторът над бутона Shift показва състоянието.
ctrl-P | PWR | Клавиш Power на Tech2; С този клавиш можете само да изключите приложението Tech2Win.
ctrl-R | не е приложимо | Рестартира Tech2Win. Подобно на цикъла Power Off/On (Изключване/включване на захранването) на Tech2. Независимо от това, прикаченият интерфейс за комуникация с автомобил (MDI) не се нулира. Файлове като PCMCIA изображенията не се зареждат отново.
Начало | Home | Бутон за начало. Поддържа се само от някои приложения.
има достъп само чрез опцията Файл от менюто. | Print Screen | Отпечатва моментна снимка на екрана на Tech2, като създава временен ВМР-файл и извиква асоциираното с ВМР-файловете приложение. Използвайте това приложение, за да промените размера или завъртите изображението, преди да го отпечатате.
има достъп само чрез опцията Файл от менюто. | Save Screen | Запазва екранна снимка на екрана на Tech2 като BMP или PNG файл.
има достъп само чрез опцията Файл от менюто. | View Report | Показва всички доклади за активната PCMCIA флаш карта, за да може да ги види потребителя.


Боравене с прозорците

Можете да преоразмерявате прозорците си чрез стандартните механизми на Windows, като влачите граничните линии на главния прозорец. Освен това, елементът от менюто Опции/Резолюция поддържа няколко предварително зададени размера. При промяна на размера на основния прозорец чрез елемент от менюто, прозорецът с цифровата клавиатура автоматично ще остане закачен.

Видът на прозорците се модифицира, като променяте конфигурацията в раздела Дисплей.


Нови конфигурации

Кликнете бутона Създай нов, за да създадете нова конфигурация. Ще се появи диалогово меню, в което ще трябва да посочите съществуващ конфигурационен файл за база. Обикновено е избрана конфигурацията по подразбиране (default). След като въведете името на новия конфигурационен файл, натиснете бутона Копирай.

Ако работите със сензорен екран, може да предпочетете да активирате симулирана PC клавиатура чрез бутона PC-клавиатура.

Бутонът Отказ ви позволява да отмените процеса по създаване.

Новата конфигурация ще използва същия PCMCIA-файл като съществуващата изходна конфигурация. Ако искате да промените това, трябва да промените конфигурацията така, че да се използва различен PCMCIA -файл. В повечето случаи просто ще копирате съществуващия PCMCIA-файл в нов и ще използвате новия. Може да предпочитате новата ви конфигурация да ползва същия PCMCIA-файл, като изходната. В този случай, когато натиснете бутона Запази, ще се появи предупредителен екран.

  • Модифициране на конфигурации


Модифициране на конфигурации

Конфигурациите, показвани в синьо, са маркирани 'само за четене' и не могат да се модифицират. Тези конфигурации могат само да се разглеждат. Естествено, можете да използвате метода 'модификация', само за да разгледате съдържанието им, но опцията Запази няма да бъде достъпна.

Конфигурацията се модифицира, като изберете индивидуалната настройка в четирите раздела Език, Интерфейс за комуникация с автомобил, Пътека, Дисплей. Трябва или да изберете желания раздел, или просто да щракнете върху бутона Нататък за следващия. След като направите нужните модификации, натиснете бутона Запази, за да запишете своята конфигурация.

Когато е необходимо въвеждане от клавиатура, можете да стартирате PC приложение, което симулира клавиатура. Това е особено удобно при лаптопи със сензорен екран, които не разполагат с клавиатура.


Език

Разделът Език ви позволява да изберете езика, на който ще работи Tech2Win. Този избор не се отразява върху езика в софтуера Tech2 в PCMCIA имиджа. Когато сваляте софтуера Tech2 от TIS, пак ще трябва да изберете съответния език.

В някои региони не всички езици са достъпни. В такъв случай ще се използва английски. Проверете дали е налице подобен език (PT Португалски-Португалия, а не PB Португалски-Бразилия).


Пътека

Разделът Пътека ви позволява да зададете пътеките на PCMCIA имиджите, както и пътеката към локалната ви софтуерна клавиатура. Освен това с бутона Копирай карта с памет можете да копирате PCMCIA имиджи. Ако току-що сте създали нова конфигурация, може да ползвате този бутон, за да избегнете няколко конфигурации, използващи едно и също PCMICA-изображение.

Memory Card Options

Копирай карта с памет ...

Този бутон ви позволява да копирате PCMCIA имидж в друг файл. Функционалността му е подобна на закупуването на нова PCMCIA карта за Tech2. Функцията за копиране работи само за файлове в директорията C:\Users\Public\General Motors\Tech2Win\pcmcia.

Слот 0 : Локация на имидж на карта с памет

Оттук можете да посочите файла, който съдържа PCMCIA имиджа за слот 0. Обикновено такъв файл трябва да се намира в C:\Users\Public\General Motors\Tech2Win\pcmcia, възможни са обаче и други места.

Слот 1 : Карта с памет или ATA

Като Tech2, Tech2Win поддържа и две PCMCIA карти (или имиджи). Все пак вторият PCMCIA имидж в рамките на конфигурацията обикновено не върши много работа. При втора конфигурация най-добре е да се използва втори софтуер.

Като при Tech2, ATA картата се използва за отстраняване на бъгове. Моля, активирайте ATA картата, само ако получите такава инструкция от отдела за техническа поддръжка. Те ще ви предоставят допълнителна информация.

Локация на софтуерна клавиатура на PC

Стойността на този файл по подразбиране се извежда от регистъра на Windows и би трябвало да сочи към приложение, способно да симулира PC клавиатура чрез мишката. Ако имате специално приложение с такава функционалност за лаптопа, който използвате, можете да го посочите оттук.


Интерфейс за комуникация с автомобил

  • COM-порт за Tech2-RS232-емулация
  • Сериен номер на MDI за използване
  • Протокол

COM-порт за Tech2-RS232-емулация

Моля, изберете свободен COM порт, който може да се използва за емулация на Tech2. Конфигураторът се опитва да открие кои серийни портове се използват вече и ги показва за ваше удобство.

Ако изберете съществуващ COM порт, Tech2Win ще се прикрепи към него. Можете да използвате този COM порт, за да изтеглите софтуера Tech2 чрез безмодемен кабел от друг компютър, който използва приложението TIS. Моля, имайте предвид, че реален COM порт може да не работи надеждно с 115.200 бода поради ограничения в Windows.

Ако бъде избран несъществуващ COM порт, Tech2Win автоматично ще създаде виртуален порт. Този виртуален порт може да се използва от приложението TIS, работещо на същия компютър, за комуникация с Tech2Win. При използване на виртуален порт няма ограничение за скоростта в бодове.

Ако изберете 'търсене' като COM порт, Tech2Win ще създаде виртуален COM порт на първия свободен номер на порт в диапазона от 9 до 1.

Сериен номер на MDI за използване

Въведете серийния номер на MDI. Номерът е отпечатан на задната страна на MDI. Използвайте номера след тирето.

Ако не въведете сериен номер, Tech2Win автоматично ще покаже списък с откритите MDI интерфейси в мрежата, за да позволи на потребителя да избере MDI. Този прозорец за избор се показва и ако указаният MDI не бъде открит.

Протокол

'ISO22900-2 / PDU-API' се избира, а J2534-2 е винаги в сиво. В бъдеще Tech2Win вероятно ще поддържа и протокола J2534.

  • Разширени теми: Конфигурационен файл
  • ЧЗВ: Как да определя кой COM порт да използвам за Tech2Win?
  • ЧЗВ: Комуникация между Tech2Win и TIS2Web
  • ЧЗВ: Как мога да използвам повече от един MDI?
  • ЧЗВ: Tech2Win не откри моя MDI


Дисплей

Разделът Дисплей се използва предимно за промяна на настройките на дисплея на Tech2Win:

  • Клавиатура
  • Цветове
  • Звук
Display and Key Options

Клавиатура

Оттук можете да изберете дали да се показва виртуалната клавиатура. Виртуалната клавиатура се появява или отляво, или отдясно на екрана на Tech2Win. Можете да изберете фоновия цвят от стандартен диалогов прозорец за цветове.

Цветове

Тук можете да изберете поотделно фоновия цвят и цвета на предния план на екрана на Tech2. Това са двете най-често използвани цветови комбинации:

Screen with background 0000FF, foreground FFFFFF | Бял фон на виртуална клавиатура; Син фон; Бял преден план
Screen with background 000000, foreground C0C0C0 | Син фон на цифровата клавиатура; Черен фон; Светлосив преден план

Звук

Тук можете да изберете да изключите звука. При всеки звук на програмата Tech2 ще се използва високоговорителя на компютъра.


Записване на конфигурацията

Активната конфигурация можете да запишете, като натиснете бутона Запази <конфигурация> в долния ляв ъгъл. Бутонът няма да го има, ако разглеждате конфигурация 'само за четене'.


Валиден лиценз чрез TIS2Web

В повечето случаи изтегляне на софтуера Tech2 от Tech2Win ви осигурява и валиден лиценз. В допълнение, можете да получите такъв, ако извършите 'Достъп до сигурността (Сигурност)' сигурен достъп чрез TIS2Web (но не чрез TIS2000). Предварително условие за това е избирането на виртуален COM порт в Конфигуратора под Интерфейс за комуникация с автомобил.

При успешен сигурен достъп ще видите иконка на отворен катинар в дясната част на лентата на състоянието. В скобите е изписан броят дни, за които е валиден лиценза. Когато отново стартирате Tech2Win, индикаторът за защита не се показва вече, тъй като не се извършва комуникация с автомобил. При първото свързване с автомобил лицензът ще бъде проверен и индикаторът ще се промени на отключен или заключен катинар.

  • Работа с Tech2Win:Сигурност
  • ЧЗВ:Как да определя кой COM порт да използвам за Tech2Win?
  • ЧЗВ:Комуникация между Tech2Win и TIS2Web
  • ЧЗВ:Валиден лиценз
  • ЧЗВ:Каква е разликата между лиценз за Tech2Win и Защитен достъп?


Работа с Tech2Win

Следните теми се използват от повечето техници при работа с Tech2Win:

  • Меню: Оформлението на екрана и отделните елементи на менютата.
  • Изтегляне на PCMCIA изображение: Актуализирането на диагностичния софтуер за Tech2Win е много подобно на метода, използван при Tech2.
  • Сигурност: Мерки за сигурност пречат на Tech2Win да извършва комуникация с автомобил в неоторизирана среда.
  • Виж доклади: Клавиатурата на Tech2 е усъвършенствана допълнително в Tech2Win. Бутонът 'Виж доклади' е най-добрият пример.
  • Работа с PCMCIA имиджи: Както може да има няколко PCMCIA карти за Tech2, така може да има и няколко PCMCIA имиджа за ползване в Tech2Win.
  • Лента за състояние: Лентата за състояние уведомява потребителя за индивидуалните части в лентата за състояние.
    • Разширени теми
    • ЧЗВ


Меню

В менюто на приложението Tech2Win има следните елементи:

  • Файл
  • Опции
  • Прозорци
  • Помощ

Файл

Менюто Файл осигурява следните възможности.

  • Запиши екрана на T2 (320x240) се използва за записване в компютъра на реалния екран на T2 като черно-бяло изображение в размер 320x240 пиксела. Можете да изберете къде и в какъв файлов формат (BMP, GIF, JPG, PNG) да запазите изображението.
  • Печат на екрана създава инвертирано черно-бяло растерно изображение (BMP) на екрана на Tech2 и извиква програмата, асоциирана с BMP файлове. След това можете да използвате тази програма, за да отпечатате изображението.
  • Виж файлове с доклади осигурява възможност за преглед (и печат) на файлове с отчети без да се използва TIS2Web.
  • Изход изключва Tech2Win.

Опции

Опции предоставя следните възможности за избор:

  • Резолюция може да се използва за избор на един от трите стандартни размери на екрана.
  • ROM-Write from 0x00003ED76 се използва за отстраняване на грешки в програмата.
  • Автоматични екранни снимки запазва всеки различен екран на Tech2 в директорията за регистрационни файлове.
  • Забранете CANdi и рестартирайте симулира липса на CANdi между Tech2 и автомобила. Това е необходимо за редките случаи, когато CANdi прекъсва нестандартни линии за комуникация с автомобил.

Прозорци

Менюто Прозорци ви предоставя възможността да активирате селекциите Дисплей за данни на Tech2Win и Дисплей на DTC на Tech2Win. Всички други селекции са посивени в текущата версия на Tech2Win.

Ако софтуерът Tech2 поддържа Дисплей за данни на Tech2Win, можете да разрешите този запис в менюто. След като отворите Дисплея за данни, Tech2Win ще показва допълнителен прозорец с Дисплей за данни, успоредно на Дисплея за данни на Tech2. Докато екранът на Tech2 показва дисплея за данни, записът в менюто не може да се разреши. В този случай трябва да излезете от дисплея за данни, да разрешите записа и да рестартирате дисплея.

Подобни ограничения за Дисплей за данни на Tech2Win важат и за Дисплей на DTC на Tech2Win. Ако софтуерът Tech2 поддържа Дисплей на DTC на Tech2Win, можете да разрешите този запис в менюто. Ще се появи допълнителен дисплей за DTC успоредно с дисплея DTC на Tech2. Докато екранът на Tech2 показва дисплея за DTC, записът в менюто не може да се разреши. В този случай трябва да излезете от дисплея за DTC, да разрешите записа и да рестартирате дисплея.

Помощ

Има следните възможности за избор:

  • Помощни теми... извиква помощните файлове на Tech2Win.
  • Параметър на команден ред показва параметрите на командния ред, използвани за Tech2Win.
  • За показва номера на текущата версия и ограниченията на Tech2Win за изтегляне на TIS2Web.


Сваляне

Първо, стартирайте Tech2Win и го оставете на главния екран. Стартирайте TIS2Web или GlobalTIS и пуснете изтегляне през COM порта, указан в раздел Интерфейс за комуникация с автомобил.

Използването на вградените COM-портове позволява да сваляте софтуер Tech2 от различен компютър, на който е стартиран TIS. Задължително използвайте кръстосан кабел RS232. В зависимост от хардуера на компютъра, на който е стартиран Tech2Win, може да се налага скоростта на трансфер на данни да бъде намалена до 57600 бода, тъй като при по-висока скорост Windows може да започне да губи данни.

Най-новата версия на Tech2Win поддържа и бързо изтегляне, когато TIS2Web и Tech2Win работят на един и същ персонален компютър. Все още се осъществява минимална комуникация между TIS2Web и Tech2Win през COM-порта, но отнемащото време прехвърляне на данни към Tech2Win беше заменено от вътрешно прехвърляне на файлове. В този случай времето на теглене е намалено драстично до много по-малко от минута.

  • Разширени теми: Конфигурационен файл
  • Първи стъпки: Интерфейс за комуникация с автомобил
  • ЧЗВ: Как да определя кой COM порт да използвам за Tech2Win?
  • ЧЗВ: Комуникация между Tech2Win и TIS2Web


Сигурност

Защитните механизми, използвани от Tech2Win, зависят от стойността на часовника на компютъра. Моля, уверете се, че часовникът на компютъра е винаги точен. Малките промени, например при преминаване от астрономическо към лятно часово време, се толерират от Tech2Win.

Ако няма валиден и активиран лиценз, Tech2Win не може да установи връзка с автомобил. Следният индикатор в лентата на състоянието показва статута на лиценза:

  • green smiley Лицензът е валиден.
  • Няма индикатор: Лицензът не е проверен.
  • red smiley Лицензът е изтекъл.

За да получите лиценз, моля, извършете актуализация на 'Достъп до сигурността (Сигурност)' чрез приложението TIS2Web. В повечето случаи изтегляне на софтуер чрез TIS2Web е достатъчно за получаване на нов лиценз. Трябва редовно да актуализирате софтуера, тъй като лицензът изтича след определен срок (в някои региони - след 4 седмици).

Лицензите са различни за всеки регион/софтуер. Може да имате лицензи на компютъра, ако използвате Tech2Win с различни софтуерни версии на Tech2.

Броят дни до изтичане на лиценза се показва в лентата на състоянието.

  • ( 0) означава, че лицензът е изтекъл или не съществува.
  • (<1) означава, че лицензът изтича в рамките на 24 часа.
  • (20) означава, че лицензът изтича в рамките на 20 дни.

Моля, не се променяйте неправомерно файла с лиценза. Неправомерните модификации на този файл се засичат от вътрешните мерки за защита и водят до загуба на всички лицензи на компютъра. Освен това Tech2Win вече няма да работи надеждно. Това може да се коригира само чрез нова инсталация.

  • Разширени теми: Съобщения за грешки и изходни кодове
  • Разширени теми: Лог-файл
  • Работа с Tech2Win: Прозорец за състояние
  • ЧЗВ: Валиден лиценз
  • ЧЗВ: Каква е разликата между лиценз за Tech2Win и Защитен достъп?
  • ЧЗВ: Неочаквано спиране


Разглеждане на доклади

View Report Този бутон може да се използва, за да видите съдържанието на PRT-файлове, налични на PCMCIA картата. Ще се отвори диалогов прозорец, който показва списък с PRT-файловете. Ако някоя програма е асоциирана с разширението PRT, то тази програма ще се отвори. В противен случай редакторът Notepad ще показва избрания файл.

В повечето случаи PRT-файлът е файл във формат ASCII, който използва съответните кодови страници за езика. За китайски, корейски, тайландски и японски файлът е във формат Unicode с водещ маркер за байтове (Byte-Order_Mark, BOM).

При разглеждане на докладите Tech2Win работи с поддиректория C:\Users\Public\General Motors\Tech2Win\reports. Тази поддиректория съществува, само ако поне веднъж сте разглеждали доклади. Директорията автоматично се изтрива и служи като временна работна директория за PRT-файловете на активната PCMCIA карта. Тя ще продължи да съдържа тези файлове, дори и ако Tech2Win бъде затворен. Ако желаете да запишете такъв файл, ще се наложи да го копирате в различна директория, тъй като той може да бъде презаписан, щом друг потребител реши да разглежда доклади.


PCMCIA имиджи

PCMCIA-изображенията обикновено се намират в поддиректорията C:\Users\Public\General Motors\Tech2Win\pcmcia. Файлът трябва да има размер от точно 32 MB (33 554 432 байта) или 10 MB (10 485 760 байта) и разширение *.bin. Имиджите се модифицират (като всяка нормално PCMCIA карта), ако бъде свалено нещо или ако Tech2Win съхрани нещо върху флаш картата. Модифицирането може да бъде забранено чрез превключвателя за защита от писане (команда -W0 или -W1), или като се премахне стойностто '-p' в опцията '-W'.(Конфигурационен файл). През конфигуратора не може да се достигне до ключа за защита срещу запис. Трябва ръчно да промените конфигурационния файл, ако желаете да използвате опциите '-W0', '-W1' или '-W'.


Лента за състояние

Лентата за състояние се показва под екрана на Tech2. Следните елементи се показват в лентата за състояние:

  1. Индикатор за скоростта
  2. Статус на комуникация с автомобил
  3. Статус на сериен порт
  4. Ключ SHIFT
  5. Автоматични екранни снимки
  6. Лог-предупреждение
  7. Лиценз

Status Bar

Индикатор за скорост

Индикаторът за скорост показва колко време прекарва CPU в емулиране на софтуера Tech2. По-добре е числото да е ниско (индикаторът да е вляво), отколкото да е високо (индикаторът да е вдясно). Докато индикаторът е в зелено, всичко е в рамките на допустимото. Индикаторът може да стане жълт за кратък период от време, ако изведнъж някаква друга задача в Windows стане активна. Добре е подобна активност да се избягва.

Статус на комуникация с автомобил

Индикаторът за състоянието на комуникацията с автомобила показва дали има интерфейс за комуникация с автомобила (MDI), както и дали е осъществена връзка между автомобила и Tech2Win.

Статус на сериен порт

При комуникация с Tech2Win през COM-порт, индикаторът показва дали комуникацията през COM-порта е активна или не.

Ключ SHIFT

Този индикатор показва, че ключът SHIFT е активен. Можете да го превключите с клавиша 'S' на клавиатурата или клавиша SHIFT на допълнителната клавиатура.

Автоматични екранни снимки

Можете да активирате опцията за автоматични снимки на екрана от менюто Опции. Всеки път когато екранът се променя, в директорията за регистрационни файлове ще се запазва нов файл със снимка на екрана. Завъртане на манивелата на червената камера в лентата на състоянието показва това. След деактивиране на опцията за автоматични снимки на екрана, камерата изчезва.

Лог-предупреждение

Индикаторът за състоянието на Регистрационния файл може да има три различни състояния.

  • gray log status indicator Регистрационният файл не съдържа предупреждения или грешки.
  • yellow log status indicator Регистрационният файл съдържа предупреждение.
  • red log status indicator Регистрационният файл съдържа съобщение за грешка.

Лиценз

Индикаторът за лиценза може да има три състояния.

  • green smiley Лицензът е валиден и активиран.
  • Няма индикатор: Лицензът не е проверен.
  • red smiley Лицензът е изтекъл или не съществува.
Моля, вижте връзката Сигурност за повече подробности.

Пояснения за лентата на състоянието

За някои икони, се показват пояснения, които дават допълнителна информация:

Пояснение за сериен номер на VCI интерфейс:
Tooltip VCI

Пояснение за версия на софтуера TECH2
Tooltip TECH2

Пояснение за COM порт
Tooltip Comport

Пояснение за номера на следващата снимка на екрана (ако опцията 'Автоматични екранни снимки' е активирана)
Tooltip Camera

Пояснение, показващо последния регистрационен файл със запис за ниво 'Предупреждение' или по-високо
Tooltip Logfile

Пояснение с точната продължителност на лиценза
Tooltip License

Поясненията се показват, ако курсорът остане 0,5 секунди над икона без да се движи. Поясненията изчезват след 5 секунди или при преместване на курсора.

  • Разширени теми: Съобщения за грешки и кодове на грешки.
  • Разширени теми: Лог-файл


Разширени теми

Темите, обсъждани тук, са от по-малко значение за стандартния потребител на Tech2Win. Следната информация може да е полезна за хората, които отговарят за настройката, управлението и конфигурацията на Tech2Win.

  • Преинсталация
  • Деинсталация
  • Директно модифициране на конфигурационните файлове
  • Лог-файл
  • Съобщения за грешки и изходни кодове
  • ATA карта
  • Регистрационни записи
  • Описание на файл
  • Примери за управление на конфигурация


Деинсталация

Пълната инсталационна директория, директорията, съдържаща потребителски данни (C:\Users\Public\General Motors\Tech2Win), и директорията, съдържащи данни за приложения, (C:\ProgramData\General Motors\Tech2Win) са изтрити.

  • Разширени теми: Преинсталация
  • Инсталация


Конфигурационен файл

Конфигурационните файлове винаги се намират в поддиректорията C:\Users\Public\General Motors\Tech2Win\config и имат файловото разширение *.conf. Можете да решите ръчно да модифицирате конфигурационния файл, тъй като не всички опции във файла са достъпни през Tech2Win. Конфигурационният файл е в Unicode с водещ маркер за ред на байтовете (Byte-Order_Mark, BOM). Силно препоръчваме при всякакви ръчни промени да използвате редактор с Unicode функционалност, като например Notepad.

Конфигурационният файл е разделен на редове. Празните редове се игнорират. Редът винаги започва с опция, в повечето случаи последвана от стойност. За пример вижте файла default.conf. Моля, вижте следната таблица за справка относно наличните опции.

Ако искате да стартирате определена конфигурация директно от десктопа, направете пряк път, който изпълнява 'C:\Program Files\General Motors\Tech2Win\bin\emulator.exe' -OF ..\config\vashiat_konfiguracionen_fail.conf'. Програмата би трябвало да се стартира от следната работна директория: 'C:\Program Files\General Motors\Tech2Win\bin'

опция | Стойност / Значение
; Коментар
@ Десетичен номер на версия във формат 'главна.вторична'.
Конфигурационните файлове с номер на главната версия, различен от Tech2Win, няма да се приемат. Конфигурационните файлове с номер на вторичната версия, по-малък от Tech2Win, ще се приемат.
-W0
-W1 		PCMCIA картата в слот 0/1 има активиран превключвател за защита от писане.
-B0
-B1 		Размерът на блока на PCMCIA картата в слот 0/1 в килобайтове. Допустимите стойности са 128 (по подразбиране) и 256.
-P0
-P1 		Файлът, съдържащ двоичния образ (имидж) на PCMCIA картата в слот 0/1. Размерът на файла трябва да бъде точно 10MB или 32MB. Променливите на средата като %ProgramData% се разширяват.
Ако тази опция не е налична, значи слотът се смята за празен.
-A0
-A1 		Файлът, съдържащ стойностите на атрибутите на PCMCIA картата в слот 0/1. Ако не е налична, ще се използват атрибути по подразбиране в зависимост от картата и размера на блока.
-W | След излизане от Tech2Win, всички данни се записват в съответните файлове. Стойностите p/f/r/c могат да се комбинират, за да обозначават респективно PCMCIA/Flash-ROM/RTC/CANDI-App.
-H | Функционалност за управление на динамична памет Стойностите 0/r/w/t може да се комбинират за респективно активиране на Нулиране, Проверки за четене, Проверки за запис и Проверки на задачи. Стойността l се използва за задължително заделяне на динамична памет на по-ниски адреси при използване на алтернативна схема за заделяне. Обикновено тази опция се използва само в среда за развитие.
-PC | Преди това пътят за копиране на PCMCIA карта. Тази опция сега се игнорира.
-MS | Идентификация на интерфейса за комуникация с автомобил (MDI) чрез сериен номер. Ако не е зададена, ще се покаже списък с наличните MDI интерфейси.
-CT | Цветът на текста (преден план) в 3 шестнадесетични байтови стойности. Стойността по подразбиране е 000000 (бяло).
-CB | Цветът на фона в 3 шестнадесетични байтови стойности. Стойността по подразбиране е FFFFFF (черно).
-ATA | Използвайте тази опция, за да разрешите ATA карта за заснемане. Премахнете я, за да забраните ATA картата за заснемане.
-C | Номерът на COM-порта (1...9), който ще се използва като RS232C порт за комуникация на Tech2. Често COM9 се използва за виртуалния COM порт, инсталиран от Tech2Win. Ако тази опция не е налице, ще се търси свободен COM порт от COM9 надолу. Използвайте пояснението в лентата за състояние между иконата на Tech2 и иконата на TIS2Web, за да видите кой COM порт се използва.
-WR | Определен PCaddress (обикновено 253558), който може да пише върху PCMCIA и в областта на FLASH ROM. Тази функционалност трябва да се активира допълнително чрез менюто (или с опцията -WA). Тя е необходима за отстраняване на грешки със SingleStep Debugger на код в памет, която не може да се модифицира.
-WA | Позволява на SingleStep дебъгера да пише в не-модифицируема памет.
-OF | Файл с опции, съдържащ двойките опция / стойност.
-TP | Корекция на времената (Пропорционална стойност). По подразбиране се задава на 5000. Намалете тази стойност и така броят изпълнени цикли ще се адаптира по-бързо към реалното време.
-TD | Корекция на времената (Диференциална стойност). По подразбиране се задава на 100. Намалете тази стойност и така ще се реагира по-бързо на промени в мигновените времена. ПРЕДУПРЕЖДЕНИЕ: Произволните промени на TP (Пропорционалните стойности на времената) и TD (Диференциалните стойности на времената) могат да доведат до проблеми със скоростта.
-PJ
-PP 		Укажете протокол, който да се използва:
PJ за J2534 комуникация.
PP за ISO22900-2 / PDU-API (по подразбиране)
-S | Присъствието на тази опция позволява извеждането на звук от бийпъра на компютъра.
-L | Езика на приложението Tech2Win. Активният език на Windows се използва по подразбиране, ако тези данни липсват. Вижте на следната връзка списък с езиците, които могат да се посочват: Езици. Самият прозорец на Tech2 за емулация ще показва езика, наличен на PCMCIA картата (с други думи, какъв език е бил изтеглен на PCMCIA картата).
-UD | Използване на друга потребителска директория за данни. В Win7 тя обикновено е в C:\Users\Public\General Motors\Tech2Win
-AD | Използване на друга директория за данни на приложения. В Win7 тя обикновено е в C:\ProgramData\General Motors\Tech2Win
-US | Използвайте специфичен за потребителя семафор за засичане на повече от една инстанция на Tech2Win. Тази опция ще позволи на всеки потребител да използва Tech2Win успоредно на една и съща машина, вероятно сървър. Когато използвате тази опция, трябва да посочите също така и опции -UD и AD.
-SS | Опция за посочване на общия размер на прозореца на Tech2Win, включително клавиатурата (ако има такава). Първият параметър трябва да е низ, ограден с двойни кавички ('), и ще се използва като име на размера в менюто Опции / Резолюция. Вторият параметър е общият брой хоризонтални пиксели на екрана на Tech2Win, включително клавиатурата. Третият параметър е общият брой вертикални пиксели на екрана на Tech2Win. Четвъртият параметър по избор е ширината на клавиатурата в пиксели.
-SH Опция за контролиране на работата с екрана. Следното десетично число се използва, за да посочи кои възможности за работа с екрана се деактивират.
  • Бит 0: Без възможен мин./макс.
  • Бит 1: Без препозициониране на екрана.
  • Бит 2: Без преоразмеряване. В този случай менюто Опции / Резолюция е посивено.
  • Бит 3: Прозорците за показване на данни и DTC ще бъдат с точно същия размер като Tech2Win (без клавиатура)


Лог-запис

Всяко стартиране на конфигурация на Tech2Win създава нов регистрационен файл в HTML формат в поддиректория C:\Users\Public\General Motors\Tech2Win\Logs. За да се избегне задръстване на твърдия диск, регистрационните файлове, по-стари от една седмица, се премахват.

Лог-файловете се именуват автоматично според датата (година, месец, ден) и часа (час, минута, секунда) на създаването им:
гггг-мм-дд_ччммсс.html

Записите вътре в лог-файловете винаги са на английски език, но във формат Unicode с водещ маркер за байтовете (Byte-Order_Mark, BOM). Всеки ред в лог-файла е от едно от следните нива на лога:

Ниво на лог | Значение
Инфо | Само информация. Няма ефект върху изпълнението на програмата.
Предупреждение | Възникнала е нетипична ситуация. Потребителят може и да не забележи отрицателни ефекти.
ERROR | Възникнала е грешка, забележима от потребителя.
CRITICAL | Възникнала е критична грешка, заради която програмата ще се държи анормално.
FATAL | Фатална грешка, заради която Tech2Win незабавно ще прекрати работа.

Всички нива над 'Предупреждение' са оцветени и могат да бъдат намерени лесно.

Освен това в поддиректория Logs ще има и видео файлове и файлове за печат, ако са използвани опциите от менюто Печат на екрана или Автоматични екранни снимки.
гггг-мм-дд_ччммсс_print_nnnnn.bmp
гггг-мм-дд_ччммсс_video_nnnnn.png
Снимките на Автоматични екранни снимки са свързани чрез HTML файл, затова използвайте HTML регистрационния файл, за да разгледате поредицата изображения.

В лентата за състояние потребителят ще се осведоми дали е налице 'Предупреждение' ( yellow lightning bolt) или по-сериозен лог-запис ( red lightning bolt).


Съобщения за грешки и изходни кодове

В диалоговите прозорци може да се появяват съобщения за грешки. Тези диалогови прозорци все пак позволяват на Tech2Win да работи успоредно с програмата Tech2. Изходните кодове са фатални грешки, които карат Tech2Win да се прекратява анормално. Изходните кодове могат да се използват в бач-файлове, за да се засече защо точно се е затворила програмата.

Съобщения за грешки

Могат да се появят следните съобщения за грешки. Ето кратко обяснение на ситуацията и на начина, по който може да се разреши проблемът.

Emulator too slow Emulator failed to start

Изходни кодове

Изходен код | Стойност | Значение
OPCODE_ERROR | -7 | Засечена е невалидна команда на микропроцесора на Tech2 (68332). Може би PCMCIA имиджът е бил повреден по някакъв начин.
ATA_PROBLEM | -6 | Възникнал е проблем с емулацията на ATA. Ако виждате такъв проблем, след като сте били инструктирани да използвате ATA картата, моля, свържете се с помощния отдел.
DEMO_TIME_IS_UP | -5 | Не би трябвало да се появява в официалната версия на Tech2Win.
DLL_NOT_LOADED | -3 | Една от необходимите DLL библиотеки не може да се зареди. Изглежда имате непълно копие на Tech2Win. Моля, направете нова инсталация и/или изберете различен език.
EXIT_INIT_FAILED | -2 | Неуспешна инициализация. Вижте лог-файла, за да откриете точната причина. Ако не съществува лог-файл, моля проверете дали имате необходимия достъп за четене/писане във всички директории.
нормален | 0 | Tech2Win се е затворил по нормален път.


ATA карта

ATA картата в Tech2 като цяло се използва само за отстраняване на бъгове по време на разработката на софтуера. Всички необходими АТА данни са съхранени в поддиректорията C:\Users\Public\General Motors\Tech2Win\ataCapture. Тази директория обикновено не е важна и може да се изтрие безопасно, освен ако изрично не са получени други инструкции.

Тъй като директорията ataCapture е фиксирана, съдържанието й ще бъде еднакво при всякакви конфигурации.


Файлове

Следните файлове и директории се използват от Tech2Win:

Директория | Място във версиите преди Vista | Място за Vista и извън него
Инсталация | Както е дефинирано по време на инсталацията
Данни за потребителя | C:\Documents And Settings\All Users\Documents\General Motors\Tech2Win | C:\Users\Public\General Motors\Tech2Win
Данни за приложението | C:\Documents And Settings\All Users\Application Data\General Motors\Tech2Win | C:\ProgramData\General Motors\Tech2Win

Файл | Използва се за
[Данни за потребителя]\atacapture | Съдържа файлове, които са налични на АТА картата. Освен ако не е определено друго, тези файлове не са необходими.
[Инсталация]\bin | Съдържа изпълнимите файлове и необходимите имиджи и DLL библиотеки за работата на програмата.
[Инсталация]\bin\emulator.exe | Главният изпълним файл, който изпълнява кода на Tech2.
[Инсталация]\bin\emulator_xx_XX.dll | DLL с ресурси за специфичния език.
[Инсталация]\bin\T2Configurator.exe | Конфигурационната част на Tech2Win.
[Инсталация]\bin\Pictures | Съдържа иконите, необходими на Tech2Win.
[Данни за потребителя]\config | Съдържа всички конфигурационни файлове.
[Данни за потребителя]\data | Съдържа файлове, които се модифицират по време на работата на Tech2Win. Тези файлове са необходими за правилното действие на Tech2Win. Обикновено не бива да пипате тези файлове, освен ако изрично не получите такива инструкции.
[Данни за приложението]\data | Съдържа файлове, които се модифицират по време на работата на Tech2Win. Тези файлове са необходими за правилното действие на Tech2Win. Обикновено не бива да пипате тези файлове, освен ако изрично не получите такива инструкции.
[Данни за приложението]\data\emulator.sec | Предпазен файл . Не модифицирайте този файл.
[Данни за приложението]\data\emulator.card | Файл на карта. Съдържа всички PCMCIA карти, известни на програмата Tech2Win. Не модифицирайте този файл.
[Данни за потребителя]\data\emulator.disp | Този файл съдържа позицията и размера на екрана на Tech2Win. Ако изтриете този файл, той ще бъде създаден наново и екранът на Tech2Win ще се появи в горния ляв ъгъл на екрана с размер 640х480.
[Данни за приложението]\data\emulator.lic | Лицензионен файл. Съдържа информация за срока на валидност на вашите лицензи. Не модифицирайте този файл.
[Данни за приложението]\data\emulator.rtc | Файл с часовник в реално време. Този файл съхранява данните, открити в RTC часовника на Tech2.
[Данни за приложението]\data\emulator.dta | Информационен файл тип 'Не ми казвай отново'.. Този файл съхранява софтуерни версии на PCMCIA, които (вече) не трябва да показват предупреждение, че не могат да се изпълнят автотестове, изискващи адаптер за обръщане към себе си.
[Данни за приложението]\data\candi.bin | Файл на приложението CANdi. Съдържа приложението на CANdi, приложено към Tech2.
[Данни за приложението]\data\eprom.bin | Вътрешен EPROM файл на Tech2. Съдържа вътрешната флаш памет на Tech2.
[Инсталация]\driver | Инсталационни файлове на драйвер за виртуален COM порт.
[Инсталация]\help\emulator_xx_XX.chm | Помощни файлове на отделни езици.
[Данни за потребителя]\Logs | Съдържа регистрационни файлове. Файлове, по-стари от една седмица, се изтриват автоматично.
[Данни за потребителя]\pcmcia | Съдържа файлове с PCMCIA имиджи. Образно казано, всеки файл отговаря на PCMCIA карта от Tech2. Тези файлове могат да се записват и на различни места по желание на потребителя.


Управление на конфигурациите

Конфигурационните файлове винаги се намират в поддиректорията C:\Users\Public\General Motors\Tech2Win\config и имат файловото разширение *.conf. Tech2Win може да се използва само за генериране на нови конфигурационни файлове или за модифициране на съществуващи конфигурационни файлове, които не са само за четене. За всякакви други операции с конфигурационните файлове, моля използвайте Windows Explorer или подобна програма за боравене с файлове. Това ще е необходимо за следните действия:

  • изтриване на конфигурационни файлове
  • преименуване на конфигурационни файлове
  • смяна на атрибута 'само за четене' на конфигурационни файлове

Силно препоръчваме винаги да имате конфигурационен файл default.conf. Този файл обикновено има зададен атрибут 'само за четене', за да не бъде презаписан случайно. Ако все пак променяте този файл така, че да отговаря на вашите конкретни необходимости, ще се наложи временно да премахнете атрибута 'само за четене'.

PCMCIA-изображенията са в поддиректорията C:\Users\Public\General Motors\Tech2Win\pcmcia. Всеки от тези файлове отговаря на PCMCIA карта, с която вече сте свикнали от работата с Tech2. С Tech2Win може да имате толкова имиджи, колкото искате. Просто копирайте някой съществуващ имидж с ново име на файл.

Ако искате да стартирате определена конфигурация директно от десктопа, направете пряк път, който изпълнява "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Програмата би трябвало да се стартира от следната работна директория: 'C:\Program Files\General Motors\Tech2Win\bin'

Броят на конфигурационните файлове не зависи от броя PCMCIA имиджи, които използвате. Можете да имате няколко конфигурационни файла с един и същ PCMCIA имидж. Това доста точно пресъздава ситуация в сервиз, при която няколко механика използват общ Tech2 (и една и съща PCMCIA карта).

Можете също така да изберете всяка конфигурация да използва свой специален PCMCIA имидж. Това ще направи индивидуалните конфигурации по-независими една от друга. Имайте предвид обаче, че трудът за актуализирането на всеки отделен PCMCIA имидж може да е твърде много.

Когато желаете да направите нова конфигурация чрез копиране на съществуваща, конфигураторът ще изпише предупреждение, ако PCMCIA-изображението не е било променено. В такъв случай бихте имали две конфигурации, които използват едно и също PCMCIA-изображение. Ако желаете именно това, просто натиснете ОК. Ако желаете новата конфигурация да използва различно или ново PCMCIA-изображение, натиснете Отказ. Тогава може да решите да направите ново изображение посредством Копирай карта с памет ...

Ето два примерни метода, по които можете да управлявате своите конфигурации и PCMCIA имиджи.

Една конфигурация на потребител

Имате възможност да запазите отделна конфигурация за всеки потребител. Името на конфигурацията може например да бъде идентично с потребителското име. Предимство е възможността за индивидуални настройки, например персонализирани настройки за интерфейсите за комуникация с автомобил (MDI), дисплея и езика. Недостатъкът е, че трябва да копирате PCMCIA файловете, ако няколко потребители трябва да използват един и същ софтуер. Разбира се, конфигурациите на потребителите могат да използват един централен PCMCIA файл.

Една конфигурация на копие на софтуер Tech2

Можете да изберете да създадете нова конфигурация за всеки софтуер, който изтеглите. Така, ако е необходимо, веднага ще могат да се използват дори по стари версии на софтуера. В този случай често името и номера на версията на софтуера се използват като име на конфигурацията.

  • Първи стъпки: Интерфейс за комуникация с автомобил
  • Първи стъпки: Пътека
  • Разширени теми: Конфигурационен файл
  • Инсталация: Стъпки за инсталация


Често задавани въпроси (ЧЗВ)

  • Как да определя кой COM порт да използвам за Tech2Win?
  • Комуникация между Tech2Win и TIS2Web
  • Валиден лиценз
  • Какво показва номера на лиценза?
  • Каква е разликата между лиценз за Tech2Win и Защитен достъп?
  • TIS2Web показва неопределена грешка при извършване на достъп за сигурност до първоначалния софтуер
  • Tech2Win не изпълнява софтуера Tech2 от друго място
  • Как мога да използвам повече от един MDI?
  • Регистрационният файл съдържа грешка 'CPU32: Too many 0000/FFFF Commands encountered'
  • Няма видим прозорец на Tech2
  • SPS не работи
  • Някои автотестове не работят
  • Индикаторът за скоростта се колебае.
  • Неочаквано спиране
  • За софтуер 15.001 се показва шведски език.
  • Загуба на връзката с MDI
  • Tech2Win не откри моя MDI
  • Искам незабавно да стартирам Tech2Win, без да се занимавам с конфигуратора
  • Къде са функциите за печат?
  • На компютъра ми има 'неизползвана' папка PCMCIA
  • Получавам съобщение 'неразрешен път към файл'

Как да определя кой COM порт да използвам за Tech2Win?

Може да използвате 'Диспечер на устройствата' в Windows и да разгледате 'Портове (COM & LPT)'. Някои компютри имат инсталирани вградени модеми или Bluetooth устройства, които не се показват под тази категория.
Друг метод е да се използва малка команда, която е предоставена заедно с конфигуратора. Имате достъп до него чрез менюто 'Старт' в папка Tech2Win и щракнете на 'show com ports'.
И двата метода показват COM портовете, които са инсталирани на компютъра и които НЕ трябва да използвате.

Комуникация между Tech2Win и TIS2Web

Важно е Tech2Win да работи преди да стартирате връзка с TIS2Web за сигурен достъп или изтегляне на софтуер. Когато Tech2Win е стартиран, TIS2Web може да разпознава само виртуални COM портове.

Валиден лиценз

В повечето случаи изтегляне на софтуер от TIS2Web ви осигурява и валиден лиценз. Ако все още нямате лиценз, трябва да осъществите 'Достъп до сигурността (Сигурност)' чрез TIS2Web (но не чрез TIS2000), за да получите валиден лиценз. Моля, не извършвайте друга комуникация с TIS2Web с Tech2Win като например 'Сваляне на софтуер (СС)', преди да получите лиценз чрез 'Достъп до сигурността (Сигурност)'.

Какво показва номера на лиценза?

Номерът на лиценза в дясната страна на лентата за състоянието показва броят на пълните дни до изтичане на лиценза. Веднага след изтегляне на софтуер или осъществяване на защитен достъп, броят на дните се променя на 30. Но след ново стартиране на Tech2Win, се показва числото 29, тъй като продължителността на лиценза е нещо подобно на 29 дни, 23 часа и 55 минути. Ако броят на дните на лиценза падне под 24 часа, за срок на лиценза се показва <1. Ако лицензът е изтекъл се показва 0.

Каква е разликата между лиценз за Tech2Win и Защитен достъп?

Лицензът за Tech2Win ви позволява да използвате Tech2Win. За да получите лиценз, трябва да изтегляте софтуер или да осъществявате защитен достъп редовно (обикновено на всеки 30 дни). Възможността да изтегляте чрез TIS2Web показва на Tech2Win, че е налице валиден потребител. Защитеният достъп, познат от Tech2, показва на Tech2Win, че определени дейности, за които се изисква оторизиран достъп, например деактивиране на въздушна възглавница, са разрешени. И получаването на лиценз за Tech2Win, и осъществяването на защитен достъп могат да се извършат чрез приложението TIS2Web Security Access. Tech2Win показва оставащия срок на лиценза в дясната страна на лентата за състоянието. За съжаление, Tech2Win не може да показва продължителността на защитения достъп, тъй като Tech2Win просто изпълнява Tech2 и няма данни за самото приложение Tech2.

TIS2Web показва неопределена грешка при извършване на достъп за сигурност до първоначалния софтуер

Поведението е същото като на Tech2 Поради възрастта си първоначалният софтуер не може да получи лиценз от TIS2Web. Това обаче не е реален проблем, тъй като демонстрационният софтуер не комуникира с автомобили и затова не му е нужен лиценз. А тъй като лицензите са специфични за изтегляне на TS2Web, така или иначе ще ви трябва лиценз за всяко отделно теглене, след като свалите софтуера на Tech2. 'Лицензът' за първоначалния софтуер няма да ви позволи да извършвате комуникация с автомобили със софтуер на North American Operations или Opel/Vauxhall.

Tech2Win не изпълнява софтуера Tech2 от друго място

Вашата версия на Tech2Win вероятно е ограничена до едно или няколко изтегляния на TIS2Web (области). Натиснете Помощ / За, за да видите какви ограничения важат за вашата версия на Tech2Win. Ранните версии на Tech2Wi позволяваха изпълнение само на софтуер за Opel/Vauxhall. Скоро ще бъдат включени други региони на General Motors. Във всички случаи, в момента Tech2Win може да изпълнява софтуера Tech2 от General Motors.

Как мога да използвам повече от един MDI?

Ако желаете да зададете определени MDI интерфейси за определени потребители, предлагаме да разрешите на всички потребители да имат отделна конфигурация. Най-добре е тези конфигурации да са с имената на съответните потребители. Във всяка от тези конфигурации трябва да въведете серийния номер на MDI интерфейсите за конкретния потребител в раздел 'Интерфейс за комуникация с автомобил'. Веднага щом потребителят стартира своята конфигурация, Tech2Win ще се опита да се свърже със съответните MDI. Само ако нито един от тези MDI не бъде открит, ще се покаже прозорец за избор със списък на всички MDI интерфейси, намерени от Tech2Win.

Ако имате няколко MDI интерфейси за общо ползване, предлагаме да използвате конфигурация, в която полето 'Интерфейс за комуникация с автомобил' в раздел 'Интерфейс за комуникация с автомобил' е оставено празно. Така потребителят винаги ще вижда прозорец за избор с наличните MDI интерфейси.

Регистрационният файл съдържа грешка 'CPU32: Too many 0000/FFFF Commands encountered'

Файлът 'C:\ProgramData\General Motors\Tech2Win\data\eprom.bin' или текущият PCMCIA файл са повредени. Моля, преинсталирайте Tech2Win и изтеглете последния Tech2 софтуер.

Няма видим прозорец на Tech2

Ако не виждате прозорец на Tech2, той вероятно е в зона, която в момента не се показва на дисплея. Това може да се получи, ако използвате повече от един екран или промените разделителната способност на екрана. Задръжте клавиша Shift натиснат по време на стартиране на вашата конфигурация. Така разделителната способност ще се върне на 640х480 и прозорецът на Tech2 ще се покаже в горния ляв ъгъл на екрана. Можете да изтриете файла C:\Users\Public\General Motors\Tech2Win\emulator.disp, за да постигнете същия ефект.

Има случаи, когато прозорецът на Tech2 не може да се покаже на екрана след затваряне на прозорците на всички други приложения. Винаги досега използването на клавишна комбинация Alt-Tab за превключване между приложения в Windows успешно извежда екрана на Tech2. Натискането на бутона Tech2Win в лентата за задачите в долната част на екрана на компютъра не винаги има ефект. В момента все още анализираме този проблем и се надяваме да го отстраним в следваща версия на Tech2Win.

SPS не работи

Да, знаем. Не планираме да променияме това. Не трябва да използвате Tech2Win вместо Tech2 за извършване на SPS. Моля, използвайте MDI директно с SPS Програмиране чрез TIS.

Някои автотестове не работят

Автотестовете на Tech2 са предназначени за тестване на отделни части от хардуера на Tech2. Някои от тези тестове изискват адаптери за обръщане към себе си. Тези тестове не могат да се използват в Tech2Win, защото Tech2Win не поддържа функционалност на адаптери за обръщане към себе си (и няма планове такава функционалност да се внедри). Моля, не пускайте такива безсмислени тестове в Tech2Win. Ако ги използвате, ще получите погрешни резултати или Tech2Win ще увисне също като Tech2 без адаптер за обръщане към себе си. В такива случаи използвайте Ctrl-R, за да рестартирате Tech2Win.

Индикаторът за скоростта се колебае.

Индикаторът за скоростта в долния ляв ъгъл на лентата на състоянието показва колко команди на Tech2Win могат да се изпълнят преди Tech2Win да трябва да 'заспи' отново. Този метод се използва, за да гарантира, че времето на Tech2Win отговаря на реалното време: по-бърз компютър 'спи' повече от по-бавен. Ако индикаторът за скоростта се колебае, вероятно и друго приложение използва ресурсите на компютъра или часовникът на компютъра се отклонява. Силните колебания имат негативно въздействие върху комуникацията с автомобила и връзката с TIS2Web. Моля, проверете дали не се изпълняват и други приложения.

Повечето преносими компютри автоматично намалят честотата на процесора, за да удължат живота на батерията Това също може да причини колебанията в скоростта, засечени от Tech2Win. В такъв случай, моля, не използвайте преносимия компютър на батерия, а го включете към външно захранване. Освен това може да се опитате да промените настройките за захранването и батерията, така че операционната система да не намалява скоростта на процесора.

Неочаквано спиране

Ако не намерите причината, поради която програмата е прекъснала работа, вероятно са се задействали вътрешните защитни механизми на Tech2Win. Моля, не променяйте следните файлове: emulator.sec, emulator.lic, emulator.card. Ако Tech2Win установи нарушение на сигурността, вероятно ще се наложи да преинсталирате.

За софтуер 15.001 се показва шведски език.

Първоначалният софтуер, който се доставя с Tech2Win, е демонстрационен софтуер, присъстващ на всяка нова PCMCIA карта. TIS2Web показва, че това е шведски език, тъй като TIS2Web показва само последния от четирите езика, поддържани от демонстрационната версия на софтуера (английски, френски, немски и шведски). Използвайте режим за актуализация 'Ръчен' вместо 'Стандартна', за да запишете нова версия на софтуера за диагностика върху демонстрационната версия.

Загуба на връзката с MDI

Загубата на връзката с MDI интерфейса може да се дължи на няколко причини.

  • Лоша кабелна връзка (Ethernet или USB).
  • Нестабилна безжична връзка.
  • Компютърът преминава в режим на готовност.

Tech2Win не откри моя MDI

Моля, проверете следното:

    1. Активиран ли е MDI?
    2. Включен ли е Диспечерът на MDI?
    3. MDI използва ли се от друго приложение като например SPS?
Можете да стартирате Диспечера на MDI чрез иконата на работния плот или от 'Старт/Всички програми/General Motors/GM MDI Software'.: Моля, обадете се на Центъра за поддръжка, ако описаното в точка 2 няма ефект.

Искам незабавно да стартирам Tech2Win, без да се занимавам с конфигуратора

Изпълнете "C:\Program Files\General Motors\Tech2Win\bin\emulator.exe" -OF "C:\Users\Public\General Motors\Tech2Win\config\your_configuration_file.conf". Използвайте следната работна директория:'C:\Program Files\General Motors\Tech2Win\bin' Все още можете да използвате конфигуратора, за да направите промени на конфигурацията.

Къде са функциите за печат?

Tech2Win не предлага пряка функция за печат. Вместо това, той създава временни файлове и извиква програмите, асоциирани с файловите разширения. Тези програми могат да се използват за печатане, което ви позволява да определите как да изглежда разпечатката ви.

Print Report | Print Report

За да отпечатате текущия екран на Tech2Win, използвайте елемента от менюто Файл / Печат на екрана или бутона от клавиатурата, върху който има символ на принтер. Ако трябва да отпечатате няколко екрана на Tech2Win, можете да използвате елемента от менюто Опции / Автоматични екранни снимки, защото създава файлове PNG за всеки екран на Tech2Win. Тези файлове PNG са включени във файла-дневник.

Можете да отпечатвате и съдържанието на екраните за данни (активира се посредством елемента от менюто Прозорци / Дисплей за данни на Tech2Win). Използвайте бутона Печат/стартиране HTML, за да стартирате, а после да спрете получаването на данни. След като спре получаването, се стартира асоциираният с HTML изпълним файл (обикновено Internet Explorer), който ви предоставя пълната функционалност за отпечатването на данните.

Data Display | Data Display

На компютъра ми има 'неизползвана' папка PCMCIA

Предишните версии на Tech2Win винаги имат дублирано съхранение на PCMCIA файловете в отделна директория. Тази директория често беше C:\PCMCIA. Тази директория вече не се използва, тъй като бързото изтегляне от TIS2Web прави второто съхранение на подобни файлове ненужно. Можете безопасно да изтриете тази директория.

Получавам съобщение 'неразрешен път към файл'

Изглежда, че името на файла съдържа неразрешени символи като например знак за процент (%). Ако виждате този проблем веднага след инсталиране, най-добре е просто да деинсталирате и да инсталирате отново. Повечето проблеми биха се разрешили по този начин.

При нормално инсталиране, променливата на средата 'Tech2WinUserData' се задава като 'PUBLIC' (за версии на Windows >= Vista) или като 'ALLUSERSPROFILE\Documents' (за версии на Windows преди Vista) В някои редки случаи променливата на средата не се задава в процеса на инсталиране, но работи добре при втория опит. Можете да зададете променливата на средата и ръчно. Поискайте помог от администратора си, ако не знаете как да зададете променлива на средата.


Регистрационни записи

Инсталационната програма генерира следните записи в регистъра. Моля, не ги модифицирайте ръчно. Подхождайте с принципно необходимото внимание при работа със записи в регистъра на Windows.

регистрационен ключ | име | тип | значение
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | CurrentVersion | REG_SZ | Вътрешен номер на версия
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Език | REG_SZ | инсталиран език
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | PcmciaCopy | REG_SZ | Път до директорията с копие на PCMCIA
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | основна директория (root) | REG_SZ | инсталационна пътека
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | Опция за деинсталиране | REG_DWORD | Настройка за деинсталация
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerConfig | REG_SZ | Версия на конфиг. файла
HKEY_LOCAL_MACHINE/SOFTWARE/GM/TECH2Win | VerDriver | REG_DWORD | Версия на драйвера за виртуалния COM порт
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | DisplayName | REG_SZ | Име на софтуера в списъка 'Добавяне / Премахване на програми'
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/; CurrentVersion/Uninstall/TECH2Win | UninstallString | REG_SZ | Път до приложението за деинсталиране


Преинсталация

Преинсталацията ще изтрие пълната инсталационна директория на Tech2Win със следните изключения.

  1. поддиректорията config с конфигурациите не се изтрива.
  2. Поддиректорията pcmcia, която обикновено съдържа PCMCIA изображенията, не се изтрива.
  3. Поддиректорията ATA, която може да съдържа информация за дебъг, не се изтрива.
Конфигурационните файлове могат да станат несъвместими: няма гаранция, че конфигурационните файлове от стара версия на Tech2Win ще могат да се четат от нова версия на Tech2Win. PCMCIA имиджите по принцип няма как да бъдат несъвместими.

Допълнителната PCMCIA директория не се засяга при преинсталирането.

Някои среди предлагат автоматична инсталация на по-нова версия на Tech2Win. Тъй като последната информация за инсталация се съхранява в регистъра, тези настройки ще бъдат предпочетени по подразбиране по време на преинсталацията.

Можете да наложите задължително преинсталиране на Tech2Win, като използвате скрипта enable reinstallation. Този скрипт се инсталира заедно с Tech2Win. Той просто променя в системния регистър, в HKEY_LOCAL_MACHINE\SOFTWARE\GM\Tech2Win, стойността на ключа CurrentVersion на '1.000'.